ISB - CM2150, ISC - CM2150, ISL - CM2150D, ISDe - CM2150, ISLe - CM2150, QSB3.3 - CM2150, B3.9/5.9/C8.3 CM2150, ISB6.7 ISD6.7 CM2150, ISB6.7 CM2150 AN, ISB5.9 CM2150 B111,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the electronic control module (ECM) related to memory hardware failures or internal ECM voltage supply circuits. | Engine may not start.
ISB, ISC, and ISL Electronic Control Module

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM is located on the fuel system side of the engine. Refer to Procedure 100-002 for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 20-Jul-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected that the primary and backup speed sensor signals are connected backwards. | The engine will shut down or will not start.
ISB, ISC, ISL with CM2150 - Engine Magnetic Speed/Position

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The ECM provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

Both engine position sensors are located on the back side of the front gear housing above the fuel pump drive. Refer to Procedure 100-002 in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The ECM detects the reversed sensors and continues to operate.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code indicates that the camshaft position sensor and crankshaft position sensor wiring harness connectors are reversed.

Refer to Troubleshooting Fault Code t05-115

Last Modified: 05-Feb-2013


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Derate in power output of the engine.
ISB, ISC, and ISL - Intake Manifold 1 Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is greater than 4.91 VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-122

Last Modified: 20-Jul-2010


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Derate in power output of the engine.
ISB, ISC, and ISL - Intake Manifold 1 Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is less than 0.26-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor.
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-123

Last Modified: 20-Jul-2010


Intake Manifold 1 Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 124 (QSB3.3)

Intake Manifold 1 Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Data Valid but Above Normal Operational Range - Moderately Severe Level. Intake manifold pressure has exceeded the maximum limit for the given engine rating. | Engine power derate.
Intake Manifold Pressure/Temperature Circuit

Circuit Description

The intake manifold pressure sensor is used by the electronic control module (ECM) to monitor the engine intake manifold pressure.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code becomes active when the intake manifold pressure exceeds the maximum pressure limit for a given engine rating.

Possible causes:

  • Malfunctioning turbocharger wastegate
  • Wastegate tampering
  • Wrong turbocharger part
  • Possible tampering of the fuel system or turbocharger system.
Refer to Troubleshooting Fault Code t05-124

Last Modified: 20-Jul-2010


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 1 circuit. | Severe derate in power output of the engine. Limp home power only.
ISB, ISC, and ISL - Accelerator Pedal or Lever Position Sensor 1 Circuit

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage, based on the accelerator pedal position, is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2. When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal or lever. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than 4.55-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery or +5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Failed accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 20-Jul-2010


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 1 signal circuit. | Severe derate in power output of the engine. Limp home power only.
ISB, ISC, and ISL - Accelerator Pedal Position Sensor 1 Circuit

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage, based on the accelerator pedal position, is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2. When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is less than 0.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed in INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor.
  • Failed accelerator pedal or lever position sensor.
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-132

Last Modified: 20-Jul-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate. Remote accelerator position will be set to zero percent.
ISB, ISC, and ISL - Remote Accelerator Pedal Position Sensor 1 Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the remote accelerator pedal signal voltage is greater than 4.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal circuit shorted to battery or +5 volt supply.
  • Open remote accelerator pedal or lever return circuit in the harness or connections.
  • Remote accelerator supply shorted to battery.
  • Failed remote accelerator pedal or lever position sensor.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-133

Last Modified: 20-Jul-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate. Remote accelerator position will be set to zero percent.
ISB, ISC, and ISL - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the remote accelerator pedal signal voltage is less than 0.1-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor.
  • Damaged remote accelerator pedal or lever position sensor.
  • Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

Note: The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-134

Last Modified: 20-Jul-2010


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
ISC and ISL CM2150 - Engine Oil Rifle Pressure 1

Circuit Description

The ECM provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is greater than 4.75-VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19.

The oil pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135.

Last Modified: 01-Aug-2011


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
ISC and ISL with CM2150 - Engine Oil Rifle Pressure 1

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is less than 0.25-VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The oil pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-141

Last Modified: 20-Jul-2010


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
ISC and ISL with CM2150 - Engine Oil Rifle Pressure 1

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

If the ECM detects low signal voltage indicating a low engine oil pressure, this fault code sets.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is less than the engine protection limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate issued by the ECM limits the power output of the engine.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the torque derate will be removed when the oil pressure reading is detected to be within the normal operating range.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code t05-143

Last Modified: 20-Jul-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for engine coolant temperature.
ISB, ISC, and ISL- Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system, and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the coolant temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Before troubleshooting Fault Code 144, check for multiple faults.

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-144

Last Modified: 20-Jul-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for engine coolant temperature.
ISB, ISC, and ISL - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the coolant temperature reading.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-145

Last Modified: 20-Jul-2010


Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Power derate and possible engine shut down if Engine Protection Shutdown feature is enabled.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine coolant. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the fault code immediately after the coolant temperature decreases below the engine protection limit.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code t05-146

Last Modified: 20-Jul-2010


Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red STOP lamp starts flashing.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than the maximum operating limits set in the ECM calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the coolant temperature decreases below the engine protection limit.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Refer to Troubleshooting Fault Code t05-151

Last Modified: 20-Jul-2010


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold air temperature.
ISB, ISC, and ISL - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
Refer to Troubleshooting Fault Code t05-153

Last Modified: 20-Jul-2010


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for intake manifold air temperature.
ISB, ISC, and ISL - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the intake manifold temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-154

Last Modified: 20-Jul-2010


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power and derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

This fault code indicates that the intake manifold temperature has exceeded the maximum engine protection limit.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature is above the maximum operating limits in the ECM calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut off if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The intake manifold air temperature sensor measures the temperature of the charge air as it passes through the intake manifold. Possible causes of this fault code include:

  • Restricted air flow through the charge air cooler
  • Undersized charge air cooler
  • High turbocharger compressor outlet temperature
  • For marine engines verify the cooling water intake is not blocked or clogged with debris.
Refer to Troubleshooting Fault Code t05-155

Last Modified: 20-Jul-2010


Fault Code Path Selection

FAULT CODE 08-fc195
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 08-fc195-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 08-fc195-3wire

Last Modified: 30-May-2007


Fault Code Path Selection

FAULT CODE 08-fc196
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 08-fc196-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 08-fc196-3wire

Last Modified: 11-Sep-2006


Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid but Below Normal Operating Range - Moderately Severe Level. Low engine coolant level detected. | Power derate and possible engine shut down if the Engine Protection Shutdown feature is enabled.
ISB, ISC, and ISL with CM2150 - Engine Control Module (ECM)

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant, versus being out of coolant. The ECM supplies 5 volts to the coolant level signal circuit. The resistance of the engine coolant level sensor changes, based on the coolant level. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light after 20 seconds when low engine coolant level has been detected.
  • The torque output of the engine will be reduced.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after 20 seconds of detecting the correct engine coolant level.

Shop Talk

Verify the engine control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Note: It may not be possible to perform an aftertreatment diesel particulate filter (DPF) regeneration while this fault code is active.

Refer to Troubleshooting Fault Code t05-197

Last Modified: 18-Sep-2012


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | Engine power derate.
ISB - Barometric Pressure Sensor Circuit
ISC and ISL - Barometric Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on elevation at which the engine is presently operating. The ambient air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The engine control module (ECM) provides a 5 volt supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level.

Component Location

ISB: The combination ambient air temperature/pressure sensor is located in the original equipment manufacturer (OEM) intake air plumbing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view. ISC and ISL: The barometric pressure sensor is located near the intake manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure signal voltage is greater than 4.75 VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the ambient pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-221

Last Modified: 07-Nov-2016


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | Engine power derate.
ISB with CM2150 - Barometric Pressure Sensor Circuit
ISC and ISL with CM2150 - Barometric Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level.

Component Location

ISB: The combination ambient air temperature/pressure sensor is located in the original equipment manufacturer (OEM) intake air plumbing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view. ISC and ISL: The barometric pressure sensor is located near the intake manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure signal voltage is less than 0.25 VDC for more than 16 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the ambient pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-222

Last Modified: 07-Nov-2016


Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
Camshaft Position Sensor and Engine Speed Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are hall effect type sensors. The electronic control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used to determine the position of the engine by the ECM.

Component Location

The crankshaft speed sensor is located on the intake side of the engine near the number 6 cylinder at the crankshaft centerline. The camshaft speed sensor is located below the fuel pump in the back of the gear housing. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine speed has exceeded the calibration limit for excessive engine speed.

Action Taken When the Fault Code is Active

  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the engine speed drops to normal operating speeds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-234

Last Modified: 20-Jul-2010


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Possible hard starting and rough running.
ISB, ISC, ISL with CM2150 - Engine Speed Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides 5 volt supply to the primary engine speed/position sensor.

Component Location

The engine speed sensor is located in the lower portion of the front cover on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the sensor supply 3 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a limit which can be calibrated, then this fault is recorded.

Possible causes of this fault code are a short circuit to ground in the engine harness, sensor, or ECM.

Refer to Troubleshooting Fault Code t05-238

Last Modified: 20-Jul-2010


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 3 circuit. | Possible hard starting and rough running.
ISB, ISC, and ISL - Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides 5 volt supply to the primary engine speed/position sensor.

Component Location

The sensor supply 3 is located in the ECM. The supply voltage is spliced off in the engine harness to each sensor it supports.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 3 signal voltage is more than 5.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

High voltage on the (+) 5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code t05-239

Last Modified: 20-Jul-2010


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect. The ECM lost the vehicle speed signal. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise control, Gear-Down Protection, and Road Speed Governor will not work.
ISB, ISC, ISL with CM2150 - Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion.

Conditions for Setting the Fault Codes

The ECM detects a loss of vehicle speed when other engine operating conditions indicate that the vehicle should be in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.

Conditions for Clearing the Fault Code

  • The ECM detects a valid engine speed signal from the vehicle speed sensor.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Refer to the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake. or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a vehicle speed signal greater than zero.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not catch all malfunctions of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors, and tachographs are not fully covered under this procedure. For more information on those components, please refer to the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-241

Last Modified: 20-Jul-2010


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P084 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change. Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to maximum engine speed without VSS parameter value. Cruise Control, Gear-down Protection, and Road Speed Governor will not work.
ISB, ISC and ISL with CM2150 - Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission.

Conditions for Running the Diagnostics

  • The adjustable parameter “VSS Anti-Tampering” must be enabled.
  • This diagnostic runs continuously when the vehicle is in motion if the feature is enabled.

Conditions for Setting the Fault Codes

The ECM detects a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.
  • Cruise Control, Gear-down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

  • The ECM detects a valid engine speed signal from the vehicle speed sensor.
  • The keyswitch must be turned ON, and the vehicle speed and engine speed must be 0 for 30 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Once the speed signal has been restored the fault code will go inactive once the keyswitch is on for 30 seconds and the ECM senses zero vehicle and engine speed.

Refer to Troubleshooting Fault Code t05-242

Last Modified: 20-Jul-2010


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S033 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can possibly stay on continuously or not run at all.
ISB, ISC and ISL with CM2150 - Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the electronic control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a Pulse Width Modulated (PWM) signal. A PWM signal is pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by the OEM. Certain OEMs may use a solenoid return that is wired to the ECM or can use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM troubleshooting and repair manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is not detected to be system voltage when the PWM signal is turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The fan will not be enabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared by using the INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24 VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24 VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM troubleshooting and repair manual for procedures to check the fan control circuit for a short circuit to ground.

Refer to Troubleshooting Fault Code t05-245

Last Modified: 20-Jul-2010


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at ambient air temperature circuit. | None on performance.
ISB - Ambient Air Temperature Sensor 1 Circuit
ISC and ISL - Ambient Air Temperature Sensor 1 Circuit

Circuit Description

The ambient air temperature sensor 1 is a variable resistor sensor and is used to measure the temperature of the air entering the turbocharger compressor inlet of the engine. The electronic control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The ambient air temperature sensor is located in the air intake. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ambient air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
Refer to Troubleshooting Fault Code t05-249

Last Modified: 20-Jul-2010


Engine Oil Level - Data Erratic, Intermittent, or Incorrect

FAULT CODE 252

Engine Oil Level - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 252 PID: P98 SPN: 98 FMI: 2 LAMP: Amber SRT: | Engine Oil Level - Data Erratic, Intermittent, or Incorrect. An intermittent signal is being received from the oil level sensor. | Oil level sensor operation will be disabled.
ISB, ISC, and ISL - Oil Level Sensor Circuit

Circuit Description

The oil level sensor will monitor the oil fluid level in the oil pan at key-on. The oil level sensor will not monitor the oil level after the engine is started or when the engine speed is greater than 0 rpm. During engine key-on, if the oil level sensor detects a critical low oil level, then the amber CHECK ENGINE lamp will blink for 30 seconds and a fault code will be logged. If an operator observes a blinking amber CHECK ENGINE lamp at key-on, the operator must check the engine oil level with the manual dipstick.

The oil level sensor provides the ECM with a pulse width modulated (PWM) signal. Within this signal, the oil level sensor transmits the engine oil level reading, oil temperature, and fault code information from the oil level sensor.

Component Location

The oil level sensor is located on the left side of the engine on the front part of the dipstick port. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

A valid PWM message is not received from the oil level sensor within the required time limits at initial key-on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The oil level sensor operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable oil level sensor operation immediately after a valid PWM signal is received from the oil level sensor.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • The oil level sensor is not receiving power from the ECM. This could be caused by an open circuit in the power supply or low voltage supplied by the primary engine ECM
  • Open return circuit on the oil level sensor circuit between the engine ECM and the oil level sensor
  • Open or short circuit on the oil level sensor signal circuit between the ECM and oil level sensor
  • A damaged oil level sensor.
Refer to Troubleshooting Fault Code t05-252

Last Modified: 20-Jul-2010


Engine Oil Level - Data Valid But Below Normal Operational Range - Most Severe Level

FAULT CODE 253

Engine Oil Level - Data Valid But Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 253 PID: P98 SPN: 98 FMI: 1 LAMP: Red SRT: | Engine Oil Level - Data Valid But Below Normal Operational Range - Most Severe Level. Very low oil level has been detected by the oil level sensor. | The engine may derate. Possible low oil pressure, possible severe engine damage.
ISB, ISC and ISL with CM2150 - Engine Oil Level Sensor Circuit

Circuit Description

An algorithm in the electronic control module (ECM) calibration monitors engine oil level while the ECM is keyed on and no engine speed is detected. If the engine oil level falls below a certain threshold, the ECM will activate Fault Code 253.

Component Location

The engine oil level sensor is located on the engine oil dipstick, on the air intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine speed is 0 rpm.

Conditions for Setting the Fault Codes

The engine oil level is detected to be very low at key-on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE lamp and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If inactive counts of Fault 253 are logged in the ECM, it could be possible that the engine was running or keyed on while tilted at an angle severe enough to cause this fault to be triggered.

Other causes of fault code 253 may include:

  • The engine may not have been filled to proper capacity during the most recent oil change
  • External engine oil leaks (oil leaking onto the ground)
  • Internal engine oil leaks (oil leaking into the fuel system or cooling system)
  • High engine oil consumption/power cylinder failure (check for abnormally high blowby when the engine is loaded).
Refer to Troubleshooting Fault Code t05-253

Last Modified: 20-Jul-2010


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the ambient air temperature circuit. | None on performance.
ISB - Barometric Pressure Sensor Circuit
ISC and ISL - Barometric Pressure Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the turbocharger compressor inlet of the engine. The electronic control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The ambient air temperature sensor is located in the air intake. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ambient air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-256

Last Modified: 20-Jul-2010


Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S126 SPN: 1347 FMI: 4 LAMP: Amber SRT: | Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel pump actuator circuit. | Engine will run poorly at idle. Engine will have low power. Fuel pressure will be higher than commanded.
ISB, ISC and ISL with CM2150 - Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the electronic control module (ECM) that controls the electronic fuel control actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the electronic fuel control actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump actuator is located on the engine-mounted fuel pump. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fuel rail pressure will be higher than the commanded rail pressure.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault becomes active when the ECM detects a short circuit in the electronic fuel control actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel control actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel control actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key-on; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Fault Code 2311 can have high counts if the fault condition is or was intermittent.

Refer to Troubleshooting Fault Code t05-271

Last Modified: 20-Jul-2010


Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3 LAMP: Amber SRT: | Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the fuel pump actuator circuit. | Engine will not run or engine will run poorly.
ISB, ISC and ISL with CM2150 - Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse with modulation (PWM) driver in the electronic control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump actuator is located on engine-mounted fuel pump housing. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fuel rail pressure will be higher than the commanded rail pressure.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault becomes active when the ECM detects an open in the fuel pump actuator circuit. Causes of this fault code are a short circuit to a positive voltage or an open circuit in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 can have high inactive counts. If the fault code is intermittent, look for causes of an intermittent open circuit such as loose pins and bad connections. If the fault code is intermittent, look closely for loose wire connections at the ECM connector. Also, if the fault code is intermittent, wiggle the harness and the electronic fuel control.

Refer to Troubleshooting Fault Code t05-272

Last Modified: 20-Jul-2010


Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 281

Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 281 PID: S126 SPN: 1347 FMI: 7 LAMP: Yellow SRT: | Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment | Engine will not run or possible low power.
High Pressure Pump

Circuit Description

The fuel pump contains two barrel and plunger assemblies; each barrel and plunger assembly utilizes an inlet and outlet check valve. Fuel at gear pump pressure is metered through the fuel pump actuator and unseats one of the two inlet check valves as the fuel at gear pump pressure enters the pumping chamber. As the pumping plunger begins its upward motion, the pressure in the pumping chamber increases rapidly and the inlet check valve is closed. As pressure reaches accumulator pressure, the outlet check valve is opened. As the plunger travels upward, fuel exits past the outlet check valve and pressurizes the fuel rail.

Component Location

The fuel pump is located on the backside of the gear housing. The barrel and plunger and check valve assemblies are part of the fuel pump head sub-assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is set active when a pumping imbalance is detected between the two high-pressure plungers inside the fuel pump.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

When the ECM detects that the pumping imbalance has been corrected, the fault code is set inactive.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Fault Code 281 will most likely come active while operating at a steady state loaded condition. At this condition, commanded fuel pressures are highest and the pump's pressure balance is affected the most.

If a high pressure seal has failed, pump head drain flow will be excessive. If seal damage has progressed far enough, the engine may not start because of an inability to develop fuel rail pressure.

If the engine will not start, there are two indications that the pump head has malfunctioned:

  • The drain flow will be excessive. This can be measured while cranking the engine. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-227 in Section 5. Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-227 in Section 5.
  • The pumping plungers are broken or mechanically stuck. This can be checked by visual inspection. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-227 in Section 5. Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-227 in Section 5.

If the engine oil level is rising due to the oil and Fault Code 281 is active, the pump head has malfunctioned and must be replaced.

Refer to Troubleshooting Fault Code t05-281

Last Modified: 20-Jul-2010


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | One or more multiplexed devices will not operate properly. One or more symptoms will occur.
ISB, ISC and ISL with CM2150 - SAE J1939 Multiplexing Circuit

Circuit Description

Normally, switches, accelerators and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 Data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

The J1939 Data link wiring and VECU location varies by OEM. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second.

The ECM detects an open or short circuit condition in the J1939 Data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning J1939 Data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, malfunctioning OEM VECU or malfunctioning Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-285

Last Modified: 20-Jul-2010


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
ISB, ISC and ISL with CM2150 - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 Data link.

Messages sent from OEM VECUs or Transmission ECUs are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

The J1939 Data link wiring and VECU location varies by OEM. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM expects to receive a valid J1939 message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-286

Last Modified: 09-Dec-2011


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

FAULT CODE 287

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 287 PID: P91 SPN: 91 FMI: 2/19 LAMP: Red SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit (VECU) detected a fault with its accelerator pedal. | Engine can possible only idle or engine will not accelerate to full speed.
ISB, ISC and ISL with CM2150 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) VECU or transmission electronic control unit in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 datalink.

Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view. The J1939 datalink wiring and VECU location varies by OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the secondary throttle position sensor indicates it is in the idle position.

When the accelerator is released and the OEM VECU reads accelerator position as 0 percent, but the secondary throttle position sensor indicates it is not in the idle position.

The OEM VECU determines that the accelerator signal wire is shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault can occur when the OEM VECU detects an error on the accelerator. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the idle validation switch states and accelerator position over the J1939 datalink from an OEM VECU, and the OEM VECU is transmitting the message for that component.

The three types of errors that can occur for this fault are:

  • When the accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent but the idle validation switch indicates it is in the idle position, this fault status is transmitted to the Cummins® engine ECM on the J1939 datalink, which causes this fault to occur in the Cummins® engine ECM.
  • When the accelerator is released and the OEM VECU reads accelerator position as 0 percent, but the idle validation switch indicates it is not in the idle position. This fault status is transmitted to the Cummins® engine ECM on the J1939 datalink, which causes this fault to occur in the Cummins® engine ECM.
  • The OEM VECU determines that the accelerator signal line is shorted high or shorted low.

Note: It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® engine ECM, for other components, or if the accelerator and idle validation switch, or if the datalink is damaged. The OEM configurations must multiplex the accelerator and idle validation switch inputs together to allow the use of the J1939 multiplexing and limp home feature for these components. INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-287

Last Modified: 20-Jul-2010


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 2/19 LAMP: Red SRT: | SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | The engine will not respond to the remote throttle. Engine may only idle. The primary or cab accelerator may be able to be used.
ISB, ISC and ISL with CM2150 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit (ECU) in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 datalink.

Messages sent from the OEM VECU or transmission ECU are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view. The J1939 datalink wiring and VECU location varies by OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The OEM VECU determines that the remote throttle signal wire is shorted high or shorted low. This fault status is transmitted to the Cummins® engine ECM on the J1939 datalink, which causes this fault to occur in the Cummins® engine ECM.

When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU. This fault status is transmitted to the ECM on the J1939 datalink, which causes this fault to occur in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 datalink from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

  • The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins® engine ECM on the J1939 datalink, which causes this fault to occur in the Cummins® engine ECM.
  • When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 datalink, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

Note: It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® engine ECM for other components, or if the remote throttle and remote throttle switch, or the datalink is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-288

Last Modified: 20-Jul-2010


Auxiliary Temperature Sensor Input 1 - Special Instructions.

FAULT CODE 292 (QSB3.3)

Auxiliary Temperature Sensor Input 1 - Special Instructions.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 292 PID: P441 SPN: 441 FMI: 14 LAMP: Red SRT: | Auxiliary Temperature Sensor Input 1 - Special Instructions. | Possible engine power derate.
OEM Temperature/Pressure Sensor Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a temperature sensor input to the Cummins ECM. A specific calibration is then created to recognize this temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate may be associated with this fault code.

Component Location

The OEM temperature sensor input will vary depending on application. Refer to the OEM troubleshooting manual for sensor location.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is activated when the temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible depending on the OEM application.

Refer to Troubleshooting Fault Code t05-292

Last Modified: 20-Jul-2010


Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 293 (QSB3.3)

Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 293 PID: P441 SPN: 441 FMI: 3 LAMP: Amber SRT: | Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the OEM auxiliary temperature circuit. | None on performance.
Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a temperature sensor input to the Cummins electronic control module (ECM). A specific calibration is then created to recognize this temperature sensor input.

Component Location

The OEM temperature sensor input will vary depending on application. Refer to the OEM troubleshooting and repair manual for sensor location.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-293

Last Modified: 20-Jul-2010


Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 294 (QSB3.3)

Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 294 PID: P441 SPN: 441 FMI: 4 LAMP: Amber SRT: | Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at OEM auxiliary temperature circuit. | None on performance.
Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a temperature sensor input to the Cummins electronic control module (ECM). A specific calibration is then created to recognize this temperature sensor input.

Component Location

The OEM temperature sensor input will vary depending on application. Refer to the OEM troubleshooting and repair manual for sensor location.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-294

Last Modified: 20-Jul-2010


Barometric Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2/2 LAMP: Amber SRT: | Barometric Pressure - Data Erratic, Intermittent, or Incorrect. The ambient air pressure sensor is reading an erratic value at initial key-on. | Engine power derate.
ISB - Barometric Pressure Sensor Circuit
QSB3.3 ISBe, ISDe, ISC, ISL, and ISLe - Barometric Pressure Circuit

Circuit Description

The ambient air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on elevation where the engine is presently operating. The ambient air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The engine control module (ECM) provides a 5 volt supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

ISB: The combination ambient air temperature/pressure sensor is located in the original equipment manufacturer (OEM) intake air plumbing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view. QSB3.3 ISBe, ISDe, ISC, ISL, and ISLe: The barometric pressure sensor is located near the intake manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned on before the engine is started.

The diagnostic only runs once per trip when the keyswitch is initially turned on.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure reading is higher or lower than the other absolute pressure sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the ambient pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

At key-on, before the engine starts, the sensor readings for intake manifold pressure, exhaust gas pressure, if equipped, and engine oil pressure, if equipped, are compared with the barometric pressure. This fault code occurs if the barometric pressure sensor reading is different from the other three. This check is only done once after the keyswitch is turned on.

Possible causes of this fault code include:

  • Stuck in-range barometric pressure sensor reading.
  • High resistance in the barometric pressure sensor signal or return lines.

On ISB applications, this fault code will go active if the intake manifold pressure/temperature sensor is accidentally installed in the ambient air temperature/pressure sensor location. These sensors appear the same on the outside and can be accidentally interchanged.

Refer to Troubleshooting Fault Code t05-295

Last Modified: 07-Nov-2016


Auxiliary Pressure Sensor Input 1 - Special Instructions

FAULT CODE 296 (QSB3.3)

Auxiliary Pressure Sensor Input 1 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 296 PID: P223 SPN: 1388 FMI: 14 LAMP: Red SRT: | Auxiliary Pressure Sensor Input 1 - Special Instructions | Possible engine power derate.
OEM Temperature/Pressure Sensor Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure sensor input to the Cummins electronic control module (ECM). A specific calibration is then created to recognize this pressure sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate may be associated with this fault code.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM troubleshooting and repair manual for sensor location.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is activated when the pressure input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible depending on the OEM application.

Refer to Troubleshooting Fault Code t05-296

Last Modified: 20-Jul-2010


Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 297 (QSB3.3)

Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 297 PID: P443 SPN: 1388 FMI: 3 LAMP: Amber SRT: | Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the OEM pressure circuit. | None on performance.
Auxiliary Pressure Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure sensor input to the Cummins electronic control module (ECM). A specific calibration is then created to recognize this pressure sensor input.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM troubleshooting and repair manual for sensor location.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-297

Last Modified: 20-Jul-2010


Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 298 (QSC3.3)

Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 298 PID: P443 SPN: 1388 FMI: 4 LAMP: Amber SRT: | Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the OEM pressure circuit. | None on performance.
Auxiliary Pressure Sensor Input 1 Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure sensor input to the Cummins electronic control module (ECM). A specific calibration is then created to recognize this pressure sensor input.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM troubleshooting and repair manual for sensor location.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the OEM harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-298

Last Modified: 20-Jul-2010


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S001 SPN: 651 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at cylinder 1 injector driver or return pin. | Engine can misfire or possibly run rough.
ISB - Injector Circuit
ISC and ISL - Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is faulty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than 1 minute.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 .

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is faulty.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than 1 minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • An open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

Same Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 322.

Last Modified: 03-Aug-2010


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S005 SPN: 655 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at cylinder 5 injector supply or return pin. | Engine can misfire or possibly run rough.
ISB - Injector Circuit
ISC and ISL - Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault code will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injector event for the cylinder(s) that is faulty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

The ECM will attempt to enable any disabled injector circuit whenever the engine is started, and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted, or if the engine is permitted to idle for more than 1 minute.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that are faulty.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted, or if the engine is permitted to idle for more than 1 minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • An open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • A damaged ECM.

If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.

Causes of multiple injector fault codes in the same bank of injectors are:

  • A short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • A short circuit in any of the three injectors in the bank - shorts to ground
  • A damaged ECM.

Same Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 323.

Last Modified: 03-Aug-2010


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S003 SPN: 653 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at injector 3 supply or return pin. | Engine can misfire or possibly run rough.
ISB - Injector Circuit
ISC and ISL - Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that are faulty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active, and the faulty condition is repaired, the fault will become inactive once the engine is restarted, or if the engine is permitted to idle for more than 1 minute.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that are faulty.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than 1 minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.

If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing, or a short circuit to ground in the injector solenoid.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

Same Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 324.

Last Modified: 15-Jun-2011


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S006 SPN: 656 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at cylinder 6 injector supply or return pin. | Engine can misfire or possibly run rough.
ISB - Injector Circuit
ISC and ISL - Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return to two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that are faulty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted, or if the engine is permitted to idle for more than 1 minute.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is faulty.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than 1 minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing, or a short circuit to ground in the injector solenoid.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

Same Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 325.

Last Modified: 03-Aug-2010


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S002 SPN: 652 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at cylinder 2 injector supply or return pin. | Engine can misfire or possibly run rough.
ISB - Injector Circuit
ISC and ISL - Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault code will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that are faulty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and malfunctions.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault code is active, and the fault condition is repaired, the fault code will become inactive once the engine is restarted, or the engine is permitted to idle for more than 1 minute.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that are faulty.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than 1 minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.

Causes of a single injector fault are:

  • An open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • A damaged ECM.

If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing, or a short circuit to ground in the injector solenoid.

Causes of multiple injector fault codes in the same bank of injectors are:

  • A short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • A short circuit in any of the three injectors in the bank - shorts to ground
  • A damaged ECM.

Same Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 331.

Last Modified: 03-Aug-2010


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S004 SPN: 654 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at cylinder 4 injector driver or return pin. | Engine can misfire or possibly run rough.
ISB with CM2150 - Injector Circuit
ISC and ISL with CM2150 - Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The electronic control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each housing pass-through connector provides power and return for two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is faulty.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled for the faulty cylinder.

Conditions for Clearing the Fault Code

The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted, or if the engine is permitted to idle for more than 1 minute.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the cylinder(s) that is faulty.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuits whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than 1 minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.

If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number two or cylinder number three.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, make sure there are no shorts to a rocker lever.

NOTE: Fault Code 951 (Cylinder Balance) can also be present due to this fault code.

Same Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 332.

Last Modified: 15-Jun-2011


Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 334 (QSB3.3)

Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 334 PID: P110 SPN: 110 FMI: 2 LAMP: Amber SRT: | Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect. The engine coolant temperature reading is not changing with engine operating conditions. | The ECM will estimate engine coolant temperature.
Engine Coolant Temperature Sensor

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is use by the ECM for the engine protection system and engine emission control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Two different failure modes of the engine coolant temperature sensor can trigger this fault code. Either the sensor is not reading ambient air temperature after an extended period with the engine not running or the engine coolant temperature is not changing with engine operating conditions.

Possible causes of this fault code include:

  • Stuck in-range engine coolant temperature sensor
  • High resistance in the engine coolant temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code t05-334

Last Modified: 20-Jul-2010


Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. ECM power supply errors have been detected. | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
ISB, ISC, and ISL with CM2150 - Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the OEM power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code t05-343

Last Modified: 20-Jul-2010


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 627 FMI: 12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Possible low power, engine misfire, and/or engine will not start.
ISC and ISL with CM2150 - Injector Power Supply
ISB with CM2150 - Injector Power Supply

Circuit Description

Between each injection event, the electronic control module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors; this power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the measured injector power supply voltage is lower than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the keyswitch is cycled.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code will become active when the engine is running, the primary engine speed sensor signal is present, the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned on.

This fault code will become inactive whenever the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code t05-351

Last Modified: 20-Jul-2010


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Engine power derate.
ISB, ISC, and ISL with CM2150 - Sensor Supply Number 1

Circuit Description

The sensor supply 1 of the electronic control module (ECM) provides a 5-VDC supply for the engine camshaft position sensor, fuel rail pressure sensor, exhaust gas pressure sensor, intake manifold pressure sensor, crankcase pressure sensor, exhaust gas recirculation (EGR) differential pressure sensor, barometric pressure sensor, engine oil pressure sensor and EGR position sensor.

Component Location

Sensor supply number 1 is located in the ECM engine harness connector and provides a 5-VDC supply to various pressure sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for all the sensors tied to the 5-VDC supply is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code t05-352

Last Modified: 20-Jul-2010


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Engine power derate.
ISB, ISC, and ISL with CM2150 - Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 of the electronic control module (ECM) provides a 5 VDC supply for the engine camshaft position sensor, fuel rail pressure sensor, exhaust gas pressure sensor, intake manifold pressure sensor, crankcase pressure sensor, exhaust gas recirculation (EGR) differential pressure sensor, barometric pressure sensor, engine oil pressure sensor and EGR position sensor.

Component Location

Sensor supply number 1 is located in the ECM engine harness connector and provides a 5 VDC supply to various pressure sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 signal voltage is greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for all the sensors tied to the 5 VDC supply.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-386

Last Modified: 20-Jul-2010


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power derate increasing in severity from time after alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing.
ISB with CM2150 - Engine Oil Rifle Pressure Circuit
ISC, and ISL with CM2150 - Engine Oil Rifle Pressure Circuit

Circuit Description

The engine control module (ECM) provides a 5-VDC supply to the engine oil pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure can be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

If the ECM detects low signal voltage indicating low engine oil pressure, this fault code sets.

Component Location

For ISB CM2150 engines, the engine oil pressure switch is located on the front of the engine on the left (intake) side on the top of the front gear housing.

For ISC and ISL CM2150 engines, the engine oil pressure sensor is located on the left (intake) side of the engine block below the ECM.

Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is below the minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate issued by the ECM, limiting the power output of the engine.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light and the torque derate will be removed when the oil pressure reading is detected to be within the normal operating range.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code indicated that low engine oil pressure has been detected by the ECM. Troubleshoot the cause of the low engine oil pressure.

Refer to Troubleshooting Fault Code t05-415

Last Modified: 01-May-2012


Water-In-Fuel Indicator - Data Valid but Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water-In-Fuel Indicator - Data Valid but Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water-In-Fuel Indicator - Data Valid but Above Normal Operatibng Range - Least Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
ISB, ISC, and ISL with CM2150 - Water-In-Fuel Indicator

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The water-in-fuel sensor is used to indicate high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that water in the fuel filter is above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the flashing amber MAINTENANCE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the flashing amber MAINTENANCE light immediately after the water has been drained from the fuel filter.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter, a malfunctioning water-in-fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code t05-418

Last Modified: 30-Apr-2012


SAE J1939 Datalink - Abnormal Update Rate

FAULT CODE 427

SAE J1939 Datalink - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9/9 LAMP: None SRT: | J1939 Datalink - Abnormal Update Rate. Communication between the electronic control module (ECM) and another device on the SAE J1939 data link has been lost. | Engine speed will ramp down and remain at idle.
ISB, ISC, and ISL with CM2150 - SAE J1939 Data Link Circuit

Circuit Description

Devices such as ABS controllers, autoshift transmissions, ASR systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) (VECUs) can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The ECM is located on the intake side of the engine, near the front. The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second. The ECM detects an open or short circuit condition in the J1939 datalink harness.

Action Taken When the Fault Code is Active

  • The ECM will log the fault code immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

The ECM will set the fault code inactive immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault occurs whenever the ECM has been receiving SAE J1939 datalink commands from an external OEM device and is no longer receiving the datalink commands. Possible causes of this fault include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
  • The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages
  • The external OEM controlling device has failed or can no longer transmit on the datalink.
Refer to Troubleshooting Fault Code t05-427

Last Modified: 20-Jul-2010


Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P097 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
ISB, ISC, and ISL with CM2150 - Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5 volt reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor signal voltage is above 4.95-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes for this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-428

Last Modified: 20-Jul-2010


Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
ISB, ISC, and ISL with CM2150 - Water-in-Fuel Sensor Indicator

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5 VDC reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor then pulls the 5 VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor signal voltage is below 0.05-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-429

Last Modified: 20-Jul-2010


Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 431

Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | Engine will only idle.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal or lever position. The switch return is a shared return with other OEM cab switches.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal or lever assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects a signal voltage detected simultaneously on both the idle validation and off-idle validation switches. Voltage will only be detected on one of the circuits.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

  • This fault code is usually caused by an open circuit on either the idle validation on-idle or the idle validation off-idle signal circuit, a loose connection, uncalibrated accelerator pedal or lever assembly, or miswired idle validation switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate the new accelerator pedal or lever assembly, turn the keyswitch to the ON position and fully depress and release the pedal or lever three times.
Refer to Troubleshooting Fault Code t05-431

Last Modified: 20-Jul-2010


Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

FAULT CODE 432

Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: S230 SPN: 558 FMI: 13/13 LAMP: Red SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration. Voltage at idle validation on-idle and off-idle circuit does not match accelerator pedal position. | Engine will only idle.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The accelerator pedal or lever position sensor is attached to the accelerator pedal or lever. The accelerator pedal or lever position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal or lever is depressed and released. The accelerator pedal or lever position circuit contains three wires: accelerator pedal or lever position supply, accelerator pedal or lever position return, and accelerator pedal or lever position signal. The switch return circuit for the on-idle and off-idle validation circuit is a shared return with other original equipment manufacturer (OEM) switches.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal or lever.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the position of the throttle pedal position and the idle validation switch do not match.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault is logged when both the on-idle and off-idle validation switches disagree with the accelerator pedal or lever position signal. Turning the keyswitch ON while partially depressing the accelerator pedal or lever can cause this fault code to go active. This fault will stay active until the pedal or lever is cycled through its full travel.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 20-Jul-2010


Fault Code Path Selection

FAULT CODE 08-fc435
Fault Code Path Selection

Is the engine an ISB? | Go to 08-fc435b
Is the engine an ISC or ISL? | Go to 08-fc435cl

Last Modified: 03-Aug-2006


Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine may stop running or be difficult to start.
ISB, ISC, and ISL with CM2150 - Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-ampere fuse in the unswitched battery wires to protect the original equipment manufacturer (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the intake side of the engine. The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is less than 6-VDC.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the fault code immediately after the battery voltage is above +6-VDC.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the ECM battery supply voltage drops below 6-VDC.

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code t05-441

Last Modified: 20-Jul-2010


Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to all electrical components.
ISB, ISC, and ISL with CM2150 - Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-ampere fuse in the unswitched battery wire to protect the OEM harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual for battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is greater than 36-VDC.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the fault code immediately after the battery voltage drops below 36-VDC.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the ECM battery supply voltage exceed 36-VDC. Causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code t05-442

Last Modified: 20-Jul-2010


Fault Code Path Selection

FAULT CODE 08-fc449
Fault Code Path Selection

Is the engine an ISB or QSB3.3 engine? | Go to 08-fc449b
Is the engine an ISC or ISL engine? | Go to 08-fc449cl

Last Modified: 03-Aug-2006


Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at rail fuel pressure sensor circuit. | Power and or speed derate.
ISB with CM2150 - Fuel Rail Pressure Sensor Circuit
ISC and ISL with CM2150 - Fuel Rail Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel rail. The fuel delivery pressure sensor has a 5-volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel rail. The ECM will detect a low signal voltage at high rail pressures. The ECM will detect a high signal voltage during low rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail. Use the following procedure for a detailed component location view.Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the fuel delivery pressure signal voltage is less than 0.20-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code will become active if there is an open circuit on any of the three pins (+5 volt supply, signal, or return) that connect the sensor or ECM to the wiring harness. This fault will also be active if the signal wire is shorted to a source of voltage. This fault code will become inactive any time the keyswitch is ON and the signal returns to a valid in-range voltage.

Causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the signal wire)
  • Open circuit on the signal wire
  • Open circuit on the +5 volt supply wire
  • Open circuit on the return wire
  • Damaged sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-451

Last Modified: 20-Jul-2010


Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the rail fuel pressure sensor circuit. | Power and or speed derate.
ISB with CM2150 - Fuel Rail Pressure Sensor Circuit
ISC and ISL with CM2150 - Fuel Rail Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel rail. The fuel delivery pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel rail. The ECM will detect a low signal voltage at high rail pressures. The ECM will detect a high signal voltage during low rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the fuel delivery pressure signal voltage is greater than 4.80-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code will become inactive anytime the keyswitch is ON and the signal pin of the ECM is too low. This can be caused by a short circuit to ground on the +5 volt supply or signal wire. This fault will also become active if a device that is powered by the common +5-VDC power supply is shorted to ground. This fault code will become inactive any time the keyswitch is ON and the signal returns to a valid in-range voltage.

Causes for this fault code include:

  • Engine harness; the supply or signal wire is shorted to ground
  • Other components; any component connected to the common power supply is shorted to ground
  • Damaged sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-452

Last Modified: 20-Jul-2010


Engine Oil Level - Data Valid But Below Normal Operational Range - Least Severe Level

FAULT CODE 471

Engine Oil Level - Data Valid But Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 471 PID: P98 SPN: 98 FMI: 1/17 LAMP: Maintenance SRT: | Engine Oil Level - Data Valid But Below Normal Operational Range - Least Severe Level. Low oil level has been detected by the oil level sensor. | The engine may derate. Possible low oil pressure, possible severe engine damage.
ISB, ISC, and ISL with CM2150 - Engine Oil Level Sensor.

Circuit Description

An algorithm in the electronic control module (ECM) calibration monitors engine oil level while the ECM is keyed on and no engine speed is detected. If the engine oil level falls below a certain threshold, the ECM will activate Fault Code 471, as well as the maintenance lamp. The maintenance lamp will flash only during a key-on event.

Component Location

The engine oil level sensor is located on the engine oil dipstick, on the left side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine speed is 0 rpm.

Conditions for Setting the Fault Codes

The engine oil level is detected to be low at key-on.

Action Taken When the Fault Code is Active

  • The amber CHECK ENGINE light will flash for 30 seconds when the keyswitch is turned on.

Conditions for Clearing the Fault Code

The amber CHECK ENGINE light will stop flashing at key-on and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If inactive counts of Fault Code 471 are logged in the ECM, it can be possible that the engine was running or keyed on while tilted at an angle severe enough to cause this fault to be triggered.

Other causes of Fault Code 471 can include:

  • The engine was not filled to proper capacity during the most recent oil change
  • External engine oil leaks (oil leaking onto the ground)
  • Internal engine oil leaks (oil leaking into the fuel system or cooling system)
  • High engine oil consumption/power cylinder failure (check for abnormally high blowby when the engine is loaded).
Refer to Troubleshooting Fault Code t05-471

Last Modified: 20-Jul-2010


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Intake Manifold 1 Pressure/ Temperature Sensor

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

When the intake air is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. This fault code indicates that the intake manifold temperature has exceeded the maximum engine protection limit.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

The maximum torque output of the engine will return and the fault code will go inactive after the intake manifold temperature drops below a calibratible limit set in the ECM.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold. Possible causes of this fault code include:

  • Plugged charge air cooler fins
  • Restricted airflow through the charge air cooler
  • An undersized charge air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-488

Last Modified: 20-Jul-2010


Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 499

Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 499 PID: P98 SPN: 98 FMI: 4 LAMP: Amber SRT: | Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The engine oil level sensor has detected an internal failure. | Oil level sensor operation will be disabled.
ISB, ISC, and ISL - Oil Level Sensor Circuit

Circuit Description

The oil level sensor will monitor the oil fluid level in the oil pan at key-on. The oil level sensor will not monitor the oil level after the engine is started or when the engine speed is greater than 0 rpm. During the engine key-on, if the oil level sensor detects a critical low oil level, then the amber CHECK ENGINE light will blink for 30 seconds and a fault code will be logged. If an operator observes a blinking amber CHECK ENGINE light at key-on, the operator must check the engine oil level with the manual dipstick.

The oil level sensor provides the electronic control module (ECM) with a pulse width modulated (PWM) signal. Within this signal, the oil level sensor transmits the engine oil level reading, oil temperature, and fault code information from the oil level sensor.

Component Location

The oil level sensor is located on the left side of the engine on the front oil dipstick port. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The oil level sensor has detected an internal short or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The oil level sensor operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable oil level sensor operation immediately after a valid PWM signal is received from the oil level sensor.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open or short circuit internally to the oil level sensor
  • A malfunctioning oil level sensor.
Refer to Troubleshooting Fault Code t05-499

Last Modified: 20-Jul-2010


Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 528

Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 528 PID: P093 SPN: 93 FMI: 2 LAMP: Amber SRT: | Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect. An error has been detected in the alternate torque switch circuit. | Torque curve setting defaults to default curve.
Alternate Torque Circuit

Circuit Description

The torque curve switch circuit allows the operator to select from up to three preprogrammed torque curves using a two- or three-position switch, depending on which one the original equipment manufacturer (OEM) has provided.

Component Location

The location of the torque curve switch circuit varies with each OEM and equipment model. Refer to the OEM troubleshooting and repair manual.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The switch can be monitored for proper operation with INSITE™ electronic service tool. If the switch is changing state correctly on the service tool, then the problem does not lie in the switch circuit.

The 3-position switch has three states:

  • Position 1 - open
  • Position 2 - closed
  • Position 3 - 1500 ohm resistance.

The 2-position switch has two states:

  • Position 1 - open
  • Position 2 - closed.
Refer to Troubleshooting Fault Code t05-528

Last Modified: 20-Jul-2010


Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 529 (QSB3.3)

Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 529 PID: S051 SPN: 703 FMI: 3 LAMP: Amber SRT: | Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage has been detected at the auxiliary input/output 3 circuit. | None on performance.
Dual Output Signal

Circuit Description

The electronic control module (ECM) provides a signal to the original equipment manufacturer (OEM) output control solenoid to turn the OEM supplied accessory on and off. The OEM output control circuit varies by OEM. Some OEMs will use a solenoid return that is wired to the ECM or will use a return that goes to engine block or chassis ground.

Component Location

The OEM output solenoid location varies by OEM. Refer to the appropriate OEM troubleshooting and repair manual to determine the location.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on this circuit. When the ECM commands the OEM output signal low, it expects the voltage level to be approximately 0-VDC. If it detects a high voltage, this fault is recorded. If Fault Code 529 is still active after completing the following troubleshooting steps, refer to the OEM troubleshooting and repair manual for procedures to check the OEM output device for an open circuit or short circuit to ground. Possible causes of this fault include:

  • Open circuit in the engine harness or OEM output control solenoid
  • Short circuit to voltage source in the OEM harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-529

Last Modified: 20-Jul-2010


Fault Code Path Selection

FAULT CODE 08-fc553
Fault Code Path Selection

Is the engine an ISB or QSB3.3 engine? | Go to 08-fc553b
Is the engine an ISC or ISL engine? | Go to 08-fc553cl

Last Modified: 26-Feb-2007


Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 554

Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 554 PID: P157 SPN: 157 FMI: 2 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect. the ECM has detected that the fuel pressure signal is not changing. | The ECM will estimate fuel pressure and power is reduced.
ISB with CM2150 - Fuel Rail Pressure Sensor
ISC and ISL with CM2150 - Fuel Rail Pressure Sensor

Circuit Description

The fuel pressure sensor contains supply, signal, and return pins. The electronic control module (ECM) provides +5 volts to the fuel pressure sensor. This +5 volt power supply is a shared supply. Other sensors on this circuit are the intake manifold pressure sensor and backup engine position sensor.

Component Location

The fuel pressure sensor is located in the rail fuel on the air intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the fuel rail pressure reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code can become active any time the engine is loaded and the electronic control module (ECM) detects the fuel pressure in the rail fuel is not changing. This fault code will become inactive whenever the ECM is powered down or if the ECM detects that the engine is loaded and the fuel pressure is changing normally. If there are many inactive counts of this fault code or if the fault is not repeatable, look for signs of tampering to the fuel pressure sensor circuit. If the fault code occurs intermittently (can not be reproduced during a road test), then inspect each of the following for poor connections or damage:

  • Intake manifold pressure sensor
  • Backup engine position sensor
  • Fuel pressure sensor.
Refer to Troubleshooting Fault Code t05-554

Last Modified: 20-Jul-2010


Fault Code Path Selection

FAULT CODE 08-fc555
Fault Code Path Selection

Is the engine an ISB or QSB3.3 engine? | Go to 08-fc555b
Is the engine an ISC or ISL engine? | Go to 08-fc555cl

Last Modified: 18-Jan-2007


Fault Code Path Selection

FAULT CODE 08-fc556
Fault Code Path Selection

Is the engine an ISB or QSB3.3 engine? | Go to 08-fc556b
Is the engine an ISC or ISL engine? | Go to 08-fc556cl

Last Modified: 18-Jan-2007


Fault Code Path Selection

FAULT CODE 08-fc559
Fault Code Path Selection

Is the engine an ISB or QSB3.3 engine? | Go to 08-fc559b
Is the engine an ISC or ISL engine? | Go to 08-fc559cl

Last Modified: 02-Aug-2006


Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
ISB, ISC, and ISL with CM2150 - Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the ECM through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It may be wired back to the ECM on some vehicles, or wired to the chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM troubleshooting and repair manual for exact location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is being energized or de-energized. In some cases the diagnostic may also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on Quickserve® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code.This fault can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code t05-584

Last Modified: 20-Jul-2010


Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S039 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at starter lockout circuit. | The engine will not have starter lockout protection.
ISB, ISC, and ISL with CM2150 - Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the electronic control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It may be wired back to the ECM on some vehicles or wired to the chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0 VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to OEM troubleshooting and repair manual for exact location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is being energized or de-energized. In some cases the diagnostics may also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM signal is detected to be greater than 0 VDC when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The starter lockout feature will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded on, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Refer to Troubleshooting Fault Code t05-585

Last Modified: 20-Jul-2010


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. High battery voltage detected by the battery voltage monitor feature. | Amber warning lamp illuminated until high battery voltage condition is corrected.
ISB, ISC, and ISL with CM2150 - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is higher than 18-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light when the battery voltage falls below 18-VDC.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Service Manual for the engine being serviced.

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if idle speedup is enabled. View the Alternator Failure Warning feature settings with INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code t05-596

Last Modified: 09-Apr-2012


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low battery voltage detected by the battery voltage monitor feature. | Amber lamp will light until low battery voltage condition is corrected.
ISB, ISC, and ISL with CM2150 - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than 10-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light when the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if Idle Speedup is enabled. View the Alternator Failure Warning feature settings using the INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault:

  • Undercharged batteries caused by a malfunctioning alternator or regulator
  • High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.
Refer to Troubleshooting Fault Code t05-597

Last Modified: 09-Apr-2012


Electrical Charging System Voltage - Data Valid But Below Normal Operatiing Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operatiing Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level. Very low battery voltage detected by the battery voltage monitor feature. | Red lamp illuminated until very low battery voltage condition is corrected.
ISB, ISC, and ISL with CM2150 - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than 8 VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light when the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the corresponding service manual for the engine bening serviced. Refer to Procedure 019-032 in Section 19.

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if Idle Speedup is enabled. View the Alternator Failure Warning feature settings with INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code t05-598

Last Modified: 09-Apr-2012


Auxiliary Commanded Dual Output Shutdown - Special Instructions

FAULT CODE 599 (QSB3.3)

Auxiliary Commanded Dual Output Shutdown - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 599 PID: S025 SPN: 640 FMI: 14 LAMP: Red SRT: | Auxiliary Commanded Dual Output Shutdown - Special Instructions. The engine protection limit has been exceeded for the dual outputs calibrated limits. | Engine will shut down.
Dual Outputs Circuit

Circuit Description

Dual outputs based on sensed parameters provide up to two independent switched outputs for original equipment manufacturer (OEM) use. The state of each switched output can be determined by different inputs to the electronic control module (ECM), depending on the engine platform. The ECM can provide different outputs to OEM devices if any of the inputs are above or below calibrated thresholds. Each switched output is independent of the other with respect to control parameter input and threshold settings.

Component Location

The dual outputs features are OEM dependent. Refer to the OEM troubleshooting and repair manual for component location.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is activated when one of the OEM defined inputs has exceeded a calibratible limit. The triggers for shutdown are OEM dependent.

Refer to Troubleshooting Fault Code t05-599

Last Modified: 20-Jul-2010


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Engine Oil Change Interval - Condition Exists. Change engine oil and filter. | Maintenance reminder only.
Maintenance Reminder

Circuit Description

The electronic control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

The oil filter is located on the exhaust side of the engine, and the oil fill port varies by application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location for the oil filter and refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for the location of the oil fill port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that based on the programmable setting in the Maintenance Monitor feature, the engine oil and filter needs to be changed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the maintenance condition is exceeded.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the Maintenance Monitor feature has been reset using INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code will only become active if the Maintenance Monitor is enabled in INSITE™ electronic service tool. Make sure that the oil and filter are changed before clearing the fault.

Refer to Troubleshooting Fault Code t05-649

Last Modified: 20-Jul-2010


Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 686

Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 686 PID: P103 SPN: 103 FMI: 2/2 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect. An invalid turbocharger speed signal has been detected by the ECM. | None on performance. The ECM uses an estimated turbocharger speed.
ISB, ISC, and ISL with CM2150 - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is above the maximum limit set in the calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the ECM detects a turbocharger speed that is greater than the speed that is physically achievable by the turbocharger. Usually this indicates a faulty sensor or incorrect speed signals from the turbocharger speed sensor. This fault can be caused by failures in the following components:

  • Turbocharger speed sensor
  • Engine harness
  • ECM power supply or grounds
  • Electronic vehicle accessories which emit excessive electromagnetic interference.

This fault becomes inactive any time the ECM detects a valid turbocharger speed. If the fault occurs intermittently:

  • Look for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector)
  • Look for sources of electronic noise such as poorly installed vehicle electronic components
  • Be sure that the vehicle chassis grounds are in good condition
  • Be sure that the ECM power supply and ground circuits are in good condition and that this power supply is not shared with other vehicle electronics.
Refer to Troubleshooting Fault Code t05-686

Last Modified: 20-Jul-2010


Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 687

Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 1/18 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low turbocharger speed detected by the ECM. | Engine power derate. The ECM uses an estimated turbocharger speed. To clear the fault code after a repair, take the vehicle on a short test drive with a few hard accelerations from stop to approximately 35 mph.
ISB, ISC, and ISL with CM2150 - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is detected to be less than 600 rpm for more than 1 second when the engine speed is greater than 1200 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will estimate turbocharger speed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes. To clear the fault code after a repair, take the vehicle on a short test drive with a few hard accelerations from stop to approximately 35 mph.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault can possibly come active if the ECM senses engine speed while at the same time a turbocharger speed signal is less than 600 rpm.

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged alternator (EMI or internal short)
  • Damaged ECM.

This fault becomes inactive any time the speed signal from the turbocharger speed sensor returns.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

For the code to clear, the ratio of boost pressure to ambient pressure must be above 1.19:1 for at least 30 consecutive seconds. This condition can only be achieved during a test drive when the engine is under load. Operating the engine at idle or high idle while stationary will not create enough load to maintain boost pressure at 1.19 times ambient pressure for 30 consecutive seconds.

Although it is possible for a damaged ECM to be the root cause of this fault code, it is highly unlikely and ECM replacement should only be considered as a last resort if no other repairs are successful in clearing the fault code.

In very rare cases, it has been shown that the turbocharger can cause this fault code to come active and turbocharger replacement may be the only way to clear the fault code.

Refer to Troubleshooting Fault Code t05-687

Last Modified: 21-Mar-2011


Engine Oil Level - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 688

Engine Oil Level - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 688 PID: P98 SPN: 98 FMI: 0 LAMP: Red SRT: | Engine Oil Level - Data Valid but Above Normal Operational Range - Most Severe Level. High oil level has been detected by the oil level sensor. | Possible low power, excessive smoke, oil dilution, contamination, or severe engine damage. The engine may derate.
ISB, ISC, and ISL with CM2150 - Engine Oil Level Sensor.

Circuit Description

An algorithm in the electronic control module (ECM) calibration monitors engine oil level while the ECM is keyed on and no engine speed is detected. If the engine oil level exceeds a certain threshold, the ECM will activate Fault 688.

Component Location

The engine oil level sensor is located on the engine oil dipstick, on the air intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in section E for further details on dipstick location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine speed is 0 rpm.

Conditions for Setting the Fault Codes

The engine oil level is detected to be above the normal operating level at key-on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Fault code 688 indicates that the oil level in the engine is much higher than the recommended oil level.

Other causes of fault code 688 may include:

  • The engine may have been overfilled with oil during the most recent oil change.
  • The fuel system may be leaking into the lube oil system. Check for fuel system faults or use fluorescent fuel system dye to identify leaks.
  • The cooling system may be leaking into the lube oil system. Check for coolant in the oil.
Refer to Troubleshooting Fault Code t05-688

Last Modified: 20-Jul-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected an error in crankshaft position sensor signal. | Engine power derate.
ISB, ISC, and ISL with CM2150 - Engine Crankshaft Speed/Position Circuit

Circuit Description

The ECM provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies depending on engine model. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the crankshaft speed/position sensor for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The crankshaft speed sensor is used to provide engine speed and position information to the ECM.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light after the ECM detects a valid signal from the crankshaft speed/position sensor.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault is logged when the ECM does not receive a valid crankshaft position signal.

Causes of this fault include:

  • Open or short circuit of the 5 volt SUPPLY, SIGNAL, or RETURN wire in the engine harness
  • Damaged crankshaft position sensor.

NOTE: On INSITE™ electronic service tool, the 'Crankshaft Position Sensor” is referred to as 'Engine Speed Main Sensor'.

Refer to Troubleshooting Fault Code t05-689

Last Modified: 10-Jul-2015


Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor inlet air temperature circuit. | Engine power derate.
ISC and ISL with CM2150 - Turbocharger Compressor Inlet Temperature Sensor Circuit
ISB with CM2150 - Ambient Air Temperature Sensor Circuit

Circuit Description

The compressor inlet air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor inlet of the turbocharger. The electronic control module (ECM) supplies 5-VDC to the compressor inlet temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Note: The ISB with CM2150 uses a combination ambient air temperature/pressure sensor located in the OEM intake air plumbing rather than a turbocharger compressor inlet temperature sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the compressor inlet temperature signal voltage is greater than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the compressor inlet temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The turbocharger inlet air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor inlet temperature sensor can be used depending on the turbocharger arrangement.

On ISB with CM2150 engines, an extension harness between the main harness and the ambient air temperature/pressure sensor is always used.

Possible causes of this fault code:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-691

Last Modified: 20-Jul-2010


Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the turbocharger compressor inlet air temperature sensor circuit. | Engine power derate.
ISC and ISL with CM2150 - Turbocharger Compressor Inlet Air Temperature Sensor Circuit
ISB with CM2150 - Ambient Air Temperature Sensor Circuit

Circuit Description

The turbocharger compressor inlet temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor inlet of the turbocharger. The electronic control module (ECM) supplies 5-VDC to the compressor inlet temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Note: The ISB with CM2150 uses a combination ambient air temperature/pressure sensor located in the OEM intake air plumbing rather than a turbocharger compressor inlet temperature sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the compressor inlet temperature signal voltage is less than 0.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the compressor inlet temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

An extension harness between the main engine harness and the turbocharger compressor inlet temperature sensor can be used, depending on the turbocharger arrangement.

On ISB with CM2150 engines, an extension harness between the main harness and the ambient air temperature/pressure sensor is always used.

Possible causes of this fault code:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-692

Last Modified: 20-Jul-2010


ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or an open circuit detected at the internal ECM temperature sensor. | None on performance.
ISB, ISC, and ISL Electronic Control Module

Circuit Description

The electronic control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM is located on the fuel system side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code t05-698

Last Modified: 20-Jul-2010


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S064 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment. Engine position signal from the engine speed sensor and camshaft position sensor do not match. | Engine will run derated. Hard start and rough idle possible.
ISB, ISC, and ISL with CM2150 - Engine Magnetic Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are hall effect type sensors. The electronic control module (ECM) provides a 5-VDC supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the lobes on the camshaft gear pass the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used to determine the position of the engine by the ECM.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

This fault code is logged when there is a mechanical misalignment between the crankshaft engine position sensor and the camshaft engine position sensor.

Possible causes for this fault code include:

  • Engine speed sensor rings that are loose or not aligned correctly
  • Mechanical misalignment.
Refer to Troubleshooting Fault Code t05-731

Last Modified: 20-Jul-2010


Engine Camshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S064 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | Engine Camshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the camshaft position sensor signal. | Engine can run rough. Possibly poor starting capability. Engine runs using primary engine position sensor.
ISB, ISC, and ISL with CM2150 - Engine Magnetic Speed/Position Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

Both engine position sensors are located on the back side of the front gear housing above the fuel pump drive. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the camshaft speed/position sensor for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the camshaft speed/position sensor.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault is logged when the ECM does not receive a valid camshaft position signal.

Causes of this fault include:

  • Open or short circuit of the 5 volt SUPPLY, SIGNAL, or RETURN wire in the engine harness
  • Damaged or malfunctioning camshaft position sensor.

NOTE: On INSITE™ electronic service tool, the 'Camshaft Position Sensor' is referred to as 'Engine Speed Backup Sensor'.

Refer to Troubleshooting Fault Code t05-778

Last Modified: 20-Jul-2010


Auxiliary Equipment Sensor Input 3 - Root Cause Not Known

FAULT CODE 779

Auxiliary Equipment Sensor Input 3 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 779 PID: S051 SPN: 703 FMI: 11 LAMP: Amber SRT: | Auxiliary Equipment Sensor Input 3 - Root Cause Not Known | Possible engine derate.
OEM Temperature/Pressure Sensor Circuit

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure or temperature sensor input to the Cummins® electronic control module (ECM). A specific calibration is then created to recognize this pressure or temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate can be associated with this fault code.

Component Location

The OEM pressure or temperature sensor input will vary, depending on application. Refer to the OEM troubleshooting and repair manual for sensor location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine protection limit for the OEM input device has been exceeded.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Engine power can be limited, depending on the specific OEM calibration.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible, depending on the OEM application.

Refer to Troubleshooting Fault Code t05-779

Last Modified: 20-Jul-2010


Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

FAULT CODE 784

Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: S145 SPN: 1590 FMI: 2/2 LAMP: None SRT: | Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect. Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
ISB, ISC, and ISL with CM2150 - Adaptive Cruise Control Circuit

Circuit Description

The adaptive cruise control unit communicates with the electronic control module (ECM) sending and receiving vehicle speed control messages through the SAE J1939 data link.

Component Location

The location of the adaptive cruise control unit will vary by original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual for specific location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from the adaptive cruise control module for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The adaptive cruise control will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault is set active if the ECM does not receive the Heartbeat message from the adaptive cruise control unit on the SAE J1939 data link.

If Adaptive Cruise Recovery is enabled, the driver can toggle the cruise enable switch from the OFF position to the ON position two times to get regular cruise control to operate and Fault Code 784 will go inactive. At the next key cycle, if the Heartbeat message is still not present, Fault Code 784 will go active.

Refer to Troubleshooting Fault Code t05-784

Last Modified: 20-Jul-2010


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below +6.2-VDC momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
ISB, ISC, and ISL with CM2150 - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the original equipment manufacturer (OEM) power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, and during the power down process (lasting 30 seconds after key OFF).

Conditions for Setting the Fault Codes

The ECM detects that primary ECM power supply dropped below 6.2-VDC while the keyswitch was in the ON position. The fault code will be active when the keyswitch is turned ON following the incomplete power down event.

Action Taken When the Fault Code is Active

  • The ECM records the fault code immediately when the diagnostic runs and fails.
  • Power down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

The ECM must see primary ECM battery voltage above +6.2-VDC when the keyswitch is turned off before the fault code will go inactive.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault is set active if the ECM battery supply voltage drops below +6.2-VDC while the keyswitch is in the ON position.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

Where the fault code is inactive, familiarize yourself with the vehicle shutdown practices used by the operator. For example, if there are controls inside the cab that can interrupt the (ECM) power supply (before the end of the 30 second power down process after key OFF), these should be considered as a potential cause when the fault code is being addressed. This should be explained to the operator.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active.

An active Fault Code 1117 can prevent critical aftertreatment soot load information from being saved to permanent memory in the ECM. The use of battery disconnect switches to turn the engine off or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. Donot operate the vehicle with an active Fault Code 1117.

Refer to Troubleshooting Fault Code t05-1117

Last Modified: 20-Jul-2010


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
ISB, ISC, and ISL with CM2150 - Accelerator Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than 2.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5 volt supply.
  • Open accelerator pedal return circuit in the harness or connections.
  • Accelerator supply shorted to battery.
  • Failed accelerator pedal position sensor.

Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-1239

Last Modified: 20-Jul-2010


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: None SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
ISB, ISC, and ISL - Accelerator or Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2. When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is less than 0.35-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Malfunctioning accelerator pedal position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-1241

Last Modified: 20-Jul-2010


Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P091 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect. Accelerator position sensor number 1 and number 2 are reading different values. | The engine will only idle.
ISB, ISC, and ISL with CM2150 - Accelerator Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the readings between accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.

Possible causes of the fault include:

  • Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2.
  • Damaged accelerator pedal position sensor number 1 and damaged accelerator pedal position sensor number 2 signal wires are shorted together.
Refer to Troubleshooting Fault Code t05-1242

Last Modified: 20-Jul-2010


Catalyst Inlet Temperature Sensor Swapped with Outlet - Condition Exists

FAULT CODE 1663

Catalyst Inlet Temperature Sensor Swapped with Outlet - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1663 PID: None SPN: 3241 FMI: 11/31 LAMP: Amber SRT: | Catalyst Inlet Temperature Sensor Swapped with Outlet - Condition Exists. The inlet and outlet catalyst temperature sensor connections are swapped. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment catalyst and aftertreatment particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment particulate filter. These sensors monitor the temperatures in the aftertreatment system and determine if the aftertreatment catalyst is missing.

Component Location

The aftertreatment temperature sensors are located in the aftertreatment system. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for specific exhaust gas temperature sensor locations.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment system is actively regenerating the aftertreatment diesel particulate filter. The diagnostic also runs during engine warm-up.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects the aftertreatment diesel oxidation catalyst inlet temperature reading is higher than the aftertreatment diesel particulate filter inlet temperature during an active regeneration event of the diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The fault code will be set inactive following a key cycle if the fault was triggered during a regeneration event. If the fault code is active at key ON, allow the after-treatment temperatures to cool below 49°C [120°F] and then start and run the engine at high idle for 10 minutes to clear the fault code.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is activated when the ECM determines that the temperature reading from the aftertreatment diesel oxidation catalyst inlet temperature sensor and the aftertreatment diesel particulate filter inlet temperature sensor are reading backwards. The most likely cause of this fault code is that the aftertreatment diesel oxidation catalyst inlet temperature sensor and the aftertreatment diesel particulate filter inlet temperature sensor connectors are swapped at the OEM harness.

The diesel oxidation catalyst inlet temperature sensor and the diesel particulate filter outlet temperature sensor are the same part number and have the same electrical connections. The diesel particulate filter inlet temperature sensor has a different connector key to prevent it from being swapped with the other temperature sensors. Verify that the aftertreatment temperature sensors are correctly installed.

An in-range failure of the aftertreatment diesel oxidation catalyst or the aftertreatment diesel particulate filter inlet temperature can cause this fault code. Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.

Refer to Troubleshooting Fault Code t05-1663.

Last Modified: 16-Jul-2012


Catalyst Missing - Condition Exists

FAULT CODE 1664

Catalyst Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1664 PID: None SPN: 3050 FMI: 11/31 LAMP: Amber SRT: | Catalyst Missing - Condition Exists. The aftertreatment catalyst in the exhaust system is not present. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment catalyst and the aftertreatment particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment particulate filter. These sensors monitor the temperatures in the aftertreatment system and determine if the aftertreatment catalyst is missing.

Component Location

The aftertreatment catalyst is located in the exhaust system. The location of the catalyst can vary depending on the original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment system is being actively regenerated to reduce soot in the aftertreatment diesel particulate filter. The diagnostic checks for a temperature increase across the catalyst during an active regeneration of the aftertreatment system to detect the presence of the catalyst.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor and the aftertreatment diesel particulate filter inlet temperature sensor are reading the same temperature during an active regeneration of the aftertreatment system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment system will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes, or at the next key-on.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code becomes active when the aftertreatment diesel oxidation catalyst inlet and aftertreatment diesel particulate filter inlet temperature sensors do not detect the presence of a catalyst in the aftertreatment system.

Possible causes of this fault code include:

  • Tampering with the catalyst system
  • Removing the catalyst system from the vehicle
  • A damaged catalyst.
Refer to Troubleshooting Fault Code t05-1664

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1665

Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1665 PID: None SPN: 3241 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the catalyst inlet sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst inlet temperature sensor is located in the aftertreatment system. It is located at the inlet of the aftertreatment catalyst. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage is less than 0.1-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst inlet temperature sensor reading is used.
  • Active regeneration of the aftertreatment diesel particulate filter is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment diesel oxidation catalyst inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return wire can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-1665

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1666

Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1666 PID: None SPN: 3241 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst inlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL with CM2150 - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst inlet temperature sensor is located in the aftertreatment system. It is located at the inlet of the aftertreatment catalyst. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature signal voltage is greater than 4.97-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst inlet temperature reading is used.
  • Active regeneration of the aftertreatment diesel particulate filter is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment diesel oxidation catalyst inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return wire can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-1666

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1667

Aftertreatment Exhaust Gas Temperature 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1667 PID: None SPN: 3241 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel oxidation catalyst inlet temperature sensor is not changing with engine operating conditions. | Active aftertreatment diesel particulate filter regeneration will be disabled.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value. When the exhaust temperature is low, the thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage (low temperature). When the exhaust gas temperature is high, the thermistor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage (high temperature).

Component Location

The aftertreatment diesel oxidation catalyst inlet temperature sensor is located in the aftertreatment system. It is located at the inlet of the diesel oxidation catalyst. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and fuel injection into the aftertreatment system is not occurring.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst inlet temperature reading is used.
  • Active regeneration of the aftertreatment diesel particulate filter is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady-state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady-state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicator lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Reference the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section19.

The aftertreatment sensors share a common ground wire with the coolant level sensor. Fault codes or problems related to the coolant level sensor and its ground circuit could potentially cause this fault.

Possible causes of this fault code include:

  • Coolant level sensor and/or coolant level sensor ground circuit fault codes or related problems
  • Stuck in-range aftertreatment diesel oxidation catalyst inlet temperature sensor
  • High resistance in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL or RETURN wires.
  • Miswired OEM harness
  • Face plugged or damaged aftertreatment diesel oxidation catalyst.
Refer to Troubleshooting Fault Code t05-1667.

Last Modified: 21-Nov-2014


Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1674

Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1674 PID: None SPN: 3249 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel particulate filter inlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL with CM2150 - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor or thermistor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst and before the aftertreatment particulate filter. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter inlet temperature signal voltage is less than 0.1-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter inlet temperature reading is used.
  • Active regeneration of the aftertreatment diesel particulate filter is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment diesel particulate filter inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-1674

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1675

Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1675 PID: None SPN: 3249 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel particulate filter inlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL with CM2150 - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst and before the aftertreatment particulate filter. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter inlet temperature signal voltage is greater than 4.97-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the aftertreatment diesel particulate filter inlet temperature reading.
  • Active regeneration of the aftertreatment diesel particulate filter is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The catalyst inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-1675

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1676

Aftertreatment Exhaust Gas Temperature 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1676 PID: None SPN: 3249 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter inlet temperature sensor is not changing with engine operating conditions. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL with CM2150 - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst and before the aftertreatment particulate filter. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and fuel injection into the aftertreatment system is not occurring.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter inlet temperature sensor reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter inlet temperature reading is used.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady-state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady-state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicator lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter inlet temperature sensor
  • High resistance in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL or RETURN wires.
Refer to Troubleshooting Fault Code t05-1676.

Last Modified: 21-Nov-2014


Catalyst Efficiency - Out of Calibration

FAULT CODE 1691

Catalyst Efficiency - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1691 PID: None SPN: 3250 FMI: 13/13 LAMP: Amber SRT: | Catalyst Efficiency - Out of Calibration. The temperature increase across the aftertreatment diesel oxidation catalyst is lower than expected. | None on performance. Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL - Aftertreatment System

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst (DOC) inlet temperature sensor is located after the turbocharger outlet at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

Active regeneration of the aftertreatment diesel particulate filter must be occurring before the diagnostic will run.

Conditions for Setting the Fault Codes

The electronic control module (ECM) has calculated DOC efficiency to be less than required to successfully complete a regeneration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Perform INSITE™ electronic service tool Aftertreatment Reset procedure.
  • Perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • This fault code also clears following a key cycle.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the conversion efficiency of the DOC is calculated to be less than that required to perform an effective regeneration.

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment diesel oxidation catalyst
  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst
  • A cracked or contaminated aftertreatment diesel oxidation catalyst
  • A leaking exhaust system between the turbocharger and the diesel oxidation catalyst.
  • Excessive automatic/stationary regenerations causing soot plugging on the front face of the aftertreatment diesel oxidation catalyst.

An in-range malfunction of the aftertreatment diesel oxidation catalyst temperature sensor or the aftertreatment diesel particulate filter inlet temperature sensor can cause this fault code. Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.

Refer to Troubleshooting Fault Code t05-1691

Last Modified: 08-Jul-2011


Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 5 circuit in the OEM harness. | Severe derate in power output of the engine. Limp home power only.
ISB, ISC, and ISL with CM2150 - Sensor Supply 5

Circuit Description

The sensor supply 5 of the electronic control module (ECM) provides a 5 volt supply for the aftertreatment diesel particulate filter differential pressure sensor, remote accelerator, tachograph speed sensor, engine coolant level sensor, and the accelerator position sensor 2. The remote accelerator and tachograph speed sensor are optional original equipment manufacturer (OEM) components.

Component Location

Sensor supply number 5 is located in the ECM OEM harness connector and provides a 5 volt supply to various components in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 5 signal voltage is greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for aftertreatment diesel particulate filter differential pressure is used.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.
  • The engine will have limp home throttle control only.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

High voltage on the 5 volt supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-1695

Last Modified: 20-Jul-2010


Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the OEM harness. | Severe derate in power output of the engine. Limp home power only.
ISB, ISC, and ISL with CM2150 - Sensor Supply 5

Circuit Description

The sensor supply 5 of the electronic control module (ECM) provides a 5 volt supply for the aftertreatment diesel particulate filter differential pressure sensor, remote accelerator, tachograph speed sensor, engine coolant level sensor, and the accelerator position sensor 2. The remote accelerator and tachograph speed sensor are optional original equipment manufacturer (OEM) components.

Component Location

Sensor supply number 5 is located in the ECM OEM harness connector and provides a 5 volt supply to various components in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 5 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.
  • The engine has limp home throttle control only.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on Quickserve™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Low voltage on the 5-volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-1696

Last Modified: 20-Jul-2010


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure circuit. | No engine protection for high crankcase pressure.
ISB, ISC, and ISL with CM2150 - Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor monitors the pressure inside the crankcase gas filter assembly. If the pressure inside the crankcase filter assembly reaches a maximum level, a fault code will be logged, indicating that maintenance is required on the crankcase filter.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the crankcase pressure signal voltage is greater than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1843

Last Modified: 20-Jul-2010


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the crankcase pressure circuit. | No engine protection for high crankcase pressure.
ISB, ISC, and ISL with CM2150 - Crankcase Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the crankcase pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankcase pressure sensor provides a signal to the ECM on the crankcase pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the crankcase filter.

Component Location

The crankcase pressure sensor is located in the rocker lever cover . Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure signal voltage is less than 0.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-1844

Last Modified: 22-Jun-2015


Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1866

Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1866 PID: P411 SPN: 411 FMI: 2/2 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect. An error in the EGR delta pressure signal was detected at initial key-on or the sensor failed the autozero test. | EGR valve actuation will be disabled.
ISB, ISC, and ISL with CM2150 - Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure in the EGR crossover tube.

The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The sensor is located near the air intake. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs at key-off when the following conditions are met:

  • Engine coolant temperature is 67°C [154°F] or higher.
  • Intake manifold air temperature is -17°C [0°F] or higher.
  • Keyswitch transitions from ON to OFF.

Conditions for Setting the Fault Codes

The fault code is set active when the EGR differential pressure sensor is reading higher or lower than a calibratible value when the keyswitch is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light at key on when the diagnostic runs and fails.
  • The EGR valve actuation is disabled.

Conditions for Clearing the Fault Code

  • The engine coolant temperature is 67°C [154°F] or higher.
  • The intake manifold air temperature is -17°C [0°F] or higher.
  • The keyswitch transitions from ON to OFF.
  • The reading of the EGR differential pressure must be within the calibratible limits.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on Quickserve™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This check is only performed at keyswitch OFF, during the ECM powerdown. During this diagnostic check, the ECM monitors the value of the EGR differential pressure sensor. If this value is outside of a specified range, Fault Code 1866 is set active.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor
  • High resistance in the wiring harness on the signal or return wire
  • Plugged or restricted EGR differential pressure sensor flow ports.
Refer to Troubleshooting Fault Code t05-1866

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1876

Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1876 PID: None SPN: 3245 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL with CM2150 - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 VDC reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor or thermistor resistance is low. The signal pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel particulate filter. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet temperature signal voltage is greater than 4.97-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter outlet temperature reading is used.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment diesel particulate filter outlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-1876

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1877

Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1877 PID: None SPN: 3245 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL with CM2150 - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet temperature signal voltage is less than 0.1-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas temperature 2 reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment diesel particulate filter outlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-1877

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 3 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1878

Aftertreatment Exhaust Gas Temperature 3 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1878 PID: None SPN: 3245 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 3 - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter outlet temperature sensor is not changing with engine operating conditions. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL with CM2150 - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel particulate filter. See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and fuel injection into the aftertreatment system is not occurring.

Conditions for Setting the Fault Codes

  • The ECM detects that the aftertreatment diesel particulate filter outlet temperature sensor reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter outlet temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady-state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer Test, utilize a routine that incorporates acceleration and motoring events, steady-state highway operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the malfunction indicactor lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter outlet temperature sensor
  • High resistance in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL or RETURN wires.
Refer to Troubleshooting Fault Code t05-1878.

Last Modified: 21-Nov-2014


Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1879

Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1879 PID: S324 SPN: 3251 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment differential pressure sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC and ISL with CM2150 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is located in the aftertreatment system. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for exact location of the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter differential pressure signal voltage is greater than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1879

Last Modified: 20-Jul-2010


Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1881

Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1881 PID: S324 SPN: 3251 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the aftertreatment differential pressure sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL with CM2150 - Aftertreatment Differential Pressure

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is located in the aftertreatment system. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for exact location of the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter differential pressure signal voltage is less than 0.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the aftertreatment diesel particulate filter differential pressure is used.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-1881

Last Modified: 20-Jul-2010


Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1883

Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1883 PID: S324 SPN: 3251 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value at initial key-ON or during engine operation. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL with CM2150 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor

Circuit Description

The ECM provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is located in the aftertreatment system. Refer to the OEM service manual for the exact location of the aftertreatment system.

Conditions for Running the Diagnostics

  • This diagnostic runs when the keyswitch is initially turned ON.
  • The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The diagnostic runs immediately after a startup delay has elapsed. The fault code is logged at key ON if the absolute value of the differential pressure is higher than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the aftertreatment diesel particulate filter differential pressure reading.
  • Aftertreatment regeneration will be disabled.

Conditions for Clearing the Fault Code

To validate the repair, perform a key cycle and leave the key in the ON position for 1 minute. Start the engine and operate to high idle for 1 minute. It is necessary to elevate the exhaust flow for at least 30 seconds to clear this fault code. For certain applications, it may be necessary to drive the vehicle in order to achieve adequate exhaust flow for clearing the fault code.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires
  • Plugged aftertreatment differential pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned off.
Refer to Troubleshooting Fault Code t05-1883

Last Modified: 06-Aug-2010


EGR Valve Controller - Out of Calibration

FAULT CODE 1896

EGR Valve Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1896 PID: S146 SPN: 2791 FMI: 13/13 LAMP: Amber SRT: | EGR Valve Controller - Out of Calibration. The EGR valve has failed the automatic calibration procedure at initial key-on. | EGR valve actuation will be disabled.
ISB, ISC, and ISL - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor is not used to close the EGR valve. The pin retracts and a spring is used to close the EGR valve.

Component Location

The EGR valve location can vary, depending on the engine application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The EGR valve motor measures the position of the EGR valve at initial key-on. If the valve is detected to be greater than 20 percent open, the fault code is set active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will stop responding to commands and the spring will close the EGR valve.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and clear the fault code after the keyswitch is cycled and the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

When the keyswitch is initially turned on and at various times during engine operation, the closed position of the EGR valve is checked. This diagnostic checks to make sure the EGR valve is not stuck open.

This fault code is logged when the following error conditions exist:

  • The EGR valve motor measures the position of the EGR valve at initial key-on. If the valve is detected to be out of the normal position, this fault code will be logged.
  • The EGR valve will close when the fault code is active.
  • The fault code will remain active until the next key cycle.

The fault code will only go inactive if the initial key-on EGR position check passes.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap-Acceleration Test to check for a malfunctioning diesel particulate filter.

  • Refer to Procedure For ISB engines, 014-013 (Aftertreatment Testing) in Section 14 in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578, for aftertreatment reuse guidelines.
  • Refer to Procedure For the ISC and ISL engines, 014-013 ( Aftertreatment Testing) in Section 14 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569, for aftertreatment reuse guidelines.
Refer to Troubleshooting Fault Code t05-1896

Last Modified: 20-Jul-2010


Exhaust Gas Recirculation Valve Delta Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1899

Exhaust Gas Recirculation Valve Delta Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1899 PID: P411 SPN: 411 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The EGR differential pressure sensor has detected low EGR gas flow or the EGR differential pressure reading is not valid for engine operating conditions. | Exhaust gas recirculation (EGR) valve actuation will be disabled.
ISB, ISC, and ISL - Differential Pressure Sensor

Circuit Description

The EGR differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure in the EGR crossover tube.

The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The sensor is located near the air intake. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the following conditions are met:

  • EGR valve position is greater than 5 percent open
  • Engine speed is greater than a calibratible value
  • Engine torque output is greater than a calibratible value.

Conditions for Setting the Fault Codes

  • EGR differential pressure is less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This diagnostic checks the EGR differential pressure sensor reading when the EGR valve is open. Since the EGR valve is open, the reading of the EGR differential pressure must be greater than zero. If the ECM detects a reading lower than expected with the EGR valve open, this fault code is logged.

Possible causes of this fault code include:

  • A malfunctioning EGR differential pressure sensor
  • A stuck closed EGR valve
  • EGR differential pressure sensor flow port cross-drillings are plugged with soot or shellac
  • A fouled EGR cooler.
Refer to Troubleshooting Fault Code t05-1899.

Last Modified: 14-Oct-2015


Fault Code Path Selection

FAULT CODE 08-fc1911
Fault Code Path Selection

Is the engine an ISB or QSB3.3 engine? | Go to 08-fc1911b
Is the engine an ISC or ISL engine? | Go to 08-fc1911cl

Last Modified: 26-Feb-2007


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1921

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1921 PID: S324 SPN: 3251 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | The check engine light will illuminate. The aftertreatment diesel particulate filter lamp will flash. Engine protection derate.
ISB, ISC, and ISL - Aftertreatment System

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code can be triggered if the application is not operating at a duty cycle high enough to actively regenerate the aftertreatment diesel particulate filter. This fault code indicates that the exhaust temperatures exiting the turbocharger are not high enough to actively regenerate the soot that is trapped in the aftertreatment diesel particulate filter. It can be necessary to increase the duty cycle of the application in order to prevent plugging of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic operates continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the soot load of the aftertreatment diesel particulate filter is above normal - moderately severe. The aftertreatment system needs to be regenerated to remove the soot.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light immediately after the diagnostic fails.
  • The ECM will flash the aftertreatment diesel particulate filter lamp immediately after the diagnostic fails.
  • Mobile active regeneration of the diesel particulate filter will be disabled (stationary regeneration will still be available).
  • A moderate torque derate will be applied to the output of the engine (Note: There is no derate in emergency vehicle calibrations.)
  • Engine speed will be limited to 1800 rpm (ISB CM2150 engines) or 1500 rpm (ISC and ISL CM2150 engines) (Note: There is no derate in emergency vehicle calibrations.)

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the soot load in the aftertreatment diesel particulate filter has dropped below the moderately severe level.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Note: This fault code indicates that the aftertreatment diesel particulate filter requires maintenance by performing a stationary regeneration procedure. This is a maintenance procedure only and is not covered by Cummins Inc. warranty.

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment diesel particulate filter.
  • Possible engine failure that causes excessive black soot to be generated.
  • If Fault Code 2777 is active along with Fault Code 1921, this indicates that a regeneration inhibit message has been received by the engine ECM and that active regeneration of the aftertreatment diesel particulate filter was not permitted. Confirm that the OEM settings for the aftertreatment permit switch are configured correctly.
  • The aftertreatment diesel particulate filter can accumulate an excessive amount of ash in a short time period, due to excessive oil consumption or due to non-combustible elements such as, but not limited to, iron, potassium, or calcium contained in the fuel supply or additives.

The aftertreatment diesel particulate filter soot loading can be classified into four different stages. As the soot load increases, the aftertreatment diesel particulate filter lamp and the Cummins® CHECK ENGINE (Amber) or STOP ENGINE (Red) lamp will operate according to the table below. Inadequate temperature of the exhaust gases entering the aftertreatment system can be a cause of high soot loads in the aftertreatment diesel particulate filter. The duty cycle of the application will need to be increased in order to prevent excessive soot from accumulating in the filter.

Soot Level Stage | Cummins® Fault Code | Aftertreatment Diesel Particulate Filter Lamp Status | Cummins® Lamp Status | Service Procedure | Engine Protection Strategy
1 | 2639 | Continuous ON | OFF | Perform stationary regeneration procedure. | No engine protection derate.
2 | 2639 | Flashing | OFF | Perform stationary regeneration procedure. | Mild engine torque derate.
3 | 1921 | Flashing | Amber | Perform stationary regeneration procedure. | Moderate engine torque and engine speed derate.
4 | 1922 | OFF | Red | Inspect, clean, or replace the aftertreatment diesel particulate filter. | Severe engine torque and engine speed derate.
Refer to Troubleshooting Fault Code t05-1921.

Last Modified: 15-Aug-2011


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1922

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1922 PID: S324 SPN: 3251 FMI: 0/0 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | The stop engine light will illuminate. Engine protection derate.
ISB, ISC, and ISL - Aftertreatment System

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code can be triggered if the application is not operating at a duty cycle that is high enough to actively regenerate the aftertreatment diesel particulate filter. This fault code indicates that the exhaust temperatures exiting the turbocharger are not high enough to actively regenerate the soot that is trapped in the aftertreatment diesel particulate filter. It can be necessary to increase the duty cycle of the application in order to prevent plugging of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system, and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the soot load of the aftertreatment diesel particulate filter has exceeded the maximum operating limits.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the red STOP ENGINE light immediately after the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • A severe torque derate will be applied to the output of the engine (Note: There is no derate in emergency vehicle calibrations).
  • Engine speed will be limited to 1800 rpm (ISB CM2150 engines) or 1500 rpm (ISC and ISL CM2150 engines). (Note: There is no derate in emergency vehicle calibrations).

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the soot load in the aftertreatment diesel particulate filter has dropped below the most severe level.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Maintenance Reset Test to change Fault Code 1922 to an inactive state after inspecting, cleaning, or replacing the aftertreatment diesel particulate filter.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code indicates that the soot load inside the aftertreatment diesel particulate filter has reached the maximum level, soot level stage 4. Regeneration of the aftertreatment diesel particulate filter at this stage is not possible. The aftertreatment diesel particulate filter must be inspected. If it meets the inspection criteria, it can be cleaned using an SPX air pulse, or equivalent, cleaning machine. If it does not meet the inspection criteria, it must be replaced.

If Fault Code 1922 is active at the same time as Fault Code 1981, it is necessary to clear Fault Code 1981 by following the troubleshooting tree for that fault, then referencing the steps for troubleshooting and clearing Fault Code 1922, below.

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The aftertreatment wiring harness connectors may be connected to the wrong aftertreatment temperature sensors.
  • The aftertreatment wiring harness or aftertreatment temperature sensor connector pin installation may be incorrect.
  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment diesel particulate filter.
  • A possible base engine malfunction that causes excessive black soot to be generated.
  • If both Fault Code 1921 and 2777 are inactive with an active Fault Code 1922, this indicates that a regeneration inhibit message had been received by the engine ECM and that active regeneration of the aftertreatment diesel particulate filter was not allowed. Use the OEM service information to confirm that the OEM settings for the aftertreatment permit switch are configured correctly.

The aftertreatment diesel particulate filter soot loading can be classified into four different stages. As the soot load increases, the aftertreatment diesel particulate filter lamp and the Cummins® CHECK ENGINE (Amber) or STOP ENGINE (Red) lamp will operate according to the table below. Inadequate temperature for the exhaust gases entering the aftertreatment system can be a cause of high soot loads in the aftertreatment diesel particulate filter. The duty cycle of the application may need to be increased in order to prevent excessive soot from accumulating in the filter.

Soot Level Stage | Cummins® Fault Code | Aftertreatment Diesel Particulate Filter Lamp Status | Cummins® Lamp Status | Service Procedure | Engine Protection Strategy
1 | 2639 | Continuous ON | OFF | Perform stationary regeneration procedure. | No engine protection derate.
2 | 2639 | Flashing | OFF | Perform stationary regeneration procedure. | Mild engine torque derate.
3 | 1921 | Flashing | Amber | Perform stationary regeneration procedure. | Moderate engine torque and engine speed derate.
4 | 1922 | OFF | Red | Inspect, clean, or replace the aftertreatment diesel particulate filter. | Severe engine torque and engine speed derate.
Refer to Troubleshooting Fault Code t05-1922.

Last Modified: 15-Aug-2011


ECU Power Output Supply Voltage 1 - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 1938

ECU Power Output Supply Voltage 1 - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1938 PID: SPN: 3597 FMI: 1/18 LAMP: Amber SRT: | ECU Power Output Supply Voltage 1 - Data Valid but Below Normal Operational Range - Moderately Severe Level. Low battery voltage detected by the VGT actuator. | None on performance.
ISB, ISC, and ISL with CM2150 - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 datalink from the primary engine ECM. The VGT actuator performs its own diagnostics and reports failures back to the primary engine electronic control module (ECM) using the J1939 datalink.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fault code is set when the voltage supplied to the VGT actuator drops below +10-VDC for 10 seconds and the engine speed must be zero rpm or above 500 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The VGT actuation will continue until battery voltage drops low enough that VGT actuation can not continue.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the voltage to the VGT actuator is greater than +10-VDC and the engine speed is zero or greater than 500 rpm.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the voltage to the VGT actuator drops below +10-VDC. The VGT will still continue to respond to commands from the primary engine ECM.

Refer to Troubleshooting Fault Code t05-1938

Last Modified: 20-Jul-2010


Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1942

Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1942 PID: P101 SPN: 101 FMI: 2 LAMP: Amber SRT: | Crankcase Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the crankcase pressure signal is not changing with engine operating conditions. | None on performance.
ISB, ISC, ISL CM2150 - Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The electronic control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

Use the following procedure for a detailed component location view of the crankcase pressure sensor and crankcase filter. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

The first part of this diagnostic runs at initial key ON and the second part runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure sensor is reading an erratic value at key ON or the crankcase pressure reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code can be caused by a crankcase breather hose disconnected between the engine outlet and the crankcase filter assembly on engines with an externally mounted crankcase filter option.

This check is only performed at keyswitch OFF, during the ECM powerdown. During this diagnostic check, the ECM monitors the value of the crankcase pressure sensor. If this value is outside of a specified range, Fault Code 1942 is set active at the next key ON.

Possible causes of this fault code include:

  • Resistance in the wiring harness
  • A malfunctioning in-range pressure sensor.

This fault code can be triggered if the crankcase pressure sensor is not installed correctly in the housing.

Refer to Troubleshooting Fault Code t05-1942

Last Modified: 20-Jul-2010


Ambient Air Density - Data Valid but Below Normal Operational Range - Least Severe Level

FAULT CODE 1943

Ambient Air Density - Data Valid but Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1943 PID: SPN: 3555 FMI: 1/17 LAMP: None SRT: | Ambient Air Density - Data Valid but Below Normal Operational Range - Least Severe Level. Engine torque has been reduced because the vehicle was operating at a high altitude condition. | Possible engine derate.
ISB, ISC, and ISL - Barometric Pressure Circuit

Circuit Description

The ambient air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is currently operating. The ambient air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 volt supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure reading is lower than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Engine torque output will be limited due to the engine operating at high altitude conditions.

Conditions for Clearing the Fault Code

The ECM will return full torque to the engine and the fault code will go inactive when the vehicle is being operated within the normal altitude conditions.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

When the engine has been operated in a high altitude location, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating in the high altitude location to protect the turbocharger and engine from excessively high exhaust temperatures. The derate limits the torque output of the engine to keep the temperatures below the maximum temperature limits.

Note: This fault code will most likely not be active with no load in the shop. The engine must be under the same operating condition (altitude and temperature) at the time that it had originally logged.

Refer to Troubleshooting Fault Code t05-1943

Last Modified: 20-Jul-2010


VGT Actuator Driver Over Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 1962

VGT Actuator Driver Over Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1962 PID: S027 SPN: 641 FMI: 0/15 LAMP: Amber SRT: | VGT Actuator Driver Over Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level. High Internal VGT actuator temperature has been detected. | None on performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 datalink from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports failures back to the primary engine ECM using the J1939 datalink.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is turned on.

Conditions for Setting the Fault Codes

The fault code will log when the internal temperature of the VGT actuator exceeds 125°C [257°F] continuously for 30 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the internal actuator temperature drops below 125°C [257°F].

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code will log when the internal temperature of the VGT actuator exceeds 125°C [257°F].

This fault code will be inactive when the vehicle is in the shop because the VGT actuator temperature has cooled down.

Troubleshoot multiple inactive counts of this fault code as an active fault code.

Also check for exhaust leaks blowing on the VGT actuator. Repair any external leaks.

Refer to Troubleshooting Fault Code t05-1962

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1966

Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1966 PID: 326 SPN: 3241 FMI: 0 LAMP: Red SRT: | Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level. Engine exhaust gas temperatures entering the aftertreatment system are above the engine protection limits. | The engine will shut down.
ISB, ISC, and ISL - Aftertreatment Exhaust Gas Temperature Sensors

Circuit Description

The aftertreatment exhaust gas temperature sensors are used by the electronic control module (ECM) to monitor the exhaust temperatures in the aftertreatment system. The aftertreatment exhaust gas temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst inlet temperature sensor is located in the inlet section of the aftertreatment system.

The aftertreatment diesel particulate filter inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel oxidation catalyst and before the aftertreatment diesel particulate filter.

The aftertreatment diesel particulate filter temperature outlet sensor is located in the outlet section of the aftertreatment system.

Refer to the OEM service manual for the location of the vehicle aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The ECM detects one of the following:

  • The aftertreatment diesel oxidation catalyst inlet temperature is greater than 617°C [1143°F] for 65 seconds.
  • The aftertreatment diesel particulate filter inlet temperature is greater than 612°C [1134°F] for 100 seconds.
  • The aftertreatment diesel particulate filter outlet temperature is greater than 617°C [1143°F] for 145 seconds.
  • The temperature differential across the aftertreatment diesel oxidation catalyst is greater than 220°C [396°F] for 55 seconds.
  • The temperature differential across the aftertreatment diesel particulate filter is greater than 265°C [477°F] for 140 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Active and stationary (parked) regeneration will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine shutdown will occur 30 seconds after the fault becomes active. In all calibrations except for emergency vehicle calibrations, engine shutdown will occur after 30 seconds if engine protection shutdown is enabled or disabled. Engine shutdown will not occur in emergency vehicle calibrations.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE lamp and the fault code will be set to inactive when the temperatures in the aftertreatment system drop below the temperature values listed:

  • The aftertreatment diesel oxidation catalyst inlet temperature is less than 592°C [1098°F].
  • The aftertreatment diesel particulate filter inlet temperature is less than 587°C [1089°F].
  • The aftertreatment diesel particulate filter outlet temperature is less than 592°C [1098°F].
  • The temperature differential across the aftertreatment diesel oxidation catalyst is less than 195°C [351°F].
  • The temperature differential across the aftertreatment diesel particulate filter is less than 240°C [432°F].

The fault code will also be set inactive following a key cycle.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is not occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel oxidation catalyst and/or aftertreatment diesel particulate filter.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • The aftertreatment diesel oxidation catalyst inlet temperature sensor failed in-range
  • The aftertreatment diesel particulate filter inlet temperature sensor failed in-range
  • The aftertreatment diesel particulate filter outlet temperature sensor failed in-range
  • An in-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14. For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code t05-1966

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 1968

Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1968 PID: SPN: 3249 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Moderately Severe Level. The aftertreatment diesel particulate filter inlet temperature sensor reading has exceeded the maximum temperature limit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL - Aftertreatment Exhaust Gas Temperature Sensors

Circuit Description

The aftertreatment exhaust gas temperature sensors are used by the electronic control module (ECM) to monitor the exhaust temperatures in the aftertreatment system. The aftertreatment exhaust gas temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel oxidation catalyst and before the aftertreatment diesel particulate filter.

Refer to the OEM service manual for the location of the vehicle aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter inlet temperature sensor reading exceeds 649°C [1200°F] for 5 seconds and then returns below 550°C [1022°F]. This must occur 5 times before the fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active and stationary (parked) regeneration will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp and the fault code will be set to inactive when the keyswitch is cycled.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel oxidation catalyst and/or aftertreatment diesel particulate filter.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • The aftertreatment diesel particulate filter inlet temperature sensor failed in-range
  • An in-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14. For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code t05-1968

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 1969

Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1969 PID: SPN: 3249 FMI: 0/0 LAMP: Red SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Most Severe Level. The aftertreatment diesel particulate filter inlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | The engine will shut down.
ISB, ISC, and ISL - Aftertreatment Exhaust Gas Temperature Sensors

Circuit Description

The aftertreatment exhaust gas temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment exhaust gas temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel oxidation catalyst and before the aftertreatment diesel particulate filter.

The aftertreatment diesel particulate filter outlet temperature sensor is located in the outlet section of the aftertreatment system.

Refer to the OEM service manual for the location of the vehicle aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The ECM detects one of the following:

  • The aftertreatment diesel particulate filter inlet temperature is greater than 800°C [1472°F] for 15 seconds.
  • The temperature differential across the aftertreatment diesel oxidation catalyst is greater than 500°C [900°F] for 120 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Active and stationary (parked) regeneration will be disabled
  • Exhaust gas recirculation (EGR) valve operation will be disabled
  • Engine shutdown will occur 30 seconds after the fault becomes active. In all calibrations except for emergency vehicle calibrations, engine shutdown will occur after 30 seconds if engine protection shutdown is enabled or disabled. Engine shutdown will not occur in emergency vehicle calibrations.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE lamp and the fault code will be set to inactive when the temperatures in the aftertreatment system drop below the temperature values listed:

  • The aftertreatment diesel particulate filter inlet temperature is less than 775°C [1427°F].
  • The temperature differential across the aftertreatment diesel oxidation catalyst is less than 475°C [855°F].

The fault code will also be set inactive following a key cycle.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel oxidation catalyst and/or aftertreatment diesel particulate filter.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • The aftertreatment diesel particulate filter inlet temperature sensor failed in-range
  • The aftertreatment diesel particulate filter outlet temperature sensor failed in-range
  • An in-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14. For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code t05-1969

Last Modified: 20-Jul-2010


Exhaust Gas Temperature 3 - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 1972

Exhaust Gas Temperature 3 - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1972 PID: SPN: 3245 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature 3 - Data Valid but Above Normal Operational Range - Moderately Severe Level. The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum temperature limit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL - Aftertreatment Exhaust Gas Temperature Sensors

Circuit Description

The aftertreatment exhaust gas temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment exhaust gas temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage (low temperature). When the exhaust gas temperature is high, the thermistor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage (high temperature).

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the outlet section of the aftertreatment system.

Refer to the OEM service manual for the location of the vehicle aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter outlet temperature sensor reading exceeds 649°C [1200°F] for 5 seconds and then returns below 575°C [1067°F]. This needs to occur 5 times before the fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active and stationary (parked) regeneration will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp and the fault code will be set to inactive when the keyswitch is cycled.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel particulate filter.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • The aftertreatment diesel particulate filter outlet temperature sensor malfunctioned in-range
  • A face plugged aftertreatment diesel oxidation catalyst
  • An in-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damaged and reuse. For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14. For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code t05-1972

Last Modified: 20-Jul-2010


Exhaust Gas Temperature 3 - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 1973

Exhaust Gas Temperature 3 - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1973 PID: SPN: 3245 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature 3 - Data Valid but Above Normal Operational Range - Most Severe Level. The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | The engine will shut down.
ISB, ISC, and ISL - Aftertreatment Gas Temperature Sensors

Circuit Description

The aftertreatment exhaust gas temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The exhaust gas aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage (low temperature). When the exhaust gas temperature is high, the thermistor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage (high temperature).

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in outlet section of the aftertreatment system.

Refer to the OEM service manual for the location of the vehicle aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate sensor outlet temperature is greater than 800°C [1472°F] for 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Active and stationary (parked) regeneration will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine shutdown will occur 30 seconds after the fault becomes active. In all calibrations except for emergency vehicle calibrations, engine shutdown will occur after 30 seconds if engine protection shutdown is enabled or disabled. Engine shutdown will not occur in emergency vehicle calibrations.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE lamp and the fault code will be set to inactive when the aftertreatment diesel particulate filter outlet temperature drops below 775°C [1427°F].

The fault code will also be set inactive following a key cycle.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel particulate filter.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • The aftertreatment diesel particulate filter outlet temperature sensor failed in-range
  • An in-range engine sensor malfunction has occurred, causing excessive fuel to enter the exhaust system.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle for potential damage and inspect for reuse.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.
Refer to Troubleshooting Fault Code t05-1973

Last Modified: 20-Jul-2010


Crankcase Pressure - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 1974

Crankcase Pressure - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1974 PID: P101 SPN: 101 FMI: 0/15 LAMP: Maintenance SRT: | Crankcase Pressure - Data Valid but Above Normal Operational Range - Least Severe Level. The crankcase breather filter requires maintenance. | None on performance.
ISB, ISC, and ISL with CM2150 - Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The electronic control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly. The crankcase filter is located on the left side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure is greater than a calibratible limit.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light for 30 seconds at initial key-on when the crankcase pressure has been detected to be above 20 cm H2O [8 in H2O].

Conditions for Clearing the Fault Code

The ECM will turn off the flashing amber CHECK ENGINE light as soon as the crankcase pressure drops below 20 cm H2O [8 in H2O].

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced.
Refer to Troubleshooting Fault Code t05-1974

Last Modified: 20-Jul-2010


Aftertreatment Particulate Filter Differential Pressure - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 1981

Aftertreatment Particulate Filter Differential Pressure - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1981 PID: S324 SPN: 3936 FMI: 0/15 LAMP: Amber SRT: | Aftertreatment Particulate Filter Differential Pressure - Data Valid but Above Normal Operational Range - Least Severe Level. The aftertreatment differential pressure has exceeded the maximum operating limits or the diesel particulate filter is plugged. | EGR valve operation will be disabled. Active regeneration will be disabled.
ISB, ISC, and ISL - Aftertreatment Differential Pressure

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual for component location information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm and when the calculated exhaust flow is above a calibratible value.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the aftertreatment diesel particulate filter is plugged or that the differential pressure across the aftertreatment diesel particulate filter is above the maximum limits.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light after the diagnostic runs and fails.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.
  • Active and stationary (parked) regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light after the differential pressure across the aftertreatment diesel particulate filter has dropped below the maximum severity level, when the calculated exhaust flow is above a calibratible value.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable changes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

An engine torque derate for extended EGR valve closed operation exists for this fault code. The engine torque derate for extended EGR valve closed operation operates on a time based system. The time based system will count up anytime a fault code that closes the EGR valve is active. Once the timer reaches 20 hours, an engine torque derate of approximately 15 percent will be applied.

The engine torque derate will be removed as soon as the fault code goes inactive, and the timer will begin to count down. If the fault code reoccurs within the next 20 hours of engine operation, the engine torque derate will immediately be applied, and the timer will then reset to 20 hours. The engine must operate for 20 hours with no active faults that close the EGR valve, for the timer to clear. After the timer has cleared, the engine must then operate for another 20 hours, with an active fault code that closes the EGR valve to apply the derate.

This fault code indicates that the soot load inside the aftertreatment diesel particulate filter has reached the maximum level, soot level stage 4. Regeneration of the aftertreatment diesel particulate filter at this stage is not possible. The aftertreatment diesel particulate filter must be inspected. If it meets the inspection criteria, it can be cleaned using an SPX air pulse cleaning machine (or equivalent). If it does not meet the inspection criteria, it must be replaced.

Possible causes of this fault code include:

  • The aftertreatment diesel particulate filter can be plugged with soot.
  • The engine has been operating in light load conditions that prevent exhaust temperatures from being high enough to actively regenerate the aftertreatment particulate filter.
  • The aftertreatment wiring harness connectors could be connected to the wrong aftertreatment exhaust gas temperature sensors.
  • The aftertreatment wiring harness or aftertreatment exhaust gas temperature sensor connector pin installation could be incorrect.
  • The aftertreatment diesel particulate filter differential pressure sensor has malfunctioned.
  • The aftertreatment diesel particulate filter may have reached the ash cleaning interval.
  • The aftertreatment diesel particulate filter can accumulate an excessive amount of ash in a short time period, due to excessive oil consumption or due to non-combustible elements such as, but not limited to, iron, potassium, or calcium contained in the fuel supply or additives.
  • An engine malfunction that is elevating the engine smoke output.
Refer to Troubleshooting Fault Code t05-1981

Last Modified: 20-Jul-2010


Aftertreatment Particulate Trap Missing - Condition Exists

FAULT CODE 1993

Aftertreatment Particulate Trap Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1993 PID: SPN: 3064 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Particulate Trap Missing - Condition Exists. The aftertreatment diesel particulate filter in the exhaust system is not present. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL - Aftertreatment Differential Pressure Sensor

Circuit Description

The engine aftertreatment system monitors for the presence of the aftertreatment particulate trap. This diagnostic checks to make sure that the aftertreatment particulate trap is present and functioning correctly.

Component Location

The aftertreatment particulate trap is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

This diagnostic monitors the aftertreatment diesel particulate trap differential pressure sensor. When the differential pressure is below a minimum value and exhaust flow rate is above a minimum flow rate, the fault code is set.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

It will be necessary to run the engine at high idle to elevate the exhaust flow for this fault code to go inactive.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • The aftertreatment differential sensor can be stuck in range
  • The aftertreatment diesel particulate filter has been removed from the vehicle
  • The aftertreatment diesel particulate filter is cracked or broken
  • The aftertreatment diesel particulate filter differential tubes are installed incorrectly, broken, loose, or have been tampered with
  • The aftertreatment diesel particulate filter differential tubes are installed backwards.
Refer to Troubleshooting Fault Code t05-1993

Last Modified: 20-Jul-2010


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2182

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2182 PID: S79 SPN: 1072 FMI: 3 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage or open circuit detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1, 2, and 3 can not be activated.
ISL with CM2150 - Engine Brake Solenoid

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake depending on the application. The electronic control module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an exhaust brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 1 circuit pulse width modulated signal is detected to be greater than 0 volts when the pulse width modulated signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2182

Last Modified: 20-Jul-2010


Engine Brake Actuator Circuit 1 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Circuit 1 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: S79 SPN: 1072 FMI: 4 LAMP: Amber SRT: | Engine Brake Actuator Circuit #1 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1,2, and 3 can not be activated.
ISL with CM2150 - Engine Brake Circuit

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake depending on the application. The electronic control module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 1 circuit pulse width modulated signal is not detected to be system voltage when the pulse width modulated signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include a short circuit to ground in the engine harness, connector, or engine brake solenoids.

Refer to Troubleshooting Fault Code t05-2183

Last Modified: 20-Jul-2010


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at +5 volt sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
ISB, ISC, and ISL with CM2150 - Accelerator Pedal or Lever Position Sensor Supply

Circuit Description

Sensor supply 4 of the electronic control module (ECM) provides a 5 volt supply to the accelerator pedal position sensor. The accelerator position sensor is a hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal assembly is located in the cab. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 4 signal voltage is more than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Refer to Troubleshooting Fault Code t05-2185

Last Modified: 20-Jul-2010


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the +5 volt sensor supply circuit to the accelerator pedal position sensor. | Engine will only die.
ISB, ISC, and ISL with CM2150 - Accelerator Pedal Position Sensor Supply Voltage Circuit

Circuit Description

Sensor supply 4 of the electronic control module (ECM) provides a 5 volt supply to the accelerator pedal position sensor. The accelerator position sensor is a hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal is located in the cab. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 4 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine will only die.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a failed accelerator, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-2186

Last Modified: 20-Jul-2010


Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

FAULT CODE 2195

Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2195 PID: S51 SPN: 703 FMI: 14 LAMP: Red SRT: | Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions. The emergency door of the vehicle has been detected open. | Engine may shut down.
Auxiliary Engine Protection

Circuit Description

Some vehicle applications may have an interlock switch indicating the position of an emergency exit door.

Component Location

The emergency door location may vary depending on the vehicle application.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the vehicle emergency door is opened.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails. The engine will be shut down.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This diagnostic will operate differently for every vehicle application. This fault code usually indicates that the vehicle emergency exit door has been opened.

Refer to Troubleshooting Fault Code t05-2195

Last Modified: 20-Jul-2010


VGT Actuator Driver Circuit - Root Cause Not Known

FAULT CODE 2198

VGT Actuator Driver Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2198 PID: S027 SPN: 641 FMI: 11/11 LAMP: Amber SRT: | VGT Actuator Driver Circuit - Root Cause Not Known. Intermittent communication between the smart VGT controller and the ECM has been detected. The VGT controller is not interpreting the J1939 message from the ECM correctly. | VGT actuation will be disabled.
ISB, ISC, and ISL with CM2150 - VGT Actuator Driver Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 datalink from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports failures back to the primary engine ECM using the J1939 datalink. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The VGT actuator does not receive a valid J1939 message from the ECM for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The VGT will move to the default open position.
  • The EGR valve will be closed.
  • Active regeneration of the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the VGT actuator receives a valid J1939 message from the ECM.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the VGT smart actuator did not receive a valid J1939 message from the primary engine ECM for 1 second. Intermittent J1939 datalink connections or interference on the J1939 network are possible causes of this fault code. Also check for intermittent power supply and ground connections to the VGT actuator.

Refer to Troubleshooting Fault Code t05-2198

Last Modified: 20-Jul-2010


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: S126 SPN: 1075 FMI: 3 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source. High voltage or open detected at the fuel lift pump signal circuit. | Engine can be difficult to start.
ISC and ISL with CM2150 - Electric Fuel Lift Pump Circuit

Circuit Description

The circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The electric fuel lift pump is located behind the ECM cooling plate on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel lift pump circuit pulse width modulated signal is detected to be greater than 0-VDC when the pulse width modulated signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine fuel lift pump will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault becomes active if the ECM detects an open circuit at key-on. Causes of this fault code include an open circuit in the electric fuel lift pump circuit.

If the fault code is intermittent, look for causes of an intermittent open circuit, such as loose pins and bad connections. At key-on, the lift pump duty cycle ramps to 100 percent. This fault code can detect open circuit conditions only at key-on. The lift pump only runs at key-on and during cranking to aid in priming of the gear pump.

Refer to Troubleshooting Fault Code t05-2265

Last Modified: 20-Jul-2010


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: S126 SPN: 1075 FMI: 4 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel lift pump circuit. | Engine can be difficult to start.
ISC and ISL with CM2150 - Electric Fuel Lift Pump Circuit

Circuit Description

The circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM and runs at 100-percent duty cycle for approximately 30 seconds at key-on.

Component Location

The electric fuel lift pump is located behind the ECM cooling plate on the intake side of the engine, near the front. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel lift pump circuit pulse width modulated signal is detected to be 0-VDC when the pulse width modulated signal is turned on by the ECM and should be at system voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine fuel lift pump will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code becomes active whenever the ECM detects a short circuit to ground or high current in the electric lift pump circuit. Causes for this fault code are a short circuit to ground or low resistance (lift pump partially shorted). During cold weather, gelled fuel can plug the lift pump and cause this fault code. Listen to the lift pump to be sure it is running during cold ambient temperatures (less than -29°C [-20°F]). This fault code can possibly also become active if the lift pump rotor stalls or seizes. When the fault condition is detected, the ECM driver to the lift pump is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will retest for the cause of the fault code. The ECM driver is re-enabled at key-on. If the cause if no longer present, the fault code will become inactive and can be cleared.

Note: This fault code will also become active if the priming pump motor stalls. Stall current for the priming pump motor is approximately 9 amperes. A good priming pump typically runs with less than 3 amperes. If the fault code is intermittent, observe the snapshot data priming pump measured current. If current was near 9 amperes when the fault condition occurred, conclude that the rotor has stalled and replace the electric priming pump.

Refer to Troubleshooting Fault Code t05-2266

Last Modified: 20-Jul-2010


EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P27 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage has been detected at the EGR valve position sensor circuit. | EGR valve actuation will be disabled.
ISB, ISC, and ISL with CM2150 - EGR Valve Position Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR valve is located on the air intake connection. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that all position sensors are reading high or all position sensors are reading low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • EGR valve position sensor wiring shorted to ground, open circuit, or shorted to power supply
  • Loss of the EGR valve position sensor supply voltage or the ground circuit.
  • Fuel Injector wiring harness shorted to ground, open circuit, or shorted to power supply.
Refer to Troubleshooting Fault Code t05-2272

Last Modified: 14-Dec-2011


Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2273

Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2273 PID: P411 SPN: 411 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the EGR differential pressure sensor circuit. | EGR valve actuation will be disabled.
ISB, ISC, and ISL with CM2150 - EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust gas pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure in the EGR crossover tube.

Component Location

The EGR differential pressure sensor is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR differential pressure signal voltage is greater than 4.8-VDC for more than 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the EGR differential pressure sensor is used.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor
  • A signal wire shorted to sensor supply or battery voltage
  • A damaged EGR differential pressure sensor.
Refer to Troubleshooting Fault Code t05-2273

Last Modified: 20-Jul-2010


Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2274

Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2274 PID: P411 SPN: 411 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the EGR differential pressure sensor circuit. | EGR valve actuation will be disabled.
ISB, ISC, and ISL with CM2150 - EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust gas pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.

Component Location

The EGR differential pressure sensor is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR differential pressure signal voltage is less than 0.26-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the EGR differential pressure sensor is used.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground
  • A malfunctioning EGR differential pressure sensor.
Refer to Troubleshooting Fault Code t05-2274

Last Modified: 20-Jul-2010


Turbocharger 1 Speed - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 2288

Turbocharger 1 Speed - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2288 PID: P103 SPN: 103 FMI: 0/15 LAMP: None SRT: | Turbocharger 1 Speed - Data Valid but Above Normal Operational Range - Least Severe Level. High turbocharger speed has been detected by the ECM. | Engine power derate to lower the turbocharger speed.
ISB, ISC, and ISL with CM2150 - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is above the maximum calibratible limits.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM will reduce torque output of the engine to reduce turbocharger speeds.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

When the engine has taken the necessary action to reduce the turbocharger speed, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating near the maximum turbocharger speed limits.

Refer to Troubleshooting Fault Code t05-2288

Last Modified: 20-Jul-2010


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S018 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. Fuel pump actuator circuit resistance too high or too low. | Possible low power.
ISB, ISC, and ISL with CM2150 - Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electronic fuel control actuator. The actuator is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump based on engine operating conditions. The electronic fuel control actuator valve is a normally open valve. High circuit resistance can cause fuel pressure to be higher than commanded at light loads.

Component Location

The fuel pump actuator valve is located on the engine-mounted fuel pump housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault is set when the fuel pump actuator circuit has intermittent circuit problems.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fuel rail pressure will be higher than the commanded rail pressure.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If this fault code occurs during road test, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Fuel pump actuator high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Fuel pump actuator with low internal resistance
  • Fuel pump actuator or engine harness that has shorted to ground
  • Intermittent circuit failures that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump actuator circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty, causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump actuator circuit is not still faulty.

Refer to Troubleshooting Fault Code t05-2311

Last Modified: 20-Jul-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: None SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Crankshaft engine speed sensor intermittent synchronization. | Engine can exhibit misfire as control switches from the primary to the backup speed sensor. Engine power is reduced while the engine operates on the backup speed sensor.
ISB, ISC, and ISL with CM2150 - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position based on the missing tooth on the speed indicator ring.

Component Location

The engine crankshaft speed/position sensor is located on the side of the front gear housing on the intake side of the engine. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will set the fault code inactive after the degraded signal from the crankshaft speed/position sensor is no longer present.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than 3 continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

A vehicle operator can notice an intermittent “misfire” if the injection events are interrupted while the ECM switches from control based on the primary and secondary speed sensors. Also, a vehicle operator can notice intermittent “low power” if a “glitch” in the primary speed sensor signal causes the engine to intermittently use the backup speed sensor for injection control.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key ON or if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

Possible causes of this fault code include:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the primary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2321

Last Modified: 30-Aug-2010


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S064 SPN: 723 FMI: 2/2 LAMP: None SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. Camshaft engine speed sensor intermittent synchronization. | None on performance.
ISB, ISC, and ISL - Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

For ISC, ISL, and ISLe, the camshaft position sensor is located on the fuel side of the engine, in the gear housing, in front of the air compressor. Refer to Procedure 100-002 in Section E.

For ISB, ISDe, and QSB 3.3, the camshaft position sensor is located on the front of the engine above the vibration dampener. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will set the fault code inactive after the ECM detects a valid signal from the camshaft speed/position sensor.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp if the signal from the secondary speed sensor is not present or degraded for more than 3 continuous seconds. If, over a period of time, the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key-ON or if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

Problems that can cause this fault:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the secondary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2322

Last Modified: 18-Jan-2012


Turbocharger 1 Speed - Abnormal Rate of Change

FAULT CODE 2345

Turbocharger 1 Speed - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2345 PID: P103 SPN: 103 FMI: 10/10 LAMP: Amber SRT: | Turbocharger 1 Speed - Abnormal Rate of Change. The turbocharger speed sensor has detected an erroneous speed value. | None on performance. The ECM uses an estimated turbocharger speed.
ISB, ISC, and ISL with CM2150 - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft passes the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is located in the center housing of the turbocharger. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed has increased faster than physically achievable by the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will estimate turbocharger speed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault becomes active if the engine is running and the turbocharger speed signal rapidly changes faster than the capabilities of the turbocharger. This fault code can be caused by an intermittent turbocharger speed sensor connection, incorrect turbocharger speed sensor air gap, or a faulty turbocharger speed sensor.

Refer to Troubleshooting Fault Code t05-2345

Last Modified: 20-Jul-2010


Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 2346

Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2346 PID: SPN: 2789 FMI: 0/15 LAMP: None SRT: | Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level. Turbocharger turbine inlet temperature has exceeded the engine protection limit. | Fuel is limited in an attempt to decrease the temperature of the exhaust gas entering the turbocharger.
ISB, ISC, and ISL with CM2150 - Electronic Control Module

Circuit Description

The exhaust gas temperature is calculated by the electronic control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger and is also know as turbine inlet temperature.

Note: Some original equipment manufacturers (OEM) have pyrometer gauges mounted in their chassis. Pyrometers measure turbine outlet temperature or the exhaust gas leaving the turbocharger and will not equal the value monitored with the exhaust gas temperature parameter with INSITE™ electronic service tool.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the calculated turbine inlet temperature is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the temperature threshold is exceeded.
  • Fuel is limited in an attempt to decrease the temperature of the exhaust gas entering the turbocharger.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is an information fault code indicating that the engine has been derated for high turbine inlet temperature (exhaust temperature). No troubleshooting is necessary for this fault code. It is only an indicator that the engine power was derated to limit the exhaust temperature.

If the condition continues to exist, Fault Code 2451 will become active.

Refer to Troubleshooting Fault Code t05-2346

Last Modified: 20-Jul-2010


Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 2347

Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2347 PID: SPN: 2790 FMI: 0/15 LAMP: None SRT: | Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level. High turbocharger compressor outlet air temperature has been calculated by the electronic control module (ECM). | Fuel is limited in an attempt to decrease the calculated turbocharger compressor outlet air temperature.
ISB, ISC, and ISL with CM2150 - Electronic Control Module

Circuit Description

The turbocharger compressor outlet air temperature is calculated by the ECM. Turbocharger compressor outlet air temperature is derived by the ECM, based on engine operating conditions such as turbocharger compressor inlet air temperature, barometric pressure, turbocharger speed, engine speed, intake manifold air temperature, and intake manifold pressure.

Component Location

There is not a physical turbocharger compressor outlet temperature sensor in the system. The turbocharger compressor outlet air temperature is a calculation of temperature of the air after it is compressed by the turbocharger compressor, but before exhaust gas recirculation (EGR) is mixed into the system and before it enters the charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the calculated turbocharger compressor outlet temperature is greater than 238°C [460°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the temperature threshold is exceeded.
  • Fuel is limited in an attempt to decrease the calculated compressor outlet temperature.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible caused of this fault code include:

  • Air intake leaks allowing hot under-hood air to enter the intake system
  • Faulty intake manifold pressure readings
  • High turbocharger speed readings
  • Faulty barometric pressure readings
  • Stuck variable geometry turbocharger.

Note: Unless the failure is a failed barometric pressure sensor or intake manifold pressure sensor, this fault code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code, and to determine if the failure has been found and fixed.

Refer to Troubleshooting Fault Code t05-2347

Last Modified: 20-Jul-2010


EGR Valve Control Circuit - Current Below Normal or Open Circuit

FAULT CODE 2349

EGR Valve Control Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2349 PID: S146 SPN: 2791 FMI: 5 LAMP: Amber SRT: | EGR Valve Control Circuit - Current Below Normal or Open Circuit. Motor terminal or motor coil open circuit has been detected by the ECM. | EGR valve actuation will be disabled.
ISB, ISC, and ISL with CM2150 - EGR Valve Position Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve is located on the air intake connection. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects an open circuit in the engine wiring harness or EGR valve motor coil.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • EGR motor circuit open circuit
  • Open circuit in the wiring harness
  • Fuel Injector wiring harness shorted to ground, open circuit, or shorted to power supply.
Refer to Troubleshooting Fault Code t05-2349.

Last Modified: 20-Dec-2011


EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2351

EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2351 PID: S146 SPN: 2791 FMI: 4 LAMP: Amber SRT: | EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source. Motor terminal or motor coil short circuit to ground or power supply has been detected by the ECM. | EGR valve actuation will be disabled.
ISB, ISC, and ISL with CM2150 - EGR Valve Position Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve is located on the air intake connection. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects a short circuit in the EGR motor supply circuits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • EGR motor circuit shorted to ground
  • EGR motor circuit shorted to battery supply.
Refer to Troubleshooting Fault Code t05-2351

Last Modified: 20-Jul-2010


EGR Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 2357

EGR Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2357 PID: S146 SPN: 2791 FMI: 7/7 LAMP: Amber SRT: | EGR Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment. The EGR motor has exceeded the duty cycle limit, indicating a stuck open EGR valve. | EGR valve actuation will be disabled.
ISB, ISC, and ISL - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary, depending on the engine application. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is set when the duty cycle required to open the EGR valve is greater than 95 percent for 3 seconds. The EGR valve controller will try to open the EGR valve again after 10 seconds. The fault code is triggered after three failed attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will stop responding to commands and the spring will close the EGR valve.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and clear the fault code after the keyswitch is cycled and the diagnostic runs and passes. The fault code will be inactive at key-on. It will only go active if the EGR valve is commanded open and the EGR valve is unable to move to the commanded position.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

This fault code is triggered when the EGR valve motor is unable to move the EGR valve in the open position. This is normally caused by a restriction in the EGR valve not allowing the EGR valve to move to the commanded position.

The fault code will be inactive at key-on. It will only go active if the EGR valve is commanded open and the EGR valve is unable to move to the commanded position.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the aftertreatment initial check procedure to test for a damaged diesel particulate filter (DPF).

  • For reuse guidelines for ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For reuse guidelines for ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Possible causes of this fault code include:

  • Fuel Injector wiring harness shorted to ground, open circuit, or shorted to power supply.
Refer to Troubleshooting Fault Code t05-2357

Last Modified: 20-Dec-2011


Exhaust Gas Recirculation Valve Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2359

Exhaust Gas Recirculation Valve Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2359 PID: P411 SPN: 411 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The EGR differential pressure sensor has detected high EGR gas flow, or the EGR differential pressure reading is not valid for engine operating conditions. | EGR valve actuation will be disabled.
ISB, ISC, and ISL - Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The electronic control module (ECM) uses this pressure differential to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.

The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is located on the air intake connection. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the following conditions are met:

  • The EGR valve position is less than 5 percent open
  • The engine speed is less than a calibratible value
  • Engine torque output is less than a calibratible value.

Conditions for Setting the Fault Codes

EGR differential pressure is greater than a calibratible value when the EGR valve position is less than 5 percent open and engine torque is less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify that the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This diagnostic checks the reading of the differential pressure sensor when the EGR valve is closed. Since the EGR valve is closed, the reading of the EGR differential pressure should be 0. If the ECM detects a reading higher than expected with the EGR valve closed, this fault code is logged.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor
  • A stuck open EGR valve
  • EGR differential pressure sensor flow port cross-drillings are plugged with soot.
Refer to Troubleshooting Fault Code t05-2359

Last Modified: 01-Sep-2011


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2363

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S029 SPN: 1073 FMI: 4 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brake on cylinders 4, 5, and 6 can not be activated.
ISL with CM2150 - Engine Brake Actuator Circuit

Circuit Description

The electronic control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. A 2-pin Weather Pack connector is located near the number 3 injector pass-through connector at the back of the engine. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 2 circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include short circuit to ground in the engine harness, connectors, or engine brake solenoids.

Refer to Troubleshooting Fault Code t05-2363

Last Modified: 20-Jul-2010


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2367

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S80 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brake on cylinders 4, 5, and 6 can not be activated.
ISB, ISC, and ISL with CM2150 - Engine Brake Actuator Circuit

Circuit Description

The electronic control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. A 2-pin Weather Pack connector is located near the number 3 injector pass-through connector at the back of the engine. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The engine brake 2 circuit PWM signal is detected to be system voltage when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-2367

Last Modified: 20-Jul-2010


Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2373

Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P131 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas pressure circuit. | None on performance.
ISB, ISC, and ISL - Exhaust Gas Pressure Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the electronic control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust gas pressure signal voltage is greater than 4.75-VDC for more than 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used of the exhaust gas pressure reading.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor
  • A signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2373

Last Modified: 20-Jul-2010


Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2374

Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P131 SPN: 1209 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas pressure circuit. | None on performance.
ISB, ISC, and ISL - Exhaust Gas Pressure Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the electronic control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust gas pressure signal voltage is less than .25-VDC for more than 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the exhaust gas pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-2374

Last Modified: 20-Jul-2010


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2375

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2375 PID: P412 SPN: 412 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at EGR temperature circuit. | EGR valve actuation will be disabled.
ISB, ISC, and ISL - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The ECM supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature signal voltage is greater than 5.1-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas recirculation temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors or sensor
  • An open signal circuit or shorted to a voltage source.

Temperature °C | Temperature [°F] | Resistance (ohms)
0 | 32 | 256k to 423k
20 | 68 | 99k to 154k
40 | 104 | 42k to 63k
100 | 212 | 5.5k to 7.1k
140 | 284 | 1.9k to 2.3k
200 | 392 | 520 to 580
Refer to Troubleshooting Fault Code t05-2375

Last Modified: 20-Jul-2010


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2376

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2376 PID: P412 SPN: 412 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at EGR temperature circuit. | EGR valve actuation will be disabled.
ISB, ISC, and ISL - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The electronic control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature signal voltage is less than 0.09-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the EGR temperature reading is used.
  • EGR valve actuation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal shorted to ground in the harness
  • A signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-2376

Last Modified: 20-Jul-2010


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S033 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan may stay on continuously or not run at all.
ISB, ISC, and ISL - Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the electronic control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The fan clutch solenoid location varies by OEM. Refer to the appropriate OEM service literature to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

For ON/OFF and variable speed fan, the diagnostic will clear when the fan is turned off and the diagnostic runs and passes. For all other fan types, the diagnostic will clear when the fan PWM signal is less than 100 percent.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on this circuit. When the ECM commands the fan signal low, it expects the voltage level to be approximately 0-VDC. If it detects a high voltage, this fault is recorded.

If Fault Code 2377 is still active after completing the following troubleshooting steps, consult the OEM troubleshooting and repair manual for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault include:

  • An open circuit in the engine harness or fan control solenoid
  • A short circuit to voltage source in the OEM harness
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2377

Last Modified: 20-Jul-2010


Variable Geometry Turbocharger (VGT) Actuator Driver Circuit (Motor) - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 2387

Variable Geometry Turbocharger (VGT) Actuator Driver Circuit (Motor) - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2387 PID: S027 SPN: 641 FMI: 7/7 LAMP: Amber SRT: | VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding Properly or Out of Adjustment. The smart VGT controller has detected incorrect stop limits, or the VGT is unable to move to the closed position. | VGT travel can be limited.
ISB, ISC, and ISL - VGT Actuator Circuit

Circuit Description

The VGT is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine ECM. The VGT actuator performs its own diagnostics and reports errors back to the primary engine control module (ECM) with the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is set when the actual VGT actuator position does not meet the commanded position for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The VGT actuator will continue to attempt to meet the commanded position, even when the CHECK ENGINE lamp is on.
  • Active and stationary regeneration of the aftertreatment system are disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes at initial key ON.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

  • This fault code is set when the actual VGT actuator position does not meet the commanded position for more than 10 seconds.
  • Large boost pressure leaks can also cause this fault code.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system can possibly have occurred. Perform the aftertreatment initial check procedure to test for a damaged diesel particulate filter.

  • For ISB engines, reference the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL engines reference the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Inspect the aftertreatment system for potential damage.

Inspect the turbocharger vanes for residue, and clean the vanes, if required. Find the source of the residue and repair.

Refer to Troubleshooting Fault Code t05-2387

Last Modified: 03-Oct-2012


Coolant Level - Data Valid but Below Normal Operational Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid but Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: SPN: 111 FMI: 1/17 LAMP: Maintenance SRT: | Coolant Level - Data Valid but Below Normal Operational Range - Least Severe Level. Low engine coolant level detected. | None on performance.
ISB, ISC, and ISL - Electronic Control Module

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light at initial key-on for 30 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

The ECM will stop flashing the amber CHECK ENGINE light at key-on when coolant has been added to the engine.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-2448

Last Modified: 20-Jul-2010


VGT Actuator Controller - Out of Calibration

FAULT CODE 2449

VGT Actuator Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2449 PID: S027 SPN: 641 FMI: 13/13 LAMP: Red SRT: | VGT Actuator Controller - Out of Calibration. The VGT has failed the automatic calibration procedure at initial key-ON. | Low intake manifold pressure.
ISB, ISC, and ISL - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronic activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine ECM. The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key on.

Conditions for Setting the Fault Codes

The internal position reference is not detected during the initial power-on due to mechanical system binding or internal condition. The actual VGT actuator position is not known.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.
  • Active and stationary regeneration of the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key on.

The fault code will clear at key-ON if the error condition no longer exists. The ECM will turn off the red STOP ENGINE light and enable VGT operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when one of the following error conditions exists.

  • If the turbocharger actuator has just been replaced and this fault code is active, this usually indicates that the turbocharger actuator has not been installed correctly. The gear alignment between the actuator and the turbocharger housing is misaligned.
  • Foreign material in the VGT turbocharger can prevent the sliding nozzle from moving to the desired position at key-on.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the aftertreatment initial check procedure to test for a damaged diesel particulate filter.

  • For ISB engines, see the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL engines, see the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.
Refer to Troubleshooting Fault Code t05-2449

Last Modified: 20-Jul-2010


Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2451

Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2451 PID: SPN: 2789 FMI: 0/16 LAMP: None SRT: | Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Moderately Severe Level. Turbocharger turbine inlet temperature has exceeded the engine protection limit. | Fuel is limited in an attempt to decrease the calculated exhaust gas temperature entering the turbocharger.
ISB, ISC, and ISL - Electronic Control Module

Circuit Description

The exhaust gas temperature is calculated by the electronic control module (ECM). Exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger and is also known as turbine inlet temperature.

Note: Some original equipment manufacturers (OEMs) have pyrometer gauges mounted in their chassis. Pyrometers measure turbine outlet temperature or the exhaust gas leaving the turbocharger and will not equal the value monitored with the exhaust gas temperature parameter in INSITE™ electronic service tool.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the calculated turbine inlet temperature is greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the temperature threshold is exceeded.
  • Fuel is limited in an attempt to decrease the exhaust gas temperature entering the turbocharger.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The most common cause of this fault code is low boost pressure. Low boost pressure can be caused by several factors; leaking charge air cooler, damaged charge air cooler piping or hose, loose charge air cooler clamps, damaged intake manifold pressure sensor, damaged variable geometry turbocharger, damaged turbocharger control valve, or damaged turbocharger control shutoff valve.

This fault code can also be caused by a turbocharger fuel control derate which can be viewed in INSITE™ electronic service tool under the Engine Operating State. Turbocharger fuel control derates can be caused by several factors: high exhaust temperatures, high turbocharger compressor inlet temperatures, and high turbocharger compressor outlet temperatures.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trip this fault code and to determine if the malfunction has been found and fixed. Running units on the dynamometer can sometimes cause this fault code to log due to the stationary nature and high temperatures.

Refer to Troubleshooting Fault Code t05-2451

Last Modified: 20-Jul-2010


Exhaust Gas Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2554

Exhaust Gas Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2554 PID: P131 SPN: 1209 FMI: 2/2 LAMP: Amber SRT: | Exhaust Gas Pressure - Data Erratic, Intermittent, or Incorrect. The exhaust gas pressure sensor is reading an erratic value at initial Key On. | The ECM will estimate the exhaust gas pressure.
ISB, ISC, and ISL - Exhaust Gas Pressure Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the electronic control module (ECM) to control exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold. Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

  • This diagnostic runs when the keyswitch is initially turned ON.
  • The diagnostic will also run when the engine is running and lower than expected exhaust pressure is detected.

Conditions for Setting the Fault Codes

  • The ECM detects that the exhaust pressure reading is higher or lower than the other absolute pressure sensors on the engine when the keyswitch is ON and the engine is not running.
  • The ECM detects that the exhaust pressure is lower than a calibratible value during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure reading.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

At KEY ON, before the engine starts, the sensor readings for intake manifold pressure, barometric air pressure, and exhaust gas pressure are compared to each other. This fault code occurs if the exhaust gas pressure sensor reading is different from the other sensor readings. This check is only done once after the keyswitch is turned ON.

Possible causes of this fault code include:

  • A stuck in-range exhaust gas pressure sensor reading
  • A high resistance in the exhaust gas pressure sensor signal or return lines
  • Plugging or restriction in the exhaust gas pressure sensor tube.
Refer to Troubleshooting Fault Code t05-2554

Last Modified: 20-Jul-2010


Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2555

Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 2555 PID: S070 SPN: 729 FMI: 3 LAMP: Amber SRT: | Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the intake air heater signal circuit. | The intake air heaters may be ON or OFF all the time.
ISB, ISC, and ISL - Intake Air Heater 1 Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The electronic control module (ECM) controls relays that switch power to the intake air heater. 12-volt systems will have two relays while 24-volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection into the intake manifold. The location of the intake air heater relays will vary by original equipment manufacturer (OEM). Use the following procedure for a detailed component location. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is activated. In some cases the diagnostic can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The intake air heater circuit PWM signal is detected to be greater than 0 volts when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Intake air heater operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. Use the following procedure to calibrate the ECM, if necessary. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Intake air heater relay signal wire not connected to the relay
  • Intake air heater relay return wire not connected to the relay
  • Open circuit in the intake air heater relay signal wire
  • Open circuit in the intake air heater relay return wire
  • Intake air heater signal wire shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-2555

Last Modified: 20-Jul-2010


Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2556

Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2556 PID: S070 SPN: 729 FMI: 4 LAMP: Amber SRT: | Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the intake air heater signal circuit. | The intake air heater may be ON or OFF all the time.
ISB, ISC, and ISL - Intake Air Heater 1 Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The electronic control module (ECM) controls relays that switch power to the intake air heater. 12-volt systems will have two relays while 24-volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection into the intake manifold. The location of the intake air heater relays will vary by original equipment manufacturer (OEM). Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The intake air heater circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The intake air heater circuit will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • A shorted intake air heater relay
  • Intake air heater relay supply wire shorted to ground.
Refer to Troubleshooting Fault Code t05-2556

Last Modified: 20-Jul-2010


Auxiliary PWM Driver 1 - Voltage Above Normal or Shorted to High Source

FAULT CODE 2557 (QSB3.3)

Auxiliary PWM Driver 1 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2557 PID: S057 SPN: 697 FMI: 3 LAMP: Amber SRT: | Auxiliary PWM Driver 1 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the analog torque circuit. | Can not control transmission.
Auxiliary Pulse Width Modulated (PWM) Driver 1 Circuit

Circuit Description

The transmission shift modulator uses this signal from the electronic control module (ECM) to determine when to shift the transmission. The return circuit is dependent on original equipment manufacturer (OEM) wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details.

Component Location

Refer to the OEM wiring diagram for the location of the transmission shift modulator.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault can be caused by the following:

  • A faulty transmission shift modulator
  • An open circuit in the output device driver return wire
  • A pin-to-pin short circuit in the output device driver wire.
Refer to Troubleshooting Fault Code t05-2557

Last Modified: 20-Jul-2010


Auxiliary PWM Driver 1 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2558 (QSB3.3)

Auxiliary PWM Driver 1 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2558 PID: S057 SPN: 697 FMI: 4 LAMP: Amber SRT: | Auxiliary PWM Driver 1 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the analog torque circuit. | Can not control transmission.
Auxiliary Pulse Width Modulated (PWM) Driver 1 Circuit

Circuit Description

The transmission shift modulator uses this signal from the electronic control module (ECM) to determine when to shift the transmission. The return circuit is dependent on original equipment manufacturer (OEM) wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details.

Component Location

Refer to the OEM diagram for the location of the transmission shift modulator.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault can be caused by the following:

  • A faulty transmission shift modulator
  • An short circuit to ground on the output device driver line
  • A short pin-to-pin in the output device driver line.
Refer to Troubleshooting Fault Code t05-2558

Last Modified: 20-Jul-2010


VGT Actuator Controller - Bad Intelligent Device or Component

FAULT CODE 2634

VGT Actuator Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2634 PID: S027 SPN: 641 FMI: 12/12 LAMP: Red SRT: | VGT Actuator Controller - Bad Intelligent Device or Component. An internal error has been detected by the smart VGT controller. | VGT actuation will be disabled.
ISB, ISC, and ISL - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The VGT actuator has detected an internal error in the VGT smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.

Conditions for Clearing the Fault Code

The diagnostic will clear at initial key-on if the error condition no longer exists. The ECM will turn off the amber CHECK ENGINE light and enable VGT operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the VGT smart actuator detected an internal error within the VGT actuator. The VGT actuator will stop controlling the turbocharger when this fault code is active.

Fault Code 2634 will become active if the VGT actuator is removed from the turbocharger and then the keyswitch is turned to the on position or it may be possible for it to become active if the actuator fails the install/calibrate procedure. If this occurs, disconnect the VGT actuator from the engine harness with the keyswitch on, and connect the VGT actuator to the engine harness. Fault Code 2634 should go inactive. Follow the VGT actuator installation procedure to install the VGT actuator.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the aftertreatment initial check procedure to test for a damaged diesel particulate filter.

For ISB engines, see the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14. For ISC and ISL engines, see the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code t05-2634

Last Modified: 20-Jul-2010


VGT Actuator Driver Circuit - Condition Exists

FAULT CODE 2635

VGT Actuator Driver Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2635 PID: S027 SPN: 641 FMI: 11/31 LAMP: Red SRT: | VGT Actuator Driver Circuit - Condition Exists. A calibration mismatch between the VGT actuator and the ECM has been detected. | VGT actuation will be disabled.
ISB, ISC, and ISL - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 datalink from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 datalink.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

  • The ECM has detected a calibration incompatibility between the VGT actuator and the ECM calibration.
  • The VGT actuator has detected that the system voltage is incorrect for the installed VGT actuator part number.
  • The ECM has detected an incorrect VGT actuator installed on the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.

Conditions for Clearing the Fault Code

The diagnostic will clear at initial key-on if the error condition no longer exists. The ECM will turn off the red STOP ENGINE light and enable VGT operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM.Refer to Procedure 019-032 (ECM Calibration Code) in Section 19.

This fault code is logged when the ECM has detected that an incorrect VGT actuator has been installed on the turbocharger.

Refer to Troubleshooting Fault Code t05-2635

Last Modified: 15-Oct-2015


VGT Actuator Driver Circuit - Abnormal Update Rate

FAULT CODE 2636

VGT Actuator Driver Circuit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2636 PID: S027 SPN: 641 FMI: 9/9 LAMP: Red SRT: | VGT Actuator Driver Circuit - Abnormal Update Rate. No communications on the J1939 data link between the engine ECM and the smart VGT controller. | The VGT will move to the default open position.
ISB, ISC, and ISL - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The primary engine ECM does not receive a valid J1939 message from the VGT actuator for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The VGT will move to the default open position.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light and enable VGT operation immediately after a valid J1939 message is received from the VGT actuator.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM again. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the primary engine ECM does not receive valid J1939 information from the VGT actuator.

Troubleshoot high inactive counts of Fault Code 2636 as an active fault code.

Possible causes of this fault code include:

  • The VGT actuator is not receiving power from the ECM. This could be caused by an open circuit in the power supply wire or low voltage supplied by the primary engine ECM
  • An open return circuit on the VGT actuator circuit
  • An open or short circuit on the J1939 data link circuit between the ECM and VGT actuator
  • Intermittent communications between the VGT actuator and the primary engine ECM on the J1939 data link
  • Rapid cycling of the keyswitch
  • Connector pins are not installed in the appropriate locations specified by the wiring diagram.
  • A damaged termination resistor in the engine data link harness
  • A damaged engine ECM.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Use the following procedures to perform the aftertreatment initial check procedure to test for a damaged diesel particulate filter. Refer to Procedure 014-013 in Section 14, in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14, in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

Refer to Troubleshooting Fault Code t05-2636

Last Modified: 20-Jul-2010


Catalyst Face Plugged - Root Cause Not Known

FAULT CODE 2637

Catalyst Face Plugged - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2637 PID: SPN: 3050 FMI: 11/11 LAMP: None SRT: | Catalyst Face Plugged - Root Cause Not Known. The front face of the aftertreatment diesel oxidation catalyst has been detected to be plugged with soot. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISB, ISC, and ISL - Aftertreatment System

Circuit Description

This fault code is set when the inlet face of the diesel oxidation catalyst (DOC) is detected to be plugged with soot.

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The temperature sensors around the aftertreatment DOC are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment DOC is located in the exhaust system. The location of the catalyst may vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating and an active regeneration of the aftertreatment is occurring.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the conditions for face plugging of the DOC are present and that plugging may have occurred.

Action Taken When the Fault Code is Active

  • The fault code is logged immediately when the diagnostic runs and fails
  • Active aftertreatment diesel particulate filter regeneration will be disabled
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The fault code will be set to inactive after performing INSITE™ electronic service tool Diesel Oxidation Catalyst Maintenance Reset procedure found under the Aftertreatment Maintenance section of Advanced ECM Data, or when the conditions for DOC face plugging are no longer occurring.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is set when the inlet face of the DOC is detected to be plugged with soot. The engine is taking corrective action to clean the DOC. No troubleshooting is required if this is the only fault. This is an information fault only.

Refer to Troubleshooting Fault Code t05-2637.

Last Modified: 22-Jul-2013


Catalyst Efficiency - Out of Calibration

FAULT CODE 2638

Catalyst Efficiency - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2638 PID: SPN: 3050 FMI: 13/13 LAMP: None SRT: | Catalyst Efficiency - Out of Calibration. The temperature increase across the aftertreatment diesel oxidation catalyst is lower than expected. | None on performance.
ISB, ISC, and ISL - Aftertreatment System

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst (DOC) inlet temperature sensor is located after the turbocharger outlet, at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

  • Active regeneration of the aftertreatment diesel particulate filter must be occurring before the diagnostic will run.

Conditions for Setting the Fault Codes

The electronic control module (ECM) has calculated DOC efficiency to be less than required to successfully complete a regeneration.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The fault code will be set to inactive after performing INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter regeneration test and the DOC efficiency is determined to be above a calibratible threshold.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the electronic control module (ECM) has calculated DOC efficiency to be less than required to successfully complete a regeneration.

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment diesel oxidation catalyst
  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst
  • Cracked or contaminated aftertreatment diesel oxidation catalyst
  • Damage in the aftertreatment fuel injection system
  • Leaking exhaust system between the turbocharger and the diesel oxidation catalyst
  • An in-range malfunction of the aftertreatment diesel oxidation catalyst or the aftertreatment diesel particulate filter inlet temperature sensor can cause this fault code. Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.
Refer to Troubleshooting Fault Code t05-2638

Last Modified: 08-Jul-2011


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2639

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2639 PID: S324 SPN: 3251 FMI: 0/15 LAMP: None SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | The aftertreatment diesel particulate filter lamp will be illuminated and will begin to flash as the severity of the soot load increases. Engine protection derate based on severity.
ISB, ISC, and ISL - Aftertreatment System

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code can be triggered if the application is not operating at a duty cycle high enough to regenerate the aftertreatment diesel particulate filter. This fault code indicates that the exhaust temperatures exiting the turbocharger are not high enough to actively regenerate the soot that is trapped in the aftertreatment diesel particulate filter. It may be necessary to increase the duty cycle of the application in order to prevent plugging of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the soot load of the aftertreatment diesel particulate filter is above normal - least severe. The aftertreatment system needs to be regenerated to remove the soot.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the aftertreatment diesel particulate filter lamp immediately after the diagnostic is set.
  • The ECM will flash the aftertreatment diesel particulate filter lamp as the severity of the soot load increases.
  • A mild torque derate will be applied to the output of the engine after the aftertreatment diesel particulate filter lamp begins to flash. (Note: There is no derate in emergency vehicle calibrations.)

Conditions for Clearing the Fault Code

The ECM will turn off the aftertreatment diesel particulate filter lamp immediately after the soot load in the aftertreatment diesel particulate filter has dropped below the least severe level.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on Quickserve™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Note: This fault code indicates that the aftertreatment diesel particulate filter requires maintenance by performing a stationary regeneration procedure. This is a maintenance procedure only and is not covered by Cummins Inc. warranty.

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The engine has been operating in light load operating conditions that prevent exhaust temperatures from being high enough to regenerate the aftertreatment diesel particulate filter
  • Possible engine damage that causes excessive black smoke to be generated.

The aftertreatment diesel particulate filter soot loading can be classified into four different stages. As the soot load increases, the aftertreatment diesel particulate filter lamp and the Cummins CHECK ENGINE (Amber) or STOP ENGINE (Red) lamp will operate according to the table below. Inadequate temperature for the exhaust gases entering the aftertreatment system can be a cause of high soot loads in the aftertreatment diesel particulate filter. The duty cycle of the application will need to be increased in order to prevent excessive soot from accumulating in the filter.

Soot Level Stage | Cummins® Fault Code | Aftertreatment Diesel Particulate Filter Lamp Status | Cummins® Lamp Status | Service Procedure | Engine Protection Strategy
1 | 2639 | Solid | Off | Perform stationary regeneration procedure | No Engine Protection Derate
2 | 2639 | Flashing | Off | Perform stationary regeneration procedure | Mild engine torque derate.
3 | 1921 | Flashing | Amber | Perform stationary regeneration procedure | Moderate engine torque and engine speed derate.
4 | 1922 | Off | Red | Replace aftertreatment diesel particulate filter | Severe engine torque and engine speed derate.
Refer to Troubleshooting Fault Code t05-2639.

Last Modified: 17-Aug-2011


Engine Coolant Temperature - Condition Exists

FAULT CODE 2646

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2646 PID: P110 SPN: 110 FMI: 31 LAMP: Amber SRT: | Engine Coolant Temperature - Condition Exists. The EGR valve was closed to reduce engine coolant temperature. | EGR valve actuation will be disabled.
ISB, ISC, ISL - Engine Coolant Temperature Circuit

Circuit Description

When the engine coolant temperature nears the engine protection limits, the exhaust gas recirculation (EGR) valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The fault code is set active when the EGR valve is closed to reduce engine coolant temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The fault code is set inactive when the EGR valve actuation is re-activated.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed. No failure has occurred to cause this fault code. Other engine protection fault codes will be active if the engine coolant temperature has exceeded the engine protection limits.

Refer to Troubleshooting Fault Code t05-2646

Last Modified: 20-Jul-2010


Engine Coolant Temperature - Condition Exists

FAULT CODE 2659

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2659 PID: P110 SPN: 110 FMI: 31 LAMP: None SRT: | Engine Coolant Temperature - Condition Exists. The EGR valve was closed to reduce engine coolant temperature. | EGR valve actuation will be disabled.
ISB, ISC, and ISL - Engine Coolant Temperature Circuit

Circuit Description

When the engine coolant temperature nears the engine protection limits, the exhaust gas recirculation (EGR) valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The fault code is set active when the EGR valve is closed to reduce engine coolant temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The fault code is set inactive when the EGR valve actuation is re-activated.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed. No failure has occurred to cause this fault code. Other engine protection fault codes will be active if the engine coolant temperature has exceeded the engine protection limits.

Refer to Troubleshooting Fault Code t05-2659

Last Modified: 20-Jul-2010


Aftertreatment Fuel Injector 1 - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2728

Aftertreatment Fuel Injector 1 - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2728 PID: SPN: 3556 FMI: 16 LAMP: None SRT: | Aftertreatment Fuel Injector 1 - Data Valid but Above Normal Operational Range - Moderately Severe Level. Active regeneration of the aftertreatment diesel particulate filter has been detected to be ineffective. | None on performance.
ISB, ISC, and ISL - Aftertreatment System

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet, at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary depending on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

The diagnostics runs continuously when the engine is running and an active regeneration of the aftertreatment is occurring.

Conditions for Setting the Fault Codes

The aftertreatment system has detected that an active regeneration event has occurred longer than a calibratible time and that the aftertreatment temperature have not reached a minimum temperature for a complete regeneration of the diesel particulate filter to occur.

Action Taken When the Fault Code is Active

  • The fault code is set active immediately when the diagnostic runs and fails

Conditions for Clearing the Fault Code

The electronic control module (ECM) will disable the fault code immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment system will try to meet target temperatures at the outlet of the diesel oxidation catalyst during a regeneration event. This fault code is activated when the control system detects that excessive fuel is entering the exhaust system, in an attempt to meet the target temperatures at the diesel oxidation catalyst outlet temperature sensor.

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment diesel oxidation catalyst
  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst
  • A cracked or contaminated aftertreatment diesel oxidation catalyst
  • A leaking exhaust system between the turbocharger and the aftertreatment diesel oxidation catalyst
  • The duty cycle of the vehicle is not high enough to provide adequate exhaust temperatures for a complete regeneration event.
Refer to Troubleshooting Fault Code t05-2728

Last Modified: 20-Jul-2010


Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 2742

Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2742 PID: SPN: 3249 FMI: 17 LAMP: None SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Least Severe Level. The temperatures in the aftertreatment system can not reach the required temperatures for stationary regeneration. | None on performance.
ISB, ISC, and ISL - Aftertreatment System

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet, at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary depending on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

  • The diagnostic runs during a stationary regeneration of the aftertreatment diesel particulate filter.
  • The diagnostic also runs during extended idle periods when the exhaust temperature can not be increased in the aftertreatment system to remove water accumulation.

Conditions for Setting the Fault Codes

  • The ECM detects that the temperature measured at the Diesel Oxidation Catalyst inlet is not meeting the target temperature required for stationary regeneration.
  • The ECM detects that the temperature entering the aftertreatment system is not high enough to remove water from the system during extended idle periods.

Action Taken When the Fault Code is Active

  • This fault code is set active immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found under ECM Diagnostics Test.
  • The ECM will disable the fault code immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment system will try to meet target temperatures at the inlet of the diesel oxidation catalyst prior to beginning a stationary regeneration event. This fault code is activated if the engine is not able to meet the commanded minimum exhaust temperature required at the inlet of the aftertreatment system. This is prior to any aftertreatment fuel injection into the exhaust system.

Possible caused of this fault code include:

  • A leaking exhaust system between the turbocharger and the aftertreatment diesel oxidation catalyst
  • Excessive exhaust temperature loss between the turbocharger outlet and the inlet of the aftertreatment system.
Refer to Troubleshooting Fault Code t05-2742

Last Modified: 28-Jul-2010


Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2743

Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2743 PID: SPN: 3249 FMI: 18 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Moderately Severe Level. The temperatures in the aftertreatment system can not reach the required temperatures for stationary regeneration. | None on performance.
ISB, ISC, and ISL - Aftertreatment System

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary depending on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

  • The diagnostic runs during a stationary regeneration of the aftertreatment diesel particulate filter.
  • The diagnostic also runs during extended idle periods when the exhaust temperature can not be increased in the aftertreatment system to remove water accumulation.

Conditions for Setting the Fault Codes

  • The ECM detects that the temperature measured at the diesel oxidation catalyst inlet is not meeting the target temperatures required for stationary regeneration.
  • The ECM detects that the temperature entering the aftertreatment system is not high enough to remove water from the system during extended idle periods.

Action Taken When the Fault Code is Active

  • The set the fault code active immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use INSITE™ electronic service tool to perform the aftertreatment diesel particulate filter regeneration test found under ECM Diagnostics Test.
  • The ECM will disable the fault code immediately after the diagnostic runs and passes or after a keyswitch cycle.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment system will try to meet target temperatures at the inlet of the diesel oxidation catalyst prior to beginning a stationary regeneration event. This fault code is activated if the engine is not able to meet the commanded minimum exhaust temperature required at the inlet of the aftertreatment system. This is prior to any aftertreatment fuel injection into the exhaust system.

Possible caused of this fault code include:

  • A leaking exhaust system between the turbocharger and the aftertreatment diesel oxidation catalyst
  • Excessive exhaust temperature loss between the turbocharger outlet and the inlet of the aftertreatment system.
Refer to Troubleshooting Fault Code t05-2743

Last Modified: 20-Jul-2010


Engine Particulate Filter Inlet Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2754

Engine Particulate Filter Inlet Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2754 PID: SPN: 81 FMI: 16 LAMP: Amber SRT: | Engine Particulate Filter Inlet Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. Excessive black smoke has been detected exiting the engine and entering the aftertreatment diesel particulate filter. | None on performance
ISB, ISC, and ISL - Aftertreatment

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code is logged when the sensors in the aftertreatment system indicates soot accumulation inside the diesel particulate filter is happening at a higher rate than under normal conditions. This indicates that the smoke (soot) being produced by the engine is higher than normal.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

This fault code is logged when the soot accumulation inside the diesel particulate filter is happening at a higher rate than under normal conditions.

Action Taken When the Fault Code is Active

  • The fault code is active immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The electronic control module (ECM) will disable the fault code immediately after the diagnostic runs and passes or after a keyswitch cycle.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19.

Possible causes of this fault code include:

  • Boost leaks in the charge air cooler plumbing
  • A malfunction of the variable geometry turbocharger (VGT)
  • A malfunction of the exhaust gas recirculation (EGR) valve
  • A faulty in-range EGR differential pressure sensor
  • A faulty in-range boost pressure sensor
  • A faulty in-range barometric pressure sensor
  • A cylinder misfire or overfueling.
Refer to Troubleshooting Fault Code t05-2754

Last Modified: 15-Sep-2010


Engine Injector Bank 1 Barcodes - Out of Calibration

FAULT CODE 2765

Engine Injector Bank 1 Barcodes - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2765 PID: N/A SPN: 2797 FMI: 13 LAMP: None SRT: | Engine Injector Bank 1 Barcodes - Out of Calibration. Invalid injector barcode information has been entered. | None on performance.
ISC and ISL - Electronic Control Module

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire, after actuating the solenoid. Each solenoid valve is normally open and is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to two injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the injector barcode values have not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The fault code will be set active when the injector barcode parameters are not adjusted correctly.

Conditions for Clearing the Fault Code

The fault code will clear immediately after the correct injector barcode values have been entered with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code t05-2765

Last Modified: 20-Jul-2010


Particulate Trap Active Regeneration Inhibited Due to Permit Switch - Condition Exists

FAULT CODE 2777

Particulate Trap Active Regeneration Inhibited Due to Permit Switch - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2777 PID: 390 SPN: 3703 FMI: 11/31 LAMP: None SRT: | Particulate Trap Active Regeneration Inhibited Due to Permit Switch - Condition Exists. Regeneration of the diesel particulate filter has been prevented due to the permit switch being disabled. | None on performance.
Aftertreatment System

Circuit Description

The OEM truck manufacturer may install a permit switch in the dash or send an inhibit message via the J1939 datalink to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile regenerations. The purpose of this fault code is to inform the technician that the permit switch was disabled when Fault Code 1921, 1922, or 2639 was set active. This fault code may indicate the reason that high aftertreatment soot load fault codes are logged.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). The permit switch may be an actual switch in the vehicle dash or it may be a J1939 message sent via the J1939 datalink. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the on position.

Conditions for Setting the Fault Codes

This fault code is triggered if the permit switch is disabled when Fault Code 1921, 1922, or 2639 is activated for high soot load levels in the diesel particulate filter.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code will be set inactive when Fault Code 1921, 1922, or 2639 are set inactive.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If this fault code is active and there has been damage to the aftertreatment system, the permit switch may have prevented the aftertreatment system from performing a mobile (active) regeneration. Consult with the OEM if the aftertreatment system has failed due to the permit switch.

Refer to Troubleshooting Fault Code t05-2777

Last Modified: 20-Jul-2010


Aftertreatment Fuel Rate - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2778

Aftertreatment Fuel Rate - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2778 PID: 289 SPN: 3481 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Fuel Rate - Data Valid but Above Normal Operational Range - Moderately Severe Level. The lubricating engine oil needs to be changed due to possible fuel dilution. | None on performance.
Aftertreatment System

Circuit Description

The aftertreatment system requires fuel from the engine to regenerate the aftertreatment diesel particulate filter. This fuel is injected into the cylinder during a late post injection of the fuel injector. During this post injection event, it is possible that some fuel will enter the crankcase. During extended regeneration events the engine oil can become diluted with diesel fuel. This fault code is triggered when the electronic control system detects that fuel dilution of the lubricating oil is possible.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). The inhibit switch may be an actual switch in the vehicle dash or it may be a J1939 message sent via the J1939 datalink. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when fuel dilution of the lubricating oil is detected by the ECM.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code is cleared by resetting the Maintenance Monitor feature. The INSITE™ electronic service tool must be used to reset the Maintenance Monitor feature.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If this fault code can be triggered when fuel dilution of the lubricating oil is possible. Change the engine lubricating oil and clear the fault code using INSITE™ electronic service tool to reset the Maintenance Monitor feature.

Refer to Troubleshooting Fault Code t05-2778

Last Modified: 20-Jul-2010


EGR Valve Control - Special Instructions

FAULT CODE 2813

EGR Valve Control - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2813 PID: 146 SPN: 2791 FMI: 14 LAMP: Amber SRT: | EGR Valve Control - Special Instructions. The EGR valve has been closed during regeneration of the aftertreatment diesel particulate filter. | EGR valve operation will be disabled.
Aftertreatment System

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code is triggered when the EGR valve is closed during an active regeneration of the aftertreatment diesel particulate filter. No failure of the aftertreatment system has occurred. Closing the EGR valve increases the exhaust temperature and increasing the rate of regeneration of the aftertreatment diesel particulate filter. No troubleshooting of the aftertreatment system is necessary. This fault code is for information only.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system. The location of the aftertreatment diesel particulate filter varies depending on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

  • Active regeneration of the diesel particulate filter must be occurring.

Conditions for Setting the Fault Codes

  • The aftertreatment control system has detected that the exhaust temperature is not high enough during an active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

  • EGR valve operation is disabled.
  • The ECM illuminates the amber CHECK engine light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will disable the fault code immediately after a complete regeneration of the aftertreatment diesel particulate filter.

Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration test found under ECM Diagnostics Test.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is triggered when the EGR valve is closed during an active regeneration of the aftertreatment diesel particulate filter. No failure of the aftertreatment system has occurred. Closing the EGR valve increases the exhaust temperature and speeds up the rate of regeneration of the aftertreatment diesel particulate filter. No troubleshooting of the aftertreatment system is necessary. This fault code is for information only.

Refer to Troubleshooting Fault Code t05-2813

Last Modified: 20-Jul-2010


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

FAULT CODE 2961

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2961 PID: P412 SPN: 412 FMI: 0/15 LAMP: None SRT: | Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. EGR temperature has exceeded the engine protection limit. | Slight fueling derate to bring EGR temperature under the maximum limit.
ISB, ISC, and ISL - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The electronic control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR valve and the air intake connection. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature is greater than 210°C [410°F] (for ISB) or 237°C [460°F] (for ISC & ISL) for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The engine torque will be derated up to 40 percent to limit the EGR temperature.

Conditions for Clearing the Fault Code

The fault will go inactive immediately after the EGR temperature drops below 210°C [410°F] or 237°C [460°F] (for ISC & ISL).

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Plugged or leaking EGR differential flow ports
  • A malfunctioning EGR valve
  • A stuck open turbocharger control valve
  • A low reading from the EGR differential pressure sensor
  • A low reading for the EGR valve position sensor
  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger
  • A fouled EGR cooler.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code t05-2961

Last Modified: 14-Sep-2010


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2962

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2962 PID: P412 SPN: 412 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. EGR temperature has exceeded the engine protection limit. | Severe fueling derate to bring EGR temperature under the maximum limit.
ISB, ISC, and ISL - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor that is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The electronic control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR valve and the air intake connection. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature is greater than 246°C [475°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine torque will be derated up to 40 percent to limit the EGR temperature.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the EGR temperature drops below 246°C [475°F].

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • A fouled EGR cooler
  • Plugged or leaking EGR differential flow ports
  • A damaged EGR valve
  • A stuck open turbocharger control valve
  • A low reading from the EGR differential pressure sensor
  • A low reading for the EGR valve position sensor
  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code t05-2962

Last Modified: 31-Mar-2011


Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. Engine coolant temperature is above the engine coolant temperature engine protection warning limit. | Power derate and possible engine shut down if engine protection shut down feature is enabled.
ISB, ISC, and ISL - Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and for engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

The ECM will turn off the fault code immediately after the coolant temperature decreases below the engine protection limit.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19

Refer to Troubleshooting Fault Code t05-2963

Last Modified: 20-Jul-2010


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Least Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
ISB, ISC, and ISL - Intake Manifold 1 Pressure/Temperature Sensor

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

When the intake air is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

This fault code indicates that the intake manifold temperature has exceeded the maximum engine protection limit.

Component Location

The intake manifold 1 temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

The maximum torque output of the engine will return and the fault code will go inactive after the intake manifold air temperature drops below a calibratible limit set in the ECM.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold. Possible causes of this fault code include:

  • Plugged charge air cooler fins
  • Restricted airflow through the charge air cooler
  • An undersized charge air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-2964

Last Modified: 20-Jul-2010


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected an intake manifold pressure signal that is too high or low for present engine operating conditions. | Engine power derate.
ISB, ISC, and ISL - Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold.

This diagnostic checks the value of the intake manifold pressure sensor at key-on and while the engine is running. If the value of the intake manifold pressure is not reading ambient pressure at key-on or is not changing with engine operating conditions, this fault code is logged.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal reading is not changing with engine operating conditions or is reading an erratic value at key ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the corresponding Troubleshooting and Repair Manual for the engine being serviced.Refer to Procedure 019-032 in Section 19.

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too high or low for the present engine operating conditions. The ECM compares the intake manifold pressure reading to turbocharger speed to determine if the pressure reading is valid.

Possible causes of this fault are:

  • A damaged intake manifold pressure sensor
  • A malfunctioning barometric pressure sensor
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Restriction in the charge-air cooler
  • A malfunctioning turbocharger speed sensor
  • Plugged or restricted exhaust system
  • A plugged intake manifold pressure sensor
  • Air filter restriction.
Refer to Troubleshooting Fault Code t05-2973

Last Modified: 20-Jul-2010


Variable Geometry Turbocharger (VGT) Actuator Position - Special Instructions

FAULT CODE 3616

Variable Geometry Turbocharger (VGT) Actuator Position - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3616 PID: SPN: 2633 FMI: LAMP: None SRT: | VGT Actuator Position - Special Instructions. | Engine power may be derated.
ISB, ISC, and ISL - VGT Actuator Circuit

Circuit Description

The VGT is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM with the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is initially turned to the ON position.

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.

Conditions for Setting the Fault Codes

The ECM has detected an abnormal VGT position at key ON.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code 10 seconds after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.

The fault code will become inactive if the error condition no longer exists.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable corrections to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This is an informational fault code indicating that the VGT actuator was unable to go to the desired position at key ON. While active, the ECM will continuously attempt to restore normal VGT operation until the engine coolant temperature reaches 74°C [165°F].

If the condition continues to exist after the coolant reaches 74°C [165°F], Fault Code 2387 will become active and Fault Code 3616 will become inactive. Fault Code 2346 may set due to a resulting fueling derate.

Inspect the turbocharger vanes for residue, and clean the vanes, if required. Find the source of the residue and repair.

Refer to Troubleshooting Fault Code t05-3616

Last Modified: 03-Oct-2012


FAULT CODE 3738 - Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3738

FAULT CODE 3738 - Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3738 PID: SPN: 3489 FMI: 18 LAMP: Amber SRT: | Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level. The air or diesel exhaust fluid supply to the dosing unit has been lost. | Diesel exhaust fluid injection into the Selective Catalytic Reduction aftertreatment system is disabled.
ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN/ISL9 CM2150 SN/ISZ13 CM2150 - Air Supply Actuator Circuit
ISM11 CM876 SN - Air Supply Actuator Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit air solenoid is used to enable and disable the truck air supply to the diesel exhaust fluid dosing unit. The air is used to transport the diesel exhaust fluid to the aftertreatment nozzle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit air solenoid is mounted to the back of the diesel exhaust fluid dosing unit. The mounting location of the diesel exhaust fluid dosing unit is OEM specific.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the Selective Catalytic Reduction (SCR) system is dosing diesel exhaust fluid into the aftertreatment system.

Conditions for Setting the Fault Codes

The dosing unit detects that the air supply has been lost while dosing diesel exhaust fluid into the aftertreatment system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the MIL immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, it is necessary to use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test.
  • Make sure that the diesel exhaust fluid dosing unit is able to successfully cycle through all phases (priming, dosing, and purging) and that diesel exhaust fluid flows evenly from the aftertreatment nozzle.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • OEM air supply tubing damaged or leaking
  • Malfunctioning air solenoid
  • Malfunctioning aftertreatment diesel exhaust fluid dosing unit.
Refer to Troubleshooting Fault Code 3738.

Last Modified: 28-Oct-2015


Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 1911

Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1911 PID: P157 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure in the rail fuel is higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load) or possible power interruption associated with dump valve reset.
ISB Fuel Flow
B3.3 Fuel Flow

Circuit Description

The electronic control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the electric fuel control valve) or decrease (CLOSE the electric fuel control valve) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed on the high-pressure fuel pump. The high-pressure relief valve is located on the fuel rail.

Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the measured fuel rail pressure is above the commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Fault Code 1911 is activated when the sensed rail fuel pressure reaches the opening pressure of the rail fuel pressure relief valve. Sensed pressure has exceeded system target range.

In normal engine operation, the ECM calibration varies the flow commanded to the fuel pump actuator to achieve the correct fuel rail pressure. System failures that cause loss of pressure control can cause the fuel rail pressure relief valve to open. The fuel rail pressure relief valve acts to protect the high-pressure components from over-pressurization. If the ECM detects that the fuel rail pressure relief valve is open without detection of a fuel pump actuator circuit error, Fault Code 1911 will become active. On certain applications, the ECM will attempt to reset automatically causing a momentary loss of power for less than 1 second.

Conditions that can cause Fault Code 1911:

  • Purging air through the fuel system can cause a pressure overshoot, therefore causing Fault Code 1911 to log. A few bubbles exiting the line during the air in fuel test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive (Refer to Procedure 006-020 (Fuel Inlet Restriction) in Section 6 in the ISB CM2150 Service Manual, Bulletin 4021578, or Refer to Procedure 006-020 (Fuel Inlet Restriction) in Section 6 in the B3.3 and QSB3.3 Series Engines Service Manual, Bulletin 4021540, or Refer to Procedure 006-020 (Fuel Inlet Restriction) in Section 6 in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597), the source of air entry should be isolated to one of the following: Suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).
  • Sustained periods of very low pressure under load followed by pressure recovery overshoot. This can be caused by high restriction due to plugged filters (Fault Code 559).
  • A tampered fuel pressure sensor that reads low, a biased pressure sensor, or a poor electrical connection.
  • If an intermittent electrical circuit problem with the fuel pump actuator circuit exists, it is possible for Fault Code 1911 to become active, then inactive during normal engine operation. ECM Fault Code 2311 is designed to detect electrical circuit issues with the actuator. Therefore, it is only necessary to inspect for bad connectors or harness issues for Fault Code 1911 if no other fault codes exist. An electric fuel control actuator with excessive leakage will result in high rail fuel pressures at idle or light load.
  • Other conditions include ECM wiring harness issues such as poor grounds, battery voltage spikes, electrical noise, low alternator output, and large disturbances of battery voltage, as when jump-starting the vehicle.
  • The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero on some engines. In such cases, it may be necessary to manually relieve the pressure from the high-pressure fuel rail.
Refer to Troubleshooting Fault Code t05-1911

Last Modified: 15-Oct-2015


Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 1911

Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1911 PID: P157 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure in the rail fuel is higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load) or possible power interruption associated with dump valve reset.
ISC and ISL Fuel Flow

Circuit Description

The electronic control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the electric fuel control valve) or decrease (CLOSE the electric fuel control valve) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed on the high-pressure fuel pump. The high-pressure relief valve is located on the fuel rail.

Refer to Procedure 100-002 (Engine Identification) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the measured fuel rail pressure is above the commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Fault Code 1911 is activated when the sensed rail fuel pressure reaches the opening pressure of the rail fuel pressure relief valve. Sensed pressure has exceeded system target range.

In normal engine operation, the ECM calibration varies the flow commanded to the fuel pump actuator to achieve the correct fuel rail pressure. System failures that cause loss of pressure control can cause the fuel rail pressure relief valve to open. The fuel rail pressure relief valve acts to protect the high-pressure components from over-pressurization. If the ECM detects that the fuel rail pressure relief valve is open without detection of a fuel pump actuator circuit error, Fault Code 1911 will become active. On certain applications, the ECM will attempt to reset automatically causing a momentary loss of power for less than 1 second.

Conditions that can cause Fault Code 1911:

  • Purging air through the fuel system can cause a pressure overshoot, therefore causing Fault Code 1911 to log. A few bubbles exiting the line during the air in fuel test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-020 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. The source of air entry should be isolated to one of the following: Suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).Refer to Procedure 006-020 in Section 6.
  • Sustained periods of very low pressure under load followed by pressure recovery overshoot. This can be caused by high restriction due to plugged filters (Fault Code 559).
  • A tampered fuel pressure sensor that reads low, a biased pressure sensor, or a poor electrical connection.
  • If an intermittent electrical circuit problem with the fuel pump actuator circuit exists, it is possible for Fault Code 1911 to become active, then inactive during normal engine operation. ECM Fault Code 2311 is designed to detect electrical circuit issues with the actuator. Therefore, it is only necessary to inspect for bad connectors or harness issues for Fault Code 1911 if no other fault codes exist. An electric fuel control actuator with excessive leakage will result in high rail fuel pressures at idle or light load.
  • Other conditions include ECM wiring harness issues such as poor grounds, battery voltage spikes, electrical noise, low alternator output, and large disturbances of battery voltage, as when jump-starting the vehicle.
  • The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Once the engine is keyed off, there could be a significant amount of time waiting on the rail to depressurize to zero. It is necessary to manually relieve the pressure from the high-pressure fuel rail by loosening the pump to rail line at the rail.
Refer to Troubleshooting Fault Code t05-1911

Last Modified: 20-Jul-2010


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 - Two Wire Sensor

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
ISB, ISC and ISL with CM2150 - Engine Coolant Level Sensor 1 Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) supplies 5 volts to the coolant level signal circuit. The resistance of the engine coolant level sensor changes based on the coolant level. The sensor resistance is between 5.4k ohms and 34k ohms when the sensor is submersed in coolant. The sensor resistance is between 333k ohms and 880k ohms when the sensor is not sumbersed in coolant. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continously when the keyswitch is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than 5.124-VDC for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-195

Last Modified: 20-Jul-2010


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 - Three Wire Sensor

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
ISB, ISC and ISL with CM2150 - Engine Coolant Level Sensor 1 Circuit

Circuit Description

The electronic control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes, based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than 4.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-195

Last Modified: 20-Jul-2010


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196 - Two Wire Sensor

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
ISB, ISC and ISL with CM2150 - Engine Coolant Level Sensor 1 Circuit

Circuit Description

The engine coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) supplies 5 volts to the coolant level signal circuit. The resistance of the engine coolant level sensor changes based on the coolant level. The sensor resistance is between 5.4k ohms and 34k ohms when the sensor is submersed in coolant. The sensor resistance is between 333k ohms and 880k ohms when the sensor is not submersed in coolant. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than 0.258-VDC for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Signal circuit shorted to ground or return in the harness, sensor, or connectors.
Refer to Troubleshooting Fault Code t05-196

Last Modified: 20-Jul-2010


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
ISB, ISC, and ISL CM2150 - Coolant Level Sensor 1 Circuit

Circuit Description

The ECM provides a 5 volt supply to the engine coolant level sensor using a common sensor SUPPLY circuit. The ECM also provides a ground on the sensor RETURN circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor SIGNAL circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than 0.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the engine harness, connector, or sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-196 (3-wire).

Last Modified: 01-Aug-2011


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect. An error in the engine oil pressure switch signal was detected by the ECM. | None on performance. No engine protection for oil pressure.
ISB with CM2150 - Engine Oil Pressure Switch Circuit

Circuit Description

The engine oil pressure switch is used by the electronic control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, the switch will open and cause Fault Code 435 to log.

The oil pressure switch is normally closed when the engine is not running and open when oil pressure is present.

Component Location

The engine oil pressure switch is located on the front of the engine on the left (intake) side on the top of the front gear housing. Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is logged when an open circuit is detected for five consecutive key cycles when the ECM expected a closed circuit at key-on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section.

The oil pressure switch is closed with the engine not running and open when oil pressure is present. This fault code is logged when an open circuit is detected for five consecutive key cycles when the ECM expected a closed circuit at key-on. Possible causes of this fault code include:

  • Damaged engine oil pressure switch
  • Open circuit in the engine oil pressure switch signal wire
  • Damaged ECM
  • Short circuit in the engine oil pressure switch signal wire to a voltage source.
Refer to Troubleshooting Fault Code t05-435

Last Modified: 20-Jul-2010


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect. The engine oil pressure sensor is reading an erratic value at key ON. | None on performance. No engine protection for oil pressure.
ISC, and ISL with CM2150 - Engine Oil Pressure Circuit

Circuit Description

The electronic control module (ECM) provides a 5 VDC supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is turned ON and before engine speed is detected.

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure reading is higher or lower than the other absolute pressure sensors on the engine when the keyswitch is ON and the engine is not operating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

At key ON, before the engine starts, the sensor readings for intake manifold pressure, exhaust gas pressure, engine air pressure, and engine oil pressure are compared to each other. This fault code occurs if the engine oil pressure sensor reading is different from the other sensor readings. This check is only done once after the keyswitch is turned ON.

Possible causes of this fault code include:

  • Stuck in-range engine oil pressure sensor reading
  • High resistance in the engine oil pressure sensor signal or return lines.
Refer to Troubleshooting Fault Code t05-435

Last Modified: 20-Jul-2010


Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P94 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure in the fuel rail is higher than the fuel pressure relief valve. | None or possible engine noise associated with higher injection pressures (especially at idle or light load) or possible power derate.
Fuel System
Fuel System

Circuit Description

The electronic control module (ECM) monitors engine-operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the electric fuel control valve) or decrease (CLOSE the electric fuel control valve) the fuel supply to the high-pressure pump.

Component Location

The high pressure relief valve is located on the fuel rail. Refer to Procedure 100-002 (Engine Diagrams) for a detail component view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the measured fuel rail pressure is above the maximum pressure allowed by the fuel pressure relief valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails. Power derate may occur on some engines.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Fault Code 449 is activated when the sensed rail fuel pressure exceeds for several consecutive seconds the opening pressure of the fuel pressure relief valve.

Fault Code 449 is not used to indicate a fuel pressure relief valve opening. It is used to indicate a fuel pressure relief valve which fails to open or does not regulate pressure. Troubleshooting must be focused on inspecting the drain line path of the fuel pressure relief valve for restrictions/obstructions and checking or replacing the fuel pressure relief valve. A restriction in the fuel-drain-to-tank return line can prevent unneeded fuel from exiting the fuel system. Check the fuel drain line restriction from the fuel rail to the tank for damage.

The fuel rail pressure sensor must also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to 0. It could be necessary to manually relieve the pressure from the high pressure fuel rail.

Refer to Troubleshooting Fault Code t05-449

Last Modified: 20-Jul-2010


Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P94 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure in the fuel rail is higher than the fuel pressure relief valve. | None or possible engine noise associated with higher injection pressures (especially at idle or light load) or possible power derate.
Fuel System

Circuit Description

The electronic control module (ECM) monitors engine-operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the electric fuel control valve) or decrease (CLOSE the electric fuel control valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure relief valve is located on the fuel rail. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the measured fuel rail pressure is above the maximum pressure allowed by the fuel pressure relief valve.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails. Power derate can occur on some engines.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Fault Code 449 is activated when the sensed rail fuel pressure exceeds for several consecutive seconds the opening pressure of the fuel pressure relief valve.

Fault Code 449 is not used to indicate a fuel pressure relief valve opening. It is used to indicate a fuel pressure relief valve which fails to open or does not regulate pressure. Troubleshooting must be focused on inspecting the drain line path of the fuel pressure relief valve for restrictions/obstructions and checking or replacing the fuel pressure relief valve. A restriction in the fuel-drain-tank return line can prevent unneeded fuel from exiting the fuel system. Check the fuel drain line restriction from the fuel rail to the tank for damage.

The fuel rail pressure sensor must also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Once the engine is keyed off, there could be a significant amount of time waiting on the rail to depressurize to 0. It is necessary to manually relieve the pressure from the high-pressure fuel rail by loosening the pump to rail line at the rail.

Refer to Troubleshooting Fault Code t05-449

Last Modified: 20-Jul-2010


Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. The ECM has detected that fuel pressure is higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load). Engine power is reduced.
ISB with CM2150 - Fuel Rail Pressure Sensor

Circuit Description

The electronic control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (open the fuel pump actuator) or decrease (close the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed in the adapter on the back of the high-pressure fuel pump.

Refer to Procedure 100-002 (Engine Identification) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the fuel rail pressure reading has exceeded the recommended operating limits.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

A default value for the fuel rail pressure reading is used.

The fuel rail pressure will be regulated to the fuel rail pressure relief valve.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the fuel rail pressure drops to zero and the fuel rail pressure relief valve resets. This will normally occur at key-off.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

If the fuel pump actuator exhibits excessive leakage, it is possible that the fuel rail pressure will reach the opening pressure of the fuel rail pressure relief valve and Fault Code 1911 can possibly also become active.

  • The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero on some engines. In such cases, it may be necessary to manually relieve the pressure from the high-pressure fuel rail.
Refer to Troubleshooting Fault Code t05-553

Last Modified: 20-Jul-2010


Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. The ECM has detected that fuel pressure is higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load). Engine power is reduced.
ISC and ISL with CM2150 - Fuel Rail Pressure Sensor

Circuit Description

The electronic control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (open the fuel pump actuator) or decrease (close the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed in the adapter on the back of the high-pressure fuel pump.

Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the fuel rail pressure reading has exceeded the recommended operating limits.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

A default value for the fuel rail pressure reading is used.

The fuel rail pressure will be regulated to the fuel rail pressure relief valve.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the fuel rail pressure drops to zero and the fuel rail pressure relief valve resets. This will normally occur at key-off.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

If the fuel pump actuator exhibits excessive leakage, it is possible that the fuel rail pressure will reach the opening pressure of the fuel rail pressure relief valve and Fault Code 1911 can possibly also become active.

  • The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Once the engine is keyed off, there could be a significant amount of time waiting on the rail to depressurize to zero. It is necessary to manually relieve the pressure from the high-pressure fuel rail by loosening the pump to rail line at the rail.
Refer to Troubleshooting Fault Code t05-553

Last Modified: 20-Jul-2010


Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 0/16 LAMP: Amber SRT: | Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. | None on performance.
ISB and QSB3.3 CM2150 - Crankcase Pressure Sensor Circuit

Circuit Description

The pressure inside the crankcase filter is measured by the crankcase pressure sensor. When the crankcase pressure sensor determines that the crankcase pressure is higher than normal, this fault code is logged.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter. Use the following procedure for a detailed component location view.Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light when the crankcase pressure limit is exceeded.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light as soon as the crankcase pressure drops below a calibrated value.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced.Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Crankcase ventilation filter needs to be replaced
  • Crankcase pressure sensor damage
  • Malfunctioning or misassembled closed crankcase ventilation valve
  • Frozen, plugged, or restricted crankcase ventilation hose
  • Plugged or restricted crankcase ventilation hose
  • Plugged or restricted crankcase ventilation oil drain tube or check valve
  • Plugged or restricted crankcase breather tube (Rear Engine Mounted Crankcase Ventilation Filter)
  • High air intake restriction.

Depending on the breather system used, the crankcase ventilation filter will be located:

  • On top of the rocker lever cover, between the rocker lever cover and the crankcase ventilation filter cover.
  • At the rear of the engine, encased in an external crankcase ventilation filter housing that mounts to the flywheel housing.

Both systems are closed crankcase breather systems, meaning the crankcase gases are vented into the intake system at the inlet to the turbocharger compressor.

It is important to check for plugged or restricted hoses, tubes, check valves, and filters in extreme cold ambient temperatures.

If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the High Blowby (Crankcase Gases (Blowby) Excessive) troubleshooting symptom tree.

Refer to Troubleshooting Fault Code t05-555

Last Modified: 20-Jul-2010


Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 0/16 LAMP: Amber SRT: | Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. | None on performance.
ISC and ISL CM2150 - Crankcase Pressure Sensor Circuit

Circuit Description

The pressure inside the crankcase filter is measured by the crankcase pressure sensor. When the crankcase pressure sensor determines that the crankcase pressure is higher than normal, this fault code is logged.

Component Location

The crankcase pressure sensor is located near the crankcase breather filter. Use the following procedure for a detailed component location view.Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light when the crankcase pressure limit is exceeded.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light as soon as the crankcase pressure drops below a calibrated value.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced.Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Crankcase pressure sensor damage
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filters in extreme cold ambient temperatures.

If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code t05-555

Last Modified: 20-Jul-2010


Crankcase Pressure - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | Crankcase Pressure - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
ISB and QSB3.3 CM2150 - Crankcase Pressure Sensor Circuit

Circuit Description

The pressure inside the crankcase is measured by the crankcase pressure sensor. When the crankcase pressure sensor determines that the crankcase pressure is higher than normal, this fault code is logged.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter. Use the following procedure for a detailed component location view.Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light when the crankcase pressure limit is exceeded.
  • The engine torque output will be reduced to protect the engine from excessive crankcase pressure.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light as soon as the crankcase pressure drops below a calibrated value.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced.Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Crankcase ventilation filter needs to be replaced
  • Crankcase pressure sensor damage
  • Malfunctioning or misassembled closed crankcase ventilation valve
  • Frozen, plugged, or restricted crankcase ventilation hose
  • Plugged or restricted crankcase ventilation hose
  • Plugged or restricted crankcase ventilation oil drain tube or check valve
  • Plugged or restricted crankcase breather tube (rear engine-mounted crankcase ventilation filter)
  • High air intake restriction.

Depending on the breather system used, the crankcase ventilation filter will be located:

  • On top of the rocker lever cover, between the rocker lever cover and the crankcase ventilation filter cover, or
  • At the rear of the engine, encased in an external crankcase ventilation filter housing that mounts to the flywheel housing.

Both systems are closed crankcase breather systems, meaning the crankcase gases are vented into the intake system at the inlet to the turbocharger compressor.

It is important to check for plugged or restricted hoses, tubes, check valves, and filters in extreme cold ambient temperatures.

If Fault Code 556 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

After Fault Code 556 occurs, it is important to check for progressive damage to the engine due to the high crankcase pressure. Check for oil leaking from gaskets and seats.

Refer to Troubleshooting Fault Code t05-556

Last Modified: 20-Jul-2010


Crankcase Pressure - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | Crankcase Pressure - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
ISC and ISL CM2150 - Crankcase Pressure Sensor Circuit

Circuit Description

The pressure inside the crankcase is measured by the crankcase pressure sensor. When the crankcase pressure sensor determines that the crankcase pressure is higher than normal, this fault code is logged.

Component Location

The crankcase pressure sensor is located near the crankcase breather filter. Use the following procedure for a detailed component location view.Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light when the crankcase pressure limit is exceeded.
  • The engine torque output will be reduced to protect the engine from excessive crankcase pressure.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light as soon as the crankcase pressure drops below a calibrated value.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced.Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Crankcase pressure sensor damage
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filters in extreme cold ambient temperatures.

If Fault Code 556 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

After Fault Code 556 occurs, it is important to check for progressive damage to the engine due to the high crankcase pressure. Check for oil leaking from gaskets and seals.

Refer to Troubleshooting Fault Code t05-556

Last Modified: 20-Jul-2010


Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level. The ECM has detected that the fuel pressure is lower than commanded pressure. | Possibly hard to start, low power, or engine smoke. Engine could possibly not start.
Fuel Rail Pressure Sensor

Circuit Description

The ECM monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the electronic fuel control actuator to supply more (or less) fuel to the high-pressure pump.

Component Location

Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected that the measured fuel rail pressure is below the commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM again. Refer to Procedure 019-032 in Section 19.

Before performing troubleshooting work, verify the vehicle's system voltage by monitoring battery voltage in the INSITE™ electronic service tool data monitor or connecting a digital volt ohm meter to the batteries. This will help identify a potential system voltage issue. Refer to the OEM service manual for specified voltage range and troubleshooting procedures.

If the engine will not start and Fault Code 559 comes active during cranking, but no speed sensor fault codes exist, monitor rail pressure with INSITE™ electronic service tool. The procedures referred to in this troubleshooting tree will also have checks for engine no start conditions.

Before servicing any fuel system components, (such as fuel lines, fuel pump, injectors, etc.) which would expose the fuel system or internal engine component to potential contaminants prior to disassembly, clean the fittings, mounting hardware, and the area around the component to be removed. Dirt or contaminants can be introduced into the fuel system and engine if the surrounding areas are not cleaned, resulting in damage to the fuel system and engine. Refer to Procedure 000-009 in Section 0.

If fuel pressure is low, check the following:

  • Fuel system prime (make sure that there is fuel in the tanks and that the system is primed)
  • Fuel gear pump pressure.

If fuel gear pump pressure is correct, test for system leakage:

  • High pressure pump leakage
  • Injector leakage
  • Fuel rail pressure relief valve leakage.

If Fault Code 559 is inactive and there are no existing performance complaints, it is possible that the vehicle was run out of fuel or that the fault came active if the engine was not primed following fuel filter replacement. Clear the inactive fault code.

Fault Code 559 sets when the engine is running and measured rail fuel pressure remains at least 100 Bar [1450 psi] less than commanded pressure. Once detected, Fault Code 559 will remain active until the engine is turned off or until the measured rail fuel pressure matches the commanded rail fuel pressure. When a condition exists that causes Fault Code 559 to become active, it is typical for the fault code to become active when the engine is heavily loaded and become inactive when the engine is lightly loaded.

When Fault Code 559 occurs, the fuel system has lost its ability to maintain rail fuel pressure. Causes of this fault include:

  • Fuel inlet restrictions
  • Fuel filter plugging
  • Fuel gear pump output low
  • Fuel gear pump pressure regulator sticking or leaking
  • High pressure pump capacity decay (high leakage to drain from the high pressure pump)
  • Fuel rail pressure relief valve leaks to drain
  • Fuel rail pressure relief valve opens at too low a pressure
  • Injector fuel circuit leaks to drain
  • Pressure sensor reads more than 100 bar lower than actual pressure
  • Air in the fuel.

A few bubbles exiting the line during the test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry could be isolated to one of the following: suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).

The fuel rail pressure sensor can be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system, to allow the pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize completely to 0. It could be necessary to manually relieve the pressure from the high pressure fuel rail.

Intermittent ECM power supply connections can cause Fault Code 559. If the engine is running with an active Fault Code 559 and Fault Codes 449, 1911, or 2311 are not present, check the ECM power supply for intermittent connections or battery issues. Fault Code 1117 can also be active if this fault condition exits.

Inactive Fault Code/Exhausted Troubleshooting Tree:

Troubleshooting inactive Fault Code 559 can be very difficult. The fault code must be active for any of the outlined procedures in which the engine is operated during the test. For engines with high counts of inactive Fault Code 559 or if the troubleshooting tree has been exhausted, operate the engine on a chassis dynamometer or a diagnostic road test to duplicate the fault code. The most common causes of intermittent Fault Code 559 that are difficult to create are leaking high-pressure connectors that only leak when the engine and the fuel are hot, intermittent fuel supply restrictions such as debris floating in the fuel tank, and a fuel pressure relief valve that opens prematurely. Check the High Pressure Connector (HPC) and connector torque and torque to specification if necessary. Operate the engine on a chassis dynamometer or conduct a diagnostic road test to duplicate the fault code. Use INSITE™ electronic service tool to log fuel system parameters during testing.

Refer to Troubleshooting Fault Code t05-559

Last Modified: 20-Jul-2010


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559 (ISC and ISL)

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 18 LAMP: Yellow SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected that fuel pressure is lower than commanded pressure. | Possibly hard to start or low power. Engine could possibly not start.
Fuel Flow

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the fuel gear pump. The ECM monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has detected the measured fuel rail pressure is below the commanded fuel rail pressure by at least 250 bar [3625 psi] for 7 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

The fuel system is designed to run on clean fuel. It has two fuel filters to maintain this cleanliness. Carelessness in handling and storage of fuel system components during the repair can subject the precision components to damaging debris. Before servicing any fuel system components (such as fuel lines, fuel pump, injectors, etc.), clean the fittings, mounting hardware, and the area around the component to be removed. Store the components in a clean environment. Keep all fuel port openings and line ends covered so that no dirt can enter. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569, or the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 000-009 in Section 0.

Fault Code 559 sets when the engine is running and measured rail fuel pressure remains at least 250 bar [3625 psi] less than commanded pressure. Once detected, Fault Code 559 will remain active until the engine is turned OFF or until the measured rail fuel pressure matches the commanded rail fuel pressure. When a condition exists that causes Fault Code 559 to become active, it is typical for the fault code to become active when the engine is heavily loaded and become inactive when the engine is lightly loaded.

Possible causes of this fault code include:

  • Fuel inlet restrictions (filters, low pressure fuel lines, OEM plumbing, etc.)
  • Sticking check valve in ECM cooling plate
  • Fuel gear pump output low
  • Fuel gear pump pressure regulator stuck open (this can result in hard start and/or no-start complaints)
  • High-pressure pump capacity decay (high leakage to drain from the high-pressure pump)
  • Fuel rail pressure relief valve leaks to drain
  • Fuel rail pressure relief valve opens at a pressure too low (Fault Code 3727 detects this condition)
  • Injector fuel circuit leaks to drain (injector body, high-pressure connectors, etc.)
  • Air in the fuel or suction leaks at gear pump shaft seal (can result in hard start and/or no start complaints)
  • Fuel level is below the suction line in the fuel tank
  • Restricted fuel screen, located in the banjo bolt, at the high-pressure fuel pump inlet, if equipped
  • External fuel leaks.

If Fault Code 559 is inactive and there are not any existing performance complaints, it is possible the vehicle was run out of fuel or the fault became active if the engine was not primed following fuel filter replacement. However, if the customer reports that the fault code becomes active during engine operation, the steps in this fault code diagnostic tree can be used to identify the cause and make a repair.

If the engine will not start and Fault Code 559 becomes active during cranking, and no speed sensor fault codes exist, it is most likely that the engine is not developing rail pressure during cranking. Possibly, the engine is not primed, gear pump pressure is too low, or the high-pressure fuel system components have excessive leakage to drain. The procedures referred to in this troubleshooting tree also have checks for engine no start conditions.

The steps of this fault code tree assume that the fault condition is repeatable (this does not necessarily mean that the fault code is active with the engine at idle). The troubleshooting has been designed to isolate the problem into four categories:

1. Other more precise fault codes exist (example: electrical circuits faults).

2. Isolate the high-pressure system; determine if the high-pressure system has high leakage.

3. Isolate the low pressure system; determine if the low pressure system works correctly. The system must first be primed. Then, it is important to note that checks of gear pump pressure and inlet restriction involves using a special service tool that causes the flow rate to increase to a rated flow. Fuel gear pump pressure and/or inlet restriction can not be accurately measured without a method of increasing the flow (i.e. using the special service tool or operating the engine at full power).

4. Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Troubleshooting inactive Fault Code 559 can be difficult. For engines with high counts of inactive Fault Code 559, or if the troubleshooting tree has been exhausted, operate the engine on a chassis dynamometer or conduct a diagnostic road test to duplicate the fault code. Be certain to have a fuel pressure gauge installed at the pressure filter outlet side during the test.

If the accuracy of the fuel rail pressure sensor is being questioned, a key ON accuracy check can be performed. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Once the engine is keyed OFF, there could be a significant amount of time waiting for the fuel to depressurize to 0 bar [0 psi]. It is necessary to manually relieve the pressure from the high-pressure fuel rail by loosening the pump-to-rail line at the rail. At key ON, a depressurized rail pressure sensor should read 0 ± 43 bar [624 psi].

Refer to Troubleshooting Fault Code t05-559

Last Modified: 13-Jan-2014


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 111 - Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 111 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Repair complete.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 111 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 115. | Active or inactive counts of Fault Code 115?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 2B. Clear the fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 115.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 115?
YES NO

Swap the engine position sensor connectors.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 115 is inactive.

Fault Code 115 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Action

Clear the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-Feb-2012


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference Fault Code 227.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 187.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19..

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19..

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the electronic control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 123 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked agaiin.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 124 - Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with INSITE™ electronic service tool. | Value of intake manifold pressure is less than 203 mm Hg [8 in Hg]?
 | STEP 1B. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct within 127 mm Hg [5 in Hg]?
 | STEP 1C. Check the system for tampering. | Tampering detected?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 124 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy with INSITE™ electronic service tool.

  • Monitor the intake manifold pressure with INSITE™ electronic service tool with the keyswitch on and the engine not running.

Value of intake manifold pressure is less than 203 mm Hg [8 in Hg]?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical intake manifold pressure gauge to the engine.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Start the engine and compare the intake manifold pressure reading on the service tool monitor screen to the reading on the mechanical intake manifold pressure gauge.

The engine may need to be loaded before the pressure readings can be compared.

Sensor reading is correct within 127 mm Hg [5 in Hg]?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check the system for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger and fuel system for the following:

  • Turbocharger wastegate tampering
  • Variable geometry turbocharger tampering
  • Fuel system tampering
  • Fuel system add-on electronic devices.

Tampering detected?
YES NO

Remove the tampering device.

 No Repair

Go to 2A

Reference the Engine Performance troubleshooting symptom tree in Section TS.

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 124 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 131 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2185.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position sensor +5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal or lever. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 131 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 132 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 is active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 or 2186 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position +5 volt SUPPLY pin to the accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal position +5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 is active?
YES NO

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO

The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 132 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 133 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 or Fault Code 1696 active?
 | STEP 1B. Check for an active fault code. | Fault Code 133 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 134 active and Fault Code 133 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 133 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 or Fault Code 1696 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1695 or Fault Code 1696.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19..

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the remote accelerator pedal position sensor from the OEM harness
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal or lever position sensor +5 volt SUPPLY pin to the remote accelerator pedal or lever position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active and Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF
  • Connect the remote accelerator pedal or lever to the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal or lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the remote accelerator pedal or lever. Refer to the OEM service manual.

The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever RETURN pin and the OEM harness remote accelerator pedal or lever RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 inactive?
YES NO

The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 133 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 134 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 443 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 134 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal or lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 or 2186 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 443 or 2186.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal or lever position +5 volt SUPPLY pin to the accelerator pedal or lever position RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the accelerator pedal or lever position +5 volt SUPPLY pin and the accelerator pedal or lever position SIGNAL pin at the sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 133 active and Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal or lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the remote accelerator pedal or lever. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SUPPLY pin and the OEM harness remote accelerator pedal or lever connector SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SIGNAL pin and the OEM harness remote accelerator pedal or lever connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 1m.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 inactive?
YES NO

The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 134 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 386.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 141 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open RETURN or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

  • Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.
  • Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Go to the appropriate troubleshooting symptom tree.

Repair complete.

Last Modified: 14-Feb-2012


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 180 ohms and 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Between 180 ohms and 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the problem.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistanc measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 0019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 144 and 145. | Fault Codes 144 and 145 active?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 144 and 145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 144 and 145 active?
YES NO

Go to Fault Code 144 or 145 troubleshooting tree.

Reference the Engine Coolant Temperature Above Normal symptom tree in Section TS of the following manuals:

  • ISB CM2100 and CM2150 Service Manual, Bulletin 4021578
  • ISBe and ISDe CM2150 Service Manual, Bulletin 4021597
  • B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540
  • ISC and ISL Engines CM2150 Service Manual, Bulletin 4021569
  • ISLe CM2150 Service Manual, Bulletin 4021630.

Repair complete.

Go to the appropriate troubleshooting symptom tree.

Last Modified: 15-Feb-2012


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 144 and 145. | Fault Codes 144 and 145 active?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 144 and 145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 144 and 145 active?
YES NO

Go to Fault Code 144 or 145 troubleshooting tree.

Reference the Engine Coolant Temperature Above Normal symptom tree in Section TS of the following manuals:

  • ISB CM2100 and CM2150 Service Manual, Bulletin 4021578
  • ISBe and ISDe CM2150 Service Manual, Bulletin 4021597
  • B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540
  • ISC and ISL Engines CM2150 Service Manual, Bulletin 4021569
  • ISLe CM2150 Service Manual, Bulletin 4021630.

Repair complete.

Go to the appropriate troubleshooting symptom tree.

Last Modified: 15-Feb-2012


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 1.6k ohms and 3.1k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if, possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the intake manifold air temperature sensor.

When measuring the resistance for the sensor, use the following temperature versus resistance specifications:

  • 15°C [59°F] = 3.10k ohms
  • 20°C [68°F] = 2.45k ohms
  • 25°C [77°F] = 2.01k ohms
  • 30°C [86°F] = 1.67k ohms.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 1.6k ohms and 3.1k ohms?
YES NO
No Repair

Replace the intake manifold air temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the problem.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-159 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold temperature. |
 | STEP 1A. Use INSITE™ electronic service tool to monitor intake manifold temperature. | Does the INSITE™ electronic service tool temperature sensor reading correlate to a known value or a mechanical gauge?

Guided Step 1 - Monitor intake manifold temperature.

Guided Step 1A - Use INSITE™ electronic service tool to monitor intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the intake manifold temperature value.

  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the INSITE™ electronic service tool temperature sensor reading correlate to a known value or a mechanical gauge?
YES NO

Reference the Intake Manifold Air Temperature Above Specification symptom tree in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578, or ISBe and ISDe CM2150 Service Manual, Bulletin 4021597, or the B3.3 and QSB3.3 Series Engines Service Manual, Bulletin 4021540, or the ISC and ISL Engines CM2150 Service Manual, Bulletin 4021569, or the ISLe CM2150 Service Manual, Bulletin 4021630.

Replace the intake manifold temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to the appropriate troubleshooting symptom tree in Section TS.

Repair complete.

Last Modified: 22-May-2012


FAULT CODE 195 - Two Wire Sensor - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 800k ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant level SIGNAL pin and the engine coolant level RETURN pin at the engine coolant level sensor connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 800k ohms?
YES NO

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the engine coolant level sensor connector SIGNAL pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant level SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 195 - Three Wire Sensor - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 volts of direct current (VDC)?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

See Fault Code 1695.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

  • Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for geneal resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

  • Troubleshoot each harness connected in series to determine which contains the open return circuit.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for geneal resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for geneal resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be checked again from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 196 - Two Wire Sensor - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 is active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 is active?
YES NO

A damaged engine coolant level sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin short to ground.

  • Measure the resistance and check for a short circuit between the engine coolant level sensor SIGNAL pin at the OEM harness ECM connector and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

See Fault Code 1696.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

See the circuit diagram or wiring diagram for connector pin identification.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ the electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine.

Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Reference the OEM service manual before replacing the coolant level sensor.

No Repair

Reference the Coolant Loss troubleshooting symptom tree in Section TS.

Repair complete.

Last Modified: 16-Feb-2012


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Reference Fault Code 386.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 221 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Feb-2012


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference Fault Code 352.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the barometric pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open RETURN or a pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 222 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Feb-2012


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Engine motoring downhill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Check for an active fault code at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring downhill?
YES NO
No Repair

Check for engine damage.

  • Electronics are Ok.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 3400 rpm, followed by moderate deceleration to 3400 rpm.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Code 689 and 778.

Go to 1D

Troubleshoot Fault Code 689 and 778.

Guided Step 1D - Check for an active fault code at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for an active fault code.

Check for active Fault Code 234 when the engine is not running above 3200 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle.

Test the vehicle in a road test to check if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 12-Apr-2012


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine speed sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine speed sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the engine speed sensor. See equipment manufacturer information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

There is a short circuit to a voltage source in the engine harness sensor supply 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 239 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Apr-2012


FAULT CODE 241 - Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle speed sensor setting in INSITE™ electronic service tool. |
 | STEP 1A. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match. | Setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness pins and the sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM harness connector pins at the ECM. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the OEM harness. | More than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | More than 100k ohms?
STEP 3. | Check for additional OEM devices. |
 | STEP 3A. Check the vehicle speed sensor circuit for additional devices. | Extra devices?
 | STEP 3B. Check for the gear slipping on the shaft. | Gear or tone wheel damaged or slips?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 241 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the vehicle speed sensor setting in INSITE™ electronic service tool.

Guided Step 1A - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.

  • Verify that the vehicle speed sensor type parameter in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

Setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness pins and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM harness connector pins at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for additional OEM devices.

Guided Step 3A - Check the vehicle speed sensor circuit for additional devices.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle speed sensor circuit.

  • Inspect the vehicle speed sensor circuit for any additional devices that can interfere with the speed signal.

Extra devices?
YES NO

Remove the device or contact an OEM representative.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the vehicle speed sensor from the transmission.

Action

Check for the gear slipping.

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal. Make sure the gear or tone wheel is not damaged or slipping on the shaft.

Gear or tone wheel damaged or slips?
YES NO

Repair or replace the gear or tone wheel. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and move the vehicle so that the ECM can read a vehicle speed.
  • Use INSITE™ electronic service tool to verify that Fault Code 241 is inactive.

Fault Code 241 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location or OEM dealer if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Apr-2012


FAULT CODE 242 - Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are correct. |
 | STEP 1A. Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled. | Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
 | STEP 1B. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match. | The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
 | STEP 1C. Verify that the Anti-Tampering Sensitivity Level is set correctly for the application. | Sensitivity Level is set correctly?
STEP 2. | Look for signs or evidence of tampering. |
 | STEP 2A. Inspect the vehicle speed sensor. | Tampering, installed incorrectly, or external device present?
 | STEP 2B. Check for open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for short circuit to ground in the OEM harness. | More than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM harness. | More than 100k ohms?
STEP 3. | Check the vehicle speed reporting. |
 | STEP 3A. Use INSITE™ electronic service tool to monitor the vehicle speed signal. | INSITE™ electronic service tool readout and the vehicle speedometer match?
 | STEP 3B. Verify the vehicle speed. | Vehicle speed is accurate?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 242 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify that the feature settings are correct.

Guided Step 1A - Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled.

Conditions

N/A

Action

Verify that the customer wants Vehicle Speed Sensor Anti-Tampering feature enabled.

.

Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Vehicle Speed Sensor Anti-Tampering feature.

Go to 1B

Go to 4A

Guided Step 1B - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.

  • Verify that the Vehicle Speed Sensor Type parameter setting in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 1C

Go to 4A

Guided Step 1C - Verify that the Anti-Tampering Sensitivity Level is set correctly for the application.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify that the Vehicle Speed Signal Tampering Sensitivity Level is set correctly for the application.

  • Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.
  • Check the ECM setting for Vehicle Speed Signal Tampering Sensitivity Level.

Sensitivity Level is set correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to set the Vehicle Speed Signal Tampering Sensitivity Level to the correct value for the vehicle.

Go to 2A

Go to 4A

Guided Step 2 - Look for signs or evidence of tampering.

Guided Step 2A - Inspect the vehicle speed sensor.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to the OEM harness
  • Other external device connected in place of the vehicle speed sensor
  • Any evidence that tampering with the vehicle speed sensor has taken place.

Tampering installed incorrectly or external device present?
YES NO

Remove the tampering device.

Install the sensor correctly or remove the external device.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the vehicle speed reporting.

Guided Step 3A - Use INSITE™ to monitor the vehicle speed signal.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the vehicle speed.

  • Verify that the vehicle speed is 0 when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Compare the vehicle speed read by INSITE™ electronic service tool to the speedometer on the dash.

INSITE™ electronic service tool readout and the vehicle speedometer match?
YES NO
No Repair

Verify that the tire size, rear axle ratio, and tailshaft gear teeth parameters are set correctly in the ECM.

Go to 3B

Go to 4A

Guided Step 3B - Verify the vehicle speed.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Vehicle moving.

Action

Use INSITE™ electronic service tool to verify that the speed reported is accurate or reasonable for the present gear.

  • (For example: 64 km/h [40 mph] in top gear is probably inaccurate data)

Vehicle speed is accurate?
YES NO
No Repair

Verify that the tire size, rear axle ratio, and tailshaft gear teeth parameters are set correctly in the ECM.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine not running.
  • Vehicle not moving.

Action

Disable the fault code.

  • With the keyswitch ON and the vehicle stationary, wait one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 242 is inactive.

Fault Code 242 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location or OEM dealer if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Apr-2012


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the original equipment manufacturer (OEM) resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control solenoid. |
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage and supply line. | Greater than 5 volts of direct current (VDC)?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 245 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

See equipment manufacturer service information for resistance specifications.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and supply line.

  • Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the OEM harness actuator connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques, Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Start the engine and let it idle for 1 minute.
  • Turn the keyswitch OFF. Shut down the engine.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 245 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 249 - Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Resistance between 1.6k ohms and 3.1k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 249 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 256 active and Fault Code 249 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 249 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin and ambient air temperature sensor RETURN pin at the ambient air temperature sensor.

When measuring the resistance for the sensor, use the following temperature versus resistance specifications.

  • 15°C [59°F] = 3.10k ohms
  • 20°C [68°F] = 2.45k ohms
  • 25°C [77°F] = 2.01k ohms
  • 30°C [86°F] = 1.67k ohms

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 1.6k ohms and 3.1k ohms?
YES NO
No Repair

Replace the ambient air temperature sensor. Refer to Procedure 019-134 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the problem.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the ambient air temperature sensor SIGNAL pin and the ambient temperature sensor RETURN pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 256 active and Fault Code 249 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor RETURN pin and the engine harness ambient air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor SIGNAL pin and the engine harness ambient air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 249 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Apr-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 252 inactive?
STEP 2. | Check the oil level sensor circuit. |
 | STEP 2A. Inspect the oil level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the oil level sensor. | 4.75 to 5.25 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the oil level sensor voltage at the ECM. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open in the oil level sensor signal circuit. |
 | STEP 3B-2. Check for a short circuit in the oil level sensor signal circuit. |
 | STEP 3B-3. Check for a short circuit to ground in the oil level sensor signal circuit. |
 | STEP 3B-4. Check the fault codes. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault code 252 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 252 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the oil level sensor and circuit.

Guided Step 2A - Inspect the oil level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.

Action

Inspect the engine harness and oil level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the oil level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil level sensor +5 volt SUPPLY pin to the oil level sensor RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the oil level sensor voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil level sensor +5 volt SUPPLY pin to the oil level sensor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

An open circuit in the oil level sensor power SUPPLY or RETURN circuit has been detected in the engine harness.

Replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4A

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 252 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open or short has been detected in the engine harness on the oil level sensor +5 volt SUPPLY or RETURN circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open in the oil level sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the oil level sensor signal circuit.

  • Measure the resistance between the oil level sensor SIGNAL pin at the oil level sensor engine harness connector and the oil level sensor SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open has been detected in the oil level sensor signal circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for a short circuit in the oil level sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the oil level sensor signal circuit.

  • Measure the resistance between the oil level sensor SIGNAL pin at the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the oil level sensor signal circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check for a short circuit to ground in the oil level sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the oil level sensor signal circuit.

  • Measure the resistance between the between the oil level sensor SIGNAL pin at the ECM engine harness connector and ground.

Refer to the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the oil level sensor signal circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

Go to 3B-4

Go to 4A

Guided Step 3E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 252 active?
YES NO

Replace the oil level sensor.

Refer to Procedure 019-056 (Lubricating Oil Level Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 252 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


FAULT CODE 253 - Engine Oil Level - Data Valid but Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 253 active?
STEP 2. | Check the engine lubricating oil level. |
 | STEP 2A. Verify the engine lubricating oil level. | Engine lubricating oil level correct?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 253 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Verify engine oil temperature near ambient temperature.
  • Make sure the vehicle is parked on level ground.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 253 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the engine lubricating oil level.

Guided Step 2A - Verify the engine lubricating oil level.

Conditions

  • Turn keyswitch OFF.

Action

Verify the engine lubricating oil level using the oil dipstick.

Engine lubricating oil level correct?
YES NO

Replace the lubricating oil level sensor. Refer to Procedure 019-056 in Section 19.

Low engine lubricating oil level has been detected.

Add engine lubricating oil to the engine.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 007-037 in Section 7.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 007-037 in Section 7.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds, and then turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Determine if Fault Code 253 is inactive.

Use INSITE™ electronic service tool to determine if Fault Code 253 is inactive.

Fault Code 253 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 256 - Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 256 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active and Fault Code 256 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 256 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 249 active and Fault Code 256 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 256 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active and Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

A damaged sensor has been detected.

Replace the ambient air temperature sensor. Refer to Procedure 019-004 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins. if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active and Fault Code 256 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between ambient air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedures need to be repeated from the beginning. A fault mode ought to have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 256 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Apr-2012


FAULT CODE 271 - Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 271 active?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 272 is active and Fault Code 271 is inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 271 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 272 active and Fault Code 271 inactive
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 271 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 271 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Inspect the fuel pump actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Inspect the pigtail wire harness as well as the engine harness for wire insulation damage that can cause a short circuit.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 is active and Fault Code 271 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 271 is inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Apr-2012


FAULT CODE 272 - Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 272 active?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel pump actuator. | Between 0.1 and 5 ohms?
 | STEP 2C. Check the fuel pump actuator diagnostic signal voltage and return circuit. | Greater than 3.0-VDC?
 | STEP 2D. Check for an open circuit in the fuel pump actuator return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel pump actuator diagnostic signal voltage. | Greater than 3.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 272 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 272 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Inspect the fuel pump actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the actuator continuity for a pin-to-pin open circuit:

  • Measure the resistance and check for an open circuit between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin.

Refer to the appropriate circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 0.1 and 5 ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator diagnostic signal voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the signal voltage and return circuit.

  • Measure the voltage between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the engine harness actuator connector.

Refer to the appropriate circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the fuel pump actuator return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness fuel pump actuator RETURN pin and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open pin-to-ground circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel pump actuator diagnostic signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the voltage from the fuel pump actuator SIGNAL pin to the fuel pump actuator RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the ECM connector of the engine harness and the fuel pump actuator SIGNAL pin at the fuel pump actuator connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 inactive?
YES NO

The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 272 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Apr-2012


FAULT CODE 281 - Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 281 is active or has more than 1 inactive count?
STEP 2. | Preliminary fuel system checks. |
 | STEP 2A. Measure the fuel gear pump pressure. | Is the fuel gear pump pressure greater than the specification outlined in Procedure 005-236 in Section 5?
 | STEP 2B. Check for air in the fuel. | Air in the fuel?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear all inactive fault codes.
  • Operate the engine at the steady state loaded condition.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 281 is active or has more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 2A

Reference the appropriate troubleshooting tree.

Guided Step 2 - Preliminary fuel system checks.

Guided Step 2A - Measure the fuel gear pump pressure.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Measure the fuel gear pump pressure.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-025 in Section 5.

If the engine will not start, perform this test while cranking the engine.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-025 in Section 5.

Is the fuel gear pump pressure greater than the specification outlined in Procedure 005-236 in Section 5?
YES NO
No Repair

Replace the fuel gear pump module.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-025 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-025 in Section 5.

Go to 2B

Go to 3A

Guided Step 2B - Check for air in fuel.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for air in the fuel.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-003 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-003 in Section 5.

Air in the fuel?
YES NO

Bubbles are an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-020 in Section 6.

Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-020 in Section 6.

If fuel inlet restriction is not excessive, the source of air entry should be isolated to one of the following:

  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipe(s) in the fuel tank(s).

Replace the high pressure fuel pump head.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-227 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-227 in Section 5.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM. Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Apr-2012


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 is active?
STEP 3. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 Data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 Data link harness. | Resistance between 50 ohms and 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 Data link harness. | Resistance between 50 ohms and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 Data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 285 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify communication with the ECM.

  • Use INSITE™ electronic service tool to verify communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 is active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 Data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use the INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.

If the status column indicates “Active” for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for specific multiplexing configuration information for several OEMs. If the OEM is not listed in the bulletin, it will be necessary to contact the OEM for specific multiplexing information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 Data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 Data link (+) wire and the SAE J1939 Data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 Data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 Data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 Data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 Data link (+) wire and the SAE J1939 Data link (-) wire on the appropriate Cummins® engine ECM OEM connection to the J1939 Data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 1 .

Resistance between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 Data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 Data link (+) wire and the SAE J1939 Data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 Data link (+) and the SAE J1939 Data link (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication troubleshooting symptom tree in Section TS.

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Apr-2012


FAULT CODE 287 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 287 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the accelerator parameters are being received properly by the ECM. | Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of zero?
 | STEP 3B. Determine if the accelerator parameters are being received properly by the ECM. | Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than zero?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 287 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 287 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the accelerator parameters are being received properly by the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation.

Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the throttle is released, the Throttle Status/Idle Validation parameter must display “released” and Percent Throttle parameter must display a value of zero.

Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of zero?
YES NO
No Repair

There is an OEM issue with the accelerator or idle validation switch or OEM VECU.

  • See the appropriate OEM for further instructions.
  • Refer to Procedure 019-054 in Section 19.
  • Refer to Procedure 019-085 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation.

When the throttle is depressed, the Throttle Status/Idle Validation parameter must display “depressed” and Percent Throttle parameter must display a value greater than zero.

Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than zero?

YES NO
No Repair

There is an OEM issue with the idle validation switch or the accelerator or with the OEM VECU.

  • See the appropriate OEM for further instructions.
  • Refer to Procedure 019-054 in Section 19.
  • Refer to Procedure 019-085 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 287 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 288 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 288 active?
STEP 2. | Check the OEM VECU and ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the remote accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of zero?
 | STEP 3B. Determine if the remote throttle switch and or remote throttle parameters are being received properly by the ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than zero?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 288 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 288 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 datalink to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and ensure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the remote accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Status/Idle Validation

Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the remote throttle is released, the Remote Throttle Switch parameter must display ON and the Percent Throttle parameter must display a value of zero.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of zero?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, the remote throttle, or with the OEM VECU.

Refer to the OEM for further instructions.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Ensure the remote throttle switch is ON and the remote accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Switch Status

Monitor parameters can possibly not appear in the electronic service tool exactly as shown above.

When the remote throttle is depressed, the Remote Throttle Switch parameter must display ON and the Percent Throttle parameter must display a value greater than zero.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than zero?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, or the remote throttle, or with the OEM VECU.

Refer to the OEM for further instructions.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 288 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Apr-2012


FAULT CODE 292 (QSB3.3) - Auxiliary Temperature Sensor Input 1 - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 292. | Active or inactive counts of Fault Code 292?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 292.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 292?
YES NO

The engine protection limit has been exceeded for the OEM supplied pressure or temperature input. Refer to the OEM service manual.

No Repair

Go to the OEM service manual.

Repair complete.

Last Modified: 16-Apr-2012


FAULT CODE 293 (QSB3.3) - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 293 inactive?
STEP 2. | Check the OEM temperature sensor and circuit. |
 | STEP 2A. Inspect the OEM temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Resistance between 180 ohms and 160K ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 293 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 293 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 293 is inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the OEM temperature sensor and circuit.

Guided Step 2A - Inspect the OEM temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor and connector pins.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the OEM temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 180 ohms 160K ohms?
YES NO

Refer to the OEM service manual for additional specifications.

Replace the OEM temperature sensor. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM temperature sensor RETURN pin and OEM harness OEM temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM temperature sensor SIGNAL pin and the OEM harness OEM temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 293 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 293 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Apr-2012


FAULT CODE 294 - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 294 is inactive?
STEP 2. | Check the original equipment manufacturer (OEM) temperature sensor and circuit. |
 | STEP 2A. Inspect the OEM temperature sensor and connector pins. | Dirty or damage pins?
 | STEP 2B. Check the circuit response. | Fault Code 293 active and Fault Code 294 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 294 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater then 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 294 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 294 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 294 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM temperature sensor and circuit.

Guided Step 2A - Inspect the OEM temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 293 active and Fault Code 294 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 294 active?
YES NO

A malfunctioning sensor has been detected.

Replace the OEM temperature sensor.

See the OEM troubleshooting and repair manual.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from ECM connector.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the OEM temperature SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or the wiring harness for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 294 is inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 294 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 295 - Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possiblity of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 221 and Fault Code 222. | Fault Code 221 or Fault Code 222 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active?
 | STEP 2C. Check the circuit response. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 222 active?
 | STEP 3C. Check the circuit response. | Fault Code 221 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verity the repair. | INSITE™ electronic service tool reading within 102 mm Hg [4 in Hg] of local barometric pressure?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 221 and Fault Code 222.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 or Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the barometric pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

An in-range malfunction of the barometric pressure sensor has been detected.

Replace the barometric pressure sensor.

  • Use the following procedure for all engines except ISB. Refer to Procedure 019-004 in Section 19.
  • Use the following procedure for ISB engines. Refer to Procedure 019-134 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the ECM connector.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start INSITE™ electronic service tool Data Monitor/Logger.
  • Use the following procedure to compare INSITE™ electronic service tool reading for Barometric Air Pressure to the local barometric pressure. Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading within 102 mm Hg [4 in Hg] of local barometric pressure?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Apr-2012


FAULT CODE 296 (QSB3.3) - Auxiliary Pressure Sensor Input 1 - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 296. | Active or inactive counts of Fault Code 296?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 296.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 296?
YES NO

The engine protection limit has been exceeded for the OEM supplied pressure input. Refer to the OEM service manual.

 No Repair

Refer to the OEM service manual.

Repair complete.

Last Modified: 16-Apr-2012


FAULT CODE 297 - Auxiliary Pressure Sensor Input 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Fault Code 386 active?
STEP 2. | Check the original equipment manufacturer (OEM) pressure sensor and circuit. |
 | STEP 2A. Inspect the OEM pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 298 active and Fault Code 297 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 297 active?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 297 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 297 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 386 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the OEM pressure sensor and circuit.

Guided Step 2A - Inspect the OEM pressure sensor and connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 active and Fault Code 297 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the OEM Pressure +5 volt SUPPLY pin and the OEM pressure RETURN pin at the sensor connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 active?
YES NO

A defective sensor has been detected.

Replace the OEM pressure sensor.

See OEM troubleshooting and repair manual.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM hanress and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure RETURN pin and the OEM harness OEM pressure sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SUPPLY pin in the OEM harness ECM connector and all other pins in the ECM OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin to pin shorted supply circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SUPPLY pin in the OEM harness ECM connector and all other pins in the ECM OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 298 (QSC3.3) - Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
STEP 2. | Check the OEM pressure sensor and circuit. |
 | STEP 2A. Inspect the OEM pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 297 active and Fault Code 298 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 298 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 298 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 298 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service to tool read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the OEM pressure sensor and circuit.

Guided Step 2A - Inspect the OEM pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the OEM pressure +5 volt SUPPLY pin and the OEM pressure RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the OEM pressure SUPPLY pin and the OEM pressure SIGNAL pin at the OEM pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 active and Fault Code 298 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 is active?
YES NO

A damaged sensor has been detected.

Replace the OEM pressure sensor. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM hanress and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure RETURN pin and the OEM harness OEM pressure sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure SIGNAL pin and the OEM harness OEM pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 ( in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Grater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin to pin shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disabel the fault code.

  • Start the engine let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-Apr-2012


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB CM2150 | 4021578
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Rocker Lever Cover | Refer to Procedure 003-011 | ISLe CM2150 | 4021630
Rocker Lever Cover | Refer to Procedure 003-011 | ISDe CM2150 | 4021597
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2150 | 4021540
Injector | Refer to Procedure 006-026 | ISB CM2150 | 4021578
Injector | Refer to Procedure 006-026 | ISC and ISL CM2150 | 4021569
Injector | Refer to Procedure 006-026 | ISLe CM2150 | 4021630
Injector | Refer to Procedure 006-026 | ISDe CM2150 | 4021597
Injector | Refer to Procedure 006-026 | QSB3.3 CM2150 | 4021540
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness. Refer to Procedure 019-063 in Section 19.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness. Refer to Procedure 019-063 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 1.
  • Disconnect the injector wiring harness from injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 2.
  • Disconnect the injector wiring harness from injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 21-Aug-2012


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB CM2150 | 4021578
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Rocker Lever Cover | Refer to Procedure 003-011 | ISLe CM2150 | 4021630
Rocker Lever Cover | Refer to Procedure 003-011 | ISDe CM2150 | 4021597
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2150 | 4021540
Injector | Refer to Procedure 006-026 | ISB CM2150 | 4021578
Injector | Refer to Procedure 006-026 | ISC and ISL CM2150 | 4021569
Injector | Refer to Procedure 006-026 | ISLe CM2150 | 4021630
Injector | Refer to Procedure 006-026 | ISDe CM2150 | 4021597
Injector | Refer to Procedure 006-026 | QSB3.3 CM2150 | 4021540
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness. Refer to Procedure 019-063 in Section 19.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness. Refer to Procedure 019-063 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 5 DRIVER pin and the cylinder number 5 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 5 DRIVER pin and the cylinder number 5 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 21-Aug-2012


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB CM2150 | 4021578
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Rocker Lever Cover | Refer to Procedure 003-011 | ISLe CM2150 | 4021630
Rocker Lever Cover | Refer to Procedure 003-011 | ISDe CM2150 | 4021597
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2150 | 4021540
Injector | Refer to Procedure 006-026 | ISB CM2150 | 4021578
Injector | Refer to Procedure 006-026 | ISC and ISL CM2150 | 4021569
Injector | Refer to Procedure 006-026 | ISLe CM2150 | 4021630
Injector | Refer to Procedure 006-026 | ISDe CM2150 | 4021597
Injector | Refer to Procedure 006-026 | QSB3.3 CM2150 | 4021540
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness. Refer to Procedure 019-063 in Section 19.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, egnine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness. Refer to Procedure 019-063 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 1.
  • Disconnect the injector wiring harness from injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 2.
  • Disconnect the injector wiring harness from injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 21-Aug-2012


FAULT CODE 325- Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB CM2150 | 4021578
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Rocker Lever Cover | Refer to Procedure 003-011 | ISLe CM2150 | 4021630
Rocker Lever Cover | Refer to Procedure 003-011 | ISDe CM2150 | 4021597
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2150 | 4021540
Injector | Refer to Procedure 006-026 | ISB CM2150 | 4021578
Injector | Refer to Procedure 006-026 | ISC and ISL CM2150 | 4021569
Injector | Refer to Procedure 006-026 | ISLe CM2150 | 4021630
Injector | Refer to Procedure 006-026 | ISDe CM2150 | 4021597
Injector | Refer to Procedure 006-026 | QSB3.3 CM2150 | 4021540
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness. Refer to Procedure 019-063 in Section 19.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness. Refer to Procedure 019-063 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 21-Aug-2012


FAULT CODE 331- Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB CM2150 | 4021578
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Rocker Lever Cover | Refer to Procedure 003-011 | ISLe CM2150 | 4021630
Rocker Lever Cover | Refer to Procedure 003-011 | ISDe CM2150 | 4021597
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2150 | 4021540
Injector | Refer to Procedure 006-026 | ISB CM2150 | 4021578
Injector | Refer to Procedure 006-026 | ISC and ISL CM2150 | 4021569
Injector | Refer to Procedure 006-026 | ISLe CM2150 | 4021630
Injector | Refer to Procedure 006-026 | ISDe CM2150 | 4021597
Injector | Refer to Procedure 006-026 | QSB3.3 CM2150 | 4021540
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness. Refer to Procedure 019-063 in Section 19.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness. Refer to Procedure in 019-063 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 1.
  • Disconnect the injector wiring harness from injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 2.
  • Disconnect the injector wiring harness from injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Aug-2012


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISB CM2150 | 4021578
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Rocker Lever Cover | Refer to Procedure 003-011 | ISLe CM2150 | 4021630
Rocker Lever Cover | Refer to Procedure 003-011 | ISDe CM2150 | 4021597
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2150 | 4021540
Injector | Refer to Procedure 006-026 | ISB CM2150 | 4021578
Injector | Refer to Procedure 006-026 | ISC and ISL CM2150 | 4021569
Injector | Refer to Procedure 006-026 | ISLe CM2150 | 4021630
Injector | Refer to Procedure 006-026 | ISDe CM2150 | 4021597
Injector | Refer to Procedure 006-026 | QSB3.3 CM2150 | 4021540
Engine Control Module (ECM) | Refer to Procedure 019-031 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISLe, ISDe, and QSB3.3 CM2150 | 4021570

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness. Refer to Procedure 019-063 in Section 19.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness. Refer to Procedure 019-063 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 21-Aug-2012


FAULT CODE 334 - Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 144 and 145. | Fault Code 144 and 145 active?
STEP 2. | Check the thermostat. |
 | STEP 2A. Check the thermostat. | Thermostat operate correctly?
STEP 3. | Check the engine coolant temperature sensor and circuit. |
 | STEP 3A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 144 active?
 | STEP 3C. Check the circuit response. | Fault Code 145 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 144 active?
 | STEP 4C. Check the circuit response. | Fault Code 145 active?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 334 inactive?
 | STEP 5B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 144 and 145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 144 or 145 active?
YES | NO
No Repair | No Repair

Fault Code 144 or 145 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the thermostat.

Guided Step 2A - Check the thermostat.

Conditions

  • Turn keyswitch OFF.

Action

Check the thermostat for correct operation.

  • Refer to Procedure 008-013 in Section 8.

Thermostat operate correctly?
YES NO
No Repair

Replace the thermostat. Refer to Procedure 008-013 in Section 8.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine coolant temperature sensor and circuit.

Guided Step 3A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor and connector pins.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant temperature SIGNAL pin and the engine coolant temperature RETURN pin at the engine coolant temperature connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant temperature SIGNAL pin and engine coolant temperature RETURN pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Make sure coolant temperature is equal to ambient air temperature.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine with coolant temperature near ambient air temperature.
  • Operate the engine until coolant temperature reaches thermostat opening temperature.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Note: The coolant temperature must be very close to the ambient air temperature before starting the engine. This diagnostic must see a change in coolant temperature before the fault will go inactive.

Fault Code 334 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-Jan-2013


FAULT CODE 343 - Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active or more than 3 inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During Cranking: At least (+) 6.2-VDC?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Recalibrate the ECM. |
 | STEP 4A. Recalibrate the ECM. | Fault Code 343 active after recalibrating the ECM?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than 3 inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During Cranking: At least (+) 6.2-VDC?
YES NO
No Repair

Charge or replace the battery. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery supply (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuse installation.

  • Inspect the OEM fuse for correct installation.

Is fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuse.

  • Verify that the OEM fuse is not blown.

Is fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Recalibrate the ECM.

Guided Step 4A - Recalibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a short circuit to ground.

  • Use INSITE™ electronic service tool to recalibrate the ECM with the latest engine calibration.

Fault Code 343 active after recalibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Turn the keyswitch to the OFF position for 30 seconds.
  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 343 is inactive.

For Fault Code 343 to become inactive, the ECM must go through one complete shutdown.

Fault Code 343 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-Apr-2012


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 322, 323, 324, 325, 331, and 332 active during engine operation?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Inspect the ECM power supply connectors and fuses. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate the engine and determine if fault code condition exists. | Fault Code 351 reoccurs during engine operation while injector Fault Codes 322, 323, 324, 325, 331, and 332 do not occur?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 351 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 322, 323, 324, 325, 331, and 332 active during engine operation?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Inspect the ECM power supply and fuses for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the power connector of the ECM power supply harness and the battery positive (+) pins at the battery positive (+) connection.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the battery terminals.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit in the ECM ground circuit.

  • Measure the resistance between the battery negative (-) pins at the ECM power supply connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measuring techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 reoccurs during engine operation while injector Fault Codes 322, 323, 324, 325, 331, and 332 do not occur?

YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

A marginal battery voltage condition is possible. Make sure the batteries are fully charged.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 351 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-Apr-2012


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the fuel rail pressure sensor and circuit connected to the sensor number supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the exhaust gas pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the intake manifold pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the crankcase pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
 | STEP 2F. Inspect the exhaust gas recirculation (EGR) differential pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response. |
 | STEP 2G. Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2G-1. Check the circuit response. |
 | STEP 2H. Inspect the EGR valve and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2H-1. Check the circuit response. |
 | STEP 2I. Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2I-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Fault Code 352 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the camshaft position sensor. Refer to Procedure 019-363 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel rail pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and the fuel rail pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the exhaust gas pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the intake manifold pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the crankcase pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

Go to 2F

Go to 4A

Guided Step 2F - Inspect the EGR differential pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in Section 19.

Go to 2G

Go to 4A

Guided Step 2G - Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2G-1

Guided Step 2G-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2H

Go to 4A

Guided Step 2H - Inspect the EGR valve and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2H-1

Guided Step 2H-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the EGR valve.

  • For ISB CM2100 and CM2150 engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-022 in Section 11.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-022 in Section 11.

Go to 2I

Go to 4A

Guided Step 2I - Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2I-1

Guided Step 2I-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine oil pressure sensor. Refer to Procedure 019-376 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Apr-2012


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault codes. | Fault Code 386 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

There is a short circuit to a voltage source in the engine harness sensor supply 1 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Apr-2012


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Low engine oil pressure has been detected.

  • For ISB engines, reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.
  • For ISC and ISL engines, reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Repair complete.

Repair complete.

Last Modified: 18-Apr-2012


FAULT CODE 418 - Water-In-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 418. | Active or inactive counts of Fault Code 418?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 418.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 418?
YES NO

Drain the water from the fuel filter.

 No Repair

Repair complete.

Repair complete.

Last Modified: 18-Apr-2012


FAULT CODE 427 - SAE J1939 Datalink - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3163151 - ECM bench calibration harness and Part Number 3164185 - ECM bench calibration adapter cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communications with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 427 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check SAE J1939 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM service manual.

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communications with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM service manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

Refer to OEM service manual.

Reference the Communication Error - Electronic Service Tool or Control Device Symptom troubleshooting symptom tree in Section TS.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 427 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Apr-2012


FAULT CODE 428 - Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 428 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 100k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 429 active and Fault Code 428 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 428 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, and water-in-fuel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the water-in-fuel sensor connector.

Refer to the circuit art or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Verify the correct water-in-fuel sensor is installed on the engine.

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active and Fault Code 428 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor RETURN pin and the engine harness water-in-fuel sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor SIGNAL pin and the engine water-in-fuel sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 428 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Apr-2012


FAULT CODE 429 - Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 429 active?
STEP 2. | Check the water-in-fuel sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 429 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the water-in-fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 is active?
YES NO

A damaged sensor has been detected.

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, sensor, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water-in-fuel SIGNAL pin at the ECM connector of the engine harness and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 is inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 429 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Apr-2012


FAULT CODE 431 - Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Troubleshooting presents the risk of equipment damage, personal injury, or death. Troubleshooting must be performed by trained, experienced technicians.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the integrated sensor switch. |
 | STEP 1A. Verify the integrated sensor switch is connected to the original equipment manufacturer (OEM) harness. | Integrated sensor switch connected to the OEM harness?
 | STEP 1B. Inspect the integrated sensor switch and connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the integrated sensor switch for an open circuit. | Less than 125 ohms?
 | STEP 1D. Check the integrated sensor switch for a pin-to-pin short circuit. | More than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for an open circuit. | Greater than 4.0 volts of direct current (VDC)?
 | STEP 2B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the OEM harness ECM battery (+) circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the integrated sensor switch.

Guided Step 1A - Verify the integrated sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the integrated sensor switch is connected to the harness.

Verify the ISS is connected to the original equipment manufacturer (OEM) harness.

Integrated sensor switch connected to the OEM harness?
YES NO
No Repair

Connect the integrated sensor switch to the OEM harness. See equipment manufacturer service information.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the integrated sensor switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Inspect the OEM harness and integrated sensor switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the integrated sensor switch for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and switch RETURN pin of the integrated sensor switch connector with the pedal or lever released.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and switch RETURN pin of the integrated sensor switch connector with the pedal or lever depressed.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 125 ohms?
YES NO
No Repair

Replace the integrated sensor switch. See equipment manufacturer service information.

Go to 1D

Go to 3A

Guided Step 1D - Check the integrated sensor switch for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the integrated sensor switch connector with the pedal or lever released and depressed.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the integrated sensor switch. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the integrated sensor switch connector of the OEM harness to the switch RETURN pin in the integrated sensor switch connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the integrated sensor switch connector of the OEM harness to the switch RETURN pin in the integrated sensor switch connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the OEM harness between the ECM connector and the integrated sensor switch connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the OEM harness between the ECM connector and the integrated sensor switch connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the switch RETURN wire in the OEM harness between the ECM connector and the integrated sensor switch connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance between the idle validation on-idle SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the OEM harness ECM battery (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the integrated sensor switch from the OEM harness.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Short circuit on two connectors - pin-to-pin check.

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the ECM power connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the ECM power connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair complete.

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever 3 times.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Service Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 432 - Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

Associated Procedures

Cautions and Warnings

WARNING

Troubleshooting presents the risk of equipment damage, personal injury, or death. Troubleshooting must be performed by trained, experienced technicians.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 432 active?
STEP 2. | Check the fault codes. |
 | STEP 2A. Perform the fault code disable procedure. | Fault Code 432 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the accelerator pedal or lever position sensor resistance. | 1500 to 3000 ohms (released) 250 to 1500 ohms (depressed)?
 | STEP 3B-1. Check the resistance of the accelerator pedal or lever position sensor. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 432 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 432 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the fault codes.

Guided Step 2A - Perform the fault code disable procedure.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal or lever to the full throttle position and release it completely 3 times.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 432 active?
YES NO
No Repair

Replace the accelerator pedal or lever assembly. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the accelerator pedal or lever position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the accelerator pedal or lever position sensor.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position +5 volt SUPPLY pin at the ECM connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin for identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Released value must be at least 1000 ohms greater than depressed value.

1500 to 3000 ohms (released) [250 to 1500 ohms (depressed)]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the resistance of the accelerator pedal or lever position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check the accelerator pedal or lever position sensor.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position +5 volt SUPPLY pin at the accelerator pedal or lever position sensor connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Released value must be at least 1000 ohms greater than depressed value.

1500 to 3000 ohms (released) [250 to 1500 ohms (depressed)]?
YES NO

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the accelerator pedal or lever assembly. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Short circuit on one connector pin-to-pin check:

  • Measure the resistance between the accelerator pedal or lever position +5 volt SUPPLY pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.
  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin of the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever 3 times.
  • Turn the keyswitch OFF for 30 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 432 is inactive.

Fault Code 432 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 435 - Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 382278 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 435 active?
STEP 2. | Check the engine oil pressure switch and circuit. |
 | STEP 2A. Inspect the switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the engine oil pressure switch. | Less than 10 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 435 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 435 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1 - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 435 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the engine oil pressure switch and circuit.

Guided Step 2A - Inspect the switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Inspect the switch and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the engine oil pressure switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check the resistance of the switch.

  • Measure the resistance between the engine oil pressure SIGNAL pin of the engine oil pressure switch and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine oil pressure switch. Refer to Procedure 019-066 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil pressure SIGNAL pin at the switch connector of the engine harness and the engine oil pressure SIGNAL pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance and check for a short circuit between the engine oil pressure SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector:

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 435 is inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 435 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 19-Apr-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 135 and Fault Code 141 | Fault Code 135 and Fault Code 141 active?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active?
 | STEP 2C. Check the circuit response. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 141 active?
 | STEP 3C. Check the circuit response. | Fault Code 135 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | INSITE™ electronic service tool reading for Engine Oil Pressure 0 kPa [0 psi]?
 | STEP 4B. Clear the fault codes. | All fault codes cleared.

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 135 and Fault Code 141.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 or Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

Fault Code 135 active?
YES NO

An in-range malfunction of the oil pressure sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

Fault Code 135 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Monitor the INSITE™ electronic service tool Data Monitor/Logger for engine oil pressure.

INSITE™ electronic service tool reading for Engine Oil Pressure is 0 kPa [0 psi]?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 19-Apr-2012


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the OEM power harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least 12-VDC (12-volt systems)
  • At least 24-VDC (24-volt systems).

Cranking conditions:

  • At least 6.2-VDC (12-volt systems)
  • At least 12-VDC (24-volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-ampere fuse is installed correctly.

  • Inspect the 30-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 30-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 19-Apr-2012


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Check the battery voltage. | Less than + 20-VDC for 12-volt system and less than + 32-VDC for 24-volt system?
 | STEP 2B. Check the alternator. | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Check the battery voltage.

  • Measure the battery voltage from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.
  • Repeat above step for the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector.

Less than + 20-VDC for 12-volt system

Less than + 32-VDC for 24-volt system?
YES NO
No Repair

Install the battery system correctly. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 442 is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault code.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 19-Apr-2012


FAULT CODE 449 - Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 449 is active?
STEP 2. | Check the high-pressure fuel rail drain line restriction. |
 | STEP 2A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 3. | Inspect the fuel pressure relief valve. |
 | STEP 3A. Inspect the fuel pressure relief valve for tampering or wrong part number. | Was the correct fuel pressure relief valve part number installed and no tampering found?
STEP 4. | Inspect the rail fuel pressure sensor |
 | STEP 4A. Verify rail fuel pressure sensor accuracy. | Is the fuel rail pressure 0 +/- 24 bar (0 +/- 348 psi)?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 449 inactive?
 | STEP 5B. Check for active fault codes. | Fault Codes 559, 1117, 1911, or 2311 active or high inactive counts?
 | STEP 5C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 is active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the high-pressure fuel rail drain line restriction.

Guided Step 2A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Inspect drain line from high pressure relief valve to OEM connection point for damage (obstructions, kinks, or crimps).

Check for excessive fuel drain line restriction.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 Service Manual, Bulletin 4021540. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Replace the drain line or repair the source of the high fuel drain line restriction.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 Service Manual, Bulletin 4021540. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 006-012 in Section 6.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the fuel pressure relief valve.

Guided Step 3A - Inspect the fuel pressure relief valve for tampering or wrong part number.

Conditions

  • Engine is not running.

Action

Make sure the correct fuel pressure relief valve part number is installed.

  • Look for tampering of the fuel pressure relief valve.

Was the correct fuel pressure relief valve part number installed and no tampering found?
YES NO
No Repair

Repair the tampering or replace the fuel pressure relief valve.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 Service Manual, Bulletin 4021540. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 006-061 in Section 6.

Go to 4A

Go to 5A

Guided Step 4 - Inspect the rail fuel pressure sensor.

Guided Step 4A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • INSITE™ Monitor.
  • Fuel pressure relieved from the high-pressure fuel rail
  • Engine not running.

Action

Make sure the correct sensor part number is installed in the high pressure fuel rail.

  • When checking the fuel rail pressure sensor accuracy, make sure the high pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to 0. It could be necessary to manually relieve the pressure from the high pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail.

  • ISB Series 6.7 L Engines, 006-071 in the ISB CM2150 Service Manual, Bulletin 4021578.
  • QSB Series 3.3L Engines, 006-071 in the Service Manual, B3.3 and QSB3.3 Series Engine, Bulletin 4021540.
  • ISBe and ISDe Series 4.5 L and 6.7L Engines, 006-071 in the ISBe, ISDe, CM2150 Service Manual, Bulletin 4021597.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure 0 +/- 24 bar (0 +/- 348 psi)?
YES NO

Repair the tampering or replace the fuel pressure relief valve.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 Service Manual, Bulletin 4021540. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 006-061 in Section 6.

Replace the rail fuel pressure sensor.

Refer to Procedure 019-115 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault Code 449 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 559, 1117, 1911, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 5C

Guided Step 5C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine not running.
  • Connect INSITE™ electronic service tool.

Action

Clear inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 19-Apr-2012


FAULT CODE 449 - Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 449 active?
STEP 2. | Check the high-pressure fuel rail drain line restriction. |
 | STEP 2A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined Procedure 006-012?
STEP 3. | Inspect the fuel pressure relief valve. |
 | STEP 3A. Inspect the fuel pressure relief valve for tampering or wrong part number. | Was the correct fuel pressure relief valve part number installed and no tampering found?
STEP 4. | Inspect the rail fuel pressure sensor |
 | STEP 4A. Verify rail fuel pressure sensor accuracy. | Is the fuel rail pressure 0 +/- 43 bar [0 +/- 624 psi]?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 449 inactive?
 | STEP 5B. Check for active fault codes. | Fault Codes 559,1117, 1911, or 2311 active or high inactive counts?
 | STEP 5C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 is active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the high-pressure fuel rail drain line restriction.

Guided Step 2A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Inspect drain line from high pressure relief valve to OEM connection point for damage (obstructions, kinks, or crimps).

Check for excessive fuel drain line restriction.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Replace the drain line or repair the source of the high fuel drain line restriction.

Check for excessive fuel drain line restriction.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-012 in Section 6.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the fuel pressure relief valve.

Guided Step 3A - Inspect the fuel pressure relief valve for tampering or wrong part number.

Conditions

  • Engine is not running.

Action

Make sure the correct fuel pressure relief valve part number is installed.

  • Look for tampering of the fuel pressure relief valve.

Was the correct fuel pressure relief valve part number installed and no tampering found?
YES NO
No Repair

Repair the tampering or replace the fuel pressure relief valve.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-061 in Section 6.

Go to 4A

Go to 5A

Guided Step 4 - Inspect the rail fuel pressure sensor.

Guided Step 4A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • INSITE™ Monitor.
  • Fuel pressure relieved from the high-pressure fuel rail.
  • Engine not running.

Action

Make sure the correct sensor part number is installed in the high pressure fuel rail.

  • When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Once the engine is keyed off, there could be a significant amount of time waiting on the rail to depressurize to 0. It is necessary to manually relieve the pressure from the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail by loosening the pump-to-rail line at the rail.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-026 in Section 6.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure 0 +/- 43 bar [0 +/- 624 psi]?
YES NO

Replace the fuel pressure relief valve.

  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-061 in Section 6.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault Code 449 inactive?
YES NO
No Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 559, 1117, 1911, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 5C

Guided Step 5C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine not operating.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

  • Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 19-Apr-2012


FAULT CODE 451Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch® test lead,Part Number 3164110 - female Bosch® test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

Replace the damaged sensor. Refer to Procedure 019-115 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 is active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness.Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Apr-2012


FAULT CODE 452 - Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch® test lead, Part Number 3164110 - female Bosch® test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Clear the inactive fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 is inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 is active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or a pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Apr-2012


FAULT CODE 471 - Engine Oil Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 471 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault Code 471 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine oil temperature near ambient temperature.
  • Make sure the vehicle is parked on level ground.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 471 active?
YES NO

Low engine lubricating oil level has been detected.

Add engine lubricating oil to the engine.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 007-037 in Section 7.
  • Use the following proceudre in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 007-037 in Section 7.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 471 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 19-Apr-2012


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold temperature. |
 | STEP 1A. Use INSITE™ electronic service tool to monitor intake manifold temperature. | Does the INSITE™ electronic service tool temperature sensor reading correlate to a known value or a mechanical gauge?

Guided Step 1 - Monitor intake manifold temperature.

Guided Step 1A - Use INSITE™ electronic service tool to monitor intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the intake manifold temperature value.

  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the INSITE™ electronic service tool temperature sensor reading correlate to a known value or a mechanical gauge?
YES NO

  • For ISB CM2100 and CM2150 engines, reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS of the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.
  • For ISBe and ISDe CM2150 engines, reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS of the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597.
  • For QSB3.3 engines, reference the Intake Manifold Air Temperature Above Specification symptom tree in the B3.3 and QSB3.3 Series Engines Service Manual, Bulletin 4021540.
  • For ISC and ISL CM2150 engines, reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS of the ISC and ISL Engines CM2150 Service Manual, Bulletin 4021569.
  • For ISLe CM2150 engines, reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS of the ISLe CM2150 Service Manual, Bulletin 4021630.

Replace the intake manifold temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to the appropriate troubleshooting symptom tree.

Repair complete.

Last Modified: 23-Apr-2012


FAULT CODE 499 - Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 499 inactive?
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the oil level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the oil level sensor. | Damage found to the oil level sensor body or connector?
 | STEP 2C. Check the fault codes. | Fault Code 499 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 499 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 499 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the oil level sensor.

Guided Step 2A - Inspect the oil level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level

Action

Inspect the engine harness and oil level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the oil level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Remove the engine oil level sensor. Refer to Procedure 019-056 in Section 19.

Action

Inspect the lubricating oil level sensor for damage to the wiring or body.

  • Inspect the o-rings for damage.

Damage found to the oil level sensor body or connector?
YES NO

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 499 active?
YES NO

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 499 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 23-Apr-2012


FAULT CODE 528 - Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 528 inactive?
STEP 2. | Check the original equipment manufacturer (OEM) switch circuit. |
 | STEP 2A. Inspect the OEM switch. | Dirty or damaged pins?
 | STEP 2B. Check the OEM switch. | Alternate torque switch operating correctly?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 528 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 528 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 528 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the OEM switch circuit.

Guided Step 2A - Inspect the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Inspect the alternater torque switch and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Check the switch.

  • Check the functionality of the alternate torque switch. See equipment manufacturer service information.

Alternate torque switch operating correctly?
YES NO
No Repair

Replace the alternate torque switch. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF,
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Measure the resistance between the alternate torque switch pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the alternate torque switch circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the alternate torque switch pin in the OEM harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector alternate torque switch pin and the OEM harness alternate torque switch pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 528 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the problem.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 528 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 529 (QSB3.3) - Auxiliary Input/Output 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 529 inactive?
STEP 2. | Check the original equipment manufacturer (OEM) output control solenoid and circuit. |
 | STEP 2A. Inspect the OEM output control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the OEM output control solenoid. | Less than 10 ohms?
 | STEP 2C. Check the OEM output control solenoid diagnostic supply voltage, supply wire, and return circuit. | Greater than 3.75 volts of direct current (VDC)?
 | STEP 2D. Check for an open circuit in the OEM output control solenoid circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM output control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 529 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 529 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 529 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM output control solenoid and circuit.

Guided Step 2A - Inspect the OEM output control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Inspect the OEM output control solenoid and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the OEM output control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check the OEM output control solenoid resistance.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the OEM output control solenoid has been detected.

Replace the OEM output control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the OEM output control solenoid diagnostic supply voltage, supply wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the OEM output control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector of the OEM harness.

Use the circuit diagram or the wiring diagram for the connector pin identification.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the OEM output control solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM output control harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM output control solenoid RETURN pin in the engine harness and ground.

Use the circuit diagram or the wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the return wire has been detected.

Use the OEM wiring diagram for return wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the return wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the ECM and OEM harness.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM output control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM OEM output control solenoid SIGNAL pin and the OEM harness OEM output control solenoid connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open OEM control output solenoid SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the OEM output control solenoid SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 529 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 529 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 553 - Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 1117, or 2311 active or high inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Is the fuel rail pressure 0 ± 24 bar [0 ± 348 psi]?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 4. | Check the fuel pump actuator. |
 | STEP 4A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel pump actuator resistance. | Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
 | STEP 4C. Monitor the fuel rail pressure at idle. | Does Measured Fuel Rail Pressure deviate more than 200 bar [2901 psi] and surge at idle?
 | STEP 4D. Inspect the fuel pump actuator for damage. | Is the fuel pump actuator damaged?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault codes inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271, 272, 1117, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ electronic service tool Monitor.
  • Fuel pressure relieved from the high-pressure fuel rail.
  • Engine not running.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.
  • When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero. It may be necessary to manually relieve the pressure from the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-071 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 Service Manual, Bulletin 4021540. Refer to Procedure 006-060 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-071 in Section 6.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure 0 ± 24 bar [0 ± 348 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for excessive fuel drain line restriction.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 Service Manual, Bulletin 4021540. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 Service Manual, Bulletin 4021540. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-012 in Section 6.

Go to 4A

Go to 5A

Guided Step 4 - Check the fuel pump actuator.

Guided Step 4A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in Section 19.

Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor Commanded Fuel Rail Pressure and Measured Fuel Rail Pressure.

Does Measured Fuel Rail Pressure deviate more than 200 bar [2901 psi] and surge at idle?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 5A

Go to 4D

Guided Step 4D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in Section 19.

Is the fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that fault codes are inactive.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


FAULT CODE 553 - Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 1117, or 2311 active or high inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Is the fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 4. | Check the fuel pump actuator. |
 | STEP 4A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel pump actuator resistance. | Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
 | STEP 4C. Monitor the fuel rail pressure at idle. | Does Measured Fuel Rail Pressure deviate more than 200 bar [2901 psi] and surge at idle?
 | STEP 4D. Inspect the fuel pump actuator for damage. | Is the fuel pump actuator damaged?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault codes inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271, 272, 1117, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ electronic service tool Monitor.
  • Fuel pressure relieved from the high-pressure fuel rail.
  • Engine not running.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.
  • When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Once the engine is keyed off, there could be a significant amount of time waiting on the rail to depressurize to zero. It is necessary to manually relieve the pressure from the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-026 in Section 6.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for excessive fuel drain line restriction.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-012 in Section 6.

Go to 4A

Go to 5A

Guided Step 4 - Check the fuel pump actuator.

Guided Step 4A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in Section 19.

Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
YES NO
No Repair

Replace the fuel pump actuator.

Refer to Procedure 019-117 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor Commanded Fuel Rail Pressure and Measured Fuel Rail Pressure.

Does Measured Fuel Rail Pressure deviate more than 200 bar [2901 psi] and surge at idle?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 5A

Go to 4D

Guided Step 4D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in Section 19.

Is the fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that fault codes are inactive.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


FAULT CODE 554 - Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 451 and 452 | Fault Code 451 or 452 is active?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 451 active?
 | STEP 2C. Check the circuit response. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pin?
 | STEP 3B. Check the circuit response. | Fault Code 451 active?
 | STEP 3C. Check the circuit response. | Fault Code 452 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 554 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 451 and 452.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 or 452 is active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the rail fuel pressure SIGNAL pin and the rail fuel pressure RETURN pin at the rail fuel pressure connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active?
YES NO

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the rail fuel pressure SIGNAL pin and rail fuel pressure RETURN pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine.
  • Operate the engine under light load for 2 minutes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 554 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


FAULT CODE 555 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active or multiple inactive counts of Fault Code 555?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?
 | STEP 2B. Check mileage / hours on the crankcase ventilation filter since last maintenance. | Filter below the maintenance interval?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation valve. | Crankcase ventilation valve operating correctly?
 | STEP 2E. Inspect the crankcase ventilation oil drain tubes and check valves. | Oil drain tubes, breather tube (rear mount breather only), or check valves plugged?
 | STEP 2F. Inspect the crankcase ventilation hose. | Closed crankcase ventilation hose frozen or plugged?
STEP 3. | Check air intake restriction. |
 | STEP 3A. Check air intake restriction. | Air intake restriction measured within specification?
STEP 4. | Measure the crankcase blowby. |
 | STEP 4A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 555 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or multiple inactive counts of Fault Code 555?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • INSITE™ electronic service tool monitor.
  • Do not operate.

Action

Verify pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not running.
  • Monitor the crankcase ventilation pressure.
  • Use INSITE™ electronic service tool to measure pressure.

Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check mileage / hours on the crankcase ventilation filter since last maintenance.

Conditions

  • /Check maintenance record (miles / hours) of the latest crankcase ventilation filter replacement.

Action

Check mileage / hours on the crankcase ventilation filter since last maintenance.

Use the following procedure in the ISB CM2150 Operation and Maintenance Manual, Bulletin 4021602. Refer to Procedure 102-002 in Section 2.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase ventilation filter.

Use the following procedure from the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-021 in Section 3.

Go to 2C

Go to 5A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Replace the crankcase breather element.

Refer to Procedure 003-019 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation valve.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the closed crankcase ventilation valve operation.

Use the following procedure in the in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-023 in Section 3.

Crankcase ventilation valve operating correctly?
YES NO
No Repair

Correct or replace the crankcase ventilation valve.

Use the following procedure in the in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-023 in Section 3.

Go to 2E

Go to 5A

Guided Step 2E - Inspect the crankcase ventilation oil drain tubes and check valves.

Conditions

  • Turn keyswitch OFF.
  • Do not operate.

Action

Inspect the oil drain tubes, breather tube (rear mount breather only), and check valves for plugging.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-002 in Section 3.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-001 in Section 3.

Oil drain tubes, breather tube (rear mount breather only), or check valves plugged?

YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, or breather tube.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-002 in Section 3.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-001 in Section 3.

No Repair

Go to 5A

Go to 2F

Guided Step 2F - Inspect the crankcase ventilation hose.

Conditions

  • Turn keyswitch OFF.
  • Do not operate.

Action

Inspect the crankcase ventilation hose for a frozen or plugged condition.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-024 in Section 3.

Closed crankcase ventilation hose frozen or plugged?
YES NO

Clean, repair, or replace the crankcase ventilation hose.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-024 in Section 3.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check air intake restriction.

Guided Step 3A - Check air intake restriction.

Conditions

  • Engine running.

Action

Check for high air intake restriction.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-031 in Section 10.

Air intake restriction measured within specification?
YES NO
No Repair

Repair the air intake restriction.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-031 in Section 10.

Go to 4A

Go to 5A

Guided Step 4 - Measure the crankcase blowby.

Guided Step 4A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engine equipped with automatic transmissions only.

Action

Measure the crankcase blowby.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-010 in section 14.

Is the crankcase blowby measurement within specification?
YES NO

Replace the crankcase ventilation filter.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-021 in Section 3.

Troubleshoot the possible causes for excessive crankcase gases.

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS of the ISB CM2150 Service Manual, Bulletin 4021578.

Go to 5A

Repair complete.

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 555 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Jun-2013


FAULT CODE 555 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active or multiple inactive counts of Fault Code 555?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H2O)?
 | STEP 2B. Check mileage / hours on the crankcase breather filter since last maintenance. | Filter below the maintenance interval?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes and oil separator. | Oil drain tubes, check valves, breather tube, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 555 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or multiple inactive counts of Fault Code 555?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • INSITE™ electronic service tool Monitor.
  • Do not operate engine.

Action

Verify pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not running.
  • Monitor the crankcase pressure.
  • Use INSITE™ electronic service tool to measure crankcase pressure.

Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H2O)?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check mileage / hours on the crankcase breather filter since last maintenance.

Conditions

  • Maintenance record (miles / hours) of the latest crankcase breather filter replacement.

Action

Check mileage / hours on the crankcase breather filter since last maintenance.

  • Use the following procedure in the ISC and ISL CM2150 Operation and Maintenance Manual, Bulletin 4021579. Refer to Procedure 102-002 in Section 2.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase ventilation filter.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 003-019 in Section 3.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Replace the crankcase breather element.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 003-019 in Section 3.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

  • Refer to Procedure 003-001 in Section 3.
  • Refer to Procedure 003-018 in Section 3.

Oil drain tubes, check valves, breather tube, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

  • Refer to Procedure 003-001 in Section 3.
  • Refer to Procedure 003-018 in Section 3.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the Crankcase Blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engine equipped with automatic transmissions only.

Action

Measure the crankcase blowby.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-010 in section 14.

Crankcase blowby measurement within specification?
YES NO

Replace the crankcase ventilation filter.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 003-019 in Section 3.

Troubleshoot the possible causes for excessive crankcase gases.

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS of the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

Go to 4A

Repair complete.

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 555 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 2A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Feb-2014


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active or multiple inactive counts of Fault Code 556?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G (0 ± 1.13 in H2O)?
 | STEP 2B. Check mileage / hours on the crankcase ventilation filter since last maintenance. | Filter below the maintenance interval?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation valve. | Crankcase ventilation valve operating correctly?
 | STEP 2E. Inspect the crankcase ventilation oil drain tubes and check valves. | Oil drain tubes, breather tube (rear mount breather only), or check valves plugged?
 | STEP 2F. Inspect the crankcase ventilation hose. | Closed crankcase ventilation hose frozen or plugged?
STEP 3. | Check air intake restriction. |
 | STEP 3A. Check air intake restriction. | Air intake restriction measured within specification?
STEP 4. | Measure the crankcase blowby. |
 | STEP 4A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 5. | Clear the fault code and check for progressive damage. |
 | STEP 5A. Disable the fault code. | Fault Code 556 inactive?
 | STEP 5B. Check for progressive damage. | Progressive damage found due to high crankcase pressure?
 | STEP 5C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or multiple inactive counts of Fault Code 556?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Connect INSITE™ electronic service tool monitor.
  • Do not operate the engine.

Action

Verify pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Monitor the crankcase ventilation pressure.
  • Use INSITE™ electronic service tool to measure pressure.

Pressure reading 0 ± 0.28 kPa - G (0 ± 1.13 in H2O)?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check mileage / hours on the crankcase ventilation filter since last maintenance.

Conditions

  • Check the maintenance record (miles / hours) for the latest crankcase ventilation filter replacement.

Action

Check mileage / hours on the crankcase ventilation filter since last maintenance.

Use the following procedure in the ISB CM2150 Operation and Maintenance Manual, Bulletin 4021602. Refer to Procedure 102-002 in Section 2.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase ventilation filter. Use the following procedure from the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-021 in Section 3.

Go to 2C

Go to 5A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Replace the crankcase breather element.

Use the following procedure from the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-021 in Section 3.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation valve.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the closed crankcase ventilation valve operation.

Use the following procedure in the in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-023 in Section 3.

Crankcase ventilation valve operating correctly?
YES NO
No Repair

Correct or replace the crankcase ventilation valve.

Use the following procedure in the in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-023 in Section 3.

Go to 2E

Go to 5A

Guided Step 2E - Inspect the crankcase ventilation oil drain tubes and check valves.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the oil drain tubes, breather tube (rear mount breather only), and check valves for plugging.

Use the following procedures in the ISB CM2150 Service Manual, Bulletin 4021578.

  • Refer to Procedure 003-002 in Section 3.
  • Refer to Procedure 003-018 in Section 3.

Oil drain tubes, breather tube (rear mount breather only), or check valves plugged?

YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves or breather tube. Use the following procedures in the ISB CM2150 Service Manual, Bulletin 4021578.

  • Refer to Procedure 003-002 in Section 3.
  • Refer to Procedure 003-018 in Section 3.

No Repair

Go to 5A

Go to 2F

Guided Step 2F - Inspect the crankcase ventilation hose.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the crankcase ventilation hose for plugging.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-024 in Section 3.

Closed crankcase ventilation hose frozen or plugged?
YES NO

Clean, repair, or replace the crankcase ventilation hose.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-024 in Section 3.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check air intake restriction.

Guided Step 3A - Check air intake restriction.

Conditions

  • Operate the engine.

Action

Check for high air intake restriction.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-031 in Section 10.

Air intake restriction measured within specification?
YES NO
No Repair

Repair the air intake restriction.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-031 in Section 10.

Go to 4A

Go to 5A

Guided Step 4 - Measure the crankcase blowby.

Guided Step 4A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engine equipped with automatic transmissions only.

NOTE: It may be necessary to disable the fault code in order to operate the engine at rated speed. Use INSITE™ electronic service tool to verify the fault code is inactive.

Action

Measure the crankcase blowby.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-010 in section 14.

Crankcase blowby measurement within specification?
YES NO

Replace the crankcase ventilation filter. Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 003-021 in Section 3.

Troubleshoot the possible causes for excessive crankcase gases.

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS of the ISB CM2150 Service Manual, Bulletin 4021578.

Go to 5A

Repair complete.

Guided Step 5 - Clear the fault code and check for progressive damage.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 556 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 2A

Guided Step 5B - Check for progressive damage.

Action

Check for progressive damage:

  • Check for progressive damage to the engine due to high crankcase pressure.
  • Check for oil leaking from gaskets and seals.

Progressive damage found due to high crankcase pressure?
YES NO

Replace the gasket, seal, or other damaged component. Reference the ISB CM2150 Service Manual, Bulletin 4021578.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 5C

Guided Step 5C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot and remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 06-May-2013


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active or multiple inactive counts of Fault Code 556?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ±0.28 kPa - G [0 ±1.13 in H2O]?
 | STEP 2B. Check mileage/hours on the crankcase breather filter since last maintenance. | Filter below the maintenance interval?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, check valves, breather tubes, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Clear the fault code and check for progressive damage. |
 | STEP 4A. Disable the fault code. | Fault Code 556 inactive?
 | STEP 4B. Check for progressive damage. | Progressive damage found due to high crankcase pressure?
 | STEP 4C. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or multiple inactive counts of Fault Code 556?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Use INSITE™ electronic service tool Monitor.
  • Do not operate engine.

Action

Verify pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Monitor the crankcase pressure.
  • Use INSITE™ electronic service tool to measure crankcase pressure.

Pressure reading 0 ±0.28 kPa - G [0 ±1.13 in H2O]?

YES NO
No Repair

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check mileage/hours on the crankcase breather filter since last maintenance.

Conditions

  • Check the maintenance record (miles/hours) for the latest crankcase breather filter replacement.

Action

Check mileage/hours on the crankcase breather filter since last maintenance.

  • Use the following procedure in the ISC and ISL CM2150 Operation and Maintenance Manual, Bulletin 4021579. Refer to Procedure 102-002 in Section 2.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase ventilation filter.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 003-019 in Section 3.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Replace the crankcase breather element.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 003-019 in Section 3.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

  • Refer to Procedure 003-001 in Section 3.
  • Refer to Procedure 003-018 in Section 3.

Oil drain tubes, check valves, breather tubes, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tubes, or oil separator.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

  • Refer to Procedure 003-001 in Section 3.
  • Refer to Procedure 003-018 in Section 3.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the crankcase blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engine equipped with automatic transmissions only.

It can be necessary to disable the fault code in order to operate the engine at rated speed. Use INSITE™ electronic service tool to verify the fault code is inactive.

Action

Measure the crankcase blowby.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-010 in Section 14.

Crankcase blowby measurement within specification?
YES NO

Replace the crankcase ventilation filter.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 003-019 in Section 3.

Troubleshoot the possible causes for excessive crankcase gases.

See the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS of the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

Go to 4A

Repair complete.

Guided Step 4 - Clear the fault code and check for progressive damage.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 556 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 2A

Guided Step 4B - Check for progressive damage.

Action

Check for progressive damage:

  • Check for progressive damage to the engine due to the high crankcase pressure.
  • Check for oil leaking from gaskets and seals.

See the ISC and ISL CM2150 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

Progressive damage found due to high crankcase pressure?
YES NO

Replace the damaged gasket, seal, or other component.

 No Repair

Go to the appropriate troubleshooting steps.

Go to 4C

Guided Step 4C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 559 (ISB) - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 281, 449, 1117, 1911, or 2311 active or high inactive counts?
 | STEP 1B. Check for active Fault Code 559. | Fault Code 559 active?
STEP 2. | Perform preliminary fuel system checks. |
 | STEP 2A. Check for adequate fuel supply. | Equipment/vehicle has an adequate fuel supply?
 | STEP 2B. Inspect for external fuel leaks. | Fuel leaks present?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Inspect for external fuel leaks. | Fuel leaks present?
 | STEP 3B. Check for air in the fuel. | Air in the fuel?
 | STEP 3C. Check fuel pressure at the fuel filter outlet. | Fuel filter outlet pressure within specifications?
 | STEP 3C-1. Check the fuel filter pressure drop. |
 | STEP 3C-2. Check the fuel inlet restriction. |
STEP 4. | Check the high-pressure fuel system. |
 | STEP 4A. Check the injector return flow. | Injector return flow within specifications?
 | STEP 4B. Check high-pressure fuel pump return flow. | Fuel return flow within specifications?
 | STEP 4C. Measure the high-pressure fuel rail return flow. | Fuel return flow within specifications?
 | STEP 4D. Inspect the fuel pressure relief valve for tampering or wrong part number. | Correct fuel pressure relief valve part number installed and no tampering found?
 | STEP 4E. Perform High-Pressure Injection Pump Flow Test. | Fuel pump flow within specifications?
 | STEP 4E-1. Check the drain line restriction. |
STEP 5. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 281, 449, 1117, 1911, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active Fault Code 559.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 559 active?
YES NO
No Repair

Treat the situation as if Fault Code 559 is active.

Go to 2A

Go to 2A

Guided Step 2 - Perform preliminary fuel system checks.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn keyswitch OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle's fuel gauge. Verify there is fuel in the tank.
  • Check the equipment/vehicle fuel gauge.
  • Inspect the fuel tank if there is any doubt about the accuracy of the fuel gauge.

Equipment/vehicle has an adequate fuel supply?
YES NO
No Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 2B

Go to 5A

Guided Step 2B - Inspect for external fuel leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for external fuel leaks.

  • Check for fuel leaking from loose fuel fittings, damaged fuel lines, and/or damaged components.

Fuel leaks present?
YES NO

Repair the fuel leak.

  • Reference the ISB CM2150 Service Manual, Bulletin 4021578.
  • Reference the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540.
  • Reference the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Inspect for external fuel leaks.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

This test can not be performed if the engine will not start. If the engine will not start, proceed to the next step.

Action

Check for external fuel leaks.

  • Start the engine and allow it to idle.
  • Check for fuel leaking from loose fuel fittings, damaged fuel lines, and/or damaged components.

Fuel leaks present?
YES NO

Repair the fuel leak.

  • Reference the ISB CM2150 Service Manual, Bulletin 4021578.
  • Reference the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540.
  • Reference the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

This test can not be performed if the engine will not start. If the engine will not start, proceed to the next step.

Action

Check for air in the fuel.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-003 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-003 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-003 in Section 6.

Air in the fuel?
YES NO

A few bubbles exiting the line during the test is expected.

A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry can be isolated to one of the following locations:

  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipes in the fuel tank(s).

Check the fuel inlet restriction.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-020 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-020 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-020 in Section 6.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the fuel pressure at the fuel filter outlet.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

This test can be performed if the engine will not start. If the engine will not start, perform the test while cranking the engine.

Action

Check the fuel pressure at the outlet of the fuel filter.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 006-015 in Section 6.

Fuel filter outlet pressure within specifications?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the fuel filter pressure drop.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

This test can be performed if the engine will not start. If the engine will not start, perform the test while cranking the engine.

Action

Check the fuel pressure drop across the filter.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 006-015 in Section 6.

Fuel pressure drop within specifications?
YES NO
No Repair

Make sure the fuel pump pressure into the filter is within specification.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 005-016 in Section 5.

If the pump is OK, replace the fuel filter and prime the fuel system. See the appropriate procedure.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-015 in Section 6.

Go to 3C-2

Go to 5A

Guided Step 3C-2 - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

This test can not be performed if the engine will not start. If the engine will not start, replace the fuel pump and proceed to Step 5A.

Action

Check the fuel inlet restriction.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-020 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-020 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction within specifications?
YES NO

Replace the fuel pump.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 005-016 in Section 5.

If inlet restriction is excessive, look for the root cause:

  • Suction side fuel filters plugged
  • Fuel heater valves are restricted
  • OEM fuel lines pinched or restricted
  • Fuel tank stand pipes restricted.

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic, paper, etc.) that could intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that could intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers or filters, or malfunctioning check valves.

If no issues are found, replace the suction side fuel filter and prime the fuel system.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-015 in Section 6.

Go to 5A

Go to 5A

Guided Step 4 - Check the high-pressure fuel system.

Guided Step 4A - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Operate engine at idle.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

This test can be performed if the engine will not start.

If the engine will not start, perform this test while cranking the engine without using the INSITE™ electronic service tool Fuel System Leakage Test.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-026 in Section 6.

Injector return flow within specifications?
YES NO
No Repair

Replace the injector of the cylinder that is contributing to the high return flow. For ISB CM800, CM850, CM2150, CM2150 SN, CM2250 and QSB CM850 and CM2250 engines, inspect the high pressure connector for damage and only replace the high pressure connector, if necessary.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-026 in Section 6. Refer to Procedure 006-052 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-026 in Section 6. Refer to Procedure 006-052 in Section 6.

Go to 4B

Go to 5A

Guided Step 4B - High-pressure fuel pump return flow.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Connect INSITE™ electronic service tool.
  • Make sure the Fuel System Leakage Test is active, if applicable.

This test can not be performed if the engine will not start.

If the engine will not start, proceed to the next step.

Action

Check for excessive fuel return from the high-pressure fuel pump.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 005-016 in Section 5.

Fuel return flow within specifications?
YES NO
No Repair

Replace the high-pressure fuel pump.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 005-016 in Section 5.

Go to 4C

Go to 5A

Guided Step 4C - Measure the high-pressure fuel rail return flow.

Conditions

  • Turn keyswitch ON.
  • Operate engine at idle.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test active, if available.

This test can not be performed if the engine will not start.

If the engine will not start proceed to the next step.

Action

Check for excessive fuel return from the high-pressure fuel rail.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-061 in Section 6.

Fuel return flow within specifications?
YES NO
No Repair

  • Replace the rail fuel pressure relief valve.
  • Determine the reason the fuel rail pressure relief valve has been tripping. Failure to do this could result in repeat malfunctions.

Examples:

  • Operation with the electronic fuel control valve unplugged.
  • Operation with a plugged fuel filter or excessive inlet restriction.

Measure the fuel rail drain flow.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-061 in Section 6.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the fuel pressure relief valve for tampering or wrong part number.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the correct fuel pressure relief valve part number is installed.

  • Look for tampering of the fuel pressure relief valve.

Was the correct fuel pressure relief valve part number installed and no tampering found?
YES NO
No Repair

Repair the tampering or replace the fuel pressure relief valve.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-061 in Section 6.

Go to 4E

Go to 5A

Guided Step 4E - Perform High-Pressure Injection Pump Flow Test.

Conditions

  • Turn keyswitch ON.
  • Crank engine.

Action

Check the high-pressure injection pump fuel flow.

Disconnect the high-pressure fuel line to the fuel rail from the high-pressure injection pump.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-071 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-071 in Section 6.

Check the high-pressure injection pump fuel flow.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 005-016 in Section 5.

Fuel pump flow within specifications?
YES NO
No Repair

Check drain line restriction.

Go to 5A

Go to 4E-1

Guided Step 4E-1 - Check the drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

If the engine will not start, crank the engine to perform this test.

Action

Check for excessive fuel drain line restriction.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150, Service Manual, Bulletin 4021597. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction within specifications?
YES NO

  • If these checks are acceptable, replace the fuel pump actuator; follow the torque sequence. Refer to Procedure 019-117 in Section 19.

After replacing the fuel pump actuator, measure the fuel pump flow again. If the flow is not within specification, replace the high-pressure fuel pump.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 005-016 in Section 5.

Repair the source of the high fuel drain line restriction.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the B3.3 and QSB3.3 CM2150 Service Manual, Bulletin 4021540. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISBe and ISDe CM2150 Service Manual, Bulletin 4021597. Refer to Procedure 006-012 in Section 6.

Go to 5A

Go to 4E

Guided Step 5 - Check the ECM calibration and clear the fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Nov-2012


FAULT CODE 559 - ISC and ISL - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 271, 272, 322, 323, 324, 325, 331, 332, 352, 449, 451, 452, 1117, 1911, or 2311 active or inactive counts?
 | STEP 1B. Check for Fault Code 559. | Active or inactive counts of Fault Code 559 present in the engine control module (ECM)?
 | STEP 1C. Check for adequate fuel supply. | Equipment/vehicle has adequate fuel supply?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Perform the low-pressure system check. | Engine passes the low-pressure system check?
 | STEP 2B. Check the fuel pump actuator condition. | Engine surges at idle and measured rail fuel pressure varies from the commanded fuel rail pressure by more than 100 bar [1450 psi] at idle?
STEP 3. | Check the high-pressure fuel system. |
 | STEP 3A. Check the injector return flow. | Injector return flow within the specifications outlined in the appropriate procedure?
 | STEP 3A-1. Check the high-pressure connector torque. |
 | STEP 3A-2. Check for individual leaking injectors. |
 | STEP 3B. Measure the high-pressure fuel rail return flow. | Fuel return flow within specifications outlined in the appropriate procedure?
STEP 4. | Check the fuel pump head. |
 | STEP 4A. Check the high-pressure fuel pump return flow. | Fuel return flow within the specifications outlined in the appropriate procedure?
STEP 5. | Symptom based troubleshooting. |
 | STEP 5A. Engine is difficult to start or will not start. | Engine difficult to start or does not start?
 | STEP 5A-1. Check the injector return flow. |
 | STEP 5A-2. Check the high-pressure connector torque. |
 | STEP 5A-3. Check for individual leaking injectors. |
 | STEP 5A-4. Measure the high-pressure fuel rail return flow. |
 | STEP 5A-5. Inspect the fuel tank for debris. |
 | STEP 5B. Engine starts and stalls. | Engine shuts down or stalls?
 | STEP 5C. Road test unit. | Fault Code 559 becomes active during the road test?
 | STEP 5D. Fault Code 559 becomes active during motoring. | Fault Code 559 becomes active during engine motoring?
 | STEP 5D-1. Check for drain line restriction. |
 | STEP 5E. Inspect the fuel tank for debris. | Debris present in the fuel tank?
 | STEP 5F. Inspect the ECM cooling plate check valve. | Check valve operates properly?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271, 272, 322, 323, 324, 325, 331, 332, 352, 449, 451, 452, 1117, 1911, or 2311 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 559.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active or inactive Fault Code 559.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 559 present in the ECM?
YES | NO
No Repair | No Repair

Go to 1C

Repair complete.

Guided Step 1C - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn keyswitch OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle fuel gauge.
  • Verify there is fuel in the tank above the suction line.
  • Check the equipment/vehicle fuel gauge.

Equipment/vehicle has adequate fuel supply?
YES | NO
No Repair | No Repair

Go to 2A

Go to 6A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Perform the low-pressure system check.

Conditions

  • Turn keyswitch ON.
  • Operate engine or engine not operating.

If the engine will start, make certain the engine is at operating temperature before performing the test.

Action

Perform the low-pressure system check.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-236 in Section 5.

Engine Operating

  • Measure the inlet restriction.
  • Check for air in the fuel.
  • Measure the gear pump pressure.
  • Measure the pressure drop at the fuel filter.

If the engine is difficult to start, measure the lift pump fuel flow.

Engine Not Operating

  • Make sure the fuel system is primed.
  • Measure the lift pump flow.
  • Measure the gear pump pressure at cranking.

Engine passes the low-pressure system check?
YES NO

For ISLe CM2150 engines, go to Step 3A.

Repair or replace the malfunctioning low-pressure system component, as necessary. Perform the low-pressure system check again to verify the issue has been corrected.

Operate engine: repair order priority:

  • Inlet restriction
  • Air in fuel
  • Fuel filter
  • Gear pump.

Engine Not Operating: repair order priority:

  • System is primed
  • Lift pump
  • Gear pump.

Go to 2B

Go to 6A

Guided Step 2B - Check the fuel pump actuator condition.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Connect INSITE™ electronic service tool.
  • Place INSITE™ electronic service tool in Monitor Mode.

This test can not be performed if the engine does not start. If the engine does not start, skip this step and proceed to Step 4A.

Action

Use INSITE™ electronic service tool to monitor the fuel rail pressure for 60 seconds.

  • Observe the commanded and measured rail pressure.

Pressure instability at idle due to a worn fuel pump actuator may be more repeatable when the engine is cold.

Engine surges at idle and measured rail fuel pressure varies from the commanded fuel rail pressure by more than 100 bar [1450 psi] at idle?

YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the high-pressure fuel system.

Guided Step 3A - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Make sure the engine is at operating temperature before performing the test.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-026 in Section 6.

Injector return flow within the specifications outlined in the appropriate procedure?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Check the high-pressure connector torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high-pressure connector torque.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. 006-052 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. 006-052 in Section 6.

Injector pressure connector torque meets specification outlined in the appropriate procedure?
YES NO
No Repair

Tighten the injector high-pressure connector.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-052 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-052 in Section 6.

Check the injector return flow again. Go back to Step 3A.

If the injector return flow is now within specification, go to Step 6A.

If the injector return flow is still high, proceed to the next step below.

Go to 3A-2

Go to 3A-2

Guided Step 3A-2 - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Make certain the engine is at operating temperature before performing the test.

Action

Check for fuel leaks at individual injectors.

Cap off each injector, one at a time, with the injector leakage isolation tool. The service tool must be installed with the engine OFF.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-026 in Section 6.

Fuel injector return flow within specifications outlined in the appropriate procedure with an injector capped off?
YES NO

Replace the high-pressure connector and injector for the cylinder causing the high injector return flow.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-026 in Section 6.

Cap off additional injectors to identify the source of high injector return flow. Replace the high-pressure connector and injector for the cylinder(s) causing the high injector return flow.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-026 in Section 6.

Go to 6A

Go to 6A

Guided Step 3B - Measure the high-pressure fuel rail return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

Make certain the engine is at operating temperature before performing the test.

Action

Check for excessive fuel return from the high-pressure fuel rail.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-061 in Section 6.

Fuel return flow within specifications outlined in the appropriate procedure?
YES NO
No Repair

Replace the fuel rail pressure relief valve.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-061 in Section 6.

Determine the reason the fuel rail pressure relief valve is leaking.

Examples:

  • Operation with the electronic fuel control valve unplugged.
  • Operation with a plugged fuel filter or excessive inlet restriction.

Go to 4A

Go to 6A

Guided Step 4 - Check the fuel pump head.

Guided Step 4A - Check the high-pressure fuel pump return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test ACTIVE, if available.

This test can be performed if the engine will not start. If the engine will not start, perform this test while cranking the engine.

If the engine will start, make certain the engine is at operating temperature before performing the test.

Action

Check for excessive fuel return from the high-pressure fuel pump.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-227 in Section 5.

Fuel return flow within the specifications outlined in the appropriate procedure?
YES NO
No Repair

Replace the high-pressure fuel pump head.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-227 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-227 in Section 5.

While the fuel pump head is removed, inspect the camshaft housing for internal damage.

Go to 5A

Go to 6A

Guided Step 5 - Symptom based troubleshooting.

Guided Step 5A - Engine is difficult to start or will not start.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Attempt to start the engine.

Engine difficult to start or does not start?

YES | NO
No Repair | No Repair

Go to 5A-1

Go to 5B

Guided Step 5A-1 - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

This test can be performed if the engine will not start. If the engine will not start, perform this test while cranking the engine.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-026 in Section 6.

Injector return flow within specifications outlined in the appropriate procedure?
YES | NO
No Repair | No Repair

Go to 5A-4

Go to 5A-2

Guided Step 5A-2 - Check the high-pressure connector torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high-pressure connector torque.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-052 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-052 in Section 6.

Injector pressure connector torque meets the specifications outlined in Procedure 006-052 in Section 6?
YES NO
No Repair

Tighten the injector high-pressure connector.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-052 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-052 in Section 6.

Check the injector return flow again.

If the injector return flow is within specification, proceed to Step 6A.

Go to 5A-3

Go to 5A-3

Guided Step 5A-3 - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test ACTIVE, if available.

This test can be performed if the engine will not start. If the engine will not start, perform this test while cranking the engine.

Action

Check for fuel leaks at individual injectors.

Cap off each injector, one at a time, with the injector leakage isolation tool. The service tool must be installed with the engine OFF.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-026 in Section 6.

Fuel injector return flow within specifications outlined in the appropriate procedure?
YES NO

Replace the high-pressure connector and injector for the cylinder that is causing the high injector return flow.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-026 in Section 6.

Cap off additional injectors to identify the source of high injector return flow. Replace the high-pressure connector and injector for the cylinder(s) causing the high injector return flow.

Replace the injector(s).

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-026 in Section 6.

Replace the fuel connector(s).

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-052 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-052 in Section 6.

Go to 6A

Go to 6A

Guided Step 5A-4 - Measure the high-pressure fuel rail return flow.

Conditions

  • Turn keyswitch ON.
  • Idle engine at operating temperature.
  • Perform INSITE™ electronic service tool Fuel System Leakage Test.

This test can be performed if the engine will not start. If the engine will not start, perform this test while cranking the engine.

Action

Check for excessive fuel return from the high-pressure fuel rail.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-061 in Section 6.

Fuel return flow within specifications outlined in the appropriate procedure?
YES NO
No Repair

Replace the rail fuel pressure relief valve.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-061 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-061 in Section 6.

Determine the reason the fuel rail pressure relief valve has been tripping.

Examples:

  • Operation with the electronic fuel control valve unplugged
  • Operation with a plugged fuel filter or excessive inlet restriction.

Go to 5A-5

Go to 6A

Guided Step 5A-5 - Inspect the fuel tank for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel tank for sources of intermittent fuel inlet restrictions, such as:

  • Shop rags
  • Sand
  • Cardboard
  • Plastic bags
  • Other debris.

Debris present in the fuel tank?
YES NO

Remove the fuel tank and clean out all debris.

Inspect the low-pressure fuel lines and low-pressure filter for debris.

Troubleshooting tree has been exhausted.

Review the Shop Talk section and/or go to the Engine Performance troubleshooting symptom tree in Section TS for further troubleshooting assistance.

Go to 6A

Go to the Engine Performance troubleshooting symptom tree in Section TS.

Guided Step 5B - Engine starts and stalls.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Start the engine.

  • Start the engine. Allow it to operate at idle for 1 minute.

Engine shuts down or stalls?
YES NO

If the engine shuts down or stalls within 15 seconds of startup, prime the fuel system and attempt to start the engine again. If the engine continues to shut down or stall within 15 seconds of startup, go to the Engine Starts But Will Not Keep Running troubleshooting symptom tree in Section TS for further repair direction.

If the engine shuts down or stalls more than 30 seconds after startup, replace the ECM cooling plate check valve.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-024 in Section 6.

No Repair

Go to 5C

Go to 6A

Guided Step 5C - Road test unit.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Road test the unit until the CHECK ENGINE light turns ON or for a maximum of 30 minutes.

Make sure the unit is driven under load for at least 10 consecutive seconds during the road test.

  • Hard accelerations
  • Drive unit up a hill
  • Pull a trailer or load (if possible)

Make sure the unit is driven under motoring for at least 10 consecutive seconds during the road test.

  • Get the unit up to highway speed, remove foot from throttle pedal, and allow the unit to coast for at least 10 seconds.
  • Drive the unit down a hill, remove foot from throttle pedal, and allow the unit to coast for at least 10 seconds.

Make a note of the engine operating conditions when the CHECK ENGINE light turns ON.

Fault Code 559 becomes active during the road test?
YES NO
No Repair

Troubleshooting tree has been exhausted.

Go to 5D

Go to 6A

Guided Step 5D - Fault Code 559 becomes active during motoring.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for Fault Code 559.

Use observations from previous road test.

Fault Code 559 becomes active during engine motoring?
YES | NO
No Repair | No Repair

Go to 5D-1

Go to 5E

Guided Step 5D-1 - Check for drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine at rated speed and at operating temperature.

Action

Operate the engine at rated speed and no load.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-012 in Section 6.

Drain line restriction within specification?
YES NO

Replace the fuel pump actuator housing.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-228 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-228 in Section 5.

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Correct the root cause of the fuel drain line restriction.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-012 in Section 6.

Go to 6A

Go to 6A

Guided Step 5E - Inspect the fuel tank for debris.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel tank for sources of intermittent fuel inlet restrictions such as:

  • Shop rags
  • Sand
  • Cardboard
  • Plastic bags
  • Other debris.

Debris present in the fuel tank?
YES NO

Remove the fuel tank and clean out all debris.

Inspect the low-pressure fuel lines, low-pressure filter, low-pressure filter head, and ECM cooling plate connections for debris.

No Repair

Go to 6A

Go to 5F

Guided Step 5F - Inspect the ECM cooling plate check valve.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM cooling plate check valve.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-024 in Section 6.

Check valve operates properly?
YES NO
No Repair

Replace the ECM cooling plate check valve.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-006 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-006 in Section 6.

Go to 5C

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2015


FAULT CODE 584 - Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 584 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10k ohms?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 584 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin.

Use the OEM wiring diagram for starter relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Replace the starter lockout relay.

See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector to ground.

Use the OEM wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

If the RETURN is wired to the ECM, repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 584 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 585 - Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check starter lockout relay and circuit. |
 | STEP 2A. Inspect starter relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the starter lockout relay resistance. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the starter lockout relay. |
 | STEP 2C. Check the starter lockout relay diagnostic supply voltage, supply line and return circuit. | Greater than 3.75 volts of direct current (VDC)?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 585 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 585 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check starter lockout relay and circuit.

Guided Step 2A - Inspect starter relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the relay resistance.

  • Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the starter lockout relay.

See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the starter lockout relay diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 585 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 596 - Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Are the voltages at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
STEP 2. | Check the charging system. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 596 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.

Are the voltages at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
YES NO
No Repair

Charge or replace the battery. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it run for 10 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 596 is inactive.

Fault Code 596 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 25-Apr-2012


FAULT CODE 597 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use these test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Battery voltage at least (+) 12 volts of direct current (VDC) under normal conditions and at least (+) 6.2 VDC during cranking?
STEP 2. | Check the alternator and power harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
 | STEP 2B. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit. | More than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Dirty or damaged wires?
 | STEP 2E. Check for a pin-to-pin short circuit in the power harness. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 597 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections. Clean the battery terminals.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal. Touch the negative (-) probe of the multimeter to the negative battery terminal while trying to start the engine.

Battery voltage at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and power harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator charging rate (amps).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the engine control module (ECM) connector.
  • Disconnect the positive battery cable from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins of the OEM power harness ECM connector and the positive (+) battery terminal.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the battery harness. See equipment manufacturer service information.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM connector.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins and the ECM battery SUPPLY (-) pins of the ECM power harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit in the supply wire to the engine block.

Any damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM Battery SUPPLY (+) pins in the OEM power harness connector to all pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resisance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it run for 10 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 597 is inactive.

Fault Code 597 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 598 - Electrical Charging System Voltage - Data Valid But Below Normal Operatiing Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Voltages at least (+) 12 volts of direct current (VDC) during normal conditions and at least (+) 6.2 VDC during cranking?
STEP 2. | Check the alternator and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
 | STEP 2B. Inspect the battery power connector. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the power harness. | More than 100k ohms?
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Dirty or damaged wires?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 598 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections. Clean the battery terminals.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.

Voltages at least (+) 12 VDC during normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and OEM harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the battery at the power connector.

Action

Inspect the battery power connector on both the battery side and the harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the battery power connector.

See equipment manufacturer service information for location and procedure.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the engine control module (ECM) connector.

Action

Check for an open circuit.

  • Measure the resistance of the ECM battery supply (+) circuit between the OEM power harness connector and the positive (+) terminal of the battery.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM connector.
  • Disconnect the positive battery cable from the battery.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the ECM battery supply (+) pins and all other pins of the power harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resisance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit at the supply wire to the engine block ground.

Damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it run for 10 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 598 is inactive.

Fault Code 598 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 599 (QSB3.3) - Auxiliary Commanded Dual Output Shutdown - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 599. | Active or inactive counts of Fault Code 599?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 599.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 599?
YES NO

The engine protection limit for the OEM supplied auxiliary device has been exceeded.

Refer to the OEM service manual.

 No Repair

OEM troubleshooting and repair manual.

Repair complete.

Last Modified: 25-Apr-2012


FAULT CODE 649 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 649. | Fault Code 649 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 649 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 649.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 649.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 649 active?
YES NO

Change the engine lubricating oil and filter.

Use INSITE™ electronic service tool to reset the Maintenance Monitor.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to reset the Maintenance Monitor.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

The Maintenance Monitor can also be reset manually.

Fault Code 649 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-May-2012


FAULT CODE 686 - Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for intermittent fault condition. |
 | STEP 1A. Operate the engine at idle and high idle to check for fault activation. | Fault Code 686 active during engine operation?
STEP 2. | Check for a malfuntioned turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Is the connector or pigtail harness damaged?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Resistance within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code reoccurs. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Fault Code 686 active during engine operation?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 686 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for intermittent fault condition.

Guided Step 1A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool and clear inactive fault codes.
  • Start the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Action

Check for fault activation.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

Does Fault Code 686 come active during engine operation?
YES NO
No Repair

An intermittent fault condition exists. The problem can possibly be with the turbocharger speed sensor circuit; however, the intermittent fault condition can possibly be due to electrical noise that is caused by other devices or damaged grounds.

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check for a failed turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure general inspection techniques. Refer to Procedure 019-361 in Section 19.

Is the connector or pigtail harness damaged?
YES NO

Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check the sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure general resistance measurement. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the turbocharger speed RETURN (-) pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

The resistance of the turbocharger speed sensor circuit must not be more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Use the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector. Otherwise, there is a low resistance (short) across the sensor input pins.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed RETURN (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short between pins of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Does Fault Code 686 come active during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

An intermittent fault condition exists. The problem may exist in the turbocharger speed sensor circuit or it may exist with other vehicle electronic components. The problem may have been corrected when the harness connections were re-engaged.

Make sure that the ECM and chassis grounds are in good condition.

Go to 5A

Refer to Procedure 019-362 in Section 19.

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Fault Code 686 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-May-2012


FAULT CODE 687 - Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Codes 122, 123, 221, or 222 active?
STEP 2. | Check for an intermittent fault condition. |
 | STEP 2A. Operate the engine and confirm that the turbocharger speed fault becomes active. | Fault Code 687 becomes active during engine operation?
STEP 3. | Check for a damaged turbocharger speed sensor. |
 | STEP 3A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 3B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
 | STEP 3C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the turbocharger speed sensor circuit continuity. | Continuity within 10 ohms of sensor resistance?
 | STEP 4C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 5. | Check the alternator. |
 | STEP 5A. Check the alternator for electrical interference. | Fault Code 687 becomes inactive with the alternator belt disconnected?
STEP 6. | Check the calibration and the ECM . |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Connect all components and determine if the fault code reoccurs. | Fault Code 687 becomes active during engine operation?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Read the fault codes with INSITE™ electronic service tool.

Fault Codes 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check for an intermittent fault condition.

Guided Step 2A - Operate the engine and confirm that the turbocharger speed fault becomes active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle.
  • Use INSITE™ electronic service tool to read the fault codes.

This step is valid even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 687 becomes active during engine operation?
YES NO
No Repair

An intermittent fault condition exists.

Go to 3A

Refer to Procedure 019-362 in Section 19

Guided Step 3 - Check for a damaged turbocharger speed sensor.

Guided Step 3A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-218 in Section 19.
  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

No Repair

Go to 7A

Go to 3B

Guided Step 3B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

The turbocharger speed sensor circuit resistance should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 3B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Continuity within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

  • Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except turbocharger speed SIGNAL (-) pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Inspect the engine harness for a short between two pins.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the alternator.

Guided Step 5A - Check the alternator for electrical interference.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the alternator belt from the alternator.
  • Connect all electrical connectors.
  • Turn keyswitch ON.
  • Start the engine.

Action

Start and run the engine for 3 minutes with the alternator belt disconnected.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 687 becomes inactive with the alternator belt disconnected?
YES NO

Replace the alternator. Refer to the OEM service manual.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the calibration and the ECM.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 7A

Guided Step 6B - Connect all components and determine if the fault code reoccurs.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Start the engine.

Action

Operate the engine at idle.

  • Take the vehicle on a short test drive with a few hard accelerations from very low vehicle speed to approximately 35 mph.
  • If the above procedure is not successful in clearing the fault code, calibrate the electronic control module (ECM) using the latest available calibration revision of the installed calibration. Check the engine serial number (ESN) on QuickServe™ Online for any applicable calibration campaigns before recalibration. Calibration of the ECM to the latest available revision level (even if it is the same revision level that is already in the ECM) will reset the latched fault code logic and should clear the fault code.
  • If the above procedure is not successful in clearing the fault code, continue troubleshooting the issue per RAPIDSERVE™ guidance.

Fault Code 687 becomes active during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

The malfunction was corrected when the components were reconnected.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2012


FAULT CODE 688 - Engine Oil Level - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 688 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault Code 688 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine oil temperature near ambient temperature.
  • Make sure the vehicle is parked on level ground.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 688 active?
YES NO

High engine lubricating oil level has been detected.

Correct the engine lubricating oil level condition.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 007-037 in Section 7.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 007-037 in Section 7.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 688 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-May-2012


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM..
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the sensor supply voltage and return circuit. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in Section 19.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by the target wheel
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

  • Replace the sensor. If mechanical damage was observed, inspect the target wheel and related components. Refer to Procedure 019-365 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an open crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the air gap and target wheel.

  • Remove the crankshaft position sensor from the engine block and measure the air gap at several points in the crankshaft revolution.

Refer to Procedure 019-365 in Section 19.

Is the air gap within specifications?

  • Minimum air gap 0.25 mm [0.009 in].
  • Maximum air gap 2.25 mm [0.089 in].
  • Minimum target runout 0.5 mm [0.02 in].
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25-VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let the engine idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2012


FAULT CODE 691 - Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking measurements: For ISB/ISC/ISL CM2150 ECM pin or harness connections use Deutsch™ 20-gauge round pin, Part Number 3822758, and Deutsch™ 20-gauge round socket, Part Number 3822917. For ISB CM2150 Ambient Air Temperature and Pressure Sensor use Framatome™ 2.8 mm [0.11 in] wide flat pin, Part Number 3164596, and Framatome™ 2.8 mm [0.11 in] wide flat socket, Part Number 3164597. For ISC CM2150 Turbocharger Compressor Inlet Temperature Sensor use Deutsch™ 16-gauge round pin, Part Number 3823993, and Deutsch™ 16-gauge round socket, Part Number 3823994.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 2. | Check the turbocharger compressor inlet air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor inlet air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 250 ohms and 380k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 691 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 691 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor inlet air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor inlet air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin and the turbocharger compressor inlet air temperature sensor RETURN pin at the turbocharger compressor inlet air temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

250 ohms to 380k ohms?
YES NO
No Repair

Replace the turbocharger compressor inlet air temperature sensor.

  • Use the following procedure for all engines, except ISB. Refer to Procedure 019-395 in Section 19.
  • Use the following procedure for ISB engines. Refer to Procedure 019-134 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor inlet air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor inlet air temperature sensor SIGNAL pin and the turbocharger compressor inlet air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor inlet air temperature sensor RETURN pin and the engine harness turbocharger compressor inlet air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open return.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector compressor inlet air temperature sensor SIGNAL pin and the engine harness turbocharger compressor inlet air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin to pin shorted signal circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 691 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-May-2012


FAULT CODE 692 - Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 2. | Check the turbocharger compressor inlet air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor inlet air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 692 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 692 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 692 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the turbocharger compressor inlet air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor inlet air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor inlet air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 is active?
YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor inlet air temperature sensor.

  • Use the following procedure for all engines except ISB. Refer to Procedure 019-395 in Section 19.
  • Use the following procedure for ISB engines. Refer to Procedure 019-134 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor inlet air temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 is inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 692 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 25-Apr-2012


FAULT CODE 698 - ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 698 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 698 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 698 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 25-Apr-2012


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 731 the only active fault code?
STEP 2. | Inspect the tone wheels and speed/position sensors. |
 | STEP 2A. Inspect the engine speed and position sensors for damage. | Damage found?
 | STEP 2B. Inspect the tone wheels for any damage. | Damage found?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check for correct engine static timing. |
 | STEP 4A. Check the static timing. | Camshaft and crankshaft timing marks properly aligned at top dead center?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 731 inactive?
 | STEP 5B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Is fault code 731 the only active fault?

YES NO
No Repair

Troubleshoot any other active faults before continuing with this tree.

Go to 2A

Go to the appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect the tone wheels and speed/position sensors.

Guided Step 2A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

  • Inspect the engine and position sensors for damage.

Damage found?
YES NO

Replace the position or speed sensor.

  • Refer to Procedure 019-363 in Section 19.
  • Refer to Procedure 019-365 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for defects.

  • Inspect the crankshaft and camshaft tone wheels for damage.
  • Make sure the vibration damper/crankshaft speed indicator ring assembly is aligned with the index pin located on the nose of the crankshaft.
  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 001-052 in Section 1.

Damage found?
YES NO

Replace the tone wheel.

Use the following procedures in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.

  • Refer to Procedure 001-008 in Section 1.
  • Refer to Procedure 001-016 in Section 1.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

  • Refer to Procedure 001-008 in Section 1.
  • Refer to Procedure 001-016 in Section 1.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

Are all grounds present, properly grounded, free of corrosion, and tight?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 5A

Guided Step 4 - Check for correct engine static timing.

Guided Step 4A - Check the static timing.

Conditions

  • Remove the gear cover.
  • Rotate the engine to TDC for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned.
  • Use the following procedures in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 001-008 in Section 1.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 001-008 in Section 1.

Action

Check the timing.

  • Inspect the engine static timing.

Are the camshaft and crankshaft timing marks properly aligned at TDC?
YES NO
No Repair

Remove and install camshaft to properly align timing marks at TDC.

  • Reference the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.
  • Reference the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 731 is inactive.

Fault Code 731 inactive?
YES NO
No Repair

Crankshaft gear slippage can be caused by excessive hydraulic loads on the gear train. Check and correct any excessive hydraulic loading condition on the vehicle.

Replace the crankshaft assembly if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-May-2012


FAULT CODE 778 - Engine Camshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 778 active?
STEP 2. | Check the camshaft position sensor and connector. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the camshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the camshaft position sensor circuit. |
 | STEP 3A. Check the camshaft position sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Verify adequate camshaft position sensor air gap. |
 | STEP 3B-4. Check the fault code and verify the camshaft position sensor condition. |
 | STEP 3C. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify camshaft position sensor condition. |
STEP 4. | Inspect the tone wheels. |
 | STEP 4A. Inspect the tone wheels for any defects. | Damage found?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft position sensor and connector.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the camshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Remove the camshaft position sensor from the gear housing. Refer to Procedure 019-363 in Section 19.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by the camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in the sensing end of the sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

  • Replace the sensor. If mechanical damage was detected, inspect the camshaft gear and related components. Refer to Procedure 019-363 in Section 19.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the camshaft position sensor circuit.

Guided Step 3A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor 1 RETURN pin at the camshaft position sensor connector of the engine wiring harness.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B-1

Guided Step 3B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector and the engine harness ECM connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-3

Go to 5A

Guided Step 3B-3 - Verify adequate camshaft position sensor air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the camshaft position sensor from the gear housing and measure the air gap at several points in the camshaft's revolution.

Refer to Procedure 019-363 in Section 19.

Is the air gap within specifications?

  • Minimum air gap 0.25 mm [0.009 in].
  • Minimum air gap 2.25 mm [0.089 in].
  • Minimum target runout 0.5 mm [0.02 in].
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 5A

Guided Step 3B-4 - Check the fault code and verify the camshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-365 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3C-1

Guided Step 3C-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor RETURN pin at the ECM.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25-VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify camshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let the engine idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the tone wheels.

Guided Step 4A - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

  • Inspect the crankshaft and camshaft tone wheels for damage.
  • Make sure the vibration damper/crankshaft speed indicator ring assembly is aligned with the index pin located on the nose of the crankshaft.
  • Use the following procedure for ISB 6.7L engine in the viscous vibration damper assembly in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 001-052 in Section 1.

Damage found?
YES NO

Replace the tone wheel.

Use the following procedures in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.

  • Refer to Procedure 001-008 in Section 1.
  • Refer to Procedure 001-016 in Section 1.

Use the following procedures in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

  • Refer to Procedure 001-008 in Section 1.
  • Refer to Procedure 001-016 in Section 1.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-May-2012


FAULT CODE 779 - Auxiliary Equipment Sensor Input 3 - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 779. | Active or inactive counts of Fault Code 779?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 779.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 779?
YES NO

The engine protection limit has been exceeded for the OEM supplied pressure or temperature input. Refer to the OEM service manual.

No Repair

Refer the OEM service manual.

Repair complete.

Last Modified: 15-May-2012


FAULT CODE 784 - Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the adaptive cruise control hardware. |
 | STEP 1A. Check for installed adaptive cruise control hardware. | Adaptive cruise control hardware installed on vehicle?
STEP 2. | Check Society of Automotive Engineers (SAE) J1939 communication. |
 | STEP 2A. Check for engine control module (ECM) communication with INSITE™ electronic service tool. | INSITE™ electronic service tool communicates with the ECM?
 | STEP 2B. Inspect the original equipment manufacturer (OEM) harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check ECM communication with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with the ECM?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 784 inactive?
 | STEP 3B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the adaptive cruise control hardware.

Guided Step 1A - Check for installed adaptive cruise control hardware.

Conditions

  • Turn keyswitch OFF.

Action

Check the control hardware.

  • Check the vehicle for installed adaptive cruise control hardware.

Adaptive cruise control hardware installed on the vehicle?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Adaptive Cruise feature.

Go to 2A

Go to 3A

Guided Step 2 - Check SAE J1939 communications.

Guided Step 2A - Check for ECM communication with INSITE™

Conditions

  • Turn keyswitch ON.
  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™, electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool.
  • Select INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

See equipment manufacturer service information for information on troubleshooting the adaptive cruise control unit and the vehicle SAE J1939 network.

No Repair

See equipment manufacturer service information.

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Connect the ECM bench calibration harness to the ECM connector.
  • Connect INLINE™ II data link adapter to the ECM bench calibration harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM SAE J1939 data link circuit is functioning properly.

See equipment manufacturer service information for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

See equipment manufacturer service information.

See the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree in Section TS.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 784 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During cranking: At least (+) 6.2-VDC?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire interrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP i4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1117 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 active?
YES NO
No Repair

If high inactive counts of Fault Code 1117 are found in the ECM, check the battery disconnect devices in the vehicle. If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system];

During cranking: At least (+) 6.2-VDC?
YES NO
No Repair

Charge or replace the battery. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Is fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Is fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the input wire.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire; such as solenoids or relays.

Keyswitch input wire interrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Turn the keyswitch to the OFF position for 30 seconds.
  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 1117 is inactive.

For Fault Code 1117 to become inactive, the ECM must go through one complete shutdown.

Fault Code 1117 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 1239 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1241 active and Fault Code 1239 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1239 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1239 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1239 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1695.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and exhaust gas temperature 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active and Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active?
YES NO

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Refer to the circuit diagram and the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1239 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 1241 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1239 active and Fault Code 1241 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1241 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1241 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1241 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 1696.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal position sensor supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the accelerator pedal position 5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1239 active and Fault Code 1241 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. Refer to the OEM service manual.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SUPPLY pin and the OEM harness accelerator pedal connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1241 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 1242 - Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 131, 132, 1239, or 1241 active?
STEP 2. | Check the accelerator pedal position sensor readings. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 132 and 1241 both active?
 | STEP 2C. Check the accelerator pedal position 1 sensor supply voltage and return circuit. | Between 4.75 and 5.25 volts of direct current (VDC)?
 | STEP 2D. Check the accelerator pedal position 2 sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 1242 inactive?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1242 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131, 132, 1239, or 1241 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor readings.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 132 and 1241 both active?
YES NO
No Repair

If Fault Code 132 did not go active, follow Fault Code 132 troubleshooting tree.

If Fault Code 1241 did not go active, follow Fault Code 1241 troubleshooting tree.

Go to 2C

Go to the appropriate fault code troubleshooting tree.

Guided Step 2C - Check the accelerator pedal position 1 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal position 1 sensor +5 volt SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM harness.

See the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 and 5.25 VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 132 troubleshooting tree.

Go to 2D

Troubleshoot Fault Code 132.

Guided Step 2D - Check the accelerator pedal position 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal position 2 sensor +5 voltt SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM harness.

See the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 and 5.25 VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 1241 troubleshooting tree.

Go to 2E

Troubleshoot Fault Code 1241.

Guided Step 2E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1242 is inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged accelerator pedal has been detected. Contact tha appropriate OEM or dealship for repair instructions.

Replace the accelerator pedal. Refer to the OEM service manual.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1242 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 1663 - Catalyst Inlet Temperature Sensor Swapped with Outlet - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1674, 1675, 1676, 1665, 1666, or 1667 active?
 | STEP 1B. Monitor the aftertreatment diesel particulate filter temperature sensor with an electronic service tool. | Do any of the aftertreatment diesel particulate filter temperature sensors vary by more than 24°C [43°F]?
 | STEP 1C. Check for fault codes. | Fault Code 1663 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Verify the repair. | Fault Code 1663 cleared?
 | STEP 2B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674, 1675, 1676, 1665, 1666, or 1667 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Monitor the aftertreatment diesel particulate filter temperature sensor with an electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine idling for greater than 10 minutes.

Action

Monitor the aftertreatment diesel particulate filter temperature sensor with an electronic service tool while the engine is idling.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no faults occur, record the values of the three aftertreatment diesel particulate filter temperature sensors.

Do any of the aftertreatment diesel particulate filter temperature sensors vary by more than 24°C [43°F]?
YES NO

Check for a short from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

The aftertreatment diesel oxidation catalyst inlet temperature sensor and the aftertreatment diesel particulate filter inlet temperature sensor have different electrical connector keys. It should not be possible to swap the connections unless the sensors are installed in the wrong location in the aftertreatment system.

Fault Code 1663 active?
YES NO

The aftertreatment diesel oxidation catalyst inlet temperature sensor and the aftertreatment diesel particulate filter inlet temperature sensor readings are reversed.

Inspect the sensor connectors. The aftertreatment diesel particulate filter inlet temperature sensor should have a different connector key than the other sensors.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Turn keyswitch OFF for 30 seconds.
  • Turn keyswitch ON and use INSITE™ electronic service tool to read the fault codes.

If Fault Code 1663 is still active at key ON, allow the aftertreatment temperatures to cool below 32°C [90°F].

Start and operate the engine at high idle for 10 minutes to clear the fault code.

Fault Code 1663 cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting tree.

Last Modified: 22-May-2012


FAULT CODE 1664 - Catalyst Missing - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1674, 1675, 1676, 1665, 1666, or 1667 active?
 | STEP 1B. Check for the presence of a diesel oxidation catalyst. | Is the diesel oxidation catalyst present in the aftertreatment system?
STEP 2. | Clear the fault code. |
 | STEP 2A. Verify the repair. | Fault Code 1664 cleared?
 | STEP 2B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674, 1675, 1676, 1665, 1666, or 1667 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for the presence of a diesel oxidation catalyst.

Conditions

  • Turn keyswitch OFF.
  • Remove the diesel oxidation catalyst from the vehicle.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Action

Check the diesel oxidation catalyst.

  • Inspect for the presence of the diesel oxidation catalyst in the exhaust system.

Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Is the diesel oxidation catalyst present in the aftertreatment system?
YES NO
No Repair

Install the proper diesel oxidation catalyst for the application. Refer to the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578, for stationary regeneration information. Refer to Procedure 014-013 in Section 14.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569, for stationary regeneration information. Refer to Procedure 014-013 in Section 14.
  • Use INSITE™ electronic service tool to perform the aftertreatment Diesel Particulate Filter test found in the ECM Diagnostic Tests.

It will be necessary to perform a Stationary Regeneration of the aftertreatment system to verify the fault code has been repaired. Use INSITE™ electronic service tool to perform the test.

Fault Code 1664 cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-May-2012


FAULT CODE 1665 - Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1665 inactive?
STEP 2. | Check the aftertreatment diesel oxidation catalyst inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel oxidation catalyst inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1666 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1665 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1665 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1665 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel oxidation catalyst inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel oxidation catalyst inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel oxidation catalyst inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel oxidation catalyst inlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 active?
YES NO

Replace the aftertreatment diesel oxidation catalyst inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1665 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 1666 - Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1666 inactive?
STEP 2. | Check the aftertreatment diesel oxidation catalyst inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel oxidation catalyst inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1665 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1666 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1665 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1666 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel oxidation catalyst inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel oxidation catalyst inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel oxidation catalyst inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment diesel oxidation catalyst inlet temperature SIGNAL pin and the aftertreatment diesel oxidation catalyst inlet temperature RETURN pin at the sensor connector of the wiring harness.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Reference the appropriate circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1665 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel oxidation catalyst inlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 active?
YES NO

A damaged aftertreatment diesel oxidation catalyst inlet temperature sensor has been detected.

Replace the aftertreatment diesel oxidation catalyst inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel oxidation catalyst inlet temperature sensor RETURN pin and the wiring harness aftertreatment diesel oxidation catalyst inlet temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor RETURN wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL pin and the wiring harness aftertreatment diesel oxidation catalyst inlet temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects..

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1666 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 1667 - Aftertreatment Exhaust Gas Temperature 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1665 or 1666 active?
STEP 2. | Check the aftertreatment diesel oxidation catalyst inlet temperature sensor, the aftertreatment diesel particulate filter inlet temperature sensor, and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel oxidation catalyst inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Inspect the aftertreatment diesel particulate filter inlet temperature sensor connector pins. |
 | STEP 2B. Check the aftertreatment diesel oxidation catalyst inlet temperature sensor for an open circuit. | Fault Code 1666 active?
 | STEP 2C. Check the aftertreatment diesel oxidation catalyst inlet temperature sensor for a short circuit | Fault Code 1665 active?
 | STEP 2D. Check the aftertreatment diesel particulate filter inlet temperature sensor for an open circuit. | Fault Code 1675 active?
 | STEP 2E. Check the aftertreatment diesel particulate filter inlet temperature sensor for a short circuit. | Fault Code 1674 active?
 | STEP 2F. Monitor the aftertreatment diesel oxidation catalyst inlet temperature sensor. | Measured resistance value of aftertreatment diesel oxidation catalyst inlet temperature sensor in range?
 | STEP 2G. Monitor the aftertreatment diesel particulate filter inlet temperature sensor. | Measured resistance value of aftertreatment diesel particulate filter inlet temperature sensor in range?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin signal short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin signal short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for a mis-wired harness. | Aftertreatment temperature sensor pins in correct locations?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 4A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the inlet face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 5. | Check for excessive black smoke. |
 | STEP 5A. Inspect the exhaust for excessive black smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 6. | Clear the fault code. |
 | STEP 6A. Verify the repair. | Aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature readings within 24°C or 43°F of each other?
 | STEP 6B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 or 1666 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1665 or 1666.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel oxidation catalyst inlet temperature sensor, the aftertreatment diesel particulate filter inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel oxidation catalyst inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel oxidation catalyst inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.
  • Replace the aftertreatment diesel oxidation catalyst inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 5A

Go to 2A-1

Guided Step 2A-1 - Inspect the aftertreatment diesel particulate filter inlet temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel particulate filter inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.
  • Replace the aftertreatment diesel particulate filter inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the aftertreatment diesel oxidation catalyst inlet temperature sensor for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the aftertreatment diesel oxidation catalyst inlet temperature sensor for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response.

  • Place a jumper wire between the aftertreatment diesel oxidation catalyst inlet temperature SIGNAL pin and the aftertreatment diesel oxidation catalyst inlet temperature RETURN pin at the aftertreatment diesel oxidation catalyst inlet temperature connector of the wiring harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the aftertreatment diesel particulate filter inlet temperature sensor for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check the aftertreatment diesel particulate filter inlet temperature sensor for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response.

  • Place a jumper wire between the aftertreatment diesel particulate filter inlet temperature SIGNAL pin and the aftertreatment diesel particulate filter inlet temperature RETURN pin at the aftertreatment diesel particulate filter inlet temperature connector of the wiring harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 active?
YES | NO
No Repair | No Repair

Go to 2F

Go to 3A

Guided Step 2F - Monitor the aftertreatment diesel oxidation catalyst inlet temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the temperature reading of the aftertreatment diesel oxidation catalyst inlet temperature sensor using the electronic service tool.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.
  • Connect two service test leads, Part Number 3164597, of the electrical test kit, Part Number 4919115, to the aftertreatment diesel oxidation catalyst inlet temperature sensor harness connector.
  • Use a digital multimeter to record the resistance value of the aftertreatment diesel oxidation catalyst inlet temperature sensor.
  • Compare the recorded resistance value of the aftertreatment diesel oxidation catalyst inlet temperature sensor against the values in the Temperature vs Resistance Chart in the following procedure. Refer to Procedure 019-449 in Section 19.

Measured resistance value of aftertreatment diesel oxidation catalyst inlet temperature sensor in range?
YES NO
No Repair

A damaged sensor has been detected.

Replace the aftertreatment diesel oxidation catalyst inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 2G

Go to 5A

Guided Step 2G - Monitor the aftertreatment diesel particulate filter inlet temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting symptomtree.
  • If no fault codes occur, record the temperature reading of the aftertreatment diesel particulate filter inlet temperature sensor using the electronic service tool,
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.
  • Connect two service test leads, Part Number 3164597, of the electrical test kit, Part Number 4919115, to the aftertreatment diesel particulate filter inlet temperature sensor harness connector.
  • Use a digital multimeter to record the resistance value of the aftertreatment diesel particulate filter inlet temperature sensor.
  • Compare the recorded resistance value of the aftertreatment diesel particulate filter inlet temperature sensor against the values in the Temperature vs Resistance Chart in the following procedure. Refer to Procedure 019-449 in Section 19.

Measured resistance value of aftertreatment diesel particulate filter inlet temperature sensor in range?
YES NO
No Repair

A damaged sensor has been detected.

Replace the aftertreatment diesel particulate filter inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-pin signal short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel oxidation catalyst inlet temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin signal short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3F

Go to 5A

Guided Step 3F - Check for a mis-wired harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor, diesel particulate filter inlet temperature sensor, and diesel particulate filter outlet temperature sensor from the wiring harness.

Action

Check for sensor pins or wires installed in incorrect connector locations between the OEM connector and each of the temperature sensors. For example, installing the SIGNAL pin in the RETURN pin location and the RETURN pin in the SIGNAL pin location on an aftertreatment temperature sensor can cause active faults to occur.

  • Use an ohm meter to verify the correct location of each aftertreatment temperature sensor wire. A length of jumper wire may be required to measure resistance from the OEM connector to the aftertreatment temperature sensor connections.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment temperature sensor pins in correct locations?
YES NO
No Repair

A mis-wired OEM harness and/or aftertreatment harness has been detected.

Repair the OEM harness and/or the aftertreatment harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 4A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

Remove the aftertreatment diesel oxidation catalyst.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Action

Inspect the aftertreatment catalyst.

Check the inlet face of the aftertreatment diesel oxidation catalyst for soot accumulation.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

More than 50 percent of the cells on the inlet face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst.

Action

Inspect the aftertreatment diesel oxidation catalyst.

Check for cracks in the aftertreatment diesel oxidation catalyst cell wall.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

A damaged sensor has been detected.

  • Replace the aftertreatment diesel oxidation catalyst inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Check for excessive black smoke.

Guided Step 5A - Inspect the exhaust for excessive black smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected test. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.
  • Perform the Snap Acceleration - Aftertreatment Disconnected test. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.

NOTE: To perform a Snap Acceleration Test, it could be necessary to temporarily adjust the Maximum Engine Speed with no vehicle speed sensor (VSS) parameter in INSITE™ electronic service tool, to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES | NO
No Repair | No Repair

Reference the appropriate engine performance troubleshooting tree.

Go to 6A

Guided Step 6 - Clear the fault code.

Guided Step 6A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the temperature readings.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for Aftertreatment Diesel Oxidation Catalyst Inlet Temperature and Aftertreatment Diesel Particulate Filter Inlet Temperature.

The engine must be operating at high idle for 25 minutes and the aftertreatment diesel oxidation catalyst inlet temperature must be above 150°C [302°F] before the fault code will clear.

Aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature readings within 24°C or 43°F of each other?

YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 23-Jul-2013


FAULT CODE 1674 - Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1674 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1675 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1674 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1674 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1674 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel particulate filter inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter inlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 active?
YES NO

Replace the aftertreatment diesel particulate filter inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1674 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 1675 - Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1675 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1674 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1675 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1675 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1675 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel particulate filter inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment diesel particulate filter inlet temperature SIGNAL pin and the aftertreatment diesel particulate filter inlet temperature RETURN pin at the sensor connector of the wiring harness.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1674 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter inlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES NO

A damaged aftertreatment diesel particulate filter inlet temperature sensor has been detected.

Replace the aftertreatment diesel particulate filter inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter inlet temperature sensor RETURN pin and the OEM harness aftertreatment diesel particulate filter inlet temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel particulate filter inlet temperature sensor RETURN wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin and the wiring harness aftertreatment diesel particulate filter inlet temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 1675 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1675 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 1676 - Aftertreatment Exhaust Gas Temperature 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1674 or 1675 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1675 active?
 | STEP 2C. Check the circuit response. | Fault Code 1674 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature reading within 24°C or 43°F of each other?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 or 1675 active?
YES | NO
No Repair | No Repair

Go to Fault Code 1674 or 1675.

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel particulate filter inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment diesel particulate filter inlet temperature SIGNAL pin and the aftertreatment diesel particulate filter inlet temperature RETURN pin at the aftertreatment diesel particulate filter inlet temperature connector of the wiring harness.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1674 active?
YES NO

A damaged aftertreatment diesel particulate filter inlet temperature sensor has been detected.

Replace the aftertreatment diesel particulate filter inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

A pin-to-ground short circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare the INSITE™ electronic service tool reading for the aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature.

The engine must be running at any speed for 15 minutes and the aftertreatment diesel oxidation catalyst inlet temperature must be above 150°C [302°F] before the fault code will clear.

Aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature reading within 24°C or 43°F of each other?

YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 1691 - Catalyst Efficiency - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for exhaust gas recirculation (EGR) valve and variable geometry turbocharger related fault codes. | Other fault codes active or have high inactive counts?
STEP 2. | Check the turbocharger outlet. |
 | STEP 2A. Check engine control module (ECM) Calibration, Features, and Parameters. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Check for excessive aftertreatment regeneration frequency. | Average aftertreatment regeneration frequency 8 hours or less?
 | STEP 2C. Check the original equipment manufacturer (OEM) or customer selected regeneration inhibit features and parameters | Features and Parameter settings preventing or interrupting regeneration?
STEP 3. | Check the exhaust system for leaks. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil, fuel, or coolant. | Engine oil, fuel, or coolant contamination found in the turbocharger exhaust outlet?
 | STEP 3B. Check the exhaust system between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
STEP 4. | Check for excessive smoke. |
 | STEP 4A. Inspect the exhaust for excessive smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 5A. Clean and inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | More than 50 percent of the cells on the inlet face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 6. | Reset aftertreatment, perform a stationary regeneration, and reset fault codes. |
 | STEP 6A. Reset aftertreatment, perform a stationary regeneration, and reset fault codes. | Aftertreatment Maintenance Reset procedure has been completed?
 | STEP 6B. Perform the stationary regeneration procedure. |
 | STEP 6C. Disable and clear the fault code. | Fault code inactive and cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for EGR valve and variable geometry turbocharger related fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for related fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive fault codes that are related to the EGR valve or variable geometry turbocharger actuator.

Other fault codes active or have counts inactive high?

YES NO

Troubleshoot the EGR or variable geometry turbocharger related fault code(s). A stuck open EGR valve or a damaged variable geometry turbocharger actuator can cause face plugging of the diesel oxidation catalyst (DOC).

No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM Calibration, Features, and Parameters.

Guided Step 2A - Check if an ECM calibration update is available

Conditions

  • Connect all components
  • Connect INSITE electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Check for excessive aftertreatment regeneration frequency

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for excessive regeneration frequency.

Use INSITE™ electronic service tool to evaluate average time between aftertreatment regenerations. This can be done by determining the average time between regeneration events in the Advance ECM Data tab, under Aftertreatment History. Regeneration frequencies of 8 hours or less are considered excessive and must be investigated.

Is the average aftertreatment regeneration frequency 8 hours or less?
YES NO

  • Reference the Aftertreatment Diesel Particulate Filter - Excessive Automatic and/or Stationary Regeneration troubleshooting symptom tree in Section TS of the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.
  • Reference the Aftertreatment Diesel Particulate Filter - Excessive Automatic and/or Stationary Regeneration troubleshooting symptom tree in Section TS of the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Go to 6A

Go to 2C

Guided Step 2C - Check the OEM or customer selected regeneration inhibit features and parameters

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check OEM or customer selected inhibit features.

Use INSITE™ electronic service tool to review the settings for Automotive Mobile Regeneration Minimum Vehicle Speed, and Active Regeneration in power takeoff (PTO) and Remote Modes. Make sure these OEM or customer selected inhibit features are not interrupting or preventing regeneration events.

Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-999 in Section F

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-999 in Section F

Were Features and Parameter settings preventing or interrupting regeneration?
YES NO

Adjust the Features and Parameters settings such that regenerations are not inhibited or interrupted. Always consult the OEM and customer prior to making any changes to these settings.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the exhaust system.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil, fuel, or coolant.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet for signs of oil, fuel, or coolant being introduced into the aftertreatment system from the engine.

  • Inspect the diesel oxidation catalyst (DOC) and diesel particulate filter for signs of oil or fuel contamination. These components must be replaced if soaked with oil or fuel. Reference the aftertreatment DOC and aftertreatment diesel particulate filter reuse guidelines in Bulletin 4021600.

Engine oil, fuel, or coolant contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil, diesel fuel, or coolant being carried from the engine into the aftertreatment system.

Reference the following manuals for the malfunctioning component(s):

  • ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.
  • ISC and ISL CM2150 Service Manual, Bulletin 4021569.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check the exhaust system between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for leaks.

  • Inspect the exhaust system between the turbocharger and aftertreatment system. Inspect for loose or leaking connections, and damaged exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged or leaking exhaust system components.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check for excessive smoke.

Guided Step 4A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

NOTE: To perform a Snap Acceleration Test, it may be necessary to temporarily adjust the Maximum Engine Speed with No VSS Parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

  • Reference the Smoke, Black - Excessive troubleshooting symptom tree and Smoke, White - Excessive troubleshooting symptom tree in Section TS of the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578, and the ISC and ISL CM2150 Service Manual, Bulletin 4021569.
  • Reference the Smoke, Black - Excessive troubleshooting symptom tree and Smoke, White - Excessive troubleshooting symptom tree in Section TS of the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 5A - Clean and inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Remove aftertreatment DOC.

Action

Clean the DOC, and inspect for reuse.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Check for cracks in the aftertreatment DOC cell wall.

  • Reference the Aftertreatment Diesel Oxidation Catalyst and Aftertreatment Diesel Particulate Filter Reuse Guidelines in Bulletin 4021600.
  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC.

  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Reset aftertreatment, perform a stationary regeneration, and reset fault codes.

Guided Step 6A - Perform the Aftertreatment Diesel Oxidation Catalyst Reset Procedure.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Perform the Atertreatment Maintenance Reset procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset Procedure under the Advanced ECM Data menu. Select the DOC Reset option.

Aftertreatment Maintenance Reset Procedure has been completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset Procedure under the Advanced ECM Data menu.

Go to 6B

Go to 6B

Guided Step 6B - Perform the stationary regeneration.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM Diagnostics Test.
  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-056 in Section 11.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-056 in Section 11.

Fault Code 1691 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Replace the aftertreatment DOC.

  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the IC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Go to 6C

Go to 6C

Guided Step 6C - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Successful completion of a stationary regeneration without the fault code coming active indicates the condition for clearing the fault code has been met. Use INSITE™ electronic service tool to clear the inactive fault code.

Fault code inactive and cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Mar-2013


FAULT CODE 1695 - Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1695 inactive?
STEP 2. | Check the ECM and OEM harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ECM battery (+) in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Verify the repair. | Fault Code 1695 inactive?
 | STEP 3B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the engine coolant level sensor.
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 5 pin at the OEM harness ECM connector to all other pins in the connector.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ECM battery (+) in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the engine coolant level sensor.
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).

Action

Check for a short circuit to ECM battery (+).

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector to the ECM battery (+) pins at the OEM power harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1695 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 1696 - Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1696 inactive?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Check the circuit response. | Fault Code 1696 active?
 | STEP 2B. Check the circuit response. | Fault Code 1696 active?
 | STEP 2C. Check the circuit response. | Fault Code 1696 active?
 | STEP 2D. Check the circuit response. | Fault Code 1696 active?
 | STEP 2E. Check the circuit response. | Fault Code 1696 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1696 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the accelerator/lever position sensor. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to Procedure 019-443 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote throttle from the OEM harness (if equipped).
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the remote throttle. Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan speed sensor from the OEM harness (if equipped).
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the fan speed sensor. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins. Refer to Procedure 019-071 in Section 19.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness
  • Disconnect the remote throttle (if equipped) from the OEM harness.
  • Disconnect the fan speed sensor (if equipped) from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal 5-VDC SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness
  • Disconnect the remote throttle (if equipped) from the OEM harness.
  • Disconnect the fan speed sensor (if equipped) from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator 5-VDC SUPPLY pin and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1696 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 1843 - Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1843 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1843 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference Fault Code 227 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes,

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to crankcase pressure sensor RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1843 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 18-Jul-2012


FAULT CODE 1844 - Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1844 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1844 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Reference Fault Code 386 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the crankcase pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted circuit has been detected on the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the engine harness ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1844 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 18-Jul-2012


FAULT CODE 1866 - Exhaust Gas Recirculation (EGR) Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2273 and 2274. | Fault Code 2273 or 2274 active?
 | STEP 1B. Check the EGR differential pressure sensor flow ports. | EGR differential pressure sensor flow ports plugged?
STEP 2. | Check the EGR delta pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR delta pressure sensor and connector pins. | Dirty or damaged pins.
 | STEP 2B. Check the circuit response. | Fault Code 2274 active?
 | STEP 2C. Check the circuit response. | Fault Code 2273 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2274 active?
 | STEP 3C. Check the circuit response. | Fault Code 2273 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verity the repair. | INSITE™ electronic service tool reading for EGR Delta Pressure is 0 kPa [0 psi]?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 2273 and 2274.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 or 2274 active?
YES | NO
No Repair | No Repair

Reference Fault Code 2273 or 2274 troubleshooting tree.

Go to 1B

Guided Step 1B - Check the EGR differential pressure sensor flow ports.

Conditions

  • Turn keyswitch OFF.
  • Remove the air intake connection. Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-080 in Section 10.

Action

Check the EGR differential pressure sensor flow ports.

  • Inspect the EGR differential pressure sensor flow port cross-drillings for restrictions, soot plugging, and shellac plugging. If any EGR differential pressure sensor flow ports are blocked, the ports must be completely cleaned prior to installing the air intake connection.
  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-080 in Section 10.

EGR differential pressure sensor flow ports plugged?
YES NO

Clean the EGR differential pressure sensor flow ports.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578, for the EGR differential pressure sensor flow port cleaning procedure. Refer to Procedure 010-080 in Section 10.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the EGR delta pressure sensor and circuit.

Guided Step 2A - Inspect the EGR delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 volt SUPPLY pin and the EGR differential pressure SIGNAL pin at the EGR differential pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2273 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 volt SUPPLY pin and the EGR differential pressure SIGNAL pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2273 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure engine coolant temperature is above 67°C [154°F].
  • Make sure intake manifold air temperature is above -17°C [0°F].
  • Do not operate engine.

Action

Verify the engine coolant temperature is above 67°C [154°F] and the intake manifold air temperature is above -17°C [0°F].

  • Turn keyswitch OFF for 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

INSITE™ electronic service tool reading for EGR delta pressure 0 kPa [0 psi]?
YES NO
No Repair

Return to the troubleshooting steps or a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 06-Sep-2012


FAULT CODE 1876 - Exhaust Gas Temperature 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1876 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1877 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1876 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1876 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1876 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the aftertreatment diesel particulate filter outlet temperature SIGNAL pin and the aftertreatment diesel particulate filter outlet temperature RETURN pin at the sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

See the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1877 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter outlet temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 active?
YES NO

A damaged aftertreatment diesel particulate filter outlet temperature sensor has been detected.

Replace the aftertreatment diesel particulate filter outlet temperature sensor.

Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter outlet temperature sensor RETURN pin and the OEM harness aftertreatment diesel particulate filter outlet temperature sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel particulate filter outlet temperature sensor RETURN wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin and the OEM harness aftertreatment diesel particulate filter outlet temperature sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following proceedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1876 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 1877 - Exhaust Gas Temperature 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP . | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1877 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1876 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1877 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1877 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 332 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter outlet temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877 active?
YES NO

A damaged aftertreatment diesel particulate filter outlet temperature sensor has been detected.

Replace the aftertreatment diesel particulate filter outlet temperature sensor.

Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1877 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 15-Oct-2015


FAULT CODE 1878 - Aftertreatment Exhaust Gas Temperature 3 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1876 or 1877 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1876 active?
 | STEP 2C. Check the circuit response. | Fault Code 1877 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Aftertreatment diesel particulate filter inlet temperature and aftertreatment diesel particulate filter outlet temperature readings within 24°C or 43°F of each other?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 or 1877 active?
YES | NO
No Repair | No Repair

Fault Code 1876 or 1877 troubleshooting tree.

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter outlet temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel particulate filter outlet temperature SIGNAL pin and the aftertreatment diesel particulate filter outlet temperature RETURN pin at the aftertreatment diesel particulate filter outlet temperature connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1877 active?
YES NO

A damaged aftertreatment diesel particulate filter outlet temperature sensor has been detected.

Replace the aftertreatment diesel particulate filter outlet temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin SIGNAL short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

A pin-to-ground short circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare the INSITE™ electronic service tool reading for aftertreatment diesel particulate filter inlet temperature and aftertreatment diesel particulate filter outlet temperature.

Note: The engine must be running at any speed for 15 minutes and the aftertreatment diesel oxidation catalyst inlet temperature must be above 150°C or 302°F before the fault code will clear.

Aftertreatment diesel particulate filter inlet temperature and aftertreatment diesel particulate filter outlet temperature readings within 24°C or 43°F of each other?

YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps

Last Modified: 16-Aug-2012


FAULT CODE 1879 - Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1879 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1881 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1879 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1879 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1879 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Fault Code 1695 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin and the aftertreatment diesel particulate filter differential pressure sensor RETURN pin at the aftertreatment diesel particulate filter differential pressure sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to Procedure 019-443 in Section 19.

None. The removal an installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter differential pressure sensor RETURN pin and the OEM harness aftertreatment diesel particulate filter differential pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1879 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Aug-2012


FAULT CODE 1881 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor or supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1881 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter differential pressure sensor and electronic connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response. | Fault Code 1879 active?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1881 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1881 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1881 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 1696 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel particulate filter differential pressure SUPPLY pin and the aftertreatment diesel particulate filter differential pressure RETURN pin at the aftertreatment diesel particulate filter differential pressure sensor connector of the OEM harness.

See the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin and the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin at the aftertreatment diesel particulate filter differential pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel particulate filter differential pressure sensor.

Refer to Procedure 019-443 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin and the OEM harness aftertreatment diesel particulate filter differential pressure sensor connector SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin and the OEM harness aftertreatment diesel particulate filter differential pressure sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure fore general resistance techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

The troubleshooting steps need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1881 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Oct-2015


FAULT CODE 1883 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1879 and 1881. | Fault Code 1879 or 1881 active?
STEP 2. | Check the aftertreatment diesel particulate filter differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1881 active?
 | STEP 2C. Check the circuit response. | Fault Code 1879 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged?
 | STEP 3B. Check for resistance in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1883 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1879 and 1881.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 or 1881 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 1879 or 1881 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel particulate filter differential pressure 5 volt SUPPLY pin and the aftertreatment diesel particulate filter differential pressure SIGNAL pin at the aftertreatment diesel particulate filter differential pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

See the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1879 active?
YES NO

An in-range malfunctioning aftertreatment diesel particulate filter differential pressure sensor has been detected.

Replace the aftertreatment diesel particulate filter differential pressure sensor.

Refer to Procedure 019-443 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for resistance in the circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin and the OEM harness aftertreatment diesel particulate filter differential pressure sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance in the SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connector in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1883 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1896 active?
STEP 2. | Check the EGR valve operation. |
 | STEP 2A. Check for active fault codes. | Fault Code 1896 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1896 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the EGR valve operation.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Turn the keyswitch OFF for 10 seconds and then turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES NO

A stuck open EGR valve has been detected.

Replace the EGR valve assembly.

  • Refer to Procedure For ISB engines, 011-022 (EGR Valve) in Section 11 in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578.
  • Refer to Procedure For ISC and ISL engines, 011-022 (EGR Valve) in Section 14 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569, for aftertreatment reuse guidelines.

Perform the Snap-Acceleration Test to check for a malfunctioning diesel particulate filter.

  • Refer to Procedure For ISC and ISL engines, 014-013 ( Aftertreatment Testing) in Section 14 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.
  • Refer to Procedure For ISB engines, 014-013 ( Aftertreatment Testing) in Section 14 in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578, for aftertreatment reuse guidelines.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1896 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


FAULT CODE 1899 - Exhaust Gas Recirculation (EGR) Valve Delta Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active EGR valve fault codes. | Fault Code 1895, 1896, or 2357 active?
 | STEP 1B. Check for active EGR differential pressure sensor fault codes. | Fault Code 1866, 2273, or 2274 active?
STEP 2. | Check the EGR system for debris or plugging. |
 | STEP 2A. Check the EGR differential pressure sensor flow ports. | EGR differential pressure sensor flow ports plugged?
 | STEP 2B. Check the EGR cooler for soot plugging. | EGR cooler exhaust outlet plugged with soot?
STEP 3. | Check the EGR delta pressure sensor and circuit. |
 | STEP 3A. Inspect the EGR delta pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2274 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 1899 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1895, 1896, or 2357 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for active EGR differential pressure sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1866, 2273, or 2274 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR system for debris or plugging.

Guided Step 2A - Check the EGR differential pressure sensor flow ports.

Conditions

  • Turn keyswitch OFF.
  • Remove the air intake connection. Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-080 in Section 10.
  • Use the following procedure in the ISC and ISL Engines CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

Action

Check the EGR differential pressure sensor flow ports.

Inspect the EGR differential pressure sensor flow port cross-drillings for restrictions, soot plugging, and shellac plugging. If any of the EGR differential pressure sensor flow ports are blocked, the ports must be cleaned completely prior to installing the air intake connection.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-080 in Section 10.
  • Use the following procedure in the ISC and ISL Engines CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

EGR differential pressure sensor flow ports plugged?
YES NO

Clean the EGR differential pressure sensor flow ports.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578, for the EGR differential pressure sensor flow port cleaning procedure. Refer to Procedure 010-080 in Section 10.
  • Use the following procedure in the ISC and ISL Engines CM2150 Service Manual, Bulletin 4021569, for the EGR differential pressure sensor flow port cleaning procedure. Refer to Procedure 010-080 in Section 10.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the EGR cooler for soot plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR crossover tube.
  • Use the following procedure in ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-025 in Section 11. Use the following procedure in ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-025 in Section 11.

NOTE: Some applications may require the removal of the EGR cooler to inspect for plugging.

Action

Inspect the EGR cooler exhaust outlet for restrictions, soot plugging, and shellac plugging.

A light covering of carbon is normal. Build up of soot or shellac blocking tube passages blocking EGR flow requires cleaning.

EGR cooler exhaust outlet plugged?
YES NO

Clean the EGR cooler.

  • Use the following procedure in ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-019 in Section 11.
  • Use the following procedure in ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-019 in Section 11.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the EGR delta pressure sensor and circuit.

Guided Step 3A - Inspect the EGR delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

A damaged sensor has been detected.

  • Replace the EGR delta pressure sensor.
  • Refer to Procedure 019-370 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1899 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Oct-2015


FAULT CODE 1911b - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 1117, or 2311 active or any inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Fuel rail pressure 0 ±43 bar [0 ±624 psi]?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Check for air in the fuel. | Air in the fuel?
 | STEP 3B. Check the fuel inlet restriction. | Fuel inlet restriction within the specifications outlined in Procedure 006-020 in Section 6?
 | STEP 3C. Check the fuel filter pressure drop. | Fuel pressure drop within the specifications outlined in Procedure 006-015 in Section 6?
STEP 4. | Check for fuel return drain line restriction. |
 | STEP 4A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012 in Section 12?
STEP 5. | Check the fuel pump actuator. |
 | STEP 5A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the fuel pump actuator resistance. | Fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
 | STEP 5C. Monitor the fuel rail pressure at idle. | Measured fuel rail pressure deviate more than 200 bar [2901 psi] and surge at idle?
 | STEP 5D. Inspect the fuel pump actuator for damage. | Fuel pump actuator damaged?
STEP 6. | Check the engine control module (ECM) to ground strap. |
 | STEP 6A. Inspect the ECM-to-ground strap. | ECM to ground strap missing or are the connections degraded?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault codes inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271, 272, 1117, or 2311 active or any inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ electronic service tool Monitor.
  • Relieve fuel pressure from the high-pressure fuel rail.
  • Do not run engine.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.
  • When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting on the rail to depressurize to zero. It may be necessary to manually relieve the pressure from the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail.

  • For ISB CM2150 engines, use the following procedure. Refer to Procedure 006-071 in Section 6.
  • For QSB3.3 engines, use the following procedure. Refer to Procedure 006-024 in Section 6.
  • For ISBe and ISDe CM2150 engines, use the following procedure. Refer to Procedure 006-071in Section 6.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Fuel rail pressure 0 ±43 bar [0 ±624 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 7A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for air in the fuel.

  • For ISB CM2150 engines, use the following procedure. Refer to Procedure 006-003 in Section 6.
  • For QSB3.3 engines, use the following procedure. Refer to Procedure 006-003 in Section 6.
  • For ISBe and ISDe CM2150 engines, use the following procedure. Refer to Procedure 006-003 in Section 6.

Air in the fuel?
YES NO

A few bubbles exiting the line during the test is expected.

A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed.

  • Use the following procedure for ISB CM2150 engines, if fuel inlet restriction is not excessive. Refer to Procedure 006-020 in Section 6.
  • Use the following procedure for QSB3.3 engines, if fuel inlet restriction is not excessive. Refer to Procedure 006-020 in Section 6.
  • Use the following procedue for the ISBe and ISDe CM2150 engines, if fuel inlet restriction is not excessive. Refer to Procedure 006-020 in Section 6.

The source of air entry must be isolated to one of the following:

  • Suction fuel lines
  • Original equipment manufacturer (OEM) fuel lines
  • Suction side fuel filter assemblies
  • Stand pipe(s) in the fuel tank(s).

 No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the fuel inlet restriction.

  • For ISB Series 6.7L engines, use the following procedure. Refer to Procedure 006-020 in Section 6.
  • For QSB3.3 engines, if fuel inlet restriction is not excessive, use the following procedure. Refer to Procedure 006-020 in Section 6.
  • For ISBe and ISDe Series 4.5L and 6.7L engines, use the following procedure. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction within the specifications outlined in Procedure 006-020 in Section 6?
YES NO
No Repair

If inlet restriction is excessive, search for the root cause:

  • Suction-side fuel filters plugged
  • Fuel heater valves are restricted
  • Original equipment manufacturer (OEM) fuel lines pinched or restricted
  • Fuel tank stand pipes restricted.

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic , paper, etc.) that can intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that could intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers, filters, or malfunctioning check valves.

If no issues are found, replace the suction side fuel filter and prime the fuel system.

  • For ISB Series 6.7L engines, use the following procedure. Refer to Procedure 006-015 in Section 6.
  • For QSB Series 3.3L engines, use the following procedure. Refer to Procedure 006-015 in Section 6.
  • For ISBe and ISDe Series 4.5L and 6.7L engines, use the following procedure. Refer to Procedure 006-015 in Section 6.

Go to 3C

Go to 7A

Guided Step 3C - Check the fuel filter pressure drop.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check the fuel pressure drop across the filter.

  • For ISB Series 6.7L engines, use the following procedure. Refer to Procedure 006-015 in Section 6.
  • For QSB Series 3.3L engines, use the following procedure. Refer to Procedure 006-015 in Section 6.
  • For ISBe and ISDe Series 4.5L and 6.7L engines, use the following procedure. Refer to Procedure 006-015 in Section 6.

Fuel pressure drop within the specifications outlined in Procedure 006-015 in Section 6?
YES NO
No Repair

Make sure the filter pump pressure into the filter is within specification.

  • For ISB Series 6.7L engines, use the following procedure. Refer to Procedure 005-016 in Section 5.
  • For QSB Series 3.3L engines, use the following procedure. Refer to Procedure 005-016 in Section 5.
  • For ISBe and ISDe Series 4.5L and 6.7L engines, use the following procedure. Refer to Procedure 005-016 in Section 5.

If the pump meets specifications, replace the fuel filter and prime the fuel system.

  • For ISB Series 6.7L engines, use the following procedure. Refer to Procedure 006-015 in Section 6.
  • For QSB Series 3.3L engines, use the following procedure. Refer to Procedure 006-015 in Section 6.
  • For ISBe and ISDe Series 4.5L and 6.7L engines, use the following procedure. Refer to Procedure 006-015 in Section 6.

Go to 4A

Go to 7A

Guided Step 4 - Check for fuel return drain line restriction.

Guided Step 4A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for excessive fuel drain line restriction.

  • For ISB CM2150 engines, use the following procedure. Refer to Procedure 006-012 in Section 6.
  • For the QSB3.3 engines, use the following procedure. Refer to Procedure 006-012 in Section 6.
  • For the ISBe and ISDe CM2150 engines, use the following procedure. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012 in Section 6.
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

  • For ISB CM2150 engines, use the following procedure. Refer to Procedure 006-012 in Section 6.
  • For the QSB3.3 engines, use the following procedure. Refer to Procedure 006-012 in Section 6.
  • For the ISBe and ISDe CM2150 engines, use the following procedure. Refer to Procedure 006-012 in Section 6.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel pump actuator.

Guided Step 5A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in Section 19.

Fuel pump actuator resistance within the specifications outlined in Procedure 019-117 in Section 19?
YES NO
No Repair

Replace the fuel pump actuator.

  • Refer to Procedure 019-117 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor Commanded Fuel Rail Pressure and Measured Fuel Rail Pressure.

Measured Fuel Rail Pressure deviate more than 200 bar [2901 psi] and surge at idle?
YES NO

Replace the fuel pump actuator.

  • Refer to Procedure 019-117 in Section 19.

No Repair

Go to 7A

Go to 5D

Guided Step 5D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in Section 19.

Fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator.

  • Refer to Procedure 019-117 in Section 19.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the engine control module (ECM)-to-ground strap.

Guided Step 6A - Inspect the ECM-to-ground strap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM-to-ground strap.

  • Check the ground connections from the cylinder block to battery (-) negative.
  • Check the ground from the ECM to the cylinder block. Refer to Procedure 019-008 in Section 19.

ECM-to-ground strap missing or are the connections degraded?
YES NO

Repair missing or degraded ground connections. Refer to the OEM service manual.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 1117, or 2311 active or any inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Check for air in the fuel. | Air in the fuel?
 | STEP 3B. Check the fuel inlet restriction at the OEM connection and gear pump. | Fuel inlet restriction within the specifications outlined in Procedure 006-020 (Fuel Inlet Restriction)?
 | STEP 3C. Measure the pressure drop at the pressure side fuel filter. | Fuel pressure drop within the specifications outlined in Procedure 005-236 (Fuel System Diagnostics)?
STEP 4. | Check for fuel return drain line restriction. |
 | STEP 4A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012 (Fuel Line Restriction)?
STEP 5. | Check the fuel pump actuator. |
 | STEP 5A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the fuel pump actuator resistance. | Fuel pump actuator resistance within the specifications outlined in Procedure 019-117 (Fuel Pump Actuator)?
 | STEP 5C. Monitor the fuel rail pressure at idle. | Measured fuel rail pressure deviate more than 200 bar [2901 psi] and surge at idle?
 | STEP 5D. Inspect the fuel pump actuator for damage. | Fuel pump actuator damaged?
STEP 6. | Check the ECM to ground strap. |
 | STEP 6A. Inspect the ECM to ground strap. | ECM to ground strap missing or connections degraded?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault codes inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271, 272, 1117, or 2311 active or any inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ electronic service tool Monitor.
  • Relieve fuel pressure from the high-pressure fuel rail.
  • Do not operate engine.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.
  • When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Once the engine is keyed off, there could be a significant amount of time waiting on the rail to depressurize to zero. It is necessary to manually relieve the pressure from the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail.

  • For ISC and ISL CM2150 engines, use the following in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.Refer to Procedure 006-026 in Section 6.
  • For ISLe CM2150 engines, use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630.Refer to Procedure 006-026 in Section 6 .

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 7A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for air in the fuel.

  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-003 in Section 6.
  • For ISLe CM2150 engines, refer to the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-003 in Section 6.

Was there air in the fuel?
YES NO

A few bubbles exiting the line during the test is expected.

A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed.

  • If fuel inlet restriction is not excessive, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-020 in Section 6. The source of air entry must be isolated to one for the following:
  • If fuel inlet restriction is not excessive, also use the ISLe CM2150 Service Manual, Bulletin 4021630.
  • If fuel inlet restriction is not excessive
  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipe(s) in the fuel tank(s).

 No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check the fuel inlet restriction at the OEM connection and gear pump.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check the fuel inlet restriction.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-020 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction within the specifications outlined in Procedure 006-020 in Section 6?
YES NO
No Repair

If inlet restriction is excessive, search for the root cause:

  • Suction side fuel filters plugged
  • Fuel heater valves are restricted
  • OEM fuel lines pinched or restricted
  • Fuel tank stand pipes restricted.

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic , paper, etc.) that could intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that could intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers, filters, or malfunctioning check valves.

If no issues are found, replace the suction side fuel filter and prime the fuel system.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630.Refer to Procedure 006-015 in Section 6.

Go to 3C

Go to 7A

Guided Step 3C - Measure the pressure drop at the pressure side fuel filter.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Measure the pressure drop.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-236 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-015 in Section 6.

Fuel pressure drop within the specifications outlined in Procedure 005-236 in Section 5?
YES NO
No Repair

Make sure the filter pump pressure into the filter is within specification.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-025 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-025 in Section 5.

If the pressure from the gear pump is within specifications, replace the fuel filter and prime the fuel system.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-015 in Section 6.

If the pressure from the gear pump is not within specifications, replace the gear pump.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-025 in Section 5.
  • Use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 005-025 in Section 5.

Go to 4A

Go to 7A

Guided Step 4 - Check for fuel return drain line restriction.

Guided Step 4A - Check drain line restriction.

Conditions

  • Trun keyswitch ON.
  • Operate engine.

Action

Check for excessive fuel drain line restriction.

  • Use the following procedure for ISC and ISL CM2150 engines, in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.Refer to Procedure 006-012 in Section 6.
  • Use the following procedure for ISLe CM2150 engines in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012 in Section 6?
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

  • For ISC and ISL CM2150 engines use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-012 in Section 6.
  • For ISLe CM2150 engines, use the following procedure in the ISLe CM2150 Service Manual, Bulletin 4021630. Refer to Procedure , Refer Procedure 006-012 in Section 6.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel pump actuator.

Guided Step 5A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in Section 19.

Fuel pump actuator resistance within the specifications outlined in Procedure 019-117 in Section 19?
YES NO
No Repair

Replace the fuel pump actuator. Use the following procedure for the correct tightening sequence. Refer to Procedure 019-117 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor Commanded Fuel Rail Pressure and Measured Fuel Rail Pressure.

Measured fuel rail pressure deviate more than 200 bar [2901 psi] and surge at idle?
YES NO

Replace the fuel pump actuator. Use the following procedure for the correct tightening sequence. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 7A

Go to 5D

Guided Step 5D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in Section 19.

Fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Use the following procedure for the correct tightening sequence. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the ECM to ground strap.

Guided Step 6A - Inspect the ECM to ground strap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM to ground strap.

  • Check the ground connections from the cylinder block to battery (-) negative.
  • Check the ground from the ECM to the cylinder block. Refer to Procedure 019-008 in Section 19.

ECM to ground strap missing or are the connections degraded?
YES NO

Repair missing or degraded ground connections. Refer to the OEM service manual.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that fault codes are inactive.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Jun-2011


FAULT CODE 1921 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operational Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes other than 1921 are active?
STEP 2. | Check the duty cycle of the application. |
 | STEP 2A. Check the aftertreatment duty cycle. | Does the duty cycle of the application need to be increased?
STEP 3. | Perform stationary regeneration procedure. |
 | STEP 3A. Perform stationary regeneration procedure. | Fault Code 1921 active after the stationary regeneration has been completed?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1921 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes other than 1921 are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the duty cycle of the application.

Guided Step 2A - Check the aftertreatment duty cycle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the duty cycle.

  • Use INSITE™ electronic service tool to view the duty cycle of the engine.
  • View the Aftertreatment Trip Information.

Determine if the duty cycle of the application needs to change in order to increase the exhaust temperatures entering the aftertreatment system.

Does the duty cycle of the application need to be increased?
YES NO

Change the duty cycle of the application in order to increase the exhaust temperatures entering the aftertreatment system.

 No Repair

Appropriate base engine troubleshooting procedure

Go to 3A

Guided Step 3 - Perform the stationary regeneration procedure.

Guided Step 3A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Use INSITE™ electronic service tool to perform the aftertreatment diesel particulate filter regeneration test found in the ECM diagnostic tests.
  • Some vehicles can be equipped with a stationary regeneration switch in the dash. This switch can also be used to perform the stationary regeneration procedure. Refer to the manufacturer's operating instructions.
  • Use the ISB CM2150 Service Manual, Bulletin 4021578 for stationary regeneration information for ISB CM2150 engines. Refer to Procedure 014-013 in Section 14.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569 for stationary regeneration information for ISC and ISL CM2150 engines. Refer to Procedure 014-013 in Section 14.

Note: If stationary regeneration will not activate, please refer to the “Stationary Regeneration - Will Not Activate” troubleshooting tree in Section TS of the appropriate Service Manual.

  • Refer to Section TS in the ISB CM2150 Service Manual, Bulletin 4021578.
  • Refer to Section TS in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

Note: Fault Code 2639 will become active during the regeneration procedure. This is normal operation as the soot is removed from the aftertreatment diesel particulate filter.

Fault Code 1921 active after the stationary regeneration has been completed?
YES NO

Check for active fault codes that may have come active during the regeneration event. Troubleshoot any active fault codes.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Codes 1921 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Aug-2010


FAULT CODE 1922 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1879, 1881, 1883, and 1981 active?
 | STEP 1B. Check for exhaust gas recirculation (EGR) system related fault codes. | Active or high counts of inactive EGR system related fault codes?
 | STEP 1C. Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool. | Aftertreatment diesel particulate filter differential pressure sensor reading 0 ± 3 kPa [0 ± 0.89 in Hg] with the keyswitch ON and the engine OFF?
 | STEP 1D. Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage. | Aftertreatment diesel particulate filter differential pressure sensor supply tubes blocked?
 | STEP 1E. Check for active fault codes. | Fault Code 1922 active?
 | STEP 1F. Review the aftertreatment fault code snapshot information. | Operator ignored aftertreatment diesel particulate filter lamps?
 | STEP 1G. Perform the Aftertreatment Diesel Particulate Filter Reset Procedure. | Aftertreatment Maintenance Reset Procedure has been completed?
 | STEP 1H. Perform the aftertreatment maintenance filter installation procedure. | INSITE™ electronic service tool Aftertreatment Maintenance Filter Installation procedure has been completed?
STEP 2. | Perform the stationary regeneration procedure. |
 | STEP 2A. Perform the stationary regeneration procedure. | Fault Code 1922 active after the stationary regeneration has been completed?
STEP 3. | Inspect aftertreatment sensors and wiring. |
 | STEP 3A. Inspect the aftertreatment temperature sensor connectors for correct installation locations. | Aftertreatment temperature sensors installed correctly?
 | STEP 3B. Inspect the aftertreatment wiring harness connectors for correct pin installation. | Aftertreatment wiring installed correctly?
STEP 4. | Check if an engine control module (ECM) calibration update is available for Fault Code 1981 and/or 1922. |
 | STEP 4A. Troubleshoot the cause of aftertreatment diesel particulate filter plugging. | Excessive black smoke during acceleration or constant black smoke at high idle?
 | STEP 4A-1. Check if an ECM calibration update is available for Fault Code 1981 and/or 1922. |
 | STEP 4A-2. Troubleshoot the cause of aftertreatment diesel particulate filter plugging. |
 | STEP 4B. Check if an ECM calibration update is available for Fault Code 1981 and/or 1922. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 5. | Check for active or inactive counts of Fault Code 3616, 2449, or 2387. |
 | STEP 5A. Inspect the turbocharger shaft movement. | Active or inactive counts of Fault Code 3616, 2449, or 2387?
STEP 6. | Inspect the exhaust. |
 | STEP 6A. Troubleshoot the cause of aftertreatment diesel particulate filter plugging. | Grid heater plugging found?
 | STEP 6B. Troubleshoot the cause of aftertreatment diesel particulate filter plugging. | Cause of excessive smoke determined after executing the above tests?
STEP 7. | Check the duty cycle of the application. |
 | STEP 7A. Check the aftertreatment duty cycle. | Duty cycle of the application needs to be increased?
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available for Fault Code 1981 and/or 1922. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1879, 1881, 1883, and 1981 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for EGR system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high counts of inactive EGR system related fault codes?
YES NO

Use the appropriate troubleshooting tree for the EGR system fault code.

It will also be necessary to inspect and clean, or replace, the aftertreatment diesel particulate filter. Use the following procedure to remove, inspect, and clean or replace the aftertreatment diesel particulate filter.

  • For ISB engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-041 in Section 11.
  • For ISC and ISL engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-041 in Section 11.

Use the following procedure to remove, inspect, and clean or replace the diesel oxidation catalyst.

  • For ISB engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • For ISC and ISL engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

NOTE: If the aftertreatment diesel particulate filter does not meet the inspection criteria in Procedure 011-041, it must be replaced.

Aftertreatment diesel particulate filters that meet the inspection criteria, and are cleaned in an SPX air pulse cleaning machine, or equivalent, must have a stationary regeneration performed after the cleaning process is complete.

No Repair

Go to 8A

Go to 1C

Guided Step 1C - Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Turn the engine OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool.

Aftertreatment diesel particulate filter differential pressure sensor reading 0 +/- 3 kPa [0 +/- 0.89 inHg] with the keyswitch ON and the engine OFF?

YES | NO
No Repair | No Repair

Go to 1E

Go to 1D

Guided Step 1D - Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

Action

Disconnect the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

  • For ISB engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-047 in Section 11.
  • For ISC and ISL engines, use the following procedure in the ISL and ISC CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-047 in Section 11.
  • Inspect the supply tubes for blockage.

Aftertreatment diesel particulate filter differential pressure sensor supply tubes blocked?
YES NO

Remove and clean the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

  • For ISB engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-047 in Section 11.
  • For ISC and ISL engines, use the following procedure in the ISL and ISC CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-047 in Section 11.

Check for a short circuit from the SIGNAL pin of the aftertreatment diesel particulate filter differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short circuit is found, replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to Procedure 019-443 in Section 19.

Go to 8A

Go to 8A

Guided Step 1E - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1922 active?
YES NO

The aftertreatment diesel particulate filter has been plugged with soot and the stationary regeneration procedure can not be performed until it has been inspected and cleaned in an SPX air pulse, or equivalent, cleaning machine.

Use the following instructions to remove, inspect, and clean or replace the aftertreatment diesel particulate filter.

  • For ISB engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-041 in Section 11.
  • For ISC and ISL engines, use the following procedure in the ISL and ISC CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-041 in Section 11.

Use the following instructions to remove, inspect, and clean or replace the diesel oxidation catalyst.

  • For ISB engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • For ISC and ISL engines, use the following procedure in the ISL and ISC CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

NOTE: If the aftertreatment diesel particulate filter does not meet the inspection criteria in Procedure 011-041, it must be replaced.

Aftertreatment diesel particulate filters that meet the inspection criteria and are cleaned in an SPX air pulse, or equivalent, cleaning machine must have a stationary regeneration after the cleaning process is complete.

No Repair

Go to 1F

Go to 7A

Guided Step 1F - Review the fault code snapshot information.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Review all fault codes, active or inactive, that are present in the ECM. Determine if any fault codes are present in the ECM that inhibit aftertreatment regeneration. If fault codes are present in the ECM that can inhibit aftertreatment regeneration, review the fault code snapshot information for the fault code(s) and determine if the fault code was active when Fault Codes 1921, 1922, and/or 2639 were active. If the fault(s) inhibiting aftertreatment regeneration were active when Fault Code 1921, 1922 and/or 2639 were active, it is likely the customer was not able to induce a stationary regeneration.
  • Review the ECM timestamps for Fault Codes 1921, 1922, and 2639.
  • If the ECM timestamp between each fault code is greater than .5 hour, the operator should be interviewed to determine why a stationary regeneration was not performed.

NOTE: Fault Code 2777 indicates that the aftertreatment regeneration permit switch was in the inhibit position when Fault Codes 1921, 1922, and/or 2639 were active. Reference the appropriate troubleshooting tree for this fault code and determine if this fault was active at the time Fault Code 1922 was active.

Operator ignored aftertreatment diesel particulate filter lamps?
YES NO

  • Educate the customer on the proper procedure for initiating a stationary regeneration.

Use the following instructions for stationary regeneration.

  • For ISB engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL engines, use the following procedure in the ISL and ISC CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 1G

Go to 1G

Guided Step 1G - Perform the Aftertreatment Diesel Particulate Filter Reset Procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset Procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Reset Procedure located in the aftertreatment maintenance selection under the advanced ECM data menu.
  • After clicking the “OK” button, it may take several minutes for Fault Code 1922 to go inactive, and Fault Code 1921 to go active.

NOTE: Fault Code 1922 must be active before the Aftertreatment Maintenance Reset Procedure can be performed.

NOTE: Fault Code 1922 will go inactive and Fault Code 1921 will go active after completing this procedure.

Aftertreatment Maintenance Reset Procedure has been completed?
YES NO
No Repair

Perform INSITE™ electronic service tool Aftertreatment Maintenance Reset Procedure listed in the Action section of this troubleshooting step.

Go to 1H

Go to 1H

Guided Step 1H - Perform the Aftertreatment Maintenance Filter Installation Procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Filter Installation procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Filter Installation Procedure found under the Advanced ECM Data Section.
  • If the Aftertreatment Maintenance Filter Installation Procedure is not completed, Fault Code 1922 could potentially activate after cleaning or replacing the aftertreatment diesel particulate filter and operating the vehicle for a short distance.

Perform the Aftertreatment Maintenance Filter Installation Procedure.

INSITE™ electronic service tool Aftertreatment Maintenance Filter Installation Procedure has been completed?
YES NO
No Repair

Perform INSITE™ electronic service tool Aftertreatment Maintenance Filter Installation Procedure listed in the Action step of this troubleshooting step.

Go to 2A

Go to 2A

Guided Step 2 - Perform the stationary regeneration procedure.

Guided Step 2A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the stationary regeneration procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM diagnostic tests.

Some vehicles can be equipped with a stationary regeneration switch in the dash. This switch can also be used to perform the stationary regeneration procedure. Refer to the OEM service manual.

  • For ISB engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578, for stationary regeneration information. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL engines, use the following procedure in the ISL and ISC CM2150 Service Manual, Bulletin 4021569, for stationary regeneration information. Refer to Procedure 014-013 in Section 14.

NOTE: If stationary regeneration will not activate, please reference the Stationary Regeneration - Will Not Activate troubleshooting tree in Section TS of the appropriate service manual.

NOTE: Fault Code 2639 will become active during the regeneration procedure. This is normal operation as the soot is removed from the aftertreatment diesel particulate filter.

Fault Code 1922 active after the stationary regeneration has been completed?
YES NO

A system issue may be causing Fault Code 1922 to remain active. Continue to follow the troubleshooting tree to locate the issue causing Fault Code 1922 to remain active.

No Repair

Go to 3A

Go to 8A

Guided Step 3 - Inspect aftertreatment sensors and wiring.

Guided Step 3A - Inspect the aftertreatment temperature sensor connectors for correct installation locations.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the aftertreatment temperature sensor connectors.

Inspect the exhaust aftertreatment temperature sensor connectors to verify that they are connected to the correct connector on the aftertreatment system wiring harness. Two of the temperature sensors have identical wiring harness connectors. The sensors are the same part number, and it is possible to install the wiring harness connectors to the wrong sensors.

To verify the correct sensor locations, use INSITE™ electronic service tool to monitor the aftertreatment temperature sensor voltages.

  • Unplug each of the aftertreatment temperature sensors one at a time.
  • If the voltage changes when you unplug the sensor, the wiring harness connector is connected to the correct sensor.
  • If the voltage does not change, switch the connector location to the other temperature sensor. Then unplug it and check for a voltage change.

Aftertreatment temperature sensors installed correctly?
YES NO
No Repair

Connect each of the aftertreatment temperature sensors in the correct locations by following the steps outlined in the Action section of this troubleshooting step.

Go to 3B

Go to 8A

Guided Step 3B - Inspect the aftertreatment wiring harness connectors for correct pin installation.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment wiring harness connectors for correct pin installation.

  • Inspect the aftertreatment sensor and wiring harness connectors for correct pin installation locations.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Aftertreatment wiring installed correctly?
YES NO
No Repair

Install the pins in their correct connector locations.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Go to 4A

Go to 8A

Guided Step 4 - Check if an ECM calibration update is available for Fault Code 1981 and/or 1922.

Guided Step 4A - Troubleshoot the cause of the aftertreatment diesel particulate filter plugging.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

NOTE: To perform a Snap Acceleration Test, it could be necessary to temporarily adjust the Maximum Engine Speed with No vehicle speed sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4B

Guided Step 4A-1 - Check if an ECM calibration update is available for Fault Code 1981 and/or 1922.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Calibrate the ECM with the calibration containing corrections to resolve Fault Code 1981 and/or 1922. Refer to Procedure 019-032 in Section 19.

Go to 5A

Go to 4A-2

Guided Step 4A-2 - Troubleshoot the cause of aftertreatment diesel particulate filter plugging.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.

NOTE: To perform a Snap Acceleration Test, it could be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES | NO
No Repair | No Repair

Go to 5A

Go to 8B

Guided Step 4B - Check if an ECM calibration update is available for Fault Code 1981 and/or 1922.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Calibrate the ECM with the calibration containing corrections to resolve Fault Code 1981 and/or 1922. Refer to Procedure 019-032 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Check for active or inactive counts of Fault Code 3616, 2449, or 2387.

Guided Step 5A - Inspect the turbocharger shaft movement

Conditions

  • Turn keyswitch ON.

Action

Monitor fault codes with INSITE™ electronic service tool and look for active or inactive occurrences of Fault Code 3616, 2449, or 2387.

Active or inactive counts of Fault Code 3616, 2449, or 2387?
YES NO

Use the following procedures to complete this repair.

  • For ISB engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 or Refer to Procedure 010-033 in Section 10.
  • For ISC and ISL engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 or Refer to Procedure 010-033 in Section 10.

Remove the variable geometry turbocharger actuator from the turbocharger assembly.

Inspect the sector gear on the turbocharger for damaged or broken gear teeth. Move the sector gear lever on the turbocharger bearing housing up and down from stop-to-stop. Check for smooth movement between the stops. There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever can be moved to the other stop position by hand.

If the nozzle does not slide evenly from stop-to-stop or the gear teeth are damaged, a turbocharger malfunction has been detected.

Note: This malfunction could have been caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage. Replace the turbocharger actuator or assembly.

If the nozzle slides evenly from stop to stop and the gear teeth are undamaged, install the turbocharger actuator per the above procedures and proceed to step 6A.

No Repair

Go to 8A

Go to 6A

Guided Step 6 - Inspect the exhaust.

Guided Step 6A - Troubleshoot the cause of the aftertreatment diesel particulate filter plugging.

Conditions

  • Turn keyswitch OFF.
  • Turn the engine OFF.

Action

Disconnect the air intake elbow and use a small mirror and a flashlight to inspect the grid heater for plugging.

Grid heater plugging found?
YES NO

  • For ISB engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-023 in Section 10.
  • For ISC and ISL engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-023 in Section 10.

No Repair

Go to 8A

Go to 6B

Guided Step 6B - Troubleshoot the cause of the aftertreatment diesel particulate filter plugging.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Perform the following checks:

  • Check air intake restriction
  • Check the air intake and exhaust system for leaks
  • Perform a Cylinder Cutout Test to check for misfire
  • Check for proper overhead adjustment.

Cause of excessive smoke determined after executing the above tests?
YES NO

Make necessary repairs to the air intake or fuel systems based on results from the above tests.

  • For ISB engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578, for information regarding intake and exhaust system leak detection. Refer to Procedure 010-024 in Section 10.
  • For ISC and ISL engines, use the following procedure in the ISC and ISL CM2150 Engines Service Manual, Bulletin 4021569. Refer to Procedure 010-024 in Section 10.

Replace the six injectors. Injector trim codes need to be updated when the injectors are replaced on ISC and ISL CM2150 engines.

  • For ISB engines, use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-026 in Section 6.
  • For ISC and ISL engines, use the following procedure in the ISC and ISL CM2150 Engines Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.

Go to 8A

Go to 8A

Guided Step 7 - Check the duty cycle of the application.

Guided Step 7A - Check the aftertreatment duty cycle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the duty cycle.

  • Use INSITE™ electronic service tool to view the duty cycle of the engine.
  • View the aftertreatment trip information.

Determine if the duty cycle of the application needs to change in order to increase the temperature of the exhaust gases entering the aftertreatment system.

Duty cycle of the application needs to be increased?
YES NO

Change the duty cycle of the application in order to increase the temperature of the exhaust gases entering the aftertreatment system.

No Repair

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available for Fault Code 1981 and/or 1922.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If the ECM calibration was already checked and updated in Guided Step 4, then skip this step and immediately proceed to Guided Step 8B.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Mar-2013


FAULT CODE 1938 - ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check the battery connections. | Battery connections tight and free of corrosion?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal?
STEP 2. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 2A. Inspect the OEM power harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the ECM power harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the OEM power harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 2F. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1938 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery terminals for corrosion or loose connections.

  • Inspect the battery terminal connections on both positive (+) and negative (-) terminals.

Battery connections tight and free of corrosion?
YES NO
No Repair

Tighten the loose connections and clean the terminals.

See OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage.

Normal Conditions:

  • At least +12 volts of direct current (VDC) (12 VDC systems)
  • At least +24 VDC (24 VDC systems)

Battery voltage acceptable in normal conditions?
YES NO
No Repair

Charge or replace the batteries.

See OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM power harness.

Guided Step 2A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM power harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the ECM power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure fore general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires.

See the OEM troubleshooting and repair manual.

Continue troubleshooting the battery system until the cause of the low battery voltage is located.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1938 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts

Last Modified: 15-Oct-2015


FAULT CODE 1942 - Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather Element | Refer to Procedure 003-019 | Signature™, ISX, and QSX15 | 3666239
Crankcase Breather Element | Refer to Procedure 003-019 | ISM, ISMe, and QSM11 | 3666322
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX CM871 and ISM CM876 | 4021560

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1942 active?
 | STEP 1B. Check for Fault Codes 1843 and 1844. | Fault Code 1843 or 1844 active?
STEP 2. | Check the system. |
 | STEP 2A. Check the oil fill cap. | Oil fill cap properly installed?
 | STEP 2B. Check the crankcase breather outlet hose. | Crankcase breather outlet hose free of restrictions?
 | STEP 2C. Check the crankcase breather inlet hose, if equipped. | Crankcase breather hose connected properly and free of kinks or other damage?
STEP 3. | Check the sensor and system. |
 | STEP 3A. Check the crankcase pressure sensor. | Sensor reading 0 +- 30.5 mm [0 +- 1.2 in] H2O?
 | STEP 3B. Check the crankcase pressure sensor. | Maximum Measured Value minus Minimum Measured Value greater than 17.8 mm [0.7 in] H2O?
 | STEP 3C. Check the crankcase breather filter element. | Crankcase breather filter element installed correctly?
 | STEP 3D. Check the crankcase breather inlet hose. | Crankcase breather inlet hose free of restrictions?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1942 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for Fault Codes 1843 and 1844.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 or 1844 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the system.

Guided Step 2A - Check the oil fill cap.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil fill cap.

  • Check the oil fill cap for proper installation.

Oil fill cap properly installed?
YES NO
No Repair

Install the oil fill cap properly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the crankcase breather outlet hose.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankcase breather outlet hose.

  • Inspect the crankcase breather outlet hose for kinking or other restrictions.
  • Inspect the crankcase breather outlet hose for ice

Crankcase breather outlet hose free of restrictions?
YES NO
No Repair

Clean or replace the crankcase breather outlet hose as necessary.

Go to 2C

Go to 4A

Guided Step 2C - Check the crankcase breather inlet hose, if equipped.

Conditions

  • Turn keyswitch OFF.
  • If the engine is not equipped with a crankcase filter hose, skip to Step 3A.

Action

Check the crankcase breather hose between the engine and the crankcase filter assembly.

  • Make sure the breather hose is properly connected and there are no kinks or other damage present.

Crankcase breather hose connected properly and free of kinks or other damage?
YES NO
No Repair

Clean or replace and properly connect the crankcase breather hose as necessary.

Go to 3A

Go to 4A

Guided Step 3 - Check the sensor and system.

Guided Step 3A - Check the crankcase pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Do not start the engine.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase pressure sensor.

  • Use INSITE™ electronic service tool to monitor the crankcase pressure sensor signal.
  • Click Data Monitor/Logger in the view bar. Click on All Parameters and find the crankcase pressure and monitor in the parameter list.

Sensor reading 0 +- 30.5 mm [0 +- 1.2 in] H2O?

YES NO
No Repair

A malfunctioning crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check the crankcase pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase pressure sensor

  • Use INSITE™ electronic service tool to monitor the crankcase pressure sensor signal at keyswitch ON and engine OFF.
  • Start and run the engine at high idle for 5 minutes.
  • Use INSITE™ electronic service tool to monitor the crankcase pressure sensor signal at high idle. Click Data Monitor/Logger in the view bar, then click on All Parameters and find the crankcase pressure and monitor in the parameter list.
  • Subtract the Minimum Measured value from the Maximum Measured Value.

Maximum Measured Value minus Minimum Measured Value greater than 17.8 mm [0.7 in] H2O?

YES | NO
No Repair | No Repair

Go to 3D

Go to 3C

Guided Step 3C - Check the crankcase breather filter element.

Conditions

  • Turn keyswitch OFF.

Action

Check the crankcase breather filter element.

  • Check to see if the crankcase breather filter element is installed correctly.

Crankcase breather filter element installed correctly?
YES NO

A malfunctioning crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 in the Associated Procedures Table.

Install the crankcase breather filter element correctly.

Refer to Procedure 003-019 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check the crankcase breather inlet hose.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather inlet hose.

Action

Check the crankcase breather inlet hose.

  • Check the crankcase breather inlet hose for restrictions or other damage.

Crankcase breather inlet hose free of restrictions?
YES NO

Replace the crankcase breather filter element.

Refer to Procedure 003-019 in the Associated Procedures Table.

Clean or replace the crankcase breather hose as necessary.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 221 or 249 inactive?
 | STEP 1C. Check the barometric pressure sensor reading. | Is the barometric pressure reading ± 25.4 mm Hg [± 1.0 in Hg] from the value in the table?
 | STEP 1D. Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in Fault Code 1943 Snapshot Data. | Are the values for Turbocharger Compressor Inlet Temperature greater than 14°C [25°F] above the ambient air temperature, or Turbocharger Compressor Outlet Temperature (calculated) above 227°C [440°F]?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1943 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 221 or 249 inactive?
YES | NO
No Repair | No Repair

Fault Code 221 or 249

Go to 1C

Guided Step 1C - Check the barometric pressure sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor reading.

  • Use INSITE™ electronic service tool to read the value for the barometric pressure.

Refer to Procedure 018-028 (Barometric Pressure at Altitude) in Section V.

Is the value for the barometric pressure within ± 25.4 mm Hg [± 1 in Hg]?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 (Barometric Air Pressure Sensor) in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in the Fault Code 1943 Snapshot Data.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Expand and read Fault Code 1943 Snapshot Data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data.

Check the values for parameters:

  • Turbocharger Compressor Inlet Temperature
  • Turbocharger Compressor Outlet Temperature.

Are the values for Turbocharger Compressor Inlet Temperature greater than 14°C [25°F] above the ambient air temperature, or Turbocharger Compressor Outlet Temperature (calculated) above 227°C [440°F]?

YES | NO
No Repair | No Repair

Contact the OEM

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Unless the failure is a failed barometric pressure or intake manifold pressure sensor, this fault code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code and to determine if the failure has been found and fixed.

Fault Code 1943 inactive?
YES NO

No repair. This fault code is triggered to derate the engine for protection and emissions.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the VGT actuator cooling system. |
 | STEP 1A. Check for active fault codes. | Fault codes related to high coolant temperature are active or high counts of inactive coolant temperature-related faults?
 | STEP 1B. Inspect VGT actuator coolant lines for links and blockages. | Blockages found in the VGT actuator cooling plate or coolant lines?
STEP 2. | Check the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1962 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the VGT actuator cooling system.

Guided Step 1A - Check for fault codes 1843 and 1844.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to high coolant temperature are active or high counts of inactive coolant temperature-related faults?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Inspect VGT actuator coolant lines for links and blockages.

Action

Inspect VGT actuator coolant lines for kinks and blockages.

  • Blow shop air reverse through the VGT actuator cooling plate to check blockages.

Blockages found in the VGT actuator cooling plate or coolant lines?
YES NO

Repair or replace the blocked coolant line.

  • Refer to Procedure For ISB CM2150 engines, 010-041 in the ISB CM2150 Service Manual, Bulletin 4021578.
  • Refer to Procedure For ISC and ISL CM2150 engines, 010-041 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1962 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2010


FAULT CODE 1966 - Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1665, 1666, 1667, 1674, 1675, or 1676 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the intake air system. |
 | STEP 2A. Inspect the intake air system for leaks. | Air leak detected?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Injector misfire detected?
 | STEP 3B. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger outlet?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665, 1666, 1667, 1674, 1675, or 1676 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect electronic service tool.
  • Idle engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the intake air system.

Guided Step 2A - Inspect the intake air system for leaks.

Conditions

  • Start the engine and run at high idle.

Action

Check hoses, clamps, and pipes for leaks.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-024 in Section 6.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-024 in Section 6.

Air leak detected?
YES NO

Repair or replace any damaged components.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-024 in Section 6.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-024 in Section 6.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Check for an injector misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.
  • Determine if a cylinder misfire is detected at any engine speed and operating condition.

Injector misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.

Replace the injector, if necessary.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-026 in Section 6.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

  • Inspect for a sign of moisture in the turbocharger exhaust outlet.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Inspect the engine for other sources of engine oil or diesel fuel entering the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-May-2014


FAULT CODE 1968 - Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1665, 1666, 1667, 1674, 1675, or 1676 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Injector misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665, 1666, 1667, 1674, 1675, or 1676 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Electronic service tool connected.
  • Engine idling for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Check for an injector misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.
  • Determine if a cylinder misfire is detected at any engine speed and operating condition.

Injector misfire detected?
YES NO

Determine the cause of the misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.

Replace the injector, if necessary.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-026 in Section 6.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of oil or fuel in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Inspect the engine for other sources of engine oil or diesel fuel entering the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2014


FAULT CODE 1969 - Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1665, 1666, 1667, 1674, 1675, or 1676 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Injector misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Injector oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665, 1666, 1667, 1674, 1675, or 1676 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect electronic service tool.
  • Idle engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Check for an injector misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.
  • Determine if a cylinder misfire is detected at any engine speed and operating condition.

Injector misfire detected?
YES NO

Determine the cause of the misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.

Replace the injector, if necessary.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-026 in Section 6.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of oil or fuel in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Inspect the engine for other sources of engine oil or diesel fuel entering the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Go to 4A

Go to 4A

Guided Step 4 - Check engine contol module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-May-2014


FAULT CODE 1972 - Exhaust Gas Temperature 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 1877, 1876, or 1878 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
 | STEP 1C. Check the diesel oxidation catalyst. | Diesel oxidation catalyst face plugged?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Injector misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 4A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the inlet face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877, 1876, or 1878 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect electronic service tool.
  • Idle engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness.

  • Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors.

  • Refer to Procedure 019-449 in Section 19.

No Repair

Go to 5A

Go to 1C

Guided Step 1C - Check the diesel oxidation catalyst.

Conditions

  • Inspect the diesel oxidation catalyst. For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Action

Inspect the diesel oxidation catalyst for face plugging. A face plugged aftertreatment can cause hydrocarbon during aftertreatment injection to be carried to the diesel particulate filter, creating high diesel particulate filter outlet temperatures.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • For ISC and ISL CM2150 engines, refer to the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Diesel oxidation catalyst face plugged?
YES NO

Remove the diesel oxidation catalyst from the vehicle and clean the face.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578 for DOC cleaning information. Refer to Procedure 011-049 in Section 11.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569 for DOC cleaning information. Refer to Procedure 011-049 in Section 11.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Check for an injector misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.
  • Determine if a cylinder misfire is detected at any engine speed and operating condition.

Injector misfire detected?
YES NO

Determine the cause of the misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.

Replace the injector, if necessary.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-026 in Section 6.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of oil or fuel in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 4A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst.
  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Action

Inspect the aftertreatment catalyst.

Check the inlet face of the aftertreatment diesel oxidation catalyst for soot accumulation.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

More than 50 percent of the cells on the inlet face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall.

Conditions

  • Aftertreatment diesel oxidation catalyst removed.

Action

Inspect the aftertreatment diesel oxidation catalyst.

Check for cracks in the aftertreatment diesel oxidation catalyst cell wall.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jun-2014


FAULT CODE 1973 - Exhaust Gas Temperature 3 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1877, 1876, or 1878 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Injector misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877, 1876, or 1878 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect electronic service tool.
  • Idle engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness.

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to ground.

  • Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors.

  • Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Check for an injector misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.
  • Determine if a cylinder misfire is detected at any engine speed and operating condition.

Injector misfire detected?
YES NO

Determine the cause of the misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.

Replace the injector, if necessary.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 006-026 in Section 6.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of oil or fuel in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Perform a snap acceleration test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage.

  • For ISB CM2150 engines, use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jun-2014


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1974 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1974 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1974 active?
YES NO

Replace the crankcase breather filter.

  • Refer to Procedure For ISB CM2100 and CM2150 engines, 003-021 (Crankcase Ventilation Filter) in Section 3 in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578.
  • Refer to Procedure For ISC and ISL CM2150 engines, 003&ndash;019 (Crankcase Breather Element) in Section 3 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1974 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2010


FAULT CODE 1981 - Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISB CM2100 and CM2150 | 4021578
Injector | Refer to Procedure 006-026 | ISC and ISL CM2150 | 4021569
Air Intake Manifold | Refer to Procedure 010-023 | ISC and ISL CM2150 | 4021569
Air Intake Manifold | Refer to Procedure 010-023 | ISB CM2100 and CM2150 | 4021578
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISC and ISL CM2150 | 4021569
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | ISB CM2100 and CM2150 | 4021578
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC and ISL CM2150 | 4021569
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB CM2100 and CM2150 | 4021578
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISC and ISL CM2150 | 4021569
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB CM2100 and CM2150 | 4021578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Mounting Bracket | Refer to Procedure 011-046 | ISC and ISL CM2150 | 4021569
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Mounting Bracket | Refer to Procedure 011-046 | ISB CM2100 and CM2150 | 4021578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC and ISL CM2150 | 4021569
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB CM2100 and CM2150 | 4021578
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISC and ISL CM2150 | 4021569
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISB CM2100 and CM2150 | 4021578
Aftertreatment Testing | Refer to Procedure 014-013 | ISC and ISL CM2150 | 4021569
Aftertreatment Testing | Refer to Procedure 014-013 | ISB CM2100 and CM2150 | 4021578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 | 4021570

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1879, 1881, or 1883 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1981 active?
 | STEP 1C. Check for exhaust gas recirculation (EGR) system related fault codes. | EGR system related fault codes active or high counts inactive?
STEP 2. | Inspect the aftertreatment diesel particulate filter differential pressure sensor. |
 | STEP 2A. Check the aftertreatment diesel particulate filter differential pressure sensor orientation. | Aftertreatment diesel particulate filter differential pressure sensor and tubes correct?
 | STEP 2B. Verify the aftertreatment diesel particulate filter differential pressure sensor accuracy. | Aftertreatment diesel particulate filter differential pressure sensor signal voltage within specification with the keyswitch ON and the engine OFF?
 | STEP 2C. Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage. | Aftertreatment diesel particulate filter differential pressure sensor supply tubes blocked?
STEP 3. | Inspect the aftertreatment exhaust gas temperature sensors and wiring. |
 | STEP 3A. Inspect the aftertreatment temperature sensor connectors for correct installation locations. | Aftertreatment temperature sensors installed correctly?
 | STEP 3B. Inspect the aftertreatment wiring harness connectors for correct pin installation. | Aftertreatment wiring installed correctly?
STEP 4. | Check the ash cleaning maintenance interval. |
 | STEP 4A. Check the ash cleaning maintenance interval. | Ash cleaning interval has been followed?
 | STEP 4A-1. Perform the Aftertreatment Maintenance Filter Installation procedure. |
 | STEP 4B. Perform the Aftertreatment Maintenance Filter Installation procedure. | Fault Code 1981 inactive?
STEP 5. | Check if an engine control module (ECM) calibration update is available for Fault Code 1981. |
 | STEP 5A. Troubleshoot the cause of aftertreatment diesel particulate filter plugging. | Excessive black smoke during acceleration or constant black smoke at high idle?
 | STEP 5A-1. Check if an ECM calibration update is available for fault code 1981. |
 | STEP 5A-2. Troubleshoot the cause of aftertreatment diesel particulate filter plugging. |
 | STEP 5B. Check if an ECM calibration update is available for fault code 1981. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 6. | Check for active or inactive counts of Fault Code 3616, 2449, or 2387. |
 | STEP 6A. Inspect the turbocharger shaft movement. | Active or inactive counts of Fault Code 3616, 2449, or 2387?
STEP 7. | Inspect the exhaust. |
 | STEP 7A. Troubleshoot cause for aftertreatment diesel particulate filter plugging. | Grid heater plugging found?
 | STEP 7B. Troubleshoot cause of aftertreatment diesel particulate filter plugging. | Cause of aftertreatment diesel particulate filter plugging determined after executing the above tests?
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1981 active?
YES | NO
No Repair | No Repair

Go to 1C

Go to 8A

Guided Step 1C - Check for EGR system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

EGR system related fault codes active or high counts inactive?
YES NO

See the appropriate troubleshooting tree for the EGR system fault code.

It will also be necessary to inspect and clean or replace the aftertreatment diesel particulate filter. Use the following instructions to remove, inspect, and clean or replace the aftertreatment diesel particulate filter.

  • Refer to Procedure 011-041 in the Associated Procedures Table.

Use the following instructions to remove, inspect, and clean or replace the diesel oxidation catalyst.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

NOTE: If the aftertreatment diesel particulate filter does not meet the inspection criteria in the following procedure, it must be replaced. Refer to Procedure 011-041 in the Associated Procedures Table.

Aftertreatment diesel particulate filters that meet the inspection criteria and are cleaned in an SPX air pulse cleaning machine, or equivalent, must have a stationary regeneration after the cleaning process is complete.

No Repair

Go to 8A

Go to 2A

Guided Step 2 - Inspect the aftertreatment diesel particulate filter differential pressure sensor.

Guided Step 2A - Aftertreatment diesel particulate filter differential pressure sensor orientation.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment differential pressure sensor and sensor tubes for proper orientation. Improper orientation will not allow water to drain correctly.

  • Check for proper location of the diesel particulate filter differential pressure sensor.
  • Check for a 10 degree diesel particulate filter differential pressure tube angle.
  • Refer to Procedure 011-046 in the Associated Procedures Table.

Aftertreatment diesel particulate filter differential pressure sensor and tubes correctly located?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2B

Guided Step 2B - Verify the aftertreatment diesel particulate filter differential pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy.

  • Monitor the aftertreatment diesel particulate filter differential pressure sensor signal voltage reading with INSITE™ electronic service tool.
  • Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment diesel particulate filter differential pressure sensor signal voltage within specification with the keyswitch ON and the engine OFF?

YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

Action

Disconnect the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.
  • Inspect the supply tubes for blockage.

Aftertreatment diesel particulate filter differential pressure sensor supply tubes blocked?
YES NO

Remove and clean the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

  • Check for a short circuit from the SIGNAL pin of the aftertreatment diesel particulate filter differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • If no short circuit is found, replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 3 - Inspect the aftertreatment exhaust gas temperature sensors and wiring.

Guided Step 3A - Inspect the aftertreatment temperature sensor connectors for correct installation locations.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the aftertreatment temperature sensor connectors.

Inspect the exhaust aftertreatment temperature sensor connectors to verify that they are connected to the correct connector on the aftertreatment system wiring harness. Two of the temperature sensors have identical wiring harness connectors. The sensors are the same part number and it is possible to install the wiring harness connectors to the wrong sensors.

To verify the correct sensor locations, use INSITE™ electronic service tool to monitor the aftertreatment temperature sensor voltages.

  • Unplug each of the aftertreatment temperature sensors one at a time.
  • If the voltage changes when you unplug the sensor, then the wiring harness connector is connected to the correct sensor.
  • If the voltage does not change, switch the connector location to the other temperature sensor. Then unplug it and check for a voltage change.

Aftertreatment temperature sensors installed correctly?
YES NO
No Repair

Connect each of the aftertreatment temperature sensors in the correct locations by following the steps outlined in the Action section.

Go to 3B

Go to 8A

Guided Step 3B - Inspect the aftertreatment wiring harness connectors for correct pin installation.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment wiring harness connectors for correct pin installation.

  • Inspect the aftertreatment sensor and wiring harness connectors for correct pin installation locations.

Reference the wiring diagram for connector pin identification and locations.

Aftertreatment wiring installed correctly?
YES NO
No Repair

Install the pins in their correct connector locations.

Reference the wiring diagram for connector pin identification and location.

Go to 4A

Go to 8A

Guided Step 4 - Check the ash cleaning maintenance interval.

Guided Step 4A - Check the ash cleaning maintenance interval.

Conditions

n/a

Action

Check the ash cleaning maintenance interval.

  • Check the ash cleaning maintenance interval of the diesel particulate filter. It is possible the ash cleaning interval has been ignored and the filter needs to be cleaned.

Reference the Operation and Maintenance manual for the recommended ash cleaning interval.

Ash cleaning interval has been followed?
YES NO

The aftertreatment diesel particulate filter has plugged with soot and the stationary regeneration procedure can not be performed until it has been inspected and cleaned in an SPX air pulse cleaning machine, or equivalent.

  • Remove, inspect, and clean or replace the aftertreatment diesel particulate filter. Refer to Procedure 011-041 in the Associated Procedures Table.
  • Remove, inspect, and clean or replace the diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

NOTE: If the aftertreatment diesel particulate filter does not meet the inspection criteria in the following procedure, it must be replaced. Refer to Procedure 011-041 in the Associated Procedures Table.

A stationary regeneration is not necessary on filters that are replaced, unless Fault Code 1922 is also active.

Aftertreatment diesel particulate filters that meet the inspection criteria and are cleaned in an SPX air pulse cleaning machine, or equivalent, must have a stationary regeneration after the cleaning process is complete.

Clean the aftertreatment diesel particulate filter. Refer to Procedure 011-041 in the Associated Procedures Table.

Go to 4B

Go to 4A-1

Guided Step 4A-1 - Perform the Aftertreatment Maintenance Filter Installation procedure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use the Aftertreatment Maintenance Filter Installation procedure to disable Fault Code 1981.

Perform the Aftertreatment Maintenance Filter Installation procedure.

Fault Code 1981 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8A

Go to 1A

Guided Step 4B - Perform the Aftertreatment Maintenance Filter Installation procedure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use the Aftertreatment Maintenance Filter Installation procedure to disable Fault Code 1981.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Filter Installation procedure, found under the Advanced ECM Data Section.

Fault Code 1981 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5 - Check if an ECM calibration update is available for Fault Code 1981.

Guided Step 5A - Troubleshoot the cause of the aftertreatment diesel particulate filter plugging.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Refer to Procedure 014-013 in the Associated Procedures Table.

To perform a Snap Acceleration Test, it could be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES | NO
No Repair | No Repair

Go to 5A-1

Go to 5B

Guided Step 5A-1 - Check if an ECM calibration update is available for Fault Code 1981.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Calibrate the ECM with the calibration containing corrections to resolve Fault Code 1981.

  • Refer to Procedure 019-032 in Section 19.

Go to 6A

Go to 5A-2

Guided Step 5A-2 - Troubleshoot the cause of aftertreatment diesel particulate filter plugging.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.

Note: To perform a Snap Acceleration Test, it could be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Is there excessive black smoke during acceleration or constant black smoke at high idle?
YES | NO
No Repair | No Repair

Go to 6A

Go to 8A

Guided Step 5B - Check if an ECM calibration update is available for Fault Code 1981.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Calibrate the ECM with the calibration containing corrections to resolve Fault Code 1981.

  • Refer to Procedure 019-032 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Check for active or inactive counts of Fault Code 3616, 2449, or 2387.

Guided Step 6A - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch ON.

Action

Monitor fault codes with INSITE™ electronic service tool and look for active or inactive occurrences of Fault Code 3616, 2449, or 2387.

Active or inactive counts of Fault Code 3616, 2449, 2387?
YES NO

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

Move the sector gear lever on the turbocharger bearing housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever can be moved to the other stop position by hand.

If the nozzle does not slide evenly from stop to stop or the gear teeth are damaged, then a turbocharger malfunction has been detected.

Note: This malfunction could have been caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger actuator or assembly, or if the nozzle slides evenly from stop to stop and the gear teeth are undamaged, install the turbocharger actuator using the following procedures and procede to Guided Step 7A.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 7A

Guided Step 7 - Inspect the exhaust.

Guided Step 7A - Troubleshoot the cause of aftertreatment diesel particulate filter plugging.

Conditions

  • Turn keyswitch OFF.
  • Turn the engine OFF.

Action

Disconnect the air intake elbow and inspect the grid heater for plugging using a small mirror and a flashlight.

Inspect the grid heater for plugging.

Grid heater plugging found?
YES NO

  • Refer to Procedure 010-023 in the Associated Procedures Table.

 No Repair

Go to 7B

Go to 7B

Guided Step 7B - Troubleshoot the cause of aftertreatment diesel particulate filter plugging.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Perform the following:

  • Check the air intake restriction.
  • Check the air intake and exhaust system for leaks.
  • Perform a Cylinder Cutout Test to check for misfire.
  • Check for proper overhead adjustment.

Cause of aftertreatment diesel particulate filter plugging determined after executing the above tests?
YES NO

Make necessary repairs to air intake or fuel systems based on results from the above tests.

For information regarding intake and exhaust system leak detection on ISB CM2150 engines, use the following procedure. Refer to Procedure 010-024 in the Associated Procedures Table.

Replace the six injectors. The injector trim codes need to be updated when the injectors are replaced on ISC and ISL CM2150 engines.

For information regarding injector removal and installation on ISB CM2150 engines, use the following procedure. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Sep-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1879, 1881, or 1883 active?
STEP 2. | Inspect the aftertreatment diesel particulate filter differential pressure. |
 | STEP 2A. Use INSITE™ electronic service tool to monitor aftertreatment system | Changes in differential pressures?
 | STEP 2B. Check the aftertreatment diesel particulate filter differential pressure sensor tubes. | Aftertreatment diesel particulate filter differential pressure sensor tubes installed correctly?
STEP 3. | Check the pressure of the aftertreatment diesel particulate filter. |
 | STEP 3A. Inspect the aftertreatment diesel particulate filter. | Tampering or removal of the aftertreatment system has been detected?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1993 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment diesel particulate filter differential pressure.

Guided Step 2A - Using INSITE™ electronic service tool to monitor aftertreatment system.

Conditions

  • Verify that all components are properly assembled and connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment differential pressure sensor operation.

  • Run the engine at varying speeds and loads.
  • Use INSITE™ electronic service tool to monitor aftertreatment differential pressure sensor operation. Look for changes in delta pressures with changes in engine speed and load.

Changes in differential pressures?
YES NO
No Repair

Replace the differential pressure sensor.

Refer to Procedure 019-443 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Check the aftertreatment diesel particulate filter differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel particulate filter differential pressure sensor tubes for the following:

  • Leaks or cracks in the differential pressure sensor tubes
  • Loose fittings on the differential pressure sensor tubes
  • Missing or broken differential pressure sensor tubes
  • Plugged tubes
  • Make sure the differential pressure tubes are installed correctly. It is possible the differential pressure tubes are connected backwards at the rubber tubes at the sensor connection. Refer to Procedure 019-443 in Section 19.

Aftertreatment diesel particulate filter differential pressure sensor tubes are installed correctly?
YES NO
No Repair

Repair or replace the aftertreatment diesel particulate filter differential pressure sensor tubes.

  • Use the following procedure for ISB CM2150 engine. Refer to Procedure 011-047 in Section 11.
  • Use the following procedure for ISC and ISL CM2150 engines. Refer to Procedure 011-047 in Section 11.

Go to 3A

Go to 4A

Guided Step 3 - Check the presence of the aftertreatment diesel particulate filter.

Guided Step 3A - Inspect the aftertreatment diesel particulate filter.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment diesel particulate filter.
  • Use the following procedure for ISB CM2150 engines. Refer to Procedure 011-041 in Section 18.
  • Use the following procedure for ISC and ISL CM2150 engines. Refer to Procedure 011-041 in Section 11.

Action

Inspect the aftertreatment diesel particulate filter.

Inspect the aftertreatment system to determine if the aftertreatment diesel particulate filter has been tampered with or has been removed from the exhaust system.

  • Use the following procedure for ISB CM2150 engines. Refer to Procedure 011-041 in Section 11.
  • Use the following procedure for ISC and ISL CM2150 engines. Refer to Procedure 011-041 in Section 11.

Tampering or removal of the aftertreatment system has been detected?
YES NO

Install the correct aftertreatment system for the vehicle.

  • Use the following procedure for ISB CM2150 engines. Refer to Procedure 011-041 in Section 11 .
  • Use the following procedure for ISC and ISL CM2150 engines. Refer to Procedure 011-041 in Section 11.

Replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to Procedure 019-443 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Run the engine at high idle for 1 minute or until the fault code goes inactive. This fault requires the exhaust flow to be above a minimum value before the fault goes inactive.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1993 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair compete

Appropriate troubleshooting steps

Last Modified: 23-Jan-2012


FAULT CODE 2182 - Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Engine Control Module | Refer to Procedure 019-031 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 Electronic Control System | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 Electronic Control System | 4021570
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISC and ISL CM2150 | 4021569

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2182 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Less than 10 ohms?
 | STEP 2C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check the engine brake solenoid for an open circuit. | Between 5 and 15 ohms?
 | STEP 3B. Check for an open circuit in the ECM. | Engine brake number 1 operate?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2182 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2182 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 1 wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL wire at the engine brake solenoid to the engine brake solenoid number 1 SIGNAL wire at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 1 signal circuit has been detected in the engine harness. The open circuit is in one of the following harnesses:

  • The main engine harness between the ECM and the 2-pin connector at the back of the engine.
  • The engine brake jumper harness between the engine harness 2-pin connector at the back of the engine and the rocker lever housing.
  • The internal engine brake harness between the rocker lever housing and the engine brake solenoid.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3E

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 wire from the engine brake pass-through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Reference the circuit or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL wire has been detected in the engine.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3E

Guided Step 3 - Check the engine brake solenoid for an open circuit.

Guided Step 3A - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid terminal pin to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from solenoid 2.
  • Turn keyswitch ON.
  • Enable Engine Brake Control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Delay time set to zero.
  • Select 100 percent braking with the manual dash-switch.
  • Connect the INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure that all conditions are met for the engine brakes to operate; for example: clutch not depressed and zero percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 1 operate?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Jan-2015


FAULT CODE 2183 - Engine Brake Actuator Circuit 1 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Engine Control Module | Refer to Procedure 019-031 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 Electronic Control System | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 Electronic Control System | 4021570
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISC and ISL CM2150 | 4021569

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758; female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917; male Weather Pack™ test lead, Part Number 3823995; female Weather Pack™ test lead, Part Number 3823996.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2183 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater thank 100k ohms?
STEP 3. | Check the engine brake solenoid. |
 | STEP 3A. Check the engine brake solenoid for a short-to-ground. | 5 ohms or greater?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 1 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2183 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an intermittent or inactive fault code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 1 SUPPLY wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 1 SUPPLY wire at the engine brake solenoid and the engine brake solenoid number 1 SIGNAL wire at the ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 1 SIGNAL circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 from the engine brake pass through connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the short-to-ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 1 from the engine brake pass through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocket lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the engine brake number 1 solenoid terminal pin to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance of the engine brake number 1 solenoid SUPPLY terminal pin to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Enable engine brake control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch leve, and fault codes.
  • Make sure all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 1 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jul-2014


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2B-1. Check for an unswitched battery supply OEM connector. |
 | STEP 2B-2. Check for a pin-to-pin short circuit in the unswitched battery supply OEM harness. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Short circuit pin-to-pin check:

  • Measure the resistance between the accelerator pedal position +5 volt SUPPLY and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for an unswitched battery supply OEM connector.

Conditions

  • Turn keyswitch OFF.

Action

Check for an unswitched battery supply.

  • Check to make sure the ECM power connection is a dedicated power supply and does not supply power to any other devices between the ECM and battery.

This dedicated connector provides unswitched battery voltage to the ECM and will be in addition to the primary OEM connector.

Dedicated unswitched battery supply OEM connector?
YES | NO
No Repair | No Repair

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check for a pin-to-pin short circuit in the unswitched battery supply OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt SUPPLY and the ECM battery SUPPLY (+) pins in the OEM power harness connector

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3 - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Oct-2015


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin to ground short circuit in the OEM harness. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2186 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the accelerator pedal/lever position sensor.

See the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the OEM harness connector or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt SUPPLY and all other pins in the OEM harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator +5 volt SUPPLY pin and engine block ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2186 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 15-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2195 is active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2195 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2195 is active?
YES NO

The fault code indicates that the emergency door of the vehicle has been opened.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2195 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair compete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


FAULT CODE 2198 - VGT Actuator Driver Circuit - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2636 active?
STEP 2. | Check the VGT actuator circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the sensor condition. | Fault Code 2198 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 2198 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2198 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 active?
YES | NO
No Repair | No Repair

Fault Code 2636 troubleshooting tree

Go to 2A

Guided Step 2 - Check the VGT actuator circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniquesfor Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the VGT actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the VGT actuator.

  • Use the following procedure for ISB CM2150 engines. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure for ISC and ISL CM2150 engines. Refer to Procedure 010-134 in Section 10.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Mar-2012


FAULT CODE 2265 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2265 active?
STEP 2. | Check the electric fuel control lift pump. |
 | STEP 2A. Inspect the engine harness and electric fuel control lift pump connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the lift pump. | Less than 10 ohms?
 | STEP 2C. Check the fuel control lift pump diagnostic supply voltage and return circuit. | Voltage between 2.5 and 4.0 volts of direct current (VDC)?
 | STEP 2D. Check for an open circuit in the fuel lift pump return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM lift pump diagnostic supply voltage. | Voltage between 2.5 and 4.0 VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2265 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2265 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 in Section 19.

Guided Step 2 - Check the electric fuel control lift pump.

Guided Step 2A - Inspect the engine harness and fuel control lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel control lift pump.

Action

Inspect the engine harness and fuel control lift pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the lift pump.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel control lift pump.

Action

Check for an open circuit in the electric fuel control lift pump.

  • Measure the resistance between the electric fuel lift pump relay SUPPLY and the fuel lift pump RETURN pin at the electric fuel supply pump connector

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the electric fuel lift pump.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 005-045 in Section 5.
  • Use the following procedure in ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 005-045 in Section 5.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel control lift pump diagnostic supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel pump.
  • Turn keyswitch ON.
  • Wait a minimum of 2 minutes.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the fuel lift pump SUPPLY pin and the fuel lift pump RETURN pin at the lift pump connector of the engine harness.

The keyswitch must be turned ON for more than 2 minutes before the check can be performed.

Use the circuit diagram or the wiring diagram for connector pin identification.

Voltage between 2.5 and 4.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the fuel lift pump return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness lift pump RETURN pin and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM lift pump diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Wait a minimum of 2 minutes.

Action

Check the supply voltage.

  • Measure the voltage between the fuel lift pump SUPPLY pin and the fuel lift pump RETURN pin at the engine harness ECM connector port.

The keyswitch must be turned ON for more than 2 minutes before the check can be performed.

Use the circuit diagram or wiring diagram for connector pin identification.

Voltage between 2.5 and 4.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the lift pump from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel lift pump SUPPLY pin at the fuel lift pump connector and the fuel lift pump SUPPLY pin at the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the lift pump from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine harness ECM connector and all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823993 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2266 active?
STEP 2. | Check the electric fuel lift pump. |
 | STEP 2A. Inspect the engine harness and electric fuel lift pump relay connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2265 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2266 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2265 active?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2266 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2266 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the electric fuel lift pump.

Guided Step 2A - Inspect the engine harness and fuel lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.

Action

Inspect the engine harness and fuel control lift pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel lift pump from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel lift pump to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 active?
YES NO

A damaged fuel lift pump has been detected.

Replace the fuel lift pump.

  • Refer to Procedure For ISB CM2150 engines, 005-045 (Fuel Lift Pump) in Section 5 in the ISB CM2150 Service Manual, Bulletin 4021578.
  • Refer to Procedure For ISC and ISL CM2150 engines, 005&ndash;045 (Fuel Lift Pump) in Section 5 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 2265 active?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel lift pump from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel lift pump from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) and wiring diagram, .

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 is inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
STEP 2. | Check the EGR valve motor and circuit. |
 | STEP 2A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2272 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness |
 | STEP 3A-2. Check for a short circuit in the engine harness. |
 | STEP 3A-3. Check for a short circuit to ground. |
 | STEP 3A-4. Check the fault codes. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2272 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352 troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR valve motor and circuit.

Guided Step 2A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Inspect the engine harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 (Weather Pack&trade; Connector Series) in Section 19.Repair the engine harness. Refer to Procedure 019-202 (Metri-Pack&trade; Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the EGR valve position +5 volt SUPPLY pin to the EGR valve position RETURN pin at the EGR valve connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve motor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure Repair the engine harness. 019-201 (Weather Pack&trade; Connector Series) in Section 19. Refer to Procedure Repair the engine harness. 019-202 (Metri-Pack&trade; Connector Series) in Section 19.
  • Refer to Procedure Replace the engine harness. 019-043 (Engine Wiring Harness) in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for an open circuit in the EGR position circuit.

  • Measure the resistance between the EGR valve position SIGNAL A pin at the EGR valve engine harness connector and the EGR valve position SIGNAL A pin at the ECM engine harness connector.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the EGR valve engine harness connector and the EGR valve position SIGNAL B pin at the ECM engine harness connector.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the EGR valve engine harness connector and the EGR valve position SIGNAL C pin at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for an short circuit in the EGR position circuit.

  • Measure the resistance between the EGR valve position SIGNAL A pin at the ECM engine harness connector and all other pins in the ECM connector.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the ECM engine harness connector and all other pins in the ECM connector.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the ECM engine harness connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for a short circuit to ground.

  • Measure the resistance between the EGR valve position SIGNAL A pin at the ECM engine harness connector and ground.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the ECM engine harness connector and ground.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the ECM engine harness connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

Replace the EGR valve motor.

  • Refer to Procedure For ISB 6.7L CM2100 and CM2150 engines, 011-022 (EGR Valve) in Section 11 in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578.
  • Refer to Procedure For ISC and ISL CM2150 engines, 011-022 (EGR Valve) in Section 11 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure Repair the engine harness. 019-201 (Weather Pack&trade; Connector Series) in Section 19. Refer to Procedure Repair the engine harness. 019-202 (Metri-Pack&trade; Connector Series) in Section 19.
  • Refer to Procedure Replace the engine harness. 019-043 (Engine Wiring Harness) in Section 19.
  • Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the EGR valve position +5 volt SUPPLY pin to EGR valve position RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2272 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2273 inactive?
STEP 2. | Check the EGR valve delta pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR valve delta pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2274 active and Fault Code 2273 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2273 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2273 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the EGR valve delta pressure sensor and circuit.

Guided Step 2A - Inspect the EGR valve delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR valve delta pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR valve delta pressure sensor SUPPLY pin to the EGR valve delta pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve delta pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A defective sensor has been detected.

Replace the EGR valve delta pressure sensor.

Refer to Procedure 019-370 (EGR Differential Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR valve delta pressure sensor SUPPLY pin to the EGR valve delta pressure sensor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2273 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2010


FAULT CODE 2274 - Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2274 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) valve delta pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR valve delta pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response. | Fault Code 2273 active and Fault Code 2274 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2274 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2274 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 352 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the EGR valve delta pressure sensor and circuit.

Guided Step 2A - Inspect the EGR valve delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR valve delta pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR valve delta pressure sensor SUPPLY pin to the EGR valve delta pressure sensor RETURN pin at the sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR valve delta pressure sensor SUPPLY pin and the EGR valve delta pressure sensor SIGNAL pin at the EGR valve delta pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

See the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2273 active and Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve delta pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

A damaged sensor has been detected.

Replace the EGR valve delta pressure sensor.

Refer to Procedure 019-370 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or place the engine harness, original equipment manufacturer (OEM) harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. See the OEM troubleshooting and repair manual.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR valve delta pressure sensor SUPPLY pin to the EGR valve delta pressure sensor RETURN pin at the ECM engine connector.

See the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or place the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. See the OEM troubleshooting and repair manual
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR valve delta pressure sensor SUPPLY pin and the EGR valve delta pressure sensor SIGNAL pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

See the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2273 active and Fault Code 2274 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2274 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2288. | Active or inactive counts of Fault Code 2288?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2288.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive counts of Fault Code 2288.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2288?
YES NO

The engine has been derated due to turbocharger high speed conditions. This is normal operation, but a torque derate was used to protect the engine from exceeding turbocharger high speed limits.

No repair action is necessary.

 No Repair

Repair complete

Repair complete

Last Modified: 20-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 2311 active or high inactive counts?
STEP 2. | Check the fuel pump actuator valve. |
 | STEP 2A. Inspect the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel pump actuator resistance. | Less than 5 ohms?
 | STEP 2C. Check the fuel pump actuator for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2311, 271, and/or 272 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the fuel pump actuator is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel pump actuator.

Guided Step 2A - Inspect the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the actuator connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques and a wiring diagram. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the fuel pump actuator.

Refer to Procedure 019-117 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques and a wiring diagram. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel pump actuator.

Refer to Procedure 019-117 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the engine harness resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques and a wiring diagram. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check the engine harness and fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques and a wiring diagram. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel pump actuator.

If a short or open circuit is induced while the engine is running, the fuel rail pressure relief valve will open.

Fault Codes 2311, 271, and/or 272 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the fuel pump actuator.

Refer to Procedure 019-117 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active or has a high number of inactive counts?
STEP 2. | Check the primary speed sensor circuit (crankshaft sensor). |
 | STEP 2A. Inspect the primary speed sensor connector pins (crankshaft sensor). | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2321 become active during engine operation?
 | STEP 3B. Inspect the air gap and the target wheel. | Air the gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2321 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 is active or has a high number of inactive counts?

Note: If Fault Code 689 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

YES | NO
No Repair | No Repair

Refer to Fault Code 689 troubleshooting tree

Go to 2A

Guided Step 2 - Check the primary speed sensor circuit (crankshaft sensor).

Guided Step 2A - Inspect the primary speed sensor connector pins (crankshaft sensor).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure Refer Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the primary speed sensor.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure Refer Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the primary speed sensor (crankshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. With the engine running, accelerate the engine several times.

  • Use INSITE™ electronic service tool to read the fault codes.

Does Fault Code 2321 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap and target wheel.

  • Remove the primary engine speed sensor (crankshaft) from the engine block and measure the air gap at several points in the crankshaft's revolution.

Refer to Procedure 019-365 in Section 19.

Air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2321 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine speed sensor connector.

Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the engine crankshaft speed/position sensor. Refer to Procedure 019-365 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disabel the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2321 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting trees

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 778 is active or has high number of inactive counts?
STEP 2. | Check the secondary speed sensor circuit (camshaft sensor). |
 | STEP 2A. Inspect the secondary speed sensor (camshaft sensor) connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2322 become active during engine operation?
 | STEP 3B. Inspect air the gap and the target wheel. | Air the gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2322 status change from inactive to active while manipulating the engine harness?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2322 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 is active or has high number of inactive counts?

Note: If Fault Code 778 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

YES | NO
No Repair | No Repair

Refer to Fault Code 778 troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary speed sensor circuit (camshaft sensor).

Guided Step 2A - Inspect the secondary speed sensor (camshaft sensor) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure Refer Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the secondary speed sensor.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure Refer Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the secondary speed sensor (camshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

With the engine running, accelerate the engine several times.

  • Use INSITE™ electronic service tool to read the fault codes.

Does Fault Code 2322 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the secondary engine speed sensor (camshaft sensor) from the gear housing and measure the air gap at several points in the crankshaft's revolution.

Refer to Procedure 019-363 in Section 19.

Air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2322 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine speed sensor connector.

Does Fault Code 2322 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the engine camshaft speed/position sensor. Refer to Procedure 019-363 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2322 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for additional fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 686 and/or 687 active or inactive?
STEP 2. | Check the turbocharger. |
 | STEP 2A. Inspect the turbocharger speed sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Inspect the turbocharger speed sensor. | Turbocharger speed sensor damage found?
 | STEP 2C. Check for an inactive fault code. | Fault Code 2345 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2345 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for additional fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 686 and/or 687 active or inactive?
YES NO

Troubleshoot fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate troubleshooting steps

Go to 2A

Guided Step 2 - Check the turbocharger.

Guided Step 2A - Inspect the turbocharger speed sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the engine harness and turbocharger speed sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure 019-361 in Section 19.For general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, or sensor if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.
  • Remove the turbocharger speed sensor from the turbocharger housing.

Action

Inspect the nose of the turbocharger speed sensor for the following:

  • Cuts or scratches on the nose of the sensor
  • Cuts or scratches on the sensor body
  • A cracked sensor mounting boss.

Turbocharger speed sensor damage found?
YES NO

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2345 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 3A

Fault Code 686 troubleshooting tree

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2345 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Code 2346 active or high inactive counts?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2346 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2346 active or high inactive counts?
YES NO

The engine power output was derated to limit the exhaust temperatures. This is normal operation. No repairs are necessary.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2346 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


FAULT CODE 2347 - Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operational Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Code 2634, 2449, or 2387 active?
 | STEP 1B. Check for inactive fault codes. | Fault Code 295 or 2973 active?
STEP 2. | Check sensor readings. |
 | STEP 2A. Check ambient air pressure sensor accuracy. | INSITE™ electronic service tool reading within 10 cm Hg 4 inHg] of local barometric pressure?
 | STEP 2B. Check the intake manifold pressure sensor accuracy. | Intake manifold pressure reading less than 10 cm Hg [4 inHg]?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2347 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2634, 2449, or 2387 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 295 or 2973 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check sensor readings.

Guided Step 2A - Check the ambient air pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare the INSITE™ electronic service tool reading for Barometric Air Pressure to local barometric pressure. Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading is within 10 cm Hg [4 inHg] of local barometric pressure?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the intake manifold pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the value of Intake Manifold Pressure without the engine running.

Intake Manifold Pressure reading is less than 10 cm Hg [4 inHg]?
YES NO

Use the following troubleshooting symptom tree for information to continue to troubleshoot for low boost pressure in the appropriate Service Manual . Reference the Intake manifold Pressure (Boost) is Below Normal in Section TS.

Replace the intake manifold pressure sensor.

Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Note: Unless the problem is a damaged barometric pressure or intake manifold pressure sensor, this fault code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code, and to determine if the damage has been found and fixed.

Fault Code 2347 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Dec-2011


FAULT CODE 2349 - EGR Valve Control Circuit - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for exhaust gas recirculation (EGR) motor circuit fault codes. | Fault Code 2349 active?
STEP 2. | Check the EGR valve motor and circuit. |
 | STEP 2A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the EGR motor supply. | Greater than 5 ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2349 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the EGR motor supply and return circuit. | Less than 10 ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 2349 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2349 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for EGR motor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2349 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the EGR valve motor and circuit.

Guided Step 2A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Inspect the engine harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the EGR motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Check the EGR motor supply and return circuit.

  • Measure the resistance from the EGR motor SUPPLY A pin to the EGR motor SUPPLY B pin at the EGR motor connector.
  • Measure the resistance from the EGR motor SUPPLY A pin to the EGR motor SUPPLY C pin at the EGR motor connector.
  • Measure the resistance from the EGR motor SUPPLY B pin to the EGR motor SUPPLY C pin at the EGR motor connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 5 ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve motor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2349 active?
YES NO

An open circuit has been detected in the EGR valve motor.

Replace the EGR valve.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 011-022 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-022 in Section 11.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the EGR motor supply and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the EGR motor supply and return circuit.

  • Measure the resistance from the EGR motor SUPPLY A pin at the EGR motor engine harness connector to the EGR motor SUPPLY A pin at the ECM connector.
  • Measure the resistance from the EGR motor SUPPLY B pin at the EGR motor engine harness connector to the EGR motor SUPPLY B pin at the ECM connector.
  • Measure the resistance from the EGR motor SUPPLY C pin at the EGR motor engine harness connector to the EGR motor SUPPLY C pin at the ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2349 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2349 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 2351 - EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for EGR motor circuit fault codes. | Fault Code 2351 active?
STEP 2. | Check the EGR valve motor and circuit. |
 | STEP 2A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the EGR motor supply and return circuits. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2351 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness. |
 | STEP 3A-2. Check for a short circuit in the engine harness. |
 | STEP 3A-3. Check for a short circuit to ground. |
 | STEP 3A-4. Check the fault codes. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the EGR motor supply and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2351 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for EGR motor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the EGR valve motor and circuit.

Guided Step 2A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Inspect the engine harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the EGR motor supply and return circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR motor supply and return circuit.

  • Measure the voltage from the EGR motor SUPPLY A pin to the EGR motor RETURN pin at the motor connector of the engine harness.
  • Measure the voltage from the EGR motor SUPPLY B pin to the EGR motor RETURN pin at the motor connector of the engine harness.
  • Measure the voltage from the EGR motor SUPPLY C pin to the EGR motor RETURN pin at the motor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve motor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for an open circuit in the EGR motor circuit.

  • Measure the resistance between the EGR motor SUPPLY A pin at the EGR valve engine harness connector and the EGR motor RETURN pin at the ECM engine harness connector.
  • Measure the resistance between the EGR motor SUPPLY B pin at the EGR valve engine harness connector and the EGR motor RETURN pin at the ECM engine harness connector.
  • Measure the resistance between the EGR motor SUPPLY C pin at the EGR valve engine harness connector and the EGR motor RETURN pin at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for a short circuit in the EGR motor circuit.

  • Measure the resistance between the EGR motor SUPPLY A pin at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the EGR motor SUPPLY B pin at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the EGR motor SUPPLY C pin at the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for a short circuit to ground.

  • Measure the resistance between the EGR motor SUPPLY A pin at the ECM engine harness connector and ground.
  • Measure the resistance between the EGR motor SUPPLY B pin at the ECM engine harness connector and ground.
  • Measure the resistance between the EGR motor SUPPLY C pin at the ECM engine harness connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 active?
YES NO

Replace the EGR valve motor.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 011-022 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-022 in Section 11.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the EGR motor supply and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the EGR motor supply and return circuit.

  • Measure the voltage from the EGR motor SUPPLY A pin to the EGR motor RETURN pin at the ECM engine connector.
  • Measure the voltage from the EGR motor SUPPLY B pin to the EGR motor RETURN pin at the ECM engine connector.
  • Measure the voltage from the EGR motor SUPPLY C pin to the EGR motor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 3.80 and 4.50-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 active?
YES NO

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 2357 - EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2357 active?
STEP 2. | Check the exhaust gas recirculation (EGR) valve. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for active fault codes. | Fault Code 1896 active?
STEP 3. | Check the EGR valve operation. |
 | STEP 3A. Monitor the EGR valve operation. | Fault Code 2357 becomes active after 30 seconds?
STEP 4. | Clear the fault code. |
 | STEP 4A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
 | STEP 4B. Disable the fault code. | Fault Code 2357 inactive?
 | STEP 4C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2357 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the EGR valve circuit.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Keyswitch OFF for 10 seconds.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES NO

A stuck open EGR valve has been detected.

Replace the EGR valve assembly.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-022 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-022 in Section 11.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the EGR valve operation.

Guided Step 3A - Monitor the EGR valve position.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Turn the keyswitch ON and wait 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2357 becomes active after 30 seconds?
YES NO

Replace the EGR valve assembly.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-022 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-022 in Section 11.

The restriction in the EGR valve has been removed. No repair is necessary.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform the aftertreatment initial check procedure to test for a malfunctioning diesel particulate filter. Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Action

Perform the aftertreatment initial check procedure to test for a malfunctioning diesel particulate filter.

Progressive damage to the aftertreatment system may have occurred. The aftertreatment system must be inspected for reuse.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment component.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-050 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-050 in Section 11.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2357 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4C

Go to 1A

Guided Step 4C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 15-Oct-2015


FAULT CODE 2359 - Exhaust Gas Recirculation Valve Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active EGR valve fault codes. | Fault Code 1895, 1896, or 2357 active?
 | STEP 1B. Check for active EGR differential pressure sensor fault codes. | Fault Code 1866, 2273, or 2274 active?
STEP 2. | Check the EGR differential pressure mounting surfaces for leaks. |
 | STEP 2A. Inspect the air intake connection for leaks. | Leaks detected at the air intake connection and EGR differential pressure sensor?
 | STEP 2B. Check the EGR differential pressure sensor flow ports. | Plugging found in the EGR differential pressure sensor flow ports?
STEP 3. | Check the EGR differential pressure sensor and circuit. |
 | STEP 3A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2274 active?
 | STEP 3C. Check the EGR valve. | EGR valve position less than 4 percent open?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 2359 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR valve fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1895, 1896, or 2357 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active EGR differential pressure sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR differential pressure sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1866, 2273, or 2274 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR differential pressure mounting surfaces for leaks.

Guided Step 2A - Inspect the air intake connection for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air intake connection for leaks.

Leaks should be easily noted by traces of soot; however, the sensor may need to be removed to inspect the o-rings between the EGR differential pressure sensor and the air intake connection for proper sealing.

  • For ISB CM2150 engines, use the following procedure in Service Manual, ISB CM2150, Bulletin 4021578. Refer to Procedure 010-080 Section 10.
  • For ISC and ISL CM2150 engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

Leaks detected at the air intake connection and EGR differential pressure sensor?
YES NO

Replace the damaged component.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the EGR differential pressure sensor flow ports.

Conditions

  • Turn keyswitch OFF.
  • Remove the air intake connection.
  • For ISB CM2150 engines, use the following procedure in in Service Manual, ISB CM2150, Bulletin 4021578. Refer to Procedure 010-080 Section 10.
  • For ISC and ISL CM2150 engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

Action

Check the EGR differential pressure sensor flow ports.

Inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage. If any of the EGR differential pressure sensor flow ports are blocked, the ports must be cleaned completely prior to installing the air intake connection.

  • For ISB CM2150 engines, use the following procedure in Service Manual, ISB CM2150, Bulletin 4021578. Refer to Procedure 010-080 Section 10.
  • For ISC and ISL CM2150 engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

Plugging found to the EGR differential pressure sensor flow ports?
YES NO

Clean the EGR differential pressure sensor flow ports.

  • For ISB CM2150 engines, use the following procedure in in Service Manual, ISB CM2150, Bulletin 4021578. Refer to Procedure 010-080 Section 10.
  • For ISC and ISL CM2150 engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the EGR differential pressure sensor and circuit.

Guided Step 3A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta differential sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the EGR valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate to high idle.

Action

Check the EGR valve position with the sensor unplugged.

  • Use INSITE™ electronic service tool to monitor the EGR valve position.

EGR valve position less than 4 percent open?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor.

  • Refer to Procedure 019-370 in Section 19.

A damaged EGR valve has been detected.

Replace the EGR valve.

  • For ISB CM2150 engines, use the following procedure in in Service Manual, ISB CM2150, Bulletin 4021578. Refer to Procedure 011-022 Section 11.
  • For ISC and ISL CM2150 engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 011-022 in Section 11.

Perform a Snap-Acceleration Test to check for a malfunctioning diesel particulate filter.

  • For ISB CM2150 engines, use the following procedure in in Service Manual, ISB CM2150, Bulletin 4021578. Refer to Procedure 014-013 Section 14.
  • For ISC and ISL CM2150 engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 014-013 Section 14.

Go to 5A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2359 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 30-Aug-2011


FAULT CODE 2363 - Engine Brake Actuator Drive Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Engine Control Module | Refer to Procedure 019-031 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 Electronic Control System | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 Electronic Control System | 4021570
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISC and ISL CM2150 | 4021569

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758; female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917; male Weather Pack™ test lead, Part Number 3823995; female Weather Pack™ test lead, Part Number 3823996.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2363 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid. |
 | STEP 3A. Check the engine brake solenoid for a short-to-ground. | 5 ohms or greater?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 2 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2363 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an intermittent or inactive fault code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 2 SUPPLY wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 2 SUPPLY wire at the engine brake solenoid and the engine brake solenoid number 2 SIGNAL wire at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 2 SIGNAL circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for a short-to-ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocket lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the engine brake number 2 solenoid terminal pin-to-ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance of the engine brake number 2 solenoid SUPPLY terminal pin-to-ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 1.
  • Enable engine brake control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 2 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Aug-2014


FAULT CODE 2367 - Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures Table
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISC and ISL CM2150 | 4021569
Engine Control Module | Refer to Procedure 019-031 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 Electronic Control System | 4021570
Engine Wiring Harness | Refer to Procedure 019-043 | ISB, ISC, ISL, ISDe, and QSB3.3 CM2150 Electronic Control System | 4021570
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISC and ISL CM2150 | 4021569

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758; female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917; male Weather Pack™ test lead, Part Number 3823995; female Weather Pack™ test lead, Part Number 3823996.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2367 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 2 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2367 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an intermittent or inactive fault code. Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 2 wire from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL wire at the engine brake solenoid to the engine brake solenoid number 2 SIGNAL wire at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 2 SIGNAL circuit has been detected in the engine harness. The open circuit is in one of the following harnesses:

  • The main engine harness between the ECM and the 2 pin connector at the back of the engine.
  • The engine brake jumper harness between the engine harness 2 pin connector at the back of the engine and the rocker level housing.
  • The internal engine brake harness between the rocker lever housing and the engine brake solenoid.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3B

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 wire from the engine brake pass through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 SIGNAL wire has been detected in the engine.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the solenoid resistance.

  • Measure the resistance from the solenoid terminal pin-to-ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 1.
  • Turn keyswitch ON.
  • Enable engine brake control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Set delay time to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 2 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Aug-2014


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2373 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active and Fault Code 2373 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2373 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2373 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES NO

A defective sensor has been detected.

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 (Exhaust Gas Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A open RETURN circuit has been detected on the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2373 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2374 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active and Fault Code 2374 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2374 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2374 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2373 active and Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES NO

A defective sensor has been detected.

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 (Exhaust Gas Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas pressure sensor SUPPLY pin to the exhaust gas pressure sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2373 active and Fault Code 2374 inactive?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harenss) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2374 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2375 inactive?
STEP 2. | Check the EGR temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 200 ohms to 2.4M ohms?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2375 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2376 active and Fault Code 2375 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2375 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2375 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the EGR temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

200 ohms to 2.4M ohms?
YES NO
No Repair

Replace the EGR temperature sensor.

Refer to Procedure 019-378 (EGR Temperature Sensor) in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the EGR temperature sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the problem.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2376 active and Fault Code 2375 inactive?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness form the ECM conductor
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor RETURN pin and the engine harness EGR temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor SIGNAL pin and the engine harness EGR temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedure needs to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2375 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2376 inactive?
STEP 2. | Check the EGR temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2376 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2376 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2376 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active?
YES NO

Replace the EGR temperature sensor.

Refer to Procedure 019-378 (EGR Temperature Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the EGR temperature sensor SIGNAL in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

A pin-to-pin short on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and ground

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedure needs to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2376 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2010


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid. | Less than 10k ohms?
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage, supply line, and return circuit. | Greater than 5.0 volts of direct current (VDC)?
 | STEP 2D. Check for an open circuit in the fan control solenoid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2377 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness.

Action

Inspect the OEM harness and fan solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check fan control solenoid resistance.

  • Measure the resistance between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open circuit in the fan control solenoid has been detected.

Replace the fan control solenoid.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the fan control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fan control solenoid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fan control solenoid RETURN pin in the engine harness and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the damaged connection.

Clean, repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM fan control solenoid SIGNAL pin and the OEM harness fan control solenoid connector fan control solenoid SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control solenoid SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fan control solenoid SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2377 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 2387 - VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for previous VGT (VGT) actuator removals. | Actuator removed or replaced during a recent repair event?
 | STEP 1C. Check for exhaust gas recirculation (EGR) related fault codes. | EGR system fault codes active?
 | STEP 1D. Check exhaust restriction. | Exhaust restriction greater than exhaust restriction limits for a dirty aftertreatment diesel particulate filter (DPF)?
 | STEP 1E. Review claims history for recent turbocharger malfunctions. | Turbocharger replaced in the past three months for the same symptoms?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Sector gear teeth not damaged and movement meets the requirements when using the sector gear gauge, according to Procedure 010-134 in Section 10 in the base engine service manual?
STEP 3. | Clear the fault code. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
 | STEP 3B. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3C. Disable the fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2387.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or high inactive counts?
YES NO
No Repair

No troubleshooting is necessary. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for previous VGT actuator removals.

Conditions

  • N/A

Action

Check for previous replacements.

  • Determine if the actuator has been removed or replaced and Fault Code 2387 is active.

Actuator removed or replaced during a recent repair event?
YES NO

Remove the actuator and install it in the correct position.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578, for ISB engines. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569, for ISC and ISL engines. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for EGR-related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or high inactive EGR valve, EGR temperature, and EGR differential pressure-related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for active or high inactive Fault Codes 1896, 1899, 2357, 2359, 2961, and 2962.

EGR system fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting procedure

Go to 1D

Guided Step 1D - Check exhaust restriction.

Conditions

  • Install a pressure gauge into the exhaust system.
  • Turn keyswitch ON.
  • Operate engine at rated horsepower and rpm.

Action

Check exhaust restriction by installing a pressure gauge into the exhaust system, just past the turbocharger outlet.

If a port is not found in the exhaust system, remove the exhaust gas temperature 1 sensor and install the pressure gauge in the temperature sensor port.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-009 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-009 in Section 11.

Is exhaust restriction greater than exhaust restriction limits for a dirty aftertreatment DPF?
YES NO

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578, for ISB engines. Refer to Procedure 018-020 in Section V.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569, for ISC and ISL engines. Refer to Procedure 018-020 in Section V.

No Repair

Go to 3A

Go to 1F

Guided Step 1E - Review claims history for recent turbocharger malfunctions.

Conditions

None

Action

Review malfunctions that have occurred over the last three months to see if the engine has been in for this same symptom.

Turbocharger been replaced in the past three months for the same symptoms?
YES NO

Inspect the grid heater for damage or plugging.

  • Refer to Procedure 010-023 in Section 10 in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578
  • Refer to Procedure 010-023 in Section 10 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

If found damaged, replace the grid heater and inspect the air handling system for debris.

Check the EGR cooler for leaks. Perform the On-Engine Pressure Test of the EGR cooler.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-019 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-019 in Section 11.

If the EGR cooler is not usable, replace the EGR cooler.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.

Replace the VGT actuator.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant.
  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.
  • Remove the VGT actuator from the turbocharger.
  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

Action

Check for a broken drive gear on the VGT actuator.

Gear is broken on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

  • Replace the VGT actuator.
  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove VGT actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

Use a sector gear travel gauge, Part Number 4919281, to check to make sure the sector gear moves through its operating range. Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.

Use the following procedure in in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

Note: It may take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

Sector gear teeth are not damaged and movement meets the requirements when using the sector gear gauge, according to Procedure 010-134 in Section 10 in the base engine service manual?

YES NO

A damaged VGT actuator has been detected.

Replace the VGT actuator, unless it was already replaced in Step 2B.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

A turbocharger mechanical malfunction has been detected.

Note: This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger assembly.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-033 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-033 in Section 10.

Note: The VGT actuator will be reused with the new turbocharger. Do not install the actuator on the malfunctioning turbocharger.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform the Snap Acceleration – Aftertreatment Connected Test to test for a damaged DPF.
  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Action

Check for progressive damage to the aftertreatment system.

Perform the Snap Acceleration - Aftertreatment Connected Test to test for a damaged DPF.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment system component(s).

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-050 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-050 in Section 11.

No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032.

Go to 3C

Go to 3C

Guided Step 3C - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 29-Jun-2017


Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2448. | Active or inactive counts of Fault Code 2448?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2448.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2448?
YES NO

Add coolant to the engine.

  • For ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • For ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

If Fault Code 2448 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Repair complete.

Repair complete

Last Modified: 17-Oct-2011


FAULT CODE 2449 - VGT Actuator Controller - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2449 active?
 | STEP 1B. Check for previous variable geometry turbocharger (VG)T actuator removals. | VGT actuator has just been removed or replaced?
 | STEP 1C. Check for active fault codes. | Fault Code 1938 or 2636 active?
 | STEP 1D. Review Claims History for recent turbocharger malfunctions. | Turbocharger replaced in the past three months for the same symptom?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Sector gear movement meets the requirements when the sector gear gage is used, according to Procedure 010-134 in the base engine service manual?
 | STEP 2D. Check the VGT output gear for correct calibration. | VGT actuator gear moves when connected to the engine wiring harness?
 | STEP 2D-1. Check the VGT output gear for manual rotation by hand. |
 | STEP 2E. Check for active Fault Code 2449. | Fault Code 2449 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
 | STEP 3B. Check if an engine control module (ECM) calibration update is available. | Fault code inactive?
 | STEP 3C. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2449.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Cycle the keyswitch several times, waiting 30 seconds between each key cycle, to see if Fault Code 2449 becomes active.

Fault Code 2449 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 2449 is active. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for previous VGT actuator removals.

Action

Check for previous replacements.

  • Determine if the actuator has just been removed or replaced and Fault Code 2449 is active.

VGT actuator has just been removed or replaced?
YES NO

Remove the actuator and install it in the correct position.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1938 or 2636 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1D

Guided Step 1D - Review claims history for recent turbocharger failures.

Conditions

None

Action

Review malfunctions that have occured over the last six months to see if the engine has been in for this same symptom.

Turbocharger replaced in the past three months for the same symptoms?
YES NO

Inspect the grid heater for damage or plugging.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-023 in Section 10
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-023 in Section 10

If found damaged, replace the grid heater and inspect the air handling system for debris.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.
  • Remove the VGT actuator from the turbocharger. Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

Action

Inspect the VGT actuator.

  • Check for a broken drive gear on the VGT actuator.

Gear broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the VGT actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

Use a sector gear travel gauge, Part Number 4919281, to check to make sure the sector gear moves through its operational range. Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.

Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

It can take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

Sector gear movement meets the requirements when the sector gear gauge is used, according to Procedure 010-134 in the base engine service manual?

YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

The VGT actuator will be reused on the new turbocharger. Do not reinstall the actuator on the malfunctioning turbocharger.

Go to 2D

Go to 3A

Guided Step 2D - Check the VGT output gear for correct calibration.

Conditions

  • Disconnect the VGT actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

Check the VGT actuator output gear operation.

  • Connect the VGT actuator to the engine wiring harness. The VGT actuator gear should rotate.

Monitor the VGT actuator output gear for movement when connected to the engine wiring harness.

  • The amount of movement and direction may change each time the harness is connected. This is acceptable, as long as it is verified that there is movement.
  • Repeat the above procedure three times, checking for VGT actuator gear movement each time the VGT actuator is connected to the engine wiring harness.

VGT actuator gear moves when connected to the engine wiring harness?
YES NO

Install the VGT actuator back on the turbocharger, making sure to perform the VGT actuator install and calibrate procedures.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check the VGT output gear for manual rotation by hand.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Turn the VGT actuator output gear by hand.

  • Try turning the VGT actuator output gear by hand in either direction.

Do NOT use pliers or any other tool to turn the gear. Rotate the gear only by hand.

VGT actuator output gear rotates by hand?
YES NO

Install the VGT actuator back on the turbocharger, making sure to perform the VGT actuator install and calibrate procedures.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

Replace the VGT actuator.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

Go to 2E

Go to 3A

Guided Step 2E - Check for active Fault Code 2449.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 2449.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2449 active?
YES NO

Replace the VGT actuator.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Action

Check for damage to the aftertreatment system.

Perform the aftertreatment initial check procedure to test for a malfunctioning diesel particulate filter.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment system component(s).

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-050 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-050 in Section 11.

No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Copmpare the ECM code and revision number n the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3C

Go to 3C

Guided Step 3C - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Oct-2015


FAULT CODE 2451 - Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Code 2634, 2449, or 2387 active?
 | STEP 1B. Check for fault codes. | Active or inactive counts of Fault Code 2973?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the air intake system sealing surface between the air filter and the hood air plenum. | Excessive wear or ineffective sealing?
 | STEP 2B. Check the charge-air cooler, clamps, hoses, and piping. | Air leaks present or clamps loose?
 | STEP 2C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on turbocharger blades?
 | STEP 2D. Inspect the exhaust gas recirculation (EGR) connections and plumbing. | Leaks found in the EGR plumbing system?
 | STEP 2E. Check for intake air temperature increase in the intake air plumbing. | Temperature increase between the ambient outside temperature and the turbocharger compressor inlet temperature greater than 14°C or 25°F?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2634, 2449, or 2387 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2973?
YES | NO
No Repair | No Repair

Fault Code 2973

Go to 2A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the air intake system sealing surface between the air filter and the hood air plenum.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake system sealing surface between the air filter and the hood air plenum.

  • Inspect the surface between the air filter and the hood plenum.
  • Check for excessive wear, ineffective sealing, and proper fit.

Excessive wear or ineffective sealing?
YES NO

Repair the leaking sealing surface(s).

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the charge-air cooler, clamps, hoses, and piping.

Conditions

  • Turn keyswitch OFF.

Action

Check the charge-air cooler, hoses, and piping for leaks.

Check the clamps for adequate torque.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 010-024 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-024 in Section 10.

Air leaks present or clamps loose?
YES NO

Repair or replace the leaking component.

Tighten any loose clamps.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 010-033 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-033 in Section 10.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 010-033 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check for air leaks in the EGR system.

Conditions

None.

Action

Check for air leaks in the EGR system.

Check for air leaks in the EGR connection tubing and connections.

Soot streaks are noticeable where leaks are present.

Leaks found in the EGR connection tubing?
YES NO

Repair any leaks in the EGR system.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the intake air temperature increase in the intake air plumbing.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Make sure that the air entering the air filter is not being drawn from under the hood. High air temperature entering the turbocharger compressor inlet can cause this fault.

The turbocharger compressor inlet temperature should not be greater than 14°C or 25°F above ambient outside temperature.

  • Check the value for the parameter turbocharger compressor inlet temperature.
  • Compare the turbocharger compressor inlet temperature with the ambient outside temperature.

Temperature increase between the ambient outside temperature and the turbocharger compressor inlet temperature greater than 14°C or 25°F?

YES NO

Determine the cause of the intake air temperature increase in the intake plumbing. Make sure hot air from under the hood of the vehicle is not being drawn into the air filter.

All engine causes have been eliminated.

Go to 3A

Contact the OEM to review the cooling/air handling package.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Sep-2013


FAULT CODE 2554 - Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2373 and 2374. | Fault Code 2373 or 2374 active?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2374 active?
 | STEP 3B. Check the circuit response. | Fault Code 2373 active?
STEP 4. | Check the exhaust gas pressure sensor tube. |
 | STEP 4A. Check the exhaust gas pressure sensor tube. | Plugging or damage found to the exhaust gas pressure sensor tube?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the repair. | INSITE™ electronic service tool reading for Exhaust Gas Pressure within ±25.4 mm-Hg [±1 in-Hg] of local ambient air pressure?
STEP 6. | Check ECM calibration and clear the fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 2373 and 2374.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 or 2374 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2373 active?
YES NO

An in-range malfunction of the exhaust gas pressure sensor has been detected.

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure SIGNAL pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2373 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check the exhaust gas pressure sensor tube.

Guided Step 4A - Check the exhaust gas pressure sensor tube.

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust gas pressure sensor tube.
  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-027 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-027 in Section 11.

Action

Check the exhaust gas pressure sensor tube.

  • Inspect the inside of the tube. If clogged, use compressed air to remove debris or soot buildup.
  • Check the tube for cracks and thread damage. Replace the tube, if cracks or damage are found.
  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-027 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-027 in Section 11.

Plugging or damage found to the exhaust gas pressure sensor tube?
YES NO

Clean or replace the exhaust gas pressure sensor tube.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-027 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-027 in Section 11.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start INSITE™ electronic service tool Data Monitor/Logger and monitor the INSITE™ electronic service tool reading for Exhaust Gas Pressure.

INSITE™ electronic service tool reading for Exhaust Gas Pressure within ±25.4 mm-Hg [±1 in-Hg] of local ambient air pressure?
YES | NO
No Repair | No Repair

Go to 6A

Go to 1A

Guided Step 6 - Check ECM calibration and clear fault codes

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Oct-2015


FAULT CODE 2555 - Intake Air Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the intake air heater relay. | Less than 100 ohms?
 | STEP 2C. Check the intake air heater diagnostic voltage, supply line, and return circuit. | Greater than 3.75 volts of direct current (VDC)?
 | STEP 2D. Check for an open circuit in the intake air heater relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2555 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the intake air heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check the intake air heater relay resistance.

  • Measure the resistance between the intake air heater SIGNAL pin and the intake air heater RETURN pin at the intake air heater relay.

For 12 volt systems, both relays must be checked individually.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

An open circuit has been detected in the intake air heater relay.

Replace the intake air heater relay.

See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the intake air heater diagnostic voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake air heater relay from the OEM harness
  • Turn keyswitch ON.

Action

Check the intake air heater supply voltage and return circuit.

  • Measure the voltage between the intake air heater relay SIGNAL line and the intake air heater relay RETURN line at the intake air heater relay connector of the OEM harness.

For 12 volt systems, both leads must be tested.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the intake air heater relay return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the intake air heater relay RETURN pin at the intake air heater relay connector to ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

Use the OEM wiring diagram for RETURN wire configuration.

  • If the RETURN is wired to the ECM, repair or replace the OEM harness.
  • Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness, if possible.

  • Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector intake air heater relay SIGNAL pin and the OEM harness intake air heater relay connector SIGNAL pin.

For 12 volt systems, both leads must be tested.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open intake air heater relay SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake air heater relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2555 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 2556 - Engine Intake Air Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2555 active and Fault Code 2556 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2556 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2556 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure fore general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 active and Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake air heater relay to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 active?
YES NO

A malfunctioning intake air heater relay has been detected.

Replace the intake air heater relay.

See the OEM troubleshooting and repair manual.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure fore general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and ground.

For 12 volt systems, both leads must be tested.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to- ground short circuit on the intake air heater relay wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the intake air heater SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2556 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 2557 - Auxiliary PWM Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 2. | Check the transmission shift modulator and circuit. |
 | STEP 2A. Inspect the transmission shift modulator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the transmission shift modulator. | Less than 2.2k ohms?
 | STEP 2C. Check the transmission shift modulator diagnostic supply voltage, supply wire, and return circuit. | Greater than 5 volts of direct current (VDC)?
 | STEP 2D. Check for an open circuit in the output device driver return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2557 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the transmission shift modulator and circuit.

Guided Step 2A - Inspect the transmission shift modulator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Inspect the OEM harness and transmission shift modulator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the transmission shift modulator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check the transmission shift modulator resistance.

  • Measure the resistance between the output device driver SIGNAL pin and the output device driver RETURN pin at the transmission shift modulator connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2.2k ohms?
YES NO
No Repair

Replace the transmission shift modulator.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the transmission shift modulator diagnostic supply voltage, supply wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.
  • Turn keyswitch ON.

Action

Check the transmission shift modulator diagnostic supply voltage and return circuit.

  • Measure the voltage between the output device driver SIGNAL pin and the output device driver RETURN pin at the transmission shift modulator connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the output device driver return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the output device driver RETURN pin at the transmission shift modulator connector to ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean and repair, or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the output device driver SIGNAL pin at the transmission shift modulator connector and the output device driver SIGNAL pin at the OEM harness ECM connector.

Use the circuit diagram wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the output device driver SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2557 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 2558 - Auxiliary PWM Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2558 is inactive?
STEP 2. | Check the transmission shift modulator and circuit. |
 | STEP 2A. Inspect the transmission shift modulator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the transmission shift modulator. | Less than 2.2k ohms?
 | STEP 2B-1. Check for a short to ground in the transmission shift modulator. |
 | STEP 2C. Check the transmission shift modulator diagnostic supply voltage, supply wire, and return circuit. | Greater than 5 volts of direct current (VDC)?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2558 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2558 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 is inactive?
YES | NO
No Repair | No Repair

Refer to Procedure Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the transmission shift modulator and circuit.

Guided Step 2A - Inspect the transmission shift modulator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Inspect the OEM harness and transmission shift modulator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the transmission shift modulator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check the transmission shift modulator resistance.

  • Measure the resistance between the output device driver SIGNAL pin and the output device driver RETURN pin at the transmission shift modulator connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Less than 2.2k ohms?
YES NO
No Repair

Replace the transmission shift modulator.

See the OEM troubleshooting and repair manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short to ground in the transmission shift modulator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check for a transmission shift modulator output short to ground.

  • Measure the resistance between the output device driver SIGNAL pin and ground at the transmission shift modulator connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the transmission shift modulator.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the transmission shift modulator diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.
  • Turn keyswitch ON.

Action

Check the transmission shift modulator diagnostic supply voltage and return circuit.

  • Measure the voltage between the output device driver SIGNAL pin and output device driver RETURN pin at the transmission shift modulator connector of the OEM harness.

Use the wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the output device driver SIGNAL pin in the OEM harness ECM connector and ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Seciton 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the output device driver SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2558 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 15-Oct-2015


FAULT CODE 2634 - VGT Actuator Controller - Bad Intelligent Device or Component

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the variable geometry turbocharger (VGT) actuator installation. |
 | STEP 1A. Check for previous VGT actuator removals. | VGT actuator recently removed or replaced?
 | STEP 1B. Check the VGT actuator. | VGT actuator removed from the turbocharger and the keyswitch turned ON?
 | STEP 1C. Check for inactive Fault Code 2634. | Fault Code 2634 inactive after disconnecting and connecting the VGT actuator connector?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check for progressive damage |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the VGT actuator installation.

Guided Step 1A - Check for previous VGT actuator removals.

Conditions

Not applicable

Action

Determine if the VGT actuator recently been removed or replaced.

  • Determine if the actuator has recently been removed or replaced and Fault Codes 2634 and 2449 are active.

VGT actuator recently been removed or replaced?
YES NO

Remove the actuator and install it in the correct position.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the VGT actuator.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for correct VGT actuator installation.

VGT actuator removed from the turbocharger and the keyswitch turned ON?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check for inactive Fault Code 2634.

Conditions

Not applicable

Action

If the VGT actuator is removed from the turbocharger and the keyswitch is turned ON with the wiring harness connected to the VGT actuator, Fault Code 2634 will be active. Follow the procedures below.

  • Turn keyswitch ON.
  • Disconnect the VGT actuator from the engine harness and connect again.

Fault Code 2636 will temporarily be active when the turbocharger actuator is disconnected.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.

Fault Code 2634 is inactive after disconnecting and connecting the VGT actuator connector?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

A damaged VGT actuator has been detected.

Replace the VGT actuator.

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10

Go to 3A

Go to 3A

Guided Step 3 - Check for progressive damage.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform aftertreatment initial check procedure to test for a damaged diesel particulate filter. Connect all components. For ISB engines, see the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14. For ISC and ISL engines, see the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Action

Progressive damage to the aftertreatment system may have occurred.

  • Perform aftertreatment initial check procedure to test for a damaged diesel particulate filter.

For ISB engines, see the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.

For ISC and ISL engines, see the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Progressive damage to the aftertreatment system is detected?
YES NO

Replace the damaged aftertreatment component.

For ISB engines, see the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-050 in Section 11.

For ISC and ISL engines, see the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-050 in Section 11.

Check for active aftertreatment-related fault codes and follow any active aftertreatment fault code troubleshooting trees.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM calibration. |
 | STEP 1A. Check the ECM calibration. | Is the ECM code correct for the engine CPL?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2635 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Check the ECM calibration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM calibration and make sure it is correct for the engine CPL.

  • Make sure the ECM code calibration voltage is correct for the application. A 24-volt calibration downloaded into a 12-volt system can cause this fault code.

Is the ECM code correct for the engine CPL?
YES NO

An incorrect VGT actuator for the voltage application has been detected.

Replace the VGT actuator. Refer to Procedure 010-134 (Variable Geometry Turbocharger Actuator, Electric) in Section 10, in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

Download the correct ECM code for the engine CPL.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2635 inactive?
YES NO
No Repair

Return the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


FAULT CODE 2636 - VGT Actuator Driver Circuit - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2636 inactive?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the J1939 data link resistor termination resistance inside the VGT actuator. | Resistance between 110 and 130 ohms?
 | STEP 2C. Check the voltage to the VGT actuator. | Voltage within 1 volt of direct current (VDC) of battery voltage?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the VGT actuator voltage at the ECM. |
 | STEP 3A-2. Check the battery supply voltage to the ECM. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the J1939 data link termination resistor. |
 | STEP 3B-2. Check for an open in the J1939 data link harness. |
 | STEP 3B-3. Check for a short circuit in the J1939 data link harness. |
 | STEP 3B-4. Check for a short circuit to ground in the J1939 data link harness. |
 | STEP 3B-5. Check the fault codes. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system found during the Snap Acceleration Test?
 | STEP 4B. Disable the fault code. | Fault Code 2636 inactive?
 | STEP 4C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the VGT actuator circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness or VGT actuator connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

Use the following procedure to replace the VGT actuator. Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the J1939 data link resistor termination resistance inside the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Check the J1939 data link resistance.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire and the SAE J1939 data link (-) wire at the VGT actuator connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 110 and 130 ohms?
YES NO
No Repair

The J1939 data link termination resistor is damaged in the VGT actuator.

  • Use the following procedure to replace the VGT actuator. Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.
  • With the actuator removed from the turbocharger, check for the signs of coolant contamination in the actuator cavity from the turbocharger cup plugs.

The ISB turbocharger does not have cup plugs installed on the actuator mounting surface so this step is not necessary. Use the following procedure in the ISC and ISL Service Manual, Bulletin 4021569, to inspect for leaks. Refer to Procedure 010-134 in Section 10.

Go to 2C

Go to 4A

Guided Step 2C - Check the voltage to the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

Measure the voltage between the VGT actuator power SUPPLY circuit and the VGT actuator RETURN circuit at the engine harness

Check the voltage at key ON and while cranking the engine.

Use the circuit diagram or the wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical/electronic contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. See equipment manufacturer service information.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the VGT actuator voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage to the VGT actuator power RETURN circuit at the ECM connector.

Check the voltage at key ON.

Use the circuit diagram or the wiring diagram for connector pin identification . Use the following procedure for general measurement techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit in the VGT actuator power SUPPLY or RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-2

Guided Step 3A-2 - Check the battery supply voltage to the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the ECM.

  • Measure the voltage between the ECM power SUPPLY circuit and the ECM RETURN circuit at the OEM power harness connector.
  • Measure the voltage between the VGT actuator power SUPPLY circuit and the VGT actuator RETURN circuit at the engine harness connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure. Use the following procedure for general measurement techniques. Refer to Procedure 019-359 in Section 19.

Voltage equal to battery voltage?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Low voltage has been detected at the ECM power connector.

Check the battery voltage and the OEM wiring between the battery and the ECM power harness connector.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. See equipment manufacturer service information.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the J1939 data link termination resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 termination resistor from the engine harness.

Action

Check the J1939 data link termination resistor resistance.

  • Measure the resistance between the SAE J1939 data link (+) and SAE J1939 data link (-) at the J1939 termination resistor.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 110 and 130 ohms?
YES NO
No Repair

Replace the J1939 termination resistor.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the terminating resistor from the engine harness.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the VGT actuator engine harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the VGT actuator engine harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link harness.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Remove the J1939 termination resistor from the engine harness.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Disregard any resistance between 50 and 130 ohms between the SAE J1939 (+) and the SAE J1939 data link (-) pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3B-5

Go to 4A

Guided Step 3B-5 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the VGT actuator to the engine harness.
  • Connect the J1939 data link termination resistor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 active?
YES NO

Use the following procedure to replace the VGT actuator. Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10.

  • With actuator removed from the turbocharger, check for the signs of coolant contamination in the actuator cavity, from the turbocharger cup plugs.

The ISB turbocharger does not have cup plugs installed on the actuator mounting surface, so this step is not necessary. Use the following procedure in Section 10 of Bulletin 4021569 to inspect for leaks. Refer to Procedure 010-134 in Section 10.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check for progressive damage to the aftertreatment system.

Conditions

  • Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578 to perform the Snap Acceleration Test. Refer to Procedure 014-013 in Section 14. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Action

Check for damage to the aftertreatment system.

Use the following procedure to perform the Snap Acceleration Test to check for damage to the aftertreatment diesel particulate filter. Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

Progressive damage to the aftertreatment system found during the Snap Acceleration Test?
YES NO

Use the following procedure to replace the damaged aftertreatment component. Use the following procedure in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-050 in Section 11. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-050 in Section 11.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contains that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4C

Go to 4C

Guided Step 4C - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Oct-2015


FAULT CODE 2637 - Catalyst Face Plugged - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System - Overview | Refer to Procedure 011-999 | ISB CM2100 and CM2150 | 4021578
Exhaust System - Overview | Refer to Procedure 011-999 | ISC8.3 and ISL9 CM2260 | 4022257
Exhaust System - Overview | Refer to Procedure 011-999 | ISC and ISL CM2150 | 4021569
Exhaust System - Overview | Refer to Procedure 011-999 | ISB6.7 CM2250 | 4022254

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for other aftertreatment and air handling system active or inactive fault codes with more than one count. | Other fault codes active or inactive with more than one count?
STEP 2. | Check Features, and Parameters, Regeneration Frequency, and engine control module (ECM) Calibration. |
 | STEP 2A. Check the original equipment manufacturer (OEM) or customer selected regeneration inhibit features and parameters. | Features and Parameter settings preventing or interrupting regeneration?
 | STEP 2B. Check for excessive aftertreatment regeneration frequency. | Average aftertreatment regeneration frequency 8 hours or less?
 | STEP 2C. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for other aftertreatment and air handling system active or inactive fault codes with more than one count.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for related fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive fault codes that are related to the diesel oxidation catalyst (DOC) or aftertreatment temperature sensors.

Other fault codes active or inactive with more than one count?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check Features and Parameters, Regeneration Frequency, and ECM Calibration.

Guided Step 2A - Check the OEM or customer selected regeneration inhibit features and parameters.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check OEM or customer selected inhibit features.

Use INSITE™ electronic service tool to review the settings for automotive mobile regeneration minimum vehicle speed, and active regeneration in powertake off (PTO) and remote modes. Make sure these OEM or customer selected inhibit features are not interrupting or preventing regeneration events.

  • Refer to Procedure 011-999 in the Associated Procedures Table.

Features and Parameter settings preventing or interrupting regeneration?
YES NO

Adjust the Features and Parameters settings such that regenerations are not inhibited or interrupted. Always consult the OEM and customer prior to making any changes to these settings.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check for excessive aftertreatment regeneration frequency.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for excessive regeneration frequency.

Use INSITE™ electronic service tool to evaluate average time between aftertreatment regenerations. This can be done by determining the average time between regeneration events in the Advance ECM Data tab, under Aftertreatment History. Regeneration frequencies of 8 hours or less are considered excessive and must be investigated.

Average aftertreatment regeneration frequency 8 hours or less?
YES NO

  • Reference the troubleshooting symptom tree t147 in Section TS, in the appropriate service manual.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

NOTE: This is an information fault only. Release unit with fault active.

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Repair complete

Go to 1A

Last Modified: 13-May-2014


FAULT CODE 2638 - Catalyst Efficiency - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for exhaust gas recirculation (EGR) valve and variable gometry turbocharger related fault codes. | Other fault codes active or have high inactive counts?
STEP 2. | Check engine control module (ECM) Calibration, Features, and Parameters. |
 | STEP 2A. Check if an ECM calibration update is available | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Check for excessive aftertreatment regeneration frequency. | Average aftertreatment regeneration frequency 8 hours or less?
 | STEP 2C. Check the original equipment manufacturer (OEM) or customer selected regeneration inhibit features and parameters. | Features and Parameter settings preventing or interrupting regeneration?
STEP 3. | Check the exhaust system. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil, fuel, or coolant. | Engine oil, fuel, or coolant contamination found in the turbocharger exhaust outlet?
 | STEP 3B. Check the exhaust system between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
STEP 4. | Check for excessive smoke. |
 | STEP 4A. Inspect the exhaust for excessive smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 5A. Clean and inspect the aftertreatment DOC for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 6. | Perform a stationary regeneration. |
 | STEP 6A. Reset aftertreatment, perform a stationary regeneration, and reset fault codes. | Aftertreatment Maintenance Reset procedure completed?
 | STEP 6B. Perform a stationary regeneration. | Fault Code 2638 inactive after performing the stationary regeneration procedure?
 | STEP 6C. Disable and clear the fault code. | Fault code inactive and cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for EGR valve and variable geometry turbocharger related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for related fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive fault codes that are related to the EGR valve or variable geometry turbocharger actuator.

Other fault codes active or have high inactive counts?

YES NO

Troubleshoot the EGR or variable geometry turbocharger related fault codes. A stuck open EGR valve or a damaged variable geometry turbocharger actuator can cause face plugging of the diesel oxidation catalyst.

No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM Calibration, Features, and Parameters.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check for excessive aftertreatment regeneration frequency.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for excessive regeneration frequency.

Use INSITE™ electronic service tool to evaluate average time between aftertreatment regenerations. This can be done by determining the average time between regeneration events in the Advance ECM Data tab, under Aftertreatment History. Regeneration frequencies of 8 hours or less are considered excessive and must be investigated.

Average aftertreatment regeneration frequency 8 hours or less?
YES NO

  • See Troubleshooting Symptom Tree t147 in Bulletin 4021578 for ISB CM2150 engines.
  • See Troubleshooting Symptom Tree t147 in Bulletin 4021569 for ISC and ISL CM2150 engines.

No Repair

Go to 6A

Go to 2C

Guided Step 2C - Check the OEM or customer selected regeneration inhibit features and parameters.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check OEM or customer selected inhibit features.

Use INSITE™ electronic service tool to review the settings for automotive mobile regeneration minimum vehicle speed, and active regeneration in power takeoff (PTO) and remote modes. Make sure these OEM or customer selected inhibit features are not interrupting or preventing regeneration events. Refer to Procedure 011-999 in Section F.

Features and Parameter settings preventing or interrupting regeneration?
YES NO

Adjust the Features and Parameters settings such that regenerations are not inhibited or interrupted. Always consult the OEM and customer prior to making any changes to these settings.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the exhaust system.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil, fuel, or coolant.

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet for signs of oil, fuel, or coolant being introduced into the aftertreatment system from the engine.

  • Inspect the DOC and diesel particulate filter for signs of oil or fuel contamination. These components must be replaced if soaked with oil or fuel. See Aftertreatment Diesel Oxidation Catalyst and Aftertreatment Diesel Particulate Filter Reuse Guidelines in Bulletin 4021600.

Engine oil, fuel, or coolant contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil, diesel fuel, or coolant being carried from the engine into the aftertreatment system.

  • For the ISB, refer to the ISB CM2100 and C2150 Service Manual, Bulletin 4021578.
  • For the ISC and ISL, refer to the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check the exhaust system between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for leaks.

  • Inspect the exhaust system between the turbocharger and aftertreatment system. Inspect for loose or leaking connections and damaged exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged or leaking exhaust system components

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check for excessive smoke.

Guided Step 4A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 014-013 in Section 14.

To perform a Snap Acceleration Test, it could be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

  • See the Smoke, Black - Excessive, or Smoke, White - Excessive troubleshooting symptom tree t116 and t117 in Section TS of the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578, and the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment DOC.

Guided Step 5A - Clean and inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Remove aftertreatment DOC.

Action

Check for cracks in the aftertreatment DOC cell wall.

Clean the DOC, and inspect for reuse.

  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.
  • Reference the Aftertreatment Diesel Oxidation Catalyst and Aftertreatment Diesel Particulate Filter Reuse Guidelines in Bulletin 4021600.
  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC.

  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-049 in Section 11.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Reset aftertreatment, perform a stationary regeneration, and reset fault codes.

Guided Step 6A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Perform the Aftertreatment DOC Reset Procedure

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset procedure under the Aftertreatment Maintenance tab in the Advanced ECM Data menu. Select the DOC Reset option.

Aftertreatment Maintenance Reset procedure has been completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset procedure under the Aftertreatment Maintenance tab in the Advanced ECM Data menu.

Go to 6B

Go to 6B

Guided Step 6B - Perform a stationary regeneration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Use the following procedure for stationary regeneration information in the ISB CM2100 and CM2150 engine in Bulletin 4021578. Refer to Procedure 014-013 in Section 14.

Fault Code 2638 inactive after performing the stationary regeneration procedure?
YES NO
No Repair

Replace the aftertreatment DOC.

  • Use the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 011-049 in Section 11.
  • Use the IC and ISL CM2150 Service Manual, Bulletin 4021569.Refer to Procedure 011-049 in Section 11.

Go to 6C

Go to 6C

Guided Step 6C - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Successful completion of a stationary regeneration without the fault code coming active indicates the condition for clearing the fault code has been met. Use INSITE™ electronic service tool to clear the inactive fault code.

Fault code inactive and cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 15-Oct-2015


Fault Code 2639 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes other than 2639 active?
STEP 2. | Perform stationary regeneration procedure. |
 | STEP 2A. Perform stationary regeneration procedure. | Fault Code 2639 is active after the stationary regeneration has been completed?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2639 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes other than 2639 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Perform the stationary regeneration procedure.

Guided Step 2A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and allow it to idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Use INSITE™ electronic service tool to perform the aftertreatment diesel particulate filter regeneration test found in the ECM diagnostic tests.
  • Some vehicles can be equipped with a stationary regeneration switch in the dash. This switch can also be used to perform the stationary regeneration procedure. Refer to the vehicle operation manual.
  • Use the following procedure for stationary regeneration information in the ISB CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 014-013 in Section 14.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569, for stationary regeneration information for ISC and ISL CM2150 engines. Refer to Procedure 014-013 in Section 14.

NOTE: If stationary regeneration will not activate, please refer to the “Stationary Regeneration - Will Not Activate” troubleshooting tree in Section TS of the appropriate Service Manual.

  • Reference Section TS in the ISB CM2150 Service Manual, Bulletin 4021578.
  • Reference Section TS in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

If active fault codes occur during the regeneration test, abort the test and troubleshoot the active fault code.

Fault Code 2639 active after the stationary regeneration has been completed?
YES NO

Check for active fault codes that may have become active during the regeneration event. Troubleshoot any active fault codes.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2639 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 17-Aug-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2646 active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2646 active?
YES NO

The EGR valve was closed to reduce engine coolant temperature.

No repair is necessary.

 No Repair

Repair complete

Repair complete

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2659 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2659 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2659 active?
YES NO

The EGR valve was closed to reduce engine coolant temperature.

No repair is necessary.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 2659 is inactive.

Fault Code 2659 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes. | Fault codes related to the VGT or EGR valve operation are active?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust system between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
STEP 3. | Perform a stationary regeneration. |
 | STEP 3A. Perform a stationary regeneration procedure. | Fault Code 2728 inactive after running the stationary regeneration procedure?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2728 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the VGT and EGR valve operation.

Fault codes related to the VGT or EGR valve operation are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 2A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust system between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust for leaks.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Perform a stationary regeneration.

Guided Step 3A - Perform a stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • For ISB CM2150 engines, 014-013 (Aftertreatment Testing) in Section 14 in the ISB CM2150 Service Manual, Bulletin 4021578 for stationary regeneration information.
  • For the ISC and ISL CM2150 engines, 014-013 (Aftertreatment Testing) in Section 14 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569 for stationary regeneration information.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Test found in the ECM Diagnostics Tests.

Note: It is not necessary to completely run the stationary regeneration procedure. The test can be stopped as soon as Fault Code 2728 goes inactive.

Fault Code 2728 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Perform the stationary regeneration procedure again.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2728 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes. | Fault code related to the VGT or EGR valve operation are active?
 | STEP 1B. Check the aftertreatment temperature sensor readings. | Are the values of Aftertreatment Diesel Oxidation Catalyst Inlet Temperature and Aftertreatment Diesel particulate Filter Inlet Temperature within 25°C [45°F] of each other?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust system between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
 | STEP 2B. Check for excessive exhaust temperature loss between the turbocharger and aftertreatment system. | Correct OEM downpipe is being used and is properly insulated?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil, coolant, or fuel. | Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Perform a stationary regeneration. |
 | STEP 4A. Perform a stationary regeneration procedure. | Fault Code 2742 inactive after running the stationary regeneration procedure?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 2742 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the VGT and EGR valve operation.

Fault code related to the VGT or EGR valve operation are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the aftertreatment temperature sensor readings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool
  • Start and idle the engine for 10 minutes.

Action

Check the aftertreatment temperature sensor readings.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • Use INSITE™ electronic service tool to monitor the values of Aftertreatment Diesel Oxidation Catalyst Inlet Temperature and Aftertreatment Diesel Particulate Filter Inlet Temperature.

Are the values of Aftertreatment Diesel Oxidation Catalyst Inlet Temperature and Aftertreatment Diesel particulate Filter Inlet Temperature within 25°C [45°F] of each other?

YES NO
No Repair

The aftertreatment diesel oxidation catalyst inlet temperature sensor or aftertreatment diesel particulate filter inlet temperature sensor is not reading properly. Compare all three aftertreatment temperature sensors to determine which sensor is reading incorrectly.

Replace the damaged aftertreatment temperature sensor.

Refer to Procedure 019-013 (Exhaust Temperature Sensor) in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust system between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust for leaks.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for excessive exhaust temperature loss between the turbocharger and aftertreatment system.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the exhaust system between the turbocharger outlet and the aftertreatment system inlet.

  • Check the downpipe for insulation that may be missing.
  • Check for incorrect downpipes that may allow for increased temperature loss between the turbocharger and aftertreatment system.
  • The correct OEM downpipe must be used to prevent temperature loss in the exhaust system.

Correct OEM downpipe is being used and is properly insulated?
YES NO
No Repair

Install the correct OEM downpipe between the turbocharger outlet and the aftertreatment inlet to prevent temperature loss in the exhaust system.

Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil, coolant, or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil, coolant, or fuel being introduced into the aftertreatment system from the engine.
  • Look for signs of moisture in the turbocharger exhaust outlet.

Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the possible cause of diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Replace the damaged component.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Perform a stationary regeneration.

Guided Step 4A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • For ISB CM2150 engines, 014-013 (Aftertreatment Testing) in Section 14 in the ISB CM2150 Service Manual, Bulletin 4021578 for stationary regeneration information.
  • For ISC and ISL engines, 014-013 (Aftertreatment Testing) in Section 14 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569 for stationary regeneration information.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Test found in the ECM Diagnostics Tests.

Note: It is not necessary to completely run the stationary regeneration procedure. The test can be stopped as soon as Fault Code 2742 goes inactive.

Fault Code 2742 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Perform the stationary regeneration procedure again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2742 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes. | Fault code related to the VGT or EGR valve operation are active?
 | STEP 1B. Check the aftertreatment temperature sensor readings. | Are the values of aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature within 25°C [45°F] of each other?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust system between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
 | STEP 2B. Check for excessive exhaust temperature loss between the turbocharger and aftertreatment system. | Correct OEM downpipe is being used and is properly insulated?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil, coolant, or fuel. | Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Perform a stationary regeneration. |
 | STEP 4A. Perform a stationary regeneration procedure. | Fault Code 2743 inactive after running the stationary regeneration procedure?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 2743 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the VGT and EGR valve operation.

Fault codes related to the VGT or EGR valve operation are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the aftertreatment temperature sensor readings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool
  • Start and idle the engine for 10 minutes.

Action

Check the aftertreatment temperature sensor readings.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • Use INSITE™ electronic service tool to monitor the values of aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature.

Are the values of aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature within 25°C [45°F] of each other?

YES NO
No Repair

The aftertreatment diesel oxidation catalyst inlet temperature sensor or aftertreatment diesel particulate filter inlet temperature sensor is not reading properly. Compare all three aftertreatment temperature sensors to determine which sensor is reading incorrectly.

Replace the damaged aftertreatment temperature sensor.

Refer to Procedure 019-013 (Exhaust Temperature Sensor) in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust system between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for leaks.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for excessive exhaust temperature loss between the turbocharger and aftertreatment system.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the exhaust system between the turbocharger outlet and the aftertreatment system inlet.

  • Check the downpipe for insulation that may be missing.
  • Check for incorrect downpipes that may allow for increased temperature loss between the turbocharger and aftertreatment system.
  • The correct OEM downpipe must be used to prevent temperature loss in the exhaust system.

Correct OEM downpipe is being used and is properly insulated?
YES NO
No Repair

Install the correct OEM downpipe between the turbocharger outlet and the aftertreatment inlet to prevent temperature loss in the exhaust system.

Go to 3A

Go to 5A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil, coolant, or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil, coolant, or fuel being introduced into the aftertreatment system from the engine.
  • Look for signs of moisture in the turbocharger exhaust outlet.

Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the possible cause of engine oil, coolant, or fuel being carried from the engine into the aftertreatment system.

Replace the damaged component.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Perform a stationary regeneration.

Guided Step 4A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • For ISB CM2150 engines, 014-013 (Aftertreatment Testing) in the ISB CM2150 Service Manual, Bulletin 4021578 for stationary regeneration information.
  • For ISC and ISL CM2150 engines, 014-013 (Aftertreatment Testing) in the ISC and ISL CM2150 Service Manual, Bulletin 4021569 for stationary regeneration information.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Test found in the ECM Diagnostics Tests.

Note: It is not necessary to completely run the stationary regeneration procedure. The test can be stopped as soon as Fault Code 2743 goes inactive.

Fault Code 2743 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Perform the stationary regeneration procedure again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2743 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


FAULT CODE 2754 - Engine Diesel Particulate Filter Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes. | Fault codes related to the VGT or EGR valve operation active?
 | STEP 1B. Check for intake manifold pressure sensor or EGR differential pressure sensor related fault codes. | Fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor active?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge air system for leaks. | Air leaks present in the charge air cooler, charge air cooler hoses, or the air intake connection?
 | STEP 2B. Check for a restricted charge air cooler. | Charge air cooler restriction within specifications?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 127 mm-hg [5 in-hg]?
STEP 4. | Check the barometric pressure sensor. |
 | STEP 4A. Verify the sensor accuracy. | INSITE™ electronic service tool within 102 mm-hg [4 in-hg] or local barometric pressure?
STEP 5. | Check the fuel system. |
 | STEP 5A. Check for an injector misfire. | Injector misfire detected?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 2754 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the VGT and EGR related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the VGT and EGR valve operation.

Fault codes related to the VGT or EGR valve operation active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for intake manifold pressure sensor or EGR differential pressure sensor related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor.

Fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge-air system for leaks.

Conditions

  • Engine is idling.

Action

Inspect the charge-air cooler and connections for air leaks.

  • Inspect the charge-air cooler connection hoses and clamps. Make sure the clamps are tight and that the hoses are not ruptured.
  • Inspect the air intake connections for air leaks.

Air leaks present in the charge air cooler, charge air cooler hoses, or the air intake connection?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for a restricted charge air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running.

Action

Check the pressure differential across the charge air cooler.

  • For ISB engines, use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 010-027 in Section 10.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-027 in Section 10.

Charge air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge air cooler, if necessary.

Go to 3A

Go to 6A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor.

  • Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.
  • Start the INSITE™ electronic service tool Data Monitor/Logger and compare the INSITE™ electronic service tool reading for Intake Manifold Pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm-hg [5 in-hg] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold pressure sensor.

See equipment manufacturer service information.

Go to 4A

Go to 6A

Guided Step 4 - Check the barometric pressure sensor.

Guided Step 4A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor.

  • Start the INSITE™ electronic service tool Data Monitor/Logger and compare the INSITE™ electronic service tool reading for Barometric Pressure to the local barometric pressure per the table below.

Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading is within 102 mm-hg [4 in-hg] of local barometric pressure?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the fuel system.

Guided Step 5A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for an injector misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.
  • Determine if a cylinder misfire is detected at any engine speed and operating condition.

Injector misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a misfiring injector.

Replace the injector if necessary.

  • For ISB engines, use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 006-026 in Section 6.
  • For ISC and ISL CM2150 engines, use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 006-026 in Section 6.

Excessive black smoke is being generated from the engine and is entering the aftertreatment system. Continue troubleshooting the cause of the excessive black smoke from the engine.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2765 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2765 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2765.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2765 active?
YES NO

The injector barcode adjustable parameters are not correct in INSITE™ electronic service tool.

The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors.

Use INSITE™ electronic service tool to correctly enter the injector barcode parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2765 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2777 is active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2777 is inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2777 is active?
YES NO

This fault code indicates that the aftertreatment regeneration permit switch was disabled when Fault Code 1921, 1922, or 2639 was activated for high aftertreatment soot load.

Perform the aftertreatment testing procedure.

  • For ISB CM2150 engines, 014-013 (Aftertreatment Testing) in Section 14 in the ISB CM2150 Service Manual, Bulletin 4021578 to check the performance of the aftertreatment system.
  • For ISC and ISL CM2150 engines, 014-013 (Aftertreatment Testing) in Section 14 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569 to check the performance of the aftertreatment system.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2777 is inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2778 is active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2778 is inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2778 is active?
YES NO

This fault code indicates that fuel in the oil may have been detected.

Change the engine lubricating oil.

  • Refer to Procedure For ISB engines, 007-037 (Lubricating Oil System) in Section 7 in the ISB CM2150 Service Manual, Bulletin 4021578.
  • Refer to Procedure For ISC and ISL engines, 007-037 (Lubricating Oil System) in Section 7 in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the Maintenance Monitor feature with INSITE™ electronic service tool to make Fault Code 2778 go inactive.

Fault Code 2778 is inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2813 is active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2813.

Fault Code 2813 is active?
YES NO

The EGR valve was closed during an active regeneration of the aftertreatment diesel particulate filter.

No repair is necessary.

 No Repair

Repair complete

Repair complete

Last Modified: 20-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2961?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 1899 or 2359 inactive?
STEP 2. | Check the cooling system. |
 | STEP 2A. Check the engine coolant mixture. | Proper engine coolant mixture?
 | STEP 2B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 3. | Check the EGR system. |
 | STEP 3A. Check the EGR differential pressure sensor and air intake for cracks or leaks. | Are cracks or leaks present?
 | STEP 3B. Check the EGR differential pressure flow ports for plugging. | Debris or soot found in either EGR differential pressure flow ports?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2961 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2961?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1899 or 2359 inactive?
YES NO

Troubleshoot the inactive fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the cooling system.

Guided Step 2A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

Check the freeze point of the engine coolant to be sure of a proper mixture.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

Proper engine coolant mixture?
YES NO
No Repair

Drain the coolant and fill the cooling system with the proper mixture.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

Go to 2B

Go to 4A

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

Note: Low engine coolant level can cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant if necessary.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • Use the following the procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

Go to 3A

Go to 4A

Guided Step 3 - Check the EGR system.

Guided Step 3A - Check the EGR differential pressure sensor and air intake connection for cracks or leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor and air intake connection for cracks or leaks.

Soot streaks can indicate the sensor is loose or cracked.

Are cracks or leaks present?
YES NO

Tighten or replace the EGR differential pressure sensor, seals, or air intake connection.

  • Use the following procedure in the EGR differential pressure sensor. Refer to Procedure 019-370 in Section 19.
  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578.Refer to Procedure 010-080 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check the EGR differential pressure flow ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor.
  • Use the following procedure for EGR differential pressure sensor. Refer to Procedure 019-370 in Section 19.

Action

Inspect the EGR differential pressure flow ports in the air intake for restrictions, soot plugging, and debris plugging.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578.Refer to Procedure 010-080 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

Debris or soot found in either EGR differential pressure flow port?
YES NO

Clear the debris or clean any restriction found in the EGR differential pressure flow ports.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578.Refer to Procedure 010-080 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

Clean the EGR cooler.

  • Use the following procedure in the ISB Series 6.7L Engines (CM2100 and CM2150 Common Rail Fuel Systems) Service Manual, Bulletin 4021578. Refer to Procedure 011-019 in Section 11.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-019 in Section 11.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2961 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2010


FAULT CODE 2962 - Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2962?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 1899 or 2359 inactive?
STEP 2. | Monitor the exhaust gas recirculation temperature sensor. |
 | STEP 2A. Monitor the exhaust gas recirculation temperature sensor. | Values of the exhaust gas recirculation temperature and the intake manifold temperature within 14˚C or 25˚F or of each other?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 3B. Check the engine coolant level. | Engine coolant at proper level?
STEP 4. | Check the EGR system. |
 | STEP 4A. Check the EGR differential pressure sensor and air intake for cracks or leaks. | Are cracks or leaks present?
 | STEP 4B. Check the EGR differential pressure flow ports for plugging. | Debris or soot found in either EGR differential pressure flow ports?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 2962 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2962?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1899 or 2359 inactive?
YES NO

Troubleshoot the inactive fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Monitor the exhaust gas recirculation temperature sensor.

Guided Step 2A - Monitor the exhaust gas recirculation temperature sensor.

Conditions

  • Make sure that the engine has been OFF for at least 1 hour or more.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the exhaust gas recirculation temperature sensor.

  • Use INSITE™ electronic service tool to monitor the exhaust gas recirculation temperature and intake manifold temperature value.
  • Compare the temperature reading of the exhaust gas recirculation temperature and intake manifold temperature.

Values of the exhaust gas recirculation temperature and the intake manifold temperature within 14˚C or 25˚F of each other?
YES NO
No Repair

Replace the EGR temperature sensor. Refer to Procedure 019-378 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

  • Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.
  • Check the freeze point of the engine coolant to be sure of a proper mixture.
  • For ISB engines, use the following procedure in Service Manual, ISB CM2100 and CM2150, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • For ISC and ISL engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and refill the cooling system with the proper mixture.

  • For ISB engines, use the following procedure in Service Manual, ISB CM2100 and CM2150, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • For ISC and ISL engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

  • For ISB engines, use the following procedure in Service Manual, ISB CM2100 and CM2150, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • For ISC and ISL engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

Note: Low engine coolant level may cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

Engine coolant at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

  • For ISB engines, use the following procedure in Service Manual, ISB CM2100 and CM2150, Bulletin 4021578. Refer to Procedure 008-018 in Section 8.
  • For ISC and ISL engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

Go to 4A

Go to 5A

Guided Step 4 - Check the EGR system.

Guided Step 4A - Check the EGR differential pressure sensor and air intake connection for cracks or leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor and air intake connection for cracks or leaks.

Soot streaks can indicate the line is loose or cracked.

Are cracks or leaks present?
YES NO

Tighten or replace the EGR differential pressure sensor seals, or air intake connection.

  • Use the following procedure for the EGR differential pressure sensor. Refer to Procedure 019-370 in Section 19.
  • For ISB engines, use the following procedure in Service Manual, ISB CM2100 and CM2150, Bulletin 4021578. Refer to Procedure 010-080 in Section 10.
  • For ISC and ISL engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the EGR differential pressure flow ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor.
  • Use the following procedure for EGR differential pressure sensor. Refer to Procedure 019-370 in Section 19.

Action

Clear the debris or clean any restriction found in the EGR differential pressure flow ports.

  • For ISB engines, use the following procedure in Service Manual, ISB CM2100 and CM2150, Bulletin 4021578. Refer to Procedure 010-080 in Section 10.
  • For ISC and ISL engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

Debris or soot found in either EGR differential pressure flow port?
YES NO

Clear the debris or clean any restriction found in the EGR differential pressure flow ports.

  • For ISB engines, use the following procedure in Service Manual, ISB CM2100 and CM2150, Bulletin 4021578. Refer to Procedure 010-080 in Section 10.
  • For ISC and ISL engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 010-080 in Section 10.

Clean the EGR cooler.

  • For ISB engines, use the following procedure in Service Manual, ISB CM2100 and CM2150, Bulletin 4021578. Refer to Procedure 011-019 in Section 11.
  • For ISC and ISL engines, use the following procedure in Service Manual, ISC and ISL CM2150, Bulletin 4021569. Refer to Procedure 011-019 in Section 11.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2962 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Aug-2011


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 144 and 145. | Fault Codes 144 and 145 active?
 | STEP 1B. Monitor coolant temperature. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check ECM calibration and clear fault code. |
 | STEP 2A. Check if an ECM calibration update is available | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 144 and 145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 144 and 145 active?
YES NO

Refer to Fault Code 144 or 145.

 No Repair

Repair complete

Go to 1B

Guided Step 1B - Monitor coolant temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor coolant temperature.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Appropriate troubleshooting symptom tree.

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Apr-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold temperature reading. |
 | STEP 1A. Monitor intake manifold temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?

Guided Step 1 - Monitor intake manifold temperature reading.

Guided Step 1A - Monitor intake manifold temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

  • For ISB engines, refer to the Intake Manifold Air Temperature Above Specification symptom tree in the ISB CM2150 Service Manual, Bulletin 4021578.
  • For ISC and ISL engines, refer to the Intake Manifold Air Temperature Above Specification symptom tree in the ISC and ISL CM2150 Service Manual, Bulletin 4021569.

Replace the intake manifold temperature sensor.

Refer to Procedure 019-159 (Intake Manifold Pressure/Temperature Sensor) in Section 19.

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 20-Jul-2010


FAULT CODE 2973 - Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | High active or inactive counts of Fault Code 122, 123, 221, 222, 295, 595, 687, or 2345?
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 51 mm-hg [2 in-hg] of local barometric pressure?
STEP 3. | Check the engine intake manifold pressure/temperature sensor and circuit. |
 | STEP 3A. Inspect the engine intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Verify the sensor accuracy. | INSITE™ electronic service tool reading for intake manifold pressure within 77 mm-hg [3 in-hg] of local barometric pressure?
 | STEP 3C. Check the circuit response. | Fault Code 123 active?
 | STEP 3D. Check the circuit response. | Fault Code 122 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 123 active?
 | STEP 4C. Check the circuit response. | Fault Code 122 active?
STEP 5. | Check the air intake system for leaks. |
 | STEP 5A. Check the charge-air cooler for leaks. | Air leak present?
 | STEP 5B. Check the intake manifold inlet and connections for leaks. | Air leak present?
 | STEP 5C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 5D. Check for a restricted charge air cooler. | Within specifications?
STEP 6. | Check the turbocharger speed sensor. |
 | STEP 6A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 6B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
STEP 7. | Check the exhaust and intake systems for restriction. |
 | STEP 7A. Check exhaust restriction. | Exhaust restriction within specifications?
 | STEP 7B. Check intake restriction. | Air intake restriction within specifications?
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 122, 123, 221, 222, 295, 595, 687, or 2345?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for barometric pressure to the local barometric pressure.

  • Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading is within 51 mm-hg [2 in-hg] of local barometric pressure?
YES NO
No Repair

Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 8A

Guided Step 3 - Check the engine intake manifold pressure/temperature sensor and circuit.

Guided Step 3A - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold pressure/temperature sensor connector and the engine harness connector for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the intake manifold pressure/temperature sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged intake manifold pressure/temperature sensor. Refer to the circuit diagram or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for intake manifold pressure sensor information. See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 3B

Guided Step 3B - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • turn engine OFF.

Action

With keyswitch ON and engine OFF, the intake manifold pressure and barometric pressure readings must agree.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the reading for barometric pressure.

INSITE™ electronic service tool reading for intake manifold pressure is within 77 mm-hg [3 in-hg] of local barometric pressure?
YES | NO
No Repair | No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES | NO
No Repair | No Repair

Go to 3D

Go to 4A

Guided Step 3D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and the engine intake manifold pressure SIGNAL pin at the engine intake manifold pressure/temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

An in-range malfunction of the intake manifold pressure/temperature sensor has been detected.

Replace the engine intake manifold pressure/temperature sensor. See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 8A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4C

Go to 8A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and engine intake manifold pressure SIGNAL pin at the engine control module engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

  • Replace the ECM.Refer to Procedure 019-031 in Section 19.

Go to 8A

Go to 8A

Guided Step 5 - Check the air intake system for leaks.

Guided Step 5A - Check the charge-air cooler for leaks.

Conditions

  • Engine running.

Action

Check the charge-air cooler and connections for air leaks.

Air leak present?
YES NO

Repair or replace the leaking component. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-027 in Section 10.

No Repair

Go to 8A

Go to 5B

Guided Step 5B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Operate engine.

Action

Check for air leaks in connections and hoses between the turbocharger and intake manifold inlet.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-024 in Section 10.

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 8A

Go to 5C

Guided Step 5C - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-033 in Section 10.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

 No Repair

Go to 8A

Go to 5D

Guided Step 5D - Check for a restricted charge air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.

Action

Check the pressure differential across the charge air cooler.

  • Use the folllowing procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-027 in Section 10.

Within specifications?
YES NO
No Repair

Clean or replace the charge air cooler, if necessary.

Go to 6A

Go to 8A

Guided Step 6 - Check the turbocharger speed sensor.

Guided Step 6A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Only perform this step if the engine is equipped with a turbocharger speed sensor. Inspect the turbocharger or refer to the engine wiring diagram to determine if the engine has a turbocharger speed sensor. If no sensor is present, skip to Step 7.

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 8A

Go to 6B

Guided Step 6B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check the turbocharger speed sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

  • The turbocharger speed sensor is damaged.
  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the exhaust and intake systems for restriction.

Guided Step 7A - Check the exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the exhaust restriction.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 011-009 in Section 11.

Exhaust restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 7B

Go to 8A

Guided Step 7B - Check the intake restriction.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-031 in Section 10.

Air intake restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Oct-2015


FAULT CODE 3616 - VGT Actuator Position - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for other active turbocharger fault codes. | Fault Code 2387 active or high inactive counts?
 | STEP 1B. Review claims history for recent turbocharger malfunctions. | Turbocharger been replaced in the past three months for the same symptoms?
STEP 2. | Verify the complaint. |
 | STEP 2A. Check the fault code. | Fault Code 3616 inactive?
 | STEP 2B. Test drive the vehicle. | Fault Code 2387 active?
 | STEP 2C. Confirm the complaint. | Customer reported a drivability complaint with a cold engine?
 | STEP 2D. Inspect the variable geometry turbocharger (VGT) actuator. | Use the sector gear travel gauge. Nozzle movement meet the requirements according to Procedure 010-134?
STEP 3. | Check the ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for other active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or high inactive counts?
YES | NO
No Repair | No Repair

Reference Fault Code 2387

Go to 1B

Guided Step 1B - Review claims history for recent turbocharger malfunctions.

Conditions

None

Action

Review the malfunctions that have occurred over the last six months to see if the engine has been in for this same symptoms.

Has the turbocharger been replaced in the past three months for the same symptoms?
YES NO

Inspect the grid heater for damage or plugging.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-023 in Section 10.
  • Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-023 in Section 10.

If found damaged, replace the grid heater and inspect the air handling system for debris.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Verify the complaint.

Guided Step 2A - Check the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 3616.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3616 active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2C

Guided Step 2B - Test drive the vehicle.

Conditions

  • Connect all components.
  • Allow the coolant temperature to cool below 74°C [165°F].

Note: This test can not be performed if the engine does not start. If the engine does not start, verify there are no other faults that can prohibit the engine from starting, skip this step, and proceed to Step 2D.

Action

Determine whether the fault goes inactive when operated with a coolant temperature above 74°C [165°F].

  • Start the engine and operate under normal driving conditions for at least 15 minutes or until the coolant temperature is greater than 74°C [165°F].
  • Use INSITE™ electronic service tool to verify the fault code.

Fault Code 2387 active?
YES NO
No Repair

Fault Code 3616 is an informational fault code indicating that the ECM has taken action to resolve a key ON condition.

Reference Fault Code 2387

Go to 2C

Guided Step 2C - Confirm the complaint.

Conditions

  • Turn keyswitch OFF.

Action

Review the customer complaint.

  • Establish whether the customer reported engine warm-up drivability complaints (low power, poor response, or low braking power).

Has the customer reported a drivability complaint with a cold engine?
YES NO
No Repair

Fault Code 3616 is an informational fault code indicating that the ECM has taken action to resolve a key ON condition.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 008-018 in Section 8. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 008-018 in Section 8.

Action

Remove the VGT actuator from the turbocharger.

  • Use a sector gear travel gauge, Part Number 4919281, to make sure the sector gear moves through its operational range. Refer to Procedure 010-134 in Section 10.

Note: It may take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-134 in Section 10. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-134 in Section 10.

Use the sector gear travel gauge. Nozzle movement meet the requirements according to Procedure 010-134?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

Note: This malfunction can be caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect the base engine components for damage.

Replace the turbocharger assembly.

  • Use the following procedure in the ISB CM2100 and CM2150 Service Manual, Bulletin 4021578. Refer to Procedure 010-033 in Section 10. Use the following procedure in the ISC and ISL CM2150 Service Manual, Bulletin 4021569. Refer to Procedure 010-033 in Section 10.

Note: The variable geometry turbocharger actuator will be reused with the new turbocharger. Do not install the actuator on the malfunctioning turbocharger.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 19-Mar-2013


FAULT CODE 3738 - Air Supply Actuator - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
ECM Calibration Code | Refer to Procedure 019-032 | ISL8.9 CM2150 SN | 4022190
ECM Calibration Code | Refer to Procedure 019-032 | ISM11 CM876 SN | 4022196
ECM Calibration Code | Refer to Procedure 019-032 | ISZ13 CM2150 | 4022133
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISL8.9 CM2150 SN | 4022190
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISM11 CM876 SN | 4022196
Aftertreatment DEF Dosing Unit | Refer to Procedure 019-440 | ISZ13 CM2150 | 4022133

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3738 inactive?
 | STEP 1B. Check for air supply actuator fault codes. | Fault Code 1697 or 1698 active?
STEP 2. | Check DEF dosing unit air supply system. |
 | STEP 2A. Check the DEF dosing unit air solenoid. | Is the air solenoid clicking, and allowing air to flow from the DEF line?
 | STEP 2B. Inspect the air supply lines to the DEF dosing unit. | Is the OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
STEP 3. | Perform the DEF doser pump override test. |
 | STEP 3A. Perform the DEF doser pump override test with INSITE™ electronic service tool. | Does the DEF dosing unit operate correctly during INSITE™ electronic service tool override test?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3738 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for air supply actuator fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1697 or 1698 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Appropriate Fault Code Troubleshooting Tree

Guided Step 2A - Check the DEF dosing unit air solenoid.

Conditions

  • Disconnect DEF line from the aftertreatment nozzle and secure appropriately
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Make sure the vehicle air tanks are full.

Action

Check the solenoid.

  • Use INSITE™ electronic service tool to perform the “DEF Doser Pump Air Solenoid Click Test” under the ECM Diagnostic Tests menu.
  • Check for correct solenoid operation.
  • While the test is running, the solenoid should click, and air flow must be felt at the outlet of the aftertreatment nozzle line.

Is the air solenoid clicking, and allowing air to flow from the DEF line?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON
  • Make sure the vehicle air tanks are full.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for contamination from water or excessive oil from the vehicle compressed air system.
  • Make sure a clean air supply of at least 517 kPa [75 psi] of pressure is present at the DEF dosing unit, downstream of the air filter.

Is the OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO

A malfunctioning DEF dosing unit has been detected. Replace the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Correct the OEM air supply connection or supply. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Perform the DEF doser pump override test.

Guided Step 3A - Perform the DEF doser pump override test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Start and idle engine.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 019-440 in the Associated Procedures Table.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

Does the DEF dosing unit operate correctly during INSITE™ electronic service tool override test?
YES NO
No Repair

Replace the DEF dosing unit. Refer to Procedure 019-440 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


INDEX
08-fc111.htm

08-t05-111.htm

08-fc115.htm

08-t05-115.htm

08-fc122.htm

08-t05-122.htm

08-fc123.htm

08-t05-123.htm

08-fc124.htm

08-t05-124.htm

08-fc131.htm

08-t05-131.htm

08-fc132.htm

08-t05-132.htm

08-fc133.htm

08-t05-133.htm

08-fc134.htm

08-t05-134.htm

08-fc135.htm

08-t05-135.htm

08-fc141.htm

08-t05-141.htm

08-fc143.htm

08-t05-143.htm

08-fc144.htm

08-t05-144.htm

08-fc145.htm

08-t05-145.htm

08-fc146.htm

08-t05-146.htm

08-fc151.htm

08-t05-151.htm

08-fc153.htm

08-t05-153.htm

08-fc154.htm

08-t05-154.htm

08-fc155.htm

08-t05-155.htm

08-fc195.htm

08-fc195-2wire.htm

08-t05-195-2wire.htm

08-fc195-3wire.htm

08-t05-195-3wire.htm

08-fc196.htm

08-fc196-2wire.htm

08-t05-196-2wire.htm

08-fc196-3wire.htm

08-t05-196-3wire.htm

08-fc197.htm

08-t05-197.htm

08-fc221.htm

08-t05-221.htm

08-fc222.htm

08-t05-222.htm

08-fc234.htm

08-t05-234.htm

08-fc238.htm

08-t05-238.htm

08-fc239.htm

08-t05-239.htm

08-fc241.htm

08-t05-241.htm

08-fc242.htm

08-t05-242.htm

08-fc245.htm

08-t05-245.htm

08-fc249.htm

08-t05-249.htm

08-fc252.htm

08-t05-252.htm

08-fc253.htm

08-t05-253.htm

08-fc256.htm

08-t05-256.htm

08-fc271.htm

08-t05-271.htm

08-fc272.htm

08-t05-272.htm

08-fc281.htm

08-t05-281.htm

08-fc285.htm

08-t05-285.htm

08-fc286.htm

00-t05-286.htm

08-fc287.htm

08-t05-287.htm

08-fc288.htm

08-t05-288.htm

08-fc292.htm

08-t05-292.htm

08-fc293.htm

08-t05-293.htm

08-fc294.htm

08-t05-294.htm

08-fc295.htm

08-t05-295.htm

08-fc296.htm

08-t05-296.htm

08-fc297.htm

08-t05-297.htm

08-fc298.htm

08-t05-298.htm

08-fc322.htm

08-t05-322.htm

08-fc323.htm

08-t05-323.htm

08-fc324.htm

08-t05-324.htm

08-fc325.htm

08-t05-325.htm

08-fc331.htm

08-t05-331.htm

08-fc332.htm

08-t05-332.htm

08-fc334.htm

08-t05-334.htm

08-fc343.htm

08-t05-343.htm

08-fc351.htm

08-t05-351.htm

08-fc352.htm

08-t05-352.htm

08-fc386.htm

08-t05-386.htm

08-fc415.htm

08-t05-415.htm

08-fc418.htm

08-t05-418.htm

08-fc427.htm

08-t05-427.htm

08-fc428.htm

08-t05-428.htm

08-fc429.htm

08-t05-429.htm

08-fc431.htm

08-t05-431.htm

08-fc432.htm

08-t05-432.htm

08-fc435.htm

08-fc435b.htm

08-t05-435b.htm

08-fc435cl.htm

08-t05-435cl.htm

08-fc441.htm

08-t05-441.htm

08-fc442.htm

08-t05-442.htm

08-fc449.htm

08-fc449b.htm

08-t05-449b.htm

08-fc449cl.htm

08-t05-449cl.htm

08-fc451.htm

08-t05-451.htm

08-fc452.htm

08-t05-452.htm

08-fc471.htm

08-t05-471.htm

08-fc488.htm

08-t05-488.htm

08-fc499.htm

08-t05-499.htm

08-fc528.htm

08-t05-528.htm

08-fc529.htm

08-t05-529.htm

08-fc553.htm

08-fc553b.htm

08-t05-553b.htm

08-fc553cl.htm

08-t05-553cl.htm

08-fc554.htm

08-t05-554.htm

08-fc555.htm

08-fc555b.htm

08-t05-555b.htm

08-fc555cl.htm

08-t05-555cl.htm

08-fc556.htm

08-fc556b.htm

08-t05-556b.htm

08-fc556cl.htm

08-t05-556cl.htm

08-fc559.htm

08-fc559b.htm

08-t05-559b.htm

08-fc559cl.htm

08-t05-559cl.htm

08-fc584.htm

08-t05-584.htm

08-fc585.htm

08-t05-585.htm

08-fc596.htm

08-t05-596.htm

08-fc597.htm

08-t05-597.htm

08-fc598.htm

08-t05-598.htm

08-fc599.htm

08-t05-599.htm

08-fc649.htm

08-t05-649.htm

08-fc686.htm

08-t05-686.htm

08-fc687.htm

08-t05-687.htm

08-fc688.htm

08-t05-688.htm

08-fc689.htm

08-t05-689.htm

08-fc691.htm

08-t05-691.htm

08-fc692.htm

08-t05-692.htm

08-fc698.htm

08-t05-698.htm

08-fc731.htm

08-t05-731.htm

08-fc778.htm

08-t05-778.htm

08-fc779.htm

08-t05-779.htm

08-fc784.htm

08-t05-784.htm

08-fc1117.htm

08-t05-1117.htm

08-fc1239.htm

08-t05-1239.htm

08-fc1241.htm

08-t05-1241.htm

08-fc1242.htm

08-t05-1242.htm

08-fc1663.htm

08-t05-1663.htm

08-fc1664.htm

08-t05-1664.htm

08-fc1665.htm

08-t05-1665.htm

08-fc1666.htm

08-t05-1666.htm

08-fc1667.htm

08-t05-1667.htm

08-fc1674.htm

08-t05-1674.htm

08-fc1675.htm

08-t05-1675.htm

08-fc1676.htm

08-t05-1676.htm

08-fc1691.htm

08-t05-1691.htm

08-fc1695.htm

08-t05-1695.htm

08-fc1696.htm

08-t05-1696.htm

08-fc1843.htm

08-t05-1843.htm

08-fc1844.htm

08-t05-1844.htm

08-fc1866.htm

08-t05-1866.htm

08-fc1876.htm

08-t05-1876.htm

08-fc1877.htm

08-t05-1877.htm

08-fc1878.htm

08-t05-1878.htm

08-fc1879.htm

08-t05-1879.htm

08-fc1881.htm

08-t05-1881.htm

08-fc1883.htm

08-t05-1883.htm

08-fc1896.htm

08-t05-1896.htm

08-fc1899.htm

08-t05-1899.htm

08-fc1911.htm

08-fc1911b.htm

08-t05-1911b.htm

08-fc1911cl.htm

08-t05-1911cl.htm

08-fc1921.htm

08-t05-1921.htm

08-fc1922.htm

08-t05-1922.htm

08-fc1938.htm

08-t05-1938.htm

08-fc1942.htm

08-t05-1942.htm

08-fc1943.htm

08-t05-1943.htm

08-fc1962.htm

08-t05-1962.htm

08-fc1966.htm

08-t05-1966.htm

08-fc1968.htm

08-t05-1968.htm

08-fc1969.htm

08-t05-1969.htm

08-fc1972.htm

08-t05-1972.htm

08-fc1973.htm

08-t05-1973.htm

08-fc1974.htm

08-t05-1974.htm

08-fc1981.htm

08-t05-1981.htm

08-fc1993.htm

08-t05-1993.htm

08-fc2182.htm

08-t05-2182.htm

08-fc2183.htm

08-t05-2183.htm

08-fc2185.htm

08-t05-2185.htm

08-fc2186.htm

08-t05-2186.htm

08-fc2195.htm

08-t05-2195.htm

08-fc2198.htm

08-t05-2198.htm

08-fc2265.htm

08-t05-2265.htm

08-fc2266.htm

08-t05-2266.htm

08-fc2272.htm

08-t05-2272.htm

08-fc2273.htm

08-t05-2273.htm

08-fc2274.htm

08-t05-2274.htm

08-fc2288.htm

08-t05-2288.htm

08-fc2311.htm

08-t05-2311.htm

08-fc2321.htm

08-t05-2321.htm

08-fc2322.htm

08-t05-2322.htm

08-fc2345.htm

08-t05-2345.htm

08-fc2346.htm

08-t05-2346.htm

08-fc2347.htm

08-t05-2347.htm

08-fc2349.htm

08-t05-2349.htm

08-fc2351.htm

08-t05-2351.htm

08-fc2357.htm

08-t05-2357.htm

08-fc2359.htm

08-t05-2359.htm

08-fc2363.htm

08-t05-2363.htm

08-fc2367.htm

08-t05-2367.htm

08-fc2373.htm

08-t05-2373.htm

08-fc2374.htm

08-t05-2374.htm

08-fc2375.htm

08-t05-2375.htm

08-fc2376.htm

08-t05-2376.htm

08-fc2377.htm

08-t05-2377.htm

08-fc2387.htm

08-t05-2387.htm

08-fc2448.htm

08-t05-2448.htm

08-fc2449.htm

08-t05-2449.htm

08-fc2451.htm

08-t05-2451.htm

08-fc2554.htm

08-t05-2554.htm

08-fc2555.htm

08-t05-2555.htm

08-fc2556.htm

08-t05-2556.htm

08-fc2557.htm

08-t05-2557.htm

08-fc2558.htm

08-t05-2558.htm

08-fc2634.htm

08-t05-2634.htm

08-fc2635.htm

08-t05-2635.htm

08-fc2636.htm

08-t05-2636.htm

08-fc2637.htm

08-t05-2637.htm

08-fc2638.htm

08-t05-2638.htm

08-fc2639.htm

08-t05-2639.htm

08-fc2646.htm

08-t05-2646.htm

08-fc2659.htm

08-t05-2659.htm

08-fc2728.htm

08-t05-2728.htm

08-fc2742.htm

08-t05-2742.htm

08-fc2743.htm

08-t05-2743.htm

08-fc2754.htm

08-t05-2754.htm

08-fc2765.htm

08-t05-2765.htm

08-fc2777.htm

08-t05-2777.htm

08-fc2778.htm

08-t05-2778.htm

08-fc2813.htm

08-t05-2813.htm

08-fc2961.htm

08-t05-2961.htm

08-fc2962.htm

08-t05-2962.htm

08-fc2963.htm

08-t05-2963.htm

08-fc2964.htm

08-t05-2964.htm

08-fc2973.htm

08-t05-2973.htm

08-fc3616.htm

08-t05-3616.htm

08-fc3738.htm

120-t05-3738.htm