ISM - CM876, ISX - CM871, QSM11 - CM876 - Power Gen, Westport GX15 CM871, ISN14 CM876 SN,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the electronic control module (ECM) related to memory hardware failures or internal ECM voltage supply circuits. | Engine may not start.
ISX and ISM Electronic Control Module

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM is located on the fuel system side of the engine.Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 09-Jul-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. The electronic control module (ECM) has detected that the primary and backup speed sensor signals are connected backwards. | None on performance.
ISM - Engine Magnetic Speed/Position
ISX - Engine Magnetic Speed/Position

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The ECM provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

Both engine position sensors are located on the back side of the front gear housing above the fuel pump drive. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The ECM detects the reversed sensors and continues to operate.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code indicates that the camshaft position sensor and crankshaft position sensor wiring harness connectors are reversed. On the ISM engine, the two camshaft position sensor connectors are reversed.

Refer to Troubleshooting Fault Code t05-115

Last Modified: 09-Jul-2010


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Derate in power output of the engine.
ISX - Intake Manifold 1 Pressure Sensor
ISM - Intake Manifold 1 Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is greater than 4.91-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-122


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Derate in power output of the engine.
ISX - Intake Manifold 1 Pressure Sensor
ISM - Intake Manifold 1 Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold. The ECM will detect a low signal voltage at operating conditions such as during idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal voltage is less than 0.26-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-123


Intake Manifold 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: 102 SPN: 102 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Valid but Below Normal Operating Range - Moderately Severe Level. Intake manifold pressure is below the minimum operating limit. | Engine power derate.
Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The ECM provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold.

If the ECM detects that the necessary charge flow into the engine is below the minimum limits for a period of time, this fault code is logged.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal reading is below the expected level for the present engine operating conditions.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code will be set inactive when the intake manifold pressure is reading within the normal operating limits.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too low for the present engine operating conditions. The ECM commands a charge flow command and the VGT and EGR valve move to meet this command. If the engine is unable to achieve the desired oxygen level necessary for complete combustion, this fault code is logged.

Possible causes of this fault code are:

  • Leaks in the air intake system between the turbocharger and the intake manifold
  • A damaged intake manifold pressure sensor
  • A damaged barometric pressure sensor
  • Restriction in the charge-air cooler
  • Fuel inlet restriction too high. Normally caused by a restricted fuel filter.
  • Restriction in the exhaust gas pressure sensing line.
  • A stuck in range exhaust gas pressure sensor.
Refer to Troubleshooting Fault Code t05-125

Last Modified: 07-Oct-2011


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 1 circuit. | Severe derate in power output of the engine. Limp home power only.
ISX and ISM - Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a potentiometer attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0%. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Note: The sensor connection pin numbers shown in the diagram above are OEM specific and those provided are for example only. Refer the OEM service diagram for the correct pinouts.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal or lever. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than 4.55-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery or +5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Failed accelerator pedal or lever position sensor.

Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-131


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 1 signal circuit. | Severe derate in power output of the engine. Limp home power only.
ISX and ISM - Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator position sensor is a potentiometer attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Note: The sensor connection pin numbers shown is the diagram above are OEM specific and those provided are for example only. Refer to the OEM diagram for correct pinouts.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is less than 0.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Failed accelerator pedal or lever position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-132


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate. Remote accelerator position will be set to zero percent.
ISX and ISM - Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the remote accelerator pedal signal voltage is greater than 4.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 of the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal circuit shorted to battery or +5 volt supply.
  • Open remote accelerator pedal or lever return circuit in the harness or connections.
  • Remote accelerator supply shorted to battery.
  • Failed remote accelerator pedal or lever position sensor.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-133


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate. Remote accelerator position will be set to 0 percent.
ISX and ISM - Remote Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the remote accelerator pedal signal voltage is less than 0.1-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor.
  • Failed remote accelerator pedal or lever position sensor.
  • Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-134


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
ISX - Engine Oil Rifle Pressure 1
ISM - Engine Oil Rifle Pressure 1

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is greater than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The oil pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
ISX - Engine Oil Rifle Pressure 1
ISM - Engine Oil Rifle Pressure 1

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is less than 0.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the engine oil pressure reading.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The oil pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-141


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
ISX - Engine Oil Rifle Pressure 1
ISM - Engine Oil Rifle Pressure 1

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

If the ECM detects low signal voltage indicating a low engine oil pressure, this fault code sets.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is less than 55 kPa [8 psi] at 800 rpm for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate issued by the ECM limiting the power output of the engine.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the torque derate will be removed when the oil pressure reading is detected to be within the normal operating range.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code t05-143


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for engine coolant temperature.
ISX - Engine Coolant Temperature Sensor Circuit
ISM - Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system, and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the coolant temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Before troubleshooting Fault Code 144, check for multiple faults.

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-144

Last Modified: 17-Jan-2011


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for engine coolant temperature.
ISX - Engine Coolant Temperature 1 Sensor Circuit
ISM - Engine Coolant Temperature 1 Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The ECM supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the coolant temperature reading.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-145


Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Power derate and possible engine shutdown if Engine Protection Shutdown feature is enabled.
ISX - Engine Coolant Temperature Sensor Circuit
ISM - Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine coolant. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing. Use the following procedure for a detailed component location view.Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the fault code immediately after the coolant temperature decreases below the engine protection limit.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM again. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. It is highly unlikely that the coolant temperature sensor is failed unless there are other active coolant temperature sensor faults.

Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree.

  • For ISM engines, refer to the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, refer to the Signature&trade;, ISX, and QSX15 Service Manual, Bulletin 3666239.
Refer to Troubleshooting Fault Code t05-146


Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red STOP lamp starts flashing.
ISX - Coolant Temperature Sensor Circuit
ISM - Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The Electronic Control Module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Use the following procedure for a detailed component location view.Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than a calibratible value for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut off if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the coolant temperature decreases below the engine protection limit.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM again. Refer to Procedure 019-032 in Section 19.

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. It is highly unlikely that the coolant temperature sensor are failed unless there are other active coolant temperature sensor faults.

Refer to the Engine Coolant Temperature Above Normal symptom troubleshooting tree.

  • For ISM engines, refer to the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, refer to the Signature&trade;, ISX, and QSX15 Service Manual, Bulletin 3666239.
Refer to Troubleshooting Fault Code t05-151


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold air temperature.
ISX - Intake Manifold 1 Pressure Sensor Circuit
ISM - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to voltage source.
Refer to Troubleshooting Fault Code t05-153


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for intake manifold air temperature.
ISX - Intake Manifold 1 Pressure Sensor Circuit
ISM - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the intake manifold temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness.
  • Signal circuit shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-154


Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operating Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing.
ISX - Intake Manifold 1 Pressure Sensor Circuit
ISM - Intake Manifold 1 Pressure Sensor Circuit

Circuit Description

The intake manifold air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold air temperature.

This fault code indicates that the intake manifold air temperature has exceeded the maximum engine protection limit.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold air temperature is greater than 132°C [270°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut off if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The intake manifold air temperature sensor measures the temperature of the charge air as it passes through the intake manifold. Possible causes of this fault code include:

  • Restricted air flow through the charge air cooler
  • Undersized charge air cooler
  • High turbocharger compressor outlet temperature
  • For marine engines verify the cooling water intake is not blocked or clogged with debris.
Refer to Troubleshooting Fault Code t05-155


Fault Code Path Selection

FAULT CODE 16-fc187
Fault Code Path Selection

Is the engine an ISM? | Go to 16-fc187ism
Is the engine an ISX? | Go to 16-fc187isx

Last Modified: 24-May-2006


Fault Code Path Selection

FAULT CODE 16-fc195
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 16-fc195-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 16-fc195-3wire

Last Modified: 25-May-2006


Fault Code Path Selection

FAULT CODE 16-fc196
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 16-fc196-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 16-fc196-3wire

Last Modified: 25-May-2006


Coolant Level - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid but Below Normal Operational Range - Moderately Severe Level. Low engine coolant level detected. | None on performance.
ISX and ISM - Engine Coolant Level 2-Wire Sensor Circuit
ISX and ISM - Engine Coolant Level 3-Wire Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) supplies 5 volts to the coolant level signal circuit. The resistance of the engine coolant level sensor changes based on the coolant level. The sensor resistance is between 5.4k ohms and 34k ohms when the sensor is submersed in coolant. The sensor resistance is between 333k ohms and 880k ohms when the sensor is not submersed in coolant. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM serive manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminated the amber CHECK ENGINE light after 20 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after 20 seconds of detecting the correct engine coolant level.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-197


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit detected at the engine oil temperature circuit. | No engine protection for engine oil temperature.
ISX - Engine Oil Temperature Sensor 1 Circuit
ISM - Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature.

When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle. 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature signal voltage is greater than 5.13-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-212


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil temperature circuit. | No engine protection for engine oil temperature.
ISX - Engine Oil Temperature Sensor 1 Circuit
ISM - Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature.

When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature signal voltage is less than 0.12-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-213


Engine Oil Temperature High - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature High - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine Oil Temperature High - Data Valid but Above Normal Operational Range - Most Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Progressive speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red STOP lamp starts flashing.
ISX - Engine Oil Temperature Sensor Circuit
ISM - Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The electronic control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature.

The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil temperature is greater than 122°C [252°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the coolant temperature decreases below the engine protection limit.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code t05-214


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | Engine power derate.
ISX - Barometric Pressure Sensor Circuit
ISM - Barometric Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on elevation that the engine is presently operating at. The ambient air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 volt supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in th ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure signal voltage is greater than 4.91-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the ambient pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-221


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | Engine power derate.
ISX - Barometric Pressure Sensor Circuit
ISM - Barometric Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure signal voltage is less than 0.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used of the ambient pressure reading.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-222


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | Engine will run derated. No engine protection for intake manifold air temperature.
ISX - Sensor Supply 2 Circuit
ISM - Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 of the electronic control module (ECM) provides a 5 volt supply for the camshaft position sensor, exhaust gas pressure sensor, rail fuel pressure sensor, intake manifold pressure/temperature sensor, and crankcase pressure sensor on the ISX engine.

For ISM engines, the sensor supply 2 of the ECM provides a 5 volt supply for the camshaft position sensor, exhaust gas pressure sensor, intake manifold pressure/temperature sensor, and crankcase pressure sensor.

Component Location

The sensor supply 2 is located in the ECM. The supply voltage is spliced off in the engine harness to each sensor it supports.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 2 signal voltage is more than 5.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas pressure sensor, intake manifold pressure sensor, and the crankcase pressure sensor is used.
  • The backup camshaft position sensor will not be functional.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a failed ECM.

Refer to Troubleshooting Fault Code t05-227


Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
Camshaft Position Sensor and Engine Speed Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are hall effect type sensors. The electronic control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used to determine the position of the engine by the ECM.

Component Location

The crankshaft speed sensor is located on the intake side of the engine near the number 6 cylinder at the crankshaft centerline. The camshaft speed sensor is located below the fuel pump in the back of the gear housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine speed has exceeded the calibration limit for excessive engine speed.

Action Taken When the Fault Code is Active

  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the engine speed drops to normal operating speeds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage.
  • Reverse powering (motoring) of the engine.
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-234


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Possible hard starting and rough running.
ISX - Engine Speed Sensor Supply 3 Circuit
ISM - Engine Speed Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides 5 volt supply to the primary engine speed/position sensor.

Component Location

The engine speed sensor is located in the lower portion of the front cover on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the sensor supply 3 signal voltage is less than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a limit which can be calibrated then this fault is recorded.

Possible causes of this fault code are a short circuit to ground in the engine harness, sensor, or ECM.

Refer to Troubleshooting Fault Code t05-238


Wheel-Based Vehicle Speed - Data Erratic, Intermittent or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Data Erratic, Intermittent or Incorrect. The ECM lost the vehicle speed signal. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise control, Gear-Down Protection, and Road Speed Governor will not work.
ISM and ISX - Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion.

Conditions for Setting the Fault Codes

The ECM detects a loss of vehicle speed when other engine operating conditions indicate that the vehicle should be in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.

Conditions for Clearing the Fault Code

  • The ECM detects a valid engine speed signal from the vehicle speed sensor.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Refer to the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a vehicle speed signal greater than zero.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not catch all failures of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, please refer to the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-241


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P084 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change. Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to maximum engine speed without VSS parameter value. Cruise Control, Gear-down Protection, and Road Speed Governor will not work.
ISX and ISM - Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission.

Conditions for Running the Diagnostics

  • The adjustable parameter “VSS Anti-Tampering” must be enabled.
  • This diagnostic runs continuously when the vehicle is in motion if the feature is enabled.

Conditions for Setting the Fault Codes

The ECM detects a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.
  • Cruise Control, Gear-down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

  • The ECM detects a valid engine speed signal from the vehicle speed sensor.
  • The keyswitch must be turned ON, and the vehicle speed and engine speed must be 0 for 30 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Once the speed signal has been restored the fault code will go inactive once the keyswitch is on for 30 seconds and the ECM senses zero vehicle and engine speed.

Refer to Troubleshooting Fault Code t05-242


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S033 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can possibly stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the electronic control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a Pulse Width Modulated (PWM) signal. A PWM signal is pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by the OEM. Certain OEMs may use a solenoid return that is wired to the ECM or can use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM troubleshooting and repair manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is not detected to be system voltage when the PWM signal is turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The fan will not be enabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared by using the INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The fan control logic can be adjusted with the INSITE™ electronic service tool. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24 VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24 VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM troubleshooting and repair manual for procedures to check the fan control circuit for a short circuit to ground.

Refer to Troubleshooting Fault Code t05-245

Last Modified: 16-Jul-2010


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at ambient air temperature circuit. | None on performance.
ISX and ISM - Ambient Air Temperature Sensor 1 Circuit

Circuit Description

The ambient air temperature sensor is used by the electronic control module (ECM) to monitor ambient air temperature. This can be used to sense the temperature inside the cab of a vehicle or the air temperature outside of the vehicle. The ambient air temperature signal is used by the ECM for the Idle Shutdown Ambient Air Temperature Override feature.

The ambient air temperature sensor is used by the ECM to monitor the ambient air temperature. The ambient air temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air temperature signal voltage is greater than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • The Idle Shutdown Ambient Air Temperature Override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-249


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S017 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at fuel shutoff valve circuit. | Fuel shutoff valve will close. Engine will shutdown.
ISX - Engine Fuel Shutoff Valve Driver Circuit
ISM - Engine Fuel Shutoff Valve Driver Circuit

Circuit Description

The fuel shutoff valve is a device used by the electronic control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

The engine fuel shutoff valve driver circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage.

Component Location

The fuel shutoff valve is located near the fuel pump. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The engine will be shutdown and will not restart.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Inspect the fuel shutoff supply circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit. If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not failed and pulled down the voltage on the fuel shutoff circuit. Inspect the engine-to-chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface.

Possible causes for this fault include:

  • Short circuit to ground in the engine harness, connectors, or fuel shutoff valve.
Refer to Troubleshooting Fault Code t05-254


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 255

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S017 SPN: 632 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or short to voltage source detected at fuel shutoff valve circuit. | Fuel shutoff valve may not open when keyswitch is in ON position, or may not close when keyswitch is in OFF position.
ISX - Engine Fuel Shutoff Valve Driver Circuit
ISM - Engine Fuel Shutoff Valve Driver Circuit

Circuit Description

The fuel shutoff valve is a device used by the electronic control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

The engine fuel shutoff valve driver circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage.

Component Location

The fuel shutoff valve is located near the fuel pump. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit PWM signal is detected to be at system voltage when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine will be shutdown and will not restart.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If there is an external shutdown system on the vehicle, make sure it is not miswired and feeding voltage into the fuel shutoff supply circuit.

Possible causes of this fault include:

  • Open circuit in the engine harness, connectors, or shutoff valve.
  • Fuel shutoff valve signal wire shorted to a voltage source in the harness.
Refer to Troubleshooting Fault Code t05-255


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at ambient air temperature circuit. | None on performance.
ISX and ISM - Ambient Air Temperature Sensor 1 Circuit

Circuit Description

The ambient air temperature sensor is used by the electronic control module (ECM) to monitor ambient air temperature. This can be used to sense the temperature inside the cab of a vehicle or the air temperature outside the vehicle. The ambient air temperature signal is used by the ECM for the Idle Shutdown Ambient Air Temperature Override feature.

The ambient air temperature sensor is used by the ECM to monitor the ambient air temperature. The ambient air temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 VDC reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air temperature signal voltage is less than 0.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • The Idle Shutdown Ambient Air Temperature Override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-256


Fault Code Path Selection

FAULT CODE 16-fc257
Fault Code Path Selection

Is the engine an ISM? | Go to 16-fc257ism
Is the engine an ISX? | Go to 16-fc257isx

Last Modified: 01-Dec-2008


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine fuel temperature circuit. | Possible low power when engine is cold.
ISX - Engine Fuel Temperature Sensor 1 Circuit

Circuit Description

The engine fuel temperature sensor is used by the electronic control module (ECM) to monitor engine fuel temperature. Fuel temperature is used by the ECM to adjust fuel delivery to the injectors. The engine fuel temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 VDC reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

Component Location

The engine fuel temperature sensor is located on the lower rear of the integrated fuel system module (IFSM). Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel temperature signal voltage is greater than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine fuel temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The engine fuel temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-263


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine fuel temperature circuit. | Possible low power when engine is cold.
ISX - Engine Fuel Temperature Sensor 1 Circuit

Circuit Description

The engine fuel temperature sensor is used by the electronic control module (ECM) to monitor the engine fuel temperature. Fuel temperature is used by the ECM to adjust fuel delivery to the injectors. The engine fuel temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 VDC reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

Component Location

The engine fuel temperature sensor is located on the lower rear of the integrated fuel system module (IFSM). Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel temperature signal voltage is less than 0.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the engine fuel temperature reading.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The engine fuel temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-265


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | One or more multiplexed devices will not operate properly. One or more symptoms will occur.
ISX and ISM - SAE J1939 Multiplexing Circuit

Circuit Description

Normally, switches, accelerators and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 Data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second.

The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, malfunctioning OEM VECU or malfunctioning Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-285


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
ISX and ISM - SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU to the Cummins® engine ECM over the SAE J1939 Data link.

Messages sent from OEM VECUs or Transmission ECUs are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

The J1939 Data link wiring and VECU location varies by OEM. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM expects to receive a valid J1939 message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-286

Last Modified: 09-Dec-2011


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

FAULT CODE 287

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 287 PID: P91 SPN: 91 FMI: 2/19 LAMP: Red SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit (VECU) detected a fault with its accelerator pedal. | Engine may only idle or engine will not accelerate to full speed.
ISX and ISM - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) VECU or transmission electronic control unit in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins engine ECM over the SAE J1939 datalink.

Messages sent from the OEM VECU or transmission electronic control unit are received by the Cummins engine ECM and used for controlling the engine. The Cummins ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view. The J1939 datalink wiring and VECU location varies by OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The accelerator is depressed and the OEM VECU reads accelerator position as greater than 0%, but the secondary throttle position sensor indicates it is in the idle position.

When the accelerator is released and the OEM VECU reads accelerator position as 0%, but the secondary throttle position sensor indicates it is not in the idle position.

The OEM VECU determines that the accelerator signal wire is shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault can occur when the OEM VECU detects an error on the accelerator. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the idle validation switch states and accelerator position over the J1939 datalink from an OEM VECU, and the OEM VECU is transmitting the message for that component.

The three types of errors that can occur for this fault are:

  • When the accelerator is depressed and the OEM VECU reads accelerator position as greater than 0%, but the idle validation switch indicates it is in the idle position. This fault status is transmitted to the Cummins ECM on the J1939 datalink, which causes this fault to occur in the Cummins ECM.
  • When the accelerator is released and the OEM VECU reads accelerator position as 0%, but the idle validation switch indicates it is not in the idle position. This fault status is transmitted to the Cummins ECM on the J1939 datalink, which causes this fault to occur in the Cummins ECM.
  • The OEM VECU determines that the accelerator signal line is shorted high or shorted low.

NOTE: It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins ECM, for other components, or the accelerator and idle validation switch, or if the datalink is damaged. The OEM configurations must multiplex the accelerator and idle validation switch inputs together to allow the use of the J1939 multiplexing and limp home feature for these components. The INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-287


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 2/19 LAMP: Red SRT: | SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | The engine will not respond to the remote throttle. Engine may only idle. The primary or cab accelerator may be able to be used.
ISX and ISM - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM VECU or transmission electronic control unit (ECU) in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins engine ECM over the SAE J1939 datalink.

Messages sent from the OEM VECU or transmission ECU are received by the Cummins engine ECM and used for controlling the engine. The Cummins ECM and OEM VECU must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view. The J1939 datalink wiring and VECU location varies by OEM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The OEM VECU determines that the remote throttle signal wire is shorted high or shorted low. This fault status is transmitted to the Cummins ECM on the J1939 datalink, which causes this fault to occur in the Cummins ECM.

When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU. This fault status is transmitted to the ECM on the J1939 datalink, which causes this fault to occur in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 datalink from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEMs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

  • The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins ECM on the J1939 datalink, which causes this fault to occur in the Cummins ECM.
  • When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU. This fault status is transmitted to the ECM on the J1939 datalink, which causes this fault to occur in the ECM. Most OEMs will not incorporate fault detection on a switch.

Note: It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins ECM for other components, or the remote throttle and remote throttle switch, or the datalink is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. The INSITE™ electronic service tool can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-288


Barometric Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2/2 LAMP: Amber SRT: | Barometric Pressure - Data Erratic, Intermittent, or Incorrect. The ambient air pressure sensor is reading an erratic value at initial key-on. | Engine power derate.
ISX - Barometric Pressure Circuit
ISM - Barometric Pressure Circuit

Circuit Description

The ambient air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on elevation where the engine is currently operating. The ambient air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 VDC supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned on before the engine is started.

The diagnostic only runs once per trip when the keyswitch is initially turned on.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure reading is higher or lower than the other absolute pressure sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the ambient pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

At key-on, before the engine starts, the sensor readings for intake manifold pressure, exhaust gas pressure, and engine oil pressure are compared with the barometric pressure. This fault code occurs if the barometric pressure sensor reading is different from the other three. This check is only done once after the keyswitch is turned on.

Possible causes of this fault code include:

  • Stuck in-range barometric pressure sensor reading.
  • High resistance in the barometric pressure sensor signal or return lines.
Refer to Troubleshooting Fault Code t05-295


Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 311

Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 311 PID: S001 SPN: 651 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 1 when voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM - Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness. with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to ground in the engine harness or injector.
  • Short circuit to voltage source in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code t05-311


Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 312

Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 312 PID: S005 SPN: 655 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 5 when the voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM - Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness. with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to ground in the engine harness or injector.
  • Short circuit to voltage source in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code t05-312


Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 313

Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 313 PID: S003 SPN: 653 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 3 when voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM - Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness. with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to ground in the engine harness or injector.
  • Short circuit to voltage source in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code t05-313


Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 314

Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 314 PID: S006 SPN: 656 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 6 when voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM - Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness. with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to ground in the engine harness or injector.
  • Short circuit to voltage source in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code t05-314


Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 315

Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 315 PID: S002 SPN: 652 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 2 when voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM - Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness. with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the right side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to ground in the engine harness or injector.
  • Short circuit to voltage source in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code t05-315


Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect

FAULT CODE 319

Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Amber (Maintenance Flashout) SRT: | Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect. Real-time clock lost power. | None on performance. Data in the ECM will not have accurate time and date information.
ISX and ISM - Real-Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the electronic control module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real-time clock battery is secured to the engine harness near the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the real time clock battery voltage is 3.3 VDC.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light at initial key-on when the diagnostic runs and fails.
  • The real time clock values in the ECM data will be incorrect.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault are weak or failed real-time clock battery, failed wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

Refer to Troubleshooting Fault Code t05-319


Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal, or Grounded Circuit

FAULT CODE 321

Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal, or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 321 PID: S004 SPN: 654 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal, or Grounded Circuit. Current detected at injector Number 4 when voltage is turned off. | Current to injector is shut off. Engine can possibly misfire or run rough.
ISM - Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • Short circuit to voltage source in the engine harness.
  • Short circuit between the injector (+) and injector (-) in the engine harness.
  • Low or high resistance in the injector.
Refer to Troubleshooting Fault Code t05-321


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal, or Open Circuit. Current detected at injector number 1 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-322


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal, or Open Circuit. Current detected at injector number 5 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-323


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal, or Open Circuit. Current detected at injector number 3 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-324


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. Current detected at injector number 6 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-325


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal, or Open Circuit. Current detected at injector number 2 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-331


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S006 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal, or Open Circuit. Current detected at injector number 4 when voltage is turned off. | The current to the injector is shut off. The engine can possibly misfire or run rough.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the injector from the ECM on the supply wire and it returns on the return wire after actuating the solenoid. Each solenoid valve is normally open, and it is only closed by an electrical pulse from the ECM during fuel injection and metering. The solenoid resistance specification is between 0.5 and 1.5 ohms.

Component Location

The ISM has an internal actuator harness that connects to the external engine harness with a 15-pin connector at the front side of the rocker lever housing. The internal actuator harness is located on the inside of the rocker lever housing on the exhaust side. It has six connectors spaced along its length - one for each injector solenoid. These connectors attach to the pigtail connector on each injector.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 0 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the injector circuit is shorted to ground, high injector solenoid resistance, or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The injector will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or injector
  • High resistance in the injector.
Refer to Troubleshooting Fault Code t05-332


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 338

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S087 SPN: 1267 FMI: 3/3 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal, or Shorted to High Source. Open circuit or short to voltage source detected at the idle shutdown vehicle accessory/ignition bus relay circuit. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
ISX and ISM - Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The electronic control module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to “Installed”, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by original equipment manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service literature to determine grounding configuration.

Component Location

This idle shutdown relay location varies by OEM. Refer to the OEM service literature to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The idle shutdown relay pulse width modulated (PWM) signal is detected to be at system voltage by the ECM when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded OFF, it records this fault code. This fault code can be caused by:

  • ECM Idle Shutdown feature set up incorrectly.
  • Open circuit in the idle shutdown relay, OEM harness or connectors.
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code t05-338


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 339

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S087 SPN: 1267 FMI: 4/4 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the idle shutdown vehicle accessory/ignition bus relay circuit when commanded. on. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
ISX and ISM - Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The electronic control module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to “Installed”, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by original equipment manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service literature to determine the grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service literature to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The idle shutdown relay pulse width modulated (PWM) signal is detected by the ECM to be at 0 VDC when the PWM voltage is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on this circuit. This fault code is logged if it detects a low voltage when the relay signal is commanded on. This fault code can be caused by a short circuit to ground in the idle shutdown relay, OEM harness or connectors.

Refer to Troubleshooting Fault Code t05-339


Electronice Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Electronice Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Electronic Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. ECM power supply errors have been detected. | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
ISX and ISM - Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the OEM power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the internal ECM diagnostics detect a read or write error internal to the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code t05-343


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: 253 SPN: 630 FMI: 12 LAMP: Amber SRT: | Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component. Invalid switch configuration adjustable parameter setting have been detected by the engine control module (ECM). | Various optional switch inputs to the ECM may not operate correctly.
Engine Control Module (ECM)

Circuit Description

The accelerator interlock switch and powertrain protection torque limit switch, clutch pedal position switch and engine protection shutdown manual override switch, idle shutdown accessory relay and engine brake lamp output, switched maximum engine operating speed and governor type switch are all outputs or switched inputs from the ECM that can be enabled or disabled using INSITE™ electronic service tool. Many of the outputs and switched inputs share a common wire on the OEM wiring harness.

Component Location

The output or switched inputs to this diagnostic are found in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key on only.

Conditions for Setting the Fault Codes

The ECM detects that features that share a common OEM harness input or output to the ECM are simultaneously enabled at the same time.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set. The features that are in conflict may not operate correctly.

Conditions for Clearing the Fault Code

The fault code will be set inactive at key on when the conflicting features have been adjusted correctly.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Many of the outputs and switched inputs share a common wire on the OEM wiring harness. If two features that share a common OEM wire are enabled simultaneously in the ECM, this fault code will be logged. To disable the fault code, disable one of the features on the shared OEM wire. For example, if the accelerator interlock switch and powertrain protection torque limit switch are both enabled in the ECM, either disable one of the features with INSITE™ electronic service tool or configure one of the features to be multiplexed using the SAE® J1939 multiplexing feature.

Refer to Troubleshooting Fault Code t05-346


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 627 FMI: 12/12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Possible low power, engine misfire, and/or engine will not start.
ISM - Injector Power Supply Circuit

Circuit Description

Between each injection event, the electronic control module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors; this power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the measured injector power supply voltage is lower than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the keyswitch is cycled.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

This fault code will become active when the engine is running, the primary engine speed sensor signal is present, the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned on.

This fault code will become inactive whenever the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code t05-351


Sensor Supply 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Engine power derate.
ISX - Sensor Supply 1 Circuit
ISM - Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 of the electronic control module (ECM) provides a 5 VDC supply for the barometric pressure sensor, engine oil pressure sensor, exhaust gas recirculation (EGR) differential pressure sensor, and the aftertreatment fuel pressure sensor.

Component Location

Sensor supply number 1 is located in the ECM engine harness connector and provides a 5 VDC supply to various pressure sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 signal voltage is less than 4.8 VDC for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure sensor, engine oil pressure sensor, EGR differential pressure sensor, and the aftertreatment fuel pressure sensor is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-352


Sensor Supply 1 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Engine power derate.
ISX - Sensor Supply 1 Circuit
ISM - Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 of the electronic control module (ECM) provides a 5 VDC supply for the barometric pressure sensor, engine oil pressure sensor, exhaust gas recirculation (EGR) differential pressure sensor, and the aftertreatment fuel pressure sensor.

Component Location

Sensor supply number 1 is located in the ECM engine harness connector and provides a 5 VDC supply to various pressure sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 1 signal voltage is greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure sensor, engine oil pressure sensor, EGR differential pressure sensor, and aftertreatment fuel pressure sensor is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-386


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing.
ISX - Engine Oil Rifle Pressure Circuit
ISM - Engine Oil Rifle Pressure Circuit

Circuit Description

The electronic control module (ECM) provides a 5 VDC supply to the engine oil pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure can be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

If the ECM detects low signal voltage indicating a low engine oil pressure, this fault code sets.

Component Location

The engine oil pressure sensor is located on the left side of the engine block, below and to the rear of the integrated fuel system module (IFSM). Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is less than the 41 kPa [6 psi] at 800 rpm for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • A torque derate issued by the ECM limiting the power output of the engine.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light and the torque derate will be removed when the oil pressure reading is detected to be within the normal operating range.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code indicated that low engine oil pressure has been detected by the ECM. Troubleshoot the cause of the low engine oil pressure.

Refer to Troubleshooting Fault Code t05-415


Water-In-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water-In-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water-In-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
ISX - Water-In-Fuel Indicator
ISM - Water-In-Fuel Indicator

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5 VDC reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor then pulls the 5 VDC reference voltage to ground indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that water in the fuel filter is above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the flashing amber MAINTENANCE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the flashing amber MAINTENANCE light immediately after the water has been drained from the fuel filter.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code t05-418

Last Modified: 12-Oct-2011


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection warning limit. | Possible reduced engine performance.
ISX - Engine Oil Temperature Sensor Circuit
ISM / QSM11 - Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil in the oil rifle. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature. The engine oil temperature sensor is used to monitor the engine oil temperature. If the temperature exceeds a calibration limit, an engine protection fault code will be triggered.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected the engine oil temperature was greater than the warning engine protection limit for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the manfunction indicator lamp (MIL) for on-board diagnostics (OBD) applications.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the warning engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature

Refer to Troubleshooting Fault Code t05-421.

Last Modified: 04-Feb-2014


SAE J1939 Datalink - Abnormal Update Rate

FAULT CODE 427

SAE J1939 Datalink - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9/9 LAMP: None SRT: | J1939 Datalink - Abnormal Update Rate. Communication between the electronic control module (ECM) and another device on the SAE J1939 data link has been lost. | Engine speed will ramp down and remain at idle.
ISX and ISM - SAE J1939 Data Link Circuit

Circuit Description

Devices such as ABS controllers, autoshift transmissions, ASR systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) (VECUs) can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The ECM is located on the intake side of the engine, near the front. The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than one second. The ECM detects an open or short circuit condition in the J1939 datalink harness.

Action Taken When the Fault Code is Active

  • The ECM will log the fault code immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

The ECM will set the fault code inactive immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault occurs whenever the ECM has been receiving SAE J1939 datalink commands from an external OEM device and is no longer receiving the datalink commands. Possible causes of this fault include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
  • The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages
  • The external OEM controlling device has failed or can no longer transmit on the datalink.
Refer to Troubleshooting Fault Code t05-427


Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 428

Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P097 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
ISX - Water-in-Fuel Sensor Circuit
ISM - Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5-VDC reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage to ground, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor signal voltage is above 4.95-VDC for one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes for this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-428


Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 429

Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
ISX - Water-in-Fuel Sensor Indicator
ISM - Water-in-Fuel Sensor Indicator

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The electronic control module (ECM) provides a 5 VDC reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor then pulls the 5 VDC reference voltage to ground indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor signal voltage is below 0.05 VDC for one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-429


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect. The engine oil pressure sensor is reading an erratic value at key ON. | None on performance. No engine protection for oil pressure.
ISX - Engine Oil Pressure Circuit
ISM - Engine Oil Pressure Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is turned ON and before engine speed is detected.

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure reading is higher or lower than the other absolute pressure sensors on the engine, when the keyswitch is ON and the engine is not operating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

At key-on, before the engine starts, the sensor readings for intake manifold pressure, exhaust gas pressure, engine air pressure, and engine oil pressure are compared to each other. This fault code occurs if the engine oil pressure sensor reading is different from the other sensor readings. This check is only done once after the keyswitch is turned ON.

Possible causes of this fault code include.

  • Stuck in-range engine oil pressure sensor reading
  • High resistance in the engine oil pressure sensor signal or return lines.
Refer to Troubleshooting Fault Code t05-435


Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine may stop running or be difficult to start.
ISX and ISM - Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-ampere fuse in the unswitched battery wires to protect the original equipment manufacturer (OEM) harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the intake side of the engine. The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is less than +6-VDC.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the fault code immediately after the battery voltage is above +6-VDC.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the ECM battery supply voltage drops below +6-VDC.

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code t05-441


Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to all electrical components.
ISX and ISM - Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-ampere fuse in the unswitched battery wire to protect the OEM harness. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view. The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual for battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the main battery supply voltage is greater than +36-VDC.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the fault code immediately after the battery voltage drops below +36-VDC.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the ECM battery supply voltage exceed +36-VDC. Causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code t05-442


Fuel Pressure Low - Data Valid But Below Normal Operational Range - Moderately Severe Level.

FAULT CODE 482

Fuel Pressure Low - Data Valid But Below Normal Operational Range - Moderately Severe Level.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 482 PID: P094 SPN: 94 FMI: 1/18 LAMP: Amber SRT: | Fuel Pressure Low - Data Valid But Below Normal Operational Range - Moderately Severe Level. | Engine may not start, white smoke, run rough, or lose power.
Fuel System Circuit

Circuit Description

The gear pump draws fuel from the fuel tank through a suction fuel filter and an anti-drainback valve. The gear pump develops between 1724 and 2620 kPa [250 and 380 psi] of fuel pressure. The fuel flows through a pressure fuel filter and fuel shutoff valve to the fueling and timing actuators and rail fuel pressure sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel pressure is monitored by the ECM. If the rail fuel pressure is lower than an acceptable level for a given set of engine operating conditions, the fault code is logged.

NOTE: One possible cause of this fault code is a damaged or sticking drain-back valve located in the fuel supply circuit in the integrated fuel system module (IFSM). The IFSM is located directly above the fuel lift pump.

Refer to Troubleshooting Fault Code t05-482.

Last Modified: 07-Jan-2011


Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: P094 SPN: 94 FMI: 3/3 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the rail fuel pressure circuit. | Engine may crank longer than usual before starting, may have low power, white smoke, or run rough.
ISX - Fuel Delivery Pressure Sensor

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel manifold of the integrated fuel system module. The fuel delivery pressure sensor has a 5-VDC supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5-VDC supply to the fuel delivery pressure sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a signal to the ECM on the fuel deliver pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The rail fuel pressure sensor is located on the bottom front corner of the integrated fuel system module. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the fuel delivery pressure signal voltage is greater than 4.92-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The rail fuel pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 546, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-546


Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: P094 SPN: 94 FMI: 4 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage or an open circuit detected at the rail fuel pressure circuit. | Engine may not start, may have low power, white smoke, or run rough.
ISX - Fuel Delivery Pressure Sensor

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel manifold of the integrated fuel system module. The fuel delivery pressure sensor has a 5 VDC supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 VDC supply to the fuel delivery pressure sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel manifold. The ECM will detect a high signal voltage during high engine load operating conditions.

Component Location

The rail fuel pressure sensor is located on the bottom front corner of the integrated fuel system module. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the fuel delivery pressure signal voltage is less than 0.34 VDC for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The rail fuel pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 547, check for multiple faults.

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor.
  • Signal circuit shorted to ground in the engine harness, connector, or sensor.
  • Failed sensor.
Refer to Troubleshooting Fault Code t05-547


Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 0/16 LAMP: Amber SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The crankcase breather system may require maintenance. | None on performance.
ISX - Crankcase Pressure Sensor Circuit
ISM - Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady-state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.

To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady-state highway-type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.

The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the malfunction indicator lamp for on-board diagnostics applications.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather element may be plugged
  • Crankcase pressure sensor damage
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code t05-555

Last Modified: 02-Nov-2015


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The crankcase breather system may require maintenance. | Possible reduced engine performance.
ISX - Crankcase Pressure Sensor Circuit
ISM - Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine torque output will be reduced to protect the engine from excessive crankcase pressure.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop-and-go city driving and steady-state highway driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady-state highway-type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the malfunction indicator lamp for on-board diagnostics applications.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather element may be plugged
  • Crankcase pressure sensor damage
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filter breather elements in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code t05-556

Last Modified: 02-Nov-2015


Starter Relay Driver Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 584

Starter Relay Driver Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Above Normal, or Shorted to High Source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
ISX and ISM - Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the ECM through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It may be wired back to the ECM on some vehicles, or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0 VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for exact location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is being energized or de-energized. In some cases the diagnostic may also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using the INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code.This fault can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code t05-584


Starter Relay Driver Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 585

Starter Relay Driver Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S039 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at starter lockout circuit. | The engine will not have starter lockout protection.
ISX and ISM - Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the electronic control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0 VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM troubleshooting and repair manual for exact location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is being energized or de-energized. In some cases the diagnostics may also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM signal is detected to be greater than 0 VDC when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The starter lockout feature will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using the INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded on, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Refer to Troubleshooting Fault Code t05-585


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. High battery voltage detected by the battery voltage monitor feature. | Amber warning lamp illuminated until high battery voltage condition is corrected.
ISX and ISM - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is higher than 18-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light when the battery voltage falls below 18-VDC.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding service manual for the engine being serviced.

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. View the Alternator Failure Warning feature settings with INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code t05-596

Last Modified: 09-Apr-2012


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low battery voltage detected by the battery voltage monitor feature. | Amber lamp will light until low battery voltage condition is corrected.
ISX and ISM - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than 10 VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light when the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the corresponding service manual for engine being serviced. Refer to Procedure 019-032 in Section 19.

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if Idle Speedup is enabled. View the Alternator Failure Warning feature settings with INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
  • High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.
Refer to Troubleshooting Fault Code t05-597

Last Modified: 09-Apr-2012


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level. Very low battery voltage detected by the battery voltage monitor feature. | Red lamp illuminated until very low battery voltage condition is corrected.
ISX and ISM - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM manual for the battery location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the battery voltage is less than 8 VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light when the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Use the corresponding service manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if Idle Speedup is enabled. View the Alternator Failure Warning feature settings with INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code t05-598

Last Modified: 09-Apr-2012


Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 629

Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 629 PID: SPN: 1176 FMI: 1/18 LAMP: Amber SRT: | Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level | An engine torque derate will occur.
ISX and ISM Electronic Control Module (ECM)

Circuit Description

The pressure differential over the compressor seal is a calculated value derived from the difference between charge pressure and crankcase pressure.

Component Location

None.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the pressure differential over the compressor seal exceeds the recommended maximum.

Action Taken When the Fault Code is Active

  • The ECM registers the fault code and illuminates the amber CHECK ENGINE light after the problem has persisted for 5 minutes.
  • An engine torque derate will occur as soon as the fault code goes active.

Conditions for Clearing the Fault Code

Once the ECM detects the pressure differential over the compressor seal has fallen below the maximum threshold, the fault code will go inactive.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable corrections to the calibration stored in the ECM. Refer to Procedure 019-032 (ECM Calibration) in Section 19.

Possible causes of this fault code include:

Crankcase filter needs to be replaced.

  • If the crankcase filter is being replaced frequently for this fault code, reference the Crankcase Coalescing Filter - Frequent Replacement troubleshooting symptom tree.
  • For ISM engines, reference the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, reference the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Air intake filter needs to be replaced.

  • Refer to Procedure For ISM engines, 010-031 (Air Intake Restriction) in Section 10 of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 010-031 (Air Intake Restriction) in Section 10 of the Signature&trade;, ISX, and QSX15 Service Manual, Bulletin 3666239.

A plugged or restricted crankcase ventilation system.

  • Check the tube between the engine and the coalescing filter.
  • Check the draft tube going from the coalescing filter to the atmosphere or intake manifold.
  • Consider the working environment. Ice, snow, or mud can temporarily block the tube and then fall away.

Complete the entire troubleshooting tree whether Fault Code 629 is active or inactive.

  • If a problem is found in the early steps, the troubleshooting tree should still be completed.
Refer to Troubleshooting Fault Code t05-629


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Engine Oil Change Interval - Condition Exists. Change engine oil and filter. | Maintenance reminder only.
Maintenance Reminder

Circuit Description

The electronic control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

The oil filter is located on the exhaust side of the engine, and the oil fill port varies by application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location for the oil filter and refer to the original equipment manufacturer (OEM) manual for the location of the oil fill port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that based on the programmable setting in the Maintenance Monitor feature, the engine oil and filter needs to be changed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the maintenance condition is exceeded.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the Maintenance Monitor feature has been reset using INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code will only become active if the Maintenance Monitor is enabled in INSITE™ electronic service tool. Make sure that the oil and filter are changed before clearing the fault.

Refer to Troubleshooting Fault Code t05-649


Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 686

Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 686 PID: P103 SPN: 103 FMI: 2/2 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect. An invalid turbocharger speed signal has been detected by the ECM. | None on performance. The ECM uses an estimated turbocharger speed.
ISX - Turbocharger 1 Speed Circuit
ISM - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger. Refer to Procedure 100-002 for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is above 120,000 rpm for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

This fault code is logged when the ECM detects a turbocharger speed that is greater than the speed that is physically achievable by the turbocharger. Usually this indicates a faulty sensor or incorrect speed signals from the turbocharger speed sensor. This fault can be caused by failures in the following components:

  • Turbocharger speed sensor.
  • Engine harness.
  • ECM power supply or grounds.
  • Electronic vehicle accessories which emit excessive electromagnetic interference.

This fault becomes inactive any time the ECM detects a valid turbocharger speed. If the fault occurs intermittently:

  • Look for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).
  • Look for sources of electronic noise such as poorly installed vehicle electronic components.
  • Be sure that the vehicle chassis grounds are in good condition.
  • Be sure that the ECM power supply and ground circuits are in good condition and that this power supply is not shared with other vehicle electronics.
Refer to Troubleshooting Fault Code t05-686


Turbocharger 1 Speed - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 687

Turbocharger 1 Speed - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 1/18 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid but Below Normal Operating Range - Moderately Severe Level. Low turbocharger speed detected by the ECM. | Engine power derate. The ECM uses an estimated turbocharger speed.
ISX - Turbocharger 1 Speed Circuit
ISM - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is detected to be less than 600 rpm for more than 1 second when the engine speed is greater than 1200 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will estimate turbocharger speed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault can possibly come active if the ECM senses engine speed while at the same time a turbocharger speed signal is less than 600 rpm.

Items that can fail and cause this fault code include:

  • Turbocharger speed sensor.
  • Engine harness.
  • ECM.

This fault becomes inactive any time the speed signal from the turbocharger speed sensor returns.

If the fault occurs intermittently, look for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code t05-687

Last Modified: 01-Jul-2011


Fault Code Path Selection

FAULT CODE 16-fc689
Fault Code Path Selection

Is the engine an ISM? | Go to 16-fc689ism
Is the engine an ISX? | Go to 16-fc689isx

Last Modified: 30-May-2006


Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the turbocharger compressor inlet air temperature circuit. | Engine power derate.
ISX - Turbocharger Compressor Inlet Temperature Sensor Circuit
ISM - Turbocharger Compressor Inlet Temperature Sensor Circuit

Circuit Description

The turbocharger compressor inlet air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor inlet of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor inlet temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the turbocharger compressor inlet air temperature.

Component Location

The turbocharger compressor inlet air temperature sensor is located in the compressor casing of the turbocharger. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the compressor inlet temperature signal voltage is greater than 4.8-VDC for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the compressor inlet temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The turbocharger compressor inlet air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor inlet temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or short circuit to a voltage source.
  • Malfunctioning sensor.

The resistance of the sensor varies with temperature. The sensor resistance should conform to the values in the table shown below.

Temperature (°F) | Temperature (°C) | Resistance (ohms)
14 | -10 | 49k to 62k
32 | 0 | 29k to 36k
68 | 20 | 11k to 14k
104 | 40 | 4.9k to 5.8k
158 | 70 | 1.6k to 1.9k
Refer to Troubleshooting Fault Code t05-691.

Last Modified: 20-Aug-2012


Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the turbocharger compressor inlet air temperature sensor circuit. | Engine power derate.
ISX - Turbocharger Compressor Inlet Air Temperature Sensor Circuit
ISM - Turbocharger Compressor Inlet Air Temperature Sensor Circuit

Circuit Description

The turbocharger compressor inlet temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor inlet of the turbocharger. The electronic control module (ECM) supplies 5 VDC to the compressor inlet temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The turbocharger compressor inlet air temperature sensor is located in the compressor casing of the turbocharger. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the compressor inlet temperature signal voltage is less than 0.2 VDC for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the compressor inlet temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

An extension harness between the main engine harness and the turbocharger compressor inlet temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code:

  • Signal circuit shorted to ground in the harness.
  • Signal circuit shorted to return or ground in the sensor.
  • Faulty sensor.

The resistance of the sensor varies with temperature. The sensor resistance should conform to the values in the table shown below.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
-10 | 14 | 49k to 62k
0 | 32 | 29k to 36k
20 | 68 | 11k to 14k
40 | 104 | 4.9k to 5.8k
70 | 158 | 1.6k to 1.9k
Refer to Troubleshooting Fault Code t05-692


ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit detected at the internal ECM temperature sensor. | None on performance.
ISX and ISM Electronic Control Module

Circuit Description

The electronic control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM is located on the fuel system side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is shorted to a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code t05-697


ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or an open circuit detected at the internal ECM temperature sensor. | None on performance.
ISX and ISM Electronic Control Module

Circuit Description

The electronic control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM is located on the fuel system side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the internal temperature sensor circuit is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code t05-698


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly, or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly, or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S064 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly, or Out of Adjustment. Engine position signal from the engine speed sensor and camshaft position sensor do not match. | Engine will run derated. Hard start and rough idle is possible.
ISX - Engine Magnetic Speed/Position
ISM - Engine Magnetic Speed/Position

Circuit Description

The crankshaft position and camshaft position sensors are hall effect type sensors. The electronic control module (ECM) provides a 5 VDC supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the lobes on the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used to determine the position of the engine by the ECM.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

This fault code is logged when there is a mechanical misalignment between the crankshaft engine position sensor and the camshaft engine position sensor.

Possible causes for this fault code include:

  • Engine speed sensor rings that are loose or not aligned correctly.
  • Mechanical misalignment.
Refer to Troubleshooting Fault Code t05-731


Fault Code Path Selection

FAULT CODE 16-fc778
Fault Code Path Selection

Is the engine an ISM? | Go to 16-fc778ism
Is the engine an ISX? | Go to 16-fc778isx

Last Modified: 30-May-2006


Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

FAULT CODE 784

Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: S145 SPN: 1590 FMI: 2/2 LAMP: None SRT: | Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect. Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
ISX and ISM - Adaptive Cruise Control Circuit

Circuit Description

The adaptive cruise control unit communicates with the electronic control module (ECM) sending and receiving vehicle speed control messages through the SAE J1939 data link.

Component Location

The location of the adaptive cruise control unit will vary by original equipment manufacturer (OEM). Refer to the OEM service manual for specific location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from the adaptive cruise control module for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The adaptive cruise control will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault is set active if the ECM does not receive the Heartbeat message from the adaptive cruise control unit on the SAE J1939 data link.

If Adaptive Cruise Recovery is enabled, the driver can toggle the cruise enable switch from the OFF position to the ON position two times to get regular cruise control to operate and Fault Code 784 will go inactive. At the next key cycle, if the Heartbeat message is still not present, Fault Code 784 will go active.

Refer to Troubleshooting Fault Code t05-784


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below 6.2 volts momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
ISX and ISM - ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the OEM power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that primary ECM power supply dropped below 6.2-VDC while the keyswitch was in the ON position. The fault code will be active when the keyswitch is turned on following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM records the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned off.

Conditions for Clearing the Fault Code

The ECM must see primary ECM battery voltage above 6.2-VDC when keyswitch is turned off before the fault code will go inactive.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. See the corresponding Service Manual for the engine being serviced.Refer to Procedure 019-032 in Section 19.

This fault is set active if the ECM battery supply voltage drops below 6.2-VDC while the keyswitch is in the ON position.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active.

An active Fault Code 1117 can prevent critical aftertreatment soot load information from being saved to permanent memory in the ECM. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch off can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Refer to Troubleshooting Fault Code t05-1117


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
ISX and ISM Accelerator Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Note: The sensor connection pin numbers shown in the diagram above are OEM specific and those provided are for example only. Refer to the OEM diagram for correct pinouts.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the throttle pedal signal voltage is greater than 2.5 VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Failed accelerator pedal position sensor.

Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-1239


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: None SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
ISX and ISM Accelerator or Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Note: The sensor connection pin numbers shown in the diagram above are OEM specific and those provided are for example only. Refer to the OEM diagram for the correct pinouts.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects when the throttle pedal signal voltage is less than 0.35 VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the INSITE™ electronic service tool while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Failed accelerator pedal position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-1241


Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P091 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect. Accelerator position sensor number 1 and number 2 are reading different values. | The engine will only idle.
ISX and ISM Accelerator Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2.

Note: The sensor connection pin numbers shown in the diagram above are OEM specific and those provided are for example only. Refer to the OEM service diagram for the correct pinouts.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the readings between accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.

Possible causes of the fault include:

  • Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2
  • Damaged accelerator pedal position sensor number 1 and damaged accelerator pedal position sensor number 2 signal wires are shorted together.
Refer to Troubleshooting Fault Code t05-1242


Aftertreatment Exhaust Gas Temperature 1 Swapped - Condition Exists

FAULT CODE 1663

Aftertreatment Exhaust Gas Temperature 1 Swapped - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1663 PID: S326 SPN: 3241 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 Swapped - Condition Exists. The inlet and outlet catalyst temperature sensor connections are swapped. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment catalyst and aftertreatment particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment particulate filter. These sensors monitor the temperatures in the aftertreatment system and determine is the aftertreatment catalyst is missing.

Component Location

The aftertreatment temperature sensors are located in the aftertreatment system. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for specific exhaust gas temperature sensor locations.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment system is actively regenerating the diesel particulate filter.

This diagnostic also runs during engine warm-up.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the aftertreatment diesel oxidation catalyst inlet temperature reading is higher than the aftertreatment diesel particulate filter inlet temperature during an active regeneration event of the diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The fault code will be set inactive following a key cycle if the fault was triggered during a regeneration event. If the fault code is active at key-on, allow the aftertreatment temperatures to cool below 32°C [90°F] and then start and run the engine at high idle for 10 minutes to clear the fault code.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is activated when the ECM determines that the temperature reading from the aftertreatment diesel oxidation catalyst inlet temperature sensor and the aftertreatment diesel particulate filter inlet temperature sensor are reading backwards. The most likely cause of this fault code is that the aftertreatment diesel oxidation catalyst inlet temperature sensor and the aftertreatment diesel particulate filter inlet temperature sensor connectors are swapped at the OEM harness.

The diesel oxidation catalyst inlet temperature sensor and the diesel particulate filter outlet temperature sensor have the same part number and electrical connections. The diesel particulate filter inlet temperature sensor has a different connector key to prevent it from being swapped with the other temperature sensors. Verify the aftertreatment temperature sensors are correctly installed.

An in-range failure of the aftertreatment diesel oxidation catalyst or the aftertreatment diesel particulate filter inlet temperature can cause this fault code. Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.

Refer to Troubleshooting Fault Code t05-1663


Catalyst Missing - Condition Exists

FAULT CODE 1664

Catalyst Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1664 PID: S380 SPN: 3050 FMI: 11/31 LAMP: Amber SRT: | Catalyst Missing - Condition Exists. The aftertreatment catalyst in the exhaust system is not present. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment catalyst and aftertreatment particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment particulate filter. These sensors monitor the temperatures in the aftertreatment system and determine if the aftertreatment catalyst is missing.

Component Location

The aftertreatment catalyst is located in the exhaust system. The location of the catalyst can vary depending on the original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment system is being actively regenerated to reduce soot in the aftertreatment diesel particulate filter. The diagnostic checks for a temperature increase across the catalyst during an active regeneration of the aftertreatment system to detect the presence of the catalyst.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor and the aftertreatment diesel particulate filter inlet temperature sensor are reading the same temperature during an active regeneration of the aftertreatment system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active regeneration of the aftertreatment system will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes, or at the next key-on.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code becomes active when the aftertreatment diesel oxidation catalyst inlet and aftertreatment diesel particulate filter inlet temperature sensors do not detect the presence of a catalyst in the aftertreatment system. This can be caused by tampering with the catalyst system, the catalyst has been removed from the vehicle, or a damaged catalyst.

Refer to Troubleshooting Fault Code t05-1664


Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1665

Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1665 PID: S326 SPN: 3241 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the catalyst inlet sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst inlet temperature sensor is located in the aftertreatment system. It is located at the inlet of the aftertreatment catalyst. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage is less than 0.1-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst inlet temperature sensor reading is used.
  • Active regeneration of the aftertreatment particulate trap is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment diesel oxidation catalyst inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return wire can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-1665


Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 1666

Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1666 PID: S326 SPN: 3241 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the catalyst inlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst inlet temperature sensor is located in the aftertreatment system. It is located at the inlet of the aftertreatment catalyst. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature signal voltage is greater than 4.97-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst inlet temperature reading is used.
  • Active regeneration of the aftertreatment diesel particulate filter is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment diesel oxidation catalyst inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return wire can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-1666


Aftertreatment Exhaust Gas Temperature 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1667

Aftertreatment Exhaust Gas Temperature 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1667 PID: S326 SPN: 3241 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel oxidation catalyst inlet temperature sensor is not changing with engine operating conditions. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage (low temperature). When the exhaust gas temperature is high, the thermistor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, (high temperature).

Component Location

The aftertreatment diesel oxidation catalyst inlet temperature sensor is located in the aftertreatment system. It is located at the inlet of the diesel oxidation catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and fuel injection into the aftertreatment system is not occurring.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst inlet temperature reading is used.
  • Active regeneration of the aftertreatment diesel particulate filter is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The engine must be running at 1200 RPM or above for 15 minutes and the aftertreatment diesel oxidation catalyst inlet temperature must be above 150°C [302°F] before the fault code will clear.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section19.

The aftertreatment sensors share a common ground wire with the coolant level sensor. Fault codes or problems related to the coolant level sensor and its ground circuit could potentially cause this fault.

Possible causes of this fault code include:

  • Coolant level sensor and/or coolant level sensor ground circuit fault codes or related problems
  • Stuck in-range aftertreatment diesel oxidation catalyst inlet temperature sensor
  • High resistance in the aftertreatment diesel oxidation catalyst inlet temperature sensor signal or return lines
  • A face plugged or damaged aftertreatment diesel oxidation catalyst.
Refer to Troubleshooting Fault Code t05-1667


Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1674

Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1674 PID: S327 SPN: 3249 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel particulate filter inlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor or thermistor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst and before the aftertreatment particulate filter. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter inlet temperature signal voltage is less than 0.1 VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter inlet temperature reading is used.
  • Active regeneration of the aftertreatment diesel particulate filter is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment diesel particulate filter inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-1674


Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1675

Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1675 PID: S327 SPN: 3249 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel particulate filter (DPF) inlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or a high temperature.

Component Location

The aftertreatment DPF inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst and before the aftertreatment particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment DPF inlet temperature signal voltage is greater than 4.97-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the aftertreatment DPF inlet temperature reading.
  • Active regeneration of the aftertreatment DPF is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the engine control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19.

The aftertreatment DPF inlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-1675

Last Modified: 09-Sep-2013


Aftertreatment Exhaust Gas Temperature 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1676

Aftertreatment Exhaust Gas Temperature 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1676 PID: S327 SPN: 3249 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter inlet temperature sensor is not changing with engine operating conditions. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts it to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst and before the aftertreatment particulate filter. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and fuel injection into the aftertreatment system is not occurring.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter inlet temperature sensor reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter inlet temperature reading is used.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The engine must be running at 1200 rpm or above for 15 minutes and the aftertreatment diesel oxidation catalyst inlet temperature must be above 150°C [300°F] before the fault code will clear.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter inlet temperature sensor.
  • High resistance in the aftertreatment diesel particulate filter inlet temperature sensor signal or return wires.
Refer to Troubleshooting Fault Code t05-1676


Catalyst Efficiency - Out of Calibration

FAULT CODE 1691

Catalyst Efficiency - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1691 PID: S380 SPN: 3250 FMI: 13/13 LAMP: Amber SRT: | Catalyst Efficiency - Out of Calibration. The temperature increase across the aftertreatment diesel oxidation catalyst is lower than expected. | None on performance. Active aftertreatment diesel particulate filter regeneration will be disabled.
Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet, at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.
  • Active regeneration of the aftertreatment diesel particulate filter must be occurring before the diagnostic will run.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the temperature differential across the aftertreatment diesel oxidation catalyst during active regeneration is not matching the expected temperature increase.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to perform INSITE™ electronic service tool Aftertreatment Reset procedure.
  • Perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • This fault code will also clear following a key cycle.

Shop Talk

Verify that the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the temperature increase across the catalyst during an aftertreatment injection event is lower than expected.

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment diesel oxidation catalyst
  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst
  • Cracked or contaminated aftertreatment diesel oxidation catalyst
  • Malfunction in the aftertreatment fuel injection system
  • Leaking exhaust system between the turbocharger and the diesel oxidation catalyst.

An in-range malfunction of the aftertreatment diesel oxidation catalyst inlet temperature sensor or the aftertreatment diesel particulate filter inlet temperature sensor can cause this fault code. Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.

Refer to Troubleshooting Fault Code t05-1691.

Last Modified: 10-May-2012


Sensor Supply 5 - Voltage Above Normal, or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal, or Shorted to High Source. High voltage detected at sensor supply number 5 circuit in the OEM harness. | Severe derate in power output of the engine. Limp home power only.
ISX and ISM - Sensor Supply 5

Circuit Description

The sensor supply 5 of the electronic control module (ECM) provides a 5 volt supply for the aftertreatment diesel particulate filter differential pressure sensor, remote accelerator, tachograph speed sensor, and the accelerator position sensor 2. The remote accelerator and tachograph speed sensor are optional original equipment manufacturer (OEM) components.

Component Location

Sensor supply number 5 is located in the ECM OEM harness connector and provides a 5 volt supply to various components in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 5 signal voltage is greater than 5.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for aftertreatment diesel particulate filter differential pressure is used.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.
  • The engine will have limp home throttle control only.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

High voltage on the 5 volt supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code t05-1695


Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the OEM harness. | Severe derate in power output of the engine. Limp home power only.
ISX and ISM - Sensor Supply 5

Circuit Description

The sensor supply 5 of the electronic control module (ECM) provides a 5 volt supply for the aftertreatment diesel particulate filter differential pressure sensor, remote accelerator, tachograph speed sensor, and accelerator position sensor 2. The remote accelerator and tachograph speed sensor are optional original equipment manufacturer (OEM) components.

Component Location

Sensor supply number 5 is located in the ECM OEM harness connector and provides a 5 volt supply to various components in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 5 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.
  • The engine has limp home throttle control only.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-1696


Crankcase Pressure Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the crankcase pressure circuit. | No engine protection for high crankcase pressure.
ISX - Crankcase Pressure Sensor
ISM - Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor monitors the pressure inside the crankcase gas filter assembly. If the pressure inside the crankcase filter assembly reaches a maximum level, a fault code will be logged indicating that maintenance is required on the crankcase filter.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the crankcase pressure signal voltage is greater than 4.8 VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1843


Crankcase Pressure Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the crankcase pressure circuit. | No engine protection for high crankcase pressure.
ISX - Crankcase Pressure Sensor
ISM - Crankcase Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the crankcase pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankcase pressure sensor provides a signal to the ECM on the crankcase pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the crankcase filter.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure signal voltage is less than 0.2 VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground, in the engine harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-1844


Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1866

Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1866 PID: P411 SPN: 411 FMI: 2/2 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect. An error in the EGR delta pressure signal was detected at initial key-on or the sensor failed the autozero test. | EGR valve actuation will be disabled.
ISX - Differential Pressure Sensor Circuit
ISM - Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure in the EGR crossover tube.

The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The sensor is located near the air intake. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs at key-off when the following conditions are met:

  • Engine coolant temperature is 67°C [154°F] or higher.
  • Intake manifold air temperature is 7°C [44°F] or higher.
  • Keyswitch transitions from ON to OFF.

Conditions for Setting the Fault Codes

The fault code is set active when the EGR differential pressure sensor is reading higher or lower than a calibratible value when the keyswitch is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light at key on when the diagnostic runs and fails.
  • The EGR valve actuation is disabled.

Conditions for Clearing the Fault Code

  • The engine coolant temperature is 67°C [154°F] or higher.
  • The intake manifold air temperature is 7°C [44°F] or higher.
  • The keyswitch transitions from ON to OFF.
  • The reading of the EGR differential pressure must be within the calibratible limits.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This check is only performed at keyswitch OFF, during the ECM powerdown. During this diagnostic check, the ECM monitors the value of the EGR differential pressure sensor. If this value is outside of a specified range, Fault Code 1866 is set active.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor.
  • High resistance in the wiring harness on the signal or return wire.
Refer to Troubleshooting Fault Code t05-1866


Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 1876

Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1876 PID: S328 SPN: 3245 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage or open circuit detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust gas temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5-VDC reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor or thermistor resistance is low. The signal pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel particulate filter. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet temperature signal voltage is greater than 4.97-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter outlet temperature reading is used.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment diesel particulate filter outlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-1876


Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1877

Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1877 PID: S328 SPN: 3245 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 3 Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously following a calibratible warm-up period. The diagnostic will not run for a calibratible period of time (up to 5 minutes) following a key cycle.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet temperature signal voltage is less than 0.1 VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas temperature 2 reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The ECM detects that the aftertreatment diesel oxidation catalyst inlet temperature sensor signal voltage has returned to normal operating conditions for more than 4 seconds.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment diesel particulate filter outlet temperature sensor shares return wires in the OEM harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-1877


Aftertreatment Exhaust Gas Temperature 3 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1878

Aftertreatment Exhaust Gas Temperature 3 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1878 PID: S328 SPN: 3245 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 3 - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter outlet temperature sensor is not changing with engine operating conditions. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel particulate filter. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and fuel injection into the aftertreatment system is not occurring.

Conditions for Setting the Fault Codes

  • The ECM detects that the aftertreatment diesel particulate filter outlet temperature sensor reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter outlet temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The engine must be running at 1200 RPM or above for 15 minutes and the aftertreatment diesel oxidation catalyst inlet temperature must be above 150°C [300°F] before the fault code will clear.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Use the appropriate procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter outlet temperature sensor.
  • High resistance in the aftertreatment diesel particulate filter outlet temperature sensor signal or return wires.
Refer to Troubleshooting Fault Code t05-1878


Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 1879

Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1879 PID: S324 SPN: 3251 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the aftertreatment differential pressure sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM Aftertreatment Diesel Particulate Filter Differential Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is located in the aftertreatment system. Refer to the OEM troubleshooting and repair manual for exact location of the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter differential pressure signal voltage is greater than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1879


Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1881

Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1881 PID: S324 SPN: 3251 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage or open circuit detected at the aftertreatment differential pressure sensor circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Differential Pressure

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is located in the aftertreatment system. Refer to the OEM troubleshooting and repair manual for exact location of the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter differential pressure signal voltage is less than 0.25-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the aftertreatment diesel particulate filter differential pressure is used.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor.
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-1881


Aftertreatment Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1883

Aftertreatment Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1883 PID: S324 SPN: 3251 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value at initial key-on or during engine operation. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is located in the aftertreatment system. Refer to the OEM troubleshooting manual for exact location of the aftertreatment system.

Conditions for Running the Diagnostics

  • This diagnostic runs when the keyswitch is initially turned on.
  • The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The diagnostic runs immediately after a startup delay has elapsed. The fault code is logged at key-on if the absolute value of the differential pressure is higher than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the aftertreatment diesel particulate filter differential pressure reading.
  • Aftertreatment regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires
  • Plugged aftertreatment differential pressure sensor tubes could cause this fault code if pressure is held in the tube after the engine is turned off.
Refer to Troubleshooting Fault Code t05-1883


EGR Valve Control Circuit - Abnormal Update Rate

FAULT CODE 1893

EGR Valve Control Circuit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1893 PID: S324 SPN: 3251 FMI: 2 LAMP: Amber SRT: | EGR Valve Control Circuit - Abnormal Update Rate. No communications or invalid data transfer rate detected on the SAE J1939 data link between the ECM and the smart EGR valve. | EGR valve operation will be disabled.
ISX - EGR Valve Circuit
ISM - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the SAE J1939 data link. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the SAE J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual-poppet valve to open the EGR valve. A spring is used to close the EGR valve.

Component Location

The EGR valve location can vary depending on the engine application. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The primary engine ECM does not receive a valid SAE J1939 message from the EGR valve for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable the EGR valve operation immediately after a valid SAE J1939 message is received from the EGR valve.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. For ISX and ISM engines, see the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the primary engine ECM did not receive valid SAE J1939 information from the EGR valve.

Possible causes of this fault code include:

  • The EGR valve is not receiving power from the ECM. This could be caused by an open circuit in the power supply wire or low voltage supplied by the primary engine ECM.
  • Open return circuit on the EGR valve circuit between the engine ECM and the EGR valve.
  • Open or short circuit on the SAE J1939 data link circuit between the ECM and the EGR valve.
  • Intermittent communications between the EGR valve and the primary engine ECM on the SAE J1939 data link.
  • Malfunctioning termination resistors in the engine data link harness.
  • A malfunctioning engine ECM.
  • A malfunctioning EGR valve.
Refer to Troubleshooting Fault Code t05-1893


EGR Valve Controller - Bad Intelligent Device or Component

FAULT CODE 1895

EGR Valve Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1895 PID: S146 SPN: 2791 FMI: 12/12 LAMP: Amber SRT: | EGR Valve Controller - Bad Intelligent Device or Component. A calibration mismatch between the EGR valve and the ECM has been detected. | EGR valve actuation will be disabled.
ISX - EGR Valve Circuit
ISM - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 datalink. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine electronic control module (ECM) using the J1939 datalink.

The EGR valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor is not used to close the EGR valve. The pin retracts and a spring is used to close the EGR valve.

This fault code is logged when the calibration version contained in the EGR valve is mismatched with the version in the ECM.

Component Location

The EGR valve location can vary depending on the engine application. Refer to Procedure 100-002 (Engine Diagrams) in Section F for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

  • The ECM has detected a calibration incompatibility between the EGR valve and the ECM calibration.
  • The ECM has detected an incorrect EGR valve installed on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will stop responding to commands and the spring will close the EGR valve.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and clear the fault code after the keyswitch is cycled and the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the ECM has detected an incorrect EGR valve has been installed on the engine.

Refer to Troubleshooting Fault Code t05-1895


EGR Valve Controller - Out of Calibration

FAULT CODE 1896

EGR Valve Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1896 PID: S146 SPN: 2791 FMI: 13/13 LAMP: Amber SRT: | EGR Valve Controller - Out of Calibration. The EGR valve has failed the automatic calibration procedure at initial key ON. | EGR valve actuation will be disabled.
ISX CM871 - EGR Valve Circuit
ISM CM876 - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 data link. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor is not used to close the EGR valve. The pin retracts and a spring is used to close the EGR valve.

Component Location

The EGR valve location can vary depending on the engine application. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section F.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The EGR valve motor measures the position of the EGR valve at initial key ON. If the valve is detected to be greater than 20 percent open, the fault code is set active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will stop responding to commands and the spring will close the EGR valve.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and clear the fault code after the keyswitch is cycled and the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding troubleshooting and repair manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

When the keyswitch is initially turned ON, and at various times during engine operation, the closed position of the EGR valve is checked. This diagnostic checks to make sure the EGR valve is not stuck open.

This fault code is logged when the following error conditions exist:

  • The EGR valve motor measures the position of the EGR valve at initial key ON. If the valve is detected to be out of the normal position, this fault code will be logged.
  • The EGR valve will close when the fault code is active.
  • The fault code will remain active until the next key cycle.

The ECM calibration contains an automatic EGR valve override test 30 seconds after turning the keyswitch ON. The EGR valve will be commanded open to 60 percent and will be held in this position for 1 minute and then it will be commanded to 0 percent open. Turn the keyswitch OFF for 20 seconds and then turn the keyswitch ON and read the fault codes. If Fault Code 1896 is active, this indicates the EGR valve is stuck in the open position.

The fault code will only become inactive if the initial key ON EGR position check passes.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap-Acceleration Test to check for a damaged diesel particulate filter. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature, ISX and QSX15 Service Manual, Bulletin 3666239, for aftertreatment reuse guidelines. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code t05-1896.

Last Modified: 03-Dec-2010


Exhaust Gas Recirculation Valve Delta Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1899

Exhaust Gas Recirculation Valve Delta Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1899 PID: P411 SPN: 411 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The EGR differential pressure sensor has detected low EGR gas flow or the EGR differential pressure reading is not valid for engine operating conditions. | EGR valve actuation will be disabled.
ISX - Differential Pressure Sensor
ISM - Differential Pressure Sensor

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The ECM uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The electronic control module (ECM) provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.

The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the following conditions are met:

  • EGR valve position is greater than 5 percent open.
  • Engine speed is greater than 1200 rpm.
  • Engine torque output is greater than a calibratible value.

Conditions for Setting the Fault Codes

EGR differential pressure is less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This diagnostic checks the reading of the EGR differential pressure sensor when the EGR valve is open. Since the EGR valve is open, the reading of the EGR differential pressure must be greater than 0. If the ECM detects a reading lower than expected with the EGR valve open, this fault code is logged.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor.
  • A leaking low or high EGR differential pressure tube.
  • A stuck closed EGR valve.
  • A plugged or restricted EGR cooler.

Note: Do not replace the EGR differential pressure tubes for plugging unless Fault Code 2774 is active.

Refer to Troubleshooting Fault Code t05-1899

Last Modified: 01-Jul-2011


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 1921

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1921 PID: S324 SPN: 3251 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | The aftertreatment dash lamp will flash. Engine protection derate.
ISX and ISM - Aftertreatment System

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code can be triggered if the application is not operating at a duty cycle high enough to actively regenerate the aftertreatment diesel particulate filter. This fault code indicates that the exhaust temperatures exiting the turbocharger are not high enough to actively regenerate the soot that is trapped in the aftertreatment diesel particulate filter. It may be necessary to increase the duty cycle of the application in order to prevent plugging of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the soot load of the aftertreatment diesel particulate filter is moderately severe. The aftertreatment system needs to be regenerated to remove the soot.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light immediately after the diagnostic fails.
  • The ECM will flash the aftertreatment lamp immediately after the diagnostic fails.
  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the soot load in the aftertreatment diesel particulate filter has dropped below the moderately severe level.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Note: This fault code indicates that the aftertreatment diesel particulate filter requires maintenance by performing a stationary regeneration procedure. This is a maintenance procedure only and is not covered by Cummins® warranty.

Possible causes of this fault code include:

  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment diesel particulate filter.
  • Possible engine damage that causes excessive black soot to be generated.
  • The aftertreatment diesel particulate filter can accumulate an excessive amount of ash in a short time period. This can be due to excessive oil consumption or due to non-combustible elements such as, but not limited to, iron, potassium, or calcium contained in fuel additives.

If Fault Code 2777 is active along with Fault Code 1921, this indicates that a regeneration inhibit message has been received by the engine ECM and that active regeneration of the aftertreatment diesel particulate filter was not permitted. Confirm that OEM settings for the aftertreatment permit switch are configured correctly. Use INSITE™ electronic service tool to perform a stationary regeneration of the aftertreatment diesel particulate filter.

The aftertreatment diesel particulate filter soot loading can be classified into four different stages. As the soot load increases, the aftertreatment lamp and the Cummins® CHECK ENGINE (Amber) or STOP ENGINE (Red) lamp will operate according to the table below. The stationary regeneration procedure can be used to clear the soot from the aftertreatment diesel particulate filter in stages 1, 2, and 3. At level 4, the aftertreatment diesel particulate filter is completely plugged and must be inspected and cleaned; or replaced, if the aftertreatment diesel particulate filter does not meet the inspection criteria. In adequate exhaust temperatures entering the aftertreatment system can be a cause of high soot loads in the aftertreatment diesel particulate filter. The duty cycle of the application may need to be increased in order to prevent excessive soot from accumulating in the filter.

Soot Level Stage | Cummins® Fault Code | Aftertreatment Lamp Status | Cummins® Lamp Status | Service Procedure | Engine Protection Strategy
1 | 2639 | Solid | Off | Perform stationary regeneration procedure | No engine protection derate
2 | 2639 | Flashing | Off | Perform stationary regeneration procedure | Engine protection derate
3 | 1921 | Flashing | Amber | Perform stationary regeneration procedure | Engine protection derate
4 | 1922 | Off | Red | Inspect and clean or replace the aftertreatment diesel particulate filter | Severe engine protection derate
Refer to Troubleshooting Fault Code t05-1921


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 1922

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1922 PID: S324 SPN: 3251 FMI: 0/0 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid but Above Normal Operational Range - Most Severe Level. The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | The stop engine light will illuminate. Severe engine derate.
ISX and ISM - Aftertreatment System

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code can be triggered if the application is not operating at a duty cycle that is high enough to actively regenerate the aftertreatment diesel particulate filter. This fault code indicates that the exhaust temperatures exiting the turbocharger are not high enough to actively regenerate the soot that is trapped in the aftertreatment diesel particulate filter. It can be necessary to increase the duty cycle of the application in order to prevent plugging of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

This fault code indicates that the soot load inside the aftertreatment diesel particulate filter has reached the maximum level: soot level stage 4.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the red STOP ENGINE light immediately after the diagnostic runs and fails.
  • Active and stationary (parked) regeneration of the diesel particulate filter will be disabled.
  • A severe torque derate will be applied to the output of the engine (Note: There is no derate in emergency vehicle calibrations).

Conditions for Clearing the Fault Code

  • Clean or replace the aftertreatment diesel particulate filter.
  • Use INSITE™ electronic service tool to perform the Diesel Particulate Filter Reset procedure found under the Aftertreatment Maintenance section of Advanced ECM Data.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration test found in the ECM Diagnostics Test.

The ECM will turn off the red STOP ENGINE light immediately after the soot load in the aftertreatment diesel particulate filter has dropped below the most severe level.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code indicates that the soot load inside the aftertreatment diesel particulate filter has reached the maximum level, soot level stage 4. Regeneration of the aftertreatment diesel particulate filter at this stage is not possible. The aftertreatment diesel particulate filter must be inspected. If it meets the inspection criteria, it can be cleaned using an SPX air pulse cleaning machine (or equivalent machine). If it does not meet the inspection criteria, it must be replaced.

Possible causes of this fault code include:

  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment diesel particulate filter.
  • Possible base engine damage that causes excessive black soot to be generated.

The aftertreatment diesel particulate filter soot loading can be classified into four different stages. As the soot load increases, the aftertreatment diesel particulate filter lamp and the Cummins® CHECK ENGINE (Amber) or STOP ENGINE (Red) lamp will operate according to the table below. Inadequate exhaust temperatures entering the aftertreatment system can be a cause of high soot loads in the aftertreatment diesel particulate filter. The duty cycle of the application may need to be increased in order to prevent excessive soot from accumulating in the filter.

Soot Level Stage | Cummins® Fault Code | Aftertreatment Diesel Particulate Filter Lamp Status | Cummins® Lamp Status | Service Procedure | Engine Protection Strategy
1 | 2639 | Solid | Off | Perform stationary regeneration procedure | No engine protection derate
2 | 2639 | Flashing | Off | Perform stationary regeneration procedure | Mild engine torque derate
3 | 1921 | Flashing | Amber | Perform stationary regeneration procedure | Moderate engine torque and engine speed derate
4 | 1922 | Off | Red | Inspect and clean or replace aftertreatment diesel particulate filter | Severe engine torque and engine speed derate
Refer to Troubleshooting Fault Code t05-1922


Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 1923

Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1923 PID: S334 SPN: 3482 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the aftertreatment fuel shutoff valve circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX - Aftertreatment Fuel Shutoff Valve 1 Circuit
ISM - Aftertreatment Fuel Shutoff Valve 1 Circuit

Circuit Description

The aftertreatment fuel shutoff valve is used to disable the fuel supply to the aftertreatment system.

Component Location

The aftertreatment fuel shutoff valve sensor is located in the aftertreatment shutoff valve assembly. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs within the first 30 seconds of the engine starting and prior to active regeneration of the diesel particulate filter.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit pulse width modulated (PWM) signal is detected to be at system voltage when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The fault code will clear within 30 seconds of starting the engine or prior to an active regeneration event of the diesel particulate filter.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or shutoff valve.
  • Fuel shutoff valve signal wire shorted to a voltage source in the harness.
  • A damaged aftertreatment fuel shutoff valve.
Refer to Troubleshooting Fault Code t05-1923


Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1924

Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1924 PID: S334 SPN: 3482 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment fuel shutoff valve circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX - Aftertreatment Fuel Shutoff Valve 1 Circuit
ISM - Aftertreatment Fuel Shutoff Valve 1 Circuit

Circuit Description

The aftertreatment fuel shutoff valve is used to disable the fuel supply to the aftertreatment system.

Component Location

The aftertreatment fuel shutoff valve sensor is located in the aftertreatment shutoff valve assembly. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs within the first 30 seconds of the engine starting and prior to active regeneration of the diesel particulate filter.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit pulse width modulated (PWM) signal is detected to be 0 volts when the PWM voltage is turned on.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The fault code will clear within 30 seconds of starting the engine or prior to an active regeneration event of the diesel particulate filter.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or shutoff valve.
  • A shorted aftertreatment fuel shutoff valve.
Refer to Troubleshooting Fault Code t05-1924


Fault Code Path Selection

FAULT CODE 16-fc1925
Fault Code Path Selection

Is the engine an ISM? | Go to 16-fc1925ism
Is the engine an ISX? | Go to 16-fc1925isx

Last Modified: 30-Jan-2009


Aftertreatment 1 Fuel Pressure Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1926

Aftertreatment 1 Fuel Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1926 PID: None SPN: 3480 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Fuel Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the aftertreatment fuel pressure signal is not changing with engine operating conditions. | None on performance.
ISX - Aftertreatment 1 Fuel Pressure Sensor Circuit
ISM - Aftertreatment 1 Fuel Pressure Sensor Circuit

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The electronic control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel pressure sensor is located in the aftertreatment shutoff valve assembly. Use this procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs within the first minute after the engine is started and prior to active regeneration of the aftertreatment particulate filter.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment fuel pressure sensor is reading an erratic value, or the aftertreatment fuel pressure reading is not changing with the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A calculated value of aftertreatment fuel pressure is used for aftertreatment operation.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Within the first minute after starting the engine, an aftertreatment pressure diagnostic cycles the aftertreatment fuel shutoff valve and aftertreatment fuel injector to check for leaks and proper operation. One of the initial checks opens the secondary aftertreatment fuel shutoff valve and opens the aftertreatment fuel injector. This relieves all of the pressure in the aftertreatment fuel line. At this check point, the aftertreatment fuel pressure sensor should read ambient air pressure. If the sensor reading does not read ambient pressure within the sensor tolerance, this fault code will be logged.

Possible causes of this fault code include:

  • A malfunctioning in-range aftertreatment fuel pressure sensor
  • A stuck closed secondary aftertreatment fuel shutoff valve
  • A plugged aftertreatment fuel drain line
  • A plugged aftertreatment fuel supply line
  • A plugged fuel filter
  • High fuel return restriction.
Refer to Troubleshooting Fault Code t05-1926


Aftertreatment 1 Fuel Pressure Sensor - Voltage Above Normal, or Shorted to High Source

FAULT CODE 1927

Aftertreatment 1 Fuel Pressure Sensor - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1927 PID: None SPN: 3480 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Fuel Pressure Sensor - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the aftertreatment fuel pressure sensor circuit. | None on performance.
ISX - Aftertreatment 1 Fuel Pressure Sensor Circuit
ISM - Aftertreatment 1 Fuel Pressure Sensor Circuit

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The electronic control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel pressure sensor is located in the aftertreatment shutoff valve assembly. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment fuel pressure signal voltage is more than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A calculated value of aftertreatment fuel pressure is used for aftertreatment operation.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connector, sensor.
  • Signal wire shorted to sensor supply or battery voltage.
  • A shorted sensor.
Refer to Troubleshooting Fault Code t05-1927


Aftertreatment 1 Fuel Pressure Sensor - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1928

Aftertreatment 1 Fuel Pressure Sensor - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1928 PID: None SPN: 3480 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Fuel Pressure Sensor - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment fuel pressure sensor circuit. | None on performance.
ISX - Aftertreatment 1 Fuel Pressure Sensor Circuit
ISM - Aftertreatment 1 Fuel Pressure Sensor Circuit

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The electronic control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel pressure sensor is located in the aftertreatment shutoff valve assembly. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment fuel pressure signal voltage is less than 0.2-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A calculated value of aftertreatment fuel pressure is used for aftertreatment operation.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connector, sensor.
  • Signal wire shorted to ground.
  • A shorted sensor.
Refer to Troubleshooting Fault Code t05-1928


Aftertreatment Fuel Injection System - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1932

Aftertreatment Fuel Injection System - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1932 PID: SPN: 3556 FMI: 2 LAMP: Amber SRT: | Aftertreatment Fuel Injection System - Data Erratic, Intermittent, or Incorrect. An error has been detected in either the aftertreatment fuel injector or the aftertreatment fuel shutoff valve system. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system, as well as a damaged aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started and prior to active regeneration of the aftertreatment system, a diagnostic test is performed on the system. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold. The aftertreatment shutoff valve is located on the same side of the manifold as the aftertreatment pressure sensor, while the aftertreatment fuel drain valve is located by itself, on the other side of the manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs during the first minutes of engine operation and before the aftertreatment system begins injecting fuel into the exhaust system for active regeneration of the aftertreatment system.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects system damage in the aftertreatment fuel system.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment particulate trap will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19.

Possible causes of this fault code include:

  • Stuck open or closed aftertreatment fuel shutoff valve or aftertreatment fuel drain valve
  • Internal or external leak in the aftertreatment fuel shutoff valve or fuel drain valve
  • Internal or external leak in the aftertreatment fuel injector
  • Loose fittings in the aftertreatment fuel system
  • Fuel leaks in the aftertreatment fuel system.

In order to correctly troubleshoot the aftertreatment fuel system, the following INSITE™ electronic service tool ECM tests must be used. These ECM tests command the aftertreatment fuel injector, aftertreatment fuel shutoff valve, and the aftertreatment fuel drain valve open or closed. The chart below shows how each test operates. It is important to note that the override test stops after 60 seconds, when the "STOP" button is pressed, or when the keyswitch is turned off.

 | Shutoff Valve | Injector | Drain Valve
Aftertreatment Injector Leak Test | OPEN | CLOSED | CLOSED
Aftertreatment Shutoff Valve Test | CLOSED | CLOSED | OPEN
Refer to Troubleshooting Fault Code t05-1932


ECU Power Output Supply Voltage 2 - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 1933

ECU Power Output Supply Voltage 2 - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1933 PID: None SPN: 3598 FMI: 0/16 LAMP: Amber SRT: | ECU Power Output Supply Voltage 2 - Data Valid but Above Normal Operational Range - Moderately Severe Level. High battery voltage detected by the EGR valve. | EGR valve actuation will be disabled.
ISX - EGR Valve Circuit
ISM - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 datalink. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the J1939 datalink.

The EGR valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor is not used to close the EGR valve. The pin retracts and a spring is used to close the EGR valve.

Component Location

The EGR valve location can vary depending on engine application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The EGR valve detects that the power supply voltage to the EGR valve is above 18-VDC for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve actuation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable EGR valve operation immediately after the power supply voltage to the EGR valve drops below 18-VDC.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible cause of this fault code include:

  • Faulty alternator or regulator that is overcharging the system.
  • Batteries connected in series instead of parallel.
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code t05-1933


ECU Power Output Supply Voltage 2 - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 1934

ECU Power Output Supply Voltage 2 - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1934 PID: S211 SPN: 3598 FMI: 1/18 LAMP: Amber SRT: | ECU Power Output Supply Voltage 2 - Data Valid but Below Normal Operational Range - Moderately Severe Level. Low battery voltage detected by the EGR valve. | Low voltage information fault code only.
ISX - EGR Valve Circuit
ISM - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 datalink. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the J1939 datalink.

The EGR valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor is not used to close the EGR valve. The pin retracts and a spring is used to close the EGR valve.

Component Location

The EGR valve location can vary depending on engine application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The EGR valve detects that the power supply voltage to the EGR valve is less than 8-VDC for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve actuation will continue.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable EGR valve operation immediately after the power supply voltage to the EGR valve is above 8-VDC.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other devices. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications.
Refer to Troubleshooting Fault Code t05-1934


EGR Actuator Driver Circuit - Root Cause Not Known

FAULT CODE 1935

EGR Actuator Driver Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1935 PID: S146 SPN: 2791 FMI: 11 LAMP: Amber SRT: | EGR Actuator Driver Circuit - Root Cause Not Known. Intermittent communication between the smart EGR valve controller and the ECM has been detected. | The EGR valve will hold the position of the last valid J1939 message.
ISX - EGR Valve Circuit
ISM - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 datalink. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the J1939 datalink.

The EGR valve is opened by a motor located on top of the EGR valve. A pin is extended from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor is not used to close the EGR valve. The pin retracts and a spring is used to close the EGR valve.

Component Location

The EGR valve location can vary depending on engine application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The EGR valve does not receive a valid J1939 message from the primary engine ECM for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve will hold the position of the last valid J1939 message.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable EGR valve operation immediately after a valid J1939 message is received by the EGR valve.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the EGR valve controller did not receive valid J1939 commands from the primary engine ECM. Intermittent J1939 datalink connections or interference on the J1939 network are possible causes of this fault code. Also check for intermittent power supply and ground connections to the EGR valve controller.

Refer to Troubleshooting Fault Code t05-1935


ECU Power Output Supply Voltage 1 - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 1938

ECU Power Output Supply Voltage 1 - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1938 PID: S212 SPN: 3597 FMI: 1/18 LAMP: Amber SRT: | ECU Power Output Supply Voltage 1 - Data Valid but Below Normal Operational Range - Moderately Severe Level. Low battery voltage detected by the VGT actuator. | None on performance.
ISX - VGT Actuator Circuit
ISM - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 datalink from the primary engine ECM. The VGT actuator performs its own diagnostics and reports failures back to the primary engine electronic control module (ECM) using the J1939 datalink.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fault code is set when the voltage supplied to the VGT actuator drops below 10-VDC for 10 seconds and the engine speed must be 0 rpm or above 500 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The VGT actuation will continue until battery voltage drops low enough that VGT actuation can not continue.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the voltage to the VGT actuator is greater than 10-VDC and the engine speed is 0 or greater than 500 rpm.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the voltage to the VGT actuator drops below 10-VDC. The VGT will still continue to respond to commands from the primary engine ECM.

Refer to Troubleshooting Fault Code t05-1938


Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1942

Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1942 PID: P101 SPN: 101 FMI: 2 LAMP: Amber SRT: | Crankcase Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the crankcase pressure signal is not changing with engine operating conditions. | None on performance.
ISX - Crankcase Pressure Sensor
ISM - Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The electronic control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the crankcase filter assembly. The crankcase filter is located on the fuel system side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

The first part of this diagnostic runs at initial key-on and the second part runs when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure sensor is reading an erratic value at key-on or the crankcase pressure reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Disconnected crankcase breather hose between the engine outlet and crankcase filter assembly
  • Resistance in the wiring harness
  • A damaged in-range pressure sensor.
Refer to Troubleshooting Fault Code t05-1942


Ambient Air Density - Data Valid but Below Normal Operational Range - Least Severe Level

FAULT CODE 1943

Ambient Air Density - Data Valid but Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1943 PID: SPN: 3555 FMI: 1/17 LAMP: None SRT: | Ambient Air Density - Data Valid but Below Normal Operational Range - Least Severe Level. Engine torque has been reduced because the vehicle was operating at a high altitude condition. | Possible engine derate.
ISX - Barometric Pressure Circuit
ISM - Barometric Pressure Circuit

Circuit Description

The ambient air pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes as the engine's elevation changes. The ambient air pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 volt supply to the ambient air pressure sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The ambient air pressure sensor provides a signal to the ECM on the ambient air pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the ambient air pressure reading is high than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Engine torque output will be limited due to the engine operating at high altitude conditions.

Conditions for Clearing the Fault Code

The ECM will return full torque to the engine and the fault code will go inactive when the vehicle is being operated within the normal altitude conditions.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19. This procedure is found in in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

When the engine has been operated in a high altitude location, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating in the high altitude location to protect the turbocharger and engine from excessively high exhaust temperatures. The derate limits the torque output of the engine to keep the temperatures below the maximum temperature limits.

Note: This fault code will most likely not be active with no load in the shop. The engine must be under the same operating conditions (altitude and temperature) that were being experienced when the fault code originally logged.

Refer to Troubleshooting Fault Code t05-1943


EGR Valve Control Circuit Calculated Over Temperature - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 1961

EGR Valve Control Circuit Calculated Over Temperature - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1961 PID: S146 SPN: 2791 FMI: 0/15 LAMP: Amber SRT: | EGR Valve Control Circuit Calculated Over Temperature - Data Valid but Above Normal Operational Range - Least Severe Level. The EGR valve has detected a high temperature condition. | EGR valve operation will be disabled.
ISX - EGR Actuator Circuit
ISM - VGT Actuator

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 datalink. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the J1939 datalink.

The EGR valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary depending on the engine application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is turned on.

Conditions for Setting the Fault Codes

This fault code logs when the internal temperature of the EGR valve motor is above 135°C [275°F].

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The fault code is set inactive when the internal temperature of the EGR valve motor is below 125°C [257°F].

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is for information only. No action is taken when this fault code is logged.

Refer to Troubleshooting Fault Code t05-1961


VGT Actuator Driver Over Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 1962

VGT Actuator Driver Over Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1962 PID: S027 SPN: 641 FMI: 0/15 LAMP: Amber SRT: | VGT Actuator Driver Over Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level. High internal VGT actuator temperature has been detected. | None on performance.
ISX - VGT Actuator Circuit
ISM - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 datalink from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports failures back to the primary engine ECM using the J1939 datalink.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is turned on.

Conditions for Setting the Fault Codes

The fault code will log when the internal temperature of the VGT actuator exceeds 125°C [257°F] continuously for 30 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the internal actuator temperature drops below 125°C [257°F].

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The fault code will log when the internal temperature of the VGT actuator exceeds 125°C [257°F].

This fault code will be inactive when the vehicle is in the shop because the VGT actuator temperature has cooled down.

Troubleshoot multiple inactive counts of this fault code as an active fault code.

Also check for exhaust leaks blowing on the VGT actuator. Repair any exhaust leaks.

Refer to Troubleshooting Fault Code t05-1962


Fault Code Path Selection

FAULT CODE 16-fc1963
Fault Code Path Selection

Is the engine an ISM? | Go to 16-fc1963ism
Is the engine an ISX? | Go to 16-fc1963isx

Last Modified: 30-Jan-2009


Aftertreatment Exhaust Gas Temperature 1 - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 1966

Aftertreatment Exhaust Gas Temperature 1 - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1966 PID: 326 SPN: 3241 FMI: 0 LAMP: Red SRT: | Aftertreatment Exhaust Gas Temperature 1 - Data Valid but Above Normal Operational Range - Most Severe Level. Engine exhaust gas temperatures entering the aftertreatment system are above the engine protection limits. | The engine will shut down.
ISX and ISM - Exhaust Gas Temperature Sensors

Circuit Description

The exhaust gas temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The exhaust gas temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The exhaust gas temperature sensors are located in the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust gas temperatures in the aftertreatment system are above a calibratible value for a calibratible amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will shut down if the high temperature condition exists for a calibratible amount of time.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE lamp and the fault code will be set to inactive when the temperatures in the aftertreatment system drop below a calibratible temperature value. The fault code will also be set inactive following a key cycle or if the high temperature condition no longer exists.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the aftertreatment injector is turned off, but the ECM has detected a high temperature condition in the aftertreatment system. This indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the diesel oxidation catalyst and/or diesel particulate filter.

An intermittent fault code condition may be caused by the aftertreatment sensor and related wiring being shorted or damaged (melted), due to component interference. If an intermittent fault code condition exists, inspection of the aftertreatment sensors and wiring for any possible damage is required. Use the appropriate securing methods to make sure the sensor and wiring are not interfering or contacting other components.

Possible causes of this fault code include:

  • A damaged fuel injector causing unburned fuel to enter the exhaust system
  • Aftertreatment diesel particulate filter inlet temperature sensor failed in-range
  • Excessive engine oil being introduced into the exhaust system from the engine or turbocharger
  • Aftertreatment temperature sensor has shorted and/or the sensor wiring or connector has been damaged.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle for potential malfunction and inspect for reuse. Refer to Procedure 014-013 in Section 14 of the Signature&trade;, ISX, and QSX15 Service Manual, Bulletin 3666239.

Refer to Troubleshooting Fault Code t05-1966


Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 1968

Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1968 PID: S327 SPN: 3249 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Moderately Severe Level. The aftertreatment diesel particulate filter inlet temperature sensor reading has exceeded the maximum temperature limit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel particulate filter inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the aftertreatment diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter inlet temperature sensor reading exceeds 649°C [1200°F] for 5 seconds and then returns below 550°C [1021°F]. This must occur five times before the fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code will be set to inactive when the keyswitch is cycled.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

An intermittent fault code condition may be caused by the aftertreatment sensor and related wiring being shorted or damaged (melted), due to component interference. If an intermittent fault code condition exists, inspection of the aftertreatment sensors and wiring for any possible damage is required. Use the appropriate securing methods to make sure the sensor and wiring are not interfering or contacting other components.

Possible causes of this fault code include:

  • A damaged fuel injector causing unburned fuel to enter the exhaust system
  • A damaged aftertreatment fuel injector
  • Aftertreatment diesel particulate filter inlet temperature sensor failed in-range
  • Excessive engine oil being introduced into the exhaust system from the engine or turbocharger
  • Aftertreatment temperature sensor has shorted and/or the sensor wiring or connector has been damaged.
Refer to Troubleshooting Fault Code t05-1968


Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 1969

Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1969 PID: S327 SPN: 3249 FMI: 0/0 LAMP: Red SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operational Range - Most Severe Level. The aftertreatment diesel particulate filter inlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment diesel oxidation catalyst inlet temperature sensor is located in the inlet section of the aftertreatment system.

The aftertreatment diesel particulate filter inlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst and before the aftertreatment diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter inlet temperature reading is greater than 800°C [1472°F], or the temperature differential across the diesel oxidation catalyst is greater than 500°C [932°F].

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.
  • Possible engine shutdown if the engine protection shutdown feature is enabled.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light and the fault code will be set to inactive when the keyswitch is cycled.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19.

An intermittent fault code condition may be caused by the aftertreatmetn sensor and related wiring being shorted or damaged (melted), due to component interference. If an intermittent fault code condition exists, inspection of the aftertreatment sensors and wiring for any possible damage is required. Use the appropriate securing methods to make sure the sensor and wiring are not interfering or contacting other components.

Possible causes of this fault code include:

  • A damaged fuel injector causing unburned fuel to enter the exhaust system
  • A damaged aftertreatment fuel injector
  • Aftertreatment diesel particulate filter inlet temperature sensor failed in-range
  • Excessive engine oil being introduced into the exhaust system from the engine or turbocharger
  • Aftertreatment temperature sensor has shorted and/or the sensor wiring or connector has been damaged.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle for potential malfunction and inspect for reuse. Use the procedure found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code t05-1969


Exhaust Gas Temperature 3 - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 1972

Exhaust Gas Temperature 3 - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1972 PID: S328 SPN: 3245 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature 3 - Data Valid but Above Normal Operational Range - Moderately Severe Level. The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum temperature limit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage (low temperature). When the exhaust gas temperature is high, the thermistor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage (high temperature).

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter outlet temperature sensor reading exceeds 675°C [1247°F] for 5 seconds and then returns below 575°C [1067°F]. This needs to occur five times before the fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code will be set to inactive when the keyswitch is cycled.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

An intermittent fault code condition may be caused by the aftertreatment sensor and related wiring being shorted or damaged (melted), due to component interference. If an intermittent fault code condition exists, inspection of the aftertreatment sensors and wiring for any possible damage is required. Use the appropriate securing methods to make sure the sensor and wiring are not interfering or contacting other components.

Possible causes of this fault code include:

  • A damaged fuel injector causing unburned fuel to enter the exhaust system
  • A damaged aftertreatment fuel injector
  • Aftertreatment diesel particulate filter outlet temperature sensor failed in-range
  • A face plugged diesel oxidation catalyst
  • Excessive engine oil being introduced into the exhaust system from the engine or turbocharger
  • Aftertreatment temperature sensor has shorted and/or the sensor wiring or connector has been damaged.
Refer to Troubleshooting Fault Code t05-1972


Exhaust Gas Temperature 3 - Data Valid But Above Normal Operational Range - Most Severe Level

FAULT CODE 1973

Exhaust Gas Temperature 3 - Data Valid But Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1973 PID: S328 SPN: 3245 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature 3 - Data Valid but Above Normal Operational Range - Most Severe Level. The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment temperature sensors are used by the electronic control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust gas temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment diesel particulate filter outlet temperature reading is greater than 800°C [1472°F] for 15 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.
  • Possible engine shutdown if the engine protection shutdown feature is enabled.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light and the fault code will be set to inactive when the keyswitch is cycled.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

An intermittent fault code condition may be caused by the aftertreatment sensor and related wiring being shorted or damaged (melted), due to component interference. If an intermittent fault code condition exists, inspection of the aftertreatment sensors and wiring for any possible damage is required. Use the appropriate securing methods to make sure the sensor and wiring are not interfering or contacting other components.

Possible causes of this fault code include:

  • A damaged fuel injector causing unburned fuel to enter the exhaust system
  • A damaged aftertreatment fuel injector
  • Aftertreatment diesel particulate filter outlet temperature sensor failed in-range
  • Excessive engine oil being introduced into the exhaust system from the engine or turbocharger
  • Aftertreatment temperature sensor has shorted and/or the sensor wiring or connector has been damaged.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle for potential malfunction and inspect for reuse. Use the procedure found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code 1973.

Last Modified: 03-Aug-2010


Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1974

Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1974 PID: P101 SPN: 101 FMI: 0/15 LAMP: Maintenance SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The crankcase breather system may requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected the crankcase pressure in the breather tube was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool “Data Monitor/Logger” feature to monitor "Crankcase Pressure" with the engine running at idle. If the crankcase pressure reading is below 7.0 in H20, the repair has been validated.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the malfunction indicator lamp for on-board diagnostics applications.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

If this fault code is active, the crankcase breather system may need to be inspected.

Refer to Troubleshooting Fault Code 1974.

Last Modified: 01-Oct-2015


Aftertreatment Fuel Injector 1 Circuit - Current Below Normal, or Open Circuit

FAULT CODE 1977

Aftertreatment Fuel Injector 1 Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1977 PID: SPN: 3556 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Fuel Injector 1 Circuit - Current Below Normal, or Open Circuit. High resistance, short circuit, or open circuit detected on the aftertreatment fuel injector circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX - Aftertreatment Fuel Injector
ISM - Aftertreatment Fuel Injector

Circuit Description

The aftertreatment fuel injector is used to inject fuel into the exhaust system. Diesel fuel is sprayed into the exhaust system when the aftertreatment diesel particulate filter needs to be regenerated. The hydrocarbons in the diesel fuel are converted into heat in the aftertreatment diesel oxidation catalyst. The heat produced by the aftertreatment catalyst is then used to actively regenerate the aftertreatment diesel particulate filter, converting trapped soot into ash.

The aftertreatment fuel injector is electronically controlled by the engine electronic control module (ECM) through a pulse width modulated (PWM) signal. The amount of fuel injected is determined by how long the PWM signal to the injector is on.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm and within the first minute of the engine starting.

Conditions for Setting the Fault Codes

The fault code will set within 30 seconds of starting the engine or prior to an active regeneration event of the diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Current to the aftertreatment particulate trap will be disabled.
  • Active aftertreatment particulate trap regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The fault code will clear within 30 seconds of starting the engine or prior to an active regeneration event of the diesel particulate filter.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • An open circuit in the supply or return wire in the engine harness.
  • An open circuit in the aftertreatment fuel injector solenoid.
  • A short circuit to ground in the engine harness.
  • A short circuit to voltage source in the engine harness.
  • High resistance in the aftertreatment fuel injector solenoid.
  • An extremely low resistance in the aftertreatment fuel injector solenoid (injector shorted internally but not to ground).
  • A damaged ECM.
Refer to Troubleshooting Fault Code t05-1977


Fault Code Path Selection

FAULT CODE 16-fc1981
Fault Code Path Selection

Is the engine a CPL 3774 and 3775? | Go to 16-fc1981cpl_3774_3775
Is the engine a Non CPL 3774 and 3775? | Go to 16-fc1981non_cpl_3774_3775

Last Modified: 07-Mar-2014


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: P190 SPN: 190 FMI: 0/16 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine speed has exceeded a critical limit | Engine will be shutdown.
ISM - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volts direct current (VDC) supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft tone wheel passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

Both engine position sensors are located on the back side of the front gear housing above the fuel pump drive. The primary engine position sensor (Number 1) is located above the backup engine position sensor (Number 2). Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Gain adjust setting is not set correctly
  • Erroneous generator speed/load governing bias signal from the generator set
  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-1992.

Last Modified: 07-Jan-2015


Aftertreatment Diesel Particulate Filter Missing - Condition Exists

FAULT CODE 1993

Aftertreatment Diesel Particulate Filter Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1993 PID: SPN: 3064 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Missing - Condition Exists. The aftertreatment diesel particulate filter in the exhaust system is not present. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Differential Pressure Sensor

Circuit Description

The engine aftertreatment system monitors for the presence of the aftertreatment diesel particulate filter. This diagnostic checks to make sure the aftertreatment diesel particulate filter is present and functioning correctly.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

This diagnostic monitors the aftertreatment diesel particulate filter differential pressure sensor. When the differential pressure is below a minimum value and the exhaust flow rate is above a minimum flow rate, this fault code is set.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The conditions for clearing this fault code require that the exhaust flow be above a minimum value before the fault code will become inactive. The exhaust volumetric flowrate as monitored in INSITE™ electronic service tool must be above 14.1 ft3/sec for a consecutive 30 seconds for the fault code to become inactive. It will be necessary to elevate the exhaust flow above this minimum flowrate value by taking the engine to maximum governed engine speed.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • The aftertreatment diesel particulate filter has been removed from the vehicle.
  • The aftertreatment diesel particulate filter is cracked or broken.
  • The aftertreatment diesel particulate filter differential pressure sensor tubes are installed incorrectly, broken, loose, or have been tampered with.
  • The aftertreatment diesel particulate filter differential pressure sensor tubes are installed backwards.
Refer to Troubleshooting Fault Code t05-1993


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2182

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2182 PID: S079 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal, or Shorted to High Source. High voltage or an open circuit detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1, 2, and 3 can be on all the time or can not be activated.
ISM - Engine Brake Solenoid Number 1 Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinders 1, 2, and 3 by sending a signal on engine brake solenoid number 1 signal circuit. The ECM will only command the brakes on under certain operating conditions.

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM. The engine harness connects to the internal actuator harness that passes through the rocker lever housing on the front of the engine. The engine brake harness is connected to the internal actuator harness through a 3-pin breakout connector located between cylinders 2 and 3.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The engine brake solenoid pulse width modulated (PWM) signal is detected to be greater than 0 VDC when the pulse width modulated (PWM) signal to the engine brakes are turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illumines the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid 1 will not be energized.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleaned using the INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Signal circuit shorted to voltage source in the engine harness
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-2182


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: S079 SPN: 1072 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1, 2, and 3 can not be activated.
ISM - Engine Brake Solenoid Number 1 Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinders 1, 2, and 3 by sending a signal on engine brake solenoid number 1 signal circuit. The ECM will only command the brakes on under certain operating conditions.

Component Location

The engine brake solenoids are located under the rocker lever cover. The engine brake solenoids are controlled through the engine harness from the ECM. The engine harness passes through the rocker lever housing on the front of the engine and is connected to the engine brake solenoids through a 3-pin breakout connector located between cylinders 2 and 3.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The engine brake solenoid pulse width modulated (PWM) signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid 1 will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes for this fault include:

  • Short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2183


Sensor Supply 4 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected at +5 volt sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
ISX and ISM - Accelerator Pedal or Lever Position Sensor Supply

Circuit Description

Sensor supply 4 of the electronic control module (ECM) provides a 5 volt supply to the accelerator pedal position sensor. The accelerator position sensor is a potentiometer attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal assembly is located in the cab. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 4 signal voltage is more than 5.25 VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than +5 VDC.

Refer to Troubleshooting Fault Code t05-2185


Sensor Supply 4 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the +5 volt sensor supply circuit to the accelerator pedal position sensor. | Engine will only die.
ISX and ISM - Accelerator Pedal Position Sensor Supply Voltage Circuit

Circuit Description

Sensor supply 4 of the electronic control module (ECM) provides a 5 volt supply to the accelerator pedal position sensor. The accelerator position sensor is a potentiometer attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the ECM as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal is located in the cab. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 4 signal voltage is less than 4.75 VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine will only die.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code t05-2186


Auxiliary Equipment Sensor Input 3 Engine Protection Critical — Special Instructions

FAULT CODE 2195

Auxiliary Equipment Sensor Input 3 Engine Protection Critical — Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2195 PID: S51 SPN: 703 FMI: 14 LAMP: Red SRT: | Auxiliary Equipment Sensor Input 3 Engine Protection Critical — Special Instructions. The emergency door of the vehicle has been detected open. | Engine can possibly shut down.
ISX and ISM Aftertreatment System

Circuit Description

Some vehicle applications can possibly have an interlock switch indicating the position of an emergency exit door.

Component Location

The emergency door location may vary depending on the vehicle application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is triggered when the vehicle emergency door is opened.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails. The engine will be shut down.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This diagnostic will operate differently for every vehicle application. This fault code usually indicates that the vehicle emergency exit door has been opened.

Refer to Troubleshooting Fault Code t05-2195


VGT Actuator Driver Circuit - Root Cause Not Known

FAULT CODE 2198

VGT Actuator Driver Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2198 PID: S027 SPN: 641 FMI: 11/11 LAMP: Amber SRT: | VGT Actuator Driver Circuit - Root Cause Not Known. Intermittent communication between the smart VGT controller and the ECM has been detected. The VGT controller is not interpreting the J1939 message from the ECM correctly. | VGT actuation will be disabled.
ISX - VGT Actuator Driver Circuit
ISM - VGT Actuator Driver Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 datalink from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports failures back to the primary engine ECM using the J1939 datalink. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The VGT actuator does not receive a valid J1939 message from the ECM for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The VGT will move to the default open position.
  • The EGR valve will be closed.
  • Active regeneration of the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the VGT actuator receives a valid J1939 message from the ECM.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the VGT smart actuator did not receive a valid J1939 message from the primary engine ECM for 1 second. Intermittent J1939 datalink connections or interference on the J1939 network are possible causes of this fault code. Also check for intermittent power supply and ground connections to the VGT actuator.

The EGR valve is also on the J1939 network. Check for an active or high inactive counts of Fault Code 1893. If Fault Code 1893 is active, troubleshoot the J1939 datalink wiring harness.

Refer to Troubleshooting Fault Code t05-2198


Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2215

Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2215 PID: P094 SPN: 94 FMI: 1/18 LAMP: Amber SRT: | Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low fuel pressure has been detected by the ECM. | Engine may not start, emit white smoke, run rough, or lose power.
ISX - Fuel System Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel manifold of the integrated fuel system module (IFSM). The fuel delivery pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel manifold. The ECM will detect a low signal voltage at operating conditions, such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

The gear pump draws fuel from the fuel tank through a suction fuel filter and an anti-drainback valve. The gear pump develops between 1724 and 2620 kPa [250 and 380 psi] of fuel pressure. The fuel flows through a pressure fuel filter and fuel shutoff valve to the fueling and timing actuators and rail fuel pressure sensor.

Component Location

The rail fuel pressure sensor is located on the bottom front corner of the IFSM. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the fuel delivery pressure is lower than the minimum pressure level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine may not start, or the performance output of the engine could be limited, due to the low fuel pressure condition.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the appropriate Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

It is possible to swap the connections between the aftertreatment fuel pressure sensor and the fuel delivery pressure sensor. If this occurs, Fault Code 2215 will intermittently go active and the engine will run rough and will surge at low idle. If these symptoms are present, make sure the fuel pressure connections are connected properly.

The fuel pressure is monitored by the ECM. If the rail fuel pressure is lower than an acceptable level for given engine operating conditions, the fault code is logged.

NOTE: One possible cause for this fault code is a damaged or sticking anti-drainback valve, located in the fuel supply circuit, in the integrated fuel system module (IFSM) which is located directly above the fuel lift pump.

NOTE: Another possible cause for this fault code is a loose or missing hot start & stall orifice, located inside the bore above the rail fuel pressure Compuchek™ fitting, in the integrated fuel system module (IFSM) which is located directly above the fuel lift pump.

Refer to Troubleshooting Fault Code t05-2215.

Last Modified: 07-Oct-2011


Fuel Pump Delivery Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2216

Fuel Pump Delivery Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2216 PID: P094 SPN: 94 FMI: 0/16 LAMP: Amber SRT: | Fuel Pump Delivery Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. High fuel pressure detected at the fuel rail in the IFSM. | The engine may be derated.
ISX - Fuel System Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel manifold of the integrated fuel system module (IFSM). The fuel delivery pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel manifold. The ECM will detect a low signal voltage at operating conditions such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

The gear pump draws fuel from the fuel tank through a suction fuel filter and an anti-drainback valve. The gear pump develops between 1724 and 2620 kPa [250 and 380 psi] of fuel pressure. The fuel flows through a pressure fuel filter and fuel shutoff valve to the fueling and timing actuators and rail fuel pressure sensor.

Component Location

The rail fuel pressure sensor is located on the bottom front corner of the integrated fuel system module. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the fuel delivery pressure is higher than the recommended pressure level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Performance output of the engine could be limited due to the high fuel pressure condition.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The fuel pressure is monitored by the ECM. If the rail fuel pressure is higher than an acceptable range for engine operating conditions, the fault code is logged.

Refer to Troubleshooting Fault Code t05-2216


EGR Valve Position Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P027 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Position Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage has been detected at the EGR position sensor circuit. | EGR valve actuation will be disabled.
ISX - EGR Valve Circuit
ISM - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 datalink. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the J1939 datalink.

The EGR valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary depending on engine application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The EGR valve has detected an internal error in the internal EGR valve smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The diagnostic will clear at initial key-on if the failure condition no longer exits. The ECM will turn off the amber CHECK ENGINE light and enable the EGR valve operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the EGR valve has detected an internal error. All failure modes listed below are internal to the EGR valve.

Possible causes of this fault code include an internal position sensor error detected by the EGR valve motor.

Refer to Troubleshooting Fault Code t05-2272


Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2273

Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2273 PID: P411 SPN: 411 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the EGR differential pressure sensor circuit. | EGR valve actuation will be disabled.
ISX - EGR Differential Pressure Sensor Circuit
ISM - EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust gas pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure in the EGR crossover tube.

Component Location

The EGR differential pressure sensor is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR differential pressure signal voltage is greater than 4.8 VDC for more than 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the EGR differential pressure sensor is used.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor.
  • A signal wire shorted to sensor supply or battery voltage.
  • A failed EGR differential pressure sensor.
Refer to Troubleshooting Fault Code t05-2273


Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2274

Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2274 PID: P411 SPN: 411 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the EGR differential pressure sensor circuit. | EGR valve actuation will be disabled.
ISX - EGR Differential Pressure Sensor Circuit
ISM - EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust gas pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes based on the differential pressure in the EGR crossover tube.

Component Location

The EGR differential pressure sensor is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR differential pressure signal voltage is less than 0.26 VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the EGR differential pressure sensor is used.
  • The EGR valve will be closed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor.
  • A supply wire open or shorted to ground.
  • A malfunctioning EGR differential pressure sensor.
Refer to Troubleshooting Fault Code t05-2274


Turbocharger 1 Speed - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 2288

Turbocharger 1 Speed - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2288 PID: P103 SPN: 103 FMI: 0/15 LAMP: None SRT: | Turbocharger 1 Speed - Data Valid but Above Normal Operational Range - Least Severe Level. High turbocharger speed has been detected by the ECM. | Engine power derate to lower the turbocharger speed.
ISX - Turbocharger 1 Speed Circuit
ISM - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The ECM interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed is above the maximum calibratible limits.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM will reduce torque output of the engine to reduce turbocharger speeds.

Conditions for Clearing the Fault Code

The fault code will be set to inactive immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

When the engine has taken the necessary action to reduce the turbocharger speed, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating near the maximum turbocharger speed limits.

Refer to Troubleshooting Fault Code t05-2288


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S018 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. Error detected on the front fueling actuator circuit. | Cylinders in front bank will not receive fuel. Engine will run rough with low power.
ISX - Front Fueling Actuator Circuit

Circuit Description

The fueling actuators are commanded by the electronic control module (ECM) to control fuel metering. Each fueling actuator is connected to the ECM by a fueling actuator (+) and fueling actuator (-) wire. An electrical signal is sent to the fueling actuator from the ECM on the (+) wire and is returned to the ECM on the (-) wire. Each actuator is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front fueling actuator is located on the fuel control housing. It is the first actuator from the front of the engine. The fuel control housing is located on the intake side of the engine below the exhaust gas recirculation (EGR) mixer. RRefer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The pulse width modulated (PWM) signal to the actuator is found to be an open circuit, shorted to ground, shorted to a voltage source, or incorrect resistance in the actuator.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fueling to cylinders 1, 2, and 3 will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault are:

  • An open circuit in the engine harness, connectors, or actuator.
  • A short circuit to ground in the engine harness or actuator.
  • A short circuit to voltage source in the engine harness.
  • A low or high resistance in the actuator.
Refer to Troubleshooting Fault Code t05-2311


Timing Actuator Driver Circuit - Condition Exists

FAULT CODE 2312

Timing Actuator Driver Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2312 PID: S020 SPN: 635 FMI: 11/31 LAMP: Amber SRT: | Timing Actuator Driver Circuit - Condition Exists. Timing Actuator Number 1 Circuit Error. Error detected on the front timing actuator circuit. | Cylinders in front bank will not receive fuel. Engine will run rough with low power.
ISX - Timing Actuator Driver Circuit

Circuit Description

The timing actuators are commanded by the electronic control module (ECM) to control fuel timing. Each timing actuator is connected to the ECM by a timing actuator (+) and timing actuator (-) wire. An electrical signal is sent to the timing actuator from the ECM on the (+) wire and is returned to the ECM on the (-) wire. Each actuator is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front timing actuator is located on the fuel control housing. It is the second actuator from the front of the engine. The fuel control housing is located on the intake side of the engine below the exhaust gas recirculation (EGR) mixer. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The pulse width modulated (PWM) signal to the actuator is found to be an open circuit, shorted to ground, shorted to a voltage source, or incorrect resistance in the actuator.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fueling to cylinders 1, 2, and 3 will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault are:

  • An open circuit in the engine harness, connectors, or actuator.
  • A short circuit to ground in the engine harness or actuator.
  • A short circuit to voltage source in the engine harness.
  • Low or high resistance in the actuator.
Refer to Troubleshooting Fault Code t05-2312


Fuel Control Valve Solenoid Driver 2 Circuit - Condition Exists

FAULT CODE 2313

Fuel Control Valve Solenoid Driver 2 Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2313 PID: S083 SPN: 1244 FMI: 11/31 LAMP: Amber SRT: | Fuel Control Valve Solenoid Driver 2 Circuit - Condition Exists. Error detected on the rear fueling actuator circuit. | Cylinders in rear bank will not receive fuel. Engine will run rough with low power.
ISX - Rear Fueling Actuator Circuit

Circuit Description

The fueling actuators are commanded by the electronic control module (ECM) to control fuel metering. Each fueling actuator is connected to the ECM by a fueling actuator (+) and fueling actuator (-) wire. An electrical signal is sent to the fueling actuator from the ECM on the (+) wire and is returned to the ECM on the (-) wire. Each actuator is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear fueling actuator is located on the fuel control housing. It is the first actuator from the rear of the engine. The fuel control housing is located on the intake side of the engine below the exhaust gas recirculation (EGR) mixer. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The pulse width modulated (PWM) signal to the actuator is found to be an open circuit, shorted to ground, shorted to a voltage source, or incorrect resistance in the actuator.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fuel to cylinders 4, 5, and 6 will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault are:

  • An open circuit in the engine harness, connectors, or actuator
  • A short circuit to ground in the engine harness or actuator
  • A short circuit to voltage source in the engine harness
  • A low or high resistance in the actuator.
Refer to Troubleshooting Fault Code t05-2313


Engine Timing Actuator Driver 2 Circuit Error - Condition Exists

FAULT CODE 2314

Engine Timing Actuator Driver 2 Circuit Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2314 PID: S084 SPN: 1245 FMI: 11/31 LAMP: Amber SRT: | Engine Timing Actuator Driver 2 Circuit Error - Condition Exists. Error detected on the rear timing actuator circuit. | Cylinders in rear bank will not receive fuel. Engine will run rough with low power.
ISX - Rear Timing Actuator Circuit

Circuit Description

The timing actuators are commanded by the electronic control module (ECM) to control fuel timing. Each timing actuator is connected to the ECM by a timing actuator (+) and timing actuator (-) wire. An electrical signal is sent to the timing actuator from the ECM on the (+) wire and is returned to the ECM on the (-) wire. Each actuator is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear timing actuator is located on the fuel control housing. It is the second actuator from the rear of the engine. The fuel control housing is located on the intake side of the engine below the exhaust gas recirculation (EGR) mixer. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The pulse width modulated (PWM) signal to the actuator is found to be an open circuit, shorted to ground, shorted to a voltage source or incorrect resistance in the actuator.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fueling to cylinders 4, 5, and 6 will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault are:

  • An open circuit in the engine harness, connectors, or actuator
  • A short circuit to ground in the engine harness or actuator
  • A short circuit to voltage source in the engine harness
  • Low or high resistance in the actuator.
Refer to Troubleshooting Fault Code t05-2314


Exhaust Back Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2319

Exhaust Back Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2319 PID: SPN: 648 FMI: 1/18 LAMP: Amber SRT: | Exhaust Back Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low exhaust back pressure detected. | Possible reduced performance.
Exhaust Gas Pressure Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to manage engine function and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 600 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust back pressure is lower than a calibratible value during normal engine operation

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Fault Code 2319 was developed for the ISX CM871 E engine as a means to detect removal of the restrictor plate installed behind the turbocharger exhaust outlet that simulates DPF back pressure. Customers have been experiencing nuisance instances of Fault Code 2319. Consequently the diagnostic has been disabled in the latest ISX CM871 E calibrations.

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Refer to Troubleshooting Fault Code t05-2319.

Last Modified: 15-Jun-2012


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: None SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Crankshaft engine speed sensor intermittent synchronization. | Engine can exhibit misfire as control switches from the primary to the backup speed sensor. Engine power is reduced while the engine operates on the backup speed sensor.
ISX - Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position, based on the missing tooth on the speed indicator ring.

Component Location

The engine speed sensor is located on the side of the front gear housing on the intake side of the engine.Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will set the fault code inactive after the degraded signal from the crankshaft speed/position sensor is no longer present.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than 3 continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

A vehicle operator can notice an intermittent “misfire” if the injection events are interrupted while the ECM switches from control based on the primary and secondary speed sensors. Also, a vehicle operator can notice intermittent “low power” if a “glitch” in the primary speed sensor signal causes the engine to intermittently use the backup speed sensor for injection control.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key ON or if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

Failures that can cause this fault:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.
  • Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the primary engine speed sensor circuit.
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket.
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit.
  • Look for pin wear at the speed sensor.
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2321


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S064 SPN: 723 FMI: 2/2 LAMP: None SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. Camshaft engine speed sensor intermittent synchronization. | None on performance.
ISX - Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor is located below the intake side of the engine in the cylinder head to the right of the ECM. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E .

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will set the fault code inactive after the ECM detects a valid signal from the camshaft speed/position sensor.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp if the signal from the secondary speed sensor is not present or degraded for more than 3 continuous seconds. If over a period of time the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key ON or if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

Failures that can cause this fault:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.
  • Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the secondary engine speed sensor circuit.
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket.
  • Look for places where the engine harness has worn into a nearby component causing an intermittent short circuit.
  • Look for pin wear at the speed sensor.
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2322

Last Modified: 19-Oct-2011


Turbocharger 1 Speed - Abnormal Rate of Change

FAULT CODE 2345

Turbocharger 1 Speed - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2345 PID: P103 SPN: 103 FMI: 10/10 LAMP: Amber SRT: | Turbocharger 1 Speed - Abnormal Rate of Change. The turbocharger speed sensor has detected an erroneous speed value. | None on performance. The ECM uses an estimated turbocharger speed.
ISX - Turbocharger 1 Speed Circuit
ISM - Turbocharger 1 Speed Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft passes the speed sensor, a signal is generated. The electronic control module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is located in the center housing of the turbocharger. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the turbocharger speed has increased faster than physically achievable by the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will estimate turbocharger speed.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Use the following procedure in the appropriate Troubleshooting and Repair Manual for the engine being serviced.Refer to Procedure 019-032 in Section 19.

This fault becomes active if the engine is running and the turbocharger speed signal rapidly changes faster than the capabilities of the turbocharger. This fault code can be caused by an intermittent turbocharger speed sensor connection, incorrect turbocharger speed sensor air gap, or a faulty turbocharger speed sensor.

Refer to Troubleshooting Fault Code t05-2345


Turbocharger Turbine Intake Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2346

Turbocharger Turbine Intake Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2346 PID: SPN: 2789 FMI: 0/15 LAMP: None SRT: | Turbocharger Turbine Intake Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level. Turbocharger turbine intake temperature has exceeded the engine protection limit. | Fuel is limited in an attempt to decrease the temperature of the exhaust gas entering the turbocharger.
ISX and ISM - Electronic Control Module

Circuit Description

The exhaust gas temperature is calculated by the electronic control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger, and is also known as turbine intake temperature.

Note: Some original equipment manufacturers (OEMs) have pyrometer gauges mounted in their chassis. Pyrometers measure turbine outlet exhaust gas temperature leaving the turbocharger, so this value will not equal the value monitored with the exhaust gas temperature parameter with INSITE™ electronic service tool.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the calculated turbine intake temperature is greater than a calibratable value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the temperature threshold is exceeded.
  • Fuel is limited in an attempt to decrease the temperature of the exhaust gas entering the turbocharger.

Conditions for Clearing the Fault Code

The fault code will be set inactive immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is an information fault code, indicating that the engine has been derated for high turbine intake temperature (exhaust temperature). No troubleshooting is necessary for this fault code. It is only an indicator that the engine power was derated to limit the exhaust temperature.

If the condition continues to exist, Fault Code 2451 will become active.

If the condition continues to exist and Fault Code 2451 does not become active or does not show any inactive counts, a possible cause is a stuck in range turbocharger compressor inlet temperature sensor or a stuck in range exhaust gas pressure sensor.

Refer to Troubleshooting Fault Code t05-2346.

Last Modified: 07-Oct-2011


Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 2347

Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2347 PID: SPN: 2790 FMI: 0/15 LAMP: None SRT: | Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level. High turbocharger compressor outlet air temperature has been calculated by the electronic control module (ECM). | Fuel is limited in an attempt to decrease the calculated turbocharger compressor outlet air temperature.
ISX and ISM - Electronic Control Module

Circuit Description

The turbocharger compressor outlet air temperature is calculated by the ECM. Turbocharger compressor outlet air temperature is derived by the ECM, based on engine operating conditions such as turbocharger compressor inlet air temperature, barometric pressure, turbocharger speed, engine speed, intake manifold air temperature, and intake manifold pressure.

Component Location

There is not a physical turbocharger compressor outlet temperature sensor in the system. The turbocharger compressor outlet air temperature is a calculation of temperature of the air after it is compressed by the turbocharger compressor, but before exhaust gas recirculation (EGR) is mixed into the system and before it enters the charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the calculated turbocharger compressor outlet temperature is greater than 238°C [460°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the temperature threshold is exceeded.
  • Fuel is limited in an attempt to decrease the calculated compressor outlet temperature.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible caused of this fault code include:

  • Air intake leaks allowing hot under-hood air to enter the intake system.
  • Faulty intake manifold pressure readings.
  • High turbocharger speed readings.
  • Fault barometric pressure readings.
  • Stuck variable geometry turbocharger.

Note: Unless the failure is a failed barometric pressure sensor or intake manifold pressure sensor, this fault code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code, and to determine if the failure has been found and fixed.

Refer to Troubleshooting Fault Code t05-2347


EGR Valve Control Circuit - Current Below Normal, or Open Circuit

FAULT CODE 2349

EGR Valve Control Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2349 PID: S146 SPN: 2791 FMI: 5/5 LAMP: Amber SRT: | EGR Valve Control Circuit - Current Below Normal, or Open Circuit. Motor terminal or motor coil open circuit has been detected by the smart EGR controller. | EGR valve actuation will be disabled.
ISX - EGR Valve Control Circuit
ISM - EGR Valve Control Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 datalink. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the J1939 datalink.

The EGR valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary depending on the engine application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The EGR valve has detected an internal error in the internal to the EGR valve smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The diagnostic will clear at initial key-on if the failure condition no longer exists. The ECM will turn off the amber CHECK ENGINE light and enable EGR valve operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the EGR valve has detected an internal error. All failure modes listed below are internal to the EGR valve.

Possible causes of this fault code include:

  • Motor terminal open circuit internal to the EGR valve.
Refer to Troubleshooting Fault Code t05-2349


EGR Valve Control Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2351

EGR Valve Control Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2351 PID: S146 SPN: 2791 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Control Circuit - Voltage Below Normal, or Shorted to Low Source. Motor terminal or motor coil short circuit to ground, or power supply has been detected by the smart EGR controller. | EGR valve actuation will be disabled.
ISX - EGR Valve Control Circuit
ISM - EGR Valve Control Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 datalink. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the J1939 datalink.

The EGR valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary depending on the engine application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The EGR valve has detected an internal error in the EGR valve smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The diagnostic will clear at initial key-on if the failure condition no longer exists. The ECM will turn off the amber CHECK ENGINE light and enable EGR valve operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the EGR valve has detected an internal error. All failure modes listed below are internal to the EGR valve.

Possible causes of this fault code include:

  • Motor terminal short to ground internal to the EGR valve.
  • Motor terminal short to battery internal to the EGR valve.
Refer to Troubleshooting Fault Code t05-2351


EGR Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 2357

EGR Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2357 PID: S146 SPN: 2791 FMI: 7/7 LAMP: Amber SRT: | EGR Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment. The EGR motor has exceeded the duty cycle limit, indicating a stuck open EGR valve. | EGR valve actuation will be disabled.
ISX - EGR Valve Circuit
ISM - EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device that receives commands from the engine electronic control module (ECM) via the J1939 data link. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the J1939 data link.

The EGR valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve location can vary depending on the engine application. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is set when the duty cycle required to open the EGR valve is greater than 95 percent for 3 seconds. The EGR valve controller will try to open the EGR valve again after 10 seconds. The fault code is triggered after three failed attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The EGR valve will stop responding to commands and the spring will close the EGR valve.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and clear the fault code after the keyswitch is cycled and the diagnostic runs and passes. The fault code will be inactive at key-on. It will only go active if the EGR valve is commanded open and the EGR valve is unable to move to the commanded position.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on Quickserve™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is triggered when the EGR valve motor is unable to move the EGR valve in the open position. This is normally caused by a restriction in the EGR valve not allowing the EGR valve to move to the commanded position.

The fault code will be inactive at key-on. It will only go active if the EGR valve is commanded open and the EGR valve is unable to move to the commanded position.

The ECM calibration contains an automatic EGR valve override test. Thirty seconds after turning the keyswitch on, the EGR valve all be commanded open to 60 percent and will be held in this position for 1 minute and then it will be commanded to 0 percent open. Turn the keyswitch off for 20 seconds and then turn the keyswitch on and read the fault codes. If Fault Code 1896 is active, this indicates that the EGR valve is stuck in the open position.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap Acceleration Test to check for a damaged diesel particulate filter.

  • Refer to Procedure 014-013 (Aftertreatment Testing) in Section 14 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature&trade;, ISX and QSX15 Service Manual, Bulletin 3666239, for reuse guidelines.
Refer to Troubleshooting Fault Code t05-2357


Exhaust Gas Recirculation Valve Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2359

Exhaust Gas Recirculation Valve Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2359 PID: P411 SPN: 411 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The EGR differential pressure sensor has detected high EGR gas flow, or the EGR differential pressure reading is not valid for engine operating conditions. | EGR valve actuation will be disabled.
ISX - Differential Pressure Sensor Circuit
ISM - Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.

The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the following conditions are met:

  • The EGR valve position is less than 5 percent open
  • The engine speed is less than 2000 rpm
  • Engine torque output is less than a calibratible value.

Conditions for Setting the Fault Codes

EGR differential pressure is greater than a calibratible value when the EGR valve position is less than 5 percent open and engine torque is less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This diagnostic checks the reading of the EGR differential pressure sensor when the EGR valve is closed. Since the EGR valve is closed, the reading of the EGR differential pressure should be 0. If the ECM detects a reading higher than expected with the EGR valve closed, this fault code is logged.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor
  • A leaking low or high EGR differential pressure tube
  • A stuck open EGR valve.
Refer to Troubleshooting Fault Code t05-2359.

Last Modified: 30-Aug-2011


Fault Code Path Selection

FAULT CODE 16-fc2363
Fault Code Path Selection

Is the engine an ISM? | Go to 16-fc2363ism
Is the engine an ISX? | Go to 16-fc2363isx

Last Modified: 30-May-2006


Engine Brake Actuator Driver Output 3 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2365

Engine Brake Actuator Driver Output 3 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2365 PID: S082 SPN: 1112 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 3 Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the engine brake solenoid Number 3 signal circuit. | Engine brake on cylinders Number 4, 5, and 6 can not be activated.
ISX - Engine Brake Solenoid 3 Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinders Number 4, 5, and 6 by sending a signal on engine brake solenoid 3 signal circuit. The ECM will only command the brakes on under certain operating conditions.

Component Location

The engine brake solenoids are located under the rocker lever cover. The 8-pin engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The engine brake solenoid pulse width modulated (PWM) signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid 3 will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes for this fault include:

  • A short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2365


Fault Code Path Selection

FAULT CODE 16-fc2367
Fault Code Path Selection

Is the engine an ISM? | Go to 16-fc2367ism
Is the engine an ISX? | Go to 16-fc2367isx

Last Modified: 30-May-2006


Engine Brake Actuator Driver Output 3 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2368

Engine Brake Actuator Driver Output 3 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2368 PID: S082 SPN: 1112 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 3 Circuit - Voltage Above Normal, or Shorted to High Source. Open circuit or high voltage detected at the engine brake solenoid Number 3 signal circuit. | Engine brakes on cylinders Number 4, 5, and 6 may be on all the time, or can not be activated.
ISX - Engine Brake Solenoid Number 3 Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinders Number 4, 5, and 6 by sending a signal on engine brake solenoid Number 3 signal circuit. The ECM will only command the brakes on under certain operating conditions.

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Component Location

The engine brake solenoids are located under the valve cover. The 8-pin engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The engine brake solenoid pulse width modulated (PWM) signal is detected to be greater than 0 volts when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid 3 can not be energized.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault include:

  • An open circuit in the engine harness, brake harness, or engine brake solenoids.
  • A short to voltage source in the engine harness.
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2368


Fuel Filter Differential Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2372

Fuel Filter Differential Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2372 PID: P095 SPN: 95 FMI: 0/16 LAMP: Amber SRT: | Fuel Filter Differential Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. Fuel filter is plugged or fuel inlet restriction is high. | The engine can respond poorly after motoring and/or the engine can have low power at high engine speeds.
ISX - Integrated Fuel System Module

Circuit Description

This fault code activates if low fuel pressure is detected by the electronic control module (ECM) during high engine rpm or motoring conditions.

Component Location

There are two fuel filters and several original equipment manufacturer (OEM) supplied components that can impact this fault code. The pressure-side fuel filter is located on the integrated fuel system module. The suction-side fuel filters and other OEM supplied components are OEM specific. The OEM is required to supply a suction-side filter with 25 to 150 micron filtration. The suction-side filter is typically frame-mounted near the integrated fuel system module. However, exact location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Fuel pressure is less than a calibratible value during high fuel flow conditions, indicating a fuel inlet restriction.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

Idle the engine for 10 seconds. The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. See the corresponding Troubleshooting and Repair Manual for the engine being serviced.Refer to Procedure 019-032 in Section 19.

Low fuel pressure during high engine speeds or motoring conditions indicates a fuel inlet restriction or a plugged pressure-side fuel filter. Items that can cause this fault code to activate are:

  • A plugged pressure or suction side fuel filter
  • Collapsed fuel inlet lines
  • An obstructed suction tube in the fuel tank
  • Sticking or worn fuel shutoff valve disc, plunger, or return spring.
Refer to Troubleshooting Fault Code t05-2372


Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2373

Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P131 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the exhaust gas pressure circuit. | None on performance.
ISX - Exhaust Gas Pressure Circuit
ISM - Exhaust Gas Pressure Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the electronic control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust gas pressure signal voltage is greater than 4.75 VDC for more than 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used of the exhaust gas pressure reading.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor.
  • A signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2373


Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2374

Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P131 SPN: 1209 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the exhaust gas pressure circuit. | None on performance.
ISX - Exhaust Gas Pressure Circuit
ISM - Exhaust Gas Pressure Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the electronic control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust gas pressure signal voltage is less than .25 VDC for more than 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value of the exhaust gas pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor.
  • A supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code t05-2374


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2375

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2375 PID: P412 SPN: 412 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at EGR temperature circuit. | EGR valve actuation will be disabled.
ISX CM871/ISM CM876 - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The electronic control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and for engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature signal voltage is greater than 5.1-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas recirculation temperature reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, use the following procedure to calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The EGR temperature sensor shares RETURN wires in the engine harness with other sensors. An open RETURN can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open RETURN circuit in the harness, connectors or sensor.
  • An open SIGNAL circuit or shorted to a voltage source.

The resistance of the EGR temperature sensor varies with the temperature. If the EGR temperature sensor is operating properly, the observed reading will be comparable to the values in the following table.

Temperature °C | Temperature [°F] | Resistance (ohms)
0 | 32 | 256k to 423k
20 | 68 | 99k to 154k
40 | 104 | 42k to 63k
100 | 212 | 5.5k to 7.1k
140 | 284 | 1.9k to 2.3k
200 | 392 | 520 to 580
Refer to Troubleshooting Fault Code 2375.

Last Modified: 20-Sep-2010


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2376

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2376 PID: P412 SPN: 412 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at EGR temperature circuit. | EGR valve actuation will be disabled.
ISX - Exhaust Gas Recirculation Temperature Sensor Circuit
ISM - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The electronic control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature signal voltage is less than 0.09 VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the EGR temperature reading is used.
  • EGR valve actuation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal shorted to ground in the harness.
  • A signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-2376


Fan Control Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S033 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal, or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan may stay on continuously or not run at all.
ISX and ISM - Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the electronic control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The fan clutch solenoid location varies by OEM. Refer to the appropriate OEM service literature to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The fan control circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

For ON/OFF and variable speed fan, the diagnostic will clear when the fan is turned off and the diagnostic runs and passes. For all other fan types, the diagnostic will clear when the fan PWM signal is less than 100 percent.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The ECM monitors the voltage level on this circuit. When the ECM commands the fan signal low, it expects the voltage level to be approximately 0-VDC. If it detects a high voltage, this fault is recorded.

If Fault Code 2377 is still active after completing the following troubleshooting steps, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault include:

  • An open circuit in the engine harness or fan control solenoid.
  • A short circuit to voltage source in the OEM harness.
  • A damaged ECM.
Refer to Troubleshooting Fault Code t05-2377

Last Modified: 16-Jul-2010


Variable Geometry Turbocharger (VGT) Actuator Driver Circuit (Motor) - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 2387

Variable Geometry Turbocharger (VGT) Actuator Driver Circuit (Motor) - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2387 PID: S027 SPN: 641 FMI: 7/7 LAMP: Amber SRT: | VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding Properly or Out of Adjustment. The smart VGT controller has detected incorrect stop limits, or the VGT is unable to move to the closed position. | VGT travel may be limited.
ISX - VGT Actuator Circuit
ISM - VGT Actuator Circuit

Circuit Description

The VGT is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine control module (ECM) with the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code will set when the actual VGT actuator position can not meet the commanded position for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The VGT actuator continuously attempts to meet the commanded position, even when the lamp is ON. Active and stationary aftertreatment regeneration are disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

This fault code will set when the actual VGT actuator position can not meet the commanded position for more than 10 seconds.

Large boost pressure leaks can also cause this fault code.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-024 in Section 10.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-024 in Section 10.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system can have possibly occurred. Perform the Snap Acceleration Test to check for a damaged diesel particulate filter.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 014-013) in Section 14. i
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

Inspect the aftertreatment system for potential damage.

Inspect the turbocharger vanes for residue, and clean the vanes, if required. Find the source of the residue and repair.

Refer to Troubleshooting Fault Code t05-2387

Last Modified: 03-Oct-2012


Fan Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2412

Fan Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2412 PID: P026 SPN: 1639 FMI: 2/2 LAMP: Amber SRT: | Fan Speed - Data Erratic, Intermittent, or Incorrect. The fan speed signal has been lost. | The fan will only be in the ON or OFF position.
ISX and ISM - Fan Speed Sensor

Circuit Description

The fan speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the fan hub shaft is a ground flat in the center of the shaft. The electronic control module (ECM) interprets this signal and converts it to a fan speed reading.

Component Location

The fan speed sensor is located in the fan hub assembly. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the fan speed signal has been lost.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The fan will only be in the ON or OFF position.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The fan speed sensor is installed by the original equipment manufacturer (OEM). This fault code is triggered when the fan speed signal is reading 0 when the engine is running. This indicates a failed fan speed sensor or a failure in the OEM wiring harness.

Refer to Troubleshooting Fault Code t05-2412


Coolant Level - Data Valid but Below Normal Operational Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid but Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: SPN: 111 FMI: 1/17 LAMP: Maintenance SRT: | Coolant Level - Data Valid but Below Normal Operational Range - Least Severe Level. Low engine coolant level detected. | None on performance.
ISX and ISM - Electronic Control Module

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light at initial key-on for 30 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

The ECM will stop flashing the amber CHECK ENGINE light at key-on when coolant has been added to the engine.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-2448


VGT Actuator Controller - Out of Calibration

FAULT CODE 2449

VGT Actuator Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2449 PID: S027 SPN: 641 FMI: 13/13 LAMP: Red SRT: | VGT Actuator Controller - Out of Calibration. The VGT has failed the automatic calibration procedure at initial key-on. | Low intake manifold pressure.
ISX - VGT Actuator Circuit
ISM - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs whenever the VGT actuator learn process occurs.

The keyswitch must be completely turned off for more than 30 seconds before this diagnostic can run at initial key-on.

Conditions for Setting the Fault Codes

The internal position reference is not detected during the VGT actuator learn process due to mechanical system binding or internal condition. The actual VGT actuator position is not known.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.
  • Active and stationary regeneration of the aftertreatment is disabled.

Conditions for Clearing the Fault Code

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key on.

The fault code will clear at KEY ON if the error condition no longer exists. The ECM will turn off the red STOP ENGINE light and enable VGT operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when one of the following error conditions exists.

  • If the turbocharger actuator has just been replaced and this fault code is active, this usually indicates that the turbocharger actuator has not been installed correctly. The gear alignment between the actuator and the turbocharger housing is misaligned.
  • Foreign material in the VGT turbocharger can prevent the sliding nozzle from moving to the desired position during the VGT actuator learn process.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap Acceleration Test to check for a damaged diesel particulate filter.

  • Use this procedure for ISM engines. Refer to Procedure 014-013 in Section 14.
  • Use this procedure for ISX engines. Refer to Procedure 014-013 in Section 14.
Refer to Troubleshooting Fault Code t05-2449


Turbocharger Turbine Intake Temperature (Calculated) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2451

Turbocharger Turbine Intake Temperature (Calculated) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2451 PID: SPN: 2789 FMI: 16 LAMP: None SRT: | Turbocharger Turbine Intake Temperature (Calculated) - Data Valid But Above Normal Operating Range - Moderately Severe Level. Turbocharger turbine intake temperature has exceeded the engine protection limit. | Fuel is limited in an attempt to decrease the calculated exhaust gas temperature entering the turbocharger.
ISX and ISM - Electronic Control Module

Circuit Description

The exhaust gas temperature is calculated by the electronic control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions, such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger, and is also known as turbine inlet temperature.

Note: Some original equipment manufacturers (OEMs) have pyrometer gauges mounted in their chassis. Pyrometers measure turbine outlet temperature or the exhaust gas temperature leaving the turbocharger, so this value will not equal the value monitored with the exhaust gas temperature parameter with INSITE™ electronic service tool.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the calculated turbine inlet temperature is greater than a calibratable value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the temperature threshold is exceeded.
  • Fuel is limited in an attempt to decrease the exhaust gas temperature entering the turbocharger.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The most common cause of this fault code is low boost pressure. Low boost pressure can be caused by several factors; leaking charge-air cooler, damaged charge-air cooler piping or hose, loose charge air cooler clamps, damaged intake manifold pressure sensor, damaged variable geometry turbocharger, damaged turbocharger control valve, or damaged turbocharger control shutoff valve. If the troubleshooting actions in this troubleshooting tree are exhausted without resolving the issue, a stuck in range turbocharger compressor inlet temperature sensor or a stuck in range exhaust gas pressure sensor are possible causes.

This fault code can also be caused by a turbocharger fuel control derate, which can be viewed with INSITE™ electronic service tool, under the Engine Operating State. Turbocharger fuel control derates can be caused by several factors; high exhaust temperatures, turbocharger compressor inlet temperatures, and turbocharger compressor outlet temperatures.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to log this fault code, and to determine if the cause has been found and repaired. Running units on the dynamometer can sometimes cause this fault code to log, due to the stationary nature and high temperatures.

Refer to Troubleshooting Fault Code t05-2451.

Last Modified: 07-Oct-2011


Injector Metering Rail 2 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2551

Injector Metering Rail 2 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2551 PID: P129 SPN: 1349 FMI: 0/16 LAMP: Red SRT: | Injector Metering Rail 2 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. Unexpected high fueling detected on the rear bank. | Engine will return to idle speed. The engine can be shut down using the keyswitch.
ISX - Rear Fueling Actuator Circuit

Circuit Description

The electronic control module (ECM) supplies voltage to open the rear fueling actuator for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects the fuel into the cylinder for combustion.

Component Location

The rear fueling actuator is located on the fuel control housing. It is the first actuator from the rear of the engine. The fuel control housing is located on the intake side of the engine, below the exhaust gas mixer. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The ECM estimates the amount of fuel injected into the front and rear banks of the engine by analyzing the acceleration of the crankshaft. This fault is set active when the estimated fueling on the rear bank is higher than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The engine speed will drop to idle.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The ECM estimates the amount of fuel injected into the front and rear banks of the engine by analyzing the acceleration of the crankshaft. This fault is set active when the estimated fueling on the rear bank is higher than expected.

Refer to Troubleshooting Fault Code t05-2551


Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2552

Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2552 PID: P157 SPN: 157 FMI: 0/16 LAMP: Red SRT: | Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. Unexpected high fueling detected on the front bank. | Engine will return to idle speed. The engine can be shut down using the keyswitch.
ISX - Front Fueling Actuator Circuit

Circuit Description

The electronic control module (ECM) supplies voltage to open the front fueling actuator for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects this fuel into the cylinder for combustion.

Component Location

The front fueling actuator is located on the fuel control housing. It is the first actuator from the front of the engine. The fuel control housing is located in the intake side of the engine, below the exhaust gas mixer. Refer to Procedure 100-002 ) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The ECM estimates the amount of fuel injected into the front and rear banks of the engine by analyzing the acceleration of the crankshaft. This fault is set active when the estimated fueling on the front bank is higher than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The engine speed will drop to idle.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The ECM estimates the amount of fuel injected into the front and rear banks of the engine by analyzing the acceleration of the crankshaft. This fault is set active when the estimated fueling on the front bank is higher than expected.

Refer to Troubleshooting Fault Code t05-2552


Exhaust Gas Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2554

Exhaust Gas Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2554 PID: P131 SPN: 1209 FMI: 2/2 LAMP: Amber SRT: | Exhaust Gas Pressure - Data Erratic, Intermittent, or Incorrect. The exhaust gas pressure sensor is reading an erratic value at initial key ON. | The engine control module (ECM) will estimate the exhaust gas pressure.
ISX - Exhaust Gas Pressure Circuit
ISM - Exhaust Gas Pressure Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the ECM to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

  • This diagnostic runs when the keyswitch is initially turned ON.
  • The diagnostic will also run when the engine is running and lower than expected exhaust pressure is detected.

Conditions for Setting the Fault Codes

  • The ECM detects that the exhaust pressure reading is higher or lower than the other absolute pressure sensors when the keyswitch is ON and the engine is not running.
  • The ECM detects that the exhaust pressure is lower than a calibratible value during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure reading.

Conditions for Clearing the Fault Code

  • To validate the repair, make sure the engine coolant temperature is above 70°C or 158°F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it high idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Verify that the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 .

At key ON, before the engine starts, the sensor readings for intake manifold pressure, barometric air pressure, and exhaust gas pressure are compared to each other. This fault code occurs if the exhaust gas pressure sensor reading is different from the other sensor readings. This check is only done once after the keyswitch is turned ON.

Possible causes of this fault code include:

  • Stuck in-range exhaust gas pressure sensor reading
  • High resistance in the exhaust gas pressure sensor signal or return lines
  • Plugging or restrictions in the exhaust gas pressure sensor tube.
Refer to Troubleshooting Fault Code t05-2554.

Last Modified: 19-Apr-2013


VGT Actuator Controller - Bad Intelligent Device or Component

FAULT CODE 2634

VGT Actuator Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2634 PID: S027 SPN: 641 FMI: 12/12 LAMP: Red SRT: | VGT Actuator Controller - Bad Intelligent Device or Component. An internal error has been detected by the smart VGT controller. | VGT actuation will be disabled.
ISX - VGT Actuator Circuit
ISM - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 in Section E .

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The VGT actuator has detected an internal error in the VGT smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.

Conditions for Clearing the Fault Code

The diagnostic will clear at initial key-on if the error condition no longer exists. The ECM will turn off the red STOP ENGINE light and enable VGT operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the VGT smart actuator detected an internal error within the VGT actuator. The VGT actuator will stop controlling the turbocharger when this fault code is active.

Fault Code 2634 will go active if the VGT actuator is removed from the turbocharger and then the keyswitch is turned to the on position or it may be possible for it to become active if the actuator fails the install/calibrate procedure. If this occurs, disconnect the VGT actuator from the engine harness with the keyswitch on, and connect the VGT actuator to the engine harness. Fault Code 2634 should go inactive. Follow the VGT actuator installation procedure to install the VGT actuator.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting. Progressive damage to the aftertreatment system may have occurred. Perform the Snap Acceleration Test to check for a malfunctioning diesel particulate filter.

  • See the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239 for aftertreatment reuse guidelines.Refer to Procedure 014-013 in Section 14.
Refer to Troubleshooting Fault Code t05-2634


VGT Actuator Driver Circuit - Condition Exists

FAULT CODE 2635

VGT Actuator Driver Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2635 PID: S027 SPN: 641 FMI: 11/31 LAMP: Red SRT: | VGT Actuator Driver Circuit - Condition Exists. A calibration mismatch between the VGT actuator and the ECM has been detected. | VGT actuation will be disabled.
ISX - VGT Actuator Circuit
ISM - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 datalink from the primary engine electronic control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary engine ECM using the J1939 datalink.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

  • The ECM has detected a calibration incompatibility between the VGT actuator and the ECM calibration.
  • The VGT actuator has detected that the system voltage is incorrect for the installed VGT actuator part number.
  • The ECM has detected an incorrect VGT actuator installed on the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.

Conditions for Clearing the Fault Code

The diagnostic will clear at initial key-on if the error condition no longer exists. The ECM will turn off the red STOP ENGINE light and enable VGT operation immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the ECM has detected that an incorrect VGT actuator has been installed on the turbocharger.

Refer to Troubleshooting Fault Code t05-2635


VGT Actuator Driver Circuit - Abnormal Update Rate

FAULT CODE 2636

VGT Actuator Driver Circuit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2636 PID: S027 SPN: 641 FMI: 9/9 LAMP: Red SRT: | VGT Actuator Driver Circuit - Abnormal Update Rate. No communications on the J1939 data link between the engine ECM and the smart VGT controller. | The VGT will move to the default open position.
ISX - VGT Actuator Circuit
ISM - VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine engine control module (ECM). The VGT actuator performs its own diagnostics and reports failures back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The primary engine ECM does not receive a valid J1939 message from the VGT actuator for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE light immediately when the diagnostic runs and fails.
  • The VGT will move to the default open position.

Conditions for Clearing the Fault Code

The ECM will turn off the red STOP ENGINE light and enable VGT operation immediately after a valid J1939 message is received from the VGT actuator.

Shop Talk

This fault code logs when the primary engine ECM did not receive valid J1939 information from the VGT actuator.

Troubleshoot high inactive counts of Fault Code 2636 as an active fault code.

Possible causes of this fault code include:

  • The VGT actuator is not receiving power from the ECM. This could be caused by an open circuit in the power supply wire or low voltage supplied by the primary engine ECM
  • Coolant entering VGT actuator and corroding circuit board
  • Rapid cycling of the keyswitch
  • An open return circuit on the VGT actuator circuit
  • An open or short circuit on the J1939 data link circuit between the ECM and VGT actuator
  • Intermittent communications between the VGT actuator and the primary engine ECM on the J1939 data link
  • Connector pins are not installed in the appropriate locations specified by the wiring schematic
  • A damaged termination resistor in the engine data link harness
  • A damaged engine ECM.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap Acceleration Test to check for a malfunctioning diesel particulate filter. Refer to Procedure 014-013 in Section 14.

Refer to Troubleshooting Fault Code t05-2636

Last Modified: 13-Feb-2014


Catalyst Face Plugged - Root Cause Not Known

FAULT CODE 2637

Catalyst Face Plugged - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2637 PID: SPN: 5018 FMI: 11/11 LAMP: None SRT: | Catalyst Face Plugged - Root Cause Not Known. The front face of the aftertreatment diesel oxidation catalyst has been detected to be plugged with soot. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment System

Circuit Description

This fault code is set when the inlet face of the diesel oxidation catalyst is detected to be plugged with soot.

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst may vary depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and an active regeneration of the aftertreatment is occurring.

Conditions for Setting the Fault Codes

The ECM detects that the conditions for face plugging of the diesel oxidation catalyst are present and that plugging may have occurred.

Action Taken When the Fault Code is Active

  • The fault code is logged immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.
  • The exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The fault code will be set to inactive after performing the INSITE™ electronic service tool Diesel Oxidation Catalyst Maintenance Reset procedure found under the Aftertreatment Maintenance section of Advanced ECM Data, or when the condition for diesel oxidation catalyst face plugging are no longer occurring.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is set when the inlet face of the diesel oxidation catalyst is detected to be plugged with soot.

Possible causes of this fault code include:

  • Engine oil or fuel plugging the front face of the aftertreatment diesel oxidation catalyst.
Refer to Troubleshooting Fault Code 2637.

Last Modified: 18-Aug-2010


Catalyst Efficiency - Out of Calibration

FAULT CODE 2638

Catalyst Efficiency - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2638 PID: SPN: S380 FMI: 13/13 LAMP: None SRT: | Catalyst Efficiency - Out of Calibration. The temperature increase across the aftertreatment diesel oxidation catalyst is lower than expected. | None on performance.
ISX and ISM - Aftertreatment System

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

  • Active regeneration of the aftertreatment diesel particulate filter must be occurring before the diagnostic will run.

Conditions for Setting the Fault Codes

The ECM detects that the temperature differential across the aftertreatment diesel oxidation catalyst during active regeneration is not matching the expected temperature increase.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The fault code will be set to inactive after performing the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test and the Diesel Oxidation Catalyst Efficiency is determined to be above a calibratible threshold.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the temperature increase across the catalyst during an aftertreatment injection event is lower than expected.

An in-range failure of the aftertreatment diesel oxidation catalyst or the aftertreatment diesel particulate filter inlet temperature can cause this fault code. Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment diesel oxidation catalyst.
  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst.
  • Cracked or contaminated aftertreatment diesel oxidation catalyst.
  • Malfunction in the aftertreatment fuel injection system.
  • Leaking exhaust system between the turbocharger and the diesel oxidation catalyst.
Refer to Troubleshooting Fault Code t05-2638

Last Modified: 15-Sep-2010


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2639

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2639 PID: S324 SPN: 3251 FMI: 0/15 LAMP: None SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | The aftertreatment dash lamp will be illuminated and will begin to flash as the severity of the soot load increases. Possible engine protection derate based on severity.
ISX and ISM - Aftertreatment System

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions it may be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code can be triggered if the application is not operating at duty cycle high enough to regenerate the aftertreatment diesel particulate filter. This fault code indicates that the exhaust temperatures exiting the turbocharger are not high enough to actively regenerate the soot that is trapped in the aftertreatment diesel particulate filter. It may be necessary to increase the duty cycle of the application in order to prevent plugging of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the soot load of the aftertreatment diesel particulate filter has reached the first stage of plugging.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the AFTERTREATMENT dash lamp immediately after the diagnostic is set.
  • The ECM will flash the AFTERTREATMENT dash lamp as the severity of the soot load increases.
  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.

Conditions for Clearing the Fault Code

The ECM will turn off the AFTERTREATMENT dash lamp immediately after the soot load in the aftertreatment diesel particulate filter has dropped below the recommended limits.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Note: This fault code indicates that the aftertreatment diesel particulate filter requires maintenance by performing a stationary regeneration procedure. This is a maintenance procedure only and is not covered by Cummins warranty.

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The engine has been operating in light load operating conditions that prevent exhaust temperatures from being high enough to regenerate the aftertreatment diesel particulate filter.
  • A possible engine damage that causes excessive black smoke to be generated.

The aftertreatment diesel particulate filter soot loading can be classified into four different stages. As the soot load increases, the AFTERTREATMENT lamp and the Cummins CHECK ENGINE (Amber) or STOP ENGINE (Red) lamp will operate according to the table below. The stationary regeneration procedure can be used to clear the soot from the aftertreatment diesel particulate filter in stages 1, 2, and 3. At level 4, the aftertreatment diesel particulate filter is completely plugged and must be replaced. Inadequate exhaust temperatures entering the aftertreatment system can be a cause of high soot loads in the aftertreatment diesel particulate filter. The duty cycle of the application may need to be increased in order to prevent excessive soot from accumulating in the filter.

Soot Level Stage | Cummins Fault Code | Aftertreatment Lamp Status | Cummins Lamp Status | Service Procedure | Engine Protection Strategy
1 | 2639 | Solid | Off | Perform stationary regeneration procedure | No Engine Protection Derate
2 | 2639 | Flashing | Off | Perform stationary regeneration procedure | Engine Protection Derate
3 | 1921 | Flashing | Amber | Perform stationary regeneration procedure | Engine Protection Derate
4 | 1922 | Off | Red | Replace aftertreatment diesel particulate filter | Severe Engine Protection Derate
Refer to Troubleshooting Fault Code t05-2639.

Last Modified: 14-Jul-2014


Engine Coolant Temperature - Condition Exists

FAULT CODE 2646

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2646 PID: P110 SPN: 110 FMI: 31 LAMP: Amber SRT: | Engine Coolant Temperature - Condition Exists. The EGR valve was closed to reduce engine coolant temperature. | EGR valve actuation will be disabled.
ISX - Engine Coolant Temperature Circuit
ISM - Engine Coolant Temperature Circuit

Circuit Description

When the engine coolant temperature nears the engine protection limits, the exhaust gas recirculation (EGR) valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The fault code is set active when the EGR valve is closed to reduce engine coolant temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The fault code is set inactive when the EGR valve actuation is re-activated.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed. No failure has occurred to cause this fault code. Other engine protection fault codes will be active if the engine coolant temperature has exceeded the engine protection limits.

Refer to Troubleshooting Fault Code t05-2646


Engine Coolant Temperature - Condition Exists

FAULT CODE 2659

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2659 PID: P110 SPN: 110 FMI: 31 LAMP: None SRT: | Engine Coolant Temperature - Condition Exists. The EGR valve was closed to reduce engine coolant temperature. | EGR valve actuation will be disabled.
ISX - Engine Coolant Temperature Circuit
ISM - Engine Coolant Temperature Circuit

Circuit Description

When the engine coolant temperature nears the engine protection limits, the exhaust gas recirculation (EGR) valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

The fault code is set active when the EGR valve is closed to reduce engine coolant temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The fault code is set inactive when the EGR valve actuation is re-activated.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed. No failure has occurred to cause this fault code. Other engine protection fault codes will be active if the engine coolant temperature has exceeded the engine protection limits.

Refer to Troubleshooting Fault Code t05-2659


Aftertreatment Fuel Injector 1 - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2728

Aftertreatment Fuel Injector 1 - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2728 PID: SPN: S382 FMI: 0/16 LAMP: None SRT: | Aftertreatment Fuel Injector 1 - Data Valid But Above Normal Operational Range - Moderately Severe Level. Active regeneration of the aftertreatment diesel particulate filter has been detected to be ineffective. | None on performance.
ISX and ISM - Aftertreatment System

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the engine is running and an active regeneration of the aftertreatment system is occurring.

Conditions for Setting the Fault Codes

The aftertreatment system has detected that an active regeneration event has occurred longer than a calibratible time and that the aftertreatment temperatures have not reached the minimum temperature for a complete regeneration of the diesel particulate filter to occur.

Action Taken When the Fault Code is Active

  • The fault code is set active immediately when the diagnostic runs and fails.
  • The aftertreatment diesel particulate filter lamp (if equipped) will become illuminated after the diagnostic runs and fails three times.

Conditions for Clearing the Fault Code

A regeneration event, either stationary or mobile, must be performed before this fault code will clear.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The aftertreatment system will try to meet target temperatures at the outlet of the diesel oxidation catalyst during a regeneration event. This fault code is activated when the control system detects that the aftertreatment fuel injector is injecting excessive fuel into the exhaust system trying to meet the target temperatures at the diesel oxidation catalyst outlet temperature sensor.

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment diesel oxidation catalyst
  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst
  • A cracked or contaminated aftertreatment diesel oxidation catalyst
  • A malfunction in the aftertreatment fuel injection system
  • A leaking exhaust system between the turbocharger and the aftertreatment diesel oxidation catalyst
  • The duty cycle of the vehicle is not high enough to provide adequate exhaust temperatures for a complete regeneration event.
Refer to Troubleshooting Fault Code t05-2728


Aftertreatment Fuel Drain Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2732

Aftertreatment Fuel Drain Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2732 PID: S338 SPN: 4097 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Fuel Drain Valve Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment fuel drain valve circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Fuel Drain Valve Circuit

Circuit Description

The aftertreatment fuel drain valve is used to relieve the fuel pressure between the aftertreatment fuel shutoff valve 1 and the aftertreatment fuel injector.

Component Location

The aftertreatment fuel drain valve is located in the aftertreatment drain valve assembly. For a detailed component location view, see the following procedure.Refer to Procedure 100-002 in Section E

Conditions for Running the Diagnostics

This diagnostic runs within the first 30 seconds of the engine starting and prior to active regenerations of the diesel particulate filter.

Conditions for Setting the Fault Codes

The aftertreatment fuel drain valve circuit pulse width modulated (PWM) signal is detected to be at system voltage when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The fault code will clear within 30 seconds of starting the engine or prior to an active regeneration event of the diesel particulate filter.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or drain valve
  • Fuel drain valve signal wire shorted to a voltage source in the harness
  • A damaged aftertreatment fuel drain valve.
Refer to Troubleshooting Fault Code t05-2732


Aftertreatment Fuel Drain Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2733

Aftertreatment Fuel Drain Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2733 PID: S338 SPN: 4097 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Fuel Drain Valve Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment fuel drain valve circuit. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Fuel Drain Valve Circuit

Circuit Description

The aftertreatment fuel drain valve is used to disable the fuel supply to the aftertreatment system.

Component Location

The aftertreatment fuel drain valve sensor is located in the aftertreatment shutoff valve assembly. For a detailed component location view, go to the following procedure.Refer to Procedure 100-002 in Section E

Conditions for Running the Diagnostics

This diagnostic runs within the first 30 seconds of the engine starting and prior to active regenerations of the diesel particulate filter.

Conditions for Setting the Fault Codes

The aftertreatment fuel drain valve circuit pulse width modulated (PWM) signal is detected to be at 0-VDC when the PWM voltage is turned on.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

The fault code will clear within 30 seconds of starting the engine or prior to an active regeneration event of the diesel particulate filter.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the corresponding Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or shutoff valve
  • A shorted aftertreatment fuel drain valve.
Refer to Troubleshooting Fault Code t05-2733


Start Enable Device 1 Circuit (Ether Injection) - Voltage Above Normal or Shorted to High Source

FAULT CODE 2738

Start Enable Device 1 Circuit (Ether Injection) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2738 PID: S237 SPN: 626 FMI: 3/3 LAMP: Amber SRT: | Start Enable Device 1 Circuit (Ether Injection) - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the ether start solenoid circuit. | Ether start functionality will be disabled.
ISX and ISM - Ether Injection Start Circuit

Circuit Description

The ether injection circuit is a device used by the engine to control the ether injection operation.

The ether injection circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0 VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The ether injection solenoid location varies by OEM. Refer to the appropriate OEM troubleshooting and repair manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the PWM device is activated. In some cases the diagnostic can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The ether injection circuit PWM signal is detected to be greater than 0-VDC when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault include:

  • An open circuit in the engine harness or ether injection solenoid.
  • A short circuit to voltage source in the OEM harness.
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2738


Start Enable Device 1 Circuit (Ether Injection) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2739

Start Enable Device 1 Circuit (Ether Injection) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2739 PID: S237 SPN: 626 FMI: 4/4 LAMP: Amber SRT: | Start Enable Device 1 Circuit (Ether Injection) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the ether start solenoid circuit. | Ether start functionality will be disabled.
ISX and ISM - Ether Injection Circuit

Circuit Description

The ether injection circuit is a device used by the engine to control the ether injection operation.

The ether injection circuit utilizes a Pulse Width Modulated (PWM) signal. A PWM signal is pulsed voltage signal between 0 VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM troubleshooting and repair manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The ether injection circuit PWM signal is not detected to be system voltage when the PWM signal is turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared by using the INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is logged when the ECM commands 12 VDC to the ether injection solenoid, but the voltage on the ether injection signal circuit is less than 12 VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

Refer to Troubleshooting Fault Code t05-2739


Aftertreatment Fuel Shutoff Valve 1 Swapped - Condition Exists

FAULT CODE 2741

Aftertreatment Fuel Shutoff Valve 1 Swapped - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2741 PID: S334 SPN: 3482 FMI: 31 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 Swapped - Condition Exists. Aftertreatment fuel shutoff valve 1 and aftertreatment fuel drain valve wiring harness connections are reversed. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX - Aftertreatment Fuel Shutoff Valve
ISM - Aftertreatment Fuel Shutoff Valve

Circuit Description

The aftertreatment fuel shutoff valve 1 is used to enable and disable the fuel supply to the aftertreatment system. The aftertreatment fuel drain valve is used to drain fuel between the aftertreatment fuel shutoff valve 1 and the aftertreatment fuel injector.

Component Location

The aftertreatment fuel shutoff valve 1 and the aftertreatment fuel drain valve are located in the aftertreatment shutoff valve assembly. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs within the first 30 seconds of starting the engine and before active regeneration of the diesel particulate filter.

Conditions for Setting the Fault Codes

The aftertreatment fuel shutoff valve 1 and the aftertreatment fuel drain valve connectors are detected to be connected backwards.

Action Taken When the Fault Code is Active

  • The electronic control module (ECM) illuminates the amber CHECK ENGINE light immediately after the diagnostic runs and fails.
  • Active aftertreatment diesel particulate filter regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault include:

  • The engine harness connectors on the aftertreatment fuel shutoff valve 1 and the aftertreatment fuel drain valve are swapped. Reverse the wiring harness connectors on the aftertreatment fuel shutoff valves.
Refer to Troubleshooting Fault Code t05-2741


Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Least Severe Level

FAULT CODE 2742

Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2742 PID: S327 SPN: 3249 FMI: 17 LAMP: None SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Least Severe Level. The temperatures in the aftertreatment system can not reach the required temperatures for stationary regeneration. | None on performance.
ISX and ISM - Aftertreatment System

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary depending on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

  • The diagnostic runs during a stationary regeneration of the aftertreatment diesel particulate filter.
  • The diagnostic also runs during extended idle periods when the exhaust temperature can not be increased in the aftertreatment system to remove water accumulation.

Conditions for Setting the Fault Codes

  • The ECM detects that the temperature measured at the diesel oxidation catalyst inlet is not meeting the target temperatures required for stationary regeneration.
  • The ECM detects that the temperature entering the aftertreatment system is not high enough to remove water from the system during extended idle periods.

Action Taken When the Fault Code is Active

  • The ECM sets the fault code active immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found under ECM Diagnostics Test.
  • The ECM will disable the fault code immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment system will try to meet target temperatures at the inlet of the diesel oxidation catalyst prior to beginning a stationary regeneration event. This fault code is activated if the engine is not able to meet the commanded minimum exhaust temperature required at the inlet of the aftertreatment system. This is prior to any aftertreatment fuel injection into the exhaust system.

Possible caused of this fault code include:

  • A leaking exhaust system between the turbocharger and the aftertreatment diesel oxidation catalyst.
  • Excessive exhaust temperature loss between the turbocharger outlet and the inlet of the aftertreatment system.
Refer to Troubleshooting Fault Code t05-2742

Last Modified: 21-Jul-2010


Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2743

Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2743 PID: S327 SPN: 3249 FMI: 18 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Below Normal Operating Range - Moderately Severe Level. The temperatures in the aftertreatment system can not reach the required temperatures for stationary regeneration. | None on performance.
ISX and ISM - Aftertreatment System

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary depending on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

  • The diagnostic runs during a stationary regeneration of the aftertreatment diesel particulate filter.
  • The diagnostic also runs during extended idle periods when the exhaust temperature can not be increased in the aftertreatment system to remove water accumulation.

Conditions for Setting the Fault Codes

  • The ECM detects that the temperature measured at the diesel oxidation catalyst inlet is not meeting the target temperatures required for stationary regeneration.
  • The ECM detects that the temperature entering the aftertreatment system is not high enough to remove water from the system during extended idle periods.

Action Taken When the Fault Code is Active

  • The set the fault code active immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found under ECM Diagnostics Test.
  • The ECM will disable the fault code immediately after the diagnostic runs and passes or after a keyswitch cycle.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The aftertreatment system will try to meet target temperatures at the inlet of the diesel oxidation catalyst prior to beginning a stationary regeneration event. This fault code is activated if the engine is not able to meet the commanded minimum exhaust temperature required at the inlet of the aftertreatment system. This is prior to any aftertreatment fuel injection into the exhaust system.

Possible caused of this fault code include:

  • A leaking exhaust system between the turbocharger and the aftertreatment diesel oxidation catalyst.
  • Excessive exhaust temperature loss between the turbocharger outlet and the inlet of the aftertreatment system.
Refer to Troubleshooting Fault Code t05-2743


Engine Particulate Filter Inlet Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2754

Engine Particulate Filter Inlet Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2754 PID: P81 SPN: 81 FMI: 16 LAMP: Amber SRT: | Engine Particulate Filter Inlet Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. Excessive black smoke has been detected exiting the engine and entering the aftertreatment diesel particulate filter. | None on performance
ISX and ISM - Aftertreatment

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code is logged when the sensors in the aftertreatment system indicates soot accumulation inside the diesel particulate filter is happening at a higher rate than under normal conditions. This indicates that the smoke (soot) being produced from the engine is higher than normal.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

This fault code is logged when the soot accumulation inside the diesel particulate filter is happening at a higher rate than under normal conditions.

Action Taken When the Fault Code is Active

  • The fault code is active immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The electronic control module (ECM) will disable the fault code immediately after the diagnostic runs and passes or after a keyswitch cycle.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Boost leaks in the charge air cooler plumbing
  • A malfunctioning variable geometry turbocharger (VGT)
  • A malfunctioning exhaust gas recirculation (EGR) valve
  • A malfunctioning in-range EGR differential pressure sensor
  • A malfunctioning in-range boost pressure sensor
  • A malfunctioning in-range barometric pressure sensor
  • A cylinder misfire or overfueling.
Refer to Troubleshooting Fault Code t05-2754


Exhaust Gas Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2764

Exhaust Gas Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2764 PID: P131 SPN: 1209 FMI: 16 LAMP: Amber SRT: | Exhaust Gas Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. High exhaust gas pressure has been detected by the exhaust gas pressure sensor. | Engine RPM derate.
ISX - Exhaust Gas Pressure Sensor Circuit
ISM - Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the electronic control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when engine speed is greater than 500 rpm.

Conditions for Setting the Fault Codes

This fault code is logged when the exhaust gas pressure sensor is reading a value above the engine protection limits.

Action Taken When the Fault Code is Active

  • The fault code is set active immediately when the exhaust gas pressure is above the engine protection limits.
  • The ECM illuminates the amber check engine light immediately after the diagnostic runs and fails.
  • An engine RPM derate is issued by the ECM.

Conditions for Clearing the Fault Code

The ECM will disable the fault code immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Malfunctioning variable geometry turbocharger
  • Damaged in-range exhaust gas pressure sensor
  • Plugged or restricted aftertreatment diesel particulate filter
  • Plugged or restricted EGR cooler
  • Exhaust gas pressure sensor connector water intrusion.
Refer to Troubleshooting Fault Code t05-2764

Last Modified: 17-Jan-2011


Exhaust Gas Recirculation (EGR) System - Condition Exists

FAULT CODE 2774

Exhaust Gas Recirculation (EGR) System - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2774 PID: S391 SPN: 3058 FMI: 11/31 LAMP: Amber SRT: | Exhaust Gas Recirculation (EGR) System - Condition Exists. Plugged EGR differential pressure sensor tubes have been detected. | EGR valve operation will be disabled.
ISX - Differential Pressure Sensor Circuit
ISM - Differential Pressure Sensor Circuit

Circuit Description

The EGR differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The electronic control module (ECM) uses this pressure to determine how much exhaust gas is flowing through the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.

The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

This diagnostic checks the EGR differential pressure tubes for plugging.

Component Location

The EGR differential pressure sensor is located near the fuel inlet to the integrated fuel system module. A high EGR differential pressure tube and a low EGR differential pressure tube extend from the EGR differential pressure orifice and connect to the EGR differential pressure sensor. The high EGR differential pressure tube connects to the EGR connection tube rearward of the EGR differential pressure orifice and connects to the front port of the EGR differential pressure sensor. The low EGR differential pressure tube connects to the EGR connection tube frontward of the EGR differential pressure orifice and connects to the rear port of the EGR differential pressure sensor. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This diagnostic monitors intake manifold pressure and EGR differential pressure to determine if the EGR differential pressure tubes are plugged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • EGR valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after a keyswitch cycle.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • A plugged or leaking low or high EGR differential pressure tube
  • Carbon buildup inside the EGR venturi tube blocking the opening to the EGR differential pressure tubes.
Refer to Troubleshooting Fault Code t05-2774


Particulate Trap Active Regeneration Inhibited Due to Inhibit Switch - Condition Exists

FAULT CODE 2777

Particulate Trap Active Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2777 PID: S390 SPN: 3703 FMI: 11/31 LAMP: None SRT: | Particulate Trap Active Regeneration Inhibited Due to Inhibit Switch - Condition Exists. Regeneration of the diesel particulate filter has been prevented due to the permit switch being disabled. | None on performance.
ISX and ISM Aftertreatment System

Circuit Description

The OEM truck manufacturer may install a permit switch in the dash or send an inhibit message via the J1939 datalink to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile regenerations. The purpose of this fault code is to inform the technician that the permit switch was disabled when Fault Code 1921, 1922 , or 2639 was set active. This fault code can possibly indicate the reason that high aftertreatment soot load fault codes are logged.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). The permit switch can possibly be an actual switch in the vehicle dash or it can possibly be a J1939 message sent via the J1939 datalink. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the on position.

Conditions for Setting the Fault Codes

This fault code is triggered if the permit switch is disabled when Fault Code 1921, 1922, or 2639 is activated for high soot load levels in the diesel particulate filter.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code will be set inactive when Fault Code 1921, 1922, 2639 is set inactive.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If this fault code is active and there has been damage to the aftertreatment system, the permit switch can possibly have prevented the aftertreatment system from performing a mobile (active) regeneration. Consult with the OEM if the aftertreatment system has failed due to the permit switch.

Refer to Troubleshooting Fault Code t05-2777


Engine Coolant Temperature - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 2789

Engine Coolant Temperature - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2789 PID: 110 SPN: 110 FMI: 1/18 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid but Below Normal Operational Range - Moderately Severe Level. Engine coolant temperature is below normal operating temperature limits. | None on performance.
ISX Coolant Temperature Sensor Circuit
ISM Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is below a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set.

Conditions for Clearing the Fault Code

The fault code will be set inactive when the coolant temperature is detected to be within the normal operating temperature limits.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

If this fault indicates that coolant temperature is below a calibratible limit set in the ECM.

  • For ISM engines, refer to Engine Coolant Temperature Below Normal troubleshooting symptom tree tree in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, refer to Engine Coolant Temperature Below Normal troubleshooting symptom tree tree in he Signature, ISX and QSX15 Service Manual, Bulletin 3666239.
Refer to Troubleshooting Fault Code t05-2789


EGR Valve Control - Special Instructions

FAULT CODE 2813

EGR Valve Control - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2813 PID: S146 SPN: 2791 FMI: 14 LAMP: Amber SRT: | EGR Valve Control - Special Instructions. The EGR valve has been closed during regeneration of the aftertreatment diesel particulate filter. | EGR valve operation will be disabled.
ISX and ISM - Aftertreatment System

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

This fault code is triggered when the EGR valve is closed during an active regeneration of the aftertreatment diesel particulate filter. No failure of the aftertreatment system has occurred. Closing the EGR valve increases the exhaust temperature and increasing the rate of regeneration of the aftertreatment diesel particulate filter. No troubleshooting of the aftertreatment system is necessary. This fault code is for information only.

Component Location

The aftertreatment system is located in the exhaust system. The location of the aftertreatment diesel particulate filter can vary depending on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

Active regeneration of the diesel particulate filter must be occurring.

Conditions for Setting the Fault Codes

The aftertreatment control system has detected that the exhaust temperature is not high enough during an active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

  • EGR valve operation is disabled.
  • The ECM illuminates the amber CHECK engine light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will disable the fault code immediately after a complete regeneration of the aftertreatment diesel particulate filter.
  • Use INSITE™ electronic service to tool perform the Aftertreatment Diesel Particulate Filter Regeneration test found under ECM Diagnostics Test.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code is triggered when the EGR valve is closed during an active regeneration of the aftertreatment diesel particulate filter. No failure of the aftertreatment system has occurred. Closing the EGR valve increases the exhaust temperature and speeds up the rate of regeneration of the aftertreatment diesel particulate filter. No troubleshooting of the aftertreatment system is necessary. This fault code is for information only.

Refer to Troubleshooting Fault Code t05-2813


Fault Code Path Selection

FAULT CODE 16-fc2878
Fault Code Path Selection

Is the engine an ISM? | Go to 16-fc2878ism
Is the engine an ISX? | Go to 16-fc2878isx

Last Modified: 30-Jan-2009


Fault Code Path Selection

FAULT CODE 16-fc2879
Fault Code Path Selection

Is the engine an ISM? | Go to 16-fc2879ism
Is the engine an ISX? | Go to 16-fc2879isx

Last Modified: 30-Jan-2009


Aftertreatment Fuel Pressure Sensor - Data Valid but Below Normal Operational Range - Least Severe Level

FAULT CODE 2881

Aftertreatment Fuel Pressure Sensor - Data Valid but Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2881 PID: S332 SPN: 3480 FMI: 1/17 LAMP: None SRT: | Aftertreatment Fuel Pressure Sensor - Data Valid but Below Normal Operational Range - Least Severe Level. Low fuel pressure has been detected in the aftertreatment fuel system. | None on performance.
ISX and ISM - Aftertreatment Fuel Injector System

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The electronic control module (ECM) supplies the aftertreatment fuel pressure sensor a 5-volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5-volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel pressure sensor is located in the aftertreatment fuel shutoff manifold. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs during the first 5 minutes of engine operation.

Conditions for Setting the Fault Codes

The aftertreatment fuel pressure sensor detects that the fuel pressure in the aftertreatment system is below the minimum fuel pressure required for fuel injection into the aftertreatment system.

Action Taken When the Fault Code is Active

  • The ECM will set the fault code active immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will set the fault code inactive following a key cycle or immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Low fuel pressure detected in the aftertreatment fuel supply system.
  • On ISM engines, check the fuel rifle connection at the cylinder head. Remove the aftertreatment fuel supply line and inspect the fuel rifle in the cylinder head for a plastic plug or ”stringer” that may be restricting the fuel flow to the aftertreatment system.
  • The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle and inspect for reuse. Refer to Procedure 014-013 in Section 14. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, or the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239.
Refer to Troubleshooting Fault Code t05-2881


Exhaust Gas Recirculation (EGR) Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2961

Exhaust Gas Recirculation (EGR) Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2961 PID: P412 SPN: 412 FMI: 0/15 LAMP: None SRT: | EGR Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. EGR temperature has exceeded the engine protection limit. | Slight fueling derate to bring EGR temperature under the maximum limit.
ISX - EGR Temperature Sensor Circuit
ISM - EGR Temperature Sensor Circuit

Circuit Description

The EGR temperature/ EGR sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The ECM supplies 5 volts to the EGR temperature signal circuit. The ECM (ECM) monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR valve and the air intake connection. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature is greater than 140°C [284°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The engine torque will be derated up to 40 percent to limit the EGR temperature.

Conditions for Clearing the Fault Code

  • The fault code will be set inactive immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Malfunctioning EGR differential pressure tubes
  • A damaged EGR valve
  • A stuck open turbocharger control valve
  • A low reading from the EGR differential pressure sensor
  • A low reading for the EGR valve position sensor
  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger
  • A fouled EGR cooler.

NOTE: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code t05-2961

Last Modified: 18-Jul-2012


Exhaust Gas Recirculation Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2962

Exhaust Gas Recirculation Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2962 PID: P412 SPN: 412 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level. EGR temperature has exceeded the engine protection limit. | Severe fueling derate to bring EGR temperature under the maximum limit.
ISX - Exhaust Gas Recirculation Temperature Sensor Circuit
ISM - Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The electronic control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR valve and the air intake connection.Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the EGR temperature is greater than 293°C [560°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine torque will be derated up to 40 percent to limit the EGR temperature.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the EGR temperature drops below 293°C [560°F].

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • A fouled EGR cooler.
  • Failed EGR differential pressure tubes.
  • A failed EGR valve.
  • A stuck open turbocharger control valve.
  • A low reading from the EGR differential pressure sensor.
  • A low reading for the EGR valve position sensor.
  • High exhaust temperatures.
  • Low coolant level.
  • High coolant temperature.
  • An incorrect coolant/water mixture.
  • A stuck closed variable geometry turbocharger.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code t05-2962


Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Least Severe Level. Engine coolant temperature is above the engine coolant temperature engine protection warning limit. | Power derate and possible engine shutdown if Engine Protection Shutdown feature is enabled.
ISX - Engine Coolant Temperature Sensor Circuit
ISM - Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The electronic control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and for engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing. Use the following procedure for a detailed component location view.Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

The ECM will turn off the fault code immediately after the coolant temperature decreases below the engine protection limit.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM again. Refer to Procedure 019-032 in Section 19.

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. It is highly unlikely that the coolant temperature sensor has malfunctioned unless there are other active coolant temperature sensor faults.

  • For ISM engines, refer to the Engine Coolant Temperature Above Normal symptom tree in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines refer to the Engine Coolant Temperature Above Normal symptom tree in the Signature&trade;, ISX and QSX15 Service Manual, Bulletin 3666239.
Refer to Troubleshooting Fault Code t05-2963


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Least Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
ISX - Intake Manifold 1 Pressure/Temperature Sensor
ISM - Intake Manifold 1 Pressure/Temperature Sensor

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

When the intake air is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

This fault code indicates that the intake manifold temperature has exceeded the maximum engine protection limit.

Component Location

The intake manifold 1 temperature sensor is located in the air intake manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

The maximum torque output of the engine will return and the fault code will go inactive after the intake manifold temperature drops below a calibratible limit set in the ECM.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold. Possible causes of this fault code include:

  • Plugged charge air cooler fins.
  • Restricted airflow through the charge air cooler.
  • An undersized charge air cooler.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-2964


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected an intake manifold pressure signal that is too high or low for present engine operating conditions. | Engine power derate.
ISX - Intake Manifold 1 Pressure/Temperature Sensor Circuit
ISM - Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

This diagnostic checks the value of the intake manifold pressure sensor at key ONand while the engine is running. If the value of the intake manifold pressure is not reading ambient pressure at key-on or is not changing with engine operating conditions, this fault code is logged.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake horn. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure signal reading is not changing with engine operating conditions or is reading an erratic value at key-on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value for the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too high or low for the current engine operating conditions. The ECM compares the intake manifold pressure reading to turbocharger speed to determine if the pressure reading is valid.

Possible causes of this fault are:

  • A malfunctioning intake manifold pressure sensor
  • A malfunctioning barometric pressure sensor.
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Restriction in the charge-air cooler
  • A malfunctioning turbocharger speed sensor
  • Plugged or restricted exhaust system
  • A plugged intake manifold pressure sensor
  • Air filter restriction.
Refer to Troubleshooting Fault Code t05-2973


Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3167

Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3167 PID: S382 SPN: 3556 FMI: 18 LAMP: Amber SRT: | Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level. | Possible ineffective regeneration of the aftertreatment diesel particulate filter. Degraded aftertreatment fuel injector.
ISX CM871/ISM CM876 - Aftertreatment Fuel Injector System

Circuit Description

The aftertreatment fuel injector is electronically controlled by the engine control module (ECM) through a pulse width modulated (PWM) signal. The amount of fuel injected is determined by how long the PWM signal to the injector is on.

Component Location

The aftertreatment fuel injector is located on the turbocharger adapter pipe.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

This fault code becomes active when the ECM detects that the aftertreatment fuel injector can not inject enough fuel for active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test. Once the temperatures in the aftertreatment system are high enough to inject diesel fuel into the exhaust, the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault include:

  • Dirty or damaged aftertreatment fuel injector.
Refer to Troubleshooting Fault Code t05-3167.

Last Modified: 10-Mar-2014


Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 3348

Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3348 PID: SPN: 1176 FMI: 1/1 LAMP: Red SRT: | Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. | Progressive power derate increasing in severity from the time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red Stop lamp starts flashing.
ISX and ISM Electronic Control Module (ECM)

Circuit Description

The pressure differential over the compressor seal is a calculated value derived from the difference between charge pressure and crankcase pressure.

Component Location

None.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the pressure differential over the compressor seal exceeds the recommended maximum.

Action Taken When the Fault Code is Active

  • The ECM registers the fault code and illuminates the red STOP ENGINE light after the problem reaches a maximum threshold.
  • An engine speed derate will occur when the fault is registered.
  • If the problem persists for 5 minutes, an engine shutdown procedure will begin.

Conditions for Clearing the Fault Code

Once the ECM detects the pressure differential over the compressor seal has fallen below the maximum threshold, the fault code will go inactive.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable corrections to the calibration stored in the ECM. Refer to Procedure 019-032 (ECM Calibration) in Section 19.

Possible causes of this fault code include:

Crankcase filter needs to be changed.

  • If the crankcase filter is being changed frequently for this fault code, reference the Crankcase Coalescing Filter - Frequent Replacement troubleshooting symptom tree.
  • For ISM engines, reference the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, reference the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Air intake filter needs to be changed.

  • Refer to Procedure For ISM engines, 010-031 (Air Intake Restriction) in Section 10 of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 010-031 (Air Intake Restriction) in Section 10 of the Signature&trade;, ISX, and QSX15 Service Manual, Bulletin 3666239.

A plugged or restricted crankcase ventilation system.

  • Check the tube between the engine and the coalescing filter.
  • Check the draft tube going from the coalescing filter to the atmosphere or intake manifold.
  • Consider the working environment. Ice, snow, or mud can temporarily block the tube and then fall away.

Complete the entire troubleshooting tree whether Fault Code 629 is active or inactive.

  • If a problem is found in the early steps, the troubleshooting tree should still be completed.
Refer to Troubleshooting Fault Code t05-3348


Roll Over Protection Brake Control Active - Condition Exists

FAULT CODE 3374

Roll Over Protection Brake Control Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3374 PID: SPN: 1818 FMI: 31/11 LAMP: None SRT: | Roll Over Protection Brake Control Active - Condition Exists. The ECM received a message from the anti-lock braking (ABS) controller, inhibiting cruise control operation. | Cruise control could possibly not operate.
ISX and ISM - SAE J1939 Multiplexing Circuit - Anti-Lock Braking (ABS) Controller

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the electronic control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to ECM and cruise control will temporarily be disabled.

Component Location

The ECM is located on the fuel system side of the engine.Refer to Procedure 100-002 in Section E.

The SAE J1939 data link wiring and anti-lock braking (ABS) controller location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code is set when cruise control has been inhibited due to certain driving conditions detected by the anti-lock braking (ABS) controller.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Cruise control has temporarily been inhibited.

Conditions for Clearing the Fault Code

The fault code will be set inactive immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM for the engine being serviced. Refer to Procedure 019-032 in Section 19.

When this fault code is active, cruise control could possibly not function. This is an information only fault code, indicating that the anti-lock braking (ABS) controller detected certain driving conditions and temporarily inhibited cruise control operation.

Refer to Troubleshooting Fault Code t05-3374


Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3385

Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3385 PID: P105 SPN: 411 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. The intake manifold temperature is below a critical threshold | None.
ISX - Intake Manifold 1 Temperature Sensor Circuit
ISM - Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The engine intake manifold temperature value is used by the electronic control module (ECM) for the engine protection system and engine emissions control.

The ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or a low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The intake manifold temperature is less than 20°C [68°F] while the engine is operating at idle for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The EGR valve was closed because the engine was idling with cold intake manifold temperatures for an extended period of time.

Refer to Troubleshooting Fault Code t05-3385.

Last Modified: 01-Aug-2011


Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

FAULT CODE 3488

Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3488 PID: SPN: 563 FMI: 9/9 LAMP: Amber SRT: | Anti-Lock Braking (ABS) Controller - Abnormal Update Rate. The ECM expected information from an anti-lock braking (ABS) controller but did not receive it soon enough or did not receive it at all. | Cruise control could possibly not operate.
ISX and ISM - SAE J1939 Multiplexing Circuit - Anti-Lock Braking (ABS) Controller

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the electronic control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to ECM and cruise control will temporarily be disabled.

Component Location

The ECM is located on the fuel system side of the engine.Refer to Procedure 100-002 in Section E.

The SAE J1939 data link wiring and anti-lock braking (ABS) controller location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from the Anti-Locking Braking (ABS) Controller for more than 0.5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • Cruise control could possibly not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM for the engine being serviced. Refer to Procedure 019-032 in Section 19.

When this fault code is active, cruise control could possibly not function.

This fault is set active if the ECM does not receive the heartbeat message from the anti-lock braking (ABS) controller on the SAE J1939 data link.

This fault can occur for the following reasons:

  • This fault can also be caused by a malfunctioning J1939 data link connection between the anti-lock braking (ABS controller and Cummins® ECM, a malfunctioning connection between the component and the anti-lock braking (ABS) controller, malfunctioning anti-lock braking (ABS) controller or malfunctioning Cummins® ECM.
Refer to Troubleshooting Fault Code t05-3488


Engine Variable Geometry Turbocharger (VGT) Nozzle Position - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3616

Engine Variable Geometry Turbocharger (VGT) Nozzle Position - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3616 PID: SPN: 641 FMI: 7/7 LAMP: None SRT: | Engine VGT Nozzle Position - Mechanical System Not Responding or Out of Adjustment | VGT travel may be limited.
ISX - VGT Actuator Circuit
ISM - VGT Actuator Circuit

Circuit Description

The VGT is electronically activated by the VGT actuator. The VGT actuator is a smart device that receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports errors back to the primary ECM with the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is initially turned to the ON position.

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial KEY ON.

Conditions for Setting the Fault Codes

The internal position reference is not detected during the initial power-on learn due to mechanical system binding or internal condition. The actual VGT actuator position is not known.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.

The fault code will clear at key ON if the error condition no longer exists.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable corrections to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This is an information fault code indicating that the VGT actuator was unable to go to the desired position at key ON. While active, the ECM will continuously attempt to restore normal VGT operation until the engine coolant temperature reaches 74°C [165°F].

If the condition continues to exist after the coolant reaches 74°C [165°F], Fault Code 2387 will become active and Fault Code 3616 will become inactive. Fault Code 2346 may set due to a resulting fueling derate.

Inspect the turbocharger vanes for residue, and clean the vanes, if required. Find the source of the residue and repair.

Refer to Troubleshooting Fault Code t05-3616

Last Modified: 03-Oct-2012


Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3733

Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3733 PID: SPN: 862 FMI: 3 LAMP: Amber SRT: | Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the crankcase breather heater. | Crankcase breather heater not functioning correctly.
ISX - Crankcase Breather Filter Heater Circuit
ISM - Crankcase Breather Filter Heater Circuit

Circuit Description

The electronic control module (ECM) controls the crankcase breather filter heater by sending a signal. The ECM will only command the crankcase breather filter heater ON under certain operating conditions.

Component Location

The crankcase breather filter heater is located on the front cover of the crankcase breather filter housing. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

The feature must be enabled. It runs any time the ECM is keyed ON.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase breather heater signal voltage is greater than 1.5-VDC for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The crankcase breather heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable corrections to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

The ECM monitors the voltage level on this circuit.

Possible causes for this fault code include:

  • A short circuit to a voltage source
  • A damaged or missing heater element
  • Wiring harness issue
  • Pins incorrectly installed in harness
  • Damaged connectors.
Refer to Troubleshooting Fault Code t05-3733

Last Modified: 08-Nov-2013


Crankcase Breather Filter Heater Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3734

Crankcase Breather Filter Heater Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3734 PID: SPN: 862 FMI: 4 LAMP: Amber SRT: | Crankcase Breather Filter Heater Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the crankcase breather heater. | Crankcase breather heater not functioning correctly.
ISX - Crankcase Breather Filter Heater Circuit
ISM - Crankcase Breather Filter Heater Circuit

Circuit Description

The electronic control module (ECM) controls the crankcase breather filter heater by sending a signal. The ECM will only command the crankcase breather filter heater ON under certain operating conditions.

Component Location

The crankcase breather filter heater is located on the front cover of the crankcase breather filter housing. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

The feature must be enabled. It runs any time the ECM is keyed ON.

Conditions for Setting the Fault Codes

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The crank case breather heater will be disabled.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The crank case breather heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Malfunctioning ECM.
  • Open Crankcase Breather Heater Circuit
Refer to Troubleshooting Fault Code t05-3734

Last Modified: 08-Nov-2013


Fault Code Path Selection

FAULT CODE 16-fc2879
Fault Code Path Selection

Is the engine a CPL 3774 and 3775? | Go to 16-fc4214cpl_3774_3775
Is the engine a Non CPL 3774 and 3775? | Go to 16-fc4214non_cpl_3774_3775

Last Modified: 07-Mar-2014


Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Condition Exists

FAULT CODE 4282

Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4282 PID: Not Mapped SPN: 5298 FMI: 11/13 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Condition Exists. The temperature increase across the aftertreatment diesel oxidation catalyst is lower than expected. | None on performance. Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX CM871/ISM CM876 - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). See the equipment manufacturer information.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.
  • Active regeneration of the aftertreatment diesel particulate filter must be occurring before the diagnostic will run.

Conditions for Setting the Fault Codes

The engine control module (ECM) detects that the temperature differential across the aftertreatment diesel oxidation catalyst during active regeneration is not matching the expected temperature increase.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to perform INSITE™ electronic service tool Aftertreatment Reset procedure.
  • Perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.

Shop Talk

Verify that the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the temperature increase across the catalyst during an aftertreatment injection event is lower than expected.

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment diesel oxidation catalyst
  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst
  • Cracked or contaminated aftertreatment diesel oxidation catalyst
  • Malfunction in the aftertreatment fuel injection system
  • Leaking exhaust system between the turbocharger and the diesel oxidation catalyst.

An in-range malfunction of the aftertreatment diesel oxidation catalyst inlet temperature sensor or the aftertreatment diesel particulate filter inlet temperature sensor can cause this fault code. Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.

Refer to Troubleshooting Fault Code t05-4282.

Last Modified: 10-Mar-2014


Aftertreatment Doser - Data Valid But Below Normal Operating Range - Condition Exists

FAULT CODE 4283

Aftertreatment Doser - Data Valid But Below Normal Operating Range - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4283 PID: SPN: 3556 FMI: 11 LAMP: None SRT: | Aftertreatment Doser - Data Valid But Below Normal Operating Range - Condition Exists. | Possible ineffective regeneration of the aftertreatment diesel particulate filter.
ISX CM871/ISM CM876 - Aftertreatment Fuel Injector System

Circuit Description

The aftertreatment fuel injector is electronically controlled by the engine control module (ECM) through a pulse width modulated (PWM) signal. The amount of fuel injected is determined by how long the PWM signal to the injector is on.

Component Location

The aftertreatment fuel injector is located on the turbocharger adapter pipe.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

This fault code becomes active when the ECM detects that the aftertreatment fuel injector can not inject enough fuel for active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test. Once the temperatures in the aftertreatment system are high enough to inject diesel fuel into the exhaust, the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Dirty or damaged aftertreatment fuel injector
  • Leaking aftertreatment fuel drain valve.
Refer to Troubleshooting Fault Code t05-4283.

Last Modified: 10-Mar-2014


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187 (ISM)

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Engine power derate.
ISM - Sensor Supply 2 Circuit

Circuit Description

The sensor supply number 2 of the electronic control module (ECM) provides a 5-VDC SUPPLY sensor for the backup camshaft position sensor, exhaust gas pressure sensor, intake manifold pressure/temperature sensor, and the crankcase pressure sensor.

Component Location

Sensor supply number 2 is located in the ECM and provides a 5-VDC SUPPLY to various pressure sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 2 signal voltage is less than 4.75-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure sensor, the intake manifold pressure sensor, and the crankcase pressure sensor.
  • The backup camshaft position sensor will not be functional.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a failed sensor, or a failed ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

  • Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time, unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.
Refer to Troubleshooting Fault Code t05-187


Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 187 (ISX)

Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Engine will run derated. No engine protection for intake manifold air temperature.
ISX - Sensor Supply Voltage Number 2 Circuit

Circuit Description

The Sensor Supply Number 2 pin of the electronic control module (ECM) provides + 5-VDC for the camshaft position sensor, exhaust gas pressure sensor, rail fuel pressure sensor, intake manifold pressure/temperature sensor, and crankcase pressure sensor.

Component Location

Sensor Supply Number 2 is located in the ECM and provides a 5 volt supply to various pressure sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the sensor supply 2 signal voltage is less than 4.8-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure sensor, the intake manifold pressure sensor, and the crankcase pressure sensor.
  • The backup camshaft position sensor will not be functional.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a failed sensor, or a failed ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

  • Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time, unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.
Refer to Troubleshooting Fault Code t05-187


Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1925 (ISM)

Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1925 (ISM) PID: 334 SPN: 3482 FMI: 2 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect. An error has been detected in the aftertreatment fuel shutoff valve. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system as well as damaged aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold. The aftertreatment shutoff valve is located on the same side of the manifold as the aftertreatment pressure sensor. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs:

  • During the first 5 minutes of engine operation
  • Prior to injecting fuel for an active regeneration, but only if greater than 2 hours have elapsed since the previous regeneration event or key-on
  • After an active regeneration.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detected an internally leaking aftertreatment fuel shutoff valve.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Clear the fault code by starting and idling the engine for 5 minutes.

Note: It maybe necessary to operate the engine multiple times in order to purge air from the aftertreatment fuel system.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Internal leak of the aftertreatment fuel shutoff valve allowing fuel pressure to leak past the shutoff valve
  • Air trapped in the aftertreatment fuel system
  • Stuck open or closed aftertreatment fuel shutoff valve or aftertreatment fuel drain valve
  • Internal or external leak in the aftertreatment fuel shutoff valve or fuel drain valve
  • Internal or external leak in the aftertreatment fuel injector
  • Loose fittings in the aftertreatment fuel system
  • External fuel leaks in the aftertreatment fuel system
  • Third-party aftertreatment fuel shutoff valve manifold
  • Fuel filter plugged.
Refer to Troubleshooting Fault Code t05-1925

Last Modified: 21-Jul-2010


Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1925 (ISX)

Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1925 (ISX) PID: 334 SPN: 3482 FMI: 2 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect. An error has been detected in the aftertreatment fuel shutoff valve. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system as well as damaged aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold. The aftertreatment shutoff valve is located on the same side of the manifold as the aftertreatment pressure sensor. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs:

  • During the first 5 minutes of engine operation
  • Prior to injecting fuel for an active regeneration, but only if greater than 2 hours have elapsed since the previous regeneration event or key-on
  • After an active regeneration.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detected an internally leaking aftertreatment fuel shutoff valve.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Clear the fault code by starting and idling the engine for 5 minutes.

Note: It maybe necessary to operate the engine multiple times in order to purge air from the aftertreatment fuel system.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Internal leak of the aftertreatment fuel shutoff valve allowing fuel pressure to leak past the shutoff valve
  • Air trapped in the aftertreatment fuel system
  • Stuck open or closed aftertreatment fuel shutoff valve or aftertreatment fuel drain valve
  • Internal or external leak in the aftertreatment fuel shutoff valve or fuel drain valve
  • Internal or external leak in the aftertreatment fuel injector
  • Loose fittings in the aftertreatment fuel system
  • External fuel leaks in the aftertreatment fuel system
  • Third-party aftertreatment fuel shutoff valve manifold
  • Fuel filter plugged.
Refer to Troubleshooting Fault Code t05-1925

Last Modified: 21-Jul-2010


Coolant Level Sensor 1 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 195 (2-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
ISX and ISM - Engine Coolant Level Sensor 1 Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) supplies 5 volts to the coolant level signal circuit. The resistance of the engine coolant level sensor changes based on the coolant level. The sensor resistance is between 5.4k ohms and 34k ohms when the sensor is submersed in coolant. The sensor resistance is between 333k ohms and 880k ohms when the sensor is not sumbersed in coolant. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continously when the keyswitch is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than 5.124-VDC for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-195


Coolant Level Sensor 1 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 195 (3-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
ISX and ISM - Engine Coolant Level Sensor 1 Circuit

Circuit Description

The electronic control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than 4.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-195


Coolant Level Sensor 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 196 (2-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
ISX and ISM - Engine Coolant Level Sensor 1 Circuit

Circuit Description

The engine coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) supplies 5 volts to the coolant level signal circuit. The resistance of the engine coolant level sensor changes based on the coolant level. The sensor resistance is between 5.4k ohms and 34k ohms when the sensor is submersed in coolant. The sensor resistance is between 333k ohms and 880k ohms when the sensor is not submersed in coolant. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than 0.258-VDC for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Signal circuit shorted to ground or return in the harness, sensor or connectors.
Refer to Troubleshooting Fault Code t05-196


Coolant Level Sensor 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 196 (3-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
ISX and ISM - Coolant Level Sensor 1 Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than 0.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor.
  • Signal circuit shorted to ground in the engine harness, connector, or sensor.
  • Failed sensor.
Refer to Troubleshooting Fault Code t05-196


Aftertreatment Fuel Shutoff Valve 1 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1963 (ISM)

Aftertreatment Fuel Shutoff Valve 1 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1963 (ISM) PID: 332 SPN: 3482 FMI: 7 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 - Mechanical System Not Responding Properly or Out of Adjustment. The aftertreatment fuel shutoff valve has been detected to be stuck closed. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system, as well as failures of the aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel injector then briefly opens and relieves some of the fuel pressure trapped between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold. Refer to Procedure 100-002 in Section E .

Conditions for Running the Diagnostics

This diagnostic runs:

  • During the first 5 minutes of engine operation
  • Prior to injecting fuel for an active regeneration, but only if greater than 2 hours have elapsed since the previous regeneration event or key-on
  • After an active regeneration.

Conditions for Setting the Fault Codes

The electronic control module (ECM) has detected that the aftertreatment fuel shutoff valve has been detected to be stuck closed.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Clear the fault code by starting and idling the engine for 5 minutes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Stuck closed aftertreatment fuel shutoff valve
  • Fuel restriction between the fuel system and the aftertreatment fuel shutoff valve assembly
  • On ISM engines, remove the aftertreatment fuel line connection from the cylinder head. Inspect the fuel rail in the cylinder head for a plastic plug or ”stringer” that may be blocking the fuel supply to the aftertreatment system
  • Fuel filter plugged.
Refer to Troubleshooting Fault Code t05-1963


Aftertreatment Fuel Shutoff Valve 1 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1963 (ISX)

Aftertreatment Fuel Shutoff Valve 1 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1963 (ISX) PID: 332 SPN: 3482 FMI: 7 LAMP: Amber SRT: | Aftertreatment Fuel Shutoff Valve 1 - Mechanical System Not Responding Properly or Out of Adjustment. The aftertreatment fuel shutoff valve has been detected to be stuck closed. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system, as well as failures of the aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel injector then briefly opens and relieves some of the fuel pressure trapped between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs:

  • During the first 5 minutes of engine operation
  • Prior to injecting fuel for an active regeneration, but only if greater than 2 hours have elapsed since the previous regeneration event or key-on
  • After an active regeneration.

Conditions for Setting the Fault Codes

The electronic control module (ECM) has detected that the aftertreatment fuel shutoff valve has been detected to be stuck closed.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Clear the fault code by starting and idling the engine for 5 minutes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Stuck closed aftertreatment fuel shutoff valve
  • Fuel restriction between the fuel system and the aftertreatment fuel shutoff valve assembly
  • On ISM engines, remove the aftertreatment fuel line connection from the cylinder head. Inspect the fuel rail in the cylinder head for a plastic plug or ”stringer” that may be blocking the fuel supply to the aftertreatment system
Refer to Troubleshooting Fault Code t05-1963


Aftertreatment Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1981 (CPL 3774 and 3775)

Aftertreatment Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1981 PID: S324 SPN: 3251 FMI: 0/15 LAMP: Amber SRT: | Aftertreatment Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The aftertreatment differential pressure has exceeded the maximum operating limits or the diesel particulate filter is plugged. | EGR valve operation will be disabled. Active regeneration will be disabled.
ISX and ISM - Aftertreatment Differential Pressure

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). See equipment manufacturer service information.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm and when the calculated exhaust flow is above a calibratible value.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the aftertreatment diesel particulate filter is plugged or that the differential pressure across the aftertreatment diesel particulate filter is above the maximum limits.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light after the diagnostic runs and fails
  • The exhaust gas recirculation (EGR) valve operation will be disabled
  • Active and stationary (parked) regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light after the differential pressure across the aftertreatment diesel particulate filter has dropped below the maximum severity level, when the calculated exhaust flow is above a calibratible value.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable changes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

An engine torque derate for extended EGR valve closed operation exists for this fault code. The engine torque derate for extended EGR valve closed operation operates on a time based system. The time based system will count up anytime a fault code that closes the EGR valve is active. Once the timer reaches 20 hours, an engine torque derate of approximately 15 percent will be applied.

The engine torque derate will be removed as soon as the fault code goes inactive, and the timer will begin to count down. If the fault code reoccurs within the next 20 hours of engine operation, the engine torque derate will immediately be applied, and the timer will then reset to 20 hours. The engine must operate for 20 hours with no active faults that close the EGR valve for the timer to clear. After the timer has cleared, the engine must then operate for another 20 hours with an active fault code that closes the EGR valve to apply the derate.

This fault code indicates that the soot load inside the aftertreatment diesel particulate filter has reached the maximum level. Regeneration of the aftertreatment diesel particulate filter at this stage is not possible. The aftertreatment diesel particulate filter must be inspected. If it meets the inspection criteria, it can be cleaned using an SPX air pulse cleaning machine (or equivalent machine). If it does not meet the inspection criteria, it must be replaced.

Possible causes of this fault code include:

  • The aftertreatment diesel particulate filter can be plugged with soot.
  • The engine has been operating in light load conditions that prevent exhaust temperatures from being high enough to actively regenerate the aftertreatment particulate filter.
  • The aftertreatment wiring harness connectors could be connected to the wrong aftertreatment exhaust gas temperature sensor.
  • The aftertreatment wiring harness or aftertreatment exhaust gas temperature sensor connector pin installation could be incorrect.
  • The aftertreatment diesel particulate filter differential pressure sensor has malfunctioned.
  • An engine malfunction that is elevating the engine smoke output.
  • The aftertreatment diesel particulate filter can accumulate an excessive amount of ash in a short time period. This can be due to excessive oil consumption or due to non-combustible elements such as, but not limited to, iron, potassium, or calcium contained in fuel additives.
Refer to Troubleshooting Fault Code t05-1981 (CPL 3774 and 3775).

Last Modified: 04-Mar-2014


Aftertreatment Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1981 (Non CPL 3774 and 3775)

Aftertreatment Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1981 PID: S324 SPN: 3251 FMI: 0/15 LAMP: Amber SRT: | Aftertreatment Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The aftertreatment differential pressure has exceeded the maximum operating limits or the diesel particulate filter is plugged. | Exhaust gas recirculation (EGR) valve operation will be disabled. Active regeneration will be disabled.
ISX and ISM - Aftertreatment Differential Pressure

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm and when the calculated exhaust flow is above a calibratible value.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the aftertreatment diesel particulate filter is plugged or that the differential pressure across the aftertreatment diesel particulate filter is above the maximum limits.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE light after the diagnostic runs and fails.
  • The EGR valve operation will be disabled.
  • Active and stationary (parked) regeneration will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light after the differential pressure across the aftertreatment diesel particulate filter has dropped below the maximum severity level, when the calculated exhaust flow is above a calibratible value.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable changes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

An engine torque derate for extended EGR valve closed operation exists for this fault code. The engine torque derate for extended EGR valve closed operation operates on a time based system. The time based system will count up anytime a fault code that closes the EGR valve is active. Once the timer reaches 20 hours, an engine torque derate of approximately 15 percent will be applied.

The engine torque derate will be removed as soon as the fault code goes inactive, and the timer will begin to count down. If the fault code reoccurs within the next 20 hours of engine operation, the engine torque derate will immediately be applied, and the timer will then reset to 20 hours. The engine must operate for 20 hours with no active faults that close the EGR valve for the timer to clear. After the timer has cleared, the engine must then operate for another 20 hours with an active fault code that closes the EGR valve to apply the derate.

This fault code indicates that the soot load inside the aftertreatment diesel particulate filter has reached the maximum level. Regeneration of the aftertreatment diesel particulate filter at this stage is not possible. The aftertreatment diesel particulate filter must be inspected. If it meets the inspection criteria, it can be cleaned using an SPX air pulse cleaning machine, or equivalent machine. If it does not meet the inspection criteria, it must be replaced.

Possible causes of this fault code include:

  • The aftertreatment diesel particulate filter can be plugged with soot.
  • The engine has been operating in light load conditions that prevent exhaust temperatures from being high enough to actively regenerate the aftertreatment particulate filter.
  • The aftertreatment wiring harness connectors could be connected to the wrong aftertreatment exhaust gas temperature sensor.
  • The aftertreatment wiring harness or aftertreatment exhaust gas temperature sensor connector pin installation could be incorrect.
  • The aftertreatment diesel particulate filter differential pressure sensor has malfunctioned.
  • An engine malfunction that is elevating the engine smoke output.
  • The aftertreatment diesel particulate filter can accumulate an excessive amount of ash in a short time period. This can be due to excessive oil consumption or due to non-combustible elements such as, but not limited to, iron, potassium, or calcium contained in fuel additives.
Refer to Troubleshooting Fault Code t05-1981 (Non CPL 3774 and 3775).

Last Modified: 04-Mar-2014


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2363 (ISM)

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S080 SPN: 1073 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brakes on cylinders number 4, 5, and 6 can not be activated.
ISM - Engine Brake Solenoid Number 2 Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinders number 4, 5, and 6 by sending a signal on engine brake signal number 2 circuit. The ECM will only command the brakes on under certain operating conditions.

Component Location

The engine brake solenoids are located under the rocker lever cover. The engine brake solenoids are controlled through the engine harness from the ECM. The engine harness passes through the rocker lever housing on the front of the engine and is connected to the engine brake solenoids through a 3-pin breakout connector located between cylinders 2 and 3.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The engine brake solenoid pulse width modulated (PWM) signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid 2 will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes for this fault include:

  • A short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2363

Last Modified: 21-Jul-2010


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2363 (ISX)

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S080 SPN: 1073 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the engine brake solenoid Number 2 signal circuit. | Engine brake on cylinders Number 2 and 3 can not be activated.
ISX - Engine Brake Solenoid 2 Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinders Number 2 and 3 by sending a signal on engine brake signal Number 2 circuit. The ECM will only command the brakes on under certain operating conditions.

Component Location

The engine brake solenoids are located under the rocker lever cover. The 8-pin engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The engine brake solenoid pulse width modulated (PWM) signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid 2 will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes for this fault include:

  • A short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2363


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2367 (ISM)

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S080 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal, or Shorted to High Source. Open circuit or high voltage detected at the engine brake solenoid Number 2 signal circuit. | Engine brakes on cylinders 4, 5, and 6 can not be deactivated, or can not be activated.
ISM - Engine Brake Solenoid Number 2 Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinders 4, 5, and 6 by sending a signal on engine brake solenoid number 2 signal circuit. The ECM will only command the brakes on under certain operating conditions.

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Component Location

The engine brake solenoids are located under the rocker lever cover. The engine brake solenoids are controlled through the engine harness from the ECM. The engine harness passes through the rocker lever housing on the front of the engine and is connected to the engine brake solenoids through a 3-pin breakout connector located between cylinders 2 and 3.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The engine brake solenoid pulse width modulated (PWM) signal is detected to be greater than 0 volts when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid can not be energized.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault include:

  • An open circuit in the engine harness, brake harness, or engine brake solenoids.
  • A short to voltage source in the engine harness.
  • A failed ECM.
Refer to Troubleshooting Fault Code t05-2367


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2367 (ISX)

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S080 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal, or Shorted to High Source. Open circuit or high voltage detected at the engine brake solenoid Number 2 signal circuit. | Engine brakes on cylinders number 2 and 3 can be on all the time, or can not be activated.
ISX - Engine Brake Solenoid Number 2 Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinders 2 and 3 by sending a signal on engine brake solenoid number 2 signal circuit. The ECM will only command the brakes on under certain operating conditions.

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Component Location

The engine brake solenoids are located under the rocker lever cover. The 8-pin engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn.Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The engine brake solenoid pulse width modulated (PWM) signal is detected to be greater than 0 volts when the PWM signal is turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine brake solenoid 2 can not be energized.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible causes of this fault include:

  • An open circuit in the engine harness, brake harness, or engine brake solenoids.
  • A short to voltage source in the engine harness.
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code t05-2367


Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 257 (ISM)

Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 257 (ISM) PID: S017 SPN: 632 FMI: 7/7 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment. Fuel shutoff valve is stuck open mechanically or leaking. | Engine will run derated. The engine may run on for a brief period when the keyswitch is turned OFF.
Engine Fuel Shutoff Valve

Circuit Description

Voltage is supplied to the fuel shutoff valve by the electronic control module (ECM) while the engine keyswitch is ON. While the keyswitch is turned OFF, the voltage to the fuel shutoff valve is turned off by the ECM. The fuel shutoff valve closes and stops fuel from flowing to the fuel system.

Component Location

The fuel shutoff valve is located on the fuel system. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned to the OFF position.

Conditions for Setting the Fault Codes

Engine speed is greater than a calibratable after the keyswitch is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using the INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Upon turning the keyswitch OFF, the ECM turns off the voltage supplied to keep the fuel shutoff valve open. The fuel control continues to fire the injectors for a short period of time as the engine speeds down. The ECM monitors engine speed using the engine position sensor during this time. If the engine speed does not drop after the keyswitch is turned OFF, the ECM activates this fault. A possible cause of this fault code is extra wires attached to the fuel shutoff valve.

Refer to Troubleshooting Fault Code t05-257


Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 257 (ISX)

Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 257 (ISX) PID: S017 SPN: 632 FMI: 7/7 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment. Fuel shutoff valve is stuck open mechanically or leaking. | Engine will run derated. The engine may run on for a brief period when the keyswitch is turned OFF.
Engine Fuel Shutoff Valve

Circuit Description

Voltage is supplied to the fuel shutoff valve by the electronic control module (ECM) while the engine keyswitch is ON. While the keyswitch is turned OFF, the voltage to the fuel shutoff valve is turned off by the ECM. The fuel shutoff valve closes and stops fuel from flowing to the fuel system.

Component Location

The fuel shutoff valve is located on the fuel system. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned to the OFF position.

Conditions for Setting the Fault Codes

Fuel pressure is greater than a calibratable value after the keyswitch is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and the fault code state will become inactive immediately after the diagnostic runs and passes. The fault code can also be cleared using the INSITE™ electronic service tool.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19. This procedure is found in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Upon turning the keyswitch OFF, the ECM turns off the voltage supplied to keep the fuel shutoff valve open. The ECM continues to fire the fueling and timing actuators for a short period of time as the engine spins down. The ECM monitors rail fuel pressure using the rail fuel pressure sensor during this time. If the rail fuel pressure does not drop after the keyswitch is turned OFF, the ECM activates this fault.

Refer to Troubleshooting Fault Code t05-257


Aftertreatment Fuel Drain Valve - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 2878 (ISM)

Aftertreatment Fuel Drain Valve - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2878 (ISM) PID: 381 SPN: 4097 FMI: 7 LAMP: Amber SRT: | Aftertreatment Fuel Drain Valve - Mechanical System Not Responding Properly or Out of Adjustment. The aftertreatment fuel shutoff drain valve has been detected to be stuck closed. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system as well as failures of the aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel injector then briefly opens and relieves some of the fuel pressure trapped between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs:

  • During the first 5 minutes of engine operation
  • Prior to injecting fuel for an active regeneration, but only if greater than 2 hours have elapsed since the previous regeneration event or key-on
  • After an active regeneration.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects a stuck closed aftertreatment fuel drain valve.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Clear the fault code by starting and idling the engine for 5 minutes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

Possible cause of this fault code includes:

  • Stuck closed aftertreatment fuel drain valve
  • Restricted aftertreatment fuel drain line
  • Fuel filter plugged.
Refer to Troubleshooting Fault Code t05-2878


Aftertreatment Fuel Drain Valve - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 2878 (ISX)

Aftertreatment Fuel Drain Valve - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2878 (ISX) PID: 381 SPN: 4097 FMI: 7 LAMP: Amber SRT: | Aftertreatment Fuel Drain Valve - Mechanical System Not Responding Properly or Out of Adjustment. The aftertreatment fuel shutoff drain valve has been detected to be stuck closed. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system as well as failures of the aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel injector then briefly opens and relieves some of the fuel pressure trapped between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs:

  • During the first 5 minutes of engine operation
  • Prior to injecting fuel for an active regeneration, but only if greater than 2 hours have elapsed since the previous regeneration event or key-on
  • After an active regeneration.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects a stuck closed aftertreatment fuel drain valve.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Clear the fault code by starting and idling the engine for 5 minutes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible cause of this fault code includes:

  • Stuck closed aftertreatment fuel drain valve
  • Restricted aftertreatment fuel drain line
  • Fuel filter plugged.
Refer to Troubleshooting Fault Code t05-2878


Aftertreatment Fuel Drain Valve - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2879 (ISM)

Aftertreatment Fuel Drain Valve - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2879 (ISM) PID: S381 SPN: 4097 FMI: 2 LAMP: Amber SRT: | Aftertreatment Fuel Drain Valve - Data Erratic, Intermittent, or Incorrect. An internal or external fuel leak has been detected in the aftertreatment fuel system. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system as well as failures of the aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel injector then briefly opens and relieves some of the fuel pressure trapped between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs:

  • During the first 5 minutes of engine operation
  • Prior to injecting fuel for an active regeneration, but only if greater than 2 hours have elapsed since the previous regeneration event or key-on
  • After an active regeneration.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects an external fuel leak in the aftertreatment fuel system, internal fuel leakage past the aftertreatment fuel drain valve, or an aftertreatment fuel injector that may be leaking fuel into the exhaust system.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Internal or external leak in the aftertreatment fuel drain valve
  • Internal or external leak in the aftertreatment fuel injector
  • Loose fittings in the aftertreatment fuel system
  • External fuel leaks in the aftertreatment fuel system
  • Third-party aftertreatment fuel shutoff valve manifold
  • Fuel filter plugged.
Refer to Troubleshooting Fault Code t05-2879


Aftertreatment Fuel Drain Valve - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2879 (ISX)

Aftertreatment Fuel Drain Valve - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2879 (ISX) PID: S381 SPN: 4097 FMI: 2 LAMP: Amber SRT: | Aftertreatment Fuel Drain Valve - Data Erratic, Intermittent, or Incorrect. An internal or external fuel leak has been detected in the aftertreatment fuel system. | Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX and ISM - Aftertreatment Fuel Injector System

Circuit Description

This fault code checks for system errors in the aftertreatment fuel injection system. This diagnostic can detect fuel leaks in the system as well as failures of the aftertreatment fuel injector, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve.

Every time the engine is started, a diagnostic test on the system is performed. The aftertreatment fuel drain valve opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel drain valve closes and the aftertreatment fuel shutoff valve opens. This pressurizes the aftertreatment fuel system to gear pump operating pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading gear pump operating pressure. The aftertreatment fuel shutoff valve then closes and traps the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure. The aftertreatment fuel injector then briefly opens and relieves some of the fuel pressure trapped between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The aftertreatment fuel drain valve then opens and relieves the remaining pressure in the system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger outlet flange. The aftertreatment fuel pressure sensor, aftertreatment fuel shutoff valve, and aftertreatment fuel drain valve are installed in the shutoff valve manifold. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs:

  • During the first 5 minutes of engine operation
  • Prior to injecting fuel for an active regeneration, but only if greater than 2 hours have elapsed since the previous regeneration event or key-on
  • After an active regeneration.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects an external fuel leak in the aftertreatment fuel system, internal fuel leakage past the aftertreatment fuel drain valve, or an aftertreatment fuel injector that may be leaking fuel into the exhaust system.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails.
  • Active regeneration of the aftertreatment diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Possible causes of this fault code include:

  • Internal or external leak in the aftertreatment fuel drain valve
  • Internal or external leak in the aftertreatment fuel injector
  • Loose fittings in the aftertreatment fuel system
  • External fuel leaks in the aftertreatment fuel system
  • Third-party aftertreatment fuel shutoff valve manifold
  • Fuel filter plugged.
Refer to Troubleshooting Fault Code t05-2879


Aftertreatment 1 Diesel Oxidation Catalyst System - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4214 (CPL 3774 and 3775)

Aftertreatment 1 Diesel Oxidation Catalyst System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4214 PID: Not Mapped SPN: 5018 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment 1 Diesel Oxidation Catalyst System - Data Valid But Below Normal Operating Range - Moderately Severe Level | None on performance. Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). See equipment manufacturer service information.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.
  • Active regeneration of the aftertreatment diesel particulate filter must be occurring before the diagnostic will run.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the temperature differential across the aftertreatment diesel oxidation catalyst during active regeneration is not matching the expected temperature increase.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to perform INSITE™ electronic service tool Aftertreatment Reset procedure.
  • Perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.

Shop Talk

Verify that the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the temperature increase across the catalyst during an aftertreatment injection event is lower than expected.

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment diesel oxidation catalyst
  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst
  • Cracked or contaminated aftertreatment diesel oxidation catalyst
  • Malfunction in the aftertreatment fuel injection system
  • Leaking exhaust system between the turbocharger and the diesel oxidation catalyst.

An in-range malfunction of the aftertreatment diesel oxidation catalyst inlet temperature sensor or the aftertreatment diesel particulate filter inlet temperature sensor can cause this fault code. Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.

Refer to Troubleshooting Fault Code t05-4214 (CPL 3774 and 3775).

Last Modified: 04-Mar-2014


Aftertreatment 1 Diesel Oxidation Catalyst System - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4214 (Non CPL 3774 and 3775)

Aftertreatment 1 Diesel Oxidation Catalyst System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4214 PID: Not Mapped SPN: 5018 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment 1 Diesel Oxidation Catalyst System - Data Valid But Below Normal Operating Range - Moderately Severe Level | None on performance. Active aftertreatment diesel particulate filter regeneration will be disabled.
ISX - Aftertreatment Temperature Sensors

Circuit Description

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst inlet temperature sensor is located after the turbocharger outlet at the inlet of the aftertreatment system. The aftertreatment diesel particulate filter inlet temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the keyswitch is in the ON position and when the engine is running.
  • Active regeneration of the aftertreatment diesel particulate filter must be occurring before the diagnostic will run.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects that the temperature differential across the aftertreatment diesel oxidation catalyst during active regeneration is not matching the expected temperature increase.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to perform INSITE™ electronic service tool Aftertreatment Reset procedure.
  • Perform INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.

Shop Talk

Verify that the ECM calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code is logged when the temperature increase across the catalyst during an aftertreatment injection event is lower than expected.

Possible causes of this fault code include:

  • Soot plugging the front face of the aftertreatment diesel oxidation catalyst
  • Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst
  • Cracked or contaminated aftertreatment diesel oxidation catalyst
  • Malfunction in the aftertreatment fuel injection system
  • Leaking exhaust system between the turbocharger and the diesel oxidation catalyst.

An in-range malfunction of the aftertreatment diesel oxidation catalyst inlet temperature sensor or the aftertreatment diesel particulate filter inlet temperature sensor can cause this fault code. Make sure there are not any fault codes related to the aftertreatment temperature sensors before following this troubleshooting tree.

Refer to Troubleshooting Fault Code t05-4214 (Non CPL 3774 and 3775).

Last Modified: 04-Mar-2014


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689 (ISM)

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Loss of signal from primary camshaft engine position sensor. | Engine can run rough. Possibly poor starting capability. Engine runs using backup speed sensor. Engine power is reduced.
ISM - Camshaft Engine Speed Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 VDC supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft tone wheel passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

Both engine position sensors are located on the back side of the front gear housing above the fuel pump drive. The primary engine position sensor (Number 1) is located above the backup engine position sensor (Number 2). Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the camshaft speed/position sensor for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The camshaft speed sensor is used to provide engine speed and position information to the ECM.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the camshaft speed/position sensor.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault is logged when the ECM does not receive a valid engine speed signal. Both primary and backup engine position sensors use identical connectors on the engine wiring harness. Be sure you are examining the proper connector on the engine harness.

Possible causes of this fault code include:

  • Open or short circuit in the engine harness or connectors.
  • Open or short circuit in the engine position sensor Number 1.
  • Signal circuit short to voltage source in the engine harness.
  • Damaged or failed engine position sensor.
Refer to Troubleshooting Fault Code t05-689


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689 (ISX)

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine speed signal. | Engine power derate.
ISX - Engine Crankshaft Speed/Position

Circuit Description

The electronic control module (ECM) provides a 5 VDC supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The engine speed sensor is located on the side of the front gear housing on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the crankshaft speed/position sensor for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The camshaft speed sensor is used to provide engine speed and position information to the ECM.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the crankshaft speed/position sensor.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault is logged when the ECM does not receive a valid engine speed signal.

Causes of this fault include:

  • Open or short circuit of the +5 volt supply, signal, or return wire in the engine harness.
  • Damaged or failed engine speed sensor.
Refer to Troubleshooting Fault Code t05-689


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778 (ISM)

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S064 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the camshaft position sensor signal. | Engine can run rough. Possibly poor starting capability. Engine runs using primary engine position sensor.
ISM - Engine Camshaft Speed/Position

Circuit Description

The electronic control module (ECM) provides a 5 VDC supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine camshaft speed/position signal is lost.

Component Location

Both engine position sensors are located on the back side of the front gear housing above the fuel pump drive. The Primary engine position sensor (Number 1) is located above the backup engine position sensor (Number 2). Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the camshaft speed/position sensor for more than one second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the camshaft speed/position sensor.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault is logged when the ECM does not receive a valid engine speed signal. Both primary and backup engine position sensors use identical connectors on the engine wiring harness. Be sure you are examining the proper connector on the engine harness.

Possible causes of this fault code include:

  • Open or short circuit in the engine harness or connectors.
  • Open or short circuit in the engine position sensor Number 2.
  • Signal circuit short to voltage source in the engine harness.
  • Damaged or failed engine position sensor.
Refer to Troubleshooting Fault Code t05-778


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778 (ISX)

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S064 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the camshaft position sensor signal. | Engine can run rough. Possibly poor starting capability. Engine runs using primary engine position sensor.
ISX - Engine Camshaft Speed/Position Sensor

Circuit Description

The electronic control module (ECM) provides 5 VDC supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor is located on the intake side of the engine in the cylinder head to the right of the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the camshaft speed/position sensor for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the ECM detects a valid signal from the camshaft speed/position sensor.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 (ECM Calibration Code) in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault is logged when the ECM does not receive a valid camshaft position signal.

Causes of this fault include:

  • Open or short circuit of the +5 volt supply, signal, or return wire in the engine harness.
  • Damaged or malfunctioning camshaft position sensor.
Refer to Troubleshooting Fault Code t05-778


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 421. | Active or inactive counts of Fault Code 421?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 421.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 421?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS of the appropriate service manual.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Nov-2014


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 10 counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 inactive?
YES NO
No Repair

Refer to Procedure Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than 10 counts?
YES NO
No Repair

Refer to Procedure Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 2B

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 111 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 115. | Active or High inactive counts of Fault Code 115?
STEP 2. | Clear the Fault Code. |
 | STEP 2A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 2B. Clear the fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 115.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or High inactive counts of Fault Code 115?
YES NO

Swap the engine position sensor connectors.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 115 is inactive.

Fault Code 115 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Action

Clear the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor.

Refer to Procedure 019-159 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 06-Dec-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor.

Refer to Procedure 019-159 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual
  • Replace the ECM
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual
  • Replace the ECM
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 123 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 125 - Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | High active or inactive counts of Fault Code 122, 123, 221, 222, 295, or 687?
 | STEP 1B. Check for active fault codes. | High active or inactive counts of fault codes that are related to the turbocharger or exhaust gas recirculation (EGR) valve system?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge-air cooler and charge-air plumbing for leaks. | Air leaks present in the charge-air system?
 | STEP 2B. Check for a restricted charge-air cooler. | Charge-air cooler restriction within specifications?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Check the intake manifold pressure sensor. | INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
STEP 4. | Check for restriction. |
 | STEP 4A. Check the exhaust system restriction. | Exhaust restriction within specifications?
 | STEP 4B. Check the intake restriction. | Air intake restriction within specifications?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 122, 123, 221, 222, 295, or 687?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the turbocharger or the EGR valve.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of fault codes that are related to the turbocharger or EGR valve system?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge-air cooler and charge-air plumbing for leaks.

Conditions

  • Operate engine.

Action

Check the charge-air cooler and charge air plumbing for leaks.

  • Check the charge-air cooler connections for leaks between the turbocharger compressor outlet and the charge-air cooler.
  • Check the charge-air cooler connections between the charge-air cooler and the intake manifold.
  • Check the air compressor inlet plumbing connections between the charge-air cooler and air compressor head for leaks.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge-air cooler hoses for leaks or loose connections.
  • Inspect the charge-air cooler clamps to make sure they are tight.
  • Inspect the charge-air plumbing for cracks.

Air leaks present in the charge-air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a restricted charge-air cooler.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the pressure differential across the charge-air cooler.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-027 in Section 10.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-027 in Section 10.

Charge-air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler as necessary.

Go to 3A

Go to 5A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and run the engine at high idle after connecting the mechanical intake manifold pressure gauge.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Remove and clean the intake manifold pressure sensor. Refer to Procedure 019-159 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for restriction.

Guided Step 4A - Check the exhaust system restriction.

Conditions

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-009 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-009 in Section 11.

Action

Check the exhaust system restriction.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-009 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-009 in Section 11.

Exhaust restriction within specifications?
YES NO
No Repair

Continue to investigate the cause of the high exhaust restriction.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-009 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-009 in Section 11.

Go to 4B

Go to 5A

Guided Step 4B - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-031 in Section 10.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-031 in Section 10.

Air intake restriction within specifications?
YES NO

Continue to troubleshoot the cause of low boost pressure.

  • Reference the Intake Manifold Pressure (Boost) is Below Normal troubleshooting Symptom tree in Section TS in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Reference the Intake Manifold Pressure (Boost) is Below Normal troubleshooting symptom tree in Section TS in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.

Repair or replace the restricted component

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Jun-2013


FAULT CODE 131 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 131 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 2185 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 n Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position sensor +5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Use the OEM diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES NO

A malfunctioning accelerator pedal or lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal or lever.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 131 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 132 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 or 2186 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position +5 volt SUPPLY pin to the accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Use the OEM diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal position +5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Use the OEM diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES NO

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 132 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 133 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 or 1696 active?
 | STEP 1B. Check for an active fault code. | Fault Code 133 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response. | Fault Code 134 active and Fault Code 133 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 133 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 133 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 or 1696 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 1695 or 1696 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the remote accelerator pedal or lever position sensor +5 volt SUPPLY pin to the remote accelerator pedal or lever position sensor RETURN pin at the sensor connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active and Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES NO

A damaged remote accelerator pedal or lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the remote accelerator pedal or lever.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever RETURN pin and the OEM harness remote accelerator pedal or lever RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 133 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 134 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 443 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 134 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal or lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 or 2186 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 443 or 2186 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal or lever position +5 volt SUPPLY pin to the accelerator pedal or lever position RETURN pin at the sensor connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal or lever position +5 volt SUPPLY pin and the accelerator pedal or lever position SIGNAL pin at the sensor connector of the OEM harness.

Check for the appropriate ECM response after 30 seconds.

Use the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active and Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal or lever has been detected.

Replace the remote accelerator pedal or lever.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SUPPLY pin and the OEM harness remote accelerator pedal or lever connector SUPPLY pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SIGNAL pin and the OEM harness remote accelerator pedal or lever connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 134 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A defective sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open RETURN or a pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Refer to the Lubricating Oil Pressure Low troubleshooting symptom tree.

  • For ISM engines, refer to the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, refer to the Signature&trade;, ISX and QSX15 Service Manual, Bulletin 3666239.

 No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 09-Jul-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following proceure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor.

Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following proceure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Jan-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A defective sensor has been detected.

Replace the engine coolant temperature sensor.

Refer to 019-019 (Engine Coolant Temperature Sensor) in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check |
 | STEP 1A. Check for coolant temperature fault code. | Fault Code 144 or 145 active?
 | STEP 2B. Monitor coolant temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check ECM calibration and clear fault code. |
 | STEP 2A. Check if an ECM calibration update is available | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for coolant temperature sensor fault codes.

Guided Step 1A - Check for coolant temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for coolant temperature sensor fault codes.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.

Fault Code 144 or 145 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 144 or 145.

Go to 1B

Guided Step 1B - Monitor coolant temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INISTE™ electronic service tool.

Action

Monitor the coolant temperature.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal symptom tree.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for coolant temperature fault code. |
 | STEP 1A. Check for coolant temperature fault code. | Fault Code 144 or 145 active?
 | STEP 1B. Monitor coolant temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check ECM calibration and clear fault code. |
 | STEP 2A. Check if an ECM calibration update is available | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for coolant temperature fault code

Guided Step 1A - Check for coolant temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for coolant temperature sensor fault codes.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.

Fault Code 144 or 145 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 144 or 145 active.

Go to 1B

Guided Step 1B - Monitor coolant temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™

Action

Monitor the coolant temperature.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool to a mechanical gauge or a know value?
YES NO

Refer to the Engine Coolant Temperature Above Normal symptom tree.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Appropriate troubleshooting symptom tree.

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pac™k test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 1.6k ohms to 3.1k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the intake manifold air temperature sensor.

Note: When measuring the resistance for the sensor, use the following temperature versus resistance specifications.

  • 15°C [59°F] = 3.10k ohms
  • 20°C [68°F] = 2.45k ohms
  • 25°C [77°F] = 2.01k ohms
  • 30°C [86°F] = 1.67k ohms

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance measurement techniques, use a wiring diagram and the following procedure. 019-360 in Section 19 and a wiring diagram.

1.6k ohms to 3.1k ohms?
YES NO
No Repair

Replace the intake manifold air temperature sensor.

Refer to 019-159 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance measurement techniques, use a wiring diagram and the following procedure. 019-360 in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance measurement techniques, use a wiring diagram and the following procedure. 019-360 in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance measurement techniques, use a wiring diagram and the following procedure. 019-360 in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

Refer to Procedure 019-159 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance measurement techniques, use a wiring diagram and the following procedure. Refer to Procedure 019-360 in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Intake Manifold Air Temperature Above Specification symptom tree.

  • For ISM engines, refer to the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, refer to the Signature&trade;, ISX, and QSX15 Service Manual, Bulletin 3666239.

Replace the intake manifold air temperature sensor.

Refer to Procedure 019-159 in Section 19.

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 09-Jul-2010


FAULT CODE 187 (ISM) - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 2. | Check the sensors and circuits connected to the sensor number 2 supply and return. |
 | STEP 2A. Inspect the intake manifold pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the exhaust gas pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the crankcase pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the engine position sensor number 2 and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the sensors and circuits connected to the sensor number 2 supply and return.

Guided Step 2A - Inspect the intake manifold pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold pressure sensor.

Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the exhaust gas pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and the exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and the crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pine?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine position sensor number 2 and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor number 2 from the engine harness.

Action

Inspect the engine harness and the engine position sensor number 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor number 2 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the engine position sensor number 2.

Refer to Procedure 019-038 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor Number 2 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 187 active?
 | STEP 2C. Inspect the intake manifold pressure sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the crankcase pressure sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the rail fuel pressure sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response |
 | STEP 2F. Inspect the exhaust gas pressure sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the sensors and circuits connected to the sensor Number 2 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to Procedure 019-363 (Camshaft Position Sensor) in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the intake manifold pressure sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159 (Intake Manifold Pressure/Temperature Sensor) in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the crankcase pressure sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 (Crankcase Pressure Sensor) in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the rail fuel pressure sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 is active?
YES NO
No Repair

Replace the rail fuel pressure sensor.

Refer to Procedure 019-115 (Rail Fuel Pressure Sensor) in Section 19.

Go to 2F

Go to 4A

Guided Step 2F - Inspect the exhaust gas pressure sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 is active?
YES NO
No Repair

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 (Exhaust Gas Pressure Sensor) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 195 (2 wire) - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 800k ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant level SIGNAL pin and the engine coolant level RETURN pin at the engine coolant level sensor connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 800k ohms?
YES NO

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the engine coolant level sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant level SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 195 Three Wire Sensor - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 1695

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

  • Refer to Procedure 019-017 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Oct-2010


FAULT CODE 196 (2 wire) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 is active?
YES NO

A defective engine coolant level sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in Section 19.

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin short to ground.

  • Measure the resistance and check for a short circuit between the engine coolant level sensor SIGNAL pin at the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Return the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 19-Oct-2015


FAULT CODE 196 (3 wire) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin to ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 1696 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Use the circuit diagram or Wiring Diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A defective sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 28-Dec-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine.

  • Refer to Procedure For ISM engines, 008-018 (Cooling System) in Section 8 of the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 008-018 (Cooling System) in Section 8 of the Service Manual, Signature&trade;, ISX, and QSX15, Bulletin 3666239.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

See the Coolant Loss symptom troubleshooting tree

Repair complete

Last Modified: 09-Jul-2010


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 212 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160 ohms?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 212 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 213 active and Fault Code 212 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 212 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor.

Refer to Procedure 019-067 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor RETURN pin and the engine harness engine oil temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor SIGNAL pin and the engine harness engine oil temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Check for the appropriate circuit response after 30 seconds.

Fault Code 212 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 212 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 212 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

Replace the engine oil temperature sensor.

Refer to Procedure 019-067 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Check for the appropriate circuit response after 30 seconds.

Fault Code 213 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 213 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 214. | Active or inactive counts of Fault Code 214?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 214.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 214?
YES NO

Refer to the Lubricating Oil Temperature Above Specification symptom troubleshooting tree.

  • For ISM engines, refer to the ISM, ISMe, or QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, refer to the Signature, ISX, QSX11 Service Manual, Bulletin 3666239.

 No Repair

Repair complete

Repair complete

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

IRefer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A defective sensor has been detected.

Replace the barometric pressure sensor.

Refer to Procedure 019-004 (Barometric Air Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 221 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the barometric pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A defective sensor has been detected.

Replace the barometric pressure sensor.

Refer to Procedure 019-004 (Barometric Air Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open RETURN or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 222 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

There is a short circuit to a voltage source in the engine harness sensor supply 2 line.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Engine motoring downhill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring downhill?
YES NO
No Repair

Check for engine damage.

  • Electronics are Ok.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 3400 rpm, followed by moderate deceleration to 3400 rpm.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

Note: Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 1D

Fault Codes 689 and 778

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not running above 3200 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test or sea trail to check if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine speed sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine speed sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

  • On ISM engines, replace the engine speed sensor. Refer to Procedure 019-038 (Engine Position Sensor (EPS)) in Section 19.
  • On ISX engines, replace the crankshaft position sensor. Refer to Procedure 019-365 (Crankshaft Position Sensor) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 241 - Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™//Metri-Pack™/ test lead, Part Number 3822917 - female Deutsch™//AMP™//Metri-Pack™/ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle speed sensor setting in INSITE™ electronic service tool. |
 | STEP 1A. Verify he vehicle speed sensor and the setting in INSITE™ electronic service tool match. | The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
STEP 2. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the OEM harness pins and the sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM harness connector pins at the ECM. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the OEM harness. | More than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | More than 100k ohms?
STEP 3. | Check for additional OEM devices. |
 | STEP 3A. Check the vehicle speed sensor circuit for additional devices. | Extra devices?
 | STEP 3B. Check for the gear slipping on the shaft. | Gear or tone wheel damaged or slips?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 241 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the vehicle speed sensor setting in INSITE™ electronic service tool.

Guided Step 1A - Verify the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool; go to the Vehicle Speed Source feature under Adjustments, Features, and Parameters.

  • Verify the vehicle speed sensor type parameter in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness pins and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM harness connector pins at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the ECM connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for additional OEM devices.

Guided Step 3A - Check the vehicle speed sensor circuit for additional devices.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle speed sensor circuit.

  • Inspect the vehicle speed sensor circuit for any additional or extra devices that can interfere with the speed signal.

Extra devices?
YES NO

Remove the device.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the vehicle speed sensor from the transmission.

Action

Check for the gear slipping.

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal. Make sure the gear or tone wheel is not damaged or slipping on the shaft.

Gear or tone wheel damaged or slips?
YES NO

See the OEM troubleshooting and repair manual to repair or replace the gear or tone wheel.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and move the vehicle so that the ECM can read a vehicle speed.
  • Use INSITE™ electronic service tool to verify that Fault Code 241 is inactive.

Fault Code 241 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location or OEM dealer if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 242 - Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the feature settings are correct. |
 | STEP 1A. Verify the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled. | Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
 | STEP 1B. Verify the vehicle speed sensor and setting in INSITE™ electronic service tool match. | The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
 | STEP 1C. Verify the Anti-Tampering Sensitivity Level is set correctly for the application. | Sensitivity Level set correctly?
STEP 2. | Look for signs or evidence of tampering. |
 | STEP 2A. Inspect the vehicle speed sensor. | Tampering, installed incorrectly, or external device present?
 | STEP 2B. Check for open circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2C. Check for short circuit to ground in the OEM harness. | More than 100k ohms?
 | STEP 2D. Check for a pin to pin short circuit in the OEM harness. | More than 100k ohms?
STEP 3. | Check the vehicle speed reporting. |
 | STEP 3A. Use INSITE™ electronic service tool to monitor the vehicle speed signal. | INSITE™ electronic service tool readout and vehicle speedometer match?
 | STEP 3B. Verify the vehicle speed. | Vehicle speed accurate?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 242 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the feature settings are correct.

Guided Step 1A - Verify the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled.

Action

Verify the customer wants Vehicle Speed Sensor Anti-Tampering feature enabled.

Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Vehicle Speed Sensor Anti-Tampering feature.

Go to 1B

Go to 4A

Guided Step 1B - Verify the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features, and Parameters.

  • Verify the Vehicle Speed Sensor Type parameter setting in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 1C

Go to 4A

Guided Step 1C - Verify the Anti-Tampering Sensitivity Level is set correctly for the application.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the Vehicle Speed Signal Tampering Sensitivity Level is set correctly for the application.

  • Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.
  • Check the ECM setting for Vehicle Speed Signal Tampering Sensitivity Level.

Sensitivity Level set correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to set the Vehicle Speed Signal Tampering Sensitivity Level to the correct value for the vehicle.

Go to 2A

Go to 4A

Guided Step 2 - Look for signs or evidence of tampering.

Guided Step 2A - Inspect the vehicle speed sensor.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to the OEM harness
  • Other external device connected in place of the vehicle speed sensor
  • Any evidence tampering with the vehicle speed sensor has taken place.

Tampering, installed incorrectly, or external device present?
YES NO

Remove the tampering device.

Install the sensor correctly or remove the external device.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the ECM connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the vehicle speed reporting.

Guided Step 3A - Use INSITE™ to monitor the vehicle speed signal.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the vehicle speed.

  • Verify the vehicle speed is 0 when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Compare the vehicle speed read by INSITE™ electronic service tool to the speedometer on the dash.

INSITE™ electronic service tool readout and vehicle speedometer match?
YES NO
No Repair

Verify the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correctly in the ECM.

Go to 3B

Go to 4A

Guided Step 3B - Verify the vehicle speed.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Vehicle moving.

Action

Use INSITE™ electronic service tool to verify the speed reported is accurate or reasonable for the present gear.

  • (For example: 64 km/h [40 mph] in top gear is probably inaccurate data)

Vehicle speed accurate?
YES NO
No Repair

Verify the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correctly in the ECM.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Do not operate engine.
  • Do not move vehicle.

Action

Disable the fault code.

  • With the keyswitch ON and the vehicle stationary, wait one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 242 is inactive.

Fault Code 242 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location or OEM dealer if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the original equipment manufacturer (OEM) resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control solenoid. |
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage and supply line. | Greater than +5 volts of direct current (VDC)?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 245 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

See equipment manufacturer service information for resistance specifications.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Replace the fan control solenoid.

See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control solenoid.

See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and supply line.

  • Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the OEM harness actuator connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Greater than +5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Start the engine and let it idle for 1 minute.
  • Turn the keyswitch OFF. Shut down the engine.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 245 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 249 - Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 249 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 256 active and Fault Code 249 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 249 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 249 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and the ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the ambient air temperature SIGNAL pin and the ambient air temperature RETURN pin at the sensor connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active and Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES NO

A damaged ambient air temperature sensor has been detected.

Replace the ambient air temperature sensor.

See the OEM troubleshooting and repair manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor RETURN pin and the OEM harness ambient air temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor SIGNAL pin and the OEM harness ambient air temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 249 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 254 active?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for extra wires connected to the fuel shutoff valve. | More than one wire connected to valve?
 | STEP 2C. Check for a pin-to-ground short circuit in the fuel shutoff valve. | Is resistance 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?
 | STEP 2D. Check the fuel shutoff valve diagnostic supply voltage and supply line. | Greater than 5.0 VDC?
 | STEP 2E. Check the fuel shutoff valve solenoid resistance. | Is the resistance 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel shutoff valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for a pin to ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 254 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 active?
YES | NO
No Repair | No Repair

Go to 2A

019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and fuel shutoff ring terminal connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for extra wires connected to the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.

Action

Extra wires connected to the fuel shutoff valve powering devices on the vehicle can cause this fault to be active.

  • Visually inspect the fuel shutoff valve terminal for more than one wire.

More than one wire connected to valve?
YES NO

Remove extra wires.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for a pin-to-ground short circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance between the fuel shutoff valve terminal stud and engine block ground.

For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Is the resistance:

  • 1 to 5 ohms for 6-VDC solenoids
  • 6 to 15 ohms for 12-VDC solenoids
  • 24 to 50 ohms for 24-VDC solenoids
  • 42 to 80 ohms for 32-VDC solenoids
  • 46 to 87 ohms for 36-VDC solenoids
  • 92 to 145 ohms for 48-VDC solenoids
  • 315 to 375 ohms for 74-VDC solenoids
  • 645 to 735 ohms for 115-VAC solenoids?
YES NO
No Repair

Replace the fuel shutoff valve.

019-050 (Fuel Shutoff Valve) in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the fuel shutoff valve diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the actuator harness.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve and supply line.

  • Measure the voltage between the fuel shutoff valve SIGNAL wire and engine block ground.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2E

Guided Step 2E - Check the fuel shutoff valve solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff valve solenoid.

Action

Check the fuel shutoff valve solenoid resistance.

  • Measure the resistance from the fuel shutoff valve solenoid to engine block ground.

For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Is the resistance:

  • 1 to 5 ohms for 6-VDC solenoids
  • 6 to 15 ohms for 12-VDC solenoids
  • 24 to 50 ohms for 24-VDC solenoids
  • 42 to 80 ohms for 32-VDC solenoids
  • 46 to 87 ohms for 36-VDC solenoids
  • 92 to 145 ohms for 48-VDC solenoids
  • 315 to 375 ohms for 74-VDC solenoids
  • 645 to 735 ohms for 115-VAC solenoids?
YES NO
No Repair

Replace the fuel shutoff valve.

019-050 (Fuel Shutoff Valve) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the ECM fuel shutoff valve voltage.

  • Use a multimeter to measure the voltage from the fuel shutoff valve SIGNAL pin at the ECM port to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit-to-ground.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO

Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Repair or replace the engine harness.

019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 255 active?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel shutoff valve. | Is resistance 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?
 | STEP 2C. Check the fuel shutoff valve diagnostic supply voltage and signal circuit. | Greater than 5.0 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel shutoff valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 255 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 active?
YES | NO
No Repair | No Repair

Go to 2A

019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and ring terminal connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance between the fuel shutoff valve ring terminal stud and engine block ground.

For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Is the resistance:

  • 1 to 5 ohms for 6-VDC solenoids
  • 6 to 15 ohms for 12-VDC solenoids
  • 24 to 50 ohms for 24-VDC solenoids
  • 42 to 80 ohms for 32-VDC solenoids
  • 46 to 87 ohms for 36-VDC solenoids
  • 92 to 145 ohms for 48-VDC solenoids
  • 315 to 375 ohms for 74-VDC solenoids
  • 645 to 735 ohms for 115-VAC solenoids?
YES NO
No Repair

Replace the fuel shutoff valve.

019-050 (Fuel Shutoff Valve) in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel shutoff valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.
  • Turn keyswitch ON.

Action

Measure the fuel shutoff valve diagnostic supply voltage.

  • Measure the voltage from the actuator harness fuel shutoff valve SIGNAL ring terminal to engine block ground.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve supply voltage.

  • Measure the voltage from the fuel shutoff valve SIGNAL pin at the ECM port to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for circuit continuity.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness fuel shutoff valve connector and the fuel shutoff valve SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO

Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Repair or replace the engine harness.

019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 255 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 256 - Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 256 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active and Fault Code 256 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 256 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 256 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active and Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

Replace the ambient air temperature sensor.

See the OEM troubleshooting and repair manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 256 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault status. |
 | STEP 1A. Check for active Fault Code 255 or high inactive counts. | Fault Code 255 active?
STEP 2. | Check for extra wires. |
 | STEP 2A. Check for extra wires attached to the fuel shutoff valve solenoid. | Extra wires?
STEP 3. | Check for proper fuel shutoff valve circuit operation. |
 | STEP 3A. Check for proper fuel shutoff valve circuit operation. | Is voltage available at the fuel shutoff valve greater than 11-VDC with the keyswitch ON, and less than 0.5-VDC with the keyswitch OFF?
STEP 4. | Check the fuel shutoff valve actuator disc. |
 | STEP 4A. Check the fuel shutoff valve actuator disc. | Debris or damage found on the valve disc, valve seat, or actuator disc?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 257 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault status.

Guided Step 1A - Check for active Fault Code 255 or high inactive counts.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 active?
YES | NO
No Repair | No Repair

Reference Fault Code 255

Go to 2A

Guided Step 2 - Check for extra wires.

Guided Step 2A - Check for extra wires attached to the fuel shutoff valve solenoid.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires.

  • Check for extra wires attached to the fuel shutoff valve solenoid.

Extra wires?
YES NO

Remove the extra wires attached to the fuel shutoff valve solenoid.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check for proper fuel shutoff valve circuit operation.

Guided Step 3A - Check for proper fuel shutoff valve circuit operation.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve circuit operation.

  • Verify the voltage available at the fuel shutoff valve is greater than 11-VDC.
  • Turn keyswitch OFF.
  • Verify the voltage available at the fuel shutoff valve is less than 0.5-VDC.

Is voltage available at the fuel shutoff valve greater than 11-VDC with the keyswitch ON, and less than 0.5-VDC with the keyswitch OFF?

YES NO
No Repair

Reference Step 3A in Troubleshooting Tree 16-t02-1001b (Engine Performance Troubleshooting Tree - ISM with CM876) in Section TT to diagnose the fuel shutoff valve circuit.

Go to 4A

Go to 5A

Guided Step 4 - Check the fuel shutoff valve actuator disc.

Guided Step 4A - Check the fuel shutoff valve actuator disc.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve solenoid, valve disc, valve seat, and actuator disc.

Action

Check the fuel shutoff valve actuator disc.

  • Check the housing, valve disc, valve seat, and actuator disc for dirt, debris, metal parts, bonding separation, corrosion, cracks, or wear.

Debris or damage found on the valve disc, valve seat, or actuator disc?
YES NO

Replace the damaged fuel shutoff valve component. Refer to Procedure 019-050 in Section 19.

Assemble the fuel shutoff valve.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Turn the keyswitch OFF for 30 seconds.
  • Use INSITE™ electronic service tool to verify Fault Code 257 is inactive.

Fault Code 257 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault status. |
 | STEP 1A. Check for active Fault Code 255 or high inactive counts. | Fault Code 255 active?
STEP 2. | Check for extra wires. |
 | STEP 2A. Check for extra wires attached to the fuel shutoff valve solenoid. | Extra wires?
STEP 3. | Check the fuel pressure sensor accuracy. |
 | STEP 3A. Check the fuel pressure sensor accuracy with keyswitch ON. | Fuel pressure less than 69 kpa [10 psi]?
 | STEP 3B. Check the fuel pressure sensor accuracy with engine running. | Fuel pressure readings within 69 kpa [10 psi]?
STEP 4. | Check for proper fuel shutoff valve circuit operation. |
 | STEP 4A. Check for proper fuel shutoff valve circuit operation. | Is voltage available at the fuel shutoff valve greater than 11-VDC with the keyswitch ON, and less than 0.5-VDC with the keyswitch OFF?
STEP 5. | Check the fuel shutoff valve actuator disc. |
 | STEP 5A. Check the fuel shutoff valve actuator disc. | Debris or damage found on the valve disc, valve seat, or actuator disc?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 257 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault status.

Guided Step 1A - Check for active Fault Code 255 or high inactive counts.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 active?
YES | NO
No Repair | No Repair

Reference Fault Code 255

Go to 2A

Guided Step 2 - Check for extra wires.

Guided Step 2A - Check for extra wires attached to the fuel shutoff valve solenoid.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires.

  • Check for extra wires attached to the fuel shutoff valve solenoid.

Extra wires?
YES NO

Remove the extra wires attached to the fuel shutoff valve solenoid.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the fuel pressure sensor accuracy.

Guided Step 3A - Check the fuel pressure sensor accuracy with keyswitch ON.

Conditions

  • Turn keyswitch OFF.
  • Connect the clear hose and shutoff valve that is normally used to check for air-in-fuel, to the rail Compuchek™ fitting. Refer to Procedure 006-003. Place the open end in a suitable, clean container and fully open the shutoff valve in the hose.
  • Remove the clear hose and shutoff valve, that are normally use to check for air-in-fuel.
  • Connect the fuel pressure gauge to the Compuchek™ fitting on the IFSM.
  • Disconnect the 2-pin connector at the fuel lift pump.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pressure sensor accuracy.

  • Verify the fuel pressure gauge reading and INSITE™ electronic service tool fuel pressure reading are both less than 69 kpa [10 psi].

Fuel pressure less than 69 kpa [10 psi]?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the fuel pressure sensor accuracy with engine running.

Conditions

  • Turn keyswitch ON.
  • Connect the fuel pressure gauge to the Compuchek™ fitting on the IFSM.
  • All components connected.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pressure accuracy.

  • Start the engine.
  • Allow the idle to stabilize.
  • Verify the pump pressure meets specification: greater than 1448 kpa [210 psi] at idle.
  • Verify the difference between the fuel pressure gauge reading and the INSITE™ electronic service tool fuel pressure reading is less than 69 kpa [10 psi].

Are the fuel pressure readings within 69 kpa [10 psi]?
YES NO
No Repair

Replace the fuel pressure sensor.

Refer to Procedure 019-115 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check for proper fuel shutoff valve circuit operation.

Guided Step 4A - Check for proper fuel shutoff valve circuit operation.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve circuit operation.

  • Verify the voltage available at the fuel shutoff valve is greater than 11-VDC.
  • Turn keyswitch OFF.
  • Verify the voltage available at the fuel shutoff valve is less than 0.5-VDC.

Is voltage available at the fuel shutoff valve greater than 11-VDC with the keyswitch ON, and less than 0.5-VDC with the keyswitch OFF?

YES NO
No Repair

Reference Step 3A in Troubleshooting Tree 16-t02-1001a (Engine Performance Troubleshooting Tree - ISX with CM871) in Section TT to diagnose the fuel shutoff valve circuit.

Go to 5A

Go to 6A

Guided Step 5 - Check the fuel shutoff valve actuator disc.

Guided Step 5A - Check the fuel shutoff valve actuator disc.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve solenoid, valve disc, valve seat, and actuator disc.

Action

Check the fuel shutoff valve actuator disc.

  • Check the housing, valve disc, valve seat, and actuator disc for dirt, debris, metal parts, bonding separation, corrosion, cracks, or wear.

Debris or damage found on the valve disc, valve seat, or actuator disc?
YES NO

Replace the damaged fuel shutoff valve component. Refer to Procedure 019-050 in Section 19.

Assemble the fuel shutoff valve.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Turn the keyswitch OFF for 30 seconds.
  • Use INSITE™ electronic service tool to verify Fault Code 257 is inactive.

Fault Code 257 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Oct-2010


FAULT CODE 263 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 263 inactive?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 263 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 263 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Inspect the engine harness and engine fuel temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin and engine fuel temperature sensor RETURN pin at the engine fuel temperature sensor.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine fuel temperature sensor.

Refer to Procedure 019-119 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine fuel temperature sensor SIGNAL pin and the engine fuel temperature sensor RETURN pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for connector pin identification.

Fault Code 265 active and Fault Code 263 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor RETURN pin and the engine harness engine fuel temperature sensor connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor SIGNAL pin and the engine harness engine fuel temperature sensor connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 263 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 265 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 265 inactive?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor and connector pins. | Dirty and damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 263 active and Fault Code 265 inactive.
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 265 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged?
 | STEP 3B. Check the circuit response. | Fault Code 263 active and Fault Code 265 inactive.
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 265 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 265 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Inspect the engine harness and engine fuel temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

Replace the engine fuel temperature sensor.

Refer to Procedure 019-119 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ to verify that the fault code is inactive.

Fault Code 265 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between the INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 285 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 is active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 Data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool Society of Automotive Engineers (SAE) J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.

If the status column indicates “Active” for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for specific multiplexing configuration information for several OEMs. If the OEM is not listed in the bulletin, it will be necessary to contact the OEM for specific multiplexing information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and ensure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 Data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 Data link (+) wire and the SAE J1939 Data link (-) wire on the service data link connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 Data link backbone.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 Data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 Data link (+) wire and the SAE J1939 Data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 Data link harness connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 Data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 Data link (+) wire and the SAE J1939 Data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 Data link (+) and the SAE J1939 Data link (-) pins.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Go to the appropriate ECM No Communication symptom tree.

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 287 is active?
STEP 2. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 datalink to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the accelerator parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of zero?
 | STEP 3B. Determine if the accelerator parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than zero?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 287 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 287 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 datalink to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and ensure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

Note: Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the throttle is released, the Throttle Status/Idle Validation parameter must display “released” and Percent Throttle parameter must display a value of zero.

Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of zero?
YES NO
No Repair

There is an OEM issue with the accelerator or idle validation switch or OEM VECU.

  • Refer to the appropriate OEM for further instructions.
  • Refer to Procedure 019-054 (Idle Validation Switch) in Section 19.
  • Refer to Procedure 019-085 (Accelerator Pedal or Lever Position Sensor) in Section 19..

Go to 3B

Go to 4A

Guided Step 3B - Determine if the accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

When the throttle is depressed, the Throttle Status/Idle Validation parameter must display “depressed” and Percent Throttle parameter must display a value greater than zero.

Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than zero?

YES NO
No Repair

There is an OEM issue with the idle validation switch or the accelerator or with the OEM VECU.

  • Refer to the appropriate OEM for further instructions.
  • Refer to Procedure 019-054 (Idle Validation Switch) in Section 19.
  • Refer to Procedure 019-085 (Accelerator Pedal or Lever Position Sensor) in Section 19..

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 287 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 288 is active?
STEP 2. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 datalink to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the remote accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of zero?
 | STEP 3B. Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than zero?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 288 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 288 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 datalink to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and ensure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the remote accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Ensure the remote throttle switch is ON and the remote accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Status/Idle Validation

NOTE: Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the remote throttle is released, the Remote Throttle Switch parameter must display ON and the Percent Throttle parameter must display a value of zero.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of zero?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, the remote throttle, or with the OEM VECU.

Refer to the appropriate OEM for further instructions.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Ensure the remote throttle switch is ON and the remote accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Switch Status

Note: Monitor parameters can possibly not appear in the electronic service tool exactly as shown above.

When the remote throttle is depressed, the Remote Throttle Switch parameter must display ON and the Percent Throttle parameter must display a value greater than zero.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than zero?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, or the remote throttle, or with the OEM VECU.

Refer to the appropriate OEM for further instructions.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 288 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 295 - Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 221 and Fault Code 222. | Fault Code 221 or Fault Code 222 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active?
 | STEP 2C. Check the circuit response. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 222 active?
 | STEP 3C. Check the circuit response. | Fault Code 221 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verity the repair. | INSITE™ reading within 102 mm-hg [4 in-hg] of local barometric pressure?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 221 and Fault Code 222.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 or Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the barometric pressure sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

An in-range malfunction of the barometric pressure sensor has been detected.

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start the INSITE™ Data Monitor/Logger. Refer to Procedure 018-028 in Section V to compare the INSITE™ electronic service tool reading for Barometric Air Pressure to the local barometric pressure.

INSITE™ reading within 102 mm-hg [4 in-hg] of local barometric pressure?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 311 - Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5 VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 311 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector.

Refer to Procedure 006-026 (Injector) in Section 6 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Replace the injector.

Refer to Procedure 006-026 (Injector) in Section 6 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 (Internal Actuator Harness) in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 (Internal Actuator Harness) in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 (Internal Actuator Harness) in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 311 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 311 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Aug-2014


FAULT CODE 312 - Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM , all other active fault codes must be investigated prior to replacing the ECM .
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5 VDC?
 | STEP 3E. Check for an inactive fault code? | Fault Code 312 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 312 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector.

Refer to Procedure 006-026 (Injector) in Section 6 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Replace the injector.

Refer to Procedure 006-026 (Injector) in Section 6 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 3A

Go to 4A

Guided Step 3 - Check the internal actuator harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 (Internal Actuator Harness) in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 (Internal Actuator Harness) in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 (Internal Actuator Harness) in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 312 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 312 is inactive.

Fault Code 312 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Aug-2014


FAULT CODE 313 - Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5 VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 313 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 313 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector.

Refer to Procedure 006-026 (Injector) in Section 6 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Replace the injector.

Refer to Procedure 006-026 (Injector) in Section 6 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 (Internal Actuator Harness) in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 (Internal Actuator Harness) in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 (Internal Actuator Harness) in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 313 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 313 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Aug-2014


FAULT CODE 314 - Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5 VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 314 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 314 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Less than 1.5 VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 314 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 314 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Aug-2014


FAULT CODE 315 - Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | More than 100k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5 VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 311 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3 .
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post-to-post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6 .

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6 .

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Less than 1.5 VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker cover or in the engine harness.

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 in Section 19.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 315 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 315 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Aug-2014


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part No. 3822758 - male Deutsch/AMP/Metri-Pack test leadPart No. 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the real-time clock battery and connections. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the real-time clock battery voltage at the ECM harness connector. | Between 3.3 and 3.6 VDC?
 | STEP 1B-1. Inspect the real-time clock battery and engine wire harness connector pins. |
 | STEP 1B-2. Check the real-time clock battery voltage at the battery module connector. |
STEP 2. | Check the battery module harness. |
 | STEP 2A. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 319 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the real-time clock battery and connections.

Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor harness connector.

Clean the connector and pins.

Repair the damaged pins harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the real-time clock battery voltage at the ECM harness connector.

Conditions

  • Engine equipped with optional real-time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the real-time clock battery voltage.

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 3.3 and 3.6 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1B-1

Guided Step 1B-1 - Inspect the real-time clock battery and engine wire harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Inspect the real-time clock battery and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Repair or replace the real-time clock battery or engine harness.

Refer to Procedure 019-311 (Real-Time Clock Battery Backup) in Section 19. Refer to Procedure Also, 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 1B-2

Guided Step 1B-2 - Check the real-time clock battery voltage at the battery module connector.

Conditions

  • Engine equipped with optional real-time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check the real-time clock battery voltage.

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 3.3 and 3.6 VDC?
YES NO
No Repair

Replace the real-time clock battery.

Refer to Procedure 019-311 (Real-Time Clock Battery Backup) in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery module harness.

Guided Step 2A - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the following resistance:

  • The resistance between the real-time clock battery SUPPLY pin at the battery connector of the engine harness to the real-time clock battery SUPPLY pin at the ECM harness connector
  • The resistance between the real-time clock battery RETURN (-) pin at the battery connector of the engine harness to the real-time clock battery RETURN (-) pin at the ECM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Using a multimeter, measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Using a multimeter, measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to set the real-time clock to the correct date and time.
  • Use INSITE™ electronic service tool to verify that Fault Code 319 is inactive.

Fault Code 319 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 321 - Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part No. 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 351 inactive?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector solenoid. | Resistance of the injector is 0.5 to 1.5 ohms?
 | STEP 2C. Check for a short circuit in the injector solenoid. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short to voltage source in the engine harness. | Less than 1.5-VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 321 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 321 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 inactive?
YES | NO
No Repair | No Repair

Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the fuel injector from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness fuel injector connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector is 0.5 to 1.5 ohms?
YES NO
No Repair

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6 .

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit to ground in the injector solenoid.

  • Measure the resistance between the injector (+) pin and engine block ground.
  • Measure the resistance between the injector (-) pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the injector to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and the injector RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the open circuit is in the internal harness inside the rocker lever housing or in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN pin and all other pins in the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the voltage between the injector SIGNAL pin to engine block ground.
  • Measure the voltage between the injector RETURN pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Less than 1.5-VDC?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 321 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 321 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Aug-2014


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Resistance greater than 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Resistance of the circuit greater than 1 ohm?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 11 and 1 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

Resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid less than 0.5 ohms?
YES NO

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 11 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 1 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the circuit greater than 1 ohm?
YES NO

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2014


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Resistance of the circuit greater than 1 ohm?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 8 and 9 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

Resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid less than 0.5 ohms?
YES NO

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater then 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 8 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 9 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the circuit greater than 1 ohm?
YES NO

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Aug-2014


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Resistance of the circuit greater than 1 ohm?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 5 and 4 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

Resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the followiing procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid less than 0.5 ohms?
YES NO

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater then 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 5 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 4 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the circuit greater than 1 ohm?
YES NO

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Aug-2014


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Resistance of the circuit greater than 1 ohm?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 10 and 20 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

See the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

Resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. See the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques, see the following procedure. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. See the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

See the following for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid less than 0.5 ohms?
YES NO

Replace the injector.

See the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

See the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater then 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 10 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 20 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the circuit greater than 1 ohm?
YES NO

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Aug-2014


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Resistance of the circuit greater than 1 ohm?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 331 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 2 and 3 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

Resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid less than 0.5 ohms?
YES NO

Replace the injector.

Use the following procedure of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater then 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 2 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 3 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the circuit greater than 1 ohm?
YES NO

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Aug-2014


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty, loose, or damaged pins?
 | STEP 2B. Check for a circuit fault in the injector solenoid and circuit. | Resistance of the injector and circuit 0.5 to 2.5 ohms?
 | STEP 2C. Check for a circuit fault in the injector solenoid and circuit. | Resistance measured in Step 2B less than 0.5 ohms?
STEP 3. | Check for a short circuit in the injector solenoid and circuit. |
 | STEP 3A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 3B. Check for a short circuit in the injector solenoid. | Resistance of the injector solenoid less than 0.5 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Resistance greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | Resistance greater then 100k ohms?
STEP 4. | Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 4A. Inspect the fuel injector and connector pins. | Dirty, loose, or damaged pins?
 | STEP 4B. Check for high resistance or an open circuit in the injector solenoid. | Resistance of the injector solenoid greater than 1.5 ohms?
 | STEP 4C. Check for high resistance or an open circuit in the engine harness. | Resistance of the circuit greater than 1 ohm?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 332 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 351

Go to 2A

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a circuit fault in the injector solenoid and circuit.

  • Measure the resistance between pins 7 and 6 at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector and circuit 0.5 to 2.5 ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for a circuit fault in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Use the resistance measurement from Step 2B.

Resistance measured in Step 2B less than 0.5 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check for a short circuit in the injector solenoid and circuit.

Guided Step 3A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or fuel injector connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for a short circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid less than 0.5 ohms?
YES NO

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin to engine block ground.
  • Measure the resistance between the injector RETURN (-) pin to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater then 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Guided Step 4A - Inspect the fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty, loose, or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal actuator harness from the injector solenoid.
  • Remove the injector solenoid wires from the solenoid.

Action

Check for an open circuit in the injector solenoid.

  • Measure the resistance from post to post on the injector solenoid.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the injector solenoid greater than 1.5 ohms?
YES NO

Replace the injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for high resistance or an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the injector SIGNAL (+) pin at the injector and pin 7 at the engine harness ECM connector.
  • Measure the resistance between the injector RETURN (-) pin at the injector and pin 6 at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance of the circuit greater than 1 ohm?
YES NO

An open circuit or high resistance has been detected in the engine harness.

  • Troubleshoot the interconnect at the rocker lever housing pass-through connector. Determine if the short circuit is in the internal harness inside the rocker lever housing or in the engine harness.
  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Aug-2014


FAULT CODE 338 - Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 338 inactive?
 | STEP 1B. Check the ECM setup for idle shutdown accessory relay. | INSITE™ electronic service tool Idle Shutdown feature set up correctly?
STEP 2. | Check the idle shutdown relay and circuit. |
 | STEP 2A. Inspect the idle shutdown relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the idle shutdown relay for an open circuit. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit in the idle shutdown relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 338 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 338 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes and electronic setting.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 338 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the Idle Shutdown feature.

  • If the vehicle has an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Not Installed”.

INSITE™ electronic service tool Idle Shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the idle shutdown relay and circuit.

Guided Step 2A - Inspect the idle shutdown relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Inspect the OEM harness and idle shutdown relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the idle shutdown relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check the idle shutdown relay resistance.

  • Measure the resistance between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin.

Use the OEM wiring diagram for idle shutdown relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the idle shutdown relay.

See the OEM troubleshooting and repair manual.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the idle shutdown relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the idle shutdown relay RETURN pin at the idle shutdown relay connector to ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the failed connection.

Clear, repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector idle shutdown relay RETURN pin and the OEM harness idle shutdown relay connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the idle shutdown SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 338 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 338 is inactive.

Fault Code 338 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 16-Oct-2015


FAULT CODE 339 - Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 339 inactive?
 | STEP 1B. Check the ECM setup for idle shutdown accessory relay. | INSITE™ electronic service tool Idle Shutdown feature set up correctly?
STEP 2. | Check the idle shutdown relay and circuit. |
 | STEP 2A. Inspect the idle shutdown relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the idle shutdown relay for an open circuit. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin to ground short circuit in the idle shutdown relay. |
 | STEP 2C. Check the idle shutdown relay diagnostic supply voltage, supply line and return circuit. | Greater than 3.75 volts of direct current (VDC)?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 339 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 339 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes and electronic settings.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 339 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the Idle Shutdown feature.

  • If the vehicle has an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Not Installed”.

INSITE™ electronic service tool Idle Shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the idle shutdown relay and circuit.

Guided Step 2A - Inspect the idle shutdown relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Inspect the OEM harness and idle shutdown relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the idle shutdown relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check the idle shutdown relay resistance.

  • Measure the resistance between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin.

Use the OEM wiring diagram for idle shutdown relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the idle shutdown relay.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2B-1 - Check for a pin to ground short circuit in the idle shutdown relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the idle shutdown relay SIGNAL pin and ground.

Use the OEM wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the idle shutdown relay.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the idle shutdown relay diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the idle shutdown relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Use the OEM wiring diagram for connector pin identification.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 339 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 339 is inactive.

Fault Code 339 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 16-Oct-2015


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active or more than three inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 volts of direct current (VDC) [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Recalibrate the ECM. |
 | STEP 4A. Recalibrate the ECM. | Fault Code 343 active after recalibrating the ECM?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals.

See the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery.

See the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery supply (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s).

  • Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

See the OEM troubleshooting and repair manual.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, i.e., no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Recalibrate the ECM.

Guided Step 4A - Recalibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a short circuit to ground.

  • Use INSITE™ electronic service tool to recalibrate the ECM with the latest engine calibration.

Fault Code 343 active after recalibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Turn the keyswitch to the OFF position for 30 seconds.
  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 343 is inactive.

For Fault Code 343 to become inactive, the ECM must go through one complete shutdown.

Fault Code 343 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 346 is active?
STEP 2. | Check the adjustable parameter settings. |
 | STEP 2A. Check for correct adjustable parameter settings. | Are both accelerator interlock and powertrain protection torque limit switch features enabled, and are both the accelerator interlock switch and powertrain protection torque limit switch features disabled in the SAE® J1939 multiplexing feature?
 | STEP 2B. Check for correct adjustable parameter settings. | Are both clutch pedal position switch and engine protection shutdown manual override switch features enabled, and are both the clutch pedal position switch and engine protection shutdown manual override switch disabled in the SAE® J1939 multiplexing feature?
 | STEP 2C. Check for correct adjustable parameter settings. | Are both idle shutdown accessory relay and engine brake lamp output features enabled?
 | STEP 2D. Check for correct adjustable parameter settings. | Are both switched maximum engine operating speed switch and governor type switch features enabled?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 346 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 346 is active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the adjustable parameter settings.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for accelerator interlock switch and powertrain protection torque limit switch.

Are both accelerator interlock and powertrain protection torque limit switch features enabled, and are both the accelerator interlock switch and powertrain protection torque limit switch features disabled in the SAE® J1939 multiplexing feature?

YES NO

Disable either the accelerator interlock switch or the powertrain protection torque limit switch features, use INSITE™ electronic service tool.

Configuring either the accelerator interlock switch or the powertrain protection torque limit switch to be multiplexed using the J1939 data link will also clear the fault code.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for clutch pedal position switch and engine protection shutdown manual override switch.

Are both clutch pedal position switch and engine protection shutdown manual override switch features enabled, and are both the clutch pedal position switch and engine protection shutdown manual override switch disabled in the SAE® J1939 multiplexing feature?

YES NO

Disable either the clutch pedal position switch or the engine protection shutdown manual override switch features, use INSITE™ electronic service tool.

Configuring either the clutch pedal position switch or the engine protection shutdown manual override switch to be multiplexed using the SAE® J1939 multiplexing feature will also clear the fault code.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for idle shutdown accessory relay and engine brake lamp output.

Are both idle shutdown accessory relay and engine brake lamp output features enabled?
YES NO

Disable either the idle shutdown accessory relay or the engine brake lamp output features, use INSITE™ electronic service tool.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings switched maximum engine operating speed switch and governor type switch.

Are both switched maximum engine operating speed switch and governor type switch features enabled?
YES NO

Disable either the switched maximum engine operating speed switch or the governor type switch features, use INSITE™ electronic service tool.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code by turning the keyswitch ON and waiting 30 seconds.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 346 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM power supply. |
 | STEP 1A. Inspect the ECM power supply connectors and fuses. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 1C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 2. | Validate the occurrence of this fault code. |
 | STEP 2A. Operate the engine and determine if fault code condition exists. | Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, and 332 do not occur?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM power supply.

Guided Step 1A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Inspect the ECM power supply and fuses for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the power connector of the ECM power supply harness and the battery positive (+) pins at the battery positive (+) connection.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders, or clean the battery terminal connections.

Refer to the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.
  • Disconnect the ECM power supply harness from the battery terminals.

Action

Check for an open circuit in the ECM ground circuit.

  • Measure the resistance between the battery negative (-) pins at the ECM power supply connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders, or clean the battery terminal connections.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Validate the occurrence of this fault code.

Guided Step 2A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: The INSITE™ electronic service tool can also be used to monitor the ECM power supply and injector power supply voltages.

Fault Code 351 reoccurs during engine operation, while injector Fault Codes 322, 323, 324, 325, 331, and 332 do not occur?

YES NO

  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

A marginal battery voltage condition is possible. Make sure the batteries are fully charged.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jul-2010


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the exhaust gas recirculation (EGR) differential pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the aftertreatment fuel pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Fault Code 352 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the intake barometric pressure sensor.

Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the EGR differential pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the EGR differential pressure sensor.

Refer to Procedure 019-370 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the aftertreatment fuel pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the aftertreatment fuel pressure sensor.

Refer to Procedure 019-444 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 16-Oct-2015


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Verify the repair. | Fault Code 386 inactive?
 | STEP 3B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

There is a short circuit to a voltage source in the engine harness sensor supply 1 line.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 16-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Low engine oil pressure has been detected.

Refer to Lubricating Oil Pressure Low symptom tree.

  • For ISX engines, refer to the Signature, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • For ISM engines, refer to the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

 No Repair

Repair complete

Repair complete

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 418. | Active or inactive counts of Fault Code 418?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 418.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 418?
YES NO

Drain the water from the fuel filter.

 No Repair

Repair complete

Repair complete

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3163151 - ECM bench calibration harnessPart Number 3164185 - ECM bench calibration adapter cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communications with the ECM bench calibration harness. | INSITE™ communicates with ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 427 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check SAE J1939 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM troubleshooting and repair manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM troubleshooting and repair manual.

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communications with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM troubleshooting and repair manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

Refer to OEM troubleshooting and repair manual.

Refer to the Communication Error - Electronic Service Tool or Control Device Symptom troubleshooting tree.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Is Fault Code 427 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Keyswitch "ON".
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 428 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 100k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 429 active and Fault Code 428 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 428 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 428 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, and water-in-fuel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the water-in-fuel sensor connector.

Refer to the circuit art or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the water-in-fuel sensor.

Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the malfunction.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19..

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active and Fault Code 428 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor RETURN pin and the engine harness water-in-fuel sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor SIGNAL pin and the engine water-in-fuel sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Troubleshooting procedures need to be repeated from the beginning. A malfunction should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 428 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 429 active?
STEP 2. | Check the water-in-fuel sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit . | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 429 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the water-in-fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 is active?
YES NO

A defective sensor has been detected.

Replace the water-in-fuel sensor.

Refer to Procedure 019-127 (Water in Fuel) in Section 19.

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, sensor, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water-in-fuel SIGNAL pin at the ECM connector of the engine harness and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 is inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 429 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 135 and Fault Code 141 | Fault Code 135 and Fault Code 141 active?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active?
 | STEP 2C. Check the circuit response. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 141 active?
 | STEP 3C. Check the circuit response. | Fault Code 135 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | INSITE™ electronic service tool reading for Engine Oil Pressure 0 kPa [0 psi]?
 | STEP 4B. Clear the fault codes. | All fault codes cleared.

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 135 and Fault Code 141.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 or Fault Code 141 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine oil pressure +5 volt SUPPLY pin and the engine oil pressure SIGNAL pin at the engine oil pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

Fault Code 135 active?
YES NO

An in-range malfunction of the oil pressure sensor has been detected.

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine oil pressure +5 volt SUPPLY pin and the engine oil pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Monitor INSITE™ electronic service tool Data Monitor/Logger for engine oil pressure.

INSITE™ electronic service tool reading for Engine Oil Pressure is 0 kPa [0 psi]?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 07-Mar-2012


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the OEM power harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections. Clean the terminals.

See the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 volts of direct current (VDC) (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s).

See the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify the 30 ampere fuse is installed correctly.

  • Inspect the 30 ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 30 ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse.

Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires.

See the OEM troubleshooting and repair manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 19-Oct-2015


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Check the battery voltage. | Less than +20-VDC for 12-volt system and less than +32-VDC for 24-volt system?
 | STEP 2B. Check the alternator. | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Check the battery voltage.

  • Measure the battery voltage from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.
  • Repeat above step for the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector.

Less than +20-VDC for 12-volt system

Less than +32-VDC for 24-volt system?
YES NO
No Repair

Install the battery system correctly. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Note: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 442 is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault code.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


FAULT CODE 482 - Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the fuel supply. |
 | STEP 2A. Verify the fuel system has been primed. | Fuel system been properly primed?
 | STEP 2B. Check the vehicle fuel tanks for fuel. | Fuel in the fuel tanks?
 | STEP 2C. Check for fuel leaks. | Any fuel leaks in the tanks or the fuel supply lines?
 | STEP 2D. Check for fuel inlet restriction. | Fuel inlet restriction less than the specifications listed?
STEP 3. | Check the engine operation. |
 | STEP 3A. Crank the engine to see if it starts. | Engine start?
STEP 4. | Check the fuel lift pump operation. |
 | STEP 4A. Check fuel lift pump for activation at keyswitch ON. | Fuel lift pump operate when the keyswitch is turned ON?
 | STEP 4B. Check the fuel lift pump pressure. | Positive fuel pressure greater than 64 kPa [10psi] present when the lift pump is operating?
STEP 5. | Check fuel shutoff valve operation. |
 | STEP 5A. Check the fuel shutoff valve electrical operation. | Fuel shutoff valve operate and is 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON?
 | STEP 5B. Check the fuel shutoff valve mechanical operation. | Pressure difference greater than 69kPa [10 psi]?
 | STEP 5C. Check the fuel lift pump pressure. | Fuel shutoff valve operate and is 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON?
STEP 6. | Check the 1724 kPa [250 psi] fuel pressure regulator. |
 | STEP 6A. Inspect the 1724 kPa [250 psi] fuel pressure regulator. | Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?
STEP 7. | Check the 2620 kPa [380 psi] pressure regulator. |
 | STEP 7A. Inspect the 2620 kPa [380 psi] pressure regulator. | More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?
STEP 8. | Check the fuel pump (gear pump) pressure. |
 | STEP 8A. Measure the fuel pump (gear pump) pressure while cranking. | Fuel pump (gear pump) pressure less than 2413 kPa [350 psi] cranking at 130 rpm for at least 15 second?
STEP 9. | Check the fuel pressure. |
 | STEP 9A. Measure the rail fuel pressure. | Rail fuel pressure at least 1448 kPa [210 psi] at idle?
 | STEP 9B. Measure the fuel pump (gear pump) pressure, engine operating. | Fuel pump (gear pump) pressure a minimum of 1931 kPa [280 psi] at 2000 rpm?
STEP 10. | Check for air in the pressure-side fuel. |
 | STEP 10A. Check for air in the pressure-side fuel. | Air present in the pressure-side fuel?
STEP 11. | Check the fuel inlet restriction. |
 | STEP 11A. Measure the fuel inlet restriction. | Fuel inlet restriction less than the specification?
STEP 12. | Check the fuel shutoff valve. |
 | STEP 12A. Check for a mechanical restriction of the fuel shutoff valve. | Debris present in the fuel shutoff valve or are there signs the fuel shutoff valve is restricting flow?
STEP 13. | Check the pressure fuel filter. |
 | STEP 13A. Measure the pressure drop across the pressure fuel filter. | Pressure drop across the pressure-side fuel filter less than 517 kPa [75 psi]?
STEP 14. | Check the 1724 kPa [250 psi] fuel pressure regulator. |
 | STEP 14A. Inspect the 1724 kPa [250 psi] fuel pressure regulator. | Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?
STEP 15. | Check the 2620 kPa [380 psi] pressure regulator. |
 | STEP 15A. Inspect the 2620 kPa [380 psi] pressure regulator. | More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?
STEP 16. | Check the fuel pressure sensor for accuracy. |
 | STEP 16A. Verify the fuel pressure sensor for accuracy. | INSITE™ electronic service tool reading and pressure gauge reading match within 138 kPa [20 psi]?
STEP 17. | Clear the fault codes. |
 | STEP 17A. Disable the fault code. | Fault Code 482 inactive?
 | STEP 17B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: If Fault Code 482 is active or inactive, attempt to clear fault. If fault remains active or inactive, continue through tree.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227

Go to 2A

Guided Step 2 - Check the fuel supply.

Guided Step 2A - Verify the fuel system has been primed.

Conditions

  • Turn keyswitch OFF.

Action

If entering this tree after a component has been replaced in the fuel system, or after the engine was emptied of fuel, verify the fuel system has been properly primed before proceeding.

  • Verify the fuel system has been properly primed.
  • Use the following procedure for fuel system priming information found in the Signature™, ISX, and QSX15, Service Manual, Bulletin 3666239. Refer to Procedure 006-015 in Section 6.

Fuel system properly primed?
YES NO
No Repair

Prime the fuel system.

  • Refer to Procedure 006-015 in Section 6.

Go to 2B

Go to 17A

Guided Step 2B - Check the vehicle fuel tanks for fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle fuel tanks for fuel.

Fuel in the fuel tanks?
YES NO
No Repair

Fill the fuel tanks.

Go to 2C

Go to 17A

Guided Step 2C - Check for fuel leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel tanks, lines, and related components for leaks.

  • Inspect for fuel leaks.

Any fuel leaks in the tanks or the fuel supply lines?
YES NO

Locate and repair the source of the fuel leak by checking all the engine and OEM supply lines, fittings, suction-side fuel filter head, fuel tank stand pipes, ECM cooling plate, and ECM cooling plate fuel supply and return lines.

No Repair

Go to 17A

Go to 2D

Guided Step 2D - Check for fuel inlet restriction.

Conditions

  • Connect the vacuum gauge to the suction side Compuchek™ fitting.
  • Turn keyswitch ON.
  • Operate engine at high idle (engine cranking if troubleshooting No-Start).

Action

If the engine uses a priming pump, wait until the priming pump has turned off and observe the reading on the vacuum gauge.

  • Check the fuel inlet restriction.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction less than the specifications listed?
YES NO

Use the following procedure for fuel inlet restriction specifications in Signature™, ISX, and QSX15 Service Manual, Bulletin 366623. Refer to Procedure 018-016 in Section V.

Locate the cause of high fuel inlet restriction.

Check the suction-side fuel filter and fuel supply lines.

Note: For QSK only, check the 300 micron inlet filter screen for debris.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.Refer to Procedure 005-073 in Section 5.

Go to 3A

Repair complete

Guided Step 3 - Check the engine operation.

Guided Step 3A - Crank the engine to see if it starts.

Conditions

  • Turn keyswitch ON.

Action

Crank the engine to see if it starts.

  • Start the engine.

Engine start?
YES | NO
No Repair | No Repair

Go to 9A

Go to 4A

Guided Step 4 - Check the fuel lift pump operation.

Guided Step 4A - Check the fuel lift pump for activation at keyswitch ON.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel lift pump for activation at keyswitch ON.

  • Verify the fuel lift pump operates when the vehicle keyswitch is turned ON.

Fuel lift pump operate when the keyswitch is turned ON?
YES NO
No Repair

Use the following procedure to check the fuel lift pump. Refer to Procedure 019-397 in Section 19.

Go to 4B

Go to 17A

Guided Step 4B - Check the fuel lift pump pressure.

Conditions

  • Turn keyswitch ON.
  • Connect a pressure gauge on the gear pump inlet Compuchek™ fitting.

Action

Check the fuel lift pump pressure.

  • Verify there is a positive fuel pressure greater than 64 kPa [10 psi] when the fuel lift pump is operating.

Note: Erratic fuel lift pump pressure can indicate air in the fuel.

Positive fuel pressure greater than 64 kPa [10 psi] present when the lift pump is operating?
YES NO
No Repair

Repair or replace the fuel lift pump. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-045 in Section 5.

Go to 5A

Go to 17A

Guided Step 5 - Check the fuel shutoff valve.

Guided Step 5A - Check the fuel shutoff valve electrical operation.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel shutoff valve for activation at keyswitch ON.

  • Verify the fuel shutoff operates and there is 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned on.

Fuel shutoff valve operate and is 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON?
YES NO
No Repair

  • Refer to Procedure 019-049 in Section 19 to check the fuel shutoff valve.

Go to 5B

Go to 17A

Guided Step 5B - Check the fuel shutoff valve mechanical operation.

Conditions

  • Connect pressure gauge, Part Number 3375932, on the rail fuel pressure Compuchek™ fitting.
  • Connect pressure gauge, Part Number 3375932, on the gear pump output pressure Compuchek™ fitting.
  • Turn keyswitch ON.

Action

Monitor the fuel pressure on both gauges with the lift pump operating.

NOTE: A restricted pressure side fuel filter will cause erroneous fuel pressure drop readings during this test. Address any fuel filter issues before proceeding.

Pressure difference greater than 69kPa [10 psi]?
YES NO
No Repair

  • Refer to Procedure 019-049 in Section 19 to check the fuel shutoff valve.

Go to 5B

Go to 17A

Guided Step 5C - Check the fuel shutoff valve mechanical operation.

Conditions

  • Connect pressure gauge, Part Number 3375932, on the rail fuel pressure Compuchek™ fitting.
  • Connect pressure gauge, Part Number 3375932, on the gear pump output pressure Compuchek™ fitting.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve for activation at keyswitch ON.

  • Verify the fuel shutoff operates and there is 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned on.

Fuel shutoff valve operate and is 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON?
YES NO
No Repair

  • Refer to Procedure 019-049 in Section 19 to check the fuel shutoff valve.

Go to 5B

Go to 17A

Guided Step 5D - Check for a mechanical restriction of the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.

Action

Check for a mechanical restriction of the fuel shutoff valve.

  • Remove and inspect the fuel shutoff valve for a mechanical restriction.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

Debris present in the fuel shutoff valve or are there signs the fuel shutoff valve is restricting flow?
YES NO

  • Repair or replace the fuel shutoff valve.
  • Refer to Procedure 019-050 in Section 19.

No Repair

Go to 17A

Go to 5A

Guided Step 6 - Check the 1724 kPa [250 psi] pressure regulator.

Guided Step 6A - Inspect the 1724 kPa [250 psi] pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 1724 kPa [250 psi] pressure regulator.

  • Disconnect the wiring harness from the fueling and timing actuators.
  • Remove the fuel line that connects the pressure fuel filter head on the integrated fuel system module (IFSM) to the ECM cooling plate at the cooling plate.
  • Install a cap onto the fitting into the cooling plate to make sure no air is brought into the fuel system.
  • Place the fuel line into a bucket and crank the engine. If there is a measurable amount of fuel coming out of the line during cranking, then fuel is bypassing the 1724 kPa [250 psi] regulator.

Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?

YES NO

Remove and inspect the 1724 kPa [250 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.

Replace the 1724 kPa [250 psi] regulator. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 7A

Guided Step 7 - Check the 2620 kPa [380 psi] pressure regulator.

Guided Step 7A - Inspect the 2620 kPa [380 psi] pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 2620 kPa [380 psi] pressure regulator.

  • Disconnect the OEM drain line connection at the integrated fuel system module (IFSM).
  • Install a short piece of hose and place the end of the hose into a bucket.
  • Disconnect the wiring harness from the fueling and timing actuators.
  • Turn keyswitch ON and wait until the lift pump stops operating.
  • Crank the engine for 15 seconds and measure the fuel from the integrated fuel system module (IFSM) drain.

More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?

YES NO

Remove and inspect the 2620 kPa [380 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.

Replace the regulator. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 8A

Guided Step 8 - Check the fuel pump (Gear Pump) pressure.

Guided Step 8A - Measure the fuel pump (gear pump) pressure while cranking.

Conditions

  • Connect a pressure gauge to the Compuchek™ fitting on the back of the fuel pump (gear pump).
  • Disconnect the wire at the fuel shutoff valve.
  • Turn keyswitch ON.

Action

Measure the fuel pump (gear pump) pressure while cranking.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after the keyswitch is turned ON or disconnect the 2-pin power supply from the lift pump.

Note: The engine wiring harness must be disconnected from the fuel shutoff valve during this step.

  • Measure the fuel pump (gear pump) pressure while cranking the engine.

NOTE: Do not crank the engine for 30 seconds continuously. Crank the engine in 15 second intervals with a 15 second pause between intervals this reduces the possibly of over heating the starting motor

Fuel pump (gear pump) pressure less than 2413 kPa [350 psi] cranking at 130 rpm for at least 15 seconds?
YES NO

Repair or replace the fuel pump (gear pump).

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-016 in Section 5.

No Repair

Go to 17A

Go to 17A

Guided Step 9 - Check the fuel pressure.

Guided Step 9A - Measure the fuel pump (gear pump) pressure at idle.

Conditions

  • Connect all components.
  • Connect pressure gauge, Part Number 3375932, or equivalent, onto the Compuchek™ fitting (as shown).
  • Operate engine at idle.

Action

Measure the fuel pump (gear pump) pressure at idle.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.

Measure the fuel pump (gear pump) pressure.

  • With the engine operating at idle, use a pressure gauge attached to the rail pressure Compuchek™ fitting on the IFSM, to measure the fuel pump (gear pump) pressure.

Fuel pump (gear pump) pressure at least 1448 kPa [210 psi] at idle?
YES | NO
No Repair | No Repair

Go to 9B

Go to 12A

Guided Step 9B - Measure the fuel pump (gear pump) pressure at high idle.

Conditions

  • Connect all components.
  • Connect pressure gauge, Part Number 3375932, or equivalent, onto the Compuchek™ fitting (as shown).
  • Turn keyswitch ON.
  • Operate engine at idle.

Action

Measure the fuel pump (gear pump) pressure at high idle.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.
  • Measure the fuel pump (gear pump) pressure with the engine operating at high idle and no load.
  • With the engine operating at idle, use a pressure gauge attached to the rail pressure Compuchek™ fitting on the IFSM to measure the fuel pump (gear pump) pressure.

Fuel pump (gear pump) pressure a minimum of 1931 kPa [280 psi] at 2000 rpm?
YES | NO
No Repair | No Repair

Go to 16A

Go to 10A

Guided Step 10 - Check the air in the pressure-side fuel.

Guided Step 10A - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the pressure-side fuel.

Note: Possible sources of air in the pressure-side fuel are leaks in:

  • OEM supply lines
  • Fittings
  • Suction-side fuel filter head
  • Fuel tank stand pipes
  • ECM cooling plate
  • ECM cooling plate fuel supply and return lines.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-003 in Section 6.

Air present in the pressure-side fuel?
YES NO

Locate and repair the source of the air leak by checking all the OEM supply lines and fittings, suction-side fuel filter head, fuel tank stand pipes, ECM cooling plate, and ECM cooling plate fuel supply and return lines.

No Repair

Go to 17A

Go to 11A

Guided Step 11 - Check the fuel inlet restriction.

Guided Step 11A - Measure the fuel inlet restriction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start the engine.

Action

Measure the fuel inlet restriction.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.
  • Check the fuel inlet restriction.

Clean Suction Filter: 203 mm-Hg [8 in-Hg]

Dirty Suction Filter: 305 mm-Hg [12 in-Hg]

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction less than the specification?
YES NO
No Repair

Replace the suction-side fuel filter or repair the cause of high inlet restriction.

Go to 12A

Go to 17A

Guided Step 12 - Check the fuel shutoff valve.

Guided Step 12A - Check for a mechanical restriction of the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve solenoid, valve disc, valve seat, and actuator disc.

Action

Check for a mechanical restriction of the fuel shutoff valve.

  • Remove and inspect the fuel shutoff valve for a mechanical restriction.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

Debris present in the fuel shutoff valve or are there signs the fuel shutoff valve is restricting flow?
YES NO

Repair or replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 17A

Go to 13A

Guided Step 13 - Check the pressure-side fuel filter.

Guided Step 13A - Measure pressure drop across the pressure-side fuel filter.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine at high idle.

Action

Measure the pressure drop across the pressure-side fuel filter.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.

NOTE: The fuel temperature must be a minimum of 38°C [100°F].

  • Measure the pressure drop across the pressure-side fuel filter while the engine is operating at high idle and no load.
  • Use the Compuchek™ fitting on the back of the fuel pump (gear pump) to measure the pressure out of the fuel pump (gear pump). This will be the high pressure reading.
  • Use the Compuchek™ fitting on the underside of the integrated fuel system module (IFSM) to measure the pressure of the fuel rail. This will be the low pressure reading.
  • Subtract the low reading from the high reading to obtain the pressure drop across the pressure-side fuel filter.

Pressure drop across the pressure-side fuel filter less than 517 kPa [75 psi]?
YES NO
No Repair

Replace the pressure fuel filter.

Go to 14A

Go to 17A

Guided Step 14 - Check the 1724 kPa [250 psi] fuel pressure regulator.

Guided Step 14A - Inspect the 1724 kPa [250 psi] fuel pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 1724 kPa [250 psi] fuel pressure regulator.

  • Disconnect the engine wiring harness from the fueling and timing actuators.
  • Remove the fuel line that connects the pressure fuel filter head on the integrated fuel system module (IFSM) to the ECM cooling plate at the cooling plate.
  • Install a cap onto the fitting into the cooling plate to make sure no air is brought into the fuel system.
  • Place the fuel line into a bucket and crank the engine. If there is a measurable amount of fuel coming out of the line during cranking, then fuel is bypassing the 1724 kPa [250 psi] regulator.

Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?

YES NO

Remove and inspect the 1724 kPa [250 psi] regulator for debris that can stick the regulator open and for cut or missing o-rings.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 15A

Guided Step 15 - Check the 2620 kPa [380 psi] fuel pressure regulator.

Guided Step 15A - Inspect the 2620 kPa [380 psi] fuel pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 2620 kPa [380 psi] fuel pressure regulator.

  • Disconnect the OEM drain line connection at the IFSM.
  • Install a short piece of hose and place the end of the hose in the bucket.
  • Disconnect the wiring harness from the fueling and timing actuators.
  • Turn the keyswitch ON and wait until the lift pump stops operating.
  • Crank the engine for 15 seconds and measure the fuel from the integrated fuel system module (IFSM).

More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?

YES NO

  • Remove and inspect the 2620 kPa [380 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.
  • Replace the regulator. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 16A

Guided Step 16 - Check the fuel pressure sensor for accuracy.

Guided Step 16A - Verify the accuracy of the rail fuel pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Install a pressure gauge on the rail fuel pressure Compuchek™ fitting.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the readings agree.

  • Verify the pressure gauge and INSITE™ electronic service tool reading for the rail fuel pressure sensor agree.

INSITE™ electronic service tool reading and pressure gauge reading match within 138 kPa [20 psi]?
YES NO

Repair or replace the fuel pump (gear pump). Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-016 in Section 5.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 17A

Go to 17A

Guided Step 17 - Clear the fault codes.

Guided Step 17A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 482 is inactive.

Fault Code 482 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 17B

Go to 1A

Guided Step 17B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Jan-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 546 inactive?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 547 active and Fault Code 546 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 546 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins.
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Fault Code 546 inactive? |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 546 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES | NO
No Repair | No Repair

019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine fuel delivery pressure sensor SUPPLY pin to the fuel delivery pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO

A defective sensor has been detected.

Replace the fuel delivery pressure sensor.

Refer to 019-115 (Fuel Rail Pressure Sensor) in Section 19.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine fuel delivery pressure sensor SUPPLY pin to the fuel deliver pressure sensor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 546 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 547 inactive?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 546 active and Fault Code 547 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 547 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins.
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 547 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 547 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the fuel delivery pressure sensor SUPPLY pin to the fuel delivery pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the fuel delivery pressure sensor SUPPLY pin and the fuel delivery pressure sensor SIGNAL pin at the fuel delivery pressure sensor connector of the engine harness.

Use INSITE™ electronic service to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

A defective sensor has been detected.

Replace the fuel delivery pressure sensor.

Refer to Procedure 019-115 (Rail Fuel Pressure Sensor) in Section 19.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the fuel delivery pressure sensor SUPPLY pin to the fuel delivery pressure sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the fuel delivery pressure sensor SUPPLY pin and the fuel delivery pressure sensor SIGNAL pin at the ECM connector.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

An open circuit or a pin-to-pin short circuit has been detected on the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 547 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if the unit has been operating in below freezing temperatures. | Are there signs of freezing in the inlet tube, outlet tube, or breather filter housing?
 | STEP 1B. Check for active fault codes. | Fault Code 555 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 555 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if the unit has been operating in below freezing temperatures.

Conditions

  • None

Action

Check the unit.

  • Check to see if the unit has been operating in below freezing temperatures.

Are there signs of freezing in the inlet tube, outlet tube, or breather filter housing?
YES NO

Customer to install a crankcase breather heater.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 555 active?
YES NO

Replace the crankcase breather filter.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.Refer to Procedure 003-021 in Section 3.
  • For ISX engines, use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-019 in Section 3.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 555 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active or multiple inactive counts of Fault Code 556?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G (0 ± 1.13 in H2O)?
 | STEP 2B. Check mileage/hours on the crankcase ventilation filter since last maintenance. | Filter below the maintenance interval?
 | STEP 2C. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, check valves, breather tubes, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Check for progressive damage. |
 | STEP 4A. Check for progressive damage. | Progressive damage found due to high crankcase pressure?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or multiple inactive counts of Fault Code 556?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate the engine.

Action

Use the INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not running.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.28 kPa - G (0 ± 1.13 in H2O)?

YES NO
No Repair

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check mileage/hours on the crankcase ventilation filter since last maintenance.

Conditions

  • Check the maintenance record (miles / hours) for the latest crankcase ventilation filter replacement.

Action

Check mileage/hours on the crankcase ventilation filter since last maintenance.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance interval for a specific engine application.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase breather element.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-019 in Section 3.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-019 in Section 3.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-002 in Section 3.
  • For ISX engines with an external breather, use the following procedures in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-001 in Section 3.
  • For ISX engines with an internal breather, use the following procedures in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-002 in Section 3.

Oil drain tubes, check valves, breather tubes, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tubes, or oil separator.

  • Use the following procedure for ISX CM871 engines with an external breather, in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-001 in Section 3.
  • Use the following procedure for ISX CM871 engines with an internal breather, in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-002 in Section 3.
  • For ISM CM876 engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-002 in Section 3.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the crankcase blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer

A stall speed test for engines equipped with automatic transmissions only.

Measure the crankcase blowby.

  • Refer to Procedure 014-010 in Section 14.

NOTE: It may be necessary to disable the fault code in order to operate the engine at rated speed. Use INSITE™ electronic service tool to verify the fault code is inactive.

Crankcase blowby measurement within specification?
YES NO

Replace the crankcase breather filter.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-019 in Section 3.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-019 in Section 3.

Troubleshoot the possible causes for excessive crankcase gases.

Go to the Crankcase Gases (Blowby) Excessive symptom tree in the appropriate service manual for a specific engine application.

Go to 4A

Go to 4A

Guided Step 4 - Check for progressive damage.

Guided Step 4A - Check for progressive damage.

Action

Check for progressive damage:

  • Check for progressive damage to the engine due to the high crankcase pressure.
  • Check for oil leaking from gaskets and seals.

Reference the appropiate service manual for a specific engine application.

Progressive damage found due to high crankcase pressure?
YES NO

Replace the damaged gasket, seal, or other component.

Troubleshoot the possible causes for excessive crankcase gases.

Refer to the Crankcase Gases (Blowby) Excessive symptom tree in the appropriate service manual for a specific engine application.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2012


FAULT CODE 584 - Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 584 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10k ohms?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 584 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin.

Use the OEM wiring diagram for starter relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Replace the starter lockout relay.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector to ground.

Use the OEM wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the failed connection.

Clean, repair, or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 584 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 19-Oct-2015


FAULT CODE 585 - Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™//Metri-Pack™/ test lead, Part Number 3822917 - female Deutsch™//AMP™//Metri-Pack™/ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check starter lockout relay and circuit. |
 | STEP 2A. Inspect starter relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the starter lockout relay resistance. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin to ground short circuit in the starter lockout relay. |
 | STEP 2C. Check the starter lockout relay diagnostic supply voltage, supply line, and return circuit. | Greater than 3.75 volts of direct current (VDC)?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 585 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 585 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check starter lockout relay and circuit.

Guided Step 2A - Inspect starter relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the relay resistance.

  • Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the starter lockout relay.

See the OEM troubleshooting and repair manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin to ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter lockout relay.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the starter lockout relay diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 585 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 19-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Are the voltages at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
STEP 2. | Check the charging system. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 596 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM troubleshooting and repair manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.

Are the voltages at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

Note: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator.

Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it run for 10 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 596 is inactive.

Fault Code 596 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 597 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use these test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Battery voltage at least (+) 12 volts of direct current (VDC) under normal conditions and at least (+) 6.2 VDC during cranking?
STEP 2. | Check the alternator and power harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
 | STEP 2B. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit. | More than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Any damaged wires?
 | STEP 2E. Check for a pin-to-pin short circuit in the power harness. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 597 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

See the OEM troubleshooting and repair manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal. Touch the negative (-) probe of the multimeter to the negative battery terminal while trying to start the engine.

Battery voltage at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

See the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and power harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator charging rate (amps).

It will be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

See the OEM troubleshooting and repair manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins of the OEM power harness ECM connector and the positive (+) battery terminal.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the battery harness.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins and the ECM battery SUPPLY (-) pins of the ECM power harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit in the supply wire to the engine block.

Any damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM Battery SUPPLY (+) pins in the OEM power harness connector to all pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it run for 10 minutes.
  • Use INSITE™ electronic service tool to verify Fault Code 597 is inactive.

Fault Code 597 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 19-Oct-2015


FAULT CODE 598 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Voltages at least (+) 12 volts of direct current (VDC) during normal conditions and at least (+) 6.2 VDC during cranking?
STEP 2. | Check the alternator and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
 | STEP 2B. Inspect the battery power connector. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the power harness. | More than 100k ohms?
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 598 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

See the OEM troubleshooting and repair manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.

Voltages at least (+) 12 VDC during normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and OEM harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

It will be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

See the OEM troubleshooting and repair manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the battery at the power connector.

Action

Inspect the battery power connector on both the battery side and the harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the battery power connector.

See the OEM troubleshooting and repair manual for location and procedure.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM

Action

Check for an open circuit.

  • Measure the resistance of the ECM battery supply (+) circuit between the OEM power harness connector and the positive (+) terminal of the battery.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the ECM battery supply (+) pins and all other pins of the power harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit at the supply wire to the engine block ground.

Damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it run for 10 minutes.
  • Use INSITE™ electronic service tool to verify Fault Code 598 is inactive.

Fault Code 598 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 19-Oct-2015


FAULT CODE 629 - Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | Signature™, ISX, and QSX15 | 3666239
Charge-Air Cooler | Refer to Procedure 010-027 | ISM, ISMe, and QSM11 | 3666322
Air Intake Restriction | Refer to Procedure 010-031 | Signature™, ISX, and QSX15 | 3666239
Air Intake Restriction | Refer to Procedure 010-031 | ISM, ISMe, and QSM11 | 3666322

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 122,123, 125, 221, 222, 295, 1843, 1844, or 2973 active, or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the crankcase ventilation system. |
 | STEP 2A. Check for crankcase pressure sensor faults. | Fault Code 555 or 556 active or inactive fault codes with more than one count logged in the last 25 engine hours?
 | STEP 2B. Check the crankcase breather system components. | Any restrictions found?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Check the intake manifold pressure sensor. | INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
STEP 4. | Check the air intake system. |
 | STEP 4A. Check air intake plumbing to compressor inlet for restriction. | Excessive restriction found?
STEP 5. | Check the charge-air cooler system. |
 | STEP 5A. Check the charge-air cooler and charge-air plumbing for leaks. | Air leaks present in the charge-air system?
 | STEP 5B. Check for a restricted charge-air cooler. | Charge-air cooler restriction within specifications?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122,123, 125, 221, 222, 295, 1843, 1844, or 2973 active, or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the crankcase ventilation system.

Guided Step 2A - Check for crankcase pressure sensor faults.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 555 or 556.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 555 or 556 active or inactive fault codes with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2B

Guided Step 2B - Check the crankcase breather system components.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankcase breather system.

  • Check for a restriction in the draft tube.
  • Check for a restriction in the tube between the engine and the filter housing.

Are any restrictions found?
YES NO

Remove the restriction.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and run the engine at high idle after connecting the mechanical intake manifold pressure gauge.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold pressure sensor.

Go to 4A

Go to 6A

Guided Step 4 - Check the air intake system.

Guided Step 4A - Check the air intake plumbing to compressor inlet for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Excessive restriction found?
YES NO

Correct the cause of high intake air restriction. Check for a plugged air filter or restricted air intake piping. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the charge-air cooler system.

Guided Step 5A - Check the charge-air cooler and charge-air plumbing for leaks.

Conditions

  • Operate the engine.

Action

Check the charge-air cooler and charge air plumbing for leaks.

  • Check the charge-air cooler connections for leaks between the turbocharger compressor outlet and the charge-air cooler.
  • Check the charge-air cooler connections between the charge-air cooler and the intake manifold.
  • Check the air compressor inlet plumbing connections between the charge-air cooler and air compressor head for leaks.
  • Inspect the intake manifold gasket for leaks. Inspect the charge-air cooler hoses for leaks or loose connections.
  • Inspect the charge-air cooler clamps to make sure they are tight.Inspect the charge-air plumbing for cracks.

Air leaks present in the charge-air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for a restricted charge-air cooler.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Clear the inactive fault codes.

  • Check the pressure differential across the charge-air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.

Charge-air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler as necessary. Refer to Procedure 010-027 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-May-2015


FAULT CODE 649 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 649. | Fault Code 649 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 649 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 649.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 649.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 649 active?
YES NO

Change the engine lubricating oil and filter.

Use INSITE™ electronic service tool to reset the Maintenance Monitor.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to reset the Maintenance Monitor.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

NOTE: The Maintenance Monitor can also be reset manually. Use the following service bulletin to reset the maintenance monitor. Maintenance Monitor Feature Description and Manual Reset Procedure, Service Bulletin 2883397.

Fault Code 649 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Jul-2012


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Cannon/Metri-Pack test leadPart Number 3822917 female Deutsch/AMP/Cannon/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for intermittent fault condition. |
 | STEP 1A. Operate the engine at idle and high idle to check for fault activation. | Does Fault Code 686 come active during engine operation?
STEP 2. | Check for a failed turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Is the connector or pigtail harness damaged?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Resistance within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code reoccurs. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Does Fault Code 686 come active during engine operation?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 686 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for intermittent fault condition.

Guided Step 1A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool and clear inactive fault codes.
  • Start the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Action

Check for fault activation.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

Does Fault Code 686 come active during engine operation?
YES NO
No Repair

An intermittent fault condition exists. The problem can possibly be with the turbocharger speed sensor circuit; however, the intermittent fault condition can possibly be due to electrical noise that is caused by other devices or faulty grounds.

Go to 2A

Inactive or Intermittent Fault Code, Refer to Procedure 019-362

Guided Step 2 - Check for a failed turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Is the connector or pigtail harness damaged?
YES NO

Repair or replace the damaged connector or turbocharger speed sensor.

Refer to Procedure 019-390.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check the sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor is failed.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the turbocharger speed RETURN (-) pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

NOTE: The resistance of the turbocharger speed sensor circuit must not be more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

For general resistance measurement techniques, refer to Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

Resistance within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector. Otherwise, there is a low resistance (short) across the sensor input pins.

Repair or replace the engine harness or connector(s).

Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed RETURN (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

There is a short between pins of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

NOTE: This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Does Fault Code 686 come active during engine operation?
YES NO

Call for pre-authorization.

Replace the ECM.

Refer to Procedure 019-031.

An intermittent fault condition exists. The problem may exist in the turbocharger speed sensor circuit or it may exist with other vehicle electronic components. The problem may have been corrected when the harness connections were re-engaged.

Be certain that the ECM and chassis grounds are in good condition.

Go to 5A

Inactive or Intermittent Fault Code, Refer to Procedure 019-362.

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

NOTE: This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Fault Code 686 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 687 - Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 122, 123, 221, or 222 active?
STEP 2. | Check for an intermittent fault condition. |
 | STEP 2A. Operate the engine and confirm that the turbocharger speed fault comes active. | Fault Code 687 active during engine operation?
STEP 3. | Check for a damaged turbocharger speed sensor. |
 | STEP 3A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 3B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 3C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the turbocharger speed sensor circuit continuity. | Within 10 ohms of sensor resistance?
 | STEP 4C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 5. | Check the ECM. |
 | STEP 5A. Connect all components and determine if the fault code reoccurs. | Fault Code 687 active during engine operation?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 687 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check for an intermittent fault condition.

Guided Step 2A - Operate the engine and confirm that the turbocharger speed fault comes active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: This step is valid even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Did Fault Code 687 come active during engine operation?
YES NO
No Repair

An intermittent fault condition exists.

Go to 3A

Refer to Procedure 019-362 in Section 19

Guided Step 3 - Check for a damaged turbocharger speed sensor.

Guided Step 3A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the turbocharger speed sensor connector or speed sensor.

  • Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the appropriate wiring diagram.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the appropriate wiring diagram.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Note: The resistance of the turbocharger speed sensor circuit resistance should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 3B.

Refer to the appropriate wiring diagram.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

Repair or replace the engine harness or connector(s).

Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the appropriate wiring diagram.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except turbocharger speed SIGNAL (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the appropriate wiring diagram.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in Section 19.

Inspect the engine harness for a short between two pins.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM.

Guided Step 5A - Connect all components and determine if the fault code recurs.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Start the engine.

Action

Operate the engine at idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle speed.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Did Fault Code 687 come active during engine operation?
YES NO

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

The condition was repaired when the components were reconnected.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Disable the fault code

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

Note: This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 687 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-Jul-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine position sensor and connector. |
 | STEP 2A. Inspect the primary engine position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the primary engine position sensor for damage | Damaged sensor?
STEP 3. | Check the engine position sensor circuit. |
 | STEP 3A. Check the primary engine position sensor supply voltage and return circuit. | Between 4.75 to 5.25 VDC?
 | STEP 3B. Check the primary engine position sensor signal circuit. | Does the INSITE™ electronic service tool value for Engine Speed match the rpm reading on the vehicle's tachometer?
 | STEP 3C. Check the fault code and verify primary engine position sensor condition. | Fault Code 689 active?
STEP 4. | Check the engine position sensor circuit. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4A-1. Check for an open in the primary engine speed sensor signal circuit in the engine wiring harness. |
 | STEP 4A-2. Check the primary engine speed sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 4A-3. Check the fault code and verify primary engine position sensor condition. |
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B-1. Check the sensor supply voltage and return circuit. |
 | STEP 4B-2. Check the fault code and verify primary engine position sensor condition. |
STEP 5. | Clear the fault codes |
 | STEP 5A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply or swapped sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Fault Code 238

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 689 active?

YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the primary engine position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine position sensor from the engine harness.

Action

Inspect the engine harness and primary engine position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the primary engine position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine position sensor from the engine harness.
  • Remove the primary engine position sensor from the gear housing. Refer to Procedure 019-038 (Engine Position Sensor (EPS)) in Section 19.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A defective sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed then inspect the camshaft gear and related components.

Refer to Procedure 019-038 (Engine Position Sensor (EPS)) in Section 19.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine position sensor circuit.

Guided Step 3A - Check the primary engine position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine position sensor (the uppermost engine speed sensor) from the engine harness.
  • Turn keyswitch ON.

Action

Check the primary engine position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the engine position sensor number 1 +5 volt SUPPLY pin and the engine position sensor number 1 RETURN pin at the engine position sensor number 1 connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4B

Guided Step 3B - Check the primary engine position sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Swap the engine position sensor connectors. Connect the engine position sensor number 1 connector to the engine position sensor number 2. Connect the engine position sensor number 2 connector to the engine position sensor number 1.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle for one minute.
  • Disconnect the engine position sensor number 2 connector from the engine position number 1 sensor.

Action

Check the primary circuit.

  • When swapping the sensor connectors, Fault Code 1137 will become active. This is expected and must be ignored throughout Step 3B.
  • Use INSITE™ electronic service tool Monitor Mode to monitor Engine Speed.

Does the INSITE™ electronic service tool value for Engine Speed match the rpm reading on the vehicle's tachometer?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the fault code and verify primary engine position sensor condition.

Conditions

  • Connect all components in the correct positions. Verify the engine position sensor connectors are no longer swapped.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 689 active?
YES NO

A failed engine position sensor has been detected.

Replace the primary engine position sensor (number 1).

Refer to Procedure 019-038 (Engine Position Sensor (EPS)) in Section 19.

None. This removal and reinstallation of the connector corrected the failure.

Go to 5A

Go to 5A

Guided Step 4 - Check the engine position sensor circuit.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 5A

Go to 4A-1

Guided Step 4A-1 - Check for an open primary engine position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine position sensor number 1 SIGNAL pin at the engine harness connector to the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 Ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Check the primary engine position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the primary engine position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine position sensor number 1 SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k Ohms ?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check the fault code and verify the primary engine position sensor condition.

Conditions

  • Connect all components in the correct positions. Verify the engine position sensor connector are no longer swapped.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

None. The removal and reinstallation of the connector corrected the failure.

Go to 5A

Go to 5A

Guided Step 4B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 5A

Go to 4B-1

Guided Step 4B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the primary engine position sensor supply voltage and return circuit

  • Measure the sensor supply voltage between the engine position sensor number 1 +5 volt SUPPLY pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 to 5.25 VDC?
YES NO

A defective connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 5A

Go to 4B-2

Guided Step 4B-2 - Check the fault code and verify primary engine position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

None. The removal and reinstallation of the connector corrected the failure.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 689 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine speed sensor and circuit. |
 | STEP 2A. Inspect the engine speed sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Engine speed sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the engine speed sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate engine speed sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor engine speed sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Fault Code 238

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running.

Action

With the engine running, check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the engine speed sensor and circuit.

Guided Step 2A - Inspect the engine speed sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage from the engine speed +5 volt SUPPLY pin to the engine speed RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool Monitor Mode to read the engine speed sensor state.

Engine speed sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the engine speed +5 volt SUPPLY pin and the engine speed SIGNAL pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool Monitor Mode to read the engine speed sensor state.

Engine speed sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine speed sensor for the following:

  • Damaged sensor tip.
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

Replace the engine speed sensor.

Refer to Procedure 019-038 (Engine Speed Sensor (EPS)) in Section 19.

No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine speed sensor from the engine.
  • Be sure the engine speed sensor is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place the ratchet drive side of the socket tool that was used to remove the sensor from the engine flush on the sensor so that the edge of the socket is on the edge of the sensor. Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Inspect for the following:

  • Check for the appropriate ECM response.
  • Use INSITE™ electronic service tool Monitor Mode to read the engine speed sensor state.

Engine speed sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

Replace the engine speed sensor.

Refer to Procedure 019-038 (Engine Speed Sensor (EPS)) in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate engine speed sensor air gap.

Conditions

  • Install the engine speed sensor in the engine
  • Turn keyswitch ON.
  • Connect the engine speed sensor to the engine harness
  • Connect INSITE™ electronic service tool.

Action

Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary. Monitor the engine speed sensor state of the engine speed sensor for the following:

  • Change of state from high to low, or low to high, or the state shows triggered.

Engine speed sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

Inspect the crankshaft tone wheel/gear teeth for damage or spinning.

  • For ISM engines, refer to the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322 for the repair or replacement.
  • For ISX engines, refer to the Signature, ISX, or QSX15 Service Manual, Bulletin 3666239 for the repair or replacement.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use the INSITE™ electronic service tool Monitor Mode to read the engine speed sensor state.

Engine speed sensor state equals low?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the engine speed +5 volt SUPPLY pin and the engine speed SIGNAL pin at the ECM port.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Read the engine speed sensor state using the INSITE™ electronic service tool Monitor Mode.

Engine speed sensor state equals high?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage from the engine speed +5 volt SUPPLY pin to the engine speed RETURN pin at the ECM port.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 689 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 2. | Check the turbocharger compressor inlet air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor inlet air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 250 ohms to 380k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 691 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 691 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the turbocharger compressor inlet air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor inlet air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin and the turbocharger compressor inlet air temperature sensor RETURN pin at the turbocharger compressor inlet air temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

250 ohms to 380k ohms?
YES NO
No Repair

Replace the turbocharger compressor inlet air temperature sensor.

Refer to Procedure 019-395 (Turbocharger Compressor Inlet Air Temperature Sensor) in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor inlet air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the failure.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor inlet air temperature sensor SIGNAL pin and the turbocharger compressor inlet air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor inlet air temperature sensor RETURN pin and the engine harness turbocharger compressor inlet air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open return.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector compressor inlet air temperature sensor SIGNAL pin and the engine harness turbocharger compressor inlet air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin to pin shorted signal circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 691 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 2. | Check the turbocharger compressor inlet air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor inlet air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 692 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 692 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 692 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the turbocharger compressor inlet air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor inlet air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor inlet air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 is active?
YES NO

A defective sensor has been detected.

Replace the turbocharger compressor inlet air temperature sensor.

Refer to Procedure 019-395 (Turbocharger Compressor Inlet Air Temperature Sensor) in Section 19.

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor inlet air temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 is inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 692 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 697 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 697 active?
YES NO

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 697 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 698 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 698 active?
YES NO

Call for authorization to replace the ECM.Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 698 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheels and speed/position sensors. |
 | STEP 1A. Inspect the engine speed and position sensors for defects. | Any defects?
 | STEP 1B. Inspect the tone wheels for any defects. | Any defects?
STEP 2. | Check for correct engine static timing. |
 | STEP 2A. Check static timing. | Does the proper wedge fit easily between the flat on the injector camshaft and the groove in the cylinder head?
 | STEP 2B. Inspect the geartrain. | Any defects?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 731 inactive?
 | STEP 3B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Inspect the tone wheels and speed/position sensors.

Guided Step 1A - Inspect the engine speed and position sensors for defects.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine speed and position sensors for defects.

Any defects?
YES NO

Replace the speed or position sensor. Refer to Procedure 019-038 (Engine Position Sensor (EPS)) in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Inspect the tone wheels for any defects.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft tone wheels for defects.

Any defects?
YES NO

Replace the tone wheel.

  • For ISM engines, refer to the camshaft or crankshaft removal procedure in the ISM, ISMe, and QSM11 Engines Service Manual, Bulletin 3666322.
  • For ISX engines, refer to the camshaft or crankshaft removal procedure in the Signature, ISX, and QSX15 Engines Service Manual, Bulletin 3666239.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for correct engine static timing.

Guided Step 2A - Check static timing.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Rotate the engine to the insert pin mark on the damper.
  • Install the injector camshaft timing wedge.

Action

Inspect the engine static timing.

  • Refer to Procedure For ISM engines, 006-025 in the ISM, ISMe, and QSM11 Engines Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 001-088 in the Signature, ISX, and QSX15 Engines Service Manual, Bulletin 3666239.

Does the proper wedge fit easily between the flat on the injector camshaft and the groove in the cylinder head?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the gear train.

Conditions

  • Turn keyswitch OFF.

Action

Remove the upper and lower front gear covers.

  • Refer to Procedure For ISX engines, 001-079 (Gear Cover, Upper) and Refer to Procedure 001&ndash;080 (Gear Cover, Lower) in Section 1 in the Signature, ISX, and QSX15 Engines Service Manual, Bulletin 3666239.
  • Refer to Procedure For ISM engines, 001&ndash;031 in the ISM, ISMe, and QSM11 Engines Service Manual, Bulletin 3666322.

Inspect the geartrain for damage that would lead to slippage.

Any defects?
YES NO

  • For ISX engines, refer to the Signature, ISX, and QSX15 Engines Service Manual, Bulletin 3666239 for repair procedure.
  • For ISM engines, refer to the ISM, ISMe, and QSM11 Engines Service Manual, Bulletin 3666322 for repair procedure.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 731 is inactive.

Fault Code 731 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location, if all the steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool, read the fault codes.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 778 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome‡ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 778 active?
STEP 2. | Check the engine position sensor and connector. |
 | STEP 2A. Inspect the backup engine position sensor and connector pins | Dirty or damaged pins?
 | STEP 2B. Inspect the backup engine position sensor for damage. | Damaged sensor?
STEP 3. | Check the engine position sensor circuit. |
 | STEP 3A. Check the backup engine position sensor supply voltage and return circuit. | Between 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 3B. Check the backup engine position sensor signal circuit. | INSITE™ electronic service tool value for engine speed matches the rpm reading on the vehicle tachometer?
 | STEP 3C. Check the fault code and verify backup engine position sensor condition. | Fault Code 778 active?
STEP 4. | Check the engine position sensor circuit. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4A-1. Check for an open backup engine position sensor signal from the engine harness. |
 | STEP 4A-2. Check the backup engine position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 4A-3. Check the fault code and verify the backup engine position sensor condition. |
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B-1. Check the sensor supply voltage and return circuit. |
 | STEP 4B-2. Check the fault code and verify the backup engine position sensor condition. |
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 778 inactive?
 | STEP 5B. Clear the inactive fault codes. | All Faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for primary engine position sensor supply or swapped sensor fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 187 or 227 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 187 or 227 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine position sensor and connector.

Guided Step 2A - Inspect the backup engine position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the backup engine position sensor and connector pins.

Action

Inspect the engine harness and backup engine position sensor (Number 2) connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the backup engine position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the backup engine position sensor from the engine harness.
  • Remove the backup engine position sensor from the gear housing. Refer to Procedure 019-038 in Section 19.

Action

Inspect the backup engine position sensor (Number 2) for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor
  • Oil leakage or insulation problems such as swelling
  • Damage to the electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the camshaft gear and related components.

Refer to Procedure 019-038 in Section 19.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine position sensor circuit.

Guided Step 3A - Check the backup engine position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the backup engine position sensor (the lowermost engine position sensor) from the engine harness.
  • Turn keyswitch ON.

Action

Check the backup engine position sensor (Number 2) supply voltage and return circuit.

  • Measure the sensor supply voltage between the engine position sensor number 2 +5 volt SUPPLY pin and the engine position sensor number 2 RETURN pin at the engine position sensor number 2 connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4B

Guided Step 3B - Check the backup engine position sensor signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Swap the engine position sensor connectors. Connect the engine position sensor Number 1 connector to the engine sensor Number 2. Connect the engine position Number 2 connector to the engine position sensor Number 1.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle for one minute.
  • Disconnect the engine position sensor Number 1 connector from the engine position Number 2 sensor.

Action

When swapping the sensor connectors, Fault Code 1137 will become active. This is expected and must be ignored throughout Step 3B.

  • Use INSITE™ electronic service tool Monitor Mode to monitor the engine speed.

INSITE™ electronic service tool value for engine speed matches the rpm reading on the vehicle tachometer?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the fault code and verify the backup engine position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Verify the engine position sensor connectors are no longer swapped.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

A malfunctioning engine position sensor has been detected.

Replace the backup engine position sensor (Number 2).

Refer to Procedure 019-038 in Section 19.

None. The removal and reinstallation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check the engine position sensor circuit.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damage harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4A-1

Guided Step 4A-1 - Check for an open backup engine position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the backup engine position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine position sensor number 2 SIGNAL pin at the engine harness engine position sensor number 2 sensor connector to the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Check the backup engine position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the backup engine position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine position sensor Number 2 SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k Ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check the fault code and verify the backup engine position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Verify the engine position sensor connectors are no longer swapped.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

None. The removal and reinstallation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pons.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B-1

Guided Step 4B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the ECM connector.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the sensor supply voltage between the engine position sensor Number 2 +5 volt SUPPLY pin and the engine position sensor Number 2 RETURN pin at the ECM.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 to 5.25 VDC?
YES NO

A damaged connection has been detected n the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B-2

Guided Step 4B-2 - Check the fault code and verify the backup engine position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 778 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 19-Oct-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 778 active?
STEP 2. | Check the camshaft position sensor and circuit. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | +4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Camshaft position sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the camshaft position sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate camshaft position sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor engine speed sensor state/camshaft position sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | +4.75 to 5.25 VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 778 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 227 active?
YES | NO
No Repair | No Repair

Fault Code 187 or 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running.

Action

With the engine running, check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Guided Step 2 - Check the camshaft position sensor and circuit.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage from the camshaft position +5 volt SUPPLY pin to the camshaft position RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

+4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool Monitor Mode to read the camshaft position sensor state.

Camshaft position sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the camshaft position +5 volt SUPPLY pin and the camshaft position SIGNAL pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool Monitor Mode to read the camshaft position sensor state.

Camshaft position sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the camshaft position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine.

Action

Inspect the camshaft position sensor for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

Replace the camshaft position sensor.

Refer to Procedure 019-363 (Camshaft Position Sensor) in Section 19.

No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the camshaft position sensor from the engine.
  • Make sure the camshaft position sensor is connected to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Using the ratchet drive side of the socket tool that was used to remove the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor. Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Inspect for the following:

  • Check for the appropriate ECM response
  • Use INSITE™ electronic service tool Monitor Mode to read the camshaft position sensor state.

Camshaft position sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to Procedure 019-363 (Camshaft Position Sensor) in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate camshaft position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Install the camshaft position sensor in the engine.
  • Connect the camshaft position sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary. Monitor the camshaft position sensor state of the camshaft position sensor for the following:

  • Change of state from high to low, or low to high, or the state shows triggered.

Camshaft position sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

Inspect the camshaft tone wheel/gear teeth for damage or spinning.

Refer to the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool Monitor Mode to read the camshaft position sensor state.

Camshaft position sensor state equals low?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the camshaft position +5 volt SUPPLY pin and the camshaft position SIGNAL pin at the ECM port.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool Monitor Mode to read the camshaft position sensor state.

Camshaft position sensor state equals high?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19..

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM sensor supply voltage.

  • Measure the voltage from the camshaft position +5 volt SUPPLY pin to the camshaft position RETURN pin at the ECM port.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

+4.75 to 5.25 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 778 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 784 - Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the adaptive cruise control hardware. |
 | STEP 1A. Check for installed adaptive cruise control hardware. | Adaptive cruise control hardware installed on vehicle?
STEP 2. | Check Society of Automotive Engineers (SAE) J1939 communication. |
 | STEP 2A. Check for engine control module (ECM) communication with INSITE™ electronic service tool. | INSITE™ electronic service tool communicates with the ECM?
 | STEP 2B. Inspect the original equipment manufacturer (OEM) harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check ECM communication with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with the ECM?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 784 inactive?
 | STEP 3B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the adaptive cruise control hardware.

Guided Step 1A - Check for installed adaptive cruise control hardware.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle for installed adaptive cruise control hardware.

Adaptive cruise control hardware installed on the vehicle?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Adaptive Cruise feature.

Go to 2A

Go to 3A

Guided Step 2 - Check SAE J1939 communications.

Guided Step 2A - Check for ECM communication with INSITE™

Conditions

  • Turn keyswitch ON.
  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™, electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool.
  • Select INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

See the OEM troubleshooting and repair manual for information on troubleshooting the adaptive cruise control unit and the vehicle SAE J1939 network.

No Repair

See the OEM troubleshooting and repair manual

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter to the ECM bench calibration harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™, electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM SAE J1939 data link circuit is functioning properly.

See the OEM troubleshooting and repair manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

See the OEM troubleshooting and repair manual.

See the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree in Section TS.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 784 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 19-Oct-2015


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 volts of direct current (VDC) [(+) 24-VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire interrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1117 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 active?
YES NO
No Repair

If high inactive counts of Fault Code 1117 are found in the ECM. check the battery disconnect devices in the vehicle. If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system];

During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM power harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s).

  • Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire interrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 and a wiring diagram.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2015


FAULT CODE 1239 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response. | Fault Code 1241 active and Fault Code 1239 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1239 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1239 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1239 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Go to Fault Code 1695 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Use the OEM diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active and Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active?
YES NO

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Use the circuit diagram and the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1239 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 1241 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response. | Fault Code 1239 active and Fault Code 1241 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1241 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin to ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1241 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1241 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to Fault Code 1696 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal position sensor supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Use the OEM diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the accelerator pedal position 5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Use the OEM diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active and Fault Code 1241 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal.

See the OEM troubleshooting and repair manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SUPPLY pin and the OEM harness accelerator pedal connector SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin to ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1241 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 1242 - Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 131, 132, 1239, or 1241 active?
STEP 2. | Check the accelerator pedal position sensor readings. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 132 and 1241 both active?
 | STEP 2C. Check the accelerator pedal position 1 sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2D. Check the accelerator pedal position 2 sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 1242 inactive?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1242 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131, 132, 1239, or 1241 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor readings.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 132 and 1241 both active?
YES NO
No Repair

If Fault Code 132 did not go active, follow Fault Code 132 troubleshooting tree.

If Fault Code 1241 did not go active, follow Fault Code 1241 troubleshooting tree.

Go to 2C

Go to the appropriate fault code troubleshooting tree.

Guided Step 2C - Check the accelerator pedal position 1 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position 1 sensor +5 volt SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM harness.

Use the OEM diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 132 troubleshooting tree.

Go to 2D

Go to the Fault Code 132 troubleshooting tree.

Guided Step 2D - Check the accelerator pedal position 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position 2 sensor +5 volt SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM harness.

Use the OEM diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 1241 troubleshooting tree.

Go to 2E

Go to the Fault Code 132 troubleshooting tree.

Guided Step 2E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1242 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal.

See the OEM troubleshooting and repair manual.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

See OEM troubleshooting procedures.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1242 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Aftertreatment Exhaust Gas Temperature 1 Swapped - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1674, 1675, 1676, 1665, 1666, or 1667 active?
 | STEP 1B. Check for fault codes. | Fault Code 1663 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Verify the repair. | Fault Code 1663 cleared?
 | STEP 2B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674, 1675, 1676, 1665, 1666, or 1667 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

The aftertreatment diesel oxidation catalyst inlet temperature sensor and the aftertreatment diesel particulate filter inlet temperature sensor have different electrical connector keys. It should not be possible to swap the connections unless the sensors are installed in the incorrect location in the aftertreatment system.

Fault Code 1663 active?
YES NO

The aftertreatment diesel oxidation catalyst inlet temperature sensor and the aftertreatment diesel particulate filter inlet temperature sensor readings are reversed.

Inspect the sensor connectors. The aftertreatment diesel particulate filter inlet temperature sensor should have a different connector key than the other sensors.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Turn keyswitch OFF for 30 seconds.
  • Turn keyswitch ON and read the fault codes using INSITE™ electronic service tool.

If Fault Code 1663 is still active at key-on, allow the aftertreatment temperatures to cool below 32°C [90°F].

Start and run the engine at high idle for 10 minutes to clear the fault code.

Fault Code 1663 cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting tree

Last Modified: 05-Jul-2011


FAULT CODE 1664 - Catalyst Missing - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1674, 1675, 1676, 1665, 1666, or 1667 active?
 | STEP 1B. Check for inactive fault codes | Fault Code 1963 inactive?
 | STEP 1C. Check for the presence of a diesel oxidation catalyst. | Is the diesel oxidation catalyst present in the aftertreatment system?
STEP 2. | Clear the fault code. |
 | STEP 2A. Verify the repair. | Fault Code 1664 cleared?
 | STEP 2B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674, 1675, 1676, 1665, 1666, or 1667 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1963 inactive?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for the presence of a diesel oxidation catalyst.

Conditions

  • Turn keyswitch OFF.
  • Remove the diesel oxidation catalyst from the vehicle. Refer to Procedure 011-049 in Section 11 in either the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Action

Check the diesel oxidation catalyst.

Inspect for the presence of the diesel oxidation catalyst in the exhaust system.

Remove the diesel oxidation catalyst from the vehicle.

  • Refer to Procedure 011-049 in Section 11 in either the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Is the diesel oxidation catalyst present in the aftertreatment system?
YES NO
No Repair

Install the proper diesel oxidation catalyst for the application.

Refer to the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Refer to Procedure 014-013 in Section 14 in either the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Test found in the ECM Diagnostic Tests.

Note: It will be necessary to perform a Stationary Regeneration of the aftertreatment system to verify the fault code has been repaired. Use INSITE™ electronic service tool to perform the test.

Fault Code 1664 cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jan-2012


FAULT CODE 1665 - Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1665 inactive?
STEP 2. | Check the aftertreatment diesel oxidation catalyst inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel oxidation catalyst inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1666 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1665 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1665 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1665 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel oxidation catalyst inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel oxidation catalyst inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel oxidation catalyst inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel oxidation catalyst inlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 active?
YES NO

Replace the aftertreatment diesel oxidation catalyst inlet temperature sensor.

Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1665 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 1666 - Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1666 inactive?
STEP 2. | Check the aftertreatment diesel oxidation catalyst inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel oxidation catalyst inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1665 active and Fault Code 1666 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1666 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1665 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1666 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel oxidation catalyst inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel oxidation catalyst inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel oxidation catalyst inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment diesel oxidation catalyst inlet temperature SIGNAL pin and the aftertreatment diesel oxidation catalyst inlet temperature RETURN pin at the sensor connector of the wiring harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 active and Fault Code 1666 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel oxidation catalyst inlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 active?
YES NO

A damaged aftertreatment diesel oxidation catalyst inlet temperature sensor has been detected.

Replace the aftertreatment diesel oxidation catalyst inlet temperature sensor.

Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel oxidation catalyst inlet temperature sensor RETURN pin and the wiring harness aftertreatment diesel oxidation catalyst inlet temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor RETURN wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL pin and the wiring harness aftertreatment diesel oxidation catalyst inlet temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel oxidation catalyst inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel oxidation catalyst inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1666 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 1667 - Aftertreatment Exhaust Gas Temperature 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1665 or 1666 active?
STEP 2. | Check the aftertreatment diesel oxidation catalyst (DOC) inlet temperature sensor, the aftertreatment diesel particulate filter (DPF) inlet temperature sensor, and circuit. |
 | STEP 2A. Inspect the aftertreatment DOC inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Inspect the aftertreatment DPF inlet temperature sensor connector pins. |
 | STEP 2B. Check the aftertreatment DOC inlet temperature sensor for an open circuit. | Fault Code 1666 active?
 | STEP 2C. Check the aftertreatment DOC inlet temperature sensor for a short circuit | Fault Code 1665 active?
 | STEP 2D. Check the aftertreatment DPF inlet temperature sensor for an open circuit. | Fault Code 1675 active?
 | STEP 2E. Check the aftertreatment DPF inlet temperature sensor for a short circuit. | Fault Code 1674 active?
 | STEP 2F. Monitor the aftertreatment DOC inlet temperature sensor. | Measured resistance value of aftertreatment DOC inlet temperature sensor in range?
 | STEP 2G. Monitor the aftertreatment DPF inlet temperature sensor. | Measured resistance value of aftertreatment DPF inlet temperature sensor in range?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin signal short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin signal short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for a mis-wired harness. | Aftertreatment temperature sensor pins in correct locations?
STEP 4. | Inspect the aftertreatment DOC. |
 | STEP 4A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the inlet face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment DOC for cracks in the cell wall. | Cracks found in the cell walls?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the repair. | Aftertreatment DOC inlet temperature and aftertreatment DPF inlet temperature readings within 24°C or 43°F of each other?
 | STEP 5B. Check if an ECM calibration update is available | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5C. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 or 1666 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1665 or 1666.

Go to 2A

Guided Step 2 - Check the aftertreatment DOC inlet temperature sensor, the aftertreatment DPF inlet temperature sensor, and circuit.

Guided Step 2A - Inspect the aftertreatment DOC inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment DOC inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.
  • Replace the aftertreatment DOC inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 5A

Go to 2A-1

Guided Step 2A-1 - Inspect the aftertreatment DPF inlet temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment DPF inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace the aftertreatment DPF inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the aftertreatment DOC inlet temperature sensor for an open circuit

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the aftertreatment DOC inlet temperature sensor for a short circuit

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DOC inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response.

  • Place a jumper wire between the aftertreatment DOC inlet temperature SIGNAL pin and the aftertreatment DOC inlet temperature RETURN pin at the aftertreatment DOC inlet temperature connector of the wiring harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the aftertreatment DPF inlet temperature sensor for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check the aftertreatment DPF inlet temperature sensor for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response.

  • Place a jumper wire between the aftertreatment DPF inlet temperature SIGNAL pin and the aftertreatment DPF inlet temperature RETURN pin at the aftertreatment DPF inlet temperature connector of the wiring harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 active?
YES | NO
No Repair | No Repair

Go to 2F

Go to 3A

Guided Step 2F - Monitor the aftertreatment DOC inlet temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting symptom tree.
  • If no fault codes occur, record the temperature reading of the aftertreatment DOC inlet temperature sensor using the electronic service tool.
  • Disconnect the aftertreatment DOC inlet temperature sensor from the wiring harness.
  • Connect two Cummins® service test leads, Part Number 3164597, of the Cummins® Electrical Test Kit, Part Number 4919115, to the Cummins® aftertreatment DOC inlet temperature sensor harness connector.
  • Use a digital multimeter to record the resistance value of the aftertreatment DOC inlet temperature sensor.
  • Compare the recorded resistance value of the aftertreatment DOC inlet temperature sensor against the values in the Temperature vs Resistance Chart in the following procedure. Refer to Procedure 019-449 in Section 19.

Measured resistance value of aftertreatment DOC inlet temperature sensor in range?
YES NO
No Repair

A damaged sensor has been detected.

Replace the aftertreatment DOC inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 2G

Go to 5A

Guided Step 2G - Monitor the aftertreatment DPF inlet temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting symptom tree.
  • If no fault codes occur, record the temperature reading of the aftertreatment DPF inlet temperature sensor using the electronic service tool,
  • Disconnect the aftertreatment DPF inlet temperature sensor from the wiring harness.
  • Connect two Cummins® service test leads, Part Number 3164597, of the Cummins® Electrical Test Kit, Part Number 4919115, to the aftertreatment DPF inlet temperature sensor harness connector.
  • Use a digital multimeter to record the resistance value of the aftertreatment DPF inlet temperature sensor.
  • Compare the recorded resistance value of the aftertreatment DPF inlet temperature sensor against the values in the Temperature vs Resistance Chart in the following procedure. Refer to Procedure 019-449 in Section 19.

Measured resistance value of aftertreatment DPF inlet temperature sensor in range?
YES NO
No Repair

A damaged sensor has been detected.

Replace the aftertreatment DPF inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-pin signal short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DOC inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DOC inlet temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment DOC inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DOC inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DOC inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the aftertreatment DOC inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin signal short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF inlet temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment DOC inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3E

Go to 5A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DPF inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the aftertreatment DOC inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3F

Go to 5A

Guided Step 3F - Check for a mis-wired harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DOC inlet temperature sensor, DPF inlet temperature sensor, and DPF outlet temperature sensor from the wiring harness.

Action

Check for sensor pins or wires installed in incorrect connector locations between the OEM connector and each of the temperature sensors. For example, installing the SIGNAL pin in the RETURN pin location and the RETURN pin in the SIGNAL pin location on an aftertreatment temperature sensor can cause active faults to occur.

  • Use an ohm meter to verify the correct location of each aftertreatment temperature sensor wire. A length of jumper wire may be required to measure resistance from the OEM connector to the aftertreatment temperature sensor connections.

Reference the appropriate circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Aftertreatment temperature sensor pins in correct locations?
YES NO
No Repair

A mis-wired OEM harness and/or aftertreatment harness has been detected.

Repair the OEM harness and/or the aftertreatment harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Inspect the aftertreatment DOC.

Guided Step 4A - Check the aftertreatment DOC for soot accumulation.

Conditions

Remove the aftertreatment DOC.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-049 in Section 11.

Action

Inspect the aftertreatment catalyst.

Check the inlet face of the aftertreatment DOC for soot accumulation.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-049 in Section 11.

More than 50 percent of the cells on the inlet face completely blocked by soot?
YES NO

Clean the aftertreatment DOC.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-049 in Section 11.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment DOC.

Check for cracks in the aftertreatment DOC cell wall.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-049 in Section 11.

Cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-049 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-049 in Section 11.

A damaged sensor has been detected.

  • Replace the aftertreatment DOC inlet temperature sensor. Refer to Procedure 019-449 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the temperature readings.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for Aftertreatment DOC Inlet Temperature and Aftertreatment DPF Inlet Temperature.

The engine must be running at high idle for 25 minutes and the aftertreatment DOC inlet temperature must be above 150°C [302°F] before the fault code will clear.

Aftertreatment DOC inlet temperature and aftertreatment DPF inlet temperature readings within 24°C or 43°F of each other?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5C

Go to 5C

Guided Step 5C - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 06-May-2013


FAULT CODE 1674 - Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1674 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1675 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1674 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1674 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1674 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel particulate filter inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter inlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 active?
YES NO

Replace the aftertreatment diesel particulate filter inlet temperature sensor.

Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin in the OEM harness ECM connector an all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1674 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 1675 - Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1675 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1674 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1675 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1675 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1675 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel particulate filter inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment diesel particulate filter inlet temperature SIGNAL pin and the aftertreatment diesel particulate filter inlet temperature RETURN pin at the sensor connector of the wiring harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter inlet temperature sensor to the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES NO

A damaged aftertreatment diesel particulate filter inlet temperature sensor has been detected.

Replace the aftertreatment diesel particulate filter inlet temperature sensor.

Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 10.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter inlet temperature sensor RETURN pin and the OEM harness aftertreatment diesel particulate filter inlet temperature sensor connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel particulate filter inlet temperature sensor RETURN wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin and the wiring harness aftertreatment diesel particulate filter inlet temperature sensor connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 1675 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1675 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 1676 - Aftertreatment Exhaust Gas Temperature 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1674 or 1675 active or high inactive counts?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1675 active?
 | STEP 2C. Check the circuit response. | Fault Code 1674 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature readings within 10°C or 18°F of each other?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 or 1675 active or high inactive counts?
YES | NO
No Repair | No Repair

Fault Code 1674 or 1675 troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness.

  • Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors.

  • Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter inlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Inspect the wiring harness and aftertreatment diesel particulate filter inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment diesel particulate filter inlet temperature SIGNAL pin and the aftertreatment diesel particulate filter inlet temperature RETURN pin at the aftertreatment diesel particulate filter inlet temperature connector of the wiring harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 active?
YES NO

A damaged aftertreatment diesel particulate filter inlet temperature sensor has been detected.

Replace the aftertreatment diesel particulate filter inlet temperature sensor.

  • Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter inlet temperature sensor from the wiring harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM.

  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

A pin-to-ground short circuit in the aftertreatment diesel particulate filter inlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for the exhaust gas temperature 1 and aftertreatment diesel particulate filter inlet temperature.

Note: The engine must be running at 1200 rpm or above for 15 minutes and the aftertreatment diesel oxidation catalyst inlet temperature must be above 150°C [302°F] before the fault code will clear.

Aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature readings within 10°C or 18°F of each other?

YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-Dec-2011


FAULT CODE 1691 - Catalyst Efficiency - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM871 | 3666239
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISM CM876 | 3666322
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM871 | 3666239
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISM CM876 | 3666322
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM871 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | ISM CM876 | 3666322
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISM CM876 | 4021560

Cautions and Warnings

WARNING

During regeneration, exhaust gas temperature can reach 800°C [1500°F], and the exhaust system surface temperature can exceed 700°C [1300°F], which is hot enough to ignite or melt common materials, and to burn people. The exhaust and exhaust components can remain hot after the vehicle has stopped moving. To avoid the risk of fire, property damage, burns or other serious personal injury allow the exhaust system to cool before beginning this procedure or repair and make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for exhaust gas recirculation (EGR) valve and variable geometry turbocharger related fault codes. | Fault codes found that are related to the EGR or variable geometry turbocharger operation?
 | STEP 1B. Check for active fault codes. | Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, or aftertreatment fuel shutoff valve active?
 | STEP 1C. Check for Fault Code 1691. | Fault Code 1691 active or inactive counts?
STEP 2. | Check the aftertreatment temperature sensors. |
 | STEP 2A. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 10°C [18°F]?
STEP 3. | Check for other active fault codes. |
 | STEP 3A. Check for Fault Code 2637. | Fault Code 2637 active or inactive?
 | STEP 3B. Check for Fault Code 2638. | Fault code 2638 active?
 | STEP 3C. Check for Fault Code 2638. | Fault code 2638 active?
STEP 4. | Perform the Aftertreatment Maintenance Reset All procedure. |
 | STEP 4A. Perform the Aftertreatment Maintenance Reset All procedure. | Aftertreatment Maintenance Reset All procedure completed?
 | STEP 4B. Perform the Aftertreatment Maintenance Reset All procedure. | Aftertreatment Maintenance Reset All procedure completed?
 | STEP 4C. Perform the Aftertreatment Maintenance Reset All procedure. | Aftertreatment Maintenance Reset All procedure completed?
STEP 5. | Check the flow of the aftertreatment fuel injector. |
 | STEP 5A. Flow the aftertreatment fuel injector and check if the flow is greater than 110 ml. | Flow greater than 110 ml?
 | STEP 5B. Flow the aftertreatment fuel injector and check if the flow is greater than 250 ml. | Flow greater than 250 ml?
 | STEP 5C. Flow the aftertreatment fuel injector and check if the flow is greater than 250 ml. | Flow greater than 250 ml?
STEP 6. | Perform the stationary regeneration procedure. |
 | STEP 6A. Perform the stationary regeneration procedure. | Stationary regeneration started?
 | STEP 6B. Check for exhaust leaks while performing the stationary regeneration procedure. | Exhaust system leaks found?
 | STEP 6C. Perform the stationary regeneration procedure. | Fault Code 1691 inactive after running the stationary regeneration procedure?
STEP 7. | Check the engine control module (ECM) calibration. |
 | STEP 7A. Check if an ECM calibration update is available | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 1691 inactive?
 | STEP 8B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for exhaust gas recirculation (EGR) valve and variable geometry turbocharger related fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for related fault codes.

  • Use INSITE™ electronic service tool to check for active or inactive fault codes that are related to the EGR valve or variable geometry turbocharger operation.
  • Only troubleshoot inactive fault codes with more than 10 counts and that were active in the last 8 hours.

NOTE: A stuck open exhaust gas recirculation (EGR) valve or a damaged variable geometry turbocharger actuator can cause face plugging of the diesel oxidation catalyst.

Fault codes found that are related to the EGR or variable geometry turbocharger operation?
YES NO

Troubleshoot the EGR or variable geometry turbocharger related fault code. A stuck open EGR valve or a damaged variable geometry turbocharger actuator can cause face plugging of the diesel oxidation catalyst.

No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment fuel injector system.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Only troubleshoot inactive fault codes with more than ten counts and that were active in the last 8 hours.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, or aftertreatment fuel shutoff valve active?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree and return to this step when corrected.

Go to 1C

Guided Step 1C - Check for Fault Code 1691.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1691 active counts?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the aftertreatment temperature sensors.

Guided Step 2A - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with INSITE™ electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, reference the appropriate fault code troubleshooting symptom tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Do any of the aftertreatment exhaust gas temperature sensors vary by more than 10°C [18°F]?
YES NO

Replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check for other active fault codes.

Guided Step 3A - Check for Fault Code 2637.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2637 active or inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Check for Fault Code 2638.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2638 active?
YES NO
No Repair

Replace the diesel oxidation catalyst (DOC). Refer to Procedure 011-049 in the Associated Procedures Table.

Go to 4A

Go to 4C

Guided Step 3C - Check for Fault Code 2638.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2638 active?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4A

Guided Step 4 - Perform the Aftertreatment Maintenance Reset All procedure.

Guided Step 4A - Perform the Aftertreatment Maintenance Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved; only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu.

Go to 5A

Go to 5A

Guided Step 4B - Perform the Aftertreatment Maintenance Reset All procedure..

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of the Advanced ECM Data

Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved; only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu

Go to 5B

Go to 5B

Guided Step 4C - Perform the Aftertreatment Maintenance Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of the Advanced ECM Data.

Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved; only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu

Go to 6A

Go to 6A

Guided Step 5 - Check the flow of the aftertreatment injector.

Guided Step 5A - Flow the aftertreatment fuel injector and check if the flow is greater than 110 ml.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the Aftertreatment Shutoff Valve and Injector Override Test by selecting System Test from the Test Mode menu. The Aftertreatment Shutoff Valve and Injector Override Test can be found in the INSITE™ electronic service tool under the Diagnostic Test menu.

Refer to Procedure 011-054 in Section 11.

  • It is only necessary to perform the flow test. The leak test is not necessary.

Is the flow greater than 110 ml
YES NO

Clean the aftertreatment fuel injector and replace the diesel oxidation catalyst.

Clean the aftertreatment fuel injector and replace the DOC.

Go to 6A

Go to 5C

Guided Step 5B - Flow the aftertreatment fuel injector and check if the flow is greater than 250ml.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the Aftertreatment Shutoff Valve and Injector Override Test by selecting System Test from the Test Mode menu. The Aftertreatment Shutoff Valve and Injector Override Test can be found in INSITE™ electronic service tool under the Diagnostic Test menu.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of the Advanced ECM Data menu.

Refer to Procedure 011-054 in the Associated Procedures Table.

  • It is only necessary to perform the flow test; the leak test is not necessary.

Is the flow greater than 250 ml?
YES NO

Clean the aftertreatment fuel injector.

Clean the aftertreatment fuel injector.

Go to 6A

Go to 5C

Guided Step 5C - Flow the aftertreatment fuel injector and check if the flow is greater than 250ml.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the Aftertreatment Shutoff Valve and Injector Override Test by selecting System Test from the Test Mode menu. The Aftertreatment Shutoff Valve and Injector Override Test can be found in INSITE™ electronic Service Tool under the Diagnostic Test menu.

  • Use INSITE™ electronic service tool to Perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data menu.

Refer to Procedure 011-054 in Section 11.

  • It is only necessary to perform the flow test; the leak test is not necessary.

Is the flow greater than 250ml?
YES NO
No Repair

Replace the aftertreatment fuel injector.

Go to 6A

Go to 6A

Guided Step 6 - Perform the stationary regeneration procedure.

Guided Step 6A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the stationary regeneration procedure.

Refer to Procedure 014-013 in the Associated Procedures Table.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test found in the ECM Diagnostics Tests.

Stationary regeneration started?
YES NO
No Repair

Reference the Stationary Regeneration - Will Not Activate or the Stationary Regeneration - Will Not Complete troubleshooting symptom trees in Section TS in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239

Go to 6B

Go to 6B

Guided Step 6B - Check for exhaust leaks while performing the stationary regeneration procedure.

Conditions

  • Stationary regeneration procedure running.

Action

Check the exhaust for leaks while the stationary regeneration procedure is running.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for leaking connections and damaged/leaking exhaust system components.

Exhaust system leaks?
YES NO

Stop regeneration and allow the system to cool. Repair or replace the damaged exhaust system component(s).

 No Repair

Go to 6C

Go to 6C

Guided Step 6C - Perform the stationary regeneration procedure.

Conditions

  • Stationary regeneration procedure running.

Action

Check for active Fault Code 1691.

Fault Code 1691 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Reference the Stationary Regeneration - Will Not Activate or the Stationary Regeneration - Will Not Complete troubleshooting symptom trees in Section TS in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again

Go to 7A

Go to 7A

Guided Step 7 - Check the engine control module (ECM) calibration.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1691 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 27-Nov-2013


FAULT CODE 1695 - Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1695 inactive?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ECM battery (+) in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Verify the repair. | Fault Code 1695 inactive?
 | STEP 3B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harenss connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the digital vehicle speed sensor from the OEM harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor supply 5 pin at the OEM harness ECM connector to all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ECM battery (+) in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the digital vehicle speed sensor from the OEM harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM harness, if equipped.

Action

Check for a short circuit to ECM battery (+).

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector to the ECM battery (+) pins at the OEM power harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1695 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 1696 - Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Check the circuit response. | Fault Code 1696 active?
 | STEP 2B. Check the circuit response. | Fault Code 1696 active?
 | STEP 2C. Check the circuit response. | Fault Code 1696 active?
 | STEP 2D. Check the circuit response. | Fault Code 1696 active?
 | STEP 2E. Check the circuit response. | Fault Code 1696 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1696 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the accelerator/lever position sensor.

See the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to Procedure 019-443 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the coolant level sensor.

Refer to Procedure 019-017 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote throttle from the OEM harness (if equipped).
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the remote throttle.

See the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

Guided Step 2E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan speed sensor from the OEM harness (if equipped).
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the fan speed sensor.

See the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness
  • Disconnect the remote throttle, if equipped, from the OEM harness.
  • Disconnect the fan speed sensor, if equipped, from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal 5 volts of direct current (VDC) SUPPLY and all other pins in the OEM harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness
  • Disconnect the remote throttle, if equipped, from the OEM harness.
  • Disconnect the fan speed sensor, if equipped, from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator 5-VDC SUPPLY pin and the engine block ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1696 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1843 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1843 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes,

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

A defective sensor has been detected.

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 (Crankcase Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to crankcase pressure sensor RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1843 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


FAULT CODE 1844 - Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1844 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1844 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 187 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes,

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the crankcase pressure sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

A defective sensor has been detected.

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted circuit has been detected on the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1844 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to appropriate troubleshooting charts.

Last Modified: 19-Mar-2016


FAULT CODE 1866 - Exhaust Gas Recirculation (EGR) Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2273 and 2274. | Fault Code 2273 or 2274 active?
STEP 2. | Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging. |
 | STEP 2A. Check the EGR differential pressure tubes for leaks. | Leaks detected at either the low or high EGR differential pressure tubes?
 | STEP 2B. Check the EGR differential pressure tubes for plugging. | Debris or soot found in either EGR differential pressure tube?
 | STEP 2C. Check the EGR differential pressure sensor adapter for leaks. | Leaks detected at the EGR differential pressure sensor adapter?
STEP 3. | Check the EGR delta pressure sensor and circuit. |
 | STEP 3A. Inspect the EGR delta pressure sensor and connector pins. | Dirty or damaged pins.
 | STEP 3B. Check the circuit response. | Fault Code 2274 active?
 | STEP 3C. Check the circuit response. | Fault Code 2273 active?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
 | STEP 4C. Check the circuit response. | Fault Code 2273 active?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the repair. | INSITE™ electronic service tool reading for EGR Delta Pressure is 0 kPa [0 psi]?
 | STEP 5B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 2273 and 2274.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 or 2274 active?
YES | NO
No Repair | No Repair

Fault Code 2273 or 2274 troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging.

Guided Step 2A - Check the EGR differential pressure tubes for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the lines for leaks.

  • Leaks should be easily noted by traces of soot.

Leaks detected at either the low or high EGR differential pressure tubes?
YES NO

Remove and clean both EGR differential pressure tubes. Install and tighten the fittings, or replace the EGR differential pressure tubes.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the EGR differential pressure tubes for plugging.

Conditions

  • Turn keyswitch OFF
  • Remove the EGR differential pressure tubes.

Action

Inspect the EGR differential pressure tubes for restrictions, soot deposits, and shellac plugging.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Debris or soot found in either EGR differential pressure tube?
YES NO

Replace the EGR differential pressure tubes.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the EGR differential pressure sensor adapter for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor adapter for leaks.

  • Leaks should be easily noted by traces of soot. The sensor may need to be removed to inspect the o-rings between the EGR differential pressure sensor and the adapter for proper sealing.

Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.

Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Leaks detected at the EGR differential pressure sensor adapter?
YES NO

Replace the EGR differential pressure sensor adapter.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the EGR delta pressure sensor and circuit.

Guided Step 3A - Inspect the EGR delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR delta pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 volt SUPPLY pin and the EGR differential pressure SIGNAL pin at the EGR differential pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 volt SUPPLY pin and the EGR differential pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify engine coolant temperature is above 67°C [154°F].
  • Verify intake manifold air temperature is above -17°C [0°F].
  • Do not operate engine.

Action

Verify the engine coolant temperature is above 67°C [154°F] and the intake manifold air temperature is above -17°C [0°F].

  • Turn keyswitch OFF for 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

INSITE™ electronic service tool reading for EGR delta pressure 0 kPa [0 psi]?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to erase all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 06-Sep-2012


FAULT CODE 1876 - Exhaust Gas Temperature 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1876 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1877 active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1876 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1876 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1876 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the aftertreatment diesel particulate filter outlet temperature SIGNAL pin and the aftertreatment diesel particulate filter outlet temperature RETURN pin at the sensor connector of the OEM harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter outlet temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 active?
YES NO

A damaged aftertreatment diesel particulate filter outlet temperature sensor has been detected.

Replace the aftertreatment diesel particulate filter outlet temperature sensor.

Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter outlet temperature sensor RETURN pin and the OEM harness aftertreatment diesel particulate filter outlet temperature sensor connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel particulate filter outlet temperature sensor RETURN wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects. Repair or replace the damaged harness and/or interconnects.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin and the OEM harness aftertreatment diesel particulate filter outlet temperature sensor connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects. Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1876 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 1877 - Exhaust Gas Temperature 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1877 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1876 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1877 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1877 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 332 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor, or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter outlet temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877 active?
YES NO

A damaged aftertreatment diesel particulate filter outlet temperature sensor has been detected.

Replace the aftertreatment diesel particulate filter outlet temperature sensor.

Refer to Procedure 019-449 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check for the appropriate circuit response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1877 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 16-Oct-2015


FAULT CODE 1878 - Aftertreatment Exhaust Gas Temperature 3 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1876 or 1877 active or high inactive counts?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1876 active?
 | STEP 2C. Check the circuit response. | Fault Code 1877 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Aftertreatment diesel particulate filter inlet temperature and aftertreatment diesel particulate filter outlet temperature readings within 25°C or 43°F of each other?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 or 1877 active or high inactive counts?
YES | NO
No Repair | No Repair

Fault Code 1876 or 1877 troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle the engine for more than 10 minutes.

Action

Use INSITE™ electronic service tool to monitor the aftertreatment exhaust gas temperature sensors while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness.

  • Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors.

  • Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter outlet temperature sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter outlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Action

Check the appropriate ECM response after 5 minutes idling the engine above 600 rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1876 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

  • Place a jumper wire between the aftertreatment diesel particulate filter outlet temperature SIGNAL pin and the aftertreatment diesel particulate filter outlet temperature RETURN pin at the aftertreatment diesel particulate filter outlet temperature connector of the OEM harness.
  • Start the engine and idle with engine speed greater than 600 rpm for 5 minutes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877 active?
YES NO

A damaged aftertreatment diesel particulate filter outlet temperature sensor has been detected.

Replace the aftertreatment diesel particulate filter outlet temperature sensor.

  • Refer to Procedure 019-449 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL pin in the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM.

  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

A pin-to-ground short circuit in the aftertreatment diesel particulate filter outlet temperature sensor SIGNAL wire has been detected in the harness. Troubleshoot the OEM harness, aftertreatment harness, and all interconnects.

Repair or replace the damaged harness and/or interconnects.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for exhaust gas temperature 1 and aftertreatment diesel particulate filter outlet temperature.

Note: The engine must be running at 1200 rpm or above for 15 minutes and the aftertreatment diesel oxidation catalyst inlet temperature must be above 150°C or 302°F before the fault code will clear.

Aftertreatment diesel particulate filter inlet temperature and aftertreatment diesel particulate filter outlet temperature readings within 25°C or 43°F of each other?

YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-Dec-2011


FAULT CODE 1879 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1879 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1881 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 volts of direct current (VDC)?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1879 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1879 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1879 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 1695 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin and the aftertreatment diesel particulate filter differential pressure sensor RETURN pin at the aftertreatment diesel particulate filter differential pressure sensor connector of the OEM harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter differential pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel particulate filter differential pressure sensor.

Refer to Procedure 019-443 in Section 19.

None. The removal an installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter differential pressure sensor RETURN pin and the OEM harness aftertreatment diesel particulate filter differential pressure sensor connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1879 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor or supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1881 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter differential pressure sensor and electronic connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1879 active?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1881 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1881 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1881 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-071 (OEM Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel particulate filter differential pressure SUPPLY pin and the aftertreatment diesel particulate filter differential pressure RETURN pin at the aftertreatment diesel particulate filter differential pressure sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin and the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin at the aftertreatment diesel particulate filter differential pressure sensor connector of the OEM harness.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter differential pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel particulate filter differential pressure sensor.

Refer to Procedure 019-443 (Aftertreatment Particulate Trap Differential Pressure Sensor).

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 (OEM Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin and the OEM harness aftertreatment diesel particulate filter differential pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 (OEM Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin and the OEM harness aftertreatment diesel particulate filter differential pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 (OEM Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 (OEM Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 (OEM Wiring Harness) in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

The troubleshooting steps need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1881 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


FAULT CODE 1883 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes 1879 and 1881. | Fault Code 1879 or 1881 active?
STEP 2. | Check the aftertreatment diesel particulate filter differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1881 active?
 | STEP 2C. Check the circuit response. | Fault Code 1879?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged?
 | STEP 3B. Check for resistance in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1883 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Fault Code 1883 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1879 and 1881.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 or 1881 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 1879 or 1881 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

The OEM harness can have multiple harness connectors. Be sure to check each harness connector in series.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel particulate filter differential pressure 5 volt SUPPLY pin and the aftertreatment diesel particulate filter differential pressure SIGNAL pin at the aftertreatment diesel particulate filter differential pressure sensor connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES NO

An in-range damaged aftertreatment diesel particulate filter differential pressure sensor has been detected.

Replace the aftertreatment diesel particulate filter differential pressure sensor.

Refer to Procedure 019-443 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for resistance in the circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin and the OEM harness aftertreatment diesel particulate filter differential pressure sensor connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance in the SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connector in series to determine which contains the open RETURN circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1883 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1883 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 16-Oct-2015


EGR Valve Control Circuit - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome® test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2636 and 1893 active?
 | STEP 1B. Check for inactive fault codes. | Fault Code 1893 inactive?
STEP 2. | Check the EGR valve circuit. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the EGR valve ground circuit. | Wiring harness eyelet tightly connected to the engine block ground stud?
 | STEP 2C. Check the voltage to the EGR valve. | Voltage greater than +11-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the EGR valve voltage at the ECM. |
 | STEP 3A-2. Check the voltage to the ECM. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the SAE J1939 data link termination resistor. |
 | STEP 3B-2. Check for an open circuit in the SAE J1939 data link harness. |
 | STEP 3B-3. Check for a short circuit in the SAE J1939 data link harness. |
 | STEP 3B-4. Check for a short circuit to ground in the SAE J1939 data link harness. |
 | STEP 3B-5. Check the fault codes. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1893 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2636 and 1893 active?
YES | NO
No Repair | No Repair

Go to the Fault Code 2636 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent active and inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the EGR valve circuit.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected at the EGR valve connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the EGR valve ground circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check to make sure the engine wiring harness ground eyelet is tightly connected to the engine block ground.

Note: On ISX engines, the grounding stud is located just below the IFSM and behind the starter. On the ISM engines, the grounding stud is located between the ECM and the starter.

Wiring harness eyelet tightly connected to the engine block ground stud?
YES NO
No Repair

A loose ground circuit has been detected at the engine block.

Tighten the ground connection.

Go to 2C

Go to 4A

Guided Step 2C - Check the voltage to the EGR valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the EGR valve.

  • Measure the voltage between the EGR valve 12 volt SUPPLY circuit and the EGR valve RETURN circuit at the engine harness connector.

Note: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Refer to the circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than +11-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the EGR valve voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the EGR valve.

  • Measure the voltage between the EGR valve power supply circuit at the ECM connector and engine block ground.

Note: Check the voltage at key ON and while cranking the engine.

Voltage greater than +11-VDC?
YES NO

An open circuit in the EGR valve power supply or return circuit has been detected in the engine harness.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-2

Guided Step 3A-2 - Check the voltage to the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the ECM.

  • Measure the voltage between the ECM power supply circuit and the ECM return circuit at the OEM power harness connector.

Note: Check the voltage at key ON and while cranking the engine.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage greater than +11-VDC?
YES NO

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Low voltage has been detected at the ECM power connector.

Check the battery voltage and the OEM wiring between the battery and the ECM power harness connector.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the SAE J1939 data link termination resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 termination resistor from the engine harness.

Action

Check the SAE J1939 data link termination resistor.

  • Measure the resistance between SAE J1939 data link (+) and SAE J1939 data link (-) at the SAE J1939 termination resistor.

Use the wiring diagram and the following procedure for general resistance measurement.Refer to Procedure 019-360 in Section 19.

Resistance between 110 and 130 ohms?
YES NO
No Repair

Replace the SAE J1939 termination resistor.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an open circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the terminating resistor from the engine harness.

Action

Check for an open circuit in the SAE J1939 datalink harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the EGR valve engine harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the EGR valve engine harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the SAE J1939 data link harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check for a short circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the VGT actuator from the harness.
  • Disconnect the engine harness from the ECM connector.
  • Remove the SAE J1939 termination resistor from the engine harness.

Action

Check for a short circuit in the SAE J1939 datalink harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Note: A value of 120 ohms will be read when the resistance is measured between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire. This is the resistance of the termination resistor and is a normal reading.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check for a short circuit to ground in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the VGT actuator from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Use the wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the SAE J1939 data link harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3B-5

Go to 4A

Guided Step 3B-5 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Connect the VGT actuator to the engine harness.
  • Connect the SAE J1939 data link termination resistor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES NO

Replace the EGR valve.

  • For ISM engines, see the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-022 in Section 11.
  • For ISX engines, see the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-022 in Section 11.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1893 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the EGR valve. |
 | STEP 1A. Check the part number of the EGR valve. | EGR valve part number is correct for application?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1895 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the EGR valve.

Guided Step 1A - Check the part number of the EGR valve.

Conditions

  • Turn keyswitch OFF.

Action

Check the part number.

  • Check the part number of the EGR valve and make sure the part number is correct for the application.

EGR valve part number is correct for the application?
YES NO
No Repair

An incorrect EGR valve has been installed on the engine.

Replace the EGR valve.

  • Refer to Procedure For ISM engines, 011&ndash;022 in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-022 in the Signature, ISX and QSX15 Service Manual, Bulletin, 3666239.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1895 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


FAULT CODE 1896 - EGR Valve Controller - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
STEP 2. | Check the EGR valve operation. |
 | STEP 2A. Check for active fault codes. | Fault Code 1896 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1896 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Fault Code 1893 troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR valve operation.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Turn the keyswitch OFF for 10 seconds and then turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES NO

A stuck open EGR valve has been detected.

ISX CM871 engines:

  • Clean the EGR valve assembly, if possible. If not, replace if necessary. Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin, 3666239. Refer to Procedure 011-094 in Section 11.

ISM CM876 engines:

  • Replace the EGR valve. Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-022 in Section 11.

Perform the Snap-Acceleration Test to check for a damaged diesel particulate filter. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1896 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting tree

Last Modified: 31-Jul-2013


FAULT CODE 1899 - Exhaust Gas Recirculation (EGR) Valve Delta Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active EGR valve fault codes. | Fault Code 1895, 1896, or 2357 active?
 | STEP 1B. Check for inactive EGR differential pressure sensor fault codes. | Fault Code 1866, 2273, or 2274 inactive?
STEP 2. | Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging. |
 | STEP 2A. Check the EGR differential pressure tubes for leaks. | Leaks detected at either the low or high EGR differential pressure tubes?
 | STEP 2B. Check the EGR differential pressure tubes for plugging. | Debris or soot found in either EGR differential pressure tube?
 | STEP 2C. Check the EGR differential pressure sensor adapter for leaks. | Leaks detected at the EGR differential pressure sensor adapter?
 | STEP 2D. Check the EGR cooler for restriction. | Restriction or damage to the EGR cooler?
STEP 3. | Check the EGR delta pressure sensor and circuit. |
 | STEP 3A. Inspect the EGR delta pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2274 active?
 | STEP 3C. Check the circuit response. | Fault Code 2273 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
STEP 5. | Check the ECM snapshot data. |
 | STEP 5A. Check the Exhaust Gas Pressure, Intake Manifold Pressure, EGR Valve Position, and EGR Differential Pressure values in the Fault Code 1899 snapshot data. | ALL of the following true?: Values for EGR Valve Position greater than 50 percent, EGR Differential Pressure less than 102 mm-Hg [4 in-Hg], and the difference between the Exhaust Gas Pressure and Intake Manifold Pressure (Exhaust Gas Pressure - Intake Manifold Pressure) greater than 1016 mm-Hg [40 in-Hg]?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR valve fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1895, 1896, or 2357 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive EGR differential pressure sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1866, 2273, or 2274 inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging.

Guided Step 2A - Check the EGR differential pressure tubes for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the lines for leaks.

Leaks should be easily noted by traces of soot.

Leaks detected at either the low or high EGR differential pressure tubes?
YES NO

Remove and clean both EGR differential pressure tubes. Then install and tighten the fittings, or replace the EGR differential pressure tubes.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, for ISM engines. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for ISX engines. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the EGR differential pressure tubes for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure tubes.

Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, for ISM engines. Refer to Procedure 011-026 in Section 11.

Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for ISX engines. Refer to Procedure 011-026 in Section 11.

Action

Inspect the EGR differential pressure tubes for restrictions, soot plugging, and shellac plugging.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, for ISM engines. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for ISX engines. Refer to Procedure 011-026 in Section 11.

Debris or soot found in either EGR differential pressure tube?
YES NO

Replace the EGR differential pressure tube.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, for ISM engines. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for ISX engines. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the EGR differential pressure sensor adapter for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor adapter for leaks.

Leaks should be easily noted by traces of soot; however, the sensor can possibly need to be removed to inspect the o-rings between the EGR differential pressure sensor and the adapter for proper sealing.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, for ISM engines. Refer to Procedure 011-028 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for ISX engines. Refer to Procedure 011-028 in Section 11.

Leaks detected at the EGR differential pressure sensor adapter?
YES NO

Replace the EGR differential pressure sensor adapter.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, for ISM engines. Refer to Procedure 011-028 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for ISX engines. Refer to Procedure 011-028 in Section 11.

No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check the EGR cooler for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR cooler for restrictions.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, for ISM engines. Refer to Procedure 011-019 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for ISX engines. Refer to Procedure 011-019 in Section 11.

Restriction or damage to the EGR cooler?
YES NO

Clear the restriction or replace the EGR cooler.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, for ISM engines. Refer to Procedure 011-019 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for ISX engines. Refer to Procedure 011-019 in Section 11.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the EGR delta pressure sensor and circuit.

Guided Step 3A - Inspect the EGR delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR delta pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

A damaged sensor has been detected.

Replace the EGR delta pressure sensor. Refer to Procedure 019-370 in Section 19.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the EGR valve delta pressure sensor SUPPLY pin and the EGR valve delta pressure sensor SIGNAL pin at the EGR valve delta pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A damaged sensor has been detected.

Replace the EGR delta pressure sensor. Refer to Procedure 019-370 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Check the ECM snapshot data.

Guided Step 5A - Check the Exhaust Gas Pressure, Intake Manifold Pressure, EGR Valve Position, and EGR Differential Pressure values in the Fault Code 1899 snapshot data.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Expand and read the Fault Code 1899 snapshot data.

  • Use INSITE™ electronic service tool to read the snapshot data.
  • Check the values for these parameters: Exhaust Gas Pressure, Intake Manifold Pressure, EGR Valve Position, and EGR Differential Pressure.

Are ALL of the following true?: Are the values for EGR Valve Position greater than 50 percent, EGR Differential Pressure less than 102 mm-Hg [4 in-Hg], and the difference between the Exhaust Gas Pressure and Intake Manifold Pressure (Exhaust Gas Pressure - Intake Manifold Pressure) greater than 1016 mm-Hg [40 in-Hg]?

YES NO

Remove the EGR cooler and inspect for plugging.

Clean the EGR cooler, if possible.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, for ISM engines. Refer to Procedure 011-019 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, for ISX engines. Refer to Procedure 011-019 in Section 11.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Nov-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes other than 1921 are active?
STEP 2. | Check the duty cycle of the application. |
 | STEP 2A. Check the aftertreatment duty cycle. | Does the duty cycle of the application need to be increased?
STEP 3. | Perform stationary regeneration procedure. |
 | STEP 3A. Perform stationary regeneration procedure. | Fault Code 1921 active after the stationary regeneration has been completed?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1921 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes other than 1921 are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the duty cycle of the application.

Guided Step 2A - Check the aftertreatment duty cycle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the duty cycle.

  • Use INSITE™ electronic service tool to view the Duty Cycle of the engine.
  • View the Aftertreatment Trip Information.

Determine if the duty cycle of the application needs to change in order to increase the exhaust temperatures entering the aftertreatment system.

Does the duty cycle of the application need to be increased?
YES NO

Change the duty cycle of the application in order to increase the exhaust temperatures entering the aftertreatment system.

 No Repair

Appropriate base engine troubleshooting procedure

Go to 3A

Guided Step 3 - Perform the stationary regeneration procedure.

Guided Step 3A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Following the aftertreatment guidelines in the service manual. Refer to Procedure 014-013 in Section 14.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Test found in the ECM Diagnostics Test.

Note: Fault Code 2639 will become active during the regeneration procedure. This is normal operation as the soot is removed from the aftertreatment diesel particulate filter.

Fault Code 1921 active after the stationary regeneration has been completed?
YES NO

Check for active fault codes that may have come active during the regeneration event. Troubleshoot any active fault codes.

Perform the Snap Acceleration Test to check for a damaged diesel particulate filter.

  • Refer to Procedure 014-013 in Section 14.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1921 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1922 active?
 | STEP 1A-1. Perform the aftertreatment diesel particulate filter reset procedure. |
 | STEP 1A-2. Perform the aftertreatment maintenance filter installation procedure. |
STEP 2. | Perform the stationary regeneration procedure. |
 | STEP 2A. Perform stationary regeneration procedure. | Fault Code 1922 active after the stationary regeneration has been completed?
STEP 3. | Inspect the aftertreatment diesel particulate filter differential pressure sensor. |
 | STEP 3A. Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool. | Is the aftertreatment diesel particulate filter differential pressure sensor reading 0 ± 3 kPa [0 ± 0.89 inHg] with the keyswitch ON and the engine OFF?
 | STEP 3B. Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage. | Are the aftertreatment diesel particulate filter differential pressure sensor supply tubes blocked?
STEP 4. | Check the duty cycle of the application. |
 | STEP 4A. Check the aftertreatment duty cycle. | Does the duty cycle of the application need to be increased?
STEP 5. | Inspect the aftertreatment sensors and wiring. |
 | STEP 5A. Inspect the aftertreatment temperature sensor connectors for correct installation locations. | Are the aftertreatment temperature sensors installed correctly?
 | STEP 5B. Inspect the aftertreatment wiring harness connectors for correct pin installation. | Is the aftertreatment wiring installed correctly?
STEP 6. | Inspect the turbocharger. |
 | STEP 6A. Inspect the turbocharger shaft movement. | Does the nozzle slide evenly from stop to stop and are the gear teeth undamaged?
STEP 7. | Inspect the exhaust. |
 | STEP 7A. Inspect the exhaust for excessive smoke. | Is there excessive black smoke during acceleration or constant black smoke at high idle?
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1922 active?
YES NO

The aftertreatment diesel particulate filter has plugged with soot and the stationary regeneration procedure can not be performed until it has been inspected and cleaned in an SPX air pulse cleaning machine (or equivalent machine).

Use the following instructions to remove, inspect, and clean or replace the aftertreatment diesel particulate filter.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-041 in Section 11.

Note: If the aftertreatment diesel particulate filter does not meet the inspection criteria in Procedure 011-041, it must be replaced.

Aftertreatment diesel particulate filters that meet the inspection criteria and are cleaned in an SPX air pulse cleaning machine (or equivalent machine) must have a stationary regeneration after the cleaning process is complete.

No Repair

Go to 1A-1

Repair complete

Guided Step 1A-1 - Perform the aftertreatment diesel particulate filter reset procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the aftertreatment maintenance reset procedure.

  • Use INSITE™ electronic service tool to perform the aftertreatment diesel particulate filter reset procedure located in the aftertreatment maintenance selection under the advanced ECM data menu.
  • After clicking the “OK” button, it may take several minutes for Fault Code 1922 to go inactive, and for Fault Code 1921 to go active.

Note: Fault Code 1922 must be active before the aftertreatment maintenance reset procedure can be performed.

Note: Fault Code 1922 will go inactive and Fault Code 1921 will go active after completing this procedure.

Aftertreatment maintenance reset procedure has been completed?
YES NO
No Repair

Perform INSITE™ electronic service tool aftertreatment maintenance reset procedure listed in the Action section of this troubleshooting step.

Go to 1A-2

Go to 1A-2

Guided Step 1A-2 - Perform the aftertreatment maintenance filter installation procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Filter Installation procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Filter Installation procedure found under the Advanced ECM Data Section.
  • If the Aftertreatment Maintenance Filter Installation procedure is not completed, Fault Code 1922 could potentially activate after cleaning or replacing the aftertreatment diesel particulate filter and operating the vehicle for a short distance.

Perform the Aftertreatment Maintenance Filter Installation procedure.

The INSITE™ electronic service tool Aftertreatment Maintenance Filter Installation procedure has been completed?
YES NO
No Repair

Perform INSITE™ electronic service tool Aftertreatment Maintenance Filter Installation procedure listed in the Action section of this troubleshooting step.

Go to 2A

Go to 2A

Guided Step 2 - Perform the stationary regeneration procedure.

Guided Step 2A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the stationary regeneration procedure.

  • Use INSITE™ electronic service tool to perform the aftertreatment diesel particulate filter regeneration test found in the ECM diagnostic tests.
  • Some vehicles can be equipped with a stationary regeneration switch in the dash. This switch can also be used to perform the stationary regeneration procedure. Refer to the manufacturer's operating instructions.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, for stationary regeneration information. Refer to Procedure 014-013 in Section 14.

Note: If stationary regeneration will not activate, please reference the “Stationary Regeneration - Will Not Activate” troubleshooting tree in Section TS in the appropriate service manual.

Note: Fault Code 2639 will become active during the regeneration procedure. This is normal operation as the soot is removed from the aftertreatment diesel particulate filter.

Fault Code 1922 active after the stationary regeneration has been completed?
YES NO

Troubleshoot a possible base engine issue creating excessive black smoke.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Inspect the aftertreatment diesel particulate filter differential pressure sensor.

Guided Step 3A - Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool.

Conditions

  • Keyswitch ON.
  • Engine OFF.
  • INSITE™ electronic service tool

Action

Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool.

Is the aftertreatment diesel particulate filter differential pressure sensor reading 0 ± 3 kPa [0 ± 0.89 inHg] with the keyswitch ON and the engine OFF?

YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage.

Conditions

  • Engine OFF.
  • Aftertreatment diesel particulate filter differential pressure sensor supply tubes disconnected.

Action

Disconnect the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-047 in Section 11.
  • Inspect the supply tubes for blockage.

Are the aftertreatment diesel particulate filter differential pressure sensor supply tubes blocked?
YES NO

Remove and clean the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-047 in Section 11.

Check for a short circuit from the signal pin of the aftertreatment diesel particulate filter differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short circuit is found, replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to Procedure 019-443 in Section 19.

Go to 7A

Go to 7A

Guided Step 4 - Check the duty cycle of the application.

Guided Step 4A - Check the aftertreatment duty cycle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the duty cycle.

  • Use INSITE™ electronic service tool to view the duty cycle of the engine.
  • View the aftertreatment trip information.

Determine if the duty cycle of the application needs to change in order to increase the temperature of the exhaust gases entering the aftertreatment system.

Does the duty cycle of the application need to be increased?
YES NO

Change the duty cycle of the application in order to increase the temperature of the exhaust gases entering the aftertreatment system.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Inspect aftertreatment sensors and wiring.

Guided Step 5A - Inspect the aftertreatment temperature sensor connectors for correct installation locations.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the aftertreatment temperature sensor connectors.

Inspect the exhaust aftertreatment temperature sensor connectors to verify that they are connected to the correct connector on the aftertreatment system wiring harness. Two of the temperature sensors have identical wiring harness connectors. The sensors are the same part number and it is possible to install the wiring harness connectors to the wrong sensors.

To verify the correct sensor locations, use INSITE™ electronic service tool to monitor the aftertreatment temperature sensor voltages.

  • Unplug each of the aftertreatment temperature sensors one at a time.
  • If the voltage changes when you unplug the sensor, the wiring harness connector is connected to the correct sensor.
  • If the voltage does not change, switch the connector location to the other temperature sensor. Then unplug it and check for a voltage change.

Are the aftertreatment temperature sensors installed correctly?
YES NO
No Repair

Connect each of the aftertreatment temperature sensors in the correct locations by following the steps outlines in the Action section.

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment wiring harness connectors for correct pin installation.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment wiring harness connectors for correct pin installation.

  • Inspect the aftertreatment sensor and wiring harness connectors for correct pin installation locations.

Refer to the wiring diagram for connector pin identification and locations.

Is the aftertreatment wiring installed correctly?
YES NO
No Repair

Install the pins in their correct connector locations.

Refer to the wiring diagram for connector pin identification and location.

Go to 6A

Go to 6A

Guided Step 6 - Inspect the turbocharger.

Guided Step 6A - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OF.
  • Variable geometry turbocharger actuator removed from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger bearing housing up and down from stop to stop. Check for smooth movement between the stops.
  • There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever can be moved to the other stop position by hand.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.

Does the nozzle slide evenly from stop to stop and are the gear teeth undamaged?
YES NO

Install the turbocharger actuator.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.

A turbocharger mechanical malfunction has been detected.

Note: This malfunction could have been caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger assembly.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual. Refer to Procedure 010-033 in Section 10.
  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-033 in Section 10.

Go to 7A

Go to 7A

Guided Step 7 - Inspect the exhaust.

Guided Step 7A - Inspect the exhaust for excessive smoke.

Conditions

  • Exhaust pipe disconnected from the aftertreatment inlet.
  • Engine running.

Action

Check the exhaust smoke.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.
  • Note: To perform a snap acceleration test, it could be necessary to temporarily adjust the Maximum Engine Speed with No vehicle speed sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Is there excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke.

 No Repair

Reference the appropriate engine performance troubleshooting tree

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM.Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jul-2010


FAULT CODE 1923 - Aftertreatment Fuel Shutoff Valve 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1923 inactive?
STEP 2. | Check the aftertreatment fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment fuel shutoff valve. | 5.0 to 7.0 ohms?
 | STEP 2C. Check the fuel shutoff valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
 | STEP 2D. Check for an open circuit in the aftertreatment fuel shutoff valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the fuel shutoff valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1923 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1923 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1923 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment fuel shutoff valve and circuit.

Guided Step 2A - Inspect the aftertreatment fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check the aftertreatment fuel shutoff valve resistance.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin and the aftertreatment fuel shutoff valve RETURN pin at the aftertreatment fuel shutoff valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

5.0 to 7.0 ohms?
YES NO
No Repair

Replace the aftertreatment fuel shutoff valve.

  • Use the following procedure for ISM engines in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-052 in Section 11.
  • Use the folloing procedure for ISX engines in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-052 in Section 11.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel shutoff valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the diagnostic voltage and return circuit.

  • Measure the voltage between the aftertreatment fuel shutoff valve SUPPLY pin and the aftertreatment fuel shutoff valve RETURN pin at the aftertreatment fuel shutoff valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the aftertreatment fuel shutoff valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment fuel shutoff valve RETURN pin at the aftertreatment fuel shutoff valve connector of the engine harness and the metal case of the aftertreatment fuel shutoff valve.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness return circuit.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the fuel shutoff valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the diagnostic supply voltage.

  • Measure the voltage from the aftertreatment fuel shutoff valve SUPPLY pin and the aftertreatment fuel shutoff valve RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin at the engine harness ECM connector and the aftertreatment fuel shutoff valve connector SUPPLY pin at the aftertreatment fuel shutoff valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment fuel shutoff valve SUPPLY pin and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1923 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 1923 is inactive.

Fault Code 1923 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Jul-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1924 inactive?
STEP 2. | Check the aftertreatment fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the aftertreatment fuel shutoff valve. | 5.0 to 7.0 ohms?
 | STEP 2B-1. Check for a short circuit to ground in the aftertreatment fuel shutoff valve. |
 | STEP 2C. Check the fuel shutoff valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the fuel shutoff valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
 | STEP 3C. Check for a pin-to-pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1924 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1924 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1924 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment fuel shutoff valve and circuit.

Guided Step 2A - Inspect the aftertreatment fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the aftertreatment fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check the aftertreatment fuel shutoff valve resistance.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin and the aftertreatment fuel shutoff valve RETURN pin at the sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

5.0 to 7.0 ohms?
YES NO
No Repair

Replace the aftertreatment fuel shutoff valve.

  • Refer to Procedure For ISM engines, 011-052 (Aftertreatment Fuel Shutoff Manifold) in Section 11 in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-052 (Aftertreatment Fuel Shutoff Manifold) in Section 11 in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short circuit to ground in the aftertreatment fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check the aftertreatment fuel shutoff valve resistance.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY and the metal case of the aftertreatment fuel shutoff valve.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

Replace the aftertreatment fuel shutoff valve.

  • Refer to Procedure For ISM engines, 011-052 (Aftertreatment Fuel Shutoff Manifold) in Section 11 in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-052 (Aftertreatment Fuel Shutoff Manifold) in Section 11 in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel shutoff valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the diagnostic voltage and return circuit.

  • Measure the voltage between the aftertreatment fuel shutoff valve SUPPLY pin and the aftertreatment fuel shutoff valve RETURN pin at the aftertreatment fuel shutoff valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the fuel shutoff valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the diagnostic supply voltage.

  • Measure the voltage from the aftertreatment fuel shutoff valve SUPPLY pin and ground at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin at the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the aftertreatment fuel shutoff valve SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel shutoff valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment fuel shutoff valve SUPPLY pin at the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1924 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 1924 is inactive.

Fault Code 1924 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


FAULT CODE 1925 - (ISM) Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Measure the fuel pump output pressure. | Does the fuel pressure meet the specification?
 | STEP 1B. Check for active fault codes. | Fault codes, other than 1925, related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Inspect the aftertreatment fuel shutoff valve. |
 | STEP 2A. Check for a stuck open or leaking aftertreatment fuel shutoff valve. | Fault Code 1925 is active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1925 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Measure the fuel pump output pressure.

Conditions

  • Connect a pressure gauge to the Compuchek™ fitting of the fuel pump.
  • Turn keyswitch ON.
  • Engine running at 1200 rpm (engine cranking if troubleshooting No-Start).

Action

Read the fuel pressure at 1200 rpm, or cranking if engine will not start.

Read the fuel pressure while cranking if the engine will not start.

  • Cranking: minimum of 172 kPa [25 psi]
  • Engine running at 1200 rpm: minimum of 827 kpa [120 psi].

Does the fuel pressure meet the specification?
YES | NO
No Repair | No Repair

Go to 1B

Reference the fuel system checks in Section TT of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes, other than 1925, related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment fuel shutoff valve.

Guided Step 2A - Check for a stuck open or leaking aftertreatment fuel shutoff valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Stuck open or leaking aftertreatment fuel shutoff valve.

  • Start the engine and idle for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is active?

Fault Code 1925 is active?
YES NO

A stuck open or leaking aftertreatment fuel shutoff valve has been detected.

Replace the aftertreatment fuel shutoff valve.

Refer to Procedure 011-052 in Section 11.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate the engine for 5 minutes to purge air from the aftertreatment fuel system.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start and idle the engine for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: It may be necessary to operate the engine multiple times in order to purge air from the aftertreatment fuel system.

Fault Code 1925 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Jul-2011


FAULT CODE 1925 - (ISX) Aftertreatment Fuel Shutoff Valve 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active counts of Fault Codes 2215. | Active or inactive counts of Fault Code 2215?
 | STEP 1B. Check for active fault codes. | Fault codes, other than 1925, related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Inspect the aftertreatment fuel shutoff valve. |
 | STEP 2A. Check for a stuck open or leaking aftertreatment fuel shutoff valve. | Fault Code 1925 is active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1925 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active counts of Fault Codes 2215.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to check for inactive counts of Fault Code 2215.

It is possible to swap the connections between the aftertreatment fuel pressure sensor and the fuel delivery pressure sensor. If this occurs, Fault Code 2215 will intermittently go active and the engine will run very rough and will surge at low idle. If these symptoms are present, make sure the fuel pressure connections are connected properly.

Active or inactive counts of Fault Code 2215?
YES NO

Properly connect the aftertreatment fuel pressure sensor and fuel delivery pressure sensor wiring harness connections.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes, other than 1925, related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment fuel shutoff valve.

Guided Step 2A - Check for a stuck open or leaking aftertreatment fuel shutoff valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Stuck open or leaking aftertreatment fuel shutoff valve.

  • Start the engine and idle for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is active?

Fault Code 1925 is active?
YES NO

A stuck open or leaking aftertreatment fuel shutoff valve has been detected.

Replace the aftertreatment fuel shutoff valve.

Refer to Procedure 011-052 in Section 11.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate the engine for 5 minutes to purge air from the aftertreatment fuel system.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start and idle the engine for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: It may be necessary to operate the engine multiple times in order to purge air from the aftertreatment fuel system.

Fault Code 1925 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Jul-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1927 and 1928. | Fault Code 1927 or 1928 active?
 | STEP 1B. Check for other engine performance issue. | Are there other engine performance issues?
STEP 2. | Check the aftertreatment fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1928 active?
 | STEP 2C. Check the circuit response. | Fault Code 1927 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1928 active?
 | STEP 3C. Check the circuit response. | Fault Code 1927 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Fault Code 1926 is inactive after idling the vehicle for 3 minutes?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1927 and 1928.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 or 1928 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for other engine performance issues.

Conditions

  • None

Action

Check for other engine performance issues.

  • Interview the driver to verify that there are no other engine performance concerns, such as low power, hesitation, rough running, etc. that can be caused by incorrect or erratic fuel pressure.

Are there other engine performance issues?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel pressure sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.

Replace the aftertreatment fuel pressure sensor, if necessary.

  • Refer to Procedure 019-444 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment fuel pressure 5 volt SUPPLY pin and aftertreatment fuel pressure SIGNAL pin at the aftertreatment fuel pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 active?
YES NO

An in-range malfunction of the aftertreatment fuel pressure sensor has been detected.

Replace the aftertreatment fuel pressure sensor.

  • Refer to Procedure 019-444 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the damaged harness or replace the ECM, which has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 active?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the aftertreatment fuel pressure 5 volt SUPPLY pin and the aftertreatment fuel pressure SIGNAL pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1926 is inactive after idling the vehicle for 3 minutes?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the active and inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Check any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1927 inactive?
STEP 2. | Check the aftertreatment 1 fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1928 active and Fault Code 1927 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1927 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1927 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment 1 fuel pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment 1 fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment 1 fuel pressure sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 active and Fault Code 1927 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 fuel pressure 5 volt SUPPLY pin to the aftertreatment 1 fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 active?
YES NO

A defective sensor has been detected.

Replace the aftertreatment 1 fuel pressure sensor.

Refer to Procedure 019-444 (Aftertreatment Fuel Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 active and Fault Code 1927 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19..

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 fuel pressure 5 volt SUPPLY pin to the aftertreatment 1 fuel pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram and wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1927 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1928 inactive?
STEP 2. | Check the aftertreatment 1 fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment 1 fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1927 active and Fault Code 1928 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1928 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1928 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment 1 fuel pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment 1 fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment 1 fuel pressure sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 fuel pressure 5 volt SUPPLY pin to the aftertreatment 1 fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment 1 fuel pressure 5 volt SUPPLY pin and the aftertreatment 1 fuel pressure SIGNAL pin at the aftertreatment 1 fuel pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 active and Fault Code 1928 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment 1 fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 active?
YES NO

A defective sensor has been detected.

Replace the aftertreatment 1 fuel pressure sensor.

Refer to Procedure 019-444 (Aftertreatment Fuel Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the aftertreatment 1 fuel pressure 5 volt SUPPLY pin to the aftertreatment 1 fuel pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment 1 fuel pressure 5 volt SUPPLY pin and the aftertreatment 1 fuel pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram and wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1927 active and Fault Code 1928 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1928 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1928 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


FAULT CODE 1932 - Aftertreatment Fuel Injection System - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive Fault Code 2215. | Fault Code 2215 inactive?
 | STEP 1B. Check for active fault codes. | Fault codes other than 1932, related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve, are active?
STEP 2. | Calibrate the ECM. |
 | STEP 2A. Calibrate the ECM to October, 2007, or later revision date. | ECM calibrated to October, 2007, or later revision date?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1932 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive Fault Code 2215.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive counts of Fault Code 2215.

  • It is possible to swap the connections between the aftertreatment fuel pressure sensor and the fuel delivery pressure sensor. If this occurs, Fault Code 2215 will intermittently go active and the engine will run very rough and will surge at low idle. If these symptoms are present, make sure the fuel pressure connections are connected correctly.

Fault Code 2215 inactive?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes other than 1932, related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve, are active?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Calibrate the ECM.

Guided Step 2A - Calibrate the ECM to October, 2007, or later revision date.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECM.

  • Use INSITE™ electronic service tool to calibrate the ECM with October, 2007 or later INCAL™ DVD.

ECM calibrated to October, 2007, or later revision date?
YES NO

Clear the fault codes, then check again for active or inactive fault codes.

 No Repair

Appropriate fault code troubleshooting tree

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine for 5 minutes to purge air from the aftertreatment fuel system.
  • Shut down engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start and idle the engine for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1932 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Feb-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check the battery voltage. | Less than 18-VDC?
 | STEP 1B. Check the EGR valve ground circuit. | Wiring harness eyelet is tightly connected to the engine block ground stud?
 | STEP 1C. Check the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1933 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the OEM power harness connector from the ECM.

Action

Check the battery voltage.

  • Measure the battery voltage from of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Less than 18-VDC?
YES NO
No Repair

Install the battery system correctly.

Refer to the equipment manufacturer's troubleshooting and repair manual.

Go to 1B

Go to 2A

Guided Step 1B - Check the EGR valve ground circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check to make sure the engine wiring harness ground eyelet is tightly connected to the engine block ground.

Note: On ISX engines, the grounding stud is located just below the integrated fuel system module (IFSM) and behind the starter. On the ISM, the grounding stud is located between the ECM and the starter.

Wiring harness eyelet is tightly connected to the engine block ground stud?
YES NO
No Repair

A loose ground circuit has been detected at the engine block.

Tighten the ground connection.

Go to 1C

Go to 2A

Guided Step 1C - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Note: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO

Locate the failure that is causing the battery voltage to be greater than 18 volts.

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1933 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM calibration. |
 | STEP 1A. Check the ECM calibration. | Is the ECM code correct for the engine CPL?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1934 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Check the ECM calibration.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM calibration and make sure it is correct for the engine CPL.

Make sure the ECM Code calibration voltage is correct for the application. A 24 volt calibration downloaded into a 12 volt system can cause this fault code.

Is the ECM code correct for the engine CPL?
YES NO

An incorrect EGR valve for the voltage application has been detected.

Replace the EGR valve.

  • Refer to Procedure For ISM engines, 011-022 (EGR Valve) in Section 11 in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011&ndash;022 (EGR Valve) in Section 11 in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Download the correct ECM code for the engine CPL.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1934 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 1935 - EGR Actuator Driver Circuit - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
STEP 2. | Check the EGR valve circuit. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1893 active?
 | STEP 2C. Check the fault codes and verify the EGR valve connector condition. | Fault Code 1935 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 1935 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1935 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Go to Fault Code 1893 troubleshooting steps.

Go to 2A

Guided Step 2 - Check the EGR valve circuit.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the EGR valve connector condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1935 active?
YES NO
No Repair

NOTE: The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the EGR valve engine harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the EGR valve engine harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link harness.

Repair or replace the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the VGT actuator from the harness.
  • Disconnect the engine harness from the ECM connector.
  • Remove the SAE J1939 termination resistor from the engine harness.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the VGT actuator from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1935 active?
YES NO

  • Replace the EGR valve motor.

Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-022 in Section 11

Use the following procedure in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-022 in Section 11.

NOTE: The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1935 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 06-Aug-2010


FAULT CODE 1938 - ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check the battery connections. | Battery connections tight and free of corrosion?
 | STEP 1B. Check the variable geometry turbocharger (VGT) actuator ground circuit. | Wiring harness eyelet tightly connected to the engine block ground stud?
 | STEP 1C. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 2A. Inspect the OEM power harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the ECM power harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the OEM pow harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 2F. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1938 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery terminals for corrosion or loose connections.

  • Inspect the battery terminal connections on both positive (+) and negative (-) terminals.

Battery connections tight and free of corrosion?
YES NO
No Repair

Tighten the loose connections, and clean the terminals.

See the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the VGT actuator ground circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check to make sure the engine wiring harness ground eyelet is tightly connected to the engine block ground.

On ISX engines, the grounding stud is located just below the integrated fuel system module and behind the starter. On ISM engines, the grounding stud is located between the ECM and the starter.

Wiring harness eyelet tightly connected to the engine block ground stud?
YES NO
No Repair

A loose ground circuit has been detected at the engine block.

Tighten the ground connection.

Go to 1C

Go to 3A

Guided Step 1C - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage.

Normal Conditions:

  • At least 12 volts of direct current (VDC) (12 VDC systems)
  • At least 24 VDC (24 VDC systems)

Battery voltage acceptable in normal conditions?
YES NO
No Repair

Charge or replace the batteries.

See the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM power harness.

Guided Step 2A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM power harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the ECM power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires.

See the OEM troubleshooting and repair manual.

Continue troubleshooting the battery system until the cause of the low battery voltage is located.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1938 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 16-Oct-2015


FAULT CODE 1942 - Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 male Framatome™ test lead and Part Number 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes 1843 and 1844. | Fault Code 1843 or 1844 active?
 | STEP 1B. Check the crankcase filter hoses for correct installation. | Are the crankcase filter hoses connected properly?
 | STEP 1C. Check the crankcase breather element (if equipped). | Crankcase breather element installed correctly?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1844 active?
 | STEP 3B. Check the circuit response. | Fault Code 1843 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Fault Code 1942 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 1843 and 1844.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 or 1844 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the crankcase filter hoses for correct installation.

Conditions

  • Turn keyswitch OFF.

Action

Check the crankcase filter hose installation.

  • Check the crankcase filter hose between the engine and the crankcase breather assembly. Make sure the hose is correctly fastened to the crankcase breather and to the engine.

On the ISM engine, it is possible to install the hose between the valve cover and the crankcase breather assembly incorrectly. Make sure the hoses are not installed backwards.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, for correct crankcase filter hose arrangement. Refer to Procedure 003-002 in Section 3.
  • Use the following procedure in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239, for correct crankcase filter hose arrangement. Refer to Procedure 003-001 in Section 3.

Are the crankcase filter hoses connected properly?
YES NO
No Repair

Properly connect the crankcase breather hose.

Go to 1C

Repair complete

Guided Step 1C - Check the crankcase breather element.

Conditions

  • Turn keyswitch OFF.

Action

Check that the crankcase breather element is correctly installed.

  • Use the following procedure in the Signature, ISX, and QSX15, Service Manual, Bulletin 3666239. Refer to Procedure 003-019 in Section 3.
  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-019 in Section 3.

Crankcase breather element installed correctly?
YES NO
No Repair

Install the crankcase breather element correctly.

  • Use the following procedure in the Signature, ISX, and QSX15, Service Manual, Bulletin 3666239. Refer to Procedure 003-019 in Section 3.
  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-019 in Section 3.

Go to 2A

Repair complete.

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY pin and the crankcase pressure SIGNAL pin at the crankcase pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active?
YES NO

An in-range malfunction of the crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the crankcase press 5 volt SUPPLY pin and the crankcase pressure SIGNAL pin at the ECM engine harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Turn the keyswitch OFF.
  • Wait 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1942 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 05-Dec-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 221 or 249 inactive?
 | STEP 1C. Check the barometric pressure sensor reading. | Is the barometric pressure reading ± 25.4 mm Hg [± 1.0 in Hg] from the value in the table?
 | STEP 1D. Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in Fault Code 1943 Snapshot Data. | Are the values for Turbocharger Compressor Inlet Temperature greater than 14°C [25°F] above the ambient air temperature, or Turbocharger Compressor Outlet Temperature (calculated) above 227°C [440°F]?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1943 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 221 or 249 inactive?
YES | NO
No Repair | No Repair

Fault Code 221 or 249

Go to 1C

Guided Step 1C - Check the barometric pressure sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor reading.

  • Use INSITE™ electronic service tool to read the value for the barometric pressure.
  • Refer to Procedure Compare the reading to the chart in Procedure 018-028 in Section V.

Is the value for the barometric pressure within ± 25.4 mm Hg [± 1 in Hg]?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in the Fault Code 1943 Snapshot Data.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Expand and read Fault Code 1943 Snapshot Data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data.

Check the values for parameters:

  • Turbocharger Compressor Inlet Temperature
  • Turbocharger Compressor Outlet Temperature.

Are the values for Turbocharger Compressor Inlet Temperature greater than 14°C [25°F] above the ambient air temperature, or Turbocharger Compressor Outlet Temperature (calculated) above 227°C [440°F]?

YES | NO
No Repair | No Repair

Contact the OEM

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Unless the problem is a malfunctioning barometric pressure or intake manifold pressure sensor, this fault code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code and to determine if the malfunction has been found and fixed.

Fault Code 1943 inactive?
YES NO

No repair. This fault code is triggered to derate the engine for protection and emissions.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1961 is active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1961 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1961 is active?
YES NO

The EGR actuator internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1961 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the VGT actuator cooling system. |
 | STEP 1A. Check for active fault codes. | Fault codes related to high coolant temperature are active or high count or inactive coolant temperature related faults?
 | STEP 1B. Inspect VGT actuator coolant lines. | Blockages found in the VGT actuator cooling plate or coolant lines?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1962 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the VGT actuator cooling system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to high coolant temperature are active or high count or inactive coolant temperature related faults?
YES NO

The VGT actuator internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Inspect VGT actuator coolant lines.

Action

Inspect the VGT actuator coolant lines for kinks and blockages.

  • Blow shop air reverse through the VGT actuator cooling plate to check blockages.

Blockages found in the VGT actuator cooling plate or coolant lines?
YES NO

Repair or replace the blocked coolant line.

  • Refer to Procedure For ISM engines, 010-041 (Turbocharger Coolant Hoses) in Section 10 in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 010-041 (Turbocharger Coolant Hoses) in Section 10 in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1962 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Fuel pump outlet pressure. |
 | STEP 1A. Measure the fuel pump outlet pressure. | Does the fuel pressure meet the specification?
 | STEP 1B. Check for active fault codes. | Other fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Check the aftertreatment fuel shutoff valve. |
 | STEP 2A. Check for a stuck closed or plugged aftertreatment fuel shutoff valve. | Fault Code 1963 inactive and Fault Code 2878 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1963 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Fuel pump outlet pressure.

Guided Step 1A - Measure the fuel pump outlet pressure.

Conditions

  • Connect a pressure gauge to the Compuchek™ fitting of the fuel pump.
  • Turn keyswitch ON.
  • Engine running at 1200 rpm (engine cranking if troubleshooting (No-Start).

Action

Read the fuel pressure at 1200 rpm, or cranking if engine will not start.

Read the fuel pressure while cranking if the engine will not start.

  • Cranking: minimum of 172 kpa [25 psi]
  • Engine running at 1200 rpm: minimum of 827 kpa [120 psi].

Does the fuel pressure meet the specification?
YES | NO
No Repair | No Repair

Go to 1B

Reference the fuel system checks in Section TT of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel shutoff valve.

Guided Step 2A - Check for a stuck closed or plugged aftertreatment fuel shutoff valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Swap the aftertreatment fuel shutoff valve (1) and aftertreatment fuel drain valve (2) locations in the aftertreatment fuel shutoff valve manifold. These valves are the same part number so swapping the valve locations will determine if the fault follows the valve.

Remove the aftertreatment fuel shutoff valve (1) and the aftertreatment fuel drain valve (2) from the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-052 in Section 11.

  • Swap the valve locations by installing the valve that was removed from the aftertreatment fuel shutoff valve into the aftertreatment fuel drain valve location.
  • Install the valve that was removed from the aftertreatment fuel drain valve into the aftertreatment fuel shutoff valve location.
  • Connect the electrical connections to the valves.
  • Start the engine and idle for 5 minutes.

Note: Do not swap the electrical connections. Make sure the electrical connection remains in the original location.

The ISX aftertreatment fuel shutoff valve manifold is pictured on the left and the ISM aftertreatment fuel shutoff valve manifold is pictured on the right.

Fault Code 1963 inactive and Fault Code 2878 active?
YES NO

A stuck closed aftertreatment fuel shutoff valve has been detected.

Replace the valve that is presently installed in the aftertreatment fuel drain valve location.

Refer to Procedure 011-052 in Section 11.

Fuel is not being correctly delivered to the aftertreatment fuel shutoff valve manifold. Troubleshoot the cause of the fuel not being correctly delivered to the aftertreatment fuel shutoff valve manifold.

There may be a restriction in the fuel supply line between the fuel system and the aftertreatment fuel shutoff valve assembly.

Note: On ISM engines, remove the aftertreatment fuel line connection from the cylinder head. Inspect the fuel rail in the cylinder head for a plastic plug that may be blocking the fuel supply to the aftertreatment system.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate the engine for 5 minutes to purge air from the aftertreatment fuel system.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start and idle the engine for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Note: It may be necessary to run the engine multiple times in order to purge air from the aftertreatment fuel system.

Fault Code 1963 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active counts of Fault Code 2215. | Active or inactive counts of Fault Code 2215?
 | STEP 1B. Check for active fault codes. | Other fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Check the aftertreatment fuel shutoff valve. |
 | STEP 2A. Check for a stuck closed or plugged aftertreatment fuel shutoff valve. | Fault Code 1963 inactive and Fault Code 2878 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1963 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active counts of Fault Code 2215.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to check for active counts of Fault Code 2215.

It is possible to swap the connections between the aftertreatment fuel pressure sensor and the fuel delivery pressure sensor. If this occurs, Fault Code 2215 will intermittently go active and the engine will run very rough and will surge at low idle. If these symptoms are present, make sure the fuel pressure connections are connected properly.

Active or inactive counts of Fault Code 2215?
YES NO

Properly connect the aftertreatment fuel pressure sensor and fuel delivery pressure sensor wiring harness connections.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Other fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel shutoff valve.

Guided Step 2A - Check for a stuck closed or plugged aftertreatment fuel shutoff valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Swap the aftertreatment fuel shutoff valve (1) and aftertreatment fuel drain valve (2) locations in the aftertreatment fuel shutoff valve manifold. These valves are the same part number so swapping the valve locations will determine if the fault follows the valve.

Remove the aftertreatment fuel shutoff valve (1) and the aftertreatment fuel drain valve (2) from the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-052 in Section 11.

  • Swap the valve locations by installing the valve that was removed from the aftertreatment fuel shutoff valve into the aftertreatment fuel drain valve location.
  • Install the valve that was removed from the aftertreatment fuel drain valve into the aftertreatment fuel shutoff valve location.
  • Connect the electrical connections to the valves.
  • Start the engine and idle for 5 minutes.

Note: Do not swap the electrical connections. Make sure the electrical connection remains in the original location.

The ISX aftertreatment fuel shutoff valve manifold is pictured on the left and the ISM aftertreatment fuel shutoff valve manifold is pictured on the right.

Fault Code 1963 inactive and Fault Code 2878 active?
YES NO

A stuck closed aftertreatment fuel shutoff valve has been detected.

Replace the valve that is presently installed in the aftertreatment fuel drain valve location.

Refer to Procedure 011-052 in Section 11.

Fuel is not being correctly delivered to the aftertreatment fuel shutoff valve manifold. Troubleshoot the cause of the fuel not being correctly delivered to the aftertreatment fuel shutoff valve manifold.

There may be a restriction in the fuel supply line between the fuel system and the aftertreatment fuel shutoff valve assembly.

Note: On ISM engines, remove the aftertreatment fuel line connection from the cylinder head. Inspect the fuel rail in the cylinder head for a plastic plug that may be blocking the fuel supply to the aftertreatment system.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate the engine for 5 minutes to purge air from the aftertreatment fuel system.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start and idle the engine for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Note: It may be necessary to run the engine multiple times in order to purge air from the aftertreatment fuel system.

Fault Code 1963 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 1966 - Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1963, 1925, 2878, or 2879 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 42°C or 76°F?
STEP 2. | Check base engine components. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
 | STEP 2B. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1963, 1925, 2878, or 2879 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect electronic service tool.
  • Idle engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 42°C or 76°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check base engine components.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Check for an injector misfire.

  • Use INSITE™ electronic service tool to monitor the cylinder performance test results.
  • Determine if a cylinder misfire is detected at any engine speed and operating conditions.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a failed injector.

Replace the injector if necessary.

  • For ISM engines, use the following procedure in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.
  • For ISX engines, use the following procedure in the Service Manual, Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-026 in Section 6

Inspect the aftertreatment system for possible damage.

  • For ISM engines, use the following procedure in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322. Refer to Procedure 014-013 in Section 14.
  • For ISX engines, in the Service Manual, Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Appropriate troubleshooting tree

Go to 2B

Guided Step 2B - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

  • Look for a sign of moisture in the turbocharger exhaust outlet.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

  • For ISM engines, use the following procedure in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322. Refer to Procedure 014-013 in Section 14.
  • For ISX engines, use the following procedure the Service Manual, Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14 .

Inspect the engine for other sources of engine oil or diesel fuel entering the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Feb-2011


FAULT CODE 1968 - Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1665, 1666, 1667, 1674, 1675, or 1676 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector. |
 | STEP 4A. Check the operation of the aftertreatment fuel injector. | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665, 1666, 1667, 1674, 1675, or 1676 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect electronic service tool.
  • Idle engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to monitor the Cylinder Performance Test results.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use the INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary.

  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.
  • For ISX engines, use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-026 in Section 6.

Inspect the aftertreatment system for possible damage.

  • For ISX engines, use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • For ISX engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector.

Guided Step 4A - Check the operation of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Use the procedure found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239 for information on the Aftertreatment Fuel Injector Flow Test. Refer to Procedure 011-054 in Section 11.

Action

Check for fuel leaking from the aftertreatment injector when the aftertreatment fuel shutoff valve is open.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Fuel Shutoff Valve Leak Test.
  • Use the procedure found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for information on the aftertreatment fuel injector flow test. Refer to Procedure 011-054 in Section 11.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
YES NO

Replace the aftertreatment fuel injector.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-042 in Section 11.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

Perform a snap acceleration test to check for black smoke from the exhaust stack, idle the engine, and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2015


FAULT CODE 1969 - Aftertreatment Exhaust Gas Temperature 2 - Data Valid but Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1665, 1666, 1667, 1674, 1675, or 1676 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector. |
 | STEP 4A. Check the operation of the aftertreatment fuel injector. | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665, 1666, 1667, 1674, 1675, or 1676 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect electronic service tool.
  • Idle engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to monitor the Cylinder Performance Test results.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-026 in Section 6.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Appropriate fault code troubleshooting tree

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector.

Guided Step 4A - Check the operation of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Use the procedure found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for information on the Aftertreatment Fuel Injector Flow Test. Refer to Procedure 011-054 in Section 11.

Action

Check for fuel leaking from the aftertreatment injector when the aftertreatment fuel shutoff valve is open.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Fuel Shutoff Valve Leak Test.
  • Use the procedure found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, for information on the aftertreatment fuel injector flow test. Refer to Procedure 011-054 in Section 11

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Shutoff Valve Leak Test?
YES NO

Replace the aftertreatment fuel injector.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-042 in Section 11

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

Perform a snap acceleration test to check for black smoke from the exhaust stack. Idle the engine and then snap the throttle to 100 percent. Perform this test multiple times, if necessary. Check for any visible black smoke.

If black smoke is present, inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jun-2014


FAULT CODE 1972 - Exhaust Gas Temperature 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 1877, 1876, or 1878 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
 | STEP 1C. Check the diesel oxidation catalyst. | Diesel oxidation catalyst face plugged?
 | STEP 1D. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall. | Any cracks found in the cell walls?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector. |
 | STEP 4A. Perform the Aftertreatment Reset All procedure. | Aftertreatment Reset All procedure completed?
 | STEP 4B. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector flows more than the specification?
 | STEP 4C. Check the operation of the aftertreatment fuel injector. | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Injector Leak Test above specification?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877, 1876, or 1878 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect electronic service tool.
  • Idle engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 5A

Go to 1C

Guided Step 1C - Check the diesel oxidation catalyst.

Conditions

  • Inspect the diesel oxidation catalyst. Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-049 in Section 11.

Action

Inspect the diesel oxidation catalyst for face plugging. A face plugged aftertreatment can cause hydrocarbon during aftertreatment injection to be carried to the diesel particulate filter, creating high diesel particulate filter outlet temperatures.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-049 in Section 11.

Diesel oxidation catalyst face plugged?
YES NO

Remove the diesel oxidation catalyst from the vehicle and clean the face.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-049 in Section 11.

No Repair

Go to 5A

Go to 1D

Guided Step 1D - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell wall.

Conditions

  • Remove aftertreatment diesel oxidation catalyst.

Action

Inspect the aftertreatment diesel oxidation catalyst.

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell wall.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-049 in Section 11.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-049 in Section 11.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to monitor the Cylinder Performance Test results.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-026 in Section 6.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Appropriate fault code troubleshooting tree

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector.

Guided Step 4A - Perform the Aftertreatment Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

NOTE: Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu.

Go to 4B

Go to 4B

Guided Step 4B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment system test.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, for information on the aftertreatment fuel injector flow test. Refer to Procedure 011-054 in Section 11.

NOTE: It is only necessary to perform the flow test; the leak test is not necessary.

Aftertreatment fuel injector flows more than the specifications?
YES NO

Verify the Aftertreatment Reset All procedure has been completed.

Replace the aftertreatment injector.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-042 in Section 11.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the operation of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Use the procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™ ISX, and QSX15 Service Manual, Bulletin 3666239, for information on the Aftertreatment Fuel Injector Flow Test. Refer to Procedure 011-054 in Section 11.

Action

Check for fuel leaking from the aftertreatment injector when the aftertreatment fuel shutoff valve is open.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Fuel Injector Leak Test.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-054 in Section 11.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Injector Leak Test above specification?
YES NO

Replace the aftertreatment fuel injector.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-042 in Section 11.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jun-2014


FAULT CODE 1973 - Exhaust Gas Temperature 3 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1877, 1876, or 1878 active?
 | STEP 1B. Monitor the aftertreatment exhaust gas temperature sensors. | Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Check the aftertreatment fuel injector. |
 | STEP 4A. Perform the Aftertreatment Reset All procedure. | Aftertreatment Reset All procedure completed?
 | STEP 4B. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector flows more than the specification?
 | STEP 4C. Check the operation of the aftertreatment fuel injector. | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Injector Leak Test above specification?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1877, 1876, or 1878 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect electronic service tool.
  • Idle engine for more than 10 minutes.

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Any of the aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in Section 19.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool to monitor the Cylinder Performance Test results.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 006-026 in Section 6.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-026 in Section 6.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Appropriate fault code troubleshooting tree

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

  • Look for signs of moisture in the turbocharger exhaust outlet.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment fuel injector.

Guided Step 4A - Perform the Aftertreatment Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

NOTE: Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu.

Go to 4B

Go to 4B

Guided Step 4B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment system test.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, for information on the aftertreatment fuel injector flow test. Refer to Procedure 011-054 in Section 11.

NOTE: It is only necessary to perform the flow test; the leak test is not necessary.

Aftertreatment fuel injector flows more than the specifications?
YES NO

Verify the Aftertreatment Reset All procedure has been completed.

Replace the aftertreatment injector.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-042 in Section 11.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check the operation of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Use the procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™ ISX, and QSX15 Service Manual, Bulletin 3666239, for information on the Aftertreatment Fuel Injector Flow Test. Refer to Procedure 011-054 in Section 11.

Action

Check for fuel leaking from the aftertreatment injector when the aftertreatment fuel shutoff valve is open.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Fuel Injector Leak Test.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-054 in Section 11.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Injector Leak Test above specification?
YES NO

Replace the aftertreatment fuel injector.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-042 in Section 11.

Inspect the aftertreatment system for possible damage.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Jun-2014


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1974 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1974 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1974 active?
YES NO

Replace the crankcase breather filter.

  • Refer to Procedure 003&ndash;019 (Crankcase Breather Element) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1974 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


FAULT CODE 1977 - Aftertreatment Doser Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1977 active?
STEP 2. | Check the aftertreatment fuel injector and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment fuel injector resistance. | Between 0.5 and 2.0 ohms?
 | STEP 2C. Check for a short to ground in the aftertreatment fuel injector. | Greater than 100k ohms?
 | STEP 2D. Check the aftertreatment fuel injector diagnostic supply voltage, supply line, and return circuit. | Between 3.25 to 5.0-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the aftertreatment fuel injector diagnostic supply voltage. | Between 3.25 to 5.0-VDC?
 | STEP 3C. Check for an open supply circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for an open return circuit in the engine harness. | Less than 10 ohms?
 | STEP 3E. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3G. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3H. Check for an inactive fault code. | Fault Code 1977 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1977 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1977 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment fuel injector and circuit.

Guided Step 2A - Inspect the aftertreatment fuel injector and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment fuel injector resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check the resistance of the aftertreatment fuel injector.

  • Measure the resistance between the aftertreatment fuel injector SIGNAL pin and the aftertreatment fuel injector RETURN pin at the aftertreatment fuel injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 0.5 and 2.0 ohms?
YES NO
No Repair

Replace the aftertreatment fuel injector.

  • Use the following procedure in Service Manual, ISM, ISMe and QSM11, Bulletin 3666322, or Service Manual, Signature™, ISX, and QSX15, Bulletin 3666239. Refer to Procedure 011-042 in Section 11.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short to ground in the aftertreatment fuel injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for a short to ground.

  • Measure the resistance between the aftertreatment fuel injector SIGNAL pin and the metal case of the aftertreatment fuel injector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment fuel injector.

Replace the aftertreatment fuel injector.

  • Use the following procedure in Service Manual, ISM, ISMe and QSM11, Bulletin 3666322, or Service Manual, Signature™, ISX, and QSX15, Bulletin 3666239. Refer to Procedure 011-042 in Section 11.

Go to 2D

Go to 4A

Guided Step 2D - Check the aftertreatment fuel injector diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel injector from the engine harness.
  • Turn keyswitch ON.

Action

Check the aftertreatment fuel injector diagnostic supply voltage and return circuit.

  • Measure the voltage between the aftertreatment fuel injector SIGNAL pin and the aftertreatment fuel injector RETURN pin at the aftertreatment fuel injector connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 3.25 to 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 3F

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment fuel injector diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the aftertreatment fuel injector diagnostic supply voltage.

  • Measure the voltage between the aftertreatment fuel injector SUPPLY pin and ground at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-359 in Section 19.

Between 3.25 to 5.0-VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open supply circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment fuel injector SUPPLY pin and the engine harness aftertreatment fuel injector connector aftertreatment fuel injector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open aftertreatment fuel injector SUPPLY circuit has been detected in the engine harness.

A wiring harness pigtail interconnect is located in the wiring harness. Continue troubleshooting to determine if the short circuit is located in the pigtail or main wiring harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open return circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment fuel injector RETURN pin and the engine harness aftertreatment fuel injector connector aftertreatment fuel injector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open aftertreatment fuel injector RETURN circuit has been detected in the engine harness.

A wiring harness pigtail interconnect is located in the wiring harness. Continue troubleshooting to determine if the short circuit is located in the pigtail or main wiring harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment fuel injector SUPPLY pin in the engine harness ECM connector and ground.
  • Measure the resistance between the aftertreatment fuel injector RETURN pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit has been detected in the engine harness.

Repair or replace the engine harness.

A wiring harness pigtail interconnect is located in the wiring harness. Continue troubleshooting to determine if the short circuit is located in the pigtail or main wiring harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment fuel injector SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the aftertreatment fuel injector SUPPLY wire has been detected in the engine harness.

A wiring harness pigtail interconnect is located in the wiring harness. Continue troubleshooting to determine if the short circuit is located in the pigtail or main wiring harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel injector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment fuel injector RETURN pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the aftertreatment fuel injector RETURN wire has been detected in the engine harness.

A wiring harness pigtail interconnect is located in the wiring harness. Continue troubleshooting to determine if the short circuit is located in the pigtail or main wiring harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 3H

Go to 4A

Guided Step 3H - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check for the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1977 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 1977 is inactive.

Fault Code 1977 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Dec-2011


FAULT CODE 1981 (CPL 3774 and 3775) - Aftertreatment Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1879, 1881, or 1883 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1981 active?
STEP 2. | Inspect the aftertreatment diesel particulate filter differential pressure sensor. |
 | STEP 2A. Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool. | Aftertreatment diesel particulate filter differential pressure sensor reading [0 ± 3 kPa 0 ± 0.89 in-Hg] with key ON and engine OFF?
 | STEP 2B. Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage. | Aftertreatment diesel particulate filter differential pressure sensor supply tubes blocked?
STEP 3. | Check the ash cleaning maintenance interval. |
 | STEP 3A. Check the ash cleaning maintenance interval. | Ash cleaning interval has been followed?
 | STEP 3B. Perform the Aftertreatment Maintenance Filter Installation procedure. | Fault Code 1981 inactive?
STEP 4. | Inspect the aftertreatment exhaust gas temperature sensors and wiring. |
 | STEP 4A. Inspect the aftertreatment wiring harness connectors for correct sensor and pin installation. | Aftertreatment wiring harness connectors and pins installed correctly?
STEP 5. | Inspect the turbocharger. |
 | STEP 5A. Inspect the turbocharger shaft movement. | Nozzle slides evenly from stop to stop and gear teeth undamaged?
STEP 6. | Inspect the exhaust. |
 | STEP 6A. Exhaust for excessive smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
 | STEP 6B. Check aftertreatment DPF restriction. | Aftertreatment DPF restriction within specifications?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1981 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 7B

Guided Step 2 - Inspect the aftertreatment diesel particulate filter differential pressure sensor.

Guided Step 2A - Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool.

Aftertreatment diesel particulate filter differential pressure sensor reading [0 ± 3 kPa 0 ± 0.89 in-Hg] with key ON and engine OFF?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

Action

Disconnect the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-047 in Section 11.
  • Inspect the supply tubes for blockage.

Aftertreatment diesel particulate filter differential pressure sensor supply tubes blocked?
YES NO

Remove and clean the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-047 in Section 11.

  • Check for a short circuit from the SIGNAL pin of the aftertreatment diesel particulate filter differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • If no short circuit is found, replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to Procedure 019-443 in Section 19.

Go to 7A

Go to 7A

Guided Step 3 - Check the ash cleaning maintenance interval.

Guided Step 3A - Check the ash cleaning maintenance interval.

Action

Check the ash cleaning maintenance interval.

  • Check the ash cleaning maintenance interval of the diesel particulate filter. It is possible the ash cleaning interval has been ignored and the filter needs to be cleaned.

Reference the Operation and Maintenance manual for the recommended ash cleaning interval.

Ash cleaning interval has been followed?
YES NO

The aftertreatment diesel particulate filter has plugged with soot and the stationary regeneration procedure can not be performed until it has been inspected and cleaned in an SPX air pulse cleaning machine, or equivalent machine.

Use the following instructions to remove, inspect, and clean or replace the aftertreatment diesel particulate filter.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-041 in Section 11.

Note: If the aftertreatment diesel particulate filter does not meet the inspection criteria in Procedure 011-041, it must be replaced.

A stationary regeneration is not necessary on filters that are replaced unless Fault Code 1922 is also active.

Aftertreatment diesel particulate filters that meet the inspection criteria and are cleaned in an SPX air pulse cleaning machine or equivalent machine, must have a stationary regeneration after the cleaning process is complete.

Clean the aftertreatment diesel particulate filter.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-041 in Section 11.

Go to 3B

Go to 3B

Guided Step 3B - Perform the Aftertreatment Maintenance Filter Installation procedure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use the Aftertreatment Maintenance Filter Installation procedure to disable Fault Code 1981.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Filter Installation procedure, found under the Advanced ECM Data Section.

Fault Code 1981 inactive?
YES NO

Note: If the aftertreatment diesel particulate filter has only been cleaned due to reaching the ash cleaning maintenance interval, go to Step 7A. Otherwise, go to Step 4A.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4A

Go to 1A

Guided Step 4 - Inspect the aftertreatment exhaust gas temperature sensors and wiring.

Guided Step 4A - Inspect the aftertreatment wiring harness connectors for correct sensor and pin installation.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment wiring harness for correct connector and pin installation.

  • Inspect the aftertreatment exhaust gas temperature sensor connectors to verify that they are connected to the correct connector on the aftertreatment system wiring harness. Two of the temperature sensors have identical wiring harness connectors. The sensors are the same part number and it is possible to install the wiring harness connectors to the wrong sensors.
  • Inspect the aftertreatment exhaust gas temperature sensors and wiring harness connectors for correct pin installation locations.

Refer to the wiring diagram for connector pin identification and locations.

Aftertreatment wiring harness connectors and pins installed correctly?
YES NO
No Repair

Install the aftertreatment wiring harness connectors in the correct locations.

Install the pins in the correct connector locations.

Refer to the wiring diagram for connector pin identification and location.

Go to 5A

Go to 7A

Guided Step 5 - Inspect the turbocharger.

Guided Step 5A - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the variable geometry turbocharger actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

Move the sector gear lever on the turbocharger bearing housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever can be moved to the other stop position by hand.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.

Nozzle slides evenly from stop to stop and gear teeth undamaged?
YES NO

Install the turbocharger actuator.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.

A turbocharger mechanical malfunction has been detected.

NOTE: This malfunction could have been caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect the base engine components for damage.

For ISX CM871 clean, inspect, and repair the turbocharger assembly for reuse.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-145 in Section 10.

For ISM CM876 replace the turbocharger assembly.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-033 in Section 10.

The variable geometry turbocharger actuator will be reused with the new or repaired turbocharger. Do not install the actuator on the malfunctioning turbocharger.

Go to 6A

Go to 6A

Guided Step 6 - Inspect the exhaust.

Guided Step 6A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.
  • NOTE: To perform a Snap Acceleration Test, it could be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke.

 No Repair

Reference the appropriate Engine Performance Troubleshooting Tree

Go to 7A

Guided Step 6B - Check the aftertreatment DPF restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the following sections of the Aftertreatment Diesel Particulate Filter Restriction Test.

  • Test.
  • Analyzing the data.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-085 in Section 11.

Aftertreatment DPF restriction within specifications?
YES NO
No Repair

Replace the DPF. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-041 in Section 11.

  • Reference the appropriate engine performance troubleshooting tree.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM. Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Mar-2014


FAULT CODE 1981 (Non CPL 3774 and 3775) - Aftertreatment Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1879, 1881, or 1883 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1981 active?
STEP 2. | Inspect the aftertreatment diesel particulate filter differential pressure sensor. |
 | STEP 2A. Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool. | Aftertreatment diesel particulate filter differential pressure sensor reading [0 ± 3 kPa 0 ± 0.89 in-Hg] with key ON and engine OFF?
 | STEP 2B. Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage. | Aftertreatment diesel particulate filter differential pressure sensor supply tubes blocked?
STEP 3. | Check the ash cleaning maintenance interval. |
 | STEP 3A. Check the ash cleaning maintenance interval. | Ash cleaning interval has been followed?
 | STEP 3B. Perform the Aftertreatment Maintenance Filter Installation procedure. | Fault Code 1981 inactive?
STEP 4. | Inspect the aftertreatment exhaust gas temperature sensors and wiring. |
 | STEP 4A. Inspect the aftertreatment wiring harness connectors for correct sensor and pin installation. | Aftertreatment wiring harness connectors and pins installed correctly?
STEP 5. | Inspect the turbocharger. |
 | STEP 5A. Inspect the turbocharger shaft movement. | Nozzle slides evenly from stop to stop and gear teeth undamaged?
STEP 6. | Inspect the exhaust. |
 | STEP 6A. Exhaust for excessive smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1981 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 7B

Guided Step 2 - Inspect the aftertreatment diesel particulate filter differential pressure sensor.

Guided Step 2A - Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment diesel particulate filter differential pressure sensor with an electronic service tool.

Aftertreatment diesel particulate filter differential pressure sensor reading [0 ± 3 kPa 0 ± 0.89 in-Hg] with key ON and engine OFF?

YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the aftertreatment diesel particulate filter differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

Action

Disconnect the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-047 in Section 11.
  • Inspect the supply tubes for blockage.

Aftertreatment diesel particulate filter differential pressure sensor supply tubes blocked?
YES NO

Remove and clean the aftertreatment diesel particulate filter differential pressure sensor supply tubes.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-047 in Section 11.

  • Check for a short circuit from the SIGNAL pin of the aftertreatment diesel particulate filter differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • If no short circuit is found, replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to Procedure 019-443 in Section 19.

Go to 7A

Go to 7A

Guided Step 3 - Check the ash cleaning maintenance interval.

Guided Step 3A - Check the ash cleaning maintenance interval.

Action

Check the ash cleaning maintenance interval.

  • Check the ash cleaning maintenance interval of the diesel particulate filter. It is possible the ash cleaning interval has been ignored and the filter needs to be cleaned.

Reference the Operation and Maintenance manual for the recommended ash cleaning interval.

Ash cleaning interval has been followed?
YES NO

The aftertreatment diesel particulate filter has plugged with soot and the stationary regeneration procedure can not be performed until it has been inspected and cleaned in an SPX air pulse cleaning machine, or equivalent machine.

Use the following instructions to remove, inspect, and clean or replace the aftertreatment diesel particulate filter.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-041 in Section 11.

Note: If the aftertreatment diesel particulate filter does not meet the inspection criteria in Procedure 011-041, it must be replaced.

A stationary regeneration is not necessary on filters that are replaced unless Fault Code 1922 is also active.

Aftertreatment diesel particulate filters that meet the inspection criteria and are cleaned in an SPX air pulse cleaning machine or equivalent machine, must have a stationary regeneration after the cleaning process is complete.

Clean the aftertreatment diesel particulate filter.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-041 in Section 11.

Go to 3B

Go to 3B

Guided Step 3B - Perform the Aftertreatment Maintenance Filter Installation procedure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use the Aftertreatment Maintenance Filter Installation procedure to disable Fault Code 1981.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Filter Installation procedure, found under the Advanced ECM Data Section.

Fault Code 1981 inactive?
YES NO

Note: If the aftertreatment diesel particulate filter has only been cleaned due to reaching the ash cleaning maintenance interval, go to Step 7A. Otherwise, go to Step 4A.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4A

Go to 1A

Guided Step 4 - Inspect the aftertreatment exhaust gas temperature sensors and wiring.

Guided Step 4A - Inspect the aftertreatment wiring harness connectors for correct sensor and pin installation.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment wiring harness for correct connector and pin installation.

  • Inspect the aftertreatment exhaust gas temperature sensor connectors to verify that they are connected to the correct connector on the aftertreatment system wiring harness. Two of the temperature sensors have identical wiring harness connectors. The sensors are the same part number and it is possible to install the wiring harness connectors to the wrong sensors.
  • Inspect the aftertreatment exhaust gas temperature sensors and wiring harness connectors for correct pin installation locations.

Refer to the wiring diagram for connector pin identification and locations.

Aftertreatment wiring harness connectors and pins installed correctly?
YES NO
No Repair

Install the aftertreatment wiring harness connectors in the correct locations.

Install the pins in the correct connector locations.

Refer to the wiring diagram for connector pin identification and location.

Go to 5A

Go to 7A

Guided Step 5 - Inspect the turbocharger.

Guided Step 5A - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the variable geometry turbocharger actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

Move the sector gear lever on the turbocharger bearing housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever can be moved to the other stop position by hand.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.
  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.

Nozzle slides evenly from stop to stop and gear teeth undamaged?
YES NO

Install the turbocharger actuator.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.

A turbocharger mechanical malfunction has been detected.

NOTE: This malfunction could have been caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect the base engine components for damage.

For ISX CM871 clean, inspect, and repair the turbocharger assembly for reuse.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-145 in Section 10.

For ISM CM876 replace the turbocharger assembly.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-033 in Section 10.

The variable geometry turbocharger actuator will be reused with the new or repaired turbocharger. Do not install the actuator on the malfunctioning turbocharger.

Go to 6A

Go to 6A

Guided Step 6 - Inspect the exhaust.

Guided Step 6A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.
  • NOTE: To perform a snap acceleration test, it could be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke.

 No Repair

Reference the appropriate Engine Performance Troubleshooting Tree

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM. Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Mar-2014


FAULT CODE 1992 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Do not operate a diesel engine where there are or can BE COMBUSTIBLE vapors. These vapors can be sucked through the air intake system and cause engine acceleration and over speeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of over speeding where an engine, due to its application, is operating in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. The equipment owner and operator ARE responsible for safe operation in a hostile environment. Consult A Cummins® Authorized Repair Location for further information.
CAUTION

If the engine speed stays above 15 percent of rated speed, the engine must be shut off immediately or engine generator equipment damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the engine. | Fault Code 1992 inactive?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if a fuel-controlled event occurred where the engine rapidly accelerated to or past 15 percent above rated speed, followed by moderate deceleration to 15 percent above rated speed.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Operate engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

NOTE: Compare the engine crankshaft speed/position sensor reading with INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the engine crankshaft speed/position sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1C

Fault Codes 689 and 1376.

Guided Step 1C - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the OEM harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine crankshaft speed/position sensor.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-218 in Section 19.

No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 1992 .

  • Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.

Action

Test the engine.

  • Test the engine to check if the overspeed condition is still present.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Jan-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1879, 1881, or 1883 active?
STEP 2. | Inspect the aftertreatment diesel particulate filter differential pressure. |
 | STEP 2A. Check the aftertreatment diesel particulate filter differential pressure sensor tubes. | Aftertreatment diesel particulate filter differential pressure sensor tubes are installed correctly?
STEP 3. | Check the pressure of the aftertreatment diesel particulate filter. |
 | STEP 3A. Inspect the aftertreatment diesel particulate filter. | Tampering or removal of the aftertreatment system has been detected?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment diesel particulate filter differential pressure.

Guided Step 2A - Check the aftertreatment diesel particulate filter differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment diesel particulate filter differential pressure sensor tubes for the following:

  • Leaks or cracks in the differential pressure sensor tubes.
  • Loose fittings on the differential pressure sensor tubes.
  • Missing or broken differential pressure sensor tubes.
  • Plugged tubes.
  • Make sure the differential pressure sensor tubes are installed correctly. It is possible the differential pressure sensor tubes are connected backwards at the rubber tubes at the sensor connection. Refer to Procedure 019-443 in Section 19.

Aftertreatment diesel particulate filter differential pressure sensor tubes are installed correctly?
YES NO
No Repair

Repair or replace the aftertreatment diesel particulate filter differential pressure sensor tubes.

  • Refer to Procedure 011-047 in Section 11

The procedure can be found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 3A

Go to 4A

Guided Step 3 - Check the presence of the aftertreatment diesel particulate filter.

Guided Step 3A - Inspect the aftertreatment diesel particulate filter.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment diesel particulate filter. Refer to Procedure 011-041 in Section 11.

The procedure can be found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™; ISX and QSX15 Service Manual, Bulletin 3666239.

Action

Inspect the aftertreatment diesel particulate filter.

  • Inspect the aftertreatment system to determine if the aftertreatment diesel particulate filter has been tampered with or has been removed from the exhaust system.

Refer to Procedure 011-041 in Section 11.

The procedure can be found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Tampering or removal of the aftertreatment system has been detected?
YES NO

Install the correct aftertreatment system for the vehicle.

  • Refer to Procedure 011-041 in Section 11.

The procedure can be found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Replace the aftertreatment diesel particulate filter differential pressure sensor. Refer to Procedure 019-443 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair compete

Go to 1A

Last Modified: 23-Jan-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an engine brake relay. |
 | STEP 1A. Inspect the engine brake relay connector. | Additional components connected to the engine brake signal line?
STEP 2. | Check the internal actuator harness, engine brake harness, and solenoids. |
 | STEP 2A. Inspect the connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the internal actuator harness, engine brake harness, and solenoid for an open circuit. | Between 5 and 15 ohms?
 | STEP 2C. Inspect the solenoid and engine brake harness connection. | Dirty or damaged pins?
 | STEP 2D. Check the internal actuator harness for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check the engine brake harness for an open circuit. | Less than 10 ohms?
 | STEP 2F. Check the engine brake solenoid for an open circuit. | Between 5 and 15 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check for an open circuit. | Greater than 5.0 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the diagnostic voltage at the ECM. | Greater than 5.0 VDC?
 | STEP 3D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3E. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3F. Check for a short circuit to a voltage source. | Less than 1 VDC?
 | STEP 3G. Inspect the solenoid and engine brake harness connection. | Dirty or damaged pins?
 | STEP 3H. Check for an open circuit in the ECM. | Did engine brake number 1 operate?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2182 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for an engine brake signal relay.

Guided Step 1A - Inspect the engine brake signal relay connector.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine harness.

  • Inspect the engine harness near the intake manifold.

Additional components connected to the engine brake signal line?
YES NO

Disconnect the components and actuate the engine brakes to determine if the fault code no longer occurs.

Refer to OEM specific troubleshooting information or Cummins® application engineers bulletins.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the internal actuator harness, engine brake harness, and solenoids.

Guided Step 2A - Inspect the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal actuator harness connector.

Action

Inspect the engine harness and internal actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19..

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the internal actuator harness, engine brake harness, and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal actuator harness connector.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 1 SIGNAL pin of the internal actuator harness connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Between 5 and 15 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the solenoid and engine brake harness connection.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003&ndash;011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Action

Inspect the engine brake harness and engine brake solenoid number 1 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Replace the engine brake harness, if necessary.

  • Refer to Procedure 019-063 (Internal Actuator Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the internal actuator harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003&ndash;011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the engine harness from the internal actuator harness connector.
  • Disconnect the engine brake harness from the internal actuator harness.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance from the internal actuator harness connector number 1 SIGNAL pin to the number 1 SIGNAL pin of the 3-pin connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the internal actuator harness.

  • Refer to Procedure 019-063 (Internal Actuator Wiring Harness) in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check the engine brake harness for an open circuit.

Conditions

  • Disconnect the engine harness from the engine brake connector.
  • Remove the rocker lever cover. Refer to Procedure 003&ndash;011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 1 and the internal actuator harness.

Action

Check the resistance of the engine brake harness.

  • Use a multimeter to measure the resistance from the engine brake harness, from the engine brake solenoid number 1 SIGNAL pin of the engine brake connector to the solenoid connector pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

Replace the engine brake harness.

  • Refer to Procedure 019-063 (Internal Actuator Wiring Harness) in Section 19.

Go to 2F

Go to 4A

Guided Step 2F - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the rocker lever cover. Refer to Procedure 003&ndash;011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the engine brake solenoid terminal pin to engine block ground.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Contact a Cummins® Authorized Repair Facility.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check the engine harness for an open circuit.

  • Use a multimeter to measure the voltage from the engine brake solenoid number 1 SIGNAL pin in the engine brake connector of the engine harness to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3E

Go to 3B

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the voltage at the ECM.

  • Use a multimeter to measure the voltage from the engine brake solenoid number 1 SIGNAL pin of the ECM port to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance of the engine brake solenoid number 1 SIGNAL wire between the ECM connector and the engine brake connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 1 SIGNAL pin in the ECM connector to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check for signal short to ground.

  • Use a multimeter to measure the voltage from the engine brake solenoid number 1 SIGNAL pin of the engine harness to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1 VDC?
YES NO
No Repair

There is a short to a voltage source.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Inspect the solenoid and engine brake harness connection.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003&ndash;011 (Rocker Lever Cover) in Section 3 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.

Action

Inspect the engine brake harness and engine brake solenoid number 1 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-063 (Internal Actuator Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3H

Guided Step 3H - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Turn keyswitch ON.
  • Engine Brake Control feature is enabled Engine Brake Minimum Vehicle Speed set to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect the INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all Engine Brake Output Circuits and Engine Brake Switch Level with the INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the Engine Brake Output Circuits Engine Brake Switch Level and Fault Codes.
  • Be sure that all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Did engine brake number 1 operate?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Use the INSITE™ electronic service tool to reset all engine brake settings and features to their original settings.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use the INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2182 inactive?
YES NO
No Repair

Return to the troubleshooting steps, or contact a local Cummins® Authorized Repair location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool, to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake solenoid number 1 signal circuit. |
 | STEP 1A. Check the diagnostic voltage at the internal actuator harness pass-through connector. | Greater than 5.0-VDC?
 | STEP 1B. Check the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the diagnostic voltage at the ECM. | Greater than 5.0-VDC?
STEP 2. | Check the internal brake harness and brake solenoids. |
 | STEP 2A. Check the internal brake harness assembly for a short to ground. | More than 100k ohms?
 | STEP 2B. Check the internal brake harness assembly for an open circuit. | Less than 10k ohms?
 | STEP 2C. Check the brake solenoids for a short to ground. | Between 5 and 15 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine brake solenoid number 1 signal circuit.

Guided Step 1A - Check the diagnostic voltage at the internal actuator harness pass-through connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal actuator harness at the pass-through connection.
  • Turn keyswitch ON.

Action

Check the diagnostic voltage.

  • Use a multimeter to measure the voltage from the engine brake solenoid number 1 SIGNAL pin of the engine harness to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the voltage.

  • Use a multimeter to measure the voltage from the engine brake solenoid number 1 SIGNAL pin of the ECM port to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 2 - Check the internal brake harness assembly and brake solenoids.

Guided Step 2A - Check the internal brake harness assembly for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal actuator harness at the pass-through connector.
  • Remove the engine rocker lever cover. Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake wiring harness from solenoid number 1.

Action

Check for a pinched or an abraded harness, or areas possibly shorted to ground.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 1 SIGNAL pin of the internal actuator harness connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the internal actuator wiring harness.

  • Refer to Procedure 019-063 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the internal brake harness assembly for an open circuit.

Conditions

  • Remove the engine rocker lever cover. Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the internal brake harness from the engine brake solenoid.
  • Disconnect the engine harness from the internal actuator harness at the pass-through connection.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance of the internal actuator harness from the engine brake solenoid number 1 SIGNAL pin of the engine brake connector to the number 1 solenoid connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Replace the internal actuator wiring harness.

  • Refer to Procedure 019-063 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the brake solenoids for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine rocker lever cover. Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake wiring harness from solenoid number 1.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the solenoid terminal pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 020-024 in Section 20.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jul-2010


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2B-1. Check for an unswitched battery supply OEM connector. |
 | STEP 2B-2. Check for a pin-to-pin short circuit in the unswitched battery supply OEM harness. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Short circuit pin-to-pin check:

  • Measure the resistance between the accelerator pedal position +5 volt SUPPLY and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for an unswitched battery supply OEM connector.

Conditions

  • Turn keyswitch OFF.

Action

Check to make sure the ECM power connection is a dedicated power supply and does not supply power to any other devices between the ECM and battery.

This dedicated connector provides unswitched battery voltage to the ECM and will be in addition to the primary OEM connector.

Dedicated unswitched battery supply OEM connector?
YES | NO
No Repair | No Repair

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check for a pin-to-pin short circuit in the unswitched battery supply OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt SUPPLY and the ECM battery SUPPLY (+) pins in the OEM power harness connector

Use the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-071 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3 - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 16-Oct-2015


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin to ground short circuit in the OEM harness. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2186 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the accelerator pedal/lever position sensor.

See the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt SUPPLY and all other pins in the OEM harness ECM connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin to ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance and check for a short circuit between the accelerator +5 volt SUPPLY pin and engine block ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2186 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 16-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2195 is active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2195 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2195 is active?
YES NO

The fault code indicates that the emergency door of the vehicle has been opened.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2195 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2636 active?
STEP 2. | Check the VGT actuator circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2636 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2198 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 2198 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2198 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 active?
YES | NO
No Repair | No Repair

Fault Code 2636 troubleshooting tree

Go to 2A

Guided Step 2 - Check the VGT actuator circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 active?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the VGT actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the VGT actuator.

  • Refer to Procedure For ISM engines, 010-134 (Variable Geometry Turbocharger Actuator, Electric) in Section 10 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 010-134 (Variable Geometry Turbocharger Actuator, Electric) in Section 10 in the Signature, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2198 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


FAULT CODE 2215 - Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an active fault code. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
 | STEP 1B. Check the fuel pressure sensor connections. | Aftertreatment fuel pressure sensor and fuel delivery pressure sensor wiring harness connections swapped?
STEP 2. | Check the fuel supply. |
 | STEP 2A. Check the vehicle fuel tanks for fuel. | Fuel in the fuel tanks?
 | STEP 2B. Verify the fuel system has been primed. | Fuel system properly primed?
 | STEP 2C. Check for fuel leaks. | Any fuel leaks in the tanks or the fuel supply lines?
 | STEP 2D. Check for fuel inlet restriction. | Fuel inlet restriction less than the specifications listed?
STEP 3. | Check the engine operation. |
 | STEP 3A. Crank the engine to see if it starts. | Engine start?
STEP 4. | Check the fuel lift pump operation. |
 | STEP 4A. Check the fuel lift pump for activation at keyswitch ON. | Fuel lift pump operate when the keyswitch is turned ON?
 | STEP 4B. Check the fuel lift pump pressure. | Positive fuel pressure greater than 64 kPa [10 psi] present when the lift pump is operating?
STEP 5. | Check the fuel shutoff valve operation. |
 | STEP 5A. Check the fuel shutoff valve electrical operation. | Fuel shutoff valve operates and 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON?
 | STEP 5B. Check the fuel shutoff valve mechanical operation. | Pressure difference greater than 69 kPa [10 psi]?
 | STEP 5C. Check for a mechanical restriction of the fuel shutoff valve. | Debris present in the fuel shutoff valve or signs the fuel shutoff valve is restricting flow?
STEP 6. | Check the 1724 kPa [250 psi] fuel pressure regulator. |
 | STEP 6A. Inspect the 1724 kPa [250 psi] fuel pressure regulator. | Any amount of fuel coming from the engine control module (ECM) cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?
STEP 7. | Check the 2620 kPa [380 psi] pressure regulator. |
 | STEP 7A. Inspect the 2620 kPa [380 psi] pressure regulator. | More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?
STEP 8. | Check the fuel pump (gear pump) pressure. |
 | STEP 8A. Measure the fuel pump (gear pump) pressure while cranking. | Fuel pump (gear pump) pressure less than 2413 kPa [350 psi] cranking at 130 rpm for 15 seconds?
STEP 9. | Check the fuel pressure. |
 | STEP 9A. Measure the fuel pump (gear pump) pressure at idle. | Fuel pump (gear pump) pressure at least 1448 kPa [210 psi] at idle?
 | STEP 9B. Measure the fuel pump (gear pump) pressure at high idle. | Fuel pump (gear pump) pressure a minimum of 1931 kPa [280 psi] at 2000 rpm?
STEP 10. | Check for air in the pressure-side fuel. |
 | STEP 10A. Check for air in the pressure-side fuel. | Air present in the pressure-side fuel?
STEP 11. | Check the fuel inlet restriction. |
 | STEP 11A. Measure the fuel inlet restriction. | Fuel inlet restriction less than the specification?
STEP 12. | Check the fuel shutoff valve. |
 | STEP 12A. Check for a mechanical restriction of the fuel shutoff valve. | Debris present in the fuel shutoff valve or signs the fuel shutoff valve is restricting flow?
STEP 13. | Check the pressure-side fuel filter. |
 | STEP 13A. Measure the pressure drop across the pressure-side fuel filter. | Pressure drop across the pressure-side fuel filter less than 517 kPa [75 psi]?
STEP 14. | Check the 1724 kPa [250 psi] fuel pressure regulator. |
 | STEP 14A. Inspect the 1724 kPa [250 psi] fuel pressure regulator. | Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?
STEP 15. | Check the 2620 kPa [380 psi] pressure regulator. |
 | STEP 15A. Inspect the 2620 kPa [380 psi] pressure regulator. | More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness.
STEP 16. | Check the fuel pressure sensor for accuracy. |
 | STEP 16A. Verify the accuracy of the rail fuel pressure sensor. | INSITE™ electronic service tool and pressure gauge readings match within 138 kPa [20 psi]?
STEP 17. | Clear the fault codes. |
 | STEP 17A. Disable the fault code. | Fault Code 2215 inactive?
 | STEP 17B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for an active fault code.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: If Fault Code 2215 is active or inactive, attempt to clear the fault. If the fault code remains active or inactive, continue through the tree.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227

Go to 1B

Guided Step 1B - Check the fuel pressure sensor connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel pressure sensor connections.

It is possible to swap the connections between the aftertreatment fuel pressure sensor and the fuel delivery pressure sensor. If this occurs, Fault Code 2215 will intermittently go active and the engine will operate very rough and will surge at low idle. If these symptoms are present, make sure the fuel pressure connections are connected properly.

Aftertreatment fuel pressure sensor and fuel delivery pressure sensor wiring harness connections swapped?
YES NO

Properly connect the aftertreatment fuel pressure sensor and fuel delivery pressure sensor wiring harness connections.

 No Repair

Go to 17A

Go to 2A

Guided Step 2 - Check the fuel supply.

Guided Step 2A - Check the vehicle fuel tanks for fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle fuel tanks for fuel.

Fuel in the fuel tanks?
YES NO
No Repair

Fill the fuel tanks.

Go to 2B

Go to 17A

Guided Step 2B - Verify the fuel system has been primed.

Conditions

  • Turn keyswitch OFF.

Action

If entering this tree after a component has been replaced in the fuel system, or after the engine was emptied of fuel, verify the fuel system has been properly primed before proceeding.

  • Verify the fuel system has been properly primed.
  • Use the following procedure for fuel system priming information found in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666329. Refer to Procedure 006-015 in Section 6.

Fuel system properly primed?
YES NO
No Repair

Prime the fuel system.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666329. Refer to Procedure 006-015 in Section 6.

Go to 2C

Go to 17A

Guided Step 2C - Check for fuel leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel tanks, lines, and related components for leaks.

  • Inspect for fuel leaks.

Any fuel leaks in the tanks or the fuel supply lines?
YES NO

Locate and repair the source of the fuel leak by checking all the engine and original equipment manufacturer (OEM) supply lines, fittings, suction-side fuel filter head, fuel tank stand pipes, ECM cooling plate, and ECM cooling plate fuel supply and return lines.

No Repair

Go to 17A

Go to 2D

Guided Step 2D - Check for fuel inlet restriction.

Conditions

  • Connect the vacuum gauge to the suction side Compuchek™ fitting.
  • Turn keyswitch ON.
  • Operate engine at high idle (engine cranking if troubleshooting No-Start).

Action

If the engine uses a priming pump, wait until the priming pump has turned off and observe the reading on the vacuum gauge.

  • Check the fuel inlet restriction.

Dirty: 305 mm-Hg [12 in-Hg]

New: 203 mm-Hg [8 in-Hg]

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction less than the specifications listed?
YES NO
No Repair

Locate the cause of high fuel inlet restriction.

Check the suction-side fuel filter and fuel supply lines.

Note: For QSK only, check the 300 micron inlet filter screen for debris.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

Go to 3A

Repair complete

Guided Step 3 - Check the engine operation.

Guided Step 3A - Crank the engine to see if it starts.

Conditions

  • Turn keyswitch ON.

Action

Start the engine.

Engine start?
YES | NO
No Repair | No Repair

Go to 9A

Go to 4A

Guided Step 4 - Check the fuel lift pump operation.

Guided Step 4A - Check the fuel lift pump operation.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel lift pump for activation at keyswitch ON.

  • Verify the fuel lift pump operates when the vehicle keyswitch is turned ON.

Fuel lift pump operate when the keyswitch is turned ON?
YES NO
No Repair

Check the fuel lift pump. Use the following procedure found in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-045 in Section 5.

Go to 4B

Go to 17A

Guided Step 4B - Check the fuel lift pump pressure.

Conditions

  • Turn keyswitch ON.
  • Connect a pressure gauge on the gear pump inlet Compuchek™ fitting.

Action

Check the fuel lift pump pressure.

  • Verify there is a positive fuel pressure greater than 64 kPa [10 psi] when the fuel lift pump is operating.

Note: Erratic fuel lift pump pressure can indicate air in the fuel.

Positive fuel pressure greater than 64 kPa [10 psi] present when the lift pump is operating?
YES NO
No Repair

Repair or replace the fuel lift pump. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-045 in Section 5.

Go to 5A

Go to 17A

Guided Step 5 - Check the fuel shutoff valve operation.

Guided Step 5A - Check the fuel shutoff valve electrical operation.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel shutoff valve for activation at keyswitch ON.

  • Verify the fuel shutoff operates and there is 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON.

Fuel shutoff valve operates and 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON?
YES NO
No Repair

Check the fuel shutoff valve. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

Go to 5B

Go to 17A

Guided Step 5B - Check the fuel shutoff valve mechanical operation.

Conditions

  • Connect pressure gauge, Part Number 3375932, on the rail fuel pressure Compuchek™ fitting.
  • Connect a pressure gauge, Part Number 3375932, on the gear pump output pressure Compuchek™ fitting.
  • Turn keyswitch ON.

Action

Monitor the fuel pressure on both gauges with the lift pump operating.

A restricted pressure-side fuel filter will cause erroneous fuel pressure drop readings during this test. Address any fuel filter issues before proceeding.

Pressure difference greater than 69 kPa [10 psi]?
YES NO

Repair or replace the fuel shutoff valve. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

No Repair

Go to 6A

Go to 5C

Guided Step 5C - Check for a mechanical restriction of the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.

Action

Check for a mechanical restriction of the fuel shutoff valve.

  • Remove and inspect the fuel shutoff valve for a mechanical restriction.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

Debris present in the fuel shutoff valve or signs the fuel shutoff valve is restricting flow?
YES NO

Repair or replace the fuel shutoff valve. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

No Repair

Go to 17A

Go to 6A

Guided Step 6 - Check the 1724 kPa [250 psi] fuel pressure regulator.

Guided Step 6A - Inspect the 1724 kPa [250 psi] fuel pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 1724 kpa [250 psi] pressure regulator.

  • Disconnect the wiring harness from the fueling and timing actuators.
  • Remove the fuel line that connects the pressure fuel filter head on the integrated fuel system module (IFSM) to the ECM cooling plate at the cooling plate.
  • Install a cap onto the fitting into the cooling plate to make sure no air is brought into the fuel system.
  • Place the fuel line into a bucket and crank the engine. If there is a measurable amount of fuel coming out of the line during cranking, fuel is bypassing the 1724 kPa [250 psi] regulator.

Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?

YES NO

Remove and inspect the 1724 kPa [250 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.

Replace the 1724 kPa [250 psi] regulator. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 7A

Guided Step 7 - Check the 2620 kPa [380 psi] pressure regulator.

Guided Step 7A - Inspect the 2620 kPa [380 psi] pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 2620 kPa [380 psi] pressure regulator.

  • Disconnect the OEM drain line connection at the IFSM.
  • Install a short piece of hose and place the end into a bucket.
  • Disconnect the wiring harness from the fueling and timing actuators.
  • Turn keyswitch ON and wait until the lift pump stops operating.
  • Crank the engine for 15 seconds and measure the fuel from the IFSM drain.

More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?

YES NO

Remove and inspect the 2620 kPa [380 psi] pressure regulator for debris that can cause the regulator to stick open and inspect for cut or missing o-rings.

Replace the regulator.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 8A

Guided Step 8 - Check the fuel pump (gear pump) pressure.

Guided Step 8A - Measure the fuel pump (gear pump) pressure while cranking.

Conditions

  • Connect a pressure gauge to the Compuchek™ fitting on the back of the fuel pump (gear pump).
  • Turn keyswitch ON.
  • Disconnect the wire at the fuel shutoff valve.

Action

Measure the fuel pump (gear pump) pressure while cranking.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after the keyswitch is turned ON or disconnect the 2-pin power supply from the lift pump.

Note: The engine wiring harness must be disconnected from the fuel shutoff valve during this step.

  • Measure the fuel pump (gear pump) pressure while cranking the engine.

Do not crank the engine for 30 seconds continuously. Crank the engine in 15 second intervals with a 15 second pause between intervals. This reduces the possibility of overheating the starting motor.

Fuel pump (gear pump) pressure less than 2413 kPa [350 psi] cranking at 130 rpm for 15 seconds?
YES NO

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239 for repair or replacement of the fuel pump (gear pump). Refer to Procedure 005-016 in Section 5.

No Repair

Go to 17A

Go to 17A

Guided Step 9 - Check the fuel pressure.

Guided Step 9A - Measure the fuel pump (gear pump) pressure at idle.

Conditions

  • Connect all components.
  • Connect pressure gauge, Part Number 3375932, on the Compuchek™ fitting (as shown).
  • Turn keyswitch ON.
  • Operate engine at idle.

Action

Measure the fuel pump (gear pump) pressure at idle.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.

Measure the fuel pump (gear pump) pressure.

  • With the engine operating at idle, use a pressure gauge attached to the rail fuel pressure Compuchek™ fitting on the IFSM to measure the fuel pump (gear pump) pressure.

Rail fuel pressure at least 1448 kPa [210 psi] at idle?
YES | NO
No Repair | No Repair

Go to 9B

Go to 12A

Guided Step 9B - Measure the fuel pump (gear pump) pressure at high idle.

Conditions

  • Turn keyswitch OFF.
  • Connect pressure gauge, Part Number 3375932, on the Compuchek™ fitting (as shown).
  • Turn keyswitch ON.
  • Operate engine at idle.

Action

Measure the fuel pump (gear pump) pressure at high idle.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.
  • Measure the fuel pump (gear pump) pressure with the engine operating at high idle and no load.
  • With the engine operating at idle, use a pressure gauge attached to the rail fuel pressure Compuchek™ fitting on the IFSM to measure the fuel pump (gear pump) pressure.

Fuel pump (gear pump) pressure a minimum of 1931 kPa [280 psi] at 2000 rpm?
YES | NO
No Repair | No Repair

Go to 16A

Go to 10A

Guided Step 10 - Check for air in the pressure-side fuel.

Guided Step 10A - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the pressure-side fuel.

Note: Possible sources of air in the pressure-side fuel are leaks in:

  • OEM supply lines
  • Fittings
  • Suction-side fuel filter head
  • Fuel tank stand pipes
  • ECM cooling plate
  • ECM cooling plate fuel supply and return lines.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-003 in Section 6.

Air present in the pressure-side fuel?
YES NO

Locate and repair the source of the air leak by checking all the OEM supply lines and fittings, suction-side fuel filter head, fuel tank stand pipes, ECM cooling plate, and ECM cooling plate fuel supply and return lines.

No Repair

Go to 17A

Go to 11A

Guided Step 11 - Check the fuel inlet restriction.

Guided Step 11A - Measure the fuel inlet restriction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start the engine.

Action

Measure the fuel inlet restriction.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.
  • Check the fuel inlet restriction.
  • Maximum clean filter: 203 mmHg [8 inHg]
  • Maximum dirty filter: 305 mmHg [12 inHg]

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction less than the specification?
YES NO
No Repair

Replace the suction-side fuel filter or repair the cause of high inlet restriction.

Go to 12A

Go to 17A

Guided Step 12 - Check the fuel shutoff valve.

Guided Step 12A - Check for a mechanical restriction of the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.

Action

Check for a mechanical restriction of the fuel shutoff valve.

  • Remove and inspect the fuel shutoff valve for a mechanical restriction.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

Debris present in the fuel shutoff valve or signs the fuel shutoff valve is restricting flow?
YES NO

Repair or replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 17A

Go to 13A

Guided Step 13 - Check the pressure-side fuel filter.

Guided Step 13A - Measure the pressure drop across the pressure-side fuel filter.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine at high idle.

Action

Measure the pressure drop across the pressure-side fuel filter.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.

Note: The fuel temperature must be a minimum of 38°C [100°F].

  • Measure the pressure drop across the pressure-side fuel filter while the engine is operating at high idle and no load.
  • Use the Compuchek™ fitting on the back of the fuel pump (gear pump) to measure the pressure out of the fuel pump (gear pump). This will be the high pressure reading.
  • Use the Compuchek™ fitting on the underside of the IFSM to measure the pressure of the fuel rail. This will be the low pressure reading.
  • Subtract the low reading from the high reading to obtain the pressure drop across the pressure-side fuel filter.

Pressure drop across the pressure-side fuel filter less than 517 kPa [75 psi]?
YES NO
No Repair

Replace the pressure fuel filter.

Go to 14A

Go to 17A

Guided Step 14 - Check the 1724 kPa [250 psi] fuel pressure regulator.

Guided Step 14A - Inspect the 1724 kPa [250 psi] fuel pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 1724 kpa [250 psi] fuel pressure regulator.

  • Disconnect the engine wiring harness from the fueling and timing actuators.
  • Remove the fuel line that connects the pressure fuel filter head on the IFSM to the ECM cooling plate at the cooling plate.
  • Install a cap onto the fitting into the cooling plate to make sure no air is brought into the fuel system.
  • Place the fuel line into a bucket and crank the engine. If there is a measurable amount of fuel coming out of the line during cranking, then fuel is bypassing the 1724 kPa [250 psi] fuel pressure regulator.

Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?

YES NO

Remove and inspect the 1724 kPa [250 psi] regulator for debris that can stick the regulator open and for cut or missing o-rings.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 36663239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 15A

Guided Step 15 - Check the 2620 kPa [380 psi] pressure regulator.

Guided Step 15A - Inspect the 2620 kPa [380 psi] pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 2620 kpa [380 psi] fuel pressure regulator.

  • Disconnect the OEM drain line connection at the IFSM.
  • Install a short piece of hose and place the end of the hose into a bucket.
  • Disconnect the wiring harness from the fueling and timing actuators.
  • Turn the keyswitch ON and wait until the lift pump stops operating.
  • Crank the engine for 15 seconds and measure the fuel from the IFSM.

More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness.

YES NO

Remove and inspect the 2620 kPa [380 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.

Replace the regulator. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 16A

Guided Step 16 - Check the fuel pressure sensor for accuracy.

Guided Step 16A - Verify the accuracy of the rail fuel pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Install a pressure gauge on the rail fuel pressure Compuchek™ fitting.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the readings agree.

  • Verify the pressure gauge and INSITE™ electronic service tool readings for the rail fuel pressure sensor agree.

INSITE™ electronic service tool and pressure gauge readings match within 138 kPa [20 psi]?
YES NO

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239 for repair or replacement of the fuel pump (gear pump). Refer to Procedure 005-016 in Section 5.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 17A

Go to 17A

Guided Step 17 - Clear the fault codes.

Guided Step 17A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2215 is inactive.

Fault Code 2215 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 17B

Go to 1A

Guided Step 17B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-Feb-2014


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fuel restriction. |
 | STEP 1A. Check for fuel restriction in the fuel drain line. | Restriction below 229 mm Hg [9 in Hg]?
STEP 2. | Check rail fuel pressure sensor. |
 | STEP 2A. Verify the accuracy with a mechanical gauge. | Gauge and INSITE™ electronic service tool readings are within 69 kPa [10 psi]?
STEP 3. | Replace the fuel regulator. |
 | STEP 3A. Replace the 1724 kPa [250 psi] fuel regulator. | Fault Code 2216 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2216 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fuel restriction.

Guided Step 1A - Check for fuel restriction in the fuel drain line.

Conditions

  • Engine running.

Action

Check for fuel restriction in the fuel drain line.

  • Install restriction gauge in fuel drain line.
  • Start the engine and run at high idle.
  • Check the restriction gauge.

Restriction below 229 mm Hg [9 in Hg]?
YES NO
No Repair

Correct drain line restriction.

Refer to Procedure 006-012 (Fuel Drain Line Restriction) in Section 6 the Signature, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 2A

Go to 4A

Guided Step 2 - Check rail fuel pressure sensor.

Guided Step 2A - Verify the accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy.

  • Connect a mechanical fuel pressure gauge to the pressure side Compuchek™ fitting.
  • Setup INSITE™ electronic service tool Monitor Mode to display Rail Fuel Pressure.
  • Start the engine and compare the rail fuel pressure reading on INSITE™ electronic service tool to the reading on the mechanical fuel pressure gauge.

Gauge and INSITE™ electronic service tool readings within 69 kPa [10 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor.

Refer to Procedure 019-115 (Fuel Rail Pressure Sensor) in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Replace the fuel regulator.

Guided Step 3A - Replace the 1724 kPa [250 psi] regulator.

Conditions

  • Turn keyswitch OFF.

Action

Replace the 1724 kPa [250 psi] regulator.

Fault Code 2216 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2215 is inactive.

Fault Code 2216 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Jul-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
 | STEP 1B. Check the fault codes. | Fault Code 2272 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2272 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Fault Code 1893 troubleshooting tree

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

Replace the EGR valve motor.

  • Refer to Procedure For ISM engines, 011&ndash;022 (EGR Valve) in Section 11 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011&ndash;022 (EGR Valve) in Section 11 in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2272 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2273 inactive?
STEP 2. | Check the EGR valve delta pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR valve delta pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2274 active and Fault Code 2273 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2273 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2273 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the EGR valve delta pressure sensor and circuit.

Guided Step 2A - Inspect the EGR valve delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR valve delta pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR valve delta pressure sensor SUPPLY pin to the EGR valve delta pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve delta pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A defective sensor has been detected.

Replace the EGR valve delta pressure sensor.

Refer to Procedure 019-370 (EGR Differential Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR valve delta pressure sensor SUPPLY pin to the EGR valve delta pressure sensor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2273 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2274 inactive?
STEP 2. | Check the EGR valve delta pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR valve delta pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2273 active and Fault Code 2274 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2274 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2274 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the EGR valve delta pressure sensor and circuit.

Guided Step 2A - Inspect the EGR valve delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR valve delta pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR valve delta pressure sensor SUPPLY pin to the EGR valve delta pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR valve delta pressure sensor SUPPLY pin and the EGR valve delta pressure sensor SIGNAL pin at the EGR valve delta pressure sensor connector of th engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active and Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve delta pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

A defective sensor has been detected.

Replace the EGR valve delta pressure sensor.

Refer to Procedure 019-370 (EGR Differential Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR valve delta pressure sensor SUPPLY pin to the EGR valve delta pressure sensor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR valve delta pressure sensor SUPPLY pin and the EGR valve delta pressure sensor SIGNAL pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active and Fault Code 2274 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2274 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for additional fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Codes 686 and/or 687 active or inactive?
STEP 2. | Check the ECM snapshot data. |
 | STEP 2A. Check the exhaust gas pressure, intake manifold pressure, EGR valve position, and EGR differential pressure values in Fault Code 2288 snapshot data. | Are ALL of the following true?: Are the values for the EGR valve position greater than 50 percent, EGR differential pressure less than 13.5 kPa [4 in-hg], and the difference between the exhaust gas pressure and intake manifold pressure (Exhaust gas pressure - (minus) intake manifold pressure) greater than 135.5 kPa [40 in-hg]?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2288 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for additional fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 686 and/or 687 active or inactive?
YES NO

  • Troubleshoot the fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate troubleshooting steps.

Go to 2A

Guided Step 2 - Check the ECM snapshot data.

Guided Step 2A - Check the exhaust gas pressure, intake manifold pressure, EGR valve position, and EGR differential pressure values in Fault Code 2288 snapshot data.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Expand and read the Fault Code 2288 snapshot data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data.
  • Check the values for the parameters: exhaust pressure, intake manifold pressure, EGR valve position, and EGR differential pressure.

Are ALL of the following true?:

Are the values for the EGR valve position greater than 50 percent, EGR differential pressure less than 13.5 kPa [4 in-hg], and the difference between the exhaust gas pressure and intake manifold pressure (Exhaust gas pressure - (minus) intake manifold pressure) greater than 135.5 kPa [40 in-hg]?

YES NO

Remove the EGR cooler and inspect for plugging.

Clean the EGR cooler if possible.

  • Refer to Procedure 011-019 in Section 11. See the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure 011-019 in Section 11. See the Signature&trade;, ISX, and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2288 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fueling actuator. |
 | STEP 1A. Inspect the fueling actuator and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the fault codes. | Fault Code 2311 inactive?
 | STEP 1C. Check the fueling actuator resistance. | 0.1 to 0.8 ohms?
 | STEP 1D. Check for a short to ground. | More than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the whole circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2D. Check for a short to voltage in the engine harness. | Less than 1.5 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 2311 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2311 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fueling actuator.

Guided Step 1A - Inspect the fueling actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.

Action

Inspect the engine harness and fueling actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the fueling actuator connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1C

Guided Step 1C - Check the fueling actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for an open circuit in the fueling actuator.

  • Measure the resistance between the front fueling actuator (+) pin and the front fueling actuator (-) pin of the front fueling actuator.

Note: Since the actuator resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

0.1 to 0.8 ohms?
YES NO
No Repair

Replace the fueling actuator.

Refer to Procedure 019-110 (Fueling Actuator) in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.

Action

Check for a short to ground in the fueling actuator.

Measure the resistance between the following front fueling actuator pins and engine block ground:

  • Front fueling actuator (+) pin
  • Front fueling actuator (-) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Replace the fueling actuator.

Refer to Procedure 019-110 (Fueling Actuator) in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the fueling actuator.
  • Disconnect the engine harness from the ECM connector.

Action

Check the reistance of the whole circuit.

  • Measure the resistance between the front fueling actuator (+) pin and the front fueling actuator (-) pin at the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

Measure the resistance between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Front fueling actuator (+) pin
  • Front fueling actuator (-) pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check for a short circuit to voltage source in the engine harness.

Measure the voltage from the following engine harness ECM connector pins to engine block ground:

  • Front fueling actuator (+) pin
  • Front fueling actuator (-) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing actuator. |
 | STEP 1A. Inspect the timing actuator and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the fault codes. | Fault Code 2312 inactive?
 | STEP 1C. Check the timing actuator resistance. | 0.1 to 0.8 ohms?
 | STEP 1D. Check for a short to ground. | More than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the whole circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2D. Check for a short to voltage in the engine harness. | Less than 1.5 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 2312 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2312 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the timing actuator.

Guided Step 1A - Inspect the timing actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Inspect the engine harness and timing actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2312 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1C

Guided Step 1C - Check the timing actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for an open circuit in the timing actuator.

  • Measure the resistance between the front timing actuator (+) pin and the front timing actuator (-) pin of the front timing actuator.

Note: Since the actuator resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

0.1 to 0.8 ohms?
YES NO
No Repair

Replace the timing actuator.

Refer to Procedure 019-111 (Timing Actuator) in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Check for a short to ground in the timing actuator.

Measure the resistance between the following front timing actuator pins and engine block ground:

  • Front timing actuator (+) pin
  • Front timing actuator (-) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Replace the timing actuator.

Refer to Procedure 019-111 (Timing Actuator) in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the timing actuator.
  • Disconnect the engine harness from the ECM connector.

Action

Check the whole circuit.

  • Measure the resistance between the front timing actuator (+) pin and the front timing actuator (-) pin at the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

Measure the resistance between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Front timing actuator (+) pin
  • Front timing actuator (-) pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check for a short circuit to voltage source in the engine harness.

Measure the voltage from the following engine harness ECM connector pins to engine block ground:

  • Front timing actuator (+) pin
  • Front timing actuator (-) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2312 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B

Repair complete

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2312 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fueling actuator. |
 | STEP 1A. Inspect the fueling actuator and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the fault codes. | Fault Code 2313 inactive?
 | STEP 1C. Check the fueling actuator resistance. | 0.1 to 0.8 ohms?
 | STEP 1D. Check for a short to ground. | More than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the whole circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2D. Check for a short to voltage in the engine harness. | Less than 1.5 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 2313 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2313 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fueling actuator.

Guided Step 1A - Inspect the fueling actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.

Action

Inspect the engine harness and fueling actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2313 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1C

Guided Step 1C - Check the fueling actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for an open circuit in the fueling actuator.

  • Measure the resistance between the rear fueling actuator (+) pin and the rear fueling actuator (-) pin of the rear fueling actuator.

Note: Since the actuator resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

0.1 to 0.8 ohms?
YES NO
No Repair

Replace the fueling actuator.

Refer to Procedure 019-110 (Fueling Actuator) in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.

Action

Check for a short to ground in the fueling actuator.

Measure the resistance between the following rear fueling actuator pins and engine block ground:

  • Rear fueling actuator (+) pin.
  • Rear fueling actuator (-) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Replace the fueling actuator.

Refer to Procedure 019-110 (Fueling Actuator) in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the fueling actuator.
  • Disconnect the engine harness from the ECM connector.

Action

Check the whole circuit.

  • Measure the resistance between the rear fueling actuator (+) pin and the rear fueling actuator (-) pin at the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

Measure the resistance between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Rear fueling actuator (+) pin
  • Rear fueling actuator (-) pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check for a short circuit to voltage source in the engine harness.

Measure the voltage from the following engine harness ECM connector pins to engine block ground:

  • Rear fueling actuator (+) pin
  • Rear fueling actuator (-) pin.

Refer to the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2313 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A

Repair complete

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2313 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing actuator. |
 | STEP 1A. Inspect the timing actuator and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the fault codes. | Fault Code 2314 inactive?
 | STEP 1C. Check the timing actuator resistance. | 0.1 to 0.8 ohms?
 | STEP 1D. Check for a short to ground. | More than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the whole circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2D. Check for a short to voltage in the engine harness. | Less than 1.5 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 2314 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2314 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the timing actuator.

Guided Step 1A - Inspect the timing actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Inspect the engine harness and timing actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2314 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1C

Guided Step 1C - Check the timing actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for an open circuit in the timing actuator.

  • Measure the resistance between the rear timing actuator (+) pin and the rear timing actuator (-) pin of the rear timing actuator.

Note: Since the actuator resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

0.1 to 0.8 ohms?
YES NO
No Repair

Replace the timing actuator.

Refer to Procedure 019-111 (Timing Actuator) in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Check for a short to ground in the timing actuator.

Measure the resistance between the following rear timing actuator pins and engine block ground:

  • Rear timing actuator (+) pin
  • Rear timing actuator (-) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Replace the timing actuator.

Refer to Procedure 019-111 (Timins Actuator) in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19..

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the timing actuator.
  • Disconnect the engine harness from the ECM connector.

Action

Check the whole circuit.

  • Measure the resistance between the rear timing actuator (+) pin and the rear timing actuator (-) pin at the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

Measure the resistance between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Rear timing actuator (+) pin
  • Rear timing actuator (-) pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19..

Go to 2D

Go to 3A

Guided Step 2D - Check for a short to voltage in the engine harness.

Conditions

  • Disconnect the engine harness from the timing actuator.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check for a short circuit to voltage source in the engine harness.

Measure the voltage from the following engine harness ECM connector pins to engine block ground:

  • Rear timing actuator (+) pin
  • Rear timing actuator (-) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 1.5 VDC?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2314 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B

Repair Complete

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic serve tool to verify the fault code is inactive.

Fault Code 2314 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 2319 - Exhaust Back Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Calibrate the ECM. |
 | STEP 1A. Calibrate the ECM to Aug, 2010, or later revision date. | ECM calibrated to Aug, 2010, or later revision date?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2319 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Calibrate the ECM.

Guided Step 1A - Calibrate the ECM to August, 2010, or later revision date.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECM.

Use INSITE™ electronic service tool to calibrate the ECM with August, 2010 or later INCAL™ DVD.

ECM calibrated to Aug, 2010, or later revision date?
YES NO

Clear the fault codes, then check again for active or inactive fault codes.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Verify that Fault Code 2319 is inactive.

Fault Code 2319 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Jun-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active or has high number of inactive counts?
STEP 2. | Check the primary speed sensor circuit (crankshaft sensor). |
 | STEP 2A. Inspect the primary speed sensor connector pins (crankshaft sensor). | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2321 become active during engine operation?
 | STEP 3B. Inspect the air gap and the target wheel. | Air gap within specification?
 | STEP 3C. Inspect the target wheel. | Target wheel damaged?
 | STEP 3D. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 is active or has a high number of inactive counts?

Note: If Fault Code 689 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

YES | NO
No Repair | No Repair

Fault Code 689 troubleshooting tree

Go to 2A

Guided Step 2 - Check the primary speed sensor circuit (crankshaft sensor).

Guided Step 2A - Inspect the primary speed sensor connector pins (crankshaft sensor).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor from the engine harness.

Action

Inspect the engine harness and primary speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the primary speed sensor connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the primary speed sensor.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use thee following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the primary speed sensor (crankshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. With the engine running, accelerate the engine several times.

  • Use INSITE™ electronic service tool to monitor fault codes.

Does Fault Code 2321 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Remove the primary engine speed sensor (crankshaft) from the engine block and measure the air gap at several points in the crankshaft's revolution.

  • Refer to Procedure 019-365 in Section 19.

Air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft target wheel/gear teeth/key for damage or spinning.

  • Refer to Procedure 001-069 in Section 1.

Target wheel damaged?
YES NO

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239 for repair or replacement.

Replace the target wheel. Refer to Procedure 001-069 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2321 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector to the engine speed sensor connector.

Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the engine crankshaft speed/position sensor. Refer to Procedure 019-365 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 778 is active or has high number of inactive counts?
STEP 2. | Check the secondary speed sensor circuit (camshaft sensor). |
 | STEP 2A. Inspect the secondary speed sensor (camshaft sensor) connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2322 become active during engine operation?
 | STEP 3B. Inspect the air gap and the target wheel. | Air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2322 status change from inactive to active while manipulating the engine harness?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2322 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 is active or has high number of inactive counts?

Note: If Fault Code 778 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

YES | NO
No Repair | No Repair

Refer to Fault Code 778 troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary speed sensor circuit (camshaft sensor).

Guided Step 2A - Inspect the secondary speed sensor (camshaft sensor) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use thee following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the secondary speed sensor.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use thee following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the secondary speed sensor (camshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

With the engine running, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Does Fault Code 2322 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the secondary engine speed sensor (camshaft sensor) from the gear housing and measure the air gap at several points in the crankshaft's revolution.

Refer to Procedure 019-363 in Section 19.

Air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2322 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine speed sensor connector.

Does Fault Code 2322 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the engine camshaft speed/position sensor. Refer to Procedure 019-363 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disabel the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2322 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for additional fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 686 and/or 687 active or inactive?
STEP 2. | Check the turbocharger. |
 | STEP 2A. Inspect the turbocharger speed sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Inspect the turbocharger speed sensor. | Turbocharger speed sensor damage found?
 | STEP 2C. Check for an inactive fault code. | Fault Code 2345 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2345 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for additional fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 686 and/or 687 active or inactive?
YES NO

Troubleshoot fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate troubleshooting steps

Go to 2A

Guided Step 2 - Check the turbocharger.

Guided Step 2A - Inspect the turbocharger speed sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the engine harness and turbocharger speed sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.
  • Remove the turbocharger speed sensor from the turbocharger housing. Refer to Procedure 019-390 in Section 19.

Action

Inspect the nose of the turbocharger speed sensor for the following:

  • Cuts or scratches on the nose of the sensor.
  • Cuts or scratches on the sensor body.
  • A cracked sensor mounting boss.

Turbocharger speed sensor damage found?
YES NO

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2345 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 3A

Fault Code 686 troubleshooting tree

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2345 inactive?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Code 2346 active or high inactive counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2346 active or high inactive counts?
YES NO

The engine power output was derated to limit the exhaust temperatures.

No Repair

Refer to Fault Code 2451 troubleshooting procedures.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jul-2010


FAULT CODE 2347 - Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operational Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Code 2634, 2449, or 2387 active?
 | STEP 1B. Check for inactive fault codes. | Fault Code 295 or 2973 active?
STEP 2. | Check sensor readings. |
 | STEP 2A. Check ambient air pressure sensor accuracy. | INSITE™ electronic service tool reading within 10 cm Hg [4 inHg] of local barometric pressure?
 | STEP 2B. Check the intake manifold pressure sensor accuracy. | Intake manifold pressure reading less than 10 cm Hg [4 inHg]?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2347 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2634, 2449, or 2387 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 295 or 2973 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check sensor readings.

Guided Step 2A - Check the ambient air pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Start INSITE™ Data Monitor/Logger and compare the INSITE™ electronic service tool reading for Barometric Air Pressure to local barometric pressure using the table below. Compare the readings.

Refer to Procedure 018-028 in Section 19.

INSITE™ electronic service tool reading within 10 cm Hg [4 inHg] of local barometric pressure?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the intake manifold pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the value of Intake Manifold Pressure without the engine running.

Intake Manifold Pressure reading less than 10 cm Hg [4 inHg]?
YES NO

Use the following Troubleshooting Symptom tree for information to continue to troubleshoot for low boost pressure in the appropriate Service Manual . Reference the Intake manifold Pressure (Boost) is Below Normal in Section TS.

Replace the intake manifold pressure sensor.

Refer to Procedure 019-159.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Note: Unless the failure is a failed barometric pressure or intake manifold pressure sensor, this fault code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code, and to determine if the failure has been found and fixed.

Fault Code 2347 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Nov-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
 | STEP 1B. Check the fault codes. | Fault Code 2349 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2349 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Fault Code 1893 troubleshooting tree

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2349 active?
YES NO

Replace the EGR valve motor.

  • Refer to Procedure For ISM engines, 011&ndash;022 (EGR Valve) in Section 11 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011&ndash;022 (EGR Valve) in Section 11 the Signature, ISX, and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2349 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
STEP 2. | Check the EGR valve. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes. | Fault Code 2351 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2349 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Fault Code 1893 troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR valve.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 active?
YES NO

Replace the EGR valve.

  • Refer to Procedure For ISM engines, 011-022 (EGR Valve) in Section 11 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-022 (EGR Valve) in Section 11 in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

None. The removal and installation of the connector corrected the failure.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2351 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Feb-2011


FAULT CODE 2357 - EGR Valve Control Circuit - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1893 active?
STEP 2. | Check the exhaust gas recircultation (EGR) valve. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for active fault codes. | Fault Code 1896 active?
STEP 3. | Check the EGR valve operation. |
 | STEP 3A. Monitor the EGR valve operation. | Fault Code 1896 becomes active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system found during the inspection?
 | STEP 4B. Disable the fault code. | Fault Code 2357 inactive?
 | STEP 4C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1893 active?
YES | NO
No Repair | No Repair

Fault Code 1893 troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR valve.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the EGR valve sensor.

  • Refer to Procedure For ISM engines, 011-022 in Section 11 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-022 in Section 11 in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Connect all components.
  • Turn keyswitch OFF for 10 seconds.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES NO

A stuck open EGR valve has been detected.

ISX CM871 engines:

  • Clean the EGR valve assembly, if possible. If the assembly can not be cleaned, replace, if necessary. Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-094 in Section 11.

ISM CM876 engines:

  • Replace the EGR valve. Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-022 in Section 11.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the EGR valve operation.

Guided Step 3A - Monitor the EGR valve position.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Turn the keyswitch ON and wait 3 minutes.

  • The EGR valve will be commanded open and closed automatically by the ECM. An automatic diagnostic test will be performed.
  • Turn the keyswitch off for 30 seconds, then turn the keyswitch back on.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 becomes active?
YES NO

ISX CM871 engines:

  • Clean the EGR valve assembly, if possible. If the assembly can not be cleaned, replace, if necessary. Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-094 in Section 11.

ISM CM876 engines:

  • Replace the EGR valve. Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-022 in Section 11.

The restriction in the EGR valve has been removed. No repair is necessary.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check for progressive damage to the aftertreatment system.

Conditions

  • Connect all components.
  • Perform the Snap Acceleration Test. Refer to Procedure 014-013 in Section 14 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322 or in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Action

Check for damage to the aftertreatment system.

  • Perform the Snap Acceleration Test to check for damage to the aftertreatment diesel particulate filter.
  • Progressive damage to the aftertreatment system may have occurred. The aftertreatment system must be inspected for reuse.
  • Refer to Procedure 014-013 in Section 14 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322 or in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Progressive damage to the aftertreatment system found during the Snap Acceleration Test?
YES NO

  • Replace the damaged aftertreatment component.Refer to Procedure 011-050 in Section 11 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322 or in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2357 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4C

Go to 1A

Guided Step 4C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 10-Dec-2013


FAULT CODE 2359 - Exhaust Gas Recirculation (EGR) Valve Differential Pressure - Data Valid But Above Normal Operating Range

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active exhaust gas recirculation (EGR) valve fault codes. | Fault Code 1895, 1896, 2357, or 2774 active?
 | STEP 1B. Check for inactive counts of Fault Code 2774. | Less than 10 counts?
 | STEP 1C. Check for active EGR differential pressure sensor fault codes. | Fault Code 1866, 2273, or 2274 active?
STEP 2. | Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging. |
 | STEP 2A. Check the EGR differential pressure tubes for leaks. | Leaks detected at either the low or high EGR differential pressure tubes?
 | STEP 2B. Check the EGR differential pressure tubes for plugging. | Debris or soot found in either EGR differential pressure tube?
 | STEP 2C. Check the EGR differential pressure sensor adapter for leaks. | Leaks detected at the EGR differential pressure sensor adapter?
 | STEP 2D. Check the EGR venturi. | Carbon buildup detected in the EGR venturi tube or EGR differential pressure tube ports?
STEP 3. | Check the EGR differential pressure sensor and circuit. |
 | STEP 3A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2274 active?
 | STEP 3C. Check the EGR valve. | EGR valve position less than 4 percent open?
 | STEP 3D. Check the EGR valve. | EGR Valve Differential Pressure and EGR Valve Position within specifications?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 2359 inactive?
 | STEP 5B. Clear the inactive fault codes. | All inactive fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR valve fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1895, 1896, 2357, or 2774 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive counts of Fault Code 2774.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check for high inactive counts of Fault Code 2774.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 2774.

Less than 10 counts?
YES | NO
No Repair | No Repair

Go to 1C

Fault Code 2774 Troubleshooting Tree

Guided Step 1C - Check for active EGR differential pressure sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1866, 2273, or 2274 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging.

Guided Step 2A - Check the EGR differential pressure tubes for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the lines for leaks.

  • Leaks can be easily noted by traces of soot.

Leaks detected at either the low or high EGR differential pressure tubes?
YES NO

Tighten the fittings or replace the EGR differential pressure tube.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the EGR differential pressure tubes for plugging.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure tubes for restrictions, soot plugging, and plugging.

Use the following procedures to remove the EGR differential pressure tubes.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Debris or soot found in either EGR differential pressure tube or connection block?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the EGR differential pressure sensor adapter for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor adapter for leaks.

Leaks should be easily noted by traces of soot; however, the sensor may need to be removed to inspect the o-rings between the EGR differential pressure sensor and the adapter for proper sealing.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-028 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-028 in Section 11.

Leaks detected at the EGR differential pressure sensor adapter?
YES NO

Replace the EGR differential pressure sensor adapter.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-028 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-028 in Section 11.

No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check EGR venturi.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure tubes.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Action

Inspect the EGR venturi for carbon buildup.

  • Inspect the EGR differential pressure tube ports for signs of carbon buildup.
  • Inspect inside the venturi tube for signs of carbon buildup.

Carbon buildup detected in the EGR venturi tube or EGR differential pressure tube ports?
YES NO

Remove the EGR venturi tube.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-025 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-025 in Section 11.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the EGR differential pressure sensor and circuit.

Guided Step 3A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and engine EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the EGR valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate to high idle.

Action

Check the EGR valve position with the sensor unplugged.

  • Use INSITE™ electronic service tool to monitor the EGR valve position.

EGR valve position less than 4 percent open?
YES NO
No Repair

A dirty or damaged EGR valve has been detected. Clean or replace the EGR valve.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-022 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-022 in Section 11.

Go to 3D

Go to 5A

Guided Step 3D - Check the EGR valve.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR differential pressure sensor engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify that the EGR valve is fully closed during the stationary (parked) regeneration.

Perform an aftertreatment diesel particulate filter (DPF) regeneration:

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 014-013 in Section 14.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.
  • Monitor the EGR Differential Pressure and the EGR Valve Position Measured (Percent Open) with INSITE™ electronic service tool during the stationary (parked) regeneration.

Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-056 in Section 11.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-056 in Section 11.

Are the EGR valve differential pressure and EGR valve position within specifications?
YES NO

A dirty or damaged EGR valve has been detected. Clean or replace the EGR valve.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-022 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-022 in Section 11.

A damaged sensor has been detected. Replace the EGR differential pressure sensor.

  • Refer to Procedure 019-370 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2359 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All inactive fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Mar-2014


FAULT CODE 2363 - Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISM CM876 | 3666322
Engine Control Module | Refer to Procedure 019-031 | ISM CM876 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 | 4021560
Engine Brake Solenoid Valve | Refer to Procedure 020-024 | ISM CM876 | 3666322

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active and/or inactive fault codes. | Fault Code 2363 active or multiple inactive counts?
STEP 2. | Check the internal brake harness assembly and brake solenoids. |
 | STEP 2A. Inspect the connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the internal actuator harness, engine brake harness, and solenoid for an open circuit. | Between 5 and 15 ohms?
 | STEP 2C. Inspect the solenoid and engine brake harness pins. | Dirty or damaged pins?
 | STEP 2D. Check the internal brake harness for a short to ground. | Greater than 100k ohms?
 | STEP 2E. Check for a short in the engine harness. | Greater than 100k ohms?
 | STEP 2F. Check the brake solenoid for a short to ground. | Between 5 and 15 ohms?
STEP 3. | Check engine brake solenoid number 1 signal circuit. |
 | STEP 3A. Check the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 2 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2363 active or multiple inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the internal brake harness assembly and brake solenoids.

Guided Step 2A - Inspect the connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal actuator harness connector.

Action

Inspect the engine harness and internal actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connecter shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the internal actuator harness, engine brake harness, and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal actuator harness.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 2 SIGNAL pin of the internal actuator harness connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 15 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the solenoid and engine brake harness connection.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the engine harness and internal actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connecter shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Replace the engine brake harness, if necessary. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check the internal brake harness assembly for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal actuator harness at the pass-through connection.
  • Remove the engine rocker lever cover. Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake harness from the solenoid 2.

Action

Check for a pinched or an abraded harness, or areas possibly shorted to ground.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 2 SIGNAL pin of the internal actuator harness connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the internal actuator wiring harness. Refer to Procedure 019-063 in Section 19.

Go to 2E

Go to 3C

Guided Step 2E - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 2 SIGNAL pin in the ECM connector to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Check the brake solenoids for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake wiring harness from solenoid number 2.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the solenoid terminal pin to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-024 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid number 2 signal circuit.

Guided Step 3A - Check the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector or ECM.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 2 SIGNAL pin in the ECM connector to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Turn keyswitch ON.
  • Enable Engine Brake Control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Delay time set to 0.
  • Select 100 percent braking with the manual dash switch.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure that all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 2 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Jun-2015


FAULT CODE 2363 (ISX) - Engine Brake Actuator Circuit 2 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISX CM871 | 3666239
Engine Control Module | Refer to Procedure 019-031 | ISX CM871 | 3666239
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM871 | 3666239
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISX CM871 | 3666239

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2363 active or multiple inactive counts?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Check the ECM and engine harness connector. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check the engine brake solenoid for a short to ground. | Resistance 5 ohms or greater?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 2 operating correctly?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

This step is for ISX CM871 only. In calibrations newer than March of 2008 all engine brake fault codes (2182, 2183, 2363, and 2367) have been masked. If directed here from another procedure, troubleshoot as if the fault code is active, even if there are no active engine brake fault codes.

Fault Code 2363 active or multiple inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 2 supply and return wires from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL wire at the engine brake solenoid and the engine brake solenoid number 2 SIGNAL wire at the ECM connector.
  • Measure the resistance between the engine brake solenoid number 2 RETURN wire at the engine brake solenoid and the engine brake solenoid number 2 RETURN wire at the ECM connector.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 2 signal or return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator signal wire has been detected in the engine harness.

Troubleshooting each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector all other pins in the ECM connector.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 signal wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance from engine brake number 2 solenoid terminal pin to ground.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Resistance 5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine harness from the engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance of engine brake number 2 solenoid SUPPLY terminal pin to RETURN terminal pin.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for a open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2
  • Turn keyswitch ON.
  • Enable Engine Brake Control feature.
  • Engine Brake Minimum Vehicle Speed set to zero.
  • Delay time set to zero.
  • Select 100 percent brake with the manual dash-switch.
  • Connect the INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all Engine Brake Output Circuits and Engine Brake Switch Level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the Engine Brake Output Circuits, Engine Brake Switch Level, and Fault Codes.
  • Make sure that all conditions are met for the engine brakes to operate; for example: clutch not depressed and zero percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 2 operating correctly?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Jul-2015


FAULT CODE 2365 - Engine Brake Actuator Driver Output 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake solenoid 3 signal circuit. |
 | STEP 1A. Check the diagnostic signal voltage at the engine brake harness pass-through connector. | Greater than 5.0 VDC?
 | STEP 1B. Check the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the diagnostic signal voltage at the ECM. | Greater than 5.0 VDC?
STEP 2. | Check the engine brake wiring harness and solenoids. |
 | STEP 2A. Check the engine brake wiring harness for a short to ground. | More than 100k ohms?
 | STEP 2B. Check the brake solenoids for a short to ground. | Greater than 5 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2365 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the engine brake solenoid 3 signal circuit.

Guided Step 1A - Check the diagnostic signal voltage at the engine brake harness pass-through connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check the diagnostic signal voltage.

  • Use a multimeter to measure the voltage from the engine brake solenoid Number 3 SIGNAL pin of the engine harness to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the diagnostic voltage.

  • Use a multimeter to measure the voltage from the engine brake solenoid Number 3 SIGNAL pin of the ECM port to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 2 - Check the engine brake wiring harness and solenoids.

Guided Step 2A - Check the engine brake wiring harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine rocker lever cover. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake wiring harness from solenoid Number 3.

Action

Check for a pinched or an abraded harness, or areas that may be shorted to ground.

  • Use a multimeter to measure the resistance from the engine brake solenoid Number 3 SIGNAL pin of the engine brake connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the engine brake wiring harness.

Refer to Procedure 019-136 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the brake solenoids for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine rocker lever cover. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 003-011 in Section .3
  • Disconnect the engine brake wiring harness from solenoid Number 3.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the solenoid terminal pin to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 5 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Use the following procedure in the Signature, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 020-012 in Section 20.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine.
  • Activate the engine brakes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2365 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Jun-2012


FAULT CODE 2367 (ISM) - Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISM CM876 | 3666322
Engine Control Module | Refer to Procedure 019-031 | ISM CM876 | 4021560
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 | 4021560
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | ISM CM876 | 4021560

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active and/or inactive fault codes. | Fault Code 2367 active or multiple inactive counts?
STEP 2. | Check the internal actuator harness, engine brake harness, and solenoids. |
 | STEP 2A. Inspect the connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the internal actuator harness, engine brake harness, and solenoid for an open circuit. | Between 5 and 15 ohms?
 | STEP 2C. Inspect the solenoid and engine brake harness connection. | Dirty or damaged pins?
 | STEP 2D. Check the internal actuator harness for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check the engine brake harness for an open circuit. | Less than 10 ohms?
 | STEP 2F. Check the engine brake solenoid for an open circuit. | Between 5 and 15 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the ECM. | Engine brake number 2 operational?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2367 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active and/or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active and/or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2367 active or multiple inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the internal actuator harness, engine brake harness, and solenoid.

Guided Step 2A - Inspect the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal actuator harness connector.

Action

Inspect the engine harness and internal actuator harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3D

Go to 2B

Guided Step 2B - Check the internal actuator harness, engine brake harness, and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal actuator harness connector.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 2 SIGNAL pin of the internal actuator harness connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 15 ohms?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2C

Guided Step 2C - Inspect the solenoid and engine brake harness connection.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the engine brake harness and engine brake solenoid number 2 connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Replace the engine brake harness, if necessary. Refer to Procedure 019-063 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the internal actuator harness and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine harness from the internal actuator harness connector.
  • Disconnect the engine brake harness from the internal actuator harness.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance from the internal actuator harness connector number 2 SIGNAL pin to the number 2 SIGNAL pin of the 3-pin connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the internal actuator harness. Refer to Procedcure 019-063 in the Associated Procedures Table.

Go to 2E

Go to 3D

Guided Step 2E - Check the engine brake harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from engine brake solenoid number 2 and the internal actuator harness.

Action

Check the resistance of the engine brake harness.

  • Use a multimeter to measure the resistance from the engine brake harness, from the engine brake solenoid number 2 SIGNAL pin of the engine brake connector to the solenoid connector pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the engine brake harness. Refer to Procedure 019-063 in the Associated Procedures Table.

Go to 2F

Go to 3D

Guided Step 2F - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 2.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid terminal pin to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid. Contact a Cummins® Authorized Engine Brake Dealer.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3D

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance of the engine brake solenoid number 2 SIGNAL wire between the ECM connector and the engine brake connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 3D

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid number 2 SIGNAL pin in the ECM connector to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 3D

Guided Step 3D - Check for a open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2
  • Turn keyswitch ON.
  • Enable Engine Brake Control feature.
  • Set engine brake minimum vehicle speed to zero.
  • Delay time set to zero.
  • Select 100 percent brake with the manual dash-switch.
  • Connect the INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure that all conditions are met for the engine brakes to operate; for example: clutch not depressed and zero percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 2 operating correctly?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 2367 (ISX) - Engine Brake Actuator Circuit 2 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | ISX CM871 | 3666239
Engine Control Module | Refer to Procedure 019-031 | ISX CM871 | 3666259
Engine Wiring Harness | Refer to Procedure 019-043 | ISX CM871 | 3666259
Engine Brake Solenoid Valve | Refer to Procedure 020-012 | ISX CM871 | 3666239

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active and/or inactive fault codes. | Fault Code 2367 active or multiple inactive counts?
STEP 2. | Check the ECM and engine brake harness pins. |
 | STEP 2A. Inspect the ECM and engine harness pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the engine brake solenoid and circuit. |
 | STEP 3A. Check the engine brake solenoid for a short to ground. | 5 ohms or greater?
 | STEP 3B. Check the engine brake solenoid for an open circuit. | Resistance between 5 and 15 ohms?
 | STEP 3C. Check for an open circuit in the ECM. | Engine brake number 2 operational?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

For ISX CM871 only: In calibrations newer than March, 2008, all engine brake fault codes (Fault Codes 2182, 2183, 2363, and 2367) have been masked. If directed here from another procedure, troubleshoot as if the fault code is active, even if there are no active engine brake fault codes.

Fault Code 2367 active or multiple inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 2B

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the internal engine brake jumper harness and pass-through connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair or replace the engine brake harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3C

Go to 2C

Guided Step 2C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake solenoid number 2 SUPPLY and RETURN wires from the engine brake solenoid.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL wire at the engine brake solenoid and the engine brake solenoid number 2 SIGNAL wire at the ECM connector.
  • Measure the resistance between the engine brake solenoid number 2 RETURN wire at the engine brake solenoid and the engine brake solenoid number 2 RETURN wire at the ECM connector.

Reference a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine brake solenoid number 2 signal or return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3C

Guided Step 2D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and ground.

Reference a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL or RETURN wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3C

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Reference a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3C

Guided Step 3 - Check the engine brake solenoid and circuit.

Guided Step 3A - Check the engine brake solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance from engine brake number 2 solenoid terminal pin to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid

Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 3B

Go to 3C

Guided Step 3B - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the engine brake harness from the engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance of engine brake number 2 solenoid SUPPLY terminal pin to RETURN terminal pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 5 ohms and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid. Refer to Procedure 020-012 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake harness from solenoid 2.
  • Turn keyswitch ON.
  • Enable Engine Brake Control feature.
  • Set engine brake minimum vehicle speed to 0.
  • Delay time set to 0.
  • Select 100 percent braking with the manual dash-switch.
  • Connect INSITE™ electronic service tool.

Action

Check for a pin-to-ground short.

  • Monitor all engine brake output circuits and engine brake switch level with INSITE™ electronic service tool.
  • Actuate the engine brakes while monitoring the engine brake output circuits, engine brake switch level, and fault codes.
  • Make sure that all conditions are met for the engine brakes to operate; for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the key must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Engine brake number 2 operational?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Refer to Procedure 019-362 in Section 19.

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2015


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake harness and solenoids. |
 | STEP 1A. Inspect the connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the engine brake harness and solenoid for an open circuit. | Between 5 and 15 ohms?
 | STEP 1C. Check the engine brake harness for an open circuit. | Less than 10 ohms?
 | STEP 1D. Check the engine brake solenoid for an open circuit. | Between 5 and 15 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Check for an open circuit. | Greater than 5.0 VDC?
 | STEP 2B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the diagnostic voltage at the ECM | Greater than 5.0 VDC?
 | STEP 2D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit in the engine harness. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2368 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine brake harness and solenoids.

Guided Step 1A - Inspect the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the engine brake connector.

Action

Inspect the engine harness and engine brake connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the engine brake harness and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid Number 3 SIGNAL pin of the engine brake connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Between 5 and 15 ohms?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine brake harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine rocker lever cover. Refer to Procedure 003&ndash;011 (Rocker Lever Cover) in Section 3 in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.
  • Disconnect the engine brake wiring harness from engine brake solenoid Number 3.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance of the engine brake harness from the engine brake solenoid Number 3 SIGNAL pin of the engine brake connector to the solenoid connector pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

Replace the engine brake harness.

Refer to Procedure 019-136 (Engine Brake Harness) in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine rocker lever cover. Refer to Procedure 003&ndash;011 (Rocker Lever Cover) in Section 3 in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.
  • Disconnect the engine brake wiring harness from the engine brake solenoid Number 3.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the engine brake solenoid terminal pin to engine block ground.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Between 5 and 15 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Refer to Procedure 020&ndash;012 (Engine Brake Solenoid Valve) in Section 20 in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Go to 3A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check the engine harness for an open circuit.

  • Use a multimeter to measure the voltage from the engine brake solenoid Number 3 SIGNAL pin in the engine brake connector of the engine harness to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the diagnostic voltage.

  • Use a multimeter to measure the voltage from the engine brake solenoid Number 3 SIGNAL pin of the ECM port to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance of the engine brake solenoid Number 3 SIGNAL wire between the ECM connector and the engine brake connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the engine brake solenoid Number 3 SIGNAL pin in the ECM connector to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

More than 100k ohms?
YES NO

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Use INSITE™ electronic service tool to reset all engine brake settings and features to their original settings.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2368 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for fault codes. | Other active or inactive fault codes?
STEP 2. | Check the pressure-side fuel filter. |
 | STEP 2A. Measure the pressure drop across the pressure fuel filter. | Is the pressure drop across the pressure fuel filter less than 517 kPa [75 psi]?
 | STEP 2B. Measure the pressure drop across the pressure fuel filter after filter change. | Is the pressure drop across the pressure fuel filter less than 517 kPa [75 psi]?
 | STEP 2C. Check the fuel shutoff valve actuator disc. | Debris or damage found on the valve disc, valve seat, or actuator disc?
STEP 3. | Check the fuel inlet restriction. |
 | STEP 3A. Measure the fuel inlet restriction. | Does the fuel inlet restriction exceed 203 mm Hg [8 in Hg] for a clean (new) filter or 305 mm Hg [12 in Hg] for a dirty (old) filter?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2372 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Other active or inactive fault codes?
YES | NO
No Repair | No Repair

Troubleshoot other fault codes

Go to 2A

Guided Step 2 - Check the pressure-side fuel filter.

Guided Step 2A - Measure the pressure drop across the pressure-side fuel filter.

Conditions

  • Turn keyswitch ON.
  • The fuel lift pump must not be running during this check. Wait 2 minutes after keyswitch ON or disconnect the two-pin power supply from the fuel lift pump.
  • Engine at high idle.
  • The fuel temperature must be a minimum of 38°C [100°F].

Action

Measure the pressure drop across the pressure-side fuel filter while the engine is operating at high idle and no load.

  • Measure the pressure out of the fuel pump, use the Compuchek™ fitting on the back of the fuel pump. This will be the high pressure reading.
  • Measure the pressure of the fuel rail, use the Compuchek™ fitting on the underside of the integrated fuel system module. This will be the low pressure reading.

Subtract the low reading from the high reading to obtain the pressure drop across the pressure-side fuel filter.

Is the pressure drop across the pressure-side fuel filter less than 517 kPa [75 psi]?
YES NO
No Repair

Replace the pressure-side fuel filter. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-015 in Section 6.

Go to 3A

Go to 2B

Guided Step 2B - Measure the pressure drop across the pressure-side fuel filter after filter replacement.

Conditions

  • Turn keyswitch ON.
  • The fuel lift pump must not be running during this check. Wait 2 minutes after keyswitch ON or disconnect the two-pin power supply from the fuel lift pump.
  • Engine at high idle.
  • The fuel temperature must be a minimum of 38°C [100°F].

Action

Measure the pressure drop across the pressure-side fuel filter while the engine is operating at high idle and no load.

  • Measure the pressure out of the fuel pump, use the Compuchek™ fitting on the back of the fuel pump. This will be the high pressure reading.
  • Measure the pressure of the fuel rail, use the Compuchek™ fitting on the underside of the integrated fuel system module. This will be the low pressure reading.

Subtract the low reading from the high reading to obtain the pressure drop across the pressure-side fuel filter.

Is the pressure drop across the pressure-side fuel filter less than 517 kPa [75 psi]?
YES NO
No Repair

Check the fuel shutoff valve components.

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel shutoff valve actuator disc.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel shutoff valve actuator disc.

  • Remove the fuel shutoff valve solenoid, valve disc, valve seat, and actuator disc. Refer to Procedure 019-050 in Section 19.
  • Inspect the housing, valve disc, valve seat, and actuator disc for dirt, debris, metal parts, bonding separation, corrosion, cracks, and wear.

Debris or damage found on the valve disc, valve seat, or actuator disc?
YES NO

Clean or replace the damaged fuel shutoff valve component. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel inlet restriction.

Guided Step 3A - Measure the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • The fuel lift pump must not be running during this check. Wait 2 minutes after keyswitch ON or disconnect the two-pin power supply from the fuel lift pump.
  • Start the engine.

Action

Measure the fuel inlet restriction.

Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction maximum:

  • Clean filter: 203 mm Hg [8 in Hg]?
  • Dirty filter: 305 mm Hg [12 in Hg]?
YES NO
No Repair

Replace the suction-side fuel filter or repair the line restriction.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to monitor the Calibration Software Phase.

For engines with phase 4 or phase 5 software:

  • Operate the engine above 1800 rpm for 15 seconds with no load.

Note: For engines with phase 4 or phase 5 software the engine must be run above 1800 rpm with no load in order for this fault code to be disabled.

  • Use INSITE™ electronic service tool to read the fault codes.

If the engine speed is limited due to maximum engine speed without VSS, use one of the following methods to clear this fault code:

  • Start the Setup for Dynamometer Test in INSITE™ electronic service tool and clear the fault code as stated above.
  • Adjust the maximum engine speed without VSS to a value above 1800 rpm and clear the fault code as stated above.
  • Run the unit in first gear with no load at wide open throttle for approximately 15 seconds.

Note: This method will not work if the load based speed control is set to values less than 1800 rpm.

For engines with phase 6 or greater software:

  • Operate the engine at idle for 10 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2373 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active and Fault Code 2373 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2373 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2373 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES NO

A defective sensor has been detected.

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 (Exhaust Gas Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A open RETURN circuit has been detected on the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2373 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2374 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active and Fault Code 2374 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2374 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2374 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES NO

A defective sensor has been detected.

Replace the exhaust gas pressure sensor.

Refer to 019-376 (Exhaust Gas Pressure Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas pressure sensor SUPPLY pin to the exhaust gas pressure sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness.

019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2374 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2375 inactive?
STEP 2. | Check the EGR temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 200 ohms to 2.4M ohms?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2375 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2376 active and Fault Code 2375 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2375 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2375 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the EGR temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

200 ohms to 2.4M ohms?
YES NO
No Repair

Replace the EGR temperature sensor.

Refer to Procedure 019-378 (EGR Temperature Sensor) in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the problem.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active and Fault Code 2375 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the ECM conductor.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor RETURN pin and the engine harness EGR temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor SIGNAL pin and the engine harness EGR temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

, Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedure need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2375 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2376 inactive?
STEP 2. | Check the EGR temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2376 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2376 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2376 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 (Inactive or Intermittent Fault Codes) in Section 19

Go to 2A

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active?
YES NO

Replace the EGR temperature sensor.

Refer to Procedure 019-378 (EGR Temperature Sensor) in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES NO
No Repair

Call for authorization to replace the ECM. Refer to Procedure Upon receipt of authorization, 019-031 (Electronic Control Module (ECM)) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the EGR temperature sensor SIGNAL in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

A pin-to-pin short on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and ground

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure For general resistance measurement techniques, 019-360 (Resistance Measurements Using a Multimeter) in Section 19 and a wiring diagram.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

Troubleshooting procedure needs to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2376 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid. | Less than 10k ohms?
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage, supply line, and return circuit. | Greater than 5.0 volts of direct current (VDC)?
 | STEP 2D. Check for an open circuit in the fan control solenoid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2377 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness.

Action

Inspect the OEM harness and fan solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check fan control solenoid resistance.

  • Measure the resistance between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open circuit in the fan control solenoid has been detected.

Replace the fan control solenoid.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the fan control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fan control solenoid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fan control solenoid RETURN pin in the engine harness and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM fan control solenoid SIGNAL pin and the OEM harness fan control solenoid connector fan control solenoid SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control solenoid SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fan control solenoid SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • For variable speed fans, the fan must be commanded off by the ECM before the diagnostic will run.

Fault Code 2377 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 2387 - Variable Geometry Turbocharger Actuator Driver Circuit (Motor) - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | Signature™, ISX, and QSX15 | 3666239
Cooling System | Refer to Procedure 008-018 | ISM, ISMe, and QSM11 | 3666322
Turbocharger | Refer to Procedure 010-033 | Signature™, ISX, and QSX15 | 3666239
Turbocharger | Refer to Procedure 010-033 | ISM, ISMe, and QSM11 | 3666322
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | Signature™, ISX, and QSX15 | 3666239
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISM, ISMe, and QSM11 | 3666322
Exhaust Restriction | Refer to Procedure 011-009 | Signature™, ISX, and QSX15 | 3666239
Exhaust Restriction | Refer to Procedure 011-009 | ISM, ISMe, and QSM11 | 3666322
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | Signature™, ISX, and QSX15 | 3666239
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISM, ISMe, and QSM11 | 3666322
Aftertreatment System | Refer to Procedure 011-050 | Signature™, ISX, and QSX15 | 3666239
Aftertreatment System | Refer to Procedure 011-050 | ISM, ISMe, and QSM11 | 3666322
Aftertreatment Testing | Refer to Procedure 014-013 | Signature™, ISX, and QSX15 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | ISM, ISMe, and QSM11 | 3666322
Engine Wiring Harness | Refer to Procedure 019-043 | Signature™, ISX, and QSX15 | 3666259
Engine Wiring Harness | Refer to Procedure 019-043 | ISM, ISMe, and QSM11 | 3666266

Cautions and Warnings

CAUTION

To prevent damage to the turbocharger actuator, be sure to drain the coolant before removing the actuator.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for previous variable geometry turbocharger (VGT) actuator removals. | Actuator recently removed or replaced?
 | STEP 1C. Check for exhaust gas recirculation (EGR)-related fault codes. | EGR system fault codes active?
 | STEP 1D. Check exhaust restriction. | Exhaust restriction greater than 41 kPa or 308 mm-Hg [6 psi or 12 in-Hg]?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger sector gear movement. | Sector gear teeth are not damaged and movement meets the requirements when using the sector gear gauge, according to Procedure 010-134 in the Associated Procedures Table?
STEP 3. | Check aftertreatment system. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system found during inspection?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2387.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
YES NO
No Repair

No troubleshooting is necessary. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for previous VGT actuator removals.

Conditions

Not applicable.

Action

Check for VGT replacements.

  • Determine if the actuator has recently been removed or replaced and Fault Code 2387 is active.

Actuator recently removed or replaced during the current repair event?
YES NO

Remove the actuator and install it in the correct position.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for EGR related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR valve, EGR temperature, and EGR differential pressure-related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for active Fault Codes 1896, 1899, 2357, 2359, 2961, and 2962.

EGR system fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 1D

Guided Step 1D - Check exhaust restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

If a port is not found in the exhaust system, remove the exhaust gas temperature 1 sensor and install the pressure gauge in the temperature sensor port.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction greater than 41 kPa or 308 mm-Hg [6 psi or 12 in-Hg]?
YES NO

Remove the diesel oxidation catalyst (DOC) from the vehicle and inspect for face plugging.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Check for a broken drive gear on the VGT actuator.

Gear broken on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the turbocharger sector gear movement.

Conditions

  • Turn keyswitch OFF.
  • Remove VGT actuator from the turbocharger.

Action

Move the sector gear lever on the turbocharger bearing housing up and down from stop-to-stop.

It may take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools.

  • Refer to Procedure 010-134 in the Associated Procedure Table.

Sector gear teeth are not damaged and movement meets the requirements when using the sector gear gauge. Refer to Procedure 010-134 in the Associated Procedure Table.
YES NO

A damaged VGT actuator has been detected.

Replace the VGT actuator unless it was already replaced in Step 2B.

Refer to Procedure 010-134 in the Associated Procedure Table.

A turbocharger mechanical malfunction has been detected.

This malfunction can possibly have been caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect the base engine components for damage.

  • Refer to Procedure 010-033 in the Associated Procedure Table.

The VGT actuator will be reused with the new or repaired turbocharger. Do not install the actuator on the malfunctioning turbocharger.

Go to 3A

Go to 3A

Guided Step 3 - Check aftertreatment system.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform the Snap Acceleration - Aftertreatment Connected Test to test for a damaged diesel particulate filter (DPF).
  • Refer to Procedure 014-013 in the Associated Procedures Table.

Action

Check for progressive damage to the aftertreatment system.

Perform the Snap Acceleration - Aftertreatment Connected Test to check for damage to the aftertreatment DPF.

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Progressive damage to the aftertreatment system found during the Snap Acceleration - Aftertreatment Connected Test?
YES NO

Replace the damaged aftertreatment system component(s).

  • Refer to Procedure 011-050 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete

Escalate or call for assistance.

Last Modified: 29-Jun-2017


FAULT CODE 2412 - Fan Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2412 inactive?
STEP 2. | Check for a malfunctioning fan speed sensor. |
 | STEP 2A. Inspect the OEM harness connector to the fan speed sensor. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the fan speed sensor. | Greater than 100k ohms?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the engine control module (ECM) and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a short to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check the fault codes. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Fault Code 2412 becomes active during engine operation?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the repair. | Fault Code 2412 inactive?
 | STEP 5B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2412 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for a malfunctioning fan speed sensor.

Guided Step 2A - Inspect the OEM harness connector to the fan speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fan speed sensor.

Action

Inspect the fan speed sensor connector, OEM harness connector, and fan speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the fan speed sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect the fan speed sensor from the OEM harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the fan speed SIGNAL (+) pin on the sensor to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The fan speed sensor is shorted to ground.

Replace the fan speed sensor.

See the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the fan speed sensor to the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan speed sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fan speed SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the fan speed sensor to the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the fan speed SIGNAL (+) pin at the OEM harness ECM connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the fan speed sensor circuit. Inspect the OEM harness for a short to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the fan speed sensor to the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance from the fan speed SIGNAL (+) pin of the OEM harness ECM connector to all other pins in the connector except the fan speed RETURN (-) pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short between pins of the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the fault codes.

Guided Step 4A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch OFF.
  • Connect the fan speed sensor to the OEM harness.
  • Connect the OEM harness to the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at idle and high idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Fault Code 2412 come active during engine operation?
YES NO

Replace the fan speed sensor.

See the OEM troubleshooting and repair manual.

An intermittent fault condition exists.

The problem can exist in the fan speed sensor circuit or with other vehicle electronic components. The problem may have been corrected when the harness connections were re-engaged.

Be certain the ECM and chassis grounds are in good condition.

Go to 5A

Refer to Procedure 019-362 in Section 19.

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2412 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting charts.

Last Modified: 16-Oct-2015


Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2448. | Active or inactive counts of Fault Code 2448?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2448.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2448?
YES NO

Add coolant to the engine.

  • Refer to Procedure For ISM engines, 008-018 (Cooling System) in Section 8 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 008-018 (Cooling System) in Section 8 in the Signature, ISX, and QSX15 Service Manual, Bulletin 3666239.

If Fault Code 2448 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor

No Repair

Repair complete.

Repair complete

Last Modified: 17-Oct-2011


FAULT CODE 2449 - VGT Actuator Controller - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2449 active?
 | STEP 1B. Check for previous VGT actuator removals. | VGT actuator has just been removed or replaced?
 | STEP 1C. Check for active fault codes. | Fault Code 1938 or 2636 active?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator hardware. | Gear is broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger sector gear movement. | Sector gear movement meets the requirements, when using the sector gear gauge, according to Procedure 010-134 in the base engine service manual?
 | STEP 2D. Check the VGT output gear for correct calibration. | VGT actuator gear moves when connected to the engine wiring harness?
 | STEP 2D-1. Check the VGT output gear for manual rotation by hand. |
 | STEP 2E. Check for active Fault Code 2449. | Fault Code 2449 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system found during the inspection?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2449.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Cycle the keyswitch several times, waiting 30 seconds between each key cycle, to see if Fault Code 2449 goes active.

Fault Code 2449 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 2449 is active. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for previous VGT actuator removals.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Determine if the actuator has just been removed or replaced and Fault Code 2449 is active.

VGT actuator has just been removed or replaced?
YES NO

Remove the actuator and install it in the correct position.

  • For ISM engines, use this procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, use this procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1938 or 2636 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator hardware.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. For ISM engines, use this procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 008-018 in Section 8.
  • For ISX engines, use this procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 008-018 in Section 8.
  • Remove the VGT actuator from the turbocharger. For ISM engines, use this procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, use this procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

Action

Check for a broken drive gear on the VGT actuator.

Gear is broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator.

  • For ISM engines, use the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, use the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger sector gear movement.

Conditions

  • Turn keyswitch OFF.
  • VGT actuator removed from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Use the sector gear gauge to check the sector gear movement range. Check for smooth movement between the stops.
  • For ISM engines, use the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, use the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

Sector gear movement meets the requirements, when using the sector gear gauge, according to Procedure 010-134 in the base engine service manual?

YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

Note: This malfunction can possibly have been caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect the base engine components for damage.

  • For ISM engines, use the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-033 in Section 10.
  • For ISX engines, use the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-145 in Section 10.

Note: The variable geometry turbocharger actuator will be reused with the new or repaired turbocharger. Do not install the actuator on the malfunctioning turbocharger.

Go to 2D

Go to 3A

Guided Step 2D - Check the VGT output gear for correct calibration.

Conditions

  • Disconnect the VGT actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

Check the VGT actuator output gear operation.

  • Connect the VGT actuator to the engine wiring harness. The VGT actuator gear should rotate.

Note: The VGT actuator output gear will exhibit one of the following movements, depending on the ECM calibration: Make sure to closely observe the VGT actuator gear when the VGT actuator is connected to the engine wiring harness.

  • The actuator output gear could possibly rotate completely in one direction and then rotate completely in the opposite direction, OR
  • The actuator output gear may only move a few degrees in one direction. This movement will be a quick snap when the VGT actuator is connected to the engine wiring harness.
  • If the VGT actuator gear does not move, disconnect the VGT actuator from the engine wiring harness for 1 second and then reconnect.
  • Repeat the above procedure three times, checking for VGT actuator gear movement each time the VGT actuator is connected to the engine wiring harness.

VGT actuator gear moves when connected to the engine wiring harness?
YES NO

Install the VGT actuator back on the turbocharger, making sure to perform the VGT actuator install and calibrate procedures.

  • For ISM engines, use the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, use the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check the VGT output gear for manual rotation by hand.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Turn the VGT actuator output gear by hand.

  • Try turning the VGT actuator output gear by hand in either direction.

Note: Do NOT use pliers or any other tool to turn the gear. ONLY rotate the gear by hand.

VGT actuator output gear rotates by hand?
YES NO

Install the VGT actuator back on the turbocharger making sure to perform theft actuator install and calibrate procedures.

  • For ISM engines, use the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, use the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

Replace the VGT actuator.

  • For ISM engines, use the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, use the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

Go to 2E

Go to 3A

Guided Step 2E - Check for active Fault Code 2449.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 2449.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2449 active?
YES NO

Replace the VGT actuator.

  • For ISM engines, use the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, use the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform the Snap Acceleration Test. For ISM engines, use the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 014-013 in Section 14.
  • For ISX engines, use the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

Action

Check for damage to the aftertreatment system.

Perform the Snap Acceleration Test to check for damage to the aftertreatment diesel particulate filter.

  • For ISM engines, use the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 014-013 in Section 14.
  • For ISX engines, use the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.Refer to Procedure 014-013 in Section 14.

Progressive damage to the aftertreatment system found during the Snap Acceleration Test?
YES NO

Replace the damaged aftertreatment system component(s).

  • For ISM engines, use the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-050 in Section 11.
  • For ISX engines, use the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-050 in Section 11.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Apr-2011


FAULT CODE 2451 - Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Codes 2634, 2449, or 2387 active?
 | STEP 1B. Check for inactive fault codes. | Fault Code 2973 inactive?
 | STEP 1C. Expand and read Fault Code 2451 snapshot data. | Is the value for the Engine Operating State set to Turbocharger Fueling Control State?
 | STEP 1D. Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in the Fault Code 2451 snapshot data. | Are the values for Turbocharger Compressor Inlet Temperature greater than 14°C or 25°F above the Ambient Air Temperature or Turbocharger Compressor Outlet Temperature (Calculated) above 227°C [440°F]?
 | STEP 1E. Check the exhaust temperature in the Fault Code 2451 snapshot data. | Is the value for Exhaust Temperature (Calculated) above 760°C [1400°F]?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the air intake system sealing surface between the air filter and the hood air plenum. | Excessive wear or ineffective sealing?
 | STEP 2B. Check the charge air cooler, clamps, hoses, and piping. | Air leaks present or clamps loose?
 | STEP 2C. Inspect the turbocharger compressor and turbine blades. | Damage found on turbocharger blades?
 | STEP 2D. Check for air leaks in the exhaust gas recirculation (EGR) system. | Air leaks found in the EGR connection tubing?
 | STEP 2E. Check for intake air temperature increase in the intake air plumbing. | Is the temperature increase between the ambient outside temperature and the turbocharger compressor inlet temperature greater than 14°C or 25°F?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2634, 2449, or 2387 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2973 inactive?
YES | NO
No Repair | No Repair

Fault Code 2973

Go to 1C

Guided Step 1C - Expand and read Fault Code 2451 snapshot data.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Expand and read Fault Code 2451 snapshot data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data.
  • Check the values for the Engine Operating State parameter.

Is the value for the Engine Operating State set to Turbocharger Fueling Control State?
YES | NO
No Repair | No Repair

Go to 1D

Go to 2A

Guided Step 1D - Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in the Fault Code 2451 snapshot data.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Expand and read Fault Code 2451 snapshot data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data.
  • Check the values for the parameters Turbocharger Compressor Inlet Temperature and Turbocharger Compressor Outlet Temperature.

Are the values for Turbocharger Compressor Inlet Temperature greater than 14°C or 25°F above the Ambient Air Temperature or Turbocharger Compressor Outlet Temperature (Calculated) above 227°C [440°F]?

YES | NO
No Repair | No Repair

Go to 2D

Go to 1E

Guided Step 1E - Check the exhaust temperature in the Fault Code 2451 snapshot data

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Expand and read Fault Code 2451 snapshot data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data
  • Check the values for the parameter: Exhaust Gas Temperature (Calculated).

Is the value for Exhaust Gas Temperature (Calculated) above 760° [1400° F]?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the air intake system sealing surface between the air filter and the hood air plenum.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake system sealing surface between the air filter and the hood air plenum.

  • Inspect the surface between the air filter and the hood air plenum.
  • Check for excessive wear, ineffective sealing, and proper fit.

Excessive wear or ineffective sealing?
YES NO

Repair sealing surface(s).

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the charge air cooler, clamps, hoses, and piping.

Conditions

  • Turn keyswitch OFF.

Action

Check the charge air cooler, hoses, and piping for leaks.

Check the clamps for correct torque.

  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-024 in Section 10.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-024 in Section 10.

Air leaks present or clamps loose?
YES NO

Repair the air leak.

  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-024 in Section 10.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-024 in Section 10.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect turbocharger compressor and turbine blades.

Conditions

  • Engine OFF.
  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-033 in Section 10.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-033 in Section 10.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check for air leaks in the EGR system.

Conditions

Action

Check for air leaks in the EGR system.

Check for air leaks in the EGR connection tubing and connections.

Soot streaks are noticeable where leaks are present.

Leaks found in the EGR connection tubing?
YES NO

Repair any leaks in the EGR system.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check for intake air temperature increase in the intake air plumbing.

Conditions

Turn keyswitch ON.

Connect INSITE™ electronic service tool.

Operate the engine.

Action

Make sure the air entering the air filter is not being drawn from under the hood.

  • The turbocharger compressor inlet temperature should not be greater than 14°C or 25°F above ambient outside temperature.
  • Check the value for the parameter turbocharger compressor inlet temperature.
  • Compare the turbocharger compressor inlet temperature with the ambient outside temperature.

Is the temperature increase between the ambient outside temperature and the turbocharger compressor inlet temperature greater than 14°C or 25°F?

YES NO

Determine the cause of the intake air temperature increase in the intake plumbing. Make sure hot air from under the hood of the vehicle is not being drawn into the air filter.

No repair. All engine causes have been eliminated.

Go to 3A

Contact the OEM to review the cooling/air handling package.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Aug-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Inspect for active or high inactive counts of Fault Code 2216. | Fault Code 2216 active?
 | STEP 1B. Check for air in the pressure-side fuel. | Air in fuel?
 | STEP 1C. Measure for drain line restriction. | Less than 229 in Hg [9.0 in Hg]?
STEP 2. | Check the rear fueling actuator performance. |
 | STEP 2A. Inspect the rear fueling actuator. | Fault Code 2552 active?
STEP 3. | Check the rear timing actuator performance. |
 | STEP 3A. Inspect the rear timing actuator. | Fault Code 2552 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 2551 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Inspect for active or high inactive counts of Fault Code 2216.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2216 active?
YES | NO
No Repair | No Repair

Fault Code 2216 troubleshooting tree

Go to 1B

Guided Step 1B - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for air in the pressure-side fuel.

  • Refer to Procedure 006-003 in Section 6 in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

Air in fuel?
YES NO

Refer to Procedure 006-003 in Section 6 in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 4A

Go to 1C

Guided Step 1C - Measure for drain line restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the drain line.

  • Measure for drain line restriction.

Refer to Procedure 006-012 in Section 6 in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

Less than 229 mm Hg [9.0 in Hg]?
YES NO
No Repair

Refer to Procedure 006-012 in Section 6 in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

Go to 2A

Go to 4A

Guided Step 2 - Check the rear fueling actuator performance.

Guided Step 2A - Inspect the rear fueling actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the front and rear fueling actuators. Inspect the actuators for damage or debris.

Refer to Procedure 019-110 in Section 19.

  • Start the engine and run above 1000 rpm for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2552 is active.

Fault Code 2552 active?
YES NO

Return the front and rear fueling actuators to their original positions.

Refer to Procedure 019-110 in Section 19.

Replace the rear fueling actuator.

Return the front and rear fueling actuators to their original positions.

Refer to Procedure 019-110 in Section 19.

Go to 4A

Go to 3A

Guided Step 3 - Check the rear timing actuator performance.

Guided Step 3A - Inspect the rear timing actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the front and rear timing actuators. Inspect the actuators for damage or debris.

Refer to Procedure 019-111 in Section 19.

  • Start the engine and run above 1000 rpm for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2552 is active.

Fault Code 2552 active?
YES NO

Return the front and rear timing actuators to their original positions.

Replace the rear timing actuator.

Refer to Procedure 019-111 in Section 19.

Return the front and rear timing actuators to their original positions.

Refer to Procedure 019-111 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and run above 1000 rpm for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2551 is inactive.

Fault Code 2551 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Inspect for active or high inactive counts of Fault Code 2216. | Fault Code 2216 active?
 | STEP 1B. Check for air in the pressure-side fuel. | Air in fuel?
 | STEP 1C. Measure for drain line restriction. | Less than 229 in Hg [9.0 in Hg]?
STEP 2. | Check the front fueling actuator performance. |
 | STEP 2A. Inspect the front fueling actuator. | Fault Code 2551 active?
STEP 3. | Check the front timing actuator performance. |
 | STEP 3A. Inspect the front timing actuator. | Fault Code 2551 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 2552 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Inspect for active or high inactive counts of Fault Code 2216.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2216 active?
YES | NO
No Repair | No Repair

Fault Code 2216 troubleshooting tree

Go to 1B

Guided Step 1B - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for air in the pressure-side fuel.

  • Refer to Procedure 006-003 in Section 6 in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

Air in fuel?
YES NO

Refer to Procedure 006-003 in Section 6 in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 4A

Go to 1C

Guided Step 1C - Measure for drain line restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the drain line.

  • Measure for drain line restriction.

Refer to Procedure 006-012 in Section 6 in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

Less than 229 mm Hg [9.0 in Hg]?
YES NO
No Repair

Refer to Procedure 006-012 in Section 6 in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

Go to 2A

Go to 4A

Guided Step 2 - Check the front fueling actuator performance.

Guided Step 2A - Inspect the front fueling actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the front and rear fueling actuators. Inspect the actuators for damage or debris.

Refer to Procedure 019-110 in Section 19.

  • Start the engine and run above 1000 rpm for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2551 is active.

Fault Code 2551 active?
YES NO

Replace the rear fueling actuator (return the front actuator to its original position). Refer to Procedure 019-110 in Section 19.

Return the front and rear fueling actuators to their original positions.

Refer to Procedure 019-110 in Section 19.

Go to 4A

Go to 3A

Guided Step 3 - Check the front timing actuator performance.

Guided Step 3A - Inspect the front timing actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the front and rear timing actuators. Inspect the actuators for damage or debris.

Refer to Procedure 019-111 in Section 19.

  • Start the engine and run above 1000 rpm for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2551 is active.

Fault Code 2551 active?
YES NO

Return the front and rear timing actuators to their original positions.

Replace the front timing actuator.

Refer to Procedure 019-111 in Section 19.

Return the front and rear timing actuators to their original positions.

Refer to Procedure 019-111 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and run above 1000 rpm for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2552 is inactive.

Fault Code 2552 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2011


FAULT CODE 2554 - Exhaust Gas Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2373 and 2374. | Fault Code 2373 or 2374 active?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2374 active?
 | STEP 3B. Check the circuit response. | Fault Code 2373 active?
STEP 4. | Check the exhaust gas pressure sensor tube. |
 | STEP 4A. Check the exhaust gas pressure sensor tube. | Plugging or damage found to the exhaust gas pressure sensor tube?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the repair. | INSITE™ electronic service tool reading for Exhaust Gas Pressure within ±102 mm-hg [±4 in-hg] of local ambient air pressure?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 2373 and 2374.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 or 2374 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure SIGNAL pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the exhaust gas pressure sensor tube.

Guided Step 4A - Check the exhaust gas pressure sensor tube.

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust gas pressure sensor tube. Use the following procedure for ISM engines: Refer to Procedure 011-027 in Section 11. This procedure is found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Use the following procedure for ISX engines: Refer to Procedure 011-027 in Section 11. This procedure is found in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

Action

Check the exhaust gas pressure sensor tube.

Inspect the inside of the tube. If clogged, use compressed air to remove debris or soot buildup.

Check the tube for cracks and thread damage. Replace the tube, if cracks or damage are found.

  • Use the following procedure for ISM engines: Refer to Procedure 011-027 in Section 11. This procedure is found in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322
  • Use the following procedure for ISX engines: Refer to Procedure 011-027 in Section 11. This procedure is found in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

Plugging or damage found to the exhaust gas pressure sensor tube?
YES NO

Clean or replace the exhaust gas pressure sensor tube.

  • Use the following procedure for ISX engines: Refer to Procedure 011-027 in Section 11. This procedure is found in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.
  • Use the following procedure for ISX engines: Refer to Procedure 011-027 in Section 11. This procedure is found in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239.

An in-range malfunction of the exhaust gas pressure sensor has been detected.

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start INSITE™ electronic service tool Data Monitor/Logger and monitor INSITE™ electronic service tool reading for exhaust gas pressure.

INSITE™ electronic service tool reading for exhaust gas pressure within ±102 mm-hg [±4 in-hg] of local ambient air pressure?
YES | NO
No Repair | No Repair

Go to 6A

Go to 1A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2015


FAULT CODE 2634 - VGT Actuator Controller - Bad Intelligent Device or Component

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check Variable Geometry Turbocharger (VGT) actuator installation. |
 | STEP 1A. Check for previous VGT actuator removals. | VGT actuator recently been removed or replaced?
 | STEP 1B. Check the VGT actuator. | VGT actuator removed from the turbocharger and the keyswitch turned ON?
 | STEP 1C. Disconnect and connect the VGT actuator connector. | Fault Code 2634 inactive after disconnecting and connecting the VGT actuator connector?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check for progressive damage |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check VGT actuator installation.

Guided Step 1A - Check for previous VGT actuator removals.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The VGT actuator has recently been removed or replaced.

  • Determine if the actuator has recently been removed or replaced and Fault Code 2634 and 2449 are active.

VGT actuator recently been removed or replaced?
YES NO

Remove the actuator and install it in the correct position.

  • For ISM engines, see the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, see the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239 to install the VGT actuator back on the turbocharger. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the VGT actuator.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for correct VGT actuator installation.

VGT actuator removed from the turbocharger and the keyswitch turned ON?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Disconnect and connect VGT actuator connector.

Action

If the VGT actuator is removed from the turbocharger and the keyswitch is turned ON with the wiring harness connected to the VGT actuator, Fault Code 2634 will be active. Follow the procedures below:

  • Turn keyswitch ON.
  • Disconnect the VGT actuator from the engine harness and connect.

Note: Fault Code 2636 will be active temporarily when the turbocharger actuator is disconnected.

  • For ISM engines, see the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, see the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, to install the VGT actuator back on the turbocharger. Refer to Procedure 010-134 in Section 10.

Fault Code 2634 inactive after disconnecting and connecting the VGT actuator connector?
YES | NO
No Repair | No Repair

Repair complete

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

A damaged VGT actuator has been detected.

Replace the VGT actuator.

  • For ISM engines, see the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For ISX engines, see the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239, to install the VGT actuator back on the turbocharger. Refer to Procedure 010-134 in Section 10.

Go to 3A

Go to 3A

Guided Step 3 - Check for progressive damage.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform aftertreatment initial check procedure to test for a damaged diesel particulate filter. Connect all components. See the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322 or the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

Action

Progressive damage to the aftertreatment system may have occurred.

  • Perform aftertreatment initial check procedure to test for a damaged diesel particulate filter.

See the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322 or the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 014-013 in Section 14.

Progressive damage to the aftertreatment system is detected?
YES NO

Replace the damaged aftertreatment component.

See the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-050 in Section 11.

Check for active aftertreatment-related fault codes and follow any active aftertreatment fault code troubleshooting trees.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Dec-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM calibration. |
 | STEP 1A. Check the ECM calibration. | Is the ECM code correct for the engine CPL?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2635 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Check the ECM calibration.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM calibration and make sure it is correct for the engine CPL.

  • Make sure the ECM code calibration voltage is correct for the application. A 24 volt calibration downloaded into a 12 volt system can cause this fault code.

Is the ECM code correct for the engine CPL?
YES NO

An incorrect VGT actuator for the voltage application has been detected.

Replace the VGT actuator.

  • For ISM engines, 010-134 (Variable Geometry Turbocharger Actuator, Electric) in Section 11 in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, 010-134 (Variable Geometry Turbocharger Actuator, Electric) in Section 11 the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Download the correct ECM code for the engine CPL.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2635 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2636 inactive?
STEP 2. | Check the VGT actuator circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the VGT actuator ground circuit. | Wiring harness eyelet is tightly connected to the engine block ground stud?
 | STEP 2C. Check the J1939 data link resistor termination resistance inside the VGT actuator. | Resistance between 110 and 130 ohms?
 | STEP 2D. Check the voltage to the VGT actuator. | Voltage is within 1-VDC of battery voltage?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the VGT actuator voltage at the ECM. |
 | STEP 3A-2. Check the battery supply voltage to the ECM. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the J1939 data link termination resistor. |
 | STEP 3B-2. Check for an open in the J1939 data link harness. |
 | STEP 3B-3. Check for a short circuit in the J1939 data link harness. |
 | STEP 3B-4. Check for a short circuit to ground in the J1939 data link harness. |
 | STEP 3B-5. Check the fault codes. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system found during the Snap Acceleration Test?
 | STEP 4B. Disable the fault code. | Fault Code 2636 inactive?
 | STEP 4C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the VGT actuator circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

If the VGT actuator harness, connector or pins can not be repaired, replace the VGT actuator.

  • For ISM, ISMe, and QSM11 engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For Signature™, ISX, and QSX15 engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the VGT actuator ground circuit.

Conditions

  • Turn keyswitch OFF.

Action

Check to make sure the engine wiring harness ground eyelet is tightly connected to the engine block ground.

Note: On ISX engines, the grounding stud is located just below the integrated fuel system module and behind the starter. On the ISM engines, the grounding stud is located between the ECM and the starter.

Wiring harness eyelet is tightly connected to the engine block ground stud?
YES NO
No Repair

A loose ground circuit has been detected at the engine block.

  • Tighten the ground connection.

Go to 2C

Go to 4A

Guided Step 2C - Check the J1939 data link resistor termination resistance inside the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Check the J1939 data link resistance.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the VGT actuator connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 110 and 130 ohms?
YES NO
No Repair

The J1939 data link termination resistor is damaged in the VGT actuator.

Replace the VGT actuator.

  • For ISM, ISMe, and QSM11 engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For Signature™, ISX, and QSX15 engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

Go to 2D

Go to 4A

Guided Step 2D - Check the voltage to the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage between the VGT actuator power SUPPLY circuit and the VGT actuator RETURN circuit at the engine harness connector.

NOTE: Check the voltage at key-on and while cranking the engine.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to Procedure 019-043 in Section 19.

Voltage is within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the VGT actuator voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage between the VGT actuator power SUPPLY circuit at the ECM connector and engine block ground.

NOTE: Check the voltage at key-ON.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Voltage is within 1-VDC of battery voltage?
YES NO

An open circuit in the VGT actuator power SUPPLY or RETURN circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-2

Guided Step 3A-2 - Check the battery supply voltage to the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the ECM.

  • Measure the voltage between the ECM power SUPPLY circuit and the ECM RETURN circuit at the OEM power harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-359 in Section 19.

Voltage is equal to battery voltage?
YES NO

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Low voltage has been detected at the ECM power connector.

Check the battery voltage and the OEM wiring between the battery and the ECM power harness connector.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the J1939 data link termination resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 data link termination resistor from the engine harness.

Action

Check the J1939 data link termination resistor resistance.

  • Measure the resistance between the SAE J1939 data link (+) and SAE J1939 data link (-) at the J1939 termination resistor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 110 and 130 ohms?
YES NO
No Repair

Replace the J1939 data link termination resistor.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an open in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the terminating resistor from the engine harness.
  • Disconnect the EGR valve from the engine harness.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the VGT actuator engine harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the VGT actuator engine harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open has been detected in the J1939 data link harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR valve from the engine harness.
  • Remove the J1939 termination resistor from the engine harness.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

NOTE: Disregard any resistance between 50 and 130 ohms between the SAE J1939 (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR valve from the engine harness.
  • Remove the J1939 termination resistor from the engine harness.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-5

Go to 4A

Guided Step 3B-5 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM connector.
  • Connect the VGT actuator to the engine harness.
  • Connect the J1939 data link termination resistor.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 active?
YES NO

Replace the VGT actuator.

  • For ISM, ISMe, and QSM11 engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-134 in Section 10.
  • For Signature™, ISX, and QSX15 engines use, the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-134 in Section 10.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform the Snap Acceleration Test. Refer to Procedure 014-013 in Section 14.

Action

Check for damage to the aftertreatment system.

  • Perform the Snap Acceleration Test to check for damage to the aftertreatment diesel particulate filter.

Refer to Procedure 014-013 in Section 14.

Progressive damage to the aftertreatment system found during the Snap Acceleration Test?
YES NO

Replace the damaged aftertreatment component.

  • Refer to Procedure 011-050 in Section 11.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2636 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4C

Go to 1A

Guided Step 4C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 06-Feb-2012


FAULT CODE 2637 - Aftertreatment 1 Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX CM871 | 3666239
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISM CM876 | 3666322
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM871 | 3666239
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISM CM876 | 3666322
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM871 | 3666239
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISM CM876 | 3666322
Exhaust System - Overview | Refer to Procedure 011-999 | ISX CM871 | 3666239
Exhaust System - Overview | Refer to Procedure 011-999 | ISM CM876 | 3666322
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM871 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | ISM CM876 | 3666322

Cautions and Warnings

WARNING

During regeneration, exhaust gas temperature can reach 800 °C [1500°F], and exhaust system surface temperature can exceed 700 °C [1300°F], which is hot enough to ignite or melt common materials, and to burn people. The exhaust and exhaust components can remain hot after the vehicle has stopped moving. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning this procedure or repair and make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active or inactive counts of other aftertreatment and air handling system fault codes. | Other fault codes found active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check Features and Parameters. |
 | STEP 2A. Check for excessive aftertreatment regeneration frequency. | Average aftertreatment regeneration frequency 8 hours or less?
 | STEP 2B. Check the original equipment manufacturer (OEM) or customer selected regeneration inhibit Features and Parameters. | Features and Parameter settings preventing or interrupting regeneration?
STEP 3. | Check the exhaust system for leaks. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil, fuel, or coolant. | Engine oil, fuel, or coolant contamination found in the turbocharger exhaust outlet?
 | STEP 3B. Check the exhaust system between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
STEP 4. | Check for excessive smoke. |
 | STEP 4A. Inspect the exhaust for excessive smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 5. | Check the aftertreatment fuel injector, if equipped. |
 | STEP 5A. Check the operation of the aftertreatment fuel injector, if equipped. | Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Injector Leak Test?
 | STEP 5B. Check the flow of the aftertreatment fuel injector, if equipped. | Aftertreatment fuel injector meets the specifications?
STEP 6. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 6A. Clean and inspect the aftertreatment DOC for cracks in the cell wall. | Any problems found during the inspection of the aftertreatment DOC?
 | STEP 6B. Perform the Aftertreatment DOC Reset procedure. | Aftertreatment Maintenance Reset procedure successfully completed?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active or inactive counts of other aftertreatment and air handling system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check for active or inactive fault codes related to the DOC or aftertreatment temperature sensors.

Other fault codes found active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check Features and Parameters.

Guided Step 2A - Check for excessive aftertreatment regeneration frequency.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to evaluate average time between aftertreatment regenerations. This can be done by determining the average time between regeneration events in the Advance ECM Data tab, under Aftertreatment History. Regeneration frequencies of 8 hours or less are considered excessive and must be investigated.

Average aftertreatment regeneration frequency 8 hours or less?
YES NO

See Aftertreatment Diesel Particulate Filter - Excessive Automatic and/or Stationary Regeneration troubleshooting symptom tree in Section TS.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the OEM or customer selected regeneration inhibit Features and Parameters.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to review the settings for automotive mobile regeneration minimum vehicle speed, and active regeneration in power take-off (PTO) and remote modes. Make sure these OEM or customer selected inhibit features are not interrupting or preventing regeneration events.

Refer to Procedure 011-999 in the Associated Procedures Table.

Features and Parameters settings preventing or interrupting regeneration?
YES NO

Adjust the Features and Parameters settings such that regenerations are not inhibited or interrupted. Always consult the OEM and customer prior to making any changes to these settings.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the exhaust system for leaks.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil, fuel, or coolant.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet for signs of oil, coolant, or fuel being introduced into the aftertreatment system from the engine.

  • Look for signs of moisture in the turbocharger exhaust outlet.

Engine oil, fuel, or coolant contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible engine oil, diesel fuel, or coolant being carried from the engine into the aftertreatment system. See equipment manufacturer service information for the malfunctioning components.

No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check the exhaust system between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the exhaust system between the turbocharger and aftertreatment system.

  • Check for loose or leaking connections and damaged exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged or leaking exhaust system components.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check for excessive smoke.

Guided Step 4A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate engine.

Action

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds. Refer to Procedure 014-013 in the Associated Procedures Table.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.
  • To perform a Snap Acceleration Test, it could be necessary to temporarily adjust the Maximum Engine Speed with No Vehicle Speed Sensor Parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke. See the Smoke, Black - Excessive troubleshooting section in the Engine Performance Troubleshooting tree in Section TT.

No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the aftertreatment fuel injector, if equipped.

Guided Step 5A - Check the operation of the aftertreatment fuel injector, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Skip to Guided Step 6A if the engine is not equipped with an aftertreatment fuel injector.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Fuel Injector Leak Test.

  • Check for fuel leaking from the aftertreatment injector when the aftertreatment fuel shutoff valve is open.

Refer to Procedure 011-054 in the Associated Procedures Table.

Fuel leaking from the aftertreatment fuel injector during the Aftertreatment Fuel Injector Leak Test?
YES NO

Replace the aftertreatment fuel injector. Refer to Procedure 011-042 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the flow of the aftertreatment fuel injector, if equipped.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.
  • Skip to Guided Step 6A if the engine is not equipped with an aftertreatment fuel injector.

Action

Refer to Procedure 011-054 in the Associated Procedures Table.

Aftertreatment fuel injector meets the specifications?
YES NO
No Repair

Clean the aftertreatment injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 6A

Go to 7A

Guided Step 6 - Inspect the aftertreatment DOC.

Guided Step 6A - Clean and inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Remove the aftertreatment DOC.
  • Clean the DOC and inspect for reuse. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC.

  • Inspect the inlet face of the aftertreatment DOC for reuse.
  • Check for cracks in the aftertreatment DOC cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Any problems found during the inspection of the aftertreatment DOC?
YES NO

Repair or replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6B

Guided Step 6B - Perform the aftertreatment DOC Reset procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset procedure under the Advanced ECM Data menu. Select the DOC Reset option.

Aftertreatment Maintenance Reset procedure successfully completed?
YES | NO
No Repair | No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2016


FAULT CODE 2638 - Catalyst Efficiency - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX CM871 | 3666239
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISM CM876 | 3666322
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM871 | 3666239
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISM CM876 | 3666322
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM871 | 3666239
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISM CM876 | 3666322
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM871 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | ISM CM876 | 3666322

Cautions and Warnings

WARNING

During regeneration, exhaust gas temperature can reach 800°C [1500°F], and the exhaust system surface temperature can exceed 700°C [1300°F], which is hot enough to ignite or melt common materials, and to burn people. The exhaust and exhaust components can remain hot after the vehicle has stopped moving. To avoid the risk of fire, property damage, burns or other serious personal injury allow the exhaust system to cool before beginning this procedure or repair and make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Any fault codes other than Fault Code 1691, 1921, 2637, 2638, 2639, or 2728 active?
STEP 2. | Perform the Aftertreatment Maintenance Reset All procedure. |
 | STEP 2A. Perform the Aftertreatment Maintenance Reset All procedure. | Aftertreatment Maintenance Reset All procedure completed?
 | STEP 2B. Perform the aftertreatment system test. | Does the aftertreatment fuel injector meet the specifications?
 | STEP 2C. Check the flow of the aftertreatment fuel injector. | Does the aftertreatment fuel injector meet the specifications?
 | STEP 2D. Clean the aftertreatment diesel oxidation catalyst. | Was the aftertreatment diesel oxidation catalyst cleaned?
STEP 3. | Perform the stationary regeneration procedure. |
 | STEP 3A. Perform the stationary regeneration procedure. | Stationary regeneration started?
 | STEP 3B. Check for exhaust leaks while performing the stationary regeneration procedure. | Exhaust system leaks found?
 | STEP 3C. Perform the stationary regeneration procedure. | Fault Code 2638 inactive after running the stationary regeneration procedure?
STEP 4. | Check the engine control module (ECM) calibration. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Aftertreatment-related fault codes inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any fault codes other than Fault Code 1691, 1921, 2637, 2638, 2639, or 2728 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Perform the Aftertreatment Maintenance Reset All procedure.

Guided Step 2A - Perform the Aftertreatment Maintenance Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu.

Go to 2B

Go to 2B

Guided Step 2B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and allow it to idle.

Action

Perform the aftertreatment system test.

Refer to Procedure 011-054 in the Associated Procedures Table.

It is only necessary to perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Clean the aftertreatment injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 2C

Guided Step 2C - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and allow it to idle.

Action

Perform the aftertreatment system test.

Refer to Procedure 011-054 in the Associated Procedures Table.

It is only necessary to perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Check the part number of the aftertreatment fuel injector.

The part number can be found by looking at the body of the injector with the heat shield removed.

If Part Number 3683570 is found, replace the aftertreatment fuel injector.

If the part number is anything else, follow these steps:

  • If the average amount collected is above the specified flow values, verify that the Reset All Function was completed and flow the doser again.
  • If the average amount collected is below the specification, replace the aftertreatment fuel injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 2D

Go to 2D

Guided Step 2D - Clean the aftertreatment diesel oxidation catalyst.

Conditions

  • Aftertreatment diesel oxidation catalyst removed.

Action

Clean the aftertreatment diesel oxidation catalyst and inspect for reuse.

Refer to Procedure 011-049 in the Associated Procedures Table.

Reference the Aftertreatment Diesel Oxidation Catalyst and Aftertreatment Diesel Particulate Filter Reuse Guidelines, Bulletin 4021600.

Was the aftertreatment diesel oxidation catalyst cleaned and did it meet reuse guidelines?
YES NO
No Repair

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Perform the stationary regeneration procedure.

Guided Step 3A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and allow it to idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Refer to Procedure 014-013 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM Diagnostics Tests.

Stationary regeneration started?
YES NO
No Repair

Reference the Stationary Regeneration - Will Not Activate or the Stationary Regeneration - Will Not Complete troubleshooting symptom trees in Section TS in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 3B

Go to 3B

Guided Step 3B - Check for exhaust leaks while performing the stationary regeneration procedure.

Conditions

  • Stationary regeneration procedure running.

Action

Check the exhaust system for leaks while performing the stationary regeneration procedure.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for leaking connections and damaged/leaking exhaust system components.

Exhaust system leaks found?
YES NO

Stop regeneration and allow the system to cool. Repair or replace the damaged exhaust system component(s).

 No Repair

Go to 3C

Go to 3C

Guided Step 3C - Perform the stationary regeneration procedure.

Conditions

  • Stationary regeneration procedure running.

Action

Check for active Fault Code 2638.

Fault Code 2638 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Reference the TS Section, t146, Stationary Regeneration - Will Not Activate or t149, Stationary Regeneration - Will Not Complete, in Section TS in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4A

Go to 1A

Guided Step 4 - Check the engine control module (ECM) calibration.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify all aftertreatment-related fault codes are inactive.

Aftertreatment-related fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 22-Jan-2013


Fault Code 2639 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes other than 2639 active?
STEP 2. | Perform stationary regeneration procedure. |
 | STEP 2A. Perform stationary regeneration procedure. | Fault Code 2639 is active after the stationary regeneration has been completed?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2639 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes other than 2639 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Perform the stationary regeneration procedure.

Guided Step 2A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and allow it to idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Refer to Procedure 014-013 (Aftertreatment Testing) in Section 14 in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature, ISX and QSX15 Service Manual, Bulletin 3666239 for stationary regeneration information.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Test found in the ECM Diagnostics Tests.

If active fault codes occur during the regeneration test, abort the test and troubleshoot the active fault code.

Fault Code 2639 active after the stationary regeneration has been completed?
YES NO

Perform the stationary regeneration procedure. Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM Diagnostics Test.

Check for active fault codes that may have come active during the regeneration event. Troubleshoot any active fault codes.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2639 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 17-Aug-2011


FAULT CODE 2646 - Engine Coolant Temperature - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2646 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2646 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2646 active?
YES NO

The EGR valve was closed to reduce engine coolant temperature.

No repair is necessary.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2646 is inactive.

Fault Code 2646 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 27-Sep-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2659 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2659 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2659 active?
YES NO

The EGR valve was closed to reduce engine coolant temperature.

No repair is necessary.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 2659 is inactive.

Fault Code 2659 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2010


Aftertreatment Fuel Injector 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX CM871 | 3666239
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISM CM876 | 3666322
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM871 | 3666239
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISM CM876 | 3666322
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM871 | 3666239
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISM CM876 | 3666322
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM871 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | ISM CM876 | 3666322

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active Fault Code 2728. | Fault Code 2728 active?
 | STEP 1B. Check for active fault codes. | Fault codes other than 2728, 2639, or 1921 active?
STEP 2. | Check the aftertreatment fuel injector. |
 | STEP 2A. Perform the Aftertreatment Reset All procedure. | Aftertreatment Reset All procedure completed?
 | STEP 2B. Check the flow of the aftertreatment fuel injector. | Does the aftertreatment fuel injector meet the specifications?
 | STEP 2C. Check the flow of the aftertreatment fuel injector. | Does the aftertreatment fuel injector meet the specifications?
STEP 3. | Perform a stationary regeneration procedure. |
 | STEP 3A. Start a stationary regeneration procedure. | Stationary regeneration started?
 | STEP 3B. Check for exhaust leaks while performing the stationary regeneration procedure. | Exhaust system leaks found?
 | STEP 3C. Perform the stationary regeneration procedure. | Fault Code 2728 inactive after running the stationary regeneration procedure?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2728 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active Fault Code 2728.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2728 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes other than 2728, 2639, or 1921 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel injector.

Guided Step 2A - Perform the Aftertreatment Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

Note: Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu.

Go to 2B

Go to 2B

Guided Step 2B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment system test.

Use the following procedure for aftertreatment system test information and the pass/fail criteria of the aftertreatment fuel injector. Refer to Procedure 011-054 in the Associated Procedures Table.

Note:Only perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Clean the aftertreatment injector.

Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 2C

Guided Step 2C - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment system test.

Use the following procedure for aftertreatment system test information and the pass/fail criteria of the aftertreatment fuel injector. Refer to Procedure 011-054 in the Associated Procedures Table.

Note: Only perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Check the part number of the aftertreatment fuel injector.

Note: The part number can be found by looking at the body of the injector with the heat shield removed

If Part Number is 3683570 is found, replace the aftertreatment fuel injector.

If the part number is anything else, follow these steps:

  • If the average amount collected is above the specified flow values, verify the Reset All Function was completed and flow the doser again.
  • If the average amount collected is below the specification, make sure a brass brush was used to clean the tip and repeat the cleaning.

Note: A thorough 1 minute cleaning using the appropriate tools returns a low flowing doser to within the specified flow values.

Go to 3A

Go to 3A

Guided Step 3 - Perform a stationary regeneration procedure.

Guided Step 3A - Start a stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

Refer to Procedure 014-013 in the Associated Procedures Table.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Test found under ECM Diagnostics Tests.

Stationary regeneration started?
YES NO
No Repair

Appropriate troubleshooting steps.

Go to 3B

Go to 3B

Guided Step 3B - Check for exhaust leaks while performing the stationary regeneration procedure.

Conditions

  • Stationary regeneration procedure running.

Action

Check the exhaust for leaks while the stationary regeneration procedure is running.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for leaking connections and damaged/leaking exhaust system components.

Note: The exhaust system will be very hot during this procedure. Be careful not to touch the exhaust system components while performing this check.

Exhaust system leaks found?
YES NO

Stop regeneration and allow the system to cool. Repair or replace the damaged exhaust system component(s).

 No Repair

Go to 3A

Go to 3C

Guided Step 3C - Perform the stationary regeneration procedure.

Conditions

  • Stationary regeneration procedure running.

Action

Check for active Fault Code 2728.

Note: It is not necessary to completely run the stationary regeneration procedure. The test can be stopped as soon as Fault Code 2728 becomes inactive.

Fault Code 2728 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Perform the stationary regeneration procedure again.

Go to 4A

Go to 3A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2728 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Aug-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2732 inactive?
STEP 2. | Check the aftertreatment fuel drain valve and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel drain valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment fuel drain valve. | 5.0 to 7.0 ohms?
 | STEP 2C. Check the fuel drain valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
 | STEP 2D. Check for an open circuit in the aftertreatment fuel drain valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the fuel drain valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2732 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2732 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2732 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment fuel drain valve and circuit.

Guided Step 2A - Inspect the aftertreatment fuel drain valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel drain valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check the aftertreatment fuel drain valve resistance.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY pin and the aftertreatment fuel drain valve RETURN pin at the aftertreatment fuel drain valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5.0 to 7.0 ohms?
YES NO
No Repair

Replace the aftertreatment fuel drain valve.

Refer to Procedure 011-052 in Section 11.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel drain valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the diagnostic voltage and return circuit.

  • Measure the voltage between the aftertreatment fuel drain valve SUPPLY pin and the aftertreatment fuel drain valve RETURN pin at the aftertreatment fuel drain valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the aftertreatment fuel drain valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment fuel drain valve RETURN pin at the aftertreatment fuel drain valve connector of the engine harness and the metal case of the aftertreatment fuel drain valve.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness return circuit.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the fuel drain valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the diagnostic supply voltage.

  • Measure the voltage from the aftertreatment fuel drain valve SUPPLY pin and the aftertreatment fuel drain valve RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, use the following procedure to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY pin at the engine harness ECM connector and the aftertreatment fuel drain valve connector SUPPLY pin at the aftertreatment fuel drain valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the engine harness ECM connector aftertreatment fuel drain valve SUPPLY pin and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2732 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Call for authorization to replace the ECM. Upon receipt of authorization use the following procedure to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2732 is inactive.

Fault Code 2732 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2733 inactive?
STEP 2. | Check the aftertreatment fuel drain valve and circuit. |
 | STEP 2A. Inspect the aftertreatment fuel drain valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the aftertreatment fuel drain valve. | 5.0 to 7.0 ohms?
 | STEP 2B-1. Check for a short circuit to ground in the aftertreatment fuel drain valve. |
 | STEP 2C. Check the fuel drain valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the fuel drain valve diagnostic supply voltage and signal circuit. | 4.75 to 6.75-VDC?
 | STEP 3C. Check for a pin-to-pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2733 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2733 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2733 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the aftertreatment fuel drain valve and circuit.

Guided Step 2A - Inspect the aftertreatment fuel drain valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel drain valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check the aftertreatment fuel drain valve resistance.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY pin and the aftertreatment fuel drain valve RETURN pin at the sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5.0 to 7.0 ohms?
YES NO
No Repair

Replace the aftertreatment fuel drain valve.

Refer to Procedure 011-052 in Section 11.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short circuit to ground in the aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check the aftertreatment fuel drain valve resistance.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY and the metal case of the aftertreatment fuel drain valve.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the aftertreatment fuel drain valve.

Refer to Procedure 011-052 in Section 11.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel drain valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the diagnostic voltage and return circuit.

  • Measure the voltage between the aftertreatment fuel drain valve SUPPLY pin and the aftertreatment fuel drain valve RETURN pin at the aftertreatment fuel drain valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the fuel drain valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the diagnostic supply voltage.

  • Measure the voltage from the aftertreatment fuel drain valve SUPPLY pin and ground at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 6.75-VDC?
YES NO
No Repair

Call for authorization to replace the ECM. Upon receipt of authorization, use the following procedure to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY pin at the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the aftertreatment fuel drain valve SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the aftertreatment fuel drain valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment fuel drain valve SUPPLY pin at the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2733 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Call for authorization to replace the ECM. Upon receipt of authorization, use the following procedure to replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2733 is inactive.

Fault Code 2733 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jul-2010


FAULT CODE 2738 - Engine Start Enable Device 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2738 inactive?
STEP 2. | Check the ether injection solenoid and circuit. |
 | STEP 2A. Inspect the ether injection solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the ether injection solenoid. | Less than 10k ohms?
 | STEP 2C. Check the ether injection solenoid diagnostic supply voltage, supply line, and return circuit. | Greater than 5.0 volts of direct current (VDC)?
 | STEP 2D. Check for an open circuit in the ether injection solenoid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in ether injection signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2738 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2738 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2738 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ether injection solenoid and circuit.

Guided Step 2A - Inspect the ether injection solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness.

Action

Inspect the OEM harness and ether injection solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the ether injection solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check ether injection solenoid resistance.

  • Measure the resistance between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin at the ether injection solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open circuit in the ether injection solenoid has been detected.

Replace the ether injection solenoid.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the ether injection solenoid diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the ether injection solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the ether injection solenoid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ether injection solenoid RETURN pin in the engine harness and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the failed connection.

Clean, repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ether injection signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM ether injection solenoid SIGNAL pin and the OEM harness ether injection solenoid connector ether injection solenoid SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open ether injection solenoid SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the ether injection solenoid SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2738 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2738 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


FAULT CODE 2739 - Engine Start Enable Device 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2739 active?
STEP 2. | Check the ether injection solenoid and circuit. |
 | STEP 2A. Inspect the ether injection solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the ether injection solenoid. | Greater than 3 ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the ether injection solenoid. |
 | STEP 2C. Check the ether injection solenoid diagnostic supply voltage and supply line. | Greater than 5 volts of direct current (VDC)?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2739 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2739 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2739 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ether injection solenoid and circuit.

Guided Step 2A - Inspect the ether injection solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the ether injection solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for low internal resistance of the ether injection solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the ether injection solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3 ohms?
YES NO
No Repair

Replace the ether injection solenoid.

See the OEM troubleshooting and repair manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the ether injection solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the ether injection SIGNAL connector pin and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the ether injection solenoid.

See the OEM troubleshooting and repair manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the ether injection solenoid diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and supply line.

  • Measure the voltage between the ether injection SIGNAL pin and the ether injection RETURN pin at the OEM harness actuator connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the ether injection SIGNAL pin of the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ether injection solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the ether injection SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2739 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2739 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2741 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2741 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active Fault Code 2741.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2741 active?
YES NO

The engine harness connectors on the aftertreatment fuel shutoff valve 1 and aftertreatment fuel drain valve are swapped. Reverse the wiring harness connectors on the aftertreatment fuel shutoff valves.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2741 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes. | Fault code related to the VGT or EGR valve operation are active?
 | STEP 1B. Check the aftertreatment temperature sensor readings. | Are the values of aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature within 25°C[45°F] degrees of each other?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust system between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
 | STEP 2B. Check for excessive exhaust temperature loss between the turbocharger and aftertreatment system. | Correct OEM downpipe is being used and is properly insulated?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil, coolant, or fuel. | Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Perform a stationary regeneration. |
 | STEP 4A. Perform a stationary regeneration procedure. | Fault Code 2742 inactive after running the stationary regeneration procedure?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 2742 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the VGT and EGR valve operation.

Fault code related to the VGT or EGR valve operation are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the aftertreatment temperature sensor readings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine for 10 minutes.

Action

Check the aftertreatment temperature sensor readings.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • Use INSITE™ electronic service tool to monitor the values of aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature.

Are the values of aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature within 25°C[45°F] degrees of each other?

YES NO
No Repair

The aftertreatment diesel oxidation catalyst inlet temperature sensor or aftertreatment diesel particulate filter inlet temperature sensor is not reading properly. Compare all three aftertreatment temperature sensors to determine which sensor is reading incorrectly.

Replace the damaged aftertreatment temperature sensor.

Refer to Procedure 019-449 (Aftertreatment Gas Temperature Sensor) in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust system between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust for leaks.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for excessive exhaust temperature loss between the turbocharger and aftertreatment system.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the exhaust system between the turbocharger outlet and the aftertreatment system inlet.

  • Check the downpipe for insulation that can possibly be missing.
  • Check for incorrect downpipes that can possibly allow for increased temperature loss between the turbocharger and aftertreatment system.
  • The correct OEM downpipe must be used to prevent temperature loss in the exhaust system.

Correct OEM downpipe is being used and is properly insulated?
YES NO
No Repair

Install the correct OEM downpipe between the turbocharger outlet and the aftertreatment inlet to prevent temperature loss in the exhaust system.

Go to 3A

Go to 5A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil, coolant, or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil, coolant, or fuel being introduced into the aftertreatment system from the engine.
  • Look for signs of moisture in the turbocharger exhaust outlet.

Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Replace the damaged component.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Perform a stationary regeneration.

Guided Step 4A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Refer to Procedure 014-013 (Aftertreatment Testing) in Section 14 in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature, ISX and QSX15 Service Manual, Bulletin 3666239 for stationary regeneration information.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM Diagnostics Tests.

Note: It is not necessary to completely run the stationary regeneration procedure. The test can be stopped as soon as Fault Code 2742 goes inactive.

Fault Code 2742 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Perform the stationary regeneration procedure again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2742 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes. | Fault code related to the VGT or EGR valve operation are active?
 | STEP 1B. Check the aftertreatment temperature sensor readings. | Are the values of aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature within 25°C [45°F] degrees of each other?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust system between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
 | STEP 2B. Check for excessive exhaust temperature loss between the turbocharger and aftertreatment system. | Correct OEM downpipe is being used and is properly insulated?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil, coolant, or fuel. | Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Perform a stationary regeneration. |
 | STEP 4A. Perform a stationary regeneration procedure. | Fault Code 2743 inactive after running the stationary regeneration procedure?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 2743 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the VGT and EGR valve operation.

Fault codes related to the VGT or EGR valve operation are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the aftertreatment temperature sensor readings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine for 10 minutes.

Action

Check the aftertreatment temperature sensor readings.

  • Idle the engine for 10 minutes to stabilize the exhaust temperature in the aftertreatment system.
  • Use INSITE™ electronic service tool to monitor the values of aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature.

Are the values of aftertreatment diesel oxidation catalyst inlet temperature and aftertreatment diesel particulate filter inlet temperature within 25°C [45°F] degrees of each other?

YES NO
No Repair

The aftertreatment diesel oxidation catalyst inlet temperature sensor or aftertreatment diesel particulate filter inlet temperature sensor is not reading properly. Compare all three aftertreatment temperature sensors to determine which sensor is reading incorrectly.

Replace the damaged aftertreatment temperature sensor. Refer to Procedure 019-449 (Aftertreatment Gas Temperature Sensor) in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust system between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for leaks.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for excessive exhaust temperature loss between the turbocharger and aftertreatment system.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the exhaust system between the turbocharger outlet and the aftertreatment system inlet.

  • Check the downpipe for insulation that can possibly be missing.
  • Check for incorrect downpipes that can possibly allow for increased temperature loss between the turbocharger and aftertreatment system.
  • The correct OEM downpipe must be used to prevent temperature loss in the exhaust system.

Correct OEM downpipe is being used and is properly insulated?
YES NO
No Repair

Install the correct OEM downpipe between the turbocharger outlet and the aftertreatment inlet to prevent temperature loss in the exhaust system.

Go to 3A

Go to 5A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil, coolant, or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil, coolant, or fuel being introduced into the aftertreatment system from the engine.
  • Look for signs of moisture in the turbocharger exhaust outlet.

Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Replace the damaged component.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Perform a stationary regeneration.

Guided Step 4A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Refer to Procedure 014-013 (Aftertreatment Testing) in Section 14 in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature, ISX and QSX15 Service Manual, Bulletin 3666239 for stationary regeneration information.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM Diagnostics Tests.

Note: It is not necessary to completely run the stationary regeneration procedure. The test can be stopped as soon as Fault Code 2743 goes inactive.

Fault Code 2743 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Perform the stationary regeneration procedure again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2743 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for VGT and EGR related fault codes. | Fault codes related to the VGT or EGR valve operation active?
 | STEP 1B. Check for intake manifold pressure sensor or EGR differential pressure sensor related fault codes. | Fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor are active?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge air system for leaks. | Air leaks present in the charge air cooler, charge air cooler hoses, or the air intake connection?
 | STEP 2B. Check for a restricted charge air cooler. | Charge air cooler restriction within specifications?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Verify the sensor accuracy. | INSITE™ electronic service tool reading is within 17 kPa [2.5 psi] of mechanical gauge reading?
STEP 4. | Check the barometric pressure sensor. |
 | STEP 4A. Verify the sensor accuracy. | INSITE™ electronic service tool reading is within 102 mm Hg [4 in Hg] of local barometric pressure?
STEP 5. | Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging. |
 | STEP 5A. Check the EGR differential pressure tubes for leaks. | Leaks detected at either the low or high EGR differential pressure tubes?
 | STEP 5B. Check the EGR differential pressure tubes for plugging. | Debris or soot found in either EGR differential pressure tube?
 | STEP 5C. Check the EGR differential pressure sensor adapter for leaks. | Leaks detected at the EGR differential pressure sensor adapter?
STEP 6. | Check the fuel system. |
 | STEP 6A. Check for an injector misfire. | Engine misfire is detected?
STEP 7. | Clear the fault code. |
 | STEP 7A. Disable the fault code. | Fault Code 2754 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the VGT and EGR related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the VGT and EGR valve operation.

Fault codes related to the VGT or EGR valve operation active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for intake manifold pressure sensor or EGR differential pressure sensor related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor.

Fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge air system for leaks.

Conditions

  • Engine is idling.

Action

Inspect the charge air cooler and connections for air leaks.

  • Inspect the charge air cooler connection hoses and clamps. Make sure the clamps are tight and that the hoses are not ruptured.
  • Inspect the air intake connections for air leaks.

Air leaks present in the charge air cooler, charge air cooler hoses, or the air intake connection?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check for a restricted charge air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running.

Action

Check the pressure differential across the charge air cooler.

  • Refer to Procedure For ISM engines , 010-027 (Charge-Air-Cooler) in Section 10 of the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 010-027 (Charge-Air-Cooler) in Section 10 of the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Charge air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge air cooler, if necessary.

Go to 3A

Go to 7A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor.

  • Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.
  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for Intake Manifold Pressure to the mechanical gauge.

INSITE™ electronic service tool reading is within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159 (Intake Manifold Pressure/Temperature Sensor) in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the barometric pressure sensor.

Guided Step 4A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor.

  • Refer to Procedure Start INSITE&trade; electronic service tool Data Monitor/Logger and compare INSITE&trade; electronic service tool reading for Barometric Pressure to the barometric pressure table in Procedure 018-028 (Barometric Pressure at Altitude) in Section V.

INSITE™ electronic service tool reading is within 102 mm Hg [4 in Hg] of local barometric pressure?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 (Barometric Air Pressure Sensor) in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging.

Guided Step 5A - Check the EGR differential pressure tubes for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the lines for leaks.

  • Leaks can be easily noted by traces of soot.

Leaks detected at either the low or high EGR differential pressure tubes?
YES NO

Tighten the fittings, or replace the EGR differential pressure tube.

  • Refer to Procedure For ISM engines, 011-026 (EGR Differential Pressure Sensor Tubes) in Section 11 of the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-026 (EGR Differential Pressure Sensor Tubes) in Section 11 of the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the EGR differential pressure tubes for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure tubes.
  • Refer to Procedure For ISM engines, 011-026 (EGR Differential Pressure Sensor Tubes) in Section 11 of the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-026 (EGR Differential Pressure Sensor Tubes) in Section 11 of the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Action

Inspect the EGR differential pressure tubes for restrictions and soot or other plugging.

  • Refer to Procedure For ISM engines, 011-026 (EGR Differential Pressure Sensor Tubes) in Section 11 of the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-026 (EGR Differential Pressure Sensor Tubes) in Section 11 of the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Debris or soot found in either EGR differential pressure tube?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • Refer to Procedure For ISM engines, 011-026 (EGR Differential Pressure Sensor Tubes) in Section 11 of the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-026 (EGR Differential Pressure Sensor Tubes) in Section 11 of the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 7A

Go to 5C

Guided Step 5C - Check the EGR differential pressure sensor adapter for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor adapter for leaks.

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the adapter for proper sealing.

  • Refer to Procedure For ISM engines, 011-028 (EGR Differential Pressure Sensor Adapter) in Section 11 of the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-028 (EGR Differential Pressure Sensor Adapter) in Section 11 of the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Leaks detected at the EGR differential pressure sensor adapter?
YES NO

Replace the EGR differential pressure sensor adapter.

  • Refer to Procedure For ISM engines, 011-028 (EGR Differential Pressure Sensor Adapter) in Section 11 of the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 011-028 (EGR Differential Pressure Sensor Adapter) in Section 11 of the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the fuel system.

Guided Step 6A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor Cylinder Performance Test results.

  • Determine if a cylinder misfire is noticed when the engine is running at low idle.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector if necessary.

  • Refer to Procedure For ISM engines, 006-026 (Injector) in Section 6 of the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • Refer to Procedure For ISX engines, 006-026 (Injector) in Section 6 of the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault code.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2754 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Exhaust Gas Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for variable geometry turbocharger (VGT) and exhaust gas recirculation (EGR) related fault codes. | Fault codes related to VGT or EGR valve operation are active?
 | STEP 1B. Check exhaust restriction. | Is exhaust restriction greater than 41 kPa [6 psi]
 | STEP 1C. Check for intake manifold pressure sensor or EGR differential pressure sensor related fault codes. | Fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor are active?
 | STEP 1D. Check the Exhaust Gas Pressure, Intake Manifold Pressure, EGR Valve Position, and EGR Differential Pressure values in the Fault Code 2764 snapshot data. | Are ALL of the following true?: Are the values for EGR Valve Position greater than 50 percent, EGR Differential Pressure less than 102 mm-Hg [4 in-Hg], and the difference between the Exhaust Gas Pressure and Intake Manifold Pressure (Exhaust Gas Pressure - Intake Manifold Pressure) greater than 1016 mm-Hg [40 in-Hg]?
STEP 2. | Check the exhaust gas pressure sensor. |
 | STEP 2A. Verify the sensor accuracy. | INSITE™ electronic service tool reading for Exhaust Gas Pressure within ± 25.4 mm Hg [± 1 in Hg] of local ambient air pressure?
STEP 3. | Perform the stationary regeneration procedure. |
 | STEP 3A. Check the aftertreatment diesel particulate filter operation. | Fault codes become active during the stationary regeneration?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2764 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for VGT and EGR related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the VGT and EGR valve operation.

Fault codes related to the VGT or EGR valve operation are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 1B

Guided Step 1B - Check exhaust restriction.

Conditions

  • Install a pressure gauge into the exhaust system.
  • Turn keyswitch ON.
  • Run engine at rated horsepower and rpm.

Action

Check exhaust restriction by installing a pressure gauge into the exhaust system just past the turbocharger outlet.

  • If a port is not found in the exhaust system, remove the exhaust gas temperature 1 sensor and install the pressure gauge in the temperature sensor port.
  • Refer to Procedure 011-009 in Section 11.

Is exhaust restriction greater than 41 kPa [6 psi]
YES NO

Remove the diesel oxidation catalyst from the vehicle and inspect for face plugging.

Refer to Procedure 011-049 in Section 11.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for intake manifold pressure sensor or EGR differential pressure sensor related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor.

Fault codes related to the intake manifold pressure sensor or EGR differential pressure sensor are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting procedure

Go to 1D

Guided Step 1D - Check the Exhaust Gas Pressure, Intake Manifold Pressure, EGR Valve Position, and EGR Differential Pressure values in the Fault Code 2764 snapshot data.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Expand and read the Fault Code 2764 snapshot data.

  • Use INSITE™ electronic service tool to read the snapshot data.
  • Check the values for these parameters: Exhaust Gas Pressure, Intake Manifold Pressure, EGR Valve Position, and EGR Differential Pressure.

Are ALL of the following true?:

Are the values for EGR Valve Position greater than 50 percent, EGR Differential Pressure less than 102 mm-Hg [4 in-Hg], and the difference between the Exhaust Gas Pressure and Intake Manifold Pressure (Exhaust Gas Pressure - Intake Manifold Pressure) greater than 1016 mm-Hg [40 in-Hg]?

YES NO

Remove the EGR Cooler and inspect for plugging.

Clean the EGR Cooler if possible.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-019 in Section 11.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-019 in Section 11.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor.

Guided Step 2A - Verify the sensor accuracy.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the repair.

  • Start INSITE™ electronic service tool Data Monitor/Logger and monitor INSITE™ electronic service tool reading for exhaust gas pressure.
  • Check local ambient air pressure.

INSITE™ electronic service tool reading for Exhaust Gas Pressure within ± 25.4 mm Hg [± 1 in Hg] of local ambient air pressure?
YES NO
No Repair

An in-range malfunction of the exhaust gas pressure sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Perform the stationary regeneration procedure.

Guided Step 3A - Check the aftertreatment diesel particulate filter operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Refer to Procedure 014-013 in Section 14.
  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Test found under ECM Diagnostic Tests.

Fault codes become active during the stationary regeneration?
YES NO
No Repair

Refer to Procedure 014-013 in Section 14.

Appropriate fault code troubleshooting procedure

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2764 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 17-Jan-2011


FAULT CODE 2774 - Engine Exhaust Gas Recirculation (EGR) System - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active EGR valve fault codes. | Fault Code 1895, 1896, or 2357 active?
 | STEP 1B. Check for inactive EGR differential pressure sensor fault codes. | Fault Code 1866, 2273, or 2274 inactive?
STEP 2. | Check the EGR differential pressure tubes and mounting surfaces for leaks for debris plugging. |
 | STEP 2A. Check the EGR differential pressure tubes for leaks. | Leaks detected at either the low or high EGR differential pressure tubes?
 | STEP 2B. Check the EGR differential pressure tubes for plugging. | Debris or soot found in either EGR differential pressure tube?
 | STEP 2C. Check EGR venturi. | Carbon buildup detected in the EGR venturi tube or EGR differential pressure tube ports?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2774 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1895, 1896, or 2357 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for inactive EGR differential pressure sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1866, 2273, or 2274 inactive?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging.

Guided Step 2A - Check the EGR differential pressure tubes for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the lines for leaks.

  • Leaks should be easily noted by traces of soot.

Leaks detected at either the low or high EGR differential pressure tubes?
YES NO

Tighten the fittings or replace the EGR differential pressure tube.

  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • For ISX engines, use the following procedure in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the EGR differential pressure tubes for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure tubes.
  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • For ISX engines, use the following procedure in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Action

Inspect the EGR differential pressure tubes for restrictions, soot plugging, and plugging.

  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • For ISX engines, use the following procedure in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Debris or soot found in either EGR differential pressure tube?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • For ISX engines, use the following procedure in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check EGR venturi.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure tubes.
  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • For ISX engines, use the following procedure in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Action

Inspect the EGR venturi for carbon buildup.

  • Inspect the EGR differential pressure tube ports for signs of carbon buildup.
  • Inspect inside the venturi tube for signs of carbon buildup.

Carbon buildup detected in the EGR venturi tube or EGR differential pressure tube ports?
YES NO

Remove the EGR venturi tube.

  • For ISM engines, use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-025 in Section 11.
  • For ISX engines, use the following procedure in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-025 in Section 11.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2774 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 26-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2777 is active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2777 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2777 is active?
YES NO

This fault code indicates that the aftertreatment regeneration permit switch was disabled when Fault Code 1921, 1922, 2639 was activated for high aftertreatment soot load.

Perform the aftertreatment testing procedure to check the performance of the aftertreatment system.

  • Refer to Procedure 014-013 in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322, or the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2777 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2789 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the Coolant Temperature value.

  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

  • For ISM engines, refer to Engine Coolant Temperature Below Normal troubleshooting symptom tree tree in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, refer to Engine Coolant Temperature Below Normal troubleshooting symptom tree tree in he Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Replace the coolant temperature sensor.

Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2789 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2813 is active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check for active Fault Code 2813.

Fault Code 2813 is active?
YES NO

The EGR valve was closed during an active regeneration of the aftertreatment diesel particulate filter.

No repair is necessary.

 No Repair

Repair complete

Repair complete

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Fuel pump output pressure. |
 | STEP 1A. Measure the fuel pump output pressure. | Does the fuel pressure meet the specification?
 | STEP 1B. Check for active fault codes. | Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Inspect the aftertreatment fuel drain valve. |
 | STEP 2A. Check for a stuck closed or plugged aftertreatment fuel drain valve. | Fault Code 2878 inactive and Fault Code 1963 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2878 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Fuel pump output pressure.

Guided Step 1A - Measure the fuel pump output pressure.

Conditions

  • Connect a pressure gauge to the Compuchek™ fitting of the fuel pump.
  • Turn keyswitch ON.
  • Engine running at 1200 rpm (engine cranking if troubleshooting No-Start).

Action

Read the fuel pressure at 1200 rpm, or cranking if engine will not start.

  • Read the fuel pressure while cranking if the engine will not start.

Cranking: minimum of 172 kpa [25 psi]

Engine running at 1200 rpm: minimum of 827 kpa [120 psi]

Does the fuel pressure meet the specification?
YES | NO
No Repair | No Repair

Go to 1B

Reference the fuel system checks in Section TT of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment fuel drain valve.

Guided Step 2A - Check for a stuck closed or plugged aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the aftertreatment fuel shutoff valve (1) and aftertreatment fuel drain valve (2) locations in the aftertreatment fuel shutoff valve manifold. These valves are the exact same part number so swapping the valve locations will determine if the fault follows the valve.

  • Remove the aftertreatment fuel shutoff valve (1) and the aftertreatment fuel drain valve (2) from the aftertreatment fuel shutoff manifold. Refer to Procedure 011-052 in Section 11 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature&trade;, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Swap the valve locations by installing the valve that was removed from the aftertreatment fuel shutoff valve into the aftertreatment fuel drain valve location.
  • Install the valve that was removed from the aftertreatment fuel drain valve into the aftertreatment fuel shutoff valve location.
  • Start the engine and idle for 5 minutes.

Note: Do not swap the electrical connections. Make sure the electrical connection remains in the original location.

The ISX aftertreatment fuel shutoff valve manifold is pictured on the left and the ISM aftertreatment fuel shutoff valve manifold is pictured on the right.

Fault Code 2878 inactive and Fault Code 1963 active?
YES NO

A stuck closed aftertreatment fuel drain valve has been detected.

Replace the valve that is presently installed in the aftertreatment fuel shutoff valve location (valve mounted below the aftertreatment fuel pressure sensor).

Refer to Procedure 011-052 in Section 11 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or the Signature&trade;, ISX, and QSX15 Service Manual, Bulletin 3666239.

A restriction has been detected in the aftertreatment fuel drain line.

Disconnect the fuel return line from the fuel shutoff manifold and the fuel return tee fitting, located in front of the engine control module. Check the fuel line for restriction.

Refer to Procedure 011-051 in Section 11 in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322, or Procedure 011-051 in Section 11 in the Signature&trade;, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine for 5 minutes to purge air from the aftertreatment fuel system.
  • Shut down engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start and idle the engine for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: It may be necessary to run the engine multiple times in order to purge air from the aftertreatment fuel system.

Fault Code 2878 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active counts of Fault Code 2215. | Active or inactive counts of Fault Code 2215?
 | STEP 1B. Check for active fault codes. | Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Inspect the aftertreatment fuel drain valve. |
 | STEP 2A. Check for a stuck closed or plugged aftertreatment fuel drain valve. | Fault Code 2878 inactive and Fault Code 1963 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2878 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active counts of Fault Code 2215.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to check for active counts of Fault Code 2215.

It is possible to swap the connections between the aftertreatment fuel pressure sensor and the fuel delivery pressure sensor. If this occurs, Fault Code 2215 will intermittently go active and the engine will run very rough and will surge at low idle. If these symptoms are present, make sure the fuel pressure connections are connected properly.

Active or inactive counts of Fault Code 2215?
YES NO

Properly connect the aftertreatment fuel pressure sensor and fuel delivery pressure sensor wiring harness connections.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Inspect the aftertreatment fuel drain valve.

Guided Step 2A - Check for a stuck closed or plugged aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the aftertreatment fuel shutoff valve (1) and aftertreatment fuel drain valve (2) locations in the aftertreatment fuel shutoff valve manifold. These valves are the exact same part number so swapping the valve locations will determine if the fault follows the valve.

  • Remove the aftertreatment fuel shutoff valve (1) and the aftertreatment fuel drain valve (2) from the aftertreatment fuel shutoff manifold. Refer to Procedure 011-052 in Section 11.
  • Swap the valve locations by installing the valve that was removed from the aftertreatment fuel shutoff valve into the aftertreatment fuel drain valve location.
  • Install the valve that was removed from the aftertreatment fuel drain valve into the aftertreatment fuel shutoff valve location.
  • Start the engine and idle for 5 minutes.

Note: Do not swap the electrical connections. Make sure the electrical connection remains in the original location.

The ISX aftertreatment fuel shutoff valve manifold is pictured on the left and the ISM aftertreatment fuel shutoff valve manifold is pictured on the right.

Fault Code 2878 inactive and Fault Code 1963 active?
YES NO

A stuck closed aftertreatment fuel drain valve has been detected.

Replace the valve that is presently installed in the aftertreatment fuel shutoff valve location (valve mounted below the aftertreatment fuel pressure sensor).

Refer to Procedure 011-052 in Section 11.

A restriction has been detected in the aftertreatment fuel drain line.

Disconnect the fuel return line from the fuel shutoff manifold and the fuel return tee fitting, located in front of the engine control module. Check the fuel line for restriction.

Refer to Procedure 011-051 in Section 11.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine for 5 minutes to purge air from the aftertreatment fuel system.
  • Shut down engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start and idle the engine for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: It may be necessary to run the engine multiple times in order to purge air from the aftertreatment fuel system.

Fault Code 2878 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Fuel pump output pressure. |
 | STEP 1A. Measure the fuel pump output pressure. | Does the fuel pressure meet the specification?
 | STEP 1B. Check for active fault codes. | Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Check the aftertreatment fuel injector and fuel shutoff valve system. |
 | STEP 2A. Check for fuel leaks. | Fuel leaks found in the aftertreatment fuel system?
 | STEP 2B. Check for a leaking aftertreatment fuel drain valve. | Fault Code 2879 inactive and Fault Code 1925 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2879 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Fuel pump output pressure.

Guided Step 1A - Measure the fuel pump output pressure.

Conditions

  • Connect a pressure gauge to the Compuchek™ fitting of the fuel pump.
  • Turn keyswitch ON.
  • Engine running at 1200 rpm (engine cranking if troubleshooting No-Start).

Action

Read the fuel pressure at 1200 rpm, or cranking if engine will not start.

  • Read the fuel pressure while cranking if the engine will not start.

Cranking: minimum of 172 kpa [25 psi]

Engine running at 1200 rpm: minimum of 827 kpa [120 psi]

Does the fuel pressure meet the specification?
YES | NO
No Repair | No Repair

Go to 1B

Reference the fuel system checks in Section TT of the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel injector and fuel shutoff valve system.

Guided Step 2A - Check for fuel leaks.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Start the engine and run at idle speed.

Action

Use INSITE™ electronic service tool to pressurize the aftertreatment fuel injection system.

  • Use INSITE™ electronic service tool to select the aftertreatment shutoff valve and injector override test under the ECM diagnostics test menu.
  • Choose aftertreatment injector leak test in the test modes selection box.

Performing this test will pressurize the aftertreatment fuel system, but will not inject fuel into the aftertreatment system.

Inspect the aftertreatment fuel shutoff valve assembly, aftertreatment fuel lines, and aftertreatment fuel line connections for external leaks.

Fuel leaks found in the aftertreatment fuel system?
YES NO

Tighten any loose fuel line fittings.

Replace the malfunctioning component if fuel is found leaking externally.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a leaking aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the aftertreatment fuel shutoff valve (1) and aftertreatment fuel drain valve (2) locations in the aftertreatment fuel shutoff valve manifold. These valves are the exact same part number so swapping the valve locations will determine if the fault follows the valve.

  • Remove the aftertreatment fuel shutoff valve (1) and the aftertreatment fuel drain valve (2) from the aftertreatment fuel shutoff manifold. Refer to Procedure 011-052 in Section 11.
  • Swap the valve locations by installing the valve that was removed from the aftertreatment fuel shutoff valve into the aftertreatment fuel drain valve location.
  • Install the valve that was removed from the aftertreatment fuel drain valve into the aftertreatment fuel shutoff valve location.
  • Start the engine and idle for 5 minutes.

NOTE: Do not swap the electrical connections. Make sure the electrical connection remains in the original location.

The ISX aftertreatment fuel shutoff valve manifold is pictured on the left and the ISM aftertreatment fuel shutoff valve manifold is pictured on the right.

Fault Code 2879 inactive and Fault Code 1925 active?
YES NO

A leaking aftertreatment fuel drain valve has been detected.

Replace the valve that is presently installed in the aftertreatment fuel shutoff valve location (valve mounted below the aftertreatment fuel pressure sensor).

  • Refer to Procedure 011-052 in Section 11.

A leaking aftertreatment fuel injector has been detected.

Replace the aftertreatment fuel injector.

  • Refer to Procedure 011-042 in Section 11.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine for 5 minutes to purge air from the aftertreatment fuel system.
  • Shut down engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start and idle the engine for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: It may be necessary to run the engine multiple times in order to purge air from the aftertreatment fuel system.

Fault Code 2879 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active counts of Fault Code 2215. | Active or inactive counts of Fault Code 2215?
 | STEP 1B. Check for active fault codes. | Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Check the aftertreatment fuel injector and fuel shutoff valve system. |
 | STEP 2A. Check for fuel leaks. | Fuel leaks found in the aftertreatment fuel system?
 | STEP 2B. Check for a leaking aftertreatment fuel drain valve. | Fault Code 2879 inactive and Fault Code 1925 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2879 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active counts of Fault Code 2215.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to check for active counts of Fault Code 2215.

It is possible to swap the connections between the aftertreatment fuel pressure sensor and the fuel delivery pressure sensor. If this occurs, Fault Code 2215 will intermittently go active and the engine will run very rough and will surge at low idle. If these symptoms are present, make sure the fuel pressure connections are connected properly.

Active or inactive counts of Fault Code 2215?
YES NO

Properly connect the aftertreatment fuel pressure sensor and fuel delivery pressure sensor wiring harness connections.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel injector and fuel shutoff valve system.

Guided Step 2A - Check for fuel leaks.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Start the engine and run at idle speed.

Action

Use INSITE™ electronic service tool to pressurize the aftertreatment fuel injection system.

  • Use INSITE™ electronic service tool to select the aftertreatment shutoff valve and injector override test under the ECM diagnostics test menu.
  • Choose aftertreatment injector leak test in the test modes selection box.

Performing this test will pressurize the aftertreatment fuel system, but will not inject fuel into the aftertreatment system.

Inspect the aftertreatment fuel shutoff valve assembly, aftertreatment fuel lines, and aftertreatment fuel line connections for external leaks.

Fuel leaks found in the aftertreatment fuel system?
YES NO

Tighten any loose fuel line fittings.

Replace the malfunctioning component if fuel is found leaking externally.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a leaking aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the aftertreatment fuel shutoff valve (1) and aftertreatment fuel drain valve (2) locations in the aftertreatment fuel shutoff valve manifold. These valves are the exact same part number so swapping the valve locations will determine if the fault follows the valve.

  • Remove the aftertreatment fuel shutoff valve (1) and the aftertreatment fuel drain valve (2) from the aftertreatment fuel shutoff manifold. Refer to Procedure 011-052 in Section 11.
  • Swap the valve locations by installing the valve that was removed from the aftertreatment fuel shutoff valve into the aftertreatment fuel drain valve location.
  • Install the valve that was removed from the aftertreatment fuel drain valve into the aftertreatment fuel shutoff valve location.
  • Start the engine and idle for 5 minutes.

NOTE: Do not swap the electrical connections. Make sure the electrical connection remains in the original location.

The ISX aftertreatment fuel shutoff valve manifold is pictured on the left and the ISM aftertreatment fuel shutoff valve manifold is pictured on the right.

Fault Code 2879 inactive and Fault Code 1925 active?
YES NO

A leaking aftertreatment fuel drain valve has been detected.

Replace the valve that is presently installed in the aftertreatment fuel shutoff valve location (valve mounted below the aftertreatment fuel pressure sensor).

  • Refer to Procedure 011-052 in Section 11.

A leaking aftertreatment fuel injector has been detected.

Replace the aftertreatment fuel injector.

  • Refer to Procedure 011-042 in Section 11.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine for 5 minutes to purge air from the aftertreatment fuel system.
  • Shut down engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start and idle the engine for 5 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: It may be necessary to run the engine multiple times in order to purge air from the aftertreatment fuel system.

Fault Code 2879 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?
STEP 2. | Check the aftertreatment fuel system. |
 | STEP 2A. Check for fuel leaks. | Fuel leaks found in the aftertreatment fuel system?
 | STEP 2B. Inspect the aftertreatment fuel shutoff manifold. | Debris found in the fuel ports or aftertreatment fuel shutoff manifold?
 | STEP 2C. Inspect the aftertreatment fuel lines. | Debris or restrictions found in the aftertreatment fuel supply line?
 | STEP 2D. Inspect the fuel rifle supply port. | Debris or restrictions found in the aftertreatment fuel supply line?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 2881 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment fuel pressure sensor, aftertreatment fuel injector, aftertreatment fuel shutoff valve, or aftertreatment fuel drain valve are active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment fuel system.

Guided Step 2A - Check for fuel leaks.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Start the engine and run at idle speed.
  • Refer to Procedure 011-054 in Section 11. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, or the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239, for information on the aftertreatment fuel injector flow test.

Action

Use INSITE™ electronic service tool to pressurize the aftertreatment fuel injection system.

  • Use INSITE™ electronic service tool to select the aftertreatment shutoff valve and injector override test under the ECM diagnostics test menu.
  • Choose aftertreatment injector leak test in the test modes selection box.

Refer to Procedure 011-054 in Section 11. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, or the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239, for information on the aftertreatment fuel injector flow test.

Inspect the aftertreatment fuel shutoff valve assembly, aftertreatment fuel lines, and aftertreatment fuel line connections for external leaks.

Fuel leaks found in the aftertreatment fuel system?
YES NO

Tighten any loose fuel line fittings.

Replace the malfunctioning component if fuel is found leaking externally.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the aftertreatment fuel shutoff manifold.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment fuel shutoff manifold. Refer to Procedure 011-052 in Section 11. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, or the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239.

Action

Inspect the aftertreatment fuel shutoff manifold.

  • Remove the aftertreatment fuel shutoff manifold from the engine. Refer to Procedure 011-052 in Section 11. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, or the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239.
  • Inspect the fuel inlet port of the aftertreatment fuel shutoff manifold for debris trapped in the inlet port, outlet, and fuel drain ports.

Debris found in the fuel ports or aftertreatment fuel shutoff manifold?
YES NO

Remove the debris from the ports of the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-052 in Section 11. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, or the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the aftertreatment fuel lines.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment fuel supply line. Refer to Procedure 011-051 in Section 11. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, or in the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239.

Action

Inspect the aftertreatment fuel lines.

  • Remove the aftertreatment fuel supply line between the fuel rifle and the aftertreatment fuel shutoff manifold. Refer to Procedure 011-051 in Section 11. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, in the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239.
  • Inspect the aftertreatment fuel supply line for plugging or restrictions.

Debris or restrictions found in the aftertreatment fuel supply line?
YES NO

Replace the aftertreatment fuel supply line.

Refer to Procedure 011-051 in Section 11. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, or in the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Inspect the fuel rifle supply port.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment injector fuel supply line from the supply outlet of the fuel rifle. Refer to Procedure 011-051 in Section 11. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, or in the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239.

Action

Inspect the fuel rifle support port.

  • Inspect the fuel rifle port for debris that may be restricting the fuel flow to the aftertreatment system.

NOTE: In the ISM engine, inspect the fuel rifle port for a plastic fitting that may be pushed into the fuel rifle port in the cylinder head.

Debris or restrictions found in the aftertreatment fuel supply line?
YES NO

Replace the aftertreatment fuel supply line.

  • Refer to Procedure 011-051 in Section 11. This procedure is found in the Service Manual, ISM, ISMe, and QSM11, Bulletin 3666322, or in the Service Manual, Signature, ISX, and QSX15, Bulletin 3666239.

Continue to troubleshoot to locate the cause of the low fuel pressure supply to the aftertreatment fuel shutoff manifold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine for 1 minute to purge air from the aftertreatment fuel system.
  • Shut down engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start and idle the engine for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: It may be necessary to run the engine multiple times in order to purge air from the aftertreatment fuel system.

Fault Code 2881 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 2961 - Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2961?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 1899 or 2359 inactive?
STEP 2. | Monitor the exhaust gas recirculation temperature sensor. |
 | STEP 2A. Monitor the exhaust gas recirculation temperature sensor. | Values of the exhaust gas recirculation temperature and the intake manifold temperature with in 14°C or 25˚F of each other?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 3B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 4. | Check the exhaust gas recirculation system. |
 | STEP 4A. Check the exhaust gas recirculation differential pressure sensor tubes for cracks, restrictions, or leaks. | Are cracks, restrictions, or leaks present?
 | STEP 4B. Check the exhaust gas recirculation differential pressure tubes for plugging. | Debris or soot found in either exhaust gas recirculation differential pressure tube?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 2961 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2961?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1899 or 2359 inactive?
YES NO

Troubleshoot the inactive fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Monitor the exhaust gas recirculation temperature sensor.

Guided Step 2A - Monitor the exhaust gas recirculation temperature sensor.

Conditions

  • Make sure that the engine has been off for at least 1 hour or more.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the exhaust gas recirculation temperature sensor.

  • Use INSITE™ electronic service tool to monitor the exhaust gas recirculation temperature and intake manifold temperature value.
  • Compare the temperature reading of the exhaust gas recirculation temperature and intake manifold temperature.

Values of the exhaust gas recirculation temperature and the intake manifold temperature with in 14°C or 25˚F of each other?
YES NO
No Repair

Replace the exhaust gas recirculation temperature sensor. Refer to Procedure 019-378 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

  • Incorrect coolant mixture will cause high exhaust gas recirculation temperatures due to inefficient cooling.
  • Check the freeze point of the engine coolant to be sure of a proper mixture.

Use the following procedure, in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 008-018 in Section 8.

Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 008-018 in Section 8.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and fill the cooling system with the proper mixture.

  • Use the following procedure, in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 008-018 in Section 8.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 008-018 in Section 8.

NOTE: Low engine coolant level may cause erratic coolant flow through the engine and exhaust gas recirculation cooler, in turn, causing the exhaust gas recirculation temperatures to rise.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 008-018 in Section 8.

Go to 4A

Go to 5A

Guided Step 4 - Check the exhaust gas recirculation system.

Guided Step 4A - Check the exhaust gas recirculation differential pressure sensor tubes for cracks, restrictions, or leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the exhaust gas recirculation differential pressure sensor tubes for cracks, restrictions, or leaks.

Soot streaks can indicate the line is loose or cracked.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Are cracks, restrictions, or leaks present?
YES NO

Tighten or replace the exhaust gas recirculation differential pressure sensor tubes.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the exhaust gas recirculation differential pressure tubes for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust gas recirculation differential pressure tubes. Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11. Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Action

Inspect the exhaust gas recirculation differential pressure tubes for restrictions, soot plugging, and plugging.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Debris or soot found in either exhaust gas recirculation differential pressure tubes?
YES NO

Clear the debris or replace the exhaust gas recirculation differential pressure tube.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Clean the exhaust gas recirculation cooler.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-019 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-019 in Section 11.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2961 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Apr-2012


FAULT CODE 2962 - Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2962?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 1899 or 2359 inactive?
STEP 2. | Monitor the exhaust gas recirculation temperature sensor. |
 | STEP 2A. Monitor the exhaust gas recirculation temperature sensor. | Values of the exhaust gas recirculation temperature and the intake manifold temperature within 14˚C or 25˚F or of each other?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 3B. Check the engine coolant level. | Engine coolant at proper level?
STEP 4. | Check the EGR system. |
 | STEP 4A. Check the EGR differential pressure sensor tubes for cracks, restrictions, or leaks. | Are cracks, restrictions, or leaks present?
 | STEP 4B. Check the EGR differential pressure tubes for plugging. | Debris or soot found in either EGR differential pressure tube?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 2962 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2962?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1899 or 2359 inactive?
YES NO

Troubleshoot the inactive fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Monitor the exhaust gas recirculation temperature sensor.

Guided Step 2A - Monitor the exhaust gas recirculation temperature sensor.

Conditions

  • Make sure that the engine has been off for at least 1 hour or more.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the exhaust gas recirculation temperature sensor.

  • Use INSITE™ electronic service tool to monitor the exhaust gas recirculation temperature and intake manifold temperature value.
  • Compare the temperature reading of the exhaust gas recirculation temperature and intake manifold temperature.

Values of the exhaust gas recirculation temperature and the intake manifold temperature within 14˚C or 25˚F of each other?
YES NO
No Repair

Replace the EGR temperature sensor. Refer to Procedure 019-378 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

  • Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.
  • Check the freeze point of the engine coolant to be sure of a proper mixture.
  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 008-018 in Section 8.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and refill the cooling system with the proper mixture.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 008-018 in Section 8.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 008-018 in Section 8.

Note: Low engine coolant level may cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

Engine coolant at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 008-018 in Section 8.

Go to 4A

Go to 5A

Guided Step 4 - Check the EGR system.

Guided Step 4A - Check the EGR differential pressure sensor tubes for cracks, restrictions, or leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor tubes for cracks, restrictions, or leaks.

Soot streaks can indicate the line is loose or cracked.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 19.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 19.

Are cracks, restrictions, or leaks present?
YES NO

Tighten or replace the EGR differential pressure sensor tubes.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 19.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the EGR differential pressure tubes for plugging.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Action

Inspect the EGR differential pressure tubes for restrictions, soot plugging, and plugging.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Debris or soot found in either EGR differential pressure tubes?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-026 in Section 11.
  • Use the following procedure in the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Clean the EGR cooler.

  • Use the following procedure in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-019 in Section 11.
  • Use the following procedurein the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 011-019 in Section 11 .

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2962 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Feb-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Coolant Temperature Fault Codes. |
 | STEP 1A. Check for coolant temperature fault code. | Fault Code 144 or 145 active?
 | STEP 2B. Monitor coolant temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check ECM calibration and clear fault code. |
 | STEP 2A. Check if an ECM calibration update is available | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for Coolant Temperature Fault Codes.

Guided Step 1A - Check for coolant temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for coolant temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 or 145 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 144 or 145.

Go to 1B

Guided Step 1B - Monitor coolant temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor coolant temperature.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal symptom tree.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Appropriate troubleshooting symptom tree

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold temperature. |
 | STEP 1A. Monitor intake manifold temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?

Guided Step 1 - Monitor intake manifold temperature.

Guided Step 1A - Monitor intake manifold temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature.

  • Use INSITE™ electronic service tool to monitor the Intake Manifold Temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

  • For ISM engines, refer to the Intake Manifold Air Temperature Above Specification symptom tree in the ISM, ISMe and QSM11 Service Manual, Bulletin 3666322.
  • For ISX engines, refer to the Intake Manifold Air Temperature Above Specification symptom tree in the Signature, ISX and QSX15 Service Manual, Bulletin 3666239.

Replace the intake manifold temperature sensor.

Refer to Procedure 019-159 (Intake Manifold Pressure/Temperature Sensor) in Section 19.

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 09-Jul-2010


FAULT CODE 2973 - Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or high inactive counts of Fault Code 122, 123, 221, 222, 295, 595, 687, or 2345?
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 51 mm-hg [2 in-hg] of local barometric pressure?
STEP 3. | Check the engine intake manifold pressure/temperature sensor and circuit. |
 | STEP 3A. Inspect the engine intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a plugged engine intake manifold pressure/temperature sensor. | Tip of the sensor have soot or carbon buildup?
 | STEP 3C. Verify the sensor accuracy. | INSITE™ electronic service tool reading for intake manifold pressure between -77 mm-hg [-3 in-hg] and 77 mm-hg [3 in-hg]?
 | STEP 3D. Check the circuit response. | Fault Code 123 active?
 | STEP 3E. Check the circuit response. | Fault Code 122 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 123 active?
 | STEP 4C. Check the circuit response. | Fault Code 122 active?
STEP 5. | Check the air intake system for leaks. |
 | STEP 5A. Check the charge air cooler for leaks. | Air leak present?
 | STEP 5B. Check the intake manifold inlet and connections for leaks. | Air leak present?
 | STEP 5C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 5D. Check for a restricted charge air cooler. | Within specifications?
STEP 6. | Check the turbocharger speed sensor. |
 | STEP 6A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 6B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
STEP 7. | Check the exhaust and intake systems for restriction. |
 | STEP 7A. Check exhaust restriction. | Exhaust restriction within specifications?
 | STEP 7B. Check intake restriction. | Air intake restriction within specifications?
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 122, 123, 221, 222, 295, 595, 687, or 2345?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for barometric pressure to the local barometric pressure.

  • Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading is within 51 mm-hg [2 in-hg] of local barometric pressure?
YES NO
No Repair

Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 8A

Guided Step 3 - Check the engine intake manifold pressure/temperature sensor and circuit.

Guided Step 3A - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold pressure/temperature sensor connector and the engine harness connector for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the intake manifold pressure/temperature sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged intake manifold pressure/temperature sensor. Refer to the circuit diagram or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-159 in Section 19.

No Repair

Go to 8A

Go to 3B

Guided Step 3B - Check for a plugged engine intake manifold pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.

Action

Remove the intake manifold pressure/temperature sensor.Inspect the tip of the sensor for soot or carbon buildup.

  • Refer to Procedure 019-159 in Section 19.

Tip of the sensor have soot or carbon buildup?
YES NO

Use compressed air to remove the soot or carbon buildup. Refer to Procedure 019-159 in Section 19.

No Repair

Go to 3C

Go to 3C

Guided Step 3C - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Turn engine OFF.

Action

Intake manifold pressure reading in INSITE™ electronic service tool reads as a gauge pressure. With keyswitch ON and engine OFF, the intake manifold pressure should read close to 0 mm-Hg (0 in-Hg).

  • Start INSITE™ electronic service tool Data Monitor/Logger and monitor the intake manifold pressure reading.

INSITE™ electronic service tool reading for intake manifold pressure between -77 mm-hg [-3 in-hg] and 77 mm-hg [3 in-hg]?
YES | NO
No Repair | No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES | NO
No Repair | No Repair

Go to 3E

Go to 4A

Guided Step 3E - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and the engine intake manifold pressure SIGNAL pin at the engine intake manifold pressure/temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

An in-range malfunction of the intake manifold pressure/temperature sensor has been detected.

Replace the engine intake manifold pressure/temperature sensor.

  • Refer to Procedure 019-159 in Section 19.

No Repair

Go to 8A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 8A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4C

Go to 8A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and engine intake manifold pressure SIGNAL pin at the engine control module engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 8A

Go to 8A

Guided Step 5 - Check the air intake system for leaks.

Guided Step 5A - Check the charge air cooler for leaks.

Conditions

  • Operate engine.

Action

Check the charge air cooler and connections for air leaks.

Air leak present?
YES NO

Repair or replace the leaking component. For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-027 in Section 10. For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-027 in Section 10.

No Repair

Go to 8A

Go to 5B

Guided Step 5B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Operate engine.

Action

Check for air leaks in connections and hoses between the turbocharger and intake manifold inlet.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-024 in Section 10.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-024 in Section 10.

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 8A

Go to 5C

Guided Step 5C - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-033 in Section 10.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

 No Repair

Go to 8A

Go to 5D

Guided Step 5D - Check for a restricted charge air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check the pressure differential across the charge air cooler.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-027 in Section 10.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-027 in Section 10.

Within specifications?
YES NO
No Repair

Clean or replace the charge air cooler, if necessary.

Go to 6A

Go to 8A

Guided Step 6 - Check the turbocharger speed sensor.

Guided Step 6A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Only perform this step if the engine is equipped with a turbocharger speed sensor. Inspect the turbocharger or refer to the engine wiring diagram to determine if the engine has a turbocharger speed sensor. If no sensor is present, skip to Step 7.

Inspect the turbocharger speed sensor connector, engine harness connector, and turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 8A

Go to 6B

Guided Step 6B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check the turbocharger speed sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

  • The turbocharger speed sensor is damaged.
  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the exhaust and intake systems for restriction.

Guided Step 7A - Check the exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the exhaust restriction.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 011-009 in Section 11.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.Refer to Procedure 011-009 in Section 11.

Exhaust restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 7B

Go to 8A

Guided Step 7B - Check the intake restriction.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-031 in Section 10.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-031 in Section 10.

Air intake restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Replace the engine intake manifold pressure/temperature sensor.

  • Refer to Procedure 019-159 in Section 10.

Repair complete

Go to 8B

Last Modified: 16-Oct-2015


FAULT CODE 3167 - Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX CM871 | 3666239
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISM CM876 | 3666322
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM871 | 3666239
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISM CM876 | 3666322

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 1923, 1924, 1925, 1926, 1927, 1928, 1932, 1963, 1977, 2728, 2732, 2733, 2741, 2878 or 2881 active or inactive?
STEP 2. | Check the aftertreatment fuel injector. |
 | STEP 2A. Perform the Aftertreatment Maintenance Reset All procedure. | Aftertreatment Maintenance Reset All procedure completed?
 | STEP 2B. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meets the specifications?
 | STEP 2C. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meets the specifications?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment fuel injector system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1923, 1924, 1925, 1926, 1927, 1928, 1932, 1963, 1977, 2728, 2732, 2733, 2741, 2878 or 2881 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment fuel injector.

Guided Step 2A - Perform the Aftertreatment Maintenance Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

NOTE: Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu.

Go to 2B

Go to 2B

Guided Step 2B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Perform the aftertreatment system test.

Refer to Procedure 011-054 in the Associated Procedures Table.

NOTE: It is only necessary to perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Clean the aftertreatment injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 2C

Guided Step 2C - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start and idle the engine.

Action

Perform the aftertreatment system test.

Refer to Procedure 011-054 in the Associated Procedures Table.

NOTE: It is only necessary to perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Replace the aftertreatment injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Mar-2014


FAULT CODE 3348 - Turbocharger 1 Compressor Inlet Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 3348 active?
STEP 2. | Check the crankcase ventilation system. |
 | STEP 2A. Check for crankcase pressure sensor faults. | Fault Code 555 or 556 active or inactive?
 | STEP 2B. Check the crankcase breather system components. | Any restrictions found?
STEP 3. | Check the intake system. |
 | STEP 3A. Check for intake manifold pressure sensor faults. | Fault Code 125 active or inactive?
 | STEP 3B. Check the intake manifold pressure sensor. | INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
 | STEP 3C. Check the condition of the air intake filter. | Excessive restriction found?
 | STEP 3D. Check the air intake plumbing up to the compressor inlet for a restriction. | Excessive restriction found?
STEP 4. | Check for oil in the compressor discharge pipe. |
 | STEP 4A. Remove the compressor discharge pipe for inspection. | Oil residue in the discharge pipe?
 | STEP 4B. Check for oil in the discharge pipe. | Fresh oil in the discharge pipe?
 | STEP 4C. Check for oil in the charge-air cooler. | Oil in the charge air cooler?
STEP 5. | Check the ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?
STEP 6. | Idle the engine to validate the repair. |
 | STEP 6A. Check for fault codes. | Fault Code 3348 active or inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3348 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the crankcase ventilation system.

Guided Step 2A - Check for crankcase pressure sensor faults.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 555 or 556.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 555 or 556 active or inactive?
YES NO

Refer to the appropriate troubleshooting tree.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check the crankcase breather system components.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankcase breather system.

  • Check for a restriction in the draft tube.
  • Check for a restriction in the tube between the engine and the filter housing.

Any restrictions found?
YES NO

Remove the restriction.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the intake system.

Guided Step 3A - Check for intake manifold pressure sensor faults.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 125.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 125 active or inactive?
YES NO

Reference Fault Code 125.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold temperature/pressure sensor. Refer to Procedure 019-159 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the condition of the air intake filter.

Conditions

  • Turn keyswitch ON.
  • Connect all sensors.

Action

Check the condition of the air intake filter.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-027 in Section 10.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-027 in Section 10.

Excessive restriction found?
YES NO

Replace the air intake filter.

 No Repair

Go to 3D

Go to 3D

Guided Step 3D - Check the air intake plumbing up to the compressor inlet for a restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the intake plumbing for restriction.

  • Remove and inspect each component from the atmosphere to the air filter for a restriction.

Excessive restriction found?
YES NO

Remove the restriction.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check for oil in the compressor discharge pipe.

Guided Step 4A - Remove the compressor discharge pipe for inspection.

Conditions

  • Assemble all components.

Action

Inspect the compressor discharge pipe.

  • Operate the engine for 5 minutes at 1000 rpm.
  • Remove the discharge pipe from the compressor.
  • Inspect the discharge pipe for oil.

Oil residue in the discharge pipe?
YES NO

Clean the compressor outlet and discharge pipe.

Assemble the discharge pipe and repeat Step 4A up to five times.

After five cleaning cycles, if there is still oil in the discharge pipe, replace the turbocharger.

For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-033 in Section 10.

For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 4A

Go to 4B

Guided Step 4B - Check for oil in the discharge pipe.

Conditions

  • Assemble all components.

Action

Check for oil in the discharge pipe.

  • Start the engine and allow it to idle at 600 rpm for 5 minutes.
  • Remove the discharge pipe and check for oil.

Fresh oil in the discharge pipe?
YES NO

If fresh oil is present after the cleaning cycles, replace the turbocharger.

For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-033 in Section 10.

For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check for oil in the charge-air cooler.

Conditions

  • Turn keyswitch OFF.

Action

Check for oil in the charge-air cooler.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-027 in Section 10.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-027 in Section 10.

Oil in the charge-air cooler?
YES NO

Clean and inspect the charge-air cooler.

  • For ISM engines, use the following procedure in the ISM, ISMe, and QSM11 Service Manual, Bulletin 3666322. Refer to Procedure 010-027 in Section 10.
  • For ISX engines, use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-027 in Section 10.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 6 - Idle the engine to validate the repair.

Guided Step 6A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start the engine.

Action

Check for fault codes.

  • Start the engine.
  • Idle the engine for 30 minutes.
  • Connect INSITE™ electronic service tool.
  • Check for fault codes.

Fault Code 3348 active or inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete

Last Modified: 18-Jan-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 3374 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 3374 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3374 active or inactive?
YES NO

Cruise control was inhibited temporarily by the anti-lock braking (ABS) controller due to certain driving conditions. No repair is necessary. This fault code is for information only.

Cruise control was inhibited temporarily by the anti-lock braking (ABS) controller due to certain driving conditions. No repair is necessary. This fault code is for information only.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 3374 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 3385 - Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold temperature. |
 | STEP 1A. Monitor intake manifold temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

The EGR valve was closed because the engine was operating with cold intake manifold temperatures for an extended period of time.

No repair is necessary

Replace the intake manifold temperature sensor.

Refer to Procedure 019-159 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Feb-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between the INSITE™ electronic service tool and ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3488 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link termination resistor. | Resistance between 110 and 130 ohms?
 | STEP 3C. Check for an open in the SAE J1939 data link harness. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit in the SAE J1939 data link harness. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground in the SAE J1939 data link harness. | More than 100k ohms?
 | STEP 3F. Check the fault codes. | Fault Code 3488 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 3488 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3488 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness.

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM upon receipt of authorization. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link termination resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 termination from the ECM connector

Action

Check the SAE J1939 data link termination resistor resistance.

  • Measure the resistance between the SAE J1939 data link (+) and SAE J1939 data link (-) at the SAE J1939 termination resistor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

See the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Resistance between 110 and 130 ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check for an open in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the terminating resistor from the engine harness.
  • Disconnect the EGR valve from the engine harness.

Action

Check for an open circuit in the SAE J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the VGT actuator engine harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the VGT actuator engine harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

See the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open has been detected in the SAE J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the terminating resistor from the engine harness.
  • Disconnect the EGR valve from the engine harness.

Action

Check for a short circuit in the SAE J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

NOTE: Disregard any resistance between 50 and 130 ohms between the SAE J1939 (+) and the SAE J1939 (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

See the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit to ground in the SAE J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR valve from the engine harness.

Action

Check for a short circuit to ground in the SAE J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

See the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3488 inactive?
YES NO

The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 4A

The appropriate ECM No Communication symptom tree

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use the INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 3488 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2010


FAULT CODE 3616 - Engine VGT Nozzle Position - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | Signature™, ISX, and QSX15 | 3666239
Cooling System | Refer to Procedure 008-018 | ISM, ISMe, and QSM11 | 3666322
Turbocharger | Refer to Procedure 010-033 | Signature™, ISX, and QSX15 | 3666239
Turbocharger | Refer to Procedure 010-033 | ISM, ISMe, and QSM11 | 3666322
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | Signature™, ISX, and QSX15 | 3666239
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISM, ISMe, and QSM11 | 3666322

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for other active turbocharger fault codes. | Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Verify the complaint. |
 | STEP 2A. Check the fault code. | Fault Code 3616 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 2B. Vehicle test drive. | Fault Code 2387 active?
 | STEP 2C. Confirm the complaint. | Customer reported a drivability complaint with a cold engine?
 | STEP 2D. Inspect the variable geometry turbocharger (VGT) actuator. | Nozzle movement meet the requirements according to Procedure 010-134 in the Associated Procedures Table using the sector gear travel gauge?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for other active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Fault Code 2387 troubleshooting tree

Go to 2A

Guided Step 2 - Verify the complaint.

Guided Step 2A - Check the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 3616.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 3616 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2C

Guided Step 2B - Vehicle test drive.

Conditions

  • Connect all components.
  • Allow the coolant temperature to cool below 74°C [165°F].

This test can not be performed if the engine does not start. If the engine does not start, verify there are no other faults that can prohibit the engine from starting. Skip this step, and proceed to Step 2D.

Action

Start the engine and operate under normal driving conditions for at least 15 minutes, or until the coolant temperature is greater than 74°C [165°F].

  • Use INSITE™ electronic service tool to verify the fault code.

Fault Code 2387 active?
YES NO
No Repair

Fault Code 3616 is an information fault code indicating that the ECM has taken action to resolve a keyswitch ON condition.

Reference Fault Code 2387

Go to 3A

Guided Step 2C - Confirm the complaint.

Conditions

  • Turn keyswitch OFF.

Action

Review the customer complaint.

  • Establish whether the customer reported engine warm-up drivability complaints (low power, poor response, or low braking power).

Customer reported a drivability complaint with a cold engine?
YES NO
No Repair

Fault Code 3616 is an information fault code indicating that the ECM has taken action to resolve a keyswitch ON condition.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.

Action

Use a sector gear travel gauge, Part Number 4919281, or equivalent, to make sure the sector gear moves through its operational range.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

It may take considerable force to move the sector gear. If it can be moved by hand, this is considered acceptable. Do not use any hand tools.

Nozzle movement meet the requirements using the sector gear travel gauge in Procedure 010-134 in the Associated Procedures Table?

YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

Replace the turbocharger assembly.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

This malfunction can possibly have been caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect the base engine components for damage. The VGT actuator will be reused with the new or repaired turbocharger. Do not reinstall the actuator on the malfunctioning turbocharger.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete

Last Modified: 04-Oct-2016


FC3733 - Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3733 inactive?
STEP 2. | Check the heater. |
 | STEP 2A. Inspect the heater connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the heater. | Less than 3 ohms?
STEP 3. | Check the ECM and heater jumper harness. |
 | STEP 3A. Inspect the ECM and jumper harness connector and pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the jumper harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3733 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the heater.

Guided Step 2A - Inspect the heater connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heater from the jumper harness.

Action

Inspect the connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heater from the jumper harness.

Action

Check the heater resistance.

  • Measure the resistance in the heater between the supply pin and return pin in the heater connector.

Less than 3 ohms?
YES NO

Replace the heater.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and heater jumper harness.

Guided Step 3A - Inspect the ECM and jumper harness connector and pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the jumper harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or jumper harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the jumper harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the jumper harness from the heater.

Action

Check for an open circuit.

  • Measure the resistance between the jumper harness pins.
  • Measure the resistance between each pin and ground.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

  • Replace the jumper harness.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Nov-2013


FC3734 - Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3734 inactive?
STEP 2. | Check the heater. |
 | STEP 2A. Inspect the heater connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the heater. | Less than 3 ohms?
STEP 3. | Check the ECM and heater jumper harness. |
 | STEP 3A. Inspect the ECM and jumper harness connector and pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the jumper harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the jumper harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3734 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the heater.

Guided Step 2A - Inspect the heater connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heater from the jumper harness.

Action

Inspect the connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heater from the jumper harness.

Action

Check the heater resistance.

  • Measure the resistance in the heater between the supply pin and return pin in the heater connector.

Less than 3 ohms?
YES NO

Replace the heater.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and heater jumper harness.

Guided Step 3A - Inspect the ECM and jumper harness connector and pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the jumper harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or jumper harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the jumper harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the jumper harness from the heater.

Action

Check for an open circuit.

  • Measure the resistance between the jumper harness pin and the ECM connector pin.

Note: The jumper harness pins can be installed into either pin location in the ECM connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected.

  • Replace the jumper harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the jumper harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the jumper harness from the heater.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the jumper harness pins.
  • Measure the resistance between each pin and ground.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected.

  • Replace the jumper harness.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Nov-2013


FAULT CODE 4214 (CPL 3774 and 3775) - Aftertreatment Diesel Oxidation Catalyst System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM871 | 3666239
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX CM871 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM871 | 3666239

Cautions and Warnings

WARNING

During regeneration, exhaust gas temperature can reach 800°C [1500°F], and the exhaust system surface temperature can exceed 700°C [1300°F], which is hot enough to ignite or melt common materials, and to burn people. The exhaust and exhaust components can remain hot after the vehicle has stopped moving. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning this procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Active or inactive counts of Fault Code 3167 or 4283?
STEP 2. | Perform the Aftertreatment Maintenance Reset All procedure. |
 | STEP 2A. Perform the Aftertreatment Maintenance Reset All procedure. | Aftertreatment Maintenance Reset All procedure completed?
STEP 3. | Perform the stationary regeneration procedure. |
 | STEP 3A. Perform the stationary regeneration procedure. | Stationary regeneration started?
 | STEP 3B. Check for exhaust leaks while performing the stationary regeneration procedure. | Exhaust system leaks found?
 | STEP 3C. Perform the stationary regeneration procedure. | Fault Code 4214 inactive after running the stationary regeneration procedure?
 | STEP 3D. Check aftertreatment DPF restriction. | Aftertreatment DPF restriction within specifications?
STEP 4. | Check the engine control module (ECM) calibration. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 4214 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 3167 or 4283?
YES NO
No Repair

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Perform the Aftertreatment Maintenance Reset All procedure.

Guided Step 2A - Perform the Aftertreatment Maintenance Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu.

Go to 3A

Go to 3A

Guided Step 3 - Perform the stationary regeneration procedure.

Guided Step 3A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

Refer to Procedure 014-013 in the Associated Procedures Table.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM Diagnostics Tests.

Stationary regeneration started?
YES NO
No Repair

Reference the Stationary Regeneration - Will Not Activate or the Stationary Regeneration - Will Not Complete troubleshooting symptom trees in Section TS in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 3B

Go to 3B

Guided Step 3B - Check for exhaust leaks while performing the stationary regeneration procedure.

Conditions

  • Run the stationary regeneration procedure.

Action

Check the exhaust for leaks while the stationary regeneration procedure is running.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for leaking connections and damaged/leaking exhaust system components.

Exhaust system leaks found?
YES NO

Stop regeneration and allow the system to cool. Repair or replace the damaged exhaust system component(s).

 No Repair

Go to 3C

Go to 3C

Guided Step 3C - Perform the stationary regeneration procedure.

Conditions

  • Run stationary regeneration procedure.

Action

Check for active Fault Code 4214.

Fault Code 4214 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Reference the Stationary Regeneration - Will Not Activate or the Stationary Regeneration - Will Not Complete troubleshooting symptom trees in Section TS in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 4A

Go to 3A

Guided Step 3D - Check the aftertreatment DPF restriction.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the following sections of the Aftertreatment Diesel Particulate Filter Restriction Test.

  • Test.
  • Analyzing the data.

Refer to Procedure 011-085 in the Associated Procedures Table.

Aftertreatment DPF restriction within specifications?
YES NO
No Repair

Replace the DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

  • Reference the appropriate engine performance troubleshooting tree.

Go to 4A

Go to 4A

Guided Step 4 - Check the engine control module (ECM) calibration.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 4214 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 05-Mar-2014


FAULT CODE 4214 (Non CPL 3774 and 3775)- Aftertreatment Diesel Oxidation Catalyst System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM871 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM871 | 3666239

Cautions and Warnings

WARNING

During regeneration, exhaust gas temperature can reach 800°C [1500°F], and the exhaust system surface temperature can exceed 700°C [1300°F], which is hot enough to ignite or melt common materials, and to burn people. The exhaust and exhaust components can remain hot after the vehicle has stopped moving. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning this procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Active or inactive counts of Fault Code 3167 or 4283?
STEP 2. | Perform the Aftertreatment Maintenance Reset All procedure. |
 | STEP 2A. Perform the Aftertreatment Maintenance Reset All procedure. | Aftertreatment Maintenance Reset All procedure completed?
STEP 3. | Perform the stationary regeneration procedure. |
 | STEP 3A. Perform the stationary regeneration procedure. | Stationary regeneration started?
 | STEP 3B. Check for exhaust leaks while performing the stationary regeneration procedure. | Exhaust system leaks found?
 | STEP 3C. Perform the stationary regeneration procedure. | Fault Code 4214 inactive after running the stationary regeneration procedure?
STEP 4. | Check the engine control module (ECM) calibration. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 4214 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 3167 or 4283?
YES NO
No Repair

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Perform the Aftertreatment Maintenance Reset All procedure.

Guided Step 2A - Perform the Aftertreatment Maintenance Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu.

Go to 3A

Go to 3A

Guided Step 3 - Perform the stationary regeneration procedure.

Guided Step 3A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the aftertreatment stationary regeneration procedure.

Refer to Procedure 014-013 in the Associated Procedures Table.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM Diagnostics Tests.

Stationary regeneration started?
YES NO
No Repair

Reference the Stationary Regeneration - Will Not Activate or the Stationary Regeneration - Will Not Complete troubleshooting symptom trees in Section TS in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 3B

Go to 3B

Guided Step 3B - Check for exhaust leaks while performing the stationary regeneration procedure.

Conditions

  • Run the stationary regeneration procedure.

Action

Check the exhaust for leaks while the stationary regeneration procedure is running.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for leaking connections and damaged/leaking exhaust system components.

Exhaust system leaks found?
YES NO

Stop regeneration and allow the system to cool. Repair or replace the damaged exhaust system component(s).

 No Repair

Go to 3C

Go to 3C

Guided Step 3C - Perform the stationary regeneration procedure.

Conditions

  • Run stationary regeneration procedure.

Action

Check for active Fault Code 4214.

Fault Code 4214 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Reference the Stationary Regeneration - Will Not Activate or the Stationary Regeneration - Will Not Complete troubleshooting symptom trees in Section TS in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 4A

Go to 3A

Guided Step 4 - Check the engine control module (ECM) calibration.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 4214 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 04-Mar-2014


FAULT CODE 4282 - Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX CM871 | 3666239
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISM CM876 | 3666322
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISX CM871 | 3666239
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISM CM876 | 3666322
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM871 | 3666239
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISM CM876 | 3666322
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM871 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | ISM CM876 | 3666322

Cautions and Warnings

WARNING

During regeneration, exhaust gas temperature can reach 800°C [1500°F], and exhaust system surface temperature can exceed 700°C [1300°F], which is hot enough to ignite or melt common materials, and to burn people. The exhaust and exhaust components can remain hot after the vehicle has stopped moving. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning this procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3167, 4214, or 4283 active?
STEP 2. | Perform the Aftertreatment Maintenance Reset All procedure. |
 | STEP 2A. Perform the Aftertreatment Maintenance Reset All procedure. | Aftertreatment Maintenance Reset All procedure completed?
 | STEP 2B. Perform the aftertreatment system test. | Aftertreatment fuel injector meet the specifications?
 | STEP 2C. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meet the specifications?
STEP 3. | Perform the stationary regeneration procedure. |
 | STEP 3A. Perform the stationary regeneration procedure. | Stationary regeneration started?
 | STEP 3B. Check for exhaust leaks while performing the stationary regeneration procedure. | Exhaust system leaks found?
 | STEP 3C. Perform the stationary regeneration procedure. | Fault code inactive after running the stationary regeneration procedure?
STEP 4. | Check the engine control module (ECM) calibration. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Aftertreatment related fault codes inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3167, 4214, or 4283 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Perform the Aftertreatment Maintenance Reset All procedure.

Guided Step 2A - Perform the Aftertreatment Maintenance Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu.

Go to 2B

Go to 2B

Guided Step 2B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment system test.

  • Refer to Procedure 011-054 in the Associated Procedures Table.

It is only necessary to perform the flow test; the leak test is unnecessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Clean the aftertreatment injector.

  • Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 2C

Guided Step 2C - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment system test.

  • Refer to Procedure 011-054 in the Associated Procedures Table.

It is only necessary to perform the flow test; the leak test is not necessary.

Does the aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Replace the aftertreatment fuel injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Perform the stationary regeneration procedure.

Guided Step 3A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment stationary regeneration procedure.

Refer to Procedure 014-013 in the Associated Procedures Table.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM Diagnostics Tests.

Stationary regeneration started?
YES NO
No Repair

Reference the Stationary Regeneration - Will Not Activate or the Stationary Regeneration - Will Not Complete troubleshooting symptom trees in Section TS of the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, QSM11 Service Manual, Bulletin 3666322.

Go to 3B

Go to 3B

Guided Step 3B - Check for exhaust leaks while performing the stationary regeneration procedure.

Conditions

  • Perform stationary regeneration procedure.

Action

Check the exhaust for leaks while the stationary regeneration procedure is running.

  • Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for leaking connections and damaged/leaking exhaust system components.

Exhaust system leaks found?
YES NO

Stop regeneration and allow the system to cool. Repair or replace the damaged exhaust system component(s).

 No Repair

Go to 3C

Go to 3C

Guided Step 3C - Perform the stationary regeneration procedure.

Conditions

  • Perform stationary regeneration procedure.

Action

Check for active Fault Code 4282.

Fault Code 4282 inactive after running the stationary regeneration procedure?
YES NO
No Repair

Reference the Stationary Regeneration - Will Not Activate or the Stationary Regeneration - Will Not Complete troubleshooting symptom trees in Section TS of the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, or the ISM, ISMe, QSM11 Service Manual, Bulletin 3666322.

Go to 4A

Go to 3A

Guided Step 4 - Check the ECM calibration.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Aftertreatment related fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 12-Mar-2014


FAULT CODE 4283 - Aftertreatment Doser - Data Valid But Below Normal Operating Range - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISX CM871 | 3666239
Aftertreatment Fuel Injector | Refer to Procedure 011-042 | ISM CM876 | 3666322
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | ISX CM871 | 3666239
Aftertreatment Fuel Shutoff Manifold | Refer to Procedure 011-052 | ISM CM876 | 3666322
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISX CM871 | 3666239
Aftertreatment Fuel Injector Flow | Refer to Procedure 011-054 | ISM CM876 | 3666322
Aftertreatment Testing | Refer to Procedure 014-013 | ISX CM871 | 3666239
Aftertreatment Testing | Refer to Procedure 014-013 | ISM CM876 | 3666322

Cautions and Warnings

WARNING

During regeneration, exhaust gas temperature can reach 800°C [1500°F], and exhaust system surface temperature can exceed 700°C [1300°F], which is hot enough to ignite or melt common materials, and to burn people. The exhaust and exhaust components can remain hot after the vehicle has stopped moving. To avoid the risk of fire, property damage, burns or other serious personal injury, allow the exhaust system to cool before beginning this procedure or repair and make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1923, 1924, 1925, 1926, 1927, 1928, 1932, 1963, 1977, 2728, 2732, 2733, 2741, 2878, or 2881 active or inactive?
STEP 2. | Check the aftertreatment fuel injector. |
 | STEP 2A. Perform the Aftertreatment Maintenance Reset All procedure. | Aftertreatment Maintenance Reset All procedure completed?
 | STEP 2B. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meet the specifications?
 | STEP 2C. Check the flow of the aftertreatment fuel injector. | Aftertreatment fuel injector meet the specifications?
STEP 3. | Check the aftertreatment fuel drain valve. |
 | STEP 3A. Check the aftertreatment fuel drain valve. | Aftertreatment fuel drain valve and aftertreatment fuel shutoff valve location changed?
 | STEP 3B. Perform the stationary regeneration procedure. | Fault Code 1925 active or inactive?
STEP 4. | Check the engine control module (ECM) calibration. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1923, 1924, 1925, 1926, 1927, 1928, 1932, 1963, 1977, 2728, 2732, 2733, 2741, 2878, or 2881 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Perform the Aftertreatment Maintenance Reset All procedure.

Guided Step 2A - Perform the Aftertreatment Maintenance Reset All procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset All procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

Performing this step may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

Aftertreatment Maintenance Reset All procedure completed?
YES NO
No Repair

Use INSITE™ electronic service tool to perform the Aftertreatment Maintenance Reset All procedure under the ECM Diagnostics Tests menu.

Go to 2B

Go to 2B

Guided Step 2B - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment system test.

  • Refer to Procedure 011-054 in the Associated Procedures Table.

It is only necessary to perform the flow test; the leak test is unnecessary.

Aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Clean the aftertreatment injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 2C

Guided Step 2C - Check the flow of the aftertreatment fuel injector.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment system test.

  • Refer to Procedure 011-054 in the Associated Procedures Table.

It is only necessary to perform the flow test; the leak test is not necessary.

Aftertreatment fuel injector meet the specifications?
YES NO
No Repair

Replace the aftertreatment fuel injector. Refer to Procedure 011-042 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment fuel drain valve.

Guided Step 3A - Check the aftertreatment fuel drain valve.

Conditions

  • Turn keyswitch OFF.

Action

Swap the location of the aftertreatment fuel drain valve and the aftertreatment fuel shutoff valve in the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-052 in the Associated Procedures Table.

  • Use INSITE™ electronic service tool to perform the Aftertreatment Diesel Particulate Filter Regeneration Test found in the ECM Diagnostics Tests.

Aftertreatment fuel drain valve and aftertreatment fuel shutoff valve location changed?
YES NO
No Repair

Swap the location of the aftertreatment fuel drain valve and aftertreatment fuel shutoff valve in the aftertreatment fuel shutoff manifold. Refer to Procedure 011-052 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Perform the aftertreatment stationary regeneration procedure.

Conditions

  • Run the aftertreament stationary regeneration procedure.

Action

Check for an active or inactive Fault Code 1925.

.

Fault Code 1925 active or inactive?
YES NO

Replace the aftertreatment fuel drain valve and return the aftertreament fuel shutoff valve to the original location. Refer to Procedure 011-052 in the Associated Procedures Table.

Return the aftertreatment fuel drain valve and aftertreatment fuel shutoff valve to the original location in the aftertreatment fuel shutoff manifold. Refer to Procedure 011-052 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-May-2014


INDEX
16-fc111.htm

16-t05-111.htm

16-fc115.htm

16-t05-115.htm

16-fc122.htm

16-t05-122.htm

16-fc123.htm

16-t05-123.htm

16-fc125.htm

16-t05-125.htm

16-fc131.htm

16-t05-131.htm

16-fc132.htm

16-t05-132.htm

16-fc133.htm

16-t05-133.htm

16-fc134.htm

16-t05-134.htm

16-fc135.htm

16-t05-135.htm

16-fc141.htm

16-t05-141.htm

16-fc143.htm

16-t05-143.htm

16-fc144.htm

16-t05-144.htm

16-fc145.htm

16-t05-145.htm

16-fc146.htm

16-t05-146.htm

16-fc151.htm

16-t05-151.htm

16-fc153.htm

16-t05-153.htm

16-fc154.htm

16-t05-154.htm

16-fc155.htm

16-t05-155.htm

16-fc187.htm

16-fc187ism.htm

16-t05-187ism.htm

16-fc187isx.htm

16-t05-187isx.htm

16-fc195.htm

16-fc195-2wire.htm

16-t05-195-2wire.htm

16-fc195-3wire.htm

16-t05-195-3wire.htm

16-fc196.htm

16-fc196-2wire.htm

16-t05-196-2wire.htm

16-fc196-3wire.htm

16-t05-196-3wire.htm

16-fc197.htm

16-t05-197.htm

16-fc212.htm

16-t05-212.htm

16-fc213.htm

16-t05-213.htm

16-fc214.htm

16-t05-214.htm

16-fc221.htm

16-t05-221.htm

16-fc222.htm

16-t05-222.htm

16-fc227.htm

16-t05-227.htm

16-fc234.htm

16-t05-234.htm

16-fc238.htm

16-t05-238.htm

16-fc241.htm

16-t05-241.htm

16-fc242.htm

16-t05-242.htm

16-fc245.htm

16-t05-245.htm

16-fc249.htm

16-t05-249.htm

16-fc254.htm

16-t05-254.htm

16-fc255.htm

16-t05-255.htm

16-fc256.htm

16-t05-256.htm

16-fc257.htm

16-fc257ism.htm

16-t05-257ism.htm

16-fc257isx.htm

16-t05-257isx.htm

16-fc263.htm

16-t05-263.htm

16-fc265.htm

16-t05-265.htm

16-fc285.htm

16-t05-285.htm

16-fc286.htm

00-t05-286.htm

16-fc287.htm

16-t05-287.htm

16-fc288.htm

16-t05-288.htm

16-fc295.htm

16-t05-295.htm

16-fc311.htm

16-t05-311.htm

16-fc312.htm

16-t05-312.htm

16-fc313.htm

16-t05-313.htm

16-fc314.htm

16-t05-314.htm

16-fc315.htm

16-t05-315.htm

16-fc319.htm

16-t05-319.htm

16-fc321.htm

16-t05-321.htm

16-fc322.htm

16-t05-322.htm

16-fc323.htm

16-t05-323.htm

16-fc324.htm

16-t05-324.htm

16-fc325.htm

16-t05-325.htm

16-fc331.htm

16-t05-331.htm

16-fc332.htm

16-t05-332.htm

16-fc338.htm

16-t05-338.htm

16-fc339.htm

16-t05-339.htm

16-fc343.htm

16-t05-343.htm

16-fc346.htm

16-t05-346.htm

16-fc351.htm

16-t05-351.htm

16-fc352.htm

16-t05-352.htm

16-fc386.htm

16-t05-386.htm

16-fc415.htm

16-t05-415.htm

16-fc418.htm

16-t05-418.htm

16-fc421.htm

00-t05-421.htm

16-fc427.htm

16-t05-427.htm

16-fc428.htm

16-t05-428.htm

16-fc429.htm

16-t05-429.htm

16-fc435.htm

16-t05-435.htm

16-fc441.htm

16-t05-441.htm

16-fc442.htm

16-t05-442.htm

16-fc482.htm

16-t05-482.htm

16-fc546.htm

16-t05-546.htm

16-fc547.htm

16-t05-547.htm

16-fc555.htm

16-t05-555.htm

16-fc556.htm

16-t05-556.htm

16-fc584.htm

16-t05-584.htm

16-fc585.htm

16-t05-585.htm

16-fc596.htm

16-t05-596.htm

16-fc597.htm

16-t05-597.htm

16-fc598.htm

16-t05-598.htm

16-fc629.htm

16-t05-629.htm

16-fc649.htm

16-t05-649.htm

16-fc686.htm

16-t05-686.htm

16-fc687.htm

16-t05-687.htm

16-fc689.htm

16-fc689ism.htm

16-t05-689ism.htm

16-fc689isx.htm

16-t05-689isx.htm

16-fc691.htm

16-t05-691.htm

16-fc692.htm

16-t05-692.htm

16-fc697.htm

16-t05-697.htm

16-fc698.htm

16-t05-698.htm

16-fc731.htm

16-t05-731.htm

16-fc778.htm

16-fc778ism.htm

16-t05-778ism.htm

16-fc778isx.htm

16-t05-778isx.htm

16-fc784.htm

16-t05-784.htm

16-fc1117.htm

16-t05-1117.htm

16-fc1239.htm

16-t05-1239.htm

16-fc1241.htm

16-t05-1241.htm

16-fc1242.htm

16-t05-1242.htm

16-fc1663.htm

16-t05-1663.htm

16-fc1664.htm

16-t05-1664.htm

16-fc1665.htm

16-t05-1665.htm

16-fc1666.htm

16-t05-1666.htm

16-fc1667.htm

16-t05-1667.htm

16-fc1674.htm

16-t05-1674.htm

16-fc1675.htm

16-t05-1675.htm

16-fc1676.htm

16-t05-1676.htm

16-fc1691.htm

16-t05-1691.htm

16-fc1695.htm

16-t05-1695.htm

16-fc1696.htm

16-t05-1696.htm

16-fc1843.htm

16-t05-1843.htm

16-fc1844.htm

16-t05-1844.htm

16-fc1866.htm

16-t05-1866.htm

16-fc1876.htm

16-t05-1876.htm

16-fc1877.htm

16-t05-1877.htm

16-fc1878.htm

16-t05-1878.htm

16-fc1879.htm

16-t05-1879.htm

16-fc1881.htm

16-t05-1881.htm

16-fc1883.htm

16-t05-1883.htm

16-fc1893.htm

16-t05-1893.htm

16-fc1895.htm

16-t05-1895.htm

16-fc1896.htm

16-t05-1896.htm

16-fc1899.htm

16-t05-1899.htm

16-fc1921.htm

16-t05-1921.htm

16-fc1922.htm

16-t05-1922.htm

16-fc1923.htm

16-t05-1923.htm

16-fc1924.htm

16-t05-1924.htm

16-fc1925.htm

16-fc1925ism.htm

16-t05-1925ism.htm

16-fc1925isx.htm

16-t05-1925isx.htm

16-fc1926.htm

16-t05-1926.htm

16-fc1927.htm

16-t05-1927.htm

16-fc1928.htm

16-t05-1928.htm

16-fc1932.htm

16-t05-1932.htm

16-fc1933.htm

16-t05-1933.htm

16-fc1934.htm

16-t05-1934.htm

16-fc1935.htm

16-t05-1935.htm

16-fc1938.htm

16-t05-1938.htm

16-fc1942.htm

16-t05-1942.htm

16-fc1943.htm

16-t05-1943.htm

16-fc1961.htm

16-t05-1961.htm

16-fc1962.htm

16-t05-1962.htm

16-fc1963.htm

16-fc1963ism.htm

16-t05-1963ism.htm

16-fc1963isx.htm

16-t05-1963isx.htm

16-fc1966.htm

16-t05-1966.htm

16-fc1968.htm

16-t05-1968.htm

16-fc1969.htm

16-t05-1969.htm

16-fc1972.htm

16-t05-1972.htm

16-fc1973.htm

16-t05-1973.htm

16-fc1974.htm

16-t05-1974.htm

16-fc1977.htm

16-t05-1977.htm

16-fc1981.htm

16-fc1981cpl_3774_3775.htm

16-t05-1981cpl_3774_3775.htm

16-fc1981non_cpl_3774_3775.htm

16-t05-1981non_cpl_3774_3775.htm

16-fc1992.htm

16-t05-1992.htm

16-fc1993.htm

16-t05-1993.htm

16-fc2182.htm

16-t05-2182.htm

16-fc2183.htm

16-t05-2183.htm

16-fc2185.htm

16-t05-2185.htm

16-fc2186.htm

16-t05-2186.htm

16-fc2195.htm

16-t05-2195.htm

16-fc2198.htm

16-t05-2198.htm

16-fc2215.htm

16-t05-2215.htm

16-fc2216.htm

16-t05-2216.htm

16-fc2272.htm

16-t05-2272.htm

16-fc2273.htm

16-t05-2273.htm

16-fc2274.htm

16-t05-2274.htm

16-fc2288.htm

16-t05-2288.htm

16-fc2311.htm

16-t05-2311.htm

16-fc2312.htm

16-t05-2312.htm

16-fc2313.htm

16-t05-2313.htm

16-fc2314.htm

16-t05-2314.htm

16-fc2319.htm

16-t05-2319.htm

16-fc2321.htm

16-t05-2321.htm

16-fc2322.htm

16-t05-2322.htm

16-fc2345.htm

16-t05-2345.htm

16-fc2346.htm

16-t05-2346.htm

16-fc2347.htm

16-t05-2347.htm

16-fc2349.htm

16-t05-2349.htm

16-fc2351.htm

16-t05-2351.htm

16-fc2357.htm

16-t05-2357.htm

16-fc2359.htm

16-t05-2359.htm

16-fc2363.htm

16-fc2363ism.htm

16-t05-2363ism.htm

16-fc2363isx.htm

16-t05-2363isx.htm

16-fc2365.htm

16-t05-2365.htm

16-fc2367.htm

16-fc2367ism.htm

16-t05-2367ism.htm

16-fc2367isx.htm

16-t05-2367isx.htm

16-fc2368.htm

16-t05-2368.htm

16-fc2372.htm

16-t05-2372.htm

16-fc2373.htm

16-t05-2373.htm

16-fc2374.htm

16-t05-2374.htm

16-fc2375.htm

16-t05-2375.htm

16-fc2376.htm

16-t05-2376.htm

16-fc2377.htm

16-t05-2377.htm

16-fc2387.htm

16-t05-2387.htm

16-fc2412.htm

16-t05-2412.htm

16-fc2448.htm

16-t05-2448.htm

16-fc2449.htm

16-t05-2449.htm

16-fc2451.htm

16-t05-2451.htm

16-fc2551.htm

16-t05-2551.htm

16-fc2552.htm

16-t05-2552.htm

16-fc2554.htm

16-t05-2554.htm

16-fc2634.htm

16-t05-2634.htm

16-fc2635.htm

16-t05-2635.htm

16-fc2636.htm

16-t05-2636.htm

16-fc2637.htm

16-t05-2637.htm

16-fc2638.htm

16-t05-2638.htm

16-fc2639.htm

16-t05-2639.htm

16-fc2646.htm

16-t05-2646.htm

16-fc2659.htm

16-t05-2659.htm

16-fc2728.htm

16-t05-2728.htm

16-fc2732.htm

16-t05-2732.htm

16-fc2733.htm

16-t05-2733.htm

16-fc2738.htm

16-t05-2738.htm

16-fc2739.htm

16-t05-2739.htm

16-fc2741.htm

16-t05-2741.htm

16-fc2742.htm

16-t05-2742.htm

16-fc2743.htm

16-t05-2743.htm

16-fc2754.htm

16-t05-2754.htm

16-fc2764.htm

16-t05-2764.htm

16-fc2774.htm

16-t05-2774.htm

16-fc2777.htm

16-t05-2777.htm

16-fc2789.htm

16-t05-2789.htm

16-fc2813.htm

16-t05-2813.htm

16-fc2878.htm

16-fc2878ism.htm

16-t05-2878ism.htm

16-fc2878isx.htm

16-t05-2878isx.htm

16-fc2879.htm

16-fc2879ism.htm

16-t05-2879ism.htm

16-fc2879isx.htm

16-t05-2879isx.htm

16-fc2881.htm

16-t05-2881.htm

16-fc2961.htm

16-t05-2961.htm

16-fc2962.htm

16-t05-2962.htm

16-fc2963.htm

16-t05-2963.htm

16-fc2964.htm

16-t05-2964.htm

16-fc2973.htm

16-t05-2973.htm

16-fc3167.htm

16-t05-3167.htm

16-fc3348.htm

16-t05-3348.htm

16-fc3374.htm

16-t05-3374.htm

16-fc3385.htm

16-t05-3385.htm

16-fc3488.htm

16-t05-3488.htm

16-fc3616.htm

16-t05-3616.htm

16-fc3733.htm

16-t05-3733.htm

16-fc3734.htm

16-t05-3734.htm

16-fc4214.htm

16-fc4214cpl_3774_3775.htm

16-t05-4214cpl_3774_3775.htm

16-fc4214non_cpl_3774_3775.htm

16-t05-4214non_cpl_3774_3775.htm

16-fc4282.htm

16-t05-4282.htm

16-fc4283.htm

16-t05-4283.htm