ISM11 CM875

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111 .

Last Modified: 13-Dec-2020
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | None on performance.
Engine Control Module (ECM) Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the primary ECM power supply dropped below a calibratible value while the keyswitch was in the ON position.

The power down sequence was interrupted by a premature ECM shutdown.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Refer to Troubleshooting Fault Code 1117 .

Last Modified: 13-Dec-2020


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | The ECM has detected the primary and backup speed sensor signals are connected backwards. | None on performance.
Engine Speed Sensor & Engine Position Sensor

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

Both engine speed/position sensors are located on the back side of the front gear housing above the fuel pump drive.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServeâ„¢ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

Refer to Troubleshooting Fault Code 115 .

Last Modified: 13-Dec-2020


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the intake manifold pressure circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold pressure sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServeâ„¢ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 122 .

Last Modified: 13-Dec-2020


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected in the intake manifold pressure sensor circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold pressure sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Verify the engine control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM.

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 123 .

Last Modified: 13-Dec-2020


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: S385 SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. Both position sensors receive a 5 volt supply from the ECM. The signal voltage from accelerator pedal position sensor 1 is twice as much as the signal voltage from the accelerator pedal position sensor 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5-VDC supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Damaged accelerator pedal position sensor.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1239 .

Last Modified: 13-Dec-2020


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: S385 SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. Both position sensors receive a 5 volt supply from the ECM. The signal voltage from accelerator pedal position sensor 1 is twice as much as the signal voltage from the accelerator pedal position sensor 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the harness or sensor
  • Damaged accelerator pedal position sensor.
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1241 .

Last Modified: 13-Dec-2020


Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P91 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator position sensor number 1 and number 2 are reading different values. | Engine will only idle.
Accelerator Pedal or Lever Position Sensor Circuits

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. Both position sensors receive a 5 volt supply from the ECM. The signal voltage from accelerator pedal position sensor 1 is twice as much as the signal voltage from the accelerator pedal position sensor 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the readings between the accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.Possible causes of the fault include:

Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2

Accelerator pedal position sensor number 1 and accelerator pedal position sensor number 2 signal wires are shorted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1242 .

Last Modified: 13-Dec-2020


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: P102 SPN: 102 FMI: 1/18 LAMP: Amber SRT: | Intake manifold pressure is below the minimum operating limit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold pressure sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was below the expected level for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Verify the engine control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM.

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too low for the present engine operating conditions. The ECM commands a charge flow command and the VGT and EGR valve move to meet this command. If the engine is unable to achieve the desired oxygen level necessary for complete combustion, this fault code is logged.

Possible causes of this fault code include:

  • Leaks in the air intake system between the turbocharger and intake manifold
  • A damaged intake manifold pressure sensor
  • Malfunctioning or damaged barometric pressure sensor.
  • Restriction in the charge-air cooler
  • Leaks or restrictions in the EGR system plumbing
  • Fuel inlet restriction too high (normally caused by a restricted fuel filter).
  • Plugging or restriction in the exhaust gas pressure sensor tube

Stuck in-range exhaust gas pressure sensor reading

Refer to Troubleshooting Fault Code 125 .

Last Modified: 13-Dec-2020


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P91 SPN: 91 FMI: 3/3 LAMP: Red SRT: | High voltage detected at accelerator pedal position number 1 circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

  • Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Malfunctioning accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 131 .

Last Modified: 13-Dec-2020


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P91 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at accelerator pedal position number 1 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Verify the engine control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM.

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

The accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM wiring harness or sensor.
  • Damaged accelerator pedal or lever position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 132 .

Last Modified: 13-Dec-2020


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

  • Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open remote accelerator pedal or lever return circuit in the harness or connections
  • Remote accelerator supply shorted to battery
  • Malfunctioned remote accelerator pedal or lever position sensor.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 133 .

Last Modified: 13-Dec-2020


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

  • Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Malfunctioned remote accelerator pedal or lever position sensor.
  • Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 134 .

Last Modified: 13-Dec-2020


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 135 .

Last Modified: 13-Dec-2020


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 141 .

Last Modified: 13-Dec-2020


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code 143 .

Last Modified: 13-Dec-2020


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144 .

Last Modified: 13-Dec-2020


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the engine coolant temperature sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 145 .

Last Modified: 13-Dec-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the applicable engine service manual.

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS

Refer to Troubleshooting Fault Code 146 .

Last Modified: 13-Dec-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS

Refer to Troubleshooting Fault Code 151 .

Last Modified: 13-Dec-2020


Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the electronic control. The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature SIGNAL circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
Refer to Troubleshooting Fault Code 153 .

Last Modified: 01-Apr-2021


Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the electronic control. The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature SIGNAL circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154 .

Last Modified: 01-Apr-2021


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the electronic control. The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature SIGNAL circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold air temperature was greater than 132°C [270°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155 .

Last Modified: 13-Dec-2020


Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1866

Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1866 PID: P411 SPN: 411 FMI: 2/2 LAMP: Amber SRT: | An error in the EGR delta pressure signal was detected at initial key ON or the sensor failed the autozero test. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted on the EGR mass measurement assembly.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF when the following conditions are met:

Engine coolant temperature is 68°C [154°F] or higher.

Intake manifold air temperature is 7°C [44°F] or higher.

Keyswitch transitions from ON to OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure sensor was reading higher or lower than a calibratable value when the keyswitch was turned OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This check is only performed at keyswitch OFF, during the ECM powerdown. During this diagnostic check, the ECM monitors the value of the EGR differential pressure sensor. If this value is outside of a specified range, Fault Code 1866 is set active.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor.
  • High resistance in the wiring harness on the signal or return wire.
Refer to Troubleshooting Fault Code 1866 .

Last Modified: 13-Dec-2020


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the sensor supply 2 circuit. | Engine power derate.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.
  • The backup camshaft position sensor will not be functional.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

  • Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running.

Refer to Troubleshooting Fault Code 187 .

Last Modified: 13-Dec-2020


Exhaust Gas Recirculation Differential Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1899

Exhaust Gas Recirculation Differential Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1899 PID: P411 SPN: 411 FMI: 1/18 LAMP: Amber SRT: | The EGR differential pressure sensor has detected low EGR gas flow or the EGR differential pressure reading is not valid for engine operating conditions. | EGR valve actuation will be disabled.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The sensor is located near the air intake.

Conditions for Running the Diagnostics

This diagnostic runs when the following conditions are met:

This diagnostic runs continuously when the engine speed is greater than 1200 RPM.

Engine torque output is greater than a calibrated value.

EGR valve position is greater than 5 percent open.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the EGR differential pressure sensor output was less than a calibratable value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This diagnostic checks the reading of the EGR differential pressure sensor when the engine is idling. At idle, the EGR valve is nearly closed and EGR flow is very low. During this condition the reading of the EGR differential pressure is compared against an expected value, and a fault is logged if measured value exceeds the expected value by more than the allowable tolerance.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor.
  • A leaking or malfunctioning EGR differential pressure sensor
  • A plugged or restricted EGR cooler.

Stuck closed EGR valve

Refer to Troubleshooting Fault Code 1899 .

Last Modified: 13-Dec-2020


Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 1943

Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1943 PID: S372 SPN: 3555 FMI: 1/17 LAMP: None SRT: | Engine torque has been reduced because the vehicle was operating at a high altitude condition. | Possible reduced engine performance.
Barometric Pressure Circuit

Circuit Description

The engine control module (ECM) monitors the ambient air pressure using either an ambient air pressure sensor or a combination turbocharger compressor intake pressure/temperature sensor. These sensors respond to pressure changes in the atmosphere, which occur based on the elevation where the engine is currently operating. This pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The ambient air or compressor intake pressure sensor provides a signal to the ECM on the pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure reading was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Engine torque output will be limited due to the engine operating at high altitude conditions.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When the engine has been operated in a high altitude location, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating in the high altitude location to protect the turbocharger and engine from excessively high exhaust temperatures. The derate limits the torque output of the engine to keep the temperatures below the maximum temperature limits.

Note: This fault code will most likely not be active with no load in the shop. The engine must be under the same operating condition (altitude and temperature) at the time that it had originally logged.

Refer to Troubleshooting Fault Code 1943 .

Last Modified: 13-Dec-2020


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine coolant level sensor circuit. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or battery voltage.
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 195 .

Last Modified: 13-Dec-2020


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine coolant level sensor circuit. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal circuit shorted to ground in the engine harness, connector, or sensor

  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 196 .

Last Modified: 13-Dec-2020


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code 197 .

Last Modified: 13-Dec-2020


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or an open circuit detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 212 .

Last Modified: 13-Dec-2020


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 213 .

Last Modified: 13-Dec-2020


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine oil temperature was above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 214 .

Last Modified: 13-Dec-2020


Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

FAULT CODE 2195

Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2195 PID: S51 SPN: 703 FMI: 14/14 LAMP: Red SRT: | The emergency door of the vehicle has been detected open. | Engine may be shut down.
Engine Control Module (ECM)

Circuit Description

Some applications use the OEM switch input to drive an engine protection event in the form of an emergency engine shutoff switch, engine compartment cover location switch, or similar.

Component Location

Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the OEM switch input changed state and activated the engine protection settings.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This diagnostic will operate differently for every application.

Refer to Troubleshooting Fault Code 2195 .

Last Modified: 13-Dec-2020


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault code include:

  • A short circuit to battery in the engine wiring harness.
  • An open return circuit in the engine wiring harness.
  • A malfunctioning barometric air pressure sensor
Refer to Troubleshooting Fault Code 221 .

Last Modified: 13-Dec-2020


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 222 .

Last Modified: 13-Dec-2020


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.
  • The backup camshaft position sensor will not be functional.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

  • High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.
Refer to Troubleshooting Fault Code 227 .

Last Modified: 13-Dec-2020


EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P27 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage has been detected at the EGR valve position sensor circuit. | EGR valve actuation will be disabled.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 data link. The EGR valve performs its own internal diagnostics and reports failures back to the primary engine ECM using the J1939 data link.

The fueling actuators are commanded by the electronic control module (ECM) to control fuel metering. Each fueling actuator is connected to the ECM by a fueling actuator (+) and fueling actuator (-) wire. An electrical signal is sent to the fueling actuator from the ECM on the (+) wire and is returned to the ECM on the (-) wire. Each actuator is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The EGR valve position sensor is internal to the EGR valve assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve position sensor signal voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

  • EGR valve position sensor wiring shorted to ground, open circuit, or shorted to power supply.
  • Loss of the EGR valve position sensor supply voltage or the ground circuit.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged EGR Valve
Refer to Troubleshooting Fault Code 2272 .

Last Modified: 12-Sep-2021


Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2273

Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2273 PID: P411 SPN: 411 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the EGR differential pressure sensor circuit. | EGR valve actuation will be disabled.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted on the EGR mass measurement assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR pressure sensor voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the EGR differential pressure sensor is used.

  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • A damaged EGR differential pressure sensor.
Refer to Troubleshooting Fault Code 2273 .

Last Modified: 13-Dec-2020


Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2274

Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2274 PID: P411 SPN: 411 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the EGR differential pressure sensor circuit. | EGR valve actuation will be disabled.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted on the EGR mass measurement assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR outlet pressure sensor voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the EGR differential pressure sensor is used.

  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.

A malfunctioning EGR differential pressure sensor.

Refer to Troubleshooting Fault Code 2274 .

Last Modified: 13-Dec-2020


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2288

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2288 PID: P103 SPN: 103 FMI: 0/15 LAMP: None SRT: | High turbocharger speed has been detected by the ECM. | Engine power derate.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was above the maximum calibratible limits.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The ECM will reduce the torque output of the engine to reduce turbocharger speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

When the engine has taken the necessary action to reduce the turbocharger speed, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating near the maximum turbocharger speed limits.

Refer to Troubleshooting Fault Code 2288 .

Last Modified: 13-Dec-2020


Exhaust Back Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2319

Exhaust Back Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2319 PID: S34 SPN: 648 FMI: 1/18 LAMP: Amber SRT: | Low exhaust back pressure detected. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

The diagnostic runs continuously when engine speed is greater than 700 rpm.

Conditions for Setting the Fault Codes

The ECM detects that the exhaust back pressure is below a calibrated value

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Refer to Troubleshooting Fault Code 2319 .

Last Modified: 13-Dec-2020


Turbocharger 1 Speed - Abnormal Rate of Change

FAULT CODE 2345

Turbocharger 1 Speed - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2345 PID: P103 SPN: 103 FMI: 10/10 LAMP: Amber SRT: | High turbocharger speed has been detected. | None on performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was greater than the speed that is physically achievable by the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Refer to Troubleshooting Fault Code 2345 .

Last Modified: 13-Dec-2020


Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2346

Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2346 PID: S384 SPN: 2789 FMI: 0/15 LAMP: None SRT: | Turbocharger turbine intake temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas temperature is calculated by the engine control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger, and is also known as turbine intake temperature.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the turbine intake temperature was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Fuel is limited in an attempt to decrease the temperature of the exhaust gas entering the turbocharger.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is an information fault code, indicating that the engine has been derated for high turbine intake temperature (exhaust temperature). No troubleshooting is necessary for this fault code. It is only an indicator that the engine power was derated to limit the exhaust temperature.

If the condition continues to exist, Fault Code 2451 will become active.

Refer to Troubleshooting Fault Code 2346 .

Last Modified: 13-Dec-2020


Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2347

Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2347 PID: P404 SPN: 2629 FMI: 0/15 LAMP: None SRT: | High turbocharger compressor outlet air temperature has been calculated by the engine control module (ECM). | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The turbocharger compressor outlet air temperature is calculated by the electronic control module (ECM). Turbocharger compressor outlet air temperature is calculated by the ECM, based on engine operating conditions such as turbocharger compressor inlet air temperature, barometric pressure, engine speed, intake manifold air temperature, and intake manifold pressure.

Component Location

There is not a physical turbocharger compressor outlet temperature sensor in the system. The turbocharger compressor outlet air temperature is a calculation of temperature of the air after it is compressed by the turbocharger compressor, but before exhaust gas recirculation (EGR) is mixed into the system, and before it enters the charge-air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the turbocharger compressor outlet temperature was greater than 250°C [482°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Fuel is limited in an attempt to decrease the calculated compressor outlet temperature.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Air intake leaks allowing hot under-hood air to enter the intake system

Faulty intake manifold pressure readings

High turbocharger speed readings

Faulty barometric pressure readings

Stuck variable geometry turbocharger.

Note: Unless the issue is a malfunctioning barometric pressure sensor or intake manifold pressure sensor, this fault code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code, and to determine if the malfunction has been found and repaired.

Refer to Troubleshooting Fault Code 2347 .

Last Modified: 13-Dec-2020


EGR Valve Position Circuit - Out of Calibration

FAULT CODE 2348

EGR Valve Position Circuit - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2348 PID: P27 SPN: 27 FMI: 13/13 LAMP: Amber SRT: | The EGR valve has failed the automatic calibration procedure at initial key ON. | Possibly hard to start or low power. Engine could possibly not start.
EGR Valve Circuit

Circuit Description

The engine control module (ECM) uses the EGR valve position sensor to determine whether or not the valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM, based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-opened valve is equivalent to 100 percent.

Component Location

The EGR valve position sensor is mounted on the EGR valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve failed the autozero span check.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged EGR Valve
  • Malfunctioning or damaged engine wiring harness
Refer to Troubleshooting Fault Code 2348 .

Last Modified: 01-May-2022


EGR Valve Control Circuit - Current Below Normal or Open Circuit

FAULT CODE 2349

EGR Valve Control Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2349 PID: S146 SPN: 2791 FMI: 5/5 LAMP: Amber SRT: | Motor terminal or motor coil open circuit has been detected by the ECM. | EGR valve actuation will be disabled.
EGR Valve Circuit

Circuit Description

The Engine Control Module (ECM) provides power to the EGR valve motor. The EGR valve motor is used to move the EGR valve to the correct position, as commanded by the ECM.

Component Location

The EGR valve is mounted to the rear of the EGR cooler on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the engine wiring harness or EGR valve motor coil.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged EGR Valve
  • Malfunctioning or damaged engine wiring harness
Refer to Troubleshooting Fault Code 2349 .

Last Modified: 01-May-2022


Exhaust Gas Recirculation Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2359

Exhaust Gas Recirculation Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2359 PID: P411 SPN: 411 FMI: 0/16 LAMP: Amber SRT: | The EGR differential pressure sensor has detected high EGR gas flow, or the EGR differential pressure reading is not valid for engine operating conditions. | EGR valve actuation will be disabled.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR valve location can vary, depending on engine application.

Conditions for Running the Diagnostics

This diagnostic runs when the following conditions are met:

The EGR valve position is less than 5 percent open

The engine speed is less than a calibratible value

  • Engine torque output is less than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure sensor was reading higher than a calibratable value at idle for a period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This diagnostic checks the reading of the EGR differential pressure sensor when the engine is idling. At idle, the EGR valve is nearly closed and EGR flow is very low. During this condition the reading of the EGR differential pressure is compared against an expected value, and a fault is logged if measured value exceeds the expected value by more than the allowable tolerance.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor.

Internally leaking EGR valve

  • Stuck open EGR valve
Refer to Troubleshooting Fault Code 2359 .

Last Modified: 13-Dec-2020


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2363

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S80 SPN: 1073 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the engine brake solenoid number 2 signal circuit. | Possible reduce engine braking performance.
Engine Brake Solenoid Number 2 Signal Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 2 pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine brake solenoid.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 2363 .

Last Modified: 10-Apr-2022


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2367

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S80 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the engine brake solenoid Number 2 signal circuit. | Possible reduce engine braking performance.
Engine Brake Solenoid Number 2 Signal Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 2 pulse width modulated (PWM) signal was detected to be system voltage when the PWM signal was turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine brake solenoid.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 2367 .

Last Modified: 20-Feb-2022


Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2373

Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P131 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the exhaust gas pressure sensor circuit. | None on performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas pressure signal voltage was greater than 4.75-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure sensor reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 2373 .

Last Modified: 13-Dec-2020


Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2374

Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P131 SPN: 1209 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the exhaust gas pressure sensor circuit. | None on performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas pressure signal voltage was less than 0.25-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure sensor reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 2374 .

Last Modified: 13-Dec-2020


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2375

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2375 PID: P412 SPN: 412 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at EGR temperature sensor circuit. | EGR valve actuation will be disabled.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature signal voltage was greater than 4.9-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas recirculation temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • An open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 2375 .

Last Modified: 13-Dec-2020


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2376

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2376 PID: P412 SPN: 412 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at EGR temperature sensor circuit. | EGR valve actuation will be disabled.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature signal voltage was less than 0.05-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas recirculation temperature reading is used.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 2376 .

Last Modified: 13-Dec-2020


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S33 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins® electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

If Fault Code 2377 is still active after completing all the steps in this fault code troubleshooting tree, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault code include:

  • An open circuit in the harness or fan control solenoid.

A short circuit to voltage source in the OEM harness.

  • Malfunctioning or damaged ECM.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 2377 .

Last Modified: 13-Dec-2020


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 238 .

Last Modified: 13-Dec-2020


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | The ECM lost the vehicle speed signal or is reading an erratic value. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed when other engine operating conditions indicated that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins® Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

Refer to Troubleshooting Fault Code 241 .

Last Modified: 13-Dec-2020


Fan Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2412

Fan Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2412 PID: P26 SPN: 1639 FMI: 2/2 LAMP: Amber SRT: | The fan speed signal has been lost. | The fan can stay on continuously or not run at all.
ISX and ISM Fan Speed Sensor

Circuit Description

The fan speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the fan hub shaft is a ground flat in the center of the shaft. The electronic control module (ECM) interprets this signal and converts it to a fan speed reading.

Component Location

The fan speed sensor is located in the fan hub assembly. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan speed signal has been lost.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The fan will only be in the ON or OFF position.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The fan speed sensor is installed by the original equipment manufacturer (OEM). This fault code is triggered when the fan speed signal is reading 0 when the engine is running. This indicates a failed fan speed sensor or a failure in the OEM wiring harness.

Refer to Troubleshooting Fault Code 2412 .

Last Modified: 13-Dec-2020


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P84 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

The adjustable parameter "VSS Anti-Tampering" must be enabled.

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Cruise Control, Gear-Down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Once the speed signal has been restored the fault code will go inactive once the keyswitch is ON for 30 seconds and the ECM senses zero vehicle and engine speed.

Refer to Troubleshooting Fault Code 242 .

Last Modified: 13-Dec-2020


Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P111 SPN: 111 FMI: 1/17 LAMP: Maintenance SRT: | Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code 2448 .

Last Modified: 13-Dec-2020


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins® electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The fan control logic can be adjusted with the recommended Cummins® electronic service tool or equivalent. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with the recommended Cummins® electronic service tool or equivalent must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Refer to Troubleshooting Fault Code 245 .

Last Modified: 13-Dec-2020


Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2451

Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2451 PID: S384 SPN: 2789 FMI: 0/16 LAMP: None SRT: | Turbocharger turbine intake temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas temperature is calculated by the engine control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger, and is also known as turbine intake temperature.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated turbine inlet temperature was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Fuel is limited in an attempt to decrease the exhaust gas temperature entering the turbocharger.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The most common cause of this fault code is low boost pressure. Low boost pressure can be caused by several factors: leaking charge-air cooler, damaged charge-air cooler piping or hose, loose charge-air cooler clamps, damaged intake manifold pressure sensor, damaged variable geometry turbocharger, damaged turbocharger control valve, or damaged turbocharger control shutoff valve.

This fault code can also be caused by a turbocharger fuel control derate, which can be viewed with the recommended Cummins® electronic service tool or equivalent, under the Engine Operating State. Turbocharger fuel control derates can be caused by several factors: high exhaust temperatures, turbocharger compressor inlet temperatures, and turbocharger compressor outlet temperatures.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trip this fault code, and to determine if the cause has been found and repaired. Running units on the dynamometer can sometimes cause this fault code to log, due to the stationary nature and high temperatures.

Refer to Troubleshooting Fault Code 2451 .

Last Modified: 13-Dec-2020


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at ambient air temperature circuit. | None on performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance. The ECM supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • The Idle Shutdown Ambient Air Temperature Override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 249 .

Last Modified: 13-Dec-2020


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at fuel shutoff valve circuit | Engine will shut down.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a device used by the Engine Control Module (ECM) to control the engine fuel supply. When the ECM energizes the fuel shutoff valve driver circuit, the fuel shutoff valve is opened. Zero voltage to the fuel shutoff valve will close the fuel shutoff valve.

Component Location

The fuel shutoff valve is located near the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit PWM signal is not detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine fuel shutoff valve will not open. The engine will not start or run

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Inspect the fuel shutoff supply circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit. If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not malfunctioned and pulled down the voltage on the fuel shutoff circuit. Inspect the engine-to-chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface.

Possible causes of this fault code include:

Short circuit to ground in the engine harness, connectors, or fuel shutoff valve.

Refer to Troubleshooting Fault Code 254 .

Last Modified: 13-Dec-2020


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 255

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S17 SPN: 632 FMI: 3/3 LAMP: Amber SRT: | Open circuit or short to voltage source detected at fuel shutoff valve circuit. | Engine may not start.
Engine Fuel Shutoff Valve Driver Circuit

Circuit Description

The fuel shutoff valve is a device used by the Engine Control Module (ECM) to control the engine fuel supply. When the ECM energizes the fuel shutoff valve driver circuit, the fuel shutoff valve is opened. Zero voltage to the fuel shutoff valve will close the fuel shutoff valve.

Component Location

The fuel shutoff valve is located near the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine fuel shutoff valve circuit PWM signal is detected to be at system voltage when the PWM voltage is turned off.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine fuel shutoff valve will not open. The engine will not start or run

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

If there is an external shutdown system on the vehicle, make sure it is wired correctly and feeding voltage into the fuel shutoff supply circuit.

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or shutoff valve.
  • Fuel shutoff valve signal wire shorted to a voltage source in the harness.
Refer to Troubleshooting Fault Code 255 .

Last Modified: 13-Dec-2020


Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2554

Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2554 PID: P131 SPN: 1209 FMI: 2/2 LAMP: Amber SRT: | The exhaust gas pressure sensor is reading an erratic value. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

The diagnostic will also run when the engine is running and lower than expected exhaust pressure is detected.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust pressure reading was higher or lower than the other absolute pressure sensors when the keyswitch is OFF and the engine is not running.

The Engine Control Module (ECM) detected the exhaust pressure was higher or lower than expected during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure sensor reading.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70 °C or 158 °F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and run it at high idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range exhaust gas pressure sensor reading

High resistance in the exhaust gas pressure sensor signal or return lines

  • Plugging or restriction in the exhaust gas pressure sensor tube
Refer to Troubleshooting Fault Code 2554 .

Last Modified: 13-Dec-2020


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at ambient air temperature circuit. | None on performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance. The ECM supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • The Idle Shutdown Ambient Air Temperature Override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 256 .

Last Modified: 13-Dec-2020


Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 257

Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 257 PID: S17 SPN: 632 FMI: 7/7 LAMP: Amber SRT: | The fuel shutoff valve is stuck open. | Engine power derate.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a device used by the Engine Control Module (ECM) to control the engine fuel supply. When the ECM energizes the fuel shutoff valve driver circuit, the fuel shutoff valve is opened. Zero voltage to the fuel shutoff valve will close the fuel shutoff valve.

Component Location

The fuel shutoff valve is located near the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the keyswitch was turned OFF but the engine did not shut down or shut down too slowly when the fuel shutoff valve was de-energized.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Refer to Troubleshooting Fault Code 257 .

Last Modified: 13-Dec-2020


Engine Coolant Temperature - Condition Exists

FAULT CODE 2646

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2646 PID: P110 SPN: 110 FMI: 11/31 LAMP: Amber SRT: | The EGR valve was closed to reduce engine coolant temperature. | EGR valve actuation will be disabled.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was above a threshold and closed the EGR valve to reduce the engine coolant temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed. No malfunction has occurred to cause this fault code. Other engine protection fault codes will be active if the engine coolant temperature has exceeded the engine protection limits.

Refer to Troubleshooting Fault Code 2646 .

Last Modified: 13-Dec-2020


Exhaust Gas Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2764

Exhaust Gas Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2764 PID: P131 SPN: 1209 FMI: 0/16 LAMP: Amber SRT: | High exhaust gas pressure has been detected by the exhaust gas pressure sensor. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Exhaust gas pressure sensor reading was greater than the engine protection limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • An engine derate will be activated to bring exhaust gas pressure below the maximum operating limits.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning variable geometry turbocharger

A damaged in-range exhaust gas pressure sensor

A plugged or restricted aftertreatment diesel particulate filter

  • A plugged or restricted EGR cooler.
Refer to Troubleshooting Fault Code 2764 .

Last Modified: 13-Dec-2020


Engine Exhaust Gas Recirculation (EGR) System - Condition Exists

FAULT CODE 2774

Engine Exhaust Gas Recirculation (EGR) System - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2774 PID: S391 SPN: 3058 FMI: 11/31 LAMP: Amber SRT: | Plugged EGR differential pressure sensor tubes have been detected. | EGR valve actuation will be disabled.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is located near the fuel inlet to the integrated fuel system module (IFSM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected plugged differential pressure sensor tubes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • To validate the repair, turn keyswitch on for 1 minute, turn keyswitch off for 1 minute, and then turn keyswitch on for 1 minute.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Plugged or restricted EGR differential pressure sensor ports

Damaged EGR differential pressure tubes

Refer to Troubleshooting Fault Code 2774 .

Last Modified: 13-Dec-2020


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2789

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2789 PID: P110 SPN: 110 FMI: 1/18 LAMP: Amber SRT: | Engine coolant temperature is below normal operating temperature limits. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was less than a calibrated threshold

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set. The features that are in conflict may not operate correctly.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

If this fault indicates that coolant temperature is below a calibratible limit set in the ECM.

Refer to Engine Coolant Temperature Below Normal troubleshooting symptom tree tree in the base engine service manual.

Refer to Troubleshooting Fault Code 2789 .

Last Modified: 13-Dec-2020


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 285 .

Last Modified: 13-Dec-2020


J1939 Network #1 - Out of Calibration

FAULT CODE 286

J1939 Network #1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a damaged J1939 data link connection between the OEM ECU and Cummins® ECM, a damaged connection between the component and the OEM ECU, damaged OEM ECU or damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 286 .

Last Modified: 01-Jun-2021


Accelerator Pedal Position 1 - Received Network Data in Error

FAULT CODE 287

Accelerator Pedal Position 1 - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 287 PID: P91 SPN: 91 FMI: 2/19 LAMP: Amber SRT: | The original equipment manufacturer (OEM) vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | Engine can ONLY idle or engine will NOT accelerate to full speed.
SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the secondary throttle position sensor indicates it is in the idle position.

When the accelerator is released and the OEM VECU reads accelerator as 0 percent, but the secondary throttle position sensor indicates it is NOT in the idle position.

The OEM VECU determined that the accelerator signal wire was shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the OEM VECU detects an error on the accelerator. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the idle validation switch states and accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component.

The three types of errors that can occur for this fault are:

When the accelerator is depressed and the OEM VECU reads accelerator position as greater than 0 percent, but the idle validation switch indicates it is in the idle position. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.

When the accelerator is released and the OEM VECU reads accelerator position as 0 percent, but the idle validation switch indicates it is not in the idle position. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.

The OEM VECU determines that the accelerator signal line is shorted high or shorted low.

It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins® ECM, for other components, or the accelerator and idle validation switch, or if the data link is damaged. The OEM configurations must multiplex the accelerator and idle validation switch inputs together to allow the use of the J1939 multiplexing and limp home feature for these components. Use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 287 .

Last Modified: 01-Apr-2021


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 2/19 LAMP: Red SRT: | The original equipment manufacturer (OEM) vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | Remote accelerator will not operate.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received a message from the OEM VECU via the J1939 data link, indicating the remote throttle signal wire or enable switch was shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.

When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

It is still possible to get a Fault Code 285 or 286, if there is an incorrect setup in the OEM VECU or Cummins® ECM for other components, or the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. Use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 288 .

Last Modified: 13-Dec-2020


Barometric Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2/2 LAMP: Amber SRT: | The ambient air temperature sensor is reading an erratic value. | Engine power derate.
Barometric Air Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric pressure reading was higher or lower than the other absolute pressure sensors on the engine, or an in-range malfunction of the sensor was detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning in-range barometric pressure sensor

High resistance in the barometric pressure sensor signal or return lines.

Refer to Troubleshooting Fault Code 295 .

Last Modified: 13-Dec-2020


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2961

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2961 PID: P412 SPN: 412 FMI: 0/15 LAMP: None SRT: | EGR temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than a threshold for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A stuck open turbocharger control valve

Damaged EGR differential pressure tubes

  • A malfunctioning EGR valve

A low reading from the EGR differential pressure sensor

A low reading for the EGR valve position sensor

  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger.
  • A fouled EGR cooler.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code 2961 .

Last Modified: 13-Dec-2020


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2962

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2962 PID: P412 SPN: 412 FMI: 0/16 LAMP: Amber SRT: | EGR temperature has exceeded the engine protection limit. | Engine power derate.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than a threshold for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A fouled EGR cooler.

A stuck open turbocharger control valve

  • A damaged EGR valve

A low reading from the EGR differential pressure sensor

A low reading for the EGR valve position sensor

  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code 2962 .

Last Modified: 13-Dec-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the base engine service manual.

Refer to Troubleshooting Fault Code 2963 .

Last Modified: 13-Dec-2020


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 2964 .

Last Modified: 13-Dec-2020


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | The intake manifold pressure sensor is reading an erratic value. | Engine power derate.
Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure sensor was reading higher or lower than expected at keyoff or during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning intake manifold pressure sensor
  • A malfunctioning barometric air pressure sensor
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Restriction in the charge-air cooler
  • A damaged turbocharger speed sensor
Refer to Troubleshooting Fault Code 2973 .

Last Modified: 13-Dec-2020


Injector Solenoid Driver 1 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 311

Injector Solenoid Driver 1 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 311 PID: S1 SPN: 651 FMI: 6/6 LAMP: Amber SRT: | Current detected at injector Number 1 when voltage is turned off. | Engine will misfire or run rough.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • A short circuit to voltage source in the engine wiring harness.

Low resistance in the injector.

Refer to Troubleshooting Fault Code 311 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 5 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 312

Injector Solenoid Driver 5 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 312 PID: S5 SPN: 655 FMI: 6/6 LAMP: Amber SRT: | Current detected at injector Number 5 when the voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • A short circuit to voltage source in the engine wiring harness.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 312 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 3 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 313

Injector Solenoid Driver 3 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 313 PID: S3 SPN: 653 FMI: 6/6 LAMP: Amber SRT: | Current detected at injector Number 3 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • A short circuit to voltage source in the engine wiring harness.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 313 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 6 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 314

Injector Solenoid Driver 6 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 314 PID: S6 SPN: 656 FMI: 6/6 LAMP: Amber SRT: | Current detected at injector Number 6 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • A short circuit to voltage source in the engine wiring harness.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 314 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 2 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 315

Injector Solenoid Driver 2 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 315 PID: S2 SPN: 652 FMI: 6/6 LAMP: Amber SRT: | Current detected at injector Number 2 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • A short circuit to voltage source in the engine wiring harness.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 315 .

Last Modified: 01-Jul-2021


Real Time Clock - Data Erratic, Intermittent, or Incorrect

FAULT CODE 319

Real Time Clock - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Maintenance SRT: | Real-time clock lost power. | None on performance.
ECM

Circuit Description

Under ordinary operating conditions, the real-time clock in the Engine Control Module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the real-time clock battery voltage was 3.3-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The real-time clock values in the ECM data will be incorrect.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault are weak or damaged real-time clock battery, damaged wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

Refer to Troubleshooting Fault Code 319 .

Last Modified: 13-Dec-2020


Injector Solenoid Driver 4 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 321

Injector Solenoid Driver 4 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 321 PID: S4 SPN: 654 FMI: 6/6 LAMP: Amber SRT: | Current detected at injector Number 4 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.
  • A short circuit to voltage source in the engine wiring harness.

Short circuit to ground in the engine harness or injector.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 321 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Current detected at injector Number 1 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of a single injector fault include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • High resistance in a single injector or injector solenoid
Refer to Troubleshooting Fault Code 322 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S5 SPN: 655 FMI: 5/5 LAMP: Amber SRT: | Current detected at injector Number 1 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • High resistance in a single injector or injector solenoid.
Refer to Troubleshooting Fault Code 323 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S3 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Current detected at injector Number 3 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • High resistance in a single injector or injector solenoid
Refer to Troubleshooting Fault Code 324 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S6 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Current detected at injector Number 6 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • High resistance in a single injector or injector solenoid
Refer to Troubleshooting Fault Code 325 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S2 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Current detected at injector Number 2 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • High resistance in a single injector or injector solenoid
Refer to Troubleshooting Fault Code 331 .

Last Modified: 01-Jul-2021


Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S4 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Current detected at injector Number 4 when voltage is turned off. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, connectors, or actuator.

Short circuit to ground in the engine harness or injector.

  • High resistance in a single injector or injector solenoid
Refer to Troubleshooting Fault Code 332 .

Last Modified: 01-Jul-2021


Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 3348

Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3348 PID: SPN: 1176 FMI: 1/1 LAMP: Red SRT: | The estimated differential pressure across the turbocharger is above the critical level. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Control Module (ECM)

Circuit Description

The ECM calculates a differential pressure across the turbocharger using the intake manifold pressure sensor and the crankcase pressure sensor.

Component Location

The intake manifold pressure sensor is located in the air intake horn. The crankcase pressure sensor is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the calculated differential pressure across the turbocharger was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • An engine speed derate will occur when the fault is registered.

If the problem persists for 5 minutes, an engine shutdown procedure will begin.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Crankcase filter needs to be changed.

If the crankcase filter is being replaced frequently for this fault code, reference the Crankcase Coalescing Filter - Frequent Replacement troubleshooting symptom tree.

Air intake filter needs to be changed.

A plugged or restricted crankcase ventilation system.

Check the tube between the engine and the coalescing filter.

Check the draft tube going from the coalescing filter to the atmosphere or intake manifold.

Consider the working environment. Ice, snow, or mud can temporarily block the tube and then fall away.

Complete the entire troubleshooting tree whether Fault Code 3348 is active or inactive.

If a problem is found in the early steps, the troubleshooting tree should still be completed.

Refer to Troubleshooting Fault Code 3348 .

Last Modified: 13-Dec-2020


Roll Over Protection Brake Control Active - Condition Exists

FAULT CODE 3374

Roll Over Protection Brake Control Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3374 PID: SPN: 1818 FMI: 11/31 LAMP: None SRT: | The ECM received a message from the anti-lock braking (ABS) controller, inhibiting cruise control operation. | Cruise control could possibly not operate.
SAE J1939 Multiplexing Circuit

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the engine control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to the ECM and cruise control will temporarily be disabled.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The anti-lock bracking (ABS) controller detected certain driving conditions and inhibited cruise control.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Cruise control has temporarily been inhibited.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, cruise control could possibly not function. This is an information only fault code, indicating that the anti-lock braking (ABS) controller detected certain driving conditions and temporarily inhibited cruise control operation. Refer to the OEM service manual.

Refer to Troubleshooting Fault Code 3374 .

Last Modified: 13-Dec-2020


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 338

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S87 SPN: 1267 FMI: 3/3 LAMP: Amber SRT: | Open circuit or short to voltage source detected at the idle shutdown vehicle accessory/ignition bus relay circuit. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The Engine Control Module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to Installed, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by Original Equipment Manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle shutdown relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

ECM Idle Shutdown feature set up incorrectly.

Open circuit in the idle shutdown relay, OEM harness, or connectors.

  • Short circuit to a voltage source in the OEM wiring harness or relay.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 338 .

Last Modified: 13-Dec-2020


Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3385

Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3385 PID: P105 SPN: 105 FMI: 1/18 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Below Normal Operational Range - Moderately Severe Level. The intake manifold temperature is below a critical threshold | None on performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The intake manifold temperature was less than 20°C [68°F] while the engine was idling for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The EGR valve was closed because the engine was idling with cold intake manifold temperatures for an extended period of time.

Refer to Troubleshooting Fault Code 3385 .

Last Modified: 13-Dec-2020


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 339

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S87 SPN: 1267 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the idle shutdown vehicle accessory or ignition bus relay circuit when commanded ON. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The Engine Control Module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to Installed, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by Original Equipment Manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle shutdown relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on this circuit. This fault code is logged if it detects a low voltage when the relay signal is commanded on. This fault code can be caused by a short circuit to ground in the idle shutdown relay, OEM harness, or connectors.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 339 .

Last Modified: 13-Dec-2020


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | ECM power supply errors have been detected. | Possible reduced engine performance. Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343 .

Last Modified: 13-Dec-2020


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12/12 LAMP: Amber SRT: | Invalid switch configuration adjustable parameter setting have been detected by the Engine Control Module (ECM). | Various optional switch inputs to the ECM may not operate correctly.
Engine Control Module (ECM)

Circuit Description

The Original Equipment Manufacturer (OEM) wiring harness connects multiple outputs or switched inputs to the ECM which can be enabled or disabled using recommended Cummins® electronic service tool or equivalent, such as such as the accelerator interlock/engine torque limit switch or the clutch/engine protection override switch. Many of the outputs and switched inputs share a common wire on the OEM wiring harness. Refer to the engine wiring diagram to determine which features share common wires in the OEM harness.

Component Location

The output or switched inputs to this diagnostic are found in the OEM harness.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected features which share a common input or output to the ECM were simultaneously enabled..

Action Taken When the Fault Code is Active

The ECM will set the fault code active immediately after the diagnostic is set. The features that are in conflict may not operate correctly.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Many of the outputs and switched inputs share a common wire on the OEM wiring harness. If two features that share a common OEM wire are enabled simultaneously in the ECM, this fault code will be logged. To disable the fault code, disable one of the features on the shared OEM wire. For example, if the accelerator interlock switch and powertrain protection torque limit switch are both enabled in the ECM, either disable one of the features with the recommended Cummins® electronic service tool or equivalent or configure one of the features to be multiplexed using the SAE J1939 multiplexing feature.

Refer to Troubleshooting Fault Code 346 .

Last Modified: 13-Dec-2020


Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

FAULT CODE 3488

Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3488 PID: SPN: 563 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the anti-lock braking (ABS) controller. | Cruise control could possibly not operate.
SAE J1939 Multiplexing Circuit

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the engine control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to the ECM and cruise control will temporarily be disabled.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Refer to Troubleshooting Fault Code 3488 .

Last Modified: 13-Dec-2020


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 3597 FMI: 12/12 LAMP: Amber SRT: | The ECM measured injector boost voltage is low. | Engine will misfire or run rough. Possibly hard to start or low power. Engine could possibly not start.
Injector Power Supply Circuit

Circuit Description

Between each injection event, the Engine Control Module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed/position sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured injector power supply voltage was less than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code will become active after key ON if the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive whenever the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351 .

Last Modified: 13-Dec-2020


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 1 circuit. | Engine power derate.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 352 .

Last Modified: 13-Dec-2020


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 1 circuit. | Engine power derate.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

  • High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.
Refer to Troubleshooting Fault Code 386 .

Last Modified: 13-Dec-2020


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | The engine oil pressure sensor indicates oil pressure is below the engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
Refer to Troubleshooting Fault Code 415 .

Last Modified: 13-Dec-2020


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P97 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water has been detected in the fuel filter. | Possible loss of power, or hard starting.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 418 .

Last Modified: 13-Dec-2020


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine oil temperature signal indicates engine oil temperature above engine protection warning limit. | Possible reduced engine performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the warning engine protection limit for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the warning engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 421 .

Last Modified: 13-Dec-2020


J1939 Network #1 - Abnormal Update Rate

FAULT CODE 427

J1939 Network #1 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9/9 LAMP: None SRT: | Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | Engine will only idle.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes. If the fault code does not go inactive after key ON, it may be necessary to drive the vehicle for at least 5 continuous minutes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits

The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages

The external OEM controlling device has malfunctioned or can no longer transmit on the data link.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 427 .

Last Modified: 01-Jun-2021


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P97 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or battery voltage.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 428 .

Last Modified: 13-Dec-2020


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P97 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was less than 0.05-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the engine wiring harness, sensor, or connector.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 429 .

Last Modified: 13-Dec-2020


Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 431

Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Voltage detected simultaneously on both idle validation and off-idle validation switches. | Engine will only idle.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the on-idle and off-idle signal circuits are in the same state simultaneously.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

When installing a new accelerator pedal assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.

Possible causes of this fault code include:

  • Malfunctioning or damaged accelerator pedal or lever idle validation switch.
  • Malfunctioning or damaged OEM wiring harness.
  • An uncalibrated accelerator pedal assembly
Refer to Troubleshooting Fault Code 431 .

Last Modified: 10-Apr-2022


Accelerator Pedal or Lever Idle Validation Switch Circuit - Out of Calibration

FAULT CODE 432

Accelerator Pedal or Lever Idle Validation Switch Circuit - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: S230 SPN: 558 FMI: 13/13 LAMP: Red SRT: | Voltage at idle validation on-idle and off-idle circuit does not match accelerator pedal position. | Engine will only idle.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The accelerator pedal or lever idle validation switch is used by the engine control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal or lever position and idle validation switch did not match.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged accelerator pedal or lever idle validation switch.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code 432 .

Last Modified: 10-Apr-2022


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | The engine oil pressure sensor is reading an erratic value. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is turned ON and before engine speed is detected.

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure reading was higher or lower than the other absolute pressure sensors on the engine after the keyswitch has been turned OFF and the engine has stopped running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High resistance in the engine wiring harness.
  • Malfunctioning engine oil pressure sensor.
Refer to Troubleshooting Fault Code 435 .

Last Modified: 13-Dec-2020


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.

If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 441 .

Last Modified: 13-Dec-2020


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to electrical components.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 442 .

Last Modified: 13-Dec-2020


Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

Open circuit in the starter lockout relay, OEM harness, or connectors

  • Short circuit to a voltage source in the OEM wiring harness or relay.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 584 .

Last Modified: 13-Dec-2020


Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 585 .

Last Modified: 13-Dec-2020


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | High battery voltage detected by the battery voltage monitor feature. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 596 .

Last Modified: 13-Dec-2020


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Low battery voltage detected by the battery voltage monitor feature. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code include:

Undercharged batteries caused by a malfunctioning alternator or regulator.

High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 597 .

Last Modified: 13-Dec-2020


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Low battery voltage detected by the battery voltage monitor feature. | None on performance.
Engine Control Module (ECM) Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code include:

Undercharged batteries caused by a malfunctioning alternator or regulator.

Refer to Troubleshooting Fault Code 598 .

Last Modified: 13-Dec-2020


Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 629

Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 629 PID: S314 SPN: 1176 FMI: 1/18 LAMP: Amber SRT: | The estimated differential pressure across the turbocharger is above the critical level. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM calculates a differential pressure across the turbocharger using the intake manifold pressure sensor and the crankcase pressure sensor.

Component Location

The intake manifold pressure sensor is located in the air intake horn. The crankcase pressure sensor is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the calculated differential pressure across the turbocharger was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Plugged or restricted air filter.
  • Restricted crankcase breather filter plugged

Restricted crankcase breather plumbing.

Refer to Troubleshooting Fault Code 629 .

Last Modified: 13-Dec-2020


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Change the engine oil and filter. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

For a detailed component location view, refer to the appropriate service manual. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for the location of the oil fill port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil and filter required changing based on the programmable setting in the Maintenance Monitor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to reset the Maintenance Monitor feature.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in the recommended Cummins® electronic service tool or equivalent. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649 .

Last Modified: 13-Dec-2020


Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 686

Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 686 PID: P103 SPN: 103 FMI: 2/2 LAMP: Amber SRT: | An invalid turbocharger speed signal has been detected by the ECM. | None on performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was greater than the speed that is physically achievable by the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Usually this fault code indicates a faulty turbocharger speed sensor or incorrect speed signals from the sensor. This fault can be caused by malfunctions in the following components:

Turbocharger speed sensor

Engine harness

ECM power supply or grounds

Electronic vehicle accessories which emit excessive electromagnetic interference.

If the fault occurs intermittently:

Look for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Look for sources of electronic noise such as poorly installed vehicle electronic components.

Be sure that the vehicle chassis grounds are in good condition.

Be sure that the ECM power supply and ground circuits are in good condition and that this power supply is not shared with other vehicle electronics.

Refer to Troubleshooting Fault Code 686 .

Last Modified: 13-Dec-2020


Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 687

Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 1/18 LAMP: Amber SRT: | Low turbocharger speed detected by the ECM. | Engine power derate.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was less than 600 rpm for more than 1 second when the engine speed was greater than 1200 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Items that can cause this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine wiring harness.
  • Damaged ECM.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code 687 .

Last Modified: 13-Dec-2020


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected a loss of signal from the camshaft position sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start. Possible reduced engine performance.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open or short circuit in the wiring harness

Short to voltage source in the engine harness

  • Damaged or malfunctioning engine position sensor.
Refer to Troubleshooting Fault Code 689 .

Last Modified: 13-Dec-2020


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the turbocharger compressor intake air temperature circuit. | Engine power derate.
Turbocharger Compressor Intake Temperature Sensor Circuit

Circuit Description

The compressor intake air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Damaged sensor.
Refer to Troubleshooting Fault Code 691 .

Last Modified: 13-Dec-2020


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • Damaged sensor.
Refer to Troubleshooting Fault Code 692 .

Last Modified: 13-Dec-2020


Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 697 .

Last Modified: 13-Dec-2020


Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 698 .

Last Modified: 13-Dec-2020


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S64 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected a loss of signal from the camshaft position sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open or short circuit in the wiring harness

A short to voltage source in the engine harness.

  • Damaged or malfunctioning camshaft position sensor.
Refer to Troubleshooting Fault Code 778 .

Last Modified: 13-Dec-2020


Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

FAULT CODE 784

Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: S145 SPN: 1590 FMI: 2/2 LAMP: None SRT: | Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
SAE J1939 Datalink Circuit

Circuit Description

The adaptive cruise control system sends commands to the ECM via the J1939 data link to limit engine speed and maintain a set following distance behind a vehicle travelling more slowly than the current cruise control set speed.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive an expected message from the Adaptive Cruise Control module.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The adaptive cruise control will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

If Adaptive Cruise Recovery is enabled, the driver can toggle the cruise enable switch from the OFF position to the ON position two times to get regular cruise control to operate and Fault Code 784 will go inactive. At the next key cycle, if the Heartbeat message is still not present, Fault Code 784 will go active.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 784 .

Last Modified: 13-Dec-2020


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


NO TITLE

ISM CM875

Fault Code: 111 | SPN: 629 | FMI: 12
Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Troubleshooting Summary

  1. ECM calibration revision history check
  2. ECM Malfunction

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM Malfunction

Solution: S00008831

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 115 | SPN: 612 | FMI: 2
Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Reversed engine position sensors
  3. Engine crankshaft speed/position sensor check
  4. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Reversed engine position sensors

Solution: S00000318

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually verify the camshaft engine position and crankshaft engine position sensor are connected properly.

Specification

  • If the sensors are not properly connected, then proceed to the repair section.

Linked Solutions

  • None

Repair

  • Connect the camshaft and crankshaft position sensors in the correct position.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 122 | SPN: 102 | FMI: 3
Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Intake manifold pressure sensor circuit response
  5. Intake manifold pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000153

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00000457

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake manifold pressure sensor circuit response

Solution: S00001987

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor 1 from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold pressure sensor 1 has been detected if the following fault code became active with the sensor disconnected: 123

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor circuit response at the ECM

Solution: S00000456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 123
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 123

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 123 | SPN: 102 | FMI: 4
Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Intake manifold pressure sensor circuit response
  5. Intake manifold pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000153

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00000457

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake manifold pressure sensor circuit response

Solution: S00003616

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor 1 from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold pressure sensor 1 SIGNAL pin and the intake manifold pressure sensor 1 SUPPLY pin at the sensor connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold pressure sensor 1 has been detected if the following fault code became active with the jumper wire in place: 122

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure sensor.

Refer to Procedure 019-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor circuit response at the ECM

Solution: S00002392

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 122
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 122

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 125 | SPN: 102 | FMI: 18
Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Restricted intake air filter
  2. Barometric air pressure sensor stuck in-range
  3. Leaks in the intake air system
  4. Charge air cooler system leak
  5. Turbocharger is malfunctioning
  6. ECM calibration revision history check
  7. Intake manifold pressure sensor is malfunctioning

1 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Barometric air pressure sensor stuck in-range

Solution: S00005632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the barometric air pressure sensor

Specification

  • A malfunctioning barometric air pressure sensor has been detected if the barometric air pressure sensor is not within the following specification of local ambient air pressure: 51 mm HG [2 in HG]

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger is malfunctioning

Solution: S00008465

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Visually inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the turbocharger.

Refer to Procedure 010-033

  • Visually inspect the air filter and air intake system for leaks allowing dirt and dust to enter the turbocharger.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Intake manifold pressure sensor is malfunctioning

Solution: S00005543

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-061

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 131 | SPN: 91 | FMI: 3
Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor circuit response
  5. Accelerator pedal position sensor open circuit check
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002114

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Accelerator Pedal or Lever Position: 387

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000444

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00000549

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000549

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor circuit response

Solution: S00000368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning accelerator pedal position sensor has been detected if the following fault code became active with the sensor disconnected: 132

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 132 | SPN: 91 | FMI: 4
Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor circuit response
  5. Accelerator pedal position sensor open circuit check
  6. Accelerator pedal position sensor circuit pin to ground short
  7. Internal ECM Error

1 - Check for primary fault codes

Solution: S00002277

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Accelerator Pedal or Lever Position: 387, 443

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000444

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00000549

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000549

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor circuit response

Solution: S00000369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the accelerator pedal position sensor SUPPLY pin and the accelerator pedal position sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning accelerator pedal position sensor has been detected if the following fault code became active with the jumper wire in place: 131

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to ground short

Solution: S00000448

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Internal ECM Error

Solution: S00001230

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISM CM875

Fault Code: 133 | SPN: 974 | FMI: 3
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Remote accelerator pedal position sensor voltage check
  2. Remote accelerator pedal position sensor circuit check
  3. Remote accelerator pedal position sensor circuit response
  4. Remote accelerator pedal position sensor open circuit check
  5. Remote accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check

1 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Remote accelerator pedal position sensor circuit response

Solution: S00000353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning remote accelerator pedal position sensor has been detected if the following fault code become active with the remote accelerator pedal position sensor disconnected: 134

Linked Solutions

  • None

Repair

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Remote accelerator pedal position sensor open circuit check

Solution: S00000449

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM harness ECM connector RETURN pin and the OEM wiring harness accelerator pedal connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Remote accelerator pedal position sensor circuit pin to pin short

Solution: S00000450

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 134 | SPN: 974 | FMI: 4
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Remote accelerator pedal position sensor voltage check
  2. Remote accelerator pedal position sensor circuit check
  3. Remote accelerator pedal position sensor circuit response
  4. Remote accelerator pedal position sensor open circuit check
  5. Remote accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check

1 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Remote accelerator pedal position sensor circuit response

Solution: S00000370

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the remote accelerator pedal position sensor SUPPLY pin and the remote accelerator pedal position sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning remote accelerator pedal position sensor has been detected if the following fault code became active with the jumper wire in place: 133

Linked Solutions

  • None

Repair

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Remote accelerator pedal position sensor open circuit check

Solution: S00000453

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SIGNAL pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Remote accelerator pedal position sensor circuit pin to pin short

Solution: S00000450

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 135 | SPN: 100 | FMI: 3
Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil pressure sensor circuit response
  3. Lubricating oil pressure sensor circuit response at the ECM
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil pressure sensor circuit response

Solution: S00000376

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning lubricating oil pressure sensor has been detected if the following fault code became active with the sensor disconnected: 141

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil pressure sensor circuit response at the ECM

Solution: S00001231

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 141
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 141

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 141 | SPN: 100 | FMI: 4
Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil pressure sensor circuit response
  3. Lubricating oil pressure sensor circuit response at the ECM
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil pressure sensor circuit response

Solution: S00000377

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the lubricating oil pressure sensor SUPPLY pin and the lubricating oil pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning lubricating oil pressure sensor has been detected if the following fault code became active with the jumper wire in place: 135

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil pressure sensor circuit response at the ECM

Solution: S00000445

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the lubricating oil pressure sensor SUPPLY pin and the lubricating oil pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 135
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 135

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 143 | SPN: 100 | FMI: 18
Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Contaminated lubricating oil
  4. Lubricating oil pressure sensor stuck in-range
  5. Lubricating oil pressure relief valve is malfunctioning
  6. Loose or broken lubricating oil suction tube
  7. Main lubricating oil pressure regulator is malfunctioning
  8. Lubricating oil pump is malfunctioning
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000078

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 135, 141
  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Contaminated lubricating oil

Solution: S00000462

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00000471

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Loose or broken lubricating oil suction tube

Solution: S00002808

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pan.

Refer to Procedure 007-025

  • Inspect the lubricating oil suction tube and o-ring for damage.

Refer to Procedure 007-025

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil suction tube o-ring or the damaged lubricating oil suction tube.

Refer to Procedure 007-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00001453

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-029

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-029

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Lubricating oil pump is malfunctioning

Solution: S00000472

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pump.

Refer to Procedure 007-031

  • Inspect the lubricating oil pump.

Refer to Procedure 007-031

If the lubricating oil pump was found to be damaged, then inspect the lubricating oil filter for metal.

Specification

  • If damaged, loose or worn gears are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pump.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 144 | SPN: 110 | FMI: 3
Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Coolant temperature sensor circuit response
  3. Engine coolant temperature sensor circuit response check at the ECM

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Coolant temperature sensor circuit response

Solution: S00000128

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant temperature sensor has been detected if the following fault code become active with the jumper wire in place: 145

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine coolant temperature sensor circuit response check at the ECM

Solution: S00000175

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 145
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 145

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 145 | SPN: 110 | FMI: 4
Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Coolant temperature sensor circuit response
  3. Engine coolant temperature sensor circuit response check at the ECM

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Coolant temperature sensor circuit response

Solution: S00000313

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant temperature sensor has been detected if the following fault code became active with the sensor disconnected: 144

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine coolant temperature sensor circuit response check at the ECM

Solution: S00000319

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 144
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 144

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 146 | SPN: 110 | FMI: 16
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Radiator is externally obstructed
  4. Radiator shutters malfunctioning (if equipped)
  5. Coolant temperature sensor resistance check
  6. Fan clutch operates incorrectly
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Malfunctioning cooling fan drive or cooling fan controls
  10. Combustion gases entering the cooling system
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00010538

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-020

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fan clutch operates incorrectly

Solution: S00006146

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-026

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-026

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 151 | SPN: 110 | FMI: 0
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Radiator is externally obstructed
  4. Radiator shutters malfunctioning (if equipped)
  5. Coolant temperature sensor resistance check
  6. Fan clutch operates incorrectly
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Malfunctioning cooling fan drive or cooling fan controls
  10. Combustion gases entering the cooling system
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00010538

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-020

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fan clutch operates incorrectly

Solution: S00006146

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-026

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-026

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 153 | SPN: 105 | FMI: 3
Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Intake manifold temperature sensor stuck in-range
  2. Intake manifold temperature sensor circuit response check at the ECM
  3. ECM calibration revision history check

1 - Intake manifold temperature sensor stuck in-range

Solution: S00005257

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F].

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the intake manifold temperature sensor.

Refer to Procedure 019-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor circuit response check at the ECM

Solution: S00000576

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 154
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 154

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 154 | SPN: 105 | FMI: 4
Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Intake manifold temperature sensor stuck in-range
  2. Intake manifold temperature sensor circuit response
  3. Intake manifold temperature sensor circuit response check at the ECM
  4. ECM calibration revision history check

1 - Intake manifold temperature sensor stuck in-range

Solution: S00005257

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F].

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the intake manifold temperature sensor.

Refer to Procedure 019-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor circuit response

Solution: S00003548

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold temperature sensor has been detected if the following fault code became active with the sensor disconnected: 153

Linked Solutions

  • None

Repair

  • Replace the intake manifold temperature sensor.

Refer to Procedure 019-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold temperature sensor circuit response check at the ECM

Solution: S00000479

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 153
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 153

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 155 | SPN: 105 | FMI: 0
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. High intake manifold temperature basic checks
  2. Radiator is externally obstructed
  3. Intake manifold temperature sensor stuck in-range
  4. EGR differential pressure sensor adapter leaking
  5. Thermostat is malfunctioning
  6. Out-of-chassis opening temperature test
  7. Leaks in the intake air system
  8. Charge air cooler system leak
  9. Malfunctioning cooling fan drive or cooling fan controls
  10. Turbocharger is malfunctioning
  11. ECM calibration revision history check

1 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold temperature sensor stuck in-range

Solution: S00005257

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F].

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the intake manifold temperature sensor.

Refer to Procedure 019-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR differential pressure sensor adapter leaking

Solution: S00003689

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Visually inspect the EGR differential pressure sensor for leaks at the mounting surface.
  • Visually inspect the aftertreatment differential pressure tubes for proper installation.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 019-370

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Turbocharger is malfunctioning

Solution: S00000780

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 187 | SPN: 3510 | FMI: 4
Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 2 voltage below normal

1 - ECM sensor supply 2 voltage below normal

Solution: S00004524

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Perform the following actions one at a time:
  • Disconnect the intake manifold pressure sensor from the engine wiring harness.
  • Disconnect the EGR valve position sensor from the engine wiring harness.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-061

  • Replace EGR valve position sensor.

Refer to Procedure 019-372

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 13-Dec-2020


NO TITLE

ISM CM875

Fault Code: 195 | SPN: 111 | FMI: 3
Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Coolant level sensor circuit response (2-wire)
  2. Coolant level sensor is malfunctioning
  3. Coolant level sensor circuit response (3-wire)
  4. Coolant level sensor is malfunctioning
  5. Coolant level sensor open circuit check (3-wire)
  6. Coolant level sensor open circuit check (2-wire)
  7. Coolant level sensor circuit pin to pin short (3-wire)
  8. Coolant level sensor circuit pin to pin short (2-wire)

1 - Coolant level sensor circuit response (2-wire)

Solution: S00000817

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the sensor disconnected: 195
  • Proceed to the Linked Solutions section if the following fault code became active with the sensor disconnected: 195

Linked Solutions

Click on the link below:

  • Coolant level sensor is malfunctioning

Refer to S00000839

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Coolant level sensor is malfunctioning

Solution: S00000839

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Coolant level sensor circuit response (3-wire)

Solution: S00000359

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the jumper wire in place: 196
  • Proceed to the Linked Solutions section if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • Coolant level sensor is malfunctioning

Refer to S00001157

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Coolant level sensor is malfunctioning

Solution: S00001157

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 195

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Coolant level sensor open circuit check (3-wire)

Solution: S00000498

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor open circuit check (2-wire)

Solution: S00004695

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short (3-wire)

Solution: S00000497

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor circuit pin to pin short (2-wire)

Solution: S00004789

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 196 | SPN: 111 | FMI: 4
Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Coolant level sensor voltage check
  2. Coolant level sensor circuit check
  3. Coolant level sensor circuit response (2-wire)
  4. Coolant level sensor is malfunctioning
  5. Coolant level sensor circuit response (3-wire)
  6. Coolant level sensor is malfunctioning
  7. Coolant level sensor open circuit check (3-wire)
  8. Coolant level sensor open circuit check (2-wire)
  9. Coolant level sensor circuit pin to ground short
  10. Coolant level sensor circuit pin to pin short (3-wire)
  11. Coolant level sensor circuit pin to pin short (2-wire)

1 - Coolant level sensor voltage check

Solution: S00000727

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the coolant level sensor SUPPLY pin to the coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Coolant level sensor circuit check

Refer to S00000815

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Coolant level sensor circuit check

Solution: S00000815

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Coolant level sensor circuit response (2-wire)

Solution: S00000817

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the sensor disconnected: 195
  • Proceed to the Linked Solutions section if the following fault code became active with the sensor disconnected: 195

Linked Solutions

Click on the link below:

  • Coolant level sensor is malfunctioning

Refer to S00000839

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Coolant level sensor is malfunctioning

Solution: S00000839

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Coolant level sensor circuit response (3-wire)

Solution: S00000359

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the jumper wire in place: 196
  • Proceed to the Linked Solutions section if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • Coolant level sensor is malfunctioning

Refer to S00001157

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Coolant level sensor is malfunctioning

Solution: S00001157

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 195

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Coolant level sensor open circuit check (3-wire)

Solution: S00000498

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor open circuit check (2-wire)

Solution: S00004695

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor circuit pin to ground short

Solution: S00000499

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor circuit pin to pin short (3-wire)

Solution: S00000497

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Coolant level sensor circuit pin to pin short (2-wire)

Solution: S00004789

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 197 | SPN: 111 | FMI: 18
Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00010538

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-020

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 212 | SPN: 175 | FMI: 3
Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Lubricating oil temperature sensor circuit response

1 - Lubricating oil temperature sensor circuit response

Solution: S00003662

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine oil temperature sensor has been detected if the following fault code became active with the jumper wire in place: 213

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 213 | SPN: 175 | FMI: 4
Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Lubricating oil temperature sensor circuit response

1 - Lubricating oil temperature sensor circuit response

Solution: S00000371

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine oil temperature sensor has been detected if the following fault code became active with the sensor disconnected: 212

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 214 | SPN: 175 | FMI: 0
Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Lubricating oil thermostat is malfunctioning
  4. Lubricating oil cooler is malfunctioning or restricted
  5. Lubricating oil cooler is leaking
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00008424

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 146, 151, 2113, 2114, 2963, 4629, 4631, 5224

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil thermostat is malfunctioning

Solution: S00000811

Verification

Conditions

  • None

Action

  • Check the lubricating oil thermostat for proper operation.

Refer to Procedure 007-039

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning oil thermostat has been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil thermostat.

Refer to Procedure 007-039

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil cooler is malfunctioning or restricted

Solution: S00000543

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the lubricating oil cooler for debris.

Refer to Procedure 007-003

Specification

  • If debris is found in the lubricating oil cooler, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the lubricating oil cooler.

Refer to Procedure 007-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil cooler is leaking

Solution: S00000810

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Pressure test the lubricating oil cooler.

Refer to Procedure 007-003

Specification

  • If there are any lubricating oil cooler leaks during the pressure test or any damage is observed during inspection, then a malfunctioning lubricating oil cooler or gaskets have been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil cooler.

Refer to Procedure 007-003

  • Replace the lubricating oil cooler element, mounting plate gasket or o-ring.

Refer to Procedure 007-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 221 | SPN: 108 | FMI: 3
Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Barometric pressure sensor voltage check
  3. Barometric pressure sensor voltage check at the ECM
  4. Barometric pressure sensor circuit response
  5. Barometric sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000060

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 386
  • Sensor supply 2: 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Barometric pressure sensor voltage check

Solution: S00001076

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Barometric pressure sensor voltage check at the ECM

Refer to S00001077

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Barometric pressure sensor voltage check at the ECM

Solution: S00001077

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Barometric pressure sensor circuit response

Solution: S00000372

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning barometric pressure sensor has been detected if the following fault code became active with the sensor disconnected: 222

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Barometric sensor circuit response at the ECM

Solution: S00000579

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 222
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 222

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 222 | SPN: 108 | FMI: 4
Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Barometric pressure sensor voltage check
  2. Barometric pressure sensor voltage check at the ECM
  3. Barometric pressure sensor circuit response
  4. Barometric sensor circuit response at the ECM

1 - Barometric pressure sensor voltage check

Solution: S00001076

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Barometric pressure sensor voltage check at the ECM

Refer to S00001077

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Barometric pressure sensor voltage check at the ECM

Solution: S00001077

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Barometric pressure sensor circuit response

Solution: S00000373

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning barometric pressure sensor has been detected if the following fault code became active with the jumper wire in place: 221

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Barometric sensor circuit response at the ECM

Solution: S00000581

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 221
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 221

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISM CM875

Fault Code: 227 | SPN: 3510 | FMI: 3
Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 2 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 2 voltage above normal

Solution: S00000992

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 227
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 227

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 238 | SPN: 3511 | FMI: 4
Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 3 voltage below normal
  2. ECM calibration revision history check

1 - ECM sensor supply 3 voltage below normal

Solution: S00003569

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft speed/position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning crankshaft speed/position senor has been detected if the following fault code became active with the sensor disconnected: 238

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-038

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 241 | SPN: 84 | FMI: 2
Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Vehicle speed sensor resistance check
  2. Vehicle speed sensor tampering
  3. Incorrect vehicle speed sensor configuration
  4. Vehicle speed sensor open circuit check
  5. Vehicle speed sensor circuit pin to ground short
  6. Vehicle speed sensor circuit pin to pin short
  7. Mechanical gear slippage causing erratic wheel speed data
  8. ECM calibration revision history check

1 - Vehicle speed sensor resistance check

Solution: S00003664

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Refer to OEM Service Manual

Specification

  • If the resistance is not within specification, then a malfunctioning vehicle speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to ground short

Solution: S00000827

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Mechanical gear slippage causing erratic wheel speed data

Solution: S00000829

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the vehicle speed sensor from the transmission.

Refer to OEM Service Manual

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal.

Refer to OEM Service Manual

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If any slippage of the tone wheel or gear relative to the shaft is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the gear or tone wheel.

Refer to OEM Service Manual

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 242 | SPN: 84 | FMI: 10
Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Troubleshooting Summary

  1. Incorrect vehicle speed signal
  2. Vehicle speed sensor tampering
  3. Incorrect vehicle speed sensor configuration
  4. Vehicle speed sensor open circuit check
  5. Vehicle speed sensor circuit pin to ground short
  6. Vehicle speed sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Incorrect vehicle speed signal

Solution: S00003601

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the vehicle speed sensor while the vehicle is stationary.
  • Drive vehicle or test on chassis dynamometer.
  • Compare the sensor reading from the recommended Cummins® electronic service tool or equivalent to the reading on the vehicle dash.

Specification

  • If the recommended Cummins® electronic service tool or equivalent and vehicle dash reading do not match, then an incorrect parameter setting has been detected.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to ground short

Solution: S00000827

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 245 | SPN: 647 | FMI: 4
Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fan control solenoid resistance check
  2. Fan control solenoid circuit pin to ground short
  3. Fan control solenoid circuit pin to pin short
  4. Fan control solenoid is malfunctioning

1 - Fan control solenoid resistance check

Solution: S00001059

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the fan control solenoid.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the fan control solenoid resistance does not meet specification, then a malfunctioning fan control solenoid has been detected.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan control solenoid circuit pin to ground short

Solution: S00001060

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Fan control solenoid circuit pin to pin short

Solution: S00004897

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fan control solenoid is malfunctioning

Solution: S00005653

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISM CM875

Fault Code: 249 | SPN: 171 | FMI: 3
Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Ambient air temperature sensor open circuit check
  2. Ambient air temperature sensor circuit pin to pin short
  3. ECM calibration revision history check

1 - Ambient air temperature sensor open circuit check

Solution: S00000833

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor RETURN pin and OEM wiring harness ambient air temperature sensor connector RETURN pin
  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor SIGNAL pin and OEM wiring harness ambient air temperature sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 254 | SPN: 632 | FMI: 4
Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fuel shutoff valve is malfunctioning
  2. Fuel shutoff valve resistance check
  3. Fuel shutoff valve circuit pin to ground short
  4. Fuel shutoff valve circuit pin to pin short
  5. ECM calibration revision history check

1 - Fuel shutoff valve is malfunctioning

Solution: S00003449

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuel shutoff valve.

Refer to Procedure 005-043

Specification

  • If a specification is not met, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuel shutoff valve.

Refer to Procedure 005-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel shutoff valve resistance check

Solution: S00003808

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine wiring harness.

Action

  • Measure the fuel shutoff valve resistance.

Refer to Procedure 019-050

Specification

  • If the fuel shutoff valve solenoid resistance does not meet specification, then a malfunctioning fuel shutoff valve solenoid has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel shutoff valve.

Refer to Procedure 019-050

Validation

  • None
Next Solution

3 - Fuel shutoff valve circuit pin to ground short

Solution: S00003613

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel shutoff valve circuit pin to pin short

Solution: S00003466

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 255 | SPN: 632 | FMI: 3
Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fuel shutoff valve is malfunctioning
  2. Fuel shutoff valve voltage check
  3. Fuel shutoff valve voltage check at the ECM
  4. Fuel shutoff valve open circuit check
  5. Fuel shutoff valve circuit pin to ground short
  6. Fuel shutoff valve circuit pin to pin short
  7. ECM calibration revision history check

1 - Fuel shutoff valve is malfunctioning

Solution: S00003449

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuel shutoff valve.

Refer to Procedure 005-043

Specification

  • If a specification is not met, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuel shutoff valve.

Refer to Procedure 005-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel shutoff valve voltage check

Solution: S00003446

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the fuel shutoff actuator SIGNAL pin and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Fuel shutoff valve voltage check at the ECM

Refer to S00003447

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel shutoff valve voltage check at the ECM

Solution: S00003447

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the fuel shutoff actuator SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 11 - 13 VDC
  • A malfunctioning ECM has been detected if the voltage is not within the following specification of battery voltage: 11 - 13 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel shutoff valve open circuit check

Solution: S00004588

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the fuel shutoff valve engine wiring harness connector and the fuel shutoff valve SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fuel shutoff valve RETURN pin at the fuel shutoff valve engine wiring harness connector and the fuel shutoff valve RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel shutoff valve circuit pin to ground short

Solution: S00003613

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel shutoff valve circuit pin to pin short

Solution: S00003466

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 256 | SPN: 171 | FMI: 4
Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Ambient air temperature sensor circuit pin to ground short
  2. Ambient air temperature sensor circuit pin to pin short
  3. ECM calibration revision history check

1 - Ambient air temperature sensor circuit pin to ground short

Solution: S00003624

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 257 | SPN: 632 | FMI: 7
Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Fuel shutoff valve is malfunctioning
  2. Fuel rail pressure sensor is malfunctioning

1 - Fuel shutoff valve is malfunctioning

Solution: S00003449

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuel shutoff valve.

Refer to Procedure 005-043

Specification

  • If a specification is not met, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuel shutoff valve.

Refer to Procedure 005-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel rail pressure sensor is malfunctioning

Solution: S00003535

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Install a mechanical gauge on the engine.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • A malfunctioning fuel rail pressure sensor has been detected if the reading is not within the following specification: 69 kPa [10 psi]

Linked Solutions

  • None

Repair

  • Replace the fuel pressure sensor.

Refer to Procedure 019-115

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 27-Mar-2022


NO TITLE

ISM CM875

Fault Code: 285 | SPN: 639 | FMI: 9
SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 286 | SPN: 639 | FMI: 13
J1939 Network #1 - Out of Calibration

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 287 | SPN: 91 | FMI: 19
Accelerator Pedal Position 1 - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISM CM875

Fault Code: 288 | SPN: 974 | FMI: 19
SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 295 | SPN: 108 | FMI: 2
Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Barometric pressure sensor is malfunctioning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Barometric pressure sensor is malfunctioning

Solution: S00004225

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 311 | SPN: 651 | FMI: 6
Injector Solenoid Driver 1 Circuit - Current Above Normal or Grounded Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has a short or grounded circuit

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has a short or grounded circuit

Solution: S00000524

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the internal actuator harness from the fuel injector solenoid.
  • Remove the fuel injector solenoid wires from the solenoid.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector (+) pin and the engine block ground.
  • Measure the resistance between the fuel injector (-) pin and the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 312 | SPN: 655 | FMI: 6
Injector Solenoid Driver 5 Circuit - Current Above Normal or Grounded Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has a short or grounded circuit

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has a short or grounded circuit

Solution: S00000524

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the internal actuator harness from the fuel injector solenoid.
  • Remove the fuel injector solenoid wires from the solenoid.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector (+) pin and the engine block ground.
  • Measure the resistance between the fuel injector (-) pin and the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 313 | SPN: 653 | FMI: 6
Injector Solenoid Driver 3 Circuit - Current Above Normal or Grounded Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has a short or grounded circuit

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has a short or grounded circuit

Solution: S00000524

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the internal actuator harness from the fuel injector solenoid.
  • Remove the fuel injector solenoid wires from the solenoid.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector (+) pin and the engine block ground.
  • Measure the resistance between the fuel injector (-) pin and the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 314 | SPN: 656 | FMI: 6
Injector Solenoid Driver 6 Circuit - Current Above Normal or Grounded Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has a short or grounded circuit

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has a short or grounded circuit

Solution: S00000524

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the internal actuator harness from the fuel injector solenoid.
  • Remove the fuel injector solenoid wires from the solenoid.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector (+) pin and the engine block ground.
  • Measure the resistance between the fuel injector (-) pin and the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 315 | SPN: 652 | FMI: 6
Injector Solenoid Driver 2 Circuit - Current Above Normal or Grounded Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has a short or grounded circuit

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has a short or grounded circuit

Solution: S00000524

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the internal actuator harness from the fuel injector solenoid.
  • Remove the fuel injector solenoid wires from the solenoid.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector (+) pin and the engine block ground.
  • Measure the resistance between the fuel injector (-) pin and the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 319 | SPN: 251 | FMI: 2
Real Time Clock - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Real-time clock power interrupted or is incorrect
  2. Low real-time clock battery voltage
  3. Engine wiring harness has a pin to pin short
  4. ECM calibration revision history check

1 - Real-time clock power interrupted or is incorrect

Solution: S00000525

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Select Advanced ECM Data - Real Time Clock Settings.
  • Check if the address for the Real Time Clock signal is correct per OEM specification.
  • Check to ensure Real Time Clock is enabled and adjust "Auto Set" if required.

Refer to Procedure 019-311

Specification

  • None

Linked Solutions

  • None

Repair

  • Modify the real-time clock battery setting to the correct configuration.

Refer to Procedure 019-311

  • Enable the real time clock.

Refer to Procedure 019-311

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Low real-time clock battery voltage

Solution: S00000526

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine wiring harness.

Action

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Specification

  • Voltage must be within the following specification: 3.3 - 3.6 VDC

Linked Solutions

  • None

Repair

  • Replace the real-time clock battery.

Refer to Procedure 019-311

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine wiring harness has a pin to pin short

Solution: S00001967

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the real time clock battery SUPPLY pin at the ECM connector of the engine wiring harness and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 321 | SPN: 654 | FMI: 6
Injector Solenoid Driver 4 Circuit - Current Above Normal or Grounded Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has a short or grounded circuit

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has a short or grounded circuit

Solution: S00000524

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the internal actuator harness from the fuel injector solenoid.
  • Remove the fuel injector solenoid wires from the solenoid.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector (+) pin and the engine block ground.
  • Measure the resistance between the fuel injector (-) pin and the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 322 | SPN: 651 | FMI: 5
Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has an open circuit
  3. Fuel injector solenoid resistance check
  4. Injector solenoid driver open circuit check
  5. Fuel injector driver solenoid circuit pin to ground short
  6. Fuel injector solenoid to engine block ground resistance check
  7. Injector driver solenoid circuit pin to pin short
  8. ECM fuel injector solenoid driver is malfunctioning

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has an open circuit

Solution: S00003456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL pin and the fuel injector solenoid RETURN pin of the ECM engine wiring harness connector for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • Fuel injector solenoid resistance check

Refer to S00003457

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel injector solenoid resistance check

Solution: S00003457

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • Proceed to the next solution if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector solenoid driver open circuit check

Solution: S00003690

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the appropriate fuel injector solenoid SIGNAL pin at the engine wiring harness fuel injector connector and the fuel injector solenoid SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the appropriate fuel injector solenoid RETURN pin at the engine wiring harness fuel injector connector and the fuel injector solenoid RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 323 | SPN: 655 | FMI: 5
Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has an open circuit
  3. Fuel injector solenoid resistance check
  4. Injector solenoid driver open circuit check
  5. Fuel injector driver solenoid circuit pin to ground short
  6. Fuel injector solenoid to engine block ground resistance check
  7. Injector driver solenoid circuit pin to pin short
  8. ECM fuel injector solenoid driver is malfunctioning

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has an open circuit

Solution: S00003456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL pin and the fuel injector solenoid RETURN pin of the ECM engine wiring harness connector for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • Fuel injector solenoid resistance check

Refer to S00003457

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel injector solenoid resistance check

Solution: S00003457

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • Proceed to the next solution if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector solenoid driver open circuit check

Solution: S00003690

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the appropriate fuel injector solenoid SIGNAL pin at the engine wiring harness fuel injector connector and the fuel injector solenoid SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the appropriate fuel injector solenoid RETURN pin at the engine wiring harness fuel injector connector and the fuel injector solenoid RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 324 | SPN: 653 | FMI: 5
Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has an open circuit
  3. Fuel injector solenoid resistance check
  4. Injector solenoid driver open circuit check
  5. Fuel injector driver solenoid circuit pin to ground short
  6. Fuel injector solenoid to engine block ground resistance check
  7. Injector driver solenoid circuit pin to pin short
  8. ECM fuel injector solenoid driver is malfunctioning

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has an open circuit

Solution: S00003456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL pin and the fuel injector solenoid RETURN pin of the ECM engine wiring harness connector for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • Fuel injector solenoid resistance check

Refer to S00003457

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel injector solenoid resistance check

Solution: S00003457

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • Proceed to the next solution if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector solenoid driver open circuit check

Solution: S00003690

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the appropriate fuel injector solenoid SIGNAL pin at the engine wiring harness fuel injector connector and the fuel injector solenoid SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the appropriate fuel injector solenoid RETURN pin at the engine wiring harness fuel injector connector and the fuel injector solenoid RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 325 | SPN: 656 | FMI: 5
Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has an open circuit
  3. Fuel injector solenoid resistance check
  4. Injector solenoid driver open circuit check
  5. Fuel injector driver solenoid circuit pin to ground short
  6. Fuel injector solenoid to engine block ground resistance check
  7. Injector driver solenoid circuit pin to pin short
  8. ECM fuel injector solenoid driver is malfunctioning

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has an open circuit

Solution: S00003456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL pin and the fuel injector solenoid RETURN pin of the ECM engine wiring harness connector for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • Fuel injector solenoid resistance check

Refer to S00003457

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel injector solenoid resistance check

Solution: S00003457

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • Proceed to the next solution if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector solenoid driver open circuit check

Solution: S00003690

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the appropriate fuel injector solenoid SIGNAL pin at the engine wiring harness fuel injector connector and the fuel injector solenoid SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the appropriate fuel injector solenoid RETURN pin at the engine wiring harness fuel injector connector and the fuel injector solenoid RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 331 | SPN: 652 | FMI: 5
Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has an open circuit
  3. Fuel injector solenoid resistance check
  4. Injector solenoid driver open circuit check
  5. Fuel injector driver solenoid circuit pin to ground short
  6. Fuel injector solenoid to engine block ground resistance check
  7. Injector driver solenoid circuit pin to pin short
  8. ECM fuel injector solenoid driver is malfunctioning

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has an open circuit

Solution: S00003456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL pin and the fuel injector solenoid RETURN pin of the ECM engine wiring harness connector for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • Fuel injector solenoid resistance check

Refer to S00003457

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel injector solenoid resistance check

Solution: S00003457

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • Proceed to the next solution if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector solenoid driver open circuit check

Solution: S00003690

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the appropriate fuel injector solenoid SIGNAL pin at the engine wiring harness fuel injector connector and the fuel injector solenoid SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the appropriate fuel injector solenoid RETURN pin at the engine wiring harness fuel injector connector and the fuel injector solenoid RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 332 | SPN: 654 | FMI: 5
Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector solenoid has an open circuit
  3. Fuel injector solenoid resistance check
  4. Injector solenoid driver open circuit check
  5. Fuel injector driver solenoid circuit pin to ground short
  6. Fuel injector solenoid to engine block ground resistance check
  7. Injector driver solenoid circuit pin to pin short
  8. ECM fuel injector solenoid driver is malfunctioning

1 - Check for primary fault codes

Solution: S00004294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111.
  • Fuel: 351.

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector solenoid has an open circuit

Solution: S00003456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL pin and the fuel injector solenoid RETURN pin of the ECM engine wiring harness connector for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • Fuel injector solenoid resistance check

Refer to S00003457

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel injector solenoid resistance check

Solution: S00003457

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • Proceed to the next solution if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector solenoid driver open circuit check

Solution: S00003690

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the appropriate fuel injector solenoid SIGNAL pin at the engine wiring harness fuel injector connector and the fuel injector solenoid SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the appropriate fuel injector solenoid RETURN pin at the engine wiring harness fuel injector connector and the fuel injector solenoid RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 338 | SPN: 1267 | FMI: 3
Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Idle shutdown vehicle accessory relay is malfunctioning
  3. Idle shutdown relay open circuit check
  4. Idle shutdown relay SIGNAL pin short in the OEM power wiring harness
  5. Idle shutdown relay circuit pin to pin short

1 - Incorrect adjustable parameter setting

Solution: S00001166

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Go to Features and Parameters.

Specification

  • If the vehicle has an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Installed".
  • If the vehicle does not have an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Not Installed".

Linked Solutions

  • None

Repair

  • Correct the Idle Shutdown feature setup.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Idle shutdown vehicle accessory relay is malfunctioning

Solution: S00000520

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace idle shutdown relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Idle shutdown relay open circuit check

Solution: S00000847

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay RETURN pin at the idle shutdown relay connector to ground.
  • Measure the resistance between the engine wiring harness ECM connector idle shutdown relay RETURN pin and the OEM wiring harness idle shutdown relay connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Idle shutdown relay SIGNAL pin short in the OEM power wiring harness

Solution: S00001165

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM power supply wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (+) pin of the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (-) pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Idle shutdown relay circuit pin to pin short

Solution: S00000521

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (+) pin of the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (-) pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 339 | SPN: 1267 | FMI: 4
Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Idle shutdown vehicle accessory relay is malfunctioning
  3. Idle shutdown relay voltage check
  4. Idle shutdown relay SIGNAL and RETURN wires resistance check
  5. Idle shutdown relay SIGNAL wire short to ground in OEM wiring harness
  6. Idle shutdown relay SIGNAL pin short in the OEM power wiring harness
  7. Idle shutdown relay circuit pin to pin short

1 - Incorrect adjustable parameter setting

Solution: S00001166

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Go to Features and Parameters.

Specification

  • If the vehicle has an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Installed".
  • If the vehicle does not have an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Not Installed".

Linked Solutions

  • None

Repair

  • Correct the Idle Shutdown feature setup.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Idle shutdown vehicle accessory relay is malfunctioning

Solution: S00000520

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace idle shutdown relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Idle shutdown relay voltage check

Solution: S00000528

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin at the idle shutdown relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Idle shutdown relay SIGNAL and RETURN wires resistance check

Refer to S00000529

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Idle shutdown relay SIGNAL and RETURN wires resistance check

Solution: S00000529

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin at the idle shutdown relay connector of the OEM wiring harness and the idle shutdown relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay RETURN pin at the idle shutdown relay connector of the OEM wiring harness and the idle shutdown relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Idle shutdown relay SIGNAL wire short to ground in OEM wiring harness

Solution: S00000527

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Idle shutdown relay SIGNAL pin short in the OEM power wiring harness

Solution: S00001165

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM power supply wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (+) pin of the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (-) pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Idle shutdown relay circuit pin to pin short

Solution: S00000521

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (+) pin of the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (-) pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 343 | SPN: 629 | FMI: 12
Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Engine crankshaft speed/position sensor is malfunctioning
  3. Charging system alternator is malfunctioning
  4. Keyswitch open circuit check
  5. ECM calibration revision history check
  6. ECM Malfunction

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine crankshaft speed/position sensor is malfunctioning

Solution: S00003612

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the crankshaft position sensor.

Refer to Procedure 019-038

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace crankshaft position sensor.

Refer to Procedure 019-038

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Keyswitch open circuit check

Solution: S00000530

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM Malfunction

Solution: S00001622

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 346 | SPN: 630 | FMI: 12
Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00002237

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.

Verify the following parameters:

Refer to Procedure 019-078

  • Accelerator interlock switch.
  • Powertrain protection torque limit switch.
  • Clutch pedal position switch.
  • Engine protection shutdown manual override switch.
  • Idle shutdown accessory relay.
  • Engine brake lamp output.
  • Air shutoff valve.

Specification

  • If the adjustable parameter setting and application do not match, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 351 | SPN: 3597 | FMI: 12
Injector Power Supply - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. ECM calibration revision history check
  3. Internal ECM Error

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Internal ECM Error

Solution: S00001230

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 352 | SPN: 3509 | FMI: 4
Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 1 voltage below normal

1 - ECM sensor supply 1 voltage below normal

Solution: S00006150

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Perform the following actions one at a time:
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the tachograph speed sensor from the OEM wiring harness.
  • Disconnect the engine barometric pressure sensor from the engine wiring harness.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the vehicle speed sensor.

Refer to OEM Service Manual

  • Replace accelerator pedal or lever position sensor.

Refer to OEM Service Manual

  • Replace the tachograph speed sensor.

Refer to OEM Service Manual

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

  • Replace camshaft position sensor.

Refer to Procedure 019-038

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 13-Dec-2020


NO TITLE

ISM CM875

Fault Code: 386 | SPN: 3509 | FMI: 3
Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 1 voltage above normal
  2. Sensor supply 1 voltage check
  3. Sensor supply 1 voltage check
  4. ECM calibration revision history check

1 - ECM sensor supply 1 voltage above normal

Solution: S00002196

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 386
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 386

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Sensor supply 1 voltage check

Solution: S00001467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the sensor SUPPLY pin of the OEM wiring harness ECM connector to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Sensor supply 1 voltage check at ECM

Refer to S00000618

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Sensor supply 1 voltage check

Solution: S00000618

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the OEM power supply wiring harness connector from the ECM.

Action

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM wiring harness ECM connector to the ECM battery (+) pins at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning ECM has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 415 | SPN: 100 | FMI: 1
Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Contaminated lubricating oil
  4. Lubricating oil pressure sensor stuck in-range
  5. Lubricating oil pressure relief valve is malfunctioning
  6. Loose or broken lubricating oil suction tube
  7. Main lubricating oil pressure regulator is malfunctioning
  8. Lubricating oil pump is malfunctioning
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000078

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 135, 141
  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Contaminated lubricating oil

Solution: S00000462

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00000471

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Loose or broken lubricating oil suction tube

Solution: S00002808

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pan.

Refer to Procedure 007-025

  • Inspect the lubricating oil suction tube and o-ring for damage.

Refer to Procedure 007-025

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil suction tube o-ring or the damaged lubricating oil suction tube.

Refer to Procedure 007-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00001453

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-029

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-029

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Lubricating oil pump is malfunctioning

Solution: S00000472

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pump.

Refer to Procedure 007-031

  • Inspect the lubricating oil pump.

Refer to Procedure 007-031

If the lubricating oil pump was found to be damaged, then inspect the lubricating oil filter for metal.

Specification

  • If damaged, loose or worn gears are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pump.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 418 | SPN: 97 | FMI: 15
Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Water accumulation in the fuel filter
  2. Water in fuel sensor circuit pin to ground short
  3. ECM calibration revision history check

1 - Water accumulation in the fuel filter

Solution: S00000545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Water has been detected in the fuel filter if a fault code from the following list is active, or has more than one inactive count within the last 25 engine operating hours: 418, 1852, 4642

Linked Solutions

  • None

Repair

  • Open the water drain from the bottom of the fuel filter to remove the water from the fuel filter.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor circuit pin to ground short

Solution: S00000874

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the water in fuel sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 421 | SPN: 175 | FMI: 16
Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Lubricating oil thermostat is malfunctioning
  4. Lubricating oil cooler is malfunctioning or restricted
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00008424

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 146, 151, 2113, 2114, 2963, 4629, 4631, 5224

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil thermostat is malfunctioning

Solution: S00000811

Verification

Conditions

  • None

Action

  • Check the lubricating oil thermostat for proper operation.

Refer to Procedure 007-039

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning oil thermostat has been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil thermostat.

Refer to Procedure 007-039

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil cooler is malfunctioning or restricted

Solution: S00000543

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the lubricating oil cooler for debris.

Refer to Procedure 007-003

Specification

  • If debris is found in the lubricating oil cooler, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the lubricating oil cooler.

Refer to Procedure 007-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 427 | SPN: 639 | FMI: 9
J1939 Network #1 - Abnormal Update Rate

Troubleshooting Summary

  1. ECM data link malfunction
  2. Incorrectly programmed OEM multiplexing unit
  3. ECM calibration revision history check

1 - ECM data link malfunction

Solution: S00003428

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the J1939 communications between the recommended Cummins® electronic service tool or equivalent and the ECM.

Specification

  • If communication between the ECM and the recommended Cummins® electronic service tool or equivalent can be established, then a malfunctioning OEM SAE J1939 data link circuit has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace OEM side of SAE J1939 data link circuit.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 428 | SPN: 97 | FMI: 3
Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Incorrect water-in-fuel sensor installed
  2. Water in fuel sensor open circuit check
  3. Water in fuel sensor circuit pin to pin short

1 - Incorrect water-in-fuel sensor installed

Solution: S00000588

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct water-in-fuel sensor is being used for the engine application.

Specification

  • If the water in fuel sensor is not the correct sensor part number for the engine configuration, then the incorrect sensor has been installed.

Linked Solutions

  • None

Repair

  • Install the correct water in fuel sensor for the engine configuration.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor open circuit check

Solution: S00003997

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the water-in-fuel sensor engine wiring harness connector and the water-in-fuel sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the water-in-fuel sensor RETURN pin at the water-in-fuel sensor engine wiring harness connector and the water-in-fuel sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Water in fuel sensor circuit pin to pin short

Solution: S00004266

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISM CM875

Fault Code: 429 | SPN: 97 | FMI: 4
Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Water in fuel sensor circuit pin to ground short
  2. Water in fuel sensor circuit pin to pin short

1 - Water in fuel sensor circuit pin to ground short

Solution: S00000874

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the water in fuel sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor circuit pin to pin short

Solution: S00004266

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 431 | SPN: 558 | FMI: 2
Accelerator Pedal or Lever Idle Validation Switch - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Idle validation switch resistance check
  2. Accelerator pedal position sensor circuit pin to pin short

1 - Idle validation switch resistance check

Solution: S00002023

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle validation idle SIGNAL pin and switch RETURN pin at the accelerator pedal assembly connector with the pedal released.
  • Measure the resistance between the idle validation OFF idle SIGNAL pin and switch RETURN pin at the accelerator pedal assembly connector with the pedal depressed.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is greater than 10 Ω on a Nonintegrated sensor, then a malfunctioning accelerator pedal assembly has been detected.
  • If the resistance is greater than 125 Ω on a Integrated sensor, then a malfunctioning accelerator pedal assembly has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00003046

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 432 | SPN: 558 | FMI: 13
Accelerator Pedal or Lever Idle Validation Switch Circuit - Out of Calibration

Troubleshooting Summary

  1. Accelerator pedal sensor malfunctioning
  2. Accelerator pedal position sensor circuit pin to pin short
  3. Accelerator pedal is malfunctioning

1 - Accelerator pedal sensor malfunctioning

Solution: S00001713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the accelerator pedal position sensor.

Refer to Procedure 019-085

Specification

  • If the resistance is not within specification, then a malfunctioning accelerator pedal or lever sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to Procedure 019-085

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00003046

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISM CM875

Fault Code: 435 | SPN: 100 | FMI: 2
Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Lubricating oil pressure sensor stuck in-range
  2. Lubricating oil pressure check
  3. Lubricating oil pressure relief valve is malfunctioning
  4. Main lubricating oil pressure regulator is malfunctioning
  5. ECM calibration revision history check

1 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Lubricating oil pressure check

Solution: S00003162

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Install a mechanical gauge on the engine.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Monitor the lubricating oil pressure.

Specification

  • If the lubricating oil pressure is not within specification, then proceed to the Linked Solutions section.

Refer to Procedure 018-017

Linked Solutions

  • Lubricating oil pressure relief valve is malfunctioning

Refer to S00004717

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00004717

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Perform following checks for progressive damage.

  • Perform the oil filter analysis.

Refer to Procedure 007-083

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00001453

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-029

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-029

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 441 | SPN: 168 | FMI: 18
Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM battery voltage check
  4. Unswitched battery open circuit check
  5. Unswitched battery circuit pin to pin short
  6. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM battery voltage check

Solution: S00002091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the ECM battery SUPPLY pin at the OEM wiring harness 4 pin connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Unswitched battery circuit pin to pin short

Solution: S00002997

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 442 | SPN: 168 | FMI: 16
Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 584 | SPN: 677 | FMI: 3
Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay open circuit check
  3. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay open circuit check

Solution: S00000642

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.
  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 585 | SPN: 677 | FMI: 4
Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay circuit pin to ground short
  3. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay circuit pin to ground short

Solution: S00000650

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 596 | SPN: 167 | FMI: 16
Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 597 | SPN: 167 | FMI: 18
Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Loose alternator belt
  3. Charging system alternator is malfunctioning
  4. ECM battery voltage check
  5. Unswitched battery open circuit check
  6. Loose charging system alternator pulley
  7. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Loose alternator belt

Solution: S00000665

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the alternator belt tension.

Refer to Procedure 013-005

  • Inspect the automatic charging system alternator belt tensioner for correct operation.

Refer to Procedure 013-021

Specification

  • If the belt tension does not meet specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the alternator belt to the proper belt tension.

Refer to Procedure 013-005

  • Replace the alternator belt.

Refer to Procedure 013-005

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM battery voltage check

Solution: S00002091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the ECM battery SUPPLY pin at the OEM wiring harness 4 pin connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Loose charging system alternator pulley

Solution: S00000666

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the alternator pulley for damage.

Refer to Procedure 013-006

  • Check the charging system alternator pulley nut torque.

Refer to Procedure 013-006

Specification

  • If damage has been observed or if alternator pulley nut torque is out of specification, the proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace or adjust the charging system alternator pulley so that it is tight on the shaft.

Refer to Procedure 013-006

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 598 | SPN: 167 | FMI: 1
Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Loose alternator belt
  3. Charging system alternator is malfunctioning
  4. Unswitched battery open circuit check
  5. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Loose alternator belt

Solution: S00000665

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the alternator belt tension.

Refer to Procedure 013-005

  • Inspect the automatic charging system alternator belt tensioner for correct operation.

Refer to Procedure 013-021

Specification

  • If the belt tension does not meet specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the alternator belt to the proper belt tension.

Refer to Procedure 013-005

  • Replace the alternator belt.

Refer to Procedure 013-005

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 629 | SPN: 1176 | FMI: 18
Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Restricted intake air filter
  2. Plugged external crankcase breather tube
  3. Leaks in the intake air system
  4. Charge air cooler system leak
  5. Turbocharger is malfunctioning
  6. ECM calibration revision history check

1 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger is malfunctioning

Solution: S00000780

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 649 | SPN: 1378 | FMI: 31
Engine Oil Change Interval - Condition Exists

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Oil change interval maintenance warning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Oil change interval maintenance warning

Solution: S00000671

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then the lubricating oil maintenance interval has been exceeded.

Linked Solutions

  • None

Repair

  • Change the lubricating oil.

Refer to Procedure 007-037

  • Change the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 686 | SPN: 103 | FMI: 2
Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Turbocharger speed sensor is malfunctioning
  2. Turbocharger speed sensor resistance check
  3. Turbocharger speed sensor open circuit check
  4. Turbocharger speed sensor is malfunctioning

1 - Turbocharger speed sensor is malfunctioning

Solution: S00002831

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the turbocharger speed sensor from the turbocharger housing.

Refer to Procedure 019-390

  • Visually inspect the turbocharger speed sensor tip for damage.

Refer to Procedure 019-390

Specification

  • If the turbocharger speed sensor tip is damaged, then a malfunctioning turbocharger speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger speed sensor resistance check

Solution: S00002828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SUPPLY pin and the turbocharger speed sensor RETURN pin at the sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is not within the following specification: 600 - 1600 Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger speed sensor open circuit check

Solution: S00000653

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SIGNAL pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the turbocharger speed sensor RETURN pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger speed sensor is malfunctioning

Solution: S00000651

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 687 | SPN: 103 | FMI: 18
Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger speed sensor is malfunctioning
  3. Turbocharger speed sensor resistance check
  4. Turbocharger speed sensor open circuit check
  5. ECM calibration revision history check
  6. Turbocharger speed sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000112

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Barometric pressure: 221, 222

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger speed sensor is malfunctioning

Solution: S00002831

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the turbocharger speed sensor from the turbocharger housing.

Refer to Procedure 019-390

  • Visually inspect the turbocharger speed sensor tip for damage.

Refer to Procedure 019-390

Specification

  • If the turbocharger speed sensor tip is damaged, then a malfunctioning turbocharger speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger speed sensor resistance check

Solution: S00002828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SUPPLY pin and the turbocharger speed sensor RETURN pin at the sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is not within the following specification: 600 - 1600 Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger speed sensor open circuit check

Solution: S00000653

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SIGNAL pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the turbocharger speed sensor RETURN pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger speed sensor is malfunctioning

Solution: S00000651

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 689 | SPN: 190 | FMI: 2
Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Engine speed sensor voltage check
  2. Engine speed sensor voltage check at the ECM
  3. Engine crankshaft speed/position sensor check
  4. ECM calibration revision history check

1 - Engine speed sensor voltage check

Solution: S00001850

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the engine speed sensor SUPPLY pin and the engine speed sensor RETURN pin at the sensor connector of the engine wiring harness.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine speed sensor voltage check at ECM

Refer to S00001851

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Engine speed sensor voltage check at the ECM

Solution: S00001851

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Measure the voltage between the engine speed sensor SUPPLY pin and the engine speed sensor RETURN pin at the ECM.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 691 | SPN: 1172 | FMI: 3
Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Turbocharger compressor intake temperature sensor resistance check
  2. Turbocharger compressor intake temperature sensor circuit response at the ECM

1 - Turbocharger compressor intake temperature sensor resistance check

Solution: S00003441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake temperature sensor SIGNAL pin and the turbocharger compressor intake temperature sensor RETURN pin at the sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning turbocharger compressor intake temperature sensor has been detected if the resistance is not within the following specification: 640 Ω to 62k Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger compressor intake temperature sensor.

Refer to Procedure 019-395

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger compressor intake temperature sensor circuit response at the ECM

Solution: S00000686

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the turbocharger 1 compressor intake temperature sensor SIGNAL pin and the turbocharger 1 compressor intake temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 692
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 692

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 692 | SPN: 1172 | FMI: 4
Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Turbocharger compressor intake temperature sensor circuit response
  2. Turbocharger compressor intake temperature sensor circuit response at the ECM

1 - Turbocharger compressor intake temperature sensor circuit response

Solution: S00000383

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning turbocharger compressor intake temperature sensor has been detected if the following fault code became active with the sensor disconnected: 691

Linked Solutions

  • None

Repair

  • Replace turbocharger compressor intake temperature sensor.

Refer to Procedure 019-395

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger compressor intake temperature sensor circuit response at the ECM

Solution: S00000685

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 691
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 691

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 697 | SPN: 1136 | FMI: 3
Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM Malfunction

1 - ECM Malfunction

Solution: S00003328

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Repair section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 697, 698, 699

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 09-Jan-2022


NO TITLE

ISM CM875

Fault Code: 698 | SPN: 1136 | FMI: 4
Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM Malfunction

1 - ECM Malfunction

Solution: S00003328

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Repair section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 697, 698, 699

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 09-Jan-2022


NO TITLE

ISM CM875

Fault Code: 778 | SPN: 723 | FMI: 2
Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Engine crankshaft speed/position sensor is malfunctioning
  4. Camshaft position sensor voltage check
  5. Camshaft position sensor voltage check at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006538

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00001825

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Voltage: 441, 442

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Engine crankshaft speed/position sensor is malfunctioning

Solution: S00003612

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the crankshaft position sensor.

Refer to Procedure 019-038

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace crankshaft position sensor.

Refer to Procedure 019-038

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Camshaft position sensor voltage check

Solution: S00000693

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Camshaft position sensor voltage check at the ECM

Refer to S00000694

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Camshaft position sensor voltage check at the ECM

Solution: S00000694

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the ECM connector.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 784 | SPN: 1590 | FMI: 2
Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. ECM calibration revision history check

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 1117 | SPN: 3597 | FMI: 2
Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Battery power removed by battery disconnect switch
  2. Battery or battery cables are malfunctioning
  3. ECM battery voltage check
  4. Unswitched battery open circuit check
  5. Keyswitch open circuit check
  6. ECM calibration revision history check

1 - Battery power removed by battery disconnect switch

Solution: S00000706

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify that the battery disconnect switches are being used correctly.

The keyswitch must be turned OFF first for 90 seconds before any battery disconnect switches are turned OFF.

Specification

  • If the battery disconnect switches are not being used correctly, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remind the operator how to correctly use the battery disconnect switches.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM battery voltage check

Solution: S00002091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the ECM battery SUPPLY pin at the OEM wiring harness 4 pin connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Keyswitch open circuit check

Solution: S00000530

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 1239 | SPN: 2623 | FMI: 3
Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Accelerator pedal voltage check
  2. Accelerator pedal circuit check
  3. Accelerator pedal position sensor open circuit check
  4. ECM calibration revision history check
  5. Accelerator pedal is malfunctioning

1 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 1241 | SPN: 2623 | FMI: 4
Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Accelerator pedal voltage check
  2. Accelerator pedal circuit check
  3. Accelerator pedal position sensor open circuit check
  4. Accelerator pedal position sensor circuit pin to ground short
  5. ECM calibration revision history check
  6. Accelerator pedal is malfunctioning

1 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Accelerator pedal position sensor circuit pin to ground short

Solution: S00000448

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 1242 | SPN: 91 | FMI: 2
Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Accelerator pedal voltage check
  2. Accelerator pedal circuit check
  3. Accelerator pedal position sensor open circuit check
  4. ECM calibration revision history check
  5. Accelerator pedal is malfunctioning

1 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 1866 | SPN: 411 | FMI: 2
Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. EGR differential pressure sensor tubes restricted
  2. EGR differential pressure sensor adapter leaking
  3. Leaks in the intake air system
  4. Charge air cooler system leak
  5. ECM calibration revision history check
  6. EGR differential pressure sensor is malfunctioning

1 - EGR differential pressure sensor tubes restricted

Solution: S00003585

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor tubes.

Refer to Procedure 011-026

  • Visually inspect the EGR differential pressure sensor tubes for restrictions.
  • Remove the EGR venturi tube.

Refer to Procedure 011-025

  • Visually inspect the EGR venturi tube for restrictions.

Specification

  • If damage or restrictions are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace EGR venturi tube.

Refer to Procedure 011-025

  • Repair or replace EGR differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR differential pressure sensor adapter leaking

Solution: S00003689

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Visually inspect the EGR differential pressure sensor for leaks at the mounting surface.
  • Visually inspect the aftertreatment differential pressure tubes for proper installation.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 019-370

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - EGR differential pressure sensor is malfunctioning

Solution: S00003480

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 1899 | SPN: 411 | FMI: 18
Exhaust Gas Recirculation Differential Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. EGR differential pressure sensor stuck in-range
  2. EGR differential pressure sensor flow port check
  3. EGR differential pressure sensor tubes restricted
  4. EGR differential pressure sensor adapter leaking
  5. ECM calibration revision history check

1 - EGR differential pressure sensor stuck in-range

Solution: S00000327

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • Proceed to the Linked Solutions section if the EGR differential pressure reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • EGR differential pressure sensor flow port check

Refer to S00002992

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - EGR differential pressure sensor flow port check

Solution: S00002992

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor flow ports.

Refer to Procedure 010-080

  • Clean the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]
  • Plugged EGR differential pressure sensor flow ports has been detected if the reading is within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure ports.

Refer to Procedure 010-080

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - EGR differential pressure sensor tubes restricted

Solution: S00003585

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor tubes.

Refer to Procedure 011-026

  • Visually inspect the EGR differential pressure sensor tubes for restrictions.
  • Remove the EGR venturi tube.

Refer to Procedure 011-025

  • Visually inspect the EGR venturi tube for restrictions.

Specification

  • If damage or restrictions are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace EGR venturi tube.

Refer to Procedure 011-025

  • Repair or replace EGR differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR differential pressure sensor adapter leaking

Solution: S00003689

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Visually inspect the EGR differential pressure sensor for leaks at the mounting surface.
  • Visually inspect the aftertreatment differential pressure tubes for proper installation.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 019-370

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 1943 | SPN: 3555 | FMI: 17
Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Barometric air pressure sensor stuck in-range
  2. ECM calibration revision history check

1 - Barometric air pressure sensor stuck in-range

Solution: S00000340

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the barometric air pressure sensor
  • Compare to the local ambient air pressure.

Refer to Procedure 019-004

Specification

  • A malfunctioning barometric air pressure sensor has been detected if the barometric air pressure sensor is not within the following specification of local ambient air pressure: 51 mm HG [2 in HG]

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2195 | SPN: 703 | FMI: 14
Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

Troubleshooting Summary

  1. Auxiliary commanded dual output shutdown
  2. ECM calibration revision history check

1 - Auxiliary commanded dual output shutdown

Solution: S00002014

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then the engine protection limit has been exceeded.

Linked Solutions

  • None

Repair

  • Engine protection limit that has been exceeded.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2272 | SPN: 27 | FMI: 4
EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR valve position sensor voltage check
  3. EGR valve position sensor voltage check at the ECM
  4. EGR valve is malfunctioning

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR valve position sensor voltage check

Solution: S00000719

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR valve SUPPLY pin and the EGR valve RETURN pin at the EGR valve connector of the engine wiring harness.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • EGR valve position sensor voltage check at the ECM

Refer to S00000720

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - EGR valve position sensor voltage check at the ECM

Solution: S00000720

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR valve SUPPLY pin and the EGR valve RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - EGR valve is malfunctioning

Solution: S00003101

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Reconnect the engine wiring harness connector from the ECM.
  • Reconnect the EGR valve motor to the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 60 seconds.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISM CM875

Fault Code: 2273 | SPN: 411 | FMI: 3
Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR differential pressure sensor stuck in-range
  3. EGR differential pressure sensor flow port check
  4. EGR differential pressure sensor voltage supply check
  5. EGR differential pressure sensor voltage check at the ECM
  6. EGR differential pressure sensor circuit response
  7. EGR differential pressure sensor circuit response at the ECM
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR differential pressure sensor stuck in-range

Solution: S00000327

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • Proceed to the Linked Solutions section if the EGR differential pressure reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • EGR differential pressure sensor flow port check

Refer to S00002992

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - EGR differential pressure sensor flow port check

Solution: S00002992

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor flow ports.

Refer to Procedure 010-080

  • Clean the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]
  • Plugged EGR differential pressure sensor flow ports has been detected if the reading is within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure ports.

Refer to Procedure 010-080

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - EGR differential pressure sensor voltage supply check

Solution: S00000767

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • EGR differential pressure sensor voltage check at the ECM.

Refer to S00000768

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - EGR differential pressure sensor voltage check at the ECM

Solution: S00000768

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - EGR differential pressure sensor circuit response

Solution: S00000366

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the following fault code became active with the sensor disconnected: 2274

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR differential pressure sensor circuit response at the ECM

Solution: S00001239

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2274
  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2274

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2274 | SPN: 411 | FMI: 4
Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR differential pressure sensor stuck in-range
  3. EGR differential pressure sensor flow port check
  4. EGR differential pressure sensor voltage supply check
  5. EGR differential pressure sensor voltage check at the ECM
  6. EGR differential pressure sensor circuit response
  7. EGR differential pressure sensor circuit response at the ECM
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR differential pressure sensor stuck in-range

Solution: S00000327

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • Proceed to the Linked Solutions section if the EGR differential pressure reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • EGR differential pressure sensor flow port check

Refer to S00002992

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - EGR differential pressure sensor flow port check

Solution: S00002992

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor flow ports.

Refer to Procedure 010-080

  • Clean the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]
  • Plugged EGR differential pressure sensor flow ports has been detected if the reading is within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure ports.

Refer to Procedure 010-080

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - EGR differential pressure sensor voltage supply check

Solution: S00000767

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • EGR differential pressure sensor voltage check at the ECM.

Refer to S00000768

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - EGR differential pressure sensor voltage check at the ECM

Solution: S00000768

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - EGR differential pressure sensor circuit response

Solution: S00001121

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the following fault code became active with the jumper wire in place: 2273

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR differential pressure sensor circuit response at the ECM

Solution: S00000592

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2273
  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2273

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2288 | SPN: 103 | FMI: 15
Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Turbocharger speed sensor is malfunctioning
  2. Turbocharger speed sensor resistance check
  3. Turbocharger speed sensor open circuit check
  4. EGR cooler plugged or restricted
  5. ECM calibration revision history check
  6. Turbocharger speed sensor is malfunctioning

1 - Turbocharger speed sensor is malfunctioning

Solution: S00002831

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the turbocharger speed sensor from the turbocharger housing.

Refer to Procedure 019-390

  • Visually inspect the turbocharger speed sensor tip for damage.

Refer to Procedure 019-390

Specification

  • If the turbocharger speed sensor tip is damaged, then a malfunctioning turbocharger speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger speed sensor resistance check

Solution: S00002828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SUPPLY pin and the turbocharger speed sensor RETURN pin at the sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is not within the following specification: 600 - 1600 Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger speed sensor open circuit check

Solution: S00000653

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SIGNAL pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the turbocharger speed sensor RETURN pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR cooler plugged or restricted

Solution: S00003523

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run engine at high idle.
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Monitor the exhaust gas pressure sensor.
  • Monitor the intake manifold pressure sensor.
  • Monitor the EGR valve position.
  • Monitor the EGR Differential Pressure.

Specification

  • The difference between exhaust gas pressure and intake manifold pressure is greater than the following specification: 1016 mm-Hg [40 in-Hg]
  • The EGR valve position is greater than the following specification: 50%
  • The EGR differential pressure is less than the following specification: 102 mm-Hg [4 in-Hg]
  • If all specifications are met, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR cooler.

Refer to Procedure 011-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger speed sensor is malfunctioning

Solution: S00000651

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2319 | SPN: 648 | FMI: 18
Exhaust Back Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Exhaust gas pressure sensor stuck in-range
  2. Plugged or damaged exhaust gas pressure sensor tube
  3. Exhaust gas pressure sensor stuck in-range
  4. Exhaust leak visual check
  5. Plugged or damaged exhaust gas pressure sensor tube

1 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Exhaust leak visual check

Solution: S00001143

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the exhaust system for leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2345 | SPN: 103 | FMI: 10
Turbocharger 1 Speed - Abnormal Rate of Change

Troubleshooting Summary

  1. Turbocharger speed sensor is malfunctioning
  2. Turbocharger speed sensor resistance check
  3. Turbocharger is malfunctioning
  4. Turbocharger speed sensor is malfunctioning

1 - Turbocharger speed sensor is malfunctioning

Solution: S00002831

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the turbocharger speed sensor from the turbocharger housing.

Refer to Procedure 019-390

  • Visually inspect the turbocharger speed sensor tip for damage.

Refer to Procedure 019-390

Specification

  • If the turbocharger speed sensor tip is damaged, then a malfunctioning turbocharger speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger speed sensor resistance check

Solution: S00002828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SUPPLY pin and the turbocharger speed sensor RETURN pin at the sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is not within the following specification: 600 - 1600 Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger is malfunctioning

Solution: S00000780

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger speed sensor is malfunctioning

Solution: S00000651

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 2346 | SPN: 2789 | FMI: 15
Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Leaks in the intake air system
  3. Charge air cooler system leak
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001559

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 124, 125, 2973
  • Turbocharger: 2387, 2451
  • EGR differential pressure: 2359
  • EGR: 2962
  • Aftertreatment differential pressure: 2639, 1921
  • Aftertreatment DOC: 2637
  • Aftertreatment regeneration: 2777

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2347 | SPN: 2629 | FMI: 15
Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Barometric air pressure sensor stuck in-range
  3. Leaks in the intake air system
  4. Charge air cooler system leak
  5. Intake manifold pressure sensor stuck in-range

1 - Check for primary fault codes

Solution: S00000189

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 595, 1898, 2277, 2355, 2387, 2449, 2634, 3616
  • Intake manifold: 123, 433, 2973
  • Barometric pressure: 295

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Barometric air pressure sensor stuck in-range

Solution: S00000340

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the barometric air pressure sensor
  • Compare to the local ambient air pressure.

Refer to Procedure 019-004

Specification

  • A malfunctioning barometric air pressure sensor has been detected if the barometric air pressure sensor is not within the following specification of local ambient air pressure: 51 mm HG [2 in HG]

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Intake manifold pressure sensor stuck in-range

Solution: S00001540

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Monitor the intake manifold pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: 0 ± 10 kPa [0 ± 3 in Hg]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 2348 | SPN: 27 | FMI: 13
EGR Valve Position Circuit - Out of Calibration

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. EGR valve is malfunctioning

1 - Check for primary fault codes

Solution: S00001974

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 2271, 2349, 2352, 2353
  • Engine brake: 2367, 2368

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR valve is malfunctioning

Solution: S00004389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

If the EGR valve has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2349 | SPN: 2791 | FMI: 5
EGR Valve Control Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. EGR valve motor resistance check
  2. EGR valve motor open circuit check
  3. EGR valve motor circuit pin to pin short
  4. EGR valve is malfunctioning

1 - EGR valve motor resistance check

Solution: S00002248

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning EGR valve motor has been detected if the resistance is greater than the following specification: 15 Ω

Linked Solutions

  • None

Repair

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR valve motor open circuit check

Solution: S00004408

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve motor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector.
  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR valve motor circuit pin to pin short

Solution: S00001620

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR valve is malfunctioning

Solution: S00004389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

If the EGR valve has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISM CM875

Fault Code: 2359 | SPN: 411 | FMI: 16
Exhaust Gas Recirculation Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR differential pressure sensor stuck in-range
  3. EGR differential pressure sensor flow port check
  4. EGR differential pressure sensor tubes restricted
  5. EGR differential pressure sensor adapter leaking
  6. Leaks in the intake air system
  7. Charge air cooler system leak
  8. ECM calibration revision history check
  9. EGR differential pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00001566

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 2271, 2272, 2348, 2349, 2351, 2352, 2353, 2357
  • EGR differential pressure: 2273, 2274
  • Turbocharger: 2277, 2278, 2347, 2355, 2356, 2384, 2385

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR differential pressure sensor stuck in-range

Solution: S00000327

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • Proceed to the Linked Solutions section if the EGR differential pressure reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • EGR differential pressure sensor flow port check

Refer to S00002992

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - EGR differential pressure sensor flow port check

Solution: S00002992

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor flow ports.

Refer to Procedure 010-080

  • Clean the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]
  • Plugged EGR differential pressure sensor flow ports has been detected if the reading is within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure ports.

Refer to Procedure 010-080

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - EGR differential pressure sensor tubes restricted

Solution: S00003585

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor tubes.

Refer to Procedure 011-026

  • Visually inspect the EGR differential pressure sensor tubes for restrictions.
  • Remove the EGR venturi tube.

Refer to Procedure 011-025

  • Visually inspect the EGR venturi tube for restrictions.

Specification

  • If damage or restrictions are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace EGR venturi tube.

Refer to Procedure 011-025

  • Repair or replace EGR differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR differential pressure sensor adapter leaking

Solution: S00003689

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Visually inspect the EGR differential pressure sensor for leaks at the mounting surface.
  • Visually inspect the aftertreatment differential pressure tubes for proper installation.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 019-370

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - EGR differential pressure sensor is malfunctioning

Solution: S00003480

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2363 | SPN: 1073 | FMI: 4
Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake solenoid valve open circuit check
  2. Loose or damaged engine brake wiring harness connector
  3. Engine brake solenoid valve resistance check
  4. Engine brake solenoid circuit pin to ground short
  5. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve open circuit check

Solution: S00004560

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the internal engine brake wiring harness connector and the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector.

Refer to Procedure 019-360

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the engine wiring harness, and all interconnects.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Loose or damaged engine brake wiring harness connector

Solution: S00003168

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake solenoids from the engine brake pass through connector.
  • Visually inspect the engine brake wiring harness for damage or broken connections.

Refer to Procedure 019-361

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid valve resistance check

Solution: S00003570

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the internal engine brake wiring harness connector to ground.

Refer to Procedure 020-024

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-024

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 2367 | SPN: 1073 | FMI: 3
Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Loose or damaged engine brake wiring harness connector
  2. Engine brake solenoid valve resistance check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid circuit pin to pin short
  5. Engine brake solenoid circuit pin to pin short

1 - Loose or damaged engine brake wiring harness connector

Solution: S00003168

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake solenoids from the engine brake pass through connector.
  • Visually inspect the engine brake wiring harness for damage or broken connections.

Refer to Procedure 019-361

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve resistance check

Solution: S00003570

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the internal engine brake wiring harness connector to ground.

Refer to Procedure 020-024

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-024

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine brake solenoid circuit pin to pin short

Solution: S00001028

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the engine brake connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 2373 | SPN: 1209 | FMI: 3
Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor voltage check
  3. Exhaust gas pressure sensor voltage check at the ECM
  4. Exhaust gas pressure sensor circuit response
  5. Plugged or damaged exhaust gas pressure sensor tube
  6. Exhaust gas pressure sensor circuit response at the ECM
  7. Exhaust gas pressure sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001088

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor voltage check

Solution: S00000776

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Exhaust gas pressure sensor voltage check at the ECM

Refer to S00000777

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Exhaust gas pressure sensor voltage check at the ECM

Solution: S00000777

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Exhaust gas pressure sensor circuit response

Solution: S00000399

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the following fault code became active with the sensor disconnected: 2374

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Exhaust gas pressure sensor circuit response at the ECM

Solution: S00001228

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2374
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2374

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Exhaust gas pressure sensor circuit pin to pin short

Solution: S00000775

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2374 | SPN: 1209 | FMI: 4
Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor voltage check
  3. Exhaust gas pressure sensor voltage check at the ECM
  4. Exhaust gas pressure sensor circuit response
  5. Exhaust gas pressure sensor circuit response at the ECM
  6. Exhaust gas pressure sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001088

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor voltage check

Solution: S00000776

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Exhaust gas pressure sensor voltage check at the ECM

Refer to S00000777

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Exhaust gas pressure sensor voltage check at the ECM

Solution: S00000777

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Exhaust gas pressure sensor circuit response

Solution: S00000400

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the following fault code became active with the jumper wire in place: 2373

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Exhaust gas pressure sensor circuit response at the ECM

Solution: S00001126

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2373
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2373

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • None
Next Solution

5 - Exhaust gas pressure sensor circuit pin to pin short

Solution: S00000775

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2375 | SPN: 412 | FMI: 3
Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. EGR temperature sensor circuit response
  2. EGR temperature sensor circuit response at the ECM
  3. ECM calibration revision history check

1 - EGR temperature sensor circuit response

Solution: S00000391

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the following fault code became active with the jumper wire in place: 2376

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR temperature sensor circuit response at the ECM

Solution: S00000575

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2376
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2376

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2376 | SPN: 412 | FMI: 4
Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. EGR temperature sensor circuit response
  2. EGR temperature sensor circuit response at the ECM
  3. ECM calibration revision history check

1 - EGR temperature sensor circuit response

Solution: S00000769

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the following fault code became active with the sensor disconnected: 2375

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR temperature sensor circuit response at the ECM

Solution: S00001089

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2375
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2375

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2377 | SPN: 647 | FMI: 3
Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fan control solenoid open circuit check
  2. Fan control solenoid circuit pin to pin short
  3. Fan control solenoid is malfunctioning

1 - Fan control solenoid open circuit check

Solution: S00001057

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness engine control module fan control SIGNAL pin and the OEM wiring harness fan control connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness engine control module fan control RETURN pin and the OEM wiring harness fan control connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Fan control solenoid circuit pin to pin short

Solution: S00004897

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan control solenoid is malfunctioning

Solution: S00005653

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISM CM875

Fault Code: 2412 | SPN: 1639 | FMI: 2
Fan Speed - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Malfunctioning cooling fan drive or cooling fan controls

1 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00001907

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run engine at high idle.
  • Wait for 30 seconds.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning fan speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the fan speed sensor.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISM CM875

Fault Code: 2448 | SPN: 111 | FMI: 17
Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00010538

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-020

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2451 | SPN: 2789 | FMI: 16
Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Restricted intake air filter
  2. Exhaust gas pressure sensor stuck in-range
  3. Plugged or damaged exhaust gas pressure sensor tube
  4. Exhaust gas pressure sensor stuck in-range
  5. Leaks in the intake air system
  6. Charge air cooler system leak
  7. Plugged or damaged exhaust gas pressure sensor tube
  8. Air leaks at the hood air plenum
  9. Turbocharger is malfunctioning
  10. ECM calibration revision history check

1 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Air leaks at the hood air plenum

Solution: S00003677

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sealing surface between the air filter and the hood plenum for damage.

Specification

  • None

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger is malfunctioning

Solution: S00000780

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2554 | SPN: 1209 | FMI: 2
Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor stuck in-range
  3. Plugged or damaged exhaust gas pressure sensor tube
  4. Exhaust gas pressure sensor stuck in-range
  5. Exhaust gas pressure sensor voltage check
  6. Exhaust gas pressure sensor voltage check at the ECM
  7. Plugged or damaged exhaust gas pressure sensor tube
  8. Exhaust gas pressure sensor open circuit check
  9. Exhaust gas pressure sensor circuit pin to pin short
  10. ECM calibration revision history check
  11. Exhaust gas pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000199

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Exhaust gas pressure: 2373, 2374

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Exhaust gas pressure sensor voltage check

Solution: S00000776

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Exhaust gas pressure sensor voltage check at the ECM

Refer to S00000777

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Exhaust gas pressure sensor voltage check at the ECM

Solution: S00000777

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Exhaust gas pressure sensor open circuit check

Solution: S00000778

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas pressure sensor SUPPLY pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Exhaust gas pressure sensor circuit pin to pin short

Solution: S00000775

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Exhaust gas pressure sensor is malfunctioning

Solution: S00003039

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning exhaust gas pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the Exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2646 | SPN: 110 | FMI: 31
Engine Coolant Temperature - Condition Exists

Troubleshooting Summary

  1. ECM calibration revision history check

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2764 | SPN: 1209 | FMI: 16
Exhaust Gas Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Exhaust gas pressure sensor stuck in-range
  2. Plugged or damaged exhaust gas pressure sensor tube
  3. Exhaust gas pressure sensor stuck in-range
  4. Plugged or damaged exhaust gas pressure sensor tube
  5. Exhaust gas pressure sensor open circuit check
  6. EGR cooler plugged or restricted
  7. Exhaust gas pressure sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Exhaust gas pressure sensor open circuit check

Solution: S00000778

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas pressure sensor SUPPLY pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR cooler plugged or restricted

Solution: S00003523

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run engine at high idle.
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Monitor the exhaust gas pressure sensor.
  • Monitor the intake manifold pressure sensor.
  • Monitor the EGR valve position.
  • Monitor the EGR Differential Pressure.

Specification

  • The difference between exhaust gas pressure and intake manifold pressure is greater than the following specification: 1016 mm-Hg [40 in-Hg]
  • The EGR valve position is greater than the following specification: 50%
  • The EGR differential pressure is less than the following specification: 102 mm-Hg [4 in-Hg]
  • If all specifications are met, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR cooler.

Refer to Procedure 011-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Exhaust gas pressure sensor circuit pin to pin short

Solution: S00000775

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2774 | SPN: 3058 | FMI: 31
Engine Exhaust Gas Recirculation (EGR) System - Condition Exists

Troubleshooting Summary

  1. EGR differential pressure sensor stuck in-range
  2. EGR differential pressure sensor flow port check
  3. EGR differential pressure sensor tubes restricted
  4. EGR differential pressure sensor adapter leaking

1 - EGR differential pressure sensor stuck in-range

Solution: S00000327

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • Proceed to the Linked Solutions section if the EGR differential pressure reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • EGR differential pressure sensor flow port check

Refer to S00002992

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - EGR differential pressure sensor flow port check

Solution: S00002992

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor flow ports.

Refer to Procedure 010-080

  • Clean the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]
  • Plugged EGR differential pressure sensor flow ports has been detected if the reading is within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure ports.

Refer to Procedure 010-080

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - EGR differential pressure sensor tubes restricted

Solution: S00003585

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor tubes.

Refer to Procedure 011-026

  • Visually inspect the EGR differential pressure sensor tubes for restrictions.
  • Remove the EGR venturi tube.

Refer to Procedure 011-025

  • Visually inspect the EGR venturi tube for restrictions.

Specification

  • If damage or restrictions are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace EGR venturi tube.

Refer to Procedure 011-025

  • Repair or replace EGR differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR differential pressure sensor adapter leaking

Solution: S00003689

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Visually inspect the EGR differential pressure sensor for leaks at the mounting surface.
  • Visually inspect the aftertreatment differential pressure tubes for proper installation.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 019-370

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 10-Apr-2022


NO TITLE

ISM CM875

Fault Code: 2789 | SPN: 110 | FMI: 18
Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Fan clutch operates incorrectly
  3. Thermostat is malfunctioning
  4. Out-of-chassis opening temperature test
  5. Radiator shutters malfunctioning (if equipped)
  6. Excessive coolant flow through OEM plumbing and heater cores
  7. ECM calibration revision history check

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan clutch operates incorrectly

Solution: S00006146

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-026

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-026

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Radiator shutters malfunctioning (if equipped)

Solution: S00003116

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for closed cold weather radiator cover or winterfront.

Refer to Procedure 008-049

Specification

  • If the radiator shutters do not operate according to the specification, then a malfunctioning radiator shutter assembly has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Excessive coolant flow through OEM plumbing and heater cores

Solution: S00002161

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the OEM installed cooling system components.

Specification

  • If OEM installed cooling system components do not meet specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2961 | SPN: 412 | FMI: 15
Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. EGR temperature sensor stuck in-range
  2. EGR differential pressure sensor stuck in-range
  3. EGR differential pressure sensor flow port check
  4. EGR differential pressure sensor tubes restricted
  5. EGR differential pressure sensor adapter leaking
  6. ECM calibration revision history check

1 - EGR temperature sensor stuck in-range

Solution: S00000341

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR temperature sensor.
  • Compare to the local ambient air temperature.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the reading is not within the following specification of the local ambient temperature reading: 10C [18F]

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR differential pressure sensor stuck in-range

Solution: S00000327

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • Proceed to the Linked Solutions section if the EGR differential pressure reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • EGR differential pressure sensor flow port check

Refer to S00002992

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - EGR differential pressure sensor flow port check

Solution: S00002992

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor flow ports.

Refer to Procedure 010-080

  • Clean the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]
  • Plugged EGR differential pressure sensor flow ports has been detected if the reading is within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure ports.

Refer to Procedure 010-080

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - EGR differential pressure sensor tubes restricted

Solution: S00003585

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor tubes.

Refer to Procedure 011-026

  • Visually inspect the EGR differential pressure sensor tubes for restrictions.
  • Remove the EGR venturi tube.

Refer to Procedure 011-025

  • Visually inspect the EGR venturi tube for restrictions.

Specification

  • If damage or restrictions are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace EGR venturi tube.

Refer to Procedure 011-025

  • Repair or replace EGR differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR differential pressure sensor adapter leaking

Solution: S00003689

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Visually inspect the EGR differential pressure sensor for leaks at the mounting surface.
  • Visually inspect the aftertreatment differential pressure tubes for proper installation.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 019-370

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2962 | SPN: 412 | FMI: 16
Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR temperature sensor stuck in-range
  3. EGR differential pressure sensor stuck in-range
  4. EGR differential pressure sensor flow port check
  5. EGR differential pressure sensor tubes restricted
  6. EGR differential pressure sensor adapter leaking
  7. Leaks in the intake air system
  8. Charge air cooler system leak
  9. EGR cooler plugged or restricted
  10. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002041

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ambient air temperature: 1943
  • Fuel: 2215
  • Turbocharger: 2277, 2346, 2347
  • EGR: 2348, 2349, 2357, 2961
  • EGR differential pressure: 2359
  • Engine coolant temperature: 2963
  • Intake manifold temperature: 2964

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR temperature sensor stuck in-range

Solution: S00000341

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR temperature sensor.
  • Compare to the local ambient air temperature.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the reading is not within the following specification of the local ambient temperature reading: 10C [18F]

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR differential pressure sensor stuck in-range

Solution: S00000327

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • Proceed to the Linked Solutions section if the EGR differential pressure reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • EGR differential pressure sensor flow port check

Refer to S00002992

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - EGR differential pressure sensor flow port check

Solution: S00002992

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor flow ports.

Refer to Procedure 010-080

  • Clean the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]
  • Plugged EGR differential pressure sensor flow ports has been detected if the reading is within the following specification: 0 +/- 22.86 mmhg [0 +/- .90 inhg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure ports.

Refer to Procedure 010-080

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - EGR differential pressure sensor tubes restricted

Solution: S00003585

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor tubes.

Refer to Procedure 011-026

  • Visually inspect the EGR differential pressure sensor tubes for restrictions.
  • Remove the EGR venturi tube.

Refer to Procedure 011-025

  • Visually inspect the EGR venturi tube for restrictions.

Specification

  • If damage or restrictions are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace EGR venturi tube.

Refer to Procedure 011-025

  • Repair or replace EGR differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR differential pressure sensor adapter leaking

Solution: S00003689

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Visually inspect the EGR differential pressure sensor for leaks at the mounting surface.
  • Visually inspect the aftertreatment differential pressure tubes for proper installation.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 019-370

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - EGR cooler plugged or restricted

Solution: S00003523

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run engine at high idle.
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Monitor the exhaust gas pressure sensor.
  • Monitor the intake manifold pressure sensor.
  • Monitor the EGR valve position.
  • Monitor the EGR Differential Pressure.

Specification

  • The difference between exhaust gas pressure and intake manifold pressure is greater than the following specification: 1016 mm-Hg [40 in-Hg]
  • The EGR valve position is greater than the following specification: 50%
  • The EGR differential pressure is less than the following specification: 102 mm-Hg [4 in-Hg]
  • If all specifications are met, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR cooler.

Refer to Procedure 011-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2963 | SPN: 110 | FMI: 15
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Radiator is externally obstructed
  4. Radiator shutters malfunctioning (if equipped)
  5. Coolant temperature sensor resistance check
  6. Fan clutch operates incorrectly
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Combustion gases entering the cooling system
  10. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00010538

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-020

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fan clutch operates incorrectly

Solution: S00006146

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-026

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-026

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 2964 | SPN: 105 | FMI: 15
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. High intake manifold temperature basic checks
  2. Intake manifold temperature sensor stuck in-range
  3. EGR differential pressure sensor adapter leaking
  4. Malfunctioning cooling fan drive or cooling fan controls
  5. Overhead component damaged or out of adjustment

1 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor stuck in-range

Solution: S00005257

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F].

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the intake manifold temperature sensor.

Refer to Procedure 019-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR differential pressure sensor adapter leaking

Solution: S00003689

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Visually inspect the EGR differential pressure sensor for leaks at the mounting surface.
  • Visually inspect the aftertreatment differential pressure tubes for proper installation.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 019-370

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Overhead component damaged or out of adjustment

Solution: S00000389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISM CM875

Fault Code: 2973 | SPN: 102 | FMI: 2
Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Barometric air pressure sensor stuck in-range
  4. Exhaust gas pressure sensor stuck in-range
  5. Plugged or damaged exhaust gas pressure sensor tube
  6. Exhaust gas pressure sensor stuck in-range
  7. Turbocharger speed sensor resistance check
  8. Leaks in the intake air system
  9. Charge air cooler system leak
  10. Turbocharger is malfunctioning
  11. ECM calibration revision history check
  12. Intake manifold pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00001389

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Barometric pressure: 221, 222, 295
  • Turbocharger: 595, 687, 691, 692, 693, 2345

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Barometric air pressure sensor stuck in-range

Solution: S00005632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the barometric air pressure sensor

Specification

  • A malfunctioning barometric air pressure sensor has been detected if the barometric air pressure sensor is not within the following specification of local ambient air pressure: 51 mm HG [2 in HG]

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Turbocharger speed sensor resistance check

Solution: S00002828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SUPPLY pin and the turbocharger speed sensor RETURN pin at the sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is not within the following specification: 600 - 1600 Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Turbocharger is malfunctioning

Solution: S00000780

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Intake manifold pressure sensor is malfunctioning

Solution: S00005543

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-061

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 3348 | SPN: 1176 | FMI: 1
Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Restricted intake air filter
  2. Intake manifold pressure sensor is malfunctioning

1 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold pressure sensor is malfunctioning

Solution: S00005543

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-061

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISM CM875

Fault Code: 3374 | SPN: 1818 | FMI: 31
Roll Over Protection Brake Control Active - Condition Exists

Troubleshooting Summary

  1. ECM calibration revision history check

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 3385 | SPN: 105 | FMI: 18
Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Intake manifold temperature sensor stuck in-range
  2. ECM calibration revision history check

1 - Intake manifold temperature sensor stuck in-range

Solution: S00005257

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F].

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the intake manifold temperature sensor.

Refer to Procedure 019-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISM CM875

Fault Code: 3488 | SPN: 563 | FMI: 9
Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


INDEX
12-fc111.htm

12-t06-111.htm

12-fc115.htm

12-t06-115.htm

12-fc122.htm

12-t06-122.htm

12-fc123.htm

12-t06-123.htm

12-fc125.htm

12-t06-125.htm

12-fc131.htm

12-t06-131.htm

12-fc132.htm

12-t06-132.htm

12-fc133.htm

12-t06-133.htm

12-fc134.htm

12-t06-134.htm

12-fc135.htm

12-t06-135.htm

12-fc141.htm

12-t06-141.htm

12-fc143.htm

12-t06-143.htm

12-fc144.htm

12-t06-144.htm

12-fc145.htm

12-t06-145.htm

12-fc146.htm

12-t06-146.htm

12-fc151.htm

12-t06-151.htm

12-fc153.htm

12-t06-153.htm

12-fc154.htm

12-t06-154.htm

12-fc155.htm

12-t06-155.htm

12-fc187.htm

12-t06-187.htm

12-fc195.htm

12-t06-195.htm

12-fc196.htm

12-t06-196.htm

12-fc197.htm

12-t06-197.htm

12-fc212.htm

12-t06-212.htm

12-fc213.htm

12-t06-213.htm

12-fc214.htm

12-t06-214.htm

12-fc221.htm

12-t06-221.htm

12-fc222.htm

12-t06-222.htm

12-fc227.htm

12-t06-227.htm

12-fc238.htm

12-t06-238.htm

12-fc241.htm

12-t06-241.htm

12-fc242.htm

12-t06-242.htm

12-fc245.htm

12-t06-245.htm

12-fc249.htm

12-t06-249.htm

12-fc254.htm

12-t06-254.htm

12-fc255.htm

12-t06-255.htm

12-fc256.htm

12-t06-256.htm

12-fc257.htm

12-t06-257.htm

12-fc285.htm

12-t06-285.htm

12-fc286.htm

12-t06-286.htm

12-fc287.htm

12-t06-287.htm

12-fc288.htm

12-t06-288.htm

12-fc295.htm

12-t06-295.htm

12-fc311.htm

12-t06-311.htm

12-fc312.htm

12-t06-312.htm

12-fc313.htm

12-t06-313.htm

12-fc314.htm

12-t06-314.htm

12-fc315.htm

12-t06-315.htm

12-fc319.htm

12-t06-319.htm

12-fc321.htm

12-t06-321.htm

12-fc322.htm

12-t06-322.htm

12-fc323.htm

12-t06-323.htm

12-fc324.htm

12-t06-324.htm

12-fc325.htm

12-t06-325.htm

12-fc331.htm

12-t06-331.htm

12-fc332.htm

12-t06-332.htm

12-fc338.htm

12-t06-338.htm

12-fc339.htm

12-t06-339.htm

12-fc343.htm

12-t06-343.htm

12-fc346.htm

12-t06-346.htm

12-fc351.htm

12-t06-351.htm

12-fc352.htm

12-t06-352.htm

12-fc386.htm

12-t06-386.htm

12-fc415.htm

12-t06-415.htm

12-fc418.htm

12-t06-418.htm

12-fc421.htm

12-t06-421.htm

12-fc427.htm

12-t06-427.htm

12-fc428.htm

12-t06-428.htm

12-fc429.htm

12-t06-429.htm

12-fc431.htm

12-t06-431.htm

12-fc432.htm

12-t06-432.htm

12-fc435.htm

12-t06-435.htm

12-fc441.htm

12-t06-441.htm

12-fc442.htm

12-t06-442.htm

12-fc584.htm

12-t06-584.htm

12-fc585.htm

12-t06-585.htm

12-fc596.htm

12-t06-596.htm

12-fc597.htm

12-t06-597.htm

12-fc598.htm

12-t06-598.htm

12-fc629.htm

12-t06-629.htm

12-fc649.htm

12-t06-649.htm

12-fc686.htm

12-t06-686.htm

12-fc687.htm

12-t06-687.htm

12-fc689.htm

12-t06-689.htm

12-fc691.htm

12-t06-691.htm

12-fc692.htm

12-t06-692.htm

12-fc697.htm

12-t06-697.htm

12-fc698.htm

12-t06-698.htm

12-fc778.htm

12-t06-778.htm

12-fc784.htm

12-t06-784.htm

12-fc1117.htm

12-t06-1117.htm

12-fc1239.htm

12-t06-1239.htm

12-fc1241.htm

12-t06-1241.htm

12-fc1242.htm

12-t06-1242.htm

12-fc1866.htm

12-t06-1866.htm

12-fc1899.htm

12-t06-1899.htm

12-fc1943.htm

12-t06-1943.htm

12-fc2195.htm

12-t06-2195.htm

12-fc2272.htm

12-t06-2272.htm

12-fc2273.htm

12-t06-2273.htm

12-fc2274.htm

12-t06-2274.htm

12-fc2288.htm

12-t06-2288.htm

12-fc2319.htm

12-t06-2319.htm

12-fc2345.htm

12-t06-2345.htm

12-fc2346.htm

12-t06-2346.htm

12-fc2347.htm

12-t06-2347.htm

12-fc2348.htm

12-t06-2348.htm

12-fc2349.htm

12-t06-2349.htm

12-fc2359.htm

12-t06-2359.htm

12-fc2363.htm

12-t06-2363.htm

12-fc2367.htm

12-t06-2367.htm

12-fc2373.htm

12-t06-2373.htm

12-fc2374.htm

12-t06-2374.htm

12-fc2375.htm

12-t06-2375.htm

12-fc2376.htm

12-t06-2376.htm

12-fc2377.htm

12-t06-2377.htm

12-fc2412.htm

12-t06-2412.htm

12-fc2448.htm

12-t06-2448.htm

12-fc2451.htm

12-t06-2451.htm

12-fc2554.htm

12-t06-2554.htm

12-fc2646.htm

12-t06-2646.htm

12-fc2764.htm

12-t06-2764.htm

12-fc2774.htm

12-t06-2774.htm

12-fc2789.htm

12-t06-2789.htm

12-fc2961.htm

12-t06-2961.htm

12-fc2962.htm

12-t06-2962.htm

12-fc2963.htm

12-t06-2963.htm

12-fc2964.htm

12-t06-2964.htm

12-fc2973.htm

12-t06-2973.htm

12-fc3348.htm

12-t06-3348.htm

12-fc3374.htm

12-t06-3374.htm

12-fc3385.htm

12-t06-3385.htm

12-fc3488.htm

12-t06-3488.htm