480C-E

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: Red SRT: | Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component. | Engine will not start.
Electronic Control Module

Circuit Description

The electronic control module (ECM) is a computer responsible for engine control, diagnostics, and user features.

Component Location

Reference Section E for a detailed component location view. The ECM is located at the top of the engine, mounted to the air intake manifold.

Shop Talk

This fault code can only be caused by an internal ECM problem. There are no repairs possible for the module in the field.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 18-Dec-2012
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Speed/Position Sensor Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Speed/Position Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2 LAMP: Red SRT: | Engine speed/position sensor circuit lost both of two signals from the magnetic pickup sensor. Data is erratic, intermittent, or incorrect. Both the primary and secondary speed sensors are hall effect sensors. | Engine will die and will not restart.
Engine Speed/Position Sensor Circuit

Circuit Description

The primary engine speed sensor provides the engine speed signal to the electronic control module (ECM) through the engine harness. The sensor generates a signal by sensing the movement of the target teeth of the flywheel.

Component Location

The primary engine speed sensor is located in the flywheel housing.

Shop Talk

The engine speed sensor provides the main engine speed signal to the ECM through the engine harness. The engine speed signal is generated when the engine speed sensor detects teeth on the ring gear. The ECM determines the engine speed by counting the number of voltage switches for a given period of time.

Refer to Troubleshooting Fault Code t05-115


Engine Speed/Position Sensor Circuit - Abnormal Rate of Change

FAULT CODE 121

Engine Speed/Position Sensor Circuit - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10 LAMP: Amber SRT: | Engine speed/position sensor circuit lost one of two signals from the magnetic pickup sensor - abnormal rate of change. Both the primary and secondary speed sensors are hall effect sensors. | Loss of backup engine speed sensor. No action by the ECM is taken.
Engine Speed/Position Sensor Circuit

Circuit Description

The secondary engine speed sensor provides a backup engine speed signal to the electronic control module (ECM) through the engine harness. The sensor generates a signal by sensing the movement of the target teeth of the flywheel.

Component Location

The secondary engine speed sensor is located in the flywheel housing.

Shop Talk

The engine speed sensor provides the main engine speed signal to the ECM through the engine harness. The engine speed signal is generated when the engine speed sensor detects teeth on the ring gear. The ECM determines the engine speed by counting the number of voltage switches for a given period of time.

Refer to Troubleshooting Fault Code t05-121


Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Derate dependant on calibration. Possible black smoke during acceleration.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the electronic control module (ECM) through the intake manifold pressure signal pin of the engine harness.

Component Location

Reference Section E for a detailed component location view. There is one intake manifold pressure sensor on the 480C E engine. It is located next to the air intake heater, behind the ECM.

Shop Talk

  • The intake manifold pressure sensor measures gauge pressure. Confirm the sensor is reading properly by comparing the reading seen in the ECM with a reading taken with a mechanical gauge. The sensor should read -38 to 38 mm Hg [-1.5 to 1.5 in Hg] using INSITE™, with the keyswitch turned to the ON position, but the engine not running.
  • Determine if the engine is being overfueled.
  • Confirm the correct intake manifold pressure sensor part number is being used.
  • Confirm the correct turbocharger is being used.
  • If it is suspected that cold intake air can be the cause of the high intake manifold pressure, test the engine while feeding it warm intake air.
  • Inspect the intake manifold pressure sensor circuit for signs of tampering. Remove any extra wires from the circuit.
Refer to Troubleshooting Fault Code t05-122


Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the intake manifold pressure circuit. | Derate dependant on calibration.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the electronic control module (ECM) through the intake manifold pressure signal pin of the engine harness.

Component Location

Reference Section E for a detailed component location view. There is one intake manifold pressure sensor on the 480C E engine. It is located next to the air intake heater, behind the ECM.

Shop Talk

  • The intake manifold pressure sensor measures gauge pressure. Confirm the sensor is reading properly by comparing the reading seen in the ECM with a reading taken with a mechanical gauge. The sensor should read -38 to 38 mm Hg [-1.5 to 1.5 in Hg] using INSITE™, with the keyswitch turned to the ON position, but the engine not running.
  • Check for high restriction in the intake manifold due to clogged air filters or a shutdown device in the manifold (if the vessel is equipped with one). Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature.
  • Make sure the turbocharger is working correctly. Check for a positive intake manifold pressure.
Refer to Troubleshooting Fault Code t05-123


Intake Manifold Pressure High - Data Valid but Above Normal Operating Range

FAULT CODE 124

Intake Manifold Pressure High - Data Valid but Above Normal Operating Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 SPN: 102 FMI: 16 LAMP: Amber SRT: | Intake manifold pressure high - data valid but above normal operating range - moderately severe level. | No action taken.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor is used by the electronic control module (ECM) to monitor the engine intake manifold pressure. The ECM monitors the voltage on the intake manifold pressure signal pin and converts this to a pressure value. The intake manifold pressure value is used by the ECM for the engine protection system.

Component Location

Reference Section E for a detailed component location view. The intake manifold pressure sensor is located next to the air intake heater behind the ECM.

Shop Talk

Possible causes:

  • Malfunctioning turbocharger wastegate. Refer to Procedure 010-050 in the Troubleshooting and Repair Manual, C Series Engines, Bulletin 3666003.
  • A faulty sensor.
Refer to Troubleshooting Fault Code t05-124


Throttle Position Signal Circuit - High Voltage

FAULT CODE 131

Throttle Position Signal Circuit - High Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3 LAMP: Red SRT: | High voltage detected at the throttle position signal circuit. | Severe derate (power and speed). Limp home power only.
Throttle Position Signal Circuit

Circuit Description

The accelerator pedal/lever provides the driver's accelerator command to the electronic control module (ECM) through the marine OEM harness and the throttle extension harness. The ECM uses this signal to determine the fueling command for the P7100 fuel pump rack.

Component Location

Reference Section E for a detailed component location view. The accelerator pedal/lever location varies with each OEM.

Shop Talk

The accelerator pedal/lever position sensor is a potentiometer. The resistance specifications of the accelerator pedal/lever position sensor are as follows:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal:Released = 1500 to 3000 ohmsDepressed = 200 to 1500 ohms

If the accelerator pedal/lever or accelerator pedal/lever position sensor is changed, or after a calibration download, cycle the accelerator pedal/lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal/lever with the ECM.

Refer to Troubleshooting Fault Code t05-131


Throttle Position Signal Circuit - Low Voltage

FAULT CODE 132

Throttle Position Signal Circuit - Low Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 3 LAMP: Red SRT: | Low voltage detected at the throttle position signal circuit. | Severe derate (power and speed). Limp home power only.
Throttle Position Signal Circuit

Circuit Description

The accelerator pedal/lever provides the driver's accelerator command to the electronic control module (ECM) through the marine OEM harness and the throttle extension harness. The ECM uses this signal to determine the fueling command for the P7100 fuel pump rack.

Component Location

Reference Section E for a detailed component location view. The accelerator pedal/lever location varies with each OEM.

Shop Talk

The accelerator pedal/lever position sensor is a potentiometer. The resistance specifications of the accelerator pedal/lever position sensor are as follows:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal:Released = 1500 to 3000 ohmsDepressed = 200 to 1500 ohms

If the accelerator pedal/lever or accelerator pedal/lever position sensor is changed, or after a calibration download, cycle the accelerator pedal/lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal/lever with the ECM.

Refer to Troubleshooting Fault Code t05-132


Remote Throttle Position Sensor Circuit - Shorted High

FAULT CODE 133

Remote Throttle Position Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P029 SPN: 974 FMI: 3 LAMP: Red SRT: | Backup throttle position sensor shorted high. | None on performance if remote throttle is not used.
Remote Throttle Position Sensor Circuit

Circuit Description

The remote accelerator pedal/lever provides a second accelerator command to the electronic control module (ECM) through the marine OEM harness and the main extension harness. The ECM uses this signal in place of the primary accelerator pedal/lever to determine the fueling command for the P7100 fuel pump rack.

Component Location

Reference Section E for a detailed component location view. The remove accelerator pedal/lever location varies with each OEM.

Shop Talk

The accelerator pedal/lever position sensor is a potentiometer. The resistance specifications of the accelerator pedal/lever position sensor are as follows:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal:Released = 1500 to 3000 ohmsDepressed = 200 to 1500 ohms

If the accelerator pedal/lever or accelerator pedal/lever position sensor is changed, or after a calibration download, cycle the accelerator pedal/lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal/lever with the ECM.

Refer to Troubleshooting Fault Code t05-133


Remote Throttle Position Sensor Circuit - Shorted Low

FAULT CODE 134

Remote Throttle Position Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P029 SPN: 91 FMI: 4 LAMP: Red SRT: | Backup throttle position sensor shorted low. | None on performance if remote throttle is not used.
Remote Throttle Position Sensor Circuit

Circuit Description

The remote accelerator pedal/lever provides a second accelerator command to the electronic control module (ECM) through the marine OEM harness and the main extension harness. The ECM uses this signal in place of the primary accelerator pedal/lever to determine the fueling command for the P7100 fuel pump rack.

Component Location

Reference Section E for a detailed component location view. The remove accelerator pedal/lever location varies with each OEM.

Shop Talk

The accelerator pedal/lever position sensor is a potentiometer. The resistance specifications of the accelerator pedal/lever position sensor are as follows:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal:Released = 1500 to 3000 ohmsDepressed = 200 to 1500 ohms

If the accelerator pedal/lever or accelerator pedal/lever position sensor is changed, or after a calibration download, cycle the accelerator pedal/lever (turn keyswitch ON) through its complete travel three times. This procedure calibrates the new accelerator pedal/lever with the ECM.

Refer to Troubleshooting Fault Code t05-134


Oil Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Oil Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Amber SRT: | Oil pressure sensor circuit - voltage above normal or shorted to high source. | Engine protection for oil pressure disabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor monitors oil pressure and passes information to the electronic control module (ECM) through the oil pressure signal pin of the engine harness. The ECM monitors the voltage on the oil pressure signal pin. Voltage exceeding the control threshold will trip Fault Code 135.

Component Location

Reference Section E for a detailed component location view. The oil pressure sensor is located between the coolant filter and the heater solenoids.

Shop Talk

If the fault occurs only in cold weather, allow the oil to warm up and see if the fault goes inactive.

If Fault Code 143 or 415 is not present, the problem is not base engine related.

Refer to Troubleshooting Fault Code t05-135


Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Amber SRT: | Oil pressure sensor circuit - voltage below normal or shorted to low source. | Engine protection for oil pressure disabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor monitors oil pressure and passes information to the electronic control module (ECM) through the oil pressure signal pin of the engine harness. The ECM monitors the voltage on the oil pressure signal pin. Voltage exceeding the control threshold will trip Fault Code 141.

Component Location

Reference Section E for a detailed component location view. The oil pressure sensor is located between the coolant filter and the heater solenoids.

Shop Talk

If the fault occurs only in cold weather, allow the oil to warm up and see if the fault goes inactive.

If Fault Code 143 or 415 is not present, the problem is not base engine related.

Refer to Troubleshooting Fault Code t05-141


Oil Pressure Sensor Circuit - Data Valid but Below Normal Operating Range

FAULT CODE 143

Oil Pressure Sensor Circuit - Data Valid but Below Normal Operating Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 18 LAMP: Amber SRT: | Oil pressure low - data valid but below normal operating range. | Engine protection shutdown enabled, engine will shut down. Engine protection derate enabled, power derate engine protection disabled, no action taken.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this signal voltage to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

Reference Section E for a detailed component location view. The oil pressure sensor is located between the coolant filter and the heater solenoids.

Shop Talk

Confirm that the oil pressure sensor supply voltage is between 4.75 and 5.25 VDC at the sensor. Reference Fault Code 141.

Verify with the operator at what engine speed the fault occurs. If the engine is being operated at too low of a speed under load (lugging), the oil pressure can drop below the engine protection limits because of oil temperature.

Oil pressure is a function of engine speed, oil level, and regulator function. Operating the engine at a low speed under load will not cause the oil pressure to be low unless the oil is hot, the oil level is low, the regulator has malfunctioned, or a loss is occurring somewhere in the system.

A faulty sensor can also cause Fault Code 143.

The number of fault lamps can be reduced to two for certain OEMs. In this case, the engine protection and stop lamps are wired together as a red lamp. The warning lamp remains an amber lamp.

Refer to Troubleshooting Fault Code t05-143


Coolant Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Coolant Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Amber SRT: | Coolant temperature sensor circuit - voltage above normal or shorted to high source. | Engine protection for coolant temperature is disabled. Possible white smoke.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

Reference Section E for a detailed component location view. The coolant temperature sensor is located in the thermostat housing.

Shop Talk

The resistance of the sensor varies with the temperature. The reading observed will compare to the following table if the sensor is functioning properly.

Temperature (°F) | Temperature (°C) | Resistance (ohms)
32 | 0 | 30k to 36k
77 | 25 | 9k to 11k
122 | 50 | 3k to 4k
167 | 75 | 1350 to 1500
212 | 100 | 600 to 675
Refer to Troubleshooting Fault Code t05-144


Coolant Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Coolant Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Amber SRT: | Coolant temperature sensor circuit - voltage below normal or shorted to low source. | Engine protection for coolant temperature is disabled.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

Reference Section E for a detailed component location view. The coolant temperature sensor is located in the thermostat housing.

Shop Talk

The resistance of the sensor varies with the temperature. The reading observed will compare to the following table if the sensor is functioning properly.

Temperature (°F) | Temperature (°C) | Resistance (ohms)
32 | 0 | 30k to 36k
77 | 25 | 9k to 11k
122 | 50 | 3k to 4k
167 | 75 | 1350 to 1500
212 | 100 | 600 to 675
Refer to Troubleshooting Fault Code t05-145


Coolant Temperature High - Data Valid but Above Normal Operating Range

FAULT CODE 151

Coolant Temperature High - Data Valid but Above Normal Operating Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Coolant temperature high - data valid but above normal operating range (most severe level). | Engine protection shutdown enabled, engine will shut down. Engine protection derate enabled, power derate engine protection disabled, no action taken.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature sensor is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on coolant temperature sensor signal pin.

Component Location

Reference Section E for a detailed component location view. The coolant temperature sensor is located in the thermostat housing.

Shop Talk

The signal voltage varies between 0.5 and 4.5 VDC as the internal resistance of the sensor changes due to changing coolant temperature. When the sensor signal voltage indicates a temperature exceeding a set limit, Fault Code 151 is logged.

This fault is often associated with a damaged sea water pump, a clogged aftercooler or sea strainer, a fouled heat exchanger or a malfunctioning thermostat.

A faulty sensor can cause Fault Code 151.

The following chart shows resistance of the coolant temperature sensor at various temperature readings.

Temperature (°F) | Temperature (°C) | Resistance (ohms)
32 | 0 | 30k to 36k
77 | 25 | 9k to 11k
122 | 50 | 3k to 4k
167 | 75 | 1350 to 1500
212 | 100 | 600 to 675

The number of fault lamps can be reduced to two for certain OEMs. The engine protection and stop lamps are wired together as a red lamp. The warning lamp remains an amber lamp.

Refer to Troubleshooting Fault Code t05-151


Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake manifold air temperature sensor circuit - voltage above normal or shorted to high source. | No engine protection for circuit or sensor failure.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

Reference Section E for a detailed component location view. The intake manifold temperature sensor is located in the intake manifold at the rear of the engine.

Shop Talk

The resistance of all the temperature sensors varies with the temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°F) | Temperature (°C) | Resistance (ohms)
32 | 0 | 30k to 36k
77 | 25 | 9k to 11k
122 | 50 | 3k to 4k
167 | 75 | 1350 to 1500
212 | 100 | 600 to 675
Refer to Troubleshooting Fault Code t05-153


Intake Manifold Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake manifold air temperature sensor circuit - voltage below normal or shorted to low source. | No engine protection for circuit or sensor failure.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

Reference Section E for a detailed component location view. The intake manifold temperature sensor is located in the intake manifold at the rear of the engine.

Shop Talk

The resistance of all the temperature sensors varies with the temperature. The reading observed should compare to the following table if the sensor is functioning properly.

Temperature (°F) | Temperature (°C) | Resistance (ohms)
32 | 0 | 30k to 36k
77 | 25 | 9k to 11k
122 | 50 | 3k to 4k
167 | 75 | 1350 to 1500
212 | 100 | 600 to 675
Refer to Troubleshooting Fault Code t05-154


Intake Manifold Air Temperature High - Data Valid but Above Normal Operating Range

FAULT CODE 155

Intake Manifold Air Temperature High - Data Valid but Above Normal Operating Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 100 FMI: 0 LAMP: Red SRT: | Intake manifold air temperature high - data valid but above normal operating range (most severe level). | Engine protection shutdown enabled, engine will shut down. Engine protection derate enabled, power derate engine protection disabled, no action taken.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control. The ECM monitors the voltage on the intake manifold temperature sensor signal pin.

Component Location

Reference Section E for a detailed component location view. The intake manifold temperature sensor is located in the intake manifold at the rear of the engine.

Shop Talk

The signal voltage varies between 0.5 and 4.5 VDC as the internal resistance of the sensor changes due to changing coolant temperature. When the sensor signal voltage indicates a temperature exceeding a set limit, Fault Code 155 is logged.

Verify the cooling water intake is not blocked or clogged with debris.

A faulty sensor can cause Fault Code 155.

The following chart shows the resistance of the intake manifold temperature sensor at various temperature readings.

Temperature (°F) | Temperature (°C) | Resistance (ohms)
32 | 0 | 30k to 36k
77 | 25 | 9k to 11k
122 | 50 | 3k to 4k
167 | 75 | 1350 to 1500
212 | 100 | 600 to 675

The number of fault lamps can be reduced to two for certain OEMs. The engine protection and stop lamps are wired together as a red lamp. The warning lamp remains an amber lamp.

Refer to Troubleshooting Fault Code t05-155


Rack Position Sensor Indicates Rack Position Greater than Calibrated Threshold

FAULT CODE 166

Rack Position Sensor Indicates Rack Position Greater than Calibrated Threshold

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 166 PID: S24 SPN: 733 FMI: 3 LAMP: Amber SRT: | The rack position sensor indicates the rack position is greater than the calibrated threshold. | No action taken by the electronic control module (ECM).
Rack Actuator Circuit

Circuit Description

The rack actuator is supplied with a varying current source from the ECM. The rack actuator uses this current to change the position of the control rack, which regulates the amount of fuel delivered from the fuel pump. The rack position feedback sensor relays the actuator rack position back to the ECM.

Component Location

The rack actuator is an integral part of the P7100 fuel pump

Shop Talk

  • Confirm the actuator connector is firmly in place.
  • When there is no power to the actuator, the actuator closes and fuel flow stops.
Refer to Troubleshooting Fault Code t05-166


Rack Actuator - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 172

Rack Actuator - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 172 PID: S23 SPN: 638 FMI: 7 LAMP: Red SRT: | Rack actuator - mechanical system not responding properly or out of adjustment. | Engine shutdown.
Rack Actuator Circuit

Circuit Description

The fuel control rack and solenoid determine the quantity of fuel metered to the engine.

Component Location

The fuel control rack and solenoid are integral parts of the P7100 fuel pump

Shop Talk

  • Confirm the actuator connector is firmly in place.
  • A defective fuel pump can cause Fault Code 172.
Refer to Troubleshooting Fault Code t05-172


Rack Actuator Mechanically Stuck Closed - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 173

Rack Actuator Mechanically Stuck Closed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 173 PID: S23 SPN: 638 FMI: 18 LAMP: Amber SRT: | Rack actuator mechanically stuck closed - data valid but below normal operating range - moderately severe level. | No action taken by the electronic control module (ECM).
Rack Actuator Circuit

Circuit Description

The fuel control rack and solenoid determine the quantity of fuel metered to the engine.

Component Location

The fuel control rack and solenoid are integral parts of the P7100 fuel pump

Shop Talk

  • Confirm the actuator connector is firmly in place.
  • A defective fuel pump can cause Fault Code 173.
Refer to Troubleshooting Fault Code t05-173


Multiple Unit Synchronization Error

FAULT CODE 237

Multiple Unit Synchronization Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 237 PID: S30 SPN: 644 FMI: 2 LAMP: Amber SRT: | External speed input (multiple unit synchronization) - data erratic, intermittent, or incorrect. | Engines will not be able to be controlled with one throttle input. The secondary engine must be controlled separately via its throttle input.
Multiple Unit Synchronization Circuit

Circuit Description

The primary engine outputs a throttle signal to the secondary engine via the J1939 interconnect. This is activated by a switch closure. This signal is interpreted by the secondary engine and is used as the throttle signal input by the secondary engine.

Component Location

Not applicable.

Shop Talk

The secondary engine expects a throttle signal to be transmitted from the primary engine via the J1939 datalink. A faulty signal will generate Fault Code 237 in the secondary engine.

Fault Code 237 can occur when the secondary keyswitch is ON and the primary keyswitch is OFF. It can also occur when there is an open circuit in the wires that connect the J1939 signal from the primary to the secondary engine. The diagram above illustrates the circuit and the data flow path.

  • Verify the multiple unit synchronization jumpers are in place.
  • Verify there is only one primary jumper and one secondary jumper.
  • Verify both keyswitches are ON.
  • Toggle the synchronization switch to determine if the fault goes active and inactive.

Verify that the SAE J1939 datalink is active and communicates correctly with INSITE™ electronic service tool on all engines. Refer to Procedure If any ECM will not communicate over the SAE J1939 datalink, follow Procedure 022-999 (Service Tools and Hardware - Overview) in Section F.

Refer to Troubleshooting Fault Code t05-237


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: SPN: 630 FMI: 12 LAMP: Yellow SRT: | Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component. | Possible reduced performance.
Engine Control Module (ECM)

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by an internal ECM malfunction. This can also be caused if battery power is disconnected before the power-down sequence is completed. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code 346.

Last Modified: 07-Oct-2016


Multiple Unit Synchronization Switch Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 497

Multiple Unit Synchronization Switch Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 497 PID: S114 SPN: 1377 FMI: 2 LAMP: Amber SRT: | Multiple unit synchronization switch circuit - data erratic, intermittent, or incorrect. | Engines will not be able to be controlled with one throttle input. The secondary engine must be controlled separately via its throttle input.
Multiple Unit Synchronization Switch Circuit

Circuit Description

The multiple unit synchronization circuit uses a complimentary switch to provide two opposite signals into the electronic control module (ECM). A double-pole, double-throw switch is used to activate synchronization mode on both engines.

Component Location

The multiple unit synchronization switch is mounted on the engine switch control panel. Reference the OEM manual for the specific location.

Shop Talk

The multiple unit synchronization switch is used to activate the engine synchronization function. The ECM expects to see the engine synchronization on/off and engine synchronization on/off complimentary switch toggle state once the feature is activated. Typical fail modes which can generate this fault are:

  • Wires are dislodged from the rear of the switch.
  • Intermittent connections are in the signal path.
  • A switch has failed.
  • Contaminated connections at the synchronization switch or in the circuit path.
  • This fault can occur when a “C-Cruise” enabled ECM calibration is improperly loaded in an engine that is not intended to use multiple unit synchronization switch and does not have a synchronization switch installed. In this situation, realibrating the ECM with the correct non “C-Cruise” calibration will eliminate the fault.
Refer to Troubleshooting Fault Code t05-497


Multiple Fault Code A

FAULT CODE A

Multiple Fault Code A

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: A PID: FMI: LAMP: SRT: | Multiple fault codes are generated due to a common supply or return wire failure in the engine harness. | Fault Codes 122 and 135 are active.
Electronic Control Module (ECM)

Circuit Description

The electronic control module (ECM) supplies all engine pressure sensors on the engine harness with +5 VDC. The ECM has common returns for all the engine pressure and temperature sensors. Reference the wiring diagram, Bulletin 4021331, for the pin assignments of these circuits. A failure on either of these circuits causes multiple fault codes.

Component Location

Reference Section E for a detailed component location view. The ECM is located at the top of the engine, mounted to the air intake manifold.

Shop Talk

An open circuit in the common supply and return wires, short circuits from battery or ground to the supply, or a defective ECM power supply can cause multiple fault codes.

A failed pressure sensor can cause multiple fault codes.

A failed pressure sensor can cause multiple active fault codes to go inactive once the engine has been started.

Refer to Troubleshooting Fault Code t05-mfc01


Multiple Fault Code B

FAULT CODE B

Multiple Fault Code B

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: B PID: FMI: LAMP: SRT: | Multiple fault codes are generated due to a common supply or return wire failure in the engine harness. | Fault Codes 123 and 141 are active.
Electronic Control Module (ECM)

Circuit Description

The electronic control module (ECM) supplies all engine pressure sensors on the engine harness with +5 VDC. The ECM has common returns for all the engine pressure and temperature sensors. Reference the wiring diagram, Bulletin 4021331, for the pin assignments of these circuits. A failure on either of these circuits causes multiple fault codes.

Component Location

Reference Section E for a detailed component location view. The ECM is located at the top of the engine, mounted to the air intake manifold.

Shop Talk

An open circuit in the common supply and return wires, short circuits from battery or ground to the supply, or a defective ECM power supply can cause multiple fault codes.

A failed pressure sensor can cause multiple fault codes.

A failed pressure sensor can cause multiple active fault codes to go inactive once the engine has been started.

Refer to Troubleshooting Fault Code t05-mfc02


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


Printable Version Printable Version

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 active?
 | STEP 1B. Check for inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait five seconds.
  • Start the engine and let it idle for one minute.

Fault Code 111 active?
YES NO

Replace the ECM.

Refer to Procedure 019-031.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive counts of Fault Code 111.

  • Use INSITE™ to read the fault codes.

Less than three counts?
YES NO
No Repair

Call for pre-authorization.

Replace the ECM.

Refer to Procedure 019-031.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 111 is inactive.

Fault Code 111 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 115 inactive?
STEP 2. | Check the primary engine speed sensor and circuit. |
 | STEP 2A. Inspect the primary engine speed sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Engine speed sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the primary engine speed sensor. | Damaged sensor tip?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2D-2. Verify adequate primary engine speed sensor air gap. |
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code or open return circuit. |
 | STEP 3B. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine control module response. |
 | STEP 3B-2. Check the engine control module response. |
 | STEP 3B-3. Check for an inactive fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 115 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the primary engine speed sensor and circuit.

Guided Step 2A - Inspect the primary engine speed sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine harness and engine speed sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-218.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine speed sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the primary engine speed sensor SUPPLY pin and the primary engine speed sensor RETURN pin at the engine speed sensor connector of the engine harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the INSITE™ monitor mode to read the engine speed sensor state.

Engine speed sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 3B

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the primary engine speed sensor SUPPLY pin and the primary engine speed sensor SIGNAL pin at the primary engine speed sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use the INSITE™ monitor mode to read the engine speed sensor state.

Engine speed sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Inspect the primary engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine speed sensor from the engine harness.

Action

Inspect the primary engine speed sensor for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

A defective sensor has been detected.

Replace the primary engine speed sensor.

Refer to Procedure 019-042.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary engine speed sensor from the engine harness.
  • Make sure the primary engine speed sensor is connected to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place the edge of the ratchet drive side of the socket tool, used to remove the sensor from the engine, on the edge of the sensor.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.
  • Use INSITE™ to read the engine speed sensor state.

Engine speed sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

A defective sensor has been detected.

Replace the primary engine speed sensor.

Refer to Procedure 019-042.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Verify adequate primary engine speed sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Connect the primary engine speed sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify adequate air gap.

  • Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary.
  • Monitor the engine speed sensor state of the primary engine speed sensor for a change of state from high to low, or low to high, or the state shows triggered.

Engine speed sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Inspect the flywheel ring gear for damage or spinning.

Refer to Procedure 016-008 in the Troubleshooting and Repair Manual, C Series Engines, Bulletin 3666003.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness connector or pins if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Turn keyswitch ON or Run/Stop switch to the RUN position.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the primary engine speed sensor SUPPLY pin and the primary engine speed sensor RETURN pin at the engine control module engine connector.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code or open return circuit.

Conditions

  • Connect all components.
  • Start the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 115 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the INSITE™ monitor mode to read the engine speed sensor state.

Engine speed sensor state equals low?
YES NO
No Repair

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the primary engine speed sensor SUPPLY pin and the primary engine speed sensor SIGNAL pin at the engine control module engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use the INSITE™ monitor mode to read the engine speed sensor state.

Engine speed sensor state equals high?
YES NO
No Repair

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 115 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

An open circuit or a pin to pin short circuit, or short to ground has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 115 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 121 inactive?
STEP 2. | Check the secondary engine speed sensor and circuit. |
 | STEP 2A. Inspect the secondary engine speed sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Engine speed sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the secondary engine speed sensor. | Damaged sensor tip?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2D-2. Verify adequate secondary engine speed sensor air gap. |
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code or open return circuit. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine control module response. |
 | STEP 3B-2. Check the engine control module response. |
 | STEP 3B-3. Check for an inactive fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 121 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the secondary engine speed sensor and circuit.

Guided Step 2A - Inspect the secondary engine speed sensor and connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the secondary engine speed sensor from the engine harness.

Action

Inspect the engine harness and secondary engine speed sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirty or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-218.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine speed sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the secondary engine speed sensor SUPPLY pin and the secondary engine speed sensor RETURN pin at the secondary engine speed sensor connector of the engine harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the INSITE™ monitor mode to read the engine speed sensor state.

Engine speed sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 3B

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the secondary engine speed sensor SUPPLY pin and the secondary engine speed sensor SIGNAL pin at the secondary engine speed sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use the INSITE™ monitor mode to read the engine speed sensor state.

Engine speed sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Inspect the secondary engine speed sensor.

Conditions

  • Turn keyswitch OFF or Run/Stop switch to the STOP position.
  • Disconnect the secondary engine speed sensor from the engine.

Action

Inspect the secondary engine speed sensor for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

A defective sensor has been detected.

Replace the secondary engine speed sensor.

Refer to Procedure 019-042.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine speed sensor from the engine harness.
  • Make sure the secondary engine speed sensor is connected to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place the edge of the ratchet drive side of the socket tool, used to remove the sensor from the engine, on the edge of the sensor.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.
  • Use INSITE™ to read the engine speed sensor state.

Engine speed sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

A defective sensor has been detected.

Replace the secondary engine speed sensor.

Refer to Procedure 019-042.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Verify adequate secondary engine speed sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Connect the secondary engine speed sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify adequate air gap.

  • Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary.
  • Monitor the engine speed sensor state of the secondary engine speed sensor for a change of state from high to low, or low to high, or the state shows triggered.

Engine speed sensor state transitions from high to low or low to high, or the state shows triggered?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Inspect the flywheel ring gear for damage or spinning.

Refer to Procedure 016-008 in the Troubleshooting and Repair Manual, C Series Engines, Bulletin 3666003.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirty or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the secondary engine speed sensor SUPPLY pin and the secondary engine speed sensor RETURN pin at the engine control module engine connector.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code or open return circuit.

Conditions

  • Connect all components.
  • Start the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 121 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirty or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the engine speed sensor state.

Engine speed sensor state equals low?
YES NO
No Repair

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the secondary engine speed sensor SUPPLY pin and the secondary engine speed sensor SIGNAL pin at the engine control module engine connector.

  • Check for the appropriate response after 30 seconds.
  • Use the INSITE™ monitor mode to read the engine speed sensor state.

Engine speed sensor state equals high?
YES NO
No Repair

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 121 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

An open circuit or a pin to pin short circuit, or short to ground has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE to verify the fault code is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | One or more of Fault Codes 135, 144, or 153 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ to read the fault codes.

One or more of Fault Codes 135, 144, or 153 active?
YES | NO
No Repair | No Repair

Reference the Multiple Fault Code Procedure A.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043.

Refer to Procedure 019-202.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 122 active?
YES NO

A defective sensor has been detected.

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043.

Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the intake manifold pressure sensor RETURN pin of the ECM harness at the ECM connection and RETURN pin at the intake manifold pressure sensor connection.

Reference the wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-360

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure sensor SIGNAL pin in the engine harness and all other pins in the engine harness connector.

Reference the wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-360

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure sensor SUPPLY pin in the engine harness and all other pins in the engine harness connector.

Reference the wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-360

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization.

Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 122 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | One or more of Fault Codes 141, 145, or 154 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ to read the fault codes.

One or more of Fault Codes 141, 145, or 154 active?
YES | NO
No Repair | No Repair

Reference the Multiple Fault Code Procedure B

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043.

Refer to Procedure 019-202.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 123 active?
YES NO

A defective sensor has been detected.

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043.

Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the intake manifold pressure sensor SUPPLY pin of the ECM harness at the ECM connection and SUPPLY pin at the intake manifold pressure sensor connection.

Reference the wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-360

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the intake manifold pressure sensor SIGNAL pin of the ECM harness at the ECM connection and SIGNAL pin at the intake manifold pressure sensor connection.

Reference the wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-360

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure sensor SIGNAL pin in the engine harness and all other pins in the engine harness connector.

Reference the wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-360

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold pressure sensor SIGNAL pin in the engine harness and ground.

Reference the wiring diagram for connector pin identification.

For general inspection techniques. Refer to Procedure 019-360

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization.

Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 123 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify sensor accuracy with a mechanical gauge. | Sensor reading is correct (within 127 mm Hg [5 in Hg])?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 124 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical intake manifold pressure gauge to the engine.
  • Connect INSITE™ to the vessel datalink.
  • Start the engine and compare the intake manifold pressure sensor reading on the INSITE™ monitor screen to the reading on the mechanical intake manifold pressure gauge.

Increase the engine rpm to make it easier to see differences in the readings.

Sensor reading is correct (within 127 mm Hg [5 in Hg])?
YES NO

Locate and repair the cause of high intake manifold pressure. Refer to Procedure 010-050 in the Troubleshooting and Repair Manual, C Series Engines, Bulletin 3666003.

Fault Code 123 is active.

Go to 2A

Fault Code 123

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 124 is inactive.

If the fault occurred at a particular rpm, run the engine at that rpm to verify the problem is corrected.

Fault Code 124 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 2. | Check the accelerator pedal/lever and circuit. |
 | STEP 2A. Inspect the accelerator pedal/lever and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal/lever supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 inactive and Fault Code 132 active?
 | STEP 2D. Check the fault codes and verify accelerator pedal/lever condition. | Fault Code 131 active?
STEP 3. | Check the engine control module and marine OEM harness. |
 | STEP 3A. Inspect the engine control module and marine OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the marine OEM harness. |
 | STEP 3A-2. Check for a pin to pin short circuit in the marine OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the accelerator pedal/lever and circuit.

Guided Step 2A - Inspect the accelerator pedal/lever and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.

Action

Inspect the throttle extension harness and accelerator pedal/lever connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-201.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal/lever supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the accelerator pedal/lever SUPPLY pin and the accelerator pedal/lever RETURN pin at the accelerator pedal/lever connector of the throttle extension harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 131 inactive and Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal/lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal/lever to the throttle extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 131 active?
YES NO

A defective accelerator pedal/lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal/lever.

Reference the appropriate OEM manual.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and marine OEM harness.

Guided Step 3A - Inspect the engine control module and marine OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.

Action

Inspect the marine OEM harness and engine control module harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module or marine OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the marine OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the marine OEM harness engine control module harness connector accelerator pedal/lever RETURN pin and the throttle extension harness accelerator pedal/lever connector accelerator pedal/lever RETURN pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the marine OEM harness.

Repair or replace the marine OEM harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a pin to pin short circuit in the marine OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the accelerator pedal/lever SIGNAL pin in the marine OEM harness engine control module harness connector and all other pins in the harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques.Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the marine OEM harness.

Repair or replace the marine OEM harness.

Refer to Procedure 019-043.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 131 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 131 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 2. | Check the accelerator pedal/lever and circuit. |
 | STEP 2A. Inspect the accelerator pedal/lever and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal/lever supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal/lever condition. | Fault Code 132 active?
STEP 3. | Check the engine control module and marine OEM harness. |
 | STEP 3A. Inspect the engine control module and marine OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the marine OEM harness. |
 | STEP 3A-2. Check for an open circuit in the marine OEM harness. |
 | STEP 3A-3. Check for a pin to pin short circuit in the marine OEM harness. |
 | STEP 3A-4. Check for a pin short circuit to ground. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the accelerator pedal/lever and circuit.

Guided Step 2A - Inspect the accelerator pedal/lever and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.

Action

Inspect the throttle extension harness and accelerator pedal/lever connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-201.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal/lever supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the accelerator pedal/lever SUPPLY pin and the accelerator pedal/lever RETURN pin at the accelerator pedal/lever connector of the throttle extension harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the accelerator pedal/lever SUPPLY pin and the accelerator pedal/lever SIGNAL pin at the accelerator pedal/lever connector of the throttle extension harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ to read the fault codes.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal/lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal/lever to the throttle extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 132 active?
YES NO

A defective accelerator pedal/lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal/lever.

Reference the appropriate OEM manual.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and marine OEM harness.

Guided Step 3A - Inspect the engine control module and marine OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.

Action

Inspect the marine OEM harness and engine control module harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module or marine OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the marine OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the marine OEM harness engine control module harness connector accelerator pedal/lever SUPPLY pin and the throttle extension harness accelerator pedal/lever connector accelerator pedal/lever SUPPLY pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the marine OEM harness.

Repair or replace the marine OEM harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an open circuit in the marine OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the marine OEM harness engine control module harness connector accelerator pedal/lever SIGNAL pin and the throttle extension harness accelerator pedal/lever connector accelerator pedal/lever SIGNAL pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the marine OEM harness.

Repair or replace the marine OEM harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a pin to pin short circuit in the marine OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the accelerator pedal/lever SIGNAL pin in the marine OEM harness engine control module harness connector and all other pins in the harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the marine OEM harness.

Repair or replace the marine OEM harness.

Refer to Procedure 019-043.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the accelerator pedal/lever from the throttle extension harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the accelerator pedal/lever SIGNAL pin in the marine OEM harness engine control module harness connector and ground.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the marine OEM harness.

Repair or replace the marine OEM harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 132 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 132 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 2. | Check the remote accelerator pedal/lever and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal/lever and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal/lever supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 inactive and Fault Code 134 active?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal/lever condition. | Fault Code 133 active?
STEP 3. | Check the engine control module and marine OEM harness. |
 | STEP 3A. Inspect the engine control module and marine OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the marine OEM harness and main extension harness. |
 | STEP 3A-2. Check for a pin to pin short circuit in the marine OEM harness and main extension harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 133 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the remote accelerator pedal/lever and circuit.

Guided Step 2A - Inspect the remote accelerator pedal/lever and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.

Action

Inspect the main extension harness and remote accelerator pedal/lever connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-201.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal/lever supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the remote accelerator pedal/lever SUPPLY pin and the accelerator pedal/lever RETURN pin at the remote accelerator pedal/lever connector of the main extension harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 133 inactive and Fault Code 134 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal/lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal/lever to the main extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 133 active?
YES NO

A defective remote accelerator pedal/lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the remote accelerator pedal/lever.

Reference the appropriate OEM manual.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and marine OEM harness.

Guided Step 3A - Inspect the engine control module and marine OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.

Action

Inspect the marine OEM harness and engine control module harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module or marine OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the marine OEM harness and main extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the marine OEM harness engine control module harness connector remote accelerator pedal/lever RETURN pin and the main extension harness remote accelerator pedal/lever connector accelerator pedal/lever RETURN pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the marine OEM and main extension harnesses.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the appropriate harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a pin to pin short circuit in the marine OEM harness and main extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the marine OEM harness engine control module harness connector and all other pins in the harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 1000 ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the marine OEM and main extension harnesses.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the appropriate harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 133 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 133 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 2. | Check the remote accelerator pedal/lever and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal/lever and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal/lever supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal/lever condition. | Fault Code 134 active?
STEP 3. | Check the engine control module and marine OEM harness. |
 | STEP 3A. Inspect the engine control module and marine OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the marine OEM harness. |
 | STEP 3A-2. Check for an open circuit in the marine OEM harness. |
 | STEP 3A-3. Check for a pin to pin short circuit in the marine OEM harness. |
 | STEP 3A-4. Check for a pin short circuit to ground. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the remote accelerator pedal/lever and circuit.

Guided Step 2A - Inspect the remote accelerator pedal/lever and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.

Action

Inspect the main extension harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal/lever supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the remote accelerator pedal/lever SUPPLY pin to the remote accelerator pedal/lever RETURN pin at the sensor connector of the main extension harness.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the remote accelerator pedal/lever SUPPLY pin and the remote accelerator pedal/lever SIGNAL pin at the sensor connector of the main extension harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ to read the fault codes.

Fault Code 133 active and Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal/lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal/lever to the main extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 134 active?
YES NO

A defective remote accelerator pedal/lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the remote accelerator pedal/lever.

Reference the appropriate OEM manual.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and marine OEM harness.

Guided Step 3A - Inspect the engine control module and marine OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the ECM.

Action

Inspect the marine OEM harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module or marine OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the marine OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the ECM.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the marine OEM harness engine control module harness connector remote accelerator pedal/lever SUPPLY pin and the main extension harness remote accelerator pedal/lever connector accelerator pedal/lever SUPPLY pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the marine OEM harness.

Repair or replace the marine OEM harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an open circuit in the marine OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the marine OEM harness engine control module harness connector remote accelerator pedal/lever SIGNAL pin and the main extension harness remote accelerator pedal/lever connector remote accelerator pedal/lever SIGNAL pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the marine OEM harness.

Repair or replace the marine OEM harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a pin to pin short circuit in the marine OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the marine OEM harness engine control module harness connector and all other pins in the harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the marine OEM harness.

Repair or replace the marine OEM harness.

Refer to Procedure 019-043.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the engine control module harness connector.
  • Disconnect the remote accelerator pedal/lever from the main extension harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the marine OEM harness engine control module harness connector and ground.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the marine OEM harness.

Repair or replace the marine OEM harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 134 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 134 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | One or more of Fault Codes 122, 144, or 153 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and 2circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 135 inactive and Fault Code 141 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 1000 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ to read the fault codes.

One or more of Fault Codes 122, 144, or 153 active?
YES | NO
No Repair | No Repair

Multiple Fault Code A

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-202.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 135 inactive and Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the oil pressure sensor SUPPLY pin and the oil pressure sensor RETURN pin at the oil pressure sensor connector of the engine harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 135 active?
YES NO

A defective sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the oil pressure sensor RETURN pin of the ECM harness at the ECM connection and the RETURN pin at the oil pressure sensor connection.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the oil pressure sensor SIGNAL pin in the engine harness and all other pins in the engine harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the oil pressure sensor SUPPLY pin in the engine harness and all other pins in the engine harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 1000 ohms?
YES NO
No Repair

A pin to pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | One or more of Fault Codes 123, 145, or 154 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 1000 ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ to read the fault codes.

One or more of Fault Codes 123, 145, or 154 active?
YES | NO
No Repair | No Repair

Multiple Fault Code B

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-202.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the oil pressure sensor SUPPLY pin and the oil pressure sensor RETURN pin at the oil pressure sensor connector of the engine harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil pressure sensor SUPPLY pin and the oil pressure sensor SIGNAL pin at the oil pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 141 active?
YES NO

A defective sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the oil pressure sensor SUPPLY pin of the ECM harness at the ECM connection and the SUPPLY pin at the oil pressure sensor connection.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the oil pressure sensor SIGNAL pin of the ECM harness at the ECM connection and the SIGNAL pin at the oil pressure sensor connection.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the oil pressure sensor SIGNAL pin in the engine harness and all other pins in the engine harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 1000 ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the oil pressure sensor SIGNAL pin in the engine harness engine control module engine connector and ground.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify sensor accuracy with a mechanical gauge. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 143 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge of known quality and calibration to the engine at one of the plugs on top of the oil filter head.
  • Connect INSITE™ to the vessel datalink.
  • Start the engine and compare the oil pressure reading on the INSITE™ monitor screen to the reading on the machanical oil pressure gauge.

Increase the engine rpm to make it easier to see differences in the readings.

Sensor reading is correct?
YES NO

Reference the Troubleshooting and Repair Manual, C Series Engines, Bulletin 3666003, for the correct specification.

 No Repair

Go to 2A

Fault Code 141

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 143 is inactive.

If the fault occurred at a particular rpm, run the engine at that rpm to verify the problem is corrected.

Fault Code 143 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 600 ohms to 36k ohms?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the coolant temperature sensor and circuit.

Guided Step 2A - Inspect the coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature from the engine harness.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell is broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-202.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the coolant temperature sensor SIGNAL pin and the coolant temperature sensor RETURN pin at the coolant temperature sensor connector.

Reference the wiring diagram for connector pin identification.

600 ohms to 36k ohms?

Reference the laminated wiring diagram, Bulletin 4021331, for specifications.
YES NO
No Repair

Replace the coolant temperature sensor.

Refer to Procedure 019-019.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell is broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature sensor RETURN pin of the ECM harness at the ECM connection and the RETURN pin at the coolant temperature sensor connection.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature sensor SIGNAL pin of the ECM harness at the ECM connection and the SIGNAL pin at the coolant temperature sensor connection.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the coolant temperature sensor SIGNAL pin of the engine harness and all other pins in the engine harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the coolant temperature sensor and circuit.

Guided Step 2A - Inspect the coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature from the engine harness.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell is broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-202.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 145 active?
YES NO

A defective sensor has been detected.

Replace the coolant temperature sensor.

Refer to Procedure 019-019.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell is broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature sensor RETURN pin of the ECM harness at the ECM connection and the RETURN pin at the coolant temperature sensor connection.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature sensor SIGNAL pin of the ECM harness at the ECM connection and the SIGNAL pin at the coolant temperature sensor connection.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the coolant temperature sensor SIGNAL pin in the engine harness engine control module engine connector and ground.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 151 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar proble. Reference the table in Shop Talk.

  • Connect a temperature probe of known quality and accuracy to the engine near the coolant temperature sensor.
  • Connect INSITE™ to the vessel datalink.
  • Compare the coolant temperature sensor reading on the service tool monitor screen to the reading from the temperature probe.

If no temperature measuring device is available, answer YES to this step.

Sensor reading is correct?
YES | NO
No Repair | No Repair

Go to 2A

Fault Code 145

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 151 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 600 ohms to 36k ohms?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold temperature sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell is broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043, Refer to Procedure 019-202, and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold temperature SIGNAL pin and intake manifold temperature RETURN pin at the intake manifold temperature sensor connector.

Reference the wiring diagram for connector pin identification.

600 ohms to 36k ohms?
YES NO
No Repair

Replace the intake manifold temperature sensor.

Refer to Procedure 019-059.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.

Action

Inspect the engine harness and engine control module harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell is broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module harness connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness engine control module harness connector RETURN pin and the engine harness intake manifold temperature sensor connector RETURN pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness engine control module harness connector intake manifold temperature sensor SIGNAL pin and the engine harness intake manifold temperature sensor connector intake manifold temperature sensor SIGNAL pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness engine control module harness connector and all other pins in the harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code, Procedure Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold temperature sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell is broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043, Refer to Procedure 019-202, and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 154 active?
YES NO

A defective sensor has been detected.

Replace the intake manifold temperature sensor.

Refer to Procedure 019-059.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.

Action

Inspect the engine harness and engine control module harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell is broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module harness connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold temperature SIGNAL pin in the engine harness engine control module harness connector and all other pins in the harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness engine control module harness connector and ground.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 154 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Call for pre-authorization. Replace the engine control module.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 155 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar probe. Reference the table in Shop Talk.

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold temperature sensor.

The probe must extend into the airflow and must not touch the intake manifold except at the probe threads.

  • Connect INSITE™ to the vessel datalink.
  • Compare the intake manifold temperature sensor reading on the service tool monitor screen to the reading from the temperature probe.

If no temperature measuring device is available, answer YES to this step.

Sensor reading is correct?
YES | NO
No Repair | No Repair

Go to 2A

Fault Code 154

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 155 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pump. |
 | STEP 1A. Inspect the fuel pump and engine harness connectors. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 166 inactive?
 | STEP 1C. Check the rack actuator coil resistance. | 7.0 to 9.0 ohms?
 | STEP 1D. Check for a pin to pin short circuit in the fuel pump harness. | More than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 166 active?
 | STEP 2C. Check for an open circuit. | Less than 20 ohms?
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 2E. Check for a pin to pin short circuit. | More than 100k ohms?
 | STEP 2F. Check for a short circuit from the return wire to the power supply. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 166 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel pump.

Guided Step 1A - Inspect the fuel pump and engine harness connectors.

Conditions

  • Turn keyswitch ON.

Action

Inspect the fuel pump and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell is broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the fuel pump or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair the fuel pump connector.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 166 inactive?
YES NO

Repair complete.

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1C

Guided Step 1C - Check the rack actuator coil resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Check the rack actuator coil resistance.

  • Measure the resistance from the P7100 Fuel + pin and the P7100 - pin of the fuel pump connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

7.0 to 9.0 ohms?
YES NO
No Repair

Call for pre-authorization. Repair or replace the fuel pump.

Refer to Procedure 005-012 in the Troubleshooting and Repair Manual, C Series Engines, Bulletin 3666003.

Go to 1D

Go to 3A

Guided Step 1D - Check for a pin to pin short circuit in the fuel pump harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a pin to pin short circuit in the fuel pump rack actuator coil.

  • Measure the resistance from the P7100 Fuel + pin of the fuel pump connector to all other pins of the connector, except the P7100 Fuel - pin.
  • Measure the resistance from the P7100 Fuel - pin of the fuel pump connector to all other pins of the connector, except the P7100 Fuel + pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

More than 100k ohms?
YES NO
No Repair

Call for pre-authorization. Repair or replace the fuel pump.

Refer to Procedure 005-012 in the Troubleshooting and Repair Manual, C Series Engines, Bulletin 3666003.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell is broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 and Refer to Procedure 019-204.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to read the fault codes.

Fault Code 166 active?
YES NO
No Repair

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the fuel pump.

Action

Check for an open circuit.

  • Measure in succession the resistance from each of the P7100 Fuel - pins to each of the P7100 + pins of the engine harness connector.

Less than 20 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit to ground

  • Measure in succession the resistance from each of the P7100 Fuel + pins of the engine harness connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin to pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the marine OEM harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a pin to pin short circuit.

  • Measure the resistance from one of the P7100 Fuel - pins of the engine harness connector to all other pins in the connector, except the second P7100 Fuel - pin, and to all pins in the marine OEM harness connector.
  • Measure the resistance from the second P7100 Fuel - pin of the engine harness connector to all other pins in the connector, except the first P7100 Fuel - pin, and to all pins in the marine OEM harness connector.
  • Measure the resistance from one of the P7100 Fuel + pins of the engine harness connector to all other pins in the connector, except the second P7100 Fuel + pin, and to all pins in the marine OEM harness connector.
  • Measure the resistance from the second P7100 Fuel + pin of the engine harness connector to all other pins in the connector, except the first P7100 Fuel + pin, and to all pins in the marine OEM harness connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit from the return wire to the power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from the return wire to the power supply.

  • Measure the resistance from each of the P7100 Fuel - pins to both of the P7100 + pins of the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 166 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 166 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 172 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.

Fault Code 166 active?
YES NO
No Repair

Call for pre-authorization.

Repair or replace the fuel pump.

Refer to Procedure 005-012 in the Troubleshooting and Repair Manual, C Series Engines, Bulletin 3666003.

Fault Code 166

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 172 is inactive.

Fault Code 172 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 166 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 173 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.

Fault Code 166 active?
YES NO
No Repair

Call for pre-authorization.

Repair or replace the fuel pump.

Refer to Procedure 005-012 in the Troubleshooting and Repair Manual, C Series Engines, Bulletin 3666003.

Fault Code 166

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 173 is inactive.

Fault Code 173 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an active fault code. |
 | STEP 1A. Read the fault codes. | Fault Code 237 active?
STEP 2. | Check the cross engine datalink harness. |
 | STEP 2A. Check the cross engine datalink and main extension harness connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the cross engine datalink harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the cross engine datalink harness. | Greater than 100k ohms?
STEP 3. | Check the J1939 datalink and main extension harnesses for the port engine. |
 | STEP 3A. Check the J1939 datalink and main extension harness connectors for the port engine. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the J1939 datalink and main extension harnesses for the port engine. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the J1939 datalink and main extension harnesses for the port engine. | Greater than 100k ohms?
STEP 4. | Check the J1939 datalink and main extension harnesses for the starboard engine. |
 | STEP 4A. Check the J1939 datalink and main extension harness connectors for the starboard engine. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 datalink and main extension harnesses for the starboard engine. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short circuit in the J1939 datalink and main extension harnesses for the starboard engine. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 237 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for an active fault code.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 237 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19

Guided Step 2 - Check the cross engine datalink harness.

Guided Step 2A - Check the cross engine datalink and main extension harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cross engine datalink harness from the main extension harness to the port engine.
  • Disconnect the cross engine datalink harness from the main extension harness to the starboard engine.

Action

Inspect the cross engine datalink and the main extension harness connectors for both engines for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the cross engine datalink harness or main extension harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-205 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit in the cross engine datalink harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit.

  • Measure the resistance between the J1939 datalink (1939+) pin on the cross engine datalink harness connector for the port engine and the J1939 datalink (1939+) pin on the cross engine datalink harness connector for the starboard engine.
  • Measure the resistance between the J1939 datalink (1939-) pin on the cross engine datalink harness connector for the port engine and the J1939 datalink (1939-) pin on the cross engine datalink harness connector for the starboard engine.

Reference the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the cross engine datalink harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-205 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a pin-to-pin short circuit in the cross engine datalink harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the J1939 datalink (1939-) pin on the cross engine datalink harness connector for the port engine and the J1939 datalink (1939+) pin on the cross engine datalink harness connector for the starboard engine.
  • Measure the resistance between the J1939 datalink (1939+) pin on the cross engine datalink harness connector for the port engine and the J1939 datalink (1939-) pin on the cross engine datalink harness connector for the starboard engine.

Reference the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the cross engine datalink harness.

Repair or replace the cross engine datalink harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-205 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the J1939 datalink and main extension harnesses for the port engine.

Guided Step 3A - Check the J1939 datalink and main extension harness connectors for the port engine.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 datalink harness from the engine control module engine connector.
  • Disconnect the cross engine datalink harness from the main extension harness to the port engine.

Action

Inspect the cross engine datalink and the main extension harness connectors for the port engine for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the J1939 datalink harness or main extension harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the cross engine datalink harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-205 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the J1939 datalink and main extension harnesses for the port engine.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 datalink harness from the engine control module engine connector.
  • Disconnect the main extension harness from the cross engine datalink harness.

Action

Check for an open circuit.

  • Measure the resistance between the J1939 datalink (1939-) pin on the cross engine datalink harness connector and the J1939 datalink (1939-) pin on the ECM connector.
  • Measure the resistance between the J1939 datalink (1939+) pin on the cross engine datalink harness connector and the J1939 datalink (1939+) pin on the ECM connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 datalink or main extension harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the faulty harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-205 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the J1939 datalink and main extension harnesses for the port engine.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 datalink harness from the engine control module engine connector.
  • Disconnect the main extension harness from the cross engine datalink harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the J1939 datalink (1939-) pin on the cross engine datalink harness connector and the J1939 datalink (1939+) pin on the ECM connector.
  • Measure the resistance between the J1939 datalink (1939+) pin on the cross engine datalink harness connector and the J1939 datalink (1939-) pin on the ECM connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the J1939 datalink and main extension harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted circuit.

Repair or replace the faulty harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-205 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the J1939 datalink and main extension harnesses for the starboard engine.

Guided Step 4A - Check the J1939 datalink and main extension harness connectors for the starboard engine.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 datalink harness from the engine control module engine connector.
  • Disconnect the cross engine datalink harness from the main extension harness to the port engine.

Action

Inspect the cross engine datalink and the main extension harness connectors for the starboard engine for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the J1939 datalink harness or main extension harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-205 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 datalink and main extension harnesses for the starboard engine.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 datalink harness from the engine control module engine connector.
  • Disconnect the main extension harness from the cross engine datalink harness.

Action

Check for an open circuit.

  • Measure the resistance between the J1939 datalink (1939-) pin on the cross engine datalink harness connector and the J1939 datalink (1939-) pin on the ECM connector.
  • Measure the resistance between the J1939 datalink (1939+) pin on the cross engine datalink harness connector and the J1939 datalink (1939+) pin on the ECM connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 datalink or main extension harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the faulty harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-205 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the J1939 datalink and main extension harnesses for the starboard engine.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 datalink harness from the engine control module engine connector.
  • Disconnect the main extension harness from the cross engine datalink harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the J1939 datalink (1939-) pin on the cross engine datalink harness connector and the J1939 datalink (1939+) pin on the ECM connector.
  • Measure the resistance between the J1939 datalink (1939+) pin on the cross engine datalink harness connector and the J1939 datalink (1939-) pin on the ECM connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the J1939 datalink and main extension harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted circuit.

Repair or replace the faulty harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-205 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitches for port and starboard engines ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
  • Turn the synchronization switch ON.

Fault Code 237 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitches for port and starboard engines ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


FAULT CODE 346 - Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 346 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the unswitched battery power circuits. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 2C. Check for an open circuit in the unswitched battery power circuits. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
STEP 3. | Check the batteries and fuses. |
 | STEP 3A. Check the batteries. | Connections tight and corrosion-free?
 | STEP 3B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 3B-1. Verify that the original equipment manufacturer (OEM) fuses are installed correctly. | Fuse installed correctly?
 | STEP 3B-2. Check if the OEM fuses are blown. | Fuse blown?
STEP 4. | Check the OEM power harness and 4 pin ECM power interface connector. |
 | STEP 4A. Inspect the power harness and 4 pin ECM power interface connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the battery power circuits. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 4C. Check for an open circuit in the battery power circuits. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 346 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 4 pin ECM power interface connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the harness. Refer to 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit in the unswitched battery power circuits.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

  • Measure the voltage between the unswitched battery voltage SUPPLY pins and RETURN pins at the 50 pin ECM engine harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery power circuits.

Conditions

  • Turn keyswitch OFF. Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the ECM.

Action

  • Measure the voltage between the unswitched battery voltage SUPPLY pins at the 50 pin engine harness connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES NO

An open or high resistance circuit has been detected in the battery voltage return circuit.

  • Troubleshoot the engine harness and all interconnects for the malfunction.

Repair or replace the damaged component as necessary.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the batteries and fuses.

Guided Step 3A - Check the batteries and fuses.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. See the equipment manufacturer service information.

Go to 3B

Go to 5A

Guided Step 3B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery. See the equipment manufacturer service information.

Go to 3B-1

Go to 5A

Guided Step 3B-1 - Verify that the OEM fuses are installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM 10A fuses between the battery and 4 pin ECM power interface are installed correctly.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Fuses installed correctly?
YES NO
No Repair

Install the fuses correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuses are blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM 10A fuses between the battery and 4 pin ECM power interface are not blown.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Fuses blown?
YES NO

Locate the short circuit.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the power harness and 4 pin ECM power interface connector.

Guided Step 4A - Inspect the power harness and the 4 pin ECM power interface connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect power harness from the 4 pin ECM Power interface connector.
  • Disconnect the power harness from the batteries.

Action

Inspect the power harness and 4 pin ECM Power interface connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the power harness or 4 pin ECM power interface connection.

  • Clean the connector and pins.
  • Reference the circuit diagram or wiring diagram for all harness interconnections.
  • Replace the harness or interface connector.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the 4 pin ECM power interface connector.

Action

  • Measure the voltage between the power harness SUPPLY pins and the power harness RETURN pins at the power harness 4 pin power interface connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES NO

Troubleshoot the engine harness and the interconnect for the malfunction.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the 4 pin ECM power interface connector.

Action

  • Measure the voltage between the power harness SUPPLY pins on the power harness 4 pin ECM power interface connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES NO

An open or high resistance circuit has been detected in the battery voltage return circuit.

  • Troubleshoot the power harness and all interconnects for the malfunction.

Repair or replace the damaged component as necessary.

An open or high resistance circuit has been detected in the battery voltage return circuit.

  • Troubleshoot the power harness and all interconnects for the malfunction.

Repair or replace the damaged component as necessary.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19 in the Associated Procedure Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete

Last Modified: 07-Oct-2016


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the synchronization switch. |
 | STEP 1A. Inspect the single and twin engine switch control panel connectors and the main extension harness connectors. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit in the synchronization switch. | Less than 10 ohms?
 | STEP 1C. Check for a pin-to-pin short circuit in the synchronization switch. | More than 100k ohms?
 | STEP 1D. Read the fault codes. | Fault Code 497 inactive?
STEP 2. | Check the marine OEM and main extension harnesses. |
 | STEP 2A. Check for an open circuit in the marine OEM and main extension harnesses. | Less than 10 ohms?
 | STEP 2B. Check for an open circuit in the marine OEM and main extension harnesses. | Less than 10 ohms?
STEP 3. | Check the marine OEM and main extension harnesses. |
 | STEP 3A. Check for a pin-to-pin short circuit in the marine OEM and main extension harnesses. | Greater than 100k ohms?
 | STEP 3B. Check for a pin-to-pin short circuit in the marine OEM and main extension harnesses. | Greater than 100k ohms?
STEP 4. | Check the marine OEM and main extension harnesses. |
 | STEP 4A. Check for an open circuit in the marine OEM and main extension harnesses. | Less than 10 ohms?
 | STEP 4B. Check for an open circuit in the marine OEM and main extension harnesses. | Less than 10 ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 497 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the synchronization switch.

Guided Step 1A - Inspect the single and twin engine switch control panel connectors and the main extension harness connectors.

Conditions

  • Turn keyswitch ON.
  • Disconnect the synchronization switch from the main extension harness.

Action

Inspect the single and twin engine switch control panel connectors and the main extension harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine switch control panel or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-204.

Refer to Procedure 019-205.

 No Repair

Go to 5A

Go to 1B

Guided Step 1B - Check for an open circuit in the synchronization switch.

Conditions

  • Turn keyswitch ON.
  • Put the multiple unit synchronization switch in the OPEN position.

Action

Check for an open circuit.

  • Put the positive lead of the multimeter on the engine synchronization on/off component switch pin of the twin engine switch control panel connector and the negative lead on the switch common pin of the twin engine switch control panel connector.
  • Put the positive lead of the multimeter on the engine synchronization on/off switch pin of the twin engine switch control panel connector and the negative lead on the switch common pin of the twin engine switch control panel connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the multiple unit synchronization switch.

Replace the multiple unit synchronization switch.

Go to 1C

Go to 5A

Guided Step 1C - Check for a pin-to-pin short circuit in the synchronization switch.

Conditions

  • Turn keyswitch ON.
  • Put the multiple unit synchronization switch in the CLOSED position.

Action

Check for a pin-to-pin short circuit.

  • Put the positive lead of the multimeter on the engine synchronization on/off component switch pin of the twin engine switch control panel connector and the negative lead on the switch common pin of the twin engine switch control panel connector.
  • Put the positive lead of the multimeter on the engine synchronization on/off switch pin of the twin engine switch control panel connector and the negative lead on the switch common pin of the twin engine switch control panel connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

More than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the multiple unit synchronization switch.

Replace the multiple unit synchronization switch.

Go to 1D

Go to 5A

Guided Step 1D - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it warm to normal operating temperature.
  • Verify Fault Code 497 is inactive.

Fault Code 497 inactive?
YES NO

Repair complete

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the marine OEM and main extension harnesses.

Guided Step 2A - Check for an open circuit in the marine OEM and main extension harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the ECM engine connector.
  • Disconnect the single engine switch control panel connector from the twin engine switch control panel connector.

Action

Check for an open circuit.

  • Measure the resistance between the multiple unit synchronization on/off component switch pin on the marine OEM harness connector and the engine synchronization on/off component switch of the twin engine switch control panel connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the marine OEM or engine connector harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the marine OEM or engine connector harness.

Refer to Procedure 019-204.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit in the marine OEM and main extension harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the marine OEM harness from the ECM engine connector.
  • Disconnect the single engine switch control panel connector from the twin engine switch control panel connector.

Action

Check for an open circuit.

  • Measure the resistance between the switch common pin on the twin engine switch control panel connector and block ground.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the marine OEM or engine connector harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the marine OEM or engine connector harness.

Refer to Procedure 019-204.

Go to 3A

Go to 5A

Guided Step 3 - Check the marine OEM and main extension harnesses.

Guided Step 3A - Check for a pin-to-pin short circuit in the marine OEM and main extension harnesses.

Conditions

  • Turn keyswitch OFF.
  • Connect the marine OEM harness to the ECM engine connector.
  • Disconnect the single engine switch control panel connector from the twin engine switch control panel connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the multiple unit synchronization on/off component switch pin in the marine OEM harness ECM engine connector and all other pins in the twin engine switch control panel connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the multiple unit synchronization on/off component switch circuit has been detected in the marine OEM and main extension harnesses.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted circuit.

Repair or replace the faulty harness.

Go to 3B

Go to 5A

Guided Step 3B - Check for a pin-to-pin short circuit in the marine OEM and main extension harnesses.

Conditions

  • Turn keyswitch OFF.
  • Connect the marine OEM harness to the ECM engine connector.
  • Disconnect the single engine switch control panel connector from the twin engine switch control panel connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the multiple unit synchronization on/off switch pin in the marine OEM harness ECM engine connector and all other pins in the twin engine switch control panel connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the multiple unit synchronization on/off switch circuit has been detected in the marine OEM and main extension harnesses.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted circuit.

Repair or replace the faulty harness.

Go to 4A

Go to 5A

Guided Step 4 - Check the marine OEM and main extension harnesses.

Guided Step 4A - Check for an open circuit in the marine OEM and main extension harnesses.

Conditions

  • Turn keyswitch ON.
  • Connect the marine OEM harness to the ECM engine connector.
  • Disconnect the single engine switch control panel connector from the twin engine switch control panel connector.

Action

Check for an open circuit.

  • Put the positive lead of the multimeter on the engine synchronization on/off component switch pin of the twin engine switch control panel connector and the negative lead on the switch common pin of the twin engine switch control panel connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the marine OEM or main extension harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the marine OEM or engine connector harness.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit in the marine OEM and main extension harnesses.

Conditions

  • Turn keyswitch ON.
  • Connect the marine OEM harness to the ECM engine connector.
  • Disconnect the single engine switch control panel connector from the twin engine switch control panel connector.

Action

Check for an open circuit.

  • Put the positive lead of the multimeter on the engine synchronization on/off switch pin of the twin engine switch control panel connector and the negative lead on the switch common pin of the twin engine switch control panel connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the marine OEM or engine connector harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the marine OEM or engine connector harness.

Refer to Procedure 019-043.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify Fault Code 497 is inactive.

Fault Code 497 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 122 and 135 active?
STEP 2. | Check the engine control module and engine harness. |
 | STEP 2A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Inspect the intake manifold pressure sensor, the oil pressure sensor, and harness connector pins. |
 | STEP 2A-2. Check for a pin to pin short circuit in the engine harness. |
 | STEP 2A-3. Check for an open circuit in the engine harness. |
 | STEP 2A-4. Check for a pin to pin short circuit in the engine harness. |
STEP 3. | Check for active fault codes. |
 | STEP 3A. Check for active fault codes. | Fault Codes 122 and 135 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 122 and 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ to read the fault codes.

Fault Code 122 and 135 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the engine control module and engine harness.

Guided Step 2A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module connector.

Action

Inspect the engine harness and engine control module connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector seals
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module connector(s) or engine harness connector(s).

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Inspect the intake manifold pressure sensor, the oil pressure sensor, and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor and oil pressure sensor from the engine harness.

Action

Inspect the intake manifold pressure sensor and oil pressure sensor connectors and intake manifold pressure sensor and oil pressure sensor engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector seals
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the intake manifold pressure sensor and/or oil pressure sensor engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

Refer to Procedure 019-202.

Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 2A-2

Guided Step 2A-2 - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.
  • Disconnect the intake manifold pressure sensor and oil pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold pressure SUPPLY pin in the engine harness engine control module harness connector and all other pins in the harness connector.
  • Measure the resistance between the oil pressure SUPPLY pin in the engine harness engine control module harness connector and all other pins in the harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the intake manifold pressure sensor or oil pressure sensor SUPPLY line has been detected in the engine harness or engine control module harness connector.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Repair or replace the engine control module harness connector.

Refer to Procedure 019-204.

Go to 2A-3

Go to 4A

Guided Step 2A-3 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.
  • Disconnect the intake manifold pressure sensor and oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness connector intake manifold pressure sensor RETURN pin and the engine harness intake manifold pressure sensor RETURN pin.
  • Measure the resistance between the engine harness connector oil pressure sensor RETURN pin and the engine harness oil pressure sensor RETURN pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected on the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Repair or replace the engine control module harness connector.

Refer to Procedure 019-204.

Go to 2A-4

Go to 4A

Guided Step 2A-4 - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.
  • Disconnect the intake manifold pressure sensor and oil pressure sensor from the engine harness.

Action

Check for a pin to pin short circuit.

  • Measure the resistance between the intake manifold pressure sensor SIGNAL pin in the engine harness engine control module harness connector and all other pins in the harness connector.
  • Measure the resistance between the oil pressure sensor SIGNAL pin in the engine harness engine control module harness connector and all other pins in the harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the intake manifold pressure sensor or oil pressure sensor SIGNAL line has been detected in the engine harness or the engine control module engine harness connector.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Repair or replace the engine control module harness connector.

Refer to Procedure 019-204.

Go to 3A

Go to 4A

Guided Step 3 - Check for active fault codes.

Guided Step 3A - Check for active fault codes.

Conditions

  • Connect all components and connectors.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Codes 122 and 135 active?
YES NO

Call for pre-authorization.

Replace the engine control module.

Refer to Procedure 019-031.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Codes 122 and 135 are inactive.

Fault Codes 122 and 135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 123 and 141 active?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the sensor supply voltage circuit. |
 | STEP 2A-2. Inspect the oil pressure sensor and harness connector pins. |
 | STEP 2A-3. Check the sensor supply voltage circuit. |
 | STEP 2A-4. Check the fault codes and verify sensor condition. |
 | STEP 3A-5. Check the fault codes and verify sensor condition. |
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for a pin to pin short circuit in the engine harness. |
 | STEP 3A-2. Check for an open circuit in the engine harness. |
 | STEP 3A-3. Check for a pin to pin short circuit in the engine harness. |
 | STEP 3A-4. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 123 or 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ to read the fault codes.

Fault Code 123 and 141 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the intake manifold pressure sensor connector and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector seals
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the intake manifold pressure sensor or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

Refer to Procedure 019-202.

Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the sensor supply voltage circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage circuit.

  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2A-4

Go to 2A-2

Guided Step 2A-2 - Inspect the oil pressure sensor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the oil pressure sensor connector and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector seals
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the oil pressure sensor or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

Refer to Procedure 019-202.

Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 2A-3

Guided Step 2A-3 - Check the sensor supply voltage circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage circuit.

  • Measure the voltage between the oil pressure sensor SUPPLY pin and the oil pressure sensor RETURN pin at the oil pressure sensor connector of the engine harness.

Reference the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2A-5

Go to 3A

Guided Step 2A-4 - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Codes 123 and 141 active?
YES NO

A defective sensor has been detected.

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061.

 No Repair

Go to 4A

Go to 2A-5

Guided Step 2A-5 - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Codes 123 and 141 active?
YES NO

A defective sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.

Action

Inspect the engine harness and engine control module harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector seals
  • Missing or damaged connector seals
  • Broken connector shell
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the engine control module harness connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

Refer to Procedure 019-204.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.
  • Disconnect the intake manifold pressure sensor and oil pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold pressure SUPPLY pin in the engine harness engine control module harness connector and all other pins in the harness connector.
  • Measure the resistance between the oil pressure SUPPLY pin in the engine harness engine control module harness connector and all other pins in the harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the intake manifold pressure sensor or oil pressure sensor SUPPLY line has been detected in the engine harness or the engine control module harness connector.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Repair or replace the engine control module harness connector.

Refer to Procedure 019-204.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector(s).
  • Disconnect the intake manifold pressure sensor and oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness connector intake manifold pressure sensor SUPPLY pin and the engine harness intake manifold pressure sensor SUPPLY pin(s).
  • Measure the resistance between the engine harness connector oil pressure sensor SUPPLY pin and the engine harness oil pressure sensor SUPPLY pin.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected on the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Repair or replace the engine control module harness connector.

Refer to Procedure 019-204.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module harness connector.
  • Disconnect the intake manifold pressure sensor and oil pressure sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the intake manifold pressure sensor SIGNAL pin in the engine harness connector and all other pins in the harness connector.
  • Measure the resistance between the oil pressure sensor SIGNAL pin in the engine harness connector and all other pins in the harness connector.

Reference the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the intake manifold pressure sensor or oil pressure SIGNAL line has been detected in the engine harness or the engine control module harness connector.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Repair or replace the engine control module harness connector.

Refer to Procedure 019-204.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check for an active fault code.

Conditions

  • Connect all components and connectors.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Codes 123 and 141 active?
YES NO

Call for pre-authorization.

Replace the engine control module.

Refer to Procedure 019-031.

None. The removal and reinstallation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify Fault Codes 123 and 141 are inactive.

Fault Codes 123 and 141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


INDEX
07-fcmfc01.htm

07-t05-mfc01.htm

07-fcmfc02.htm

07-t05-mfc02.htm

07-fc111.htm

07-t05-111.htm

07-fc115.htm

07-t05-115.htm

07-fc121.htm

07-t05-121.htm

07-fc122.htm

07-t05-122.htm

07-fc123.htm

07-t05-123.htm

07-fc124.htm

07-t05-124.htm

07-fc131.htm

07-t05-131.htm

07-fc132.htm

07-t05-132.htm

07-fc133.htm

07-t05-133.htm

07-fc134.htm

07-t05-134.htm

07-fc135.htm

07-t05-135.htm

07-fc141.htm

07-t05-141.htm

07-fc143.htm

07-t05-143.htm

07-fc144.htm

07-t05-144.htm

07-fc145.htm

07-t05-145.htm

07-fc151.htm

07-t05-151.htm

07-fc153.htm

07-t05-153.htm

07-fc154.htm

07-t05-154.htm

07-fc155.htm

07-t05-155.htm

07-fc166.htm

07-t05-166.htm

07-fc172.htm

07-t05-172.htm

07-fc173.htm

07-t05-173.htm

07-fc237.htm

07-t05-237.htm

07-fc346.htm

07-t05-346.htm

07-fc497.htm

07-t05-497.htm