Power Generation Control Systems

Last Modified: 30 October 2018

Copyright © 2018
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module (ECM) Microprocessor

FAULT CODE 111

Electronic Control Module (ECM) Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: FMI: LAMP: Shutdown SRT: | Error internal to the ECM. | Engine will not start.
GCS ECM

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

Refer to the OEM manual for the component location.

Shop Talk

This fault code can only be caused by an internal ECM problem.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 29-Jul-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Timing Actuator is Not Responding to ECM Commands

FAULT CODE 112

Engine Timing Actuator is Not Responding to ECM Commands

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 112 PID: FMI: LAMP: Shutdown SRT: | Engine Timing Actuator is Not Responding to ECM Commands. The error between the estimated timing fueling and the desired timing fueling is outside the allowable limits. | Calibration-dependent engine shutdown or no action is taken by ECM.
Fuel System Flow Schematic

Circuit Description

The ECM uses the timing pressure signal and engine speed to estimate the actual timing the engine is receiving and then constantly compares this value to the desired timing for the given speed and load. When the error in these values is too large for too long, Fault Code 112 is logged.

Component Location

The timing rail actuators are located at the left side toward the top of the ECVA.

Shop Talk

The estimated timing fueling and the desired timing fueling parameters can be monitored on the electronic service tool. This fault is a check on the ECM's control of the timing rail actuator and subsequent fuel flow. If the desired timing fueling can not be met by commanding more current to the actuator or if the desired timing fueling is being exceeded and can not be reduced by reducing the current to the actuator, Fault Code 112 is logged.

  • Fault Code 112 will not be triggered if Fault Code 116 or 117 is active
  • Once the run/stop switch is cycled, Fault Code 112 becomes inactive.

Follow the troubleshooting steps before replacing the actuator. This fault code is commonly caused by:

  • Air in the fuel system
  • External power source on harness wiring (battery charger)
  • Timing rail actuator malfunction.
Refer to Troubleshooting Fault Code t05-112

Last Modified: 03-Oct-2011


Timing Rail Actuator Circuit - Shorted High

FAULT CODE 113

Timing Rail Actuator Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 113 PID: FMI: LAMP: Warning SRT: | Engine timing actuator circuit - shorted high. Timing actuator circuit is open, or the timing rail actuator signal pin is shorted to ground, or the timing rail actuator return pin is shorted to battery. | No action by the ECM is taken. Actuator is open, closed, or partially closed. Engine power output will vary and white smoke can occur. Fault Code 112 can also be logged.
Timing Rail Actuator Circuit

Circuit Description

The timing rail actuator circuit supplies current to the timing rail actuator(s). The engine control module (ECM) commands a varying amount of current to the timing rail actuator to control the amount of timing pressure to the injectors.

Component Location

The timing rail actuators are located at the left side, toward top, of the ECVA.

Shop Talk

Confirm that the actuator connector is firmly in place. When there is power to the actuator(s), the actuator opens. This can cause Fault Code 112, timing flow mismatch.

Refer to Troubleshooting Fault Code t05-113

Last Modified: 29-Jul-2010


Engine Speed/Position Sensor Circuit - Lost Both of Two Signals From the Magnetic Pickup Sensor

FAULT CODE 115

Engine Speed/Position Sensor Circuit - Lost Both of Two Signals From the Magnetic Pickup Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: FMI: LAMP: Shutdown SRT: | No engine speed signal detected from the main and backup speed sensors. | Engine is shut down and can not be run.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual-coil circuit that provides the engine speed signal to the engine control module (ECM) through the engine harness.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If the problem occurs only at a certain engine temperature, be sure to check the engine speed sensor circuit while the engine is at that particular temperature. Check for correct air gap of engine speed sensor to flywheel tooth. Refer to Procedure 019-042 in Section 19. Some speed sensors can use a single Deutsch™ harness connector instead of the two Weather-Pack™ connectors.

Refer to Troubleshooting Fault Code t05-115.

Last Modified: 08-May-2012


Fuel Timing Rail Pressure Sensor Circuit - Shorted High

FAULT CODE 116

Fuel Timing Rail Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 116 PID: FMI: LAMP: Shutdown SRT: | Fuel timing pressure sensor circuit - shorted high. | Calibration-dependent engine shutdown occurs, or no action is taken by ECM.
Fuel Timing Rail Pressure Sensor Circuit

Circuit Description

The timing rail pressure sensor provides the timing rail pressure signal to the electronic control module (ECM), through the engine harness. The ECM uses the timing rail pressure signal to monitor the timing rail pressure going to the injector's timing chamber from the control valve body.

Component Location

The timing rail pressure sensor is located on the right-side, toward the top, of the ECVA, across from the timing rail actuators.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin call outs. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-116

Last Modified: 29-Jul-2010


Fuel Timing Rail Pressure Sensor Circuit - Shorted Low

FAULT CODE 117

Fuel Timing Rail Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 117 PID: FMI: LAMP: Shutdown SRT: | Fuel timing pressure sensor circuit - shorted low. | Calibration-dependent engine shutdown occurs, or no action is taken by ECM.
Fuel Timing Rail Pressure Sensor Circuit

Circuit Description

The timing rail pressure sensor provides the timing rail pressure signal to the electronic control module (ECM), through the engine harness. The ECM uses the timing rail pressure signal to monitor the timing rail pressure going to the injector's timing chamber from the control valve body.

Component Location

The timing rail pressure sensor is located on the right-side, toward the top, of the ECVA (toward top), across from the timing rail actuators.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-117

Last Modified: 29-Jul-2010


Fuel Pump Delivery Pressure Sensor Circuit - Shorted High

FAULT CODE 118

Fuel Pump Delivery Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 118 PID: FMI: LAMP: Warning SRT: | Fuel pump delivery pressure sensor circuit - shorted high. | No action is taken by the ECM. Possible loss of performance.
Fuel Pump Pressure Sensor Circuit

Circuit Description

The fuel pump pressure sensor provides the fuel pump pressure signal to the ECM, through the engine harness. The ECM uses the fuel pump pressure signal to monitor the fuel pump pressure going to the control valve body.

Component Location

The fuel pump pressure sensor is located on the fuel pumps just above the fuel pump actuator.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-118

Last Modified: 29-Jul-2010


Fuel Pump Delivery Pressure Sensor Circuit - Shorted Low

FAULT CODE 119

Fuel Pump Delivery Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 119 PID: FMI: LAMP: Warning SRT: | Fuel pump delivery pressure sensor circuit - shorted low. | No action is taken by the ECM. Possible loss of performance.
Fuel Pump Delivery Pressure Sensor Circuit

Circuit Description

The fuel pump pressure sensor provides the fuel pump pressure signal to the ECM, through the engine harness. The ECM uses the fuel pump pressure signal to monitor the fuel pump pressure going to the control valve body.

Component Location

The fuel pump pressure sensor is located on the fuel pump, just above the fuel pump actuator.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-119

Last Modified: 29-Jul-2010


Engine Speed/Position Sensor Circuit - Lost One of Two Signals From the Magnetic Pickup Sensor

FAULT CODE 121

Engine Speed/Position Sensor Circuit - Lost One of Two Signals From the Magnetic Pickup Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: FMI: LAMP: Warning SRT: | No engine speed signal detected from either the main or backup speed sensors. | No action by the ECM is taken. No effect on performance.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual coil circuit that provides the engine speed signal to the engine control module (ECM) through the engine harness.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

If the problem occurs only at a certain engine temperature, be sure to check the engine speed sensor circuit while the engine is at that particular temperature. Check for a correct air gap of engine speed sensor to flywheel tooth. Some speed sensors can use a single Deutsch™ harness connector instead of two Weather-Pack™ connectors.

Refer to Troubleshooting Fault Code t05-121.

Last Modified: 08-May-2012


Fuel Shutoff Valve 1 Circuit - Root Cause Not Known (Left Bank)

FAULT CODE 1211

Fuel Shutoff Valve 1 Circuit - Root Cause Not Known (Left Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1211 PID: FMI: LAMP: Shutdown SRT: | Fuel shutoff valve 1 circuit - root cause not known (left bank). | Engine will shut down.
Fuel Shutoff Valve Solenoid Circuit

Circuit Description

The fuel shutoff valve solenoid is a device used by the electronic control module (ECM) to control the engine fuel supply. The ECM can shut down the engine by cutting off the power to the fuel shutoff valve solenoid. This fault code can be caused by the signal shorted to low or ground, signal open, or return open.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Inspect the fuel shutoff supply circuit for external wires that are, perhaps, spliced in to power another device. Remove any extra wires that are found in the circuit. If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not failed and lowered the voltage on the fuel shutoff circuit. Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry conductive surface. Check the starter solenoid positive (+) terminal for a loose connector or accessory wiring with damaged insulation.

This diagnostic is enabled when the Run/Stop Switch is in the Run position and the engine is cranking. The fail mode must be corrected and the fault must be cleared and acknowledged before the engine will restart.

Refer to Troubleshooting Fault Code t05-1211

Last Modified: 29-Jul-2010


Fuel Shutoff Valve 2 Circuit - Root Cause Not Known (Right Bank)

FAULT CODE 1212

Fuel Shutoff Valve 2 Circuit - Root Cause Not Known (Right Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1212 PID: FMI: LAMP: Shutdown SRT: | Fuel shutoff valve 2 circuit - root cause not known (right bank). | Engine will shut down.
Fuel Shutoff Valve Solenoid Circuit

Circuit Description

The fuel shutoff valve solenoid is a device used by the electronic control module (ECM) to control the engine fuel supply. The ECM can shut down the engine by cutting off the power to the fuel shutoff valve solenoid. This fault code can be caused by the signal shorted to low or ground, signal open, or return open.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Inspect the fuel shutoff supply circuit for external wires that are, perhaps, spliced in to power another device. Remove any extra wires that are found in the circuit. If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not failed and lowered the voltage on the fuel shutoff circuit. Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry conductive surface. Check the starter solenoid positive (+) terminal for a loose connector or accessory wiring with damaged insulation.

The diagnostic is enabled when the Run/Stop Switch is in the Run position and the engine is cranking. The fail mode must be corrected and the fault must be cleared and acknowledged before the engine will restart.

Refer to Troubleshooting Fault Code t05-1212

Last Modified: 29-Jul-2010


Intake Manifold Pressure Sensor Circuit - Shorted High

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: FMI: LAMP: Warning SRT: | Intake manifold pressure sensor 1 circuit - shorted high. | No action is taken by the ECM. Possible loss of performance.
Intake Manifold Pressure Sensor 1 Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the electronic control module (ECM). High voltage will trip Fault Code 122 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Determine if the engine is being over fueled.

Confirm that the correct Intake Manifold Pressure Sensor part number is being used.

Confirm that the correct turbocharger is being used.

It is suspected that cold intake air can be the cause of the high intake manifold pressure, test the engine while feeding warm intake air. Inspect the intake manifold pressure sensor circuit for signs of tampering. Remove any extra wires from the circuit. Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-122

Last Modified: 29-Jul-2010


Intake Manifold Pressure Sensor 1 Circuit - Shorted Low

FAULT CODE 123

Intake Manifold Pressure Sensor 1 Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: FMI: LAMP: Warning SRT: | Intake manifold pressure sensor 1 circuit - shorted low. | No action is taken by the ECM. Possible loss of performance.
Intake Manifold Pressure Sensor 1 Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the electronic control module (ECM). Low voltage will trip Fault Code 123 and can be caused by shorts in the supply, signal, or return wires, an open in the supply or signal wires, low supply voltage from the ECM, or a failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Check for high restriction in the intake air manifold due to clogged air filters or a shutdown device in the manifold. Do not remove this device, if the engine is operated in a flammable atmosphere. The device is an essential safety feature.

Make sure the turbocharger is working correctly. Check for a positive intake manifold pressure.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-123

Last Modified: 29-Jul-2010


Intake Manifold Pressure Sensor 2 Circuit - Shorted High (Right Bank)

FAULT CODE 128

Intake Manifold Pressure Sensor 2 Circuit - Shorted High (Right Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 128 PID: FMI: LAMP: Warning SRT: | Intake manifold pressure sensor 2 circuit - shorted high (right bank). | No action is taken by the ECM. Possible loss of performance.
Intake Manifold Pressure Sensor 2 Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the electronic control module (ECM). High voltage will trip Fault Code 128 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Determine if the engine is being over fueled.

Confirm that the correct Intake Manifold Pressure Sensor part number is being used, and that the correct turbocharger is being used.

If it is suspected that cold intake air can be the cause of the high intake manifold pressure, test the engine while feeding it warm intake air.

Inspect the intake manifold pressure sensor circuit for signs of tampering. Remove any extra wires from the circuit.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-128

Last Modified: 29-Jul-2010


Intake Manifold Pressure Sensor 2 Circuit - Shorted Low

FAULT CODE 129

Intake Manifold Pressure Sensor 2 Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 129 PID: FMI: LAMP: Warning SRT: | Intake manifold pressure sensor 2 circuit - shorted low. | No action is taken by the ECM. Possible loss of performance.
Intake Manifold Pressure Sensor 2 Circuit

Circuit Description

The intake manifold pressure sensor monitors boost pressure and passes information to the electronic control module (ECM). Low voltage will trip Fault Code 129 and can be caused by shorts in the supply, signal, or return wires, an open in the supply or signal wires, low supply voltage from the ECM, or a failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Check for high restriction in the intake air manifold due to clogged air filters or a shutdown device in the manifold.

Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature.

Make sure the turbocharger is working correctly. Check for a positive intake manifold pressure.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-129

Last Modified: 29-Jul-2010


Customer - Defined Fault Code 1

FAULT CODE 1311

Customer - Defined Fault Code 1

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1311 PID: FMI: LAMP: Shutdown/Warning SRT: | Customer-defined Fault Code 1. | Trim dependent generator set will possibly not take any action, or it will possibly shut down.
Generator Set ECM Card Cage

Circuit Description

Component Location

Refer to Troubleshooting Fault Code t05-1311.

Last Modified: 08-May-2012


Customer - Defined Fault Code 2

FAULT CODE 1312

Customer - Defined Fault Code 2

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1312 PID: FMI: LAMP: Shutdown/Warning SRT: | Customer-defined Fault Code 2. | Trim dependent generator set will possibly not take any action, or it will possibly shut down.
Generator Set ECM Card Cage

Circuit Description

Component Location

Refer to Troubleshooting Fault Code t05-1312.

Last Modified: 08-May-2012


Customer - Defined LonWorks Fault Code 1

FAULT CODE 1313

Customer - Defined LonWorks Fault Code 1

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1313 PID: FMI: LAMP: Shutdown/Warning SRT: | Customer-defined LonWorks Fault Code 1. | Trim dependent generator set will possibly not take any action, or it will possibly shut down.
Generator Set ECM Card Cage

Circuit Description

Component Location

Refer to Troubleshooting Fault Code t05-1313.

Last Modified: 08-May-2012


Customer - Defined LonWorks Fault Code 2

FAULT CODE 1314

Customer - Defined LonWorks Fault Code 2

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1314 PID: FMI: LAMP: Shutdown/Warning SRT: | Customer-defined LonWorks Fault Code 2. | Trim dependent generator set will possibly not take any action, or it will possibly shut down.
Generator Set ECM Card Cage

Circuit Description

Component Location

Refer to Troubleshooting Fault Code t05-1314.

Last Modified: 08-May-2012


Customer - Defined LonWorks Fault Code 3

FAULT CODE 1315

Customer - Defined LonWorks Fault Code 3

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1315 PID: FMI: LAMP: Shutdown/Warning SRT: | Customer-defined LonWorks Fault Code 3. | Trim dependent generator set will possibly not take any action, or it will possibly shut down.
Generator Set ECM Card Cage

Circuit Description

Component Location

Refer to Troubleshooting Fault Code t05-1315.

Last Modified: 08-May-2012


Customer - Defined LonWorks Fault Code 4

FAULT CODE 1316

Customer - Defined LonWorks Fault Code 4

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1316 PID: FMI: LAMP: Shutdown/Warning SRT: | Customer-defined LonWorks Fault Code 4. | Trim dependent generator set will possibly not take any action, or it will possibly shut down.
Generator Set ECM Card Cage

Circuit Description

Component Location

Refer to Troubleshooting Fault Code t05-1316.

Last Modified: 08-May-2012


Customer - Defined Fault Code 3

FAULT CODE 1317

Customer - Defined Fault Code 3

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1317 PID: FMI: LAMP: Shutdown/Warning SRT: | Customer-defined Fault Code 3. | Trim dependent generator set will possibly not take any action, or it will possibly shut down.
Refer to Troubleshooting Fault Code t05-1317.

Last Modified: 08-May-2012


Customer - Defined Fault Code 4

FAULT CODE 1318

Customer - Defined Fault Code 4

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1318 PID: FMI: LAMP: Shutdown/Warning SRT: | Customer-defined Fault Code 4. | Trim dependent generator set will possibly not take any action, or it will possibly shut down.
Refer to Troubleshooting Fault Code t05-1318.

Last Modified: 08-May-2012


Alternator Temperature - Alternator Protection

FAULT CODE 1319

Alternator Temperature - Alternator Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1319 PID: FMI: LAMP: Warning SRT: | Alternator temperature has exceeded the warning threshold for high alternator temperature. | No action is taken by the ECM. Possible loss of generator performance.
Alternator Temperature Sensor Circuit

Circuit Description

The alternator temperature sensor is used by the electronic control module (ECM) for the generator set protection system. The ECM monitors the temperature of the alternator and informs the operator, via the warning lamp, that the alternator temperature has increased past the warning threshold for alternator temperature.The ECM monitors the voltage on the alternator temperature signal pin and expects to see a voltage vary between 0.5 and 4.5 VDC during normal engine operation.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

Make sure that the alternator is being properly cooled/ventilated.

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-1319

Last Modified: 29-Jul-2010


Common Warning Output Relay Driver Diagnostic

FAULT CODE 1321

Common Warning Output Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1321 PID: FMI: LAMP: Warning SRT: | Common warning output relay driver diagnostic has detected an error. | Any customer systems/features dependent on the common warning output will not function correctly. No action is taken by the ECM. No loss of performance.
Common Warning Output Relay Driver Circuit

Circuit Description

The engine control module (ECM) checks the common warning output relay driver to make certain it is operating correctly. The ECM uses the common warning output to inform if any customer systems/features are dependent on the ECM for knowledge for noncritical fault with the generator set.

The ECM monitors the voltage (no voltage increase will trip Fault Code 1321) and can be caused by shorts, opens, or a failed common warning output relay driver in the ECM.

Component Location

Refer to the customer/facility/installation/documentation for the location of the common relay warning output.

Shop Talk

The possible failure modes are open circuit, short to ground, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1321.

Last Modified: 08-May-2012


Analog Input Signal Circuit for Load Govern Kilowatt Setpoint - Voltage Above Normal or Shorted to High Source

FAULT CODE 1322

Analog Input Signal Circuit for Load Govern Kilowatt Setpoint - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1322 PID: FMI: LAMP: Warning SRT: | The analog input signal for the load governed Kilowatt set point is shorted high. | No effect on performance.
Load Govern Kilowatt Set Point - Remote Input Device Circuit

Circuit Description

The load govern kilowatt set point analog input signal is an external input into the engine control module used to control and vary the alternator kilowatt output while the generator set is parallel to the utility. The load govern kilowatt set point analog input signal is sent to the engine control module from the remote input device.

The engine control module monitors the voltage on the load govern kilowatt set point analog input SIGNAL pin and expects to see a voltage vary between 0.5 and 4.5-VDC during normal engine operation.

High voltage will trip Fault Code 1322 and can be caused by shorts in the SIGNAL wire or a failed input device.

Component Location

Reference Section E for location of the engine control module card cage.

Reference the customer/facility/installation documentation for the location of the remote input device.

Shop Talk

The possible failure modes are open circuit, short to battery positive (+), and failed input device.

Verify that normal operating range of input device is 0.1 to 5.0-VDC.

Make sure shields and grounds are good.

The remote input device must be set up to provide a 0 to 5-VDC signal. If this device is set up to provide a 0 to 24-VDC signal, the load govern range checking set point must be disabled using INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code t05-1322.

Last Modified: 08-May-2012


Analog Input Signal Circuit for Load Govern Kilowatt Setpoint - Voltage Above Normal or Shorted to Low Source

FAULT CODE 1323

Analog Input Signal Circuit for Load Govern Kilowatt Setpoint - Voltage Above Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1323 PID: FMI: LAMP: Warning SRT: | The analog input signal for the load governed Kilowatt set point is shorted low. | No effect in performance.
Load Govern Kilowatt Setpoint - Remote Input Device Circuit

Circuit Description

The load govern kilowatt setpoint analog input signal is an external input into the engine control module used for load governing of the engine/generator set. The load govern kilowatt setpoint analog input signal is sent to the engine control module from the remote input device.

The engine control module monitors the voltage on the load govern kilowatt setpoint analog input SIGNAL pin and expects to see a voltage vary between 0.5 and 4.5-VDC during normal engine operation. This fault can trip, however, even if the generator set is not paralleled.

Low voltage will trip Fault Code 1323 and can be caused by shorts in the SIGNAL wire, an open in the signal, or a failed input device.

Component Location

Reference Section E for location of the engine control module card cage.

Reference the customer/facility/installation documentation for the location of the remote input device.

Shop Talk

The possible failure modes are open circuit, short to ground, and failed input device.

Check input voltage with the electronic service tool.

The remote input device must be set up to provide a 0 to 5-VDC signal. If this device is set up to provide a 0 to 24-VDC signal, you must disable the load govern range checking setpoint using the electronic service tool.

Refer to Troubleshooting Fault Code t05-1323.

Last Modified: 08-May-2012


Analog Input Signal Circuit for Load Govern kVAR Setpoint -Voltage Above Normal or Shorted to High Source

FAULT CODE 1324

Analog Input Signal Circuit for Load Govern kVAR Setpoint -Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1324 PID: FMI: LAMP: Warning SRT: | The analog input signal for the load governed kilovolt-ampere setpoint is shorted high. | No action is taken by the engine control module. Possible loss of performance.
Load Govern Kilovolt-Ampere Setpoint - Remote Input Device Circuit

Circuit Description

The load govern kilovolt-ampere setpoint analog input signal is an external input into the engine control module used to control and vary the kilovolt-ampere output of the alternator while the generator set is paralleled to the utility. The load govern kilovolt-ampere setpoint analog input signal is sent to the engine control module from a remote device, usually a PLC that is monitoring another source to determine the amount of power to be provided by the generator.

The engine control module monitors the voltage on the load govern kilovolt-ampere setpoint analog input signal pin and expects to see a voltage vary between 0.5 and 4.5-VDC during normal engine operation.

High voltage will trip Fault Code 1324 and can be caused by shorts in the signal wire or a failed input device.

Component Location

Reference Section E for location of the engine control module card cage.

Reference the customer/facility/installation documentation for the location of the remote input device.

Shop Talk

The possible failure modes are open circuit, short to battery positive (+), and failed input device.

Make sure shields and grounds are good.

Check input voltage using INSITE™ electronic service tool.

Can reduce kilovolt-amperes to zero and run the unit at a unity PF.

Refer to Troubleshooting Fault Code t05-1324.

Last Modified: 08-May-2012


Analog Input Signal Circuit for Load Govern kVAR Setpoint - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1325

Analog Input Signal Circuit for Load Govern kVAR Setpoint - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1325 PID: FMI: LAMP: Warning SRT: | The analog input signal for the load governed kilovolt-ampere setpoint is shorted low. | No action is taken by the engine control module. Possible loss of performance.
Load Govern Kilovolt-Ampere Setpoint - Remote Input Device Circuit

Circuit Description

The load govern kilovolt-ampere setpoint analog input signal is an external input into the engine control module used for load governing of the engine/generator set. The load govern kilovolt-ampere setpoint analog input signal is sent to the engine control module from the remote input device.

The engine control module monitors the voltage on the load govern kilovolt-ampere setpoint analog input SIGNAL pin and expects to see a voltage vary between 0.5 and 4.5-VDC during normal engine operation.

Low voltage will trip Fault Code 1325 and can be caused by shorts in the signal wire, an open in the signal, or a malfunctioned input device.

Component Location

Reference Section E for location of the engine control module card cage.

Reference the customer/facility/installation documentation for the location of the remote input device.

Shop Talk

The possible failure modes are open circuit, short to ground, and failed input device.

Make sure shields and grounds are good.

Check input signal with INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code t05-1325.

Last Modified: 08-May-2012


Starter Backup Disconnect

FAULT CODE 1326

Starter Backup Disconnect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1326 PID: FMI: LAMP: Warning SRT: | The starter backup disconnect has failed. | No action is taken by the ECM. Possible damage can occur to the starter.
Starter Circuit

Circuit Description

The generator set starter has two disconnects: The starter main disconnect and a backup. This fault code is used by the ECM to inform the operator that the backup starter disconnect has failed, engine speed is above 950 rpm, and backup start disconnect is still connected. Therefore, if the main starter disconnect fails, damage can possibly occur to the starter.

Component Location

Refer to Section E for location of the starter backup disconnect

Shop Talk

Where the main starter disconnect gets commanded by the engine speed sensor, the backup starter disconnect gets commanded by the PMG excitation voltage sent to the voltage regulator. This excitation voltage occurs once the engine has started and the alternator rotor is turning. The backup starter disconnect activates once the PMG voltage is 105 VAC or higher.

The possible failure modes are open circuit, short to ground, and failed voltage regulator.

Refer to Troubleshooting Fault Code t05-1326

Last Modified: 29-Jul-2010


Load Governed Kilowatt Setpoint - Analog Input Signal Circuit

FAULT CODE 1327

Load Governed Kilowatt Setpoint - Analog Input Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1327 PID: FMI: LAMP: Shutdown SRT: | The analog input signal for the load governed kilowatt setpoint is outside the acceptable working limits. | Generator set will shut down.
Load Govern Kilowatt Setpoint - Paralleling Controller Circuit

Circuit Description

The load govern kilowatt setpoint analog input signal is an external input into the engine control module used for load governing of the engine/generator set. The load govern kilowatt setpoint analog input signal is sent to the engine control module from the paralleling controller.

The engine control module monitors the voltage on the load govern kilowatt setpoint analog input signal pin and expects to see a voltage vary between 0.5 and 4.5-VDC during normal engine operation.

Low voltage will trip Fault Code 1327 and can be caused by shorts in the signal wire, an open in the signal, a failed input device, or an improper setup.

Component Location

Refer to Section E for location of the engine control module card cage.

Refer to customer/facility/installation documentation for the location of the paralleling controller.

Shop Talk

The possible failure modes are open circuit, short to ground, and failed input device.

If analog input signal source is not set up to provide a 0 to 5-VDC signal, you must disable load govern kilowatt setpoint range checking enable using INSITE™ electronic service tool.

Load Govern Operating Load Level
VDC | Operating Load Level
0 to 0.5 | Ramp from present load to no load
0.5 to 1.0 | No load
1.0 to 4.5 | 0 to 100% of standby rating
4.5 to 5.0 | 100% of standby rating
Refer to Troubleshooting Fault Code t05-1327.

Last Modified: 08-May-2012


Generator Set Circuit Breaker

FAULT CODE 1328

Generator Set Circuit Breaker

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1328 PID: FMI: LAMP: Warning SRT: | The generator set circuit breaker has tripped. | Load dump will occur. Generator set continues to run.
Generator Set Circuit Breaker Circuit

Circuit Description

The generator set circuit breaker is the switch for the generator set's connection to the bus. The circuit breaker opens when events have occurred, which forces the generator set to no longer be connected to the bus. The circuit breaker closes when the generator set is to be connected to the bus.

This fault code is used by the ECM to tell the operator that, due to an event, the generator set is to be disconnected from the bus.

Component Location

Refer to Section E for location of the ECM card cage.

Refer to customer/facility/installation documentation for the location of the generator set circuit breaker.

Shop Talk

The possible failure modes are short circuit, open circuit, and failed generator set circuit breaker.

The circuit breaker is an overcurrent protection device.

In paralleling, the generator set circuit breaker acts as a switch to autoconnect generator set to system bus and other generator sets.

Refer to Troubleshooting Fault Code t05-1328

Last Modified: 29-Jul-2010


Voltage Regulator

FAULT CODE 1329

Voltage Regulator

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1329 PID: FMI: LAMP: Warning SRT: | The voltage regulator has lost its DC power supply. | The voltage regulator will not be able to regulate generator set output voltage. Possible low AC voltage (Fault Code 1447) condition can occur.
Voltage Regulator Circuit

Circuit Description

The ECM uses this fault code to inform the operator that the base board can not drive DC power to the voltage regulator.

Component Location

Refer to Section E for location of the voltage regulator.

Shop Talk

The possible failure modes are open circuit, short circuit, short to ground, internal shorts to the voltage regulator or base board, or bad diode.

Refer to Troubleshooting Fault Code t05-1329

Last Modified: 29-Jul-2010


Voltage Regulator Driver Diagnostic

FAULT CODE 1331

Voltage Regulator Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1331 PID: FMI: LAMP: Shutdown SRT: | The voltage regulator driver diagnostic has detected a short circuit condition. | Generator set will shut down.
Voltage Regulator Driver Circuit

Circuit Description

The ECM checks the voltage regulator driver to make certain it is operating correctly. The ECM uses fault code to inform the operator that the ECM is no longer driving the voltage regulator.

The ECM monitors the voltage (no voltage will trip Fault Code 1331) and can be caused by short circuits, failed voltage regulator, or a voltage regulator driver in the ECM.

Component Location

Refer to Section E for location of the voltage regulator.

Shop Talk

The possible failure modes are short circuit, short to ground, and loss of voltage inside the ECM.

The voltage regulator pulse width modulated circuit is either shorted high or low. The voltage regulator pulse width modulated driver is shorted itself or is driving into a shorted circuit.

The voltage regulator driver is on the base board. If the driver itself is bad, the base board must be replaced.

Refer to Troubleshooting Fault Code t05-1331

Last Modified: 29-Jul-2010


Off/Manual/Auto Switch Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1332

Off/Manual/Auto Switch Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1332 PID: FMI: LAMP: Warning SRT: | The Off/Manual/Auto switch signal is shorted low. | The ECM will only allow the generator set to run in Auto.
Off/Manual/Auto Switch Circuit

Circuit Description

The Off/Manual/Auto switch is monitored by the engine control module (ECM) to determine the operation mode of the generator set.

The ECM monitors the voltage on the operation mode switch manual SIGNAL pin and expects to see a voltage vary between 0.5 and 4.5-VDC during normal operation. The ECM monitors the voltage on the operation mode switch auto SIGNAL pin and expects to see a voltage of either 0 or 5-VDC during normal operation. Low voltage will trip Fault Code 1332 and can be caused by shorts in the signal, or return wires, an open in the return wire, or a failed switch.

Component Location

Reference Section E for location of the operator interface panel and the Off/Manual/Auto switch.

Shop Talk

The possible failure modes are open circuit, short to ground, failed switch, and loss of supply voltage inside the ECM.

The ECM will consider the switch to be in the Auto position when the auto SIGNAL pin is grounded, regardless of the state of the manual SIGNAL pin.

Refer to Troubleshooting Fault Code t05-1332.

Last Modified: 08-May-2012


Off/Manual/Auto Switch Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1333

Off/Manual/Auto Switch Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1333 PID: FMI: LAMP: Warning SRT: | The Off/Manual/Auto switch signal is shorted high. | The ECM will default to an Off value when switch is in Manual. Auto and Off positions will function normally.
Off/Manual/Auto Switch Circuit

Circuit Description

The Off/Manual/Auto switch is monitored by the engine control module (ECM) to determine the operation mode of the generator set.

The ECM monitors the voltage on the operation mode switch manual SIGNAL pin and expects to see a voltage vary between 0.5 and 4.5-VDC during normal operation. The ECM monitors the voltage on the operation mode switch auto SIGNAL pin and expects to see a voltage of either 0 or 5-VDC during normal operation. High voltage will trip Fault Code 1333 and can be caused by shorts in the signal, or return wires, an open in the return wire, or a failed switch.

Component Location

Reference Section E for location of the operator interface panel and the Off/Manual/Auto switch.

Shop Talk

The possible failure modes are open circuit, short to battery positive (+), failed switch, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1333.

Last Modified: 08-May-2012


Critical Scalar Out-of-Range

FAULT CODE 1334

Critical Scalar Out-of-Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1334 PID: FMI: LAMP: Shutdown SRT: | One or more trims have been set so that a critical scalar in out-of-range. | No alternator protection. Possible loss of performance.
Refer to Troubleshooting Fault Code t05-1334

Last Modified: 29-Jul-2010


Non-Critical Scalar Out-of-Range

FAULT CODE 1335

Non-Critical Scalar Out-of-Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1335 PID: FMI: LAMP: Warning SRT: | One or more trims have been set so that a non-critical scalar in out-of-range. | No alternator protection. Possible loss of performance.
Refer to Troubleshooting Fault Code t05-1335.

Last Modified: 08-May-2012


Generator Set Shutdown

FAULT CODE 1336

Generator Set Shutdown

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1336 PID: FMI: LAMP: Shutdown SRT: | Engine shutdown. | The generator set will shutdown.
Refer to Troubleshooting Fault Code t05-1336

Last Modified: 29-Jul-2010


LonWorks Wink Command Event

FAULT CODE 1337

LonWorks Wink Command Event

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1337 FMI: LAMP: None SRT: | LonWorks wink event has been commanded. | No corrective action taken with this fault code.
Refer to Troubleshooting Fault Code t05-1337

Last Modified: 29-Jul-2010


LonWorks Network Commanded Shutdown

FAULT CODE 1341

LonWorks Network Commanded Shutdown

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1341 FMI: LAMP: None SRT: | The paralleling controller has requested a generator shutdown. | The generator will shutdown.
Refer to Troubleshooting Fault Code t05-1341

Last Modified: 29-Jul-2010


Fuel System Board - Incorrect Installation

FAULT CODE 1342

Fuel System Board - Incorrect Installation

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1342 PID: FMI: LAMP: Shutdown SRT: | The fuel system board (slot 0) is missing or has not been installed correctly. | Engine will not start.
Generator Set ECM Fuel Board

Circuit Description

Once the software has been loaded into the ECM, the software will do a hardware check to make sure that all necessary cards are installed for the application.

This fault code is used by the ECM to tell the operator that the fuel system board (slot 0) is missing or has been installed incorrectly.

Component Location

Refer to Section E for location of the ECM card cage and the fuel system board (slot 0).

Shop Talk

The possible failure modes are incorrect installation of the fuel system board and loading an incorrect software calibration into the ECM.

Refer to Troubleshooting Fault Code t05-1342

Last Modified: 29-Jul-2010


Base Board - Incorrect Installation

FAULT CODE 1343

Base Board - Incorrect Installation

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1343 PID: FMI: LAMP: Shutdown SRT: | The base board (slot 1) is missing or has not been installed correctly. | Engine will not start.
Generator Set ECM Base Board

Circuit Description

Once the software has been loaded into the ECM, the software will do a hardware check to make sure that all necessary cards are installed for the application.

This fault code is used by the ECM to tell the operator that the base board (slot 1) is missing or has been installed incorrectly.

Component Location

Refer to Section E for location of the ECM card cage and the base board (slot 1).

Shop Talk

The possible failure modes are incorrect installation of the base board and loading an incorrect software calibration into the ECM.

Refer to Troubleshooting Fault Code t05-1343

Last Modified: 29-Jul-2010


Generator Interface Board - Incorrect Installation

FAULT CODE 1344

Generator Interface Board - Incorrect Installation

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1344 PID: FMI: LAMP: Shutdown SRT: | The generator interface board(slot 2) is missing or has notbeen installed correctly. | Engine will not start.
Generator Set ECM Generator Interface Board

Circuit Description

Once the software has been loaded into the ECM, the software will do a hardware check to make sure that all necessary cards are installed for the application.

This fault code is used by the ECM to tell the operator that the generator interface board (slot 2) is missing or has been installed incorrectly.

Component Location

Refer to Section E for location of the ECM card cage and the generator interface board (slot 2).

Shop Talk

The possible failure modes are incorrect installation of the generator interface board and loading an incorrect software calibration into the ECM.

Refer to Troubleshooting Fault Code t05-1344

Last Modified: 29-Jul-2010


Paralleling Board - Incorrect Installation

FAULT CODE 1345

Paralleling Board - Incorrect Installation

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1345 PID: FMI: LAMP: Shutdown SRT: | The paralleling board (slot 3) is missing or has not been installed correctly. | Engine will not start.
Generator Set ECM Paralleling Board

Circuit Description

Once the software has been loaded into the ECM, the software will do a hardware check to make sure that all necessary cards are installed for the application.

This fault code is used by the ECM to tell the operator that the paralleling board (slot 3) is missing or has been installed incorrectly.

Component Location

Refer to Section E for location of the ECM card cage and the paralleling board (slot 3).

Shop Talk

The possible failure modes are incorrect installation of the paralleling board and loading an incorrect software calibration into the ECM.

Refer to Troubleshooting Fault Code t05-1345

Last Modified: 29-Jul-2010


LonWorks Network Board - Incorrect Installation

FAULT CODE 1346

LonWorks Network Board - Incorrect Installation

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1346 PID: FMI: LAMP: Shutdown SRT: | The LonWorks Network board (slot 4) is missing or has not been installed correctly. | Engine will not start.
Generator Set ECM LonWorks Board

Circuit Description

Once the software has been loaded into the ECM, the software will do a hardware check to make sure that all necessary cards are installed for the application.

This fault code is used by the ECM to tell the operator that the LonWorks Network board (slot 4) is missing or has been installed incorrectly.

Component Location

Refer to Section E for location of the ECM card cage and the LonWorks Network board (slot 4).

Shop Talk

The possible failure modes are incorrect installation of the LonWorks Network board and loading an incorrect software calibration into the ECM.

Refer to Troubleshooting Fault Code t05-1346

Last Modified: 29-Jul-2010


Slot 5 Board - Incorrect Installation

FAULT CODE 1347

Slot 5 Board - Incorrect Installation

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1347 PID: FMI: LAMP: Shutdown SRT: | The slot 5 board is missing or has not been installed correctly. | Engine will not start.
Generator Set ECM Card Cage

Circuit Description

Once the software has been loaded into the ECM, the software will do a hardware check to make sure that all necessary cards are installed for the application.

This fault code is used by the ECM to tell the operator that the slot 5 board is missing or has been installed incorrectly.

Component Location

Refer to Section E for location of the ECM card cage and the slot 5 board.

Shop Talk

The possible failure modes are incorrect installation of the slot 5 board and loading an incorrect software calibration into the ECM.

Refer to Troubleshooting Fault Code t05-1347

Last Modified: 29-Jul-2010


Slot 6 Board - Incorrect Installation

FAULT CODE 1348

Slot 6 Board - Incorrect Installation

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1348 PID: FMI: LAMP: Shutdown SRT: | The slot 6 board is missing or has not been installed correctly. | Engine will not start.
Generator Set ECM Card Cage

Circuit Description

Once the software has been loaded into the ECM, the software will do a hardware check to make sure that all necessary cards are installed for the application.

This fault code is used by the ECM to tell the operator that the slot 6 board is missing or has been installed incorrectly.

Component Location

Refer to Section E for location of the ECM card cage and the slot 6 board.

Shop Talk

The possible failure modes are incorrect installation of the slot 6 board and loading an incorrect software calibration into the ECM.

Refer to Troubleshooting Fault Code t05-1348

Last Modified: 29-Jul-2010


Slot 7 Board - Incorrect Installation

FAULT CODE 1349

Slot 7 Board - Incorrect Installation

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1349 PID: FMI: LAMP: Shutdown SRT: | The slot 7 board is missing or has not been installed correctly. | Engine will not start.
Generator Set ECM Card Cage

Circuit Description

Once the software has been loaded into the ECM, the software will do a hardware check to make sure that all necessary cards are installed for the application.

This fault code is used by the ECM to tell the operator that the slot 7 board is missing or has been installed incorrectly.

Component Location

Refer to Section E for location of the ECM card cage and the slot 7 board.

Shop Talk

The possible failure modes are incorrect installation of the slot 7 board and loading an incorrect software calibration into the ECM.

Refer to Troubleshooting Fault Code t05-1349

Last Modified: 29-Jul-2010


Engine Oil Pressure Sensor Circuit - Shorted High

FAULT CODE 135

Engine Oil Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: FMI: LAMP: Warning SRT: | Engine oil pressure sensor is shorted high - shorted high. | No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor monitors oil pressure and passes information to the electronic control module (ECM). The ECM monitors the voltage on the oil pressure signal pin and expects to see the voltage vary between 0.46 and 4.56 VDC during normal engine operation. High voltage will trip Fault Code 135 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Does the fault code occur only in cold weather? If so, allow the oil to warm up and see if the fault code goes inactive.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-135

Last Modified: 29-Jul-2010


LonWorks Network Board - Missing

FAULT CODE 1351

LonWorks Network Board - Missing

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1351 PID: FMI: LAMP: Shutdown SRT: | The LonWorks Network board is missing. | The generator set will not be able to communicate with other devices on the LonWorks Network.
Generator Set ECM LonWorks Network Board

Circuit Description

Once the software has been loaded into the ECM, the software will do a hardware check to make sure that all necessary cards are installed for the application.

This fault code is used by the ECM to tell the operator that the LonWorks Network board (slot 4) is missing.

Component Location

Refer to Section E for location of the ECM card cage and the LonWorks Network board (slot 4).

Shop Talk

The possible failure mode is that the LonWorks Network board has lost its independent power supply.

Refer to Troubleshooting Fault Code t05-1351

Last Modified: 29-Jul-2010


Engine Oil Pressure Sensor Circuit - Shorted Low

FAULT CODE 141

Engine Oil Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: FMI: LAMP: Warning SRT: | Engine oil pressure sensor circuit - shorted low. | No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor monitors oil pressure and passes information to the electronic control module (ECM). The ECM monitors the voltage on the oil pressure signal pin and expects to see the voltage vary between 0.46 and 4.56 VDC during normal engine operation. Low voltage will trip Fault Code 141 and can be caused by shorts in the supply, signal, or return wires, an open in the supply or signal wires, low supply voltage from the ECM, or a failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

If Fault Code 143 or 415 is not present, the problem is not base engine related.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-141

Last Modified: 29-Jul-2010


Frequency Adjust Potentiometer Circuit

FAULT CODE 1411

Frequency Adjust Potentiometer Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1411 PID: FMI: LAMP: Warning SRT: | Frequency adjust potentiometer signal is shorted high. | The frequency adjustment feature will be disabled and a default value of zero will be used. Possible loss of performance.
Frequency Adjust Potentiometer Circuit

Circuit Description

The frequency adjust potentiometer is so the operator can adjust the breakpoint frequency for the 100-percent 0.8 power factor load acceptance. This is the frequency at which the generator set output voltage starts to drop. The ECM monitors the voltage and expects to see the voltage vary between 0.5 and 4.5 VDC during normal operation. High voltage will trip Fault Code 1411 and can be caused by shorts in the signal wire, an open in the return wire, or a failed potentiometer.

Component Location

Refer to the OEM manual for location.

Shop Talk

Potentiometers are very sensitive to the environment. Clean the potentiometer and check its resistance first.

Refer to Troubleshooting Fault Code t05-1411

Last Modified: 29-Jul-2010


Droop Adjust Potentiometer Circuit

FAULT CODE 1412

Droop Adjust Potentiometer Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1412 PID: FMI: LAMP: Warning SRT: | Droop adjust potentiometer signal is shorted high. | The droop adjustment feature will be disabled and a default value of zero will be used. Possible loss of performance.
Droop Adjust Potentiometer Circuit

Circuit Description

The droop adjust potentiometer is so the operator can adjust the amount of cross-current compensation the voltage regulator produces when paralleling. The ECM monitors the voltage and expects to see the voltage vary between 0.5 and 4.5 VDC during normal operation. High voltage will trip Fault Code 1412 and can be caused by shorts in the signal wire, an open in the return wire, or a failed potentiometer.

Component Location

Refer to the OEM manual for location.

Shop Talk

Potentiometers are very sensitive to the environment. Clean the potentiometer and check its resistance first.

Refer to Troubleshooting Fault Code t05-1412

Last Modified: 29-Jul-2010


Configuration Error

FAULT CODE 1413

Configuration Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1413 PID: FMI: LAMP: Shutdown SRT: | Configuration error has been detected. | Engine will not start.
GCS ECM

Circuit Description

The ECM checks to see what other components are installed at power-up, and if the list of installed components does not match the calibration, then the ECM will trip Fault Code 1413, Configuration Error.

Component Location

Refer to the OEM manual for location of the ECM.

Shop Talk

Verify that the correct calibration is loaded in the ECM. If it continues replace the ECM.

Refer to Troubleshooting Fault Code t05-1413

Last Modified: 29-Jul-2010


Run Relay Contact Diagnostic

FAULT CODE 1414

Run Relay Contact Diagnostic

Printable Version Printable Version

Overview

Run Relay Contact Diagnostic

CODE | REASON | EFFECT
Fault Code: 1414 PID: FMI: LAMP: Warning SRT: | Run relay contact diagnostic has detected an error. | The ECM will not be able to enter Run mode.
Run Relay Contact Circuit

Circuit Description

The ECM checks the run relay contact to make certain it is operating correctly. The ECM uses the contacts to determine that the engine is now in the Run mode. The ECM monitors the feedback from the status line to give the position of the run relay contact.

Component Location

Refer to Section E for the location of the run relay contact and the ECM.

Shop Talk

The possible modes are open circuit, short to ground, bad run contact, and loss of supply voltage inside the ECM. When the Manual Run/Stop button is in the Run mode, if there is 24 VDC present at the Inline F switched B+ pin, then the circuit is working properly.

Refer to Troubleshooting Fault Code t05-1414

Last Modified: 29-Jul-2010


Run Relay Driver Diagnostic

FAULT CODE 1415

Run Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1415 FMI: LAMP: Warning SRT: | Run relay driver has detected an error. | The ECM will not enter run mode.
Refer to Troubleshooting Fault Code t05-1415

Last Modified: 29-Jul-2010


Failed to Shut Down

FAULT CODE 1416

Failed to Shut Down

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1416 PID: SPN: FMI: LAMP: Warning SRT: | Fail to shut down. | The operator has enabled the user-engaged engine shutdown override feature. No engine protection features are working.
ECM

Circuit Description

Not applicable

Component Location

Not applicable

Refer to Troubleshooting Fault Code t05-1416

Last Modified: 29-Jul-2010


Controller Power Down Fault

FAULT CODE 1417

Controller Power Down Fault

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1417 PID: FMI: LAMP: Warning SRT: | A controller power-down error has been detected. | The ECM can not power down because of some unknown condition. Possible drain on battery.
GCS ECM

Circuit Description

The ECM checks during the power-down sequences to see if power is being shut off. If the power line is still hot, it checks for a reason for not shutting down. If no reason exists, then there must be a problem with the module that is not allowing it to power down.

Component Location

Refer to the OEM manual for location of the ECM.

Shop Talk

This fault indicates a hardware failure in the ECM.

Refer to Troubleshooting Fault Code t05-1417

Last Modified: 29-Jul-2010


Gain Adjust Potentiometer Circuit

FAULT CODE 1418

Gain Adjust Potentiometer Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1418 PID: FMI: LAMP: Warning SRT: | Gain adjust potentiometer signal is shorted high. | The gain adjustment feature will be disabled, and a default value of zero will be used. Possible loss of performance.
Gain Adjust Potentiometer Circuit

Circuit Description

The gain adjust potentiometer is so the operator can adjust the amplification of the difference in the value between the “desired speed” and the “actual speed” of the engine, so that the governor can respond to engine speed fluctuations. The difference between the “desired speed” and the “actual speed” is called the error signal. When the gain is increased, the error signal amplification is increased, more corrective action is taken by the governor, and its response is quicker. When the gain is reduced, the error signal amplification is reduced, less corrective action is taken by the governor, and its response is slower. If the gain is set too high, the governor can overcorrect the speed error signal, which will lead to engine speed surging or “hunting.” The ECM monitors the voltage and expects to see the voltage vary between 0.5 and 4.5 volts during normal operation. High voltage will trip Fault Code 1418 and can be caused by shorts in the signal wire, an open in the return wire, or a failed potentiometer.

Component Location

Refer to the OEM manual for location.

Shop Talk

Potentiometers are very sensitive to the environment. Clean the potentiometer, and check its resistance first.

Refer to Troubleshooting Fault Code t05-1418

Last Modified: 29-Jul-2010


Fuel Rail Driver Diagnostic

FAULT CODE 1419

Fuel Rail Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1419 PID: FMI: LAMP: Warning SRT: | Fuel rail driver diagnostic has detected an error. | No action is taken by the ECM. Possible loss of performance.
Fuel Rail Actuator Circuit

Circuit Description

The ECM checks the fuel rail actuator drivers to sustain correct operation. The fuel rail actuators are actuated by the electronic control module (ECM) to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering. The ECM monitors the voltage, no voltage will trip Fault Code 1419, and can be caused by shorts, opens, or a failed fuel rail actuator driver in the ECM.

Component Location

The fuel rail drivers are contained in the ECM.

Shop Talk

The possible failure modes are open circuit, short to ground, high actuator resistance, and loss of boost voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1419

Last Modified: 29-Jul-2010


Timing Rail Number 1 Driver Diagnostic

FAULT CODE 1421

Timing Rail Number 1 Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1421 PID: FMI: LAMP: Warning SRT: | Timing rail Number 1 driver diagnostic has detected an error. | No action is taken by the ECM. Possible loss of performance.
Timing Rail Number 1 Actuator Circuit

Circuit Description

The ECM checks the timing rail Number 1 actuator driver to sustain correct operation. The timing rail Number 1 actuator is actuated by the electronic control module (ECM) to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering. The ECM monitors the voltage, no voltage will trip Fault Code 1421, and can be caused by shorts, opens, or a failed fuel pump actuator driver in the ECM.

Component Location

The timing rail Number 1 driver is located in the ECM.

Shop Talk

The possible failure modes are open circuit, short to ground, high actuator resistance, and loss of boost voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1421

Last Modified: 29-Jul-2010


Timing Rail Number 2 Driver Diagnostic

FAULT CODE 1422

Timing Rail Number 2 Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1422 PID: FMI: LAMP: Warning SRT: | Timing rail Number 2 driver diagnostic has detected an error. | No action is taken by the ECM. Possible loss of performance.
Timing Rail Number 2 Actuator Circuit

Circuit Description

The ECM checks the timing rail Number 2 actuator driver to sustain correct operation. The timing rail Number 2 actuator is actuated by the electronic control module (ECM) to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering. The ECM monitors the voltage, no voltage will trip Fault Code 1422, and can be caused by shorts, opens, or a failed fuel pump actuator driver in the ECM.

Component Location

The timing rail Number 2 driver is located in the ECM.

Shop Talk

The possible failure modes are open circuit, short to ground, high actuator resistance, and loss of boost voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1422

Last Modified: 29-Jul-2010


Fuel Pump Driver Diagnostic

FAULT CODE 1423

Fuel Pump Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1423 PID: FMI: LAMP: Warning SRT: | Fuel pump driver diagnostic has detected an error. | No action is taken by the ECM. Possible loss of performance.
Fuel Pump Actuator Circuit

Circuit Description

The ECM checks the fuel pump actuator driver to sustain correct operation. The fuel pump actuator is actuated by the electronic control module (ECM) to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering. The ECM monitors the voltage, no voltage will trip Fault Code 1423, and can be caused by shorts, opens, or a failed fuel pump actuator driver in the ECM.

Component Location

The fuel pump driver is located in the ECM.

Shop Talk

The possible failure modes are open circuit, short to ground, high actuator resistance, and loss of boost voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1423

Last Modified: 29-Jul-2010


Relay High Side Driver Diagnostic

FAULT CODE 1424

Relay High Side Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1424 PID: FMI: LAMP: Warning SRT: | Relay high side driver diagnostic has detected an error. | The user interface relay drivers will not function correctly. No action is taken by the ECM. No loss of performance.
Relay High Side Driver Circuit

Circuit Description

The relay driver supply pin supplies power for all of the user interface relay drivers. The ECM monitors the voltage, no voltage/low voltage will trip Fault Code 1424, and can be caused by shorts, opens, or a failed driver in the ECM.

Component Location

Refer to the OEM manual for location of the ECM. Refer to the OEM manual for location of the user interface panel.

Shop Talk

The possible failure modes are open circuit, short to ground, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1424

Last Modified: 29-Jul-2010


Common Shutdown Relay Driver Diagnostic

FAULT CODE 1425

Common Shutdown Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1425 PID: FMI: LAMP: Warning SRT: | Common shutdown relay driver diagnostic has detected an error. | The common shutdown relay will not function correctly. No action is taken by the ECM. No loss of performance.
Common Shutdown Relay Driver Circuit

Circuit Description

The ECM checks the common shutdown relay driver to sustain correct operation. The ECM uses the common shutdown relay to inform the operator of a noncritical fault. The ECM monitors the voltage, no voltage drop will trip Fault Code 1425, and can be caused by shorts, opens, bad relays, or a failed common shutdown relay driver in the ECM.

Component Location

Refer to the OEM manual for location of the ECM. Refer to the OEM manual for location of the user interface panel and the common shutdown relay.

Shop Talk

The possible failure modes are open circuit, short to ground, burned-out relay, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1425

Last Modified: 29-Jul-2010


Common Warning Relay Driver Diagnostic

FAULT CODE 1426

Common Warning Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1426 PID: FMI: LAMP: Warning SRT: | Common warning relay driver diagnostic has detected an error. | The warning relay will not function correctly. No action is taken by the ECM. No loss of performance.
Common Warning Relay Driver Circuit

Circuit Description

The ECM checks the common warning relay driver to sustain correct operation. The ECM uses the common warning relay to inform the operator of a noncritical fault. The ECM monitors the voltage, no voltage drop will trip Fault Code 1426, and can be caused by shorts, opens, bad relays, or a failed common warning relay driver in the ECM.

Component Location

Refer to the OEM manual for location of the ECM. Refer to the OEM manual for location of the user interface panel and the common warning relay.

Shop Talk

The possible failure modes are open circuit, short to ground, burned-out relay, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1426

Last Modified: 29-Jul-2010


Overspeed Shutdown Relay Driver Diagnostic

FAULT CODE 1427

Overspeed Shutdown Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1427 PID: FMI: LAMP: Warning SRT: | Overspeed shutdown relay driver diagnostic has detected an error. | The overspeed shutdown relay will not function correctly. No action is taken by the ECM. No loss of performance.
Overspeed Shutdown Relay Driver Circuit

Circuit Description

The ECM checks the overspeed shutdown relay driver to sustain correct operation. The ECM uses the overspeed shutdown relay to inform the operator of a noncritical fault. The ECM monitors the voltage, no voltage drop will trip Fault Code 1427, and can be caused by shorts, opens, bad relays, or a failed overspeed shutdown relay driver in the ECM.

Component Location

Refer to the OEM manual for location of the ECM. Refer to the OEM manual for location of the user interface panel and the overspeed shutdown relay.

Shop Talk

The possible failure modes are open circuit, short to ground, burned-out relay, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1427

Last Modified: 29-Jul-2010


Low Oil Pressure Relay Driver Diagnostic

FAULT CODE 1428

Low Oil Pressure Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1428 PID: FMI: LAMP: Warning SRT: | Low oil pressure relay driver diagnostic has detected an error. | The low oil pressure relay will not function correctly. No action is taken by the ECM. No loss of performance.
Low Oil Pressure Relay Driver Circuit

Circuit Description

The ECM checks the low oil pressure relay driver to sustain correct operation. The ECM uses the low oil pressure relay to inform the operator of a noncritical fault. The ECM monitors the voltage, no voltage drop will trip Fault Code 1428, and can be caused by shorts, opens, bad relays, or a failed low oil pressure relay driver in the ECM.

Component Location

Refer to the OEM manual for location of the ECM. Refer to the OEM manual for location of the user interface panel and the low oil pressure relay.

Shop Talk

The possible failure modes are open circuit, short to ground, burned-out relay, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1428

Last Modified: 29-Jul-2010


High Engine Temperature Relay Driver Diagnostic

FAULT CODE 1429

High Engine Temperature Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1429 PID: FMI: LAMP: Warning SRT: | High engine temperature relay driver diagnostic has detected an error. | The high engine temperature relay will not function correctly. No action is taken by the ECM. No loss of performance.
High Engine Temperature Relay Driver Circuit

Circuit Description

The ECM checks the high engine temperature relay driver to sustain correct operation. The ECM uses the high engine temperature relay to inform the operator of a noncritical fault. The ECM monitors the voltage, no voltage drop will trip Fault Code 1429, and can be caused by shorts, opens, bad relays, or a failed high engine temperature relay driver in the ECM.

Component Location

Refer to the OEM manual for location of the ECM. Refer to the OEM manual for location of the user interface panel and the high engine temperature relay.

Shop Talk

The possible failure modes are open circuit, short to ground, burned-out relay, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1429

Last Modified: 29-Jul-2010


Engine Oil Pressure Low - Warning

FAULT CODE 143

Engine Oil Pressure Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: FMI: LAMP: Warning SRT: | Engine oil pressure low - warning. Voltage signal indicates off pressure has dropped below the warning threshold for low oil pressure. | Calibration-dependent engine shutdown occurs, or no action is taken by ECM. Pre-low oil pressure relay driver is energized.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

NOTE: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-143

Last Modified: 29-Jul-2010


Pre-low Oil Pressure Relay Driver Diagnostic

FAULT CODE 1431

Pre-low Oil Pressure Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1431 PID: FMI: LAMP: Warning SRT: | Pre-low oil pressure relay driver diagnostic has detected an error. | The pre-low oil pressure relay will not function correctly. No action is taken by the ECM. No loss of performance.
Pre-Low Oil Pressure Relay Driver Circuit

Circuit Description

The ECM checks the pre-low oil pressure relay driver to sustain correct operation. The ECM uses the pre-low oil pressure relay to inform the operator of a noncritical fault. The ECM monitors the voltage, no voltage drop will trip Fault Code 1431, and can be caused by shorts, opens, bad relays, or a failed pre-low oil pressure relay driver in the ECM.

Component Location

Refer to the OEM manual for location of the ECM. Refer to the OEM manual for location of the user interface panel and the pre-low oil pressure relay.

Shop Talk

The possible failure modes are open circuit, short to ground, burned-out relay, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1431

Last Modified: 29-Jul-2010


Pre-High Engine Temperature Relay Driver Diagnostic

FAULT CODE 1432

Pre-High Engine Temperature Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1432 PID: FMI: LAMP: Warning SRT: | Pre-high engine temperature relay driver diagnostic has detected an error. | The pre-high engine temperature relay will not function correctly. No action is taken by the ECM. No loss of performance.
Pre-High Engine Temperature Relay Driver Circuit

Circuit Description

The ECM checks the pre-high engine temperature relay driver to sustain correct operation. The ECM uses the pre-high engine temperature relay to inform the operator of a non-critical fault. The ECM monitors the voltage, no voltage drop will trip Fault Code 1432, and can be caused by shorts, opens, bad relays, or a failed pre-high engine temperature relay driver in the ECM.

Component Location

Refer to the OEM manual for location of the ECM. Refer to the OEM manual for location of the user interface panel and the Pre-High engine temperature relay.

Shop Talk

The possible failure modes are open circuit, short to ground, burned-out relay, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1432

Last Modified: 29-Jul-2010


Operator Interface Mode Transition to Emergency Stop (Due to E-Stop)

FAULT CODE 1433

Operator Interface Mode Transition to Emergency Stop (Due to E-Stop)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1433 PID: SPN: FMI: LAMP: Shutdown SRT: | Operator interface mode transition to emergency stop (due to E-Stop). | Engine will shut down and will not restart until the emergency stop switch has been reset.

Circuit Description

Component Location

Refer to Troubleshooting Fault Code t05-1433

Last Modified: 29-Jul-2010


Operator Interface Mode Transition to Emergency Stop (Due to Remote E-Stop)

FAULT CODE 1434

Operator Interface Mode Transition to Emergency Stop (Due to Remote E-Stop)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1434 PID: SPN: FMI: LAMP: Shutdown SRT: | Operator interface mode transition to emergency stop (due to remote E-Stop). | Engine will shut down and will not restart until the remote emergency stop switch has been reset.

Circuit Description

Component Location

Refer to Troubleshooting Fault Code t05-1434

Last Modified: 29-Jul-2010


Engine Cold - Potential Starting Problem

FAULT CODE 1435

Engine Cold - Potential Starting Problem

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1435 PID: SPN: FMI: LAMP: Warning SRT: | Engine cold - potential starting problem. | No action is taken by the ECM. Possible hard starting.

Circuit Description

Component Location

Refer to Troubleshooting Fault Code t05-1435

Last Modified: 29-Jul-2010


HPI-PT Fuel System Driver Diagnostic

FAULT CODE 1436

HPI-PT Fuel System Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1436 PID: FMI: LAMP: Warning SRT: | HPI-PT fuel system driver common diagnostic has detected an error. | No action is taken by the ECM. Possible loss of performance.
HPI-PT Fuel System Driver Diagnostic Circuit

Circuit Description

The electronic control module (ECM) checks the HPI-PT fuel system actuator drivers to sustain correct operation. The fuel system actuators are actuated by the ECM to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

The ECM monitors the voltage, no voltage will trip Fault Code 1436, and can be caused by shorts, opens, or a failed fuel pump actuator driver in the ECM.

Component Location

Refer to the OEM manual for location of the ECM. Refer to Procedure 100-002 for the component location.

Shop Talk

The possible failure modes are open circuit, short to ground, high actuator resistance, and loss of boost voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1436

Last Modified: 29-Jul-2010


Failed to Crank

FAULT CODE 1438

Failed to Crank

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1438 PID: SPN: FMI: LAMP: Warning SRT: | Fail to crank. | No action is taken by the ECM, although the engine will not start.

Circuit Description

Component Location

Refer to Troubleshooting Fault Code t05-1438

Last Modified: 29-Jul-2010


Fuel Level Low in Day Tank

FAULT CODE 1439

Fuel Level Low in Day Tank

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1439 PID: FMI: LAMP: Warning SRT: | Fuel level low in day tank. | No action is taken by the ECM. Possible loss of performance.
Day Tank Fuel Level Sensor Circuit

Circuit Description

The fuel level sensor monitors the fuel level within the day tank and passes information to the electronic control module (ECM).

Component Location

Refer to customer/facility/installation documentation for the location of the fuel day tank and the fuel level sensor used on the day tank.

Shop Talk

When the fuel level drops below a certain level in the tank, it could cause the fuel pump to work harder to obtain the desired fuel pressure.

If a shorting plug is used in the fuel level circuit, verify that it is wired correctly.

Inspect all connectors and the sensor pins for damage.

Refer to Troubleshooting Fault Code t05-1439

Last Modified: 29-Jul-2010


Engine Coolant Temperature Sensor Circuit - Shorted High

FAULT CODE 144

Engine Coolant Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: FMI: LAMP: Warning SRT: | Engine coolant temperature sensor signal is shorted high. | No engine protection for coolant temperature. Possible white smoke.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is high, the ECM will log Fault Code 144. Voltage high can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-144

Last Modified: 29-Jul-2010


Fuel Level Low in Main Tank

FAULT CODE 1441

Fuel Level Low in Main Tank

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1441 PID: FMI: LAMP: Warning SRT: | Fuel level low in main tank. | No action is taken by the ECM. Possible loss of performance.
Main Tank Fuel Level Sensor Circuit

Circuit Description

The fuel level sensor monitors the fuel level within the main tank and passes information to the electronic control module (ECM).

Component Location

Refer to customer/facility/installation documentation for the location of the fuel main tank and the fuel level sensor used on the main tank.

Shop Talk

When the fuel level drops below a certain level in the tank, it could cause the fuel pump to work harder to obtain the desired fuel pressure.

If a shorting plug is used in the fuel level circuit, verify that it is wired correctly.

Inspect all connectors and the sensor pins for damage.

Refer to Troubleshooting Fault Code t05-1441

Last Modified: 29-Jul-2010


Unswitched Battery Supply Circuit - Battery is Weak

FAULT CODE 1442

Unswitched Battery Supply Circuit - Battery is Weak

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1442 PID: FMI: LAMP: Warning SRT: | Battery is weak. | No action is taken by the ECM.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives unswitched battery input through the engine harness. There is an in-line 20 amp fuse in the unswitched positive (+) battery wire of the engine harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Refer to the OEM manual for the battery location.

Shop Talk

This fault is usually caused by loose or corroded battery connections.

Refer to Troubleshooting Fault Code t05-1442.

Last Modified: 08-May-2012


Unswitched Battery Supply Circuit - Battery is Dead

FAULT CODE 1443

Unswitched Battery Supply Circuit - Battery is Dead

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1443 PID: FMI: LAMP: Shutdown SRT: | Battery is dead. | Engine will not start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives unswitched battery input through the engine harness. There is an inline 20-amp fuse in the unswitched positive (+) battery wire of the engine harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Refer to the OEM service manual for the battery location.

Shop Talk

This fault is usually caused by loose or corroded battery connections.

Refer to Troubleshooting Fault Code t05-1443.

Last Modified: 08-May-2012


Kilowatt Overload - Alternator Protection

FAULT CODE 1444

Kilowatt Overload - Alternator Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1444 PID: FMI: LAMP: Warning SRT: | The kilowatt has reached overload. | No action is taken by the ECM.
Generator Circuit

Circuit Description

The generator set produces electric power. When the generator is connected to the bus, it can be governed by adjusting the kilowatt load or the kVAR load. The engine control module (ECM) monitors the three-phase generator output. The threshold for kilowatt overload is 115 percent of rated power output. The ECM uses this fault code to inform the operator that the kilowatt load is too high for the engine and needs to be reduced.

Component Location

Refer to Section E for location of the alternator.

Refer to customer/facility/installation documentation for diagrams on the generator set/electric bus setup.

Shop Talk

Check the load and load lead connections.

Refer to Troubleshooting Fault Code t05-1444.

Last Modified: 08-May-2012


Alternator Short Circuit - Alternator Protection

FAULT CODE 1445

Alternator Short Circuit - Alternator Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1445 PID: FMI: LAMP: Shutdown SRT: | Alternator short circuit. | Generator set will shut down.
Alternator Circuit

Circuit Description

The alternator turns the mechanical energy produced by the engine into electrical energy. The ECM monitors the performance and operation of the alternator. The threshold for short circuit condition is 175 percent of rated.

The ECM uses this fault code to inform the operator that a short circuit condition exists in the generator set alternator output circuit.

Component Location

Refer to Section E for location of the alternator. Refer to customer/facility/installation documentation for diagrams on the generator set/electric bus setup.

Shop Talk

Check the load and load lead connections.

Refer to Troubleshooting Fault Code t05-1445

Last Modified: 29-Jul-2010


Generator AC Output Voltage - High

FAULT CODE 1446

Generator AC Output Voltage - High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1446 PID: FMI: LAMP: Shutdown SRT: | Generator AC output voltage is high. | Generator set will shut down.
Generator Circuit

Circuit Description

The generator set produces electric power. This power is in the form of three-phase AC. The engine control module (ECM) monitors the performance and operation of the generator set. The threshold for a high AC output voltage condition is that one or more of the phase voltages has exceeded 130 percent of nominal or has exceeded 110 percent of nominal for at least 10 seconds. The ECM uses this fault code to tell the operator when the generator set AC output voltage is high.

Component Location

Refer to customer/facility/installation documentation for diagrams on the generator set/electric bus setup.

Shop Talk

This fault can be caused by a failed voltage regulator, PT/CT board, open circuit, or short circuit in one of the harnesses.

If the voltages at the output leads of the alternator do not correspond to the voltages read by the electronic service tool, the problem can be in the voltage sensing circuits.

At idle, if INSITE™ electronic service tool shows greater than residual voltages from the alternator, the problem can be with either the PMG, field wiring, or voltage regulator. If you unplug connector 10 and the AC output voltage drops to residual, the problem is with the voltage regulator. If the voltage does not drop, the problem is with the PMG or field wiring.

Refer to Troubleshooting Fault Code t05-1446.

Last Modified: 08-May-2012


Generator AC Output Voltage - Low

FAULT CODE 1447

Generator AC Output Voltage - Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1447 PID: FMI: LAMP: Shutdown SRT: | Generator AC output voltage is low. | Generator set will shut down.
Generator Circuit

Circuit Description

The generator set produces electric power. This power is in the form of three-phase AC. The engine control module (ECM) monitors the performance and operation of the generator set. The threshold for a low AC output voltage condition is that one or more of the phase voltages has dropped below 85 percent of nominal for at least 10 seconds.

The ECM uses this fault code to tell the operator when he generator set AC output voltage is low.

Component Location

Refer to customer/facility/installation documentation for diagrams on the generator set/electrical bus setup.

Shop Talk

If output voltage is low, the control can not drive the output voltage high enough. This fault can be caused by a failed voltage regulator, PT/CT board, bad PMG on field wirings, or an open or short circuit in one of the harnesses.

If the voltages at the output leads of the alternator are significantly higher than the voltages read by INSITE™ electronic service tool, the problem can be in the voltage sensing circuits.

If the voltage regulator is getting B positive (+). but the isolated supply LED is not lit, the problem is with the voltage regulator.

Check for overload.

Refer to Troubleshooting Fault Code t05-1447.

Last Modified: 08-May-2012


Generator AC Output Frequency - High

FAULT CODE 1448

Generator AC Output Frequency - High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1448 PID: FMI: LAMP: Shutdown SRT: | Generator AC output frequency is low. | Generator set will shut down.
Generator Set

Circuit Description

The generator set produces electrical power. This power is in the form of three-phase AC. The ECM monitors the performance and operation of the generator set. The threshold for a low AC output frequency condition is that the engine speed has dropped below 90 percent of nominal for at least 10 seconds.

The engine control module (ECM) uses this fault code to tell the operator when the generator set AC output frequency is low.

Component Location

Refer to customer/facility/installation documentation for diagrams on the generator set/electrical bus setup.

Shop Talk

Check the fuel supply, intake air supply, and load.

Refer to Troubleshooting Fault Code t05-1448.

Last Modified: 08-May-2012


Generator AC Output Frequency - Low

FAULT CODE 1449

Generator AC Output Frequency - Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1449 PID: FMI: LAMP: Warning SRT: | Generator AC output frequency is high. | No action is taken by the ECM.
Generator Set

Circuit Description

The generator set produces electric power. This power is in the form of three-phase AC. The ECM monitors the performance and operation of the generator set. The threshold for a high AC output frequency condition is that the engine speed has dropped below 110 percent of nominal for at least 10 seconds.

The engine control module (ECM) uses this fault code to tell the operator when the generator set AC output frequency is low.

Component Location

Refer to customer/facility/installation documentation for diagrams on the generator set/electric bus setup.

Shop Talk

Check the fuel supply, intake air supply, and load.

Refer to Troubleshooting Fault Code t05-1449.

Last Modified: 08-May-2012


Engine Coolant Temperature Sensor Circuit - Shorted Low

FAULT CODE 145

Engine Coolant Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: FMI: LAMP: Warning SRT: | Engine coolant temperature sensor signal is shorted low. | No engine protection for coolant temperature. Possible white smoke.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing and fueling control. If the voltage is low for more than 2 seconds, the ECM will log Fault Code 145. Low voltage can be caused by shorts to ground on the supply or return wires or an internally grounded failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-145

Last Modified: 29-Jul-2010


Generator Output Voltage and Electric Bus Voltage Differ - Condition Exists

FAULT CODE 1451

Generator Output Voltage and Electric Bus Voltage Differ - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1451 PID: FMI: LAMP: Warning SRT: | Generator output voltage and electric bus voltage differ by more than the allowed threshold. | No action is taken by the ECM.
Generator Circuit

Circuit Description

The generator set produces electric power. This power is in the form of three-phase AC. The engine control module (ECM) uses this fault code to tell the operator that after the circuit breaker closed, the voltage of the generator set was different from the voltage of the bus.

Component Location

Refer to customer/facility/installation documentation for the location of the paralleling controller.

Shop Talk

Check the alternator voltage calibration and bus voltage calibration.

Refer to Troubleshooting Fault Code t05-1451.

Last Modified: 08-May-2012


Generator Circuit Breaker - Failed to Close - Condition Exists

FAULT CODE 1452

Generator Circuit Breaker - Failed to Close - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1452 PID: FMI: LAMP: Shutdown SRT: | Generator circuit breaker failed to close. | Generator set will shut down.
Generator Set Circuit Breaker Circuit

Circuit Description

The generator set circuit breaker is the switch for the generator set's connection to the bus. The circuit breaker opens when events have occurred, which forces the generator set to no longer be connected to the bus. The circuit breaker closes when the generator set is to be connected to the bus.

This fault code is used by the engine control module (ECM) to tell the operator that due to an event, the generator set can not connect to the bus.

Component Location

Refer to Section E for location of the ECM card cage.

Refer to customer/facility/installation documentation for the location of the generator set circuit breaker.

Shop Talk

Verify that the charging mechanism of the paralleling breaker is functioning properly.

Check the closed signal to the breaker.

Verify that the auxiliary contact signals from the breaker to ECM are operational.

Refer to Troubleshooting Fault Code t05-1452.

Last Modified: 08-May-2012


Generator Circuit Breaker - Failed to Open - Condition Exists

FAULT CODE 1453

Generator Circuit Breaker - Failed to Open - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1453 PID: FMI: LAMP: Shutdown SRT: | The generator circuit breaker failed to open. | The generator set will shut down.
Generator Set Circuit Breaker Circuit

Circuit Description

The generator set circuit breaker is the switch for the generator set's connections to the bus. The circuit breaker opens when events have occurred , which forces the generator set to no longer be connected to the bus. The circuit breaker closes when the generator set is to be connected to the bus.

This fault code is used by the engine control module (ECM) to tell the operator that, due to an event, the generator set can not disconnect from the bus.

Component Location

Refer to Section E for the location of the ECM card cage.

Refer to customer/facility/installation documentation for the location of the generator set circuit breaker.

Shop Talk

The possible failure modes are that the generator set circuit breaker was not wired properly, an open circuit, shorted circuit, or short pin-to-pin condition exists.

Refer to Troubleshooting Fault Code t05-1453.

Last Modified: 08-May-2012


Generator Circuit Breaker Position Contact Failed - Condition Exists

FAULT CODE 1454

Generator Circuit Breaker Position Contact Failed - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1454 PID: FMI: LAMP: Warning SRT: | Generator circuit breaker position contact failed. | No action is taken by the ECM.
Generator Circuit

Circuit Description

The generator set circuit breaker is the switch for the generator set's connection to the bus. The circuit breaker opens when events have occurred, which forces the generator set to no longer be connected to the bus. The circuit breaker closes when the generator set is to be connected to the bus.

This fault code is used by the engine control module (ECM) to tell the operator that, due to an event, the ECM can not determine the position of the circuit breaker.

Component Location

Refer to Section E for location of the ECM card cage.

Refer to customer/facility/installation documentation for the location of the generator set circuit breaker.

Shop Talk

The possible failure modes are that the generator set circuit breaker was not wired properly, an open circuit, shorted circuit, or short pin-to-pin condition exists.

Refer to Troubleshooting Fault Code t05-1454.

Last Modified: 08-May-2012


Utility Circuit Breaker Position Contact Selected is Incorrect for Generator Application - Condition Exists

FAULT CODE 1455

Utility Circuit Breaker Position Contact Selected is Incorrect for Generator Application - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1455 PID: FMI: LAMP: Shutdown SRT: | Utility circuit breaker position contact selected is incorrect for generator application. | Generator set will not start.
Generator Circuit

Circuit Description

The generator set circuit breaker is the switch for the generator set's connection to the bus. The circuit breaker opens when events have occurred, which forces the generator set to no longer be connected to the bus. The circuit breaker closes when the generator set is to be connected to the bus.

This fault code is used by the engine control module (ECM) to tell the operator that the electronically selected position contact for the utility circuit breaker is not correct for the generator application.

Component Location

Refer to Section E for location of the ECM card cage.

Refer to customer/facility/installation documentation for the location of the generator set circuit breaker.

Shop Talk

The possible failure modes are improper calibration/trim and/or setup.

Refer to Troubleshooting Fault Code t05-1455.

Last Modified: 08-May-2012


Electric Bus Voltage and/or Frequency Are Out of Range for Synchronizing to Occur - Condition Exists

FAULT CODE 1456

Electric Bus Voltage and/or Frequency Are Out of Range for Synchronizing to Occur - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1456 PID: FMI: LAMP: Warning SRT: | Electric bus voltage and/or frequency are out of range for synchronizing to occur. | Generator will continue to run, but will not pick up load.
Generator Circuit

Circuit Description

The generator set picks up the electrical load from the bus. For the generator to connect to a bus (other than a dead bus), it must match, with a threshold, the voltage and frequency of the bus. The generator set can not connect to the bus while voltage and frequency are outside the threshold otherwise, damage could occur to the generator set.

This fault code is used by the engine control module (ECM) to tell the operator that, due to either the frequency or voltage being outside the synchronizing threshold, the generator set can not connect to the bus.

Component Location

Reference Section E for location of the ECM card cage.

Reference customer/facility/installation documentation for the location of the generator set circuit breaker and interface with the electric bus.

Shop Talk

Check the governor for correct setup.

Check the synchronizing parameters for correct setup.

Check the fuel system for problems that can cause instability.

Refer to Troubleshooting Fault Code t05-1456.

Last Modified: 08-May-2012


Generator Synchronizing to Electric Bus Failed - Condition Exists

FAULT CODE 1457

Generator Synchronizing to Electric Bus Failed - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1457 PID: FMI: LAMP: Warning SRT: | Generator synchronizing to electric bus failed. | Generator will continue to run, but will not pick up load.
Generator Circuit

Circuit Description

The generator set picks up the electrical load from the bus. For the generator to connect to a bus (other than a dead bus), it must match, with a threshold, the voltage and frequency of the bus. The generator set can not connect to the bus while voltage and frequency are outside the threshold; otherwise, damage could occur to the generator set.

This fault code is used by the engine control module (ECM) to tell the operator that the generator set failed to synchronize to the electrical bus.

Component Location

Reference Section E for location of the ECM card cage.

Reference customer/facility/installation documentation for the location of the generator set circuit breaker and interface with the electrical bus.

Shop Talk

Check the governor for correct setup.

Check the synchronizing parameters for correct setup.

Check the fuel system for problems that can cause instability.

Refer to Troubleshooting Fault Code t05-1457.

Last Modified: 08-May-2012


Generator Set - Cannot Synchronize Phase

FAULT CODE 1458

Generator Set - Cannot Synchronize Phase

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1458 PID: FMI: LAMP: Warning SRT: | Generator and electric bus phase sequences differ. | Generator will continue to run, but will not pick up load.
Generator Circuit

Circuit Description

The generator set picks up the electrical load from the bus. For the generator to connect to a bus (other than a dead bus), it must match, in phase sequences as well as with a threshold, the voltage and frequency of the bus. The generator set can not connect to the bus while voltage and frequency are outside the threshold, or the phase sequences of the generator set do not match the electric bus; otherwise, damage can occur to the generator set.

This fault code is used by the ECM to tell the operator that the generator set failed to synchronize to the electric bus.

Component Location

Refer to Section E for location of the ECM card cage.

Refer to customer/facility/installation documentation for the location of the generator set circuit breaker and interface with the electric bus.

Shop Talk

Check the bus feedback wires to the bus PT.

Verify phase rotation of generator and bus.

Refer to Troubleshooting Fault Code t05-1458

Last Modified: 09-May-2012


Generator is Absorbing Power From the Electric Bus - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1459

Generator is Absorbing Power From the Electric Bus - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1459 PID: FMI: LAMP: Shutdown SRT: | Reverse kW detected (generator is absorbing voltage from the electric bus). | The generator set will shut down.
Generator Circuit

Circuit Description

Under normal operating conditions, the generator set connects to the bus. Generator set is producing power, and when it connects to the bus, power is added to the main electric bus. When some events occur, a condition can occur when the generator set is no longer producing power for the electric bus, but rather is drawing power from the electric bus. This condition is called reverse kW.

Component Location

Reference Section E for location of the engine control module (ECM) card cage. Reference customer/facility/installation documentation for the location of the generator set circuit breaker and interface with the electric bus.

Shop Talk

The system (electric bus) is driving the engine using the alternator as a motor.

If the problem occurs at initial start-up, verify proper connection of the generator's current transformers.

Verify proper connection of load-sharing lines.

Verify that the generator is operating at the correct frequency and voltage.

Verify that there are no new fuel system problems that are causing the engine not to be able to pick up the load.

Refer to Troubleshooting Fault Code t05-1459.

Last Modified: 08-May-2012


Engine Coolant Temperature High - Warning

FAULT CODE 146

Engine Coolant Temperature High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: FMI: LAMP: Warning SRT: | Engine coolant temperature has exceeded the warning threshold for high coolant temperature. | Calibration dependent no action is taken by the ECM or engine shutdown as temperature increases over thresholds. Pre-High Engine Temperature relay driver is energized.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low for more than 2 seconds, the ECM will log Fault Code 146.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Make sure the airflow through the radiator is not obstructed.The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-146

Last Modified: 29-Jul-2010


Loss of Electric Field Due to Reverse KVAR - Condition Exists

FAULT CODE 1461

Loss of Electric Field Due to Reverse KVAR - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1461 PID: FMI: LAMP: Shutdown SRT: | Loss of field (electric) due to reverse kVAR. | Generator set will shut down.
Generator Circuit

Circuit Description

Under normal operating conditions, the generator set connects to the bus. The generator set is producing power, and when it connects to the bus, power is added to the main electric bus. When some events occur, a condition can occur when the generator set is no longer producing power for the electric bus, but rather is drawing power from the electric bus. This condition is called reverse kilovolt-ampere reduction (kVAR). Sometimes a reverse kVAR condition can cause the alternator to lose its electric field.

This fault code is used by the engine control module to tell the operator that the engine control module has detected a loss of electric field in the alternator due to a reverse kVAR condition.

Component Location

Reference Section E for location of the engine control module card cage.

Reference customer/facility/installation documentation for the location of the generator set circuit breaker and interface with the electric bus.

Shop Talk

The possible failure mode is perhaps due to power factor correction capacitors or other power sources feeding kVAR into the generator set.

Beyond a certain threshold, reverse kVAR can lead to voltage output instability and pole slipping due to the fact that the alternator becomes self-excited.

Check load-sharing lines for proper connection.

Refer to Troubleshooting Fault Code t05-1461.

Last Modified: 08-May-2012


High Current on Ground Circuit - Condition Exists

FAULT CODE 1462

High Current on Ground Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1462 PID: FMI: LAMP: Warning SRT: | Electric ground circuit has a high current. | Calibration-dependent no action taken by the ECM, or engine shutdown.
Generator Ground Circuit

Circuit Description

The generator-set electronics have a common ground circuit. The engine control module (ECM) monitors the ground circuit; when a high current condition occurs, the ECM will set the fault to active. High current on the common ground could have undefinable effects on the control system.

Component Location

Reference Section E for location of the ECM card cage.

Reference Section E for drawings of the common ground circuit for the ECM electronics.

Shop Talk

The possible modes are a dirty or improper ground and a voltage supply wire shorted to a ground wire.

Refer to Troubleshooting Fault Code t05-1462.

Last Modified: 08-May-2012


Generator Set Not in Auto

FAULT CODE 1463

Generator Set Not in Auto

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1463 FMI: LAMP: None SRT: | The generator announces to the LonWorks network that it is not in auto. | No action is taken by the ECM.
Refer to Troubleshooting Fault Code t05-1463

Last Modified: 29-Jul-2010


Generator Set Load Dump

FAULT CODE 1464

Generator Set Load Dump

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1464 FMI: LAMP: None SRT: | The generator announces to the LonWorks network that a 'load dump” has occurred. | No action is taken by the ECM.
Refer to Troubleshooting Fault Code t05-1464

Last Modified: 29-Jul-2010


Generator Set Ready to Accept Load

FAULT CODE 1465

Generator Set Ready to Accept Load

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1465 FMI: LAMP: None SRT: | The generator announces to the LonWorks network that it is “ready to accept load”. | No action is taken by the ECM.
Refer to Troubleshooting Fault Code t05-1465

Last Modified: 29-Jul-2010


Modem-Lost Communication

FAULT CODE 1466

Modem-Lost Communication

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1466 PID: FMI: LAMP: Warning SRT: | ECM can not communicate with the modem. | No action taken by the ECM.
Modem Circuit

Circuit Description

The ECM checks the modem to make certain it is operating correctly. The ECM uses the modem to inform a remote operator about generator set operation, performance, setup, and diagnostics. The ECM monitors the modem (no communication with the modem will trip Fault Code 1466) and can be caused by shorts or opens.

Component Location

Refer to Section E for location of the modem.

Shop Talk

The possible failure modes are open circuit, short to ground, and loss of supply voltage inside the ECM.

Check for open, short circuit to ground, and loose connections on customer-supplied wiring to the modem.

Refer to Troubleshooting Fault Code t05-1466

Last Modified: 29-Jul-2010


LonWorks Network-Lost Communication

FAULT CODE 1468

LonWorks Network-Lost Communication

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1468 PID: FMI: LAMP: Warning SRT: | Loss of communication from the LonWorks Network. | No action taken by ECM.
LonWorks Network Circuit

Circuit Description

If a LonWorks Network is installed, the ECM checks communication to make sure it is operating correctly. The ECM uses the LonWorks Network to inform other controllers on the LonWorks Network about generator set operation, performance, setup, and diagnostics.The ECM monitors the LonWorks Network, no communication with the LonWorks Network will trip Fault Code 1468, caused by shorts or open circuits.

Component Location

Refer to Section E for location of the LonWorks board.

Shop Talk

Refer to the LonWorks Network publications for more specific troubleshooting methods.

Refer to Troubleshooting Fault Code t05-1468

Last Modified: 29-Jul-2010


Generator Set Measured Speed and AC Output Frequency Conflict - Condition Exists

FAULT CODE 1469

Generator Set Measured Speed and AC Output Frequency Conflict - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1469 PID: FMI: LAMP: Shutdown SRT: | Generator measured speed and measured AC output frequency do not agree. | Generator set will shut down.
Generator Circuit

Circuit Description

The generator set monitors engine speed and AC output frequency. The AC output frequency is dependent on the engine speed. Therefore, if the engine speed does not match what the AC output frequency would expect, the engine control module (ECM) will make this fault code active.

Component Location

Reference Section E for location of the engine speed sensor and the PT/CT board.

Reference customer/facility/installation documentation for the location of the generator set circuit breaker and interface with the electric bus.

Shop Talk

This fault code could be caused by a faulty PT/CT board, a problem with the engine speed sensor circuit, and a problem with the generator control harness.

Refer to Troubleshooting Fault Code t05-1469.

Last Modified: 08-May-2012


Generator AC Output Current High - Warning

FAULT CODE 1471

Generator AC Output Current High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1471 PID: FMI: LAMP: Warning SRT: | AC output current has exceeded the warning threshold for high current. | No action is taken by the ECM.
AC Output Current Circuit

Circuit Description

The generator set produces electric power. This power is in the form of three-phase AC. The engine control module (ECM) monitors the AC output current to make certain it is operating correctly and performance of the generator output current has exceeded 110 percent of rated for at least 60 seconds.

The ECM uses this fault code to tell the operator when the AC output current passes the warning threshold for high current.

Component Location

Reference Section E for location of the voltage regulator and PT/CT module.

Shop Talk

The alternator is beginning to become overloaded. The AC output current has passed the calibrated threshold for a warning level.

Check load-sharing lines for proper connection.

Refer to Troubleshooting Fault Code t05-1471.

Last Modified: 08-May-2012


Generator AC Output Current High - Critical

FAULT CODE 1472

Generator AC Output Current High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1472 PID: FMI: LAMP: Shutdown SRT: | AC output current has exceeded the shutdown threshold for high current. | Generator set will shut down.
AC Output Current Circuit

Circuit Description

The generator set produces electric power. This power is in the form of three-phase AC. The engine control module (ECM) monitors the AC output current to make certain the generator set is performing and operating correctly. The threshold for a high AC output current condition is that the generator output current has exceeded 100 percent of rated for at least 120 seconds.

The ECM uses this fault code to tell the operator when the AC output current passes the shutdown threshold for high current.

Component Location

Reference Section E for location of the voltage regulator and PT/CT board.

Shop Talk

The alternator is beginning to become overloaded. The AC output current has passed the calibrated threshold for a shutdown level.

Check load-sharing lines for proper connection.

Refer to Troubleshooting Fault Code t05-1472.

Last Modified: 08-May-2012


Electronic Control Module Watchdog Has Failed - Condition Exists

FAULT CODE 1473

Electronic Control Module Watchdog Has Failed - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1473 PID: SPN: FMI: LAMP: Shutdown SRT: | The ECM watchdog has failed. | Engine will shut down.
Refer to Troubleshooting Fault Code t05-1473.

Last Modified: 08-May-2012


Base Board - Extended I/O Software Mismatch

FAULT CODE 1474

Base Board - Extended I/O Software Mismatch

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1474 PID: FMI: LAMP: Shutdown SRT: | Software version mismatch between the base board and the extended I/O board. | Generator set will shut down.
Generator Set ECM Card Cage

Circuit Description

This fault code is used by the ECM to tell the operator that the base board software version does not correspond to the version of software loaded into the extended I/O board.

Component Location

Refer to section E for location of the ECM card cage, the base board, and the extended I/O board.

Shop Talk

The possible failure modes are incorrect installation of the base board or extended I/O board, and loading an incorrect software calibration into the ECM.

Refer to Troubleshooting Fault Code t05-1474

Last Modified: 29-Jul-2010


Permission to connect - not received

FAULT CODE 1475

Permission to connect - not received

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1475 PID: FMI: LAMP: Warning SRT: | Permission to connect to a closed bus has not been received in the required time. | Generator set will connect to the dead bus.
Paralleling Controller Circuit

Circuit Description

This fault code is used by the ECM to tell the operator that the ECM did not receive a command from the paralleling controller to connect to the bus. The ECM monitors the bus for a set amount of time and if the ECM still sees a dead bus after that set amount of time, then it will connect to the bus.

The paralleling controller is wired into the ECM and can give it commands to pick up load, dump load, or load governing commands.

Component Location

Refer to section E for location of the ECM card cage.Refer to customer/facility/installation documentation for the location of the paralleling controller.

Shop Talk

The possible failure modes are short circuit, open circuit, short to ground, and failed input device. Check the master first start sensor for failures.

Refer to Troubleshooting Fault Code t05-1475

Last Modified: 29-Jul-2010


Engine Control Module Base Board Not Responding to LonWorks Board

FAULT CODE 1476

Engine Control Module Base Board Not Responding to LonWorks Board

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1476 PID: FMI: LAMP: Warning SRT: | ECM base board is not responding to the LonWorks board. | No action is taken by the ECM.
Generator Set ECM Card Cage

Circuit Description

This fault code is used by the engine control module (ECM) to tell the operator that the base board is not responding to commands sent via the LonWorks board.

Component Location

Reference Section E for location of the ECM card cage, the base board, and the LonWorks Network board.

Shop Talk

The possible failure modes are incorrect installation of the base board, LonWorks board, and loading an incorrect software calibration into the ECM.

Refer to Troubleshooting Fault Code t05-1476.

Last Modified: 08-May-2012


Crank Relay Contact Driver Diagnostic

FAULT CODE 1477

Crank Relay Contact Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1477 PID: FMI: LAMP: Warning SRT: | Crank relay contact diagnostic has detected and error. | ECM will possibly not be able to crank the engine.
Crank Relay Contact Circuit

Circuit Description

The engine control module (ECM) checks the crank relay contact to make certain it is operating correctly. The ECM uses the fault code to inform the operator that the generator set is commanding “cranking,” but the feedback from the crank relay contact is not confirming.

Component Location

Reference Section E for location of the crank relay contact and the ECM.

Shop Talk

The possible failure modes are open circuit, short to ground, bad crank relay, bad crank slave relay, and loss of supply voltage inside the ECM.

If the engine will crank, the problem is with the crank status circuit.

If the engine will not crank, the problem is with the crank supply circuit, the crank signal circuit, a bad crank relay, or bad crank slave relay.

If the 20 amp fuse (battery side of Inline E) blows when attempting to crank, check the diode on the crank slave coil circuit for proper installation and operation.

Refer to Troubleshooting Fault Code t05-1477.

Last Modified: 08-May-2012


Crank Relay Driver Diagnostic

FAULT CODE 1478

Crank Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1478 FMI: LAMP: SRT: Warning | Crank relay driver diagnostic has detected an error. | The ECM will not be able to crank the engine.
Refer to Troubleshooting Fault Code t05-1478

Last Modified: 29-Jul-2010


Fail To Start Relay Driver Diagnostic

FAULT CODE 1479

Fail To Start Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1479 PID: FMI: LAMP: Warning SRT: | Fail to start relay driver diagnostic has detected an error. | The fail to start relay will not function correctly. No action is taken by the ECM. No loss of performance.
Fail To Start Relay Driver Circuit

Circuit Description

The engione control module (ECM) checks the fail-to-start relay driver to sustain correct operation. The ECM uses the fail-to-start relay to inform the operator of a noncritical fault. The ECM monitors the voltage, no voltage drop will trip Fault Code 1479, and can be caused by shorts, opens, bad relays, or a failed fail to start relay driver in the ECM.

Component Location

Reference the OEM service manual for location of the ECM. Reference the OEM service manual for location of the user interface panel and the fail to start relay.

Shop Talk

The possible failure modes are open circuit, short to ground, burned-out relay, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1479.

Last Modified: 08-May-2012


Voltage Regulator Driver Diagnostic - Open Circuit

FAULT CODE 1481

Voltage Regulator Driver Diagnostic - Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1481 PID: FMI: LAMP: Shutdown SRT: | Voltage regulator driver diagnostic has detected an open circuit condition. | Generator set will shut down.
Voltage Regulator Driver Circuit

Circuit Description

The engine control module (ECM) checks the voltage regulator (VR) driver to make certain it is operating correctly. The ECM uses this fault code to inform the operator that the ECM is no longer driving the voltage regulator.

The ECM monitors the voltage (no voltage will trip Fault Code 1481) and can be caused by shorts, opens, a failed voltage regulator, or a failed voltage regulator driver in the ECM.

Component Location

Reference Section E for location of the voltage regulator.

Shop Talk

The possible failure modes are short circuit, open circuit, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1481.

Last Modified: 08-May-2012


One or More Fault Codes Have Not Been Acknowledged

FAULT CODE 1483

One or More Fault Codes Have Not Been Acknowledged

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1483 FMI: LAMP: None SRT: | One or more fault codes have not been acknowledged. | No action taken by the ECM.
Refer to Troubleshooting Fault Code t05-1483

Last Modified: 29-Jul-2010


Electronic Fuel Control (EFC) Driver - Grounded Circuit

FAULT CODE 1485

Electronic Fuel Control (EFC) Driver - Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1485 PID: FMI: LAMP: Shutdown SRT: | Electronic fuel control driver diagnostic has detected a grounded circuit condition. | Generator set will shut down.
Electronic Fuel Control

Circuit Description

The engine control module (ECM) checks the electronic fuel control (EFC) driver to make certain it is operating correctly. The ECM uses this fault code to inform the operator that the ECM is no longer driving the electronic fuel control.

The electronic fuel control unit is only used on hydromechanical fuel systems. This fault code will not be active on any other types (electronic full-authority) fuel systems.

The ECM monitors the voltage (no voltage will trip Fault Code 1486) and can be caused by shorts, a failed voltage regulator, or a failed voltage regulator driver in the ECM.

Component Location

Reference Section E for location of the electronic fuel control unit.

Shop Talk

The possible failure modes are short circuit, short to ground, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1485.

Last Modified: 08-May-2012


Electronic Fuel Control (EFC) Driver - Open Circuit

FAULT CODE 1486

Electronic Fuel Control (EFC) Driver - Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1486 PID: FMI: LAMP: Shutdown SRT: | Electronic fuel control driver diagnostic has detected an open circuit condition. | Generator set will shut down.
Electronic Fuel Control

Circuit Description

The engine control module (ECM) checks the electronic fuel control (EFC) driver to make certain it is operating correctly. The ECM uses this fault code to inform the operator that the ECM is no longer driving the EFC.

The electronic fuel control unit is only used on hydromechanical fuel systems. This fault code will not be active on any other types (electronic full-authority) of fuel systems.

The ECM monitors the voltage (no voltage will trip Fault Code 1486), and can be caused by shorts, opens, a failed voltage regulator, or a failed voltage regulator driver in the ECM.

Component Location

Reference Section E for location of the electronic fuel control.

Shop Talk

The possible failure modes are short circuit, open circuit, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1486.

Last Modified: 08-May-2012


Not in Auto LED Driver Diagnostic

FAULT CODE 1487

Not in Auto LED Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1487 PID: FMI: LAMP: Warning SRT: | Switch panel Not in Auto LED driver diagnostic has detected an error. | The Not in Auto LED will not function correctly. No action is taken by the ECM. No loss of performance.
Not in Auto LED Driver Circuit

Circuit Description

The ECM checks the Not in Auto LED driver to make certain it is operating correctly. The ECM uses the Not in Auto lamp to inform the operator that the generator set is not in manual mode but rather it is currently in auto (remote start enabled) mode.

The ECM monitors the voltage (no voltage drop will trip Fault Code 1487) and can be caused by shorts, opens, bad bulbs, or a failed Not in Auto LED driver in the ECM.

Component Location

Refer to section E for location of the switch panel and the Not in Auto lamp.

Shop Talk

The possible failure modes are open circuit, short to ground, burned-out bulb, and loss of supply voltage inside the ECM.

Proper diagnostic lamp operation can be verified by checking to see that the lamps briefly light when the ECM is powered up.

Refer to Troubleshooting Fault Code t05-1487

Last Modified: 29-Jul-2010


Warning LED Driver Diagnostic

FAULT CODE 1488

Warning LED Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1488 PID: FMI: LAMP: Warning SRT: | Switch panel warning LED driver diagnostic has detected an error. | The warning LED will not function correctly. No action is taken by the ECM. No loss of performance.
Warning LED Driver Circuit

Circuit Description

The ECM checks the warning LED driver to make certain it is operating correctly. The ECM uses the warning lamp to inform the operator that a noncritical fault has occurred with the generator set.

The ECM monitors the voltage, (no voltage drop will trip Fault Code 1488) and can be caused by shorts, opens, bad bulbs, or a failed warning LED driver in the ECM.

Component Location

Refer to Section E for location of the switch panel and the warning lamp.

Shop Talk

The possible failure modes are open circuit, short to ground, burned out bulb, and loss of supply voltage inside the ECM.

Proper diagnostic lamp operation can be verified by checking to see that the lamps briefly light when the ECM is powered up.

Refer to Troubleshooting Fault Code t05-1488

Last Modified: 29-Jul-2010


Shutdown LED Driver Diagnostic

FAULT CODE 1489

Shutdown LED Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1489 PID: FMI: LAMP: Warning SRT: | Switch panel shutdown LED driver diagnostic has detected an error. | The shutdown LED will not function correctly. No action is taken by the ECM. No loss of performance.
Shutdown LED Driver Circuit

Circuit Description

The ECM checks the shutdown LED driver to be sure of correct operation. The ECM uses the shutdown lamp to inform the operator that a critical fault has occurred with the generator set.

The ECM monitors the voltage (no voltage drop will trip Fault Code 1489) and can be caused by shorts, opens, bad bulbs, or a failed shutdown LED driver in the ECM.

Component Location

Refer to Section E for location of the switch panel and the shutdown lamp.

Shop Talk

The possible failure modes are open circuit, short to ground, burned-out bulb, and loss of supply.

Proper diagnostic lamp operation can be verified by checking to see that the lamps briefly light when the ECM is powered up.

Refer to Troubleshooting Fault Code t05-1489

Last Modified: 29-Jul-2010


Ready to Load Output Relay Driver Diagnostic

FAULT CODE 1491

Ready to Load Output Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1491 PID: FMI: LAMP: Warning SRT: | The Ready to Load output relay driver diagnostic has detected an error. | Any customer systems/features dependent on the Ready to Load output will not function correctly. No action is taken by the ECM. No loss of performance.
The Ready to Load Output Relay Driver Circuit

Circuit Description

The ECM checks the Ready to Load output relay driver to ensure correct operation. The ECM uses the Ready to Load output to inform any customer systems/features dependent on the ECM for knowledge of when the generator set is ready to pick up load.

Component Location

Refer to section E for location of the output for the Ready to Load.

Shop Talk

The possible failure modes are open circuit, short circuit, short to ground, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1491

Last Modified: 29-Jul-2010


Load Dump Output Relay Driver Diagnostic

FAULT CODE 1492

Load Dump Output Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1492 PID: FMI: LAMP: Warning SRT: | The Load Dump output relay driver diagnostic has detected an error. | Any customer system/features dependent on the Load Dump output will not function correctly. No action taken by ECM. No loss of performance.
The Load Dump Output Relay Driver Circuit

Circuit Description

The ECM checks the Load Dump output relay driver to ensure correct operation. The ECM uses the Load Dump output to inform any customers/feature dependent on the ECM for knowledge of when the generator set has to dump a load. The ECM monitors the voltage (no voltage increase will trip Fault Code 1492) caused by short circuits, open circuits, or failed Load Dump output relay driver in the ECM.

Component Location

Refer to Section E for location of the output for the Load Dump.

Shop Talk

Possible failure modes are open circuits, short circuits, short to ground, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1492

Last Modified: 03-Nov-2011


Operator Interface Panel Power Relay Driver Diagnostic

FAULT CODE 1493

Operator Interface Panel Power Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1493 PID: FMI: LAMP: Warning SRT: | Operator interface panel power relay driver diagnostic has detected an error. | Operator interface panel will not function correctly. No action taken by ECM. No loss of performance.
Operator Interface Panel Power Relay Driver Circuit

Circuit Description

The ECM checks the operator interface panel power relay driver to ensure correct operation. The ECM uses the operator interface panel to inform the operator about generator set operation, performance, setup, and diagnostics. The ECM monitors the voltage (no voltage increase will trip Fault Code 1493) caused by short circuits, open circuits, or failed operator interface panel power relay driver in the ECM.

Component Location

Refer to section E for location of the operator interface panel.

Shop Talk

Possible failure modes are open circuits, short circuits, short to ground, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1493

Last Modified: 29-Jul-2010


Modem Power Relay Driver Diagnostic

FAULT CODE 1494

Modem Power Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1494 PID: FMI: LAMP: Warning SRT: | Modem power relay driver diagnostic has detected an error. | Modem will not function correctly. No action taken by ECM. No loss of performance.
Modem Power Relay Driver Circuit

Circuit Description

The ECM checks the modem power relay driver to ensure correct operation. The ECM uses the modem to inform a remote operator about generator set operation, performance, setup, and diagnostics. The ECM monitors the voltage (no voltage increase will trip Fault Code 1494) caused by short circuits, open circuits, or failed modem power relay driver in the ECM.

Component Location

Refer to site documentation for location of the modem.

Shop Talk

Possible failure modes are open circuits, short circuits, short to ground, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1494

Last Modified: 29-Jul-2010


Common Shutdown Output Relay Driver Diagnostic

FAULT CODE 1495

Common Shutdown Output Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1495 PID: FMI: LAMP: Warning SRT: | The Common Shutdown output relay driver diagnostic has detected an error. | Any customer features dependent on Common Shutdown output will not function correctly. No action taken by ECM. No loss of performance.
Common Shutdown Output Relay Driver Circuit

Circuit Description

The ECM checks the common shutdown output relay driver to ensure correct operation. The ECM uses common shutdown output to inform any customer/features dependent on the ECM for knowledge of a critical fault with the generator set. The ECM monitors the voltage (no voltage increase will trip Fault Code 1495) caused by short circuits, open circuits, or failed common shutdown output relay driver in the ECM.

Component Location

Refer to section E for location of the output for the common shutdown.

Shop Talk

Possible failure modes are open circuits, short circuits, short to ground, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1495

Last Modified: 29-Jul-2010


Auto Mode Output Relay Driver Diagnostic

FAULT CODE 1496

Auto Mode Output Relay Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1496 PID: FMI: LAMP: Warning SRT: | The Auto Mode output relay driver diagnostic has detected an error. | Any customer features dependent on Auto Mode output will not function correctly. No action taken by ECM. No loss of performance.
Auto Mode Output Relay Driver Circuit

Circuit Description

The ECM checks the Auto Mode output relay driver to ensure correct operation. The ECM uses the Auto Mode output to inform any customer/features dependent on the ECM for knowledge of when the generator set is running.The ECM monitors the voltage (no voltage increase will trip Fault Code 1496) caused by short circuits, open circuits, or failed Auto Mode output relay driver in the ECM.

Component Location

Refer to Section E for location of the output Auto Mode.

Shop Talk

When the control is in auto mode, the circuit will provide B positive (+) voltage. When the control is not in auto mode, the circuit will be open. Possible failure modes are short circuits, short to ground, and loss of supply voltage inside the ECM.

Refer to Troubleshooting Fault Code t05-1496

Last Modified: 29-Jul-2010


Manual Run/Stop LED Driver Diagnostic

FAULT CODE 1497

Manual Run/Stop LED Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1497 PID: FMI: LAMP: Warning SRT: | Switch panel Manual Run/Stop LED driver diagnostic has detected an error. | The Manual Run/Stop LED will not function correctly. No action taken by ECM. No loss of performance.
Manual Run/Stop LED Driver Circuit

Circuit Description

The ECM checks the to ensure correct operation. The ECM uses the Manual Run/Stop lamp to inform the operator if the generator set is in manual Run mode. The ECM monitors the voltage (no voltage drop will trip Fault Code 1497) caused by short circuits, open circuits, bad bulbs, or a failed Manual Run/Stop LED driver in the ECM.

Component Location

Refer to Section E for location of the switch panel, and the Manual Run/Stop lamp.

Shop Talk

Possible failure modes are open circuits, short to ground, burned-out bulb, and loss of supply voltage inside the ECM.

Proper diagnostic lamp operation can be verified by checking to see that the lamps briefly light when the ECM is powered up.

Refer to Troubleshooting Fault Code t05-1497

Last Modified: 29-Jul-2010


Exercise LED Driver Diagnostic

FAULT CODE 1498

Exercise LED Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1498 PID: FMI: LAMP: Warning SRT: | Switch panel Exercise LED driver diagnostic has detected an error. | The Exercise LED will not function correctly. No action taken by ECM. No loss of performance.
Exercise LED Driver Circuit

Circuit Description

The ECM checks the Exercise LED driver to ensure correct operation. The ECM uses Exercise lamp to inform the operator if the generator set is in exercise mode.

Component Location

Refer to section E for location of the switch panel, and Exercise lamp.

Shop Talk

Possible failure modes are open circuits, short to ground, burned-out LED, and loss of supply voltage inside the ECM.

Proper diagnostic lamp operation can be verified by checking to see that the lamps briefly light when the ECM is powered up.

Refer to Troubleshooting Fault Code t05-1498

Last Modified: 29-Jul-2010


Remote Start LED Driver Diagnostic

FAULT CODE 1499

Remote Start LED Driver Diagnostic

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1499 PID: FMI: LAMP: Warning SRT: | Switch panel Remote Start LED driver diagnostic has detected an error. | The Remote Start LED will not function correctly. No action taken by ECM. No loss of performance.
Remote Start LED Driver Circuit

Circuit Description

The ECM checks the Remote Start LED driver to ensure correct operation. The ECM uses the Remote Start lamp to inform the operator if the generator set is in Remote Start mode. The ECM monitors the voltage (no voltage drop will trip Fault Code 1499) caused by short circuits, open circuits, bad LED, or failed Remote Start LED driver in the ECM.

Component Location

Refer to section E for location of the switch panel and Remote Start lamp.

Shop Talk

Possible failure modes are open circuits, short to ground, burned - out LED, and loss of supply voltage inside the ECM.

Proper diagnostic lamp operation can be verified by checking to see that the lamps briefly light when the ECM is powered up.

Refer to Troubleshooting Fault Code t05-1499

Last Modified: 29-Jul-2010


Engine Coolant Temperature High - Critical

FAULT CODE 151

Engine Coolant Temperature High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: FMI: LAMP: Shutdown SRT: | Engine coolant temperature has exceeded the alarm (shutdown) threshold for high coolant temperature. | Engine will shut down. High engine temperature (HET) relay driver is energized.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low for more than 2 seconds, the ECM will log Fault Code 151.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Make sure the airflow through the radiator is not obstructed. The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-151

Last Modified: 29-Jul-2010


Engine Coolant Temperature Low - Warning

FAULT CODE 152

Engine Coolant Temperature Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 152 PID: FMI: LAMP: Warning SRT: | Engine coolant temperature has dropped below the warning threshold for low coolant temperature. | No action is taken by the ECM. No effect on performance.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is high for more than 2 seconds, the ECM will log Fault Code 152.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Make sure the airflow through the radiator is not obstructed.The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-152

Last Modified: 29-Jul-2010


Intake Manifold Temperature Sensor Number 1 Circuit - Shorted High

FAULT CODE 153

Intake Manifold Temperature Sensor Number 1 Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: FMI: LAMP: Warning SRT: | Engine intake manifold temperature sensor signal is shorted high. | No engine protection for the intake manifold air temperature. Possible white smoke.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is high, the ECM will log Fault Code 153. Voltage high can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-153

Last Modified: 29-Jul-2010


Intake Manifold Temperature Sensor Number 1 Circuit - Shorted Low

FAULT CODE 154

Intake Manifold Temperature Sensor Number 1 Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: FMI: LAMP: Warning SRT: | Engine intake manifold temperature sensor signal is shorted low. | No engine protection for the intake manifold temperature.Possible white smoke.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold downstream of the aftercooler element. The intake manifold temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low, the ECM will log Fault Code 154. Low voltage can be caused by shorts to engine block ground on the supply or return wires or an internally grounded failed sensor.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-154

Last Modified: 29-Jul-2010


Intake Manifold Temperature Number 1 High - Critical

FAULT CODE 155

Intake Manifold Temperature Number 1 High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: FMI: LAMP: Shutdown SRT: | Engine intake manifold air temperature has exceeded the alarm (shutdown) threshold for high intake manifold temperature. | Engine will shut down. High engine temperature (HET) relay driver is energized
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low, the ECM will log Fault Code 155. Low voltage can be caused by a cooling system failure or an in-range sensor failure.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-155

Last Modified: 29-Jul-2010


Intake Manifold Temperature Sensor Number 2 Circuit - Shorted High

FAULT CODE 159

Intake Manifold Temperature Sensor Number 2 Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 159 PID: FMI: LAMP: Warning SRT: | Engine intake manifold temperature sensor signal is shorted high. | No engine protection for the intake manifold air temperature. Possible white smoke.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor Number 2 is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor Number 2 is used by the ECM for the timing and fueling control. If the voltage is high, the ECM will log Fault Code 159. Voltage high can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-159

Last Modified: 29-Jul-2010


Intake Manifold Temperature Sensor Number 2 Circuit - Shorted Low

FAULT CODE 161

Intake Manifold Temperature Sensor Number 2 Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 161 PID: FMI: LAMP: Warning SRT: | Engine intake manifold temperature sensor signal is shorted low. | No engine protection for the intake manifold temperature. Possible white smoke.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor Number 2 is used by the ECM to monitor the temperature of the air in the intake manifold downstream of the aftercooler element. The intake manifold temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low, the ECM will log Fault Code 161. Low voltage can be caused by shorts to engine block ground on the supply or return wires or an internally grounded failed sensor.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-161

Last Modified: 29-Jul-2010


Fuel Rack Actuator Position 1 Circuit - Open Circuit (Left Bank)

FAULT CODE 168

Fuel Rack Actuator Position 1 Circuit - Open Circuit (Left Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 168 PID: FMI: LAMP: Shutdown SRT: | Fuel rack actuator position 1 circuit - open circuit (left bank). | Engine can possibly shut down due to an overspeed condition. Fault Code 171 can also activate.
Fuel Rack Actuator Position 1 Circuit

Circuit Description

The fuel rack actuators are actuated by the ECM to control fuel metering. Each rack actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the rack actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering. This test checks to see that the current being supplied from the ECM to the actuator is being fed back to the ECM on the return circuit.

Component Location

The fuel rack actuator position 1 is part of the left bank fuel pump.

Shop Talk

The possible failure modes for this fault are an open circuit or short to ground on the fuel rack actuator PWM 1 supply circuit or an open circuit or short to battery supply on the fuel rack actuator PWM 1 return circuit.

This fault requires engine speed greater than zero before the fault will go active. If fuel rack position is being monitored, the right rack position will be roughly twice that of the left rack position. If the engine logs a Fault Code 234 (engine overspeed) and a Fault Code 168, troubleshoot Fault Code 168 first.

Fault Code 171 can go active after Fault Code 168 is corrected. If this is the case, key off and Fault Code 171 will go inactive and can be cleared.

Refer to Troubleshooting Fault Code t05-168

Last Modified: 29-Jul-2010


Fuel Rack Actuator Position 1 Circuit - Short Circuit (Left Bank)

FAULT CODE 169

Fuel Rack Actuator Position 1 Circuit - Short Circuit (Left Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 169 PID: FMI: LAMP: Shutdown SRT: | Fuel rack actuator position 1 circuit - short circuit (left bank). | Engine can possibly shut down due to an overspeed. Fault Code 2974 can also activate
Fuel Rack Actuator Position 1 Circuit

Circuit Description

The fuel rack actuators are actuated by the ECM to control fuel metering. Each rack actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the rack actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering. This test checks to see that the current being supplied from the ECM to the actuator is being fed back to the ECM on the return circuit.

Component Location

The rack actuator is part of the left bank fuel pump.

Shop Talk

This fault requires engine speed greater than zero before the fault will go active

The possible failure modes are low actuator resistance or the fuel rack actuator PWM 1 supply shorted to battery.

This fault code procedure also provides for troubleshooting when the fuel rack actuator PWM 1 return is shorted to ground. This type of failure will not cause a fault code at this time, but will cause the engine to run rough.

If Fault Code 2974 and Fault Code 169 are active, troubleshoot Fault Code 169 first.

Refer to Troubleshooting Fault Code t05-169

Last Modified: 29-Jul-2010


Fuel Rack Actuator Position 1 Circuit - Data Incorrect (Left Bank)

FAULT CODE 171

Fuel Rack Actuator Position 1 Circuit - Data Incorrect (Left Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 171 PID: FMI: LAMP: Warning SRT: | Fuel rack actuator position 1 circuit - data incorrect (left bank). | Performance can be sluggish or slow to respond.
Fuel Rack Actuator Position 1 Circuit

Circuit Description

The fuel rack position sensor circuit's measured, reference and common signals are used by the ECM to verify that the rack has been properly positioned by the rack actuator. This fault code indicates that either the rack is mechanically stuck, or the rack position sensor data is incorrect. This is accomplished as follows:

The ECM sends out a fixed frequency and voltage signal on the reference signal line to the fuel pump. The ECM also sends out a fixed frequency but variable voltage signal that is 180 degrees out of phase from the reference signal from the measured signal line to the fuel pump. The amplitude of the measured signal voltage is measured in the ECM and represents the rack position of the fuel pump.

Circuitry inside the fuel pump compares the difference in voltage between the reference signal input and the measured signal input to the pump and sends a signal back to the ECM that is the difference of these two signals. The difference voltage signal is output on the common signal line back to the ECM. The amplitude of the common signal is dependent on the position of the rack inside the fuel pump. Circuitry inside the ECM determines if the common signal is below a certain threshold. If it is, this means that the rack position of the fuel pump is at the commanded position. The voltage value of the measured signal line is then measured by the ECM and represents the rack position.

Component Location

The fuel pump rack, rack actuator, and rack position sensor are all located within the fuel pump.

This fault code requires engine speed greater than zero before the fault will go active.

Shop Talk

The possible failure modes are rack mechanically stuck, rack position sensor stuck in range, rack position sensor out of calibration, or bad fuel pump.

This fault code requires engine speed greater than zero before the fault will go active.

Fault Code 171 can go active after Fault Code 168 is corrected. If this is the case, key off and Fault Code 171 will go inactive and can be cleared

Refer to Troubleshooting Fault Code t05-171

Last Modified: 29-Jul-2010


Fuel Rack Actuator Position 2 Circuit - Data Incorrect (Right Bank)

FAULT CODE 174

Fuel Rack Actuator Position 2 Circuit - Data Incorrect (Right Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 174 PID: FMI: LAMP: Warning SRT: | Fuel Rack Actuator Position 2 Circuit - data incorrect (right bank). | Performance can be sluggish or slow to respond.
Fuel Rack Actuator Position 2 Circuit

Circuit Description

The fuel rack position sensor circuit's measured, reference and common signals are used by the ECM to verify that the rack has been properly positioned by the rack actuator. This fault code indicates that either the rack is mechanically stuck, or the rack position sensor data is incorrect. This is accomplished as follows:

The ECM sends out a fixed frequency and voltage signal on the reference signal line to the fuel pump. The ECM also sends out a fixed frequency but variable voltage signal that is 180 degrees out of phase from the reference signal from the measured signal line to the fuel pump. The amplitude of the measured signal voltage is measured in the ECM and represents the rack position of the fuel pump.

Circuitry inside the fuel pump compares the difference in voltage between the reference signal input and the measured signal input to the pump and sends a signal back to the ECM that is the difference of these two signals. The difference voltage signal is output on the common signal line back to the ECM. The amplitude of the common signal is dependent on the position of the rack inside the fuel pump. Circuitry inside the ECM determines if the common signal is below a certain threshold. If it is, this means that the rack position of the fuel pump is at the commanded position. The voltage value of the measured signal line is then measured by the ECM and represents the rack position.

Component Location

The fuel pump rack, rack actuator, and rack position sensor are all located within the fuel pump.

Shop Talk

The possible failure modes are rack mechanically stuck, rack position sensor stuck in range, rack position sensor out of calibration, or bad fuel pump.

This fault code requires engine speed greater than zero before the fault will go active.

Fault Code 174 will go active after Fault Code 183 is corrected. If this is the case, key off and Fault Code 174 will go inactive and can be cleared.

Refer to Troubleshooting Fault Code t05-174

Last Modified: 29-Jul-2010


Fuel Rack Actuator Position 2 Circuit - Short Circuit (Right Bank)

FAULT CODE 182

Fuel Rack Actuator Position 2 Circuit - Short Circuit (Right Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 182 PID: FMI: LAMP: Shutdown SRT: | Fuel rack actuator position 2 circuit - short circuit (right bank). | Engine can possibly shut down due to an overspeed. Fault Code 2975 can possibly also activate.
Fuel Rack Actuator Position 2 Circuit

Circuit Description

The fuel rack actuators are actuated by the ECM to control fuel metering. Each rack actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the rack actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering. This test checks to see that the current being supplied from the ECM to the actuator is being fed back to the ECM on the return circuit.

Component Location

The rack actuator is part of the right bank fuel pump.

Shop Talk

This fault requires engine speed greater than zero before the fault will go active.

The possible failure modes are low actuator resistance or the fuel rack actuator PWM2 supply shorted to battery.

This fault code procedure also provides for troubleshooting when the fuel rack actuator PWM2 return is shorted to ground. This type of failure will not cause a fault code at this time, but will cause the engine to run rough.

If Fault Code 2975 and Fault Code 182 are active, troubleshoot Fault Code 182 first.

Refer to Troubleshooting Fault Code t05-182

Last Modified: 29-Jul-2010


Fuel Rack Actuator Position 2 Circuit - Open Circuit (Right Bank)

FAULT CODE 183

Fuel Rack Actuator Position 2 Circuit - Open Circuit (Right Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 183 PID: FMI: LAMP: Shutdown SRT: | Fuel rack actuator position 2 circuit - open circuit (right bank). | Engine can shut down due to an overspeed. Fault Code 174 can also activate.
Fuel Rack Actuator Position 2 Circuit

Circuit Description

The fuel rack actuators are actuated by the ECM to control fuel metering. Each rack actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the rack actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering. This test checks to see that the current being supplied from the ECM to the actuator is being fed back to the ECM on the return circuit.

Component Location

The fuel rack actuator position 2 is part of the right bank fuel pump.

Shop Talk

The possible failure modes for this fault are an open circuit or short to ground on the fuel rack actuator PWM 2 supply circuit or an open circuit or short to battery supply on the fuel rack actuator PWM 2 return circuit.

This fault requires engine speed greater than zero before the fault will go active. If fuel rack position is being monitored, the right rack position will be roughly twice that of the left rack position. If the engine logs a Fault Code 234 (engine overspeed) and a Fault Code 168, troubleshoot Fault Code 183 first.

Fault Code 174 can go active after Fault Code 183 is corrected. If this is the case, key off and Fault Code 174 will go inactive and can be cleared.

Refer to Troubleshooting Fault Code t05-183

Last Modified: 29-Jul-2010


Engine Coolant Level Low - Warning

FAULT CODE 197

Engine Coolant Level Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: FMI: LAMP: Warning SRT: | Engine coolant level low - warning. Voltage signal indicates low radiator coolant level. | No action is taken by the ECM. Fault Codes 146, 151, 228, and/or 233 can also be logged.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM).

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

  • When the coolant level drops below a certain level, a power derate will be activated, which will decrease the power output by 50 percent over a 30-second period.
  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly, the coolant level switch high signal must be shorted to the coolant level switch supply, and the coolant level switch low signal must be shorted to the coolant level switch return.
  • Inspect the wiring harness between the four-way connector and the coolant level sensor for damage.
Refer to Troubleshooting Fault Code t05-197

Last Modified: 29-Jul-2010


Aftercooler Water Inlet Temperature Sensor - Shorted High

FAULT CODE 2111

Aftercooler Water Inlet Temperature Sensor - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2111 PID: FMI: LAMP: Warning SRT: | Engine coolant temperature 2 sensor circuit - shorted high. This was formerly called the aftercooler water inlet temperature sensor. | No engine protection for aftercooler water inlet temperature.
Aftercooler Water Inlet Temperature Sensor Circuit

Circuit Description

The aftercooler water inlet temperature sensor is used by the electronic control module (ECM) to monitor the ability of the engine cooling system to cool down the engine coolant. The aftercooler water inlet temperature is used by the ECM for the engine protection system. The ECM monitors the voltage on the aftercooler water inlet temperature signal pin and expects to see a voltage vary between 0.5 to 4.5 VDC during normal engine operation. High voltage will trip Fault Code 2111 and can be caused by shorts in the signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to Procedure 100-002 for the component location.

Shop Talk

The possible failure modes are open circuit, short to battery positive (+), failed sensor, and loss of supply voltage inside the ECM. The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-2111

Last Modified: 29-Jul-2010


Aftercooler Water Inlet Temperature Sensor - Shorted Low

FAULT CODE 2112

Aftercooler Water Inlet Temperature Sensor - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2112 PID: FMI: LAMP: Warning SRT: | Engine coolant temperature 2 sensor circuit - shorted low. This was formerly called the aftercooler water inlet temperature sensor. | No engine protection for aftercooler water inlet temperature.
Aftercooler Water Inlet Temperature Sensor Circuit

Circuit Description

The aftercooler water inlet temperature sensor is used by the electronic control module (ECM) to monitor the ability of the engine cooling system to cool down the engine coolant. The aftercooler water inlet temperature is used by the ECM for the engine protection system. The ECM monitors the voltage on the aftercooler water inlet temperature signal pin and expects to see a voltage vary between 0.5 and 4.5 VDC during normal engine operation. Low voltage will trip Fault Code 2112 and can be caused by shorts in the signal, or return wires, an open in the signal wire, or a failed sensor.

Component Location

Refer to Procedure 100-002 for the component location.

Shop Talk

The possible failure modes are open circuit, short to ground, failed sensor, and loss of supply voltage inside the ECM. The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-2112

Last Modified: 29-Jul-2010


Aftercooler Water Inlet Temperature High - Warning

FAULT CODE 2113

Aftercooler Water Inlet Temperature High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2113 PID: FMI: LAMP: Warning SRT: | Engine coolant temperature 2 high - warning. Voltage signal indicates aftercooler water inlet temperature has exceeded the warning threshold for high aftercooler water inlet temperature. | Calibration-dependent. No action is taken by the ECM, or engine shutdown.
Aftercooler Water Inlet Temperature Sensor Circuit

Circuit Description

The aftercooler water inlet temperature sensor is used by the electronic control module (ECM) to monitor the ability of the engine cooling system to cool down the engine coolant. The aftercooler water inlet temperature value is used by the ECM for the engine protection system. The ECM monitors the voltage on the aftercooler water inlet temperature signal pin and expects to see a voltage vary between 0.5 and 4.5 VDC during normal engine operation.

Component Location

Refer to Procedure 100-002 for the component location.

Shop Talk

Make sure that the water inlet flow is not restricted. The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-2113

Last Modified: 29-Jul-2010


Aftercooler Water Inlet Temperature High - Critical

FAULT CODE 2114

Aftercooler Water Inlet Temperature High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2114 PID: FMI: LAMP: Shutdown SRT: | Engine coolant temperature 2 high - critical. Voltage signal indicates aftercooler water inlet temperature has exceeded the shutdown threshold for high aftercooler water inlet temperature. | Engine will shut down.
Aftercooler Water Inlet Temperature Sensor Circuit

Circuit Description

The aftercooler water inlet temperature sensor is used by the electronic control module (ECM) to monitor the ability of the engine cooling system to cool down the engine coolant. The aftercooler water inlet temperature value is used by the ECM for the engine protection system. The ECM monitors the voltage on the aftercooler water inlet temperature signal pin and expects to see a voltage vary between 0.5 and 4.5 VDC during normal engine operation.

Component Location

Refer to Procedure 100-002 for the component location.

Shop Talk

Make sure that the water inlet flow is not restricted. The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-2114

Last Modified: 29-Jul-2010


Engine Oil Temperature Sensor Circuit - Shorted High

FAULT CODE 212

Engine Oil Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: FMI: LAMP: Warning SRT: | Engine oil temperature sensor signal is shorted high. | No engine protection for oil temperature. No effect on performance.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and the engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-212

Last Modified: 29-Jul-2010


Engine Oil Temperature Sensor Circuit - Shorted Low

FAULT CODE 213

Engine Oil Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: FMI: LAMP: Warning SRT: | Engine oil temperature sensor signal is shorted low. | No engine protection for the oil temperature. No effect on performance.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and engine protection is enabled, a derate condition will be incurred, possibly leading to shutdown.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-213

Last Modified: 29-Jul-2010


Engine Oil Temperature High - Critical

FAULT CODE 214

Engine Oil Temperature High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: FMI: LAMP: Shutdown SRT: | Engine oil temperature has exceeded the alarm (shutdown) threshold for high oil temperature. | Engine will shut down.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is used by the ECM to monitor the temperature of the engine oil. If the oil temperature becomes too high and engine protection is enabled, a derate condition will be incurred, possibly leading to shutdown.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-214

Last Modified: 29-Jul-2010


Low Oil Level Detected in Centinel™ Make Up Tank

FAULT CODE 219

Low Oil Level Detected in Centinel™ Make Up Tank

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 219 PID: P17 SPN: 1380 FMI: LAMP: Warning SRT: | Engine oil level 2 (remote) low - maintenance. Low oil level is detected in the remote oil reservoir used in the Centinel™ system. | Centinel™ system is deactivated.
ECM

Circuit Description

The oil make up tank provides clean oil to the make up valve of the Centinel™ system to replenish oil that was burned by the Centinel™ system.

Component Location

Varies by installation. Refer to Centinel™ Master Repair Manual 3666231 for further information.

Shop Talk

This fault indicates that the oil is low in the makeup tank.

Refer to Troubleshooting Fault Code t05-219

Last Modified: 29-Jul-2010


Barometric Pressure Sensor Circuit - Shorted High

FAULT CODE 221

Barometric Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: FMI: LAMP: Warning SRT: | Barometric pressure sensor circuit - shorted high. | No action is taken by the ECM. Possible loss of performance.
Barometric Pressure Sensor Circuit

Circuit Description

This troubleshooting tree is intended for troubleshooting absolute pressure sensors only. The barometric pressure sensor monitors barometric pressure and passes information to the electronic control module (ECM). The ECM uses the barometric pressure sensor to adjust fueling based on the altitude.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Monitor the barometric pressure reading with an electronic service tool to confirm that the pressure reading matches the actual air pressure.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

The following shows the typical PSIA pressure values for the corresponding altitude values:

Altitude (ft) | PSIA
0 | 14.45
3000 | 13.17
6000 | 11.78
9000 | 10.50
12000 | 9.35
Refer to Troubleshooting Fault Code t05-221

Last Modified: 29-Jul-2010


Barometric Pressure Sensor Circuit - Shorted Low

FAULT CODE 222

Barometric Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: FMI: LAMP: Warning SRT: | Barometric pressure sensor is shorted low. | No engine protection for barometric pressure. Possible loss of performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor provides the barometric air pressure signal to the electronic control module (ECM). The ECM uses the barometric pressure sensor to adjust fueling based on the altitude.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Monitor the barometric pressure reading with an electronic service tool to confirm that the pressure reading matches the actual air pressure.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-222

Last Modified: 29-Jul-2010


Centinel™ Burn Valve Solenoid Circuit - Voltage Incorrect

FAULT CODE 223

Centinel™ Burn Valve Solenoid Circuit - Voltage Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: S85 SPN: 1265 FMI: 4 LAMP: Yellow SRT: | The Centinel™ burn valve solenoid circuit is open or shorted. Less than 18.0 VDC detected at the Centinel™ burn valve solenoid supply pin of the engine harness or resistance of the solenoid has dropped below 80 ohms. | ECM turns off the burn valve supply voltage and the Centinel™ system is disabled.
Burn Valve Solenoid Circuit

Circuit Description

The burn valve solenoid controls the flow of oil in the oil control valve during the burn cycle.

Component Location

The burn valve solenoid is located on top of the oil control valve.

Refer to Troubleshooting Fault Code t05-223

Last Modified: 29-Jul-2010


Engine Coolant Pressure Low - Critical

FAULT CODE 228

Engine Coolant Pressure Low - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 228 PID: FMI: LAMP: Shutdown SRT: | Engine coolant pressure low - critical. Voltage signal indicates coolant pressure has dropped below the shutdown threshold for low coolant pressure. | Engine will shut down.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the electronic control module (ECM) to monitor coolant pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The coolant pressure value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Confirm that the coolant pressure sensor supply voltage is between 4.75 and 5.25 VDC at the sensor. See Fault Code 232.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

NOTE: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-228

Last Modified: 29-Jul-2010


Fuel Supply Pump Driver Diagnostic has Detected an Error

FAULT CODE 2297

Fuel Supply Pump Driver Diagnostic has Detected an Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2297 PID: FMI: LAMP: Warning SRT: | Fuel supply pump driver diagnostic has detected an error. | Priming pump is disabled. Possible loss of performance.
Fuel Supply Circuit

Circuit Description

The priming pumps supply fuel to the left and right bank fuel pumps through the fuel filter. The ECM activates the priming pumps at start up while the engine is cranking to prime the left and right bank fuel pumps for the engine to start.

Component Location

Refer to Procedure 100-002 for the component location. There is one fuel lift pump housing that contains dual lift pumps. The housing is located on the right bank of the engine above the flywheel and next to the fuel filter.

Shop Talk

This fault code is caused by a short circuit in the harness or priming pump. It can also be caused by a failed ECM.

This fault code will only go active when the engine is cranking or running. To clear the fault code, the fail mode needs to be fixed and the engine will have to crank again to clear.

The service tool can be used to enable the fuel pump and check the fuel supply pressure as a system check.

Refer to Troubleshooting Fault Code t05-2297

Last Modified: 29-Jul-2010


Engine Coolant Pressure Sensor Circuit - Shorted High

FAULT CODE 231

Engine Coolant Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: FMI: LAMP: Warning SRT: | Engine coolant pressure sensor circuit - shorted high. | No engine protection for coolant pressure.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor monitors coolant pressure and passes information to the electronic control module (ECM). High voltage will trip Fault Code 231 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Confirm that the radiator cap is installed correctly.

Check the radiator cap for proper operation.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-231

Last Modified: 29-Jul-2010


Coolant Pressure Sensor Circuit - Shorted Low

FAULT CODE 232

Coolant Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 232 PID: FMI: LAMP: Warning SRT: | Engine coolant pressure sensor circuit - shorted low. | No engine protection for coolant pressure.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor monitors coolant pressure and passes information to the engine control module (ECM). Low voltage will trip Fault Code 232 and can be caused by shorts in the supply, signal, or return wires, an open in the return wires, or a failed sensor.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Confirm that the radiator cap is installed correctly.

Check the radiator cap for proper operation.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Reference specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-232.

Last Modified: 08-May-2012


Coolant Pressure - Engine Protection

FAULT CODE 233

Coolant Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 233 PID: FMI: LAMP: Warning SRT: | Engine coolant pressure low - warning. Voltage signal indicates coolant pressure has dropped below the warning threshold for low coolant pressure. | Calibration-dependent engine shutdown occurs, or not action is taken by ECM.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the electronic control module (ECM) to monitor coolant pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The coolant pressure value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Confirm that the coolant sensor supply is between 4.75 and 5.25 VDC at the sensor. See Fault Code 232.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

NOTE: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-233

Last Modified: 29-Jul-2010


Engine Speed High - Critical

FAULT CODE 234

Engine Speed High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: FMI: LAMP: Shutdown SRT: | Engine speed signals indicate an engine speed greater than shutdown threshold. | Engine will shut down. Fuel shutoff valves are de-energized (valves close). Overspeed relay driver is energized.
Engine Overspeed

Circuit Description

The engine position sensor(s) monitor the engine position and the engine speed. It then passes this information to the electronic control module (ECM) through the engine harness.

Component Location

Use the following procedure for component location.Refer to Procedure 100-002 for the component location.

Shop Talk

Possible causes of this fault code include external fuel sources drawn into the intake air passage, reverse powering (motoring) of the engine, or tampering of the engine speed/position sensors. Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-234

Last Modified: 29-Jul-2010


Engine Coolant Level Low - Critical

FAULT CODE 235

Engine Coolant Level Low - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: FMI: LAMP: Shutdown SRT: | Engine coolant level has dropped below the shutdown threshold for low coolant level. | Engine will shut down.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the ECM.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

  • When the coolant level drops below a certain level, a power derate will be activated, which will decrease the power output by 50 percent over a 30-second period.
  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly. The coolant level switch high signal must be shorted to the coolant level switch supply and the coolant level switch low signal must be shorted to the coolant level switch return.
  • Inspect the wiring harness between the four-way connector and the coolant level sensor for damage.
Refer to Troubleshooting Fault Code t05-235

Last Modified: 29-Jul-2010


Engine Speed/Position Sensor Circuit - Loss of Signal

FAULT CODE 236

Engine Speed/Position Sensor Circuit - Loss of Signal

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 236 PID: FMI: LAMP: Shutdown SRT: | Engine speed/position sensors signal is not detected. | Engine will shut down.
Engine Speed/Position Sensor Circuits

Circuit Description

The crankshaft and camshaft engine position sensor provides engine speed and position information to the electronic control module (ECM) through the engine harness.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Possible causes of this fault code include damaged camshaft engine position sensor, open or shorted circuit, and power supply voltage failure.

Refer to Troubleshooting Fault Code t05-236

Last Modified: 29-Jul-2010


Engine Oil Level Number 1 Sensor - Data Incorrect

FAULT CODE 252

Engine Oil Level Number 1 Sensor - Data Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 252 PID: FMI: LAMP: Warning SRT: | Engine oil level Number 1 sensor circuit - data incorrect. | No engine protection for low oil level. Centinel system is disabled.
Oil Level Sensor Circuit

Circuit Description

The lubricating oil level sensor is used by the ECM to monitor the amount of oil in the engine. Low oil level detected can cause the engine protection system to shut down the engine.

Component Location

The lubricating oil level sensor is in the engine oil pan.

Refer to Troubleshooting Fault Code t05-252

Last Modified: 29-Jul-2010


Engine Oil Level Number 1 Low - Critical

FAULT CODE 253

Engine Oil Level Number 1 Low - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 253 PID: FMI: LAMP: Shutdown SRT: | Engine oil level has dropped below the shutdown threshold for low oil level. | Engine will shut down.
Oil Level Sensor Circuit

Circuit Description

The oil level sensor monitors the oil level within the oil system and passes information to the ECM. Low oil level can cause the engine to not start.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

Some engine configurations will use a 3-pin oil level sensor and others will use a 4-pin oil level sensor.

Refer to Troubleshooting Fault Code t05-253

Last Modified: 29-Jul-2010


Fuel Shutoff Valve Circuit - Shorted Low

FAULT CODE 254

Fuel Shutoff Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: FMI: LAMP: Shutdown SRT: | Fuel shutoff valve circuit - shorted low. Low voltage detected at the fuel shutoff valve signal pin or the resistance of the solenoid has dropped below specified threshold. | The engine will shut down.
Fuel Shutoff Valve Solenoid Circuit

Circuit Description

The fuel shutoff valve solenoid is a device used by the electronic control module (ECM) to control the engine fuel supply. The ECM can shut down the engine by cutting off the power to the fuel shutoff valve solenoid.

Component Location

Refer to the Engine Diagrams (Procedure 100-002) in Section E of this manual for the component location.

Shop Talk

Inspect the fuel shutoff supply circuit for external wires that are, perhaps, spliced in to power another device. Remove any extra wires that are found in the circuit. If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not failed and lowered the voltage on the fuel shutoff circuit. Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, dry conductive surface. Check the starter solenoid positive (+) terminal for a loose connector or accessory wiring with damaged insulation.

Refer to Troubleshooting Fault Code t05-254

Last Modified: 29-Jul-2010


Engine Gear Box Oil Pressure Low - Critical

FAULT CODE 2561

Engine Gear Box Oil Pressure Low - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2561 FMI: LAMP: Shutdown SRT: | Voltage signal indicates the engine gear box oil pressure has dropped below the shutdown threshold for low engine gear box oil pressure. | Generator set will shutdown.
Engine Gear Box Oil Pressure Sensor Circuit

Circuit Description

The engine gear box oil pressure sensor is a switch type sensor. After the pressure drops below the switch point, the sensor will close the circuit. This closed circuit will cause the LonWorks digital input module to send a signal on the LonWorks network to the generator set ECM indicating an engine gear box oil pressure low - critical condition exists.

Component Location

The engine gear box oil pressure sensor is located on the gear box.

Shop Talk

This fault can be caused by a low pressure condition, or a short circuit in the engine gear box oil pressure switch to digital input module circuit. Both pressure of the gearbox oil and a check for a short circuit must be performed to troubleshoot this fault.

Refer to Troubleshooting Fault Code t05-2561

Last Modified: 29-Jul-2010


Engine Gear Box Oil Temperature High - Critical

FAULT CODE 2562

Engine Gear Box Oil Temperature High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2562 FMI: LAMP: Shutdown SRT: | Voltage signal indicates the engine gear box oil temperature has exceeded the shutdown threshold for high engine gear box oil temperature. | Generator set will shutdown.
Engine Gear Box Oil Temperature Sensor Circuit

Circuit Description

The engine gear box oil temperature sensor is a switch type sensor. After the temperature increases above the switch point, the sensor will close the circuit. This closed circuit will cause the LonWorks digital input module to send a signal on the LonWorks network to the generator set ECM indicating an engine gear box oil temperature high - critical condition exists.

Component Location

The engine gear box oil temperature sensor is located on the gear box.

Shop Talk

This fault code can be caused by a high temperature condition, or a short circuit in the engine gear box oil temperature switch to digital input module circuit. Both temperature of the gear box oil and a check for a short circuit must be performed to troubleshoot this fault.

Refer to Troubleshooting Fault Code t05-2562

Last Modified: 29-Jul-2010


Fuel Shutoff Valve - Stuck Open

FAULT CODE 259

Fuel Shutoff Valve - Stuck Open

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 259 PID: FMI: LAMP: Warning SRT: | Fuel shutoff valve - stuck open. | No action is taken by the electronic control module (ECM). Possible engine slow shutdown.
Fuel Shutoff Valve Solenoid Circuit

Circuit Description

Voltage is supplied to the fuel shutoff valve by the ECM while the Run/Stop switch is in the Run position and engine speed is equal to crank. Upon placing the Run/Stop switch in the Stop position, the voltage to the fuel shutoff valve solenoid is turned off by the ECM. The fuel shutoff valve closes and stops fuel from flowing to the fueling and timing actuators.

Component Location

Refer to the Engine Diagrams (Procedure 100-002) in Section E of this manual for the component location.

Shop Talk

With the Run/Stop switch in the Stop position, the ECM turns off the voltage supplied to keep the fuel shutoff valve open. The ECM continues to fire the fueling and timing actuators as the engine spins down. The ECM monitors the engine speed. If the engine speed does not drop after the fuel shutoff valve solenoid is turned off, the ECM activates this fault.

Refer to Troubleshooting Fault Code t05-259

Last Modified: 29-Jul-2010


Fuel Temperature High - Warning

FAULT CODE 261

Fuel Temperature High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: FMI: LAMP: Warning SRT: | Engine fuel temperature has exceeded the warning threshold for high fuel temperature. | Calibration-dependent no action is taken by the ECM, or engine shutdown as temperature increases over thresholds.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-261

Last Modified: 29-Jul-2010


Fuel Temperature Sensor Circuit - Shorted to High Source

FAULT CODE 263

Fuel Temperature Sensor Circuit - Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: FMI: LAMP: Warning SRT: | Engine fuel temperature sensor signal is shorted high. | No engine protection for fuel temperature. No effect on performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is high, the ECM will log Fault Code 263. High voltage can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-263.

Last Modified: 26-Jan-2011


Fuel Temperature Sensor Circuit - Shorted Low

FAULT CODE 265

Fuel Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: FMI: LAMP: Warning SRT: | Engine fuel temperature sensor signal is shorted low. | No engine protection for fuel temperature. No effect on performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control. If the voltage is low, the ECM will log Fault Code 265. Low voltage can be caused by shorts to ground on the supply or return wires or an internally grounded, failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-265

Last Modified: 29-Jul-2010


Fuel Temperature High - Critical

FAULT CODE 266

Fuel Temperature High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 266 PID: FMI: LAMP: Shutdown SRT: | Engine fuel temperature has exceeded the shutdown threshold for high fuel temperature. | Engine will shut down.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel. The fuel temperature value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-266

Last Modified: 29-Jul-2010


Fuel Rack Position 1 Circuit - Root Cause Not Known (Left Bank)

FAULT CODE 2974

Fuel Rack Position 1 Circuit - Root Cause Not Known (Left Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2974 PID: FMI: LAMP: Warning SRT: | Fuel rack position 1 circuit - root cause not known (left bank). | Engine can possibly run rough or overspeed and shutdown.
Fuel Rack Position Sensor 1 Circuit

Circuit Description

The ECM uses this rack position measured signal to determine if the fuel rack is at the commanded position. This is accomplished as follows:

The ECM sends out a fixed frequency and voltage signal on the reference signal line to the fuel pump. The ECM also sends out a fixed frequency but variable voltage signal that is 180 degrees out of phase from the reference signal from the measured signal line to the fuel pump. The amplitude of the measured signal voltage is measured in the ECM and represents the rack position of the fuel pump.

Circuitry inside the fuel pump compares the difference in voltage between the reference signal input and the measured signal input to the pump and sends a signal back to the ECM that is the difference of these two signals. The difference voltage signal is output on the common signal line back to the ECM. The amplitude of the common signal is dependent on the position of the rack inside the fuel pump. Circuitry inside the ECM determines if the common signal is below a certain threshold. If it is, this means that the rack position of the fuel pump is at the commanded position. The voltage value of the measured signal line is then measured by the ECM and represents the rack position.

Component Location

The fuel rack position sensor 1 is located internal to the fuel pump on the left bank of the engine.

Shop Talk

The possible fail modes for this circuit are:

  • Short to battery on the rack position measured signal, common signal, reference signal circuits
  • Short pin to pin on the rack position measured signal, common signal, reference signal circuits
  • Short to ground on the rack position measured signal, common signal, reference signal circuits
  • Open circuit on the rack position measured signal, common signal, reference signal circuits
  • Bad fuel pump
  • Bad ECM.

This fault does not require engine speed to log a fault. The engine can overspeed and shut down. If Fault Code 234 (overspeed fault) and Fault Code 2974 are present, troubleshoot the Fault Code 2974 first. If you are monitoring the fuel rack position for the left bank, it will read zero millimeters (zero fueling).

If Fault Code 2974 and 169 are active, troubleshoot Fault Code 169 first.

Refer to Troubleshooting Fault Code t05-2974

Last Modified: 29-Jul-2010


Fuel Rack Position Sensor 2 Circuit - Shorted High (Right Bank)

FAULT CODE 2975

Fuel Rack Position Sensor 2 Circuit - Shorted High (Right Bank)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: PID: FMI: LAMP: Warning SRT: | Fuel rack position 2 circuit - root cause not known (right bank). | Engine can possibly run rough or overspeed and shutdown.
Fuel Rack Position Sensor 2 Circuit

Circuit Description

The ECM uses this rack position measured signal to determine if the fuel rack is at the commanded position. This is accomplished as follows:

The ECM sends out a fixed frequency and voltage signal on the reference signal line to the fuel pump. The ECM also sends out a fixed frequency but variable voltage signal that is 180 degrees out of phase from the reference signal from the measured signal line to the fuel pump. The amplitude of the measured signal voltage is measured in the ECM and represents the rack position of the fuel pump.

Circuitry inside the fuel pump compares the difference in voltage between the reference signal input and the measured signal input to the pump and sends a signal back to the ECM that is the difference of these two signals. The difference voltage signal is output on the common signal line back to the ECM. The amplitude of the common signal is dependent on the position of the rack inside the fuel pump. Circuitry inside the ECM determines if the common signal is below a certain threshold. If it is, this means that the rack position of the fuel pump is at the commanded position. The voltage value of the measured signal line is then measured by the ECM and represents the rack position.

Component Location

The fuel rack position sensor 2 is located internal to the fuel pump on the right bank of the engine.

Shop Talk

The possible fail modes for this circuit are:

  • Short to battery on the rack position measured signal, common signal, reference signal circuits
  • Short pin to pin on the rack position measured signal, common signal, reference signal circuits
  • Short to ground on the rack position measured signal, common signal, reference signal circuits
  • Open circuit on the rack position measured signal, common signal, reference signal circuits
  • Bad fuel pump
  • Bad ECM.

This fault does not require engine speed to log a fault. The engine can overspeed and shut down. If Fault Code 234 (overspeed fault) and Fault Code 2975 are present, troubleshoot the Fault Code 2975 first. If you are monitoring the fuel rack position for the right bank, it will read zero millimeters (zero fueling).

If Fault Code 2975 and 182 are active, troubleshoot Fault Code 182 first.

Refer to Troubleshooting Fault Code t05-2975

Last Modified: 29-Jul-2010


Fuel Supply Pump Actuator - Shorted High

FAULT CODE 316

Fuel Supply Pump Actuator - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 316 PID: FMI: LAMP: Warning SRT: | Fuel supply pump actuator circuit - shorted high. Fuel pump actuator circuit is open, the fuel pump actuator signal pin is shorted to battery voltage or ground, or fuel pump actuator return pin is shorted to battery voltage or ground. | No action is taken by the ECM. Possible loss of performance. Actuator is open, closed, or partially closed.
Fuel Supply Pump Actuator Circuit

Circuit Description

The fuel pump actuator circuit supplies current to the fuel pump actuator. The ECM commands a varying amount of current to the fuel pump actuator to control the fuel pump output pressure to the control valve assembly.

Component Location

The fuel pump actuator is on the fuel pump, just below the fuel pump sensor.

Shop Talk

Confirm that the actuator connector is firmly in place. When there is no power to the actuator, the actuator closes and fuel flow continues.

Refer to Troubleshooting Fault Code t05-316

Last Modified: 29-Jul-2010


Fuel Supply Pump Actuator - Mechanically Stuck

FAULT CODE 318

Fuel Supply Pump Actuator - Mechanically Stuck

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 318 PID: FMI: LAMP: Warning SRT: | Fuel supply pump actuator - mechanically stuck. The error between the estimated fuel pump pressure and the desired fuel pump pressure is outside the allowable limits. | No action is taken by the ECM. Possible loss of performance.
Fuel System Flow Schematic

Circuit Description

The ECM uses the fuel pump pressure signal and engine speed to estimate the actual fueling the engine is receiving, and constantly compares this value to the desired fueling for the given speed and load. When there is too large of an error in these values for too long of a time, Fault Code 318 is logged.

Component Location

The fuel pump actuator is on the fuel pump, just below the fuel pressure sensor.

Shop Talk

This fault is a check on the ECM's control of the fuel pump actuator and subsequent fuel flow. If the desired fueling can not be met by commanding more current to the actuator or if the desired fueling is being exceeded and can not be reduced by limiting the amount of current to the actuator, then Fault Code 318 is logged. Fault Code 318 is not logged if the coolant temperature is below 0°C [32°F].

  • Make sure that the correct calibration loaded into the ECM. For example, if a QSK45 calibration is loaded into a QSK60 ECM, this fault code will be activated.
  • Check for air in the fuel system.
  • Check for high fuel inlet restriction (plugged fuel filter, etc.)
Refer to Troubleshooting Fault Code t05-318

Last Modified: 29-Jul-2010


Engine Oil Level Number 1 Low - Warning

FAULT CODE 326

Engine Oil Level Number 1 Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 326 PID: FMI: LAMP: Warning SRT: | Engine oil level Number 1 low - warning. Voltage signal indicates low lubricating oil level in the engine. | Calibration-dependent engine shutdown or no action is taken by ECM.
Oil Level Sensor Circuit

Circuit Description

The oil level sensor is used by the electronic control module (ECM) to monitor the amount of oil in the engine.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

A 4-pin oil level sensor will not trigger Fault Code 326.

Refer to Troubleshooting Fault Code t05-326

Last Modified: 29-Jul-2010


Engine Control Module - Warning

FAULT CODE 343

Engine Control Module - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: FMI: LAMP: Warning SRT: | Internal ECM error. | No action is taken by the ECM. Possible loss of performance.
Electronic Control Module

Circuit Description

The electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

This is a fault with the internal circuitry of the electronic control module (ECM). Loose engine or chassis ground connections can cause Fault Code 343 to be logged, as well as complaints of an intermittent stumble. Pay special attention to the negative starter post connection. Moisture in the ECM connectors can also cause the ECM to log Fault Code 343.

Refer to Troubleshooting Fault Code t05-343

Last Modified: 29-Jul-2010


Engine Failed to Start

FAULT CODE 359

Engine Failed to Start

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 359 PID: SPN: FMI: LAMP: Warning SRT: | Engine failed to start. | No action is taken by ECM, although the engine will not start.
ECM

Circuit Description

Not applicable for this fault code

Component Location

Not applicable for this fault code

Refer to Troubleshooting Fault Code t05-359

Last Modified: 29-Jul-2010


Fueling Actuator Number 1 - Open Circuit (Front)

FAULT CODE 378

Fueling Actuator Number 1 - Open Circuit (Front)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 378 PID: FMI: LAMP: Shutdown SRT: | Fueling actuator Number 1 circuit - open circuit. (front) | Engine will shut down.
Fueling Actuator Number 1 Circuit

Circuit Description

The fuel actuators are actuated by the ECM to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front fueling actuator is mounted on the fuel delivery housing. It is the actuator closest to the front of the QSX15 engine.

Shop Talk

The possible failure modes are open circuit, short to ground, high actuator resistance, supply wire shorted to battery, and loss of boost voltage inside of ECM.

Refer to Troubleshooting Fault Code t05-378

Last Modified: 29-Jul-2010


Fueling Actuator Number 1 - Grounded Circuit (Front)

FAULT CODE 379

Fueling Actuator Number 1 - Grounded Circuit (Front)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 379 PID: FMI: LAMP: Shutdown SRT: | Fueling actuator Number 1 circuit - grounded circuit. (front) | Engine will shut down.
Fueling Actuator Number 1 Circuit

Circuit Description

The fueling actuators are actuated by the ECM to control fuel metering. Each fueling actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fueling actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front fueling actuator is mounted on the fuel delivery housing. It is the actuator closest to the front of the QSX15 engine.

Shop Talk

The possible failure modes are short to battery, low actuator resistance, or short between supply and return wires.

Refer to Troubleshooting Fault Code t05-379

Last Modified: 29-Jul-2010


Timing Actuator Number 1 - Open Circuit (Front)

FAULT CODE 394

Timing Actuator Number 1 - Open Circuit (Front)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 394 PID: FMI: LAMP: Shutdown SRT: | Timing actuator Number 1 circuit - open circuit. (front) | Engine will shut down.
Timing Actuator Number 1 Circuit

Circuit Description

The timing actuators are actuated by the ECM to control fuel metering. Each timing actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the timing actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front timing actuator is mounted on the fuel delivery housing. It is the second actuator from the front of the QSX15 engine.

Shop Talk

The possible failure modes are open circuit, short to ground, high actuator resistance, and loss of boost voltage inside of ECM.

Refer to Troubleshooting Fault Code t05-394

Last Modified: 29-Jul-2010


Timing Actuator Number 1 - Grounded Circuit (Front)

FAULT CODE 395

Timing Actuator Number 1 - Grounded Circuit (Front)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 395 PID: FMI: LAMP: Shutdown SRT: | Timing actuator Number 1 circuit - grounded circuit. (front) | Engine will shut down.
Timing Actuator Number 1 Circuit

Circuit Description

The timing actuators are actuated by the ECM to control fuel timing. Each timing actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the timing actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front timing actuator is mounted on the fuel delivery housing. It is the actuator closest to the front of the QSX15 engine.

Shop Talk

The possible failure modes are short to battery, low actuator resistance, or short between supply and return wires.

Refer to Troubleshooting Fault Code t05-395

Last Modified: 29-Jul-2010


Fueling Actuator Number 2 - Open Circuit (Rear)

FAULT CODE 396

Fueling Actuator Number 2 - Open Circuit (Rear)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 396 PID: FMI: LAMP: Shutdown SRT: | Fueling actuator Number 2 circuit - open circuit. (rear) | Engine will shut down.
Fueling Actuator Number 2 Circuit

Circuit Description

The fuel actuators are actuated by the ECM to control fuel metering. Each fuel actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fuel actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear fueling actuator is mounted on the fuel delivery housing. It is the actuator closest to the rear of the QSX15 engine.

Shop Talk

The possible failure modes are open circuit, short to ground, and high actuator resistance.

Refer to Troubleshooting Fault Code t05-396

Last Modified: 29-Jul-2010


Fueling Actuator Number 2 - Grounded Circuit (Rear)

FAULT CODE 397

Fueling Actuator Number 2 - Grounded Circuit (Rear)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 397 PID: FMI: LAMP: Shutdown SRT: | Fueling actuator Number 2 circuit - grounded circuit. (rear) | Engine will shut down.
Fueling Actuator Number 2 Circuit

Circuit Description

The fueling actuators are actuated by the ECM to control fuel metering. Each fueling actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the fueling actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear fueling actuator is mounted on the fuel delivery housing. It is the actuator closest to the front of the QSX15 engine.

Shop Talk

The possible failure modes are short to battery, low actuator resistance, or short between supply and return wires.

Refer to Troubleshooting Fault Code t05-397

Last Modified: 29-Jul-2010


Timing Actuator Number 2 - Open Circuit (Rear)

FAULT CODE 398

Timing Actuator Number 2 - Open Circuit (Rear)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 398 PID: FMI: LAMP: Shutdown SRT: | Timing actuator Number 2 circuit - open circuit. (rear) | Engine will shut down.
Timing Actuator Number 2 Circuit

Circuit Description

The timing actuators are actuated by the ECM to control fuel metering. Each timing actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the timing actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear timing actuator is mounted on the fuel delivery housing. It is the third actuator from the front of the QSX15 engine.

Shop Talk

The possible failure modes are open circuit, short to ground, and high actuator resistance.

Refer to Troubleshooting Fault Code t05-398

Last Modified: 29-Jul-2010


Timing Actuator Number 2 - Grounded Circuit (Rear)

FAULT CODE 399

Timing Actuator Number 2 - Grounded Circuit (Rear)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 399 PID: FMI: LAMP: Shutdown SRT: | Timing actuator Number 2 circuit - grounded circuit. (rear) | Engine will shut down.
Timing Actuator Number 2 Circuit

Circuit Description

The timing actuators are actuated by the electronic control module (ECM) to control fuel timing. Each timing actuator is connected to the ECM by a supply and a return wire. An electrical pulse is sent to the timing actuator from the ECM on the supply wire and returns to the ECM on the return wire. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear timing actuator is mounted on the fuel delivery housing. It is the third actuator from the front of the QSX15 engine.

Shop Talk

The possible failure modes are short to battery, low actuator resistance, or short between supply and return wires.

Refer to Troubleshooting Fault Code t05-399

Last Modified: 29-Jul-2010


Engine Oil Pressure Low - Critical

FAULT CODE 415

Engine Oil Pressure Low - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: FMI: LAMP: Shutdown SRT: | Engine oil pressure low - critical. Voltage signal indicates oil pressure has dropped below the shutdown threshold for low oil pressure. | Engine will shut down. Low oil pressure relay driver is energized.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Confirm that the oil pressure sensor supply voltage is between 4.75 and 5.25 VDC at the sensor. See Fault Code 141.Verify with the operator at what engine speed the fault occurs. If the engine is being operated at too low of a speed under load (lugging), the oil pressure can drop below the engine protection limits because of the oil temperature. Oil pressure is a function of engine speed, oil level, and regulator function. Operating the engine at a low speed under load will not cause the oil pressure to be low unless the oil is hot, at a low level, regulator has malfunctioned, or a loss is occurring somewhere in the system.

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

NOTE: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-415

Last Modified: 29-Jul-2010


Engine Oil Temperature High - Warning

FAULT CODE 421

Engine Oil Temperature High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: FMI: LAMP: Warning SRT: | Engine oil temperature has exceeded the warning threshold for high oil temperature. | No action is taken by the ECM. Possible loss of performance.
Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. The oil temperature becomes too high and engine protection is enabled, a derate condition could by incurred, possibly leading to shutdown.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of all the temperature sensors varies with the temperature.

Refer to Troubleshooting Fault Code t05-421

Last Modified: 29-Jul-2010


Engine Coolant Level Sensor - Data Incorrect

FAULT CODE 422

Engine Coolant Level Sensor - Data Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 422 PID: FMI: LAMP: Warning SRT: | Engine coolant level switch sensor error. | No engine protection for coolant level. No effect on performance.
Coolant Level Switch Sensor Circuit

Circuit Description

The coolant level switch sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM). For normal coolant level the ECM expects to see 5 VDC on the coolant level switch high signal wire and 0 VDC on the coolant level switch low signal wire. For low coolant level, the ECM expects to see 0 VDC on the coolant level switch high signal wire and 5 VDC on the coolant level switch low signal wire. This fault code occurs when the ECM receives conflicting messages from the two signal wires on the coolant level switch sensor.

Component Location

The coolant level switch sensor is located on the radiator.

Shop Talk

This fault code will go active when both signal wires show the same voltage. An open circuit in a signal wire can cause the signal to give a 5 VDC reading to the ECM. Check the coolant level. A possible failure mode is that the sensor failed while coolant level was normal and the ECM will not detect it. If the coolant level then went low, the ECM will then report a sensor error, not low coolant level.

Refer to Troubleshooting Fault Code t05-422

Last Modified: 29-Jul-2010


Fuel Timing Pressure or Timing Actuator Stuck

FAULT CODE 423

Fuel Timing Pressure or Timing Actuator Stuck

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 423 PID: FMI: LAMP: Warning SRT: | Fuel timing pressure or timing actuator stuck. Timing pressure sensor in-range error detected. Voltage signal indicates that the timing pressure sensor signal can possibly not be accurate. | No action taken by the ECM. Possible loss of performance.
Timing Rail Pressure Sensor Circuit

Circuit Description

The timing rail pressure sensor provides the timing rail pressure signal to the electronic control module (ECM), through the engine harness. The ECM uses the timing rail pressure signal to monitor the timing fuel pressure going to the injector's timing chamber from the control valve body.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

The fuel timing pressure sensor is located on the right, towards the top of the ECVA. Across from the timing rail actuator.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-423

Last Modified: 29-Jul-2010


SAE J1939 Datalink - Abnormal Update Rate

FAULT CODE 427

SAE J1939 Datalink - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9/9 LAMP: None SRT: | J1939 Datalink - Abnormal Update Rate. Communication between the engine control module (ECM) and another device on the Society of Automotive Engineers (SAE) J1939 data link has been lost. | Engine speed will ramp down and remain at idle.
SAE J1939 Data Link Circuit

Circuit Description

Devices such as antilock braking system controllers, autoshift transmissions, traction control systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) (VECUs) can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The ECM is located on the intake side of the engine, near the front. The SAE J1939 data link wiring and the SAE J1939 devices vary by original equipment manufacturer (OEM) options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than one second. The ECM detects an open or short circuit condition in the J1939 datalink harness.

Action Taken When the Fault Code is Active

  • The ECM will log the fault code immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

The ECM will set the fault code inactive immediately after the diagnostic runs and passes.

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault occurs whenever the ECM has been receiving SAE J1939 data link commands from an external OEM device and is no longer receiving the data link commands. Possible causes of this fault include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
  • The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages
  • The external OEM controlling device has failed or can no longer transmit on the data link.
Refer to Troubleshooting Fault Code t05-427

Last Modified: 16-Feb-2017


Battery 1 Voltage Low - Warning

FAULT CODE 441

Battery 1 Voltage Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: FMI: LAMP: Warning SRT: | Battery 1 voltage low - warning. | ECM voltage supply approaching level at which unpredictable operation will occur.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives unswitched battery input through the engine harness. There is an in-line 20-amp fuse in the unswitched positive (+) battery wire of the engine harness to protect the engine harness from overheating. The battery wires are connected to the starters. The customer connects the batteries to the starters.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Refer to the OEM manual for the battery location.

Shop Talk

This fault is usually caused by loose or corroded battery connections.

Refer to Troubleshooting Fault Code t05-441

Last Modified: 29-Jul-2010


Battery 1 Voltage High - Warning

FAULT CODE 442

Battery 1 Voltage High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: FMI: LAMP: Warning SRT: | Battery 1 voltage high - warning. | ECM damage will occur.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives unswitched battery input through the engine harness. There is an in-line 20 amp fuse in the unswitched positive (+) battery wire of the engine harness to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. Refer to the OEM manual for the battery location.

Shop Talk

Improper wiring of the battery circuit is the most likely cause of this fault.

Refer to Troubleshooting Fault Code t05-442

Last Modified: 29-Jul-2010


High Fuel Pressure

FAULT CODE 449

High Fuel Pressure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: FMI: LAMP: Warning SRT: | High fuel supply pressure was detected at the fuel pressure sensor. | No action is taken by the ECM. Possible black smoke.
Fuel System Circuit

Circuit Description

The gear pump draws fuel from the fuel tank through the fuel filter and anti-drainback valve. The gear pump develops 689 to 2206 kPa [100 to 320 psi] of fuel pressure. The fuel flows through the fuel filter screen and fuel shutoff valve to the fueling and timing actuators and the fuel pressure sensor. The 1724 kPa [250 psi] regulator controls the fuel pressure.

Component Location

Hydraulic Fuel System Circuit Components
1 | Quick-disconnect pressure tap - suction side | 5 | Fuel inlet | 9 | Fuel shutoff valve solenoid | 13 | Front timing actuator
2 | 2206 kPa [320 psi] pressure regulator | 6 | Fuel filter/water separator | 10 | Quick-disconnect pressure tap - pressure side | 14 | Rear timing actuator
3 | Fuel return line fitting | 7 | Fuel/water separator drain valve/Water-in-fuel sensor | 11 | Fuel pressure sensor | 15 | Rear metering actuator
4 | 36-micron filter screen | 8 | 1724 kPa [250 psi] pressure regulator | 12 | Front metering actuator |  |

Shop Talk

The fuel pressure is monitored by the ECM. If the fuel pressure is outside of an acceptable range the fault code is activated.

Refer to Troubleshooting Fault Code t05-449

Last Modified: 29-Jul-2010


Fuel Rail Pressure Sensor Circuit - Shorted High

FAULT CODE 451

Fuel Rail Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: FMI: LAMP: Warning SRT: | Injector metering rail 1 pressure sensor circuit - shorted high. This was formerly called the fuel rail pressure sensor. | Calibration-dependent engine shutdown occurs, or no action is taken by ECM.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The fuel rail pressure sensor provides the fuel rail pressure signal to the electronic control module (ECM), through the engine harness. The ECM uses the fuel rail pressure signal to monitor the fuel rail pressure going to the injector's metering chamber from the control valve body.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-451

Last Modified: 29-Jul-2010


Fuel Rail Pressure Sensor Circuit - Shorted Low

FAULT CODE 452

Fuel Rail Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: FMI: LAMP: Warning SRT: | Injector metering rail 1 pressure sensor circuit - shorted low. This was formerly called the fuel rail pressure sensor. | Calibration-dependent engine shutdown occurs, or no action is taken by ECM.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The fuel rail pressure sensor provides the fuel rail pressure signal to the engine control module (ECM), through the engine harness. The ECM uses the fuel rail pressure signal to monitor the fuel rail pressure going to the injector's metering chamber from the control valve body.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack™ type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack™ connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack™ type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-452.

Last Modified: 08-May-2012


Fuel Rail Actuator - Shorted High

FAULT CODE 455

Fuel Rail Actuator - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 455 PID: FMI: LAMP: Shutdown SRT: | Fuel control valve circuit - shorted high. This was formerly called the fuel rail actuator circuit. Fuel rail actuator circuit is open, the fuel rail actuator signal pin is shorted to battery voltage or ground, or the fuel rail actuator return pin is shorted to battery voltage or ground. | Engine will run at one speed or will shutdown. Fault Code 514 may also be logged.
Fuel Rail Actuator Circuit

Circuit Description

The fuel rail actuator is a device used by the electronic control module (ECM) to control the engine fuel supply. The ECM can shut down the engine by cutting off the power to the fuel rail actuator.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Confirm that the valve connector is firmly in place. When there is shorted power to the actuator, the actuator opens and fuel flow is uncontrolled. This will cause Fault Code 234, engine overspeed, or Fault Code 514, fueling flow mismatch.

Refer to Troubleshooting Fault Code t05-455

Last Modified: 29-Jul-2010


Timing Rail Actuator - Data Incorrect

FAULT CODE 467

Timing Rail Actuator - Data Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 467 PID: FMI: LAMP: Warning SRT: | Timing rail actuator circuit - data incorrect. The error between desired timing fueling and commanded timing fueling exceeds a normal limit. | No action taken by the ECM. Possible loss of performance.
Fuel System Flow Schematic

Circuit Description

The ECM uses the timing pressure signal and engine speed to estimate the actual timing the engine is receiving, and then constantly compares this value to the desired timing for the given speed and load. When there is too large of an error in these values for too long, Fault Code 467 is logged.

Component Location

The timing rail actuators are located on the left-side (top) of the ECVA.

Shop Talk

The estimated timing fueling and the desired timing fueling parameters can be monitored on the electronic service tool. This fault is a check on the ECM's control of the timing actuator and subsequent fuel flow. If the desired timing fueling can not be met by commanding more current to the actuator, or if the desired timing fueling is being exceeded and can not be reduced by limiting the amount of current to the actuator, then Fault Code 467 is logged.

Refer to Troubleshooting Fault Code t05-467

Last Modified: 29-Jul-2010


Fuel Rail Actuator - Data Incorrect

FAULT CODE 468

Fuel Rail Actuator - Data Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 468 PID: FMI: LAMP: Warning SRT: | Fuel rail actuator circuit - data incorrect. The error between desired rail fueling and commanded rail fueling exceeds a normal limit. | No action is taken by the ECM. Possible loss of performance.
Fuel System Flow Schematic

Circuit Description

The ECM uses the rail pressure signal and the engine speed to estimate the actual fueling that the engine is receiving, and then constantly compares this value to the desired fueling for the given speed and load. When there is too large of an error in these values for too long, this fault is logged.

Component Location

The fuel rail actuator is located on the left-side (bottom) of the ECVA.

Shop Talk

The estimated fuel railing and the desired fuel railing parameters can be monitored using the electronic service tool. This fault is a check on the ECM's control of the rail actuator and subsequent fuel flow. If the desired fuel railing can not be met by commanding more current to the actuator, or if the desired fuel railing is being exceeded and can not be reduced by limiting the amount of current to the actuator, then this fault is logged.

Refer to Troubleshooting Fault Code t05-468

Last Modified: 29-Jul-2010


Engine Oil Level Number 1 Low - Warning

FAULT CODE 471

Engine Oil Level Number 1 Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 471 PID: FMI: LAMP: Shutdown SRT: | Engine oil level has dropped below the warning threshold for low oil level. | Calibration-dependent. No action is taken by the ECM, or engine shutdown.
Oil Level Sensor Circuit

Circuit Description

The oil level sensor monitors the oil level within the oil system and passes information to the electronic control module (ECM). Low oil level can cause the engine to not start.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Some engine configurations will use a 3-pin oil level sensor and others will use a 4-pin oil level sensor.

Refer to Troubleshooting Fault Code t05-471

Last Modified: 29-Jul-2010


Intake Manifold Temperature Number 1 High - Warning

FAULT CODE 488

Intake Manifold Temperature Number 1 High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: FMI: LAMP: Warning SRT: | Engine intake manifold air temperature has exceeded the warning threshold for high intake manifold temperature. | Calibration-dependent. No action is taken by the engine control module, or engine shutdown as temperature increases over thresholds. Pre-HET relay driver is energized.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-488

Last Modified: 29-Jul-2010


Engine Oil Level Number 1 Sensor Circuit - Shorted High

FAULT CODE 498

Engine Oil Level Number 1 Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 498 PID: FMI: LAMP: Warning SRT: | Engine oil level Number 1 sensor circuit - shorted high. | No engine protection for low oil level. Centinel system is disabled.
Oil Level Sensor Circuit

Circuit Description

The oil level sensor is used by the electronic control module (ECM) to monitor the lubricating oil level. The ECM monitors the voltage on the oil level signal pin and converts this to an electronic value. The oil level value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

High voltage can be caused by the signal wire shorting to another wire in the harness, an open circuit in the return wire, or a faulty sensor.

Refer to Troubleshooting Fault Code t05-498

Last Modified: 29-Jul-2010


Engine Oil Level Number 1 Sensor Circuit - Shorted Low

FAULT CODE 499

Engine Oil Level Number 1 Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 499 PID: FMI: LAMP: Warning SRT: | Engine oil level Number 1 sensor signal - shorted low. | No engine protection for oil level. Centinel system is disabled.
Oil Level Sensor Circuit

Circuit Description

The oil level sensor is used by the electronic control module (ECM) to monitor the lubricating oil level. The ECM monitors the voltage on the oil level signal pin and converts this to an electronic value. The oil level value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Low voltage can be caused by an open circuit in the signal wire, a short to ground in the signal wire, a short to ground in the supply wire, an open circuit in the supply wire, or a faulty sensor.

A 4-pin oil level sensor will not trigger Fault Code 499.

Refer to Troubleshooting Fault Code t05-499

Last Modified: 29-Jul-2010


Fuel Rail Actuator - Mechanically Stuck

FAULT CODE 514

Fuel Rail Actuator - Mechanically Stuck

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 514 PID: FMI: LAMP: Shutdown SRT: | Fuel control valve - mechanically stuck. This was formerly called the fuel rail actuator circuit. The error between the estimated rail fueling and desired rail fueling is outside of acceptable limits. | Engine will overspeed, run at one speed, or will not run.
Quantum Fuel System Flow Schematic

Circuit Description

The ECM uses the fuel rail pressure signal and the engine speed to estimate the actual fueling that the engine is receiving, and then constantly compares this value to the desired fueling for the given speed and load. When there is too large of an error in these values for too long, then Fault Code 514 is logged.

Component Location

The fuel rail actuator is located on the left-side (bottom) of the ECVA.

Shop Talk

The estimated fuel rail and the desired fuel rail parameters can be monitored on the electronic service tool. This fault is a check on the ECM's control of the rail actuator and subsequent fuel flow. If the desired fuel rail can not be met by commanding more current to the actuator, or if the desired fuel rail is being exceeded and can not be reduced by reducing the current to the actuator, then Fault Code 514 is logged. This fault is not logged when:

  • Engine speed is below 1200 rpm
  • Coolant temperature is below 0°C [32°F]
  • Fault Code 451 or 452 is active. Once the Run/Stop switch is cycled, the fault becomes inactive.
Refer to Troubleshooting Fault Code t05-514

Last Modified: 29-Jul-2010


Fuel Delivery Pressure Sensor Circuit - Shorted High

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: FMI: LAMP: Warning SRT: | Fuel supply pressure sensor signal - shorted high. | No action take by the ECM. Possible loss of performance.
Fuel Supply Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor provides the fuel pressure supply signal to the electronic control module (ECM). This fault indicates that the signal pin on the ECM has been shorted to at least 5 VDC.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-546

Last Modified: 29-Jul-2010


Fuel Delivery Pressure Sensor Circuit - Shorted Low

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: FMI: LAMP: Warning SRT: | Fuel supply pressure sensor circuit - shorted low. | No action taken by the ECM. Possible loss of performance.
Fuel Supply Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor provides the fuel supply pressure signal to the electronic control module (ECM).

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-547

Last Modified: 29-Jul-2010


Fuel Rail Pressure Sensor Error

FAULT CODE 554

Fuel Rail Pressure Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 554 PID: FMI: LAMP: Warning SRT: | Fuel pressure sensor error. Fuel rail pressure sensor in-range error detected at key-on. Voltage signal indicates that the fuel rail pressure sensor signal can possibly not be accurate. | No action taken by the ECM. Possible loss of performance.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The fuel rail pressure sensor provides the fuel rail pressure signal to the electronic control module (ECM), through the engine harness. The ECM uses the fuel rail pressure signal to monitor the fuel pressure going to the injectors from the control valve body.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

The fuel rail pressure sensor is located on the right side, toward the bottom of the ECVA, across from the fuel rail actuator.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-554

Last Modified: 29-Jul-2010


Blowby Pressure - Warning Level

FAULT CODE 555

Blowby Pressure - Warning Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: FMI: LAMP: Warning SRT: | Engine blowby - warning level. Voltage signal indicates blowby pressure has exceeded the warning threshold for high blowby. | Calibration-dependent engine shutdown or no action is taken by ECM.
Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor is used by the electronic control module (ECM) to monitor the engine crankcase pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The blowby pressure value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Confirm that the crankcase breathers and breather tubes are not obstructed.

Refer to Troubleshooting Fault Code t05-555

Last Modified: 29-Jul-2010


Blowby Pressure - Critical Level

FAULT CODE 556

Blowby Pressure - Critical Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: FMI: LAMP: Shutdown SRT: | Engine blowby - critical level. Voltage signal indicates blowby pressure has exceeded the shutdown threshold for high blowby. | Engine will shut down.
Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor is used by the electronic control module (ECM) to monitor the engine crankcase pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The blowby pressure value is used by the ECM for the engine protection system.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Confirm that the crankcase breathers and breather tubes are not obstructed.

Refer to Troubleshooting Fault Code t05-556

Last Modified: 29-Jul-2010


Fuel Supply Pressure Sensor Circuit - Shorted High

FAULT CODE 581

Fuel Supply Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 581 PID: FMI: LAMP: Warning SRT: | Fuel supply pressure sensor circuit - shorted high. | No action taken by the ECM. Possible loss of performance.
Fuel Supply Pressure Sensor Circuit

Circuit Description

The fuel supply pressure sensor provides the fuel pressure supply signal to the electronic control module (ECM). This fault indicates that the signal pin on the ECM has been shorted to at least 5 VDC.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-581

Last Modified: 29-Jul-2010


Fuel Supply Pressure Sensor Circuit - Shorted Low

FAULT CODE 582

Fuel Supply Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 582 PID: FMI: LAMP: Warning SRT: | Fuel supply pressure sensor circuit - shorted low. | No action taken by the ECM. Possible loss of performance.
Fuel Supply Pressure Sensor Circuit

Circuit Description

The fuel supply pressure sensor provides the fuel pressure supply signal to the electronic control module (ECM). This fault indicates that the signal pin on the ECM has been shorted to ground.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

Note: Some engine models will use the Metri-Pack type connector on this pressure sensor, and some will use the Danfoss™ type connector. The Metri-Pack connector pin designators are alpha and the Danfoss™ connector pin designators are numeric. The steps depicted in this fault code show the Metri-Pack type connector with alpha pin callouts. Refer to specific engine wiring diagrams to determine the correct pin designators for the type of connector.

Refer to Troubleshooting Fault Code t05-582

Last Modified: 29-Jul-2010


Engine Hot Shutdown

FAULT CODE 611

Engine Hot Shutdown

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 611 PID: FMI: LAMP: Warning SRT: | Engine hot shutdown. Engine shutdown by operator before proper engine cooldown. | No action taken by the ECM. Possible loss of performance. Possible damage to engine can occur.

Circuit Description

nonapplicable for this fault code

Component Location

nonapplicable for this fault code

Refer to Troubleshooting Fault Code t05-611

Last Modified: 29-Jul-2010


Change Lubricating Oil and Filter

FAULT CODE 649

Change Lubricating Oil and Filter

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: SPN: FMI: LAMP: Warning SRT: | Change lubricating oil and filter. The Centinel system has not been able to replace old oil with new. The condition has persisted long enough that the oil quality warrants a full change out. | No action is taken by the ECM. Possible damage to engine can occur.

Circuit Description

The oil make up tank provides clean oil to the make up valve of the Centinel system to replenish oil that was burned by the Centinel system.

Component Location

Varies by installation. Refer to Centinel Master Repair Manual 3666231 for further information.

Shop Talk

This fault indicates that the old oil has not been replenished with new oil.

Refer to Troubleshooting Fault Code t05-649

Last Modified: 29-Jul-2010


Engine Oil Level Number 1 High - Warning

FAULT CODE 688

Engine Oil Level Number 1 High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 688 PID: FMI: LAMP: Shutdown SRT: | Engine oil level Number 1 high - critical. Voltage signal indicates very high lubricating oil level in the engine. | Engine will shut down.
Oil Level Sensor Circuit

Circuit Description

The oil level sensor is used by the ECM to monitor the amount of oil in the engine. High oil level detected can cause the engine to shut down or not start.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

A 4-pin oil level sensor will not trigger Fault Code 688.

Refer to Troubleshooting Fault Code t05-688

Last Modified: 29-Jul-2010


Crankshaft Engine Speed Sensor Error

FAULT CODE 689

Crankshaft Engine Speed Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: FMI: LAMP: Shutdown SRT: | Primary engine speed sensor error. No engine speed signal detected from the crankshaft engine speed sensor. | No action taken by the ECM. Engine will continue to run on the camshaft engine position sensor. Possible loss of performance.
Crankshaft Engine Speed Sensor Circuit

Circuit Description

The crankshaft engine speed sensor provides engine speed and position information to the electronic control module (ECM). The sensor must be powered up by +5 VDC to operate. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Possible causes of this fault code include damaged crankshaft engine speed sensor, open or shorted circuit, or power supply voltage failure.

Refer to Troubleshooting Fault Code t05-689

Last Modified: 29-Jul-2010


Blowby Pressure Sensor - Shorted High

FAULT CODE 719

Blowby Pressure Sensor - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 719 PID: FMI: LAMP: Warning SRT: | Crankcase blowby pressure sensor circuit - shorted high. | No engine protection for blowby pressure.
Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor monitors crankcase blowby pressure and passes information to the electronic control module (ECM). High voltage will trip Fault Code 719 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Confirm that the crankcase breathers, breather tubes, and blowby sensor are not obstructed.

Refer to Troubleshooting Fault Code t05-719

Last Modified: 29-Jul-2010


Blowby Pressure Sensor - Shorted Low

FAULT CODE 729

Blowby Pressure Sensor - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 729 PID: FMI: LAMP: Warning SRT: | Crankcase blowby pressure sensor circuit - shorted low. | No engine protection for blowby pressure.
Blowby Pressure Sensor Circuit

Circuit Description

The blowby pressure sensor monitors blowby pressure and passes information to the electronic control module (ECM). Low voltage will trip Fault Code 729 and can be caused by shorts in the supply, signal, or return wires, an open in the return wires, or a failed sensor.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Confirm that the crankcase breathers, breather tubes, and blowby sensor are not obstructed.

Refer to Troubleshooting Fault Code t05-729

Last Modified: 29-Jul-2010


Engine Speed/Position - Mechanical Misalignment of Crankshaft and Camshaft

FAULT CODE 731

Engine Speed/Position - Mechanical Misalignment of Crankshaft and Camshaft

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: FMI: LAMP: Warning SRT: | A mechanical misalignment has occurred between the camshaft and crankshaft. A sync error will occur. | No action is taken by the ECM. Possible loss of performance.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a solid-state sensor that provides the engine speed signal to the electronic control module (ECM), through the engine harness.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

If the problem occurs only at a certain engine temperature, be sure to check the engine speed sensor circuit while the engine is at that particular temperature.

Refer to Troubleshooting Fault Code t05-731

Last Modified: 29-Jul-2010


Camshaft Engine Position Sensor Error

FAULT CODE 778

Camshaft Engine Position Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: FMI: LAMP: Shutdown SRT: | No engine speed signal detected from the camshaft engine position sensor. | Engine will shutdown.
Camshaft Engine Position Sensor Circuit

Circuit Description

The camshaft engine position sensor provides engine speed and position information to the electronic control module (ECM). The sensor must be powered up by 5 VDC to operate. The sensor generates the signal from an extra lobe on the camshaft.

Component Location

Refer to the Engine Diagrams. 100-002 for the component location.

Shop Talk

Possible causes of this fault code include damaged camshaft engine position sensor, open or shorted circuit, or power supply voltage failure.

Refer to Troubleshooting Fault Code t05-778

Last Modified: 29-Jul-2010


Multiple Fault Codes on the Engine Harness

FAULT CODE Multiple

Multiple Fault Codes on the Engine Harness

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple PID: FMI: LAMP: SRT: | Multiple fault codes generated due to a common supply or a return wire failure in the engine harness. | Multiple fault codes.

Multiple Fault Circuit

Circuit Description

The electronic control module (ECM) supplies all of the engine pressure sensors on the engine harness with +5 VDC. The ECM has common returns for most of the engine pressure and temperature sensors. A failure on either of these wires will cause multiple fault codes.

Component Location

Refer to Procedure 100-002 for the component location.

Shop Talk

Look for open circuits in the common supply and return wires and shorts from battery or ground to the supply and return wires or defective ECM power supply. A failed pressure sensor can cause multiple fault codes. A failed pressure sensor can cause multiple active fault codes to go inactive once the engine has been started.

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead
Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead
Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Record all active fault codes
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 3B. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Recorded fault codes inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect the electronic service tool.

Action

  • Using the electronic service tool, read the multiple fault codes.
OK NOT OK

Record all active fault codes

Only a single fault code. Go to the specific fault code procedure.

Go to 2A

Specific fault code number

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the engine harness from the extension harness.

Action

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Repair the extension harness. Refer to Procedure 019-208.
  • Replace the extension harness. Refer to Procedure 019-175.

Go to 2B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead
Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Identify the common wire(s) for all fault codes active.
  • Disconnect the engine harness from the extension harness.
  • Disconnect all sensors that are part of the common wire from the engine harness.

Action

  • Measure the resistance from the common wire(s) pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead
Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Guided Step 2C - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Identify the common wire(s) for all fault codes active.
  • Disconnect the engine harness from the extension harness.
  • Disconnect all sensors that are part of the common wire from the engine harness.

Action

  • Measure the resistance from the common wire(s) pin on the engine harness inline connector to the common wire(s) pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead
Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Identify the common wire(s) for all fault codes active.
  • Disconnect the engine harness from the extension harness.
  • Disconnect all sensors that are part of the common wire from the engine harness.

Action

  • Measure the resistance from the common wire(s) pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Guided Step 3A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the extension harness connector from the ECM.

Action

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead
Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop switch in the Stop position.
  • Identify the common wire(s) for all fault codes active.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the ECM.

Action

  • Measure the resistance from the common wire(s) pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175.

Go to 3C

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead
Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Guided Step 3C - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Identify the common wire(s) for all fault codes active.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the ECM.

Action

  • Measure the resistance from the common wire(s) pin on the extension harness connector to the common wire(s) pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:
Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead
Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop switch in the Stop position.
  • Identify the common wire(s) for all fault codes active.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the ECM.

Action

  • Measure the resistance from the common wire(s) pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Idle/Rated switch in the Idle position.
  • Run/Stop switch in the Run position and idle for 1 minute.

Action

  • Using the electronic service tool, verify recorded fault codes are inactive.
OK NOT OK

Recorded fault codes inactive

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect all components.
  • Connect the electronic service tool.

Action

  • Using the electronic service tool, clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Feb-2004


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 427 - SAE J1939 Data Link - Abnormal Update Rate

Printable Version Printable Version

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3163151 - ECM bench calibration harness Part Number 3164185 - ECM bench calibration adapter cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communications with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with ECM?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check SAE J1939 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Cummins® INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using a Cummins® INLINE™ II data link adapter (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM service manual.

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has ben detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communications with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect Cummins® INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using an Cummins® INLINE™ II data link adapter (J1939) ECM connection.

INSITE™ electronic service tool communicates with ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM service manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

Refer to OEM service manual.

Reference the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree in Section TS.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Aug-2012


Fault Code 111 - Electronic Control Module (ECM) Microprocessor

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module. |
 | STEP 1A. Check the engine control module. | Fault Code 111 inactive
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine control module.

Guided Step 1A - Check the engine control module.

Conditions

  • Connect all of the components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the STOP position and wait 5 seconds.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Check the engine control module.

  • Use INSITE™ electronic service tool to verify that the Fault Code 111 is inactive.
OK NOT OK

Fault Code 111 inactive

  • Replace the engine control module. Refer to Procedure 019-031in Section 19.

1B

2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.
OK NOT OK

Less than three counts

  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

2A

2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all of the components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.
  • Operate the engine for at least 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 111 is inactive.
OK NOT OK

Fault Code 111 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

2B

1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 112 - Timing Actuator is Not Responding to ECM Commands

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the complaint. |
 | STEP 1A. Are other fault codes active besides Fault Code 112? | Other fault codes inactive
 | STEP 1B. Interview the operator. Are engine symptoms present? | Symptoms present
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check for an external power source on the engine harness or generator control system. | Remove the external power supply from the harness.
STEP 3. | Check the suction side of the fuel system flow. |
 | STEP 3A. Check the fuel tank level. | Fuel in tank
 | STEP 3B. Inspect the fuel system for leaks, broken lines, and loose fittings. | No leaks, broken lines, or loose fittings
 | STEP 3C. Check the fuel inlet restriction. | Less than 203 mm-Hg [8 in-Hg]
 | STEP 3D. Check for air in the fuel. | Minimal air in the fuel
STEP 4. | Check the pressure-side fuel system flow. |
 | STEP 4A. Check the fuel pump output pressure. | QSK45 140 ± 20 psi @ 750 rpm, 255 ± 30 psi @ 1500 rpm, 300 ± 30 psi @ 1800 rpm. QSK60 140 ± 20 psi @ 750 rpm, 280 ± 30 psi @ 1500 rpm, 350 ± 30 psi @ 1800 rpm
 | STEP 4A-1. Check the injector o-rings. |
 | STEP 4A-2. Check for fuel in the oil or coolant. |
 | STEP 4B. Inspect the actuator screen for debris. | No debris
 | STEP 4C. Inspect the actuator for corrosion. | No corrosion
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 112 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify the complaint.

Guided Step 1A - Are other fault codes active besides Fault Code 112?

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Check for other active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Other faults inactive.

Investigate other fault codes first.

Go to 1B

Appropriate fault tree

Guided Step 1B - Interview the operator. Are engine symptoms present?

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Interview the operator for the following:

  • Are engine symptoms present?
  • Is the operator complaining about specific symptoms or shutdowns/derates due to Fault Code 112?
OK NOT OK

Symptoms present

  • Clear the fault code. Inactive faults have been logged. Since operator is not experiencing a problem, clear the fault.

Go to 2A

Go to 5B

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check for external power source on the engine harness or generator control system.

Conditions

  • Place run/stop/auto switch in the STOP position.

Action

Check for external power supply (such as a battery charger) on the engine harness or generator control system. Refer to the wiring diagram for proper wiring connections.

Use the following procedure for additional service literature for wiring diagram bulletin numbers. Refer to Procedure 205-001 in Section L.

OK NOT OK

Remove the external power supply from the harness.

Go to 3A

Go to 5A

Guided Step 3 - Check the suction side of the fuel system flow.

Guided Step 3A - Check the fuel tank level.

Conditions

  • Place run/stop/auto switch in the STOP position.

Action

Check the fuel tank level.
OK NOT OK

Fuel in tank

Fill the tank with fuel

Go to 3B

Go to 5A

Guided Step 3B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Place run/stop/auto switch in the STOP position.

Action

Inspect the fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings.
OK NOT OK

No leaks, broken lines, or loose fittings

Tighten or replace the leaking fitting or fuel line. Replace the fuel line.

  • Use the following procedure for Signature™, ISX, and QSX15 engines. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure for QSK23 engine. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure for QST30 engine. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure for QSK45 and QSK60 engines. Refer to Procedure 006-024 in Section 6.
  • Use the following procedure for QSK78 engine. Refer to Procedure 006-024 in Section 6.

Go to 3C

Go to 5A

Guided Step 3C - Check the fuel inlet restriction.

Conditions

  • Place run/stop/auto switch in the RUN position.

Action

Check the inlet restriction as follows:

  • Measure the inlet restriction.
  • Use the following procedure for Signature™, ISX, and QSX15 engines. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure for QSK23 engine. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure for QSK45 and QSK60 engines. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure for QSK78 engine. Refer to Procedure 005-016 in Section 5.
OK NOT OK

Less than 203 mm-Hg [8 in-Hg]

Find cause of restriction and remove restriction. Check for clogged fuel filters, debris in the fuel tank, fuel tank vents clogged, collapsed or faulty fuel lines, or faulty check valves.

Go to 3D

Go to 5A

Guided Step 3D - Check for air in the fuel.

Conditions

  • Place run/stop/auto switch in the RUN position.

Action

Check for air in the fuel.

  • Use the following procedure for Signature™, ISX, and QSX15 engines. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure for QSK23 engine. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure for QSK45 and QSK60 engines. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure for QSK78 engine. Refer to Procedure 005-016 in Section 5.
OK NOT OK

Minimal air in the fuel

Find cause of air in the fuel. Check for missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.

Go to 4A

Go to 5A

Guided Step 4 - Check the pressure-side fuel system flow.

Guided Step 4A - Check the fuel pump output pressure.

Conditions

  • Place run/stop/auto switch in the RUN position.

Action

Check the fuel pump output pressure.

  • Measure the output pressure of the pump at the Compuchek® fitting.
  • Use the following procedure for Signature™, ISX, and QSX15 engines. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure for QSK23 engine. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure for QSK45 and QSK60 engines. Refer to Procedure 005-016 in Section 5.
  • Use the following procedure for QSK78 engine. Refer to Procedure 005-016 in Section 5.
OK NOT OK

QSK45: 140 ± 20 psi @ 750 rpm, 255 ± 30 psi @ 1500 rpm, 300 ± 30 psi @ 1800 rpm. QSK60: 140 ± 20 psi @ 750 rpm, 280 ± 30 psi @ 1500 rpm, 350 ± 30 psi @ 1800 rpm.

Go to 4B

Go to 4A-1

Guided Step 4A-1 - Check the injector o-rings.

Conditions

  • Place run/stop/auto switch in the RUN position.

Action

Check the injector o-rings.

The o-rings can be checked by observing the drain output of the front three versus the rear three cylinders.

  • Disconnect the drain lines at the T-junction.
  • Place each half into separate, equal-size buckets.
  • Operate the engine at rated speed for enough time to determine if output is equal from each half.
OK NOT OK

Drain output equal from front and rear halves

Replace the injector o-rings on faulty bank.

  • Use the following procedure for Signature™, ISX, and QSX15 enegines. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure for QSK23 engine. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure for QST30 engine. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure for QSK45 and QSK60 engines. Refer to Procedure 006-026 in Section 6.
  • Use the following procedure for QSK78 engine. Refer to Procedure 006-026 in Section 6.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Check for fuel in the oil or coolant.

Conditions

  • Place run/stop/auto switch in the STOP position.

Action

Check for fuel in the oil or coolant.
OK NOT OK

No fuel in the oil or coolant

Fuel in the oil or coolant

Go to 5A

Appropriate Symptom Tree

Guided Step 4B - Inspect the actuator screen for debris.

Conditions

  • Place run/stop/auto switch in the STOP position.

Action

Inspect the actuator screen(s) for debris.

  • Remove the timing rail actuator(s) Number 1 and 2. Refer to Procedure 019-111 in Section 19.
OK NOT OK

No debris

  • Replace the timing rail actuator(s) screen. Refer to Procedure 019-111 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Inspect the actuator for corrosion.

Conditions

  • Place run/stop/auto switch in the STOP position.

Action

Inspect the actuator(s) for corrosion.

  • Remove the timing actuator(s) Number 1 and 2. Refer to Procedure 019-111 in Section 19.
OK NOT OK

No corrosion

  • Replace the timing actuator(s). Refer to Procedure 019-111 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in the STOP position.

Action

Disable the fault code.

  • Start the engine and run throughout the operating range to verify the Fault Code 112 stays inactive.
OK NOT OK

Fault Code 112 inactive

Return to the Troubleshooting Steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-Feb-2012


FAULT CODE 113 - Timing Rail Actuator Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing rail actuator. |
 | STEP 1A. Inspect the timing rail actuator and the engine harness connector pins. | No damaged pins
 | STEP 1B. Check the coil resistance of the timing rail actuator. | 7.0 to 9.0 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 20 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms
 | STEP 2D. Check for a return short to the power supply. | Greater than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 20 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms
 | STEP 3D. Check for return short to the power supply. | Greater than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 113 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the timing rail actuator.

Guided Step 1A - Inspect the timing rail actuator and the engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the timing rail actuator.

Action

Inspect the timing actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace timing rail actuator. Refer to Procedure 019-111 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the coil resistance of the timing rail actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the timing rail actuator.

Action

Check the coil resistance of the timing rail actuator(s).

  • Measure the resistance from the timing rail actuator (1) SUPPLY pin to the timing rail actuator (1) RETURN pin.
  • Measure the resistance from the timing rail actuator (2) SUPPLY pin to the timing rail actuator (2) RETURN pin.
OK NOT OK

7.0 to 9.0 ohms

Replace the timing rail actuator(s). Refer to Procedure 019-111 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the extension harness connector.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-203 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the timing rail actuator.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail actuator (1) RETURN pin to the timing rail actuator (1) SUPPLY pin at the engine harness inline connector.
  • Measure the resistance from the timing rail actuator (2) RETURN pin to the timing rail actuator (2) SUPPLY pin at the engine harness inline connector.
OK NOT OK

Less than 20 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail actuator.

Action

Check for a short circuit from pin to pin.

  • Measure resistance between the timing rail actuator (1) SUPPLY pin and all other pins of the engine harness inline connector.
  • Measure resistance between the timing rail actuator (2) SUPPLY pin and all other pins of the engine harness inline connector.
OK NOT OK

Greater than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a return short to the power supply.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail actuator.

Action

Check for a return short to the power supply.

  • Measure the resistance from the timing rail actuator (1) RETURN pin to the timing rail actuator (1) SUPPLY pin in the engine harness inline connector.
  • Measure the resistance from the timing rail actuator (2) RETURN pin to the timing rail actuator (2) SUPPLY pin in the engine harness inline connector.
OK NOT OK

Greater than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check for a return short to the power supply.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail actuator (1) SUPPLY pin to the timing rail actuator (1) RETURN pin at the extension harness connector.
  • Measure the resistance from the timing rail actuator (2) SUPPLY pin to the timing rail actuator (2) RETURN pin at the extension harness connector.
OK NOT OK

Less than 20 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit from pin to pin.

  • Measure resistance between the timing rail actuator (1) SUPPLY pin and all other pins of the extension harness connector.
  • Measure resistance between the timing rail actuator (2) SUPPLY pin and all other pins of the extension harness connector.
OK NOT OK

Greater than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a return short to the power supply.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a return short to the power supply.

  • Measure the resistance from the timing rail actuator (1) RETURN pin to the timing rail actuator (1) SUPPLY pin in the extension harness connector.
  • Measure the resistance from the timing rail actuator (2) RETURN pin to the timing rail actuator (2) SUPPLY pin in the extension harness connector.
OK NOT OK

Greater than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 113 is inactive.
OK NOT OK

Fault Code 113 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Refer to the appropriate troubleshooting charts for any remaining active fault codes.

Repair Complete

Appropriate troubleshooting charts

Last Modified: 20-Apr-2012


FAULT CODE 115 - Engine Speed/Position Sensor Circuit - Lost Both of Two Signals from the Magnetic Pickup Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead Part Number 3822917 - female AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Inspect the engine speed sensor. | No damage to engine speed sensor
 | STEP 1C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 1D. Check for an open circuit. | 1k to 2k ohms
 | STEP 1E. Check for a short circuit between coils. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 2k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 2k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 115 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the engine speed sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect engine speed sensor for the following:

  • Metal debris on end of sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor
  • Damage to end of sensor caused by camshaft gear or flywheel ring gear.
OK NOT OK

No damage to engine speed sensor

Replace the engine speed sensor.

  • Refer to Procedure 019-042 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine block ground.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin to the engine block ground.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

More than 100k ohms

Replace the engine speed sensor.

  • Refer to Procedure 019-042 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

1k to 2k ohms

Replace the engine speed sensor.

  • Refer to Procedure 019-042 in Section 19.

Go to 1E

Go to 4A

Guided Step 1E - Check for a short circuit between coils.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine speed sensor 2 SIGNAL pin.
  • Measure the resistance between the engine speed sensor 1 RETURN pin to the engine speed sensor 2 RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

More than 100k ohms

Replace the engine speed sensor.

  • Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the engine harness inline connector.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the engine harness inline connector.
OK NOT OK

Less than 2k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using the electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the extension harness to the engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the extension harness to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the engine harness.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the extension harness connector.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the extension harness connector.
OK NOT OK

Less than 2k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 115 is inactive.
OK NOT OK

Fault Code 115 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Apr-2012


FAULT CODE 116 - Fuel Timing Rail Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/ AMP™/Metri-Pack™ test lead Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3824774 - Pressure sensor breakout cable Part Number 3824776 - Pressure sensor breakout cable Part Number 3163594 - engine control module connector breakout box Part Number 3164752 - Danfoss™ pressure sensor breakout cable Part Number 3164132 - Deutsch™ socket pin test lead Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the timing rail pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the engine control module response. |
 | STEP 5A. Check for the appropriate engine control module response. | Fault Code 116 inactive or Fault Code 117 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 116 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the timing rail pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the timing rail pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the timing rail pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the timing rail pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the timing rail pressure sensor.

  • Refer to Procedure 019-113 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to the timing rail pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the timing rail pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to the timing rail pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to the timing rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to the timing rail pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine control module response.

Guided Step 5A - Check for the appropriate engine control module response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate connector.
  • Install a jumper wire between the timing rail pressure SIGNAL pin and the timing rail pressure RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 116 inactive or Fault Code 117 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 116 is inactive.
OK NOT OK

Fault Code 116 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 117 - Fuel Timing Rail Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3824774 - Pressure sensor breakout cable Part Number 3824776 - Pressure sensor breakout cable Part Number 3163594 - ECM connector breakout box Part Number 3164752 - Danfoss™ pressure sensor breakout cable Part Number 3164132 - Deutsch™ socket pin test lead Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 119, 452 and 729 are not active
STEP 2. | Check the timing rail pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 117 inactive or Fault Code 116 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 117 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel pump pressure sensor.
OK NOT OK

Fault Codes 119, 452 and 729 inactive

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the timing rail pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the timing rail pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the timing rail pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19, Refer to Procedure 019-213 in Section 19 or Refer to Procedure 019-201 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to the timing rail pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to the timing rail pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to the timing rail pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the timing rail pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the ECM.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to the timing rail pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to the timing rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to the timing rail pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout board.
  • Connect the breakout board harness to the appropriate ECM connector.
  • Install a jumper wire between the timing rail pressure SIGNAL pin and the timing rail pressure SUPPLY pin on the breakout board.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 117 inactive or Fault Code 116 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Verify Fault Code 117 is inactive.
OK NOT OK

Fault Code 117 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-Feb-2012


FAULT CODE 118 - Fuel Pump Delivery Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3824774 - Pressure sensor breakout cable Part Number 3824776 - Pressure sensor breakout cable Part Number 3163594 - ECM connector breakout box Part Number 3164752 - Danfoss™ pressure sensor breakout cable Part Number 3164132 - Deutsch™ socket pin test lead Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the fuel pump pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 118 inactive or Fault Code 119 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 118 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel pump pressure sensor.
OK NOT OK

No other fault codes inactive

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel pump pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel pump pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the fuel pump pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pump pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pump pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the engine harness inline connector to the fuel pump pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the engine harness inline connector to the fuel pump pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the engine harness inline connector to the fuel pump pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel pump pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the extension harness connector to the fuel pump pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the extension harness connector to the fuel pump pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the extension harness connector to the fuel pump pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the fuel pump pressure SIGNAL pin and the fuel pump pressure RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 118 inactive or Fault Code 119 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 118 is inactive.
OK NOT OK

Fault Code 118 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-Feb-2012


FAULT CODE 119 - Fuel Pump Delivery Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3824774 - Pressure sensor breakout cable Part Number 3824776 - Pressure sensor breakout cable Part Number 3163594 - engine control module connector breakout box Part Number 3164752 - Danfoss™ pressure sensor breakout cable Part Number 3164132 - Deutsch™ socket pin test lead Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 117 and 452 are not active
STEP 2. | Check the fuel pump pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the engine control module response. |
 | STEP 5A. Check for the appropriate engine control module response. | Fault Code 119 inactive or Fault Code 118 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 119 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel pump pressure sensor.
OK NOT OK

Fault Codes 117 and 452 are not active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel pump pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel pump pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pump pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pump pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the fuel pump pressure sensor. Refer to Procedure 019-118 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the engine harness inline connector to the fuel pump pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the engine harness inline connector to the fuel pump pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the engine harness inline connector to the fuel pump pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel pump pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the extension harness connector to the fuel pump pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the extension harness connector to the fuel pump pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the extension harness connector to the fuel pump pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin to pin

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pump pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine control module response.

Guided Step 5A - Check for the appropriate engine control module response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the fuel pump pressure SIGNAL pin and the fuel pump pressure SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 119 inactive or Fault Code 118 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 119 is inactive.
OK NOT OK

Fault Code 119 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 121 - Engine Speed/Position Sensor Circuit - Lost One of Two Signals from the Magnetic Pickup Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Inspect the engine speed sensor. | No damaged engine speed sensor
 | STEP 1C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 1D. Check for an open circuit. | 1k to 2k ohms
 | STEP 1E. Check for short circuit between coils. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 2k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 2k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the engine speed sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1B

4A

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect engine speed sensor for the following:

  • Metal debris on end of sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor
  • Damage to end of sensor caused by camshaft gear or flywheel ring gear.
OK NOT OK

No damaged engine speed sensor.

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine block ground.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin to the engine block ground.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

More than 100k ohms

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

1k to 2k ohms

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1E

Go to 4A

Guided Step 1E - Check for short circuit between coils.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine speed sensor 2 SIGNAL pin.
  • Measure the resistance between the engine speed sensor 1 RETURN pin to the engine speed sensor 2 RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

OK NOT OK

More than 100k ohms

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

4A

Guided Step 2B - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the engine harness inline connector.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the engine harness inline connector.
OK NOT OK

Less than 2k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the engine harness inline connector.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the extension harness inline connector to the engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the extension harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the engine harness.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the extension harness connector.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the extension harness connector.
OK NOT OK

Less than 2k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the extension harness connector.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 121 is inactive.
OK NOT OK

Fault Code 121 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 122 - Intake Manifold Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3162898 - Pressure/Temperature sensor breakout cablePart Number 3824774 - Pressure sensor breakout cablePart Number 3824776 - Pressure sensor breakout cablePart Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 122 inactive or Fault Code 123 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 122 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the intake manifold pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the intake manifold pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the intake manifold pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure sensor 1 RETURN pin on the engine harness inline connector to the intake manifold pressure sensor 1 RETURN pin in the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold pressure sensor 1 +5-VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the intake manifold pressure sensor 1 SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure sensor 1 RETURN pin at the extension harness connector to the intake manifold pressure sensor 1 RETURN pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold pressure sensor 1 +5-VDC SUPPLY pin at the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold pressure sensor 1 SIGNAL pin at the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate connector.
  • Install a jumper wire between the intake manifold pressure sensor 1 SIGNAL pin and the intake manifold pressure sensor 1 RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 122 inactiveFault Code 123 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 122 is inactive.
OK NOT OK

Fault Code 122 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-Feb-2012


FAULT CODE 123 - Intake Manifold Pressure Sensor 1 Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - ECM connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 123 inactive or Fault Code 122 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 123 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the intake manifold pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the intake manifold pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold pressure sensor 1 SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the intake manifold pressure sensor 1, 5-VDC SUPPLY pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure sensor 1 SIGNAL pin in the engine harness inline connector to the intake manifold pressure sensor 1 SIGNAL pin at the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure sensor 1, 5-VDC SUPPLY pin in the engine harness inline connector to the intake manifold pressure sensor 1, 5-VDC SUPPLY pin at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold pressure sensor 1, 5-VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the intake manifold pressure sensor 1 SIGNAL pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the intake manifold pressure sensor 1 RETURN pin on the engine harness inline connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold pressure sensor 1 SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the intake manifold pressure sensor 1, 5-VDC SUPPLY pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure sensor 1 SIGNAL pin on the extension harness connector to the intake manifold pressure sensor 1 SIGNAL pin at the extension harness inline connector.
  • Measure the resistance from the intake manifold pressure sensor 1, 5-VDC SUPPLY pin on the extension harness connector to the intake manifold pressure sensor 1, 5-VDC SUPPLY pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold pressure sensor 1, 5-VDC SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold pressure sensor 1 RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold pressure sensor 1 SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the intake manifold pressure sensor 1 SIGNAL pin and the intake manifold pressure sensor 1, 5-VDC SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 123 inactive or Fault Code 122 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 123 is inactive.
OK NOT OK

Fault Code 123 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Feb-2012


FAULT CODE 128 - Intake Manifold Pressure Sensor 2 Circuit - Shorted High (Right Bank)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3162898 - Pressure/Temperature sensor breakout cable, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 128 inactive, Fault Code 129 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 128 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the intake manifold pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the intake manifold pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure sensor 2 RETURN pin in the engine harness inline connector to the intake manifold pressure sensor 2 RETURN pin in the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold pressure sensor 2 +5-VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the intake manifold pressure sensor 2 SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure sensor 2 RETURN pin at the extension harness connector to the intake manifold pressure sensor 2 RETURN pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold pressure sensor 2 +5 VDC SUPPLY pin at the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold pressure sensor 2 SIGNAL pin at the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate connector.
  • Install a jumper wire between the intake manifold pressure sensor 2 SIGNAL pin and the intake manifold pressure sensor 2 RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 128 inactive, Fault Code 129 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 128 is inactive.
OK NOT OK

Fault Code 128 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Mar-2012


FAULT CODE 129 - Intake Manifold Pressure Sensor 2 Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - ECM connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 129 inactive, Fault Code 128 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 129 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool, read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the intake manifold pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the intake manifold pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold pressure sensor 2 SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the intake manifold pressure sensor 2 +5-VDC SUPPLY pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure sensor 2 SIGNAL pin on the engine harness inline connector to the intake manifold pressure sensor 2 SIGNAL pin at the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure sensor 2 +5-VDC SUPPLY pin on the engine harness inline connector to the intake manifold pressure sensor 2 +5-VDC SUPPLY pin at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold pressure sensor 2 +5-VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the intake manifold pressure sensor 2 SIGNAL pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the intake manifold pressure sensor 2 RETURN pin on the engine harness inline connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold pressure sensor 2 SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the intake manifold pressure sensor 2 +5-VDC SUPPLY pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold pressure sensor 2 SIGNAL pin on the extension harness connector to the intake manifold pressure sensor 2 SIGNAL pin at the extension harness inline connector.
  • Measure the resistance from the intake manifold pressure sensor 2 +5-VDC SUPPLY pin on the extension harness connector to the intake manifold pressure sensor 2 +5-VDC SUPPLY pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold pressure sensor 2 +5-VDC SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold pressure sensor 2 RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold pressure sensor 2 SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the intake manifold pressure sensor 2 SIGNAL pin and the intake manifold pressure sensor 2 +5 VDC SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 129 inactive, Fault Code 128 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 129 is inactive.
OK NOT OK

Fault Code 129 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Mar-2012


FAULT CODE 135 - Engine Oil Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3162898 - Pressure/Temperature sensor breakout cable, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - ECM connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damage pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 135 inactive or Fault Code 141 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 135 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the oil pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the oil pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19 and Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19 and Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the oil pressure RETURN pin on the engine harness inline connector to the oil pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil pressure +5-VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the oil pressure RETURN pin on the extension harness connector to the oil pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil pressure +5-VDC SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the oil pressure SIGNAL pin and the oil pressure RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 135 inactiveFault Code 141 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 135 is inactive.
OK NOT OK

Fault Code 135 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-Mar-2012


FAULT CODE 141 - Engine Oil Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3162898 - Pressure/Temperature sensor breakout cable, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - ECM connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damage pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 141 inactive, Fault Code 135 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 141 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical ground/return with the oil pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the oil pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19 and Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19 and Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the oil pressure +5-VDC SUPPLY pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness inline connector to the oil pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the oil pressure +5-VDC SUPPLY pin on the engine harness inline connector to the oil pressure +5-VDC SUPPLY pin on the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil pressure +5-VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the oil pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil pressure SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the oil pressure +5-VDC pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the oil pressure SIGNAL pin on the extension harness connector to the oil pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the oil pressure +5-VDC SUPPLY pin on the extension harness connector to the oil pressure +5-VDC SUPPLY pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil pressure +5-VDC SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the oil pressure SIGNAL pin and the oil pressure +5-VDC SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 141 inactive, Fault Code 135 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 141 is inactive.
OK NOT OK

Fault Code 141 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-Mar-2012


FAULT CODE 143 - Engine Oil Pressure Low - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil pressure sensor accuracy. |
 | STEP 1A. Verify the oil pressure sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the oil pressure sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 143 inactive
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the oil pressure sensor accuracy.

Guided Step 1A - Verify oil pressure sensor accuracy with a mechanical gauge.

Conditions

  • Connect a mechanical oil pressure gauge of known quality and calibration to the engine at one of the plugs on top of the oil filter head.
  • Connect INSITE™ electronic service tool to the data link.
  • Place the run/stop/auto switch in the RUN position.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Start engine and compare the oil pressure reading on INSITE™ electronic service tool monitor screen to the reading on mechanical oil pressure gauge.

NOTE: The engine rpm will need to be increased to make it easier to see differences in the readings.
OK NOT OK

Sensor reading is correct.

Refer to Procedure 007-028 in Section 7. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Refer to Procedure 007-028 in Section 7. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.

Refer to Procedure 007-028 in Section 7. QST30 Service Manual, Bulletin 4021539.

Refer to Procedure 007-028 in Section 7. QSK45 and QSK60 Service Manual, Bulletin 4021560.

Refer to Procedure 007-028 in Section 7. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to Fault Code 141

Go to 2A

Fault Code 141

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the oil pressure sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the oil pressure sensor.
OK NOT OK

Fault simulation is disabled

Disable fault simulation.

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the oil pressure sensor.
OK NOT OK

Fault threshold is set correctly. Reference symptom tree, Lubricating Oil Pressure Low in Section TS in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021560.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Place the idle/rated switch in the IDLE position.
  • Start the engine and idle for 1 minute.

NOTE: If the fault was at a particular rpm, operate engine at that rpm to verify the problem is corrected.
OK NOT OK

Fault Code 143 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear any inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 144 - Engine Coolant Temperature Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822817 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 144 inactive, Fault Code 145 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable Fault Code. | Fault Code 144 inactive
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool, read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the coolant temperature sensor.
OK NOT OK

No other fault codes are active

Go to 2A

Multiple fault tree

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance between the coolant temperature SIGNAL pin and the coolant temperature RETURN pin.
OK NOT OK

600 ohms to 36k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the coolant temperature RETURN pin on the engine harness inline connector to the coolant temperature RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the engine harness inline connector to the coolant temperature SIGNAL pin at the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the coolant temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.

Action

Inspect the extension harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the coolant temperature RETURN pin on the extension harness connector to the coolant temperature RETURN pin at the extension harness inline connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the extension harness connector to the coolant temperature SIGNAL pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the coolant temperature SIGNAL pin and the coolant temperature RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 144 inactive, Fault Code 145 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 144 is inactive.
OK NOT OK

Fault Code 144 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-Mar-2012


FAULT CODE 145 - Engine Coolant Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the engine control module response. |
 | STEP 5A. Check for the appropriate engine control module response. | Fault Code 145 inactive, Fault Code 144 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 145 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for a multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the coolant temperature sensor.
OK NOT OK

No other fault codes are active

Multiple fault codes

Go to 2A

Multiple fault tree

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the coolant temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance between the coolant temperature SIGNAL pin and the coolant temperature RETURN pin.
OK NOT OK

600 ohms to 36k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the coolant temperature sensor connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from coolant temperature sensor.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the coolant temperature SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the coolant temperature RETURN pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared SUPPLY or return with the coolant temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the coolant temperature SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the coolant temperature RETURN pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine control module response.

Guided Step 5A - Check for the appropriate engine control module response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the coolant temperature SIGNAL pin and the coolant temperature SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 145 inactive, Fault Code 144 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 145 is inactive.
OK NOT OK

Fault Code 145 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 146 - Engine Coolant Temperature High - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the ECM sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 146 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 144

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM sensor value.

  • Verify that the fault simulation is not enabled for the coolant temperature sensor by connecting to the ECM via the electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation.

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the coolant temperature sensor.
OK NOT OK

Fault threshold is set correctly.

Reference the symptom trees t022 and t023 in Section TS in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.QSK45 and QSK60 Service Manual, Bulletin 4021560.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 146 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Mar-2012


FAULT CODE 151 - Engine Coolant Temperature High - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the ECM sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 151 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 144

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM sensor value.

  • Verify that the fault simulation is not enabled for the coolant temperature sensor by connecting to the ECM via INSITE™ electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the coolant temperature sensor.
OK NOT OK

Fault threshold is set correctly. Reference symptom trees t022 and t023, in Section TS,in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.QSK45 and QSK60 Service Manual, Bulletin 4021560.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 151 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Mar-2012


FAULT CODE 152 - Engine Coolant Temperature Low - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the ECM sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 152 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 145

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM sensor value.

  • Verify that the fault simulation is not enabled for the coolant temperature sensor by connecting to the ECM via INSITE™ electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the coolant temperature sensor.
OK NOT OK

Fault threshold is set correctly. Reference symptom tree t024 in Section TS in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.QSK45 and QSK60 Service Manual, Bulletin 4021560.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 152 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 18-Feb-2014


FAULT CODE 153 - Intake Manifold Temperature Sensor Number 1 Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the intake manifold temperature sensor. | 600 ohms to 36k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 153 inactive, Fault Code 154 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 153 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the intake manifold temperature sensor.
OK NOT OK

No other fault codes are active

No other fault codes are active

Go to 2A

Multiple fault tree

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the intake manifold temperature sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance between the intake manifold temperature SIGNAL pin and the intake manifold temperature RETURN pin.
OK NOT OK

600 ohms to 36k ohms

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness inline connector to the intake manifold temperature RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness inline connector to the intake manifold temperature SIGNAL pin at the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.

Action

Inspect the extension harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold temperature RETURN pin on the extension harness connector to the intake manifold temperature RETURN pin at the extension harness inline connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector to the intake manifold temperature SIGNAL pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the intake manifold SIGNAL pin and the intake manifold RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 153 inactive, Fault Code 154 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 153 is inactive.
OK NOT OK

Fault Code 153 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Mar-2012


FAULT CODE 154 - Intake Manifold Temperature Sensor Number 1 Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 154 inactive, Fault Code 153 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 154 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the intake manifold temperature sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the intake manifold temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance between the intake manifold temperature SIGNAL pin and the intake manifold temperature RETURN pin.
OK NOT OK

600 ohms to 36k ohms

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the intake manifold temperature sensor connector to the engine block ground.
OK NOT OK

More than 100k ohms

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from intake manifold temperature sensor.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from ECM.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature RETURN pin extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector pin to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the intake manifold temperature SIGNAL pin and the intake manifold temperature SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 154 inactive, Fault Code 153 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 154 is inactive.
OK NOT OK

Fault Code 154 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Mar-2012


FAULT CODE 155 - Intake Manifold Temperature Number 1 High - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the ECM sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the intake manifold temperature sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code 155 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the intake manifold temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the intake manifold temperature reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct.

Sensor reading is correct.

Go to 2A

Fault Code 153

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the intake manifold temperature sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM sensor value.

  • Verify that the fault simulation is not enabled for the intake manifold temperature sensor by connecting to the ECM via INSITE™ electronic service tool.
OK NOT OK

Fault simulation is disabled.

Disable fault simulation.

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the intake manifold air temperature sensor.
OK NOT OK

Fault threshold is set correctly. Reference symptom tree t096 in Section TS, in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021560.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 155 is inactive.
OK NOT OK

Fault Code 155 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-Apr-2012


FAULT CODE 159 - Intake Manifold Temperature Sensor Number 2 Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the intake manifold temperature sensor. | 600 ohms to 36k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 159 inactive, Fault Code 161 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 159 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the intake manifold temperature sensor.
OK NOT OK

No other fault codes are active

No other fault codes are active

Go to 2A

Multiple fault tree

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the intake manifold temperature sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance between the intake manifold temperature SIGNAL pin and the intake manifold temperature RETURN pin.
OK NOT OK

600 ohms to 36k ohms

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness inline connector to the intake manifold temperature RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness inline connector to the intake manifold temperature SIGNAL pin at the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.

Action

Inspect the extension harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the intake manifold temperature RETURN pin on the extension harness connector to the intake manifold temperature RETURN pin at the extension harness inline connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector to the intake manifold temperature SIGNAL pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the intake manifold SIGNAL pin and the intake manifold RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 159 inactive, Fault Code 161 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 159 is inactive.
OK NOT OK

Fault Code 159 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Run/Stop switch in the Stop position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-Apr-2012


FAULT CODE 161 - Intake Manifold Temperature Sensor Number 2 Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 161 inactive, Fault Code 159 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 161 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the intake manifold temperature sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the intake manifold temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Lose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance between the intake manifold temperature SIGNAL pin and the intake manifold temperature RETURN pin.
OK NOT OK

600 ohms to 36k ohms

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the intake manifold temperature sensor connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19 and Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from intake manifold temperature sensor.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from ECM.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature RETURN pin extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin on the extension harness connector pin to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the intake manifold temperature SIGNAL pin and the intake manifold temperature supply pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 161 inactive, Fault Code 159 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Idle/Rated switch in the Idle position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 161 is inactive.
OK NOT OK

Fault Code 161 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-Oct-2015


FAULT CODE 168 - Fuel Rack Actuator Position 1 Circuit - Open Circuit (Left Bank)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rack actuator position 1 (left bank). |
 | STEP 1A. Inspect the actuator and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
 | STEP 1C. Check for short circuit to engine block ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 168 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel rack actuator position 1 (left bank).

Guided Step 1A - Inspect the actuator and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the left bank fuel pump connector.

Action

Inspect the harness and the fuel pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the fuel pump. Reference the following manuals for the procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the left bank fuel pump connector.

Action

Check the resistance of the fuel pump rack actuator.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin to the fuel rack actuator position 1 pulse width modulated RETURN pin of the fuel pump connector.
OK NOT OK

0.5 to 1.5 ohms

Replace the fuel pump. Reference the following manuals for the procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1C

Go to 4A

Guided Step 1C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the left bank fuel pump connector.

Action

Check for short circuit to ground in the fuel pump rack actuator.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin to engine block ground.
  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated RETURN pin to engine block ground.
OK NOT OK

More than 100k ohms

Replace the fuel pump. Reference the following manuals for the procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the left bank fuel pump.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-175 in Section 19

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the left bank fuel pump.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin on the engine harness inline connector to the fuel rack actuator position 1 pulse width modulated SUPPLY pin on the engine harness fuel pump connector.
  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated RETURN pin on the engine harness inline connector to the fuel rack actuator position 1 pulse width modulated RETURN pin on the engine harness fuel pump connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use the electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check for an open circuit in the extension harness.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin on the extension harness engine control module connector to the fuel rack actuator position 1 pulse width modulated SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated RETURN pin on the extension harness engine control module connector to the fuel rack actuator position 1 pulse width modulated RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin on the extension harness engine control module connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated RETURN pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 168 is inactive.
OK NOT OK

Fault Code 168 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 169 - Fuel Rack Actuator Position 1 Circuit - Short Circuit (Left Bank)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead. Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rack actuator position 1 (left bank). |
 | STEP 1A. Inspect the fuel pump connector and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 169 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel rack actuator position 1 (left bank).

Guided Step 1A - Inspect the fuel pump connector and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel pump connector.

Action

Inspect the harness and the fuel pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or connector damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the left bank fuel pump connector.

Action

Check the resistance of the fuel pump rack actuator.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin to the fuel rack actuator position 1 pulse width modulated RETURN pin of the fuel pump connector.
OK NOT OK

0.5 to 1.5 ohms

Replace the fuel pump. Reference the following procedures in these manuals:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the left bank fuel pump.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or connector damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or eplace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump.

Action

Check for short circuit to ground.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Inspect the engine and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or connector damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use the electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated RETURN pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit to ground.

  • Measure the resistance from the fuel rack actuator position 1 pulse width modulated RETURN pin on the extension harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 169 is inactive.
OK NOT OK

Fault Code 169 inactive

Replace the engine control module. Refer to Procedure 019-031 Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 171 - Fuel Rack Actuator Position 1 Circuit - Data Incorrect (Left Bank)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify rack position movement. |
 | STEP 1A. Verify rack position at zero position. | Rack position is between 0 to 3 mm
 | STEP 1B. Verify that the rack position changes. | Rack position changes at each step
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 171 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify rack position movement.

Guided Step 1A - Verify rack position at zero position.

Conditions

  • Operation mode switch in Manual position.
  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Verify that the rack position is zero.

  • Use INSITE™ electronic service tool to monitor the left rack position and verify that it is zero when left rack DC is set to zero.
OK NOT OK

Rack position is between 0 to 3 mm

Replace the fuel pump. Reference the following manuals for the procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.

Go to 1B

Go to 2A

Guided Step 1B - Verify that the rack position changes.

Conditions

  • Operation mode switch in Manual position.
  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Verify that the fuel rack position changes.

  • Use INSITE™ electronic service tool to perform the fuel rack position test for the left bank. Input a rack position of 15, 10, 5, 0 mm and monitor left rack position.

Note: The fuel rack position 1 override command is located under the Test/Fuel System Test menu in INSITE™ electronic service tool.

OK NOT OK

Rack position changes within plus or minus 3 mm of the commanded position at each step

Replace the fuel pump. Reference the following manuals for the procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 171 is inactive.
OK NOT OK

Fault Code 171 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-Apr-2012


FAULT CODE 174 - Fuel Rack Actuator Position 2 Circuit - Data Incorrect (Right Bank)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify rack position movement. |
 | STEP 1A. Verify rack position at zero position. | Rack position is between 0-3mm
 | STEP 1B. Verify that the rack position changes. | Rack position changes at each step
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 174 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify rack position movement.

Guided Step 1A - Verify rack position at zero position.

Conditions

  • Operation mode switch in Manual position.
  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™electronic service tool.

Action

Verify that the rack position is zero.

  • Use INSITE™ electronic service tool to monitor the right rack position and verify that it is zero when right rack DC is set to zero.
OK NOT OK

Rack position is between 0-3mm

Replace the fuel pump. Reference the following procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1B

Go to 2A

Guided Step 1B - Verify that the rack position changes.

Conditions

  • Place operation mode switch in the manual position.
  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Verify that the fuel rack position changes.

  • Perform the fuel rack position test for the right bank using the electronic service tool. Input a rack position of 15, 10, 5, 0 mm and monitor right rack position.

Note: The fuel rack position 2 override command is located under the Test/Fuel System Test menu in the electronic service tool.

OK NOT OK

Rack position changes within + or − 3 mm of the commanded position at each step

Replace the fuel pump. Reference the following procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 174 is inactive.
OK NOT OK

Fault Code 174 inactive

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Apr-2012


FAULT CODE 182 - Fuel Rack Actuator Position 2 Circuit - Short Circuit (Right Bank)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rack actuator position 2 (right bank). |
 | STEP 1A. Inspect the fuel pump connector and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 182 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel rack actuator position 2 (right bank).

Guided Step 1A - Inspect the fuel pump connector and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel pump connector.

Action

Inspect the harness and the fuel pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or connector damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the right bank fuel pump connector.

Action

Check the resistance of the fuel pump rack actuator.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin to the fuel rack actuator position 2 pulse width modulated RETURN pin of the fuel pump connector.
OK NOT OK

0.5 to 1.5 ohms

Replace the fuel pump. Reference the following procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the right bank fuel pump.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or connector damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump.

Action

Check for short circuit to ground.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Inspect the engine and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or connector damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated RETURN pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit to ground.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated RETURN pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 182 is inactive.
OK NOT OK

Fault Code 182 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 183 - Fuel Rack Actuator Position 2 Circuit - Open Circuit (Right Bank)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rack actuator position 2 (right bank). |
 | STEP 1A. Inspect the actuator and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
 | STEP 1C. Check for short circuit to engine block ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 183 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel rack actuator position 2 (right bank).

Guided Step 1A - Inspect the actuator and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the right bank fuel pump connector.

Action

Inspect the harness and the fuel pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-207 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the fuel pump. Reference the following procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the right bank fuel pump connector.

Action

Check the resistance of the fuel pump rack actuator.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin to the fuel rack actuator position 2 pulse width modulated RETURN pin of the fuel pump connector.
OK NOT OK

0.5 to 1.5 ohms

Replace the fuel pump. Reference the following procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1C

Go to 4A

Guided Step 1C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the right bank fuel pump connector.

Action

Check for short circuit to ground in the fuel pump rack actuator.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin to engine block ground.
  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated RETURN pin to engine block ground.
OK NOT OK

More than 100k ohms

Replace the fuel pump. Reference the following procedures:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the right bank fuel pump.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the right bank fuel pump.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin on the engine harness inline connector to the fuel rack actuator position 2 pulse width modulated SUPPLY pin on the engine harness fuel pump connector.
  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated RETURN pin on the engine harness inline connector to the fuel rack actuator position 2 pulse width modulated RETURN pin on the engine harness fuel pump connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 n Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use the electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check for an open circuit in the extension harness.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin on the extension harness engine control module connector to the fuel rack actuator position 2 pulse width modulated SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated RETURN pin on the extension harness engine control module connector to the fuel rack actuator position 2 pulse width modulated RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin on the extension harness engine control module connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rack actuator position 2 pulse width modulated RETURN pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 183 is inactive.
OK NOT OK

Fault Code 183 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 197 - Engine Coolant Level Low - Warning

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the coolant is low. |
 | STEP 1A. Check the coolant level. | Coolant level is normal
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Confirm the fault is still active with the engine operating. | Fault is still active
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault code 197 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify that the coolant is low.

Guided Step 1A - Check the coolant level.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

temp

  • Remove the radiator cap and inspect coolant level.
OK NOT OK

Coolant level is normal

Add coolant to the radiator.

Note: Make sure coolant has proper amount of antifreeze, DCA, and water.

Go to 2A

Go to 3A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Confirm the fault is still active with the engine operating.

Conditions

  • Connect the electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Confirm the fault is still active.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault is still active. Replace sensor. Refer to Procedure 019-017 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the coolant level sensor.
OK NOT OK

Fault code threshold is set correctly. Reference Section TS, symptom tree T020 and T021

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and let idle for 1 minute.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 197 is inactive.
OK NOT OK

Fault Code 197 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Apr-2012


FAULT CODE 212 - Engine Oil Temperature Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Amp™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead, and Part Number 3163594 - ECM harness breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the oil temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 212 inactive, Fault Code 213 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 212 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the oil temperature sensor.
OK NOT OK

No other fault codes are active

Go to 2A

Multiple fault tree

Guided Step 2 - Check the oil temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the oil temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the oil temperature sensor.

Action

Check the resistance of the oil temperature sensor.

  • Measure the resistance between the oil temperature SIGNAL pin and the oil temperature RETURN pin.
OK NOT OK

600 ohms to 36k ohms

  • Replace the oil temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the oil temperature RETURN pin on the engine harness inline connector to the oil temperature RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the engine harness inline connector to the oil temperature SIGNAL pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.

Action

Inspect the extension harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the oil temperature RETURN pin on the extension harness connector to the oil temperature RETURN pin at the extension harness inline connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the extension harness connector to the oil temperature SIGNAL pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 n Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the oil temperature SIGNAL pin and the oil temperature RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 212 inactive, Fault Code 213 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 212 is inactive.
OK NOT OK

Fault Code 212 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Apr-2012


FAULT CODE 213 - Engine Oil Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the oil temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damage pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 213 inactive, Fault Code 212 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 213 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the oil temperature sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the oil temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the oil temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the oil temperature sensor.

Action

Check the resistance of the oil temperature sensor.

  • Measure the resistance between the oil temperature SIGNAL pin and the oil temperature RETURN pin.
OK NOT OK

600 ohms to 36k ohms

  • Replace the oil temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the oil temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the oil temperature sensor connector to the engine block ground.
OK NOT OK

More than 100k ohms

  • Replace the oil temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from oil temperature sensor.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil temperature SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the oil temperature RETURN pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from oil temperature sensor.
  • Disconnect engine harness from extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the oil temperature SIGNAL pin on the engine harness inline connector to the oil temperature sensor connector SIGNAL pin.
  • Measure the resistance from the oil temperature RETURN pin on the engine harness inline connector to the oil temperature sensor connector RETURN pin.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from ECM.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil temperature SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the oil temperature RETURN pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19..

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from ECM.
  • Disconnect extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the oil temperature SIGNAL pin on the extension harness connector to the oil temperature SIGNAL pin at the extension harness inline connector.
  • Measure the resistance from the oil temperature RETURN pin on the extension harness connector to the oil temperature RETURN pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the oil temperature SIGNAL pin and the oil temperature SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 213 inactive, Fault Code 212 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 213 is inactive.
OK NOT OK

Fault Code 213 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Apr-2012


FAULT CODE 214 - Engine Oil Temperature High - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the ECM sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 214 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect the temperature probe to the engine near the oil temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the oil temperature reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Sensor reading is incorrect

Go to 2A

Fault Code 212

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM sensor value.

  • Verify that the fault simulation is not enabled for the oil temperature sensor by connecting to the ECM via the electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 3A

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the oil temperature sensor.
OK NOT OK

Fault threshold is set correctly. Reference the Lubricating Oil Temperature Above Specification symptom tree in Section TS:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 214 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Apr-2012


FAULT CODE 219 - Low Oil Level Detected in Centinel™ Make Up Tank

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

Action

Verify oil level in makeup tank.

Refer to Centinel™ Master Repair Manual, Bulletin 3666231.
OK NOT OK

Oil level is OK.

  • Add oil to the Centinel™ Oil Makeup tank.
  • If the fault remains active with a full Centinel™ Oil Makeup tank, remove and clean the oil level sensor.

Repair Complete

Repair Complete

Last Modified: 10-Apr-2012


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the barometric pressure sensor signal voltage. | Acceptable signal voltage
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 221 inactive, Fault Code 222 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 221 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine specific wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the barometric pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the barometric pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the ambient air pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the barometric pressure sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the barometric pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the ambient air pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

Acceptable signal voltage? Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

  • Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the barometric pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the barometric air pressure RETURN pin on the engine harness inline connector to the barometric air pressure RETURN pin at the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the barometric pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the barometric pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the barometric air pressure +5 VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the barometric air pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the barometric air pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the barometric air pressure RETURN pin on the extension harness connector to the barometric air pressure RETURN pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the barometric air pressure +5 VDC SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the barometric air pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the barometric air pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the barometric air pressure SIGNAL pin and the barometric air pressure RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 221 inactive, Fault Code 222 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 221 is inactive.
OK NOT OK

Fault Code 221 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Apr-2012


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, and Part Number 3163594 - ECM connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the barometric pressure sensor signal voltage. | Altitude (ft) - Voltage, 0 (sea level) - 4.00 to 4.58, 3000 - 3.60 to 4.40, 6000 - 3.20 to 4.00, 9000 - 3.00 to 3.80, 12,000 - 2.60 to 3.40
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 222 inactive, Fault Code 221 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 222 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the barometric pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the barometric pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the ambient air pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the barometric pressure sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the barometric pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the ambient air pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

Acceptable signal voltage? Refer to specific engine wiring diagram for the output voltage of the pressure sensor.

  • Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the barometric pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the barometric air pressure SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the barometric air pressure RETURN pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the barometric pressure SUPPLY pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the barometric pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the barometric air pressure SIGNAL pin on the engine harness inline connector to the barometric air pressure SIGNAL pin at the engine harness sensor connector.
  • Measure the resistance from the barometric air pressure +5 VDC SUPPLY pin on the engine harness inline connector to the barometric air pressure +5 VDC SUPPLY pin at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the barometric pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the barometric pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the barometric air pressure +5 VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the barometric air pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the barometric air pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the barometric air pressure SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the barometric air pressure RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the barometric air pressure +5 VDC SUPPLY pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the barometric air pressure SIGNAL pin on the extension harness connector to the barometric air pressure SIGNAL pin at the extension harness inline connector.
  • Measure the resistance from the barometric air pressure +5 VDC SUPPLY pin on the extension harness connector to the barometric air pressure +5 VDC SUPPLY pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the barometric air pressure +5 VDC SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the barometric air pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the barometric air pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the barometric air pressure SIGNAL pin and the barometric air pressure +5 VDC SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 222 inactive, Fault Code 221 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 222 is inactive.
OK NOT OK

Fault Code 222 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Apr-2012


FAULT CODE 223 - Centinel™ Burn Valve Solenoid Circuit - Voltage Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead Part Number 3823995 - male Weather-Pack™ test lead Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the burn valve solenoid. |
 | STEP 1A. Verify the burn valve solenoid is connected to the engine harness. | Solenoid is connected
 | STEP 1B. Inspect the burn valve solenoid and harness connector pins. | No damaged pins
 | STEP 1C. Check for an open circuit. | Less than 120 ohms
 | STEP 1D. Check short circuit to engine block ground. | More than 80 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and extension harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and engine control module connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 225 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the burn valve solenoid.

Guided Step 1A - Verify the burn valve solenoid is connected to the engine harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Verify the burn valve solenoid is connected to the engine harness.
OK NOT OK

Solenoid is connected

Connect the solenoid to the engine harness

Go to 1B

Go to 4A

Guided Step 1B - Inspect the burn valve solenoid and harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the burn valve solenoid.

Action

Inspect the burn valve solenoid and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the burn valve solenoid. Refer to Procedure 019-173 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the burn valve solenoid from the engine harness.

Action

Check for an open circuit in the burn valve solenoid.

  • Measure the resistance from pin A to pin B of the burn valve solenoid connector.
OK NOT OK

Less than 120 ohms

Replace the burn valve solenoid. Refer to Procedure 019-173 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit to engine block ground.

Conditions

  • Disconnect the engine harness from the burn solenoid valve.

Action

Check for a short circuit to ground in the burn valve solenoid.

  • Measure the resistance from pin A of the burn solenoid connector to engine block ground.
OK NOT OK

More than 80 ohms

Replace the burn valve solenoid. Refer to Procedure 019-173 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the burn valve solenoid from the engine harness.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit in the burn valve solenoid circuit.

  • Measure the resistance from the Centinel™ actuator +5 VDC SUPPLY pin on the engine harness inline connector to the Centinel™ actuator +5 VDC SUPPLY pin at the engine harness solenoid connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the burn valve solenoid from the engine harness.
  • Disconnect the engine harness from the extension harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the Centinel™ actuator +5 VDC SUPPLY pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the burn valve solenoid.
  • Disconnect the engine harness from the extension harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Centinel™ actuator +5 VDC SUPPLY pin on the engine harness inline connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for an open circuit in the burn valve solenoid circuit.

  • Measure the resistance from the Centinel™ actuator +5 VDC SUPPLY pin on the extension harness engine control module connector to the Centinel™ actuator +5 VDC SUPPLY pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to ground.

  • Measure the resistance from the Centinel™ actuator +5 VDC SUPPLY pin on the extension harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Centinel™ actuator +5 VDC SUPPLY pin on the extension harness engine control module connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 223 is inactive.
OK NOT OK

Fault Code 223 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in the RUN position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Apr-2012


FAULT CODE 228 - Engine Coolant Pressure Low - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant pressure sensor accuracy. |
 | STEP 1A. Verify the coolant pressure sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Check the ECM sensor value. |
 | STEP 2A. Verify that the fault simulation feature is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 228 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the coolant pressure sensor accuracy.

Guided Step 1A - Verify the coolant pressure sensor accuracy with a mechanical gauge.

Conditions

  • Connect a mechanical coolant pressure gauge of known quality and calibration to the engine.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Start the engine and compare the coolant pressure reading on INSITE™ electronic service tool monitor screen to the reading on the mechanical coolant pressure gauge.

NOTE: The engine speed will have to be increased to make it easier to see the differences in the readings.
OK NOT OK

Sensor reading is correct. Reference the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Fault Code 232

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM sensor values.

  • Verify that the fault simulation is not enabled for the coolant pressure sensor by connecting to the ECM via INSITE™ electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the oil pressure sensor.
OK NOT OK

Fault threshold is set correctly. Reference symptom trees T020 and T021 in Section TS in the following manuals"

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 228 is inactive.

NOTE: If fault was at a particular speed, operate engine at that speed to verify problem is corrected.
OK NOT OK

Fault Code 228 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Apr-2012


FAULT CODE 231 - Engine Coolant Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - ECM connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the coolant pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 231 inactive, Fault Code 232 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 231 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the coolant pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the coolant pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the coolant pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the coolant pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the coolant pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the coolant pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the coolant pressure RETURN pin on the engine harness inline connector to the coolant pressure RETURN pin at the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the coolant pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant pressure +5 VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the coolant pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the coolant pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the coolant pressure RETURN pin on the extension harness connector to the coolant pressure RETURN pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant pressure +5 VDC SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the coolant pressure SIGNAL pin and the coolant pressure RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 231 inactive, Fault Code 232 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 231 is inactive.
OK NOT OK

Fault Code 231 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Apr-2012


FAULT CODE 232 - Coolant Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - ECM connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the coolant pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the ECM connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the ECM response. |
 | STEP 5A. Check for the appropriate ECM response. | Fault Code 232 inactive, Fault Code 231 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault codes. | Fault Code 232 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the coolant pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the coolant pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the coolant pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Place the run/stop/auto switch in the RUN position.

Action

Check the coolant pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Place the run/stop/auto switch in the RUN position.

Action

Check the coolant pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the coolant pressure SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the coolant pressure RETURN pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the coolant pressure +5 VDC SUPPLY pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the coolant pressure SIGNAL pin on the engine harness inline connector to the coolant pressure SIGNAL pin at the engine harness sensor connector.
  • Measure the resistance from the coolant pressure +5 VDC SUPPLY pin on the engine harness inline connector to the coolant pressure +5 VDC SUPPLY pin at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the coolant pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant pressure +5 VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the coolant pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the coolant pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the ECM.

Action

Inspect the extension harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the coolant pressure SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the coolant pressure +5 VDC SUPPLY pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the coolant pressure SIGNAL pin on the extension harness connector to the coolant pressure SIGNAL pin at the extension harness inline connector.
  • Measure the resistance from the coolant pressure +5 VDC SUPPLY pin on the extension harness connector to the coolant pressure +5 VDC SUPPLY pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant pressure +5 VDC SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the ECM.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate ECM connector.
  • Install a jumper wire between the coolant pressure SIGNAL pin and the coolant pressure +5 VDC SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 232 inactive, Fault Code 231 active

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 232 is inactive.
OK NOT OK

Fault Code 232 inactive

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Apr-2012


FAULT CODE 233 - Coolant Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant pressure sensor accuracy. |
 | STEP 1A. Verify the coolant pressure sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Check the ECM sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the coolant pressure sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 233 inactive
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the coolant pressure sensor accuracy.

Guided Step 1A - Verify the coolant pressure sensor accuracy with a mechanical gauge.

Conditions

  • Connect a mechanical coolant pressure gauge of known quality and calibration to the engine.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Start engine and compare the coolant pressure reading on the electronic service tool monitor screen to the reading on mechanical coolant pressure gauge.

NOTE: The engine rpm will need to be increased to make it easier to see differences in the readings.
OK NOT OK

Sensor reading is correct. Reference the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Fault Code 232

Guided Step 2 - Check the ECM sensor value.

Guided Step 2A - Verify that the fault simulation feature for the coolant pressure sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM sensor value.

  • Verify that the fault simulation is not enabled for the coolant pressure sensor by connecting to the ECM via INSITE™ electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the ECM.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the oil pressure sensor.
OK NOT OK

Fault threshold is set correctly. Reference the TS section of the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

NOTE: If the fault was at a particular rpm, operate engine at that rpm to verify the problem is corrected.
OK NOT OK

Fault Code 233 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear any inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the STOP position.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Apr-2012


FAULT CODE 234 - Engine Speed High - Critical

Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 2650 rpm, the engine must be shut off immediately.
CAUTION

To reduce the possibility of damaging the new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | No load dump
 | STEP 1B. Verify whether any fault simulation feature is enabled. | None enabled
 | STEP 1C. Check threshold setting. | Fault threshold is set correctly
 | STEP 1D. Check for an alternate fuel source. | No alternate fuel source
 | STEP 1E. Check the engine rpm with the monitor mode. | Correct rpm reading
 | STEP 1F. Check the injector overhead settings. | Correct injector overhead settings
 | STEP 1G. Check for an active fault at low engine rpm. | Inactive fault at low rpm
 | STEP 1H. Test the generator. | Inactive fault
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for proper operating conditions.

  • Check if the engine was just coming off a load dump when the fault was logged.
OK NOT OK

No load dump

Check the engine for damage.

  • Electronics are functional.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Verify whether any fault simulation feature is enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify there are no fault simulations.

  • Use INSITE™ electronic service tool to verify there are no fault simulations enabled.
OK NOT OK

None enabled

Disable all fault simulations

Go to 1C

Go to 2A

Guided Step 1C - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that the fault threshold is not within the normal operating range for the engine overspeed sensor.
OK NOT OK

Fault threshold is set correctly. Reference symptom tree Engine Will Not Shut Off in Section TS:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 1D

Go to 2A

Guided Step 1D - Check for an alternate fuel source.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for an alternate fuel source.

  • Check if the operator reported a fuel controlled event where the engine rapidly accelerated, followed by moderate deceleration.
OK NOT OK

No alternate fuel source

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

Go to 1E

Go to 2A

Guided Step 1E - Check the engine rpm with the monitor mode.

Conditions

  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Check the engine rpm with the monitor mode.

  • Use INSITE™ electronic service tool to monitor the engine rpm.
OK NOT OK

Correct rpm reading

Inspect the engine position sensor. Check the engine position sensor as outlined for Fault Codes 115 and 121, or Fault Codes 689 and 778.

Go to 1F

Fault Codes 115 and 121 or 689 and 778

Guided Step 1F - Check the injector overhead settings.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the injector overhead settings. Check for correct injector overhead settings. Use the procedure in the following manuals:

  • Refer to Procedure 003-004 in Section 3. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 003-006 in Section 3. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 003-004 in Section 3. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 003-006 in Section 3. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 003-006 in Section 3. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
OK NOT OK

Correct injector overhead settings

Reset the overhead per the outer base circle method. Inspect the base engine for damage due to an overspeed condition.

Go to 1G

Go to 2A

Guided Step 1G - Check for an active fault at low engine rpm.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Check for an active fault at low engine rpm.

  • Check for active Fault Code 234 when the engine is not operating above the engine overspeed shutdown threshold.
OK NOT OK

Inactive fault at low rpm

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 1H

Go to 2A

Guided Step 1H - Test the generator.

Action

Test the generator.

  • Check if the overspeed condition is still present.
OK NOT OK

Inactive fault

Adjust the governor gain settings as outlined for Fault Code 1418.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and check again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 234 is inactive.
OK NOT OK

Fault Code 234 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 235 - Engine Coolant Level Low - Critical

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

Do not add cold coolant to a hot engine. Casting can be damaged. Allow engine to cool to below 50°C [120°F] before adding coolant.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the coolant is low. |
 | STEP 1A. Check the coolant level. | Coolant level is normal
STEP 2. | Check the coolant level sensor. |
 | STEP 2A. Confirm the fault is still active with the engine running. | Fault is still active
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 235 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify that the coolant is low.

Guided Step 1A - Check the coolant level.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

temp

  • Remove the radiator cap and inspect coolant level.
OK NOT OK

Coolant level is normal

Add coolant to the radiator.

Note: Make sure coolant has proper amount of antifreeze, DCA, and water.

Go to 2A

Go to 3A

Guided Step 2 - Check the coolant level sensor.

Guided Step 2A - Confirm the fault is still active with the engine operaating.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Confirm the fault is still active.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault is still active. Replace sensor.

Refer to Procedure 019-017 in Section 19.

Fault is still active.

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the oil pressure sensor.
OK NOT OK

Fault threshold is set correctly.

Reference symptom tres, Coolant Loss and Coolant Loss - Interna in,Section TS, in the the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QST30 Service Manual, Bulletin 4021539.

Fault threshold is not set correctly.

Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 235 is inactive.
OK NOT OK

Fault Code 235 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Apr-2012


FAULT CODE 236 - Engine Speed/Position Sensor Circuit - Loss of Signal

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot individual fault codes. |
 | STEP 1A. Troubleshoot Fault Code 689. | Fault Code 689 inactive
 | STEP 1B. Troubleshoot Fault Code 778. | Fault Code 778 inactive
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 236 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Troubleshoot individual fault codes.

Guided Step 1A - Troubleshoot Fault Code 689.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Confirm the fault is still active.

  • Use INSITE™ electronic service tool to verify the status of Fault Code 689.
OK NOT OK

Fault Code 689 inactive

Fault Code 689 active

Go to 1B

Fault Code 689

Guided Step 1B - Troubleshoot Fault Code 778.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Confirm the fault is still active.

  • Use INSITE™ electronic service tool to verify the status of Fault Code 778.
OK NOT OK

Fault Code 778 inactive

Fault Code 778 active

Go to 2A

Fault Code 778

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 236 is inactive.
OK NOT OK

Fault Code 236 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Apr-2012


FAULT CODE 252 - Engine Oil Level Number 1 Sensor - Data Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the lubricating oil level sensor. |
 | STEP 2A. Inspect the sensor and sensor harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the engine harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the extension harness. |
 | STEP 5A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for an open circuit. | Less than 10 ohms
 | STEP 5D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 252 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the oil level sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the lubricating oil level sensor.

Guided Step 2A - Inspect the sensor and sensor harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness connector from the oil level sensor.

Action

Inspect the sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the sensor.
  • Connect the electronic service tool.

Action

Check the oil level sensor supply voltage.

  • Measure the supply voltage from the oil level SUPPLY pin to the oil level RETURN pin at the sensor connector.
OK NOT OK

4.75 to 5.25-VDC

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil level sensor signal voltage.

  • Use the engine control module breakout box to measure the signal voltage from the oil level sensor by monitoring the voltage between the oil level SIGNAL pin and the oil level RETURN pin.
OK NOT OK

0.46 to 4.56-VDC

  • Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness and the engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.

Action

Inspect the sensor harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil level SIGNAL pin on the sensor harness connector to the engine block ground.
  • Measure the resistance from the oil level SUPPLY pin on the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for an open circuit.

  • Measure the resistance from the oil level SIGNAL pin on the sensor harness connector to the oil level SIGNAL pin on the sensor harness sensor connector.
  • Measure the resistance from the oil level SUPPLY pin on the sensor harness connector to the oil level SUPPLY pin on the sensor harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.
  • Disconnect the sensor harness from all sensors that have a shared supply or return with the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level SUPPLY pin on the sensor harness connector to all other pins in the sensor harness.
  • Measure the resistance from the oil level RETURN pin on the sensor harness connector to all other pins in the sensor harness.
  • Measure the resistance from the oil level SIGNAL pin on the sensor harness connector to all other pins in the sensor harness.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil level SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the oil level SUPPLY pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.

Action

Check for an open circuit.

  • Measure the resistance from the oil level SIGNAL pin on the engine harness inline connector to the oil level SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the oil level SUPPLY pin on the engine harness inline connector to the oil level SUPPLY pin on the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level SUPPLY pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the oil level RETURN pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the oil level SIGNAL pin on the engine harness inline connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the extension harness.

Guided Step 5A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. 019-031 in Section 19.

Go to 5B

Go to 6A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil level SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the oil level SUPPLY pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the oil level SIGNAL pin on the extension harness connector to the oil level SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the oil level SUPPLY pin on the extension harness connector to the oil level SUPPLY pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil level RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil level SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 252 is inactive.
OK NOT OK

Fault Code 252 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Apr-2012


FAULT CODE 253 - Engine Oil Level Number 1 Low - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Determine oil level sensor type. |
 | STEP 1A. Is oil level sensor a 3-pin type? | Sensor is a 3-pin type
STEP 2. | Check the oil level sensor accuracy. |
 | STEP 2A. Verify oil level sensor. | Oil level is correct
STEP 3. | Check the engine control module sensor value. |
 | STEP 3A. Verify that the fault simulation feature for the oil level sensor is not enabled. | Fault simulation is disabled
 | STEP 3B. Check threshold setting. | Fault threshold is set correctly
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 253 inactive
 | STEP 6B. Clear any inactive fault codes. | All fault codes cleared

Guided Step 1 - Determine oil level sensor type.

Guided Step 1A - Determine oil level sensor type.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Is oil level sensor a 3-pin type?

Is the oil level sensor a 3 pin type?
OK NOT OK

Sensor is a 3-pin type

Sensor is a 4-pin type

Go to 2A

Go to 4A

Guided Step 2 - Check the oil level sensor accuracy.

Guided Step 2A - Verify oil level sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Use a dipstick to verify the oil level.
OK NOT OK

Oil level is correct

Fill the engine lubricating oil to the appropriate level. Use the procedure in the following manuals

  • Refer to Procedure 007-037 in Section 7. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 007-037 in Sectin 7. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 007-037 in Section 7. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 007-037 in Section 7. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 007-037 in Section 7. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine control module sensor value.

Guided Step 3A - Verify that the fault simulation feature for the oil level sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Verify that the fault simulation is not enabled for the oil level sensor by connecting to the engine control module via INSITE™ electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 3B

Go to 6A

Guided Step 3B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the oil pressure sensor.
OK NOT OK

Fault threshold is set correctly

Fault threshold is not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 6A

Go to 6A

Guided Step 4 - Verify that the oil is low.

Guided Step 4A - Check the oil level.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the oil level.

  • Verify oil level using the dipstick.
OK NOT OK

Oil level is normal

Fill the engine lubricating oil to the correct level.

Go to 5A

Go to 6A

Guided Step 5 - Check the coolant level sensor.

Guided Step 5A - Confirm the fault is still active with the engine operating.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Confirm the fault is still active.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault still active. Replace sensor. Refer to Procedure 019-017 in Section 19.

Fault not active.

Go to 5B

Go to 6A

Guided Step 5B - Check the threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the oil pressure sensor.
OK NOT OK

Fault threshold set correctly

Fault threshold not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify if Fault Code 253 is inactive.
OK NOT OK

Fault Code 253 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear any inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Apr-2012


FAULT CODE 254 - Fuel Shutoff Valve Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff valve solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff valve solenoid post. | No extra wires
 | STEP 1B. Clean the solenoid posts and the wiring terminal. | Solenoid posts clean
 | STEP 1C. Check the supply voltage at the fuel shutoff valve solenoid. | More than 17.0 VDC for +24 VDC fuel shutoff, More than 11.0 VDC for +12 VDC fuel shutoff
 | STEP 1D. Check the fuel shutoff solenoid resistance. | 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 254 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel shutoff valve solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff valve solenoid post.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for extra wires.

Check for extra wires on the fuel shutoff solenoid post.
OK NOT OK

No extra wires

Remove the extra wires, and connect the removed wires to a proper 24-VDC supply.

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid posts and the wiring terminal.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the fuel shutoff control wire to the fuel shutoff valve solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the posts of the fuel shutoff valve solenoid and the terminal for the fuel shutoff valve solenoid control wires of the engine harness.
OK NOT OK

Solenoid posts clean

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the fuel shutoff valve solenoid. Refer to Procedure 019-050 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check the supply voltage at the fuel shutoff valve solenoid.

Conditions

  • Disconnect the engine harness from the fuel shutoff valve solenoid.
  • Place the run/stop/auto switch in the RUN position.
  • Engine must be cranking.

Action

Check the supply voltage at the fuel shutoff solenoid.

  • Measure the voltage from the fuel shutoff supply wire ring terminal on the harness side to the engine block ground.
OK NOT OK

More than 17.0 VDC for +24 VDC fuel shutoff.

More than 11.0 VDC for +12 VDC fuel shutoff.

Go to 1D

Go to 2A

Guided Step 1D - Check the fuel shutoff solenoid resistance.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.

Action

Check the fuel shutoff solenoid resistance.

  • Measure the resistance from the fuel shutoff solenoid supply post to the fuel shutoff solenoid ground post.

Use the following procedue for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

1 to 5 ohms for 6-VDC solenoids

6 to 15 ohms for 12-VDC solenoids

24 to 50 ohms for 24-VDC solenoids

42 to 80 ohms for 32-VDC solenoids

46 to 87 ohms for 36-VDC solenoids

92 to 145 ohms for 48-VDC solenoids

315 to 375 ohms for 74-VDC solenoids

645 to 735 ohms for 115-VAC solenoids

Replace the fuel shutoff solenoid.

  • Refer to Procedure 005-043 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-043 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-043 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-043 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel shutoff valve solenoid.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to the engine block ground.

Use the following procedue for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel shutoff valve solenoid.
  • Disconnect engine harness from extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to the fuel shutoff valve signal ring terminal.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to the fuel shutoff valve return ring terminal.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel shutoff valve solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

OK NOT OK

More than 100k ohms

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin on the extension harness connector to the fuel shutoff valve SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to the fuel shutoff valve RETURN pin on the extension harness inline connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 254 is inactive.
OK NOT OK

Fault Code 254 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Apr-2012


FAULT CODE 259 - Fuel Shutoff Valve - Stuck Open

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff solenoid posts. | No extra wires
 | STEP 1B. Clean the solenoid posts and the wiring terminals. | Solenoid posts clean
 | STEP 1C. Check the supply voltage at the fuel shutoff solenoid | More than 17.0 VDC for +24 VDC fuel shutoff, More than 11.0 VDC for +12 VDC fuel shutoff.
 | STEP 1D. Check the fuel shutoff solenoid resistance. | 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Replace the fuel shutoff valve solenoid. |
 | STEP 4A. Replace the fuel shutoff valve solenoid. | Fault Code 259 inactive
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 259 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel shutoff solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff solenoid posts.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for extra wires.

Check for extra wires on the shutoff solenoid posts.
OK NOT OK

No extra wires

Connect removed wires to a proper 24-VDC supply.

Go to 1B

Go to 5A

Guided Step 1B - Clean the solenoid posts and the wiring terminals.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the fuel shutoff control wire to the fuel shutoff solenoid.

Action

Clean the solenoid posts and the wiring terminals.

  • Clean the post of the fuel shutoff solenoid and the terminal for the fuel shutoff solenoid control wire of the engine harness.
OK NOT OK

Solenoid posts clean

Repair ring terminal or replace the fuel shutoff valve solenoid.

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the fuel shutoff valve solenoid. Refer to Procedure 019-050 in Section 19.

Go to 1C

Go to 5A

Guided Step 1C - Check the supply voltage at the fuel shutoff solenoid.

Conditions

  • Place the run/stop/auto switch in the RUN position.
  • Engine must be cranking.

Action

Check the supply voltage at the fuel shutoff solenoid.

  • Measure the voltage from the fuel shutoff control wire connector on the harness side to the engine block ground.
OK NOT OK

More than 17.0 VDC for +24 VDC fuel shutoff.

More than 11.0 VDC for +12 VDC fuel shutoff.

Go to 1D

Go to 2A

Guided Step 1D - Check the fuel shutoff solenoid resistance.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.

Action

Check the supply voltage at the fuel shutoff solenoid.

  • Measure the resistance between the two fuel shutoff valve solenoid posts.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

OK NOT OK

1 to 5 ohms for 6-VDC solenoids

6 to 15 ohms for 12-VDC solenoids

24 to 50 ohms for 24-VDC solenoids

42 to 80 ohms for 32-VDC solenoids

46 to 87 ohms for 36-VDC solenoids

92 to 145 ohms for 48-VDC solenoids

315 to 375 ohms for 74-VDC solenoids

645 to 735 ohms for 115-VAC solenoids

Replace the fuel shutoff solenoid.

  • Refer to Procedure 005-043 in Section 19. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-043 in Section 19. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-043 in Section 19. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-043 in Section 19. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel shutoff solenoid.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to the engine block ground.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel shutoff solenoid.
  • Disconnect engine harness from extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to the fuel shutoff valve SIGNAL pin, at the solenoid.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to the fuel shutoff valve RETURN pin, at the solenoid.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel shutoff solenoid.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel shutoff solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to the engine block ground.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to the fuel shutoff valve SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to the fuel shutoff valve RETURN pin on the extension harness inline connector.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms.

Reference symptom tree t081, Engine Will Not Shut Off, Section TS in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

t081, Engine Will Not Shut Off

Go to 5A

Guided Step 4 - Replace the fuel shutoff valve solenoid.

Guided Step 4A - Replace the fuel shutoff valve solenoid.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the harness from the fuel shutoff valve solenoid.

Action

Check for a short circuit from pin to pin.

  • Refer to Procedure 019-050 in Section 19.
OK NOT OK

Fault Code 259 inactive

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 259 is inactive.
OK NOT OK

Fault Code 259 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-Apr-2012


FAULT CODE 261 - Fuel Temperature High - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 261 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the fuel temperature reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 263

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Verify that the fault simulation is not enabled for the fuel temperature sensor by connecting to the engine control module via the electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the fuel temperature sensor.
OK NOT OK

Fault threshold is set correctly. Reference symptom tree T057 Section TS:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 261 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Apr-2012


FAULT CODE 263 - Fuel Temperature Sensor Circuit - Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the engine control module response. |
 | STEP 5A. Check for the appropriate engine control module response. | Fault Code 263 inactive, Fault Code 265 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable Fault Code. | Fault Code 263 inactive
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel temperature sensor.
OK NOT OK

No other fault codes are active

Multiple fault codes are active

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the fuel temperature SIGNAL pin and the fuel temperature RETURN pin.
OK NOT OK

600 ohms to 36k ohms

  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel temperature RETURN pin on the engine harness inline connector to the fuel temperature RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the engine harness inline connector to the fuel temperature SIGNAL pin at the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel temperature RETURN pin on the extension harness connector to the fuel temperature RETURN pin at the extension harness inline connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the extension harness connector to the fuel temperature SIGNAL pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine control module response.

Guided Step 5A - Check for the appropriate engine control module response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the fuel temperature SIGNAL pin and the fuel temperature RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 263 inactive, Fault Code 265 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 263 is inactive.
OK NOT OK

Fault Code 263 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault code.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 265 - Fuel Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the engine control module response. |
 | STEP 5A. Check for the appropriate engine control module response. | Fault Code 265 inactive, Fault Code 263 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 265 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for a multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the fuel temperature sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the fuel temperature SIGNAL pin and the fuel temperature pin.
OK NOT OK

600 ohms to 36k ohms

  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the fuel temperature sensor connector to the engine block ground.
OK NOT OK

More than 100k ohms

  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel temperature sensor.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel temperature SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel temperature RETURN pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel temperature SIGNAL pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel temperature RETURN pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel temperature SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine control module response.

Guided Step 5A - Check for the appropriate engine control module response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the fuel temperature SIGNAL pin and the fuel temperature SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 265 inactive, Fault Code 263 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 265 is inactive.
OK NOT OK

Fault Code 265 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Apr-2012


FAULT CODE 266 - Fuel Temperature High - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 266 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the fuel temperature reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 263

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Verify that the fault simulation is not enabled for the fuel temperature sensor by connecting to the engine control module via the electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the fuel temperature sensor.
OK NOT OK

Fault threshold is set correctly. Reference symptom tree T057 in Section TS in the following manuals:

  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 266 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Apr-2012


FAULT CODE 316 - Fuel Supply Pump Actuator - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pump actuator. |
 | STEP 1A. Inspect the actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the coil resistance of the fuel pump actuator. | 7.0 to 9.0 ohms
 | STEP 1C. Check for a SUPPLY pin short to engine block ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 20 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for a short circuit to the power supply. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 20 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for a short circuit to the power supply. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 316 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel pump actuator.

Guided Step 1A - Inspect the actuator and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel pump actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the coil resistance of the fuel pump actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check the coil resistance.

  • Measure the resistance of the fuel pump actuator.
OK NOT OK

7.0 to 9.0 ohms

  • Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a SUPPLY pin short to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for the SUPPLY pin short to engine block ground.

  • Measure the resistance from pin A to the engine block ground.
  • Measure the resistance form pin B to the engine block ground.
OK NOT OK

More than 100k ohms

  • Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel pump actuator SUPPLY pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump actuator SIGNAL pin on the engine harness inline connector to the fuel pump actuator SIGNAL pin on the engine harness actuator connector.
  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness inline connector to the fuel pump actuator RETURN pin on the engine harness actuator connector.
OK NOT OK

Less than 20 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pump actuator SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to the power supply.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for a short circuit from power supply.

  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness inline connector to all SUPPLY pins on the engine harness inline connector.
  • Measure the resistance from the fuel pump actuator SIGNAL pin on the engine harness inline connector to all SUPPLY pins on the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel pump actuator SUPPLY pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump actuator SIGNAL pin on the extension harness connector to the fuel pump actuator SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to the fuel pump actuator RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 20 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump actuator SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit to the power supply.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit from power supply.

  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to all SUPPLY pins on the extension harness connector.
  • Measure the resistance from the fuel pump actuator SIGNAL pin on the extension harness connector to all SUPPLY pins on the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 316 is inactive.
OK NOT OK

Fault Code 316 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Apr-2012


FAULT CODE 318 - Fuel Supply Pump Actuator - Mechanically Stuck

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the complaint. |
 | STEP 1A. Are other fault codes active besides Fault Code 318? | Other fault codes not active
 | STEP 1B. Interview the operator. Are engine symptoms present? | Symptoms present
STEP 2. | Check the suction-side of the fuel system flow. |
 | STEP 2A. Check the fuel tank level. | Fuel in tank
 | STEP 2B. Inspect the fuel system for leaks, broken lines, and loose fittings. | No leaks, broken lines, or loose fittings
 | STEP 2C. Check the fuel inlet restriction. | Less than 203 mm-Hg [8 in-Hg]
 | STEP 2D. Check for air in the fuel. | Minimal air in the fuel
STEP 3. | Check the pressure-side fuel system flow. |
 | STEP 3A. Check the fuel pump output pressure. | min 55 psi @ 600 rpm, min 175 psi @ 1300 rpm, min 250 psi @ 2100 rpm, min 265 psi @ 2350 rpm
 | STEP 3B. Check the fuel pump output pressure sensor. | Sensor agrees with mechanical gauge
 | STEP 3C. Inspect the actuator screen for debris. | No debris
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 318 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify the complaint.

Guided Step 1A - Are other fault codes active besides Fault Code 318?

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Check for other active fault codes besides Fault Code 318.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Other fault codes not active

Investigate other fault codes first

Go to 1B

Appropriate fault tree

Guided Step 1B - Interview the operator. Are engine symptoms present?

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Interview the operator for the following:

  • Are engine symptoms present?
  • Is the operator complaining about specific symptoms or shutdowns/derates due to Fault Code 318?
OK NOT OK

Symptoms present

Clear the fault. Inactive faults have been logged. Since operator is not experiencing a problem, clear the fault.

Go to 2A

Go to 4B

Guided Step 2 - Check the suction-side of the fuel system flow.

Guided Step 2A - Check the fuel tank level.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the fuel tank level for the following:

  • Fuel in the tank.
OK NOT OK

Fuel in tank

Fill the tank with fuel

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings.
OK NOT OK

No leaks, broken lines, or loose fittings

Repair the leak. Tighten or replace the leaking fitting or fuel line. Replace the fuel line.Reference the following manuals:

  • Refer to Procedure 006-024 in Section 6. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 006-024 in Section 6. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 006-024 in Section 6. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 006-024 in Section 6. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 006-024 in Section 6. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel inlet restriction.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Measure the inlet restriction as follows:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
OK NOT OK

Less than 203 mm-Hg [8 in-Hg]

Find the cause of the restriction and remove the restriction. Check for clogged fuel filters, debris in the fuel tank, fuel tank vents clogged, collapsed or faulty fuel lines, or faulty check valves.

Go to 2D

Go to 4A

Guided Step 2D - Check for air in the fuel.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check for air in the fuel. Reference the procedure in the following manuals:

Refer to Procedure 006-003 in Section 6. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Refer to Procedure 006-003 in Section 6. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.

Refer to Procedure 006-003 in Section 6. QST30 Service Manual, Bulletin 4021539.

Refer to Procedure 006-003 in Section 6. QSK45 and QSK60 Service Manual, Bulletin 4021530.

Refer to Procedure 006-003 in Section 6. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

OK NOT OK

Minimal air in the fuel

Find the cause of air in the fuel. Check for missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.

Go to 3A

Go to 4A

Guided Step 3 - Check the pressure-side fuel system flow.

Guided Step 3A - Check the fuel pump output pressure.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check the fuel pump output pressure. Reference the procedure in the following manuals:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
OK NOT OK

min 55 psi @ 600 rpm, min 175 psi @ 1300 rpm, min 250 psi @ 2100 rpm, min 265 psi @ 2350 rpm

Go to 3B

Go to A1

Guided Step 3B - Check the fuel pump output pressure sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the fuel pump output pressure sensor.

Measure the output pressure of the pump at the check fitting. Compare this mechanical reading to fuel pump pressure sensor parameter. Refer to the electronic service tool manual for the procedure to monitor this parameter. Reference the procedure in the following manuals:

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
OK NOT OK

At various speed and load points, the fuel pump pressure sensor agrees with mechanical sensor.

Replace the fuel pump pressure sensor. Refer to Procedure 019-117 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the actuator screen for debris.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the fuel pump actuator screen for debris.

  • Remove the fuel pump actuator. Refer to Procedure 019-117 in Section 19.
OK NOT OK

No debris

Replace the fuel pump actuator screen. Refer to Procedure 019-117 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and run throughout the operating range to verify the Fault Code 318 stays inactive.
OK NOT OK

Fault Code 318 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Apr-2012


FAULT CODE 326 - Engine Oil Level Number 1 Low - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil level sensor accuracy. |
 | STEP 1A. Verify the oil level sensor. | Oil level is correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the oil level sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 326 inactive
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the oil level sensor accuracy.

Guided Step 1A - Verify oil level sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Verify the oil level using the oil dipstick.
OK NOT OK

Oil level is correct

Drain the engine lubricating oil to the appropriate level

Go to 2A

Go to 3A

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the oil level sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Verify that the fault simulation is not enabled for the oil level sensor by connecting to the engine control module via INSITE™ electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the oil level sensor.
OK NOT OK

Fault threshold is set correctly. Reference symptom tree T087 in Section TS in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Place the idle/rated switch in the IDLE position.
  • Start engine and idle for 1 minute.

NOTE: If the fault was at a particular rpm, run engine at that rpm to verify the problem is corrected.
OK NOT OK

Fault Code 326 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear any inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Apr-2012


FAULT CODE 343 - Engine Control Module - Warning

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 343 inactive
 | STEP 1B. Disconnect the power to the engine control module. | Fault Code 343 inactive
STEP 2. | Check the power and ground connections. |
 | STEP 2A. Check all engine and chassis power and ground connections. | Clean and tight
 | STEP 2B. Check all power resistances. | Less than 10 ohms
 | STEP 2C. Check all ground resistances. | Less than 10 ohms
STEP 3. | Check for moisture in the connectors. |
 | STEP 3A. Check for moisture in the engine control module connectors. | All connectors dry
 | STEP 3B. Check for moisture in the inline connectors. | All connectors dry
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 343 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position and wait at least 5 seconds.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Read the fault code.

  • Use INSITE™ electronic service tool to check for Fault Code 343.
OK NOT OK

Fault Code 343 inactive

Go to 2A

Go to 1B

Guided Step 1B - Disconnect the power to the engine control module.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Disconnect power to the engine control module.

  • Disconnect the power to the engine control module at the battery.
  • Wait 1 minute.
  • Connect the power to the engine control module at the battery.
  • Connect INSITE™ electronic service tool to the datalink.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.
  • Use INSITE™ electronic service tool to check for inactive Fault Code 343.
OK NOT OK

Fault Code 343 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the power and ground connections.

Guided Step 2A - Check all engine and chassis power and ground connections.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check all engine and vehicle power and ground connections for the following:

  • Corrosion
  • Loose connections.
OK NOT OK

Clean and tight

Repair or replace damaged connection(s).

Go to 2B

Go to 4A

Guided Step 2B - Check all power resistances.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the negative battery cable from the battery.
  • Disconnect the positive battery cable from the battery.

Action

Check all power resistances.

  • Measure the resistance from all pins connected to the positive battery terminal of the extension harness connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms

Go to 2C

Fault Code 441

Guided Step 2C - Check all ground resistances.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the negative battery cable from the battery.
  • Disconnect the positive battery cable from the battery.

Action

Check all ground resistances.

  • Measure the resistance from all pins connected to the negative (-) battery terminal of the extension harness connector to the negative (-) battery terminal connector.
OK NOT OK

Less than 10 ohms

Go to 3A

Fault Code 441

Guided Step 3 - Check for moisture in the connectors.

Guided Step 3A - Check for moisture in the engine control module connectors.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check for moisture in the connectors.

  • Check for moisture in the engine control module connectors and extension harness connector.
OK NOT OK

All connectors dry

Dry the connectors

Go to 3B

Go to 4A

Guided Step 3B - Check for moisture in the inline connectors.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the OEM interface harness.

Action

Check for moisture in the inline connectors.

  • Check for moisture in the extension harness and the OEM interface harness inline connectors.
OK NOT OK

All connectors dry

Dry the connectors

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 343 is inactive.
OK NOT OK

Fault Code 343 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Apr-2012


FAULT CODE 359 - Engine Failed to Start

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

Action

Use INSITE™ electronic service tool to read any fault code then refer to those fault codes for troubleshooting.

Follow the troubleshooting symptom tree for:

Engine Difficult to Start or Will not Start - No Smoke

Engine Difficult to Start or Will not Start in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
OK NOT OK

Use INSITE™ electronic service tool to clear the fault code after completing the troubleshooting of all other fault codes and the Engine Difficult to Start or Will not Start symptom trees.

Repair Complete

Repair Complete

Last Modified: 13-Apr-2012


FAULT CODE 378 - Fueling Actuator Number 1 - Open Circuit (Front)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fueling actuator. |
 | STEP 1A. Inspect the actuator and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
 | STEP 1C. Check for short circuit to engine block ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the circuit. | Less than 10 ohms
 | STEP 2C. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 5 ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 3C. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 5 ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 378 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fueling actuator.

Guided Step 1A - Inspect the actuator and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fueling actuator Number 1.

Action

Inspect the harness and the actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fueling actuator Number 1.

Action

Check the resistance of the actuator.

  • Measure the resistance across the two terminals on the fueling actuator Number 1.
OK NOT OK

0.5 to 1.5 ohms

Replace the fueling actuator Number 1. Refer to Procedure 019-110 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fueling actuator Number 1.

Action

Check for short circuit to engine block ground.

  • Measure the resistance between the fueling actuator Number 1 SUPPLY pin to the engine block ground.
  • Measure the resistance between the fueling actuator Number 1 RETURN pin to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the fueling actuator Number 1. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the resistance of the circuit through the engine harness.

  • Measure the resistance between the fueling actuator Number 1 SIGNAL and RETURN pins at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fueling actuator Number 1.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the fueling actuator Number 1 SUPPLY pin at the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fueling actuator Number 1 RETURN pin at the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fueling actuator Number 1.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the fueling actuator Number 1 SIGNAL pin at the engine harness inline connector to the fueling actuator Number 1 SIGNAL pin at the engine harness actuator connector.
  • Measure the resistance from the fueling actuator Number 1 RETURN pin at the engine harness inline connector to the fueling actuator Number 1 RETURN pin at the engine harness actuator connector.
OK NOT OK

Less than 5 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fueling actuator Number 1.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fueling actuator Number 1 SUPPLY pin in the engine harness inline connector to all other pins in the connector.
  • Measure the resistance from the fueling actuator Number 1 RETURN pin in the engine harness inline connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the engine and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins.

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the resistance of the whole circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check the resistance of the circuit through the extension harness.

  • Measure the resistance between the fueling actuator Number 1 SIGNAL and RETURN pins at the extension harness connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the fueling actuator Number 1 SUPPLY pin at the extension harness connector to the engine block ground.
  • Measure the resistance from the fueling actuator Number 1 RETURN pin at the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the fueling actuator Number 1 SIGNAL pin at the extension harness connector to the fueling actuator Number 1 SIGNAL pin at the extension harness inline connector.
  • Measure the resistance from the fueling actuator Number 1 RETURN pin at the extension harness connector to the fueling actuator Number 1 RETURN pin at the extension harness inline connector.
OK NOT OK

Less than 5 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fueling actuator Number 1 SUPPLY pin in the extension harness connector to all other pins in the connector.
  • Measure the resistance from the fueling actuator Number 1 RETURN pin in the extension harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 378 is inactive.
OK NOT OK

Fault Code 378 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Apr-2012


FAULT CODE 379 - Fueling Actuator Number 1 - Grounded Circuit (Front)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fueling actuator. |
 | STEP 1A. Inspect the actuator and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the circuit. | Less than 10 ohms
 | STEP 2C. Check for short circuit to battery. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to battery. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 379 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fueling actuator.

Guided Step 1A - Inspect the actuator and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fueling actuator Number 1.

Action

Inspect the harness and the actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or connector damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fueling actuator Number 1.

Action

Check the resistance of the actuator.

  • Measure the resistance across the two terminals on the fueling actuator Number 1.
OK NOT OK

0.5 to 1.5 ohms

  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or connector damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the resistance of the circuit.

  • Measure the resistance between the fueling actuator Number 1 SIGNAL and RETURN pins at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to battery.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fueling actuator Number 1.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for short circuit to battery.

  • Measure the resistance from the fueling actuator Number 1 SUPPLY pin at the engine harness inline connector to the battery source SUPPLY pins on the same connector.
  • Measure the resistance from the fueling actuator Number 1 RETURN pins at the engine harness inline connector to the battery source SUPPLY pins on the same connector.
OK NOT OK

More than 100k ohms

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fueling actuator Number 1.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fueling actuator Number 1 SUPPLY pin in the engine harness inline connector to all other pins in the connector.
  • Measure the resistance from the fueling actuator Number 1 RETURN pins in the engine harness inline connector to all other pins in the connector
OK NOT OK

More than 100k ohms

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.

Action

Inspect the engine and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or connector damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the resistance of the whole circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check the resistance of the whole circuit.

  • Measure the resistance between the fueling actuator Number 1 SIGNAL and RETURN pins at the extension harness connector.
OK NOT OK

Less than 10 ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to battery.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for short circuit to battery.

  • Measure the resistance from the fueling actuator Number 1 SUPPLY pin at the extension harness inline connector to the battery source SUPPLY pins on the same connector.
  • Measure the resistance from the fueling actuator Number 1 RETURN pins at the extension harness inline connector to the battery source SUPPLY pins on the same connector.
OK NOT OK

More than 100k ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fueling actuator Number 1 SUPPLY pin in the extension harness connector to all other pins in the connector.
  • Measure the resistance from the fueling actuator Number 1 RETURN pins in the extension harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 379 is inactive.
OK NOT OK

Fault Code 379 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Apr-2012


FAULT CODE 394 - Timing Actuator Number 1 - Open Circuit (Front)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing actuator. |
 | STEP 1A. Inspect the actuator and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
 | STEP 1C. Check for short circuit to engine block ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the circuit. | Less than 10 ohms
 | STEP 2C. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 5 ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 5 ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 394 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the timing actuator.

Guided Step 1A - Inspect the actuator and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing actuator Number 1.

Action

Inspect the harness and the actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing actuator Number 1.

Action

Check the resistance of the actuator solenoid.

  • Measure the resistance across the two terminals on the timing actuator Number 1.
OK NOT OK

0.5 to 1.5 ohms

Replace the timing actuator Number 1. Refer to Procedure 019-110 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the timing actuator Number 1.

Action

Check for short circuit to engine block ground.

  • Measure the resistance between the timing actuator Number 1 SUPPLY pin to engine block ground.
  • Measure the resistance between the timing actuator Number 1 RETURN pin to engine block ground.
OK NOT OK

More than 100k ohms

Replace the timing actuator Number 1. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the resistance of the circuit through the engine harness.

  • Measure the resistance between the timing actuator Number 1 SIGNAL and RETURN pins at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the timing actuator Number 1.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the timing actuator Number 1 SUPPLY pin at the engine harness inline connector to the engine block ground.
  • Measure the resistance from the timing actuator Number 1 RETURN pin at the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the timing actuator Number 1.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the timing actuator Number 1 SIGNAL pin at the engine harness inline connector to the timing actuator Number 1 SIGNAL pin at the engine harness actuator connector.
  • Measure the resistance from the timing actuator Number 1 RETURN pin at the engine harness inline connector to the timing actuator Number 1 RETURN pin at the engine harness actuator connector.
OK NOT OK

Less than 5 ohms

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing actuator Number 1.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the timing actuator Number 1 SUPPLY pin in the engine harness inline connector to all other pins in the connector.
  • Measure the resistance from the timing actuator Number 1 RETURN pin in the engine harness inline connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the resistance of the whole circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check the resistance of the whole circuit.

  • Measure the resistance between the timing actuator Number 1 SIGNAL and RETURN pins at the extension harness connector.
OK NOT OK

Less than 10 ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the timing actuator Number 1 SUPPLY pin at the extension harness connector to the engine block ground.
  • Measure the resistance from the timing actuator Number 1 RETURN pin at the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the timing actuator Number 1 SIGNAL pin at the extension harness connector to the timing actuator Number 1 SIGNAL pin at the extension harness inline connector.
  • Measure the resistance from the timing actuator Number 1 RETURN pin at the extension harness connector to the timing actuator Number 1 RETURN pin at the extension harness inline connector.
OK NOT OK

Less than 5 ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the timing actuator Number 1 SUPPLY pin in the extension harness connector to all other pins in the connector.
  • Measure the resistance from the timing actuator Number 1 RETURN pin in the extension harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 394 is inactive.
OK NOT OK

Fault Code 394 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 395 - Timing Actuator Number 1 - Grounded Circuit (Front)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing actuator. |
 | STEP 1A. Inspect the actuator and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the circuit. | Less than 10 ohms
 | STEP 2C. Check for short circuit to battery. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 3C. Check for short circuit to battery. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 395 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the timing actuator.

Guided Step 1A - Inspect the actuator and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing actuator Number 1.

Action

Inspect the harness and the actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing actuator Number 1.

Action

Check the resistance of the actuator.

  • Measure the resistance across the two terminals on the timing actuator Number 1.
OK NOT OK

0.5 to 1.5 ohms

Replace the timing actuator Number 1. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the resistance of the circuit.

  • Measure the resistance between the timing actuator Number 1 SIGNAL and RETURN pins at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to battery.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the timing actuator Number 1.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for short circuit to battery.

  • Measure the resistance from the timing actuator Number 1 SUPPLY pin at the engine harness inline connector to the battery source SUPPLY pins on the same connector.
  • Measure the resistance from the timing actuator Number 1 RETURN pin at the engine harness inline connector to the battery source SUPPLY pins on the same connector.
OK NOT OK

More than 100k ohms

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing actuator Number 1.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the timing actuator Number 1 SUPPLY pin in the engine harness inline connector to all other pins in the connector.
  • Measure the resistance from the timing actuator Number 1 RETURN pin in the engine harness inline connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the resistance of the whole circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check the resistance of the whole circuit.

  • Measure the resistance between the timing actuator Number 1 SIGNAL and RETURN pins at the extension harness connector.
OK NOT OK

Less than 10 ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for short circuit to battery.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for short circuit to battery.

  • Measure the resistance from the timing actuator Number 1 SUPPLY pin at the extension harness connector to the battery source SUPPLY pins on the same connector.
  • Measure the resistance from the timing actuator Number 1 RETURN pin at the extension harness connector to the battery source SUPPLY pins on the same connector.
OK NOT OK

More than 100k ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the timing actuator Number 1 SUPPLY pin in the extension harness connector to all other pins in the connector.
  • Measure the resistance from the timing actuator Number 1 RETURN pin in the extension harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 395 is inactive.
OK NOT OK

Fault Code 395 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Apr-2012


FAULT CODE 396 - Fueling Actuator Number 2 - Open Circuit (Rear)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811- male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fueling actuator. |
 | STEP 1A. Inspect the actuator and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
 | STEP 1C. Check for short circuit to engine block ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the circuit. | Less than 10 ohms
 | STEP 2C. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 5 ohms
 | STEP 2E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 3C. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 5 ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 396 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fueling actuator.

Guided Step 1A - Inspect the actuator and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fueling actuator Number 2.

Action

Inspect the harness and the actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fueling actuator Number 2.

Action

Check the resistance of the actuator solenoid.

  • Measure the resistance across the two terminals on the fueling actuator Number 2.
OK NOT OK

0.5 to 1.5 ohms

Replace the fueling actuator Number 2. Refer to Procedure 019-110 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fueling actuator Number 2.

Action

Check for short circuit to ground in the actuator solenoid.

  • Measure the resistance between the fueling actuator Number 2 SUPPLY pin to chassis ground.
  • Measure the resistance between the fueling actuator Number 2 RETURN pin to chassis ground.
OK NOT OK

More than 100k ohms

Replace the fueling actuator Number 2. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the resistance of the circuit through the engine harness.

  • Measure the resistance between the fueling actuator Number 2 SIGNAL and RETURN pins at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fueling actuator Number 2.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the fueling actuator Number 2 SUPPLY pin at the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fueling actuator Number 2 RETURN pin at the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fueling actuator Number 2.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fueling actuator Number 2 SIGNAL pin at the engine harness inline connector to the fueling actuator Number 2 SIGNAL pin at the engine harness actuator connector.
  • Measure the resistance from the fueling actuator Number 2 RETURN pin at the engine harness inline connector to the fueling actuator Number 2 RETURN pin at the engine harness actuator connector.
OK NOT OK

Less than 5 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fueling actuator Number 2.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fueling actuator Number 2 SUPPLY pin in the engine harness inline connector to all other pins in the connector.
  • Measure the resistance from the fueling actuator Number 2 RETURN pin in the engine harness inline connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the resistance of the whole circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check the resistance of the circuit through the extension harness.

  • Measure the resistance between the fueling actuator Number 2 SIGNAL and RETURN pins at the extension harness connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the fueling actuator Number 2 SUPPLY pin at the extension harness connector to the engine block ground.
  • Measure the resistance from the fueling actuator Number 2 RETURN pin at the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit in the extension harness.

  • Measure the resistance from the fueling actuator Number 2 SIGNAL pin at the extension harness connector to the fueling actuator Number 2 SIGNAL pin at the extension harness inline connector.
  • Measure the resistance from the fueling actuator Number 2 RETURN pin at the extension harness connector to the fueling actuator Number 2 RETURN pin at the extension harness inline connector.
OK NOT OK

Less than 5 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fueling actuator Number 2 SUPPLY pin in the extension harness connector to all other pins in the connector.
  • Measure the resistance from the fueling actuator Number 2 RETURN pin in the extension harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 396 is inactive.
OK NOT OK

Fault Code 396 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Apr-2012


FAULT CODE 397 - Fueling Actuator Number 2 - Grounded Circuit (Rear)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fueling actuator. |
 | STEP 1A. Inspect the actuator and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the circuit. | Less than 10 ohms
 | STEP 2C. Check for short circuit to battery. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 3C. Check for short circuit to battery. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 397 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fueling actuator.

Guided Step 1A - Inspect the actuator and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fueling actuator Number 2.

Action

Inspect the harness and the actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Moisture in or on the connector
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fueling actuator Number 2.

Action

Check the resistance of the actuator.

  • Measure the resistance across the two terminals on the fueling actuator Number 2.
OK NOT OK

0.5 to 1.5 ohms

Replace the fueling actuator Number 2. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the resistance of the circuit from the engine harness.

  • Measure the resistance between the fueling actuator Number 2 SIGNAL and RETURN pins at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to battery.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fueling actuator Number 2.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for short circuit to battery in the engine harness.

  • Measure the resistance from the fueling actuator Number 2 SUPPLY pin at the engine harness inline connector to the battery source SUPPLY pins on the same connector.
  • Measure the resistance from the fueling actuator Number 2 RETURN pin at the engine harness inline connector to the battery source SUPPLY pins on the same connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fueling actuator Number 2.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fueling actuator Number 2 SUPPLY pin in the engine harness inline connector to all other pins in the connector.
  • Measure the resistance from the fueling actuator Number 2 RETURN pin in the engine harness inline connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the resistance of the whole circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check the resistance of the circuit from the extension harness.

  • Measure the resistance between the fueling actuator Number 2 SIGNAL and RETURN pins at the extension harness connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for short circuit to battery.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for short circuit to battery in the extension harness.

  • Measure the resistance from the fueling actuator Number 2 SUPPLY pin at the extension harness connector to the battery source SUPPLY pins on the same connector.
  • Measure the resistance from the fueling actuator Number 2 RETURN pin at the extension harness connector to the battery source SUPPLY pins on the same connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the fueling actuator Number 2 SUPPLY pin in the extension harness connector to all other pins in the connector.
  • Measure the resistance from the fueling actuator Number 2 RETURN pin in the extension harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 397 is inactive.
OK NOT OK

Fault Code 397 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 398 - Timing Actuator Number 2 - Open Circuit (Rear)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing actuator. |
 | STEP 1A. Inspect the actuator and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
 | STEP 1C. Check for short circuit to engine block ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the circuit. | Less than 10 ohms
 | STEP 2C. Check for an open circuit. | Less than 5 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 3C. Check for an open circuit. | Less than 5 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for short circuit to engine block ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 398 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the timing actuator.

Guided Step 1A - Inspect the actuator and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing actuator Number 2.

Action

Inspect the harness and the actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing actuator Number 2.

Action

Check the resistance of the actuator solenoid.

  • Measure the resistance across the two terminals on the timing actuator Number 2.
OK NOT OK

0.5 to 1.5 ohms

Replace the timing actuator Number 2. Refer to Procedure 019-110 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the timing actuator Number 2.

Action

Check for short circuit to engine block ground.

  • Measure the resistance between the timing actuator Number 2 SUPPLY pin to chassis ground.
  • Measure the resistance between the timing actuator Number 2 RETURN pin to chassis ground.
OK NOT OK

More than 100k ohms

Replace the timing actuator Number 2. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the resistance of the circuit through the engine harness.

  • Measure the resistance between the timing actuator Number 2 SIGNAL and RETURN pins at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the timing actuator Number 2.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the timing actuator Number 2 SIGNAL pin at the engine harness inline connector to the SIGNAL pin at the engine harness actuator connector.
  • Measure the resistance from the timing actuator Number 2 RETURN pin at the engine harness inline connector to the RETURN pin at the engine harness actuator connector.
OK NOT OK

Less than 5 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing actuator Number 2.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the timing actuator Number 2 SUPPLY pin in the engine harness inline connector to all other pins in the connector.
  • Measure the resistance from the timing actuator Number 2 RETURN pin in the engine harness inline connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the timing actuator Number 2.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the timing actuator Number 2 SUPPLY pin at the engine harness inline connector to the engine block ground.
  • Measure the resistance from the timing actuator Number 2 RETURN pin at the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the resistance of the whole circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check the resistance of the circuit through the extension harness.

  • Measure the resistance between the timing actuator Number 2 SIGNAL and RETURN pins at the extension harness connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit in the extension harness.

  • Measure the resistance from the timing actuator Number 2 SIGNAL pin at the extension harness connector to the timing actuator Number 2 SIGNAL pin at the extension harness inline connector.
  • Measure the resistance from the timing actuator Number 2 RETURN pin at the extension harness connector to the timing actuator Number 2 RETURN pin at the extension harness inline connector.
OK NOT OK

Less than 5 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the timing actuator Number 2 SUPPLY pin in the extension harness connector to all other pins in the connector.
  • Measure the resistance from the timing actuator Number 2 RETURN pin in the extension harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit to ground in the actuator.

  • Measure the resistance from the timing actuator Number 2 SUPPLY pin at the extension harness connector to the engine block ground.
  • Measure the resistance from the timing actuator Number 2 RETURN pin at the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 398 is inactive.
OK NOT OK

Fault Code 398 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Apr-2012


FAULT CODE 399 - Timing Actuator Number 2 - Grounded Circuit (Rear)

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing actuator. |
 | STEP 1A. Inspect the actuator and engine harness pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the circuit. | Less than 10 ohms
 | STEP 2C. Check for short circuit to battery. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check the resistance of the whole circuit. | Less than 10 ohms
 | STEP 3C. Check for short circuit to battery. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 399 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the timing actuator.

Guided Step 1A - Inspect the actuator and engine harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing actuator Number 2.

Action

Inspect the harness and the actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing actuator Number 2.

Action

Check the resistance of the actuator.

  • Measure the resistance across the two terminals on the timing actuator Number 2.
OK NOT OK

0.5 to 1.5 ohms

Replace the timing actuator Number 2. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine and extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the resistance of the circuit from the engine harness.

  • Measure the resistance between the timing actuator Number 2 SIGNAL and RETURN pins at the engine harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to battery.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the timing actuator Number 2.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for short circuit to battery in the engine harness.

  • Measure the resistance from the timing actuator Number 2 SUPPLY pin at the engine harness inline connector to the battery source SUPPLY pins on the same connector.
  • Measure the resistance from the timing actuator Number 2 RETURN pin at the engine harness inline connector to the battery source SUPPLY pins on the same connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing actuator Number 2.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the timing actuator Number 2 SUPPLY pin in the engine harness inline connector to all other pins in the connector.
  • Measure the resistance from the timing actuator Number 2 RETURN pin in the engine harness inline connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the resistance of the whole circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Check the resistance of the circuit from the extension harness.

  • Measure the resistance between the timing actuator Number 2 SIGNAL and RETURN pins at the extension harness connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for short circuit to battery.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal from battery.

Action

Check for short circuit to battery in the extension harness.

  • Measure the resistance from the timing actuator Number 2 SUPPLY pin at the extension harness connector to the battery source SUPPLY pins on the same connector.
  • Measure the resistance from the timing actuator Number 2 RETURN pin at the extension harness connector to the battery source SUPPLY pins on the same connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the timing actuator Number 2 SUPPLY pin in the extension harness connector to all other pins in the connector.
  • Measure the resistance from the timing actuator Number 2 RETURN pin in the extension harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and test the generator for 15 minutes.
  • Use INSITE™ electronic service tool to verify Fault Code 399 is inactive.
OK NOT OK

Fault Code 399 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Apr-2012


FAULT CODE 415 - Engine Oil Pressure Low - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil pressure sensor accuracy. |
 | STEP 1A. Verify the oil pressure sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 415 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the oil pressure sensor accuracy.

Guided Step 1A - Verify the oil pressure sensor accuracy with a mechanical gauge.

Conditions

  • Connect a mechanical oil pressure gauge of known quality and calibration to the engine at one of the plugs on top of the oil filter head.
  • Connect INSITE™ electronic service tool to the datalink.
  • Place the run/stop/auto switch in the RUN position.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Start the engine and compare the oil pressure reading on INSITE™ electronic service tool monitor screen to the reading on the mechanical oil pressure gauge.

NOTE: The engine speed will have to be increased to make it easier to see the differences in the readings.
OK NOT OK

Sensor reading is correct. Use the procedure in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Fault Code 141

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature is not enabled.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the oil pressure sensor.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that the fault threshold is not within the normal operating range for the oil pressure.
OK NOT OK

Fault threshold is set correctly. See Section TS, symptom tree T105 in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 415 is inactive.

NOTE: If fault was at a particular speed, operate the engine at that speed to verify problem is corrected.
OK NOT OK

Fault Code 415 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Apr-2012


FAULT CODE 421 - Engine Oil Temperature High - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation is disabled
 | STEP 2B. Check threshold setting. | Fault threshold is set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 421 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the oil temperature sensor.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Place the run/stop/auto switch in the RUN position.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the oil temperature reading on the service tool monitor screen to the reading from the temperature probe.

Note: If no temperature measuring device is available, then answer "OK" to this step.
OK NOT OK

Sensor reading is correct

Go to 2A

Fault Code 212

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Read the engine control module sensor value.

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the oil temperature sensor.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the oil temperature sensor.
OK NOT OK

Fault threshold is set correctly. Reference the symptom tree T105 in Section TS of the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold is not correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 421 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Apr-2012


FAULT CODE 422 - Engine Coolant Level Sensor - Data Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap or the coolant temperature sensor. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check for proper engine control module response. |
 | STEP 2A. Inspect the sensor and sensor harness connector pins. | No damaged pins
 | STEP 2B. Check for the appropriate engine control module response. | Fault Code 422 active
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the engine harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for an open circuit in the sensor harness. | Less than 10 ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4D. Check for an open circuit in the engine harness. | Less than 10 ohms
STEP 5. | Check the extension harness. |
 | STEP 5A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5D. Check for an open circuit in the extension harness. | Less than 10 ohms
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 422 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check for proper engine control module response.

Guided Step 2A - Inspect the sensor and sensor harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness connector from the coolant level switch sensor.

Action

Inspect the sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant level switch sensor. Refer to Procedure 019-017 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check for the appropriate engine control module response.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the coolant level switch sensor from the sensor harness.
  • Install a jumper wire between the coolant level switch SUPPLY pin and coolant level switch high pin on the sensor harness.
  • Install a jumper wire between the coolant level switch RETURN pin and coolant level switch low pin on the sensor harness.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 422 active

Fault Code 422 inactive. Replace the coolant level switch sensor. Refer to Procedure 019-017 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness and the engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the sensor harness from the engine harness.

Action

Inspect the sensor harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the coolant level switch sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant level switch SUPPLY pin on the sensor harness connector to all other pins in the sensor harness.
  • Measure the resistance from the coolant level switch RETURN pin on the sensor harness connector to all other pins in the sensor harness.
  • Measure the resistance from the coolant level switch high pin on the sensor harness connector to all other pins in the sensor harness.
  • Measure the resistance from the coolant level switch low pin on the sensor harness connector to all other pins in the sensor harness.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the coolant level switch sensor.

Action

Check for a short circuit to ground from the SUPPLY, high, and low wires.

  • Measure the resistance from the coolant level switch SUPPLY pin on the sensor harness connector to engine block ground.
  • Measure the resistance from the coolant level switch high pin on the sensor harness connector to engine block ground.
  • Measure the resistance from the coolant level switch low pin on the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit in the sensor harness.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the coolant level switch sensor.

Action

Check for a short circuit to ground from the SUPPLY, high, and low wires.

  • Measure the resistance from the coolant level switch SUPPLY pin on the sensor harness engine harness connector to the coolant level switch SUPPLY pin on the sensor harness sensor connector.
  • Measure the resistance from the coolant level switch RETURN pin on the sensor harness engine harness connector to the coolant level switch RETURN pin on the sensor harness sensor connector.
  • Measure the resistance from the coolant level switch high pin on the sensor harness engine harness connector to the coolant level switch high pin on the sensor harness sensor connector.
  • Measure the resistance from the coolant level switch low pin on the sensor harness engine harness connector to the coolant level switch low pin on the sensor harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the sensor harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant level switch SUPPLY pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the coolant level switch RETURN pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the coolant level switch high pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the coolant level switch low pin on the engine harness inline connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the sensor harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant level switch SUPPLY pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the coolant level switch high pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the coolant level switch low pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit in the engine harness.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the sensor harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant level switch SUPPLY pin on the engine harness inline connector to the coolant level switch SUPPLY pin on the engine harness sensor harness connector.
  • Measure the resistance from the coolant level switch RETURN pin on the engine harness inline connector to the coolant level switch RETURN pin on the engine harness sensor harness connector.
  • Measure the resistance from the coolant level switch high pin on the engine harness inline connector to the coolant level switch high pin on the engine harness sensor harness connector.
  • Measure the resistance from the coolant level switch low pin on the engine harness inline connector to the coolant level switch low pin on the engine harness sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the extension harness.

Guided Step 5A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. 019-031 in Section 19.

Go to 5A

Go to 6A

Guided Step 5B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant level switch SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant level switch RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant level switch high pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the coolant level switch low pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5B

Go to 6A

Guided Step 5C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to ground from the SUPPLY, high, and low wires.

  • Measure the resistance from the coolant level switch SUPPLY pin on the extension harness connector to engine block ground.
  • Measure the resistance from the coolant level switch high pin on the extension harness connector to engine block ground.
  • Measure the resistance from the coolant level switch low pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an open circuit in the extension harness.

Conditions

  • Place the run/stop/auto switch in the STOP position
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the SUPPLY, RETURN, high, and low wires.

  • Measure the resistance from the coolant level switch SUPPLY pin on the extension harness engine control module connector to the coolant level switch SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the coolant level switch RETURN pin on the extension harness engine control module connector to the coolant level switch RETURN pin on the extension harness inline connector.
  • Measure the resistance from the coolant level switch high pin on the extension harness engine control module connector to the coolant level switch high pin on the extension harness inline connector.
  • Measure the resistance from the coolant level switch low pin on the extension harness engine control module connector to the coolant level switch low pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 422 is inactive.
OK NOT OK

Fault Code 422 inactive

Retrun to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Operation mode switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Apr-2012


FAULT CODE 423 - Fuel Timing Pressure or Timing Actuator Stuck

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing rail pressure sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check for sensor accuracy. |
 | STEP 4A. Compare timing, rail, and ambient air pressure sensor readings. | Timing = rail pressure, Timing = ½ ambient air pressure
STEP 5. | Check for drain line restriction. |
 | STEP 5A. Check for drain line restriction. | No restriction in drain line
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 423 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the timing rail pressure sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the timing rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the engine harness or the timing rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 1B

Go to 6A

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Place the run/stop/auto switch in the RUN position.

Action

Check the timing rail pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 1C

Go to 2A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Place the run/stop/auto switch in the RUN position.

Action

Check the timing rail pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the timing rail pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 2A

Go to 6A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the timing rail pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to the timing rail pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to the timing rail pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to the timing rail pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 6A

Guided Step 2D - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to the timing rail pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to the timing rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to the timing rail pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the extension harness connector to engine block ground.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the timing rail pressure RETURN pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check for sensor accuracy.

Guided Step 4A - Compare timing, rail, and ambient air pressure sensor readings.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to measure timing, rail, and ambient air pressure.

Use INSITE™ electronic service tool to measure timing, rail, and ambient air pressure.
OK NOT OK

Timing = rail pressure

Timing = ½ ambient air pressure

Refer to Procedure 019-113 in Section 19 in the base engine troubleshooting and repair manual.

Go to 5A

Go to 6A

Guided Step 5 - Check for drain line restriction.

Guided Step 5A - Check for drain line restriction.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for drain restriction in the drain line.

Check for drain line restriction.
OK NOT OK

No restriction in drain line

Correct restriction in drain line.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 423 is inactive.
OK NOT OK

Fault Code 423 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Apr-2012


FAULT CODE 441 - Battery 1 Voltage Low - Warning

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC, (24-VDC system)
 | STEP 1C. Check the battery ground connection. | Less than 10 ohms
 | STEP 1D. Check for an add-on or accessory wiring at the positive (+) terminal of the battery. | No damaged wires
STEP 2. | Check Inline E (OEM battery harness). The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM manual for more detailed instructions. |
 | STEP 2A. Inspect the OEM battery harness and the Inline E connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness fuse connection. | Fuse installed correctly
 | STEP 3B. Check the engine harness fuse. | Fuse not blown
 | STEP 3C. Inspect the engine harness and the extension harness inline connector pins. | No damaged pins
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 441 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the battery cable connections.

Inspect the battery cable connections for:

  • Corrosion
  • Loose connection.
OK NOT OK

No damaged connections

Repair the damaged connections. Tighten the battery connections and clean the battery terminals. Refer to the OEM manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the battery voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
OK NOT OK

17.3 to 34.7-VDC, (24-VDC system)

Charge or replace the battery.

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1C

Go to 5A

Guided Step 1C - Check the battery ground connection.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) battery terminal to the engine block ground.
OK NOT OK

Less than 10 ohms

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 1D

Go to 5A

Guided Step 1D - Check for an add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause SUPPLY wire to be shorted to the engine block.
OK NOT OK

No damaged wires

Repair the damaged wiring

Go to 2A

Go to 5A

Guided Step 2 - Check Inline E (OEM battery harness). The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM manual for more detailed instructions.

Guided Step 2A - Inspect the OEM battery harness and the Inline E connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM battery harness from the Inline E connector.

Action

Inspect the OEM Inline E connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the Inline E connector and the OEM battery harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the OEM battery harness. Refer to the OEM manual.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM wiring harness from the engine harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the OEM battery harness at the Inline E connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms

Replace the OEM battery harness. Refer to the OEM manual.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all unswitched battery pins on the Inline E connector to all other pins on the Inline E connector.

Note: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the OEM battery harness. Refer to the OEM manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness fuse connection.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check if the 20-amp fuse is installed correctly.

Check fuse for proper installation.
OK NOT OK

Fuse installed correctly

Install fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine harness fuse.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the 20-amp fuse from the OEM harness.

Action

Check if the 20-amp fuse is blown.

Check for blown fuse.
OK NOT OK

Fuse not blown

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the engine harness and the extension harness inline connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the engine harness inline connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all unswitched battery pins on the engine harness inline connector to all other pins on the engine harness inline connector.

Note: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module connector.

Action

Check for an open circuit in the battery supply circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the extension harness connector to the pins being supplied by unswitchable battery at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for an short circuit from pin to pin.

  • Measure the resistance from all unswitched battery pins on the extension harness connector to all other pins on the extension harness connector.

Note: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 441 is inactive.
OK NOT OK

Fault Code 441 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Apr-2012


FAULT CODE 442 - Battery 1 Voltage High - Warning

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC, (24-VDC system)
 | STEP 1C. Check the battery ground connection. | Less than 10 ohms
 | STEP 1D. Check the alternator. | Alternator functioning normally
 | STEP 1E. Check for an add-on or accessory wiring at the positive (+) terminal of the battery. | No damaged wires
STEP 2. | Check Inline E (OEM battery harness). The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM manual for more detailed instructions. |
 | STEP 2A. Inspect the OEM battery harness and the Inline E connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness fuse connection. | Fuse installed correctly
 | STEP 3B. Check the engine harness fuse. | Fuse not blown
 | STEP 3C. Inspect the engine harness and the extension harness inline connector pins. | No damaged pins
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 442 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the battery cable connections for:

  • Corrosion
  • Loose connection.
OK NOT OK

No damaged connections

Repair the damaged connections. Tighten the battery connections and clean the battery terminals. Refer to the OEM manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the battery voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
OK NOT OK

17.3 to 34.7-VDC, (24-VDC system)

Charge or replace the battery. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 5A

Guided Step 1C - Check the battery ground connection.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) battery terminal to the engine block ground.
OK NOT OK

Less than 10 ohms

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 1D

Go to 5A

Guided Step 1D - Check the alternator.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the alternator for normal operation.

Inspect the alternator for normal operation.
OK NOT OK

Alternator functioning normally

Repair the alternator. Refer to the OEM Troubleshooting and Repair Manual.

Go to 1E

Go to 5A

Guided Step 1E - Check for an add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause SUPPLY wire to be shorted to the engine block.
OK NOT OK

No damaged wires

Repair the damaged wiring

Go to 2A

Go to 5A

Guided Step 2 - Check Inline E (OEM battery harness). The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM manual for more detailed instructions.

Guided Step 2A - Inspect the OEM battery harness and the Inline E connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM battery harness from the Inline E connector.

Action

Inspect the OEM battery harness and the Inline E connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the Inline E connector and/or the OEM battery harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the OEM battery harness. Refer to the OEM manual.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM wiring harness from the engine harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the OEM wiring harness at the Inline E connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms

Replace the OEM battery harness. Refer to the OEM manual.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an short circuit from pin to pin.

  • Measure the resistance from all unswitched battery pins on the Inline E connector to all other pins on the Inline E connector.

Note: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the OEM battery harness. Refer to the OEM manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness fuse connection.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check if the 20-amp fuse is installed correctly.

Check that the 20 amp fuse is installed correctly.
OK NOT OK

Fuse installed correctly

Install fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine harness fuse.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the 20 amp fuse from the OEM harness.

Action

Check if the 20-amp fuse is blown.

Check if the 20 amp fuse is blown.
OK NOT OK

Fuse not blown

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the engine harness and the extension harness inline connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the engine harness inline connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an short circuit from pin to pin.

  • Measure the resistance from all unswitched battery pins on the engine interface harness inline connector to all other pins on the engine harness inline connector.

Note: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module connector.

Action

Check for an open circuit in the battery supply circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the extension harness connector to the pins being supplied by unswitched battery at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for an short circuit from pin to pin.

  • Measure the resistance from all unswitched battery pins on the extension harness connector to all other pins on the extension harness connector.

Note: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 442 is inactive.
OK NOT OK

Fault Code 442 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Apr-2012


FAULT CODE 449 - High Fuel Pressure

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fuel restriction. |
 | STEP 1A. Check for fuel restriction in the drain line. | Restriction below 103 mm-Hg [4.0 in-Hg]
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a mechanical gauge. | Gauge and sensor pressure are within 69 kPa [10 psi]
STEP 3. | Replace fuel regulator. |
 | STEP 3A. Replace the 1724 kPa [250 psi] fuel regulator. | Fault Code 449 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 449 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for fuel restriction.

Guided Step 1A - Check for fuel restriction in the drain line.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for fuel restriction in the drain line.

  • Install a restriction gauge in the fuel return line.
OK NOT OK

Restriction below 102 mm-Hg [4.0 in-Hg]

Clear the restriction from the drain line

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Verify the sensor accuracy.

  • Connect a mechanical fuel pressure gauge to the pressure-side Compuchek™ fitting.
  • Connect INSITE™ electronic service tool.
  • Start the engine and compare the fuel pressure reading on INSITE™ service tool monitor screen to the reading on the mechanical fuel pressure gauge.
OK NOT OK

Gauge and sensor pressures are within 69 kPa [10 psi]

Replace the fuel pressure sensor. Refer to Procedure 019-118 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Replace the fuel regulator.

Guided Step 3A - Replace the 1724 kPa [250 psi] regulator.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Replace the 250-psi regulator.

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
OK NOT OK

Fault Code 449 inactive

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and let the engine idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 449 is inactive.
OK NOT OK

Fault Code 449 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Apr-2012


FAULT CODE 451 - Fuel Rail Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™ AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - engine control module connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the fuel rail pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
STEP 5. | Check the engine control module response. |
 | STEP 5A. Check for the appropriate engine control module response. | Fault Code 451 inactive, Fault Code 452 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 451 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel rail pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Place the run/stop/auto switch in the RUN position.

Action

Check the fuel rail pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Place the run/stop/auto switch in the RUN position.

Action

Check the fuel rail pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel rail pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the engine harness inline connector to the fuel rail pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to the fuel rail pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to the fuel rail pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the extension harness connector to the fuel rail pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to the fuel rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to the fuel rail pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine control module response.

Guided Step 5A - Check for the appropriate engine control module response.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the fuel rail pressure SIGNAL pin and the fuel rail pressure RETURN pin on the breakout box.
  • Place the run/stop/auto switch in the RUN position.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 451 inactive, Fault Code 452 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 451 is inactive.
OK NOT OK

Fault Code 451 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 452 - Fuel Rail Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/ AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable. Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - engine control module connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the fuel rail pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for short circuit to engine block ground. | More than 100k ohms
STEP 5. | Check the engine control module response. |
 | STEP 5A. Check for the appropriate engine control module response. | Fault Code 452 inactive, Fault Code 451 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 452 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel pump pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Place the run/stop/auto switch in the RUN position.

Action

Check the pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Place the run/stop/auto switch in the RUN position.

Action

Check the pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel rail pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to the fuel rail pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to the fuel rail pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to the fuel rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to the fuel rail pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine control module response.

Guided Step 5A - Check for the appropriate engine control module response.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the fuel rail pressure SIGNAL pin and the fuel rail pressure SUPPLY pin on the breakout box.
  • Place the run/stop/auto switch in the RUN position.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 452 inactive, Fault Code 451 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Verify that Fault Code 452 is inactive.
OK NOT OK

Fault Code 452 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 17-Apr-2012


FAULT CODE 455 - Fuel Rail Actuator - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rail actuator. |
 | STEP 1A. Inspect the fuel rail actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the coil resistance of the fuel rail actuator. | 7.0 to 9.0 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the engine control module supply voltage. |
 | STEP 4A. Check the supply voltage at the engine control module. | More than 17.0-VDC
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 455 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel rail actuator.

Guided Step 1A - Inspect the fuel rail actuator and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel rail actuator.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Check the coil resistance of the fuel rail actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the resistance of the valve.

  • Measure the resistance of the fuel rail actuator SUPPLY pin to the fuel rail actuator RETURN pin.
OK NOT OK

7.0 to 9.0 ohms

Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel rail actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rail actuator RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail actuator SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel rail actuator.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel rail actuator RETURN pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel rail actuator.
  • Disconnect engine harness from extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the engine harness inline connector to the fuel rail actuator SUPPLY pin.
  • Measure the resistance from the fuel rail actuator RETURN pin on the engine harness inline connector to the fuel rail actuator RETURN pin.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rail actuator RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail actuator SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the extension harness connector to the engine block ground.
  • Measure the resistance from the fuel rail actuator RETURN pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the extension harness connector to the fuel rail actuator SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail actuator RETURN pin on the extension harness connector to the fuel rail actuator RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module supply voltage.

Guided Step 4A - Check the supply voltage at the engine control module.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Place the run/stop/auto switch in the RUN position.

Action

Check the engine control module supply voltage at the breakout box.

  • Measure the voltage from the engine control module SUPPLY pin of the fuel shutoff valve solenoid at the breakout box.
OK NOT OK

More than 17.0-VDC

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 455 is inactive.
OK NOT OK

Fault Code 455 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


FAULT CODE 467 - Timing Rail Actuator - Data Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the complaint. |
 | STEP 1A. Check for other active fault codes besides Fault Code 467. | Other fault codes not active
STEP 2. | Check the suction side of the fuel system flow. |
 | STEP 2A. Check the fuel tank level. | Fuel in tank
 | STEP 2B. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2C. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 2D. Inspect the fuel system for leaks, damaged lines, and loose fittings. | No leaks, damaged lines, or loose fittings
 | STEP 2E. Check the fuel inlet restriction. | Less than 203 mm-Hg [8 in-Hg]
 | STEP 2F. Check for air in the fuel. | Minimal air in the fuel
STEP 3. | Check the pressure side fuel system flow. |
 | STEP 3A. Check the fuel pump output pressure. | Minimum 55 psi @ 600 rpm, Minimum 250 psi @ 2100 rpm, Minimum 265 psi @ 2350 rpm
 | STEP 3B. Inspect the actuator screen for debris. | No debris
 | STEP 3C. Inspect the actuator for corrosion. | No corrosion
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 467 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify the complaint.

Guided Step 1A - Check for active fault codes other than Fault Code 467.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check for other active fault codes besides Fault Code 467.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Other faults not active

Investigate other fault codes first

Go to 2A

Appropriate fault tree

Guided Step 2 - Check the suction side of the fuel system flow.

Guided Step 2A - Check the fuel tank level.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the fuel tank level for:

  • Sufficient fuel level.
OK NOT OK

Fuel in tank

Fill the tank with fuel

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the fuel tank level for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the engine control module.

Action

Check the fuel tank level for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the fuel system for leaks, damaged lines, and loose fittings.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect fuel system for the following:

  • Leaks
  • Damaged lines
  • Loose fittings.
OK NOT OK

No leaks, damaged lines, or loose fittings

Tighten or replace the leaking fitting or fuel line.

Replace the fuel line.

  • Refer to Procedure 006-024 in Section 6. In the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 006-024 in Section 6. In the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 006-024 in Section 6. In the QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 006-024 in Section 6. In the QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 006-024 in Section 6. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2E

Go to 4A

Guided Step 2E - Check the fuel inlet restriction.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check the inlet restriction as follows:

Measure the inlet restriction.

  • Refer to Procedure 006-020 in Section 6. In the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 006-020 in Section 6. In the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 006-020 in Section 6. In the QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 006-020 in Section 6. In the QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 006-020 in Section 6. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
OK NOT OK

Less than 203 mm-Hg [8 in-Hg]

Find the cause of the restriction and remove the restriction. Check for clogged fuel filters, debris in the fuel tank, fuel tank vents clogged, collapsed or faulty fuel lines, or faulty check valves.

Go to 2F

Go to 4A

Guided Step 2F - Check for air in the fuel.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in Section 6. In the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 006-003 in Section 6. In the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 006-003 in Section 6. In the QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 006-003 in Section 6. In the QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 006-003 in Section 6. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
OK NOT OK

Minimal air in the fuel

Find the cause of the air in the fuel. Check for missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.

Go to 3A

Go to 4A

Guided Step 3 - Check the pressure side fuel system flow.

Guided Step 3A - Check the fuel pump output pressure.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check the fuel pump output pressure.

  • Measure the output pressure of the pump at the Compuchek® fitting. Use the appropriate procedure:
  • Refer to Procedure 005-016 in Section 5. In the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. In the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. In the QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
OK NOT OK

Minimum 55 psi @ 600 rpm, Minimum 250 psi @ 2100 rpm, Minimum 265 psi @ 2350 rpm

Go to 3B

Go to 2D

Guided Step 3B - Inspect the actuator screen for debris.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the actuator screen for debris.

  • Remove the timing actuator Number 1. Refer to Procedure 019-111 in Section 19.
  • Remove the timing actuator Number 2. Refer to Procedure 019-111 in Section 19.
OK NOT OK

No debris

Replace the timing actuator screen. Refer to Procedure 019-111 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the actuator for corrosion.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the actuator for corrosion.

  • Remove the timing actuator to inspect for corrosion.

Refer to Procedure 019-111 in Section 19.

OK NOT OK

No corrosion

Replace the timing actuator. Refer to Procedure 019-111 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and run through the operating range to verify the Fault Code 467 stays inactive.
OK NOT OK

Fault Code 467 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Apr-2012


FAULT CODE 468 - Fuel Rail Actuator - Data Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823254 - male 3-way Metri-Pack™ connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rail actuator. |
 | STEP 1A. Inspect the fuel rail actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the coil resistance of the fuel rail actuator. | 7.0 to 9.0 ohms
 | STEP 1C. Check for a short circuit from supply to ground. | More than 100k ohms
STEP 2. | Check the fuel system flow. |
 | STEP 2A. Check the fuel tank level. | Fuel in tank
 | STEP 2B. Inspect the fuel system for leaks, damaged lines, and loose fittings. | No leaks, damaged lines, or loose fittings
 | STEP 2C. Check the inlet restriction. | Less than 203 mm-Hg [8 in-Hg]
 | STEP 2D. Check for air in the fuel. | Minimal air in the fuel
 | STEP 2E. Inspect the fuel shutoff solenoid for excessive wear. | No excessive wear
 | STEP 2F. Check the fuel pump output pressure. | For QSK45/60:Minimum 110 psi @ 600 rpm, Minimum 200 psi @ 1300 rpm, Minimum 250 psi @ 1900 rpm, Minimum 260 psi @ 2300 rpm
 | STEP 2G. Check the injector o-rings. | Output is equal
 | STEP 2H. Check for fuel in the oil or coolant. | No fuel in the oil or coolant
 | STEP 2I. Inspect the actuator screen for debris. | No debris
 | STEP 2J. Inspect the actuator for corrosion. | No corrosion
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 468 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel rail actuator.

Guided Step 1A - Inspect the fuel rail actuator and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel rail actuator.

Action

Inspect the rail actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness, or replace the rail actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the coil resistance of the fuel rail actuator.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel rail actuator.

Action

Check the coil resistance of the rail actuator.

  • Measure the coil resistance from the fuel rail SUPPLY pin to the fuel rail RETURN pin of the fuel rail actuator connector.
OK NOT OK

7.0 to 9.0 ohms

Replace the rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit from supply to ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the fuel rail actuator.

Action

Check for a short circuit from supply to ground.

  • Measure the resistance from the fuel rail SUPPLY pin to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system flow.

Guided Step 2A - Check the fuel tank level.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the fuel tank level for:

  • Fuel in the tank.
OK NOT OK

Fuel in tank

Fill tank with fuel

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel system for leaks, damaged lines, and loose fittings.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the fuel system for leaks, broken lines, and loose fittings.

Inspect the fuel system for leaks, broken lines, and loose fittings.
OK NOT OK

No leaks, damaged lines, or loose fittings

Repair the leak. Tighten or replace the leaking fitting or fuel line.

  • Refer to Procedure 006-024 in Section 6. In the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 006-024 in Section 6. In the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 006-024 in Section 6. In the QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 006-024 in Section 6. In the QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 006-024 in Section 6. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2C

Go to 3A

Guided Step 2C - Check the inlet restriction.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check the inlet restriction as follows:

  • Refer to Procedure 005-016 in Section 5. In the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. In the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. In the QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
OK NOT OK

Less than 203 mm-Hg [8 in-Hg]

Find cause of restriction and remove restriction. Check for clogged fuel filters, debris in the fuel tank, clogged fuel tank vents, collapsed or faulty fuel lines, or faulty check valves.

Go to 2D

Go to 3A

Guided Step 2D - Check for air in the fuel.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check for air in the fuel system.

  • Refer to Procedure 005-016 in Section 5. In the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. In the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. In the QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
OK NOT OK

Minimal air in the fuel

Find cause of air in the fuel. Check for missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.

Go to 2E

Go to 3A

Guided Step 2E - Inspect the fuel shutoff solenoid for excessive wear.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the fuel shutoff solenoid for excessive wear.

  • Remove the fuel shutoff solenoid and inspect the spacer for excessive wear. Refer to the base engine troubleshooting and repair manual.
OK NOT OK

No excessive wear

Repair or replace the fuel shutoff valve.

  • Refer to Procedure 005-043 in Section 5. In the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-043 in Section 5. In the QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-043 in Section 5. In the QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-043 in Section 5. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2F

Go to 3A

Guided Step 2F - Check the fuel pump output pressure.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check the fuel pump output pressure.

Measure the output pressure of the pump at the Compucheck® fitting.

  • Refer to Procedure 005-016 in Section 5. In the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. In the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. In the QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
OK NOT OK

For QSK45/60: Minimum 110 psi @ 600 rpm, Minimum 200 psi @ 1300 rpm, Minimum 250 psi @ 1900 rpm, Minimum 260 psi @ 2300 rpm

Go to 2G

Go to 3A

Guided Step 2G - Check the injector o-rings.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the injector o-rings.

  • The o-rings can be checked by observing the drain output of the front three versus the rear three cylinders.
  • Disconnect the drain lines at the T-junction.
  • Place each half into separate, equal-size buckets.
  • Operate the engine at rated speed for enough time to determine if the output is equal from each half.
OK NOT OK

Output is equal

Replace the injector o-rings on the faulty bank.

  • Refer to Procedure 006-026 in Section 6. In the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 006-026 in Section 6. In the QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 006-026 in Section 6. In the QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 006-026 in Section 6. In the QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 006-026 in Section 6. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2H

Go to 3A

Guided Step 2H - Check for fuel in the oil or coolant.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for fuel in the oil or coolant.

Check for fuel in the oil or coolant.
OK NOT OK

No fuel in the oil or coolant

Fuel in oil or coolant

Go to 2I

Appropriate troubleshooting symptom tree

Guided Step 2I - Inspect the actuator screen for debris.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the actuator screen for debris.

  • Remove the fuel rail actuator. Refer to Procedure 019-110 in Section 19.
OK NOT OK

No debris

Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 2J

Go to 3A

Guided Step 2J - Inspect the actuator for corrosion.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the actuator for corrosion.

  • Remove the rail actuator to inspect for corrosion. Refer to Procedure 019-110 in Section 19.
OK NOT OK

No corrosion

Replace the rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and run through the operating range to verify that Fault Code 468 stays inactive.
OK NOT OK

Fault Code 468 inactive

Go to the appropriate symptom-driven tree in Section TS or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Appropriate symptom tree

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting tree

Last Modified: 20-Apr-2012


FAULT CODE 471 - Engine Oil Level Number 1 Low - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Determine oil level sensor type. |
 | STEP 1A. Is oil level sensor a 3-pin type? | Sensor is a 3-pin type
STEP 2. | Check the oil level sensor accuracy. |
 | STEP 2A. Verify oil level sensor. | Oil level is correct
STEP 3. | Check the engine control module sensor value. |
 | STEP 3A. Verify that the fault simulation feature for the oil level sensor is not enabled. | Fault simulation is disabled
 | STEP 3B. Check threshold setting. | Fault threshold is set correctly
STEP 4. | Verify oil level is low. |
 | STEP 4A. Check the oil level. | Oil level is normal.
STEP 5. | Check the coolant level sensor. |
 | STEP 5A. Confirm the fault is still active with the engine operating. | Fault still active.
 | STEP 5B. Check the threshold setting. | Fault threshold set correctly.
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 471 inactive
 | STEP 6B. Clear any inactive fault codes. | All fault codes cleared

Guided Step 1 - Determine oil level sensor type.

Guided Step 1A - Determine oil level sensor type.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Is oil level sensor a 3-pin type?
OK NOT OK

Sensor is a 3-pin type

Sensor is a 4-pin type

Go to 2A

Go to 4A

Guided Step 2 - Check the oil level sensor accuracy.

Guided Step 2A - Verify oil level sensor.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Verify the oil level using the oil dipstick.
OK NOT OK

Oil level is correct

Fill the engine lubricating oil to the appropriate level.

  • Refer to Procedure 018-017 in Section V. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 018-017 in Section V. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 018-017 in Section V. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 018-017 in Section V. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 018-0173 in Section V. In the QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine control module sensor value.

Guided Step 3A - Verify that the fault simulation feature for the oil level sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Verify that the fault simulation is not enabled for the oil level sensor by connecting to the engine control module via INSITE™ electronic service tool.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 3B

Go to 6A

Guided Step 3B - Check threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the oil pressure sensor.
OK NOT OK

Fault threshold is set correctly

Fault threshold is not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 6A

Go to 6A

Guided Step 4 - Verify that the oil is low.

Guided Step 4A - Check the oil level.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the oil level.

  • Use the dipstick to verify the oil level.
OK NOT OK

Oil level is normal

Fill the engine lubricating oil to the correct level.

Go to 5A

Go to 6A

Guided Step 5 - Check the coolant level sensor.

Guided Step 5A - Confirm the fault is still active with the engine operating.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Confirm the fault is still active.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault still active. Replace sensor. Refer to Procedure 019-017 in Section 19.

Go to 5B

Go to 6A

Guided Step 5B - Check the threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that Fault Simulation is not enabled for the oil pressure sensor.
OK NOT OK

Fault threshold set correctly

Fault threshold not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify if Fault Code 471 is inactive.
OK NOT OK

Fault Code 471 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear any inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 488 - Intake Manifold Temperature Number 1 High - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the intake manifold temperature sensor is not enabled. | Fault simulation disabled
 | STEP 2B. Check the threshold setting. | Fault threshold set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 488 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the intake manifold temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the intake manifold temperature reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, then answer “OK” to this step.
OK NOT OK

Sensor reading correct

Go to 2A

Fault Code 153

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the intake manifold temperature sensor is not enabled.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Verify that the fault simulation is not enabled for the intake manifold temperature sensor by connecting to the engine control module via the electronic service tool.
OK NOT OK

Fault simulation disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check the threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the manifold temperature sensor.
OK NOT OK

Fault threshold set correctly. Reference symptom tree T096 in Section TS in the following manuals:

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 488 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Apr-2012


FAULT CODE 498 - Engine Oil Level Number 1 Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the engine harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit in the sensor harness. | Less than 10 ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4C. Check for an open circuit in the engine harness. | Less than 10 ohms
STEP 5. | Check the extension harness. |
 | STEP 5A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5C. Check for an open circuit in the extension harness. | Less than 10 ohms
STEP 6. | Check the engine control module response. |
 | STEP 6A. Check for the appropriate engine control module response. | Fault Code 498 inactive, Fault Code 499 active
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 498 inactive
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the oil level sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the oil level sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness connector from the oil level sensor.

Action

Inspect the sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 2B

Go to 7A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the sensor.
  • Connect INSITE™ electronic service tool.

Action

Check the oil level sensor supply voltage.

  • Measure the supply voltage from the oil level SUPPLY pin to the oil level RETURN pin at the sensor connector.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil level sensor signal voltage.

  • Use the engine control module breakout box to measure the signal voltage from the oil level sensor by monitoring the voltage between the oil level SIGNAL pin and the oil level RETURN pin.
OK NOT OK

0.46 to 4.56-VDC

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 3A

Go to 7A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness and the engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.

Action

Inspect the sensor harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level SUPPLY pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the oil level RETURN pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the oil level SIGNAL pin on the sensor harness connector to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

3C

Go to 7A

Guided Step 3C - Check for an open circuit in the sensor harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from the oil level RETURN pin on the sensor harness connector to the oil level RETURN pin on the sensor harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture form the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil level RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the oil level SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

4C

Go to 7A

Guided Step 4C - Check for an open circuit in the engine harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor harness.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from the oil level RETURN pin on the engine harness inline connector to the oil level RETURN pin on the sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the extension harness.

Guided Step 5A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil level RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil level SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for an open circuit in the extension harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from the oil level RETURN pin on the extension harness connector to the oil level RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the engine control module response.

Guided Step 6A - Check for the appropriate engine control module response.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the oil level SIGNAL pin and the oil level RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 498 inactive, Fault Code 499 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 498 is inactive.
OK NOT OK

Fault Code 498 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Apr-2012


FAULT CODE 499 - Engine Oil Level Number 1 Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes active
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the sensor harness. |
 | STEP 3A. Inspect the sensor harness and the engine harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit in the sensor harness. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit in the engine harness. | Less than 10 ohms
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the extension harness. |
 | STEP 5A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for an open circuit in the extension harness. | Less than 10 ohms
 | STEP 5C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 6. | Check the engine control module response. |
 | STEP 6A. Check for the appropriate engine control module response. | Fault Code 499 inactive, Fault Code 498 active
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 499 inactive
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the oil level sensor.
OK NOT OK

No other fault codes active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the oil level sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness connector from the oil level sensor.

Action

Inspect the sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 2B

Go to 7A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the sensor.
  • Connect INSITE™ electronic service tool.

Action

Check the oil level sensor supply voltage.

  • Measure the supply voltage from the oil level SUPPLY pin to the oil level RETURN pin at the sensor connector.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil level sensor signal voltage.

  • Use the engine control module breakout box to measure the signal voltage from the oil level sensor by monitoring the voltage between the oil level SIGNAL pin and the oil level RETURN pin.
OK NOT OK

0.46 to 4.56-VDC

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Go to 3A

Go to 7A

Guided Step 3 - Check the sensor harness.

Guided Step 3A - Inspect the sensor harness and the engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.

Action

Inspect the sensor harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the sensor harness. Repair the engine harness.

  • Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19, Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 7A

Guided Step 3B - Check for an open circuit in the sensor harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for an open circuit in the signal and supply wires.

  • Measure the resistance from the oil level SIGNAL pin on the sensor harness connector to the oil level SIGNAL pin on the sensor harness sensor connector.
  • Measure the resistance from the oil level SUPPLY pin on the sensor harness connector to the oil level SUPPLY pin on the sensor harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil level SIGNAL pin on the sensor harness connector to engine block ground.
  • Measure the resistance from the oil level RETURN pin on the sensor harness connector to engine block ground.
  • Measure the resistance from the oil level SUPPLY pin on the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level SUPPLY pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the oil level RETURN pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the oil level SIGNAL pin on the sensor harness connector to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture form the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check for an open circuit in the engine harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.

Action

Check for an open circuit in the signal and supply wires.

  • Measure the resistance from the oil level SIGNAL pin on the engine harness inline connector to the oil level SIGNAL pin on the sensor harness connector.
  • Measure the resistance from the oil level SUPPLY pin on the engine harness inline connector to the oil level SUPPLY pin on the sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil level SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the oil level RETURN pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the oil level SUPPLY pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the oil level sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level SUPPLY pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the oil level RETURN pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the oil level SIGNAL pin on the engine harness inline connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the extension harness.

Guided Step 5A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Check for an open circuit in the extension harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the signal and supply wires.

  • Measure the resistance from the oil level SIGNAL pin on the extension harness connector to the oil level SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the oil level SUPPLY pin on the extension harness connector to the oil level SUPPLY pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the oil level SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the oil level RETURN pin on the extension harness connector to engine block ground.
  • Measure the resistance from the oil level SUPPLY pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5D

Go to 7A

Guided Step 5D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the oil level SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil level RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the oil level SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the engine control module response.

Guided Step 6A - Check for the appropriate engine control module response.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the oil level SIGNAL pin and the oil level SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 499 inactive, Fault Code 498 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 499 is inactive.
OK NOT OK

Fault Code 499 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2012


FAULT CODE 514 - Fuel Rail Actuator - Mechanically Stuck

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the complaint. |
 | STEP 1A. Other fault codes active besides Fault Code 514. | Other fault codes inactive
 | STEP 1B. Interview the operator to see if the engine symptoms are present. | Symptoms present
 | STEP 1C. Engine surges. | No engine surge
 | STEP 1D. Engine dies and Fault Code 514 becomes active. | Fault becomes active; then engine is shut down or derated
 | STEP 1E. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 1F. Inspect the extension harness and the engine control module connector pins. | No damaged pins
STEP 2. | Check the fuel system flow. |
 | STEP 2A. Check the fuel tank level. | Fuel in tank
 | STEP 2B. Inspect the fuel system for leaks, damaged lines, and loose fittings. | No leaks, damaged lines, or loose fittings
 | STEP 2C. Check the fuel inlet restriction. | Less than 203 mm-Hg [8 in-Hg]
 | STEP 2D. Check for air in the fuel. | Minimal air in the fuel
 | STEP 2E. Inspect the fuel shutoff solenoid for excessive wear. | No excessive wear
 | STEP 2F. Check the fuel pump output pressure. | For QSK45 and QSK60: Minimum 110 psi @ 600 rpm, Minimum 200 psi @ 1300 rpm, Minimum 250 psi @ 1900 rpm, Minimum 260 psi @ 2300 rpm
 | STEP 2G. Check the injector o-rings. | Drain output is equal
 | STEP 2H. Check for fuel in the oil or coolant. | No fuel in the oil or coolant
 | STEP 2I. Inspect the actuator screen for debris. | No debris
 | STEP 2J. Inspect the actuator for corrosion. | No corrosion
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 514 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify the complaint.

Guided Step 1A - Other fault codes active besides Fault Code 514.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Other fault codes active besides Fault Code 514.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Other fault codes inactive

Investigate the other fault codes first

Go to 1B

Appropriate troubleshooting chart

Guided Step 1B - Interview the operator to see if the engine symptoms are present.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Interview the operator to see if the engine symptoms are present.

  • Check if the operator is complaining about specific symptoms, shutdowns, or derates due to this fault.
OK NOT OK

Symptoms present

Clear the fault code. Check to see if inactive fault codes have been logged. Since the customer is not experiencing a problem, clear the inactive fault codes.

Go to 1C

Go to 3A

Guided Step 1C - Engine surges.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Engine surges.

  • Observe engine surge.
OK NOT OK

No engine surge

Refer to the specific symptom tree. Complete the symptom tree that best describes when the surge occurs.

Go to 1D

Appropriate symptom tree

Guided Step 1D - Engine dies and Fault Code 514 becomes active.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Engine dies and Fault Code 514 becomes active.

  • Observe when Fault Code 514 becomes active.
OK NOT OK

Fault becomes active; then engine is shut down or derated

Check the fuel shutoff circuit. Find Fault Code 254. Check for an intermittent open circuit in the harness.

Go to 1E

Fault Code 254

Guided Step 1E - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Engine dies and Fault Code 514 becomes active.

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 1F

Go to 3A

Guided Step 1F - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Engine dies and Fault Code 514 becomes active.

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system flow.

Guided Step 2A - Check the fuel tank level.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the fuel tank level for the following:

  • Fuel in the tank.
OK NOT OK

Fuel in tank

Fill tank with fuel.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel system for leaks, damaged lines, and loose fittings.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the fuel system for leaks, broken lines, and loose fittings.
OK NOT OK

No leaks, damaged lines, or loose fittings

Repair the leak. Tighten or replace the leaking fitting or fuel line.

  • Refer to Procedure 006-024 in Section 6. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 006-024 in Section 6. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 006-024 in Section 6. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 006-024 in Section 6. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 006-024 in Section 6. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2C

Go to 3A

Guided Step 2C - Check the inlet restriction.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check the inlet restriction as follows:

Measure the inlet restriction.

  • Refer to Procedure 005-016 in Section 6. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 6. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 6. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 6. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bullein 4021539.
OK NOT OK

Less than 203 mm-Hg [8 in-Hg]

Find cause of restriction and remove restriction. Check for clogged fuel filters, debris in the fuel tank, clogged fuel tank vents, collapsed or faulty fuel lines, or faulty check valves.

Go to 2D

Go to 3A

Guided Step 2D - Check for air in the fuel.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check for air in the fuel.

Check for air in the fuel system.

  • Refer to Procedure 005-016 in Section 5 Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5 QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5 QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bullein 4021539.
OK NOT OK

Minimal air in the fuel

Find cause of air in the fuel. Check for missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.

Go to 2E

Go to 3A

Guided Step 2E - Inspect the fuel shutoff solenoid for excessive wear.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the fuel shutoff solenoid for excessive wear.

  • Remove the fuel shutoff solenoid and inspect the spacer for excessive wear. Refer to the base engine troubleshooting and repair manual.
OK NOT OK

No excessive wear

Repair or replace the fuel shutoff valve.

  • Refer to Procedure 005-043 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-043 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-043 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-043 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2F

Go to 3A

Guided Step 2F - Check the fuel pump output pressure.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check the fuel pump output pressure.

Measure the output pressure of the pump at the Compucheck® fitting.

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bullein 4021539.
OK NOT OK

For QSK45 and QSK60:

  • Minimum 110 psi @ 600 rpm
  • Minimum 200 psi @ 1300 rpm
  • Minimum 250 psi @ 1900 rpm
  • Minimum 260 psi @ 2300 rpm.

Go to 2G

Go to 3A

Guided Step 2G - Check the injector o-rings.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check the injector o-rings.

  • The o-rings can be checked by observing the drain output of the front three versus the rear three cylinders.
  • Disconnect the drain lines at the T-junction.
  • Place each half into separate, equal-size buckets.
  • Operate the engine at rated speed for enough time to determine if the output is equal from each half.
OK NOT OK

Drain output is equal

Replace the injector o-rings on the faulty bank.

  • Refer to Procedure 006-026 in Section 6. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 006-026 in Section 6. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 006-026 in Section 6. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 006-026 in Section 6. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 006-026 in Section 6. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2H

Go to 3A

Guided Step 2H - Check for fuel in the oil or coolant.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for fuel in the oil or coolant.
OK NOT OK

No fuel in the oil or coolant

Fuel in oil or coolant

Go to 2I

Appropriate troubleshooting symptom tree

Guided Step 2I - Inspect the actuator screen for debris.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the actuator screen for debris.

  • Remove the fuel rail actuator. Refer to Procedure 019-110 in Section 19.
OK NOT OK

No debris

Replace the rail actuator screen. Refer to Procedure 019-110 in Section 19.

Go to 2J

Go to 3A

Guided Step 2J - Inspect the actuator for corrosion.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the actuator for corrosion.

  • Remove the rail actuator to inspect for corrosion. Refer to Procedure 019-110 in Section 19.
OK NOT OK

No corrosion

Replace the rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and run through the operating range to verify that Fault Code 514 stays inactive.
OK NOT OK

Fault Code 514 inactive

Go to the appropriate symptom-driven tree in Section TS or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Appropriate symptom tree

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting tree

Last Modified: 20-Apr-2012


FAULT CODE 546 - Fuel Delivery Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - engine control module connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pressure sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the engine control module response. |
 | STEP 4A. Check for the appropriate engine control module response. | Fault Code 546 inactive, Fault Code 547 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 546 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel pressure sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 1C

Go to 2A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

2C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the fuel pressure SUPPLY pin on the engine harness inline connector to the fuel pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel pressure SIGNAL pin on the engine harness inline connector to the fuel pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel pressure RETURN pin on the engine harness inline connector to the fuel pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the fuel pressure SUPPLY pin on the extension harness connector to the fuel pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel pressure SIGNAL pin on the extension harness connector to the fuel pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel pressure RETURN pin on the extension harness connector to the fuel pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module response.

Guided Step 4A - Check for the appropriate engine control module response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the fuel pressure SIGNAL pin and the fuel pressure RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 546 inactive, Fault Code 547 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Verify that Fault Code 546 is inactive.
OK NOT OK

Fault Code 546 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Apr-2012


FAULT CODE 547 - Fuel Delivery Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch/™AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - engine control module connector breakout boxPart Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes active
STEP 2. | Check the fuel pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 5. | Check the engine control module response. |
 | STEP 5A. Check for the appropriate engine control module response. | Fault Code 547 inactive, Fault Code 546 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 547 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel pump pressure sensor.
OK NOT OK

No other fault codes active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pressure SIGNAL pin on the engine harness inline connector to the fuel pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel pressure RETURN pin on the engine harness inline connector to the fuel pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel pressure SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the fuel pressure RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pressure SIGNAL pin on the extension harness connector to the fuel pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel pressure RETURN pin on the extension harness connector to the fuel pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel pressure SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel pressure RETURN pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine control module response.

Guided Step 5A - Check for the appropriate engine control module response.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the fuel pressure SIGNAL pin and the fuel pressure SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 547 inactive, Fault Code 546 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 547 is inactive.
OK NOT OK

Fault Code 547 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Apr-2012


FAULT CODE 554 - Fuel Rail Pressure Sensor Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - engine control module connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rail pressure sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 554 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel rail pressure sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 1C

Go to 4A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the fuel supply pressure sensor. Refer to Procedure 019-113 in Section 19.

Go to 2A

Go to 6A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the engine harness inline connector to the fuel rail pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to the fuel rail pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to the fuel rail pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the fuel rail pressure RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the extension harness connector to the fuel rail pressure SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to the fuel rail pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to the fuel rail pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rail pressure SUPPLY pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel rail pressure SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel rail pressure RETURN pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 554 is inactive.
OK NOT OK

Fault Code 554 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Apr-2012


FAULT CODE 555 - Blowby Pressure - Warning Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the blowby pressure sensor. | Sensor reading correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the blowby pressure sensor is not enabled. | Fault simulation disabled
 | STEP 2B. Check the threshold setting. | Fault threshold set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 555 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the blowby pressure sensor.

Conditions

  • Connect a water manometer gauge to the engine.
  • Connect INSITE™ electronic service tool and service harness to the data link connector on the engine harness.
  • Place the run/stop/auto switch in the RUN position.

Action

temp

Note: Operate the engine at rated rpm and full load (wide open throttle) until a steady reading is obtained.
OK NOT OK

Sensor reading correct

Check the crankcase breathers. Reference the procedure in the following manuals:

  • Refer to Procedure 003-001 in Section 3. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 003-001 in Section 3. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 003-001 in Section 3. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 003-001 in Section 3. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 003-001 in Section 3. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Fault Code 719

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the blowby pressure sensor is not enabled.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled.
OK NOT OK

Fault simulation disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check the threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the blowby pressure sensor.
OK NOT OK

Fault threshold set correctly. Reference the symptom tree T027 in Section TS

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 555 is inactive.
OK NOT OK

Fault Code 555 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Apr-2012


FAULT CODE 556 - Blowby Pressure - Critical Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the blowby pressure sensor. | Sensor reading correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the blowby pressure sensor is not enabled. | Fault simulation disabled
 | STEP 2B. Check the threshold setting. | Fault threshold set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 556 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the blowby pressure sensor.

Conditions

  • Connect a water manometer gauge to the engine.
  • Connect INSITE™ electronic service tool and service harness to the data link connector on the engine harness.
  • Place the run/stop/auto switch in the STOP position.

Action

temp

Note: Operate the engine at rated rpm and full load (wide-open throttle) until a steady reading is obtained.
OK NOT OK

Sensor reading correct

Check the crankcase breathers. Reference the procedure in the following manual:.

  • Refer to Procedure 003-001 in Section 3. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 003-001 in Section 3. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 003-001 in Section 3. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 003-001 in Section 3. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 003-001 in Section 3. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Fault Code 719

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the blowby pressure sensor is not enabled.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled.
OK NOT OK

Fault simulation disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check the threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the blowby pressure sensor.
OK NOT OK

Fault threshold set correctly. Reference symptom tree T027 in Section TS.

  • Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • QST30 Service Manual, Bulletin 4021539.
  • QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Fault threshold not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the STOP position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 556 is inactive.
OK NOT OK

Fault Code 556 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Apr-2012


FAULT CODE 581 - Fuel Supply Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - engine control module connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel supply pressure sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the engine control module response. |
 | STEP 4A. Check for the appropriate engine control module response. | Fault Code 581 inactive, Fault Code 582 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 581 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel supply pressure sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel supply pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19., Refer to Procedure 019-202 in Section 19., Refer to Procedure 019-205 in Section 19. or Refer to Procedure 019-219 in Section 19..
  • Replace the fuel supply pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 1C

Go to 2A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the fuel supply pressure sensor. Refer to Procedure 019-115 in Section 19..

Go to 2A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19..
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19..

Go to 2B

Go to 5A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel supply pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel supply pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel supply pressure +5 VDC SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel supply pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel supply pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

2C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel supply pressure sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the fuel supply pressure +5 VDC SUPPLY pin on the engine harness inline connector to the fuel supply pressure +5 VDC SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the fuel supply pressure SIGNAL pin on the engine harness inline connector to the fuel supply pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel supply pressure RETURN pin on the engine harness inline connector to the fuel supply pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 3A

Go to 5A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19..
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19..
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel supply pressure +5 VDC SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel supply pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel supply pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19..
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19..

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the fuel supply pressure +5 VDC SUPPLY pin on the extension harness connector to the fuel supply pressure +5 VDC SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel supply pressure SIGNAL pin on the extension harness connector to the fuel supply pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel supply pressure RETURN pin on the extension harness connector to the fuel supply pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19..
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19..

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module response.

Guided Step 4A - Check for the appropriate engine control module response.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the fuel supply pressure SIGNAL pin and the fuel supply pressure RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 581 inactive, Fault Code 582 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Verify that Fault Code 581 is inactive.
OK NOT OK

Fault Code 581 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Apr-2012


FAULT CODE 582 - Fuel Supply Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3163594 - engine control module connector breakout box, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes active
STEP 2. | Check the fuel supply pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
 | STEP 4D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 5. | Check the engine control module response. |
 | STEP 5A. Check for the appropriate engine control module response. | Fault Code 582 inactive, Fault Code 581 active
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 582 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel supply pressure sensor.
OK NOT OK

No other fault codes active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the fuel supply pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the fuel supply pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-219 in Section 19.
  • Replace the fuel supply pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the fuel supply pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel supply pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel supply pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel supply pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel supply pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

3C

Go to 6A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel supply pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the fuel supply pressure SIGNAL pin on the engine harness inline connector to the fuel supply pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the fuel supply pressure RETURN pin on the engine harness inline connector to the fuel supply pressure RETURN pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel supply pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel supply pressure SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the fuel supply pressure RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel supply pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel supply pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel supply pressure SIGNAL pin on the extension harness connector to the fuel supply pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel supply pressure RETURN pin on the extension harness connector to the fuel supply pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel supply pressure SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel supply pressure RETURN pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the engine control module response.

Guided Step 5A - Check for the appropriate engine control module response.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the fuel supply pressure SIGNAL pin and the fuel supply pressure +5 VDC SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 582 inactive, Fault Code 581 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 582 is inactive.
OK NOT OK

Fault Code 582 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Apr-2012


FAULT CODE 611 - Engine Hot Shutdown

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Action

No corrective action.

NOTE: Fault Code 611 is used for notification to technician of engine hot shutdown.
OK NOT OK

Last Modified: 24-Apr-2012


FAULT CODE 649 - Change Lubricating Oil and Filter

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Change lubricating oil.

Use INSITE™ electronic service tool to set the “Oil Changed” parameter in the Adjustments - Features - Maintenance Monitor group to YES.

OK NOT OK

Repair Complete

Repair Complete

Last Modified: 24-Apr-2012


FAULT CODE 688 - Engine Oil Level Number 1 High - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the oil level. | Oil level correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the oil level sensor is not enabled. | Fault simulation disabled
 | STEP 2B. Check the threshold setting. | Fault threshold set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 688 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the oil level.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check lubricating oil level.
OK NOT OK

Oil level normal

Use the following procedure for the appropriate lubricating oil level.

  • Refer to Procedure 018-017 in Section V. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 018-017 in Section V. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 018-017 in Section V. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 018-017 in Section V. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 018-017 in Section V. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the oil level sensor is not enabled.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Verify that the fault simulation is not enabled for the oil level sensor by connecting to the engine control module via the electronic service tool.
OK NOT OK

Fault simulation disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Check the threshold setting.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that fault simulation is not enabled for the oil level sensor.
OK NOT OK

Fault threshold set correctly

Fault threshold not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 688 is inactive.
OK NOT OK

Fault Code 688 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 24-Apr-2012


FAULT CODE 689 - Crankshaft Engine Speed Sensor Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 10 ohms
 | STEP 1C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 1D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 2. | Check the extension harness. |
 | STEP 2A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the crankshaft engine speed sensor. |
 | STEP 3A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 3B. Check signal from the sensor. | Signal present
 | STEP 3C. Check sensor supply voltage. | 4.75 to 5.25-VDC
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the crankshaft engine speed sensor SUPPLY pins on the engine harness inline connector to the crankshaft engine speed sensor SUPPLY pins at the engine harness sensor connector.
  • Measure the resistance from the crankshaft engine speed sensor RETURN pin on the engine harness inline connector to the crankshaft engine speed sensor RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the crankshaft engine speed sensor SIGNAL pin on the engine harness inline connector to the crankshaft engine speed sensor SIGNAL pin at the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the crankshaft engine speed sensor SUPPLY pins on the engine harness inline connector to engine block ground.
  • Measure the resistance from the crankshaft engine speed sensor SIGNAL pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the crankshaft engine speed sensor SUPPLY pins to all other pins of the engine harness inline connector.
  • Measure the resistance between the crankshaft engine speed sensor RETURN pin to all other pins of the engine harness inline connector.
  • Measure the resistance between the crankshaft engine speed sensor SIGNAL pin to all other pins of the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

2A

Go to 4A

Guided Step 2 - Check the extension harness.

Guided Step 2A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the engine harness.
  • Connect the engine harness to the crankshaft engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the crankshaft engine speed sensor SIGNAL pin to the RETURN pin on the extension harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the crankshaft engine speed sensor SUPPLY pins on the extension harness connector to engine block ground.
  • Measure the resistance from the crankshaft engine speed sensor RETURN pin on the extension harness connector to engine block ground.
  • Measure the resistance from the crankshaft engine speed sensor SIGNAL pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the crankshaft engine speed sensor SUPPLY pins and all other pins on the extension harness connector.
  • Measure the resistance between the crankshaft engine speed sensor RETURN pin and all other pins on the extension harness connector.
  • Measure the resistance between the crankshaft engine speed sensor SIGNAL pin and all other pins on the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the crankshaft engine speed sensor.

Guided Step 3A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture form the connector, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-038 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check signal from the sensor.

Conditions

  • Install breakout cable, between the crankshaft engine speed sensor and the engine harness.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the STOP position.

Action

Check sensor signal voltage:

  • While barring the engine over, use the sensor breakout cable to measure the voltage from the SIGNAL pin to the RETURN pin. Signal must change from +4.0 through 5.0-VDC to +0.5 through 2.3-VDC and back, about every 60 degrees of crankshaft rotation.
OK NOT OK

Signal present

Signal not present

Go to 4A

Go to 3C

Guided Step 3C - Check sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Connect INSITE™ electronic service tool.

Action

Check the supply voltage.

  • Measure the voltage from the crankshaft engine speed sensor SUPPLY pins to the crankshaft engine speed sensor RETURN pin on the harness side of the crankshaft engine speed sensor connector.
OK NOT OK

4.75 to 5.25-VDC

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-038 in Section 19.

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 689 is inactive.
OK NOT OK

Fault Code 689 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 24-Apr-2012


FAULT CODE 719 - Blowby Pressure Sensor - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes active
STEP 2. | Check the blowby pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the sensor harness. Note: QSK45 ONLY |
 | STEP 3A. Inspect the sensor harness and the engine harness connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
STEP 5. | Check the extension harness. |
 | STEP 5A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5C. Check for an open circuit. | Less than 10 ohms
STEP 6. | Check the engine control module response. |
 | STEP 6A. Check for the appropriate engine control module response. | Fault Code 719 inactive, Fault Code 729 active
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 719 inactive
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the blowby pressure sensor.
OK NOT OK

No other fault codes are active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the blowby pressure sensor.

Guided Step 2A - Inspect the sensor and sensor harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness connector from the blowby pressure sensor.

Action

Inspect the sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 2B

Go to 7A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the blowby pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Install the blowby pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the blowby pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 3A

Go to 7A

Guided Step 3 - Check the blowby pressure sensor harness. Note: QSK45 ONLY

Guided Step 3A - Inspect the sensor harness and the engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.

Action

Inspect the sensor harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor or engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor or engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the blowby pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the blowby pressure SUPPLY pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the blowby pressure RETURN pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the blowby pressure SIGNAL pin on the sensor harness connector to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the blowby pressure sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the blowby pressure RETURN pin on the sensor harness connector to the blowby pressure RETURN pin on the sensor harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the sensor harness.

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the engine or extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the blowby pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the blowby pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the blowby pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the blowby pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

4C

Go to 7A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the blowby pressure RETURN pin on the engine harness inline connector to the blowby pressure RETURN pin on the sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the extension harness.

Guided Step 5A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the blowby pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the blowby pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the blowby pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the blowby pressure RETURN pin on the extension harness connector to the blowby pressure RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the engine control module response.

Guided Step 6A - Check for the appropriate engine control module response.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the blowby pressure SIGNAL pin and the blowby pressure RETURN pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 719 inactive, Fault Code 729 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 719 is inactive.
OK NOT OK

Fault Code 719 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 24-Apr-2012


FAULT CODE 729 - Blowby Pressure Sensor - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes active
STEP 2. | Check the blowby pressure sensor. |
 | STEP 2A. Inspect the sensor and sensor harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC
STEP 3. | Check the sensor harness. Note: QSK45 ONLY |
 | STEP 3A. Inspect the sensor harness and the engine harness connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the extension harness. |
 | STEP 5A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for an open circuit. | Less than 10 ohms
 | STEP 5C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 6. | Check the engine control module response. |
 | STEP 6A. Check for the appropriate engine control module response. | Fault Code 729 inactive, Fault Code 719 active
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 729 inactive
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine-specific wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the blowby pressure sensor.
OK NOT OK

No other fault codes active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the blowby pressure sensor.

Guided Step 2A - Inspect the sensor and sensor harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness connector from the blowby pressure sensor.

Action

Inspect the sensor and the sensor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seal
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 2B

Go to 7A

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the blowby pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply (pin A) and return (pin B) connectors into the multimeter.
OK NOT OK

4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the blowby pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal (pin C) and return (pin B) connectors into the multimeter.
OK NOT OK

0.46 to 4.56-VDC

Replace the blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 3A

Go to 7A

Guided Step 3 - Check the sensor harness. Note: QSK45 ONLY

Guided Step 3A - Inspect the sensor harness and the engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.

Action

Inspect the sensor harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 7A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the blowby pressure sensor.

Action

Check for an open circuit in the signal and supply wires.

  • Measure the resistance from the blowby pressure SIGNAL pin on the sensor harness connector to the blowby pressure SIGNAL pin on the sensor harness sensor connector.
  • Measure the resistance from the blowby pressure SUPPLY pin on the sensor harness connector to the blowby pressure SUPPLY pin on the sensor harness sensor connector.
OK NOT OK

Less than 10 ohms

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the blowby pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the blowby pressure SIGNAL pin on the sensor harness connector to engine block ground.
  • Measure the resistance from the blowby pressure RETURN pin on the sensor harness connector to engine block ground.
  • Measure the resistance from the blowby pressure SUPPLY pin on the sensor harness connector to engine block ground.
OK NOT OK

More than 100k ohms

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the sensor harness from the engine harness.
  • Disconnect the sensor harness from the blowby pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the blowby pressure SUPPLY pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the blowby pressure RETURN pin on the sensor harness connector to all other pins in the sensor harness connector.
  • Measure the resistance from the blowby pressure SIGNAL pin on the sensor harness connector to all other pins in the sensor harness connector.
OK NOT OK

More than 100k ohms

  • Repair the sensor harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the sensor harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Check for an open circuit in the signal and supply wires.

  • Measure the resistance from the blowby pressure SIGNAL pin on the engine harness inline connector to the blowby pressure SIGNAL pin on the sensor harness connector.
  • Measure the resistance from the blowby pressure SUPPLY pin on the engine harness inline connector to the blowby pressure SUPPLY pin on the sensor harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the blowby pressure sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the blowby pressure SIGNAL pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the blowby pressure RETURN pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the blowby pressure SUPPLY pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the blowby pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the blowby pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the blowby pressure SUPPLY pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the blowby pressure RETURN pin on the engine harness inline connector to all other pins in the engine harness.
  • Measure the resistance from the blowby pressure SIGNAL pin on the engine harness inline connector to all other pins in the engine harness.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the extension harness.

Guided Step 5A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the signal and supply wires.

  • Measure the resistance from the blowby pressure SIGNAL pin on the extension harness connector to the blowby pressure SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the blowby pressure SUPPLY pin on the extension harness connector to the blowby pressure SUPPLY pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the blowby pressure SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the blowby pressure RETURN pin on the extension harness connector to engine block ground.
  • Measure the resistance from the blowby pressure SUPPLY pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5D

Go to 7A

Guided Step 5D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the blowby pressure SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the blowby pressure RETURN pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the blowby pressure SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the engine control module response.

Guided Step 6A - Check for the appropriate engine control module response.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the coolant pressure SIGNAL pin and the coolant pressure SUPPLY pin on the breakout box.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 729 inactive, Fault Code 719 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 729 is inactive.
OK NOT OK

Fault Code 729 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 25-Apr-2012


FAULT CODE 731 - Engine Speed/Position - Mechanical Misalignment of Crankshaft and Camshaft

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot individual fault codes. |
 | STEP 1A. Troubleshoot Fault Code 689. | Fault Codes 689 inactive
 | STEP 1B. Troubleshoot Fault Code 778. | Fault Codes 778 inactive
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 731 inactive
 | STEP 2B. Clear the inactive fault code. | All fault codes cleared
 | STEP 2C. If fault returns. | All fault codes cleared and timing checked

Guided Step 1 - Troubleshoot individual fault codes.

Guided Step 1A - Troubleshoot Fault Code 689.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Confirm the fault is still active.

  • Use INSITE™ electronic service tool to verify the status of Fault Code 689.
OK NOT OK

Fault Code 689 inactive

Go to 1B

Fault Code 689

Guided Step 1B - Troubleshoot Fault Code 778.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Confirm the fault is still active.

  • Use INSITE™ electronic service tool to verify the status of Fault Code 778.
OK NOT OK

Fault Code 778 inactive

Go to 2A

Fault Code 778

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 731 is inactive.
OK NOT OK

Fault Code 731 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete. Read Step 2C

Appropriate troubleshooting chart

Guided Step 2C - If fault returns.

Conditions

  • Complete all steps above and recheck.

Action

Check the static timing of the injector camshaft.

Use the procedure in the following manuals:

  • Refer to Procedure 003-004 in Section 3. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 003-006 in Section 3. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 003-004 in Section 3. QST30 Service Manual, Bulletin 4021539. eng 57
  • Refer to Procedure 003-006 in Section 3.QSK45 and QSK60 Service Manual, Bulletin 4021530.eng 56
  • Refer to Procedure 003-006 in Section 3. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.
OK NOT OK

All fault codes cleared and timing checked

Refer to appropriate troubleshooting charts for any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Apr-2012


FAULT CODE 778 - Camshaft Engine Position Sensor Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the camshaft engine position sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Check signal from the sensor. | Signal present
 | STEP 1C. Check sensor supply voltage. | 4.75 to 5.25-VDC
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 778 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the camshaft engine position sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness connector from the engine position sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check signal from the sensor.

Conditions

  • Install breakout cable between the camshaft engine position sensor and the engine harness.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the STOP position.

Action

Check sensor signal voltage:

  • While barring the engine over, use the sensor breakout cable to measure the voltage from the SIGNAL pin to the RETURN pin. Signal must change about every 60 degrees of camshaft rotation, 120 degrees of crankshaft rotation.
OK NOT OK

Signal present

Signal not present

Go to 2A

Go to 1C

Guided Step 1C - Check sensor supply voltage.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the camshaft engine position sensor.
  • Connect INSITE™ electronic service tool.

Action

Check the supply voltage.

  • Measure the voltage from the camshaft engine position sensor SUPPLY pin to the camshaft engine position sensor RETURN pin on the engine harness sensor connector.
OK NOT OK

4.75 to 5.25-VDC

Replace the camshaft engine position sensor. Refer to Procedure 019-038 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine position sensor.

Action

Check for an open circuit.

  • Measure the resistance from the camshaft engine position sensor SUPPLY pin on the engine harness inline connector to the camshaft engine position sensor SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the camshaft engine position sensor RETURN pin on the engine harness inline connector to the camshaft engine position sensor RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the camshaft engine position sensor SIGNAL pin on the engine harness inline connector to the camshaft engine position sensor SIGNAL pin on the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine position sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the camshaft engine position sensor SUPPLY pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the camshaft engine position sensor SIGNAL pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine position sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the camshaft engine position sensor SUPPLY pin to all other pins of the engine harness inline connector.
  • Measure the resistance between the camshaft engine position sensor RETURN pin to all other pins of the engine harness inline connector.
  • Measure the resistance between the camshaft engine position sensor SIGNAL pin to all other pins of the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the engine harness.
  • Connect the engine harness to the engine position sensor.

Action

Check for an open circuit.

  • Measure the resistance from the camshaft engine position sensor SIGNAL pin to the camshaft engine position sensor RETURN pin on the extension harness connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the camshaft engine position sensor SUPPLY pin on the extension harness connector to engine block ground.
  • Measure the resistance from the camshaft engine position sensor RETURN pin on the extension harness connector to engine block ground.
  • Measure the resistance from the camshaft engine position sensor SIGNAL pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the camshaft engine position sensor SUPPLY pin and all other pins on the extension harness connector.
  • Measure the resistance between the camshaft engine position sensor RETURN pin and all other pins on the extension harness connector.
  • Measure the resistance between the camshaft engine position sensor SIGNAL pin and all other pins on the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Idle/Rated switch in the Idle position.
  • Run/Stop switch in the Run position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 778 is inactive.
OK NOT OK

Fault Code 778 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 25-Apr-2012


FAULT CODE 1211 - Fuel Shutoff Valve 1 Circuit - Root Cause Not Known (Left Bank)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff valve solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff valve solenoid post. | No extra wires
 | STEP 1B. Clean the solenoid posts and the wiring terminal. | Solenoid posts clean
 | STEP 1B-1. Check the solenoid coil for an internal short. |
 | STEP 1C. Check the supply voltage at the fuel shutoff valve solenoid. | More than 17.0 VDC for +24 VDC fuel shutoff, More than 11.0 VDC for +12 VDC fuel shutoff
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2B-1. Check for continuity to engine block ground. |
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1211 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel shutoff valve solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff valve solenoid post.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for extra wires on the fuel shutoff solenoid post.
OK NOT OK

No extra wires

Remove the extra wires, and connect the removed wires to a proper 24-VDC supply.

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid posts and the wiring terminal.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the fuel shutoff control wire to the fuel shutoff valve solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the posts of the fuel shutoff valve solenoid and the terminal for the fuel shutoff valve solenoid control wires of the engine harness.
OK NOT OK

Solenoid posts clean

Repair ring terminal or replace the fuel shutoff valve solenoid.

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the fuel shutoff valve solenoid. Refer to Procedure 019-050 in Section 19.

Go to 1B-1

Go to 4A

Guided Step 1B-1 - Check the solenoid coil for an internal short.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the fuel shutoff signal and return wires from the fuel shutoff valve.

Action

Check the solenoid coil for an internal short.

  • Measure the resistance from the fuel shutoff signal post to engine block ground.
  • Measure the resistance from the fuel shutoff return post to engine block ground.
OK NOT OK

More than 100k ohms

Replace the fuel shutoff valve solenoid. Refer to Procedure 019-050 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check the supply voltage at the fuel shutoff valve solenoid.

Conditions

  • Disconnect the engine harness from the fuel shutoff valve solenoid.
  • Place the run/stop/auto switch in the RUN position.
  • Engine must be cranking.

Action

Check the supply voltage at the fuel shutoff solenoid.

  • Measure the voltage from the fuel shutoff supply wire ring terminal on the harness side to the engine block ground.
OK NOT OK

More than 17.0 VDC for +24 VDC fuel shutoff, More than 11.0 VDC for +12 VDC fuel shutoff

Go to 4A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel shutoff valve solenoid.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for continuity to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel shutoff valve solenoid.
  • Disconnect engine harness from extension harness.

Action

Check for continuity.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness fuel shutoff connector to engine block ground.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel shutoff valve solenoid.
  • Disconnect engine harness from extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to the fuel shutoff valve signal ring terminal.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to the fuel shutoff valve return ring terminal.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel shutoff valve solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to the fuel shutoff valve SIGNAL pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1211 is inactive.
OK NOT OK

Fault Code 1211 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Apr-2012


FAULT CODE 1212 - Fuel Shutoff Valve 2 Circuit - Root Cause Not Known (Right Bank)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel shutoff valve solenoid. |
 | STEP 1A. Check for extra wires on the fuel shutoff valve solenoid post. | No extra wires
 | STEP 1B. Clean the solenoid posts and the wiring terminal. | Solenoid posts clean
 | STEP 1B-1. Check the solenoid coil for an internal short. |
 | STEP 1C. Check the supply voltage at the fuel shutoff valve solenoid. | More than 17.0 VDC for +24 VDC fuel shutoff, More than 11.0 VDC for +12 VDC fuel shutoff
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2B-1. Check for continuity to engine block ground. |
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1212 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel shutoff valve solenoid.

Guided Step 1A - Check for extra wires on the fuel shutoff valve solenoid post.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for extra wires on the fuel shutoff solenoid post.

Check for extra wires on the fuel shutoff solenoid post.
OK NOT OK

No extra wires

Remove the extra wires, and connect the removed wires to a proper 24-VDC supply.

Go to 1B

Go to 4A

Guided Step 1B - Clean the solenoid posts and the wiring terminal.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the fuel shutoff control wire to the fuel shutoff valve solenoid.

Action

Clean the solenoid post and the wiring terminal.

  • Clean the posts of the fuel shutoff valve solenoid and the terminal for the fuel shutoff valve solenoid control wires of the engine harness.
OK NOT OK

Solenoid posts clean

Repair ring terminal or replace the fuel shutoff valve solenoid.

  • Repair the ring terminal. Refer to Procedure 019-197 in Section 19.
  • Replace the fuel shutoff valve solenoid. Refer to Procedure 019-050 in Section 19.

Go to 1B-1

Go to 4A

Guided Step 1B-1 - Check the solenoid coil for an internal short.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the fuel shutoff signal and return wires from the fuel shutoff valve.

Action

Check the solenoid coil for an internal short.

  • Measure the resistance from the fuel shutoff signal post to engine block ground.
  • Measure the resistance from the fuel shutoff return post to engine block ground.
OK NOT OK

More than 100k ohms

Replace the fuel shutoff valve solenoid. Refer to Procedure 019-050 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check the supply voltage at the fuel shutoff valve solenoid.

Conditions

  • Disconnect the engine harness from the fuel shutoff valve solenoid.
  • Place the run/stop/auto switch in the RUN position.
  • Engine must be cranking.

Action

Check the supply voltage at the fuel shutoff solenoid.

  • Measure the voltage from the fuel shutoff supply wire ring terminal on the harness side to the engine block ground.
OK NOT OK

More than 17.0 VDC for +24 VDC fuel shutoff, More than 11.0 VDC for +12 VDC fuel shutoff

Go to 4A

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel shutoff valve solenoid.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for continuity to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel shutoff valve solenoid.
  • Disconnect engine harness from extension harness.

Action

Check for continuity.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness fuel shutoff connector to engine block ground.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect engine harness from fuel shutoff valve solenoid.
  • Disconnect engine harness from extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to the fuel shutoff valve signal ring terminal.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to the fuel shutoff valve return ring terminal.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel shutoff valve solenoid.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel shutoff valve solenoid.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to the fuel shutoff valve SIGNAL pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1212 is inactive.
OK NOT OK

Fault Code 1212 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Apr-2012


FAULT CODE 1311 - Customer-Defined Fault Code 1

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to Customer documentation for fault code details. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot the fault code.

Conditions

This is a customer-defined fault code.

Action

This is a customer-defined fault code.

  • Refer to the customer documentation for details on the fault code.

YES | NO
No Repair | No Repair

Go to

Last Modified: 30-Apr-2012


FAULT CODE 1312 - Customer-Defined Fault Code 2

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to Customer documentation for fault code details. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot the fault code.

Conditions

This is a customer-defined fault code.

Action

This is a customer-defined fault code.

  • Refer to the customer documentation for details the fault code.

YES | NO
No Repair | No Repair

Last Modified: 30-Apr-2012


FAULT CODE 1313 - Customer-Defined LonWorks Fault Code 1

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to Customer documentation for fault code details. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot the fault code.

Conditions

This is a customer-defined LonWorks fault code.

Action

This is a customer-defined Lonworks fault code.

  • Refer to the customer documentation for details on the fault code.

YES | NO
No Repair | No Repair

Last Modified: 30-Apr-2012


FAULT CODE 1314 - Customer-Defined LonWorks Fault Code 2

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to Customer documentation for fault code details. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot the fault code.

Conditions

This is a customer-defined LonWorks fault code.

Action

This is a customer-defined LonWorks fault code.

  • Refer to the customer documentation for details on the fault code.

YES | NO
No Repair | No Repair

Last Modified: 30-Apr-2012


FAULT CODE 1315 - Customer-Defined LonWorks Fault Code 3

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to Customer documentation for fault code details. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot the fault code.

Conditions

This is a customer-defined LonWorks fault code.

Action

This is a customer-defined LonWorks fault code.

  • Refer to the customer documentation for details on the fault code.

YES | NO
No Repair | No Repair

Last Modified: 30-Apr-2012


LT CODE 1316 - Customer-Defined LonWorks Fault Code 4

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to Customer documentation for fault code details. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot the fault code.

Conditions

This is a customer-defined LonWorks fault code.

Action

This is a customer-defined LonWorks fault code.

  • Refer to the customer documentation for details on the fault code.

YES | NO
No Repair | No Repair

Last Modified: 30-Apr-2012


FAULT CODE 1317 - Customer-Defined Fault Code 3

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to Customer documentation for fault code details. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot the fault code.

Conditions

This is a customer-defined fault code.

Action

This is a customer-defined fault code.

  • Refer to the customer documentation for details on the fault code.

YES | NO
No Repair | No Repair

Go to

Go to

Last Modified: 30-Apr-2012


FAULT CODE 1318 - Customer-Defined Fault Code 4

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to Customer documentation for fault code details. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot the fault code.

Conditions

This is a customer-defined fault code.

Action

This is a customer-defined fault code.

  • Refer to the customer documentation for details on the fault code.

YES | NO
No Repair | No Repair

Go to

Go to

Last Modified: 30-Apr-2012


FAULT CODE 1319 - Alternator Temperature - Alternator Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the sensor is not enabled. | Fault simulation disabled
 | STEP 2B. Verify that the threshold for the fault is set correctly. | Fault threshold set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1319 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect the temperature probe to the alternator near the alternator temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the alternator temperature reading on INSITE™ service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer OK to this step.
OK NOT OK

Sensor reading correct

Replace the alternator temperature sensor.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the alternator temperature sensor.
OK NOT OK

Fault simulation disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Verify that the threshold for the fault is set correctly.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the alternator temperature sensor.
OK NOT OK

Fault threshold set correctly

Fault threshold is not set correctly. Reset the threshold to the lowest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 1319 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Operation mode run/stop/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Apr-2012


FAULT CODE 1321 - Common Warning Output Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board.To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the common warning output post. |
 | STEP 1A. Check for multiple fault codes. | No other fault codes active
 | STEP 1B. Inspect the common warning output post. | No damaged pins
 | STEP 1C. Check the wiring connected to the output post for shorts. | More than 100k ohms
 | STEP 1D. Check connection between the terminal block and paralleling harness. | No damaged connectors
STEP 2. | Check the paralleling harness. |
 | STEP 2A. Inspect the paralleling harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1321 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the common warning output post.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific wiring diagram to verify that no fault codes are active for any relays sharing a common electrical supply with the common warning relay.
OK NOT OK

No other fault codes active

Go to multiple fault tree

Go to 1B

Multiple fault tree

Guided Step 1B - Inspect the common warning output post.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer wiring from the common warning output post.

Action

Inspect the customer wiring and the common warning output post for the following:

  • Loose connector
  • Corroded post
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged post

Repair the damaged post.

  • Flush the dirt, debris, or moisture from the post. Use electrical contact cleaner, Part Number 3824510.
  • Repair the customer wiring. Refer to OEM service manual.
  • Replace the customer wiring. Refer to OEM service manual.
  • Replace the common warning output post. Refer to Procedure 019-321 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the wiring connected to the output post for shorts.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the parallel harness from the terminal block.
  • Connect the customer wiring to the common warning output post.

Action

Inspect the customer wiring and the common warning output post for the following:

  • Measure the resistance from the common warning posts to all other post on the terminal block.
OK NOT OK

More than 100k ohms

Repair or replace the terminal block or the customer wiring.

  • Repair or replace the terminal block. Refer to Procedure 019-321 in Section 19.
  • Repair/replace the customer wiring. Refer to OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check connection between terminal block and paralleling harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness wire from the common warning output post.

Action

Inspect the paralleling harness conections and the terminal block connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged connectors

Repair the damaged connectors.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.
  • Replace the terminal block. Refer to Procedure 019-321 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the paralleling harness.

Guided Step 2A - Inspect the paralleling harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module connector pins.

Action

Inspect the paralleling harness and the engine control module connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged connectors.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.
  • Replace the paralleling board. Refer to Procedure 019-322 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the common warning output post.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the common warning pin on the paralleling harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the common warning output post.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the common warning pin on the paralleling harness connector to all other pins on the paralleling harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the common warning output post.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the common warning pin on the paralleling harness connector to the common warning pin output post connector.
OK NOT OK

Less than 10 ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1321 is inactive.
OK NOT OK

Fault Code 1321 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Operation mode run/stop/auto in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Apr-2012


FAULT CODE 1322 - Load Govern Kilowatt Setpoint - Analog Input Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the remote analog input signal source. |
 | STEP 1A. Inspect the input device connector pins and the customer paralleling harness pins. | No damaged pins
 | STEP 1B. Verify input device is set up correctly. | Trim set correctly
 | STEP 1C. Check the input device for failures. | Input device is not experiencing any failures
STEP 2. | Check the customer paralleling wiring. |
 | STEP 2A. Inspect the customer paralleling wiring and the terminal block post. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the paralleling harness. |
 | STEP 3A. Check connection between the terminal block and paralleling harness. | No damaged connectors
 | STEP 3B. Inspect the paralleling harness and the engine control module connector pins. | No damaged pins
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1322 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the remote analog input signal source.

Guided Step 1A - Inspect the input device connector pins and the customer paralleling harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the input device.

Action

Inspect the wiring and the input device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged wiring or the input device, whichever has the damaged pins or wires.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair/replace the customer paralleling wiring. Refer to site installation document and remote input device document procedures.
  • Replace the input device. Refer to remote input device document procedures.

Go to 1B

Go to 4A

Guided Step 1B - Verify input device is set up correctly.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Verify input device is set up correctly.

  • If remote input device is set up to provide a 0 to 5-VDC signal, use INSITE™ electronic service tool to enable the load govern kilowatt setpoint range checking enable.
  • If remote input device is set up to provide a 0 to 24-VDC signal, use INSITE™ electronic service tool to disable the load govern kilowatt setpoint range checking enable.
OK NOT OK

Trim set correctly

Trim set incorrectly. Use INSITE™ electronic service tool to set trim correctly.

Go to 1C

Go to 4A

Guided Step 1C - Check the input device for failures.

Conditions

  • Place the run/stop/auto switch in the RUN position.
  • Disconnect the customer paralleling wiring from the input device.

Action

Use the input device's users manual and electronic service tool to verify that the input device is functioning normally.
OK NOT OK

Input device is not experiencing any failures

Repair or replace the remote input device. Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the customer paralleling wiring.

Guided Step 2A - Inspect the customer paralleling wiring and the terminal block post.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the terminal block post.

Action

Inspect the customer paralleling harness and the terminal block post for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the pins
  • Missing or damaged connector seals
  • Pushed back or expanded pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins or the terminal block, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the customer paralleling harness. Refer to site installation document and remote input device document procedures.
  • Replace the customer paralleling harness. Refer to site installation document and remote input device document procedures.
  • Replace the terminal block. Refer to Procedure 019-321 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the terminal block.
  • Disconnect the customer paralleling wiring from the input device.

Action

Check for an open circuit in the SIGNAL wires.

  • Measure the resistance from the load govern kilowatt positive (+) wire on the customer paralleling wiring to the load govern kilowatt positive (+) pin on the input device connector.
  • Measure the resistance from the load govern kilowatt negative (-) wire on the customer paralleling wiring to the load govern kilowatt negative (-) pin on the input device connector.
OK NOT OK

Less than 10 ohms

Repair or replace the customer paralleling wiring. Refer to site installation document and input device document procedures.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the terminal block.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the load govern kilowatt positive (+) wire on the customer paralleling wiring to all other pins on the customer paralleling wiring connections.
  • Measure the resistance from the load govern kilowatt negative (-) wire on the customer paralleling wiring to all other pins on the customer paralleling wiring connections.
OK NOT OK

More than 100k ohms

Repair or replace the customer paralleling wiring. Refer to site installation document and remote input device document procedures.

Go to 3A

Go to 4A

Guided Step 3 - Check the paralleling harness.

Guided Step 3A - Check connection between terminal block and paralleling harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness wires from the load govern kilowatt +/- posts.

Action

Inspect the paralleling harness connections and the terminal block connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the pins
  • Pushed back or expanded pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged connectors

Repair the damaged connectors.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.
  • Replace the terminal block. Refer to Procedure 019-321 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Inspect the paralleling harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module connector pins.

Action

Inspect the paralleling harness and the engine control module connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged connectors.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.
  • Replace the paralleling board. Refer to Procedure 019-322 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the load govern kilowatt +/- posts.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the load govern kilowatt positive (+) pin on the paralleling harness connector to all other pins on the paralleling harness connector.
  • Measure the resistance from the load govern kilowatt negative (-) pin on the paralleling harness connector to all other pins on the paralleling harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the load govern kilowatt positive (+) and negative (-) posts.

Action

Check for an open circuit in the SIGNAL wires.

  • Measure the resistance from the load govern kilowatt positive (+) pin on the paralleling harness connector to the load govern kilowatt positive (+) pin output post connector.
  • Measure the resistance from the load govern kilowatt negative (-) pin on the paralleling harness connector to the load govern kilowatt negative (-) pin output post connector.
OK NOT OK

Less than 10 ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1322 is inactive.
OK NOT OK

Fault Code 1322 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Operation mode run/stop/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Apr-2012


FAULT CODE 1323 - Load Governed Kilowatt Setpoint - Analog Input Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the remote analog input signal source. |
 | STEP 1A. Inspect the remote input device connector pins and the customer paralleling wiring. | No damaged pins
 | STEP 1B. Verify input device is set up correctly. | Trim set correctly
 | STEP 1C. Check the remote input device for failures. | Input device is not experiencing any failures
STEP 2. | Check the customer paralleling wiring. |
 | STEP 2A. Inspect the customer paralleling wiring and the terminal block post. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the paralleling harness. |
 | STEP 3A. Check connection between the terminal block and paralleling harness. | No damaged connectors
 | STEP 3B. Inspect the paralleling harness and the engine control module connector pins. | No damaged pins
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1323 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the remote analog input signal source.

Guided Step 1A - Inspect the remote input device connector pins and the customer paralleling wiring.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring the remote input device.

Action

Inspect the harness and the controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins or the remote input device, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair/replace the customer paralleling wiring. Reference site installation document and remote input device document procedures.
  • Replace the remote input device. Reference the remote input device document procedures.

Go to 1B

Go to 4A

Guided Step 1B - Verify input device is set up correctly.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Verify input device is set up correctly.

  • If remote input device is set up to provide a 0 to 5-VDC signal. Use INSITE™ electronic service tool to enable the load govern kilowatt setpoint range checking enable.
  • If remote input device is set up to provide a 0 to 24-VDC signal. Use INSITE™ electronic service tool to disable the load govern kilowatt setpoint range checking enable.
OK NOT OK

Trim set correctly

Trim set incorrectly. Set trim correctly. Use INSITE™ electronic service tool.

Go to 1C

Go to 4A

Guided Step 1C - Check the remote input device for failures.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Verify input device is set up correctly.

  • Verify that the remote input device is functioning normally.
OK NOT OK

Input device is not experiencing any failures

Repair or replace the remote input device. Reference remote input device document procedures.

Go to 2A

Go to 4A

Guided Step 2 - Check the customer paralleling wiring.

Guided Step 2A - Inspect the customer paralleling wiring and the terminal block post.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the terminal block post.

Action

Inspect the paralleling harness and the terminal block post for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins or the terminal block, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair/replace the customer paralleling wiring. Reference site installation document and remote input device document procedures.
  • Replace the terminal block. Refer to Procedure 019-321 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the terminal block.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Check for an open circuit in the signal wire.

  • Measure the resistance from the external kilowatt positive (+) wire on the customer paralleling wiring to the external kilowatt positive (+) pin on the remote input device connector.
  • Measure the resistance from the external kilowatt negative (-) wire on the customer paralleling wiring to the external kilowatt negative (-) pin on the remote input device connector.
OK NOT OK

Less than 10 ohms

Repair or replace the customer paralleling wiring. Reference site installation document and remote input device document procedures.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the terminal block.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the external kilowatt positive (+) wire on the customer paralleling wiring to all other pins on the customer paralleling wiring connections.
  • Measure the resistance from the external kilowatt positive (-) wire on the customer paralleling wiring to all other pins on the customer paralleling wiring connections.
OK NOT OK

More than 100k ohms

Repair or replace the customer paralleling wiring. Reference site installation document and remote input device document procedures.

Go to 3A

Go to 4A

Guided Step 3 - Check the paralleling harness.

Guided Step 3A - Check connection between terminal block and paralleling harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness wires from the external kilowatt positive (+) and negative (-) posts.

Action

Inspect the paralleling harness connections and the terminal block connections for the following:

  • Loose connector
  • Corroded post
  • Bent or broken post
  • Moisture in or on the post
  • Pushed back or expanded post
  • Dirt or debris in or on the connector post
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged connectors

Repair the damaged connectors.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.
  • Replace the terminal block. Refer to Procedure 019-321 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Inspect the paralleling harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module connector pins.

Action

Inspect the paralleling harness and the engine control module connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged connectors.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.
  • Replace the paralleling board. Refer to Procedure 019-322 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the external kilowatt positive (+) and negative (-) posts.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the external kilowatt positive (+) pin on the paralleling harness connector to engine block ground.
  • Measure the resistance from the external kilowatt negative (-) pin on the paralleling harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the external kilowatt positive (+) and negative (-) posts.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the external kilowatt positive (+) pin on the paralleling harness connector to all other pins on the paralleling harness connector.
  • Measure the resistance from the external kilowatt negative (-) pin on the paralleling harness connector to all other pins on the paralleling harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the external kilowatt positive (+) and negative (-) posts.

Action

Check for an open circuit in the signal wire.

  • Measure the resistance from the external kilowatt positive (+) pin on the paralleling harness connector to the external kilowatt positive (+) pin output post connector.
  • Measure the resistance from the external kilowatt negative (-) pin on the paralleling harness connector to the external kilowatt negative (-) pin output post connector.
OK NOT OK

Less than 10 ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1323 is inactive.
OK NOT OK

Fault Code 1323 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Operation run/stop/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Apr-2012


FAULT CODE 1324 - Load Governed Kilovolt-Ampere Setpoint - Analog Input Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the remote analog input signal source. |
 | STEP 1A. Inspect the remote input device connector pins and the customer paralleling harness pins. | No damaged pins
 | STEP 1B. Verify input device is set up correctly. | Trim set correctly
 | STEP 1C. Check the remote input device for malfunctions. | Input device is not experiencing any malfunctions
STEP 2. | Check the customer paralleling wiring. |
 | STEP 2A. Inspect the customer paralleling wiring and the terminal block post. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the paralleling harness. |
 | STEP 3A. Check connection between the terminal block and paralleling harness. | No damaged connectors
 | STEP 3B. Inspect the paralleling harness and the engine control module connector pins. | No damaged pins
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1324 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the remote analog input signal source.

Guided Step 1A - Inspect the remote input device connector pins and the customer paralleling harness pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Inspect the wiring and the remote input device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the customer paralleling wiring or the remote input device, whichever has the damaged pins/wires.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair/replace the customer paralleling harness. Reference the site installation document and remote input device document procedures.
  • Replace the remote input device. Reference the remote input device document procedures.

Go to 1B

Go to 4A

Guided Step 1B - Verify input device is set up correctly.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wires from the remote input device.

Action

Verify input device is set up correctly

  • If remote input device is set up to provide a 0 to 5-VDC signal, use the electronic service tool to enable the load govern kW setpoint range checking enable.
  • If remote input device is set up to provide a 0 to 24-VDC signal, use the electronic service tool to disable the load govern kW setpoint range checking enable.
OK NOT OK

Trim set correctly

Trim set incorrectly. Set trim correctly. Use INSITE™ electronic service tool.

Go to 1C

Go to 4A

Guided Step 1C - Check the remote input device for malfunctions.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Using the paralleling controller's user manual and service tools.

  • Verify that the remote input device is functioning normally.
  • Look for signal on the remote input device.
OK NOT OK

Input device is not experiencing any malfunctions

Repair or replace the remote input device.

  • Repair/replace remote input device. Reference the remote input device document procedures.

Go to 2A

Go to 4A

Guided Step 2 - Check the customer paralleling wiring.

Guided Step 2A - Inspect the customer paralleling wiring and the terminal block post.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the terminal block post.

Action

Inspect the paralleling wiring and the terminal block post for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the pins
  • Pushed back or expanded pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the customer paralleling wiring or the terminal block, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair/replace the customer paralleling wiring. Reference the site installation document and remote input device document procedures.
  • Replace the terminal block. Refer to Procedure 019-321 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the terminal block.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Check for an open circuit in the signal wire.

  • Measure the resistance from the external kilovolt-ampere positive (+) wire on the customer paralleling wiring to the external kilovolt-ampere positive (+) pin on the remote input device connector.
  • Measure the resistance from the external kilovolt-ampere negative (-) wire on the customer paralleling wiring to the external kilovolt-ampere negative (-) pin on the remote input device connector.
OK NOT OK

Less than 10 ohms

Repair or replace the customer paralleling wiring.

  • Repair/replace the customer paralleling wiring. Reference the site installation document and remote input device document procedures.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring wires from the terminal block.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the external kilovolt-ampere positive (+) wire on the customer paralleling wiring to all other pins on the customer paralleling wiring connections.
  • Measure the resistance from the external kilovolt-ampere negative (-) wire on the customer paralleling wiring to all other pins on the customer paralleling wiring connections.
OK NOT OK

More than 100k ohms

Repair or replace the customer paralleling wiring.

  • Repair/replace the customer paralleling wiring. Reference the site installation document and remote input device document procedures.

Go to 3A

Go to 4A

Guided Step 3 - Check the paralleling harness.

Guided Step 3A - Check connection between terminal block and paralleling harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness wires from the external kilovolt-ampere positive (+) and negative (-) posts.

Action

Inspect the paralleling harness connections and the terminal block connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the pins
  • Pushed back or expanded pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged connectors

Repair or replace the paralleling harness connections or the terminal block.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the paralleling harness. Refer to Procedure 019-213 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.
  • Replace the terminal block. Refer to Procedure 019-321 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Inspect the paralleling harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module connector pins.

Action

Inspect the paralleling harness and the engine control module connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the paralleling harness connections or the terminal block.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the paralleling harness. Refer to Procedure 019-213 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.
  • Replace the paralleling board. Refer to Procedure 019-322 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the external kilovolt-ampere positive (+) and negative (-) posts.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the external kilovolt-ampere positive (+) pin on the paralleling harness connector to all other pins on the paralleling harness connector.
  • Measure the resistance from the external kilovolt-ampere negative (-) pin on the paralleling harness connector to all other pins on the paralleling harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-213 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the external kilovolt-ampere positive (+) and negative (-) posts.

Action

Check for an open circuit in the signal wire.

  • Measure the resistance from the external kilovolt-ampere positive (+) pin on the paralleling harness connector to the external kilovolt-ampere positive (+) pin output post connector.
  • Measure the resistance from the external kilovolt-ampere negative (-) pin on the paralleling harness connector to the external kilovolt-ampere negative (-) pin output post connector.
OK NOT OK

Less than 10 ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-213 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1324 is inactive.
OK NOT OK

Fault Code 1322 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Operation run/stop/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Apr-2012


FAULT CODE 1325 - Load Governed Kilovolt-Ampere Setpoint - Analog Input Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the remote input device. |
 | STEP 1A. Inspect the remote input device connector pins and the customer paralleling wiring pins. | No damaged pins
 | STEP 1B. Verify input device is set up correctly. | Trim set correctly
 | STEP 1C. Check the remote input device for failures. | Input device is not experiencing any failures
STEP 2. | Check the customer paralleling wiring. |
 | STEP 2A. Inspect the customer paralleling wiring and the terminal block post. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the paralleling harness. |
 | STEP 3A. Check connection between the terminal block and paralleling harness. | No damaged connectors
 | STEP 3B. Inspect the paralleling harness and the engine control module connector pins. | No damaged pins
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3E. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1325 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the remote input device.

Guided Step 1A - Inspect the remote input device connector pins and the customer paralleling wiring pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Inspect the wiring and the input device connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the customer paralleling wiring or the remote input device, whichever has the damaged pins/wires.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair/replace the customer paralleling harness. Reference the site installation document and remote input device document procedures.
  • Replace the remote input device. Reference the remote input device document procedures.

Go to 1B

Go to 4A

Guided Step 1B - Verify input device is set up correctly.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Use INSITE™ electronic service tool.

  • If remote input device is set up to provide a 0 to 5-VDC signal. Use INSITE™ electronic service tool to enable the load govern kilovolt-ampere setpoint range checking enable.
  • If remote input device is set up to provide a 0 to 24-VDC signal. Use INSITE™ electronic service tool to disable the load govern kilovolt-ampere setpoint range checking enable.
OK NOT OK

Trim set correctly

Set trim correctly. Use INSITE™ electronic service tool.

Go to 1C

Go to 4A

Guided Step 1C - Check the remote input device for failures.

Conditions

  • Place the run/stop/auto switch in the RUN position.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Using INSITE™ electronic service tool.

  • Verify that the remote input device is functioning normally.
OK NOT OK

Input device is not experiencing any malfunctions.

Repair or replace the remote input device.

  • Repair/replace remote input device. Reference the remote input device document procedures.

Go to 2A

Go to 4A

Guided Step 2 - Check the customer paralleling wiring.

Guided Step 2A - Inspect the customer paralleling wiring and the terminal block post.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring from the terminal block post.

Action

Inspect the customer paralleling wiring and the terminal block posts for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the pins
  • Missing or damaged connector seals
  • Pushed back or expanded pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the customer paralleling wiring or the terminal block, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the customer paralleling wiring. Reference the site installation document and remote input device document procedures.
  • Replace the customer paralleling wiring. Reference the site installation document and remote input device document procedures.
  • Replace the terminal block. Refer to Procedure 019-321 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring wires from the terminal block.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Check for an open circuit in the signal wire.

  • Measure the resistance from the load govern kilovolt-ampere positive (+) wire on the customer paralleling wiring to the load govern kilovolt-ampere positive (+) pin on the remote input device connector.
  • Measure the resistance from the load govern kilovolt-ampere negative (-) wire on the customer paralleling wiring to the load govern kilovolt-ampere negative (-) pin on the remote input device connector.
OK NOT OK

Less than 10 ohms

Repair or replace the customer paralleling wiring.

  • Repair/replace the customer paralleling wiring. Reference the site installation document and remote input device document procedures.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the customer paralleling wiring wires from the terminal block.
  • Disconnect the customer paralleling wiring from the remote input device.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the load govern kilovolt-ampere positive (+) wire on the customer paralleling wiring to all other pins on the customer paralleling wiring connections.
  • Measure the resistance from the load govern kilovolt-ampere negative (-) wire on the customer paralleling wiring to all other pins on the customer paralleling wiring connections.
OK NOT OK

More than 100k ohms

Repair or replace the customer paralleling wiring.

  • Repair/replace the customer paralleling wiring. Reference the site installation document and remote input device document procedures.

Go to 4A

Go to 4A

Guided Step 3 - Check the paralleling harness.

Guided Step 3A - Check connection between terminal block and paralleling harness.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness wires from the load govern kilovolt-ampere positive (+) and negative (-) posts.

Action

Inspect the paralleling harness connections and the terminal block connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the pins
  • Missing or damaged connector seals
  • Pushed back or expanded pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged connectors

Repair or replace the paralleling harness connections or the terminal block.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the paralleling harness. Refer to Procedure 019-213 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.
  • Replace the terminal block. Refer to Procedure 019-321 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Inspect the paralleling harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module connector pins.

Action

Inspect the paralleling harness and the engine control module connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the paralleling harness connections or the terminal block.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the paralleling harness. Refer to Procedure 019-213 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.
  • Replace the paralleling board. Refer to Procedure 019-322 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the load govern kilovolt-ampere positive (+) and negative (-) posts.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the load govern kilovolt-ampere positive ( + ) pin on the paralleling harness connector to engine block ground.
  • Measure the resistance from the load govern kilovolt-ampere negative ( - ) pins on the paralleling harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-213 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the load govern kilovolt-ampere positive (+) and negative (-) posts.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the load govern kilovolt-ampere positive ( + ) pin on the paralleling harness connector to all other pins on the paralleling harness connector.
  • Measure the resistance from the load govern kilovolt-ampere negative ( - ) pin on the paralleling harness connector to all other pins on the paralleling harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-213 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the paralleling harness from the engine control module.
  • Disconnect the paralleling harness from the load govern kilovolt-ampere positive (+) and negative (-) posts.

Action

Check for an open circuit in the signal wire.

  • Measure the resistance from the common warning pin on the paralleling harness connector to the common warning pin output post connector.
  • Measure the resistance from the load govern kilovolt-ampere positive (+) pin on the paralleling harness connector to the load govern kilovolt-ampere positive (+) output post connector.
  • Measure the resistance from the load govern kilovolt-ampere negative (-) pin on the paralleling harness connector to the load govern kilovolt-ampere negative (-) output post connector.
OK NOT OK

Less than 10 ohms

Repair or replace the paralleling harness.

  • Repair the paralleling harness. Refer to Procedure 019-213 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the paralleling harness. Refer to Procedure 019-316 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1325 is inactive.
OK NOT OK

Fault Code 1325 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place operation run/stop/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Apr-2012


FAULT CODE 1326 - Starter Backup Disconnect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for other fault codes. |
 | STEP 1A. Read fault codes. | Fault Code 1329 is not active
STEP 2. | Check the AC harness from PMG to voltage regulator. |
 | STEP 2A. Check output voltage on PMG. | 140 to 260 VDC at rated
 | STEP 2B. Inspect the PMG, AC harness, and voltage regulator connector pins. | No damaged pins
 | STEP 2C. Check the AC harness for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2D. Check the AC harness for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2E. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the voltage regulator and crank coil. |
 | STEP 3A. Inspect the voltage regulator connector pins. | No damaged pins
 | STEP 3B. Check the voltage regulator for failures. | LED is on
 | STEP 3C. Check the crank coil post for correct wiring. | Wiring correct
STEP 4. | Check the generator control harness. |
 | STEP 4A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4C. Check for an open circuit. | Less than 10 ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1326 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for other fault codes.

Guided Step 1A - Read fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Verify that Fault Code 1329 is not active.
OK NOT OK

Fault Code 1329 is not active

Fault Code 1329 is active. Troubleshoot Fault Code 1329 first

Go to 2A

Fault Code 1329

Guided Step 2 - Check the AC harness from PMG to voltage regulator.

Guided Step 2A - Check output voltage on PMG.

Conditions

  • Place the run/stop/auto switch in the RUN position.
  • Place the idle/rated switch in RATED.
  • Connect INSITE™ electronic service tool.

Action

Use a multimeter to check the PMG connectors to AC harness.

  • Check phase-to- phase voltage from three phases.
OK NOT OK

140 to 260-VDC at rated

Less than 140-VDC. Replace the PMG. Reference the site installation document procedures.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the PMG, AC harness, and voltage regulator connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the AC harness from the PMG.
  • Disconnect the AC harness from the voltage regulator.

Action

Inspect the PMG, AC harness, and voltage regulator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the PMG, AC harness, or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-206 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.
  • Replace the PMG. Reference the site installation document procedures.

Go to 2C

Go to 5A

Guided Step 2C - Check the AC harness for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the AC harness from the PMG.
  • Disconnect the AC harness from the voltage regulator connector 10.

Action

Check AC harness for a short circuit to engine block ground.

  • Measure the resistance from the PMG AC harness P2 pin to engine block ground.
  • Measure the resistance from the PMG AC harness P3 pin to engine block ground.
  • Measure the resistance from the PMG AC harness P4 pin to engine block ground.
OK NOT OK

More than 100k ohms

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-206 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check the AC harness for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the AC harness from the PMG.
  • Disconnect the AC harness from the voltage regulator connector 10.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the AC harness PMG connector pin P2 to all other pins in the AC harness PMG connector.
  • Measure the resistance from the AC harness PMG connector pin P3 to all other pins in the AC harness PMG connector.
  • Measure the resistance from the AC harness PMG connector pin P4 to all other pins in the AC harness PMG connector.
OK NOT OK

More than 100k ohms

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-206 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the AC harness from the PMG.
  • Disconnect the AC harness from the voltage regulator connector 10.

Action

Check for an open circuit in the AC harness.

  • Measure the resistance from the AC harness PMG connector wire P2 to the AC harness connector pin P2 on connector 10.
  • Measure the resistance from the AC harness PMG connector wire P3 to the AC harness connector pin P3 on connector 10.
  • Measure the resistance from the AC harness PMG connector wire P4 to the AC harness connector pin P4 on connector 10.
OK NOT OK

Less than 10 ohms

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-206 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the voltage regulator and crank coil.

Guided Step 3A - Inspect the voltage regulator connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the voltage regulator.

Action

Inspect the generator control harness and the voltage regulator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check the voltage regulator for failures.

Conditions

  • Place the run/stop/auto switch in the RUN position.
  • Place the idle/rated switch in the IDLE.
  • Connect INSITE™ electronic service tool.

Action

Check to see if backup starter disconnect LED is on, indicating starter disconnect contacts are open.

Check to see if backup starter disconnect LED is on, indicating starter disconnect contacts are open.
OK NOT OK

LED is on

Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the crank coil post for correct wiring.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check crank coil post for correct wiring.

Check to make sure B positive (+) is not wired into crank relay post and crank secondary coil post.

OK NOT OK

Wiring correct

Remove B positive (+) wire. Replace proper wire.

Go to 4A

Go to 5A

Guided Step 4 - Check the generator control harness.

Guided Step 4A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module connector 06.

Action

Inspect the generator control harness and engine control module connector 06 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the base board. Refer to Procedure 019-322 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the voltage regulator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the starter backup disconnect pin at the generator control harness engine control module connector to all other pins in the generator control harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the voltage backup.

Action

Check for an open circuit in the supply wire.

  • Measure the resistance from the starter backup disconnect pin on the generator control harness connector 07 to the starter backup disconnect pin on the generator control harness engine control module connector 06.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1326 is inactive.
OK NOT OK

Fault Code 1326 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the run/stop/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Apr-2012


FAULT CODE 1327 - Load Governed Kilovolt-Ampere Setpoint - Analog Input Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify proper set up. |
 | STEP 1A. Verify load govern kilovolt-ampere method is set up correctly. | Analog input enabled
STEP 2. | Check for shorted low. |
 | STEP 2A. Check for active Fault Code 1323. | Fault Code 1323 inactive
STEP 3. | Check for shorted high. |
 | STEP 3A. Check for active Fault Code 1322. | Fault Code 1322 inactive
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1327 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify proper setup.

Guided Step 1A - Verify load govern kilovolt-ampere method is set up correctly.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that load govern kilovolt-ampere method is set to Analog Input.
OK NOT OK

Analog input enabled

Set to Analog Input

Go to 2A

Go to 4A

Guided Step 2 - Check for shorted low.

Guided Step 2A - Check for active Fault Code 1323.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to check for Fault Code 1323.
OK NOT OK

Fault Code 1323 inactive

Troubleshoot Fault Code 1323

Go to 3A

Go to 4A

Guided Step 3 - Check for shorted high.

Guided Step 3A - Check for active Fault Code 1322.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to check for Fault Code 1322.
OK NOT OK

Fault Code 1322 inactive

Troubleshoot Fault Code 1322

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1327 is inactive.
OK NOT OK

Fault Code 1327 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the run/stop/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1328 - Generator Set Circuit Breaker

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check for other fault codes. | No other fault codes active
 | STEP 1B. Check circuit breaker for overcurrent. | Overcurrent not present
STEP 2. | Check the generator set circuit breaker. |
 | STEP 2A. Inspect the generator set circuit breaker connector pins. | No damaged pins
 | STEP 2B. Check the generator set circuit breaker for failures. | No visible failures
STEP 3. | Check the generator control harness. |
 | STEP 3A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1328 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check for other fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other fault codes active

Multiple fault codes

Go to 1B

Multiple fault tree

Guided Step 1B - Check circuit breaker for over current.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Check circuit breaker for over current.

  • Check to see that the circuit breaker was tripped due to over current condition.
OK NOT OK

Overcurrent not present

Look downstream for over current condition.

Go to 2A

Go to 4A

Guided Step 2 - Check the generator set circuit breaker.

Guided Step 2A - Inspect the generator set circuit breaker connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the generator set circuit breaker.

Action

Inspect the harness and the circuit breaker connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set circuit breaker connector. Refer to site documentation.

Go to 2B

Go to 4A

Guided Step 2B - Check the generator set circuit breaker for failures.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Manually check to see if the switch can close.

Manually check to see if the switch can close.
OK NOT OK

No visible failures

Replace circuit breaker. Refer to site documentation.

Go to 3A

Go to 4A

Guided Step 3 - Check the generator control harness.

Guided Step 3A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the generator set board terminal block.

Action

Inspect the generator control harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded posts
  • Bent or broken posts
  • Pushed back or expanded posts
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector posts
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the base board. Refer to Procedure 019-322 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the generator set circuit breaker.

Action

Check for a short circuit from wire to wire.

  • Measure the resistance from the generator set circuit breaker position wire on the generator control harness connector to all other wires on the generator control harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the generator set circuit breaker.

Action

Check for an open circuit in the supply wire.

  • Measure the resistance from the generator set circuit breaker supply pin on the generator control harness connector to the generator set circuit breaker supply pin on the generator control harness controller connector.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1328 is inactive.
OK NOT OK

Fault Code 1328 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the run/stop/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1329 - Voltage Regulator

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the generator control harness. |
 | STEP 1A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1D. Check for an open circuit. | Less than 10k ohms
STEP 2. | Check the voltage regulator. |
 | STEP 2A. Inspect the voltage regulator connector pins. | No damaged pins
 | STEP 2B. Check DC power supply voltage. | Voltage present
 | STEP 2C. Check the voltage regulator for failures. | LED is on
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1329 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the generator control harness.

Guided Step 1A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module connector pins.

Action

Inspect the generator control harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the base board. Refer to Procedure 019-322 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the voltage regulator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the voltage regulator DC power SUPPLY pin on the generator control harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the voltage regulator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the voltage regulator DC power SUPPLY pin on the generator control harness connector to all other pins on the generator control harness connector.
  • Measure the resistance from the voltage regulator RETURN pin on the generator control harness connector to all other pins on the generator control harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the voltage regulator.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from the voltage regulator DC power SUPPLY pin on the generator control harness connector to the voltage regulator SUPPLY pin on the generator control harness controller connector.
  • Measure the resistance from the voltage regulator RETURN pin (ground) to the correct ground pin on TB3.
OK NOT OK

Less than 10k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the voltage regulator.

Guided Step 2A - Inspect the voltage regulator connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the voltage regulator.

Action

Inspect the harness and the controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check DC power supply voltage.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.
  • Place the idle/rated switch in the IDLE.

Action

Use INSITE™ electronic service tool to go to Test, Manual Operation, and disable excitation.

  • Disconnect connector 07 and check for voltage on the DC power supply of the harness side.
OK NOT OK

Voltage present

Replace the base board. Refer to Procedure 019-322 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the voltage regulator for failures.

Conditions

  • Place the run/stop/auto switch in the RUN position.

Action

Check to make sure the isolated supply green LED is lit.

Check to make sure the isolated supply green LED is lit.
OK NOT OK

LED is on

Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1329 is inactive.
OK NOT OK

Fault Code 1329 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the run/stop/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1331 - Voltage Regulator Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a newengine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the voltage regulator. |
 | STEP 1A. Inspect the voltage regulator and the generator control harness connector pins. | No damaged pins
 | STEP 1B. Check the voltage regulator for failures. | No visible failures
STEP 2. | Check the generator control harness. |
 | STEP 2A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1331 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the voltage regulator.

Guided Step 1A - Inspect the voltage regulator and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the voltage regulator.

Action

Inspect the generator control harness and the voltage regulator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the voltage regulator for failures.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect the generator control harness and the voltage regulator connector pins for the following:

  • No burn marks
  • No bent or broken connectors.
OK NOT OK

No visible failures

Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module connector pins.

Action

Inspect the generator control harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the base board. Refer to Procedure 019-322 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the voltage regulator.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from the voltage regulator DC power SUPPLY pin on the generator control harness connector to the voltage regulator SUPPLY pin on the generator control harness controller connector.
  • Measure the resistance from the voltage regulator RETURN pin (ground) to the correct ground pin on TB3.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the voltage regulator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the voltage regulator DC power SUPPLY pin on the generator control harness connector to all other pins on the generator control harness connector.
  • Measure the resistance from the voltage regulator RETURN pin on the generator control harness connector to all other pins on the generator control harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1331 is inactive.
OK NOT OK

Fault Code 1331 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the run/stop/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1332 - Off/Manual/Auto Switch Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3828746 - PowerCommand™ Control tool kit.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the off/manual/auto switch. |
 | STEP 1A. Inspect the off/manual/auto switch and generator control harness connector pins. | No damaged pins
 | STEP 1B. Check the voltage of the off/manual/auto switch in the OFF position. | Manual signal: 4.25 to 4.70-VDC, Auto signal: 4.75 to 5.25-VDC
 | STEP 1C. Check the voltage of the off/manual/auto switch in the MANUAL position. | Manual signal: 0.3 to 1.0-VDC, Auto signal: 4.75 to 5.25-VDC
 | STEP 1D. Check the voltage of the off/manual/auto switch in the AUTO position. | Manual signal: 4.25 to 4.70-VDC, Auto signal: 0-VDC
STEP 2. | Check the generator control harness. |
 | STEP 2A. Inspect the generator control harness and the Inline D connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the engine control module response. |
 | STEP 4A. Check for the appropriate engine control module response. | Fault Code 1332 inactive, Fault Code 1333 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1332 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the off/manual/auto switch.

Guided Step 1A - Inspect the off/manual/auto switch and generator control harness connector pins.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the off/manual/auto switch.

Action

Inspect the off/manual/auto switch, switch panel, and generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Check the voltage of the off/manual/auto switch in the OFF position.

Conditions

  • Place the off/manual/auto switch in OFF position.
  • Place the run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.
  • Disconnect the generator control harness from switch panel.
  • Connect the PowerCommand™ Control tool kit to switch panel and the generator control harness.

Action

Check the voltage of the off/manual/auto switch in OFF position.

  • Use the multimeter to measure the operation mode switch manual signal voltage.
  • Use the multimeter to measure the operation mode switch auto signal voltage.
OK NOT OK

Manual signal: 4.25 to 4.70-VDC, Auto signal: 4.75 to 5.25-VDC

Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 1C

Go to 5A

Guided Step 1C - Check the voltage of the off/manual/auto switch in the MANUAL position.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.
  • Disconnect the generator control harness from switch panel.
  • Connect the PowerCommand™ Control tool kit to switch panel and the generator control harness.

Action

Check the voltage of the off/manual/auto switch in MANUAL position.

  • Measure the operation mode switch manual signal voltage using the multimeter.
  • Measure the operation mode switch auto signal voltage using the multimeter.
OK NOT OK

Manual signal: 0.3 to 1.0-VDC, Auto signal: 4.75 to 5.25-VDC

Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 1D

Go to 5A

Guided Step 1D - Check the voltage of the off/manual/auto switch in the AUTO position.

Conditions

  • Place the off/manual/auto switch in the AUTO position.
  • Place the run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.
  • Disconnect the generator control harness from switch panel.
  • Connect the PowerCommand™ Control tool kit to switch panel and the generator control harness.

Action

Check the voltage of the off/manual/auto switch in the AUTO position.

  • Measure the operation mode switch manual signal voltage using the multimeter.
  • Measure the operation mode switch auto signal voltage using the multimeter.
OK NOT OK

Manual signal: 4.25 to 4.70-VDC, Auto signal: 0-VDC

Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the Inline D connector pins.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the generator control harness from the extension harness.

Action

Inspect the generator control harness and Inline D connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from the operation mode switch manual SIGNAL pin on the switch panel connector to the operation mode switch manual SIGNAL pin on the Inline D connector.
  • Measure the resistance from the operation mode switch auto SIGNAL pin on the switch panel connector to the operation mode switch auto SIGNAL pin on the engine control module.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the generator control harness from Inline D.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the operation mode switch manual SIGNAL pin on the switch panel connector to all other pins in the switch panel connector.
  • Measure the resistance from the operation mode switch auto SIGNAL pin on the switch panel connector to all other pins in the switch panel connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the extension harness from engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the base board. Refer to Procedure 019-322 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the generator control harness.

Action

Check for an open circuit.

  • Measure the resistance from manual SIGNAL pin on the extension harness connector to the manual SIGNAL pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the generator control harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the manual SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module response.

Guided Step 4A - Check for the appropriate engine control module response.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for the engine control module appropriate response.

  • Use INSITE™ electronic service tool to check for the appropriate engine control module response.
OK NOT OK

Fault Code 1332 inactive, Fault Code 1333 active

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the RUN mode and idle for 1 minute.

Action

Disable the fault code.

  • Verify that Fault Code 1333 is inactive.
OK NOT OK

Fault Code 1332 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in the AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Apr-2012


FAULT CODE 1333 - Off/Manual/Auto Switch Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3828746 - PowerCommand™ Control tool kit

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the off/manual/auto switch. |
 | STEP 1A. Inspect the off/manual/auto switch panel and generator control harness connector pins. | No damaged pins
 | STEP 1B. Check the voltage of the off/manual/auto switch in the OFF position. | Manual signal: 4.25 to 4.70-VDC, Auto signal: 4.75 to 5.25-VDC
 | STEP 1C. Check the voltage of the off/manual/auto switch in the MANUAL position. | Manual signal: 0.3 to 1.0-VDC, Auto signal: 4.75 to 5.25-VDC
 | STEP 1D. Check the voltage of the off/manual/auto switch in the AUTO position. | Manual signal: 4.25 to 4.70-VDC, Auto signal: 0-VDC
STEP 2. | Check the generator control harness. |
 | STEP 2A. Inspect the generator control harness and the Inline D connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the engine control module response. |
 | STEP 4A. Check for the appropriate engine control module response. | Fault Code 1333 inactive, Fault Code 1332 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1333 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the off/manual/auto switch.

Guided Step 1A - Inspect the off/manual/auto switch and generator control harness connector pins.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the off/manual/auto switch.

Action

Inspect the off/manual/auto switch, switch panel, and generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Check the voltage of the off/manual/auto switch in the OFF position.

Conditions

  • Place the off/manual/auto switch in OFF position.
  • Place the run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.
  • Disconnect the generator control harness from switch panel.
  • Connect the PowerCommand™ Control tool kit to switch panel and the generator control harness.

Action

Check the voltage of the run/stop/auto switch in the OFF position.

  • Use the multimeter to measure the operation mode switch manual signal voltage.
  • Use the multimeter to measure the operation mode switch auto signal voltage.
OK NOT OK

Manual signal: 4.25 to 4.70-VDC, Auto signal: 4.75 to 5.25-VDC

Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 1C

Go to 5A

Guided Step 1C - Check the voltage of the off/manual/auto switch in the Manual position.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.
  • Disconnect the generator control harness from switch panel.
  • Connect the PowerCommand™ Control tool kit to switch panel and the generator control harness.

Action

Check the voltage of the off/manual/auto switch, in the MANUAL position.

  • Use the multimeter to measure the operation mode switch manual signal voltage.
  • Use the multimeter to measure the operation mode switch auto signal voltage.
OK NOT OK

Manual signal: 0.3 to 1.0-VDC, Auto signal: 4.75 to 5.25-VDC

Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 1D

Go to 5A

Guided Step 1D - Check the voltage of the off/manual/auto switch in the Auto position.

Conditions

  • Place the off/manual/auto switch in the AUTO position.
  • Place the run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.
  • Disconnect the generator control harness from switch panel.
  • Connect the PowerCommand™ Control tool kit to switch panel and the generator control harness.

Action

Check the voltage of the off/manual/auto switch switch, in the AUTO position.

  • Use the multimeter to measure the operation mode switch manual signal voltage.
  • Use the multimeter to measure the operation mode switch auto signal voltage.
OK NOT OK

Manual signal: 4.25 to 4.70-VDC, Auto signal: 0-VDC

Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the Inline D connector pins.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the generator control harness from the extension harness.

Action

Inspect the generator control harness and Inline D connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from the operation mode switch manual SIGNAL pin on the switch panel connector to the operation mode switch manual SIGNAL pin on the Inline D connector.
  • Measure the resistance from the operation mode switch auto SIGNAL pin on the switch panel connector to the operation mode switch auto SIGNAL pin on the engine control module.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the generator control harness from Inline D.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the operation mode switch manual SIGNAL pin on the switch panel connector to all other pins in the switch panel connector.
  • Measure the resistance from the operation mode switch auto SIGNAL pin on the switch panel connector to all other pins in the switch panel connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replaced the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the extension harness from engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the base board. Refer to Procedure 019-322 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the generator control harness.

Action

Check for an open circuit.

  • Measure the resistance from manual SIGNAL pin on the extension harness connector to the manual SIGNAL pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the generator control harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the manual SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module response.

Guided Step 4A - Check for the appropriate engine control module response.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for the engine control module appropriate response.

  • Use INSITE™ electronic service tool to check for the appropriate engine control module response.
OK NOT OK

Fault Code 1333 inactive, Fault Code 1332 active

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the RUN mode and idle for 1 minute.

Action

Disable the fault code.

  • Verify that Fault Code 1333 is inactive.
OK NOT OK

Fault Code 1333 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in the STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in the AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1334 - Critical Scalar Out-of-Range

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. View audit trail for engine control module and “unmake” the changes in reverse order. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - View record/audit trail for engine control module and “unmake” the changes in reverse order.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the STOP position.

Action

View/record audit trail for the engine control module.

  • In reverse order (last changes first) “unmake” the change.
  • After change is “unmade” check service tool to see if fault code cleared.
  • Repeat for all changes.
  • If fault code does not clear after all changes have been “unmade” calibrate engine control module with correct calibration data for the application/installation.
OK NOT OK

Go to

Go to

Last Modified: 30-Apr-2012


FAULT CODE 1335 - Critical Scalar Out-of-Range

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. View audit trail for engine control module and “unmake” the changes in reverse order. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - View record/audit trail for engine control module and “unmake” the changes in reverse order.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the STOP position.

Action

View/record audit trail for the engine control module.

  • In reverse order (last changes first) “unmake” the change.
  • After change is “unmade” check service tool to see if fault code cleared.
  • Repeat for all changes.
  • If fault code does not clear after all changes have been “unmade” calibrate engine control module with correct calibration data for the application/installation.
OK NOT OK

Go to

Go to

Last Modified: 30-Apr-2012


FAULT CODE 1336 - Generator Set Shutdown

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Fault code announces that generator set has shutdown to LonWorks network. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot the fault code.

Conditions

Engine shutdown.

Action

There is no corrective action for this fault code.

  • This fault code announces that the generator set has completed a normal shutdown to the LonWorks network.
OK NOT OK

Go to

Go to

Last Modified: 29-Apr-2012


FAULT CODE 1337 - LonWorks Wink Command Event

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot fault code. |
 | STEP 1A. Used to see what other controllers are on network. | No corrective action taken.

Guided Step 1 - Troubleshoot fault code.

Guided Step 1A - Used to see what other controllers are on network.

Conditions

Used when setting up LonWorks Network.

Action

There is no corrective action taken with LonWorks wink command event.

  • The LonWorks wink command event is a commanded event by another controller on the LonWorks network to see what other controllers are on the network.
  • This fault code and the LonWorks wink command are tools to be used while setting up a LonWorks network.
OK NOT OK

Go to

Go to

Last Modified: 29-Apr-2012


FAULT CODE 1341 - LonWorks Network Commanded Shutdown

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot fault code. |
 | STEP 1A. Load demand not sufficient to run generator. |

Guided Step 1 - Troubleshoot fault code.

Guided Step 1A - Load demand not sufficient to run generator.

Conditions

The paralleling controller has requested a generator shutdown.

Action

No corrective action take with this fault code.

  • Fault code announces to the LonWorks network that the paralleling controller has requested a generator set shutdown through the load demand shutdown circuit at TB3.
  • The paralleling controller sees that the load demand is not sufficient to run the generator set.
OK NOT OK

Go to

Go to

Last Modified: 29-Apr-2012


FAULT CODE 1342 - Fuel System Board - Incorrect Installation

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and connect the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel system board. |
 | STEP 1A. Inspect the fuel system board for correct installation. | Correct installation
 | STEP 1B. Inspect the fuel system board for visible failures. | No burn marks or bent pins
 | STEP 1C. Inspect the backplane board for visible failures. | No burn marks or bent pins
STEP 2. | Check the software calibration. |
 | STEP 2A. Verify that the correct software calibration has been loaded into the engine control module. | Correct calibration
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1342 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel system board.

Guided Step 1A - Inspect the fuel system board for correct installation.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the fuel system board for visible failures.

Conditions

  • Disconnect battery power.
  • Place the run/stop/auto switch in the STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible failures.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the fuel system board

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the backplane board for visible failures.

Conditions

  • Disconnect battery power.
  • Place the run/stop/auto switch in the STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect backplane board for visible failures.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the backplane board

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 2A

Go to 3A

Guided Step 2 - Check the software calibration.

Guided Step 2A - Verify that the correct software calibration has been loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct calibration software

Incorrect calibration software. Load correct calibration software.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position and idle for 1 minute.

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify Fault Code 1342 is inactive.
OK NOT OK

Fault Code 1342 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in the AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1343 - Base Board - Incorrect Installation

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the base board. |
 | STEP 1A. Inspect the base board for correct installation. | Correct Installation
 | STEP 1B. Inspect the base board for visible failures. | No burn marks, bent pins, or blown fuse
 | STEP 1C. Inspect the backplane board for visible failures. | No burn marks or bent pins
STEP 2. | Check the software calibration. |
 | STEP 2A. Verify that the correct software calibration has been loaded into the engine control module. | Correct calibration
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1343 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the base board.

Guided Step 1A - Inspect the base board for correct installation.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the base board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in the STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible failures.

  • Bent board pins
  • Inspect the 5-amp fuse on the base board
  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins.
OK NOT OK

No burn marks, bent pins, or blown fuse

Replace the base board

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the backplane board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in the STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect backplane board for visible failures.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the backplane board

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 2A

Go to 3A

Guided Step 2 - Check the software calibration.

Guided Step 2A - Verify that the correct software calibration has been loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct calibration software

Incorrect calibration software. Load correct calibration software.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify Fault Code 1343 is inactive.
OK NOT OK

Fault Code 1343 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in the AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1344 - Generator Interface Board - Incorrect Installation

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the generator interface board. |
 | STEP 1A. Inspect the generator interface board for correct installation. | Correct installation
 | STEP 1B. Inspect the generator interface board for visible failures. | No burn marks or bent pins
 | STEP 1C. Inspect the backplane board for visible failures. | No burn marks or bent pins
STEP 2. | Check the software calibration. |
 | STEP 2A. Verify that the correct software calibration has been loaded into the engine control module. | Correct calibration
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1344 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the generator interface board.

Guided Step 1A - Inspect the generator interface board for correct installation.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the generator interface board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible failures.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the generator interface board

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the backplane board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect backplane board for visible failures.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the backplane board

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 2A

Go to 3A

Guided Step 2 - Check the software calibration.

Guided Step 2A - Verify that the correct software calibration has been loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct calibration software

Incorrect calibration software. Load correct calibration software.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify Fault Code 1344 is inactive.
OK NOT OK

Fault Code 1344 inactive

Return to troubleshooting steps or contact your a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1345 - Paralleling Board - Incorrect Installation

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility or arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the paralleling board. |
 | STEP 1A. Inspect the paralleling board for correct installation. | Correct installation
 | STEP 1B. Inspect the paralleling board for visible failures. | No burn marks or bent pins
 | STEP 1C. Inspect the backplane board for visible failures. | No burn marks or bent pins
STEP 2. | Check the software calibration. |
 | STEP 2A. Verify that the correct software calibration has been loaded into the engine control module. | Correct software calibration
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1345 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the paralleling board.

Guided Step 1A - Inspect the paralleling board for correct installation.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the paralleling board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible failures.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the paralleling board

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the backplane board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect Backplane board for visible failures.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the backplane board

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 2A

Go to 3A

Guided Step 2 - Check the software calibration.

Guided Step 2A - Verify that the correct software calibration has been loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct software calibration

Incorrect calibration software. Load correct calibration software.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify Fault Code 1345 is inactive.
OK NOT OK

Fault Code 1345 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1346 - LonWorks Network Board - Incorrect Installation

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the LonWorks Network board. |
 | STEP 1A. Inspect the LonWorks Network board for correct installation. | Correct installation
 | STEP 1B. Inspect the LonWorks Network board for visible failures. | No burn marks or bent pins
 | STEP 1C. Inspect the backplane board for visible failures. | No burn marks or bent pins
STEP 2. | Check the software calibration. |
 | STEP 2A. Verify that the correct software calibration has been loaded into the engine control module. | Correct software calibration
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1346 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the LonWorks Network board.

Guided Step 1A - Inspect the LonWorks Network board for correct installation.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the LonWorks Network board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible failures.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the LonWorks Network board

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the backplane board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect backplane board for visible failures.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the backplane board

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 2A

Go to 3A

Guided Step 2 - Check the software calibration.

Guided Step 2A - Verify that the correct software calibration has been loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct software calibration

Incorrect calibration software. Load correct calibration software.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify Fault Code 1346 is inactive.
OK NOT OK

Fault Code 1346 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1347 - Slot 5 Board - Incorrect Installation

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the slot 5 board. |
 | STEP 1A. Inspect the slot 5 board for correct installation. | Correct installation
 | STEP 1B. Inspect the slot 5 board for visible failures. | No burn marks or bent pins
 | STEP 1C. Inspect the backplane board for visible failures. | No burn marks or bent pins
STEP 2. | Check the software calibration. |
 | STEP 2A. Verify that the correct software calibration has been loaded into the engine control module. | Correct software calibration
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1347 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the slot 5 board.

Guided Step 1A - Inspect the slot 5 board for correct installation.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the slot 5 board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible failures.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the slot 5 board

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the backplane board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect backplane board for visible failures.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the backplane board

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 2A

Go to 3A

Guided Step 2 - Check the software calibration.

Guided Step 2A - Verify that the correct software calibration has been loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct software calibration

Incorrect calibration software. Load correct calibration software.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify Fault Code 1347 is inactive.
OK NOT OK

Fault Code 1347 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes with the electronic service tool.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1348 - Slot 6 Board - Incorrect Installation

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the slot 6 board. |
 | STEP 1A. Inspect the slot 6 board for correct installation. | Correct installation
 | STEP 1B. Inspect the slot 6 board for visible failures. | No burn marks or bent pins
 | STEP 1C. Inspect the backplane board for visible failures. | No burn marks or bent pins
STEP 2. | Check the software calibration. |
 | STEP 2A. Verify that the correct software calibration has been loaded into the engine control module. | Correct calibration
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1348 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the slot 6 board.

Guided Step 1A - Inspect the slot 6 board for correct installation.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the slot 6 board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible failures.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the slot 6 board

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the backplane board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect backplane board for visible failures.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the backplane board

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 2A

Go to 3A

Guided Step 2 - Check the software calibration.

Guided Step 2A - Verify that the correct software calibration has been loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct calibration software

Incorrect calibration software. Load correct calibration software.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify Fault Code 1348 is inactive.
OK NOT OK

Fault Code 1348 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1349 - Slot 7 Board - Incorrect Installation

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the slot 7 board. |
 | STEP 1A. Inspect the slot 7 board for correct installation. | Correct installation
 | STEP 1B. Inspect the slot 7 board for visible failures. | No burn marks or bent pins
 | STEP 1C. Inspect the backplane board for visible failures. | No burn marks or bent pins
STEP 2. | Check the software calibration. |
 | STEP 2A. Verify that the correct software calibration has been loaded into the engine control module | Correct software calibration
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1349 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the slot 7 board.

Guided Step 1A - Inspect the slot 7 board for correct installation.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the slot 7 board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible failures.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the slot 7 board

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the backplane board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect backplane board for visible failures.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the backplane board

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 2A

Go to 3A

Guided Step 2 - Check the software calibration.

Guided Step 2A - Verify that the correct software calibration has been loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct software calibration

Incorrect calibration software. Load correct calibration software.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify Fault Code 1349 is inactive.
OK NOT OK

Fault Code 1349 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Run/Stop switch in Stop position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-Apr-2012


FAULT CODE 1351 - LonWorks Network Board - Missing

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the LonWorks Network board power supply. |
 | STEP 1A. Inspect LonWorks Network board independent power supply connector pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 5 ohms
STEP 2. | Check the LonWorks Network board. |
 | STEP 2A. Inspect the LonWorks Network board for correct installation. | Correct installation
 | STEP 2B. Inspect the LonWorks Network board for visible failures. | No burn marks or bent pins
 | STEP 2C. Inspect the backplane board for visible failures. | No burn marks or bent pins
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1351 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the LonWorks Network board power supply.

Guided Step 1A - Inspect the LonWorks Network board independent power supply connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the LonWorks Network board power supply connector from the LonWorks Network board.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and LonWorks connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the generator control harness or the LonWorks Network board, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Reference the installation documentation.
  • Replace the generator control harness. Reference the installation documentation.
  • Replace the LonWorks Network board. Reference the installation documentation.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the LonWorks board.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance of the LonWorks board B positive (+) pin on the generator control harness board connector to the B positive (+) pin on Inline K.
  • Measure the resistance of the LonWorks board ground pin on the generator control harness board connector to the ground pin on Inline K.
OK NOT OK

Less than 5 ohms

Repair or replace the generator control harness, from Inline K to LonWorks connector.

  • Repair the generator control harness. Reference the installation documentation.
  • Replace the generator control harness. Reference the installation documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the LonWorks Network board.

Guided Step 2A - Inspect the LonWorks Network board for correct installation.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the LonWorks Network board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible failures.

  • Burn marks or discoloration on the board.
  • Burn marks or discoloration on the board pins.
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the LonWorks Network board

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the backplane board for visible failures.

Conditions

  • Disconnect battery supply.
  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect backplane board for visible failures.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the backplane board

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify Fault Code 1351 is inactive.
OK NOT OK

Fault Code 1351 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Apr-2012


FAULT CODE 1411 - Frequency Adjust Potentiometer Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the frequency adjust potentiometer. |
 | STEP 1A. Inspect the frequency adjust potentiometer assembly for damage to pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 5k ohms
 | STEP 1C. Check the resistance range of the frequency adjust potentiometer. | Resistance varies
STEP 2. | Check the generator interface harness. |
 | STEP 2A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1411 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the frequency adjust potentiometer.

Guided Step 1A - Inspect the frequency adjust potentiometer assembly for damage to pins.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the frequency adjust potentiometer assembly for damage to pins:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damage.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the potentiometer. Refer to the OEM service manual.
  • Repair the generator interface harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the potentiometer from the harness.

Action

Check the potentiometer resistance.

  • Use a multimeter to measure the resistance between the potentiometer pins.
OK NOT OK

Less than 5k ohms

Replace the potentiometer. Refer to the OEM service manual.

1C

Go to 3A

Guided Step 1C - Check the resistance range of the frequency adjust potentiometer.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the potentiometer from the harness.
  • Adjust the potentiometer throughout its entire range.

Action

Check the potentiometer resistance.

  • Use a multimeter to measure the resistance between the potentiometer pins.
OK NOT OK

Resistance varies

Replace the potentiometer. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator interface harness.

Guided Step 2A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the frequency adjust potentiometer SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the droop/frequency RETURN pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the bulb from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the frequency adjust potentiometer SUPPLY pin at the generator interface harness connector to the frequency adjust potentiometer SUPPLY pin at the potentiometer connection.
  • Measure the resistance from the droop/frequency RETURN pin at the generator interface harness connector to the droop/frequency RETURN pin at the potentiometer connection.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1411 is inactive.
OK NOT OK

Fault Code 1411 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Apr-2012


FAULT CODE 1412 - Droop Adjust Potentiometer Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the droop adjust potentiometer. |
 | STEP 1A. Inspect the droop adjust potentiometer assembly for damage to pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 5k ohms
 | STEP 1C. Check the resistance range of the droop adjust potentiometer. | Resistance varies
STEP 2. | Check the generator interface harness. |
 | STEP 2A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1412 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the droop adjust potentiometer.

Guided Step 1A - Inspect the droop adjust potentiometer assembly for damage to pins.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the droop adjust potentiometer assembly for damage to pins:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damage.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the potentiometer. Refer to the OEM service manual.
  • Repair the generator interface harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Run/Stop switch in the Stop position.
  • Disconnect the potentiometer from the harness.

Action

Check the potentiometer resistance.

  • Use a multimeter to measure the resistance between the potentiometer pins.
OK NOT OK

Less than 5k ohms

Replace the potentiometer. Refer to the OEM service manual.

Go to 1C

Go to 3A

Guided Step 1C - Check the resistance range of the droop adjust potentiometer.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Adjust the potentiometer throughout its entire range.
  • Disconnect the potentiometer from the harness.

Action

Check the potentiometer resistance.

  • Use a multimeter to measure the resistance between the potentiometer pins.
OK NOT OK

Resistance varies

Replace the potentiometer. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator interface harness.

Guided Step 2A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the droop adjust potentiometer SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the droop/frequency RETURN pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

2C

3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Check for an open circuit.

  • Measure the resistance from the droop adjust potentiometer SUPPLY pin at the generator interface harness connector to the droop adjust potentiometer pin at the potentiometer connection.
  • Measure the resistance from the droop adjust potentiometer RETURN pin at the generator interface harness connector to the droop adjust potentiometer pin at the potentiometer connection.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

3A

3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1412 is inactive.
OK NOT OK

Fault Code 1412 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

3B

1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Apr-2012


FAULT CODE 1413 - Configuration Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and engine control module damage, troubleshoot all other active fault codes before replacing the engine control module.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module. |
 | STEP 1A. Verify that the fault code is active and the correct calibration is loaded into the engine control module. | Active fault code and correct calibration
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1413 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine control module.

Guided Step 1A - Verify that the fault code is active and the correct calibration is loaded into the engine control module.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in STOP position.

Action

Verify fault code and correct calibration.

  • Use INSITE™ electronic service tool to verify that Fault Code 1413 is active.
  • Use INSITE™ electronic service tool to verify that the correct calibration is loaded into the engine control module.
OK NOT OK

Active fault code and correct calibration

Load correct calibration into the engine control module. Refer to Procedure 019-032 in Section 19 .

2A

2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the Fault Code 1413 is inactive.
OK NOT OK

Fault Code 1413 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been competed and checked again.

2B

1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Apr-2012


FAULT CODE 1414 - Run Relay Contact Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking measurements: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check for Fault Code 1415. | Fault Code 1415 inactive
STEP 2. | Check the run relay contact |
 | STEP 2A. Inspect the run relay and the engine harness connections. | No damaged connections
 | STEP 2B. Check the run relay contact for correct operation in the open position. | More than 100k ohms
 | STEP 2C. Check the run relay contact for correct operation in the closed position. | 24-VDC
STEP 3. | Check the extension harness |
 | STEP 3A. Inspect the extension harness and engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 5 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1414 Inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check for Fault Code 1415.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any of the circuits sharing a common electrical supply with the run relay contact.
OK NOT OK

Fault Code 1415 inactive

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check the run relay contact.

Guided Step 2A - Inspect the run relay and the engine harness connections.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the run relay contact.

Action

Inspect the engine harness and run relay contact pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged connections

Repair or replace the engine harness or run relay connect, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the run relay contact. Reference the site installation documentation.

Go to 2B

Go to 4A

Guided Step 2B - Check the run relay for correct operation in the open position.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in STOP mode.

Action

Check run relay contact for correct operation.

  • Measure resistance across contact.
OK NOT OK

More than 100k ohms

Run relay contact malfunctioned.

Reference site installation documentation.

Go to 2C

Go to 4A

Guided Step 2C - Check the run relay for correct operation in the closed position.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in RUN mode.

Action

Check run relay contact for correct operation.

  • Use a multimeter to measure the voltage at the run status contact of the relay ground.
OK NOT OK

24-VDC

Run relay contact malfunctioned.

Reference site installation documentation.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and engine control module connector pins.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the extension harness from the run relay contact.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the extension harness or the base board, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the base board. Refer to Procedure 019-322 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the extension harness from the run relay contact.
  • Disconnect the extension harness from the engine control module.

Action

Check for short circuit to engine block ground.

  • Measure the resistance from the run status pin to the extension harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the extension harness from the run relay contact.
  • Disconnect the extension harness from the engine control module.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the run status pin on the extension harness connector to run status pin on the extension harness inline connector.
OK NOT OK

More than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the extension harness from the run relay contact.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the run status pin on the extension harness inline connector to all other pins on the extension harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in RUN mode and idle for 1 minute.

Action

Disable the fault code.

  • Use the electronic service tool to verify that Fault Code 1414 is inactive.
OK NOT OK

Fault Code 1414 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in RUN mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared.

Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1415 - Run Relay Driver Diagnostic

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Troubleshoot all other fault codes first. | Replace base board if Fault Code 1415 is active.

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot all other fault codes first.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in STOP position.

Action

Troubleshoot all other fault codes first.

  • If Fault Code 1415 is not inactive the engine control module has determined the run relay driver on the base board card has failed.
OK NOT OK

Fault Code 1415 is inactive

Replace the base board.

Go to

Go to

Last Modified: 30-Apr-2012


FAULT CODE 1416 - Failed to Shut Down

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

  • Shut down the engine.
  • Use INSITE™ electronic service tool to disengage the user-engaged shutdown override feature.

Action

Use INSITE™ electronic service tool to read any fault codes and then refer to those fault codes for the troubleshooting steps to repair any damage done to the engine. Use INSITE™ electronic service tool to clear the fault code after correcting any damage.

NOTE: The product warranty does not cover damage to the GCS or the engine resulting from the use of the Shutdown Override feature.

OK NOT OK

Go to

Go to

Last Modified: 30-Apr-2012


FAULT CODE 1417 - Controller Power Down Fault

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and engine control module damage, troubleshoot all other active fault codes before replacing the engine control module boards.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module. |
 | STEP 1A. Verify that the fault code is active and the correct calibration is loaded into the engine control module. | Active fault code and correct calibration
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1417 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine control module.

Guided Step 1A - Verify that the fault code is active and the correct calibration is loaded into the engine control module.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in STOP position.

Action

Verify fault code and correct calibration.

  • Use INSITE™ electronic service tool to verify that Fault Code 1417 is active.
  • Use INSITE™ electronic service tool to verify that the correct calibration is loaded into the engine control module.
OK NOT OK

Active fault code and correct calibration

Load correct calibration into the engine control module. Refer to Procedure 019-032 in Section 19.

2A

2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1417 is inactive.
OK NOT OK

Fault Code 1417 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

2B

1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1418 - Gain Adjust Potentiometer Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number - 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number - 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the gain adjust potentiometer. |
 | STEP 1A. Inspect the droop adjust potentiometer assemblage for damage to pins. | No damaged pins
 | STEP 1B. Check for an open circuit. | Less than 5k ohms
 | STEP 1C. Check the resistance range of the gain adjust potentiometer. | Resistance varies
STEP 2. | Check the Inline D connector. |
 | STEP 2A. Inspect the Inline D connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1418 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the gain adjust potentiometer.

Guided Step 1A - Inspect the droop adjust potentiometer assemblage for damage to pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the OEM harness connector from the governor gain adjust potentiometer.

Action

Inspect the harness and the potentiometer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the potentiometer. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the OEM harness from the gain potentiometer.

Action

Check for an open circuit.

  • Measure the resistance of the governor gain potentiometer.
OK NOT OK

Less than 5k ohms

Replace the potentiometer. Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the resistance range of the gain adjust potentiometer.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Adjust the potentiometer through its entire range.

Action

Check the resistance range.

  • Monitor the resistance of the governor gain potentiometer through the full range.
OK NOT OK

Resistance varies

Replace the potentiometer. Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the Inline D connector.

Guided Step 2A - Inspect the Inline D connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the Inline D connector.

Action

Inspect the Inline D connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the Inline D connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair connector. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the Inline D connector.
  • Disconnect the extension harness connector from the governor gain adjust potentiometer.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the governor gain adjust potentiometer SIGNAL pin at Inline D to all the other pins in the connector.
  • Measure the resistance from the governor gain adjust potentiometer RETURN pin at Inline D to all the other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the Inline D connector.
  • Disconnect the extension harness connector from the governor gain adjust potentiometer.

Action

Check for an open circuit.

  • Measure the resistance from the governor gain adjust potentiometer SIGNAL pin at Inline D to the signal side of the potentiometer.
  • Measure the resistance from the governor gain adjust potentiometer RETURN pin at Inline D to the return side of the potentiometer.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for short circuit from pin to pin.

  • Measure the resistance from the governor gain adjust SIGNAL pin at the extension harness connector to all other pins in the connector.
  • Measure the resistance from the governor gain adjust RETURN pin at the extension harness connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the engine harness from the extension harness.

Action

Check for an open circuit.

  • Measure the resistance from the governor gain adjust SIGNAL pin at the extension harness connector to the SIGNAL pin at the extension harness inline connector.
  • Measure the resistance from the governor gain adjust RETURN pin at the extension harness connector to the RETURN pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Idle/Rated switch in the Idle position.
  • Run/Stop switch in the Run position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1418 is inactive.
OK NOT OK

Fault Code 1418 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all of the components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Apr-2012


FAULT CODE 1419 - Fuel Rail Driver Diagnostic

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rail actuator. |
 | STEP 1A. Inspect the actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1419 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel rail actuator.

Guided Step 1A - Inspect the actuator and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness connector from the fuel rail actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the fuel rail actuator.

Action

Check the coil resistance of the actuator.

  • Measure the resistance from the SUPPLY pin to the RETURN pin.
OK NOT OK

0.5 to 1.5 ohms

Replace the fuel rail actuator. Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail actuator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the fuel rail actuator RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rail actuator RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel rail actuator.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the engine harness inline connector to the fuel rail actuator SUPPLY pin on the engine harness actuator connector.
  • Measure the resistance from the fuel rail actuator RETURN pin on the engine harness inline connector to the fuel rail actuator RETURN pin on the engine harness actuator connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel rail actuator RETURN pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rail actuator RETURN pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail actuator SUPPLY pin on the extension harness connector to the fuel rail actuator SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel rail actuator RETURN pin on the extension harness connector to the fuel rail actuator RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1419 is inactive.
OK NOT OK

Fault Code 1419 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1421 - Timing Rail Number 1 Driver Diagnostic

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing rail Number 1 actuator. |
 | STEP 1A. Inspect the actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 2.0 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1421 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the timing rail Number 1 actuator.

Guided Step 1A - Inspect the actuator and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness connector from the timing rail Number 1 actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the timing rail Number 1 actuator. Refer to Procedure 019-111 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the timing rail Number 1 actuator.

Action

Check the coil resistance of the actuator.

  • Measure the resistance from the timing rail actuator Number 1 SUPPLY pin to the timing rail actuator Number 1 RETURN pin.
OK NOT OK

0.5 to 2.0 ohms

Replace the timing rail Number 1 actuator. Refer to Procedure 019-111 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail Number 1 actuator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the timing rail Number 1 actuator SUPPLY pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the timing rail Number 1 actuator RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail Number 1 actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the timing rail Number 1 actuator SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail Number 1 actuator RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail Number 1 actuator.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail Number 1 actuator SUPPLY pin on the engine harness inline connector to the timing rail Number 1 actuator SUPPLY pin on the engine harness actuator connector.
  • Measure the resistance from the timing rail Number 1 actuator RETURN pin on the engine harness inline connector to the timing rail Number 1 actuator RETURN pin on the engine harness actuator connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the timing rail Number 1 actuator SUPPLY pin on the extension harness connector to engine block ground.
  • Measure the resistance from the timing rail Number 1 actuator RETURN pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the timing rail Number 1 actuator SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail Number 1 actuator RETURN pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail Number 1 actuator SUPPLY pin on the extension harness connector to the timing rail Number 1 actuator SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the timing rail Number 1 actuator RETURN pin on the extension harness connector to the timing rail Number 1 actuator RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Idle/Rated switch in the Idle position.
  • Run/Stop switch in the Run position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1421 is inactive.
OK NOT OK

Fault Code 1421 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1422 - Timing Rail Number 2 Driver Diagnostic

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing rail Number 2 actuator. |
 | STEP 1A. Inspect the actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 2.0 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1422 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the timing rail Number 2 actuator.

Guided Step 1A - Inspect the actuator and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness connector from the timing rail Number 2 actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the timing rail Number 2 actuator. Refer to Procedure 019-111 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the timing rail Number 2 actuator.

Action

Check the coil resistance of the actuator.

  • Measure the resistance from the timing rail actuator Number 2 SUPPLY pin to the timing rail actuator Number 2 RETURN pin.
OK NOT OK

0.5 to 2.0 ohms

Replace the timing rail Number 2 actuator. Refer to Procedure 019-111 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail Number 2 actuator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the timing rail Number 2 actuator SUPPLY pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the timing rail Number 2 actuator RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail Number 2 actuator.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail Number 2 actuator SUPPLY pin on the engine harness inline connector to the timing rail Number 2 actuator SUPPLY pin on the engine harness actuator connector.
  • Measure the resistance from the timing rail Number 2 actuator RETURN pin on the engine harness inline connector to the timing rail Number 2 actuator RETURN pin on the engine harness actuator connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail Number 2 actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the timing rail Number 2 actuator SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the timing rail Number 2 actuator RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the timing rail Number 2 actuator SUPPLY pin on the extension harness connector to engine block ground.
  • Measure the resistance from the timing rail Number 2 actuator RETURN pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail Number 2 actuator SUPPLY pin on the extension harness connector to the timing rail Number 2 actuator SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the timing rail Number 2 actuator RETURN pin on the extension harness connector to the timing rail Number 2 actuator RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the timing rail Number 2 actuator SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the timing rail Number 2 actuator RETURN pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1422 is inactive.
OK NOT OK

Fault Code 1422 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1423 - Fuel Pump Driver Diagnostic

Associated Procedures

Cautions and Warnings

WARNING

The actuators receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the actuators or the actuator wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead, Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pump actuator. |
 | STEP 1A. Inspect the actuator and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the actuator. | 0.5 to 1.5 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1423 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel pump actuator.

Guided Step 1A - Inspect the actuator and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness connector from the fuel pump actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seal
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the actuator.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check the coil resistance of the actuator.

  • Measure the resistance from the fuel pump actuator SUPPLY pin to the fuel pump actuator RETURN pin.
OK NOT OK

0.5 to 1.5 ohms

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel pump actuator SUPPLY pin on the engine harness inline connector to engine block ground.
  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness inline connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pump actuator SUPPLY pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump actuator SUPPLY pin on the engine harness inline connector to the fuel pump actuator SUPPLY pin on the engine harness actuator connector.
  • Measure the resistance from the fuel pump actuator RETURN pin on the engine harness inline connector to the fuel pump actuator RETURN pin on the engine harness actuator connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel pump actuator SUPPLY pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pump actuator SUPPLY pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel pump actuator SUPPLY pin on the extension harness connector to the fuel pump actuator SUPPLY pin on the extension harness inline connector.
  • Measure the resistance from the fuel pump actuator RETURN pin on the extension harness connector to the fuel pump actuator RETURN pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1423 is inactive.
OK NOT OK

Fault Code 1423 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1424 - Relay High Side Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 1425, 1426, 1427, 1428, 1429, 1431, and 1432 are active
STEP 2. | Check the generator interface harness. |
 | STEP 2A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1424 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 1425, 1426, 1427, 1428, 1429, 1431, and 1432 are active

Troubleshoot active fault codes.

2A

Go to active fault code(s)

Guided Step 2 - Check the generator interface harness.

Guided Step 2A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

2B

3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the relay driver SUPPLY pin on the generator interface harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

2C

3A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

2D

3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the bulb from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the relay driver supply connections for each lamp.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

3A

3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1424 is inactive.
OK NOT OK

Fault Code 1424 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

3B

1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1425 - Common Shutdown Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the common shutdown relay. |
 | STEP 1A. Check for correct operation of the common shutdown relay. | Relay functions normally
STEP 2. | Check for multiple fault codes. |
 | STEP 2A. Read the fault codes. | Fault Codes 1426, 1427, 1428, 1429, 1431, and 1432 are not active
STEP 3. | Check the generator interface harness. |
 | STEP 3A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1425 inactive
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared

Guided Step 1 - Check the common shutdown relay.

Guided Step 1A - Check for correct operation of the common shutdown relay.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for correct operation of the common shutdown relay.

  • Use the electronic service tool fault simulation feature to command a common shutdown.
OK NOT OK

Relay functions normally

Replace relay. Reference the site documentation.

2A

4A

Guided Step 2 - Check for multiple fault codes.

Guided Step 2A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 1426, 1427, 1428, 1429, 1431, and 1432 are not active

If all the fault codes are active, go to Fault Code 1424

3A

4A

Guided Step 3 - Check the generator interface harness.

Guided Step 3A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

3B

4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the engine block ground.
  • Measure the resistance from the common shutdown pin at the generator interface harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

3C

4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the relay driver SUPPLY pin at the relay connector.
  • Measure the resistance from the common shutdown pin at the generator interface harness connector to the common shutdown pin at the relay connector.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

3D

4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the common shutdown pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

4A

4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1425 is inactive.
OK NOT OK

Fault Code 1425 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

4B

1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1426 - Common Warning Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the common warning relay. |
 | STEP 1A. Check for correct operation of the common warning relay. | Relay functions normally
STEP 2. | Check for multiple fault codes. |
 | STEP 2A. Read the fault codes. | Fault Codes 1425, 1427, 1428, 1429, 1431, and 1432 are not active
STEP 3. | Check the generator interface harness. |
 | STEP 3A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1426 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the common warning relay.

Guided Step 1A - Check for correct operation of the common warning relay.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for correct operation of the common warning relay.

  • Use the electronic service tool fault simulation feature to command a common warning.
OK NOT OK

Relay functions normally

Replace relay. Reference the site documentation.

Go to 2A

Go to 4A

Guided Step 2 - Check for multiple fault codes.

Guided Step 2A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 1425, 1427, 1428, 1429, 1431, and 1432 are not active

If all the fault codes are active, go to Fault Code 1424

Go to 3A

Fault Code 1424

Guided Step 3 - Check the generator interface harness.

Guided Step 3A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the engine block ground.
  • Measure the resistance from the common warning pin at the generator interface harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the relay driver supply connector at the relay connection.
  • Measure the resistance from the common warning pin at the generator interface harness connector to the common warning pin at the relay connection.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the common warning pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1426 is inactive.
OK NOT OK

Fault Code 1426 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1427 - Overspeed Shutdown Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the overspeed shutdown relay. |
 | STEP 1A. Check for correct operation of the overspeed shutdown relay. | Relay functions normally
STEP 2. | Check for multiple fault codes. |
 | STEP 2A. Read the fault codes. | Fault Codes 1425, 1426, 1428, 1429, 1431, and 1432 are not active
STEP 3. | Check the generator interface harness. |
 | STEP 3A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit in the generator interface harness. | Less than 10 ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1427 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the overspeed shutdown relay.

Guided Step 1A - Check for correct operation of the overspeed shutdown relay.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for correct operation of the overspeed shutdown relay.

  • Use the electronic service tool fault simulation feature to command an overspeed shutdown.
OK NOT OK

Relay functions normally

Replace relay. Reference the site documentation.

Go to 2A

Go to 4A

Guided Step 2 - Check for multiple fault codes.

Guided Step 2A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 1425, 1426, 1428, 1429, 1431, and 1432 are not active

If all the fault codes are active, go to Fault Code 1424

Go to 3A

Fault Code 1424

Guided Step 3 - Check the generator interface harness.

Guided Step 3A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit to ground from the return and supply wires.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the engine block ground.
  • Measure the resistance from the overspeed shutdown pin at the generator interface harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the overspeed shutdown pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the generator interface harness.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for an open circuit in the supply an return wires.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the relay driver SUPPLY pin at the relay connection.
  • Measure the resistance from the overspeed shutdown pin at the generator interface harness connector to the overspeed shutdown pin at the relay connection.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Verify that Fault Code 1427 is inactive.
OK NOT OK

Fault Code 1427 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1428 - Low Oil Pressure Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the low oil pressure relay. |
 | STEP 1A. Check for correct operation of the low oil pressure relay. | Relay functions normally
STEP 2. | Check for multiple fault codes. |
 | STEP 2A. Read the fault codes. | Fault Codes 1425, 1426, 1427, 1429, 1431, and 1432 are not active
STEP 3. | Check the generator interface harness. |
 | STEP 3A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1428 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the low oil pressure relay.

Guided Step 1A - Check for correct operation of the low oil pressure relay.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

temp

  • Use the electronic service tool fault simulation feature to command a low oil pressure.
OK NOT OK

Relay functions normally

Replace relay. Reference the site documentation.

2A

4A

Guided Step 2 - Check for multiple fault codes.

Guided Step 2A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 1425, 1426, 1427, 1429, 1431, and 1432 are not active

If all fault codes are active, go to Fault Code 1422

3A

Fault Code 1422

Guided Step 3 - Check the generator interface harness.

Guided Step 3A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

3B

4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the engine block ground.
  • Measure the resistance from the low oil pressure pin at the generator interface harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

3C

4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for an open circuit in the supply an return wires.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the relay driver SUPPLY pin at the relay connection.
  • Measure the resistance from the low oil pressure pin at the generator interface harness connector to the low oil pressure pin at the relay connection.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

3D

4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the low oil pressure pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

4A

4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1428 is inactive.
OK NOT OK

Fault Code 1428 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

4B

1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1429 - High Engine Temperature Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the high engine temperature relay. |
 | STEP 1A. Check for correct operation of the high engine temperature relay. | Relay functions normally
STEP 2. | Check for multiple fault codes. |
 | STEP 2A. Read the fault codes. | Fault Codes 1425, 1426, 1427, 1428, 1431, and 1432 are not active
STEP 3. | Check the generator interface harness. |
 | STEP 3A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1429 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the high engine temperature relay.

Guided Step 1A - Check for correct operation of the high engine temperature relay.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for correct operation of the high engine temperature relay.

  • Use the electronic service tool fault simulation feature to command a high engine temperature.
OK NOT OK

Relay functions normally

Replace relay. Reference the site documentation.

Go to 2A

Go to 4A

Guided Step 2 - Check for multiple fault codes.

Guided Step 2A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 1425, 1426, 1427, 1428, 1431, and 1432 are not active

If all the fault codes are active, go to Fault Code 1424

Go to 3A

Fault Code 1424

Guided Step 3 - Check the generator interface harness.

Guided Step 3A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the engine block ground.
  • Measure the resistance from the high engine temperature pin at the generator interface harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the relay driver SUPPLY pin at the relay connection.
  • Measure the resistance from the high engine temperature RETURN pin at the generator interface harness connector to the high engine temperature pin at the relay connection.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the high engine temperature pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1429 is inactive.
OK NOT OK

Fault Code 1429 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1431 - Pre-low Oil Pressure Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the pre-low oil pressure relay. |
 | STEP 1A. Check for correct operation of the pre-low oil pressure relay. | Relay functions normally
STEP 2. | Check for multiple fault codes. |
 | STEP 2A. Read the fault codes. | Fault Codes 1425, 1426, 1427, 1428, 1429, and 1432 are not active
STEP 3. | Check the generator interface harness. |
 | STEP 3A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1431 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the pre-low oil pressure relay.

Guided Step 1A - Check for correct operation of the pre-low oil pressure relay.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for correct operation of the pre-low oil pressure relay.

  • Use the electronic service tool fault simulation feature to a command a pre-low oil pressure.
OK NOT OK

Relay functions normally

Replace relay. Reference the site documentation.

Go to 2A

Go to 4A

Guided Step 2 - Check for multiple fault codes.

Guided Step 2A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 1425, 1426, 1427, 1428, 1429, and 1432 are not active

If all the fault codes are active, go to Fault Code 1424

Go to 3A

Fault Code 1424

Guided Step 3 - Check the generator interface harness.

Guided Step 3A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the engine block ground.
  • Measure the resistance from the pre-low oil pressure pin at the generator interface harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the relay driver SUPPLY pin at the relay connection.
  • Measure the resistance from the pre-low oil pressure pin at the generator interface harness connector to the pre-low oil pressure pin at the relay connection.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the pre-low oil pressure pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1431 is inactive.
OK NOT OK

Fault Code 1431 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1432 - Pre-High Engine Temperature Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the pre-high engine temperature relay. |
 | STEP 1A. Check for correct operation of the pre-high engine temperature relay. | Relay functions normally
STEP 2. | Check for multiple fault codes. |
 | STEP 2A. Read the fault codes. | Fault Codes 1425, 1426, 1427, 1428, 1429, and 1431 are not active
STEP 3. | Check the generator interface harness. |
 | STEP 3A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1432 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the pre-high engine temperature relay.

Guided Step 1A - Check for correct operation of the pre-high engine temperature relay.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for correct operation of the pre-high engine temperature relay.

  • Use the electronic service tool fault simulation feature to command a pre-high engine temperature.
OK NOT OK

Relay functions normally

Replace relay. Reference the site documentation.

Go to 2A

Go to 4A

Guided Step 2 - Check for multiple fault codes.

Guided Step 2A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 1425,1426, 1427, 1428, 1429, and 1431 are not active

If all fault codes are active, go to Fault Code 1424

Go to 3A

Fault Code 1424

Guided Step 3 - Check the generator interface harness.

Guided Step 3A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the engine block ground.
  • Measure the resistance from the pre-high engine temperature pin at the generator interface harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the relay driver SUPPLY pin at the relay connection.
  • Measure the resistance from the pre-high engine temperature pin at the generator interface harness connector to the pre-high engine temperature pin at the relay connection.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the pre-high engine temperature pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1432 is inactive.
OK NOT OK

Fault Code 1432 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1433 - Operator Interface Mode Transition to Emergency Stop (Due to E-Stop)

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

  • Interview the operator to determine the reason for the emergency stop button being pressed.

Action

Take any actions based on the operator's comments and then reset the emergency stop button. Use INSITE™ electronic service tool to clear the fault code after resetting the emergency stop.

NOTE: To reset the emergency stop button, turn the run/stop/auto switch to STOP and then hit the alarm reset.
OK NOT OK

Go to

Go to

Last Modified: 01-May-2012


FAULT CODE 1434 - Operator Interface Mode Transition to Emergency Stop (Due to Remote E-Stop)

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

  • Interview the operator to determine the reason for the remote emergency stop button being pressed.

Action

Take any actions based on the operator's comments and then reset the remote emergency stop button. Use INSITE™ electronic service tool to clear the fault code after resetting the remote emergency stop.

NOTE: Check 5A remote emergency inline fuse.
OK NOT OK

Go to

Go to

Last Modified: 01-May-2012


FAULT CODE 1435 - Engine Cold - Potential Starting Problem

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Action

Allow the engine to warm up.

Use a starting aid when attempting to start the engine.
OK NOT OK

Last Modified: 01-May-2012


FAULT CODE 1436 - HPI-PT Fuel System Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and engine control module damage, troubleshoot all other active fault codes before replacing engine control module boards.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the multiple fault codes. |
 | STEP 1A. Read the fault code. | Fault Code 1419 active
 | STEP 1B. Read the fault code. | Fault Code 1421 active
 | STEP 1C. Read the fault code. | Fault Code 1422 active
 | STEP 1D. Read the fault code. | Fault Code 1423 active
STEP 2. | Check the fuel system actuators. |
 | STEP 2A. Check the fuel rail actuator. | Go to Fault Code 1419
 | STEP 2B. Check the timing rail number 1 actuator. | Go to Fault Code 1421
 | STEP 2C. Check the timing rail number 2 actuator. | Go to Fault Code 1422
 | STEP 2D. Check the fuel pump actuator. | Go to Fault Code 1423
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1436 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the multiple fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Verify fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1419 is active.
OK NOT OK

Fault Code 1419 active

Fault Code 1419 inactive

Fault Code 1419

Go to 1B

Guided Step 1B - Read the fault code.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Verify fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1421 is active.
OK NOT OK

Fault Code 1421 active

Fault Code 1421 inactive

Fault Code 1421

Go to 1C

Guided Step 1C - Read the fault code.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Verify fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1422 is active.
OK NOT OK

Fault Code 1422 active

Fault Code 1422 inactive

Fault Code 1422

Go to 1D

Guided Step 1D - Read the fault code.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Verify fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1423 is active.
OK NOT OK

Fault Code 1423 active

Fault Code 1423 inactive

Fault Code 1423

Go to 2A

Guided Step 2 - Check the fuel system actuators.

Guided Step 2A - Check the fuel rail actuator.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Troubleshoot Fault Code 1419.

Troubleshoot Fault Code 1419.
OK NOT OK

No problem found

Problem corrected with fuel rail driver

Go to 2B

Go to 3A

Guided Step 2B - Check the timing rail number 1 actuator.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Troubleshoot Fault Code 1421.

Troubleshoot Fault Code 1421.
OK NOT OK

No problem found

Problem corrected with timing rail number 1 driver

Go to 2C

Go to 3A

Guided Step 2C - Check the timing rail number 2 actuator.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Troubleshoot Fault Code 1422.

Troubleshoot Fault Code 1422.
OK NOT OK

No problem found

Problem corrected with timing rail number 2 driver

Go to 2D

Go to 3A

Guided Step 2D - Check the fuel pump actuator.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Troubleshoot Fault Code 1423.

Troubleshoot Fault Code 1423.
OK NOT OK

No problem found

Problem corrected with fuel pump driver

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1436 is inactive.
OK NOT OK

Fault Code 1436 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1438 - Failed to Crank

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Action

Use INSITE™ electronic service tool to read any fault codes and then refer to those fault codes for troubleshooting.

Follow the troubleshooting symptom trees for:

  • Engine Difficult to Start or Will not Start - No Smoke
  • Engine Difficult to Start or Will not Start
OK NOT OK

Use INSITE™ electronic service tool to clear the fault codes and the Engine Difficult to Start or Will not Start symptom trees.

Repair complete

Last Modified: 01-May-2012


FAULT CODE 1439 - Fuel Level Low in Day Tank

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the day tank fuel level sensor accuracy. |
 | STEP 1A. Verify the day tank fuel level sensor. | Sensor reading correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the day tank fuel level sensor is not enabled. | Fault simulation is disabled
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1439 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the day tank fuel level sensor accuracy.

Guided Step 1A - Verify the day tank fuel level sensor.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify the day tank fuel level sensor.

  • Inspect the fuel level in the tank and compare with the fuel level sensor on the service tool monitor screen.
OK NOT OK

Sensor reading correct

Replace the day tank fuel level sensor. Reference the site installation documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the day tank fuel level sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the day tank fuel level sensor.
OK NOT OK

Fault simulation is disabled

Disable fault simulation

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1439 is inactive.
OK NOT OK

Fault Code 1439 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1441 - Fuel Level Low in Main Tank

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the main tank fuel level sensor accuracy. |
 | STEP 1A. Verify the main tank fuel level sensor. | Sensor reading correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the main tank fuel level sensor is not enabled. | Fault simulation disabled
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1441 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the main tank fuel level sensor accuracy.

Guided Step 1A - Verify the main tank fuel level sensor.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify the main tank fuel level sensor.

  • Inspect the fuel level in the tank and compare with the fuel level sensor on the service tool monitor screen.
OK NOT OK

Sensor reading correct

Replace the main tank fuel level sensor. Reference the site installation documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the main tank fuel level sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Use INSITE™ electronic service tool to verify that the fault simulation is not enabled for the main tank fuel level sensor.
OK NOT OK

Fault simulation disabled

Disable fault simulation

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1441 is inactive.
OK NOT OK

Fault Code 1441 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1442 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male test lead, Part Number 3824812 - female test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC, (24-VDC system)
 | STEP 1C. Check the battery ground connection. | Less than 10 ohms
 | STEP 1D. Check for an add-on or accessory wiring at the positive (+) terminal of the battery. | No damaged wires
STEP 2. | Check Inline E (battery harness). |
 | STEP 2A. Inspect the battery harness and the Inline E connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness fuse connections. | Fuse installed correctly
 | STEP 3B. Check the engine harness fuse. | Fuse not blown
 | STEP 3C. Inspect the engine harness and the extension harness inline connector pins. | No damaged pins
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1442 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connection.
OK NOT OK

No damaged connections

Repair the damaged connections. Tighten the battery connections and clean the battery terminals.

Go to 1B

Go to 5A

Guided Step 1B - Check the battery voltage.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
OK NOT OK

17.3 to 34.7-VDC, (24-VDC system)

Charge or replace the battery. Reference the site installation manual.

Go to 1C

Go to 5A

Guided Step 1C - Check the battery ground connection.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) battery terminal to the engine block ground.
OK NOT OK

Less than 10 ohms

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 1D

Go to 5A

Guided Step 1D - Check for an add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or installation error that can cause supply wire to be shorted to the engine block.
OK NOT OK

No damaged wires

Repair the damaged wiring.

Go to 2A

Go to 5A

Guided Step 2 - Check Inline E (battery harness).

Guided Step 2A - Inspect the battery harness and the Inline E connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the battery harness from the Inline E connector.

Action

Inspect the battery harness and the Inline E connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the Inline E connector. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Repair the battery harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the wiring harness from the engine harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins that are being supplied by unswitched battery on the engine harness inline connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms

Repair the battery harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all unswitched battery pins on the Inline E connector to all other pins on the Inline E connector.

NOTE: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Repair the battery harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness fuse connection.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check if the 20 ampere fuse is installed correctly.

Check if the 20 ampere fuse is installed correctly.
OK NOT OK

Fuse installed correctly

Install fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine harness fuse.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the 20 ampere fuse from the engine harness.

Action

Check if the 20 ampere fuse is blown.
OK NOT OK

Fuse not blown

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the engine harness and the extension harness inline connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the engine harness inline connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all unswitched battery pins on the engine harness inline connector to all other pins on the engine harness inline connector.

NOTE: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the base or fuel board. See wiring diagram for specific board. Refer to Procedure 019-322 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module connector.

Action

Check for an open circuit in the battery supply circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the extension harness connector to the pins being supplied by unswitchable battery at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit.

  • Measure the resistance from all unswitched battery pins on the extension harness connector to all other pins on the extension harness connector.

Note: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1442 is inactive.
OK NOT OK

Fault Code 1442 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1443 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC, (24-VDC system)
 | STEP 1C. Check the battery ground connection. | Less than 10 ohms
 | STEP 1D. Check for an add-on or accessory wiring at the positive (+) terminal of the battery. | No damaged wires
STEP 2. | Check Inline E (OEM battery harness). The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manual for more detailed instructions. |
 | STEP 2A. Inspect the OEM battery harness and the Inline E connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness fuse connection. | Fuse installed correctly
 | STEP 3B. Check the engine harness fuse. | Fuse not blown
 | STEP 3C. Inspect the engine harness and the extension harness inline connector pins. | No damaged pins
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the extension harness. |
 | STEP 4A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 4B. Check for an open circuit. | Less than 10 ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1443 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connection.
OK NOT OK

No damaged connections

Repair the damaged connections. Tighten the battery connections and clean the battery terminals. Refer to the OEM service manual.

Go to 1B

Go to 5A

Guided Step 1B - Check the battery voltage.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
OK NOT OK

17.3 to 34.7-VDC, (24-VDC system)

Charge or replace the battery. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 5A

Guided Step 1C - Check the battery ground connection.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) battery terminal to the engine block ground.
OK NOT OK

Less than 10 ohms

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 1D

Go to 5A

Guided Step 1D - Check for an add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or installation error that can cause supply wire to be shorted to the engine block.
OK NOT OK

No damaged wires

Repair the damaged wiring

Go to 2A

Go to 5A

Guided Step 2 - Check Inline E (OEM battery harness). The following steps have been constructed for generic OEM troubleshooting of the OEM circuit. Refer to the OEM service manual for more detailed instructions.

Guided Step 2A - Inspect the OEM battery harness and the Inline E connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the OEM battery harness from the Inline E connector.

Action

Inspect the OEM battery harness and the Inline E connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the Inline E connector. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the OEM battery harness. Refer to the OEM service manual.
  • Repair the OEM battery harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the OEM wiring harness from the engine harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the engine harness inline connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms

Replace the OEM battery harness. Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from all unswitched battery pins on the Inline E connector to all other pins on the Inline E connector.

NOTE: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the OEM battery harness. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness fuse connection.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check if the 20 ampere fuse is installed correctly.

Check fuse for proper installation.
OK NOT OK

Fuse installed correctly

Install fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine harness fuse.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the 20 ampere fuse from the engine harness.

Action

Check if the 20 ampere fuse is blown.

Check for blown fuse.
OK NOT OK

Fuse not blown

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Inspect the engine harness and the extension harness inline connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness inline connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Replace the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine inline connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the engine harness inline connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the positive (+) battery terminal.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from all unswitched battery pins on the engine harness inline connector to all other pins on the engine harness inline connector.

Note: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the extension harness.

Guided Step 4A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Call for authorization.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module connector.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by unswitched battery on the extension harness connector to the pins being supplied by unswitchable battery at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from all unswitched battery pins on the extension harness connector to all other pins on the extension harness connector.

Note: See wiring diagram for common pins.
OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1443 is inactive.
OK NOT OK

Fault Code 1443 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1444 - Kilowatt Overload - Alternator Protection

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the kilowatt accuracy. |
 | STEP 1A. Verify the kilowatt load demanded by the parallel controller is not above generator set limits. | Kilowatt load command below set limits
STEP 2. | Check the engine control module value. |
 | STEP 2A. Verify that the fault simulation feature for the kilowatt overload is not enabled. | Fault simulation disabled
STEP 3. | Check the current transformers. |
 | STEP 3A. Inspect the current transformers and current transformer connections. | Current transformer connections correct
 | STEP 3B. Check the AC harness. | No damaged pins
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the PT/CT board. |
 | STEP 4A. Check the PT/CT board 3 ohm resistors. | 3 ohm resistors are good
 | STEP 4B. Inspect the PT/CT board and the generator control harness connector pins. | No damaged pins
STEP 5. | Check the generator control harness. |
 | STEP 5A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for an open circuit. | Less than 10 ohms
 | STEP 5D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 1444 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the kilowatt accuracy.

Guided Step 1A - Verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt load demand is not above generator set limits.

  • Use INSITE™ electronic service tool to verify the kilowatt load demanded by the parallel controller is not above generator set limits.
OK NOT OK

Kilowatt load command below set limits

Kilowatt load command above set limits. Reference the customer/facility/installation documentation.

Go to 2A

Go to 6A

Guided Step 2 - Check the engine control module value.

Guided Step 2A - Verify that the fault simulation feature for the kilowatt overload is not enabled.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault simulation feature is not enabled.

  • Use INSITE™ electronic service tool to verify that the fault simulation feature for the kilowatt overload is not enabled.
OK NOT OK

Fault simulation disabled

Kilowatt overload is enabled. Reference the customer/facility/installation documentation.

Go to 3A

Go to 6A

Guided Step 3 - Check the current transformers.

Guided Step 3A - Inspect the current transformers and current transformer connections.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Current transformer connections correct

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Check the AC harness.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT Board.

Action

Inspect the AC harness connector and the PT/CT board connector 09 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the damaged PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness PT/CT board connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

More than 100k ohms

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the current transformer pins on the AC harness connector to all other pins on the AC harness connector.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

More than 100k ohms

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the PT/CT board.

Guided Step 4A - Check the PT/CT board 3 ohm resistors.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the generator control harness from the PT/CT board.

Action

Verify the 3 ohm resistors from PT/CT board connector 08.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.
OK NOT OK

3 ohm resistors are good

The 3 ohm resistor malfunctioned. Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the PT/CT board from the generator control harness.

Action

Inspect the PT/CT board and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the generator control harness.

Guided Step 5A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set or parallel board. See wiring diagram for appropriate board. Refer to Procedure 019-322 in Section 19.

Go to 5B

Go to 6A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each PT/CT pin on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for an open circuit in the generator control harness.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the pins on the generator control harness PT/CT board connector to the aligned generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each pin on the generator control harness engine control module connector to all other pins on the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1444 is inactive.
OK NOT OK

Fault Code 1444 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 6A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1445 - Alternator Short Circuit - Alternator Protection

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the kilowatt accuracy. |
 | STEP 1A. Verify the kilowatt output is not above the threshold for alternator short circuit. | Kilowatt output below threshold
STEP 2. | Check the output leads. |
 | STEP 2A. Inspect the alternator output leads and harness cables. | No damaged/corroded posts
 | STEP 2B. Check for a short circuit from post to post. | More than 100k ohms
STEP 3. | Check the current transformers. |
 | STEP 3A. Inspect the current transformers and current transformer connections. | Current transformer connections correct
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from post to post. | More than 100k ohms
STEP 4. | Check the PT/CT board. |
 | STEP 4A. Check the PT/CT board 3 ohm resistors. | 3 ohm resistors are good
 | STEP 4B. Inspect the PT/CT board and the generator control harness connector pins. | No damaged pins
STEP 5. | Check the generator control harness. |
 | STEP 5A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for a short circuit from post to post. | More than 100k ohms
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 1445 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the kilowatt accuracy.

Guided Step 1A - Verify the kilowatt output is not above the threshold for alternator short circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt output is not above threshold for alternator for short circuit.

  • Use INSITE™ electronic service tool to verify the kilowatt output is not above the threshold for alternator short circuit.
OK NOT OK

kilowatt output is below threshold

Kilowatt output is above the threshold for alternator short circuit. Reference the customer/facility/installation documentation.

Go to 2A

Go to 6A

Guided Step 2 - Check the output leads.

Guided Step 2A - Inspect the alternator output leads and harness cables.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the load harnesses from the alternator output cables.

Action

Verify kilowatt output is not above threshold for alternator for short circuit.

  • Loose connector
  • Corroded posts
  • Bent or broken posts
  • Pushed back or expanded posts
  • Moisture in or on the connector
  • Dirt or debris in or on the connector posts
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged/corroded posts

Repair the damaged posts. Flush the dirt, debris, or moisture from the connector posts.

  • Repair the load harness cables. Reference the site installation documentation.
  • Replace the alternator output leads.

Go to 2B

Go to 6A

Guided Step 2B - Check for a short circuit from post to post.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the load harness cables from the alternator output leads.

Action

Check for a short circuit from post to post.

  • Measure the resistance between each of the alternator output leads.
OK NOT OK

More than 100k ohms

Repair or replace the alternator. Reference the site installation documentation.

Go to 3A

Go to 6A

Guided Step 3 - Check the current transformers.

Guided Step 3A - Inspect the current transformers and current transformer connections.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Verify current transformer's are connected properly.

Verify current transformer's are connected properly.
OK NOT OK

Current transformer connections correct

Properly correct current transformer connections. Reference the site installation documentation.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness PT/CT connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

More than 100K ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from post to post.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit from post to post.

  • Measure the resistance from the current transformers' pins on the AC harness connector to all other pins on the AC harness connector.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the PT/CT board.

Guided Step 4A - Check the PT/CT board 3 ohm resistors.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check the 3-ohm resistors from PT/CT board connector 08.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.
OK NOT OK

3 ohm resistor good

3 ohm resistor is damaged. Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the PT/CT board from the generator control harness.

Action

Inspect the PT/CT board and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the generator control harness.

Guided Step 5A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the PT/CT board and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the appropriate engine control module board. See wiring diagram for appropriate board. Refer to Procedure 019-322 in Section 19.

Go to 5B

Go to 6A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each PT/CT board connector pin on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit from post to post.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check for a short circuit from post to post.

  • Measure the resistance of each PT/CT pin on the generator control harness engine control module connector to all other pins on the generator control harness engine control module connector.
OK NOT OK

More than 100K ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1445 is inactive.
OK NOT OK

Fault Code 1445 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2012


FAULT CODE 1446 - Generator AC Output Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the voltage accuracy. |
 | STEP 1A. Verify the AC voltage at the alternator matches the AC voltage seen by the control. | AC voltages are consistent
STEP 2. | Check the AC harness. |
 | STEP 2A. Check the AC harness and voltage regulator connections. | No damaged connections
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the voltage regulator and generator control harness. |
 | STEP 3A. Check the voltage regulator for proper operation. | AC output greater than residual and LED is on
 | STEP 3B. Inspect the voltage regulator and generator control harness connector pins. | No damaged pins
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the load cables. |
 | STEP 4A. Inspect the load cables and AC harness connections. | No damaged connections
STEP 5. | Check the AC harness. |
 | STEP 5A. Inspect the AC harness and PT/CT board connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5D. Check for an open circuit. | Less than 10 ohms
STEP 6. | Check the PT/CT board. |
 | STEP 6A. Inspect the PT/CT board and the generator control harness connector pins. | No damaged pins
 | STEP 6B. Check PT/CT board primary PTs. | 1k to 2.5k ohms
 | STEP 6C. Check PT/CT board secondary PTs. | 140 to 225 ohms
STEP 7. | Check the generator control harness. |
 | STEP 7A. Inspect the generator control harness and engine control module connector pins. | No damaged pins
 | STEP 7B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 7C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 7D. Check for an open circuit. | Less than 10 ohms
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 1446 inactive
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the voltage accuracy.

Guided Step 1A - Verify the AC voltage at the alternator matches the AC voltage seen by the control.

Conditions

  • Place the run/stop/auto switch in RUN position.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in RATED position.
  • Attach multimeter leads to the alternator output leads.

Action

Verify that the voltages displayed on INSITE™ electronic service tool are correct.

  • Use the multimeter to read the L1, L2, and L3 voltages in INSITE™ electronic service tool. Verify that they are consistent with the voltages of the output leads.
OK NOT OK

AC voltages are consistent

Problem is in the voltage sensing.

Go to 2A

Go to 4A

Guided Step 2 - Check the AC harness.

Guided Step 2A - Check the AC harness and voltage regulator connections.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness connector from the voltage regulator.

Action

Inspect the AC harness and voltage regulator connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged connections

Repair the damaged connections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 2B

Go to 8A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the PMG.
  • Disconnect the AC harness connectors from the alternator.
  • Disconnect the AC harness connector from the voltage regulator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from each pin in the AC harness voltage regulator connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 2C

Go to 8A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the PMG.
  • Disconnect the AC harness connectors from the alternator.
  • Disconnect the AC harness connector from the voltage regulator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from each pin in the AC harness voltage regulator connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 2D

Go to 8A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness connector from the PMG.
  • Disconnect the AC harness connector from the alternator.
  • Disconnect the AC harness connector from the voltage regulator.

Action

Check for an open circuit in the AC harness.

  • Measure the resistance of the P2 pin on the AC harness voltage regulator connector 10 to the AC harness P2 connection to the PMG.
  • Measure the resistance of the P3 pin on the AC harness voltage regulator connector 10 to the AC harness P3 connection to the PMG.
  • Measure the resistance of the P4 pin on the AC harness voltage regulator connector 10 to the AC harness P4 connection to the PMG.
  • Measure the resistance of the F1 pin on the AC harness voltage regulator connector 10 to the AC harness F1 connection to the alternator.
  • Measure the resistance of the F2 pin on the AC harness voltage regulator connector 10 to the AC harness F2 connection to the alternator.
OK NOT OK

Less than 10 ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3A

Go to 8A

Guided Step 3 - Check the voltage regulator and generator control harness.

Guided Step 3A - Check the voltage regulator for proper operation.

Conditions

  • Place the run/stop/auto switch in RUN position.
  • Place the idle/rated switch in IDLE.
  • Connect INSITE™ electronic service tool.

Action

Check the voltage regulator.

  • Use INSITE™ electronic service tool to verify that the AC voltage output is greater than residual.
  • If AC voltage output is residual, check to see if the Output Duty Cycle green LED on the voltage regulator is on.
OK NOT OK

AC voltage output greater than residual, and LED is on.

  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 8A

Go to 3B

Guided Step 3B - Inspect the voltage regulator and generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the voltage regulator.

Action

Inspect the generator control harness and voltage regulator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 3C

Go to 8A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the voltage regulator.
  • Disconnect the generator control harness from the engine control module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from each pin on the generator control harness voltage regulator connector to all other pins in the generator control harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 8A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the voltage regulator.
  • Disconnect the generator control harness from the engine control module connector 01 on the generator set board.

Action

Check for a open circuit in the generator control harness.

  • Measure the resistance of the voltage regulator pulse width modulated positive (+) pin on the generator control harness voltage regulator connector 07 to the voltage regulator pulse width modulated positive (+) pin on the generator control harness on the generator set board connector 01.
  • Measure the resistance of the voltage regulator pulse width modulated negative (-) pin on the generator control harness voltage regulator connector 07 to the voltage regulator pulse width modulated negative (-) pin on the generator control harness on the generator set board connector 01.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 8A

Guided Step 4 - Check the load cables.

Guided Step 4A - Inspect the load cables and AC harness connections

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the load cables.

Action

Inspect the load cables and AC harness connections for the following:

  • Corroded post
  • Bent or broken post
  • Dirt or debris in or on the post.
OK NOT OK

No damaged connections

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Repair the load cables. Refer to Procedure 019-197 in Section 19.

Go to 5A

Go to 8A

Guided Step 5 - Check the AC harness.

Guided Step 5A - Inspect the AC harness and PT/CT board connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.

Action

Inspect the AC harness and the PT/CT board connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 8A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the current transformers.
  • Disconnect the AC harness from the load cables.
  • Disconnect the AC harness from the PT/CT board.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the AC harness PT/CT board connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the current transformers.
  • Disconnect the AC harness from the load cables.
  • Disconnect the AC harness from the PT/CT board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each pin on the AC harness PT/CT board connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 5D

Go to 8A

Guided Step 5D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the current transformers.
  • Disconnect the AC harness from the load cables.
  • Disconnect the AC harness from the PT/CT board.

Action

Check for an open circuit in the AC harness.

  • Measure the resistance of the GEN L3 pin on the AC harness PT/CT board connector 09 to the GEN L3 connection on the AC harness to load cable W.
  • Measure the resistance of the GEN L2 pin on the AC harness PT/CT board connector 09 to the GEN L2 connection on the AC harness to load cable V.
  • Measure the resistance of the GEN L1 pin on the AC harness PT/CT board connector 09 to the GEN L1 connection on the AC harness to load cable U.
  • Measure the resistance of the COMMON pin on the AC harness PT/CT board connector 09 to the COMMON connection on the AC harness to load cable N.
OK NOT OK

Less than 10 ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 6A

Go to 8A

Guided Step 6 - Check the PT/CT board.

Guided Step 6A - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.

Action

Inspect the generator control harness and the PT/CT board connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 6B

Go to 8A

Guided Step 6B - Check PT/CT board primary PTs.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the AC harness from the PT/CT board.

Action

Verify resistance of primary PT's from PT/CT board connector 09.

  • Measure the resistance of the GEN L1 pin to the COMMON pin on connector 09.
  • Measure the resistance of the GEN L2 pin to the COMMON pin on connector 09.
  • Measure the resistance of the GEN L3 pin to the COMMON pin on connector 09.
OK NOT OK

1k to 2.5k ohms

Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 6C

Go to 8A

Guided Step 6C - Check PT/CT board secondary PTs.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the AC harness from the PT/CT board.

Action

Verify resistance of secondary PT's from PT/CT board connector 08.

  • Measure the resistance of the GEN L1 pin to the GEN L1 COM pin on connector 08.
  • Measure the resistance of the GEN L2 pin to the GEN L2 COM pin on connector 08.
  • Measure the resistance of the GEN L3 pin to the GEN L3 COM pin on connector 08.
OK NOT OK

140 to 225 ohms

Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the generator control harness.

Guided Step 7A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module board. See wiring diagram for appropriate board. Refer to Procedure 019-322 in Section 19.

Go to 7B

Go to 8A

Guided Step 7B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness PT/CT board connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 7C

Go to 8A

Guided Step 7C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each pin on the generator control harness engine control module connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 7D

Go to 8A

Guided Step 7D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance of the GEN L1 pin on the generator control harness PT/CT board connector 08 to the GEN L1 pin on the generator control harness engine control module connector.
  • Measure the resistance of the GEN L1 COM pin on the generator control harness PT/CT board connector 08 to the GEN L1 COM pin on the generator control harness engine control module connector.
  • Measure the resistance of the GEN L2 pin on the generator control harness PT/CT board connector 08 to the GEN L1 pin on the generator control harness engine control module connector.
  • Measure the resistance of the GEN L2 COM pin on the generator control harness PT/CT board connector 08 to the GEN L1 COM pin on the generator control harness engine control module connector.
  • Measure the resistance of the GEN L3 pin on the generator control harness PT/CT board connector 08 to the GEN L1 pin on the generator control harness engine control module connector.
  • Measure the resistance of the GEN L3 COM pin on the generator control harness PT/CT board connector 08 to the GEN L1 COM pin on the generator control harness engine control module connector.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1446 is inactive.
OK NOT OK

Fault Code 1446 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1447 - Generator AC Output Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the voltage accuracy. |
 | STEP 1A. Verify the AC voltage at the alternator matches the AC voltage seen by the control. | AC voltages are consistent
STEP 2. | Check the AC harness. |
 | STEP 2A. Check the AC harness and voltage regulator connections. | No damaged connections
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for an open circuit. | Less than 10 ohms
STEP 3. | Check the voltage regulator and generator control harness. |
 | STEP 3A. Inspect the voltage regulator and generator control harness connector pins. | No damaged pins
 | STEP 3B. Check the voltage regulator DC power supply. | B positive (+) OK
 | STEP 3C. Check the voltage regulator for proper operation. | LED on
 | STEP 3D. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3F. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the load cables. |
 | STEP 4A. Inspect the load cables and AC harness connections. | No damaged connections
STEP 5. | Check the AC harness. |
 | STEP 5A. Inspect the AC harness and PT/CT board connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5D. Check for an open circuit. | Less than 10 ohms
STEP 6. | Check the PT/CT board. |
 | STEP 6A. Inspect the PT/CT board and the generator control harness connector pins. | No damaged pins
 | STEP 6B. Check PT/CT board primary PTs. | 1k to 2.5k ohms
 | STEP 6C. Check PT/CT board secondary PTs. | 140 to 225 ohms
STEP 7. | Check the generator control harness. |
 | STEP 7A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 7B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 7C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 7D. Check for an open circuit. | Less than 10 ohms
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 1447 inactive
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the voltage accuracy.

Guided Step 1A - Verify the AC voltage at the alternator matches the AC voltage seen by the control.

Conditions

  • Place the run/stop/auto switch in RUN position.
  • Connect INSITE™ electronic service tool.
  • Attach multimeter leads to the alternator output leads.

Action

Verify that the voltages displayed on the electronic service tool are correct.

  • Use a multimeter to read the L1, L2, and L3 voltages in INSITE™ electronic service tool. Verify that they are consistent with the voltages of the output leads.
OK NOT OK

AC voltages are consistent

Problem is in the voltage sensing.

Go to 2A

Go to 4A

Guided Step 2 - Check the AC harness.

Guided Step 2A - Check the AC harness and voltage regulator connections.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the voltage regulator.

Action

Inspect the AC harness and voltage regulator connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged connections

Repair the damaged connections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 2B

Go to 8A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the PMG.
  • Disconnect the AC harness connectors from the alternator.
  • Disconnect the AC harness connector from the voltage regulator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from each pin in the AC harness voltage regulator connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 2C

Go to 8A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness connector from the PMG.
  • Disconnect the AC harness connector from the alternator.
  • Disconnect the AC harness connector from the voltage regulator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from each pin in the AC harness voltage regulator connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 2D

Go to 8A

Guided Step 2D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the PMG.
  • Disconnect the AC harness connectors from the alternator.
  • Disconnect the AC harness connectors from the voltage regulator.

Action

Check for a open circuit in the AC harness.

  • Measure the resistance of the P2 pin on the AC harness voltage regulator connector 10 to the AC harness P2 connection to the PMG.
  • Measure the resistance of the P3 pin on the AC harness voltage regulator connector 10 to the AC harness P3 connection to the PMG.
  • Measure the resistance of the P4 pin on the AC harness voltage regulator connector 10 to the AC harness P4 connection to the PMG.
  • Measure the resistance of the F1 pin on the AC harness voltage regulator connector 10 to the AC harness F1 connection to the alternator.
  • Measure the resistance of the F2 pin on the AC harness voltage regulator connector 10 to the AC harness F2 connection to the alternator.
OK NOT OK

Less than 10 ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3A

Go to 8A

Guided Step 3 - Check the voltage regulator and generator control harness.

Guided Step 3A - Inspect the voltage regulator and generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the voltage regulator.

Action

Inspect the generator control harness and voltage regulator connector pins for the following:.

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 3B

Go to 8A

Guided Step 3B - Check the voltage regulator DC power supply.

Conditions

  • Place the run/stop/auto switch in RUN position.
  • Place the idle/rated switch in IDLE position.
  • Disconnect the generator control harness from the voltage regulator connector 07.

Action

Check the voltage regulator DC power supply.

  • Use a multimeter to test for B positive (+) into the voltage regulator and check the voltage on the DC power SUPPLY pin of the generator control harness.
OK NOT OK

B positive (+) OK

B positive (+) OK

Go to 3C

Go to 3D

Guided Step 3C - Check the voltage regulator for proper operation.

Conditions

  • Place the run/stop/auto switch in RUN position.
  • Place the idle/rated switch in IDLE position.
  • Reconnect the generator control harness to the voltage regulator.

Action

Check the voltage regulator for proper operation.

  • Check to see that the isolated supply green LED is lit.
OK NOT OK

LED on

Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 3D

Go to 8A

Guided Step 3D - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the voltage regulator.
  • Disconnect the generator control harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness voltage regulator connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3E

Go to 8A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the voltage regulator.
  • Disconnect the generator control harness from the engine control module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each pin on the generator control harness voltage regulator connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3F

Go to 8A

Guided Step 3F - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the voltage regulator.
  • Disconnect the generator control harness from the engine control module connector 01 on the generator set board.

Action

Check for a open circuit in the generator control harness.

  • Measure the resistance of the voltage regulator pulse width modulated positive (+) pin on the generator control harness voltage regulator connector 07 to the voltage regulator pulse width modulated positive (+) pin on the generator control harness on the genset board connector 01.
  • Measure the resistance of the voltage regulator pulse width modulated negative (-) pin on the generator control harness voltage regulator connector 07 to the voltage regulator pulse width modulated negative (-) pin on the generator control harness on the genset board connector 01.
  • Measure the resistance of the DC power SUPPLY pin on the generator control harness voltage regulator connector 07 to the DC power SUPPLY pin on the generator control harness on the base board connector 06.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 8A

Guided Step 4 - Check the load cables.

Guided Step 4A - Inspect the load cables and AC harness connections.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the load cables.

Action

Inspect the load cables and AC harness connections for the following:

  • Corroded post
  • Bent or broken post
  • Dirt or debris on the post.
OK NOT OK

No damaged connections

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Repair the load cables. Reference the site installation documentation.

Go to 5A

Go to 8A

Guided Step 5 - Check the AC harness.

Guided Step 5A - Inspect the AC harness and PT/CT board connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.

Action

Inspect the AC harness and the PT/CT board connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 8A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the current transformers.
  • Disconnect the AC harness from the load cables.
  • Disconnect the AC harness from the PT/CT board.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the AC harness PT/CT board connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the current transformers.
  • Disconnect the AC harness from the load cables.
  • Disconnect the AC harness from the PT/CT board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each pin on the AC harness PT/CT board connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 5D

Go to 8A

Guided Step 5D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the current transformers.
  • Disconnect the AC harness from the load cables.
  • Disconnect the AC harness from the PT/CT board.

Action

Check for an open circuit in the AC harness.

  • Measure the resistance of the GEN L3 pin on the AC harness PT/CT board connector 09 to the GEN L3 connection on the AC harness to load cable W.
  • Measure the resistance of the GEN L2 pin on the AC harness PT/CT board connector 09 to the GEN L2 connection on the AC harness to load cable V.
  • Measure the resistance of the GEN L1 pin on the AC harness PT/CT board connector 09 to the GEN L1 connection on the AC harness to load cable U.
  • Measure the resistance of the COMMON pin on the AC harness PT/CT board connector 09 to the COMMON connection on the AC harness to load cable N.
OK NOT OK

Less than 10 ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 6A

Go to 8A

Guided Step 6 - Check the PT/CT board.

Guided Step 6A - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.

Action

Inspect the generator control harness and the PT/CT board connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 6B

Go to 8A

Guided Step 6B - Check PT/CT board primary PTs.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the AC harness from the PT/CT board.

Action

Verify resistance of primary PTs from PT/CT board connector 09.

  • Measure the resistance of the GEN L1 pin to the COMMON pin on connector 09.
  • Measure the resistance of the GEN L2 pin to the COMMON pin on connector 09.
  • Measure the resistance of the GEN L3 pin to the COMMON pin on connector 09.
OK NOT OK

1k to 2.5k ohms

Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 6C

Go to 8A

Guided Step 6C - Check PT/CT board secondary PTs.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the AC harness from the PT/CT board.

Action

Verify resistance of secondary PTs from PT/CT board connector 08.

  • Measure the resistance of the GEN L1 pin to the GEN L1 COM pin on connector 08.
  • Measure the resistance of the GEN L2 pin to the GEN L2 COM pin on connector 08.
  • Measure the resistance of the GEN L3 pin to the GEN L3 COM pin on connector 08.
OK NOT OK

140 to 225 ohms

Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the generator control harness.

Guided Step 7A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module board. See wiring diagram for appropriate board. Refer to Procedure 019-322 in Section 19.

Go to 7B

Go to 8A

Guided Step 7B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness PT/CT board connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 7C

Go to 8A

Guided Step 7C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each pin on the generator control harness engine control module connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 7D

Go to 8A

Guided Step 7D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance of the GEN L1 pin on the generator control harness PT/CT board connector 08 to the GEN L1 pin on the generator control harness engine control module connector.
  • Measure the resistance of the GEN L1 COM pin on the generator control harness PT/CT board connector 08 to the GEN L1 COM pin on the generator control harness engine control module connector.
  • Measure the resistance of the GEN L2 pin on the generator control harness PT/CT board connector 08 to the GEN L1 pin on the generator control harness engine control module connector.
  • Measure the resistance of the GEN L2 COM pin on the generator control harness PT/CT board connector 08 to the GEN L1 COM pin on the generator control harness engine control module connector.
  • Measure the resistance of the GEN L3 pin on the generator control harness PT/CT board connector 08 to the GEN L1 pin on the generator control harness engine control module connector.
  • Measure the resistance of the GEN L3 COM pin on the generator control harness PT/CT board connector 08 to the GEN L1 COM pin on the generator control harness engine control module connector.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1447 is inactive.
OK NOT OK

Fault Code 1447 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1448 - Generator AC Output Frequency

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module. |
 | STEP 1A. Check for multiple fault codes. | No other active fault codes
 | STEP 1B. Verify correct calibration is loaded into the engine control module. | Correct calibration loaded
 | STEP 1C. Verify that the initial setup of the generator set was installed correctly. | Initial setup is correct
 | STEP 1D. Check for overload. | No overload conditions or faults
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1448 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine control module.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other active fault codes

Other fault codes are active. Troubleshoot all other fault codes first.

Go to 1B

Go to 2A

Guided Step 1B - Verify correct calibration is loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct calibration loaded

Incorrect or no calibration loaded. Load correct calibration software. Reference INSITE™ electronic service tool user's manual.

Go to 1C

Go to 2A

Guided Step 1C - Verify that the initial setup of the generator set was installed correctly.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read initial setup.

  • Use INSITE™ electronic service tool to verify the initial setup was installed correctly.
OK NOT OK

Initial setup is correct

Correctly install initial setup. Reference the site documentation.

Go to 1D

Go to 2A

Guided Step 1D - Check for overload.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Check for overload.

  • Use the electronic service tool to verify the load is acceptable and within proper limits.
OK NOT OK

No overload conditions or faults. See appropriate base engine manual, Section TS. Reference symptom tree T057.

Generator set is being overloaded. Correctly install initial setup and correct any overload. Reference the site documentation.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1448 is inactive.
OK NOT OK

Fault Code 1448 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1449 - Generator AC Output Frequency

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module. |
 | STEP 1A. Check for multiple fault codes. | No other active fault codes
 | STEP 1B. Verify that the correct calibration is loaded into the engine control module. | Correct calibration loaded
 | STEP 1C. Verify that the initial setup of the generator set was installed correctly. | Initial setup is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1449 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine control module.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other active fault codes

Other fault codes are active. Troubleshoot all other fault codes first.

Go to 1B

Go to 2A

Guided Step 1B - Verify that the correct calibration is loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct calibration loaded

Incorrect or no calibration loaded. Load correct calibration software. Reference INSITE™ electronic service tool user's manual.

Go to 1C

Go to 2A

Guided Step 1C - Verify that the initial setup of the generator set was installed correctly.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read initial setup.

  • Use INSITE™ electronic service tool to verify the initial setup was installed correctly.
OK NOT OK

Initial setup is correct. See appropriate base engine manual, Section TS, symptom tree T067.

Correctly install initial setup. Refer to site documentation.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1449 is inactive.
OK NOT OK

Fault Code 1449 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1451 - Generator vs Bus Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the bus voltage. |
 | STEP 1A. Verify that the bus voltage is proper and not single phase. | Bus voltage is proper
 | STEP 1B. Check for proper voltage calibration. | Voltages are consistent
STEP 2. | Check the load cables. |
 | STEP 2A. Inspect the load cables and AC harness connection post. | No damaged post
STEP 3. | Check the AC harness. |
 | STEP 3A. Inspect the AC harness and bus PT connector pins. | No damaged pins
 | STEP 3B. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the bus PT module. |
 | STEP 4A. Inspect the bus PT module and generator control harness connector pins. | No damaged pins
 | STEP 4B. Check bus PT primary PTs. | 1k to 2.5k
 | STEP 4C. Check bus PT secondary PTs. | 140 to 225 ohms
STEP 5. | Check the generator control harness. |
 | STEP 5A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5D. Check for an open circuit. | Less than 10 ohms
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 1451 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the bus voltage.

Guided Step 1A - Verify that the bus voltage is proper and not single phase.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify that the bus voltage is not single phase.

  • Use INSITE™ electronic service tool to verify the bus voltage is proper and not single phase.
OK NOT OK

Bus voltage is proper

Bus voltage is single phase. Reference the site documentation.

Go to 1B

Go to 6A

Guided Step 1B - Check for proper voltage calibration.

Conditions

  • Place the run/stop/auto switch in RUN position.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in RATED.
  • Close generator set circuit to bus.

Action

Check for proper alternator and bus voltage calibration.

  • Use INSITE™ electronic service tool to compare AC output voltages at the alternator and at the bus, and make sure the difference is within tolerable limits. Difference must be less than 1 percent.
OK NOT OK

Voltages are consistent

Voltages are out of calibration. Calibrate alternator/bus voltages. Reference the the electronic service tool manual.

Go to 2A

Go to 6A

Guided Step 2 - Check the load cables.

Guided Step 2A - Inspect the load cables and AC harness connection post.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the load cables on the bus side of the circuit breaker.

Action

Inspect the load cables and AC harness connection post for the following:

  • Corroded post
  • Bent or broken post
  • Dirt or debris on the connector post.
OK NOT OK

No damaged post

Repair or replace the load cables or the AC harness, whichever has the damaged post.

  • Flush the dirt, debris, or moisture from the connector post. Use electrical contact cleaner, Part Number 3824510.
  • Repair the load cables. Reference the site installation documentation.
  • Replace the load cables. Reference the site installation documentation.
  • Repair the AC harness. Refer to Procedure 019-197 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the AC harness.

Guided Step 3A - Inspect the AC harness and bus PT connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the engine control module.
  • Disconnect the AC harness from the bus PT module.

Action

Inspect the AC harness and bus PT connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-197 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the bus PT module. Reference the site documentation.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the load cables on the bus side of the circuit breaker.
  • Disconnect the AC harness from the bus PT module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each post on the AC harness bus PT connections to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-197 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the load cables on the bus side of the circuit breaker.
  • Disconnect the AC harness from the bus PT module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each post on the AC harness bus PT connections to all other posts on TB1.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-197 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the load cables on the bus side of the circuit breaker.
  • Disconnect the AC harness from the bus PT module.

Action

Check for an open circuit in the AC harness.

  • Measure the resistance from the BUS L3 post on the AC harness bus PT connection at TB1 to the BUS L3 connection on the AC harness to load cable W.
  • Measure the resistance from the BUS L2 post on the AC harness bus PT connection at TB1 to the BUS L2 connection on the AC harness to load cable V.
  • Measure the resistance from the BUS L1 post on the AC harness bus PT connection at TB1 to the BUS L1 connection on the AC harness to load cable U.
  • Measure the resistance from the COMMON post on the AC harness bus PT connection at TB1 to the COMMON connection on the AC harness to load cable N.
OK NOT OK

Less than 10 ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-197 in Section 19 or Refer to Procedure 019-203 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the bus PT module.

Guided Step 4A - Inspect the bus PT module and generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the bus PT module.

Action

Inspect the generator control harness and bus PT module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the bus PT module. Refer to Procedure 019-319 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Check bus PT primary PTs.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the bus PT.
  • Disconnect the AC harness from the bus PT.

Action

Verify resistance of primary PTs from bus PT connector post at TB1.

  • Measure the resistance of BUS L1 post to the COMMON post on TB1.
  • Measure the resistance of BUS L2 post to the COMMON post on TB1.
  • Measure the resistance of BUS L3 post to the COMMON post on TB1.
OK NOT OK

1k to 2.5k

Replace the bus PT module. Refer to Procedure 019-319 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check bus PT secondary PTs.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the bus PT.
  • Disconnect the AC harness from the bus PT.

Action

Verify resistance of secondary PTs from bus PT connector post at TB2.

  • Measure the resistance of BUS L1 post to the BUS L1 COM post on TB2.
  • Measure the resistance of BUS L2 post to the BUS L2 COM post on TB2.
  • Measure the resistance of BUS L3 post to the BUS L3 COM post on TB2.
OK NOT OK

140 to 225 ohms

Replace the bus PT module. Refer to Procedure 019-319 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the generator control harness.

Guided Step 5A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness board from the engine control module.
  • Disconnect the generator control harness from the bus PT module.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the bus PT module. Refer to Procedure 019-319 in Section 19.

Go to 5B

Go to 6A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the bus PT module.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness bus PT connections to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the bus PT module.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each pin on the generator control harness engine control module connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the bus PT module.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from the BUS L1 post on the generator control harness bus PT connection to the BUS L1 pin on the generator control harness engine control module connector.
  • Measure the resistance from the BUS L1 COM post on the generator control harness bus PT connection to the BUS L1 COM pin on the generator control harness engine control module connector.
  • Measure the resistance from the BUS L2 post on the generator control harness bus PT connection to the BUS L2 pin on the generator control harness engine control module connector.
  • Measure the resistance from the BUS L2 COM post on the generator control harness bus PT connection to the BUS L2 COM pin on the generator control harness engine control module connector.
  • Measure the resistance from the BUS L3 post on the generator control harness bus PT connection to the BUS L3 pin on the generator control harness engine control module connector.
  • Measure the resistance from the BUS L3 COM post on the generator control harness bus PT connection to the BUS L3 COM pin on the generator control harness engine control module connector.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1451 is inactive.
OK NOT OK

Fault Code 1451 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-May-2012


FAULT CODE 1452 - Generator Set Circuit Breaker - Failed to Close

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the generator set circuit breaker. |
 | STEP 1A. Inspect the generator set circuit breaker connector pins. | No damaged pins
 | STEP 1B. Check the generator set circuit breaker for failures. | No visible failures
 | STEP 1C. Check the generator set circuit breaker for proper charge. | Circuit breaker properly charged
STEP 2. | Check the customer circuit breaker harness. |
 | STEP 2A. Inspect the customer circuit breaker harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1452 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the generator set circuit breaker.

Guided Step 1A - Inspect the generator set circuit breaker connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the circuit breaker connector.

Action

Inspect the generator control harness and the circuit breaker connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.
  • Repair the circuit breaker connector. Reference the site documentation.
  • Replace the circuit breaker connector. Reference the site documentation.

Go to 1B

Go to 3A

Guided Step 1B - Check the generator set circuit breaker for failures.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Inspect the circuit breaker.

  • Inspect the generator set circuit breaker for any malfunctions.
OK NOT OK

No visible failures

Replace the generator set circuit breaker. Reference the site installation documentation.

Go to 1C

Go to 3A

Guided Step 1C - Check the generator set circuit breaker for proper charge.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check the generator set circuit breaker for proper charge.

Check the generator set circuit breaker for proper charge.
OK NOT OK

Circuit breaker properly charged

Repair circuit breaker. Reference the site documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the customer circuit breaker harness.

Guided Step 2A - Inspect the customer circuit breaker harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Inspect the harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the engine control module.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the generator set circuit breaker on the customer circuit breaker harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the customer circuit breaker harness.

  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the engine control module.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from generator set circuit breaker pins on the customer circuit breaker harness board connector to the customer circuit breaker harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the customer circuit breaker harness.

  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the engine control module.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the generator set circuit breaker pin on the customer circuit breaker harness engine control module connector to the customer circuit breaker harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the customer circuit breaker harness.

  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1452 is inactive.
OK NOT OK

Fault Code 1452 inactive

Return to troubleshooting steps or contact your a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


Generator Circuit Breaker Failed to Open - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the generator set circuit breaker. |
 | STEP 1A. Inspect the generator set circuit breaker connector pins. | No damaged pins
 | STEP 1B. Check the generator set circuit breaker for malfunctions. | No visible failures
STEP 2. | Check the customer circuit breaker harness. |
 | STEP 2A. Inspect the customer circuit breaker harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1453 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the generator set circuit breaker.

Guided Step 1A - Inspect the generator set circuit breaker connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the circuit breaker connector.

Action

Inspect the harness and the circuit breaker connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the customer circuit breaker harness or the circuit breaker connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.
  • Repair the circuit breaker connector. Reference the site documentation.
  • Replace the circuit breaker connector. Reference the site documentation.

Go to 1B

Go to 3A

Guided Step 1B - Check the generator set circuit breaker for malfunctions.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Inspect the circuit breaker.

  • Inspect the generator set circuit breaker for any malfunctions.
OK NOT OK

No visible malfunctions

Replace the generator set circuit breaker. Replace the generator set circuit breaker. Reference the site documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the customer circuit breaker harness.

Guided Step 2A - Inspect the customer circuit breaker harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Inspect the harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the customer circuit breaker harness or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.
  • Replace the generator set board. Refer to Procedure 019-322.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the engine control module.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the generator set circuit breaker on the customer circuit breaker harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the customer circuit breaker harness.

  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the engine control module.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from generator set circuit breaker pins on the customer circuit breaker harness board connector to the customer circuit breaker harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the customer circuit breaker harness.

  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the engine control module.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the generator set circuit breaker pin on the customer circuit breaker harness engine control module connector to the customer circuit breaker harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the customer circuit breaker harness.

  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1453 is inactive.
OK NOT OK

Fault Code 1453 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1454 - Generator Circuit Breaker Position Contact Failed - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the generator set circuit breaker. |
 | STEP 1A. Inspect the generator set circuit breaker connector pins. | No damaged pins
 | STEP 1B. Check the generator set circuit breaker for malfunctions. | No visible malfunctions
STEP 2. | Check the customer circuit breaker harness. |
 | STEP 2A. Inspect the customer circuit breaker harness and the engine control module connector pins. | No damage pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit in the customer circuit breaker harness. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1454 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the generator set circuit breaker.

Guided Step 1A - Inspect the generator set circuit breaker connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the circuit breaker connector.

Action

Inspect the harness and the circuit breaker connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the customer circuit breaker harness or the circuit breaker connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.
  • Repair the circuit breaker connector. Reference the site documentation.
  • Replace the circuit breaker connector. Reference the site documentation.

Go to 1B

Go to 3A

Guided Step 1B - Check the generator set circuit breaker for malfunctions.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Inspect the circuit breaker.

  • Inspect the generator set circuit breaker for any malfunctions.
OK NOT OK

No visible malfunctions

Replace the generator set circuit breaker. Replace the generator set circuit breaker. Reference the site documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the customer circuit breaker harness.

Guided Step 2A - Inspect the customer circuit breaker harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Inspect the harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the customer circuit breaker harness or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the engine control module.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the generator set circuit breaker on the customer circuit breaker harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the customer circuit breaker harness.

  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the engine control module.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for an open circuit in the harness.

  • Measure the resistance from generator set circuit breaker pins on the customer circuit breaker harness board connector to the customer circuit breaker harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the customer circuit breaker harness.

  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer circuit breaker harness from the engine control module.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the generator set circuit breaker pin on the customer circuit breaker harness engine control module connector to the customer circuit breaker harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the customer circuit breaker harness.

  • Repair the customer circuit breaker harness. Reference the site documentation.
  • Replace the customer circuit breaker harness. Reference the site documentation.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1454 is inactive.
OK NOT OK

Fault Code 1454 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1455 - Utility Circuit Breaker Position Contact Selected is Incorrect for Generator Application - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check engine control module. |
 | STEP 1A. Verify that the setup for the generator set utility circuit breaker position contact is correct. | Setup is correct
 | STEP 1B. Verify that the correct calibration is loaded into the engine control module of the generator set. | Calibration is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1455 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine control module.

Guided Step 1A - Verify that the setup for the generator set utility circuit breaker position contact is correct.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify the setup for the generator set utility circuit breaker position contact is correct.

  • Use INSITE™ electronic service tool to verify that the setup for the generator set utility circuit breaker position contact is correct.
OK NOT OK

Setup is correct

Setup is incorrect. Reference the installation manual.

Go to 1B

Go to 2A

Guided Step 1B - Verify that the correct calibration is loaded into the engine control module of the generator set.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module of the generator set.
OK NOT OK

Calibration is correct

Incorrect calibration loaded. Load correct calibration software.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1455 is inactive.
OK NOT OK

Fault Code 1455 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1456 - Generator Set - Cannot Synchronize

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active.
STEP 2. | Check the engine control module. |
 | STEP 2A. Verify that the setup for the generator set governor is correct. | Setup is correct
 | STEP 2B. Verify that the setup of the generator set synchronizer is correct. | Setup is correct
STEP 3. | Check the fuel system. |
 | STEP 3A. Verify that the fuel system is operating normally. | Fuel system is functioning normally
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1456 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other fault codes are active

Go to multiple fault tree.

Go to 2A

Multiple fault tree

Guided Step 2 - Check the engine control module.

Guided Step 2A - Verify that the setup for the generator set governor is correct.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify the setup for the generator set governor is correct.

  • Use INSITE™ electronic service tool to verify that the setup for the generator set governor is correct.
OK NOT OK

Setup is correct

Setup is incorrect. Refer to installation manual.

Go to 2B

Go to 4A

Guided Step 2B - Verify that the setup of the generator set synchronizer is correct.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify that the setup of the generator set synchronizer is correct.

  • Use INSITE™ electronic service tool to verify that the setup of the generator set synchronizer is correct.
OK NOT OK

Setup is correct

Setup is incorrect. Refer to installation manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Verify that the fuel system is operating normally.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Verify that the fuel system is operating normally.

  • No fuel system fault codes
  • Engine operating normally.
OK NOT OK

Fuel system is functioning normally

Fuel system is not operating normally. Reference symptom tree T066 in Section TS.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1456 is inactive.
OK NOT OK

Fault Code 1456 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1457 - Generator Set - Failed to Synchronize

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other fault codes are active
STEP 2. | Check the engine control module. |
 | STEP 2A. Verify that the setup of the generator set governor is correct. | Setup is correct
 | STEP 2B. Verify that the setup of the generator set synchronizer is correct. | Setup is correct
STEP 3. | Check the fuel system. |
 | STEP 3A. Verify that the fuel system is functioning normally. | Fuel system is functioning normally
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1457 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other fault codes are active

Go to multiple fault tree.

Go to 2A

Multiple fault tree

Guided Step 2 - Check the engine control module.

Guided Step 2A - Verify that the setup for the generator set governor is correct.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify the setup for the generator set governor is correct.

  • Use INSITE™ electronic service tool to verify that the setup for the generator set governor is correct.
OK NOT OK

Setup is correct

Setup is incorrect. Reference the installation manual.

Go to 2B

Go to 4A

Guided Step 2B - Verify that the setup of the generator set synchronizer is correct.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify that the setup of the generator set synchronizer is correct.

  • Use INSITE™ electronic service tool to verify that the setup of the generator set synchronizer is correct.
OK NOT OK

Setup is correct

Setup is incorrect. Reference the installation manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Verify that the fuel system is functioning normally.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Verify that the fuel system is functioning normally.

  • No fuel system fault codes
  • Engine operates normally.
OK NOT OK

Fuel system is functioning normally

Fuel system is functioning normally. Reference symptom tree T066 in Section TS.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1457 is inactive.
OK NOT OK

Fault Code 1457 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1458 - Generator Set - Cannot Synchronize Phase

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the bus voltage. |
 | STEP 1A. Verify that the bus voltage is proper and is not single phase. | Bus voltage is proper
STEP 2. | Check the power output feeders. |
 | STEP 2A. Verify that the power output feeders are properly connected. | Power output feeders properly connected
STEP 3. | Check the generator control harness. |
 | STEP 3A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1458 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the bus voltage.

Guided Step 1A - Verify that the bus voltage is proper and is not single phase.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify that the bus voltage is not single phase.

  • Use INSITE™ electronic service tool to verify that the bus voltage is proper and is not single phase.
OK NOT OK

Bus voltage is proper

Bus voltage is single phase. Reference the site documentation.

Go to 2A

Go to 4A

Guided Step 2 - Check the power output feeders.

Guided Step 2A - Verify that the power output feeders are properly connected.

Conditions

  • Place the run/stop/auto switch in RUN position.
  • Connect INSITE™ electronic service tool.

Action

Verify that the bus voltage is not single phase.

  • Energize the system bus and start the generator set in the RUN mode, but do not close the paralleling breaker. Connect each voltmeter from the line to load side of a single phase of the paralleling breaker. If the generator set and bus have the same phase rotation, the voltmeter will rise and fall in voltage at the same time. If they are not in phase, one will rise while the other falls.
OK NOT OK

Power output feeders properly connected

Power output feeders are incorrectly connected. Reference the site documentation.

Go to 3A

Go to 4A

Guided Step 3 - Check the generator control harness.

Guided Step 3A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness board from the engine control module.
  • Disconnect the generator control harness from the BUS/PT board.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the BUS/PT board. Refer to Procedure 019-319 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the BUS/PT board.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the BUS/PT board pins on the generator control harness board connector to the aligned generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the BUS/PT board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each BUS/PT pin on the generator control harness engine control module connector to all other pins on the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1458 is inactive.
OK NOT OK

Fault Code 1458 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1459 - Reverse Kilowatt

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module. |
 | STEP 1A. Verify that the correct calibration is loaded into the engine control module. | Correct calibration loaded
 | STEP 1B. Verify that the initial setup of the generator set was completed correctly. | Initial setup is correct
 | STEP 1C. Verify if there are any active or inactive counts of fuel system faults. | No active or inactive fuel system faults
 | STEP 1D. Verify if there are any active or inactive counts of air intake faults. | No active or inactive air intake faults
 | STEP 1E. Verify that the fault simulation feature for reverse kilowatt protection is not enabled. | Fault simulation is disabled
STEP 2. | Check the output leads. |
 | STEP 2A. Inspect the alternator and the output leads. | No damaged/corroded connections
 | STEP 2B. Check for a short circuit from post to post. | More than 100k ohms
STEP 3. | Check the current transformers. |
 | STEP 3A. Inspect the current transformers and current transformer connections. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the PT/CT board. |
 | STEP 4A. Check the PT/CT board 3 ohm resistors. | 3 ohm resistors are good
 | STEP 4B. Inspect the PT/CT board and the generator control harness connector pins. | No damaged pins
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4D. Check for an open circuit. | Less than 10 ohms
 | STEP 4E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the BUS/PT board. |
 | STEP 5A. Check the BUS/PT board and the generator control harness connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for an open circuit. | Less than 10 ohms
 | STEP 5D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 6. | Check the generator system. |
 | STEP 6A. Verify that the transient responses for the generators in the system are not greatly dissimilar. | Transient responses are similar
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 1459 inactive
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine control module.

Guided Step 1A - Verify that the correct calibration is loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct calibration loaded

Incorrect calibration loaded. Load correct calibration software.

Go to 1B

Go to 7A

Guided Step 1B - Verify that the initial setup of the generator set was installed correctly.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read initial setup.

  • Use INSITE™ electronic service tool to verify that the initial setup was installed correctly.
OK NOT OK

Initial setup is correct

Correctly install initial setup. Reference the site documentation.

Go to 1C

Go to 7A

Guided Step 1C - Verify if there are any active or inactive counts of fuel system faults.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify if there are any fuel system faults.

  • Use INSITE™ electronic service tool to verify if there are any fuel system faults.
OK NOT OK

No active or inactive fuel system faults

Fuel system faults found. Reference the site documentation.

Go to 1D

Go to 7A

Guided Step 1D - Verify if there are any active or inactive counts of air intake faults.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify if there are any air intake faults.

  • Use INSITE™ electronic service tool to verify if there are any air intake faults.
OK NOT OK

No active or inactive air intake faults

Air intake faults found. Reference the site documentation.

Go to 1E

Go to 7A

Guided Step 1E - Verify that the fault simulation feature for reverse kilowatt protection is not enabled.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify that reverse kilowatt protection is not enabled.

  • Use INSITE™ electronic service tool to verify that the fault simulation feature for reverse kilowatt protection is not enabled.
OK NOT OK

Fault simulation is disabled

Reverse kilowatt protection is enabled. Reference the site installation documentation.

Go to 2A

Go to 7A

Guided Step 2 - Check the output leads.

Guided Step 2A - Inspect the alternator and the output leads.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the load cables from the alternator.

Action

Verify that reverse kilowatt protection is not enabled.

  • Corroded posts
  • Loose connections.
OK NOT OK

No damaged/corroded connections

Repair the damaged connections. Reference the site documentation.

Go to 2B

Go to 7A

Guided Step 2B - Check for a short circuit from post to post.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit from post to post.

  • Measure the resistance between each of the output leads.
OK NOT OK

More than 100k ohms

Repair or replace the alternator. Reference the site installation documentation.

Go to 3A

Go to 7A

Guided Step 3 - Check the current transformers.

Guided Step 3A - Inspect the current transformers and current transformer connections.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-207 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the damaged current transformer. Reference the site installation documentation.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness engine control module connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-207 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness from the current transformers.

Action

Check for an open circuit.

  • Measure the resistance of each current transformer pin on the AC harness engine control module connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

Less than 10 ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-207 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the current transformer pin on the AC harness connector to all other pins on the generator control harness connector.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-207 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the PT/CT board.

Guided Step 4A - Check the PT/CT board 3 ohm resistors.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the generator control harness from the PT/CT board 3 ohms resistor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.
OK NOT OK

3 ohm resistors are good

3 ohm resistor is damaged. Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the PT/CT board from the generator control harness.

Action

Inspect the PT/CT board and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each PT/CT pin on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the PT/CT board pins on the generator control harness board connector to the aligned generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each PT/CT pin on the generator control harness engine control module connector to all other pins on the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the BUS/PT board.

Guided Step 5A - Inspect the BUS/PT board and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the BUS/PT board from the generator control harness.

Action

Inspect the BUS/PT board and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the BUS/PT board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the BUS/PT board.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each BUS/PT pin on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the BUS/PT board.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the BUS/PT board pins on the generator control harness board connector to the aligned generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5D

Go to 7A

Guided Step 5D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the BUS/PT board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each BUS/PT pin on the generator control harness engine control module connector to all other pins on the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the generator system.

Guided Step 6A - Verify that the transient responses for the generators in the system are not greatly dissimilar.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify that the transient responses are not greatly dissimilar.

  • Use INSITE™ electronic service tool to verify that the transient responses for the generators in the system are not greatly dissimilar.
OK NOT OK

Transient responses are similar

Transient responses are greatly dissimilar. Reference the site installation documentation.

Go to 7A

Go to 7

Guided Step 7A - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1459 is inactive.
OK NOT OK

Fault Code 1459 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1461 - Loss of Electric Field Due to Reverse KVAR - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the kilowatt accuracy. |
 | STEP 1A. Verify the kilowatt load demanded by the parallel controller is not above generator set limits. | Kilowatt load command is below set limits
STEP 2. | Check the load cables and connections. |
 | STEP 2A. Inspect the alternator and the load harness connections. | No damaged/corroded connections
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the alternator. |
 | STEP 3A. Inspect the alternator for component failures. | No visible damage
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1461 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the kilowatt accuracy.

Guided Step 1A - Verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt load demand is not above generator set limits.

  • Use INSITE™ electronic service tool to verify the kilowatt load demanded by the parallel controller is not above generator set limits.
OK NOT OK

kilowatt load command is below set limits

kilowatt load command is above set limits. Reference the customer/facility/installation documentation.

Go to 2A

Go to 4A

Guided Step 2 - Check the load cable harness connections.

Guided Step 2A - Inspect the alternator and the load harness connections.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the load cable harness from the alternator.

Action

Inspect the alternator and load cable harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged/corroded connections

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the load cable harness or the alternator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the load cable harness. Reference the site installation documentation.
  • Replace the load cable harness. Reference the site installation documentation.
  • Replace the alternator. Reference the site installation documentation.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the load cable harness from the alternator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the alternator pin on the load cable harness connector to all other pins on the load cable harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the load cable harness

  • Repair the load cable harness. Reference the site installation documentation.
  • Replace the load cable harness. Reference the site installation documentation.

Go to 3A

Go to 4A

Guided Step 3 - Check the alternator.

Guided Step 3A - Inspect the alternator for component failures.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the load cable harness from the alternator.

Action

Inspect the alternator's components for the following:

  • Broken or loose belt
  • Sufficient belt tension
  • Loose or corroded connections.
OK NOT OK

No visible damage

Alternator component malfunction. Reference the site installation documentation.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1461 is inactive.
OK NOT OK

Fault Code 1461 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes with the electronic service tool.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1462 - High Current on Ground

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Use INSITE™ electronic service tool to check for other active fault code(s). | No other fault codes active
STEP 2. | Check the ground. |
 | STEP 2A. Inspect ground connections. | No damaged connections
 | STEP 2B. Check ground connections. | Less than 10 ohms
 | STEP 2C. Check for add-on or accessory wiring at the ground location on the engine block. | No damaged wires
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1462 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Use INSITE™ electronic service tool to check for other active fault code(s).

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any circuit sharing a common electrical supply with the run relay contact.
OK NOT OK

No other fault codes active

Go to multiple fault tree.

Go to 2A

Multiple fault tree

Guided Step 2 - Check the ground.

Guided Step 2A - Inspect ground connections.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect all earth ground connections for the following:

  • Loose connector
  • Corroded connector
  • Damaged connector
  • Moisture in or on the connector
  • Dirt or debris in or on the connector.
OK NOT OK

No damaged connections

Repair or replace damaged connection. Reference the site installation documentation.

Go to 2B

Go to 3A

Guided Step 2B - Check ground connections.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check earth ground connections.

  • Measure the resistance from engine block ground to earth ground.
OK NOT OK

Less than 10 ohms

Repair or replace appropriate ground connector or harness. Reference the site installation documentation.

Go to 2C

Go to 2C

Guided Step 2C - Check for add-on or accessory wiring at the ground location on the engine block.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect add-on or accessory wiring at the ground location on the engine block for the following:

  • Loose connector
  • Corroded connector
  • Damaged connector
  • Moisture in or on the connector
  • Dirt or debris in or on the connector.
OK NOT OK

No damaged wires

Repair or replace damaged wires. Reference the site installation documentation.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1462 is inactive.
OK NOT OK

Fault Code 1462 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1463 - Generator Set Not in Auto

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Place generator in AUTO mode. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Place Generator in AUTO mode.

Conditions

The generator is in either OFF or MANUAL mode.

Action

No corrective action can be taken.

Fault code announces that the generator is in OFF or MANUAL mode to the LonWorks board.

The generator can not be remotely started.

OK NOT OK

Go to

Go to

Last Modified: 03-May-2012


FAULT CODE 1464 - Generator Set Load Dump

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Generator dropped because of an overload or under frequency. |

Guided Step 1 - Troubleshoot the fault code

Guided Step 1A - Generator dropped because of an overload or under frequency.

Conditions

Overload or under frequency has occurred.

Action

No corrective action can be taken with this fault code.

Generator announces to the LonWorks network that it has dropped load because of a overload or under frequency condition.
OK NOT OK

Go to

Go to

Last Modified: 03-May-2012


FAULT CODE 1465 - Generator Set Ready to Accept Load

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Generator is ready to accept load. |

Guided Step 1 - Troubleshoot the fault code

Guided Step 1A - Generator is ready to accept load.

Conditions

Generator is ready to accept load.

Action

No corrective action to be taken with this fault code.

The generator set announces to the LonWorks network that it is ready to accept load.
OK NOT OK

Go to

Go to

Last Modified: 03-May-2012


FAULT CODE 1466 - Modem-Lost Communication

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Use INSITE™ electronic service tool to check for other active fault code(s). | No other fault codes active
STEP 2. | Check modem. |
 | STEP 2A. Inspect modem connector pins. | No damaged pins
 | STEP 2B. Check modem for malfunctions. | No visible failures
STEP 3. | Check customer-supplied wiring. |
 | STEP 3A. Inspect customer-supplied wiring and engine control module terminal block posts. | No damaged connectors
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1466 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Use INSITE™ electronic service tool to check for other active fault code(s).

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any circuit sharing a common electrical supply with the run relay contact.
OK NOT OK

No other fault codes active

Go to multiple fault tree

Go to 2A

Multiple fault tree

Guided Step 2 - Check modem.

Guided Step 2A - Inspect modem connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect modem connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the modem line. Reference the site documentation.
  • Replace the modem lines. Reference the site documentation.
  • Replace the modem. Reference the site documentation.

Go to 2B

Go to 4A

Guided Step 2B - Check modem for malfunctions.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Inspect modem for malfunctions.

  • Check modem for external damage.
OK NOT OK

No visible failures

Repair or replace modem. Reference the site documentation.

Go to 3A

Go to 4A

Guided Step 3 - Check customer-supplied wiring.

Guided Step 3A - Inspect customer-supplied wiring and engine control module terminal block posts.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer-supplied wiring from the engine control module.

Action

Inspect the wiring and engine control module connectors for the following:

  • Corroded connector
  • Bent or broken connector
  • Moisture in or on the connector
  • Dirt or debris in or on the connector.
OK NOT OK

No damaged connectors

Repair or replace the customer-supplied wiring or replace the engine control module board, whichever has the damaged connector.

  • Flush the dirt, debris, or moisture from the connectors. Use electrical contact cleaner, Part Number 3824510.
  • Repair the customer-supplied wiring. Refer to Procedure 019-197 in Section 19.
  • Replace the customer-supplied wiring. Reference the site documentation.
  • Replace the generator set board. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1466 is inactive.
OK NOT OK

Fault Code 1466 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1468 - LonWorks Network-Lost Communication

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check LonWorks Network board. |
 | STEP 1A. Inspect LonWorks Network board for visible failures. | No burn marks or bent pins
 | STEP 1B. Inspect the LonWorks Network board connector pins. | No damaged pins
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1468 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the LonWorks Network board.

Guided Step 1A - Inspect the LonWorks Network board for visible failures.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible failures.

  • Burn marks or discoloration on the board.
  • Burn marks or discoloration on the board pins.
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the LonWorks Network board.

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 2A

Guided Step 1B - Inspect the LonWorks Network board connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the twisted pair customer wiring from TB6.

Action

Inspect the customer wiring and the terminal block for:

  • Bent or broken wires.
  • Pushed back or expanded posts.
  • Moisture in or on the connector.
  • Damaged terminal blocks.
OK NOT OK

No damaged pins

Repair or replace the twisted pair customer wiring. Reference the site documentation.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1468 is inactive.
OK NOT OK

Fault Code 1468 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1469 - Measure Speed vs AC Output Frequency

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check for active speed sensor fault codes. | No active fault codes
 | STEP 1B. Check for active AC output voltage fault codes. | No active fault codes
STEP 2. | Check for proper engine control module calibration. |
 | STEP 2A. Verify that the proper calibration has been loaded into the engine control module. | Control setup okay
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1469 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check for active speed sensor fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to check for active engine speed sensor fault codes.
OK NOT OK

No active fault codes

Troubleshoot active speed sensor fault codes. Go to appropriate fault code troubleshooting steps.

Go to 1B

Go to 3A

Guided Step 1B - Check for active AC output voltage fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to check for active AC output voltage fault codes.
OK NOT OK

No active fault codes

Troubleshoot active AC output voltage fault codes. Go to appropriate fault code troubleshooting steps.

Go to 2A

Go to 3A

Guided Step 2 - Check for proper engine control module calibration.

Guided Step 2A - Verify that the proper calibration has been loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to check to see that the control is set up with the correct number of flywheel teeth.
OK NOT OK

Control setup okay

Adjust control setup as necessary. Refer to INSITE™ electronic service tool manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1469 is inactive.
OK NOT OK

Fault Code 1469 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-May-2012


FAULT CODE 1471 - AC Output Current - High Warning

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurements: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the AC output current accuracy. |
 | STEP 1A. Verify the AC current at the alternator matches the AC current seen by the control. | Current sensing is OK
 | STEP 1B. Check the load. | No overload condition exists
STEP 2. | Check the output leads. |
 | STEP 2A. Inspect the alternator output leads. | No damaged/corroded posts
 | STEP 2B. Check for a short circuit from post to post. | More than 100k ohms
STEP 3. | Check the AC harness. |
 | STEP 3A. Check the AC harness and PT/CT board connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the PT/CT board. |
 | STEP 4A. Check the PT/CT board 3 ohm resistors. | 3 ohm resistors are good
 | STEP 4B. Inspect the PT/CT board and the generator control harness connector pins. | No damaged pins
STEP 5. | Check the generator control harness. |
 | STEP 5A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5D. Check for an open circuit. | Less than 10 ohms
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 1471 inactive
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the AC output current accuracy.

Guided Step 1A - Verify the AC current at the alternator matches the AC current seen by the control.

Conditions

  • Place the run/stop/auto switch in RUN position.
  • Connect INSITE™ electronic service tool.
  • Attach multimeter leads to alternator output leads.

Action

temp

Use a multimeter to read the L1, L2, and L3 current in INSITE™ electronic service tool and verify that they are constant with the current of the output leads.

OK NOT OK

Current sensing is OK

Problem is in the current sensing.

Go to 1B

Go to 4A

Guided Step 1B - Check the load.

Conditions

  • Place the run/stop/auto switch in RUN position.
  • Connect INSITE™ electronic service tool.

Action

Check the load.

  • Verify the load is within the generator set's operating range.
OK NOT OK

No overload condition exists

Check the load and load cables. Repair is necessary. Reference the site documentation.

Go to 2A

Go to 6A

Guided Step 2 - Check the output leads.

Guided Step 2A - Inspect the alternator and output leads.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the load cables from output leads.

Action

Check the load.

  • Corroded posts
  • Loose connections.
OK NOT OK

No damaged/corroded posts

Repair the damaged posts. Reference the site documentation.

Go to 2B

Go to 6A

Guided Step 2B - Check for a short circuit from post to post.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit from post to post.

  • Measure the resistance between each of the output leads.
OK NOT OK

More than 100k ohms

Repair or replace the alternator. Reference the site documentation.

Go to 3A

Go to 6A

Guided Step 3 - Check the AC harness.

Guided Step 3A - Check the AC harness and PT/CT board connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit from post to post.

Verify that all connections to the current transformers are correct.
OK NOT OK

Current transformers correct

Current transformer connections incorrect. Repair connections if necessary. Reference the site documentation.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the current transformers.
  • Disconnect the AC harness from the PT/CT board.

Action

Check for a short circuit from post to post.

  • Measure the resistance of each current transformer pin on the AC harness to engine block ground.
  • Repeat previous step for all other current transformer terminals.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the current transformers.
  • Disconnect the AC harness from the PT/CT board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between each pin in the AC harness connector 09.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the current transformers.
  • Disconnect the AC harness from the PT/CT board.

Action

Check for an open circuit in the AC harness.

  • Measure the resistance of each current transformer wire from one end of the harness to the other.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

Less than 10 ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the PT/CT board.

Guided Step 4A - Check the PT/CT board 3 ohm resistors.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check for an open circuit in the AC harness.

  • Measure the resistance of the CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance of the CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance of the CT23 pin on connector 08 and CT23 COM pin on connector 08.
OK NOT OK

3 ohm resistors are good

3 ohm resistor failed. Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the PT/CT board from the generator control harness.

Action

Inspect the PT/CT board and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-208 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the generator control harness.

Guided Step 5A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 5B

Go to 6A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each PT/CT pin on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for a short circuit from post to post.

  • Measure the resistance of each PT/CT pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the PT/CT board pins on the generator control harness PT/CT board connector to the aligned generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1471 is inactive.
OK NOT OK

Fault Code 1471 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1472 - AC Output Current - High Shutdown

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the AC output current accuracy. |
 | STEP 1A. Verify the AC output current was high by viewing the fault snapshot data. | AC output current was high
STEP 2. | Check the output leads. |
 | STEP 2A. Inspect the alternator output leads. | No damage/corroded posts
 | STEP 2B. Check for a short circuit from post to post | More than 100k ohms
STEP 3. | Check the current transformers. |
 | STEP 3A. Inspect the current transformers and current transformer connections. | CT connections correct
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3D. Check for an open circuit. | Less than 10 ohms
STEP 4. | Check the PT/CT board. |
 | STEP 4A. Check the PT/CT board 3 ohm resistors. | 3 ohm resistors are good
 | STEP 4B. Inspect the PT/CT board and the generator control harness connector pins. | No damaged pins
STEP 5. | Check the generator control harness. |
 | STEP 5A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5D. Check for an open circuit. | Less than 10 ohms
STEP 6. | Clear the fault codes |
 | STEP 6A. Disable the fault code | Fault Code 1472 inactive
 | STEP 6B. Clear the inactive fault codes | All fault codes cleared

Guided Step 1 - Check the AC output current accuracy.

Guided Step 1A - Verify the AC output current was high by viewing the fault snapshot data.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify the AC output current.

Use INSITE™ electronic service tool to verify the AC output current.
OK NOT OK

AC output current was high

AC output current was normal

Go to 2A

Go to 6A

Guided Step 2 - Check the output leads.

Guided Step 2A - Inspect the alternator output leads.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the load cables from output leads.

Action

Verify the AC output current.

  • Corroded posts
  • Loose connections.
OK NOT OK

No damaged/corroded posts

Repair the damaged posts. Reference the site documentation.

Go to 2B

Go to 6A

Guided Step 2B - Check for a short circuit from post to post.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit from post to post.

  • Measure the resistance between each of the output leads.
OK NOT OK

More than 100k ohms

Repair or replace the alternator. Reference the site documentation.

Go to 3A

Go to 6A

Guided Step 3 - Check the current transformers.

Guided Step 3A - Inspect the current transformers and current transformer connections.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit from post to post.

Verify that all connections to the current transformers are correct.
OK NOT OK

Current transformer connections correct

Current transformers incorrect. Repair connections if necessary. Reference the site documentation.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness to engine block ground.
  • Repeat previous step for all other current transformer terminals.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between each pin in the AC harness connector 09.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness from the current transformers.

Action

Check for an open circuit.

  • Measure the resistance of each current transformer wire from one end of the harness to the other.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

Less than 10 ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the PT/CT board.

Guided Step 4A - Check the PT/CT board 3 ohm resistors.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the generator control harness from the PT/CT board.

Action

Check for an open circuit.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.
OK NOT OK

3 ohms resistors are good

3 ohm resistor malfunctioned. Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the PT/CT board from the generator control harness.

Action

Inspect the PT/CT board and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-208 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the generator control harness.

Guided Step 5A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 5B

Go to 6A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each PT/CT pin on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for a short circuit from post to post.

  • Measure the resistance of each PT/CT pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D -

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the PT/CT board.
  • Disconnect the generator control harness from the engine control module paralleling board connector 04, if installed. If the paralleling board is not installed, disconnect the generator control harness from the engine control module generator set board connector 01.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the PT/CT board pins on the generator control harness PT/CT board connector to the aligned generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1472 is inactive.
OK NOT OK

Fault Code 1472 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1473 - Engine Control Module Internal Watchdog Test Has Failed

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Action

Attempt to reload the calibration engine control module.
OK NOT OK

The fault code cleared and engine operation is okay.

The fault code is still active after successfully reloading calibration.

Replace the engine control module.

Refer to Procedure 019-031 in Section 19.

Repair complete

Go to

Last Modified: 06-May-2012


FAULT CODE 1474 - Base Board - Extended I/O Software Mismatch

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the base board. |
 | STEP 1A. Inspect the base board for correct installation. | Correct installation
 | STEP 1B. Inspect the base board for visible damage. | No burn marks or bent pins
 | STEP 1C. Inspect the backplane board for visible damage. | No burn marks or bent pins
 | STEP 1D. Verify that the correct software calibration has been loaded into the base board. | Correct software calibration
STEP 2. | Check the extended I/O board. |
 | STEP 2A. Inspect the extended I/O board for correct installation. | Correct installation
 | STEP 2B. Inspect the extended I/O board for visible damage. | No burn marks or bent pins
 | STEP 2C. Verify that the correct software calibration has been loaded into the extended I/O board. | Correct software calibration
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1474 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the base board.

Guided Step 1A - Inspect the base board for correct installation.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board.

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 3A

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery last.
Guided Step 1B - Inspect the base board for visible damage.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect unswitched 24-VDC battery supply.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible damage.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the base board.

  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the backplane board for visible damage.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect unswitched 24-VDC battery supply.
  • Loosen screws and remove board from the card cage.

Action

Inspect Backplane board for visible failures.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the base board.

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1D

Go to 3A

Guided Step 1D - Verify that the correct software calibration has been loaded into the base board.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify the correct calibration has been loaded into the base board.
OK NOT OK

Correct software calibration

Incorrect software calibration. Load correct calibration software.

Go to 2A

Go to 3A

Guided Step 2 - Check the extended I/O board.

Guided Step 2A - Inspect the extended I/O board for correct installation.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board.

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the extended I/O board for visible damage.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect unswitched 24-VDC battery supply.
  • Loosen screws and remove board from the card cage.

Action

Inpsect board for visible failures.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the extended I/O board.

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 2C

Go to 3A

Guided Step 2C - Verify that the correct software calibration has been loaded into the extended I/O board.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect unswitched 24-VDC battery supply.
  • Connect INSITE™ electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct software calibration

Incorrect software calibration. Load correct calibration software.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1474 is inactive.
OK NOT OK

Fault Code 1474 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1475 - Permission to Connect - Not Received

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the paralleling controller. |
 | STEP 1A. Inspect the paralleling controller connector pins. | No damaged pins
 | STEP 1B. Check the paralleling controller for malfunctions. | Input device is not experiencing any malfunctions
STEP 2. | Check the customer paralleling harness. |
 | STEP 2A. Inspect the customer paralleling harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2D. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1475 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the paralleling controller.

Guided Step 1A - Inspect the paralleling controller connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer paralleling harness from the paralleling controller.

Action

Inspect the harness and the controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the customer paralleling harness or the paralleling controller, whichever has the damaged pins.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the customer paralleling harness. Reference the site installation document and paralleling controller document procedures.
  • Replace the customer paralleling harness. Reference the site installation document and paralleling controller document procedures.
  • Replace the paralleling controller. Reference the paralleling controller document procedures.

Go to 1B

Go to 3A

Guided Step 1B - Check the paralleling controller for malfunctions.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer paralleling harness from the paralleling controller.

Action

Use the paralleling controller's user manual and service tools.

  • Verify that the paralleling controller is functioning normally.
  • Verify the master first start sensor is functioning normally.
OK NOT OK

Input device is not experiencing any malfunctions

Repair or replace the paralleling controller.

  • Repair paralleling controller. Reference the paralleling controller document procedures.
  • Replace paralleling controller. Reference the paralleling controller document procedures.

Go to 2A

Go to 3A

Guided Step 2 - Check the customer paralleling harness.

Guided Step 2A - Inspect the customer paralleling harness and the TB3 connections.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer paralleling harness from TB3.

Action

Inspect the customer paralleling harness and the TB3 connections for the following:

  • Loose wiring
  • Incorrect wiring
  • Frayed or kinked wires.
OK NOT OK

No damaged connections

Repair the bad connections. Repair or replace the customer paralleling harness or TB3, whichever has the bad connections.

  • Repair the customer paralleling harness. Reference the site installation document and paralleling controller document procedures.
  • Replace the customer paralleling harness. Reference the site installation document and paralleling controller document procedures.
  • Replace TB3. Refer to Procedure 019-321.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer paralleling harness from TB3.
  • Disconnect the customer paralleling harness from the paralleling controller.

Action

Check for an open circuit.

  • Measure the resistance from the synchronization enable wire on the customer paralleling harness connector to the synchronization enable wire on the paralleling controller connector.
  • Measure the resistance from the first start enable wire on the customer paralleling harness connector to the first start enable wire on the paralleling controller connector.
OK NOT OK

Less than 10 ohms

Repair or replace the customer paralleling harness.

  • Repair the customer paralleling harness. Reference the site installation document and paralleling controller document procedures.
  • Replace the customer paralleling harness. Reference the site installation document and paralleling controller document procedures.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer paralleling harness from TB3.
  • Disconnect the customer paralleling harness from the paralleling controller.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the synchronization enable wire on the customer paralleling harness connector to all other pins on the customer paralleling harness connector.
  • Measure the resistance from the first start enable wire on the customer paralleling harness connector to all other pins on the customer paralleling harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the customer paralleling harness.

  • Repair the customer paralleling harness. Reference the site installation document and paralleling controller document procedures.
  • Replace the customer paralleling harness. Reference the site installation document and paralleling controller document procedures.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer paralleling harness from TB3.
  • Disconnect the customer paralleling harness from the paralleling controller.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the synchronization enable wire on the customer paralleling harness connector to the engine block ground.
  • Measure the resistance from the first start enable wire on the customer paralleling harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the customer paralleling harness.

  • Repair the customer paralleling harness. Reference the site installation document and paralleling controller document procedures.
  • Replace the customer paralleling harness. Reference the site installation document and paralleling controller document procedures.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1475 is inactive.
OK NOT OK

Fault Code 1475 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1476 - Base Board - Not Responding to LonWorks Board

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the base board. |
 | STEP 1A. Inspect the base board for correct installation. | Correct installation
 | STEP 1B. Inspect the base board for visible damage. | No burn marks or bent pins
 | STEP 1C. Inspect the backplane board for visible damage. | No burn marks or bent pins
STEP 2. | Check the LonWorks Network board. |
 | STEP 2A. Inspect the LonWorks Network board for correct installation. | Correct installation
 | STEP 2B. Inspect the LonWorks Network board for visible damage. | No burn marks or bent pins
STEP 3. | Check the software calibration. |
 | STEP 3A. Verify that the correct software calibration has been loaded into the engine control module. | Correct software calibration
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1476 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the base board.

Guided Step 1A - Inspect the base board for correct installation.

Conditions

  • Run/Stop switch in Stop position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct installation

Remove and reset board.

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the base board for visible damage.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect unswitched 24-VDC battery supply.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible damage.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the base board.

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 1C

Go to 4A

Guided Step 1C - Inspect the backplane board for visible damage.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect unswitched 24-VDC battery supply.
  • Loosen screws and remove board from the card cage.

Action

Inspect Backplane board for visible damage.

  • Burn marks or discoloration on the backplane board
  • Burn marks or discoloration on the backplane board pins
  • Bent backplane board pins.
OK NOT OK

No burn marks or bent pins

Replace the backplane board.

  • Loosen screws and slip board out of the backplane board.
  • Replace backplane board.
  • Insert board into the backplane board and tighten screws.

Go to 2A

Go to 4A

Guided Step 2 - Check the LonWorks Network board.

Guided Step 2A - Inspect the LonWorks Network board for correct installation.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect board for correct installation.

  • Verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.
OK NOT OK

Correct software installation

Remove and reset board.

  • Loosen screws and slip board out of the backplane board.
  • Replace board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the LonWorks Network board for visible damage.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect unswitched 24-VDC battery supply.
  • Loosen screws and remove board from the card cage.

Action

Inspect board for visible damage.

  • Burn marks or discoloration on the board
  • Burn marks or discoloration on the board pins
  • Bent board pins.
OK NOT OK

No burn marks or bent pins

Replace the LonWorks Network board.

  • Loosen screws and slip board out of the backplane board.
  • Insert replacement board and verify board is sitting fully into the backplane board.
  • Verify screws are firmly tightened.

Go to 3A

Go to 4A

Guided Step 3 - Check the software calibration.

Guided Step 3A - Verify that the correct software calibration has been loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the electronic service tool.

Action

Read the software calibration.

  • Use INSITE™ electronic service tool to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct software calibration

Incorrect software calibration. Load correct calibration software.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1476 is inactive.
OK NOT OK

Fault Code 1476 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1477 - Crank Relay Contact Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check for active Fault Code 1478. | Fault Code 1478 inactive
STEP 2. | Test for proper engine cranking. |
 | STEP 2A. Verify engine will crank. | Engine will crank
STEP 3. | Check the crank relay. |
 | STEP 3A. Inspect the crank relay and the generator control harness connection pins. | No damaged pins
 | STEP 3B. Check the crank relay contacts for proper operation. | Less than 10 ohms
STEP 4. | Check the generator control harness. |
 | STEP 4A. Inspect the generator control harness and the extension harness connector pins. | No damaged pins
 | STEP 4B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 4D. Check for an open circuit. | Less than 10 ohms
STEP 5. | Check the extension harness. |
 | STEP 5A. Inspect the extension harness and the engine harness connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 5D. Check for an open circuit. | Less than 10 ohms
STEP 6. | Check the engine harness and Inline E connector. |
 | STEP 6A. Inspect the engine harness and crank slave relay posts. | No damaged pins
 | STEP 6B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 6C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 6D. Check for an open circuit. | Less than 10 ohms
STEP 7. | Check the battery harness and Inline E connector. |
 | STEP 7A. Inspect the battery harness and crank slave relay posts. | No damaged pins
 | STEP 7B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 7C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 7D. Check for an open circuit. | Less than 10 ohms
STEP 8. | Check the crank slave relay. |
 | STEP 8A. Check the crank slave relay contacts for proper operation. | More than 18-VDC
STEP 9. | Clear the fault codes. |
 | STEP 9A. Disable the fault code. | Fault Code 1477 inactive
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check for active Fault Code 1478.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to check for active Fault Code 1478.
OK NOT OK

Fault Code 1478 inactive

Fault Code 1478 active. Replace the base board. Refer to Procedure 019-322 in Section 19.

Go to 2A

Go to 9A

Guided Step 2 - Test for proper engine cranking.

Guided Step 2A - Verify engine will crank.

Conditions

  • Place the run/stop/auto switch in RUN position.

Action

Crank the engine.

Check the engine.
OK NOT OK

Engine will crank

Engine will not crank

Go to 5A

Go to 3A

Guided Step 3 - Check the crank relay.

Guided Step 3A - Inspect the crank relay and the generator control harness connection pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the crank relay.
  • Crank the engine.

Action

Inspect the crank relay and the generator control harness connection pins:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-197 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the crank relay.

Go to 3B

Go to 9A

Guided Step 3B - Check the crank relay contacts for proper operation.

Conditions

  • Place the run/stop/auto switch in RUN position.
  • Disconnect crank signal and crank supply wires from crank relay.

Action

Check the crank relay for correct operation.

While attempting to start the generator set, measure the resistance across the crank supply contact and crank signal contact on the crank relay.

OK NOT OK

Less than 10 ohms

Replace crank relay

Go to 4A

Go to 9A

Guided Step 4 - Check the generator control harness.

Guided Step 4A - Inspect the generator control harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the crank relay.
  • Disconnect the engine harness from the extension harness.

Action

Check the crank relay for correct operation.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4B

Go to 9A

Guided Step 4B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the crank relay contact.
  • Disconnect the generator control harness from the extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the crank SIGNAL pin on the generator control harness Inline D connector to engine block ground.
  • Measure the resistance from the crank SUPPLY pin on the generator control harness Inline D connector to engine block ground.
OK NOT OK

More than 100k ohms

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4C

Go to 9A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the crank relay contact.
  • Disconnect the generator control harness from the extension harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the crank SIGNAL pin on the generator control harness Inline D connector to all other pins on the connector.
  • Measure the resistance from the crank SUPPLY pin on the generator control harness Inline D connector to all other pins on the connector.
OK NOT OK

More than 100k ohms

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4D

Go to 9A

Guided Step 4D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the crank relay contact.
  • Disconnect the generator control harness from the extension harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the crank SIGNAL pin on the generator control harness Inline D connector to the crank signal wire on the generator control harness crank relay connector.
  • Measure the resistance from the crank SUPPLY pin on the generator control harness Inline D connector to the crank supply wire on the generator control harness crank relay connector.
OK NOT OK

Less than 10 ohms

  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the extension harness.

Guided Step 5A - Inspect the extension harness and the engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the Inline D.
  • Disconnect the extension harness from the engine control module.

Action

Check for an open circuit in the return wire.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5B

Go to 9A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the crank relay contact.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the crank SIGNAL pin on the extension harness Inline C connector to engine block ground.
  • Measure the resistance from the crank status pin on the extension harness Inline A connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5C

Go to 9A

Guided Step 5C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the crank relay contact.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the crank SIGNAL pin on the extension harness Inline C connector to all other pins on the extension harness inline connector.
  • Measure the resistance from the crank status pin on the extension harness Inline A connector to all other pins on the extension harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 5D

Go to 9A

Guided Step 5D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the crank relay contact.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the crank SIGNAL pin on the extension harness Inline C connector to crank SIGNAL pin on the extension harness Inline D connector.
  • Measure the resistance from the crank status pin on the extension harness Inline A connector to crank status pin on the extension harness engine control module connector 05.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the engine harness and Inline E connector.

Guided Step 6A - Inspect the engine harness and crank slave relay posts.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the Inline E.

Action

Check for an open circuit in the return wire.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the battery harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.

Go to 6B

Go to 9A

Guided Step 6B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the battery harness

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the crank SIGNAL pin on the engine harness side (male pins) of Inline E to engine block ground.
  • Measure the resistance from the crank status pin on the engine harness side (male pins) of Inline E to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.
  • Repair the battery harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.

Go to 6C

Go to 9A

Guided Step 6C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the crank relay contact.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the crank SIGNAL pin on the engine harness side (male pins) of Inline E to all other pins in the connector.
  • Measure the resistance from the crank status pin on the engine harness side (male pins) of Inline E to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-175 in Section 19.

Go to 6D

Go to 9A

Guided Step 6D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the crank relay contact.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the crank SIGNAL pin on the engine harness side (male pins) of Inline E to the crank SIGNAL pin on the engine harness Inline C connector.
  • Measure the resistance from the crank status pin on the engine harness side (male pins) of Inline E to the crank SIGNAL pin on the engine harness Inline A connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 7A

Go to 9A

Guided Step 7 - Check the battery harness and Inline E connector.

Guided Step 7A - Inspect the battery harness and crank slave relay posts.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the battery harness from the Inline E.

Action

Check for an open circuit in the return wire.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the battery harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.

Go to 7B

Go to 9A

Guided Step 7B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the battery harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the crank SIGNAL pin on the battery harness side (female pins) of Inline E to engine block ground.
  • Measure the resistance from the crank status pin on the battery harness side (female pins) of Inline E to engine block ground.
OK NOT OK

More than 100k ohms

Repair the battery harness. Refer to Procedure 019-197 in Section 19.

Go to 7C

Go to 9A

Guided Step 7C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the crank relay contact.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the crank SIGNAL pin on the battery harness side (female pins) of Inline E to all other pins in the connector.
  • Measure the resistance from the crank status pin on the battery harness side (female pins) of Inline E to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair the battery harness. Refer to Procedure 019-197 in Section 19.

Go to 7D

Go to 9A

Guided Step 7D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the battery harness from the crank relay contact.
  • Disconnect the battery harness from Inline E.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the crank SIGNAL pin on the battery harness side (female pins) of Inline E to the crank signal wire on the battery harness crank slave relay terminal.
  • Measure the resistance from the crank status pin on the engine harness side (male pins) of Inline E to the crank SIGNAL pin on the engine harness Inline A connector.
OK NOT OK

Less than 10 ohms

Repair the battery harness. Refer to Procedure 019-197 in Section 19.

Go to 8A

Go to 9A

Guided Step 8 - Check the crank slave relay.

Guided Step 8A - Check the crank slave relay contacts for proper operation.

Conditions

  • Disconnect the crank status wire from the crank slave relay.
  • Place the off/manual/auto switch in MANUAL position.
  • Place the run/stop/auto switch in RUN position.

Action

While attempting to start the generator set, measure the voltage at the crank status post on the crank slave relay.

While attempting to start the generator set, measure the voltage at the crank status post on the crank slave relay.
OK NOT OK

More than 18-VDC

Replace crank slave relay

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1477 is inactive.
OK NOT OK

Fault Code 1477 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1478 - Crank Relay Driver Diagnostic

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Troubleshoot all other fault codes first. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Troubleshoot all other fault codes first.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in STOP position.

Action

Use INSITE™ electroinc service to troubleshoot all other fault codes first.

If fault code 1478 does not become inactive, the engine control module has determined the crank relay on the base driver board has failed.

OK NOT OK

Replace the base board.

Go to

Go to

Last Modified: 06-May-2012


FAULT CODE 1479 - Fail-To-Start Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fail-to-start relay. |
 | STEP 1A. Check for correct operation of the fail-to-start relay. | Relay functions normally
STEP 2. | Check for multiple fault codes. |
 | STEP 2A. Read the fault codes. | Fault Codes 1425, 1426,1427, 1428, 1429, 1431, and 1432 are not active
STEP 3. | Check the generator interface harness. |
 | STEP 3A. Inspect the generator interface harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1479 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fail-to-start relay.

Guided Step 1A - Check for correct operation of the fail-to-start relay.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for correct operation of the fail-to-start relay.

  • Use INSITE™ electronic service tool fault simulation feature to command a fail-to-start.
OK NOT OK

Relay functions normally

Replace relay. Reference the site documentation.

Go to 2A

Go to 4A

Guided Step 2 - Check for multiple fault codes.

Guided Step 2A - Read the fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 1425, 1426, 1427, 1428, 1429, 1431, and 1432 are not active

If all the fault codes are active, go to Fault Code 1424

Go to 3A

Go to 4A

Guided Step 3 - Check the generator interface harness.

Guided Step 3A - Inspect the generator interface harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.

Action

Inspect the generator interface harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the engine block ground.
  • Measure the resistance from the fail-to-start pin at the generator interface harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for an open circuit.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to the relay driver SUPPLY pin at the relay connector.
  • Measure the resistance from the fail-to-start pin at the generator interface harness connector to the fail-to-start pin at the relay connector.
OK NOT OK

Less than 10 ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator interface harness from the engine control module.
  • Disconnect the relay from the generator interface harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the relay driver SUPPLY pin at the generator interface harness connector to all other pins in the generator interface harness.
  • Measure the resistance from the fail-to-start pin at the generator interface harness connector to all other pins in the generator interface harness.
OK NOT OK

More than 100k ohms

Repair or replace the generator interface harness.

  • Repair the generator interface harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator interface harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1479 is inactive.
OK NOT OK

Fault Code 1479 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1481 - Voltage Regulator Drive Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the voltage regulator. |
 | STEP 1A. Inspect the voltage regulator connector pins. | No damaged pins
 | STEP 1B. Check the voltage regulator for malfunctions. | No visible malfunctions
STEP 2. | Check the generator control harness. |
 | STEP 2A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1481 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the voltage regulator.

Guided Step 1A - Inspect the voltage regulator connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the voltage regulator.

Action

Inspect the harness and the controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the voltage regulator for malfunctions.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Verify the voltage regulator has not malfunctioned.

  • No burn marks
  • No bent or broken connectors.
OK NOT OK

No visible malfunctions

Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module connector pins.

Action

Inspect the generator control harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the base board. Refer to Procedure 019-322 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the voltage regulator.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the voltage regulator SUPPLY pin on the generator control harness connector to engine block ground.
  • Measure the resistance from the voltage regulator RETURN pin on the generator control harness connector to engine block ground.
  • Measure the resistance from the voltage regulator SIGNAL pin on the generator control harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the voltage regulator.

Action

Check for an open circuit in the supply wire.

  • Measure the resistance from the voltage regulator SUPPLY pin on the generator control harness connector to the voltage regulator SUPPLY pin on the generator control harness controller connector.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the voltage regulator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the voltage regulator SUPPLY pin on the generator control harness connector to all other pins on the generator control harness connector.
  • Measure the resistance from the voltage regulator RETURN pin on the generator control harness connector to all other pins on the generator control harness connector.
  • Measure the resistance from the voltage regulator SIGNAL pin on the generator control harness connector to all other pins on the generator control harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1481 is inactive.
OK NOT OK

Fault Code 1481 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1483 - One or More Fault Codes Have Not Been Acknowledged

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Acknowledge all fault codes. |

Guided Step 1 - Troubleshoot the fault codes.

Guided Step 1A - Acknowledge all fault codes.

Conditions

Refer to the specific troubleshooting steps for the fault codes.

Action

Acknowledge all fault codes.

The generator announces to the LonWorks network that some fault codes have not been acknowledged by the operator.

OK NOT OK

Go to

Go to

Last Modified: 06-May-2012


FAULT CODE 1485 - Electronic Fuel Control Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic fuel control. |
 | STEP 1A. Inspect the electronic fuel control connector pins. | No damaged pins
 | STEP 1B. Check the electronic fuel control for malfunctions. | No visible malfunctions
STEP 2. | Check the generator control harness. |
 | STEP 2A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1485 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the electronic fuel control.

Guided Step 1A - Inspect the electronic fuel control connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the electronic fuel control.

Action

Inspect the harness and the electronic fuel control pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the generator control harness or the electronic fuel control, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Reference the site documentation.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the electronic fuel control. Reference the site documentation.

Go to 1B

Go to 3A

Guided Step 1B - Check the electronic fuel control for malfunctions.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the electronic fuel control.

  • Check for any visible malfunctions.
OK NOT OK

No visible failures

Replace the electronic fuel control. Reference the site documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the generator control harness or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Reference the site documentation.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the electronic fuel control pin on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Reference the site documentation.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the electronic fuel control.

Action

Check for an open circuit in the harness.

  • Measure the resistance from electronic fuel control pin on the generator control harness control connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Reference the site documentation.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the electronic fuel control.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the electronic fuel control pin on the generator control harness engine control module connector to all other pins on the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Reference the site documentation.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1485 is inactive.
OK NOT OK

Fault Code 1485 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1486 - Electronic Fuel Control Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a newengine control module board, all other active fault codes must be investigated prior to replacing theengine control module board.To avoid pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - AMP™/Metri-Pack™ male test leadPart Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic fuel control. |
 | STEP 1A. Inspect the electronic fuel control connector pins. | No damaged pins
 | STEP 1B. Check the electronic fuel control for malfunctions. | No visible malfunctions
STEP 2. | Check the generator control harness. |
 | STEP 2A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1486 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the electronic fuel control.

Guided Step 1A - Inspect the electronic fuel control connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the electronic fuel control.

Action

Inspect the harness and the electronic fuel control pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the generator control harness or the electronic fuel control, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Reference the site documentation.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the electronic fuel control. Reference the site documentation.

Go to 1B

Go to 3A

Guided Step 1B - Check the electronic fuel control for malfunctions.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the electronic fuel control.

  • Check for any visible malfunctions.
OK NOT OK

No visible malfunctions

Replace the electronic fuel control. Reference the site documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the generator control harness or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Reference the site documentation.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the electronic fuel control.

Action

Check for an open circuit in the harness.

  • Measure the resistance from electronic fuel control pin on the generator control harness control connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Reference the site documentation.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the electronic fuel control.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the electronic fuel control pin on the generator control harness engine control module connector to all other pins on the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Reference the site documentation.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1486 is inactive.
OK NOT OK

Fault Code 1486 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1487 - Not in Auto LED Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the switch panel. |
 | STEP 1A. Check the switch panel for correct operation. | Switch panel working correctly
 | STEP 1B. Inspect the switch panel and the generator control harness connector pins. | No damaged pins
STEP 2. | Check the generator control harness. |
 | STEP 2A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1487 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the switch panel.

Guided Step 1A - Check the switch panel for correct operation.

Conditions

  • Place the off/manual/auto switch in AUTO mode.
  • Connect INSITE™ electronic service tool.

Action

Verify switch panel for correct operation.

  • Use INSITE™ electronic service tool to verify correct operation.
OK NOT OK

Switch panel working correctly

Switch panel not working correctly. Replace switch panel. Refer to Procedure 019-314 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the switch panel and the generator control harness connector pins.

Conditions

  • Place the off/manual/auto switch in AUTO mode.
  • Disconnect the generator control harness from the switch panel.

Action

Inspect the switch panel and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-208 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the off/manual/auto switch in AUTO mode.
  • Disconnect the generator control harness from the switch panel.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the off/manual/auto switch in AUTO mode.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the operator interface panel power on pin on the generator control harness connector 01 to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the off/manual/auto switch in AUTO mode.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from the operator interface panel power on pin on the operator panel connector 21 to the operator interface panel power on pin on the generator control harness connector 01.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the off/manual/auto switch in AUTO mode.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the switch panel pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN mode and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1487 is inactive.
OK NOT OK

Fault Code 1487 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the off/manual/auto switch in AUTO mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1488 - Warning LED Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the warning LED. |
 | STEP 1A. Check the bulb for the warning lamp. | Bulb is good
STEP 2. | Check the switch panel. |
 | STEP 2A. Check the switch panel for correct operation | Switch panel working correctly
 | STEP 2B. Inspect the switch panel and the generator control harness connector pins. | No damaged pins
STEP 3. | Check the generator control harness. |
 | STEP 3A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1488 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the warning LED.

Guided Step 1A - Check the bulb for the warning lamp.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check the warning lamp bulb.

  • Verify if bulb is good.
OK NOT OK

Bulb is good

Bulb is bad. Replace switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the switch panel.

Guided Step 2A - Check the switch panel for correct operation.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify operator interface panel for correct operation.

  • Use INSITE™ electronic service tool to verify correct operation.
OK NOT OK

Switch panel working correctly

Replace switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the switch panel and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.

Action

Inspect the switch panel and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-208 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the generator control harness.

Guided Step 3A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the switch panel on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from switch panel pins on the generator control harness board connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the switch panel pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1488 is inactive.
OK NOT OK

Fault Code 1488 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1489 - Shutdown LED Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the shutdown LED. |
 | STEP 1A. Check the shutdown lamp bulb. | Bulb is good
STEP 2. | Check the switch panel. |
 | STEP 2A. Check the switch panel for correct operation. | Switch panel working correctly
 | STEP 2B. Inspect the switch panel and the generator control harness connector pins | No damaged pins
STEP 3. | Check the generator control harness. |
 | STEP 3A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1489 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the shutdown LED.

Guided Step 1A - Check the shutdown lamp bulb.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check the shutdown lamp bulb.

  • Verify if bulb is good.
OK NOT OK

Bulb is good

Bulb is bad. Replace switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the switch panel.

Guided Step 2A - Check the switch panel for correct operation.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify switch panel for correct operation.

  • Use INSITE™ electronic service tool to verify correct operation.
OK NOT OK

Switch panel working correctly

Switch panel not working correctly. Replace switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the switch panel and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.

Action

Inspect the switch panel and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-208 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the generator control harness.

Guided Step 3A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the switch panel on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100K ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for an open circuit in the harness.

  • Measure the resistance from switch panel pins on the generator control harness board connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the switch panel pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100K ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1489 is inactive.
OK NOT OK

Fault Code 1489 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1491 - Ready to Load Output Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the output post. |
 | STEP 1A. Inspect the output post for damage or corrosion. | No damage or corrosion
 | STEP 1B. Check the wires connected to the output post for shorts. | All wires connected correctly
STEP 2. | Check the generator control harness. |
 | STEP 2A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1491 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the output post.

Guided Step 1A - Inspect the output post for damage or corrosion.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the output post for damage or corrosion.

Inspect the output post for damage or corrosion,
OK NOT OK

No damage or corrosion

Repair or replace the output post. Reference the site installation documentation.

Go to 1B

Go to 3A

Guided Step 1B - Check the wires connected to the output post for shorts.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the wires connected to the output post for shorts.

Inspect the wires connected to the output post for shorts.
OK NOT OK

All wires connected correctly

Wires connected incorrectly.

  • Reference the the appropriate wiring diagram for correct wire connections.
  • Repair or replace any damaged wires. Reference the site installation documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the load output relay driver connector on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the operator interface panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from operator interface panel pins on the generator control harness board connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the operator interface panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the operator interface panel pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1491 is inactive.
OK NOT OK

Fault Code 1491 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1492 - Load Dump Output Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check output post. |
 | STEP 1A. Inspect output post for damage or corrosion. | No damage or corrosion
 | STEP 1B. Check the wires connected to the output post for shorts. | All wires connected correctly
STEP 2. | Check generator control harness. |
 | STEP 2A. Inspect generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1492 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault cleared

Guided Step 1 - Check the output post.

Guided Step 1A - Inspect the output post for damage or corrosion.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the output post for damage or corrosion.

Inspect the output post for damage or corrosion.
OK NOT OK

No damage or corrosion

Repair or replace the output post. Reference the site installation documentation.

Go to 1B

Go to 3A

Guided Step 1B - Check the wires connected to the output post for shorts.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the wires connected to the output post for shorts.

Inspect the wires connected to the output post for shorts.
OK NOT OK

All wires connected correctly

Wires connected incorrectly.

  • Reference the the appropriate wiring diagram for correct wire connections.
  • Repair or replace any damaged wires. Reference the site installation documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the load output relay driver connector on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the operator interface panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from operator interface panel pins on the generator control harness board connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the operator interface panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the operator interface panel pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1492 is inactive.
OK NOT OK

Fault Code 1492 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1493 - Operator Interface Panel Power Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - AMP™/Metri-Pack™ male test lead and Part Number 3822917 - AMP™/Metri-Pack™ female test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the operator interface panel. |
 | STEP 1A. Check the operator interface panel for correct operation. | Operating correctly
 | STEP 1B. Inspect the operator interface panel and the generator control harness connector pins. | No damaged pins
STEP 2. | Check the generator control harness. |
 | STEP 2A. Check the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1493 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the operator interface panel.

Guided Step 1A - Check the operator interface panel for correct operation.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify operator interface panel for correct operation.

  • Use INSITE™ electronic service tool to verify correct operation.
OK NOT OK

Operating correctly

Operating correctly. Replace operator interface panel. Refer to Procedure 019-314 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the operator interface panel and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the operator interface panel.

Action

Inspect the operator interface panel and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-207 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the operator interface panel. Refer to Procedure 019-314 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the operator interface panel.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair or replace the generator control harness or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the operator interface panel. Refer to Procedure 019-314 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the operator interface panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the operator interface panel on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the operator interface panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from operator interface panel pins on the generator control harness board connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the operator interface panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the operator interface panel pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1493 is inactive.
OK NOT OK

Fault Code 1493 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-May-2012


FAULT CODE 1494 - Modem Power Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the modem. |
 | STEP 1A. Inspect modem connector pins. | No damaged pins
 | STEP 1B. Check the modem for malfunctions. | No visible malfunctions.
STEP 2. | Check the generator control harness. |
 | STEP 2A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1494 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check modem.

Guided Step 1A - Inspect the modem connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect modem connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the modem. Reference the site documentation.
  • Repair the modem power wire. Reference the site documentation.

Go to 1B

Go to 3A

Guided Step 1B - Check the modem for malfunctions.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Inspect the modem for malfunctions.

  • Check the modem for external damage.
OK NOT OK

No visible malfunctions

Repair or replace the modem. Reference the site documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the modem.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Reference the site documentation.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the relay driver supply.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the relay driver supply wire on generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the relay driver supply.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from the relay driver supply wire on generator control harness engine control module connector to the relay driver supply wire on generator control harness modem connector.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the relay driver supply.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the relay driver supply wire on generator control harness engine control module connector to all other pins.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1494 is inactive.
OK NOT OK

Fault Code 1494 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 1495 - Common Shutdown Output Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board.To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check output post. |
 | STEP 1A. Inspect output post for damage or corrosion. | No damage or corrosion
 | STEP 1B. Check wires connected to the output post for shorts. | All wires connected correctly
STEP 2. | Check the generator control harness. |
 | STEP 2A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1495 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the output post.

Guided Step 1A - Inspect the output post for damage or corrosion.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the output post for damage or corrosion.

Inspect the output post for damage or corrosion.
OK NOT OK

No damage or corrosion

Repair or replace the output post. Reference the site installation documentation.

Go to 1B

Go to 3A

Guided Step 1B - Check the wires connected to the output post for shorts.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Inspect the wires connected to the output post for shorts.

Inspect the wires connected to the output post for shorts.
OK NOT OK

All wires connected correctly

Wires connected incorrectly.

  • Reference the the appropriate wiring diagram for correct wire connections.
  • Repair or replace any damaged wires. Reference the site installation documentation.

Go to 2A

Go to 3A

Guided Step 2 - Check the generator control harness.

Guided Step 2A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the load output relay driver connector on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the operator interface panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from operator interface panel pins on the generator control harness board connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the operator interface panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the operator interface panel pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1495 is inactive.
OK NOT OK

Fault Code 1495 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 1496 - Auto Mode Output Relay Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify proper operation. |
 | STEP 1A. Check for voltage when in AUTO mode. | 17.3 to 34.7-VDC
STEP 2. | Check the customer wiring. |
 | STEP 2A. Inspect the customer wiring and the terminal blocks on TB4. | No damaged wires
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for a short circuit from wire to wire. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1496 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Verify proper operation.

Guided Step 1A - Check for voltage when in AUTO mode.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer wiring from TB4.

Action

Check for B positive (+) voltage when in AUTO mode.

  • While in AUTO mode, measure the voltage from the AUTO mode terminal on TB4 to ground
OK NOT OK

17.3 to 34.7-VDC (24-VDC system)

Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the customer wiring.

Guided Step 2A - Inspect the customer wiring and the terminal blocks on TB4.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer wiring from TB4.

Action

Check for B positive (+) voltage when in AUTO mode.

  • Frayed or kinked wires
  • Loose connections
  • Incorrect wiring.
OK NOT OK

No damaged wires

Repair or replace the damaged wires. Repair or replace the damaged wires or replace the TB4, whichever has the damage.

  • Repair the customer wiring. Reference the site documentation.
  • Replace the customer wiring. Reference the site documentation.
  • Replace TB4. Refer to Procedure 019-320 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer wiring from TB4.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the AUTO mode wire on the customer wiring to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the customer wiring.

  • Repair the customer wiring. Reference the site documentation.
  • Replace the customer wiring. Reference the site documentation.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from wire to wire.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the customer wiring from TB4.

Action

Check for a short circuit from wire to wire.

  • Measure the resistance from the AUTO mode wire on the customer wiring to all other customer wires.
OK NOT OK

More than 100k ohms

Repair or replace the customer wiring.

  • Repair the customer wiring. Reference the site documentation.
  • Replace the customer wiring. Reference the site documentation.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1496 is inactive.
OK NOT OK

Fault Code 1496 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 1497 - Manual Run/Stop LED Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check Manual Run/Stop LED. |
 | STEP 1A. Check for the Manual Run/Stop LED. | LED is good
STEP 2. | Check the switch panel. |
 | STEP 2A. Check the switch panel for correct operation. | Operating correctly
 | STEP 2B. Inspect the switch panel and the generator control harness connector pins. | No damaged pins
STEP 3. | Check the generator control harness. |
 | STEP 3A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1497 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check Manual Run/Stop LED.

Guided Step 1A - Check for the Manual Run/Stop LED.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check the Manual Run/Stop LED.

  • Verify if LED is good.
OK NOT OK

LED is good

LED is bad. Replace switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the switch panel.

Guided Step 2A - Check the switch panel for correct operation.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify switch panel for correct operation.

  • Use INSITE™ electronic service tool to verify correct operation.
OK NOT OK

Operating correctly

Operating correctly. Replace switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the switch panel and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.

Action

Inspect the switch panel and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the generator control harness.

Guided Step 3A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the switch panel on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from switch panel pins on the generator control harness board connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the switch panel pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1497 is inactive.
OK NOT OK

Fault Code 1497 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 1498 - Exercise LED Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check Exercise LED. |
 | STEP 1A. Check for the Exercise LED. | LED is good
STEP 2. | Check the switch panel. |
 | STEP 2A. Check switch panel for correct operation. | Operating correctly
 | STEP 2B. Inspect the switch panel and the generator control harness connector pins. | No damaged pins
STEP 3. | Check the generator control harness. |
 | STEP 3A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1498 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check Exercise LED.

Guided Step 1A - Check for the Exercise LED.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check the Exercise LED.

  • Verify if LED is good.
OK NOT OK

LED is good

LED is bad. Replace LED. Reference the site installation documentation.

Go to 2A

Go to 4A

Guided Step 2 - Check the switch panel.

Guided Step 2A - Check the switch panel for correct operation.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Check the Exercise LED.

  • Use INSITE™ electronic service tool to verify correct operation.
OK NOT OK

Operating correctly

Operating correctly. Replace switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the switch panel and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.

Action

Inspect the operator interface panel and the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the generator control harness.

Guided Step 3A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the switch panel on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from switch panel pins on the generator control harness board connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the switch panel pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1498 is inactive.
OK NOT OK

Fault Code 1498 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 1499 - Remote Start LED Driver Diagnostic

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module board, all other active fault codes must be investigated prior to replacing the engine control module board. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Remote Start LED. |
 | STEP 1A. Check the Remote Start LED. | LED is good
STEP 2. | Check switch panel. |
 | STEP 2A. Check switch panel for correct operation. | Operating correctly
 | STEP 2B. Inspect the switch panel and the generator control harness connector pins. | No damaged pins
STEP 3. | Check generator control harness. |
 | STEP 3A. Inspect the generator control harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1499 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the Remote Start LED.

Guided Step 1A - Check the Remote Start LED.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check the Remote Start LED.

  • Verify if LED is good.
OK NOT OK

LED is good

LED is bad. Replace switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the switch panel.

Guided Step 2A - Check the switch panel for correct operation.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Verify operator interface panel for correct operation.

  • Use INSITE™ electronic service tool to verify correct operation.
OK NOT OK

Operating correctly

Operating incorrectly. Replace switch panel. Refer to Procedure 019-314 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the switch panel and the generator control harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.

Action

Verify operator interface panel for correct operation.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the switch panel. Refer to Procedure 019-314 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the generator control harness.

Guided Step 3A - Inspect the generator control harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.
  • Disconnect the generator control harness from the engine control module.

Action

Inspect the generator control harness and engine control module connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set board. Refer to Procedure 019-322 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the switch panel on the generator control harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from switch panel pins on the generator control harness board connector to the generator control harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the engine control module.
  • Disconnect the generator control harness from the switch panel.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the switch panel pin on the generator control harness engine control module connector to the generator control harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1499 is inactive.
OK NOT OK

Fault Code 1499 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 2111 - Aftercooler Water Inlet Temperature Sensor - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftercooler water inlet temperature sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the sensor. | 600 ohms to 36k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the engine control module response. |
 | STEP 4A. Check for the appropriate engine control module response. | Fault Code 2111 inactive, Fault Code 2112 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2111 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the aftercooler water inlet temperature sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the aftercooler water inlet temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance of the sensor.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check the resistance of the aftercooler water inlet temperature sensor.

  • Measure the resistance between the aftercooler water inlet temperature sensor SIGNAL pin and the aftercooler water inlet RETURN pin.
OK NOT OK

600 ohms to 36k ohms

Replace the aftercooler water inlet temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the engine harness inline connector to the aftercooler water inlet temperature RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the engine harness inline connector to the aftercooler water inlet temperature SIGNAL pin at the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the extension harness connector to the aftercooler water inlet temperature RETURN pin at the extension harness inline connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the extension harness connector to the aftercooler water inlet temperature SIGNAL pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module response.

Guided Step 4A - Check for the appropriate engine control module response.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the aftercooler water inlet temperature SIGNAL pin and the aftercooler water inlet temperature RETURN pin on the breakout box.
  • Place the run/stop/auto switch in RUN position.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 2111 inactive, Fault Code 2112 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2111 is inactive.
OK NOT OK

Fault Code 2111 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 2112 - Aftercooler Water Inlet Temperature Sensor - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3163594 - engine control module connector breakout box.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftercooler water inlet temperature sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the sensor. | 600 ohms to 36k ohms
 | STEP 1C. Check for a short circuit to engine block ground. | More than 100k ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the engine control module response. |
 | STEP 4A. Check for the appropriate engine control module response. | Fault Code 2112 inactive, Fault Code 2111 active
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2112 inactive
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the aftercooler water inlet temperature sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness connector from the aftercooler water inlet temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the aftercooler water inlet temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Check the resistance of the sensor.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check the resistance of the aftercooler water inlet temperature sensor.

  • Measure the resistance between the aftercooler water inlet temperature sensor temperature SIGNAL pin and the aftercooler water inlet temperature RETURN pin.
OK NOT OK

600 ohms to 36k ohms

Replace the aftercooler water inlet temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1C

Go to 5A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from one of the pins of the aftercooler water inlet temperature sensor connector to the engine block ground.
OK NOT OK

More than 100k ohms

Replace the aftercooler water inlet temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect engine harness from aftercooler water inlet temperature sensor.
  • Disconnect engine harness from extension harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the engine harness inline connector to the engine block ground.
  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the engine harness inline connector to the aftercooler water inlet temperature RETURN pin at the engine harness sensor connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the engine harness inline connector to the aftercooler water inlet temperature SIGNAL pin at the engine harness sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the aftercooler water inlet temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect extension harness from engine control module.
  • Disconnect extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the extension harness connector to the engine block ground.
  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the extension harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the extension harness from the engine control module.

Action

Check for an open circuit.

  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the extension harness connector to the aftercooler water inlet temperature RETURN pin at the extension harness inline connector.
  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the extension harness connector to the aftercooler water inlet temperature SIGNAL pin at the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the aftercooler water inlet temperature SIGNAL pin at the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the aftercooler water inlet temperature RETURN pin at the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine control module response.

Guided Step 4A - Check for the appropriate engine control module response.

Conditions

  • Disconnect the extension harness from the engine control module.
  • Connect the extension harness to the breakout box.
  • Connect the breakout box harness to the appropriate engine control module connector.
  • Install a jumper wire between the aftercooler water inlet temperature SIGNAL pin and the aftercooler water inlet temperature SUPPLY pin on the breakout box.
  • Place the run/stop/auto switch in RUN position.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 2112 inactive, Fault Code 2111 active

Replace the engine control module. Refer to Procedure 019-031 in Section 19

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2112 is inactive.
OK NOT OK

Fault Code 2112 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 2113 - Aftercooler Water Inlet Temperature High - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the aftercooler water inlet temperature sensor is not enabled. | Fault simulation disabled
 | STEP 2B. Verify that the threshold for the fault is set correctly. | Fault threshold set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2113 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the aftercooler water inlet temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the aftercooler water inlet temperature reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, then answer "OK" to this step.
OK NOT OK

Sensor reading correct

Go to 2A

Fault Code 2111

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Verify that the fault simulation is not enabled for the aftercooler water inlet temperature sensor by connecting to the engine control module via INSITE™ electronic service tool.
OK NOT OK

Fault simulation disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Verify that the threshold for the fault is set correctly.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the aftercooler water inlet temperature sensor.
OK NOT OK

Fault threshold set correctly

Fault threshold not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 2113 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 2114 - Aftercooler Water Inlet Temperature High - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading correct
STEP 2. | Check the engine control module sensor value. |
 | STEP 2A. Verify that the fault simulation feature for the aftercooler water inlet temperature sensor is not enabled. | Fault simulation disabled
 | STEP 2B. Verify that the threshold for the fault is set correctly. | Fault threshold set correctly
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2114 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect the temperature probe to the engine near the aftercooler water inlet temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the aftercooler water inlet temperature reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, then answer "OK" to this step.
OK NOT OK

Sensor reading correct

Go to 2A

Fault Code 2111

Guided Step 2 - Check the engine control module sensor value.

Guided Step 2A - Verify that the fault simulation feature for the sensor is not enabled.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module sensor value.

  • Verify that the fault simulation is not enabled for the aftercooler water inlet temperature sensor by connecting to the engine control module via INSITE™ electronic service tool.
OK NOT OK

Fault simulation disabled

Disable fault simulation

Go to 2B

Go to 3A

Guided Step 2B - Verify that the threshold for the fault is set correctly.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Read the engine control module.

  • Use INSITE™ electronic service tool to verify that fault threshold is not within the normal operating range for the aftercooler water inlet temperature sensor.
OK NOT OK

Fault threshold set correctly

Fault threshold not set correctly. Reset the threshold to the highest allowable setting. Determine the mean operating condition before adjusting the threshold.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position.

Action

Disable the fault code.

  • Start the engine and warm it up to normal operating temperature to verify that the fault has been fixed.
OK NOT OK

Fault Code 2114 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 2297 - Fuel Supply Pump Driver Diagnostic has Detected an Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™ test lead, Part Number 3814812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2297 active
STEP 2. | Check the fuel supply pump relay and circuit. |
 | STEP 2A. Inspect the fuel supply pump relay and connector pins. | No damaged pins
 | STEP 2B. Check the fuel supply pump relay coil resistance. | Greater than 100k ohms
 | STEP 2C. Check the circuit response. | Fault Code 2297 inactive
 | STEP 2D. Check the circuit response. | Fault Code 2297 inactive
 | STEP 2D-1. Check for a pin to pin short circuit in the engine harness. |
 | STEP 2D-2. Check for short circuit to engine block ground. |
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for short circuit to engine block ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2297 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 2297 active

Fault Code 2297 inactive

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel supply pump relay and circuit.

Guided Step 2A - Inspect the fuel supply pump relay and connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the fuel supply pump relay from the engine harness.

Action

Inspect the engine harness and relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-211 in Section 19.
  • Replace the fuel supply pump relay.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel supply pump relay coil resistance.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the fuel supply pump relay from the engine harness.

Action

Check the fuel supply pump relay coil resistance.

  • Measure the resistance from the fuel supply pump relay SIGNAL pin at the pump relay connector to engine block ground.
OK NOT OK

Greater than 100k ohms

Less than 100k ohms.

  • Replace the fuel supply pump relay.

Go to 2C

Go to 4A

Guided Step 2C - Check the circuit response.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the fuel supply pump relay from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position.

Action

Crank the engine for 5 to 10 seconds and check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 2297 inactive

Fault Code 2297 active.

  • Replace the fuel supply pump relay.

Go to 2D

Go to 4A

Guided Step 2D - Check the circuit response.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the fuel supply pump relay from the engine harness.
  • Disconnect the engine harness from the INLINE™ connector.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in RUN position.

Action

Crank the engine for 5 to 10 seconds and check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to verify the fault codes.
OK NOT OK

Fault Code 2297 inactive.

Fault Code 2297 active.

  • Replace the fuel supply pump relay.

Go to 2D-1

Go to 4A

Guided Step 2D-1 - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness INLINE™ connector from the extension harness INLINE™ connector.
  • Disconnect the fuel supply pump relay from the engine harness.

Action

Short circuit on one connector - pin to pin check:

  • Measure the resistance and check for a short circuit between the following engine harness INLINE™ connector pins and all other pins in the engine harness INLINE™ connector:

Fuel supply pump relay SIGNAL pin.

Refer to the wiring diagram for connector pin identification.
OK NOT OK

Greater than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D-2

Go to 4A

Guided Step 2D-2 - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness INLINE™ connector from the extension harness INLINE™ connector.
  • Disconnect the fuel supply pump relay from the engine harness.

Action

Short circuit on one connector - pin to ground check:

  • Measure the resistance and check for a short circuit between the following engine harness INLINE™ connector pins and ground:

Fuel supply pump relay SIGNAL pin.

Refer to the wiring diagram for connector pin identification.
OK NOT OK

Greater than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness connector from the engine control module.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance and check for a short circuit between the following extension harness engine control module (02) connector pins and all other pins on the engine control module (02) connector: Fuel supply pump relay SIGNAL pin

Refer to the wiring diagram for connector pin identification.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness connector from the engine control module.
  • Disconnect the engine harness INLINE connector from the extension harness.

Action

Check for short circuit to engine block ground.

Measure the resistance from the fuel supply pump relay SIGNAL pin on the extension harness engine control module connector to the engine block ground.

OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the run/stop/auto switch in the RUN position.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 2297 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in the Stop position.
  • Connect all of the components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-May-2012


FAULT CODE 2561 - Engine Gear Box Oil Pressure Low - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine gear box oil pressure sensor accuracy. |
 | STEP 1A. Verify the oil pressure sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Check the harness. |
 | STEP 2A. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2561 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault code cleared

Guided Step 1 - Check the engine box oil pressure sensor accuracy.

Guided Step 1A - Verify the oil pressure sensor accuracy with a mechanical gauge.

Conditions

  • Connect a mechanical oil pressure gauge of known quality and calibration to the engine gear box.
  • Connect INSITE™ electronic service tool to the data link.
  • Place the run/stop/auto switch in RUN position.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Start the engine and compare the engine gear box oil pressure reading.
OK NOT OK

Engine gear box oil pressure is below the 79.97 kPa [11.60 psig] limit for low engine gear box oil pressure. Reference the the troubleshooting and repair manual for the specific engine series.

Engine gear box oil pressure is above the 79.97 kPa [11.60 psig] limit for low engine gear box oil pressure.

Go to 3A

Go to 2A

Guided Step 2 - Check the harness.

Guided Step 2A - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the engine gear box oil pressure SIGNAL pin at the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the harness.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine gear box oil pressure SIGNAL pin to the engine gear box oil pressure RETURN pin.
  • Measure the resistance from the engine gear box oil pressure SIGNAL pin to the engine gear box temperature SIGNAL pin.
  • Measure the resistance from the engine gear box oil pressure SIGNAL pin to the engine gear box oil temperature RETURN pin.
OK NOT OK

More than 100k ohms

Repair or replace the harness.

Go to 2B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool to the data link.
  • Place the run/stop/auto switch in STOP position.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to check the state of Fault Code 2561.
OK NOT OK

Fault Code 2561 is inactive.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool to the datalink.
  • Place the run/stop/auto switch in STOP position.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 08-May-2012


FAULT CODE 2562 - Engine Gear Box Oil Temperature High - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine gear box oil temperature sensor accuracy. |
 | STEP 1A. Verify the oil temperature sensor accuracy with a thermocouple or a similar temperature probe. | Sensor reading is correct
STEP 2. | Check the harness. |
 | STEP 2A. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100 k ohms
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2562 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine gear box oil temperature sensor accuracy

Guided Step 1A - Verify the oil temperature sensor accuracy with a thermocouple or a similar temperature probe.

Conditions

  • Connect a temperature probe of known quality and calibration to the engine gear box.
  • Connect INSITE™ electronic service tool to the data link.
  • Place the run/stop/auto switch in RUN position.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Start the engine and compare the engine gear box oil temperature.
OK NOT OK

Engine gear box oil temperature is above the 93°C [199.4°F] limit for high engine gear box oil temperature. reference the the troubleshooting and repair manual for the specific engine series.

Engine gear box oil temperature is below the 93°C [199.4°F] limit for high engine gear box oil temperature.

Go to 3A

Go to 2A

Guided Step 2 - Check the harness

Guided Step 2A - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the engine gear box oil temperature SIGNAL pin at the sensor harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the harness

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine gear box oil temperature SIGNAL pin to the engine gear box oil temperature RETURN pin
  • Measure the resistance from the engine gear box oil temperature SIGNAL pin to the engine gear box oil pressure SIGNAL pin.
  • Measure the resistance from the engine gear box oil temperature SIGNAL pin to the engine gear box oil pressure RETURN pin
OK NOT OK

More than 100k ohms

Repair or replace the harness

Go to 2B

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool to the databank.
  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit from pin to pin.

  • Use INSITE™ electronic service tool to check the state of Fault Code 2562.
OK NOT OK

Fault Code 2562 is inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool to the data link.
  • Place the run/stop/auto switch in STOP position.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining inactive fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 08-May-2012


FAULT CODE 2974 - Fuel Rack Position 1 Circuit - Root Cause Not Known (Left Bank)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rack position sensor 1. |
 | STEP 1A. Inspect the fuel pump harness and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the fuel rack position sensor 1 coil. | 17 to 23 ohms
 | STEP 1C. Check the resistance of fuel rack position sensor 1 reference coil. | 17 to 23 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for short circuit to engine block ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2974 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel rack position sensor 1.

Guided Step 1A - Inspect the fuel pump harness and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness connector from the fuel pump.

Action

Inspect the fuel pump harness and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-207 in Section 19.

Replace the fuel pump.

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the fuel rack position sensor 1 coil.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect engine harness connector from fuel pump.

Action

Check the resistance of the rack position sensor coil.

  • Measure the resistance from the fuel rack position sensor 1 measured SIGNAL pin and the fuel rack position 1 common SIGNAL pin of the fuel pump connector.
OK NOT OK

17 to 23 ohms

Replace the fuel pump.

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1C

Go to 2A

Guided Step 1C - Check the resistance of fuel rack position sensor 1 reference coil.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect engine harness from fuel pump connector.

Action

Check resistance of rack position sensor reference coil.

  • Measure the resistance from the fuel rack position 1 reference SIGNAL pin to the fuel rack position 1 common SIGNAL pin of the fuel pump connector.
OK NOT OK

17 to 23 ohms

Replace the fuel pump.

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rack position sensor 1 measured SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rack position 1 common SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rack position 1 reference SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel rack position sensor 1 measured SIGNAL pin on the engine harness inline connector to the fuel rack position sensor 1 measured SIGNAL pin on the engine harness fuel pump connector.
  • Measure the resistance from the fuel rack position 1 common SIGNAL pin on the engine harness inline connector to the fuel rack position 1 common SIGNAL pin on the engine harness fuel pump connector.
  • Measure the resistance from the fuel rack position 1 reference SIGNAL pin on the engine harness inline connector to the fuel rack position 1 reference SIGNAL pin on the engine harness fuel pump connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rack position sensor 1 measured SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel rack position 1 common SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel rack position 1 reference SIGNAL pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness connector from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rack position sensor 1 measured SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rack position 1 common SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rack position 1 reference SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the extension harness.

  • Measure the resistance from the fuel rack position sensor 1 measured SIGNAL pin on the extension harness engine control module connector to the fuel rack position sensor 1 measured SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel rack position 1 common SIGNAL pin on the extension harness engine control module connector to the fuel rack position 1 common SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel rack position 1 reference SIGNAL pin on the extension harness engine control module connector to the fuel rack position 1 reference SIGNAL pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rack position sensor 1 measured SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel rack position 1 common SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel rack position 1 reference SIGNAL pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 2974 is inactive.
OK NOT OK

Fault Code 2974 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


FAULT CODE 2975 - Fuel Rack Position Sensor 2 Circuit - Shorted High (Right Bank)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead, Part Number 3823994 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rack position sensor 2. |
 | STEP 1A. Inspect the fuel pump harness and engine harness connector pins. | No damaged pins
 | STEP 1B. Check the resistance of the fuel rack position sensor 2 coil. | 17 to 23 ohms
 | STEP 1C. Check the resistance of fuel rack position sensor 2 reference coil. | 17 to 23 ohms
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for short circuit to engine block ground. | More than 100k ohms
STEP 3. | Check the extension harness. |
 | STEP 3A. Inspect the extension harness and the engine control module connector pins. | No damaged pins
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for short circuit to engine block ground. | More than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2975 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fuel rack position sensor 2.

Guided Step 1A - Inspect the fuel pump harness and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness connector from the fuel pump.

Action

Inspect the fuel pump harness and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-207.

Replace the fuel pump.

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1B

Go to 4A

Guided Step 1B - Check the resistance of the fuel rack position sensor 2 coil.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect engine harness connector from fuel pump.

Action

Check the resistance of the rack position sensor coil.

  • Measure the resistance from the fuel rack position sensor 2 measured SIGNAL pin and the fuel rack position 2 common SIGNAL pin of the fuel pump connector.
OK NOT OK

17 to 23 ohms

Replace the fuel pump.

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 1C

Go to 2A

Guided Step 1C - Check the resistance of fuel rack position sensor 2 reference coil.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect engine harness from fuel pump connector.

Action

Check resistance of rack position sensor reference coil.

  • Measure the resistance from the fuel rack position 2 reference SIGNAL pin to the fuel rack position 2 common SIGNAL pin of the fuel pump connector.
OK NOT OK

17 to 23 ohms

Replace the fuel pump.

  • Refer to Procedure 005-016 in Section 5. Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.
  • Refer to Procedure 005-016 in Section 5. QSK23 Troubleshooting and Repair Manual, Bulletin 4021375.
  • Refer to Procedure 005-012 in Section 5. QST30 Service Manual, Bulletin 4021539.
  • Refer to Procedure 005-016 in Section 5. QSK45 and QSK60 Service Manual, Bulletin 4021530.
  • Refer to Procedure 005-016 in Section 5. QSK78 Troubleshooting and Repair Manual, Bulletin 3666727.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the extension harness. Refer to Procedure 019-208 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rack position sensor 2 measured SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rack position 2 common SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
  • Measure the resistance from the fuel rack position 2 reference SIGNAL pin on the engine harness inline connector to all other pins in the engine harness inline connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel rack position sensor 2 measured SIGNAL pin on the engine harness inline connector to the fuel rack position sensor 2 measured SIGNAL pin on the engine harness fuel pump connector.
  • Measure the resistance from the fuel rack position 2 common SIGNAL pin on the engine harness inline connector to the fuel rack position 2 common SIGNAL pin on the engine harness fuel pump connector.
  • Measure the resistance from the fuel rack position 2 reference SIGNAL pin on the engine harness inline connector to the fuel rack position 2 reference SIGNAL pin on the engine harness fuel pump connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rack position sensor 2 measured SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel rack position 2 common SIGNAL pin on the engine harness inline connector to the engine block ground.
  • Measure the resistance from the fuel rack position 2 reference SIGNAL pin on the engine harness inline connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the extension harness.

Guided Step 3A - Inspect the extension harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness connector from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Inspect the extension harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for component connector and pin inspection. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.
  • Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel rack position sensor 2 measured SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rack position 2 common SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
  • Measure the resistance from the fuel rack position 2 reference SIGNAL pin on the extension harness connector to all other pins in the extension harness connector.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for an open circuit in the extension harness.

  • Measure the resistance from the fuel rack position sensor 2 measured SIGNAL pin on the extension harness engine control module connector to the fuel rack position sensor 2 measured SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel rack position 2 common SIGNAL pin on the extension harness engine control module connector to the fuel rack position 2 common SIGNAL pin on the extension harness inline connector.
  • Measure the resistance from the fuel rack position 2 reference SIGNAL pin on the extension harness engine control module connector to the fuel rack position 2 reference SIGNAL pin on the extension harness inline connector.
OK NOT OK

Less than 10 ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the extension harness from the engine control module.
  • Disconnect the extension harness from the engine harness.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the fuel rack position sensor 2 measured SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel rack position 2 common SIGNAL pin on the extension harness connector to engine block ground.
  • Measure the resistance from the fuel rack position 2 reference SIGNAL pin on the extension harness connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the extension harness.

  • Repair the extension harness. Refer to Procedure 019-213 in Section 19.
  • Replace the extension harness. Refer to Procedure 019-175 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 2975 is inactive.
OK NOT OK

Fault Code 2975 inactive

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-May-2012


INDEX
01-fcmfc.htm

01-fc111.htm

01-t05-111.htm

01-fc112.htm

01-t05-112.htm

01-fc113.htm

01-t05-113.htm

01-fc115.htm

01-t05-115.htm

01-fc116.htm

01-t05-116.htm

01-fc117.htm

01-t05-117.htm

01-fc118.htm

01-t05-118.htm

01-fc119.htm

01-t05-119.htm

01-fc121.htm

01-t05-121.htm

01-fc122.htm

01-t05-122.htm

01-fc123.htm

01-t05-123.htm

01-fc128.htm

01-t05-128.htm

01-fc129.htm

01-t05-129.htm

01-fc135.htm

01-t05-135.htm

01-fc141.htm

01-t05-141.htm

01-fc143.htm

01-t05-143.htm

01-fc144.htm

01-t05-144.htm

01-fc145.htm

01-t05-145.htm

01-fc146.htm

01-t05-146.htm

01-fc151.htm

01-t05-151.htm

01-fc152.htm

01-t05-152.htm

01-fc153.htm

01-t05-153.htm

01-fc154.htm

01-t05-154.htm

01-fc155.htm

01-t05-155.htm

01-fc159.htm

01-t05-159.htm

01-fc161.htm

01-t05-161.htm

01-fc168.htm

01-t05-168.htm

01-fc169.htm

01-t05-169.htm

01-fc171.htm

01-t05-171.htm

01-fc174.htm

01-t05-174.htm

01-fc182.htm

01-t05-182.htm

01-fc183.htm

01-t05-183.htm

01-fc197.htm

01-t05-197.htm

01-fc212.htm

01-t05-212.htm

01-fc213.htm

01-t05-213.htm

01-fc214.htm

01-t05-214.htm

01-fc219.htm

01-t05-219.htm

01-fc221.htm

01-t05-221.htm

01-fc222.htm

01-t05-222.htm

01-fc223.htm

01-t05-223.htm

01-fc228.htm

01-t05-228.htm

01-fc231.htm

01-t05-231.htm

01-fc232.htm

01-t05-232.htm

01-fc233.htm

01-t05-233.htm

01-fc234.htm

01-t05-234.htm

01-fc235.htm

01-t05-235.htm

01-fc236.htm

01-t05-236.htm

01-fc252.htm

01-t05-252.htm

01-fc253.htm

01-t05-253.htm

01-fc254.htm

01-t05-254.htm

01-fc259.htm

01-t05-259.htm

01-fc261.htm

01-t05-261.htm

01-fc263.htm

01-t05-263.htm

01-fc265.htm

01-t05-265.htm

01-fc266.htm

01-t05-266.htm

01-fc316.htm

01-t05-316.htm

01-fc318.htm

01-t05-318.htm

01-fc326.htm

01-t05-326.htm

01-fc343.htm

01-t05-343.htm

01-fc359.htm

01-t05-359.htm

01-fc378.htm

01-t05-378.htm

01-fc379.htm

01-t05-379.htm

01-fc394.htm

01-t05-394.htm

01-fc395.htm

01-t05-395.htm

01-fc396.htm

01-t05-396.htm

01-fc397.htm

01-t05-397.htm

01-fc398.htm

01-t05-398.htm

01-fc399.htm

01-t05-399.htm

01-fc415.htm

01-t05-415.htm

01-fc421.htm

01-t05-421.htm

01-fc422.htm

01-t05-422.htm

01-fc423.htm

01-t05-423.htm

01-fc427.htm

00-t05-427.htm

01-fc441.htm

01-t05-441.htm

01-fc442.htm

01-t05-442.htm

01-fc449.htm

01-t05-449.htm

01-fc451.htm

01-t05-451.htm

01-fc452.htm

01-t05-452.htm

01-fc455.htm

01-t05-455.htm

01-fc467.htm

01-t05-467.htm

01-fc468.htm

01-t05-468.htm

01-fc471.htm

01-t05-471.htm

01-fc488.htm

01-t05-488.htm

01-fc498.htm

01-t05-498.htm

01-fc499.htm

01-t05-499.htm

01-fc514.htm

01-t05-514.htm

01-fc546.htm

01-t05-546.htm

01-fc547.htm

01-t05-547.htm

01-fc554.htm

01-t05-554.htm

01-fc555.htm

01-t05-555.htm

01-fc556.htm

01-t05-556.htm

01-fc581.htm

01-t05-581.htm

01-fc582.htm

01-t05-582.htm

01-fc611.htm

01-t05-611.htm

01-fc649.htm

01-t05-649.htm

01-fc688.htm

01-t05-688.htm

01-fc689.htm

01-t05-689.htm

01-fc719.htm

01-t05-719.htm

01-fc729.htm

01-t05-729.htm

01-fc731.htm

01-t05-731.htm

01-fc778.htm

01-t05-778.htm

01-fc1211.htm

01-t05-1211.htm

01-fc1212.htm

01-t05-1212.htm

01-fc1311.htm

01-t05-1311.htm

01-fc1312.htm

01-t05-1312.htm

01-fc1313.htm

01-t05-1313.htm

01-fc1314.htm

01-t05-1314.htm

01-fc1315.htm

01-t05-1315.htm

01-fc1316.htm

01-t05-1316.htm

01-fc1317.htm

01-t05-1317.htm

01-fc1318.htm

01-t05-1318.htm

01-fc1319.htm

01-t05-1319.htm

01-fc1321.htm

01-t05-1321.htm

01-fc1322.htm

01-t05-1322.htm

01-fc1323.htm

01-t05-1323.htm

01-fc1324.htm

01-t05-1324.htm

01-fc1325.htm

01-t05-1325.htm

01-fc1326.htm

01-t05-1326.htm

01-fc1327.htm

01-t05-1327.htm

01-fc1328.htm

01-t05-1328.htm

01-fc1329.htm

01-t05-1329.htm

01-fc1331.htm

01-t05-1331.htm

01-fc1332.htm

01-t05-1332.htm

01-fc1333.htm

01-t05-1333.htm

01-fc1334.htm

01-t05-1334.htm

01-fc1335.htm

01-t05-1335.htm

01-fc1336.htm

01-t05-1336.htm

01-fc1337.htm

01-t05-1337.htm

01-fc1341.htm

01-t05-1341.htm

01-fc1342.htm

01-t05-1342.htm

01-fc1343.htm

01-t05-1343.htm

01-fc1344.htm

01-t05-1344.htm

01-fc1345.htm

01-t05-1345.htm

01-fc1346.htm

01-t05-1346.htm

01-fc1347.htm

01-t05-1347.htm

01-fc1348.htm

01-t05-1348.htm

01-fc1349.htm

01-t05-1349.htm

01-fc1351.htm

01-t05-1351.htm

01-fc1411.htm

01-t05-1411.htm

01-fc1412.htm

01-t05-1412.htm

01-fc1413.htm

01-t05-1413.htm

01-fc1414.htm

01-t05-1414.htm

01-fc1415.htm

01-t05-1415.htm

01-fc1416.htm

01-t05-1416.htm

01-fc1417.htm

01-t05-1417.htm

01-fc1418.htm

01-t05-1418.htm

01-fc1419.htm

01-t05-1419.htm

01-fc1421.htm

01-t05-1421.htm

01-fc1422.htm

01-t05-1422.htm

01-fc1423.htm

01-t05-1423.htm

01-fc1424.htm

01-t05-1424.htm

01-fc1425.htm

01-t05-1425.htm

01-fc1426.htm

01-t05-1426.htm

01-fc1427.htm

01-t05-1427.htm

01-fc1428.htm

01-t05-1428.htm

01-fc1429.htm

01-t05-1429.htm

01-fc1431.htm

01-t05-1431.htm

01-fc1432.htm

01-t05-1432.htm

01-fc1433.htm

01-t05-1433.htm

01-fc1434.htm

01-t05-1434.htm

01-fc1435.htm

01-t05-1435.htm

01-fc1436.htm

01-t05-1436.htm

01-fc1438.htm

01-t05-1438.htm

01-fc1439.htm

01-t05-1439.htm

01-fc1441.htm

01-t05-1441.htm

01-fc1442.htm

01-t05-1442.htm

01-fc1443.htm

01-t05-1443.htm

01-fc1444.htm

01-t05-1444.htm

01-fc1445.htm

01-t05-1445.htm

01-fc1446.htm

01-t05-1446.htm

01-fc1447.htm

01-t05-1447.htm

01-fc1448.htm

01-t05-1448.htm

01-fc1449.htm

01-t05-1449.htm

01-fc1451.htm

01-t05-1451.htm

01-fc1452.htm

01-t05-1452.htm

01-fc1453.htm

01-t05-1453.htm

01-fc1454.htm

01-t05-1454.htm

01-fc1455.htm

01-t05-1455.htm

01-fc1456.htm

01-t05-1456.htm

01-fc1457.htm

01-t05-1457.htm

01-fc1458.htm

01-t05-1458.htm

01-fc1459.htm

01-t05-1459.htm

01-fc1461.htm

01-t05-1461.htm

01-fc1462.htm

01-t05-1462.htm

01-fc1463.htm

01-t05-1463.htm

01-fc1464.htm

01-t05-1464.htm

01-fc1465.htm

01-t05-1465.htm

01-fc1466.htm

01-t05-1466.htm

01-fc1468.htm

01-t05-1468.htm

01-fc1469.htm

01-t05-1469.htm

01-fc1471.htm

01-t05-1471.htm

01-fc1472.htm

01-t05-1472.htm

01-fc1473.htm

01-t05-1473.htm

01-fc1474.htm

01-t05-1474.htm

01-fc1475.htm

01-t05-1475.htm

01-fc1476.htm

01-t05-1476.htm

01-fc1477.htm

01-t05-1477.htm

01-fc1478.htm

01-t05-1478.htm

01-fc1479.htm

01-t05-1479.htm

01-fc1481.htm

01-t05-1481.htm

01-fc1483.htm

01-t05-1483.htm

01-fc1485.htm

01-t05-1485.htm

01-fc1486.htm

01-t05-1486.htm

01-fc1487.htm

01-t05-1487.htm

01-fc1488.htm

01-t05-1488.htm

01-fc1489.htm

01-t05-1489.htm

01-fc1491.htm

01-t05-1491.htm

01-fc1492.htm

01-t05-1492.htm

01-fc1493.htm

01-t05-1493.htm

01-fc1494.htm

01-t05-1494.htm

01-fc1495.htm

01-t05-1495.htm

01-fc1496.htm

01-t05-1496.htm

01-fc1497.htm

01-t05-1497.htm

01-fc1498.htm

01-t05-1498.htm

01-fc1499.htm

01-t05-1499.htm

01-fc2111.htm

01-t05-2111.htm

01-fc2112.htm

01-t05-2112.htm

01-fc2113.htm

01-t05-2113.htm

01-fc2114.htm

01-t05-2114.htm

01-fc2297.htm

01-t05-2297.htm

01-fc2561.htm

01-t05-2561.htm

01-fc2562.htm

01-t05-2562.htm

01-fc2974.htm

01-t05-2974.htm

01-fc2975.htm

01-t05-2975.htm